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Preface

This guide contains information about installing the on-premise features and configuring Kofax 
AP Agility to work on a TotalAgility On-Premise Multi-Tenancy environment or a Kofax hosted 
TotalAgility Azure environment.

This guide is written with the assumption that you have a thorough understanding of Kofax 
TotalAgility and its environment.

Cloud solution considerations
When configuring Kofax AP Agility to work in a multi-tenant or Kofax hosted Azure environment 
for Kofax TotalAgility, it is important to note that there are several limitations when compared to a 
traditional installation.
• User exits are not supported.
• SAP ECC, Oracle, and MarkView integrations are not supported.
• PIX is not supported. Because of this you cannot process electronic XML invoices.
• ERP data such as purchase order or company data is provided by an ERP connector only.
• Exporting to Process Director is not supported.
• Windows Authentication is not supported.

Related documentation
In addition to this guide, see the following documentation for additional installation and 
configuration information.

The product document set for Kofax AP Agility is available from https://docshield.kofax.com/Portal/
Products/APAgility/2.7.0-79qrk2m1wh/APAgility.htm.

The product document set for Kofax TotalAgility is available for the following supported versions:
• 7.7.0
• 7.8.0
• 7.9.0
• 7.10.0
• 7.11.0
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Select the documentation link for the Kofax TotalAgility version that you are currently using.

If you select the incorrect link, it is possible that some features documented are not in your installed 
version.

In addition to this guide, the AP Agility document set includes the following items:

Kofax AP Agility Release Notes
This guide contains late-breaking product information that may not be included in other Kofax AP 
Agility documentation. Release notes are also available for each of your installed Kofax applications.

Kofax AP Agility Configuration Help
This help provides detailed information on how to configure Kofax AP Agility for your environment.

Kofax AP Agility PIX Correction activity Help
This help provides detailed information about how to navigate through the PIX Correction activity. It 
also includes details about how to use the PIX Correction activity when processing documents with 
Kofax AP Agility Invoice Processing.

Kofax AP Agility Error Handling Help
This helps provides information on how to handle documents that end up in an error state during 
Invoice Processing.

Kofax AP Agility Scan activity Help
This help provides information on how to scan documents for Kofax AP Agility Invoice Processing.

Kofax AP Agility Line Pairing Correction activity
This help provides use cases and examples for correcting a document that fails line pairing during 
Invoice Processing.

Kofax AP Agility Validation activity Help
This help provides information about validating a document in Kofax AP Agility Invoice Processing.
Additional documentation about validating documents is available in the Kofax TotalAgility Validation 
activity Help.

Kofax AP Agility AP Workflow Help
This help provides information about how to use the various activities that are part ofs the AP Agility 
AP Workflow. This includes general information that is relevant for all activities as well as specific 
information related to the Approval activity, the Coding activity, the Exception activity, the Line 
Pairing Exception activity, the Hold activity, and the Comment Request activity.

Analytics for AP Agility Installation Guide
This guide provides information about installing Analytics for AP Agility and integrating it with Kofax 
AP Agility.

Analytics for AP Agility Help
This help provides detailed information on how to generate and interpret the various reports that 
are available in Analytics for AP Agility .
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Training
Kofax offers both classroom and computer-based training to help you make the most of your Kofax 
TotalAgility solution. To learn more about training courses and schedules, visit the Kofax Education 
Portal on the Kofax website.

Getting help with Kofax products
The Kofax Knowledge Portal repository contains articles that are updated on a regular basis to 
keep you informed about Kofax products. We encourage you to use the Knowledge Portal to obtain 
answers to your product questions.

To access the Kofax Knowledge Portal, go to https://knowledge.kofax.com.

 The Kofax Knowledge Portal is optimized for use with Google Chrome, Mozilla Firefox, or 
Microsoft Edge.

The Kofax Knowledge Portal provides:
• Powerful search capabilities to help you quickly locate the information you need.

Type your search terms or phrase into the Search box, and then click the search icon.
• Product information, configuration details and documentation, including release news.

To locate articles, go to the Knowledge Portal home page and select the applicable Solution 
Family for your product, or click the View All Products button.

From the Knowledge Portal home page, you can:
• Access the Kofax Community (for all customers).

On the Resources menu, click the Community link.
• Access the Kofax Customer Portal (for eligible customers).

Go to the Support Portal Information page and click Log in to the Customer Portal.
• Access the Kofax Partner Portal (for eligible partners).

Go to the Support Portal Information page and click Log in to the Partner Portal.
• Access Kofax support commitments, lifecycle policies, electronic fulfillment details, and self-

service tools.
Go to the Support Details page and select the appropriate article.
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Chapter 1

System requirements

For information on supported operating systems and other system requirements, see the Kofax AP 
Agility Technical Specifications document on the Kofax AP Agility Documentation site.

This document is updated regularly, and we recommend that you review it carefully to ensure 
success with Kofax AP Agility.

 A customer portal login is required to access the Kofax Knowledge Base.

Software prerequisites
The software prerequisites required prior to the installation of the Kofax AP Agility on-premise 
features in a multi-tenant environment are listed as follows.

For the on-premise aspects of the Kofax AP Agility installation, the following must be available on 
the on-premise machine before an installation.

.NET 4.8 or higher
This is the minimum version required by the Kofax AP Agility assemblies and the Kofax TotalAgility 
integration.

Internet Information Services (IIS) 7.5 or higher
This is required to install the Agnostic ERP connector.

Important installation notes
The following notes are important when installing Kofax AP Agility.

Administrator Rights
To install the product, the logged on user must have Administrator rights on the local computer.

Database Editing
Kofax AP Agility does not support direct database editing. You can make any changes needed for 
your solution using the Kofax AP Agility configuration tools.
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Localize Kofax AP Agility
The localization of Kofax AP Agility is available for the following languages.
• English
• French
• German
• Spanish
• Brazilian Portuguese

If the main language of your web browser is set to one of the above languages, the user interface 
and documentation for Kofax AP Agility appear in that language automatically. For any other 
language, and for the administrative documentation, the user interface and documentation 
defaults to English.

However, this localizes the Kofax AP Agility activities only. Because Kofax AP Agility is a part of Kofax 
TotalAgility, it is necessary to install the Kofax TotalAgility language packs to ensure a fully localized 
environment. For more information about localizing Kofax TotalAgility, refer to the Kofax TotalAgility 
Installation Guide.
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Chapter 2

Deploying Kofax AP Agility on Kofax 
TotalAgility On-Premise Multi-Tenancy

Installing Kofax AP Agility on Kofax TotalAgility On-Premise Multi-Tenancy requires the following on-
premise installation steps.

Kofax AP Agility on-premise components
Your environment determines which installation zip files are needed. The table below lists what files 
are needed to install the on-premise components for Kofax AP Agility:

Environment type Installation ZIP files

Kofax hosted TotalAgility Azure 
environment

• KofaxAPAgility-2.8.0_Azure_OnPremiseComponents.ZIP

This file is a deliverable that is part of Kofax AP Agility 2.8.0.
• KofaxTotalAgility-<Version>_IS.ZIP

This file is a deliverable that is part of Kofax TotalAgility.

TotalAgility on-premise multi-
tenant environment

• KofaxAPAgility-OPMT.ZIP

This file is a deliverable that is part of Kofax AP Agility 2.8.0.
• KofaxTotalAgility-<Version>_IS.ZIP

This file is a deliverable that is part of Kofax TotalAgility.

TotalAgility on-premise multi-
tenant environment with 
MarkView

• KofaxAPAgility-OPMT_MarkView.ZIP

This file is a deliverable that is part of Kofax AP Agility 2.8.0.
• KofaxTotalAgility-<Version>_IS.ZIP

This file is a deliverable that is part of Kofax TotalAgility and is needed 
only if your customers plan to use file system or email ingestion.

Install SSL certificate
In order to use Kofax AP Agility in a multi-tenant or Kofax hosted Azure environment, you must 
install the on-premise components on a server where there is an SSL certificate.

Once the certificate is available, it is listed in the IIS Server Certification settings for the on-premise 
server.
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You can install an SSL certificate as well as configure your IIS site binding settings by following these 
steps:.

1. Launch the Internet Information Services Manager (IIS) on your on-premise server.
2. Open the Default Web Site.

If you plan to use another website when installing the Kofax AP Agility ERP Connector, select 
that web site instead.
The central pane is updated with settings for the selected site.

3. In the Actions pane on the right, in the Edit Site group, select Bindings.
The Site Bindings window is displayed.

4. Click Add.
The Add Site Binding window is displayed.

5. From the Type list, select https.
6. Optionally, enter a Port that matches your solution.
7. From the SSL certificate list, select your certificate.
8. Click OK.

The Add Site Binding window closes and your new site binding is listed in the Site Bindings
window.

9. Click Close.
The Site Bindings window closes.

Install the Integration Server
The Integration Server installer adds the necessary on-premise TotalAgility components so that 
Kofax AP Agility works in a multi-tenant or Kofax hosted Azure environment.

 Skip this procedure if:
• you do not plan to use the AP Workflow for any of the organizations configured in Kofax AP 

Agility.
• you are installing Kofax AP Agility in an OPMT environment with MarkView and are using the 

Scan activity only, rather than file or email ingestion.

You can install the Integration Server by following these steps:
1. Ensure that you can access the Kofax AP Agility tenant from this server.

If you cannot access your tenant, add an entry that lists your IP address and host name to the 
hosts file.
For example,
192.168.0.10 tenant.apagility.cloudapp.net

2. Download and extract the KofaxTotalAgility-<Version>_IS.ZIP file.
3. Navigate to the IntegrationServerInstall folder and run the Setup.exe file.

The Kofax TotalAgility Integration Server Setup wizard is displayed.
4. Click Next.

The Kofax Inc. Software License Agreement step of the Setup wizard is displayed.
5. After reading the license agreement, click Next.
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The Type of Install step of the Setup wizard is displayed.
6. The only type of install available is the Web/Application Server and it is already selected. Click

Next.
The Destination step of the Setup wizard is installed.

7. If you want to change the default Destination Folder, click Browse and select a new path.
Otherwise, click Next.
The Credentials step of the Setup wizard is displayed.

8. In the Account settings, provide Windows Administrator credentials for the server where you 
are installing the Integration Server.

9. Choose which root Website is used to host your installation and click Next.
If you use the default setting, click Next.
The Software Checks step of the Setup wizard is displayed and the checks are carried out 
automatically.

10. If the software checks are successful, click Next.
If any of the steps fail, install the missing software and then click Back and then Next to run 
the checks again. Once successful, click Next.
The Tenant Information step of the Setup wizard is displayed.

11. Enter the Tenant URL that points to the server where the TotalAgility Designer is located.
For example, https://<TenantName>.apagility.cloudapp.net. Do not include /
Designer in the path.

12. Enter the System Session ID.
You can find this by going to the TotalAgility Designer > System > System settings > Logon 
and authentication > User sessions.

13. Click Next.
The Installation Review step of the Setup wizard is displayed.

14. Review the installation parameters. If necessary, click Back to edit any steps.
Otherwise, click Next.
The Installation Progress step of the Setup wizard is displayed. A progress bar shows the 
installation progress.
When the installation is complete, the Kofax TotalAgility Integration Server Installation
page is displayed with a list of installed components.

15. Click Finish.
The Setup wizard closes and your installation is complete.

Install the Kofax AP Agility on-premise components
It is necessary to install the Kofax AP Agility on-premise components on the same server where the 
Kofax TotalAgility Integration Server is installed.

You can install the ERP Connector by following these steps:
1. Download and extract the appropriate ZIP file for your environment.

For more details on what files are needed for your environment, see Kofax AP Agility on-
premise components.

2. Navigate to the Installer folder.
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The contents of the Installer folder are displayed.
3. Right-click on the Kofax AP Agility installer and select Run as Administrator to begin the 

Setup Wizard.
The installer is displayed and calculates if there is enough space on disk for the installation.

4. Once the Install Wizard confirms that there is enough disk space, click Next.
The End-User License Agreement Setup Wizard step is displayed.

5. Select I accept the terms in the License Agreement and then click Next.
The Prerequisites Setup Wizard step is displayed along with any information about missing 
prerequisites.

6. The information displayed on the Prerequisites step is relevant if you are installing the listed 
components only.
For example, if you receive a message that the SAP ECC .NET connector is missing, but you 
are not using SAP ECC, ignore this message. However, if you are using one of the components 
listed, click Cancel and then Finish to exit the Setup Wizard, install the required prerequisite, 
and then restart the installer. Otherwise, click Next.
If you did not install the necessary prerequisites, the corresponding settings are not available 
for installation.
The Choose Setup Type Setup Wizard step is displayed.

7. On the Choose Setup type window, select Custom.
The Custom Setup step is displayed along with a list of available components.

8. Exclude all components by selecting Entire feature will be unavailable, except the ERP 
Connector Web Service and then click Next.
The Kofax TotalAgility Connection Setup Wizard step is displayed.

9. On the Kofax TotalAgility Connection step, enter the following information.

a. If the default Kofax TotalAgility URL that is provided is not correct, update the TotalAgility 
URL.
This must be the on-premise version that is installed on a local server and not the Azure 
URL.
For example, https://<KTAIntegrationServerName>/TotalAgility/.

b. Select Authentication by username and password.
enter the User name and User password for the Administrator used when installing the 
Kofax TotalAgility Integration Server.

c. Click Test connection to ensure that your information is correct. If not, repeat the 
previous steps and try again.

d. Once your connection test is successful, click Next.
The AP Agility ERP Connector Configuration Setup Wizard step is displayed.

10. On the AP Agility ERP Connector Configuration step, enter the following information.

a. Optionally, enter an alternate Web Site.

 This web site must exist in IIS before it can be added here. All other items are created 
dynamically.

b. Optionally, enter a different Virtual Directory.
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c. Optionally, enter a different Application Pool.

d. For Pool Identity, select Custom Account.
The User name and User Password must match the credentials provided when installing 
the Integration Server.

e. Select Update web service URL for the ERP Connector to update the ERP Connector 
Host value, if needed.
If cleared, ERP Connector Host is greyed out and cannot be edited. You can always edit 
this value in the ApAgilityErpConnector properties located in the TotalAgility Designer 
Home menu at Integration > Web Service references at another time.

f. If available, enter a valid ERP Connector Host. This setting is available only if the Update 
web service URL for ERP Connector is selected above.
This is the URL that points to the Web Sever for your ERP Connector, not the entire web 
service URL. By default this is set to https://{ServerName}. This value is then used 
to build the full web service URL for your ERP Connector web service. This value and the 
rest of the web service URL is visible after installation in the ApAgilityErpConnector
properties located in the TotalAgility Designer Home menu at Integration > Web Service 
references.

g. Click Next.
The Installing Kofax AP Agility 2.8 Setup Wizard step is displayed. A progress bar is displayed 
showing the status of the installation.

11. Click Finish.
Optionally, select the View Installation Log setting. The log file is displayed after the installer 
is closed.
The installer closes and if selected, the log file is displayed.

Disable ERP Web Connector anonymous authentication
In order for the ERP Connector to work efficiently, it is necessary to disable anonymous 
authentication for that web site.

You can disable the anonymous authentication for your ERP Connector web site by following these 
steps:

1. Open the Internet Information Services Manager (IIS) on the server where you installed the 
ERP web connector.

2. Open the Default Web Site.
If you have configured another web site for the on-premise components of Kofax AP Agility, 
select that web site instead.
The web site home page is displayed.

3. Select the virtual directory for the ERP Connector. By default, this is called
ApAgilityErpConnector.
If you changed this name during installation, select your virtual directory.
The settings for the selected virtual directory are displayed.

4. Under the IIS category, select Authentication.
A list of Authentication settings are displayed.
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5. Right-click Anonymous Authentication and select Disable.
6. Restart the World Wide Web Publishing Service.

Configure Web service references
After configuring the ERP web.config, it is necessary to update the ERP web service for on-premise 
TotalAgility Designer.

You can configure the web service references by following these steps:
1. Launce the on-premise TotalAgility Designer.

The menu is limited to on-premise settings.
2. On the menu, select Integration > Web service references.

The Web service references are displayed for the default category.
3. From the Category list, select AP Agility.

A list of web service references for the AP Agility is displayed.
4. Click ApAgilityErpConnector.

The Edit web service references window is displayed.
5. Edit the URL so that it uses https and edit "localhost" to point to the location where the 

Integration Server and the Kofax AP Agility on-premise components are installed.
6. Click Save.

When prompted to regenerate the proxy DLLs, click OK.
Your changes are saved.
If there are any issues with the connection, an error is displayed with information on the 
issue. If there is an authentication issue, refer to Disable ERP Web Connector anonymous 
authentication.

Encrypt database connection string for OPMT
This is an optional procedure that is necessary only if your organization has a separate 
Administrator that maintains tenants. In this case you may wish to encrypt the database connection 
string so that other users cannot access to the Kofax AP Agility database.

You can use the encryption tool to encrypt the database connection string by following these steps:
1. View the extracted files from the ZIP file for your environment.

For more details on what files are needed for your environment, see Kofax AP Agility on-
premise components.

2. Navigate to <installation files>\EncryptionUtility.
3. Run the ConnectionStringEncrypter.exe application.

The Connection String Encrypter application is displayed.
4. In the Database Connection String setting, enter the database connection string to access 

the Kofax AP Agility database.
The SQL log on credentials that are part of the connection string must use the APA schema as 
default. For example,
Server=tcp:ktaservername.database.windows.net,1433;Initial 
 Catalog=TotalAgility_tenantId;Persist Security 
      Info=False;User ID=apa_live_user;Password=the-user-strong-password; 
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      MultipleActiveResultSets=False;TrustServerCertificate=False;Connection 
 Timeout=30;

5. Click Encrypt.
The connection string is encrypted.

6. Select Copy to Clipboard and paste the string alongside the other connection information that 
you provide to your users.

MarkView and the Scan form
If you are using MarkView then it is necessary to perform the following steps in order to update 
the Scan activity navigation to use the correct capture process that is specific to MarkView. This is 
a global change that affects the Scan activity for all organizations. However, the extra Scan activity 
fields are not displayed if an organization uses another ERP system or other databases.

You can update the Scan form to use the MarkView-specific process by following these steps:
1. Launch the TotalAgility Designer.
2. On the menu, select User interface > Navigations.

A list of Navigations is displayed for the Default Category.
3. From the Category list, select AP Agility.

A list of Navigations is displayed for the AP Agility category.
4. Select AP Agility Menu.

The Edit navigation menu window is displayed for the AP Agility menu.
5. From the menu on the left pane, select Scan.

The right pane is updated with the Scan navigation menu settings.
6. From the Target setting, select the InvoiceProcessingAgility category, and then select the

Capture_Scan_MV
The Scan activity and its list of invoice types is updated for MarkView.

Configure MarkView file ingestion
If you plan to use the Scan activity to get documents into Kofax AP Agility, it is not necessary to 
perform these steps.

If you are using MarkView and also want to use file system or email ingestion, it is necessary to 
create a MarkView-specific ingestion type so that it uses the correct process.

You can create a file ingestion for MarkView by following these steps:
1. Launch the TotalAgility Designer.
2. On the menu, select Integration > Import settings.

The Import Settings page is displayed.
3. Under Import Connections, click the name that you provided when you created the ingestion 

connection.

The import connection you created earlier is visible but it has no Import sources.
4. Under the Import sources section, click .

The New import source window is displayed.
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5. On the New import source window, edit the following settings to configure your input source.

a. In the Type list, select the import source type as FILE.
The available settings are updated so that they match the selected source type.

b. Enter a Display name, such as "IPFileSystemImport."

c. Select Normalize images and create pages.

d. Optionally, after configuring file import, click Test file import.

e. In the Associated action(s) group, ensure that the Job type setting is set to Create new 
job.

f. From the Process setting, click on the list, select the InvoiceProcessingAgility category, 
and then select one of the following, depending on your ERP system:
• If you have one or more organization integrated with MarkView, select the

CaptureDocumentMV process.
• If you are using another ERP system, select the CaptureDocument process.

The Initialization variables table is populated with fields related to the selected process.

g. Two fields require mapping only. Select the corresponding values as follows.

Name Mapping

InputSource Input Source Type

FileName File Name

 You can map additional fields, but if you do, this mapping overrides the mapping 
configured in the Settings > Invoice Processing > Global Settings > Import Settings.

h. Edit the other settings as needed.
For more information on these settings, see the Kofax TotalAgility Help.

i. Click Save.
Your changes are saved, the New import source window is closed, and your new import 
source is displayed on the Update import connection window.

Increase upload buffer size
If you plan on processing large documents, it is necessary to edit the uploadReadAheadSize value 
for your web server. This is the number of bytes that the Web server reads into a buffer and passes 
on to AP Agility. If your document size is greater than 48Mb, it is necessary to increase the value of 
this setting in order for them to be processed by AP Agility in a timely manner.

You can increase the upload buffer size by following these steps:
1. Launch the Internet Information Services Manager (IIS) on your on-premise server.
2. Select the Default Web Site or the site where you installed the AP Agility ERP Connector.

The central pane is updated with settings for the selected site.
3. In the Management group, double-click on Configuration Editor.

The Configuration Editor page is displayed.
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4. From the Section list, select system.webServer > serverRuntime.
A list of settings related to server runtime are displayed.

5. For the uploadReadAheadSize setting, increase the value from 49152 to "49152000".
This increases the default upload buffer size from 48kb to 48000kb.

6. Optionally, close IIS.

Install Analytics for Kofax AP Agility components
Use the following steps to install the Analytics for Kofax AP Agility components.

Configure Kofax AP Agility navigation menu
It is necessary to configure the navigation menu so that users can access Analytics for Kofax AP 
Agility from Kofax AP Agility.

For more information on configuring the Kofax AP Agility navigation menu, see the Analytics for 
Kofax AP Agility Installation Guide.

Configure the data load schedule
It is necessary to configure the data load schedule and its frequency so that data is regularly sent 
from Kofax AP Agility to Analytics for Kofax AP Agility.

For more information on configuring the data load schedule, see the Analytics for Kofax AP Agility 
Installation Guide.

Configure Kofax AP Agility resources
In order to ensure that the right users are able to access Analytics for Kofax AP Agility from the 
Kofax AP Agility menu, it is necessary to provide the necessary permissions.

For more information on configuring Kofax AP Agility resources, see the Analytics for Kofax AP 
Agility Installation Guide.

Test the Analytics for Kofax AP Agility installation
Test if you have a successful installation by following these steps:

1. Close or log out from all instances of Kofax AP Agility, Kofax TotalAgility, or Analytics for Kofax 
AP Agility because you cannot log on to multiple sessions in the same Browser.

2. Open the Kofax AP Agility tenant URL.
For example, https://tenant-id.server-name.net/forms/apagility/ using valid user 
credentials.

3. Ensure that the menu navigation that you created earlier is visible.
4. Click on the new menu item to open Analytics for Kofax AP Agility.

Enter valid user credentials when prompted.
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You are logged on successfully to Analytics for Kofax AP Agility.
If there is an error, review the user credentials or the installation steps.
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Chapter 3

Configure your Kofax AP Agility installation

The following steps are necessary after installing Kofax AP Agility. Each step contains its own set of 
instructions and the order is important. Skipping steps that are not optional, or performing steps 
out of sequence can result in a failed installation.

The configuration of your Kofax AP Agility installation is broken down into three parts.

1. Configuration steps that apply to the functionality of entire product
• if you do not want to use the Agnostic ERP, integrate another ERP system.

2. Configuration steps that are specific to the Invoice Processing functionality.
• CSV files for database lookups.
• Configure document ingestion.
• Optionally, modify the recognition engines in the Transformation Designer.

This step is necessary if you are processing documents in languages other than English only.

3. Configuration steps that are specific to the AP Agility Workflow functionality.
• Configure AP Agility Workflow administrative resource access.

General considerations for Kofax AP Agility in a cloud solution
There are several steps required to configure Kofax AP Agility that are independent of how you plan 
to process invoices.

If you are using an Enterprise Resource Planning system it is necessary to integrate that system 
with Kofax AP Agility in a multi-tenant or Kofax hosted Azure environment.

Integration with Enterprise Resource Planning systems
Kofax AP Agility exports all validated and approved invoices to the Enterprise Resource Planning 
system (ERP) through a connector plugin. When you first install Kofax AP Agility, you installed the 
Agnostic ERP connector. The Agnostic ERP integration provides an ERP-neutral way of integration 
by transferring data to and from folders. The Kofax AP Agility Administrator specifies the output file 
system folder and the file name format for exported invoices. The administrator creates an invoice 
image in the original format and metadata (XML, CSV) files in the specified folder for all exported 
invoices. You can also use SAP ECC or MarkView for your ERP as long as the necessary SAP client or 
Oracle client components are available at the time of the Kofax AP Agility installation.
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In addition to the Agnostic ERP connector, SAP ECC, and MarkView, Kofax AP Agility provides plugins 
for the following ERPs:
• PeopleSoft
• S/4HANA Cloud ES

 After you are finished integrating an ERP connector, refer to the Manage ERP integrations
chapter in the Configuration Help for more information about the steps needed to complete the 
ERP connector integration in Kofax AP Agility.

Install PeopleSoft connector
If you are using the PeopleSoft ERP system, it is necessary to install the PeopleSoft ERP connector in 
addition to the Agnostic ERP connector. You cannot install this connector without the Agnostic ERP 
connector.

If the Agnostic ERP connector is installed, you can install the PeopleSoft ERP connector by following 
these steps:

1. Download the KofaxAPAgilityERPConnector-2.5.0_For_PeopleSoft.ZIP file from the Kofax 
Fulfillment Site and extract it on a local drive available to your users.
Note the extraction location as this is needed in subsequent steps after you install the 
connector.

2. Copy the contents in ERP Connector\bin from the extracted files to the bin folder in IIS 
where the ERP connector files are stored.
By default, this path is <Program Files (x86)>\Kofax\APAgility\Web\bin.
The PeopleSoft connector is installed and ready for integration with Kofax AP Agility.

Import the PeopleSoft ERP plugin
Before using the PeopleSoft ERP in Kofax AP Agility it is necessary to import the ERP plugin into 
Kofax TotalAgility.

You can import the PeopleSoft ERP plugin by following these steps:
1. On the filesystem, navigate to where the extracted contents of the

KofaxAPAgilityERPConnector-2.5.0_For_PeopleSoft.zip file are located.
You extracted this file when the PeopleSoft connector was installed.

2. Launch the TotalAgility Designer.
3. On the menu, select Import.

The Import page is displayed.
4. Click Browse and then navigate to your extracted files and select ERP Plugin

\ErpPluginPackage-PeopleSoft.zip.
A list of files and artifacts for import are displayed for that package.

5. For the Overwrite options select Overwrite all.
6. For the Non-versioned items select Overwrite.
7. Click Import.

When prompted to confirm the import, click OK.
When the ERP plugin is imported successfully a message is displayed.
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What Next?

Now that your PeopleSoft ERP plugin is imported, open Kofax AP Agility and perform the following 
steps:
• Register your ERP plugin.
• Add your PeopleSoft ERP connection.
• Add or edit an organization to use the newly added PeopleSoft ERP connection.

For more information on configuring ERP connections and organizations, refer to the Kofax AP 
Agility Configuration Help.

PeopleSoft integration
You can integrate PeopleSoft with Kofax AP Agility by following these steps:

1. On the filesystem, navigate to where the extracted contents of the
KofaxAPAgilityERPConnector-2.5.0_For_PeopleSoft.zip file are located.
You extracted this file when the PeopleSoft connector was installed.

2. Navigate to the ERP Integration\PeopleSoft folder.
This folder contains the KofaxConnector_For_PeopleSoft.zip file.

3. Extract the KofaxConnector_For_PeopleSoft.zip file.
The KOFAX_CONNECTOR folder is extracted.

4. Start the PeopleSoft Application Designer.
5. On the menu, select Tools > Copy Project > From File.

The Copy From File : Select Project window is displayed.
6. Select the KOFAX_CONNECTOR project and settings from the Copy From File : Select Project

window and perform the following steps.

a. Navigate to and select the KOFAX_CONNECTOR folder.
Under Name, KOFAX_CONNECTOR is displayed, and KOFAX_CONNECTOR is displayed 
under Select Project from the List Below.

b. Click Select to the right of the Select Project from the List Below box.
The Copy From File window is displayed.

c. Click Select All to select all definition types.

d. Click Copy.
The project and its definition types are installed.

7. Open PeopleSoft in a compatible web browser and configure KOFAX_APA_SERVICE by 
performing the following steps.

a. Go to PeopleTools > Integration Broker > Integration Setup > Services.

b. Open KOFAX_APA_SERVICE.
Information about KOFAX_APA_SERVICE and a list of service operations is displayed.

c. Open one of the KOFAX_APA_SERVICE service operations and click Service Operation 
Security.

d. Set the PTPT1000 permission to Full Access and click Save.
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e. Repeat steps 7.c–7.d until all of the KOFAX_APA_SERVICE service operations have been 
configured.

PeopleSoft invoice export
Additional settings are needed to enable invoice export from PeopleSoft. The ChartFields settings 
are used for GL segments for invoices. If the buyer does not have access to the ChartFields settings, 
GL segment values from exported invoices are ignored and replaced by default values. You can 
enable buyers to access these settings by following these steps:

1. Start PeopleSoft.
2. In the PeopleSoft menu, select Navigator > eSettlements > Buyer Information > Review 

Buyer Details.
3. Select the buyer who should have access.

The Review Buyer Details window for that buyer is displayed.
4. Click the ChartField Configuration tab.
5. Change the Supplier Access settings for the buyer to make applicable GL segments editable.
6. Save the settings.

Install S/4HANA Cloud ES ERP plugin
S/4HANA Cloud ES differs from the other supported ERP systems because it is a cloud-based ERP 
system. Also, its connector is installed within Kofax TotalAgility, so no separate ERP connector is 
needed.

You can install the S/4HANA Cloud ES ERP plugin by following these steps:
1. Download and extract the contents of the

KofaxAPAgilityERPConnector-2.5.0_For_SAPS4HANACloudES.ZIP file.
This file is a deliverable that is part of Kofax AP Agility 2.8.0.
Make note of this location as it is needed later in these steps.

2. Launch the TotalAgility Designer.
3. On the menu, select Import.

The Import page is displayed.
4. Click Browse and then navigate to your extracted files and select ErpPluginPackage-

SAPS4HanaCloud.zip.
A list of files and artifacts for import are displayed for that package.

5. For the Overwrite options select Overwrite all.
6. For the Non-versioned items select Overwrite.
7. Click Import.

When prompted to confirm the import, click OK.
When the ERP plugin is imported successfully a message is displayed.

What Next?

Now that your S/4HANA Cloud ES ERP plugin is imported, open Kofax AP Agility and perform the 
following steps:
• Register your ERP plugin.
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• Add your S/4HANA Cloud ES ERP connection.
• Add or edit an organization to use the newly added S/4HANA Cloud ES ERP connection.

For more information on configuring ERP connections and organizations, refer to the Kofax AP 
Agility Configuration Help.

ERP master data import
The ERP master data in the Kofax AP Agility database must be updated regularly. For the Agnostic 
ERP, data is imported from CSV files. For other connections, data is usually imported from the ERP 
application. For S/4HANA Cloud ES, some of master data must be uploaded as CSV files. The files 
required by S/4HANA Cloud ES are Payment Terms, Payment Term Details, and Plants files.

For the Agnostic ERP, you need to edit the paths for the employee, UOM conversion, tax code, and 
miscellaneous charge in the Settings  > Global Import Files. For more information on this form, 
refer to the Kofax AP Agility Configuration Help.

To import the ERP master data, use the AP Data Import job. The Kofax AP Agility Administrator sets 
up the schedule for the job or starts the job manually. One job imports data for all organizations.

Kofax AP Agility makes records about the status of the import jobs in these Kofax AP Agility 
database tables:
• ERP_CONNECTOR_SERVICE_CALL_STATUS: Contains the status of each ERP Connector call.
• ERP_IMPORT_JOB_STATUS: Contains the status of loading data as it is prepared by the ERP 

Connector to the Kofax AP Agility database.

Use these records for troubleshooting purposes if the import fails or not all data was loaded.

The ERP master data includes the following types of data with the corresponding Kofax AP Agility 
database tables:
• ERP invoices: ERP_INVOICE
• Payment terms: PAYMENT_TERM
• Payment terms details: PAYMENT_TERM_DETAIL
• Vendors: VENDOR_MASTER_DATA, BRWVendorMaster
• PO headers: PO_HEADER
• PO lines: PO_LINES
• GL Segments: GL_SEGMENTS
• Plants: PLANTS
• Receipt lines: RECEIPT_LINES
• Tax Codes: TaxCode
• Miscellaneous Charge: MiscChargesAccount
• Unit of Measure Conversions: BRWUOMConversions
• Employee: BRWEmployeeMaster
• Cost Center Segments: COST_CENTER_SEGMENTS
• Work Breakdown Structures: WBS_SEGMENTS
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The data for all ERP master data types is located in the corresponding CSV files. Data types and 
formats are as follows:
• Number: Standard number format
• Integer: Standard integer number format
• Double: Double number format with floating decimal
• String: Commas in the text must be in quotation marks
• Datetime: yyyy-mm-dd HH:MM:SS
• Bit: 0 or 1

CSV exchange format
In CSV format, place the fields in the order specified in this section. This format must contain a 
header, and fields must be separated by a comma.

ERP invoices CSV format

Table name: ERP_INVOICE

File name (for Agnostic ERP): erp_invoices.csv

Field 
Index

Column Name Type(Max) Mandatory Description

1 ERP_INVOICE_ID nvarchar(50) Yes The Invoice ID in the customer 
ERP system.
This value is mandatory.

2 ERP_BUSINESS_UNIT_ID nvarchar(100) No* The Business Unit ID in the 
customer ERP system.
* This value is optional. 
However, when left empty there 
are no business units.

3 INVOICE_NUMBER nvarchar(50) No* Invoice number.
* This value is mandatory when 
the Use the number of the 
invoice to identify duplicates
setting is enabled in the
Settings > Workflow > General 
Settings.

4 INVOICE_DATE date No* Invoice date.
* This value is mandatory when 
the Use the date of the invoice 
to identify duplicates setting 
is enabled in the Settings >
Workflow > General Settings.

5 INVOICE_TYPE nvarchar(50) No Invoice type:
• PO (for single PO invoices)
• Non-PO
• Credit Memo Invoice
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Field 
Index

Column Name Type(Max) Mandatory Description

6 INVOICE_AMOUNT numeric No* Invoice amount.
* This value is mandatory when 
the Use the amount of the 
invoice to identify duplicates
setting is enabled in the
Settings > Workflow > General 
Settings.

7 PO_NUMBER nvarchar(50) No PO Number (or Purchase Order 
Number).

8 PAYMENT_DATE date No Payment date.

9 CANCELLED_DATE date No Canceled date.

10 INVOICE_STATUS nvarchar(50) No Invoice payment status (PAID or 
UNPAID).

11 VENDOR_NAME1 nvarchar(50) No Vendor Name.
This value is mandatory for any 
duplicate search.

12 VENDOR_SITE_ID nvarchar(50) No Vendor site ID.

13 VENDOR_SITE_CODE nvarchar(50) No Vendor site code.

14 ERP_VENDOR_ID nvarchar(50) Yes ERP vendor ID.
This value is mandatory.

For example, the contents of the erp_invoices.csv file may look as follows:

ERP_INVOICE_ID, ERP_BUSINESS_UNIT_ID, INVOICE_NUMBER, INVOICE_DATE, INVOICE_TYPE, 
 INVOICE_AMOUNT, PO_NUMBER, PAYMENT_DATE, CANCELLED_DATE, INVOICE_STATUS, VENDOR_NAME1, 
 VENDOR_SITE_ID, VENDOR_SITE_CODE, ERP_VENDOR_ID
214303,204,nd03np_KTM_05/31/2017,2017-05-31 00:00:00,Non-PO Invoice,1000,,,,UNPAID,GE 
 Capital,BOSTON,289,93
214304,204,nd04np_KTM_05/31/2017,2017-05-31 00:00:00,Non-PO Invoice,1000,,,,UNPAID,GE 
 Capital,BOSTON,289,94
214302,204,nd02np_KTM_05/31/2017,2017-05-31 00:00:00,Non-PO Invoice,1000,,,,UNPAID,GE 
 Capital,BOSTON,289,95

Payment terms CSV format

Table name: PAYMENT_TERM

File name (for Agnostic ERP): payment_terms.csv

This CSV file is required when using the S/4HANA Cloud ES ERP.

Field 
Index

Column Name Type(Max) Mandatory Description

1 ERP_TERM_ID nvarchar(50) Yes The payment term ID in the 
customer ERP system.
This value is mandatory.
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Field 
Index

Column Name Type(Max) Mandatory Description

2 ERP_BUSINESS_UNIT_ID nvarchar(100) No* The Business Unit ID in the 
customer ERP system.
* This value is optional. 
However, when left empty there 
are no business units.

3 TERM_NAME nvarchar(50) Yes The payment term name.
This value is mandatory.

4 TERM_DESCRIPTION nvarchar(1000) No The payment term description.

For example, the contents of the payment_terms.csv file may look as follows:
ERP_TERM_ID,ERP_BUSINESS_UNIT_ID,TERM_NAME,TERM_DESCRIPTION
10001,204,Immediate,Scheduled for payment immediately.
10002,204,End next month,Paid on the last day of the following month
10003,204, "30 Days Net, 14 Days -2%","30 Days Net, 2% Discount if paid within 14 days"

Payment terms details CSV format

Table name: PAYMENT_TERM_DETAIL

File name (for Agnostic ERP): payment_term_details.csv

This CSV file is required when using the S/4HANA Cloud ES ERP.

Field 
Index

Column Name Type(Max) Mandatory Description

1 ERP_TERM_ID nvarchar(50) Yes The payment term ID in the 
customer ERP system.
This value is mandatory.

2 ERP_BUSINESS_UNIT_ID nvarchar(100) No* The business unit ID in the 
customer ERP system.
* This value is optional. 
However, when left empty there 
are no business units.

3 SEQUENCE_NUM int Yes The payment sequence number.
This value is mandatory.

4 DUE_PERCENT numeric No The percentage of the invoice 
amount that must be paid 
before the invoice due date.

5 DUE_AMOUNT numeric No The amount that must be paid 
before the invoice due date.
One of the fields DUE_PERCENT
or DUE_AMOUNT must be left 
blank.

6 DUE_DAYS int No The number of days left before 
the invoice due date.
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Field 
Index

Column Name Type(Max) Mandatory Description

7 DUE_DAY_OF_MONTH int No The day of the month in the 
invoice due date

8 DUE_MONTHS_FORWARD int No The months left for the invoice 
to be paid

9 DISCOUNT_PERCENT_1 numeric No The percentage of the discount.

10 DISCOUNT_DAYS_1 int No The days left before the discount 
due date.

11 DISCOUNT_DAY_OF_MONTH_1 int No The day of the month before the 
discount due date.

12 DISCOUNT_MONTH_FORWARD_1 int No The number of months before 
the discount due date.

For example, the contents of the payment_term_details.csv file may look as follows:
ERP_TERM_ID, ERP_BUSINESS_UNIT_ID, SEQUENCE_NUM, DUE_PERCENT, DUE_AMOUNT,DUE_DAYS, 
 DUE_DAY_OF_MONTH, DUE_MONTHS_FORWARD, DISCOUNT_PERCENT_1, DISCOUNT_DAYS_1, 
 DISCOUNT_DAY_OF_MONTH_1, DISCOUNT_MONTH_FORWARD_1
10000,204,1,100,,0,,,,,,,
10001,204,1,100,,10,,,,,,
10002,204,1,100,,60,,,4,10,,

Vendors CSV format

Table name: VENDOR_MASTER_DATA

File name (for Agnostic ERP): vendors.csv

Field 
Index

Column Name Type(Max) Mandatory Description

1 ERP_VENDOR_ID nvarchar(50) Yes The unique vendor ID from the 
extracted data. Each row must 
have a unique reference. This is 
not the unique vendor ID from 
the customer ERP system if a site 
ID is also used.
This value is mandatory.

2 ERP_BUSINESS_UNIT_ID nvarchar(100) No* The business unit ID in the 
customer ERP system (company 
code).
* This value is optional. 
However, when left empty there 
are no business units.

3 ERP_TERM_ID nvarchar(50) No The default payment terms ID 
for the vendor in the customer 
ERP system. This column should 
match the payment terms in 
Payment Terms CSV.

4 DESCRIPTION nvarchar(max) No The description.
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Field 
Index

Column Name Type(Max) Mandatory Description

5 VENDOR_NAME nvarchar(360) Yes The vendor name.
This value is mandatory.

6 VENDOR_SITE_ID nvarchar(50) No* The vendor site ID.
This value should be empty if the 
ERP does not support the vendor 
sites.
* This value is mandatory if your 
ERP system supports vendor 
sites.

7 VENDOR_SITE_CODE nvarchar(50) No* Vendor site code.
This value should be empty if the 
ERP does not support the vendor 
sites.
* This value is mandatory if your 
ERP system supports vendor 
sites.

8 VENDOR_STREET1 nvarchar(100) No The vendor street address line 1.

9 VENDOR_STREET2 nvarchar(100) No The vendor street address line 2.

10 VENDOR_CITY nvarchar(50) No The vendor city.

11 VENDOR_ZIP nvarchar(50) No The vendor zip code or postal 
code.

12 VENDOR_STATE nvarchar(50) No The vendor state.
For U.S. addresses, the state 
code is expected here, such as 
CA = California, VA = Virginia.

13 VENDOR_COUNTRY nvarchar(50) No The vendor country.
This is a two-character ISO code 
for the country. For example, 
US = United States of America, 
DE = Germany, and GB = United 
Kingdom.

14 VENDOR_VAT_CODE nvarchar(50) No The vendor VAT code.

15 VENDOR_VAT_REGNO nvarchar(100) No The vendor VAT registration 
number. If the vendor is 
registered for VAT in more than 
one country, then multiple 
VAT registration numbers are 
provided in a comma-separated 
list. The entire column value 
should be quoted to preserve 
CSV format.

16 TAX_NUMBER nvarchar(50) No The tax number.

17 BANK_CODE nvarchar(50) No The bank code. This is the U.S. 
equivalent of a routing number.
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Field 
Index

Column Name Type(Max) Mandatory Description

18 BANK_ACCOUNT_NUMBER nvarchar(50) No The bank account number.

19 EMAIL nvarchar(250) No The email.

20 URL nvarchar(250) No The URL.

21 TELEPHONE nvarchar(50) No The vendor telephone number.

22 FAX nvarchar(50) No The fax number.

23 CONTACT_NAME nvarchar(50) No The contact name.

24 ACTIVE bit Yes The boolean value that indicates 
if an entry is valid or not.
This value is mandatory.

25 N/A Reserved for future use.

26 TERM_DATE_BASIS nvarchar(50) No The term date basis:
• Invoice
• Goods received
• Current
• Invoice received

27 PO_BOX nvarchar(50) No The vendor Post Office (PO) box 
number.

28 PO_BOX_ZIP nvarchar(50) No The ZIP or postal code 
associated with the vendor Post 
Office (PO) box.

29 EU_MEMBER nvarchar(50) Yes Indicates if the vendor is in an 
EU member country or not.

30 CURRENCY nvarchar(50) No The vendor currency.

31 TAX_ID_1 nvarchar(50) No The vendor tax ID 1.

32 TAX_ID_2 nvarchar(50) No The vendor tax ID 2.

33 TAX_JUR_CODE nvarchar(100) No The ID of the tax office where 
the vendor is based.

34 INVOICE_TYPE nvarchar(50) No Vendor invoice type. This is set 
to a value that denotes either 
PO-supplying vendor or vendor 
who submits invoices that 
legitimately do not reference a 
purchase order.
The meaning of the values must 
be mapped against the PO Value 
and Non-PO Value settings in 
the Invoice Type Settings.
By default, the supported values 
are PO and NONPO.
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Field 
Index

Column Name Type(Max) Mandatory Description

35 PAYMENT_METHODS nvarchar(50) No The comma-separated list 
of payment method codes 
appropriate for the vendor. If 
more than one code is specified 
then entire column value to be 
quoted to preserve CSV format.

36 WITHHOLDING_TAX_DETAILS nvarchar(50) No
 This value is relevant for 
SAP ECC only.

This column is used to resolve 
the tax type and the tax code 
that is submitted to SAP ECC /
S/4HANA Cloud ES.

37 COMPANY_CODE nvarchar(50) No This field is no longer used and 
should be left empty.
Use the
ERP_BUSINESS_UNIT_ID
instead.

38 UTILITY_FLAG nvarchar(50) No Indicates whether the vendor is 
a utility vendor

39 POR_SUBSCRIBER_NO nvarchar(50) No Vendor POR subscriber number 
used only for Switzerland.

40 EXTERNAL_SITE_ID nvarchar(50) No External site ID.

41 VENDOR_ACCOUNT_GROUP nvarchar(50) No ERP system vendor account 
group.

42 ALTERNATIVE_PAYEE nvarchar(50) No The party that receives payment 
for an invoice.

43 PERMITTED_PAYEE nvarchar(50) No A comma-separated list of 
alternate payees for the vendor.

44 SIRET_ID nvarchar(50) No The vendor SIRET ID. This 
ID code used in France that 
uniquely identifies a single 
vendor at a single address. It is 
often found on French invoices.

45 VENDOR_IDENTIFIER nvarchar(50) No The unique vendor identifier 
code, such as a Chinese tax 
number.

46 INTERCOMPANY bit Yes This indicates whether a vendor 
is an InterCompany vendor or 
not.

47 ERP_BANK_ACCOUNT_CODE nvarchar(50) No The vendor bank account code 
as specified in ERP.
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Field 
Index

Column Name Type(Max) Mandatory Description

48 IS_ONE_TIME_VENDOR bit No Indicates is a vendor is to be 
used once only.

For example, the contents of the vendors.csv file may look as follows:
ERP_VENDOR_ID, ERP_BUSINESS_UNIT_ID, ERP_TERM_ID, DESCRIPTION, VENDOR_NAME, 
 VENDOR_SITE_ID, VENDOR_SITE_CODE, VENDOR_STREET1, VENDOR_STREET2, VENDOR_CITY, 
 VENDOR_ZIP, VENDOR_STATE, VENDOR_COUNTRY, VENDOR_VAT_CODE, VEBDOR_VAT_REGNO, 
 TAX_NUMBER, BANK_CODE, BANK_ACCOUNT_NUMBER, EMAIL, URL, TELEPHONE, FAX, CONTACT_NAME, 
 ACTIVE, , TERM_DATE_BASIS, PO_BOX, PO_BOX_ZIP, EU_MEMBER, CURRENCY, TAX_ID1, 
 TAX_ID2, TAX_JUR_CODE, INVOICE_TYPE, PAYMENT_METHODS, WITHHOLDING_TAX_DETAILS, 
 COMPANY_CODE, UTILITY_FLAG, POR_SUBSCRIBER_NO, EXTERNAL_SITE_ID, VENDOR_ACCOUNT_GROUP, 
 ALTERNATIVE_PAYEE, PERMITTED_PAYEE, SIRET_ID, VENDOR_IDENTIFIER, INTERCOMPANY, 
 ERP_BANK_ACCOUNT_CODE, IS_ONE_TIME_VENDOR
100403, 204, 77745, test vendor a, Thumbs Up, VSID100403, VSID100403, Dummers Lane, , 
 Bury, BL9 9UT, GB, GB, GB339072747, GB339072747, , , , , , , , , 1, 1, , , , X, 
 GBP, , , , , , , , , , VSID100403, , , , , , 0, 0
100406, 204, 10043, GE Capital Kofax, GE Capital Kofax, 100500, SiteCode388, Abbey 
 Road 69, NoName Street, New York, Zip1, NY, US, Vat1, VatRegNo1, 1, BankCode1, 
 BankAccountNum1, mail@gecapitalkofax.com, www.gecapitalkofax.com, +12345671, (070) 412 
 34 561, Ivan Scott, True, True, Invoice, PoBox1, PoBoxZip1, 0, USD, TaxId1, TaxId2, 
 TaxJurCode1, NON-PO, , , , , , GEC0001, , , , , , , , BAC1, 0

PO headers CSV format

Table name: PO_HEADER

File name (for Agnostic ERP): po_headers.csv

Field 
Index

Column Name Type(Max) Mandatory Description

1 ERP_PO_HEADER_ID nvarchar(50) Yes PO header ID in ERP.
This value is mandatory.

2 ERP_BUSINESS_UNIT_ID nvarchar(100) Yes Business unit ID in ERP.
This value is mandatory.

3 PO_NUMBER nvarchar(50) Yes PO numbe.r
This value is mandatory.

4 PO_TYPE nvarchar(50) No PO type:
• MATERIAL
• SERVICE

5 ERP_VENDOR_ID nvarchar(50) Yes Vendor ID in ERP.
This value is mandatory.

6 VENDOR_NAME1 nvarchar(100) No Vendor name.
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Field 
Index

Column Name Type(Max) Mandatory Description

7 VENDOR_SITE_ID nvarchar(50) No* Vendor site ID.
This value should be empty if the 
ERP does not support the vendor 
sites.
* This value is mandatory if your 
ERP system supports vendor 
sites.

8 VENDOR_SITE_CODE nvarchar(50) No* Vendor site code.
This value should be empty if the 
ERP does not support the vendor 
sites.
* This value is mandatory if your 
ERP system supports vendor 
sites.

9 PO_STATUS nvarchar(50) No PO Status.

10 ACTIVE bit Yes Is Active.

11 CURRENCY_CODE nvarchar(3) No The 3-character currency code.

For example, the contents of the po_headers.csv file may look as follows:
ERP_PO_HEADER_ID, ERP_BUSINESS_UNIT_ID, PO_NUMBER, PO_TYPE, ERP_VENDOR_ID, 
 VENDOR_NAME1, VENDOR_SITE_ID, VENDOR_SITE_CODE, PO_STATUS, ACTIVE, CURRENCY_CODE
4500043355,204,4500043355,MATERIAL,100403,Thumbs Up,VSID100403,VSC100403,NULL,1,GBP
4500043375,204,4500043375,MATERIAL,100403,Thumbs Up,VSID100403,VSC100403,NULL,1,GBP

PO lines CSV format

Table name: PO_LINES

File name (for Agnostic ERP): po_lines.csv

Field 
Index

Column Name Type(Max) Mandatory Description

1 ERP_PO_LINE_ID nvarchar(50) Yes PO line ID in ERP.
This value is mandatory.

2 ERP_BUSINESS_UNIT_ID nvarchar(100) Yes Business unit ID in ERP.
This value is mandatory.

3 ERP_PO_HEADER_ID nvarchar(50) Yes PO header ID in ERP.
This value is mandatory.

4 PO_NUMBER nvarchar(50) Yes PO number.
This value is mandatory.

5 LINE_NUMBER nvarchar(50) Yes Line number.

6 MATERIAL_NO nvarchar(50) No Material number.

7 MATERIAL_GROUP nvarchar(50) No Material group.

8 DESCRIPTION nvarchar(255) No Description.
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Field 
Index

Column Name Type(Max) Mandatory Description

9 PO_QUANTITY numeric No* PO Quantity.
* This value is required for 
material lines only.

10 UNIT_PRICE numeric No* Unit price.
* This value is required for 
material lines only.

11 PO_TOTAL numeric Yes PO total.

12 TAX_CODE nvarchar(50) No Tax code.

13 TAX_JUR_CODE nvarchar(50) No Tax jurisdiction code.

14 UOM nvarchar(50) No Unit of measure.

15 PRICE_UNIT numeric No Price unit.

16 PUOM nvarchar(50) No PUOM (Order price unit of 
measure.)

17 TOTAL_QUANTITY_DELIVERED numeric No* Total quantity delivered.
* This value is required for 
material lines only.

18 TOTAL_VALUE_DELIVERED numeric No* Total value delivered.
* This value is required for 
material lines only.

19 TOTAL_QUANTITY_INVOICED numeric No* Total quantity invoiced.
* This value is required for 
material lines only.

20 TOTAL_VALUE_INVOICED numeric No* Total value invoiced.
* This value is required for 
material lines only.

21 ITEM_CATEGORY nvarchar(50) No Item category or line item type.

22 PLANT nvarchar(50) No Plant (The location code for 
the ship-to address where the 
goods were delivered, or where 
a service was performed.)

23 CHARGE_CODE nvarchar(50) No Charge code.

24 CHARGE_CODE_ID nvarchar(50) No Charge code ID.

25 ERP_PO_TYPE nvarchar(50) No ERP PO type (for JD Edwards PO.)

26 ERS nvarchar(50) No ERS flag.

27 RECEIPT_REQUIRED bit Yes Receipt required.

For example, the contents of the po_lines.csv file may look as follows:
ERP_PO_LINE_ID, ERP_BUSINESS_UNIT_ID, ERP_PO_HEADER_ID, P)_NUMBER, LINE_NUMBER, 
 MATERIAL_NO, MATERIAL_GROUP, DESCRIPTION, PO_QUANTITY, UNIT_PRICE, PO_TOTAL, TAX_CODE, 
 TAX_JUR_CODE, UOM, PRICE_UNIT, PUOM, TOTAL_QUANTITY_DELIVERED, TOTAL_VALUE_DELIVERED, 
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 TOTAL_QUANTITY_INVOICED, TOTAL_VALUE_INVOICED, ITEM_CATEGORY, PLANT, CHARGE_CODE, 
 CHARGE_CODE_ID, ERP_PO_TYPE, ERS, RECEIPT_REQUIRED
00010-4500043388, 204, 4500043388, 4500043388, 00010, NULL, ZT00, pencils, 1.00, 1.00, 
 1.00, V0, NULL, EA, 1.00, EA, 1.00, 1.00, 0.00, 0.00, 0, 2000, NULL, NULL, NULL, , 1
00020-4500043388, 204, 4500043388, 4500043388, 00020, NULL, ZT00, rulers, 1.00, 2.00, 
 2.00, V0, NULL, EA, 1.00, EA, 0.00, 0.00, 0.00, 0.00, 0, 2000, NULL, NULL, NULL, , 1
00030-4500043388, 204, 4500043388, 4500043388, 00030, NULL, ZT00, pens, 1.00, 3.00, 
 3.00, V0, NULL, EA, 1.00, EA, 0.00, 0.00, 0.00, 0.00, 0, 2000, NULL, NULL, NULL, , 1
00040-4500043388, 204, 4500043388, 4500043388, 00040, NULL, ZT00, crayons, 1.00, 4.00, 
 4.00, V0, NULL, EA, 1.00, EA, 1.00, 4.00, 0.00, 0.00, 0, 2000, NULL, NULL, NULL, , 1

GL segments CSV format

Table name: GL_SEGMENTS

File name (for Agnostic ERP): gl_segments.csv

Field 
Index

Column Name Type Mandatory Description

1 ERP_SEGMENT_ID nvarchar(50) Yes The Segment ID number in the 
customer ERP system.
This value is mandatory.

2 ERP_BUSUNESS_UNIT_ID nvarchar(100) No* The Business Unit ID in the 
customer ERP system.
* This value is optional. 
However, when left empty there 
are no business units.

3 GL_SEGMENT_NUMBER int Yes The order number of the 
Segment.
This value is mandatory.

4 GL_SEGMENT_VALUE nvarchar(50) Yes The Segment value.
This value is mandatory.

5 DESCRIPTION nvarchar(255) Yes The description of the Segment.
This value is mandatory.

6 GL_SEGMENT_NAME nvarchar(50) No The name of the GL Segment.

7 PARENT_ERP_SEGMENT_ID nvarchar(200) No The ID of the parent segment. 
This is null for the first segment 
in a structure.
Values for this column are 
required if you are using 
hierarchical GL codes. Refer to 
the Kofax AP Agility Configuration 
Help for more information on GL 
code hierarchies.

For example, the contents of the gl_segments.csv file may look as follows:
ERP_SEGMENT_ID, ERP_BUSUNESS_UNIT_ID, GL_SEGMENT_NUMBER, GL_SEGMENT_VALUE, 
 GL_SEGMENT_DESCRIPTION, GL_SEGMENT_NAME, PARENT_ERP_SEGMENT_ID
0101,204,1,001001,USA,COUNTRY1,
0102,204,1,001002,UK,COUNTRY2,
...
0201,204,2,002001,California,STATE1,0101
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0202,204,2,002002,New York,STATE2,0101
0205,204,2,002005,Bristol,STATE5,0102
0206,204,2,002006,London,STATE6,0102
...
0301,204,3,003001,Los Angeles,CITY1,0201
0302,204,3,003002,San Francisco,CITY2,0201
0303,204,3,003005,New York,CITY5,0202
0304,204,3,003006,Buffalo,CITY6,0202
03017,204,3,0030017,Bishopston,CITY17,0205
03018,204,3,0030018,London,CITY18,0206
...

Plants CSV format

Table name: PLANTS

File name (for Agnostic ERP): plants.csv

This CSV file is required when using the S/4HANA Cloud ES ERP.

Field 
Index

Column Name Type(Max) Mandatory Description

1 PLANT_ID nvarchar(50) Yes The plant ID. It must be unique 
in CSV file. It matches the Plant 
value specified for PO lines. It 
is exported as the invoice line 
Plant field.
This value is mandatory.

2 ERP_ORGANIZATION_ID nvarchar(50) No The plant belongs to this 
organization ID. If an 
organization ID is not provided, 
the plant is created and linked to 
the organization defined in the 
ERP Connection.
This value is mandatory.

3 COUNTRY_CODE nvarchar(2) Yes The two-character ISO country 
code for the plant.
This value is mandatory.

 Entries with empty 
country codes are skipped in 
the import process.

4 STATE_CODE nvarchar(60) No The state where the plant is 
located. For the United States, 
use the two-character state code 
such as CA for California.

For example, the contents of the plants.csv file may look as follows:
PLANT_ID,ERP_ORGANIZATION_ID,COUNTRY_CODE,STATE_CODE
USA001,Kofax,US,NY
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Receipt Lines data format

Table name: RECEIPT_LINES

File name (for Agnostic ERP): receipt_lines.csv

Field 
Index

Column Name Type(Max) Mandatory Description

1 ERP_BUSINESS_UNIT_ID nvarchar(100) Yes The business unit ID in customer 
ERP system (company code).
This value is mandatory.

2 PO_NUMBER nvarchar(50) Yes The PO number that is used 
during line pairing to match the 
receipt line.
See PO lines CSV format.

3 PO_LINE_NUMBER nvarchar(50) Yes The PO line number in the 
customer ERP system. This is an 
ERP-specific line ID in the PO, 
such as the line number. It must 
be unique among lines in the 
PO. It is used during line pairing 
to match the receipt line to the 
number of PO line.
See PO lines CSV format.

4 ERP_RECEPT_ID nvarchar(50) Yes The receipt ID in the customer 
ERP system. This value is used 
by Kofax AP Agility Invoice 
Processing as the receipt 
number (DOC_NO field) during 
line pairing. For the line-paired 
invoice lines this column is 
exported as the GRDocNo tag.

5 RECEIPT_LINE_NUMBER nvarchar(50) Yes The receipt item number in 
the customer ERP system. This 
value is used by Kofax AP Agility 
Invoice Processing as the receipt 
item (DOC_ITEM field) during line 
pairing. For paired invoice lines, 
it is exported as the GRDocItem
tag.

6 DELIVERY_DOCUMENT_NUMBER nvarchar(50) No The delivery document number.

7 QUANTITY numeric Yes The quantity on a document.

8 UNITPRICE numeric Yes The unit price on a document.

9 TOTAL numeric Yes The total amount on a 
document.

10 QUANTITY_INVOICED numeric Yes The quantity invoiced on a 
document.
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Field 
Index

Column Name Type(Max) Mandatory Description

11 TOTAL_INVOICED numeric Yes The total invoiced on a 
document.

12 DOC_YEAR nvarchar(50) No The receipt year on a document.

For example, the contents of the receipt_lines.csv file may look as follows:
BUSINESS_UNIT, PO_NUMBER, PO_LINE_NUMBER, ERP_RECEPT_ID, RECEIPT_LINE_NUMBER, 
 DELIVERY_DOCUMENT_NUMBER, QUANTITY, UNIT_PRICE, TOTAL, QUANTITY_INVOICED, 
 TOTAL_INVOICED, DOC_YEAR
204,4500043375,00010,5000000940,0001,NULL,4.00,5.00,20.00,0.00,0.00,2019
204,4500043375,00010,5000000941,0001,NULL,6.00,5.00,30.00,0.00,0.00,2019
204,4500043375,00020,5000000941,0002,NULL,7.00,8.00,56.00,0.00,0.00,2019
204,4500043375,00020,5000000940,0002,NULL,3.00,8.00,24.00,0.00,0.00,2019

Employee format

Table name: BRWEmployeeMaster

File name (for Agnostic ERP): employee.csv

Field 
Index

Column Name Type(Max) Mandatory Description

1 INDEX_ID nvarchar(100) Yes The index ID of the employee 
record.
This value is mandatory.

2 PARTITION_ID int Yes The ID of the partition for the 
employee.
This value is mandatory.

3 ID nvarchar(50) Yes The ID of the employee.
This value is mandatory.

4 NAME nvarchar(100) No The employee name.

5 ADDRESS1 nvarchar(200) No The first line of the employee's 
address.

6 ADDRESS2 nvarchar(200) No The second line of the 
employee's address.

7 CITY nvarchar(50) No The employee city.

8 ZIP nvarchar(15) No The employee ZIP code.

9 STATE nvarchar(50) No The employee state.

10 COUNTRY nvarchar(10) No The employee country code.

11 TEL_NO nvarchar(50) No The employee telephone 
number.

12 TAX_ID1 nvarchar(50) No The employee tax ID 1.

13 TAX_ID2 nvarchar(50) No The employee tax ID 2.

For example, the contents of the employee.csv file may look as follows:
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INDEX_ID, PARTITION_ID, ID, NAME, ADDRESS1, ADDRESS2, CITY, ZIP, STATE, COUNTRY, 
 TEL_NO, TAXID1, TAXID2
0-1,0,1,John Doe,330 Tijeras NW,,Albuquerque,87102,New Mexico,USA,1 505 842 1234,,

Miscellaneous Charge format

Table name: MiscChargesAccount

File name (for Agnostic ERP): misc_charge.csv

Field 
Index

Column Name Type(Max) Mandatory Description

1 POPARTITION int Yes The PO partition.
This value is mandatory.

2 COMPANYCODE varchar(50) Yes The company code.
This value is mandatory.

3 CATEGORY varchar(50) Yes The category of the charge.
This value is mandatory.

4 PLANT varchar(50) No The plant.

5 LINETYPE varchar(10) No The line type.

6 GLACCOUNT varchar(50) No The GL account number.

7 COSTCENTER varchar(50) No The cost center.

8 PROFITCENTER varchar(50) No The profit center.

9 TAXCODE varchar(50) No The tax code.

For example, the contents of the misc_charge.csv file may look as follows:
POPARTITION, COMPANYCODE, CATEGORY, PLANT, LINETYPE, GLACCOUNT, COSTCENTER, 
 PROFITCENTER, TAXCODE
0,123,Good,Plant-SF,POLine,188-662,Irvine,Irvine,1

Tax code format

Table name: TaxCode

File name (for Agnostic ERP): taxcode.csv

Field 
Index

Column Name Type(Max) Mandatory Description

1 PARTITION_ID int Yes Partition ID.
This value is mandatory.

2 VENDOR_ID varchar(50) No Vendor ID.

3 COUNTRY varchar(2) No Two-character country code.
This value is mandatory.

4 SHIP_TO varchar(2) No Two-character code of the 
country where the item was 
shipped to.
This value is mandatory.

39



Kofax AP Agility On-Premise Multi-Tenant Installation Guide

Field 
Index

Column Name Type(Max) Mandatory Description

5 SHIP_FROM varchar(2) No Two-character code of the 
country where the item was 
shipped from.
This value is mandatory.

6 SERVICE varchar(1) No If this is a service. Enter either Y 
or N.

7 MATERIAL_NO varchar(50) No Material number.

8 MATERIAL_GROUP varchar(50) No Material group.

9 PERCENTAGE decimal Yes Tax percentage.
This value is mandatory.

10 TAX_CODE varchar(50) No Tax code.

For example, the contents of the taxcode.csv file may look as follows:
PARTITION_ID, VENDOR_ID, COUNTRY, SHIP_TO, SHIP_FROM, SERVICE, MATERIAL_NO, 
 MATERIAL_GROUP, PERCENTAGE, TAX_CODE
1,1,US,US,US,Y,12345,1,10,2

Unit of Measure Conversion format

Table name: BRWUOMConversions

File name (for Agnostic ERP): uom_conversion.csv

Field 
Index

Column Name Type(Max) Mandatory Description

1 PO_PARTITION int Yes PO partition.
This value is mandatory.

2 MATERIAL_NO varchar(50) Yes Material number.
This value is mandatory.

3 BASE_UOM varchar(50) Yes Base unit of measure.
This value is mandatory.

4 NUMERATOR varchar(50) Yes Numerator for the unit of 
measure.
This value is mandatory.

5 DENOMINATOR varchar(50) Yes Denominator for the unit of 
measure.
This value is mandatory.

6 EXTERNAL_UOM varchar(50) Yes External unit of measure.
This value is mandatory.

For example, the contents of the uom_conversion.csv file may look as follows:
PO_PARTITION,MATERIAL_NO,BASE_UOM,NUMERATOR,DENOMINATOR,EXTERNAL_UOM
0,1,100,5,2,1001
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Cost center segments CSV format

Table name: COST_CENTER_SEGMENTS

File name (for Agnostic ERP): cc_segments.csv

Field 
Index

Column Name Type(Max) Mandatory Description

1 ERP_SEGMENT_ID nvarchar(50) Yes The segment ID number in the 
customer ERP system.
This value is mandatory.

2 ERP_BUSUNESS_UNIT_ID nvarchar(100) No* The Business Unit ID number in 
the customer ERP system.
* This value is optional. 
However, when left empty there 
are no business units.

3 CC_SEGMENT_NUMBER int Yes The order number of the 
segment.
This value is mandatory.

4 CC_SEGMENT_VALUE nvarchar(50) Yes The segment code.
This value is mandatory.

5 CC_SEGMENT_DESCRIPTION nvarchar(255) Yes The segment description.
This value is mandatory.

6 CC_SEGMENT_NAME nvarchar(50) No The Name of the cost center 
segment.

7 PARENT_ERP_SEGMENT_ID nvarchar(50) No A column used for storing 
information about the parent 
segment. This is null for the first 
segment in a structure.

For example, the contents of the COST_CENTER_SEGMENTS.csv file may look as follows:
ERP_SEGMENT_ID,ERP_BUSUNESS_UNIT_ID,CC_SEGMENT_NUMBER,CC_SEGMENT_VALUE, 
 CC_SEGMENT_DESCRIPTION,CC_SEGMENT_NAME,PARENT_ERP_SEGMENT_ID
1001,204,1,000,Organization Desc,Organization
1002,204,2,001,Logstics Desc,Logstics,1001
1003,204,3,002,Energy Desc,Energy,1002
1004,204,3,003,Warehouse Desc,Warehouse,1002
1005,204,2,004,Administration Desc,Administration,1001
1006,204,3,005,Purchase Desc,Purchase,1005
1007,204,3,006,Accounting Desc,Accounting,1005
1008,204,2,007,Production Desc,Production,1001
1009,204,3,008,Production Department Desc,Production Department,1008
1010,204,3,009,Line Department Desc,Line Department,1008

Work breakdown structure segments CSV format

Table name: WBS_SEGMENTS

File name (for Agnostic ERP): WBS_SEGMENTS.csv
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Field 
Index

Column Name Type Mandatory Description

1 ERP_SEGMENT_ID nvarchar(50) Yes The segment ID number in the 
customer ERP system.
This value is mandatory.

2 ERP_BUSUNESS_UNIT_ID nvarchar(100) No* The Business Unit ID number in 
the customer ERP system.
* This value is optional. 
However, when left empty there 
are no business units.

3 WBS_SEGMENT_NUMBER int Yes The order number of the 
segment.
This value is mandatory.

4 WBS_SEGMENT_VALUE nvarchar(50) Yes The value of the work 
breakdown structure.
This value is mandatory.

5 WBS_SEGMENT_DESCRIPTION nvarchar(255) Yes The segment description.
This value is mandatory.

6 WBS_SEGMENT_NAME nvarchar(50) No The Name of the work 
breakdown structure segment.

7 PARENT_ERP_SEGMENT_ID nvarchar(50) No A column used for storing 
information about the parent 
segment. This is null for the first 
segment in a structure.

For example, the contents of the WBS_SEGMENTS.csv file may look as follows:
ERP_SEGMENT_ID, ERP_BUSUNESS_UNIT_ID, WBS_SEGMENT_NUMBER, WBS_SEGMENT_VALUE, 
 WBS_SEGMENT_DESCRIPTION, WBS_SEGMENT_NAME, PARENT_ERP_SEGMENT_ID
2001, 204, 1, 000, Development Desc, Development
2002, 204, 2, 001, Project Management, Project Management, 2001

Configure ERP import job schedule
Since your ERP master data may change regularly it is necessary to set up a regular schedule to 
update to the Kofax AP Agility database. The following tables store the master data in Kofax AP 
Agility.
• ERP invoices: ERP_INVOICE
• Payment terms: PAYMENT_TERM
• Payment terms details: PAYMENT_TERM_DETAIL
• Vendors: VENDOR_MASTER_DATA, BRWVendorMaster
• PO headers: PO_HEADER
• PO lines: PO_LINES
• GL Segments: GL_SEGMENTS
• Plants: PLANTS
• Receipt lines: RECEIPT_LINES
• Tax Codes: TaxCode
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• Miscellaneous Charge: MiscChargesAccount
• Unit of Measure Conversions: BRWUOMConversions
• Employee: BRWEmployeeMaster
• Cost Center Segments: COST_CENTER_SEGMENTS
• Work Breakdown Structures: WBS_SEGMENTS

To configure the optimal schedule, consider the amount of the ERP master data. If you have a large 
amount of the ERP master data and you set the import job schedule to run too often, performance 
issues may occur.

Configure the job schedule that imports the ERP master data to the Kofax AP Agility database by 
following these steps:

1. Launch the TotalAgility Designer.
2. On the menu, select System > Job Schedules.

The Job schedules page is displayed for the Default Category.
3. From the Category list, select AP Agility.

A list of AP Agility job schedules is displayed.
4. Select the AP Data Import job schedule.

The AP Data Import job schedule is displayed.
5. Edit the job schedule as needed.

It is recommended that you configure the import job schedule to run once per day. In case of 
performance issues, ensure that the import occurs when Kofax AP Agility if not heavily used. 
For example, at night.

6. Click New to add a new schedule.
The New job schedule window is displayed.

7. Fill in the new job schedule form to set up the address dump as follows.

a. Enter a Name such as Dump Address Files.

b. Click on the Process list, select the InvoiceProcessingAgility category, and then select 
the DumpAddressFiles job.

c. Specify the other settings as required.
It is recommended that you set up the dump job schedule to run once per day, but after 
the data import process has finished. This is because the results of the data import 
process are required by the dump address process. In case of performance issues, ensure 
that the dump occurs when Kofax AP Agility if not heavily used. For example, at night.

8. Click Save to save the import job schedule.

Localization
Kofax AP Agility supports localized end-user activities in English, French, German, Spanish, and 
Brazilian Portuguese.

However, the translations for the Kofax TotalAgility Global Variables are not installed automatically 
when Kofax AP Agility is installed. Instead, it is necessary to manually install the translations for 
these variables.
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Install translations for global variables
Because translations for the Kofax TotalAgility Global Variables are not installed automatically when 
Kofax AP Agility installed, it is necessary to do this manually.

You can manually install the translations for the Kofax TotalAgility Global Variables needed by Kofax 
AP Agility by following these steps:

1. Launch the TotalAgility Designer.
2. On the menu, select Import.

The Import page is displayed.
3. Click Browse, navigate to your extracted files, and then select /Languages/

KofaxAPAgility-2.8.0_Lang.zip.
The zip file is loaded automatically.

4. Click Import to start the import.
When the languages are imported successfully, a message is displayed.

5. On the menu, select Translation.
The Translation page is displayed.

6. From the Translate list, select Global Variables and then click Translate.
The Translation: Global variables window is displayed with a list of variable values in English 
and the other supported languages.

7. Click Save.
This applies the imported translations to any forms that use one or more of the global 
variables.

8. Optionally, close the TotalAgility Designer.

Configure Invoice Processing
In order to use the Invoice Processing functionality of Kofax AP Agility, the following additional 
configuration steps are required. Each step contains its own set of instructions and the order is 
important. Skipping steps that are not optional, or performing steps out sequence can result in a 
failed installation.

1. Create CSV files for database lookups.

2. Optionally, modify the recognition engines in Transformation Designer.
This step is necessary only if you are processing documents in languages other than English.

3. Prepare ingestion configuration.
• Configure scan ingestion.
• Optionally, configure scan ingestion for MarkView
• Configure filesystem ingestion.
• Configure email ingestion.

4. Configure page Image rendition.

5. Restart the services.
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Dump data to CSV databases
If you are using an ASE database it is necessary to create CSV files. There is a process in Kofax 
TotalAgility that enables you to automatically create CSV files from the BRWVendorMaster,
BRWEmployeeMaster, and the BRWCompanyAddressMaster tables in the AP Agility database. These 
files are then stored in Kofax TotalAgility.

You can create the CSV database needed for the database lookups in Transformation Designer by 
following these steps:

1. Ensure that data is available in the AP Agility database for the BRWVendorMaster,
BRWEmployeeMaster, and the BRWCompanyAddressMaster tables.
If you have no data for these tables at this time, or you do not plan to use all three database 
lookups, you can leave those tables blank. The CSV tables are created using mod data that you 
can update at a later time when it is available.

2. Open the AP Agility Workspace.
3. On the menu, select Jobs  > Create.

The Create Jobs page is displayed.
4. From the Category list, select InvoiceProcessingAgility.

The Process list is populated with processes.
5. From the Process list, select DumpAddressFiles
6. Click Create.

A message is displayed when the job is created successfully and the Vendor.csv, Employee.csv, 
and CompanyCode.csv files are created automatically. These files are stored in Kofax 
TotalAgility and picked up automatically by the corresponding database locators in the 
Transformation Designer.
However, it is still necessary to Release your project in Transformation Designer after you 
create the CSV databases.

7. Optionally, configure the CSV databases to update automatically.

Release project with new database references
When Kofax AP Agility is first installed, three database lookups are created in Transformation 
Designer automatically. Now that you have dumped your address data to CSV files that are stored in 
Kofax TotalAgility, it is necessary to open and then release your project in Transformation Designer 
so that the newly created databases are use.

You can update the project and its databases by following these steps:
1. If not already done, dump your address data.
2. Open the Transformation Designer.
3. From the Project tab, click Open Project.

The Open Project window is displayed.
4. From the Select category group, select the InoviceProcessingAgility category.

The Select project area is updated.
5. In the Select project area, expand Shared, and then double-click on the

InvoiceProcessingAgility project.
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The project is displayed.
6. On the Project tab, click Project Settings.

The Project Settings window is displayed.
7. In the Project Settings window, click on the Databases tab.

The Databases tab is displayed.
8. Select the VendorASE database and click Import.

When prompted to import the database click Yes.
The corresponding CSV file is imported.

9. If you are using the Employee field, select the EmployeeASE database and click Import.
When prompted to import the database click Yes.
The corresponding CSV file is imported.

10. If you are using the Company Code field, select the CompanyCodeASE database and click
Import.
When prompted to import the database click Yes.
The corresponding CSV file is imported.

11. On the Project Settings window, click OK.
Your changes are saved and the window closes.

12. On the Project tab, click Release.
The project is released with the updated databases.

13. Close the Transformation Designer.

Configure CSV databases to update automatically
When you converted the BRWVendorMaster, BRWEmployeeMaster, and the
BRWCompanyAddressMaster database tables into CSV databases, that was a single point-in-time 
representation of that data. Since it is likely that some of those tables are modified regularly with 
additional data over the lifetime of your project, it is necessary to update the CSV files at regular 
intervals.

You can update the CSV databases at regular intervals by following these steps:
1. Launch the TotalAgility Designer.
2. On the menu, select System > Job schedules.

The Job schedules page is displayed for the Default Category.
3. From the Categories list, select InvoiceProcessingAgilty.

A filtered list of scheduled jobs is displayed.
4. Click the AddressData2CSV scheduled job.
5. When prompted, click Yes to lock the scheduled job for modification.

The properties for the job are displayed.
6. Select Active.
7. Edit the Schedule settings so that this job is executed as needed.

For more information on these settings, see the TotalAgility Designer Help.
8. Click Save.

Your changes are saved.
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9. Optionally, Close the TotalAgility Designer.

Modify the Transformation Designer recognition engines
If you are processing documents in languages other than English, it is recommended that you 
update the recognition engines in the Transformation Designer. This ensures that the recognition 
engines are more efficient for your needs than they are by default.

You can modify the recognition engines by following these steps:
1. Open the Transformation Designer.
2. On the Project tab, click Open Project.

The Open Project window is displayed.
3. From the Select category group, select the InoviceProcessingAgility category.

The Select project area is updated.
4. In the Select project area, expand Shared, and then double-click on the

InvoiceProcessingAgility project.
The project is displayed.

5. On the Project tab, click Project Settings.
The Project Settings window is displayed.

6. On the Project Settings window, click the Recognition tab.
A list or recognition engines is displayed.

7. Double-click on the default FineReader recognition engine.
This is the third entry in the list.
The FineReader Profile Settings window is displayed.

8. In the Languages list, select each language that your process.

 For the best results, ensure that Digits and English are selected in addition to any other 
languages selected.

9. Click OK to save your changes.
The FineReader Profile Settings window closes.

10. Click OK to save changes to the project settings.
The Project Settings window closes.

11. On the Project tab, click Release.
The project is released with the updated databases.

12. Close the Transformation Designer.

Prepare ingestion configuration
Before you can configure individual types of ingestion, you first need to create a general import 
connection for Kofax AP Agility Invoice Processing. Once the import connection is available, you can 
add filesystem and email ingestion.
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 If you are using Kofax AP Agility in a multi-tenant environment, use the Kofax TotalAgility 
Integration Server to configure ingestion.

You can add an import connection by following these steps:
1. Launch the TotalAgility Designer.
2. On the menu, select Integration > Import settings.

The Import Settings page is displayed.
3. Click New.

The New import connection page is displayed.
4. For the New import connection setting, enter a Name such as "InvoiceProcessing."
5. Enter a Description for your new connection.
6. Configure the Message Connector URL settings. This is set to http://localhost:25086/ by 

default. This is the most common configuration. by following these steps:
You can confirm the URL on your server

a. On the Windows Start menu, select Start > Kofax > Message Connector > Message 
Connector Monitor.
The Message Connector Web Portal website is displayed.

b. Copy the hostname and port for the Message Connector Web Portal and then paste them 
into the Message Connector URL field back on the Import Connection page.

7. Edit the other settings based on your requirements.
For more information on these settings, see the TotalAgility Designer Help.

8. Click Save.
Your changes are saved and you are returned to the Import settings page where your new 
import connector is listed.

Configure scan ingestion
You can configure scan ingestion by following these steps:

1. Open the AP Agility Workspace.
2. On the menu, select Scan.

The Kofax Web Capture Service Required window is displayed.
3. Install the Kofax Web Capture Service by clicking the click here link in the window.

A progress bar is displayed while the installation occurs.
4. Click OK to close the Kofax Web Capture Service Required window after the installation is 

complete.
5. Optionally, configure the settings to scan documents in languages other than English.
6. Refresh the Scan activity page.

This ensures that the newly installed Web Capture Service is accessible to Scan activity.
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Configure language settings
If your invoices are in a language other than English, you can improve the extraction results by 
selecting the relevant language before scanning your documents. To aid in document recognition, 
these languages are available for selection at the point of scan.

1. AR - Arabic

2. CN - Chinese

3. GR - Greek

4. JP - Japanese

5. KR - Korean

6. RU - Russian

7. TH - Thai

Depending on which of the above language is selected, a dedicated recognition profile is available 
in Transformation Designer. Each of these languages has its own profile that is configured to extract 
documents in the relevant language. Using one of these dedicated recognition profiles ensures 
better extraction results than the default recognition profile. For more information on recognition 
profiles, refer to the Transformation Designer Help.

You can configure scan language settings by following these steps:
1. Open the AP Agility Workspace.
2. On the menu, select Scan
3. On the Scan activity form, select the language from the Language ID list.
4. Refer to the Configure scan ingestion to complete the remaining steps of the ingestion 

process.

Configure scan ingestion for MarkView
If you are using MarkView then it is necessary to perform the following steps in order to update 
the Scan activity navigation to use the correct capture process that is specific to MarkView. This is 
a global change that affects the Scan activity for all organizations. However, the extra Scan activity 
fields are not displayed if an organization uses another ERP system or other databases.

You can configure the Scan activity navigation to include the necessary content for Scan activity by 
following these steps:

1. Launch the TotalAgility Designer.
2. On the menu, select User interface > Navigations.

A list of Navigations is displayed for the default category.
3. From the Category list, select AP Agility.

A list of MarkView is displayed for AP Agility category.
4. Select the AP Agility Menu.

The Edit navigation menu window is displayed for the AP Agility menu.
5. Select the Scan menu item.

The right pane is updated to show the Scan menu settings.
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6. From the Target list, select the InvoiceProcessingAgility category, and select
CaptureDocument_Scan_MV process.

7. Restart the Kofax Core Worker Service.
The Scan activity and its list of invoice types is updated for MarkView.

Configure file system ingestion
You can configure file system ingestion by following these steps:

1. Launch the TotalAgility Designer.
2. On the menu, select Integration > Import settings.

The Import Settings page is displayed.
3. Under Import Connections, click the name that you provided when you created the ingestion 

connection.

The import connection you created earlier is visible but it has no Import sources.
4. Under the Import sources section, click .

The New import source window is displayed.
5. On the New import source window, edit the following settings to configure your input source.

a. In the Type list, select the import source type as FILE.
The available settings are updated so that they match the selected source type.

b. Enter a Display name, such as "IPFileSystemImport."

c. Select Normalize images and create pages.

d. Optionally, after configuring file import, click Test file import.

e. In the Associated action(s) group, ensure that the Job type setting is set to Create new 
job.

f. From the Process setting, click on the list, select the InvoiceProcessingAgility category, 
and then select one of the following, depending on your ERP system:
• If you have one or more organization integrated with MarkView, select the

CaptureDocumentMV process.

 A MarkView cover page must be included for the AP Invoice Follow-Up,
Previously Entered Invoice, and the Supplier Follow-Up invoice types. Without the 
cover page these documents cannot be exported to MarkView.

• If you are using another ERP system, select the CaptureDocument process.

The Initialization variables table is populated with fields related to the selected process.

g. Two fields require mapping only. Select the corresponding values as follows.

Name Mapping

InputSource Input Source Type

FileName File Name
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 You can map additional fields, but if you do, this mapping overrides the mapping 
configured in the Settings > Invoice Processing > Global Settings > Import Settings.

h. Edit the other settings as needed.
For more information on these settings, see the Kofax TotalAgility Help.

i. Click Save.
Your changes are saved, the New import source window is closed, and your new import 
source is displayed on the Update import connection window.

6. Click Save.
Your changes are saved and the Update import connection window is closed.

7. Optionally, close the TotalAgility Designer.

Configure email ingestion
If you plan to process invoices received by one or more email addresses, email ingestion is 
necessary. An email import process is required for each email address that you monitor. This is 
configured in the same location as filesystem ingestion. For more information on ingestion and its 
various settings, refer to the Kofax TotalAgility Help.

You can configure email ingestion by following these steps:
1. Launch the TotalAgility Designer.
2. On the menu, select Integration > Import settings.

The Import Settings page is displayed.
3. Under Import Connections, click the name that you provided when you created the ingestion 

connection.

The import connection you created earlier is visible but it has no Import sources.
4. In the Input sources window, click .

The New import source window is displayed.
5. On the New import source window, edit the following settings to configure your input source.

a. In the Type list, select the import source type as POP3 or IMAP.
The available settings are updated so that they match the selected source type.

b. Enter a Display Name, such as "IPEmailImport."

c. Select Normalize images and create pages.

d. Enter your email service provider into the Host field.

e. Enter a Port.

f. Enter a Username and Password.

g. Test your settings by clicking Test Mailbox.

h. In the Associated action(s) group, ensure that the Job type setting is set to Create new 
job.
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i. Create a job in one of the following two ways:
• To create a single job from one email, regardless of how many attachments, from the

Process setting, click on the list, select the InvoiceProcessingAgility category, and 
then select the CaptureDocument process.

• To create a separate job for each email attachment, a custom process with the
InputSource and ClientID input variables is required. A folder input variable is also 
required.
The folder inside the custom process is where documents for each attachment are 
located. Loop over the folder and move each document to a temporary folder. Then 
use the CreateJob method of the TotalAgility.Sdk.JobService class to initialize a
CaptureDocument job with the two input variables (InputSource and ClientID) 
and the temp folder. After the method is complete remove the document from the 
temporary folder and continue the loop.
Map the Process setting on the New import source window to use the custom process.

The Initialization variables table is populated with fields related to the selected process.

j. Two fields require mapping only. Select the corresponding values as follows.

Name Mapping

InputSource Input Source Type

ClientID You can either hard code a Client ID or you 
can select one of the metadata variables. If 
you do map a variable, you need to modify the
CaptureDocument process so that it can use 
the Metadata value and process it accordingly.

You can map additional fields, but if you do, this mapping overrides the mapping 
configured in the Settings > Invoice Processing > Global Settings > Import Settings.

k. Edit the other settings as needed.
For more information on these settings, see the Kofax TotalAgility Help.

l. Click Save.
Your changes are saved, the New import source window is closed, and your new import 
source is displayed on the Update import connection window.

6. Click Save.
Your changes are saved and the Update import connection window is closed.

7. Optionally, close the TotalAgility Designer.
8. On your mail server, do the following.

a. In the email account specified above, enable POP or IMAP downloads in the account 
settings.

b. Configure the settings to allow Kofax AP Agility to access your email account.
Your settings are now configured to use email ingestion.
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Image rendition
Rendition is used in Invoice Processing stage of Kofax AP Agility to keep a copy of the originally 
ingested document when ImageProcessing activities are performed. For example, copies are kept 
for a PDF, a 200 DPI image, or a color TIFF image.

The ImageProcessing activities in the main process convert all documents to 300 DPI black and 
white TIFF images.

The original document is stored in rendition.

Add image rendition
You need to add image rendition to Kofax AP Agility and provide "Original" as its name.

You can add image rendition by following these steps:
1. Launch the TotalAgility Designer.
2. On the menu, select System  > System settings.

A list of system settings is displayed.
3. In the Capture group, click Page renditions.

The Page renditions window is displayed.
4. If no rendition is available, define one and click Save.

The Page renditions window is closed and you are returned ot the list of System settings.

Restart the services
You need to restart the following services to complete the Kofax AP Agility installation.
• Kofax TotalAgility Core Worker
• Kofax Transformation Server
• World Wide Web Publishing Service

Configure the AP Agility Workflow
After installing Kofax AP Agility, it is necessary to configure the AP Agility Workflow administrative 
resource. Otherwise, it is not possible to administer the AP Agility Workflow aspects of Kofax AP 
Agility.

Configure AP Agility Workflow Administrator access
Before you can start configuring the AP Agility Workflow functionality for Kofax AP Agility it is 
necessary to configure AP Agility Workflow Administrator access in the TotalAgility Designer.

You can configure the AP Agility Workflow Administrator resource access by following these steps:
1. Launch the TotalAgility Designer.
2. On the menu, select Resources > Groups.

53



Kofax AP Agility On-Premise Multi-Tenant Installation Guide

The Resources and groups page is displayed for the Default Category.
3. From the Category list, select the AP Agility category from the menu.

A list of groups related to AP Agility is displayed.
4. Click APA Administrators.

The Edit resource group window is displayed for the selected resource group.
5. To add group members click Add next to the Group members field.

The Add group members window is displayed.
6. In the list of users in the Individual tab, click Administrator to add this to your group.

The selected user is added to the list below.
7. Click Done.

The Add group members window is closed and the Administrator user is added to the APA 
Administrators resource group.

8. In the Edit group resource window, click Save.
The Edit group resource is closed and your changes are saved.

Configure AP_Approvers Permissions
In order for a Approval activity user to have access to the User Settings menu where they configure 
approval email notifications, they must be a member of the AP_Approvers resource group or one 
of its subgroups in Kofax TotalAgility.

You can add a user to
1. Launch the TotalAgility Designer.
2. On the menu, select Resources > Groups.

The Resources and groups page is displayed for the Default Category.
3. From the Category list, select the AP Agility category from the menu.

A list of groups related to AP Agility is displayed.
4. Click AP_Approvers or one of its subgroups, depending on need.

The Edit resource group window is displayed for the selected resource group.
5. To add group members click Add next to the Group members field.

The Add group members window is displayed.
6. In the list of users on the Individual tab, click a user to add it to the selected resource group.

Alternatively, select the Group tab and click a group to add it to the selected resource group.
The selected user or group is added to the list below.

7. Click Done.
The Add group members window is closed and the Administrator user is added to the APA 
Administrators resource group.

8. In the Edit group resource window, click Save.
The Edit group resource is closed and your changes are saved.

9. Optionally, repeat the above steps for other subgroups.
10. Optionally, close the TotalAgility Designer.
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AP Agility workspace
After successfully installing Kofax AP Agility, the Kofax AP Agility workspace is available to the AP 
Agility user. The Kofax AP Agility workspace includes the Kofax AP Agility site and work queue.

Kofax AP Agility site
The SPA package creates the Kofax TotalAgility site called AP Agility with the following settings.

Site Parameter Parameter Value Comment

Category Kofax AP Agility Installed with the Kofax AP Agility 
package

Name Kofax AP Agility The site name in Kofax AP Agility 
URL

Header Form Workspace_Header_2 Installed with the Kofax AP Agility 
package

Horizontal Navigation Kofax AP Agility Menu Installed with the Kofax AP Agility 
package

Vertical Navigation N/A N/A

Default Form TotalAgility Work Queue Standard Kofax TotalAgility form

Theme TotalAgility Workspace Standard Kofax TotalAgility theme

The Kofax AP Agility site URL address must be in the following format, depending on the 
installation:
• On-premise: http(s)://<kta_server>/TotalAgility/forms/APAgility
• Multi-tenant/Azure: https://<kta_server>/forms/APAgility

In both cases, <kta_server> is the Kofax TotalAgility server host name.

Work Queue form
Kofax AP Agility uses the standard Work Queue form to access invoices.
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Upgrade considerations

You can upgrade from an older version of Kofax AP Agility and Kofax Invoice Processing Agility to 
the next released version of Kofax AP Agility, while maintaining the any customizations made. The 
Kofax AP Agility and Kofax Invoice Processing Agility are implemented as sub-processes. These are 
automatically upgraded to the new Kofax AP Agility package that is installed.

 Kofax recommends that you process all outstanding jobs for both the Invoice Processing and 
the AP Agility Workflow functionality of Kofax AP Agility.

If this is not possible for any reason, you can upgrade unprocessed invoices that are already in-
progress.

You must not modify any processes, business rules, or forms, with the exception of the following 
artifacts.
• Classification Group

• InvoiceProcessingAgility

• Document Group
• InvoiceProcessingAgility

• Forms
• CaptureDocument_Scan

• GeneralWorkQueue

• Invoices_Validation

• RescanRejectedDocs_Re Scan_Scan

• XMLDisplay

• IPA_SessionTimeout

• Processes
• CaptureDocument

• ParkNAIDocuments

• PostLinePairing

Transformation Designer project customizations
In most cases, changes to the project in Transformation Designer are required. This is because your 
organization may have specific requirements that are not available in the out-of-the-box solution.
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The following guidelines should be met when customizing your project. These guidelines ensure 
that any customizations are still available in future versions of Kofax AP Agility.

 Keep notes about all changes made to a project. This is so that you can manually redo them 
if necessary, or to confirm if a future upgrade and merge are successful. Also, before an upgrade 
is performed, ensure that you have no unsaved customizations in the Transformation Designer 
project and release the project if necessary.

Save a backup copy of any scripts to a location outside of the Transformation Designer. These are 
needed after an upgrade.

It is important that you do not delete, move, or rename the following.
• Classes.
• Field Groups.
• Fields.
• Locators.

If you delete one of these items and then add it back, the internal ID is no longer the same, so the 
item does not behave as it should.

• All new Classes, Field Groups, Fields, or Locators should have a name that will not conflict with 
future releases of the solution. For example, add the "Custom_" prefix to all new items.

• Do not remove any Databases, Dictionaries, Recognition Profiles, Table Models, or other 
dependent settings.

• You can modify Recognition Profiles by adding an additional language.
• Add script below the marking line that says 'Modify script only below this line. Any 

modifications above this line can cause problems with the package and are not included in a 
future merge.

• In script, refer to lookup fields and other items by their name and not by their index IDs. This is 
because the indexes can change and the names are not likely to change.

Document sets and training sets are included in the merge process. This means that if you have 
documents in either the classification training set or the extraction straining set, make a copy of 
them outside of the training folder to ensure that they are not lost during the merge. You can copy 
them back after the merge.

After the upgrade, merge your old project to the new version.

Customized Workflow processes
Any customized processes are not overwritten during an upgrade. However, variable values 
are overwritten with the default value of False. This means that if you are using any customized 
Workflow processes, it is necessary to go to Kofax AP Agility > Settings > Administration >
Variables and update the values of the processes that you are using back to True, after an upgrade.
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Upgrade Kofax AP Agility in a multi-tenant environment
There are four parts to upgrading Kofax AP Agility in a multi-tenant environment.

1. Review the version of the Kofax TotalAgility Integration Server to see if it compatible with the 
new version of Kofax AP Agility.
If that version is not compatible, it is necessary to upgrade the Integration Server before you 
upgrade Kofax AP Agility.

2. Upgrade the Kofax AP Agility on-premise components.

3. Import upgraded Kofax TotalAgility packages.

4. Run Kofax AP Agility database upgrade job.

Upgrade Kofax AP Agility on-premise components
If you want to upgrade Kofax AP Agility that is used in either a Kofax hosted TotalAgility Azure 
environment or your own multi-tenant TotalAgility environment, it is necessary to run the installer. 
The installer is included in the installation zip file.

You can upgrade the Kofax AP Agility on-premise components by following these steps:
1. Download and extract the appropriate ZIP file for your environment.

For more details on what files are needed for your environment, see Kofax AP Agility on-
premise components.

2. Navigate to the Installer folder.
The contents of the Installer folder are displayed.

3. Right-click on the Kofax AP Agility installer and select Run as Administrator to begin the 
Setup Wizard.
The installer is displayed and calculates if there is enough space on disk for the installation.

4. Once the Install Wizard confirms that there is enough disk space, click Next.
The End-User License Agreement Setup Wizard step is displayed.

5. Select I accept the terms in the License Agreement and then click Next.
The Prerequisites Setup Wizard step is displayed along with any information about missing 
prerequisites.

6. The information displayed on the Prerequisites step is relevant if you are installing the listed 
components only.
For example, if you receive a message that the SAP ECC .NET connector is missing, but you 
are not using SAP ECC, ignore this message. However, if you are using one of the components 
listed, click Cancel and then Finish to exit the Setup Wizard, install the required prerequisite, 
and then restart the installer. Otherwise, click Next.
If you did not install the necessary prerequisites, the corresponding settings are not available 
for installation.
The Choose Setup Type Setup Wizard step is displayed.

7. On the Choose Setup type window, select Custom.
The Custom Setup step is displayed along with a list of available components.
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8. Exclude all components by selecting Entire feature will be unavailable, except the ERP 
Connector Web Service and then click Next.
The Kofax TotalAgility Connection Setup Wizard step is displayed.

9. On the Kofax TotalAgility Connection step, enter the following information.

a. If the default Kofax TotalAgility URL that is provided is not correct, update the TotalAgility 
URL.
This must be the on-premise version that is installed on a local server and not the Azure 
URL.
For example, https://<KTAIntegrationServerName>/TotalAgility/.

b. Select Authentication by username and password.
enter the User name and User password for the Administrator used when installing the 
Kofax TotalAgility Integration Server.

c. Click Test connection to ensure that your information is correct. If not, repeat the 
previous steps and try again.

d. Once your connection test is successful, click Next.
The AP Agility ERP Connector Configuration Setup Wizard step is displayed.

10. On the AP Agility ERP Connector Configuration step, enter the following information.

a. Optionally, enter an alternate Web Site.

 This web site must exist in IIS before it can be added here. All other items are created 
dynamically.

b. Optionally, enter a different Virtual Directory.

c. Optionally, enter a different Application Pool.

d. For Pool Identity, select Custom Account.
The User name and User Password must match the credentials provided when installing 
the Integration Server.

e. Select Update web service URL for the ERP Connector to update the ERP Connector 
Host value, if needed.
If cleared, ERP Connector Host is greyed out and cannot be edited. You can always edit 
this value in the ApAgilityErpConnector properties located in the TotalAgility Designer 
Home menu at Integration > Web Service references at another time.

f. If available, enter a valid ERP Connector Host. This setting is available only if the Update 
web service URL for ERP Connector is selected above.
This is the URL that points to the Web Sever for your ERP Connector, not the entire web 
service URL. By default this is set to https://{ServerName}. This value is then used 
to build the full web service URL for your ERP Connector web service. This value and the 
rest of the web service URL is visible after installation in the ApAgilityErpConnector
properties located in the TotalAgility Designer Home menu at Integration > Web Service 
references.

g. Click Next.
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The Installing Kofax AP Agility 2.8 Setup Wizard step is displayed. A progress bar is displayed 
showing the status of the installation.

11. Click Finish.
Optionally, select the View Installation Log setting. The log file is displayed after the installer 
is closed.
The installer closes and if selected, the log file is displayed.

Upgrade Kofax TotalAgility packages
To continue to upgrade Kofax AP Agility it is necessary to upgrade the Kofax TotalAgility packages.

You can upgrade the Kofax TotalAgility packages by following these steps:
1. Launch the TotalAgility Designer.
2. On the menu, select Import.
3. Click Browse and select the KofaxAPAgility-2.6.0_OPMT\TotalAgility\Packages

\Invoice Capture.zip file.
A list of package artifacts is displayed.

4. For Non-versioned items select Overwrite.
5. Click Import.

When prompted, click Yes to start the import.
A progress bar is displayed and closes when the import is complete. Any errors or warning are 
displayed.

6. Click OK to return to the Import page
7. Browse to the KofaxAPAgility-2.6.0_OPMT\TotalAgility\Packages\AP Workflow.zip

file.
A list of package artifacts is displayed.

8. For Non-versioned items select Overwrite.
9. Click Import.

When prompted, click Yes to start the import.
A progress bar is displayed and closes when the import is complete. Any errors or warning are 
displayed.

10. Click OK.

Upgrade Kofax AP Agility database
To finalize the upgrade of Kofax AP Agility, upgrade the Kofax AP Agility database by following these 
steps:

1. Log on to Kofax AP Agility.
2. On the menu, select Jobs > Create.
3. From the category list select AP Agility.

The list of processes is updated for the AP Agility category.
4. From the Processes list, select AP Database Upgrade.

In the text field provide a database schema name for upgrade. This should be [apa_live]
[apa_dev].
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Click Create to start the job.
The Kofax AP Agility database is updated.

ERP Connectors after upgrade
After an upgrade, if an ERP connection is listed from a previous version and the corresponding ERP 
plugin is not installed in the upgraded system, any attempts to edit that ERP connection result in an 
error.

In addition, the AP Data Import process also logs an error if an ERP plugin is missing. To ensure 
that the ERP Connections page is up-to-date and that there are no errors during the data import 
process, install the required plugin or remove the unused ERP connection.

Merge Transformation Designer project customizations
If you have made changes your Transformation Designer project it is necessary to merge those 
changes after an upgrade.

You can merge your project by by following these steps:
1. Open the Transformation Designer.
2. On the menu, select File > Merge Local Changes from Previous Version.

The Choose Project Version with Desired Local Changes window is displayed.
3. Each time a project is released, a new version number is assigned. From the list of versions, 

select the most recent version and then click OK.
A Data Transfer progress window and then the Comparing Project Version progress window 
indicate the merge process. when they are complete, the Select Items to Merge window is 
displayed.

4. In this window, any differences between the old version and the new version are selected 
automatically.
Review the selections to ensure that only the changes you have made are selected. Do not 
revert any locators, table models, or table header pack. When you are done, click OK.
When the merge is complete, click OK.

5. Optionally, restore any custom scripts.
6. If you have made any of the following changes to your project, these were lost with the merge. 

Redo these changes as appropriate.
• KSMS database configurations
• Searchable columns in ASE databases
• If you have added any custom fields, regenerate and then edit the validation form to include 

the additional custom fields.
7. Release the project.

The merges from the older project are saved and available in the newly released project.
8. Test the released project to ensure that it works as expected.
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Upgrade document variants
After an upgrade is performed it is necessary to update the document variants used in your 
solution. This is done by releasing the InvoiceProcessingAgility extraction group.

You can update the document variants by following these steps:.
1. Launch the TotalAgility Designer.
2. On the menu, select Capture > Extraction groups.

The Extraction groups page is displayed.
3. From the Category list, select InvoiceProcessingAgility.

A list of extraction groups is displayed for the InvoiceProcessingAgility category.
4. Select the InvoiceProcessingAgility extraction group.

The designer is opened so that you can make changes to the InvoiceProcessingAgility
extraction group.

5. Click Release.
When prompted to confirm that you want to re-release this extraction group, click Yes.
The extraction group is released and the document variants are updated successfully.

6. Optionally, close TotalAgility Designer

Update field configurations
After an upgrade it is necessary to update the field configurations for all organizations that use 
work breakdown structures and cost centers when processed by the AP Agility Workflow.

You can update organization field configurations by following these steps:
1. Log on to Kofax AP Agility.
2. On the menu select Settings > Organizations.

A list of organizations is displayed.
3. For each organization in the list that uses work breakdown structures or cost centers in the AP 

Workflow, perform the following:

a. Click on the organization name link.
The organization and its configuration details are displayed.

b. Click on the Field Configuration tab.

c. Click Update at the bottom of the form.
The field configurations for that organization are updated.

d. Repeat for all other organizations that use work breakdown structures and cost centers 
when processed by the AP Agility Workflow.

All organizations are now able to successfully apply both work breakdown structures and cost 
centers during the AP Agility Workflow.
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How to deal with unprocessed invoices
If you have unprocessed invoices in one of the AP Workflow activities, it is ideal to finish processing 
those invoices before upgrading Kofax AP Agility. However, this is not always possible. As a result, 
after you upgrade to the new Kofax AP Agility version, you can update any active jobs by following 
these steps:

1. Log on to Kofax TotalAgility as an Administrator and then navigate to the General Work 
Queue.

2. On the menu, select Administration > Job Upgrader
The Job Upgrader page is displayed.

3. From the Category list, select AP Agility.
The process list is updated for processes specific to Kofax AP Agility.

4. From the Process list, select Main AP Workflow.
5. Click Start.

The upgrade job is scheduled.
6. On the menu, select Jobs > Find.

A list of jobs on Kofax AP Agility is displayed.
7. Ensure that the version listed for the activities is the maximum version for Kofax AP Agility.
8. On the menu, select Jobs > Create.

The Create Jobs page is displayed.
9. From the Category list, select AP Agility.

The process list is updated for processes specific to Kofax AP Agility.
10. From the Process list, select AP Restart Job and then click Create.

The AP Restart Job process is run and all processes are upgraded to the new Kofax AP Agility 
version.

MarkView upgrade requirements
If you are using MarkView, then specific requirements were overwritten during the upgrade. As a 
result, it is necessary to perform these tasks after the upgrade.

In order to use MarkView document types, it is necessary to update the Scan form. See MarkView 
and the Scan form for information on how to configure the Scan form for MarkView.

If you have the Kofax TotalAgility Integration Server installed and use file system ingestion for 
MarkView, it is necessary to update the ingestion settings. See Configure MarkView file ingestion for 
information on how to configure file system ingestion for MarkView. Otherwise, skip the integration 
update.
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 If you are upgrading and have one or more organizations using the MarkView template then 
there is a change related to company partition support that you need to know.
• If an organization created in Kofax AP Agility 2.6.0 uses the MarkView template then Kofax AP 

Agility automatically uses the MV_COMPANYDATA database table, meaning that partitions are 
supported.

• If an organization created in an earlier version of Kofax AP Agility uses the MarkView template, 
Kofax AP Agilitycontinues to use the old MV_COMPANY database table that does not have 
partition support.
If you require partition support, update the database mappings for the MarkView organizations 
manually and then run the AP Data Import process.
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Remove Kofax AP Agility

If you no longer want Kofax AP Agility on your server, you can remove several components from 
your server using the installer via Windows Programs and Features.

Specifically, the following component is removed.
• Agnostic ERP Web Service

 Although it is also possible to remove Kofax AP Agility using Windows Programs and Features, 
Kofax recommends that you use the Kofax AP Agility installer instead.

You can remove several Kofax AP Agility components by following these steps:
1. Open Windows Programs and Features.

A list of installed programs is displayed.
2. Select Kofax AP Agility 2.8.0 from the list.

The list of available buttons changes at the top of the program list.
3. Click Uninstall.

A message is displayed for you to confirm the removal of Kofax AP Agility 2.8.0.
4. Click Yes.

Kofax AP Agility 2.8.0 is uninstalled and removed from the list of installed programs.
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Access Kofax AP Agility documentation

By default, the Kofax AP Agility documentation is available online. However, if necessary, you can 
also configure Kofax AP Agility to use help offline.

Default online documentation
The product documentation for Kofax AP Agility 2.8.0 is available at the following location.

https://docshield.kofax.com/Portal/Products/APAgility/2.7.0-79qrk2m1wh/APAgility.htm

To launch the online help for the Kofax AP Agility site, select the required help from the Help menu 
or click on the Help button within the AP Agility Workflow.

Configure offline documentation
To access the documentation offline, download KofaxAPAgilityDocumentation-2.5.0_EN.zip from the
Kofax Fulfillment Site and extract it on a local drive available to your users.

This compressed file includes both help and print folders. The print folder contains all guides, 
such as the Kofax AP Agility Installation Guide and the Analytics for Kofax AP Agility Administrator's 
Guide.

The compressed file for all other languages contains the help folder only. For more information on 
other languages, refer to the Localized offline help

You can configure Kofax AP Agility to use offline help by following these steps:
1. Extract the contents of the compressed documentation file, 

KofaxAPAgilityDocumentation-2.5.0_EN.zip.
2. Navigate to where Kofax TotalAgility is installed.

By default, this is <Program Files>\Kofax\TotalAgility.
3. In the Agility.Server.Web\Help\ folder, create a folder called en_US.

If you are using other languages, refer to the
4. Copy the help from the extracted EN zip file into the en_US folder.
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 This location is suggested because it is available and already used for Kofax TotalAgility 
offline documentation. However, for Kofax AP Agility, it is possible to use any path for 
the help, as long as it is on a web server available through http. Modify the paths below 
accordingly.

5. To configure the user help, open Kofax AP Agility with Administrative permissions.
6. On the menu, select Settings > Administration.

The Administration page is displayed.
7. Locate the Help Base URL and make a note of its contents so that you can revert back to the 

online help at any point in the future.
8. In the Help Base URL field, enter the following URL.

http://<Server>/TotalAgility/Help/.
Where <Server> is host name or IP address of the Kofax TotalAgility server.

9. Click Save Help Settings.
A message is displayed to indicate that your changes are saved successfully.

10. To test your changes, select any of Help menu settings.
The help is displayed from the file-based location. If you selected to open the Configuration 
help, the path should be similar to the following path.
http://<localhost>/TotalAgility/Help/en_US/CFG/
APAgility_Configuration_help/c_welcome.html.
If the help is not displayed, review your changes and try again.

Localized offline help
Localized help is available in German, Spanish, Brazilian Portuguese, and French for the following 
activities. The language is indicated in the documentation zip file.

The following four activities are included in the localized help.

1. The Invoice Processing Scan activity

2. The Invoice Processing Validation activity

3. The Invoice Processing Line Pairing Correction activity

4. The AP Agility help, that consists of the following activities in a single help system.
• The AP Agility Workflow Coding activity.
• The AP Agility Workflow Approval activity.
• The AP Agility Workflow Hold activity.
• The AP Agility Workflow Comment Request activity.
• The AP Agility Workflow Exception activity.
• The AP Agility Workflow Line Pairing Exception activity.

For languages other than English, the zip file contains the help folder only. the print folder is 
available for English only. Also, not all help is localized. Administrative help such as the Kofax AP 
Agility Configuration Help and the Kofax AP Agility PIX Correction activity Help are available in English 
only.
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An example of the folder hierarchy needed to support multiple languages is as follows.

Copy the required hierarchy using the above hierarchy as a reference. The country codes needed for 
the supported languages are as follows.
• German - de_DE
• Spanish - es_ES
• French - fr_FR
• Portuguese (Brazilian) - pt_BR
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