%%phrase%%

Kofax Capture Export Type Library

Project Overview

Description

Kofax Capture Export Type Library

Classes

Class Module | Description
BatchField | The BatchField object represents an individual batch field in the BatchFields collection of a ReleaseSetupData object.
BatchFields | The BatchFields collection is a collection of BatchField objects for a ReleaseSetupData object.
CustomProperties | The CustomProperties collection is a collection of CustomProperty objects for a ReleaseSetupData object or ReleaseData object. Use this collection to store any named values needed by the export process. The collection is read-only to the export connector.
CustomProperty | CustomProperty represents a custom property in the CustomProperties collection of a ReleaseSetupData or ReleaseData object. Use the ReleaseSetupScript Add method to add a property to the CustomProperties collection.
ImageFile | ImageFile represents a single image (page) of a document in the ImageFiles collection. ImageFile contains the method for copying an image to the export directory. The Export module initializes the ImageFiles collection with data before calling ReleaseDoc.
ImageFiles | ImageFiles is a collection of ImageFile objects for ReleaseData. It contains all the image files associated with a document. An export connector can process the collection of ImageFile objects individually or process all the objects at the collection level.
IndexField | The IndexField object represents an individual index field in the IndexFields collection of a ReleaseSetupData object.
IndexFields | The IndexFields collection is a collection of IndexField objects for a ReleaseSetupData object.
KfxPDFFile | KfxPDFFile represents a file containing a PDF file result in the KfxPDFFiles collection of ReleaseData. KfxPDFFile contains methods to copy the file to the export directory. The Export module initializes the collection with data before calling ReleaseDoc.
KfxPDFFiles | KfxPDFFiles is a collection of KfxPDFFile objects for a ReleaseData object. It contains the PDF files associated with a document. An export connector can process the collection of KfxPDFFile objects individually or process the objects at the collection level.
Link | Link represents a field mapping in the Links collection of a ReleaseSetupData object. The mapping identifies the data field (source) and the destination column or field in the external data repository. Use the Add method to add a link to the Links collection.
Links | Links is a collection of Link objects for a ReleaseSetupData object. This collection identifies all the document index data fields (index fields, batch fields, text constants, and Kofax Capture Values) for which data is saved in an external data repository.
ReleaseData | ReleaseData is used by the Export module and export connector to access the batch and document class information, and to perform a document export. The ReleaseDoc method reads the properties and saves the index data to an external data repository.
ReleaseSetupData | ReleaseSetupData is used by the Administration module and export connector setup to define a document class export process. The ReleaseSetupData properties provide configuration information such as target export folders and external data repository.
RelInfoData | RelInfoData Class
RowValues | RowValues specifies the row values for a table field.
TableRows | TableRows specifies the table rows for a particular table.
TableRowValues | TableRowValues specifies the table rows for a particular table.
Tables | Tables specifies the tables of a particular document.
TextFile | TextFile represents a file containing a full-text OCR result in the TextFiles collection of ReleaseData. TextFile contains methods to copy the file to the export directory. The Export module initializes the collection with data before calling ReleaseDoc.
TextFiles | TextFiles is a collection of TextFile objects for a ReleaseData object. It contains all the text files associated with a document. An export connector can process the collection of TextFile objects individually or process all the objects at the collection leve?ｺ??'
Value | Value represents an individual data point in the Values collection of a ReleaseData object. Value identifies the data field (source) and the destination column or field in the external data repository.
Values | Values is a collection of Value objects for a ReleaseData object. This collection includes all the data that can be saved for the document. It contains the actual values for the field mappings established by the ReleaseSetupScript using the Links collection.

Public Enumerations

Enumeration | Description
KfxActionValue |
KfxIndexFieldType |
KfxInfoReturnValue |
KfxLinkSourceType |
KfxReturnValue |
KfxStorageType |
KfxTextFileType |

© 1994-2015 Kofax. All rights reserved. U.S. Patent No. 6,370,277. Use is subject to license terms.


%%PageItemTitle%%

See Also

BatchField Members

See Also Kofax Capture Export Type Library

BatchField Object

Description

The BatchField object represents an individual batch field in the BatchFields collection of a ReleaseSetupData object.

For a list of all members defined in this module, see BatchField members.

See Also

BatchField Members


%%PageItemTitle%% $$Members$$

BatchField Overview

BatchField Object Members

Public Properties

Public Property Name | Returns a string that uniquely identifies a member of the BatchFields collection. This string can be used as the Key to retrieve an individual member from the BatchFields collection.
Public Property Type | Returns a KfxIndexFieldType value that indicates the data type of the batch field.

See Also

BatchField Overview


%%PageItemTitle%%

BatchField Object

Name Property

Description

Returns a string that uniquely identifies a member of the BatchFields collection. This string can be used as the Key to retrieve an individual member from the BatchFields collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

BatchField Object


%%PageItemTitle%%

BatchField Object

Type Property

Description

Returns a KfxIndexFieldType value that indicates the data type of the batch field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As KfxIndexFieldType

See Also

BatchField Object


%%PageItemTitle%%

BatchFields Members

BatchFields Collection

Description

The BatchFields collection is a collection of BatchField objects for a ReleaseSetupData object.

For a list of all members defined in this module, see BatchFields members.

Object Model

See Also

BatchFields Members


%%PageItemTitle%% $$Members$$

BatchFields Overview

BatchFields Collection Members

Public Properties

Public Property Count | Returns a long integer indicating the number of BatchField objects in the BatchFields collection.
Public Property Item | Returns the BatchField specified by the Key. The Key as a string contains the Name property of the BatchField object, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default for the collection.

See Also

BatchFields Overview


%%PageItemTitle%%

BatchFields Collection

Count Property

Description

Returns a long integer indicating the number of BatchField objects in the BatchFields collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

BatchFields Collection


%%PageItemTitle%%

BatchFields Collection

Key
See Also Kofax Capture Export Type Library

Item Property

Description

Returns the BatchField specified by the Key. The Key as a string contains the Name property of the BatchField object, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default for the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByRef Key As Variant _
) As BatchField

Parameters

Key

See Also

BatchFields Collection


%%PageItemTitle%%

CustomProperties Members

CustomProperties Collection

Description

The CustomProperties collection is a collection of CustomProperty objects for a ReleaseSetupData object or ReleaseData object. Use this collection to store any named values needed by the export process. The collection is read-only to the export connector.

For a list of all members defined in this module, see CustomProperties members.

Object Model

Interfaces

Implemented Interface | Description
ICustomProperties2 |

See Also

CustomProperties Members


%%PageItemTitle%% $$Members$$

CustomProperties Overview

CustomProperties Collection Members

Public Methods

Public Method Add | Adds a new CustomProperty object to the CustomProperties collection. Name uniquely identifies CustomProperty. The CustomProperty value must be stored as a string in the collection. If the value is of another data type, it must be converted to a string.
Public Method Remove | Removes the CustomProperty object specified by the Key from the CustomProperties collection. The varIndex parameter as a string contains the Name property of CustomProperty, or as a long integer indicates the member痴 ordinal position within the collection.
Public Method RemoveAll | Removes all CustomProperty objects from the CustomProperties collection.

Public Properties

Public Property Count | Returns a long integer indicating the number of CustomProperty objects in the Custom Properties collection.
Public Property Item | Returns the CustomProperty specified by the Key. The Key as a string contains the Name property of CustomProperty, or as a long integer indicates the member痴 ordinal position within the collection. Item is the default property for the collection.

See Also

CustomProperties Overview


%%PageItemTitle%%

CustomProperties Collection

Name
Value
See Also Kofax Capture Export Type Library

Add Method

Description

Adds a new CustomProperty object to the CustomProperties collection. Name uniquely identifies CustomProperty. The CustomProperty value must be stored as a string in the collection. If the value is of another data type, it must be converted to a string.

Syntax

Public Sub Add( _
   ByVal Name As String, _
   ByVal Value As String _
)

Parameters

Name
Value

See Also

CustomProperties Collection


%%PageItemTitle%%

CustomProperties Collection

Key
See Also Kofax Capture Export Type Library

Remove Method

Description

Removes the CustomProperty object specified by the Key from the CustomProperties collection. The varIndex parameter as a string contains the Name property of CustomProperty, or as a long integer indicates the member痴 ordinal position within the collection.

Syntax

Public Sub Remove( _
   ByRef Key As Variant _
)

Parameters

Key

See Also

CustomProperties Collection


%%PageItemTitle%%

CustomProperties Collection

RemoveAll Method

Description

Removes all CustomProperty objects from the CustomProperties collection.

Syntax

Public Sub RemoveAll()

See Also

CustomProperties Collection


%%PageItemTitle%%

CustomProperties Collection

Count Property

Description

Returns a long integer indicating the number of CustomProperty objects in the Custom Properties collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

CustomProperties Collection


%%PageItemTitle%%

CustomProperties Collection

Key
See Also Kofax Capture Export Type Library

Item Property

Description

Returns the CustomProperty specified by the Key. The Key as a string contains the Name property of CustomProperty, or as a long integer indicates the member痴 ordinal position within the collection. Item is the default property for the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByRef Key As Variant _
) As CustomProperty

Parameters

Key

See Also

CustomProperties Collection


%%PageItemTitle%% $$Members$$

CustomProperties Collection

ICustomProperties2 Implemented Interface Members

Methods

Public Implemented Method Add | Adds a new CustomProperty object to the CustomProperties collection. Name uniquely identifies CustomProperty. The CustomProperty value must be stored as a string in the collection. If the value is of another data type, it must be converted to a string.
Public Implemented Method Remove | Removes the CustomProperty object specified by the Key from the CustomProperties collection. The varIndex parameter as a string contains the Name property of CustomProperty, or as a long integer indicates the member痴 ordinal position within the collection.
Public Implemented Method RemoveAll | Removes all CustomProperty objects from the CustomProperties collection.
Public Implemented Method TryGetValue | Gets the value associated with the specified key returning true or false depending on whether or not the item is found

Properties

Public Implemented Property Count | Returns a long integer indicating the number of CustomProperty objects in the Custom Properties collection.
Public Implemented Property Item | Returns the CustomProperty specified by the Key. The Key as a string contains the Name property of CustomProperty, or as a long integer indicates the member痴 ordinal position within the collection. Item is the default property for the collection.

See Also

CustomProperties Collection


%%PageItemTitle%%

CustomProperties Collection | ICustomProperties2 Implemented Interface

Name
Value
See Also Kofax Capture Export Type Library

Add Implemented Method

Description

Adds a new CustomProperty object to the CustomProperties collection. Name uniquely identifies CustomProperty. The CustomProperty value must be stored as a string in the collection. If the value is of another data type, it must be converted to a string.

Syntax

Public Sub Add( _
   ByVal Name As String, _
   ByVal Value As String _
)

Parameters

Name
Value

See Also

CustomProperties Collection | ICustomProperties2 Implemented Interface


%%PageItemTitle%%

CustomProperties Collection | ICustomProperties2 Implemented Interface

Key
See Also Kofax Capture Export Type Library

Remove Implemented Method

Description

Removes the CustomProperty object specified by the Key from the CustomProperties collection. The varIndex parameter as a string contains the Name property of CustomProperty, or as a long integer indicates the member痴 ordinal position within the collection.

Syntax

Public Sub Remove( _
   ByRef Key As Variant _
)

Parameters

Key

See Also

CustomProperties Collection | ICustomProperties2 Implemented Interface


%%PageItemTitle%%

CustomProperties Collection | ICustomProperties2 Implemented Interface

See Also Kofax Capture Export Type Library

RemoveAll Implemented Method

Description

Removes all CustomProperty objects from the CustomProperties collection.

Syntax

Public Sub RemoveAll()

See Also

CustomProperties Collection | ICustomProperties2 Implemented Interface


%%PageItemTitle%%

CustomProperties Collection | ICustomProperties2 Implemented Interface

Key
See Also Kofax Capture Export Type Library

TryGetValue Implemented Method

Description

Gets the value associated with the specified key returning true or false depending on whether or not the item is found

Syntax

Public Function TryGetValue( _
   ByVal Key As Variant _
) As CustomProperty

Parameters

Key

See Also

CustomProperties Collection | ICustomProperties2 Implemented Interface


%%PageItemTitle%%

CustomProperties Collection | ICustomProperties2 Implemented Interface

See Also Kofax Capture Export Type Library

Count Implemented Property

Description

Returns a long integer indicating the number of CustomProperty objects in the Custom Properties collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ICustomProperties2_Count() As Long

See Also

CustomProperties Collection | ICustomProperties2 Implemented Interface


%%PageItemTitle%%

CustomProperties Collection | ICustomProperties2 Implemented Interface

Key
See Also Kofax Capture Export Type Library

Item Implemented Property

Description

Returns the CustomProperty specified by the Key. The Key as a string contains the Name property of CustomProperty, or as a long integer indicates the member痴 ordinal position within the collection. Item is the default property for the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ICustomProperties2_Item( _
   ByRef Key As Variant _
) As CustomProperty

Parameters

Key

See Also

CustomProperties Collection | ICustomProperties2 Implemented Interface


%%PageItemTitle%%

CustomProperty Members

CustomProperty Object

Description

CustomProperty represents a custom property in the CustomProperties collection of a ReleaseSetupData or ReleaseData object. Use the ReleaseSetupScript Add method to add a property to the CustomProperties collection.

For a list of all members defined in this module, see CustomProperty members.

See Also

CustomProperty Members


%%PageItemTitle%% $$Members$$

CustomProperty Overview

CustomProperty Object Members

Public Properties

Public Property Name | Returns a string that uniquely identifies a member of the CustomProperties collection. This string can be used as the Key to retrieve an individual member from the collection.
Public Property Value | Sets or returns a string that represents the value of the CustomProperty object. You may need to convert the string to a different data type to use the value. This property can be up to 65,536 characters.

See Also

CustomProperty Overview


%%PageItemTitle%%

CustomProperty Object

Name Property

Description

Returns a string that uniquely identifies a member of the CustomProperties collection. This string can be used as the Key to retrieve an individual member from the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

CustomProperty Object


%%PageItemTitle%%

CustomProperty Object

Value Property

Description

Sets or returns a string that represents the value of the CustomProperty object. You may need to convert the string to a different data type to use the value. This property can be up to 65,536 characters.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

CustomProperty Object


%%PageItemTitle%%

ImageFile Members

ImageFile Object

Description

ImageFile represents a single image (page) of a document in the ImageFiles collection. ImageFile contains the method for copying an image to the export directory. The Export module initializes the ImageFiles collection with data before calling ReleaseDoc.

For a list of all members defined in this module, see ImageFile members.

See Also

ImageFile Members


%%PageItemTitle%% $$Members$$

ImageFile Overview

ImageFile Object Members

Public Methods

Public Method Copy | Copies the image file from the Capture image folder to the ReleaseData.ImageFilePath property. The export directory may be specified as a parameter to this method. Duplicate file names are overwritten. The ReleaseData.UseOriginalFileNames property is obeyed.
Public Method Delete | Deletes the image file that was copied to the export directory. The optional parameter bstrDir specifies the export directory for the image file. If Directory is omitted, the image file is deleted from the directory specified by ReleaseData.ImageFilePath.

Public Properties

Public Property CopiedFileName | This string is the full path name of the final destination file after calling the Copy method on the collection or on this object.
Public Property FileName | Returns a string that specifies the file name of the image file. This string uniquely identifies the image in the ImageFiles collection. This string can be used as the Key to retrieve an individual member from the collection.
Public Property ImageType | Returns a long integer that identifies the image format of the file.
Public Property NonImageFileExtension | Holds the extension of a non-image file and exposes it to the user. For regular image files, this property returns an empty string.
Public Property RawOriginalFileName | This string is the raw, original file name. This file name does not include the path or extension.

See Also

ImageFile Overview


%%PageItemTitle%%

ImageFile Object

Directory
See Also Kofax Capture Export Type Library

Copy Method

Description

Copies the image file from the Capture image folder to the ReleaseData.ImageFilePath property. The export directory may be specified as a parameter to this method. Duplicate file names are overwritten. The ReleaseData.UseOriginalFileNames property is obeyed.

Syntax

Public Sub Copy( _
   Optional ByVal Directory As String = "" _
)

Parameters

Directory

See Also

ImageFile Object


%%PageItemTitle%%

ImageFile Object

Directory
See Also Kofax Capture Export Type Library

Delete Method

Description

Deletes the image file that was copied to the export directory. The optional parameter bstrDir specifies the export directory for the image file. If Directory is omitted, the image file is deleted from the directory specified by ReleaseData.ImageFilePath.

Syntax

Public Sub Delete( _
   Optional ByVal Directory As String = "" _
)

Parameters

Directory

See Also

ImageFile Object


%%PageItemTitle%%

ImageFile Object

CopiedFileName Property

Description

This string is the full path name of the final destination file after calling the Copy method on the collection or on this object.

Property type

Read-write property

Syntax (Visual Basic)

Public Property CopiedFileName() As String

See Also

ImageFile Object


%%PageItemTitle%%

ImageFile Object

FileName Property

Description

Returns a string that specifies the file name of the image file. This string uniquely identifies the image in the ImageFiles collection. This string can be used as the Key to retrieve an individual member from the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FileName() As String

See Also

ImageFile Object


%%PageItemTitle%%

ImageFile Object

ImageType Property

Description

Returns a long integer that identifies the image format of the file.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ImageType() As Long

See Also

ImageFile Object


%%PageItemTitle%%

ImageFile Object

NonImageFileExtension Property

Description

Holds the extension of a non-image file and exposes it to the user. For regular image files, this property returns an empty string.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NonImageFileExtension() As String

See Also

ImageFile Object


%%PageItemTitle%%

ImageFile Object

RawOriginalFileName Property

Description

This string is the raw, original file name. This file name does not include the path or extension.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RawOriginalFileName() As String

See Also

ImageFile Object


%%PageItemTitle%%

ImageFiles Members

ImageFiles Collection

Description

ImageFiles is a collection of ImageFile objects for ReleaseData. It contains all the image files associated with a document. An export connector can process the collection of ImageFile objects individually or process all the objects at the collection level.

For a list of all members defined in this module, see ImageFiles members.

Object Model

See Also

ImageFiles Members


%%PageItemTitle%% $$Members$$

ImageFiles Overview

ImageFiles Collection Members

Public Methods

Public Method Copy | Copies the images to the destination location. If ReleaseData.UseOriginalFileNames is set, then files are named based on their original file names. If a duplicate file name is used, then an error occurs and some image files in the document may not be copied.
Public Method Delete | Deletes the image files that were copied to the export directory. The optional parameter bstrDir specifies the export directory for image files. If Directory is omitted, the image files are deleted from the directory specified by ReleaseData.ImageFilePath.

Public Properties

Public Property ContainsNonImageFile | A read-only boolean property that is set to true if the document contains one or more non-image files (eDocuments). If the document contains only regular image files, this property returns false.
Public Property Count | Returns a long integer indicating the number of ImageFile objects in the ImageFiles collection.
Public Property Item | Returns the ImageFile specified by the Key. The Key as a string contains the FileName property of ImageFile, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.
Public Property NonImageFilesReleasedDirectory | Returns a string that identifies the copied location of the non-image files in the document. If the document contains only image files, this property returns and empty string.
Public Property ReleasedDirectory | Returns a string that identifies the full path of the directory for exporting the image files associated with a document. If the image files are exported as a set of single-page images, the ReleaseDirectory path includes the subdirectory for the images files.
Public Property ReleasedToDirectory | Returns a long integer (Boolean) that indicates whether the image files associated with a document are exported as a set of single-page images to a subdirectory (True) or as a multi-page image file to the specified export directory (False).

See Also

ImageFiles Overview


%%PageItemTitle%%

ImageFiles Collection

Directory
ImageType
See Also Kofax Capture Export Type Library

Copy Method

Description

Copies the images to the destination location. If ReleaseData.UseOriginalFileNames is set, then files are named based on their original file names. If a duplicate file name is used, then an error occurs and some image files in the document may not be copied.

Syntax

Public Sub Copy( _
   Optional ByVal Directory As String = "", _
   Optional ByVal ImageType As Long = -1 _
)

Parameters

Directory
ImageType

See Also

ImageFiles Collection


%%PageItemTitle%%

ImageFiles Collection

Directory
See Also Kofax Capture Export Type Library

Delete Method

Description

Deletes the image files that were copied to the export directory. The optional parameter bstrDir specifies the export directory for image files. If Directory is omitted, the image files are deleted from the directory specified by ReleaseData.ImageFilePath.

Syntax

Public Sub Delete( _
   Optional ByVal Directory As String = "" _
)

Parameters

Directory

See Also

ImageFiles Collection


%%PageItemTitle%%

ImageFiles Collection

ContainsNonImageFile Property

Description

A read-only boolean property that is set to true if the document contains one or more non-image files (eDocuments). If the document contains only regular image files, this property returns false.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ContainsNonImageFile() As Long

See Also

ImageFiles Collection


%%PageItemTitle%%

ImageFiles Collection

Count Property

Description

Returns a long integer indicating the number of ImageFile objects in the ImageFiles collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ImageFiles Collection


%%PageItemTitle%%

ImageFiles Collection

Key
See Also Kofax Capture Export Type Library

Item Property

Description

Returns the ImageFile specified by the Key. The Key as a string contains the FileName property of ImageFile, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByRef Key As Variant _
) As ImageFile

Parameters

Key

See Also

ImageFiles Collection


%%PageItemTitle%%

ImageFiles Collection

NonImageFilesReleasedDirectory Property

Description

Returns a string that identifies the copied location of the non-image files in the document. If the document contains only image files, this property returns and empty string.

Property type

Read-only property

Syntax (Visual Basic)

Public Property NonImageFilesReleasedDirectory() As String

See Also

ImageFiles Collection


%%PageItemTitle%%

ImageFiles Collection

ReleasedDirectory Property

Description

Returns a string that identifies the full path of the directory for exporting the image files associated with a document. If the image files are exported as a set of single-page images, the ReleaseDirectory path includes the subdirectory for the images files.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReleasedDirectory() As String

See Also

ImageFiles Collection


%%PageItemTitle%%

ImageFiles Collection

ReleasedToDirectory Property

Description

Returns a long integer (Boolean) that indicates whether the image files associated with a document are exported as a set of single-page images to a subdirectory (True) or as a multi-page image file to the specified export directory (False).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReleasedToDirectory() As Long

See Also

ImageFiles Collection


%%PageItemTitle%%

IndexField Members

IndexField Object

Description

The IndexField object represents an individual index field in the IndexFields collection of a ReleaseSetupData object.

For a list of all members defined in this module, see IndexField members.

See Also

IndexField Members


%%PageItemTitle%% $$Members$$

IndexField Overview

IndexField Object Members

Public Properties

Public Property FieldTypeDescription | Returns a string that uniquely identifies the field type definition.
Public Property FieldTypeName | Returns a string that uniquely identifies the field type definition.
Public Property FolderClassName | A string that identifies the folder class name. An empty string is returned if this is not a folder index field. For example, the folder class name Customer Information is returned for the Name property, [Customer Information].Customer Name.
Public Property FolderIndexFieldName | A string that identifies the folder index field name. An empty string is returned if this is not a folder index field. For example, the folder index field name Customer Name is returned for the Name property, [Customer Information].Customer Name.
Public Property Name | Returns a string that uniquely identifies a document index field in the IndexFields collection. The following is an example string that identifies a document index field name from the collection: [Customer Information].Customer Name.
Public Property TableName | The name of the associated table. An empty string is a single-value field.
Public Property Type | Returns a KfxIndexFieldType value that indicates the data type of the document index field or folder index field.

See Also

IndexField Overview


%%PageItemTitle%%

IndexField Object

FieldTypeDescription Property

Description

Returns a string that uniquely identifies the field type definition.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FieldTypeDescription() As String

See Also

IndexField Object


%%PageItemTitle%%

IndexField Object

FieldTypeName Property

Description

Returns a string that uniquely identifies the field type definition.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FieldTypeName() As String

See Also

IndexField Object


%%PageItemTitle%%

IndexField Object

FolderClassName Property

Description

A string that identifies the folder class name. An empty string is returned if this is not a folder index field. For example, the folder class name Customer Information is returned for the Name property, [Customer Information].Customer Name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FolderClassName() As String

See Also

IndexField Object


%%PageItemTitle%%

IndexField Object

FolderIndexFieldName Property

Description

A string that identifies the folder index field name. An empty string is returned if this is not a folder index field. For example, the folder index field name Customer Name is returned for the Name property, [Customer Information].Customer Name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FolderIndexFieldName() As String

See Also

IndexField Object


%%PageItemTitle%%

IndexField Object

Name Property

Description

Returns a string that uniquely identifies a document index field in the IndexFields collection. The following is an example string that identifies a document index field name from the collection: [Customer Information].Customer Name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

IndexField Object


%%PageItemTitle%%

IndexField Object

TableName Property

Description

The name of the associated table. An empty string is a single-value field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TableName() As String

See Also

IndexField Object


%%PageItemTitle%%

IndexField Object

Type Property

Description

Returns a KfxIndexFieldType value that indicates the data type of the document index field or folder index field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Type() As KfxIndexFieldType

See Also

IndexField Object


%%PageItemTitle%%

IndexFields Members

IndexFields Collection

Description

The IndexFields collection is a collection of IndexField objects for a ReleaseSetupData object.

For a list of all members defined in this module, see IndexFields members.

Object Model

See Also

IndexFields Members


%%PageItemTitle%% $$Members$$

IndexFields Overview

IndexFields Collection Members

Public Properties

Public Property Count | Returns a long integer indicating the number of IndexField objects in the IndexFields collection.
Public Property Item | Returns the IndexField specified by the Key. The Key as a string contains the Name property of the IndexField, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

See Also

IndexFields Overview


%%PageItemTitle%%

IndexFields Collection

Count Property

Description

Returns a long integer indicating the number of IndexField objects in the IndexFields collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

IndexFields Collection


%%PageItemTitle%%

IndexFields Collection

Key
See Also Kofax Capture Export Type Library

Item Property

Description

Returns the IndexField specified by the Key. The Key as a string contains the Name property of the IndexField, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByRef Key As Variant _
) As IndexField

Parameters

Key

See Also

IndexFields Collection


%%PageItemTitle%%

KfxPDFFile Members

KfxPDFFile Object

Description

KfxPDFFile represents a file containing a PDF file result in the KfxPDFFiles collection of ReleaseData. KfxPDFFile contains methods to copy the file to the export directory. The Export module initializes the collection with data before calling ReleaseDoc.

For a list of all members defined in this module, see KfxPDFFile members.

See Also

KfxPDFFile Members


%%PageItemTitle%% $$Members$$

KfxPDFFile Overview

KfxPDFFile Object Members

Public Methods

Public Method _Init | method _Init
Public Method Copy | Copies the PDF file from a temporary directory to the export directory. The optional parameter bstrDir specifies the export directory. If Directory is omitted, the text file is exported to the directory specified by ReleaseSetupData.KofaxPDFPath.
Public Method Delete | Deletes the text file copied to the export directory. The optional parameter bstrDir specifies the export directory for the text file. If Directory is omitted, the text file is deleted from the directory specified by ReleaseSetupData.KofaxPDFPath.

Public Properties

Public Property FileName property FileName

See Also

KfxPDFFile Overview


%%PageItemTitle%%

KfxPDFFile Object

bstrName
bstrDir
UniqueDocID
See Also Kofax Capture Export Type Library

_Init Method

Description

method _Init

Syntax

Public Sub _Init( _
   ByVal bstrName As String, _
   ByVal bstrDir As String, _
   ByVal UniqueDocID As Long _
)

Parameters

bstrName
bstrDir
UniqueDocID

See Also

KfxPDFFile Object


%%PageItemTitle%%

KfxPDFFile Object

bstrDir
See Also Kofax Capture Export Type Library

Copy Method

Description

Copies the PDF file from a temporary directory to the export directory. The optional parameter bstrDir specifies the export directory. If Directory is omitted, the text file is exported to the directory specified by ReleaseSetupData.KofaxPDFPath.

Syntax

Public Sub Copy( _
   ByVal bstrDir As String _
)

Parameters

bstrDir

See Also

KfxPDFFile Object


%%PageItemTitle%%

KfxPDFFile Object

bstrDir
See Also Kofax Capture Export Type Library

Delete Method

Description

Deletes the text file copied to the export directory. The optional parameter bstrDir specifies the export directory for the text file. If Directory is omitted, the text file is deleted from the directory specified by ReleaseSetupData.KofaxPDFPath.

Syntax

Public Sub Delete( _
   ByVal bstrDir As String _
)

Parameters

bstrDir

See Also

KfxPDFFile Object


%%PageItemTitle%%

KfxPDFFile Object

FileName Property

Description

property FileName

Property type

Read-only property

Syntax (Visual Basic)

Public Property FileName() As String

See Also

KfxPDFFile Object


%%PageItemTitle%%

KfxPDFFiles Members

KfxPDFFiles Object

Description

KfxPDFFiles is a collection of KfxPDFFile objects for a ReleaseData object. It contains the PDF files associated with a document. An export connector can process the collection of KfxPDFFile objects individually or process the objects at the collection level.

For a list of all members defined in this module, see KfxPDFFiles members.

Object Model

See Also

KfxPDFFiles Members


%%PageItemTitle%% $$Members$$

KfxPDFFiles Overview

KfxPDFFiles Object Members

Public Methods

Public Method _Init | method _Init
Public Method Add | method Add
Public Method Copy | Copies the PDF files in the collection from a temporary directory to the export directory. The optional parameter bstrDir specifies the export directory. If Directory is omitted, PDF files are exported to directory specified by ReleaseSetupData.KofaxPDFPath.
Public Method Delete | Deletes the PDF files copied to the export directory. The optional parameter bstrDir specifies the export directory for the PDF files. If Directory is omitted, the PDF files are deleted from the directory specified by ReleaseSetupData.KofaxPDFPath.
Public Method Remove | method Remove

Public Properties

Public Property _NewEnum | property _NewEnum
Public Property Count | Returns a long integer indicating the number of KfxPDFFile objects in the KfxPDFFiles collection.
Public Property Item | Returns the KfxPDFFile specified by the Key. The Key as a string contains the File name property of the Value, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.
Public Property ReadOnly | property ReadOnly

See Also

KfxPDFFiles Overview


%%PageItemTitle%%

KfxPDFFiles Object

pdispOpsSession
pdispDocument
pdispBatch
bstrDir
bReadOnly
See Also Kofax Capture Export Type Library

_Init Method

Description

method _Init

Syntax

Public Sub _Init( _
   ByVal pdispOpsSession As Object, _
   ByVal pdispDocument As Object, _
   ByVal pdispBatch As Object, _
   ByVal bstrDir As String, _
   ByVal bReadOnly As Long _
)

Parameters

pdispOpsSession
pdispDocument
pdispBatch
bstrDir
bReadOnly

See Also

KfxPDFFiles Object


%%PageItemTitle%%

KfxPDFFiles Object

pKfxPDFFile
bstrName
See Also Kofax Capture Export Type Library

Add Method

Description

method Add

Syntax

Public Sub Add( _
   ByVal pKfxPDFFile As KfxPDFFile, _
   ByVal bstrName As String _
)

Parameters

pKfxPDFFile
bstrName

See Also

KfxPDFFiles Object


%%PageItemTitle%%

KfxPDFFiles Object

Directory
See Also Kofax Capture Export Type Library

Copy Method

Description

Copies the PDF files in the collection from a temporary directory to the export directory. The optional parameter bstrDir specifies the export directory. If Directory is omitted, PDF files are exported to directory specified by ReleaseSetupData.KofaxPDFPath.

Syntax

Public Sub Copy( _
   Optional ByVal Directory As String = "" _
)

Parameters

Directory

See Also

KfxPDFFiles Object


%%PageItemTitle%%

KfxPDFFiles Object

Directory
See Also Kofax Capture Export Type Library

Delete Method

Description

Deletes the PDF files copied to the export directory. The optional parameter bstrDir specifies the export directory for the PDF files. If Directory is omitted, the PDF files are deleted from the directory specified by ReleaseSetupData.KofaxPDFPath.

Syntax

Public Sub Delete( _
   Optional ByVal Directory As String = "" _
)

Parameters

Directory

See Also

KfxPDFFiles Object


%%PageItemTitle%%

KfxPDFFiles Object

varIndex
See Also Kofax Capture Export Type Library

Remove Method

Description

method Remove

Syntax

Public Sub Remove( _
   ByRef varIndex As Variant _
)

Parameters

varIndex

See Also

KfxPDFFiles Object


%%PageItemTitle%%

KfxPDFFiles Object

_NewEnum Property

Description

property _NewEnum

Property type

Read-only property

Syntax (Visual Basic)

Public Property _NewEnum() As Unknown

See Also

KfxPDFFiles Object


%%PageItemTitle%%

KfxPDFFiles Object

Count Property

Description

Returns a long integer indicating the number of KfxPDFFile objects in the KfxPDFFiles collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

KfxPDFFiles Object


%%PageItemTitle%%

KfxPDFFiles Object

varIndex
See Also Kofax Capture Export Type Library

Item Property

Description

Returns the KfxPDFFile specified by the Key. The Key as a string contains the File name property of the Value, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByRef varIndex As Variant _
) As KfxPDFFile

Parameters

varIndex

See Also

KfxPDFFiles Object


%%PageItemTitle%%

KfxPDFFiles Object

ReadOnly Property

Description

property ReadOnly

Property type

Read-write property

Syntax (Visual Basic)

Public Property ReadOnly() As Long

See Also

KfxPDFFiles Object


%%PageItemTitle%%

Link Members

Link Object

Description

Link represents a field mapping in the Links collection of a ReleaseSetupData object. The mapping identifies the data field (source) and the destination column or field in the external data repository. Use the Add method to add a link to the Links collection.

For a list of all members defined in this module, see Link members.

See Also

Link Members


%%PageItemTitle%% $$Members$$

Link Overview

Link Object Members

Public Properties

Public Property Destination | Returns a string that indicates the field or column name in the external data repository. This string can be used as the Key to retrieve an individual member from the collection.
Public Property Source | Sets or returns a string that indicates the name of the document class field.
Public Property SourceType | Sets or returns a KfxLinkSourceType value that indicates the type of document index data field (index field, batch field, text constant, or Kofax Capture Value).

See Also

Link Overview


%%PageItemTitle%%

Link Object

Destination Property

Description

Returns a string that indicates the field or column name in the external data repository. This string can be used as the Key to retrieve an individual member from the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Destination() As String

See Also

Link Object


%%PageItemTitle%%

Link Object

Source Property

Description

Sets or returns a string that indicates the name of the document class field.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Source() As String

See Also

Link Object


%%PageItemTitle%%

Link Object

SourceType Property

Description

Sets or returns a KfxLinkSourceType value that indicates the type of document index data field (index field, batch field, text constant, or Kofax Capture Value).

Property type

Read-write property

Syntax (Visual Basic)

Public Property SourceType() As KfxLinkSourceType

See Also

Link Object


%%PageItemTitle%%

Links Members

Links Collection

Description

Links is a collection of Link objects for a ReleaseSetupData object. This collection identifies all the document index data fields (index fields, batch fields, text constants, and Kofax Capture Values) for which data is saved in an external data repository.

For a list of all members defined in this module, see Links members.

Object Model

See Also

Links Members


%%PageItemTitle%% $$Members$$

Links Overview

Links Collection Members

Public Methods

Public Method _Init | method _Init
Public Method Add | Adds a Link object to the Links collection. The parameters for Add are bstrSource (document index data field to export), nType (document index data field type), and bstrDest (identifies the Link object and the field in the repository that receives the data).
Public Method Remove | Removes the Link object specified by the Key from the Links collection. The parameter varIndex as a string contains the Destination property of Link, or as a long integer indicates the member痴 ordinal position within the collection.
Public Method RemoveAll | Removes all Link objects from the Links collection.

Public Properties

Public Property _NewEnum | property _NewEnum
Public Property Count | Returns a long integer indicating the number of Link objects in the Links collection.
Public Property Item | Returns the Link specified by the Key. The Key as a string contains the Destination property of the Link, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

See Also

Links Overview


%%PageItemTitle%%

Links Collection

RelSetup
ReadOnly
See Also Kofax Capture Export Type Library

_Init Method

Description

method _Init

Syntax

Public Sub _Init( _
   ByVal RelSetup As Object, _
   ByVal ReadOnly As Long _
)

Parameters

RelSetup
ReadOnly

See Also

Links Collection


%%PageItemTitle%%

Links Collection

Source
SourceType
Destination
See Also Kofax Capture Export Type Library

Add Method

Description

Adds a Link object to the Links collection. The parameters for Add are bstrSource (document index data field to export), nType (document index data field type), and bstrDest (identifies the Link object and the field in the repository that receives the data).

Syntax

Public Sub Add( _
   ByVal Source As String, _
   ByVal SourceType As KfxLinkSourceType, _
   ByVal Destination As String _
)

Parameters

Source
SourceType
Value Description
KFX_REL_UNDEFINED_LINK
KFX_REL_INDEXFIELD
KFX_REL_TEXTCONSTANT
KFX_REL_VARIABLE
KFX_REL_BATCHFIELD
KFX_REL_DOCUMENTID
Destination

See Also

Links Collection


%%PageItemTitle%%

Links Collection

Key
See Also Kofax Capture Export Type Library

Remove Method

Description

Removes the Link object specified by the Key from the Links collection. The parameter varIndex as a string contains the Destination property of Link, or as a long integer indicates the member痴 ordinal position within the collection.

Syntax

Public Sub Remove( _
   ByRef Key As Variant _
)

Parameters

Key

See Also

Links Collection


%%PageItemTitle%%

Links Collection

RemoveAll Method

Description

Removes all Link objects from the Links collection.

Syntax

Public Sub RemoveAll()

See Also

Links Collection


%%PageItemTitle%%

Links Collection

_NewEnum Property

Description

property _NewEnum

Property type

Read-only property

Syntax (Visual Basic)

Public Property _NewEnum() As Unknown

See Also

Links Collection


%%PageItemTitle%%

Links Collection

Count Property

Description

Returns a long integer indicating the number of Link objects in the Links collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Links Collection


%%PageItemTitle%%

Links Collection

Key
See Also Kofax Capture Export Type Library

Item Property

Description

Returns the Link specified by the Key. The Key as a string contains the Destination property of the Link, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByRef Key As Variant _
) As Link

Parameters

Key

See Also

Links Collection


%%PageItemTitle%%

ReleaseData Members

ReleaseData Object

Description

ReleaseData is used by the Export module and export connector to access the batch and document class information, and to perform a document export. The ReleaseDoc method reads the properties and saves the index data to an external data repository.

For a list of all members defined in this module, see ReleaseData members.

Object Model

See Also

ReleaseData Members


%%PageItemTitle%% $$Members$$

ReleaseData Overview

ReleaseData Object Members

Public Methods

Public Method CopyKofaxPDFFile | Copy the PDF file that belongs to a document into the export PDF path that is defined during export setup. Supports high availability through retries.
Public Method CopyKofaxPDFFileToPath | Copy the PDF file that belongs to a document into a specified path (the path is a string input argument for this method). Supports high availability through retries.
Public Method DoneWithContext | Notifies the Export module that the asynchronous export process for a document is complete. When the export process is finished, use the SetContext method to reference the document, and then call DoneWithContext to indicate that the export is complete.
Public Method LogError | Logs an error in the Kofax Capture Error Log. A new error log is created for each month and the file name indicates the month and year. For example, the error log for January 2008 is ERR_0108.txt.
Public Method SendMessage | Sends status information to the Export module. This can be a notification of an error or an update on the progress of an asynchronous export process. You can also use this method to send a string for the Export module to display in a Event Log output list.
Public Method SetContext | Directs the Export module to set up the ReleaseData object with the data for a document exported to an asynchronous export process. The document is specified by the ContextID argument, obtained from the ReleaseData object during initial document export.

Public Properties

Public Property BatchClassDescription | Contains the description of the batch class.
Public Property BatchClassID | Uniquely identifies the batch class.
Public Property BatchClassName | Contains the name of the batch class.
Public Property BatchDescription | Contains the description of the batch.
Public Property BatchName | Contains the name of the batch.
Public Property ConnectString | Contains the name of the external database.
Public Property ContextID | Uniquely identifies the current document. If you are exporting to an asynchronous export process, you must save this value to reference the document when the asynchronous process is finished.
Public Property CustomProperties | A collection that contains any named values you need for the export process.
Public Property DocClassID | Uniquely identifies the document class.
Public Property DocClassName | A string that contains the name of the document class.
Public Property DocumentCustomStorageString | A document custom storage string (DCSS) can be read/written by an export connector, custom module, OCX, or workflow agent. A unique DCSS name is vital so that data is not overwritten by mistake. Only DCSSs attached to documents are available to export connecto?ｺ??'
Public Property ImageFilePath | Contains the name of the directory to which the image files will be exported.
Public Property ImageFiles | A collection that contains the file names and image formats for the image files to be exported.
Public Property KofaxPDFFileName | The internal name of the Kofax PDF file that will be copied to the export directory.
Public Property KofaxPDFPath | Contains the name of a export directory for Kofax PDF files.
Public Property KofaxPDFReleaseScriptEnabled | Indicates whether Kofax PDF is enabled by the export connector.
Public Property Name | Contains the name of the export connector.
Public Property Password | Contains the password needed to log in to the external database.
Public Property RepositoryDocumentID | This document ID value can be read or written by export connectors and the data is retrieved or stored in the document custom storage string Kofax.AC.RepositoryDocumentID. The value is exposed to other export connectors.
Public Property RowSeparator | The multi-value field delimiter setting for the batch class.
Public Property ServicePackVersion | property ServicePackVersion
Public Property StorageType | A KfxStorageType value that indicates the type of file system to which the images and text files will be exported.
Public Property TableName | Contains the name of the table in the external database that will receive the document data.
Public Property TextFilePath | Contains the name of the directory to which the text files will be exported.
Public Property TextFiles | A TextFiles collection that contains the file names and file formats of the text files to be exported.
Public Property UniqueDocumentID | Uniquely identifies the current document.
Public Property UseOriginalFileNames | Mirrors the ReleaseSetup flag. If set, the ImageFiles.Copy and ImageFile.Copy methods use the original file name rather than the default output file name.
Public Property UserName | Contains the user name needed to log in to an external database.
Public Property Values | A collection that contains all the data that can be saved for the current document. It contains the data for all the mappings established by the ReleaseSetupScript using the Links collection.

See Also

ReleaseData Overview


%%PageItemTitle%%

ReleaseData Object

CopyKofaxPDFFile Method

Description

Copy the PDF file that belongs to a document into the export PDF path that is defined during export setup. Supports high availability through retries.

Syntax

Public Sub CopyKofaxPDFFile()

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

bstrPathName
See Also Kofax Capture Export Type Library

CopyKofaxPDFFileToPath Method

Description

Copy the PDF file that belongs to a document into a specified path (the path is a string input argument for this method). Supports high availability through retries.

Syntax

Public Sub CopyKofaxPDFFileToPath( _
   ByVal bstrPathName As String _
)

Parameters

bstrPathName

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

DoneWithContext Method

Description

Notifies the Export module that the asynchronous export process for a document is complete. When the export process is finished, use the SetContext method to reference the document, and then call DoneWithContext to indicate that the export is complete.

Syntax

Public Sub DoneWithContext()

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

Err1
Err2
Err3
ErrorMessage
CodeModule
LineNumber
See Also Kofax Capture Export Type Library

LogError Method

Description

Logs an error in the Kofax Capture Error Log. A new error log is created for each month and the file name indicates the month and year. For example, the error log for January 2008 is ERR_0108.txt.

Syntax

Public Sub LogError( _
   ByVal Err1 As Long, _
   ByVal Err2 As Long, _
   ByVal Err3 As Long, _
   ByVal ErrorMessage As String, _
   ByVal CodeModule As String, _
   ByVal LineNumber As Long _
)

Parameters

Err1
Err2
Err3
ErrorMessage
CodeModule
LineNumber

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

MessageString
ErrorNumber
InfoRet
See Also Kofax Capture Export Type Library

SendMessage Method

Description

Sends status information to the Export module. This can be a notification of an error or an update on the progress of an asynchronous export process. You can also use this method to send a string for the Export module to display in a Event Log output list.

Syntax

Public Sub SendMessage( _
   ByVal MessageString As String, _
   ByVal ErrorNumber As Long, _
   ByVal InfoRet As KfxInfoReturnValue _
)

Parameters

MessageString
ErrorNumber
InfoRet
Value Description
KFX_REL_NO_DOC_MESSAGE
KFX_REL_DOC_MESSAGE
KFX_REL_DOC_ERROR
KFX_REL_DOC_QUEUED
KFX_REL_DOC_RELEASED

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

ContextID
See Also Kofax Capture Export Type Library

SetContext Method

Description

Directs the Export module to set up the ReleaseData object with the data for a document exported to an asynchronous export process. The document is specified by the ContextID argument, obtained from the ReleaseData object during initial document export.

Syntax

Public Sub SetContext( _
   ByVal ContextID As Long _
)

Parameters

ContextID

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

BatchClassDescription Property

Description

Contains the description of the batch class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BatchClassDescription() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

BatchClassID Property

Description

Uniquely identifies the batch class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BatchClassID() As Long

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

BatchClassName Property

Description

Contains the name of the batch class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BatchClassName() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

BatchDescription Property

Description

Contains the description of the batch.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BatchDescription() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

BatchName Property

Description

Contains the name of the batch.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BatchName() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

ConnectString Property

Description

Contains the name of the external database.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ConnectString() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

ContextID Property

Description

Uniquely identifies the current document. If you are exporting to an asynchronous export process, you must save this value to reference the document when the asynchronous process is finished.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ContextID() As Long

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

CustomProperties Property

Description

A collection that contains any named values you need for the export process.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CustomProperties() As CustomProperties

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

DocClassID Property

Description

Uniquely identifies the document class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DocClassID() As Long

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

DocClassName Property

Description

A string that contains the name of the document class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DocClassName() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

Name
See Also Kofax Capture Export Type Library

DocumentCustomStorageString Property

Description

A document custom storage string (DCSS) can be read/written by an export connector, custom module, OCX, or workflow agent. A unique DCSS name is vital so that data is not overwritten by mistake. Only DCSSs attached to documents are available to export connecto?ｺ??'

Property type

Read-write property

Syntax (Visual Basic)

Public Property DocumentCustomStorageString( _
   ByVal Name As String _
) As String

Parameters

Name

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

ImageFilePath Property

Description

Contains the name of the directory to which the image files will be exported.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ImageFilePath() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

ImageFiles Property

Description

A collection that contains the file names and image formats for the image files to be exported.

Property type

Read-only property

Syntax (Visual Basic)

Public Property ImageFiles() As ImageFiles

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

KofaxPDFFileName Property

Description

The internal name of the Kofax PDF file that will be copied to the export directory.

Property type

Read-only property

Syntax (Visual Basic)

Public Property KofaxPDFFileName() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

KofaxPDFPath Property

Description

Contains the name of a export directory for Kofax PDF files.

Property type

Read-only property

Syntax (Visual Basic)

Public Property KofaxPDFPath() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

KofaxPDFReleaseScriptEnabled Property

Description

Indicates whether Kofax PDF is enabled by the export connector.

Property type

Read-only property

Syntax (Visual Basic)

Public Property KofaxPDFReleaseScriptEnabled() As Boolean

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

Name Property

Description

Contains the name of the export connector.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

Password Property

Description

Contains the password needed to log in to the external database.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Password() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

RepositoryDocumentID Property

Description

This document ID value can be read or written by export connectors and the data is retrieved or stored in the document custom storage string Kofax.AC.RepositoryDocumentID. The value is exposed to other export connectors.

Property type

Read-write property

Syntax (Visual Basic)

Public Property RepositoryDocumentID() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

RowSeparator Property

Description

The multi-value field delimiter setting for the batch class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RowSeparator() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

ServicePackVersion Property

Description

property ServicePackVersion

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServicePackVersion() As Long

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

StorageType Property

Description

A KfxStorageType value that indicates the type of file system to which the images and text files will be exported.

Property type

Read-only property

Syntax (Visual Basic)

Public Property StorageType() As KfxStorageType

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

TableName Property

Description

Contains the name of the table in the external database that will receive the document data.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TableName() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

TextFilePath Property

Description

Contains the name of the directory to which the text files will be exported.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TextFilePath() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

TextFiles Property

Description

A TextFiles collection that contains the file names and file formats of the text files to be exported.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TextFiles() As TextFiles

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

UniqueDocumentID Property

Description

Uniquely identifies the current document.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UniqueDocumentID() As Long

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

UseOriginalFileNames Property

Description

Mirrors the ReleaseSetup flag. If set, the ImageFiles.Copy and ImageFile.Copy methods use the original file name rather than the default output file name.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UseOriginalFileNames() As Long

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

UserName Property

Description

Contains the user name needed to log in to an external database.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserName() As String

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseData Object

Values Property

Description

A collection that contains all the data that can be saved for the current document. It contains the data for all the mappings established by the ReleaseSetupScript using the Links collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Values() As Values

See Also

ReleaseData Object


%%PageItemTitle%%

ReleaseSetupData Members

ReleaseSetupData Object

Description

ReleaseSetupData is used by the Administration module and export connector setup to define a document class export process. The ReleaseSetupData properties provide configuration information such as target export folders and external data repository.

For a list of all members defined in this module, see ReleaseSetupData members.

Object Model

See Also

ReleaseSetupData Members


%%PageItemTitle%% $$Members$$

ReleaseSetupData Overview

ReleaseSetupData Object Members

Public Methods

Public Method Apply | Saves the current values in the ReleaseSetupData object to the Kofax Capture database. The New property is set to False the first time this method is used.
Public Method LogError | Logs an error in the Kofax Capture Error Log. A new error log is created for each month and the file name indicates the month and year. For example, the error log for January 2008 is ERR_0108.txt
Public Method Refresh | Updates the ReleaseSetupData object property values with data from the Kofax Capture database. Use this method to discard property settings changed by an export connector setup. The optional DoTransaction parameter specifies whether to discard or retain change?ｺ??'

Public Properties

Public Property _Separators | property _Separators
Public Property BatchClassDescription | Contains the description of the batch class.
Public Property BatchClassID | Uniquely identifies the batch class.
Public Property BatchClassName | Contains the name of the batch class.
Public Property BatchClassSupportsNonImageFiles | Indicates if the batch class supports eDocuments.
Public Property BatchFields | A collection of batch field objects available to the document class.
Public Property BatchVariableNames | A collection of variant values containing the names of the Kofax Capture Values available to the document class.
Public Property ConnectString | Contains the name of the external database. (Default value = "", an empty string.)
Public Property CustomProperties | A collection of custom property objects. Contains any named values you need for the export process.
Public Property DocClassID | Uniquely identifies the document class.
Public Property DocClassName | Contains the name of the document class.
Public Property ExternalBatchClassID | property ExternalBatchClassID
Public Property ImageFilePath | Contains the name of folder to which the image files will be exported. (Default value = "", an empty string.) You can override this property in the export connector.
Public Property ImageType | A long integer that you must set to specify the image format for the exported images. (Default value = 0, Multi-page TIFF - CCITT Group 4.)
Public Property ImageTypes | A collection of available image file formats (IFF). Objects in this collection have the properties Name (IFF name), Description (IFF description), Type (ReleaseSetupData ImageType value), and MultiplePage (non-zero if multiple pages supported).
Public Property IndexFields | A collection of index field objects associated with the document class.
Public Property KofaxPDFDocClassEnabled | Indicates whether Kofax PDF is enabled by the document class.
Public Property KofaxPDFPath | Contains the name of the Export folder of the Kofax PDF files.
Public Property KofaxPDFReleaseScriptEnabled | Indicates whether Kofax PDF is enabled in the export connector.
Public Property Links | A collection of link objects that you must fill to establish the mappings between the document class data fields and the fields or columns in the destination external data repository.
Public Property Name | Contains the name of the export connector.
Public Property New | Indicates if the script has been loaded for the first time for a given document class/batch class pair. Use this property to determine whether to populate fields in the setup form with data from the ReleaseSetup object or with default values from the script.
Public Property Password | Contains the password needed to log in to an external database. (Default value = "", empty string.)
Public Property RowSeparator | The multi-value field delimiter setting for the batch class.
Public Property ServicePackVersion | property ServicePackVersion
Public Property SkipFirstPage | Indicates if the script is to skip separator sheets containing index fields when exporting images for a document. (Default value = 0, False.)
Public Property StorageType | A KfxStorageType value that you must set to specify the type of file system to which the images and text files will be exported. (Default value = 0 (KFX_REL_FILESYSTEM), standard file system.)
Public Property TableName | Contains the name of a table in an external database. (Default value = "", empty string.)
Public Property TextFileEnabled | Indicates whether full-text OCR is enabled for the document class.
Public Property TextFilePath | Contains the name of the folder to which full-text OCR files will be exported. (Default value = "", empty string.)
Public Property UseOriginalFileNames | Corresponds to the batch class, Export module property that indicates whether original file names are to be used for export.
Public Property UserName | Contains the username needed to log in to an external database. (Default value = "", empty string.)

See Also

ReleaseSetupData Overview


%%PageItemTitle%%

ReleaseSetupData Object

Apply Method

Description

Saves the current values in the ReleaseSetupData object to the Kofax Capture database. The New property is set to False the first time this method is used.

Syntax

Public Sub Apply()

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

Err1
Err2
Err3
ErrorMessage
CodeModule
LineNumber
See Also Kofax Capture Export Type Library

LogError Method

Description

Logs an error in the Kofax Capture Error Log. A new error log is created for each month and the file name indicates the month and year. For example, the error log for January 2008 is ERR_0108.txt

Syntax

Public Sub LogError( _
   ByVal Err1 As Long, _
   ByVal Err2 As Long, _
   ByVal Err3 As Long, _
   ByVal ErrorMessage As String, _
   ByVal CodeModule As String, _
   ByVal LineNumber As Long _
)

Parameters

Err1
Err2
Err3
ErrorMessage
CodeModule
LineNumber

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

DoTransaction
See Also Kofax Capture Export Type Library

Refresh Method

Description

Updates the ReleaseSetupData object property values with data from the Kofax Capture database. Use this method to discard property settings changed by an export connector setup. The optional DoTransaction parameter specifies whether to discard or retain change?ｺ??'

Syntax

Public Sub Refresh( _
   Optional ByVal DoTransaction As Long = 1 _
)

Parameters

DoTransaction

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

_Separators Property

Description

property _Separators

Property type

Read-write property

Syntax (Visual Basic)

Public Property _Separators() As Long

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

BatchClassDescription Property

Description

Contains the description of the batch class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BatchClassDescription() As String

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

BatchClassID Property

Description

Uniquely identifies the batch class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BatchClassID() As Long

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

BatchClassName Property

Description

Contains the name of the batch class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BatchClassName() As String

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

BatchClassSupportsNonImageFiles Property

Description

Indicates if the batch class supports eDocuments.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BatchClassSupportsNonImageFiles() As Long

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

BatchFields Property

Description

A collection of batch field objects available to the document class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BatchFields() As BatchFields

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

BatchVariableNames Property

Description

A collection of variant values containing the names of the Kofax Capture Values available to the document class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property BatchVariableNames() As Object

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

ConnectString Property

Description

Contains the name of the external database. (Default value = "", an empty string.)

Property type

Read-write property

Syntax (Visual Basic)

Public Property ConnectString() As String

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

CustomProperties Property

Description

A collection of custom property objects. Contains any named values you need for the export process.

Property type

Read-only property

Syntax (Visual Basic)

Public Property CustomProperties() As CustomProperties

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

DocClassID Property

Description

Uniquely identifies the document class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DocClassID() As Long

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

DocClassName Property

Description

Contains the name of the document class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DocClassName() As String

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

ExternalBatchClassID Property

Description

property ExternalBatchClassID

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExternalBatchClassID() As Long

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

ImageFilePath Property

Description

Contains the name of folder to which the image files will be exported. (Default value = "", an empty string.) You can override this property in the export connector.

Property type

Read-write property

Syntax (Visual Basic)

Public Property ImageFilePath() As String

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

ImageType Property

Description

A long integer that you must set to specify the image format for the exported images. (Default value = 0, Multi-page TIFF - CCITT Group 4.)

Property type

Read-write property

Syntax (Visual Basic)

Public Property ImageType() As Long

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

ImageTypes Property

Description

A collection of available image file formats (IFF). Objects in this collection have the properties Name (IFF name), Description (IFF description), Type (ReleaseSetupData ImageType value), and MultiplePage (non-zero if multiple pages supported).

Property type

Read-only property

Syntax (Visual Basic)

Public Property ImageTypes() As Object

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

IndexFields Property

Description

A collection of index field objects associated with the document class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property IndexFields() As IndexFields

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

KofaxPDFDocClassEnabled Property

Description

Indicates whether Kofax PDF is enabled by the document class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property KofaxPDFDocClassEnabled() As Long

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

KofaxPDFPath Property

Description

Contains the name of the Export folder of the Kofax PDF files.

Property type

Read-write property

Syntax (Visual Basic)

Public Property KofaxPDFPath() As String

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

KofaxPDFReleaseScriptEnabled Property

Description

Indicates whether Kofax PDF is enabled in the export connector.

Property type

Read-write property

Syntax (Visual Basic)

Public Property KofaxPDFReleaseScriptEnabled() As Boolean

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

Links Property

Description

A collection of link objects that you must fill to establish the mappings between the document class data fields and the fields or columns in the destination external data repository.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Links() As Links

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

Name Property

Description

Contains the name of the export connector.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

New Property

Description

Indicates if the script has been loaded for the first time for a given document class/batch class pair. Use this property to determine whether to populate fields in the setup form with data from the ReleaseSetup object or with default values from the script.

Property type

Read-only property

Syntax (Visual Basic)

Public Property New() As Long

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

Password Property

Description

Contains the password needed to log in to an external database. (Default value = "", empty string.)

Property type

Read-write property

Syntax (Visual Basic)

Public Property Password() As String

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

RowSeparator Property

Description

The multi-value field delimiter setting for the batch class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RowSeparator() As String

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

ServicePackVersion Property

Description

property ServicePackVersion

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServicePackVersion() As Long

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

SkipFirstPage Property

Description

Indicates if the script is to skip separator sheets containing index fields when exporting images for a document. (Default value = 0, False.)

Property type

Read-write property

Syntax (Visual Basic)

Public Property SkipFirstPage() As Long

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

StorageType Property

Description

A KfxStorageType value that you must set to specify the type of file system to which the images and text files will be exported. (Default value = 0 (KFX_REL_FILESYSTEM), standard file system.)

Property type

Read-write property

Syntax (Visual Basic)

Public Property StorageType() As KfxStorageType

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

TableName Property

Description

Contains the name of a table in an external database. (Default value = "", empty string.)

Property type

Read-write property

Syntax (Visual Basic)

Public Property TableName() As String

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

TextFileEnabled Property

Description

Indicates whether full-text OCR is enabled for the document class.

Property type

Read-only property

Syntax (Visual Basic)

Public Property TextFileEnabled() As Long

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

TextFilePath Property

Description

Contains the name of the folder to which full-text OCR files will be exported. (Default value = "", empty string.)

Property type

Read-write property

Syntax (Visual Basic)

Public Property TextFilePath() As String

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

UseOriginalFileNames Property

Description

Corresponds to the batch class, Export module property that indicates whether original file names are to be used for export.

Property type

Read-only property

Syntax (Visual Basic)

Public Property UseOriginalFileNames() As Long

See Also

ReleaseSetupData Object


%%PageItemTitle%%

ReleaseSetupData Object

UserName Property

Description

Contains the username needed to log in to an external database. (Default value = "", empty string.)

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserName() As String

See Also

ReleaseSetupData Object


%%PageItemTitle%%

RelInfoData Members

RelInfoData Object

Description

RelInfoData Class

For a list of all members defined in this module, see RelInfoData members.

See Also

RelInfoData Members


%%PageItemTitle%% $$Members$$

RelInfoData Overview

RelInfoData Object Members

Public Properties

Public Property Document | property Document
Public Property ErrorNumber | property ErrorNumber
Public Property MessageText | property MessageText
Public Property MessageType | property MessageType

See Also

RelInfoData Overview


%%PageItemTitle%%

RelInfoData Object

Document Property

Description

property Document

Property type

Read-write property

Syntax (Visual Basic)

Public Property Document() As Object

See Also

RelInfoData Object


%%PageItemTitle%%

RelInfoData Object

ErrorNumber Property

Description

property ErrorNumber

Property type

Read-write property

Syntax (Visual Basic)

Public Property ErrorNumber() As Long

See Also

RelInfoData Object


%%PageItemTitle%%

RelInfoData Object

MessageText Property

Description

property MessageText

Property type

Read-write property

Syntax (Visual Basic)

Public Property MessageText() As String

See Also

RelInfoData Object


%%PageItemTitle%%

RelInfoData Object

MessageType Property

Description

property MessageType

Property type

Read-write property

Syntax (Visual Basic)

Public Property MessageType() As KfxInfoReturnValue

See Also

RelInfoData Object


%%PageItemTitle%%

RowValues Members

RowValues Collection

Description

RowValues specifies the row values for a table field.

For a list of all members defined in this module, see RowValues members.

Object Model

See Also

RowValues Members


%%PageItemTitle%% $$Members$$

RowValues Overview

RowValues Collection Members

Public Properties

Public Property Count | Returns a long integer indicating the number of Value objects in the RowValues collection.
Public Property Item | Returns the Value specified by the Key. The Key as a string contains the Row number property of the Value, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

See Also

RowValues Overview


%%PageItemTitle%%

RowValues Collection

Count Property

Description

Returns a long integer indicating the number of Value objects in the RowValues collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

RowValues Collection


%%PageItemTitle%%

RowValues Collection

Key
See Also Kofax Capture Export Type Library

Item Property

Description

Returns the Value specified by the Key. The Key as a string contains the Row number property of the Value, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByRef Key As Variant _
) As Value

Parameters

Key

See Also

RowValues Collection


%%PageItemTitle%%

TableRows Members

TableRows Collection

Description

TableRows specifies the table rows for a particular table.

For a list of all members defined in this module, see TableRows members.

Object Model

See Also

TableRows Members


%%PageItemTitle%% $$Members$$

TableRows Overview

TableRows Collection Members

Public Properties

Public Property Count | Returns a long integer indicating the number of Value objects in the TableRows collection.
Public Property Item | Returns the Value specified by the Key. The Key as a string contains the Row number property of the Value, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

See Also

TableRows Overview


%%PageItemTitle%%

TableRows Collection

Count Property

Description

Returns a long integer indicating the number of Value objects in the TableRows collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

TableRows Collection


%%PageItemTitle%%

TableRows Collection

Key
See Also Kofax Capture Export Type Library

Item Property

Description

Returns the Value specified by the Key. The Key as a string contains the Row number property of the Value, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByRef Key As Variant _
) As TableRowValues

Parameters

Key

See Also

TableRows Collection


%%PageItemTitle%%

TableRowValues Members

TableRowValues Collection

Description

TableRowValues specifies the table rows for a particular table.

For a list of all members defined in this module, see TableRowValues members.

Object Model

See Also

TableRowValues Members


%%PageItemTitle%% $$Members$$

TableRowValues Overview

TableRowValues Collection Members

Public Properties

Public Property Count | Returns a long integer indicating the number of Value objects in the TableRows collection.
Public Property Item | Returns the Value specified by the Key. The Key as a string contains the Field (column) property of the Value, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

See Also

TableRowValues Overview


%%PageItemTitle%%

TableRowValues Collection

Count Property

Description

Returns a long integer indicating the number of Value objects in the TableRows collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

TableRowValues Collection


%%PageItemTitle%%

TableRowValues Collection

Key
See Also Kofax Capture Export Type Library

Item Property

Description

Returns the Value specified by the Key. The Key as a string contains the Field (column) property of the Value, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByRef Key As Variant _
) As Value

Parameters

Key

See Also

TableRowValues Collection


%%PageItemTitle%%

Tables Members

Tables Collection

Description

Tables specifies the tables of a particular document.

For a list of all members defined in this module, see Tables members.

Object Model

See Also

Tables Members


%%PageItemTitle%% $$Members$$

Tables Overview

Tables Collection Members

Public Properties

Public Property Count | Returns a long integer indicating the number of Table rows objects in the Tables collection.
Public Property Item | Returns the Value specified by the Key. The Key as a string contains the Table number property of the Value, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

See Also

Tables Overview


%%PageItemTitle%%

Tables Collection

Count Property

Description

Returns a long integer indicating the number of Table rows objects in the Tables collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Tables Collection


%%PageItemTitle%%

Tables Collection

Key
See Also Kofax Capture Export Type Library

Item Property

Description

Returns the Value specified by the Key. The Key as a string contains the Table number property of the Value, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByRef Key As Variant _
) As TableRows

Parameters

Key

See Also

Tables Collection


%%PageItemTitle%%

TextFile Members

TextFile Object

Description

TextFile represents a file containing a full-text OCR result in the TextFiles collection of ReleaseData. TextFile contains methods to copy the file to the export directory. The Export module initializes the collection with data before calling ReleaseDoc.

For a list of all members defined in this module, see TextFile members.

See Also

TextFile Members


%%PageItemTitle%% $$Members$$

TextFile Overview

TextFile Object Members

Public Methods

Public Method Copy | Copies the text file from a temporary directory to the export directory. The optional parameter bstrDir specifies the export directory. If Directory is omitted, the text file is exported to the directory specified by ReleaseData.TextFilePath.
Public Method Delete | Deletes the text file copied to the export directory. The optional parameter bstrDir specifies the export directory for the text file. If Directory is omitted, the text file is deleted from the directory specified by ReleaseData.TextFilePath.

Public Properties

Public Property FileName | Returns a string that specifies the file name of the text file. This string uniquely identifies the text file in the TextFiles collection. This string can be used as the Key to retrieve an individual member from the collection.
Public Property FileType | Returns a KfxTextFileType value that indicates the type of text file.

See Also

TextFile Overview


%%PageItemTitle%%

TextFile Object

Directory
See Also Kofax Capture Export Type Library

Copy Method

Description

Copies the text file from a temporary directory to the export directory. The optional parameter bstrDir specifies the export directory. If Directory is omitted, the text file is exported to the directory specified by ReleaseData.TextFilePath.

Syntax

Public Sub Copy( _
   Optional ByVal Directory As String = "" _
)

Parameters

Directory

See Also

TextFile Object


%%PageItemTitle%%

TextFile Object

Directory
See Also Kofax Capture Export Type Library

Delete Method

Description

Deletes the text file copied to the export directory. The optional parameter bstrDir specifies the export directory for the text file. If Directory is omitted, the text file is deleted from the directory specified by ReleaseData.TextFilePath.

Syntax

Public Sub Delete( _
   Optional ByVal Directory As String = "" _
)

Parameters

Directory

See Also

TextFile Object


%%PageItemTitle%%

TextFile Object

FileName Property

Description

Returns a string that specifies the file name of the text file. This string uniquely identifies the text file in the TextFiles collection. This string can be used as the Key to retrieve an individual member from the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FileName() As String

See Also

TextFile Object


%%PageItemTitle%%

TextFile Object

FileType Property

Description

Returns a KfxTextFileType value that indicates the type of text file.

Property type

Read-only property

Syntax (Visual Basic)

Public Property FileType() As KfxTextFileType

See Also

TextFile Object


%%PageItemTitle%%

TextFiles Members

TextFiles Collection

Description

TextFiles is a collection of TextFile objects for a ReleaseData object. It contains all the text files associated with a document. An export connector can process the collection of TextFile objects individually or process all the objects at the collection leve?ｺ??'

For a list of all members defined in this module, see TextFiles members.

Object Model

See Also

TextFiles Members


%%PageItemTitle%% $$Members$$

TextFiles Overview

TextFiles Collection Members

Public Methods

Public Method Copy | Copies the text files in the collection from a temporary directory to the export directory. The optional parameter bstrDir specifies the export directory. If Directory is omitted, text files are exported to a directory specified by ReleaseData.TextFilePath.
Public Method Delete | Deletes the text files copied to the export directory. The optional parameter bstrDir specifies the export directory for the text files. If Directory is omitted, the text files are deleted from the directory specified by ReleaseData.TextFilePath.

Public Properties

Public Property _NewEnum | property _NewEnum
Public Property Count | Returns a long integer indicating the number of TextFile objects in the TextFiles collection.
Public Property Item | Returns the TextFile specified by the Key. The Key as a string contains the FileName property of the TextFile, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

See Also

TextFiles Overview


%%PageItemTitle%%

TextFiles Collection

Directory
See Also Kofax Capture Export Type Library

Copy Method

Description

Copies the text files in the collection from a temporary directory to the export directory. The optional parameter bstrDir specifies the export directory. If Directory is omitted, text files are exported to a directory specified by ReleaseData.TextFilePath.

Syntax

Public Sub Copy( _
   Optional ByVal Directory As String = "" _
)

Parameters

Directory

See Also

TextFiles Collection


%%PageItemTitle%%

TextFiles Collection

Directory
See Also Kofax Capture Export Type Library

Delete Method

Description

Deletes the text files copied to the export directory. The optional parameter bstrDir specifies the export directory for the text files. If Directory is omitted, the text files are deleted from the directory specified by ReleaseData.TextFilePath.

Syntax

Public Sub Delete( _
   Optional ByVal Directory As String = "" _
)

Parameters

Directory

See Also

TextFiles Collection


%%PageItemTitle%%

TextFiles Collection

_NewEnum Property

Description

property _NewEnum

Property type

Read-only property

Syntax (Visual Basic)

Public Property _NewEnum() As Unknown

See Also

TextFiles Collection


%%PageItemTitle%%

TextFiles Collection

Count Property

Description

Returns a long integer indicating the number of TextFile objects in the TextFiles collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

TextFiles Collection


%%PageItemTitle%%

TextFiles Collection

Key
See Also Kofax Capture Export Type Library

Item Property

Description

Returns the TextFile specified by the Key. The Key as a string contains the FileName property of the TextFile, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByRef Key As Variant _
) As TextFile

Parameters

Key

See Also

TextFiles Collection


%%PageItemTitle%%

Value Members

Value Object

Description

Value represents an individual data point in the Values collection of a ReleaseData object. Value identifies the data field (source) and the destination column or field in the external data repository.

For a list of all members defined in this module, see Value members.

See Also

Value Members


%%PageItemTitle%% $$Members$$

Value Overview

Value Object Members

Public Properties

Public Property DataType | Returns a KfxIndexFieldType value that indicates the data type of the value.
Public Property Destination | Returns a string that indicates the field or column name in the external data repository. This string can be used as the key to retrieve an individual member from the collection.
Public Property RowValues | Represents a collection of Value objects for each row of a table. Nothing if a single-value field.
Public Property SourceName | Returns a string that indicates the name of the document index data field.
Public Property SourceType | Returns a KfxLinkSourceType value that indicates the type of the document index data field (index field, batch field, text constant, or Kofax Capture Value).
Public Property TableName | Returns a TableName value that indicates the name of the table. If the corresponding field belongs to a table the table name can be obtained, otherwise this value is empty ("").
Public Property Value | Returns a data string to save in the external database. The data may need to be converted from a string to the appropriate data type before saving the data. If a table field is obtained from ReleaseData, then Value is the list of values for all rows.

See Also

Value Overview


%%PageItemTitle%%

Value Object

DataType Property

Description

Returns a KfxIndexFieldType value that indicates the data type of the value.

Property type

Read-only property

Syntax (Visual Basic)

Public Property DataType() As KfxIndexFieldType

See Also

Value Object


%%PageItemTitle%%

Value Object

Destination Property

Description

Returns a string that indicates the field or column name in the external data repository. This string can be used as the key to retrieve an individual member from the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Destination() As String

See Also

Value Object


%%PageItemTitle%%

Value Object

Key
See Also Kofax Capture Export Type Library

RowValues Property

Description

Represents a collection of Value objects for each row of a table. Nothing if a single-value field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property RowValues( _
   ByRef Key As Variant _
) As Object

Parameters

Key

See Also

Value Object


%%PageItemTitle%%

Value Object

SourceName Property

Description

Returns a string that indicates the name of the document index data field.

Property type

Read-only property

Syntax (Visual Basic)

Public Property SourceName() As String

See Also

Value Object


%%PageItemTitle%%

Value Object

SourceType Property

Description

Returns a KfxLinkSourceType value that indicates the type of the document index data field (index field, batch field, text constant, or Kofax Capture Value).

Property type

Read-only property

Syntax (Visual Basic)

Public Property SourceType() As KfxLinkSourceType

See Also

Value Object


%%PageItemTitle%%

Value Object

TableName Property

Description

Returns a TableName value that indicates the name of the table. If the corresponding field belongs to a table the table name can be obtained, otherwise this value is empty ("").

Property type

Read-only property

Syntax (Visual Basic)

Public Property TableName() As String

See Also

Value Object


%%PageItemTitle%%

Value Object

Value Property

Description

Returns a data string to save in the external database. The data may need to be converted from a string to the appropriate data type before saving the data. If a table field is obtained from ReleaseData, then Value is the list of values for all rows.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Value() As String

See Also

Value Object


%%PageItemTitle%%

Values Members

Values Collection

Description

Values is a collection of Value objects for a ReleaseData object. This collection includes all the data that can be saved for the document. It contains the actual values for the field mappings established by the ReleaseSetupScript using the Links collection.

For a list of all members defined in this module, see Values members.

Object Model

See Also

Values Members


%%PageItemTitle%% $$Members$$

Values Overview

Values Collection Members

Public Properties

Public Property Count | Returns a long integer indicating the number of Value objects in the Values collection.
Public Property Item | Returns the Value specified by the Key. The Key as a string contains the Destination property of the Value, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

See Also

Values Overview


%%PageItemTitle%%

Values Collection

Count Property

Description

Returns a long integer indicating the number of Value objects in the Values collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Values Collection


%%PageItemTitle%%

Values Collection

Key
See Also Kofax Capture Export Type Library

Item Property

Description

Returns the Value specified by the Key. The Key as a string contains the Destination property of the Value, or as a long integer indicates the member痴 ordinal position within the collection. The Item property is the default property for the collection.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Item( _
   ByRef Key As Variant _
) As Value

Parameters

Key

See Also

Values Collection


%%PageItemTitle%%

Kofax Capture Export Type Library

KfxActionValue Enumeration

Members

Member | Description
KFX_REL_UNDEFINED_ACTION |
KFX_REL_DOCCLASS_RENAME |
KFX_REL_BATCHCLASS_RENAME |
KFX_REL_INDEXFIELD_DELETE |
KFX_REL_INDEXFIELD_INSERT |
KFX_REL_INDEXFIELD_RENAME |
KFX_REL_BATCHFIELD_DELETE |
KFX_REL_BATCHFIELD_INSERT |
KFX_REL_BATCHFIELD_RENAME |
KFX_REL_RELEASESETUP_DELETE |
KFX_REL_IMPORT |
KFX_REL_UPGRADE |
KFX_REL_PUBLISH_CHECK |
KFX_REL_START |
KFX_REL_END |
KFX_REL_FOLDERCLASS_INSERT |
KFX_REL_FOLDERCLASS_RENAME |
KFX_REL_FOLDERCLASS_DELETE |
KFX_REL_TABLE_DELETE |
KFX_REL_TABLE_INSERT |
KFX_REL_TABLE_RENAME |


%%PageItemTitle%%

Kofax Capture Export Type Library

KfxIndexFieldType Enumeration

Members

Member | Description
SQL_UNKNOWN_TYPE |
SQL_CHAR |
SQL_NUMERIC |
SQL_DECIMAL |
SQL_INTEGER |
SQL_SMALLINT |
SQL_FLOAT |
SQL_REAL |
SQL_DOUBLE |
SQL_DATETIME |
SQL_VARCHAR |


%%PageItemTitle%%

Kofax Capture Export Type Library

KfxInfoReturnValue Enumeration

Members

Member | Description
KFX_REL_NO_DOC_MESSAGE |
KFX_REL_DOC_MESSAGE |
KFX_REL_DOC_ERROR |
KFX_REL_DOC_QUEUED |
KFX_REL_DOC_RELEASED |


%%PageItemTitle%%

Kofax Capture Export Type Library

KfxLinkSourceType Enumeration

Members

Member | Description
KFX_REL_UNDEFINED_LINK |
KFX_REL_INDEXFIELD |
KFX_REL_TEXTCONSTANT |
KFX_REL_VARIABLE |
KFX_REL_BATCHFIELD |
KFX_REL_DOCUMENTID |


%%PageItemTitle%%

Kofax Capture Export Type Library

KfxReturnValue Enumeration

Members

Member | Description
KFX_REL_SUCCESS |
KFX_REL_REINIT |
KFX_REL_STOPPED |
KFX_REL_QUEUED |
KFX_REL_UNSUPPORTED |
KFX_REL_ERROR |
KFX_REL_DOCCLASSERROR |
KFX_REL_FATALERROR |
KFX_REL_FATALBATCHERROR |


%%PageItemTitle%%

Kofax Capture Export Type Library

KfxStorageType Enumeration

Members

Member | Description
KFX_REL_UNDEFINED_STORAGE |
KFX_REL_FILESYSTEM |
KFX_REL_ASCENTSTORAGE |


%%PageItemTitle%%

Kofax Capture Export Type Library

KfxTextFileType Enumeration

Members

Member | Description
KFX_REL_UNDEFINED_FILE |
KFX_REL_TEXT |


Kofax Capture API Reference Guide

Overview

The Kofax Capture API Reference Guide contains the details of each API library needed to customize Kofax Capture. This guide assumes you have a detailed understanding of Kofax Capture and the development environments used to implement the APIs described here. This API Reference Guide is designed to be used along with the Kofax Capture Developer's Guide as the primary tools for customization development.

The following API libraries are described in this guide:

Project Description
Kofax Capture Module Type Library

The Kofax Capture Module Type Library is used to add custom panels, menu items and import applications to the Scan, Quality Control, Validation, and/or Verification modules.

Object name: AscentCaptureModule
File name: ACModule.dll

Kofax Capture Admin Module Library

The Kofax Capture Admin Module Library is used to create custom panels for the Administration module or Setup OCXs for custom modules. You can also use this library to create Setup OCXs for workflow agents.

Object name: AscentCaptureAdminMod
File name: ACAdMod.dll

Kofax Capture Document Access

Kofax Capture Document Access is the control that allows you to integrate a custom module into your Kofax Capture installation. Kofax Capture Document Access makes it possible for the custom module to access batch information from Kofax Capture. Likewise, it allows your custom module to relay batch information from the custom module to Kofax Capture.

Object name: ACDB
File name: DBLite.dll

Kofax Capture Optimized Custom Module API

The Kofax Capture Optimized Custom Module is an easy-to-use custom module interface that allows fast retrieval and selective update of data. This API provides a mechanism that allows use of the Kofax Capture Document Access dynamic-link library (DBLite) to select and open a batch.

Object name: DBLiteOpt
File name: DBLiteOpt.dll

Kofax Capture Custom Workflow Interface

The Kofax Capture Custom Workflow Interface is used by workflow agents as batches are closed by modules.

Object name: ACWFLib
File name: ACWFLib.dll

Kofax Capture Release Type Library

The Kofax Capture Release Type Library is used to create custom release scripts.

Object name: AscentRelease
File name: AscRel.dll
Kofax Capture .NET Scripting Library

The Kofax Capture .NET Scripting Library is used to create VB .NET custom scripts for Validation and Recognition modules.

Object name: ScriptInterface
File name: ScriptInterface.dll
Kofax Capture CaptureInfo The Kofax.SDK.CaptureInfo assembly is used to allow customizations to query the user selected language. See here for some examples .

The following samples shipped with Kofax Capture are now localized. The developer can look at them to see how to write a localizable component.

Database Export Connector

Text Export Connector

Object name: CaptureInfo
File name: Kofax.SDK.CaptureInfo.dll

The Fluent UI and the API

Kofax Capture 10 has a new user interface in many of its modules. This interface is similar to the interface used in recent versions of Microsoft Office, and is called the Fluent UI. The Fluent UI is characterized by a new set of elements (ribbons, tabs, groups, and commands).

The Fluent UI also supports right-click (context) menus, which are unchanged from prior interface approaches. See the Kofax Capture Help for more information on the various elements of the Kofax Capture implementation of the Fluent UI.

Keep the following in mind when developing customizations for the Fluent UI.

Legacy/Context Menu Usage | Fluent UI Usage/Comments
menubar | Ribbon An application window can have only one Ribbon.
menubar text /menu | Tab The tabs typically appear at the top of the Ribbon. There is no Help tab, instead there is around Help button.
 | Group A “group” is an organizing container for commands (menu items) and belongs to a tab. A tab may have many groups. Groups perform a function similar to divider bars in menus, but there is no programmatic mapping from a menu based interface to groups. A tab may have many groups. When using the existing API, a group called “Menu Items” is automatically created. However, in the new AddMenuEx method, the last strGroupName parameter specifies the text to be used for the group name.
menu text/menu item | Command Commands can have downward pointing arrows that reveal a window with related commands. For example, the Paste command in Word opens to show several options for pasting text.

To maintain backwards compatibility, the names and behaviors and documentation of existing methods and other API and customization elements are unchanged.

For example, the description, behavior and syntax of the SelectMenuItem method are unchanged. In a Ribbon tab, it causes the command (formerly menu item) with the specified resource ID to be triggered. In a context menu it causes the menu item with the specified resource ID to be triggered.

As another example, the ShowMenu method shows or hides a tab in the Ribbon. In the context of the Fluent UI, the strMenuBarText parameter is ignored. The tab label is determined by the strMenuText parameter.

Note that unless a method or other API element is specifically restricted to context menus, its documented functionality may apply to either the Fluent UI or a context menu (depending on the context of the application code).

Several new methods have been added that directly support the capabilities of the Fluent UI. It is strongly suggested that when updating or creating new customizations, these new methods be employed. More information about these new items may be found in the Kofax Capture API Reference Guide.


%%PageItemTitle%%

Enumerations Members

Enumerations Object

For a list of all members defined in this module, see Enumerations members.

See Also

Enumerations Members


%%PageItemTitle%% $$Members$$

Enumerations Overview

Enumerations Object Members

See Also

Enumerations Overview


Kofax Capture API Reference Guide

Localized Custom Module and Export Connector Names

The AEX or INF file allows a customization to register its component name and description in multiple languages.

The following example shows how the KTM Validation module would specify its name and language in German and French languages:

[Modules]
KTM Validation

[KTM Validation]
ModuleID=LCI.Validation
Description=The Validation module is used to review extraction results for an entire document and to ensure that all information is valid. Documents can also be marked for online learning.
Version=4.5
Languages= LCI.Validation-Languages
…

[LCI.Validation-Languages]
LCI.Validation-de
LCI.Validation-fr

[LCI.Validation-de]
CultureInfoName=de
Name=KTM Validatie
Description=De validatie-module wordt gebruikt voor de winning resultaten verslag voor een volledig document en ervoor te zorgen dat alle informatie geldig is. Documenten kunnen ook worden gemarkeerd voor online leren.

[LCI.Validation-fr]
CultureInfoName=fr
Name=KTM Validation
Description=Le module de Validation est utilisé pour reconsidérer des résultats d'extraction pour un document entier et garantir que tous les informations sont valides. Les documents peuvent aussi être marqués pour l'apprentissage en ligne.

The following example shows how the Text export connector would specify its name and in German and French:

[Scripts]
Ascent Capture Text

[Ascent Capture Text]
SetupModule=.\Kofax.TextRelease.dll
SetupProgID=TextRel.kfxreleasesetupscript
SetupVersion=9.0
ReleaseModule=.\Kofax.TextRelease.dll
ReleaseProgID=TextRel.kfxreleasescript
ReleaseVersion=9.0
SupportsNonImageFiles=True
SupportsKofaxPDF=True
RemainLoaded=True
SupportsOriginalFileName=True
SupportsMultipleInstances=True
PathSubstitution=ASCII File Name
DisplayName=Text Export Connector
Languages=Ascent Capture Text-Languages
…

[Ascent Capture Text-Languages]
de
fr

[de]
CultureInfoName=de
DisplayName=Kofax CaptureText

[fr]
CultureInfoName=fr
DisplayName=Kofax Capture Texte

Copyright © 2011, Kofax Image Products, Inc. All rights reserved.