Kofax Capture API Reference Overview

Kofax Capture API Reference
Kofax Capture API Reference Overview

Welcome to the Kofax Capture API Reference, which gives you details about the API libraries used to customize Kofax Capture.

This reference assumes that you have a detailed understanding of Kofax Capture and the development environment required to implement the API libraries described here.

The table lists the API libraries included in this guide, along with the Kofax Capture Export Type Library that is documented separately, as noted in the table.

Project | Namespace | Description
Kofax Capture Module .NET Type Library (Kofax.Capture.CaptureModule.dll) | Kofax.Capture.CaptureModule Namespace Kofax.Capture.CaptureModule.InteropServices Namespace | Used to create custom OCX panels for the Scan, Quality Control, Validation, and Verification modules.
Kofax Capture Administration .NET Type Library (Kofax.Capture.AdminModule.dll) | Kofax.Capture.AdminModule Namespace Kofax.Capture.AdminModule.InteropServices Namespace | Used to create custom panels for the Administration module or Setup OCXs for custom modules or workflow agents.
Kofax Capture Custom Module .NET Type Interface Library (Kofax.Capture.SDK.CustomModule.dll) | Kofax.Capture.SDK.CustomModule Namespace | Provides .NET type interfaces used to integrate a custom module into your Kofax Capture installation. Implementation of this interface library is used with the Kofax Capture Document Access .NET Type implementation. Also referred to as the DBLite .NET Interface Library.
Kofax Capture Document Access .NET Type Implementation Library (Kofax.DBLite.dll) | Kofax.Capture.DBLite Namespace | Used to integrate a custom module into your Kofax Capture installation. Kofax Capture Document Access .NET Type Implementation Library makes it possible for the custom module to access batch informatiofrom Kofax Capture. This library also allows your custom module to relay batch information from the custom module to Kofax Capture. Also referred to as the DBLite .NET Implementation Library.
Kofax Capture Optimized Custom Module .NET Type Interface Library (Kofax.Capture.SDK.Data.dll) | Kofax.Capture.SDK.Data Namespace | Provides .NET type interfaces used for fast retrieval and selective update of data. Implementation of this interface library is used with the Kofax Capture Optimized Custom Module .NET Type Implementation Library. Also referred to as the DbLiteOpt .NET Interface Library.
Kofax Capture Optimized Custom Module .NET Type Implementation Library (Kofax.DBLiteOpt.dll) | Kofax.Capture.DBLiteOpt Namespace | An easy-to-use custom module interface used for fast retrieval and selective update of data. This API provides a mechanism that allows use of the Kofax Capture Document Access .NET Type Implementation Library dynamic-link library (Kofax.DBLite.dll) to select and open a batch. Also referred to as the DBLite Opt .NET Implementation Library.
Kofax Capture Custom Workflow .NET Type Interface Library (Kofax.Capture.SDK.Workflow.dll) | Kofax.Capture.SDK.Workflow Namespace | Provides interfaces used by workflow agents to close batches by modules. Implementation of this interface library is used with the Kofax Capture Custom Workflow .NET Type Implementation Library. Also referred to as the Workflow .NET Interface Library.
Kofax Capture Custom Workflow .NET Type Implementation Library (Kofax.Capture.ACWFlib.dll) | Kofax.Capture.ACWFLib Namespace | An implementation of Kofax Capture Custom Workflow .NET Type Interface Library. Also referred to as the Workflow .NET Implementation Library.
Kofax Capture .NET Scripting Library (ScriptInterface.dll) | Kofax.AscentCapture.Scripting Namespace Kofax.AscentCapture.NetScripting Namespace | Used to create VB.NET custom field, validation, and recognition scripts.
Kofax Capture Information Type Library (Kofax.SDK.CaptureInfo.dll) | Kofax.SDK.CaptureInfo Namespace | Provides classes and methods to access the selected language and custom theme for Kofax Capture. Also supports the ability for custom components to display in the same language as the standard Kofax Capture modules.
Kofax Capture Export Type Library (AscRel.dll) (Kofax.ReleaseLib.Interop.dll) | Kofax.ReleaseLib Namespace | Used to create custom export connectors. This library is available in C++ rather than .NET. For details, see the Kofax Capture Export Type Library API Reference, APIRefExport.chm, which is documented separately (on your installation media, go to Documentation\Help\APIRef).

© 2008-2017 Kofax. All rights reserved.


Kofax.AscentCapture.NetScripting Namespace

Kofax.AscentCapture.NetScripting Namespace

Provides base Document, Folder, Field and Recognition classes for customization scripts to work on.

Classes in this namespace are designed to work with the Tungsten Capture Module .NET Type Library (Kofax.Capture.CaptureModule.dll).

Classes
 | Class | Description
Public class | BatchEventArgs | The event argument class used in BatchLoading and BatchUnloading events.
Public class | DocumentValidationScript | Base class for the document validation script.
Public class | FatalErrorException | Signals a fatal error. This exception can be thrown in validation, recognition, and field scripts.
Public class | FieldScript | Base class for the field validation script.
Public class | FolderValidationScript | Base class for the folder validation script.
Public class | FormatFieldEventArgs | This class represents the event arguments for the FieldScript.FieldFormatting event.
Public class | IndexFieldVariableAttribute | This is an attribute class used to indicate that the current field in the class is an index field in the document validation script, or folder validation script.
Public class | PostDocumentEventArgs | This class represents the event arguments for the DocumentValidationScript.DocumentPostProcessing event.
Public class | PostFieldEventArgs | This class represents the event arguments for the FieldScript.FieldPostProcessing event.
Public class | PostFolderEventArgs | This class represents the event arguments for the FolderValidationScript.FolderPostProcessing event.
Public class | PostRecognitionEventArgs | This class represents the event arguments for the RecognitionScript.RecognitionPostProcessing event.
Public class | PreDocumentEventArgs | This class represents the event arguments for the DocumentValidationScript.DocumentPreProcessing event.
Public class | PreFieldEventArgs | This class represents the event arguments for the FieldScript.FieldPreProcessing event.
Public class | PreFolderEventArgs | This class represents the event arguments for the FolderValidationScript.FolderPreProcessing event.
Public class | PreRecognitionEventArgs | This class represents the event arguments for the RecognitionScript.RecognitionPreProcessing event.
Public class | RecognitionScript | Base class for the recognition script.
Public class | RejectAndSkipDocumentException | Defines reject and skip a document error. This exception is to be thrown in document validation scripts only. It is treated as a FatalErrorException if thrown from other script types. Note: Folder validation script doesn’t have an equivalent exception, as folder cannot be rejected.
Public class | ScriptUtils | Supply the validation and formatting the number methods
Public class | SuppressFieldEventsOnDocCloseAttribute |
Public class | ValidationErrorException | Signals a validation error. This exception is to be thrown in validation scripts only. It is treated as a FatalErrorException if the Recognition Server receives this exception.
Delegates
 | Delegate | Description
Public delegate | BatchEventHandler | Defines callback for the BatchLoading and BatchUnloading events.
Public delegate | FormatFieldEventHandler | Defines callback for the FieldFormatting event.
Public delegate | PostDocumentEventHandler | Defines callback for the DocumentPostProcessing event.
Public delegate | PostFieldEventHandler | Defines callback for the FieldPostProcessing event.
Public delegate | PostFolderEventHandler | Defines callback for the FolderPostProcessing event.
Public delegate | PostRecognitionEventHandler | Defines callback for RecognitionPostProcessing event.
Public delegate | PreDocumentEventHandler | Defines callback for the DocumentPreProcessing event.
Public delegate | PreFieldEventHandler | Defines callback for the FieldPreProcessing event.
Public delegate | PreFolderEventHandler | Defines callback for the FolderPreProcessing event.
Public delegate | PreRecognitionEventHandler | Defines callback for RecognitionPreProcessing event.
Public delegate | RecognitionBatchLoadingHandler | Defines callback for RecognitionBatchLoading event.
Public delegate | RecognitionBatchUnloadingHandler | Defines callback for RecognitionBatchUnloading event.
Enumerations
 | Enumeration | Description
Public enumeration | ApplicationEnum | This is an enumeration type that indicates which application is executing the script.
Public enumeration | PreFieldEventArgsSkipModeEnum | Skips mode enumeration.
Remarks


ApplicationEnum Enumeration

ApplicationEnum Enumeration

This is an enumeration type that indicates which application is executing the script.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public enum ApplicationEnum
Public Enumeration ApplicationEnum
Members
Member name | Value | Description
Validation | 1 | Validation module.
Verification | 2 | Verification module.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


BatchEventArgs Class

BatchEventArgs Class

The event argument class used in BatchLoading and BatchUnloading events.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingBatchEventArgs

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class BatchEventArgs
Public NotInheritable Class BatchEventArgs

The BatchEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BatchEventArgs | Initializes a new instance of the Kofax.AscentCapture.NetScripting.BatchEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Batch | Gets the Batch object.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


BatchEventArgs Constructor

BatchEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.NetScripting.BatchEventArgs class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public BatchEventArgs(
    IBatch oBatch
)
Public Sub New (
    oBatch As IBatch
)

Parameters

oBatch
Type: Kofax.Capture.CaptureModule.InteropServicesIBatch
Batch object.
See Also

Reference

BatchEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


BatchEventArgs Methods

BatchEventArgs Methods

The BatchEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


BatchEventArgs Properties

BatchEventArgs Properties

The BatchEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Batch | Gets the Batch object.
Top
See Also

Reference

BatchEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


BatchEventArgs.Batch Property

BatchEventArgsBatch Property

Gets the Batch object.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch Batch { get; }
Public ReadOnly Property Batch As IBatch
    Get

Property Value

Type: IBatch
See Also

Reference

BatchEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


BatchEventHandler Delegate

BatchEventHandler Delegate

Defines callback for the BatchLoading and BatchUnloading events.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void BatchEventHandler(
    Object sender,
    BatchEventArgs e
)
Public Delegate Sub BatchEventHandler (
    sender As Object,
    e As BatchEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.NetScriptingBatchEventArgs
The Kofax.AscentCapture.NetScripting.BatchEventArgs object that contains the Kofax.Capture.CaptureModule.InteropServices.Batch object.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


DocumentValidationScript Class

DocumentValidationScript Class

Base class for the document validation script.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingDocumentValidationScript

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public abstract class DocumentValidationScript
Public MustInherit Class DocumentValidationScript

The DocumentValidationScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Application | Gets the application executing the script.
Public property | LocaleName | Gets the locale name.
Public property | UserID | Gets the User ID.
Top
Events
 | Name | Description
Public event | BatchLoading | Called when a batch is opened.
Public event | BatchUnloading | Called when a batch is closed.
Public event | DocumentPostProcessing | Called after each document is closed.
Public event | DocumentPreProcessing | Called each time a new document is opened.
Top
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


DocumentValidationScript Methods

DocumentValidationScript Methods

The DocumentValidationScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


DocumentValidationScript Properties

DocumentValidationScript Properties

The DocumentValidationScript type exposes the following members.

Properties
 | Name | Description
Public property | Application | Gets the application executing the script.
Public property | LocaleName | Gets the locale name.
Public property | UserID | Gets the User ID.
Top
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


DocumentValidationScript.Application Property

DocumentValidationScriptApplication Property

Gets the application executing the script.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ApplicationEnum Application { get; }
Public ReadOnly Property Application As ApplicationEnum
    Get

Property Value

Type: ApplicationEnum
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


DocumentValidationScript.LocaleName Property

DocumentValidationScriptLocaleName Property

Gets the locale name.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string LocaleName { get; }
Public ReadOnly Property LocaleName As String
    Get

Property Value

Type: String
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


DocumentValidationScript.UserID Property

DocumentValidationScriptUserID Property

Gets the User ID.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string UserID { get; }
Public ReadOnly Property UserID As String
    Get

Property Value

Type: String
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


DocumentValidationScript Events

DocumentValidationScript Events

The DocumentValidationScript type exposes the following members.

Events
 | Name | Description
Public event | BatchLoading | Called when a batch is opened.
Public event | BatchUnloading | Called when a batch is closed.
Public event | DocumentPostProcessing | Called after each document is closed.
Public event | DocumentPreProcessing | Called each time a new document is opened.
Top
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


DocumentValidationScript.BatchLoading Event

DocumentValidationScriptBatchLoading Event

Called when a batch is opened.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event BatchEventHandler BatchLoading
Public Event BatchLoading As BatchEventHandler

Value

Type: Kofax.AscentCapture.NetScriptingBatchEventHandler
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


DocumentValidationScript.BatchUnloading Event

DocumentValidationScriptBatchUnloading Event

Called when a batch is closed.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event BatchEventHandler BatchUnloading
Public Event BatchUnloading As BatchEventHandler

Value

Type: Kofax.AscentCapture.NetScriptingBatchEventHandler
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


DocumentValidationScript.DocumentPostProcessing Event

DocumentValidationScriptDocumentPostProcessing Event

Called after each document is closed.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PostDocumentEventHandler DocumentPostProcessing
Public Event DocumentPostProcessing As PostDocumentEventHandler

Value

Type: Kofax.AscentCapture.NetScriptingPostDocumentEventHandler
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


DocumentValidationScript.DocumentPreProcessing Event

DocumentValidationScriptDocumentPreProcessing Event

Called each time a new document is opened.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PreDocumentEventHandler DocumentPreProcessing
Public Event DocumentPreProcessing As PreDocumentEventHandler

Value

Type: Kofax.AscentCapture.NetScriptingPreDocumentEventHandler
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


FatalErrorException Class

FatalErrorException Class

Signals a fatal error. This exception can be thrown in validation, recognition, and field scripts.

Inheritance Hierarchy
SystemObject
SystemException
Kofax.AscentCapture.NetScriptingFatalErrorException

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class FatalErrorException : Exception
Public Class FatalErrorException
    Inherits Exception

The FatalErrorException type exposes the following members.

Constructors
 | Name | Description
Public method | FatalErrorException | Initializes a new instance of the Kofax.AscentCapture.NetScripting.FatalErrorException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)
Top
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


FatalErrorException Constructor

FatalErrorException Constructor

Initializes a new instance of the Kofax.AscentCapture.NetScripting.FatalErrorException class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public FatalErrorException(
    string strErrorMessage
)
Public Sub New (
    strErrorMessage As String
)

Parameters

strErrorMessage
Type: SystemString
Error message.
See Also

Reference

FatalErrorException Class
Kofax.AscentCapture.NetScripting Namespace


FatalErrorException Methods

FatalErrorException Methods

The FatalErrorException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

FatalErrorException Class
Kofax.AscentCapture.NetScripting Namespace


FatalErrorException Properties

FatalErrorException Properties

The FatalErrorException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)
Top
See Also

Reference

FatalErrorException Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript Class

FieldScript Class

Base class for the field validation script.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingFieldScript

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class FieldScript
Public Class FieldScript

The FieldScript type exposes the following members.

Constructors
 | Name | Description
Public method | FieldScript | Default constructor.
Top
Methods
 | Name | Description
Public method | DefaultFieldFormatting | Call this method in the FieldFormatting event handler to perform the default formatting of the current index field. The current index field is formatted based on its data type and the formatted value is returned if it is formatted successfully. Otherwise, the current index field value is not formatted and returned.
Public method | DefaultFieldPostProcessing | Calls this method in the FieldPostProcessing event handler to perform the default post-field processing of the current index field. The current index field is validated based on its data type and a ValidationErrorException is thrown if the validation fails.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Application | Gets the application executing the script.
Public property | BatchField | Gets the BatchField object for the current field.
Public property | IndexField | Gets the IndexField object for the current field.
Public property | LocaleName | Gets the locale name.
Public property | UserID | Gets the User ID.
Top
Events
 | Name | Description
Public event | FieldFormatting | Raised for every field as every other field is exited. Allows the display of a field to differ from the stored value.
Public event | FieldPostProcessing | Raised as the field is exited. Sets e.SaveAndSkipDocument = True to save the field and move to the next document.
Public event | FieldPreProcessing | Raised as the field is entered. Set e.SaveAndSkipField = True to save the field and skip to the field.
Top
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


FieldScript Constructor

FieldScript Constructor

Default constructor.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public FieldScript()
Public Sub New
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript Methods

FieldScript Methods

The FieldScript type exposes the following members.

Methods
 | Name | Description
Public method | DefaultFieldFormatting | Call this method in the FieldFormatting event handler to perform the default formatting of the current index field. The current index field is formatted based on its data type and the formatted value is returned if it is formatted successfully. Otherwise, the current index field value is not formatted and returned.
Public method | DefaultFieldPostProcessing | Calls this method in the FieldPostProcessing event handler to perform the default post-field processing of the current index field. The current index field is validated based on its data type and a ValidationErrorException is thrown if the validation fails.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript.DefaultFieldFormatting Method

FieldScriptDefaultFieldFormatting Method

Call this method in the FieldFormatting event handler to perform the default formatting of the current index field.

The current index field is formatted based on its data type and the formatted value is returned if it is formatted successfully. Otherwise, the current index field value is not formatted and returned.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string DefaultFieldFormatting()
Public Function DefaultFieldFormatting As String

Return Value

Type: String
The formatted value.
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript.DefaultFieldPostProcessing Method

FieldScriptDefaultFieldPostProcessing Method

Calls this method in the FieldPostProcessing event handler to perform the default post-field processing of the current index field.

The current index field is validated based on its data type and a ValidationErrorException is thrown if the validation fails.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DefaultFieldPostProcessing()
Public Sub DefaultFieldPostProcessing
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript Properties

FieldScript Properties

The FieldScript type exposes the following members.

Properties
 | Name | Description
Public property | Application | Gets the application executing the script.
Public property | BatchField | Gets the BatchField object for the current field.
Public property | IndexField | Gets the IndexField object for the current field.
Public property | LocaleName | Gets the locale name.
Public property | UserID | Gets the User ID.
Top
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript.Application Property

FieldScriptApplication Property

Gets the application executing the script.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ApplicationEnum Application { get; }
Public ReadOnly Property Application As ApplicationEnum
    Get

Property Value

Type: ApplicationEnum
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript.BatchField Property

FieldScriptBatchField Property

Gets the BatchField object for the current field.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchField BatchField { get; }
Public ReadOnly Property BatchField As IBatchField
    Get

Property Value

Type: IBatchField
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript.IndexField Property

FieldScriptIndexField Property

Gets the IndexField object for the current field.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexField IndexField { get; }
Public ReadOnly Property IndexField As IIndexField
    Get

Property Value

Type: IIndexField
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript.LocaleName Property

FieldScriptLocaleName Property

Gets the locale name.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string LocaleName { get; }
Public ReadOnly Property LocaleName As String
    Get

Property Value

Type: String
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript.UserID Property

FieldScriptUserID Property

Gets the User ID.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string UserID { get; }
Public ReadOnly Property UserID As String
    Get

Property Value

Type: String
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript Events

FieldScript Events

The FieldScript type exposes the following members.

Events
 | Name | Description
Public event | FieldFormatting | Raised for every field as every other field is exited. Allows the display of a field to differ from the stored value.
Public event | FieldPostProcessing | Raised as the field is exited. Sets e.SaveAndSkipDocument = True to save the field and move to the next document.
Public event | FieldPreProcessing | Raised as the field is entered. Set e.SaveAndSkipField = True to save the field and skip to the field.
Top
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript.FieldFormatting Event

FieldScriptFieldFormatting Event

Raised for every field as every other field is exited. Allows the display of a field to differ from the stored value.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event FormatFieldEventHandler FieldFormatting
Public Event FieldFormatting As FormatFieldEventHandler

Value

Type: Kofax.AscentCapture.NetScriptingFormatFieldEventHandler
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript.FieldPostProcessing Event

FieldScriptFieldPostProcessing Event

Raised as the field is exited. Sets e.SaveAndSkipDocument = True to save the field and move to the next document.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PostFieldEventHandler FieldPostProcessing
Public Event FieldPostProcessing As PostFieldEventHandler

Value

Type: Kofax.AscentCapture.NetScriptingPostFieldEventHandler
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FieldScript.FieldPreProcessing Event

FieldScriptFieldPreProcessing Event

Raised as the field is entered. Set e.SaveAndSkipField = True to save the field and skip to the field.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PreFieldEventHandler FieldPreProcessing
Public Event FieldPreProcessing As PreFieldEventHandler

Value

Type: Kofax.AscentCapture.NetScriptingPreFieldEventHandler
See Also

Reference

FieldScript Class
Kofax.AscentCapture.NetScripting Namespace


FolderValidationScript Class

FolderValidationScript Class

Base class for the folder validation script.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingFolderValidationScript

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public abstract class FolderValidationScript
Public MustInherit Class FolderValidationScript

The FolderValidationScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Application | Gets the application executing the script.
Public property | LocaleName | Gets the locale name.
Public property | UserID | Gets the user ID.
Top
Events
 | Name | Description
Public event | BatchLoading | Called when a batch is opened.
Public event | BatchUnloading | Called when a batch is closed.
Public event | FolderPostProcessing | Called after each folder is closed.
Public event | FolderPreProcessing | Called each time a new folder is opened.
Top
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


FolderValidationScript Methods

FolderValidationScript Methods

The FolderValidationScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


FolderValidationScript Properties

FolderValidationScript Properties

The FolderValidationScript type exposes the following members.

Properties
 | Name | Description
Public property | Application | Gets the application executing the script.
Public property | LocaleName | Gets the locale name.
Public property | UserID | Gets the user ID.
Top
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


FolderValidationScript.Application Property

FolderValidationScriptApplication Property

Gets the application executing the script.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ApplicationEnum Application { get; }
Public ReadOnly Property Application As ApplicationEnum
    Get

Property Value

Type: ApplicationEnum
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


FolderValidationScript.LocaleName Property

FolderValidationScriptLocaleName Property

Gets the locale name.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string LocaleName { get; }
Public ReadOnly Property LocaleName As String
    Get

Property Value

Type: String
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


FolderValidationScript.UserID Property

FolderValidationScriptUserID Property

Gets the user ID.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string UserID { get; }
Public ReadOnly Property UserID As String
    Get

Property Value

Type: String
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


FolderValidationScript Events

FolderValidationScript Events

The FolderValidationScript type exposes the following members.

Events
 | Name | Description
Public event | BatchLoading | Called when a batch is opened.
Public event | BatchUnloading | Called when a batch is closed.
Public event | FolderPostProcessing | Called after each folder is closed.
Public event | FolderPreProcessing | Called each time a new folder is opened.
Top
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


FolderValidationScript.BatchLoading Event

FolderValidationScriptBatchLoading Event

Called when a batch is opened.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event BatchEventHandler BatchLoading
Public Event BatchLoading As BatchEventHandler

Value

Type: Kofax.AscentCapture.NetScriptingBatchEventHandler
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


FolderValidationScript.BatchUnloading Event

FolderValidationScriptBatchUnloading Event

Called when a batch is closed.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event BatchEventHandler BatchUnloading
Public Event BatchUnloading As BatchEventHandler

Value

Type: Kofax.AscentCapture.NetScriptingBatchEventHandler
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


FolderValidationScript.FolderPostProcessing Event

FolderValidationScriptFolderPostProcessing Event

Called after each folder is closed.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PostFolderEventHandler FolderPostProcessing
Public Event FolderPostProcessing As PostFolderEventHandler

Value

Type: Kofax.AscentCapture.NetScriptingPostFolderEventHandler
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


FolderValidationScript.FolderPreProcessing Event

FolderValidationScriptFolderPreProcessing Event

Called each time a new folder is opened.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PreFolderEventHandler FolderPreProcessing
Public Event FolderPreProcessing As PreFolderEventHandler

Value

Type: Kofax.AscentCapture.NetScriptingPreFolderEventHandler
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.NetScripting Namespace


FormatFieldEventArgs Class

FormatFieldEventArgs Class

This class represents the event arguments for the FieldScript.FieldFormatting event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingFormatFieldEventArgs

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class FormatFieldEventArgs
Public NotInheritable Class FormatFieldEventArgs

The FormatFieldEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FormatFieldEventArgs(IBatchField, String) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.FormatFieldEventArgs class.
Public method | FormatFieldEventArgs(IIndexField, String) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.FormatFieldEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DisplayValue | Gets or sets the current display value of this index field.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


FormatFieldEventArgs Constructor

FormatFieldEventArgs Constructor
Overload List
 | Name | Description
Public method | FormatFieldEventArgs(IBatchField, String) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.FormatFieldEventArgs class.
Public method | FormatFieldEventArgs(IIndexField, String) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.FormatFieldEventArgs class.
Top
See Also

Reference

FormatFieldEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


FormatFieldEventArgs Constructor (IBatchField, String)

FormatFieldEventArgs Constructor (IBatchField, String)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.NetScripting.FormatFieldEventArgs class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public FormatFieldEventArgs(
    IBatchField oBatchField,
    string strDisplayValue
)
Public Sub New (
    oBatchField As IBatchField,
    strDisplayValue As String
)

Parameters

oBatchField
Type: Kofax.Capture.CaptureModule.InteropServicesIBatchField
IndexField object.
strDisplayValue
Type: SystemString
Display value.
See Also

Reference

FormatFieldEventArgs Class
FormatFieldEventArgs Overload
Kofax.AscentCapture.NetScripting Namespace


FormatFieldEventArgs Constructor (IIndexField, String)

FormatFieldEventArgs Constructor (IIndexField, String)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.NetScripting.FormatFieldEventArgs class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public FormatFieldEventArgs(
    IIndexField oIndexField,
    string strDisplayValue
)
Public Sub New (
    oIndexField As IIndexField,
    strDisplayValue As String
)

Parameters

oIndexField
Type: Kofax.Capture.CaptureModule.InteropServicesIIndexField
IndexField object.
strDisplayValue
Type: SystemString
Display value.
See Also

Reference

FormatFieldEventArgs Class
FormatFieldEventArgs Overload
Kofax.AscentCapture.NetScripting Namespace


FormatFieldEventArgs Methods

FormatFieldEventArgs Methods

The FormatFieldEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FormatFieldEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


FormatFieldEventArgs Properties

FormatFieldEventArgs Properties

The FormatFieldEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DisplayValue | Gets or sets the current display value of this index field.
Top
See Also

Reference

FormatFieldEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


FormatFieldEventArgs.DisplayValue Property

FormatFieldEventArgsDisplayValue Property

Gets or sets the current display value of this index field.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string DisplayValue { get; set; }
Public Property DisplayValue As String
    Get
    Set

Property Value

Type: String
See Also

Reference

FormatFieldEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


FormatFieldEventHandler Delegate

FormatFieldEventHandler Delegate

Defines callback for the FieldFormatting event.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void FormatFieldEventHandler(
    Object sender,
    FormatFieldEventArgs e
)
Public Delegate Sub FormatFieldEventHandler (
    sender As Object,
    e As FormatFieldEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.NetScriptingFormatFieldEventArgs
The Kofax.AscentCapture.NetScripting.FormatFieldEventArgs object that contains the Kofax.Capture.CaptureModule.InteropServices.IndexField object and DisplayValue property. Handles this event to format the current index field value.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


IndexFieldVariableAttribute Class

IndexFieldVariableAttribute Class

This is an attribute class used to indicate that the current field in the class is an index field in the document validation script, or folder validation script.

Inheritance Hierarchy
SystemObject
SystemAttribute
Kofax.AscentCapture.NetScriptingIndexFieldVariableAttribute

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[AttributeUsageAttribute(AttributeTargets.Field)]
public sealed class IndexFieldVariableAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Field)>
Public NotInheritable Class IndexFieldVariableAttribute
    Inherits Attribute

The IndexFieldVariableAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | IndexFieldVariableAttribute | Initializes a new instance of the Kofax.AscentCapture.NetScripting.IndexFieldVariableAttribute class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets the index field name.
Public property | TypeId | (Inherited from Attribute.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | (Inherited from Attribute.)
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


IndexFieldVariableAttribute Constructor

IndexFieldVariableAttribute Constructor

Initializes a new instance of the Kofax.AscentCapture.NetScripting.IndexFieldVariableAttribute class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IndexFieldVariableAttribute(
    string strFieldName
)
Public Sub New (
    strFieldName As String
)

Parameters

strFieldName
Type: SystemString
Index field name.
See Also

Reference

IndexFieldVariableAttribute Class
Kofax.AscentCapture.NetScripting Namespace


IndexFieldVariableAttribute Methods

IndexFieldVariableAttribute Methods

The IndexFieldVariableAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Public method | ToString | (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | (Inherited from Attribute.)
Top
See Also

Reference

IndexFieldVariableAttribute Class
Kofax.AscentCapture.NetScripting Namespace


IndexFieldVariableAttribute Properties

IndexFieldVariableAttribute Properties

The IndexFieldVariableAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the index field name.
Public property | TypeId | (Inherited from Attribute.)
Top
See Also

Reference

IndexFieldVariableAttribute Class
Kofax.AscentCapture.NetScripting Namespace


IndexFieldVariableAttribute.Name Property

IndexFieldVariableAttributeName Property

Gets the index field name.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

IndexFieldVariableAttribute Class
Kofax.AscentCapture.NetScripting Namespace


PostDocumentEventArgs Class

PostDocumentEventArgs Class

This class represents the event arguments for the DocumentValidationScript.DocumentPostProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingPostDocumentEventArgs

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PostDocumentEventArgs
Public NotInheritable Class PostDocumentEventArgs

The PostDocumentEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PostDocumentEventArgs | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PostDocumentEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DataAccepted | Indicates whether the operator accepted or rejected the data.
Public property | Document | Gets the Document object.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PostDocumentEventArgs Constructor

PostDocumentEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.NetScripting.PostDocumentEventArgs class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PostDocumentEventArgs(
    IDocument oDocument,
    bool bDataAccepted
)
Public Sub New (
    oDocument As IDocument,
    bDataAccepted As Boolean
)

Parameters

oDocument
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
Document object.
bDataAccepted
Type: SystemBoolean
Whether the data is accepted.
See Also

Reference

PostDocumentEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostDocumentEventArgs Methods

PostDocumentEventArgs Methods

The PostDocumentEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PostDocumentEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostDocumentEventArgs Properties

PostDocumentEventArgs Properties

The PostDocumentEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DataAccepted | Indicates whether the operator accepted or rejected the data.
Public property | Document | Gets the Document object.
Top
See Also

Reference

PostDocumentEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostDocumentEventArgs.DataAccepted Property

PostDocumentEventArgsDataAccepted Property

Indicates whether the operator accepted or rejected the data.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool DataAccepted { get; }
Public ReadOnly Property DataAccepted As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PostDocumentEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostDocumentEventArgs.Document Property

PostDocumentEventArgsDocument Property

Gets the Document object.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocument Document { get; }
Public ReadOnly Property Document As IDocument
    Get

Property Value

Type: IDocument
See Also

Reference

PostDocumentEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostDocumentEventHandler Delegate

PostDocumentEventHandler Delegate

Defines callback for the DocumentPostProcessing event.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PostDocumentEventHandler(
    Object sender,
    PostDocumentEventArgs e
)
Public Delegate Sub PostDocumentEventHandler (
    sender As Object,
    e As PostDocumentEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.NetScriptingPostDocumentEventArgs
The Kofax.AscentCapture.NetScripting.PostDocumentEventArgs object that contains the Kofax.Capture.CaptureModule.InteropServices.IDocument object. Handles this event to perform cleanup before the document is closed.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PostFieldEventArgs Class

PostFieldEventArgs Class

This class represents the event arguments for the FieldScript.FieldPostProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingPostFieldEventArgs

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PostFieldEventArgs
Public NotInheritable Class PostFieldEventArgs

The PostFieldEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PostFieldEventArgs(IBatchField, String) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PostFieldEventArgs class.
Public method | PostFieldEventArgs(IIndexField, String) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PostFieldEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PreviousValue | Gets the value entered when the validation operator tabs out of the field.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PostFieldEventArgs Constructor

PostFieldEventArgs Constructor
Overload List
 | Name | Description
Public method | PostFieldEventArgs(IBatchField, String) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PostFieldEventArgs class.
Public method | PostFieldEventArgs(IIndexField, String) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PostFieldEventArgs class.
Top
See Also

Reference

PostFieldEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostFieldEventArgs Constructor (IBatchField, String)

PostFieldEventArgs Constructor (IBatchField, String)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.NetScripting.PostFieldEventArgs class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PostFieldEventArgs(
    IBatchField oIndexField,
    string strEnteredValue
)
Public Sub New (
    oIndexField As IBatchField,
    strEnteredValue As String
)

Parameters

oIndexField
Type: Kofax.Capture.CaptureModule.InteropServicesIBatchField
IndexField object.
strEnteredValue
Type: SystemString
Entered value.
See Also

Reference

PostFieldEventArgs Class
PostFieldEventArgs Overload
Kofax.AscentCapture.NetScripting Namespace


PostFieldEventArgs Constructor (IIndexField, String)

PostFieldEventArgs Constructor (IIndexField, String)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.NetScripting.PostFieldEventArgs class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PostFieldEventArgs(
    IIndexField oIndexField,
    string strEnteredValue
)
Public Sub New (
    oIndexField As IIndexField,
    strEnteredValue As String
)

Parameters

oIndexField
Type: Kofax.Capture.CaptureModule.InteropServicesIIndexField
IndexField object.
strEnteredValue
Type: SystemString
Entered value.
See Also

Reference

PostFieldEventArgs Class
PostFieldEventArgs Overload
Kofax.AscentCapture.NetScripting Namespace


PostFieldEventArgs Methods

PostFieldEventArgs Methods

The PostFieldEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PostFieldEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostFieldEventArgs Properties

PostFieldEventArgs Properties

The PostFieldEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | PreviousValue | Gets the value entered when the validation operator tabs out of the field.
Top
See Also

Reference

PostFieldEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostFieldEventArgs.PreviousValue Property

PostFieldEventArgsPreviousValue Property

Gets the value entered when the validation operator tabs out of the field.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string PreviousValue { get; }
Public ReadOnly Property PreviousValue As String
    Get

Property Value

Type: String
See Also

Reference

PostFieldEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostFieldEventHandler Delegate

PostFieldEventHandler Delegate

Defines callback for the FieldPostProcessing event.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PostFieldEventHandler(
    Object sender,
    PostFieldEventArgs e
)
Public Delegate Sub PostFieldEventHandler (
    sender As Object,
    e As PostFieldEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.NetScriptingPostFieldEventArgs
The Kofax.AscentCapture.NetScripting.PostFieldEventArgs object that contains the Kofax.Capture.CaptureModule.InteropServices.IndexField object. Handles this event to perform post-field processing.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PostFolderEventArgs Class

PostFolderEventArgs Class

This class represents the event arguments for the FolderValidationScript.FolderPostProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingPostFolderEventArgs

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PostFolderEventArgs
Public NotInheritable Class PostFolderEventArgs

The PostFolderEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PostFolderEventArgs | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PostFolderEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DataAccepted | Indicates whether the operator accepted or rejected the data.
Public property | Folder | Gets the folder object.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PostFolderEventArgs Constructor

PostFolderEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.NetScripting.PostFolderEventArgs class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PostFolderEventArgs(
    IFolder oFolder,
    bool bDataAccepted
)
Public Sub New (
    oFolder As IFolder,
    bDataAccepted As Boolean
)

Parameters

oFolder
Type: Kofax.Capture.CaptureModule.InteropServicesIFolder
Folder object.
bDataAccepted
Type: SystemBoolean
Whether the data is accepted.
See Also

Reference

PostFolderEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostFolderEventArgs Methods

PostFolderEventArgs Methods

The PostFolderEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PostFolderEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostFolderEventArgs Properties

PostFolderEventArgs Properties

The PostFolderEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DataAccepted | Indicates whether the operator accepted or rejected the data.
Public property | Folder | Gets the folder object.
Top
See Also

Reference

PostFolderEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostFolderEventArgs.DataAccepted Property

PostFolderEventArgsDataAccepted Property

Indicates whether the operator accepted or rejected the data.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool DataAccepted { get; }
Public ReadOnly Property DataAccepted As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PostFolderEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostFolderEventArgs.Folder Property

PostFolderEventArgsFolder Property

Gets the folder object.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolder Folder { get; }
Public ReadOnly Property Folder As IFolder
    Get

Property Value

Type: IFolder
See Also

Reference

PostFolderEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostFolderEventHandler Delegate

PostFolderEventHandler Delegate

Defines callback for the FolderPostProcessing event.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PostFolderEventHandler(
    Object sender,
    PostFolderEventArgs e
)
Public Delegate Sub PostFolderEventHandler (
    sender As Object,
    e As PostFolderEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.NetScriptingPostFolderEventArgs
The Kofax.AscentCapture.NetScripting.PostFolderEventArgs object that contains the Kofax.Capture.CaptureModule.InteropServices.Folder object. Handles this event to perform cleanup before the folder is closed.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PostRecognitionEventArgs Class

PostRecognitionEventArgs Class

This class represents the event arguments for the RecognitionScript.RecognitionPostProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingPostRecognitionEventArgs

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PostRecognitionEventArgs
Public NotInheritable Class PostRecognitionEventArgs

The PostRecognitionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PostRecognitionEventArgs | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PostRecognitionEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
Name Description
Public property Confidence

Gets or sets the confidence level of the recognition engine. It is an integer between 0-100, with 100 being the highest confidence. If you perform recognition with a custom engine, you are responsible for setting this value.

Public property ImageFile

Gets the file name of the zone snippet currently being processed. Image processing has already been performed by the time the script gets access to this file. Note that this is a temporary file and is read-only; attempting to modify the file may have unpredictable consequences. The value is empty if the RecognitionScript.ImageFileRequired property is set to False. Otherwise, it contains the image file name.

Public property RegistrationHorizBMU

Gets or sets the horizontal registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). Registration offsets are only produced by the Kofax OCR and Kofax High Performance OCR/ICR engines. If you want to design a custom profile that produces registration offsets, you must derive your custom profile from the profile of one of those engines (you can skip the default engine logic by setting the SaveAndSkip property to True). Registration offsets may be generated by any zone type, but the values are ignored unless the zone is a registration zone. If you are customizing a registration zone and want to guarantee success, the script must have the Value property set to SearchText, Confidence set to 100, and the two offset variables set to a value >= 0. These values default to -1 if the default engine has not yet been run, or does not generate offsets.

Public property RegistrationVertBMU

Gets or sets the vertical registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). See RegistrationHorizBMU property for more information.

Public property SearchText

Gets the search text is the expected search string set in the Administration module for a separation, form identification, or registration zone. Additionally, if the field type for an index zone has exactly one suggested value, and is marked as Force Match, then the search text exposes that value.

Public property Value

Gets or sets the current recognized value. It is null or Nothing in the PreRecognitionEventArgs object and is overwritten in the PostRecognitionEventArgs object by the Kofax recognition engine unless PreRecognitionEventArgs.SaveAndSkip is set to True. It can be modified in the PostRecognitionEventArgs object.

Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PostRecognitionEventArgs Constructor

PostRecognitionEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.NetScripting.PostRecognitionEventArgs class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PostRecognitionEventArgs(
    int nConfidence,
    string strImageFile,
    int nRegistrationHorizBMU,
    int nRegistrationVertBMU,
    string strSearchText,
    string strValue
)
Public Sub New (
    nConfidence As Integer,
    strImageFile As String,
    nRegistrationHorizBMU As Integer,
    nRegistrationVertBMU As Integer,
    strSearchText As String,
    strValue As String
)

Parameters

nConfidence
Type: SystemInt32
Confidence.
strImageFile
Type: SystemString
ImageFile.
nRegistrationHorizBMU
Type: SystemInt32
RegistrationHorizBMU.
nRegistrationVertBMU
Type: SystemInt32
RegistrationVertBMU.
strSearchText
Type: SystemString
SearchText.
strValue
Type: SystemString
Value.
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostRecognitionEventArgs Methods

PostRecognitionEventArgs Methods

The PostRecognitionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostRecognitionEventArgs Properties

PostRecognitionEventArgs Properties

The PostRecognitionEventArgs type exposes the following members.

Properties
Name Description
Public property Confidence

Gets or sets the confidence level of the recognition engine. It is an integer between 0-100, with 100 being the highest confidence. If you perform recognition with a custom engine, you are responsible for setting this value.

Public property ImageFile

Gets the file name of the zone snippet currently being processed. Image processing has already been performed by the time the script gets access to this file. Note that this is a temporary file and is read-only; attempting to modify the file may have unpredictable consequences. The value is empty if the RecognitionScript.ImageFileRequired property is set to False. Otherwise, it contains the image file name.

Public property RegistrationHorizBMU

Gets or sets the horizontal registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). Registration offsets are only produced by the Kofax OCR and Kofax High Performance OCR/ICR engines. If you want to design a custom profile that produces registration offsets, you must derive your custom profile from the profile of one of those engines (you can skip the default engine logic by setting the SaveAndSkip property to True). Registration offsets may be generated by any zone type, but the values are ignored unless the zone is a registration zone. If you are customizing a registration zone and want to guarantee success, the script must have the Value property set to SearchText, Confidence set to 100, and the two offset variables set to a value >= 0. These values default to -1 if the default engine has not yet been run, or does not generate offsets.

Public property RegistrationVertBMU

Gets or sets the vertical registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). See RegistrationHorizBMU property for more information.

Public property SearchText

Gets the search text is the expected search string set in the Administration module for a separation, form identification, or registration zone. Additionally, if the field type for an index zone has exactly one suggested value, and is marked as Force Match, then the search text exposes that value.

Public property Value

Gets or sets the current recognized value. It is null or Nothing in the PreRecognitionEventArgs object and is overwritten in the PostRecognitionEventArgs object by the Kofax recognition engine unless PreRecognitionEventArgs.SaveAndSkip is set to True. It can be modified in the PostRecognitionEventArgs object.

Top
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostRecognitionEventArgs.Confidence Property

PostRecognitionEventArgsConfidence Property

Gets or sets the confidence level of the recognition engine. It is an integer between 0-100, with 100 being the highest confidence. If you perform recognition with a custom engine, you are responsible for setting this value.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Confidence { get; set; }
Public Property Confidence As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostRecognitionEventArgs.ImageFile Property

PostRecognitionEventArgsImageFile Property

Gets the file name of the zone snippet currently being processed. Image processing has already been performed by the time the script gets access to this file. Note that this is a temporary file and is read-only; attempting to modify the file may have unpredictable consequences. The value is empty if the RecognitionScript.ImageFileRequired property is set to False. Otherwise, it contains the image file name.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ImageFile { get; }
Public ReadOnly Property ImageFile As String
    Get

Property Value

Type: String
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostRecognitionEventArgs.RegistrationHorizBMU Property

PostRecognitionEventArgsRegistrationHorizBMU Property

Gets or sets the horizontal registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). Registration offsets are only produced by the Kofax OCR and Kofax High Performance OCR/ICR engines. If you want to design a custom profile that produces registration offsets, you must derive your custom profile from the profile of one of those engines (you can skip the default engine logic by setting the SaveAndSkip property to True). Registration offsets may be generated by any zone type, but the values are ignored unless the zone is a registration zone. If you are customizing a registration zone and want to guarantee success, the script must have the Value property set to SearchText, Confidence set to 100, and the two offset variables set to a value >= 0. These values default to -1 if the default engine has not yet been run, or does not generate offsets.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int RegistrationHorizBMU { get; set; }
Public Property RegistrationHorizBMU As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostRecognitionEventArgs.RegistrationVertBMU Property

PostRecognitionEventArgsRegistrationVertBMU Property

Gets or sets the vertical registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). See RegistrationHorizBMU property for more information.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int RegistrationVertBMU { get; set; }
Public Property RegistrationVertBMU As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostRecognitionEventArgs.SearchText Property

PostRecognitionEventArgsSearchText Property

Gets the search text is the expected search string set in the Administration module for a separation, form identification, or registration zone. Additionally, if the field type for an index zone has exactly one suggested value, and is marked as Force Match, then the search text exposes that value.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string SearchText { get; }
Public ReadOnly Property SearchText As String
    Get

Property Value

Type: String
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostRecognitionEventArgs.Value Property

PostRecognitionEventArgsValue Property

Gets or sets the current recognized value. It is null or Nothing in the PreRecognitionEventArgs object and is overwritten in the PostRecognitionEventArgs object by the Kofax recognition engine unless PreRecognitionEventArgs.SaveAndSkip is set to True. It can be modified in the PostRecognitionEventArgs object.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PostRecognitionEventHandler Delegate

PostRecognitionEventHandler Delegate

Defines callback for RecognitionPostProcessing event.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PostRecognitionEventHandler(
    Object sender,
    PostRecognitionEventArgs e
)
Public Delegate Sub PostRecognitionEventHandler (
    sender As Object,
    e As PostRecognitionEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.NetScriptingPostRecognitionEventArgs
The Kofax.AscentCapture.NetScripting.PostRecognitionEventArgs object containing the recognition information.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PreDocumentEventArgs Class

PreDocumentEventArgs Class

This class represents the event arguments for the DocumentValidationScript.DocumentPreProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingPreDocumentEventArgs

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PreDocumentEventArgs
Public NotInheritable Class PreDocumentEventArgs

The PreDocumentEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PreDocumentEventArgs | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PreDocumentEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AlreadyProcessed | Indicates whether the document is being processed for the first time or if it has already been processed.
Public property | Document | Gets the Document object.
Public property | SaveAndSkip | Gets or sets the SaveAndSkip flag. True indicates that all data fields should be saved and the Validation or Verification module should advance to the next document.Typically used to automatically skip a document that does not need to be validated by an operator (for example, because the confidence level of all the fields is high). The FieldScript.FieldPreProcessing and FieldScript.FieldPostProcessing objects for all remaining fields are not called, but the DocumentValidationScript.DocumentPostProcessing event is called.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PreDocumentEventArgs Constructor

PreDocumentEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.NetScripting.PreDocumentEventArgs class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PreDocumentEventArgs(
    IDocument oDocument,
    bool bAlreadyProcessed
)
Public Sub New (
    oDocument As IDocument,
    bAlreadyProcessed As Boolean
)

Parameters

oDocument
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
Document object.
bAlreadyProcessed
Type: SystemBoolean
Indicates whether the document is already processed.
See Also

Reference

PreDocumentEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreDocumentEventArgs Methods

PreDocumentEventArgs Methods

The PreDocumentEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PreDocumentEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreDocumentEventArgs Properties

PreDocumentEventArgs Properties

The PreDocumentEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AlreadyProcessed | Indicates whether the document is being processed for the first time or if it has already been processed.
Public property | Document | Gets the Document object.
Public property | SaveAndSkip | Gets or sets the SaveAndSkip flag. True indicates that all data fields should be saved and the Validation or Verification module should advance to the next document.Typically used to automatically skip a document that does not need to be validated by an operator (for example, because the confidence level of all the fields is high). The FieldScript.FieldPreProcessing and FieldScript.FieldPostProcessing objects for all remaining fields are not called, but the DocumentValidationScript.DocumentPostProcessing event is called.
Top
See Also

Reference

PreDocumentEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreDocumentEventArgs.AlreadyProcessed Property

PreDocumentEventArgsAlreadyProcessed Property

Indicates whether the document is being processed for the first time or if it has already been processed.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool AlreadyProcessed { get; }
Public ReadOnly Property AlreadyProcessed As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PreDocumentEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreDocumentEventArgs.Document Property

PreDocumentEventArgsDocument Property

Gets the Document object.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocument Document { get; }
Public ReadOnly Property Document As IDocument
    Get

Property Value

Type: IDocument
See Also

Reference

PreDocumentEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreDocumentEventArgs.SaveAndSkip Property

PreDocumentEventArgsSaveAndSkip Property

Gets or sets the SaveAndSkip flag. True indicates that all data fields should be saved and the Validation or Verification module should advance to the next document.Typically used to automatically skip a document that does not need to be validated by an operator (for example, because the confidence level of all the fields is high). The FieldScript.FieldPreProcessing and FieldScript.FieldPostProcessing objects for all remaining fields are not called, but the DocumentValidationScript.DocumentPostProcessing event is called.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SaveAndSkip { get; set; }
Public Property SaveAndSkip As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PreDocumentEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreDocumentEventHandler Delegate

PreDocumentEventHandler Delegate

Defines callback for the DocumentPreProcessing event.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PreDocumentEventHandler(
    Object sender,
    PreDocumentEventArgs e
)
Public Delegate Sub PreDocumentEventHandler (
    sender As Object,
    e As PreDocumentEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.NetScriptingPreDocumentEventArgs
The Kofax.AscentCapture.NetScripting.PreDocumentEventArgs object that contains the Kofax.Capture.CaptureModule.InteropServices.IDocument object.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PreFieldEventArgs Class

PreFieldEventArgs Class

This class represents the event arguments for the FieldScript.FieldPreProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingPreFieldEventArgs

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PreFieldEventArgs
Public NotInheritable Class PreFieldEventArgs

The PreFieldEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PreFieldEventArgs(IBatchField) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PreFieldEventArgs class.
Public method | PreFieldEventArgs(IIndexField) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PreFieldEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SkipMode | Indicates whether to skip the current field, document, or folder. Default is NoSkip.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PreFieldEventArgs Constructor

PreFieldEventArgs Constructor
Overload List
 | Name | Description
Public method | PreFieldEventArgs(IBatchField) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PreFieldEventArgs class.
Public method | PreFieldEventArgs(IIndexField) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PreFieldEventArgs class.
Top
See Also

Reference

PreFieldEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreFieldEventArgs Constructor (IBatchField)

PreFieldEventArgs Constructor (IBatchField)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.NetScripting.PreFieldEventArgs class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PreFieldEventArgs(
    IBatchField oIndexField
)
Public Sub New (
    oIndexField As IBatchField
)

Parameters

oIndexField
Type: Kofax.Capture.CaptureModule.InteropServicesIBatchField
IndexField object.
See Also

Reference

PreFieldEventArgs Class
PreFieldEventArgs Overload
Kofax.AscentCapture.NetScripting Namespace


PreFieldEventArgs Constructor (IIndexField)

PreFieldEventArgs Constructor (IIndexField)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.NetScripting.PreFieldEventArgs class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PreFieldEventArgs(
    IIndexField oIndexField
)
Public Sub New (
    oIndexField As IIndexField
)

Parameters

oIndexField
Type: Kofax.Capture.CaptureModule.InteropServicesIIndexField
IndexField object.
See Also

Reference

PreFieldEventArgs Class
PreFieldEventArgs Overload
Kofax.AscentCapture.NetScripting Namespace


PreFieldEventArgs Methods

PreFieldEventArgs Methods

The PreFieldEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PreFieldEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreFieldEventArgs Properties

PreFieldEventArgs Properties

The PreFieldEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SkipMode | Indicates whether to skip the current field, document, or folder. Default is NoSkip.
Top
See Also

Reference

PreFieldEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreFieldEventArgs.SkipMode Property

PreFieldEventArgsSkipMode Property

Indicates whether to skip the current field, document, or folder. Default is NoSkip.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PreFieldEventArgsSkipModeEnum SkipMode { get; set; }
Public Property SkipMode As PreFieldEventArgsSkipModeEnum
    Get
    Set

Property Value

Type: PreFieldEventArgsSkipModeEnum
See Also

Reference

PreFieldEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreFieldEventArgs.SkipModeEnum Enumeration

PreFieldEventArgsSkipModeEnum Enumeration

Skips mode enumeration.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public enum SkipModeEnum
Public Enumeration SkipModeEnum
Members
Member name | Value | Description
NoSkip | 0 | Does not skip.
SaveAndSkipDocumentOrFolder | 1 | Saves and skips the document or folder.
SaveAndSkipField | 2 | Saves and skips the field.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PreFieldEventHandler Delegate

PreFieldEventHandler Delegate

Defines callback for the FieldPreProcessing event.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PreFieldEventHandler(
    Object sender,
    PreFieldEventArgs e
)
Public Delegate Sub PreFieldEventHandler (
    sender As Object,
    e As PreFieldEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.NetScriptingPreFieldEventArgs
The Kofax.AscentCapture.NetScripting.PreFieldEventArgs object that contains the Kofax.Capture.CaptureModule.InteropServices.IndexField object. Handles this event to perform pre-field processing.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PreFolderEventArgs Class

PreFolderEventArgs Class

This class represents the event arguments for the FolderValidationScript.FolderPreProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingPreFolderEventArgs

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PreFolderEventArgs
Public NotInheritable Class PreFolderEventArgs

The PreFolderEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PreFolderEventArgs | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PreFolderEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AlreadyProcessed | Indicates whether the folder is being processed for the first time or if it has already been processed.
Public property | Folder | Gets the Folder object.
Public property | SaveAndSkip | Gets or sets the SaveAndSkip flag. True indicates that all data fields should be saved and the Validation or Verification module should advance to the next folder. Typically used to automatically skip a folder that does not need to be validated by an operator (for example, because the confidence level of all the fields is high). The FieldScript.FieldPreProcessing and FieldScript.FieldPostProcessing objects for all remaining fields are not called, but the FolderValidationScript.FolderPostProcessing event is called.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PreFolderEventArgs Constructor

PreFolderEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.NetScripting.PreFolderEventArgs class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PreFolderEventArgs(
    IFolder oFolder,
    bool bAlreadyProcessed
)
Public Sub New (
    oFolder As IFolder,
    bAlreadyProcessed As Boolean
)

Parameters

oFolder
Type: Kofax.Capture.CaptureModule.InteropServicesIFolder
Folder object.
bAlreadyProcessed
Type: SystemBoolean
Whether the folder is already processed.
See Also

Reference

PreFolderEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreFolderEventArgs Methods

PreFolderEventArgs Methods

The PreFolderEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PreFolderEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreFolderEventArgs Properties

PreFolderEventArgs Properties

The PreFolderEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AlreadyProcessed | Indicates whether the folder is being processed for the first time or if it has already been processed.
Public property | Folder | Gets the Folder object.
Public property | SaveAndSkip | Gets or sets the SaveAndSkip flag. True indicates that all data fields should be saved and the Validation or Verification module should advance to the next folder. Typically used to automatically skip a folder that does not need to be validated by an operator (for example, because the confidence level of all the fields is high). The FieldScript.FieldPreProcessing and FieldScript.FieldPostProcessing objects for all remaining fields are not called, but the FolderValidationScript.FolderPostProcessing event is called.
Top
See Also

Reference

PreFolderEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreFolderEventArgs.AlreadyProcessed Property

PreFolderEventArgsAlreadyProcessed Property

Indicates whether the folder is being processed for the first time or if it has already been processed.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool AlreadyProcessed { get; }
Public ReadOnly Property AlreadyProcessed As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PreFolderEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreFolderEventArgs.Folder Property

PreFolderEventArgsFolder Property

Gets the Folder object.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolder Folder { get; }
Public ReadOnly Property Folder As IFolder
    Get

Property Value

Type: IFolder
See Also

Reference

PreFolderEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreFolderEventArgs.SaveAndSkip Property

PreFolderEventArgsSaveAndSkip Property

Gets or sets the SaveAndSkip flag. True indicates that all data fields should be saved and the Validation or Verification module should advance to the next folder. Typically used to automatically skip a folder that does not need to be validated by an operator (for example, because the confidence level of all the fields is high). The FieldScript.FieldPreProcessing and FieldScript.FieldPostProcessing objects for all remaining fields are not called, but the FolderValidationScript.FolderPostProcessing event is called.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SaveAndSkip { get; set; }
Public Property SaveAndSkip As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PreFolderEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreFolderEventHandler Delegate

PreFolderEventHandler Delegate

Defines callback for the FolderPreProcessing event.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PreFolderEventHandler(
    Object sender,
    PreFolderEventArgs e
)
Public Delegate Sub PreFolderEventHandler (
    sender As Object,
    e As PreFolderEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.NetScriptingPreFolderEventArgs
The Kofax.AscentCapture.NetScripting.PreFolderEventArgs object that contains the Kofax.Capture.CaptureModule.InteropServices.Folder object.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PreRecognitionEventArgs Class

PreRecognitionEventArgs Class

This class represents the event arguments for the RecognitionScript.RecognitionPreProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingPreRecognitionEventArgs

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PreRecognitionEventArgs
Public NotInheritable Class PreRecognitionEventArgs

The PreRecognitionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PreRecognitionEventArgs | Initializes a new instance of the Kofax.AscentCapture.NetScripting.PreRecognitionEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
Name Description
Public property Confidence

Gets or sets the confidence level of the recognition engine. It is an integer between 0-100, with 100 being the highest confidence. If you perform recognition with a custom engine, you are responsible for setting this value.

Public property ImageFile

Gets the file name of the zone snippet currently being processed. Image processing has already been performed by the time the script gets access to this file. Note that this is a temporary file and is read-only; attempting to modify the file may have unpredictable consequences. The value is empty if the RecognitionScript.ImageFileRequired property is set to False. Otherwise, it contains the image file name.

Public property RegistrationHorizBMU

Gets or sets the horizontal registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs).

Registration offsets are only produced by the Kofax OCR and Kofax High Performance OCR/ICR engines. If you want to design a custom profile that produces registration offsets, you must derive your custom profile from the profile of one of those engines (you can skip the default engine logic by setting the SaveAndSkip property to True). Registration offsets may be generated by any zone type, but the values are ignored unless the zone is a registration zone. If you are customizing a registration zone and want to guarantee success, the script must have the Value property set to SearchText, Confidence set to 100, and the two offset variables set to a value >= 0. These values default to -1 if the default engine has not yet been run, or does not generate offsets.

Public property RegistrationVertBMU

Gets or sets the vertical registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). See RegistrationHorizBMU property for more information.

Public property SaveAndSkip

Gets or sets the SaveAndSkip flag. If True, sets the recognition information and skips the Kofax recognition. The RecognitionScript.RecognitionPostProcessing event is still called if it’s set in RecognitionScript.RecognitionPreProcessing event.

Public property SearchText

Gets the search text is the expected search string set in the Administration module for a separation, form identification, or registration zone. Additionally, if the field type for an index zone has exactly one suggested value, and is marked as Force Match, then the search text exposes that value.

Public property Value

Gets or sets the current recognized value. It is null or Nothing in the PreRecognitionEventArgs object and is overwritten in the PostRecognitionEventArgs object by the Kofax recognition engine unless PreRecognitionEventArgs.SaveAndSkip is set to True. It can be modified in the PostRecognitionEventArgs object.

Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


PreRecognitionEventArgs Constructor

PreRecognitionEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.NetScripting.PreRecognitionEventArgs class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PreRecognitionEventArgs(
    int nConfidence,
    string strImageFile,
    int nRegistrationHorizBMU,
    int nRegistrationVertBMU,
    bool bSaveAndSkip,
    string strSearchText,
    string strValue
)
Public Sub New (
    nConfidence As Integer,
    strImageFile As String,
    nRegistrationHorizBMU As Integer,
    nRegistrationVertBMU As Integer,
    bSaveAndSkip As Boolean,
    strSearchText As String,
    strValue As String
)

Parameters

nConfidence
Type: SystemInt32
Confidence.
strImageFile
Type: SystemString
ImageFile.
nRegistrationHorizBMU
Type: SystemInt32
RegistrationHorizBMU.
nRegistrationVertBMU
Type: SystemInt32
RegistrationVertBMU.
bSaveAndSkip
Type: SystemBoolean
SaveAndSkip.
strSearchText
Type: SystemString
SearchText.
strValue
Type: SystemString
Value.
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreRecognitionEventArgs Methods

PreRecognitionEventArgs Methods

The PreRecognitionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreRecognitionEventArgs Properties

PreRecognitionEventArgs Properties

The PreRecognitionEventArgs type exposes the following members.

Properties
Name Description
Public property Confidence

Gets or sets the confidence level of the recognition engine. It is an integer between 0-100, with 100 being the highest confidence. If you perform recognition with a custom engine, you are responsible for setting this value.

Public property ImageFile

Gets the file name of the zone snippet currently being processed. Image processing has already been performed by the time the script gets access to this file. Note that this is a temporary file and is read-only; attempting to modify the file may have unpredictable consequences. The value is empty if the RecognitionScript.ImageFileRequired property is set to False. Otherwise, it contains the image file name.

Public property RegistrationHorizBMU

Gets or sets the horizontal registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs).

Registration offsets are only produced by the Kofax OCR and Kofax High Performance OCR/ICR engines. If you want to design a custom profile that produces registration offsets, you must derive your custom profile from the profile of one of those engines (you can skip the default engine logic by setting the SaveAndSkip property to True). Registration offsets may be generated by any zone type, but the values are ignored unless the zone is a registration zone. If you are customizing a registration zone and want to guarantee success, the script must have the Value property set to SearchText, Confidence set to 100, and the two offset variables set to a value >= 0. These values default to -1 if the default engine has not yet been run, or does not generate offsets.

Public property RegistrationVertBMU

Gets or sets the vertical registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). See RegistrationHorizBMU property for more information.

Public property SaveAndSkip

Gets or sets the SaveAndSkip flag. If True, sets the recognition information and skips the Kofax recognition. The RecognitionScript.RecognitionPostProcessing event is still called if it’s set in RecognitionScript.RecognitionPreProcessing event.

Public property SearchText

Gets the search text is the expected search string set in the Administration module for a separation, form identification, or registration zone. Additionally, if the field type for an index zone has exactly one suggested value, and is marked as Force Match, then the search text exposes that value.

Public property Value

Gets or sets the current recognized value. It is null or Nothing in the PreRecognitionEventArgs object and is overwritten in the PostRecognitionEventArgs object by the Kofax recognition engine unless PreRecognitionEventArgs.SaveAndSkip is set to True. It can be modified in the PostRecognitionEventArgs object.

Top
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreRecognitionEventArgs.Confidence Property

PreRecognitionEventArgsConfidence Property

Gets or sets the confidence level of the recognition engine. It is an integer between 0-100, with 100 being the highest confidence. If you perform recognition with a custom engine, you are responsible for setting this value.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Confidence { get; set; }
Public Property Confidence As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreRecognitionEventArgs.ImageFile Property

PreRecognitionEventArgsImageFile Property

Gets the file name of the zone snippet currently being processed. Image processing has already been performed by the time the script gets access to this file. Note that this is a temporary file and is read-only; attempting to modify the file may have unpredictable consequences. The value is empty if the RecognitionScript.ImageFileRequired property is set to False. Otherwise, it contains the image file name.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ImageFile { get; }
Public ReadOnly Property ImageFile As String
    Get

Property Value

Type: String
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreRecognitionEventArgs.RegistrationHorizBMU Property

PreRecognitionEventArgsRegistrationHorizBMU Property

Gets or sets the horizontal registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs).

Registration offsets are only produced by the Kofax OCR and Kofax High Performance OCR/ICR engines. If you want to design a custom profile that produces registration offsets, you must derive your custom profile from the profile of one of those engines (you can skip the default engine logic by setting the SaveAndSkip property to True). Registration offsets may be generated by any zone type, but the values are ignored unless the zone is a registration zone. If you are customizing a registration zone and want to guarantee success, the script must have the Value property set to SearchText, Confidence set to 100, and the two offset variables set to a value >= 0. These values default to -1 if the default engine has not yet been run, or does not generate offsets.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int RegistrationHorizBMU { get; set; }
Public Property RegistrationHorizBMU As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreRecognitionEventArgs.RegistrationVertBMU Property

PreRecognitionEventArgsRegistrationVertBMU Property

Gets or sets the vertical registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). See RegistrationHorizBMU property for more information.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int RegistrationVertBMU { get; set; }
Public Property RegistrationVertBMU As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreRecognitionEventArgs.SaveAndSkip Property

PreRecognitionEventArgsSaveAndSkip Property

Gets or sets the SaveAndSkip flag. If True, sets the recognition information and skips the Kofax recognition. The RecognitionScript.RecognitionPostProcessing event is still called if it’s set in RecognitionScript.RecognitionPreProcessing event.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SaveAndSkip { get; set; }
Public Property SaveAndSkip As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreRecognitionEventArgs.SearchText Property

PreRecognitionEventArgsSearchText Property

Gets the search text is the expected search string set in the Administration module for a separation, form identification, or registration zone. Additionally, if the field type for an index zone has exactly one suggested value, and is marked as Force Match, then the search text exposes that value.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string SearchText { get; }
Public ReadOnly Property SearchText As String
    Get

Property Value

Type: String
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreRecognitionEventArgs.Value Property

PreRecognitionEventArgsValue Property

Gets or sets the current recognized value. It is null or Nothing in the PreRecognitionEventArgs object and is overwritten in the PostRecognitionEventArgs object by the Kofax recognition engine unless PreRecognitionEventArgs.SaveAndSkip is set to True. It can be modified in the PostRecognitionEventArgs object.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.NetScripting Namespace


PreRecognitionEventHandler Delegate

PreRecognitionEventHandler Delegate

Defines callback for RecognitionPreProcessing event.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PreRecognitionEventHandler(
    Object sender,
    PreRecognitionEventArgs e
)
Public Delegate Sub PreRecognitionEventHandler (
    sender As Object,
    e As PreRecognitionEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.NetScriptingPreRecognitionEventArgs
The Kofax.AscentCapture.NetScripting.PreRecognitionEventArgs object containing the recognition information.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


RecognitionBatchLoadingHandler Delegate

RecognitionBatchLoadingHandler Delegate

Defines callback for RecognitionBatchLoading event.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void RecognitionBatchLoadingHandler(
    Object sender,
    ref bool ImageFileRequired
)
Public Delegate Sub RecognitionBatchLoadingHandler (
    sender As Object,
    ByRef ImageFileRequired As Boolean
)

Parameters

sender
Type: SystemObject
Object that raises this event.
ImageFileRequired
Type: SystemBoolean
Indicates whether the file name of the zone snippet currently being processed should be provided. The default is False. Note: This parameter default is False for performance reasons. Generating the zone TIFF file accounts for about 10% of zone execution time. In most cases, the zone image does not need to be generated for built-in engine execution. Setting it to True forces the zone image to be created every time. Therefore, do not set this parameter to True unless you actually need access to the image.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


RecognitionBatchUnloadingHandler Delegate

RecognitionBatchUnloadingHandler Delegate

Defines callback for RecognitionBatchUnloading event.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void RecognitionBatchUnloadingHandler(
    Object sender
)
Public Delegate Sub RecognitionBatchUnloadingHandler (
    sender As Object
)

Parameters

sender
Type: SystemObject
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


RecognitionScript Class

RecognitionScript Class

Base class for the recognition script.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingRecognitionScript

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public abstract class RecognitionScript
Public MustInherit Class RecognitionScript

The RecognitionScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | BatchLoading | Called when a batch is opened.
Public event | BatchUnloading | Called when a batch is closed.
Public event | RecognitionPostProcessing | Called after each zone snippet is processed.
Public event | RecognitionPreProcessing | Called before each zone snippet is processed.
Top
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


RecognitionScript Methods

RecognitionScript Methods

The RecognitionScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RecognitionScript Class
Kofax.AscentCapture.NetScripting Namespace


RecognitionScript Events

RecognitionScript Events

The RecognitionScript type exposes the following members.

Events
 | Name | Description
Public event | BatchLoading | Called when a batch is opened.
Public event | BatchUnloading | Called when a batch is closed.
Public event | RecognitionPostProcessing | Called after each zone snippet is processed.
Public event | RecognitionPreProcessing | Called before each zone snippet is processed.
Top
See Also

Reference

RecognitionScript Class
Kofax.AscentCapture.NetScripting Namespace


RecognitionScript.BatchLoading Event

RecognitionScriptBatchLoading Event

Called when a batch is opened.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event RecognitionBatchLoadingHandler BatchLoading
Public Event BatchLoading As RecognitionBatchLoadingHandler

Value

Type: Kofax.AscentCapture.NetScriptingRecognitionBatchLoadingHandler
See Also

Reference

RecognitionScript Class
Kofax.AscentCapture.NetScripting Namespace


RecognitionScript.BatchUnloading Event

RecognitionScriptBatchUnloading Event

Called when a batch is closed.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event RecognitionBatchUnloadingHandler BatchUnloading
Public Event BatchUnloading As RecognitionBatchUnloadingHandler

Value

Type: Kofax.AscentCapture.NetScriptingRecognitionBatchUnloadingHandler
See Also

Reference

RecognitionScript Class
Kofax.AscentCapture.NetScripting Namespace


RecognitionScript.RecognitionPostProcessing Event

RecognitionScriptRecognitionPostProcessing Event

Called after each zone snippet is processed.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PostRecognitionEventHandler RecognitionPostProcessing
Public Event RecognitionPostProcessing As PostRecognitionEventHandler

Value

Type: Kofax.AscentCapture.NetScriptingPostRecognitionEventHandler
See Also

Reference

RecognitionScript Class
Kofax.AscentCapture.NetScripting Namespace


RecognitionScript.RecognitionPreProcessing Event

RecognitionScriptRecognitionPreProcessing Event

Called before each zone snippet is processed.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PreRecognitionEventHandler RecognitionPreProcessing
Public Event RecognitionPreProcessing As PreRecognitionEventHandler

Value

Type: Kofax.AscentCapture.NetScriptingPreRecognitionEventHandler
See Also

Reference

RecognitionScript Class
Kofax.AscentCapture.NetScripting Namespace


RejectAndSkipDocumentException Class

RejectAndSkipDocumentException Class

Defines reject and skip a document error. This exception is to be thrown in document validation scripts only. It is treated as a FatalErrorException if thrown from other script types. Note: Folder validation script doesn’t have an equivalent exception, as folder cannot be rejected.

Inheritance Hierarchy
SystemObject
SystemException
Kofax.AscentCapture.NetScriptingRejectAndSkipDocumentException

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class RejectAndSkipDocumentException : Exception
Public Class RejectAndSkipDocumentException
    Inherits Exception

The RejectAndSkipDocumentException type exposes the following members.

Constructors
 | Name | Description
Public method | RejectAndSkipDocumentException | Initializes a new instance of the Kofax.AscentCapture.NetScripting.RejectAndSkipDocumentException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)
Top
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


RejectAndSkipDocumentException Constructor

RejectAndSkipDocumentException Constructor

Initializes a new instance of the Kofax.AscentCapture.NetScripting.RejectAndSkipDocumentException class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public RejectAndSkipDocumentException(
    string strErrorMessage
)
Public Sub New (
    strErrorMessage As String
)

Parameters

strErrorMessage
Type: SystemString
Error message.
See Also

Reference

RejectAndSkipDocumentException Class
Kofax.AscentCapture.NetScripting Namespace


RejectAndSkipDocumentException Methods

RejectAndSkipDocumentException Methods

The RejectAndSkipDocumentException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

RejectAndSkipDocumentException Class
Kofax.AscentCapture.NetScripting Namespace


RejectAndSkipDocumentException Properties

RejectAndSkipDocumentException Properties

The RejectAndSkipDocumentException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)
Top
See Also

Reference

RejectAndSkipDocumentException Class
Kofax.AscentCapture.NetScripting Namespace


ScriptUtils Class

ScriptUtils Class
Supply the validation and formatting the number methods
Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.NetScriptingScriptUtils

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ScriptUtils
Public Class ScriptUtils

The ScriptUtils type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptUtils | Initializes a new instance of the ScriptUtils class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | KfxFormatDecimal | Formats a decimal or numeric value.
 | KfxFormatDouble | Formats a double value.
 | KfxFormatReal | Formats a real or float value.
 | KfxRoundInteger | This function will round a double value to an integer as follows: If the decimal part of the number is >= 0.5, the number is rounded up, otherwise, it is rounded down.
 | KfxRoundSmallInteger | This function will round a double value to a small integer as follows: If the decimal part of the number is >= 0.5, the number is rounded up, otherwise, it is rounded down.
 | KfxValidateDecimal | Validates a decimal or numeric value.
 | KfxValidateDouble | Validates a double value.
 | KfxValidateReal | Validates a real or float value.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


ScriptUtils Constructor

ScriptUtils Constructor
Initializes a new instance of the ScriptUtils class

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ScriptUtils()
Public Sub New
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.NetScripting Namespace


ScriptUtils Methods

ScriptUtils Methods

The ScriptUtils type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | KfxFormatDecimal | Formats a decimal or numeric value.
 | KfxFormatDouble | Formats a double value.
 | KfxFormatReal | Formats a real or float value.
 | KfxRoundInteger | This function will round a double value to an integer as follows: If the decimal part of the number is >= 0.5, the number is rounded up, otherwise, it is rounded down.
 | KfxRoundSmallInteger | This function will round a double value to a small integer as follows: If the decimal part of the number is >= 0.5, the number is rounded up, otherwise, it is rounded down.
 | KfxValidateDecimal | Validates a decimal or numeric value.
 | KfxValidateDouble | Validates a double value.
 | KfxValidateReal | Validates a real or float value.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.NetScripting Namespace


ScriptUtils.KfxFormatDecimal Method

ScriptUtilsKfxFormatDecimal Method

Formats a decimal or numeric value.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxFormatDecimal(
    ref string strValue,
    int nPrecision,
    int nScale
)
Public Shared Function KfxFormatDecimal (
    ByRef strValue As String,
    nPrecision As Integer,
    nScale As Integer
) As Boolean

Parameters

strValue
Type: SystemString
The value to be formatted.
nPrecision
Type: SystemInt32
The number of digits.
nScale
Type: SystemInt32
The number of decimal places.

Return Value

Type: Boolean
True if the value has been formatted successfully. Otherwise, False.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.NetScripting Namespace


ScriptUtils.KfxFormatDouble Method

ScriptUtilsKfxFormatDouble Method

Formats a double value.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxFormatDouble(
    ref string strValue
)
Public Shared Function KfxFormatDouble (
    ByRef strValue As String
) As Boolean

Parameters

strValue
Type: SystemString
The value to be formatted.

Return Value

Type: Boolean
True if the value has been formatted successfully. Otherwise, False.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.NetScripting Namespace


ScriptUtils.KfxFormatReal Method

ScriptUtilsKfxFormatReal Method

Formats a real or float value.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxFormatReal(
    ref string strValue
)
Public Shared Function KfxFormatReal (
    ByRef strValue As String
) As Boolean

Parameters

strValue
Type: SystemString
The value to be formatted.

Return Value

Type: Boolean
True if the value has been formatted successfully. Otherwise, False.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.NetScripting Namespace


ScriptUtils.KfxRoundInteger Method

ScriptUtilsKfxRoundInteger Method
This function will round a double value to an integer as follows: If the decimal part of the number is >= 0.5, the number is rounded up, otherwise, it is rounded down.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxRoundInteger(
    string strIntVal,
    ref int outVal
)
Public Shared Function KfxRoundInteger (
    strIntVal As String,
    ByRef outVal As Integer
) As Boolean

Parameters

strIntVal
Type: SystemString
double value in string
outVal
Type: SystemInt32

Return Value

Type: Boolean
True if strIntVal is a valid string and the double value in the integer range. Otherwise, false.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.NetScripting Namespace


ScriptUtils.KfxRoundSmallInteger Method

ScriptUtilsKfxRoundSmallInteger Method
This function will round a double value to a small integer as follows: If the decimal part of the number is >= 0.5, the number is rounded up, otherwise, it is rounded down.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxRoundSmallInteger(
    string strIntVal,
    ref short outVal
)
Public Shared Function KfxRoundSmallInteger (
    strIntVal As String,
    ByRef outVal As Short
) As Boolean

Parameters

strIntVal
Type: SystemString
double value in string
outVal
Type: SystemInt16

Return Value

Type: Boolean
True if strIntVal is a valid string and the double value in the integer range. Otherwise, false.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.NetScripting Namespace


ScriptUtils.KfxValidateDecimal Method

ScriptUtilsKfxValidateDecimal Method

Validates a decimal or numeric value.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxValidateDecimal(
    ref string strValue,
    int nPrecision,
    int nScale
)
Public Shared Function KfxValidateDecimal (
    ByRef strValue As String,
    nPrecision As Integer,
    nScale As Integer
) As Boolean

Parameters

strValue
Type: SystemString
The value to be validated.
nPrecision
Type: SystemInt32
The number of digits.
nScale
Type: SystemInt32
The number of decimal places.

Return Value

Type: Boolean
True if the value has been validated successfully. Otherwise, False.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.NetScripting Namespace


ScriptUtils.KfxValidateDouble Method

ScriptUtilsKfxValidateDouble Method

Validates a double value.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxValidateDouble(
    ref string strValue
)
Public Shared Function KfxValidateDouble (
    ByRef strValue As String
) As Boolean

Parameters

strValue
Type: SystemString
The value to be validated.

Return Value

Type: Boolean
True if the value has been validated successfully. Otherwise, False.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.NetScripting Namespace


ScriptUtils.KfxValidateReal Method

ScriptUtilsKfxValidateReal Method

Validates a real or float value.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxValidateReal(
    ref string strValue
)
Public Shared Function KfxValidateReal (
    ByRef strValue As String
) As Boolean

Parameters

strValue
Type: SystemString
The value to be validated.

Return Value

Type: Boolean
True if the value has been validated successfully. Otherwise, False.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.NetScripting Namespace


SuppressFieldEventsOnDocCloseAttribute Class

SuppressFieldEventsOnDocCloseAttribute Class

Inheritance Hierarchy
SystemObject
SystemAttribute
Kofax.AscentCapture.NetScriptingSuppressFieldEventsOnDocCloseAttribute

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[AttributeUsageAttribute(AttributeTargets.Class)]
public sealed class SuppressFieldEventsOnDocCloseAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class)>
Public NotInheritable Class SuppressFieldEventsOnDocCloseAttribute
    Inherits Attribute

The SuppressFieldEventsOnDocCloseAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | SuppressFieldEventsOnDocCloseAttribute | Initializes a new instance of the Kofax.AscentCapture.NetScripting.SuppressFieldEventsOnDocCloseAttribute class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SuppressFieldEventsOnDocClose | Gets the script attribute.
Public property | TypeId | (Inherited from Attribute.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | (Inherited from Attribute.)
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


SuppressFieldEventsOnDocCloseAttribute Constructor

SuppressFieldEventsOnDocCloseAttribute Constructor

Initializes a new instance of the Kofax.AscentCapture.NetScripting.SuppressFieldEventsOnDocCloseAttribute class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public SuppressFieldEventsOnDocCloseAttribute(
    bool bSuppress
)
Public Sub New (
    bSuppress As Boolean
)

Parameters

bSuppress
Type: SystemBoolean
See Also

Reference

SuppressFieldEventsOnDocCloseAttribute Class
Kofax.AscentCapture.NetScripting Namespace


SuppressFieldEventsOnDocCloseAttribute Methods

SuppressFieldEventsOnDocCloseAttribute Methods

The SuppressFieldEventsOnDocCloseAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Public method | ToString | (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | (Inherited from Attribute.)
Top
See Also

Reference

SuppressFieldEventsOnDocCloseAttribute Class
Kofax.AscentCapture.NetScripting Namespace


SuppressFieldEventsOnDocCloseAttribute Properties

SuppressFieldEventsOnDocCloseAttribute Properties

The SuppressFieldEventsOnDocCloseAttribute type exposes the following members.

Properties
 | Name | Description
Public property | SuppressFieldEventsOnDocClose | Gets the script attribute.
Public property | TypeId | (Inherited from Attribute.)
Top
See Also

Reference

SuppressFieldEventsOnDocCloseAttribute Class
Kofax.AscentCapture.NetScripting Namespace


SuppressFieldEventsOnDocCloseAttribute.SuppressFieldEventsOnDocClose Property

SuppressFieldEventsOnDocCloseAttributeSuppressFieldEventsOnDocClose Property
Kofax Capture API Reference

Gets the script attribute.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SuppressFieldEventsOnDocClose { get; }
Public ReadOnly Property SuppressFieldEventsOnDocClose As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

SuppressFieldEventsOnDocCloseAttribute Class
Kofax.AscentCapture.NetScripting Namespace


ValidationErrorException Class

ValidationErrorException Class

Signals a validation error. This exception is to be thrown in validation scripts only. It is treated as a FatalErrorException if the Recognition Server receives this exception.

Inheritance Hierarchy
SystemObject
SystemException
Kofax.AscentCapture.NetScriptingValidationErrorException

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ValidationErrorException : Exception
Public Class ValidationErrorException
    Inherits Exception

The ValidationErrorException type exposes the following members.

Constructors
 | Name | Description
Public method | ValidationErrorException(String) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.ValidationErrorException class.
Public method | ValidationErrorException(String, IIndexField) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.ValidationErrorException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | ActiveField | Gets the index field that will receive focus.
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)
Top
See Also

Reference

Kofax.AscentCapture.NetScripting Namespace


ValidationErrorException Constructor

ValidationErrorException Constructor
Overload List
 | Name | Description
Public method | ValidationErrorException(String) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.ValidationErrorException class.
Public method | ValidationErrorException(String, IIndexField) | Initializes a new instance of the Kofax.AscentCapture.NetScripting.ValidationErrorException class.
Top
See Also

Reference

ValidationErrorException Class
Kofax.AscentCapture.NetScripting Namespace


ValidationErrorException Constructor (String)

ValidationErrorException Constructor (String)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.NetScripting.ValidationErrorException class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ValidationErrorException(
    string strErrorMessage
)
Public Sub New (
    strErrorMessage As String
)

Parameters

strErrorMessage
Type: SystemString
Error message.
See Also

Reference

ValidationErrorException Class
ValidationErrorException Overload
Kofax.AscentCapture.NetScripting Namespace


ValidationErrorException Constructor (String, IIndexField)

ValidationErrorException Constructor (String, IIndexField)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.NetScripting.ValidationErrorException class.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ValidationErrorException(
    string strErrorMessage,
    IIndexField oActiveIndexField
)
Public Sub New (
    strErrorMessage As String,
    oActiveIndexField As IIndexField
)

Parameters

strErrorMessage
Type: SystemString
Error message.
oActiveIndexField
Type: Kofax.Capture.CaptureModule.InteropServicesIIndexField
Index field to receive focus.
See Also

Reference

ValidationErrorException Class
ValidationErrorException Overload
Kofax.AscentCapture.NetScripting Namespace


ValidationErrorException Methods

ValidationErrorException Methods

The ValidationErrorException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

ValidationErrorException Class
Kofax.AscentCapture.NetScripting Namespace


ValidationErrorException Properties

ValidationErrorException Properties

The ValidationErrorException type exposes the following members.

Properties
 | Name | Description
Public property | ActiveField | Gets the index field that will receive focus.
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)
Top
See Also

Reference

ValidationErrorException Class
Kofax.AscentCapture.NetScripting Namespace


ValidationErrorException.ActiveField Property

ValidationErrorExceptionActiveField Property

Gets the index field that will receive focus.

Namespace: Kofax.AscentCapture.NetScripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexField ActiveField { get; }
Public ReadOnly Property ActiveField As IIndexField
    Get

Property Value

Type: IIndexField
See Also

Reference

ValidationErrorException Class
Kofax.AscentCapture.NetScripting Namespace


Kofax.AscentCapture.Scripting Namespace

Kofax.AscentCapture.Scripting Namespace

Provides base Document, Folder, Field and Recognition classes for customization scripts to work on.

Classes in this namespace are designed to work with the Tungsten Capture Module Type Library (Kofax.AscentCaptureModule.Interop.dll).

Classes
 | Class | Description
Public class | BatchEventArgs | Defines the event argument class used in BatchLoading and BatchUnloading events.
Public class | DocumentValidationScript | Base class for the document validation script.
Public class | FatalErrorException | Signals a fatal error. This exception can be thrown in validation, recognition, and field scripts.
Public class | FieldScript | Base class for the field validation script.
Public class | FolderValidationScript | Base class for the folder validation script.
Public class | FormatFieldEventArgs | This class represents the event arguments for the FieldScript.FieldFormatting event.
Public class | IndexFieldVariableAttribute | This is an attribute class used to indicate that the current field in the class is an index field in the document validation script, or folder validation script.
Public class | PostDocumentEventArgs | This class represents the event arguments for the DocumentValidationScript.DocumentPostProcessing event.
Public class | PostFieldEventArgs | This class represents the event arguments for the FieldScript.FieldPostProcessing event.
Public class | PostFolderEventArgs | This class represents the event arguments for the FolderValidationScript.FolderPostProcessing event.
Public class | PostRecognitionEventArgs | This class represents the event arguments for the RecognitionScript.RecognitionPostProcessing event.
Public class | PreDocumentEventArgs | This class represents the event arguments for the DocumentValidationScript.DocumentPreProcessing event.
Public class | PreFieldEventArgs | This class represents the event arguments for the FieldScript.FieldPreProcessing event.
Public class | PreFolderEventArgs | This class represents the event arguments for the FolderValidationScript.FolderPreProcessing event.
Public class | PreRecognitionEventArgs | This class represents the event arguments for the RecognitionScript.RecognitionPreProcessing event.
Public class | RecognitionScript | Base class for the recognition script.
Public class | RejectAndSkipDocumentException | Rejects and skips a document. This exception is to be thrown in document validation scripts only. It is treated as a FatalErrorException if thrown from other script types. Note: Folder validation script doesn’t have an equivalent exception, as folder cannot be rejected.
Public class | ScriptUtils | Supply the validation and formatting the number methods
Public class | SuppressFieldEventsOnDocCloseAttribute | Defines the suppress field event on document close event class.
Public class | ValidationErrorException | Signals a validation error. This exception is to be thrown in validation scripts only. It is treated as a FatalErrorException if the Recognition Server receives this exception.
Delegates
 | Delegate | Description
Public delegate | BatchEventHandler | Callback for the BatchLoading and BatchUnloading events.
Public delegate | FormatFieldEventHandler | Defines callback for the FieldFormatting event.
Public delegate | PostDocumentEventHandler | Defines callback for the DocumentPostProcessing event.
Public delegate | PostFieldEventHandler | Defines callback for the FieldPostProcessing event.
Public delegate | PostFolderEventHandler | Defines callback for the FolderPostProcessing event.
Public delegate | PostRecognitionEventHandler | Defines callback for RecognitionPostProcessing event.
Public delegate | PreDocumentEventHandler | Defines callback for the DocumentPreProcessing event.
Public delegate | PreFieldEventHandler | Defines callback for the FieldPreProcessing event.
Public delegate | PreFolderEventHandler | Defines callback for the FolderPreProcessing event.
Public delegate | PreRecognitionEventHandler | Defines callback for RecognitionPreProcessing event.
Public delegate | RecognitionBatchLoadingHandler | Defines callback for RecognitionBatchLoading event.
Public delegate | RecognitionBatchUnloadingHandler | Defines callback for RecognitionBatchUnloading event.
Enumerations
 | Enumeration | Description
Public enumeration | ApplicationEnum | This is an enumeration type that indicates which application is executing the script.
Public enumeration | PreFieldEventArgsSkipModeEnum | Skips mode enumeration.
Remarks
Custom validation scripts based on this namespace will not work if VB6 components were excluded from your installation.


ApplicationEnum Enumeration

ApplicationEnum Enumeration

This is an enumeration type that indicates which application is executing the script.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public enum ApplicationEnum
Public Enumeration ApplicationEnum
Members
Member name | Value | Description
Validation | 1 | Validation module.
Verification | 2 | Verification module.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


BatchEventArgs Class

BatchEventArgs Class

Defines the event argument class used in BatchLoading and BatchUnloading events.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingBatchEventArgs

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class BatchEventArgs
Public NotInheritable Class BatchEventArgs

The BatchEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | BatchEventArgs | Initializes a new instance of the Kofax.AscentCapture.Scripting.BatchEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Batch | Gets the Batch object.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


BatchEventArgs Constructor

BatchEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.Scripting.BatchEventArgs class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public BatchEventArgs(
    Batch oBatch
)
Public Sub New (
    oBatch As Batch
)

Parameters

oBatch
Type: Batch
Batch object.
See Also

Reference

BatchEventArgs Class
Kofax.AscentCapture.Scripting Namespace


BatchEventArgs Methods

BatchEventArgs Methods

The BatchEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchEventArgs Class
Kofax.AscentCapture.Scripting Namespace


BatchEventArgs Properties

BatchEventArgs Properties

The BatchEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Batch | Gets the Batch object.
Top
See Also

Reference

BatchEventArgs Class
Kofax.AscentCapture.Scripting Namespace


BatchEventArgs.Batch Property

BatchEventArgsBatch Property

Gets the Batch object.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Batch Batch { get; }
Public ReadOnly Property Batch As Batch
    Get

Property Value

Type: Batch
See Also

Reference

BatchEventArgs Class
Kofax.AscentCapture.Scripting Namespace


BatchEventHandler Delegate

BatchEventHandler Delegate

Callback for the BatchLoading and BatchUnloading events.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void BatchEventHandler(
    Object sender,
    BatchEventArgs e
)
Public Delegate Sub BatchEventHandler (
    sender As Object,
    e As BatchEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.ScriptingBatchEventArgs
The Kofax.AscentCapture.Scripting.BatchEventArgs object that contains the Kofax.AscentCaptureModule.Batch object.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


DocumentValidationScript Class

DocumentValidationScript Class

Base class for the document validation script.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingDocumentValidationScript

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public abstract class DocumentValidationScript
Public MustInherit Class DocumentValidationScript

The DocumentValidationScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Application | Gets the application executing the script.
Public property | LocaleName | Gets the locale name.
Public property | UserID | Gets the User ID.
Top
Events
 | Name | Description
Public event | BatchLoading | Called when a batch is opened.
Public event | BatchUnloading | Called when a batch is closed.
Public event | DocumentPostProcessing | Called after each document is closed.
Public event | DocumentPreProcessing | Called each time a new document is opened.
Top
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


DocumentValidationScript Methods

DocumentValidationScript Methods

The DocumentValidationScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.Scripting Namespace


DocumentValidationScript Properties

DocumentValidationScript Properties

The DocumentValidationScript type exposes the following members.

Properties
 | Name | Description
Public property | Application | Gets the application executing the script.
Public property | LocaleName | Gets the locale name.
Public property | UserID | Gets the User ID.
Top
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.Scripting Namespace


DocumentValidationScript.Application Property

DocumentValidationScriptApplication Property

Gets the application executing the script.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ApplicationEnum Application { get; }
Public ReadOnly Property Application As ApplicationEnum
    Get

Property Value

Type: ApplicationEnum
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.Scripting Namespace


DocumentValidationScript.LocaleName Property

DocumentValidationScriptLocaleName Property

Gets the locale name.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string LocaleName { get; }
Public ReadOnly Property LocaleName As String
    Get

Property Value

Type: String
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.Scripting Namespace


DocumentValidationScript.UserID Property

DocumentValidationScriptUserID Property

Gets the User ID.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string UserID { get; }
Public ReadOnly Property UserID As String
    Get

Property Value

Type: String
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.Scripting Namespace


DocumentValidationScript Events

DocumentValidationScript Events

The DocumentValidationScript type exposes the following members.

Events
 | Name | Description
Public event | BatchLoading | Called when a batch is opened.
Public event | BatchUnloading | Called when a batch is closed.
Public event | DocumentPostProcessing | Called after each document is closed.
Public event | DocumentPreProcessing | Called each time a new document is opened.
Top
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.Scripting Namespace


DocumentValidationScript.BatchLoading Event

DocumentValidationScriptBatchLoading Event

Called when a batch is opened.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event BatchEventHandler BatchLoading
Public Event BatchLoading As BatchEventHandler

Value

Type: Kofax.AscentCapture.ScriptingBatchEventHandler
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.Scripting Namespace


DocumentValidationScript.BatchUnloading Event

DocumentValidationScriptBatchUnloading Event

Called when a batch is closed.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event BatchEventHandler BatchUnloading
Public Event BatchUnloading As BatchEventHandler

Value

Type: Kofax.AscentCapture.ScriptingBatchEventHandler
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.Scripting Namespace


DocumentValidationScript.DocumentPostProcessing Event

DocumentValidationScriptDocumentPostProcessing Event

Called after each document is closed.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PostDocumentEventHandler DocumentPostProcessing
Public Event DocumentPostProcessing As PostDocumentEventHandler

Value

Type: Kofax.AscentCapture.ScriptingPostDocumentEventHandler
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.Scripting Namespace


DocumentValidationScript.DocumentPreProcessing Event

DocumentValidationScriptDocumentPreProcessing Event

Called each time a new document is opened.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PreDocumentEventHandler DocumentPreProcessing
Public Event DocumentPreProcessing As PreDocumentEventHandler

Value

Type: Kofax.AscentCapture.ScriptingPreDocumentEventHandler
See Also

Reference

DocumentValidationScript Class
Kofax.AscentCapture.Scripting Namespace


FatalErrorException Class

FatalErrorException Class

Signals a fatal error. This exception can be thrown in validation, recognition, and field scripts.

Inheritance Hierarchy
SystemObject
SystemException
Kofax.AscentCapture.ScriptingFatalErrorException

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class FatalErrorException : Exception
Public Class FatalErrorException
    Inherits Exception

The FatalErrorException type exposes the following members.

Constructors
 | Name | Description
Public method | FatalErrorException | Initializes a new instance of the Kofax.AscentCapture.Scripting.FatalErrorException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)
Top
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


FatalErrorException Constructor

FatalErrorException Constructor

Initializes a new instance of the Kofax.AscentCapture.Scripting.FatalErrorException class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public FatalErrorException(
    string strErrorMessage
)
Public Sub New (
    strErrorMessage As String
)

Parameters

strErrorMessage
Type: SystemString
Error message.
See Also

Reference

FatalErrorException Class
Kofax.AscentCapture.Scripting Namespace


FatalErrorException Methods

FatalErrorException Methods

The FatalErrorException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

FatalErrorException Class
Kofax.AscentCapture.Scripting Namespace


FatalErrorException Properties

FatalErrorException Properties

The FatalErrorException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)
Top
See Also

Reference

FatalErrorException Class
Kofax.AscentCapture.Scripting Namespace


FieldScript Class

FieldScript Class

Base class for the field validation script.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingFieldScript

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class FieldScript
Public Class FieldScript

The FieldScript type exposes the following members.

Constructors
 | Name | Description
Public method | FieldScript | Default constructor.
Top
Methods
 | Name | Description
Public method | DefaultFieldFormatting | Call this method in the FieldFormatting event handler to perform the default formatting of the current index field. The current index field is formatted based on its data type and the formatted value is returned if it is formatted successfully. Otherwise, the current index field value is not formatted and returned.
Public method | DefaultFieldPostProcessing | Calls this method in the FieldPostProcessing event handler to perform the default post-field processing of the current index field. The current index field is validated based on its data type and a ValidationErrorException is thrown if the validation fails.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Application | Gets the application executing the script.
Public property | BatchField | Gets the BatchField object for the current field.
Public property | IndexField | Gets the IndexField object for the current field.
Public property | LocaleName | Gets the locale name.
Public property | UserID | Gets the User ID.
Top
Events
 | Name | Description
Public event | FieldFormatting | Raised for every field as every other field is exited. Allows the display of a field to differ from the stored value.
Public event | FieldPostProcessing | Raised as the field is exited. Sets e.SaveAndSkipDocument = True to save the field and move to the next document.
Public event | FieldPreProcessing | Raised as the field is entered. Sets e.SaveAndSkipField = True to save the field and skip to the field.
Top
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


FieldScript Constructor

FieldScript Constructor

Default constructor.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public FieldScript()
Public Sub New
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FieldScript Methods

FieldScript Methods

The FieldScript type exposes the following members.

Methods
 | Name | Description
Public method | DefaultFieldFormatting | Call this method in the FieldFormatting event handler to perform the default formatting of the current index field. The current index field is formatted based on its data type and the formatted value is returned if it is formatted successfully. Otherwise, the current index field value is not formatted and returned.
Public method | DefaultFieldPostProcessing | Calls this method in the FieldPostProcessing event handler to perform the default post-field processing of the current index field. The current index field is validated based on its data type and a ValidationErrorException is thrown if the validation fails.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FieldScript.DefaultFieldFormatting Method

FieldScriptDefaultFieldFormatting Method

Call this method in the FieldFormatting event handler to perform the default formatting of the current index field.

The current index field is formatted based on its data type and the formatted value is returned if it is formatted successfully. Otherwise, the current index field value is not formatted and returned.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string DefaultFieldFormatting()
Public Function DefaultFieldFormatting As String

Return Value

Type: String
The formatted value.
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FieldScript.DefaultFieldPostProcessing Method

FieldScriptDefaultFieldPostProcessing Method

Calls this method in the FieldPostProcessing event handler to perform the default post-field processing of the current index field.

The current index field is validated based on its data type and a ValidationErrorException is thrown if the validation fails.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DefaultFieldPostProcessing()
Public Sub DefaultFieldPostProcessing
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FieldScript Properties

FieldScript Properties

The FieldScript type exposes the following members.

Properties
 | Name | Description
Public property | Application | Gets the application executing the script.
Public property | BatchField | Gets the BatchField object for the current field.
Public property | IndexField | Gets the IndexField object for the current field.
Public property | LocaleName | Gets the locale name.
Public property | UserID | Gets the User ID.
Top
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FieldScript.Application Property

FieldScriptApplication Property

Gets the application executing the script.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ApplicationEnum Application { get; }
Public ReadOnly Property Application As ApplicationEnum
    Get

Property Value

Type: ApplicationEnum
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FieldScript.BatchField Property

FieldScriptBatchField Property
Gets the BatchField object for the current field.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public BatchField BatchField { get; }
Public ReadOnly Property BatchField As BatchField
    Get

Property Value

Type: BatchField
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FieldScript.IndexField Property

FieldScriptIndexField Property
Gets the IndexField object for the current field.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IndexField IndexField { get; }
Public ReadOnly Property IndexField As IndexField
    Get

Property Value

Type: IndexField
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FieldScript.LocaleName Property

FieldScriptLocaleName Property

Gets the locale name.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string LocaleName { get; }
Public ReadOnly Property LocaleName As String
    Get

Property Value

Type: String
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FieldScript.UserID Property

FieldScriptUserID Property

Gets the User ID.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string UserID { get; }
Public ReadOnly Property UserID As String
    Get

Property Value

Type: String
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FieldScript Events

FieldScript Events

The FieldScript type exposes the following members.

Events
 | Name | Description
Public event | FieldFormatting | Raised for every field as every other field is exited. Allows the display of a field to differ from the stored value.
Public event | FieldPostProcessing | Raised as the field is exited. Sets e.SaveAndSkipDocument = True to save the field and move to the next document.
Public event | FieldPreProcessing | Raised as the field is entered. Sets e.SaveAndSkipField = True to save the field and skip to the field.
Top
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FieldScript.FieldFormatting Event

FieldScriptFieldFormatting Event

Raised for every field as every other field is exited. Allows the display of a field to differ from the stored value.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event FormatFieldEventHandler FieldFormatting
Public Event FieldFormatting As FormatFieldEventHandler

Value

Type: Kofax.AscentCapture.ScriptingFormatFieldEventHandler
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FieldScript.FieldPostProcessing Event

FieldScriptFieldPostProcessing Event

Raised as the field is exited. Sets e.SaveAndSkipDocument = True to save the field and move to the next document.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PostFieldEventHandler FieldPostProcessing
Public Event FieldPostProcessing As PostFieldEventHandler

Value

Type: Kofax.AscentCapture.ScriptingPostFieldEventHandler
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FieldScript.FieldPreProcessing Event

FieldScriptFieldPreProcessing Event

Raised as the field is entered. Sets e.SaveAndSkipField = True to save the field and skip to the field.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PreFieldEventHandler FieldPreProcessing
Public Event FieldPreProcessing As PreFieldEventHandler

Value

Type: Kofax.AscentCapture.ScriptingPreFieldEventHandler
See Also

Reference

FieldScript Class
Kofax.AscentCapture.Scripting Namespace


FolderValidationScript Class

FolderValidationScript Class

Base class for the folder validation script.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingFolderValidationScript

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public abstract class FolderValidationScript
Public MustInherit Class FolderValidationScript

The FolderValidationScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Application | Gets the application executing the script.
Public property | LocaleName | Gets the locale name.
Public property | UserID | Gets the User ID.
Top
Events
 | Name | Description
Public event | BatchLoading | Called when a batch is opened.
Public event | BatchUnloading | Called when a batch is closed.
Public event | FolderPostProcessing | Called after each folder is closed.
Public event | FolderPreProcessing | Called each time a new folder is opened.
Top
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


FolderValidationScript Methods

FolderValidationScript Methods

The FolderValidationScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.Scripting Namespace


FolderValidationScript Properties

FolderValidationScript Properties

The FolderValidationScript type exposes the following members.

Properties
 | Name | Description
Public property | Application | Gets the application executing the script.
Public property | LocaleName | Gets the locale name.
Public property | UserID | Gets the User ID.
Top
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.Scripting Namespace


FolderValidationScript.Application Property

FolderValidationScriptApplication Property

Gets the application executing the script.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ApplicationEnum Application { get; }
Public ReadOnly Property Application As ApplicationEnum
    Get

Property Value

Type: ApplicationEnum
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.Scripting Namespace


FolderValidationScript.LocaleName Property

FolderValidationScriptLocaleName Property

Gets the locale name.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string LocaleName { get; }
Public ReadOnly Property LocaleName As String
    Get

Property Value

Type: String
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.Scripting Namespace


FolderValidationScript.UserID Property

FolderValidationScriptUserID Property

Gets the User ID.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string UserID { get; }
Public ReadOnly Property UserID As String
    Get

Property Value

Type: String
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.Scripting Namespace


FolderValidationScript Events

FolderValidationScript Events

The FolderValidationScript type exposes the following members.

Events
 | Name | Description
Public event | BatchLoading | Called when a batch is opened.
Public event | BatchUnloading | Called when a batch is closed.
Public event | FolderPostProcessing | Called after each folder is closed.
Public event | FolderPreProcessing | Called each time a new folder is opened.
Top
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.Scripting Namespace


FolderValidationScript.BatchLoading Event

FolderValidationScriptBatchLoading Event

Called when a batch is opened.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event BatchEventHandler BatchLoading
Public Event BatchLoading As BatchEventHandler

Value

Type: Kofax.AscentCapture.ScriptingBatchEventHandler
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.Scripting Namespace


FolderValidationScript.BatchUnloading Event

FolderValidationScriptBatchUnloading Event

Called when a batch is closed.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event BatchEventHandler BatchUnloading
Public Event BatchUnloading As BatchEventHandler

Value

Type: Kofax.AscentCapture.ScriptingBatchEventHandler
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.Scripting Namespace


FolderValidationScript.FolderPostProcessing Event

FolderValidationScriptFolderPostProcessing Event

Called after each folder is closed.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PostFolderEventHandler FolderPostProcessing
Public Event FolderPostProcessing As PostFolderEventHandler

Value

Type: Kofax.AscentCapture.ScriptingPostFolderEventHandler
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.Scripting Namespace


FolderValidationScript.FolderPreProcessing Event

FolderValidationScriptFolderPreProcessing Event

Called each time a new folder is opened.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PreFolderEventHandler FolderPreProcessing
Public Event FolderPreProcessing As PreFolderEventHandler

Value

Type: Kofax.AscentCapture.ScriptingPreFolderEventHandler
See Also

Reference

FolderValidationScript Class
Kofax.AscentCapture.Scripting Namespace


FormatFieldEventArgs Class

FormatFieldEventArgs Class

This class represents the event arguments for the FieldScript.FieldFormatting event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingFormatFieldEventArgs

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class FormatFieldEventArgs
Public NotInheritable Class FormatFieldEventArgs

The FormatFieldEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FormatFieldEventArgs(BatchField, String) | Initializes a new instance of the Kofax.AscentCapture.Scripting.FormatFieldEventArgs class.
Public method | FormatFieldEventArgs(IndexField, String) | Initializes a new instance of the Kofax.AscentCapture.Scripting.FormatFieldEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DisplayValue | Gets or sets the current display value of this index field.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


FormatFieldEventArgs Constructor

FormatFieldEventArgs Constructor
Overload List
 | Name | Description
Public method | FormatFieldEventArgs(BatchField, String) | Initializes a new instance of the Kofax.AscentCapture.Scripting.FormatFieldEventArgs class.
Public method | FormatFieldEventArgs(IndexField, String) | Initializes a new instance of the Kofax.AscentCapture.Scripting.FormatFieldEventArgs class.
Top
See Also

Reference

FormatFieldEventArgs Class
Kofax.AscentCapture.Scripting Namespace


FormatFieldEventArgs Constructor (BatchField, String)

FormatFieldEventArgs Constructor (BatchField, String)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.Scripting.FormatFieldEventArgs class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public FormatFieldEventArgs(
    BatchField oBatchField,
    string strDisplayValue
)
Public Sub New (
    oBatchField As BatchField,
    strDisplayValue As String
)

Parameters

oBatchField
Type: BatchField
IndexField object.
strDisplayValue
Type: SystemString
Display value.
See Also

Reference

FormatFieldEventArgs Class
FormatFieldEventArgs Overload
Kofax.AscentCapture.Scripting Namespace


FormatFieldEventArgs Constructor (IndexField, String)

FormatFieldEventArgs Constructor (IndexField, String)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.Scripting.FormatFieldEventArgs class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public FormatFieldEventArgs(
    IndexField oIndexField,
    string strDisplayValue
)
Public Sub New (
    oIndexField As IndexField,
    strDisplayValue As String
)

Parameters

oIndexField
Type: IndexField
IndexField object.
strDisplayValue
Type: SystemString
Display value.
See Also

Reference

FormatFieldEventArgs Class
FormatFieldEventArgs Overload
Kofax.AscentCapture.Scripting Namespace


FormatFieldEventArgs Methods

FormatFieldEventArgs Methods

The FormatFieldEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FormatFieldEventArgs Class
Kofax.AscentCapture.Scripting Namespace


FormatFieldEventArgs Properties

FormatFieldEventArgs Properties

The FormatFieldEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DisplayValue | Gets or sets the current display value of this index field.
Top
See Also

Reference

FormatFieldEventArgs Class
Kofax.AscentCapture.Scripting Namespace


FormatFieldEventArgs.DisplayValue Property

FormatFieldEventArgsDisplayValue Property

Gets or sets the current display value of this index field.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string DisplayValue { get; set; }
Public Property DisplayValue As String
    Get
    Set

Property Value

Type: String
See Also

Reference

FormatFieldEventArgs Class
Kofax.AscentCapture.Scripting Namespace


FormatFieldEventHandler Delegate

FormatFieldEventHandler Delegate

Defines callback for the FieldFormatting event.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void FormatFieldEventHandler(
    Object sender,
    FormatFieldEventArgs e
)
Public Delegate Sub FormatFieldEventHandler (
    sender As Object,
    e As FormatFieldEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.ScriptingFormatFieldEventArgs
The Kofax.AscentCapture.Scripting.FormatFieldEventArgs object that contains the Kofax.AscentCaptureModule.IndexField object and DisplayValue property. Handles this event to format the current index field value.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


IndexFieldVariableAttribute Class

IndexFieldVariableAttribute Class

This is an attribute class used to indicate that the current field in the class is an index field in the document validation script, or folder validation script.

Inheritance Hierarchy
SystemObject
SystemAttribute
Kofax.AscentCapture.ScriptingIndexFieldVariableAttribute

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[AttributeUsageAttribute(AttributeTargets.Field)]
public sealed class IndexFieldVariableAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Field)>
Public NotInheritable Class IndexFieldVariableAttribute
    Inherits Attribute

The IndexFieldVariableAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | IndexFieldVariableAttribute | Initializes a new instance of the Kofax.AscentCapture.Scripting.IndexFieldVariableAttribute class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets the index field name.
Public property | TypeId | (Inherited from Attribute.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | (Inherited from Attribute.)
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


IndexFieldVariableAttribute Constructor

IndexFieldVariableAttribute Constructor

Initializes a new instance of the Kofax.AscentCapture.Scripting.IndexFieldVariableAttribute class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IndexFieldVariableAttribute(
    string strFieldName
)
Public Sub New (
    strFieldName As String
)

Parameters

strFieldName
Type: SystemString
Index field name.
See Also

Reference

IndexFieldVariableAttribute Class
Kofax.AscentCapture.Scripting Namespace


IndexFieldVariableAttribute Methods

IndexFieldVariableAttribute Methods

The IndexFieldVariableAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Public method | ToString | (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | (Inherited from Attribute.)
Top
See Also

Reference

IndexFieldVariableAttribute Class
Kofax.AscentCapture.Scripting Namespace


IndexFieldVariableAttribute Properties

IndexFieldVariableAttribute Properties

The IndexFieldVariableAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the index field name.
Public property | TypeId | (Inherited from Attribute.)
Top
See Also

Reference

IndexFieldVariableAttribute Class
Kofax.AscentCapture.Scripting Namespace


IndexFieldVariableAttribute.Name Property

IndexFieldVariableAttributeName Property

Gets the index field name.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

IndexFieldVariableAttribute Class
Kofax.AscentCapture.Scripting Namespace


PostDocumentEventArgs Class

PostDocumentEventArgs Class

This class represents the event arguments for the DocumentValidationScript.DocumentPostProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingPostDocumentEventArgs

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PostDocumentEventArgs
Public NotInheritable Class PostDocumentEventArgs

The PostDocumentEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PostDocumentEventArgs | Initializes a new instance of the Kofax.AscentCapture.Scripting.PostDocumentEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DataAccepted | Indicates whether the operator accepted or rejected the data.
Public property | Document | Gets the Document object.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PostDocumentEventArgs Constructor

PostDocumentEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.Scripting.PostDocumentEventArgs class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PostDocumentEventArgs(
    Document oDocument,
    bool bDataAccepted
)
Public Sub New (
    oDocument As Document,
    bDataAccepted As Boolean
)

Parameters

oDocument
Type: Document
Document object.
bDataAccepted
Type: SystemBoolean
Whether the data is accepted.
See Also

Reference

PostDocumentEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostDocumentEventArgs Methods

PostDocumentEventArgs Methods

The PostDocumentEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PostDocumentEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostDocumentEventArgs Properties

PostDocumentEventArgs Properties

The PostDocumentEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DataAccepted | Indicates whether the operator accepted or rejected the data.
Public property | Document | Gets the Document object.
Top
See Also

Reference

PostDocumentEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostDocumentEventArgs.DataAccepted Property

PostDocumentEventArgsDataAccepted Property

Indicates whether the operator accepted or rejected the data.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool DataAccepted { get; }
Public ReadOnly Property DataAccepted As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PostDocumentEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostDocumentEventArgs.Document Property

PostDocumentEventArgsDocument Property

Gets the Document object.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get

Property Value

Type: Document
See Also

Reference

PostDocumentEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostDocumentEventHandler Delegate

PostDocumentEventHandler Delegate

Defines callback for the DocumentPostProcessing event.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PostDocumentEventHandler(
    Object sender,
    PostDocumentEventArgs e
)
Public Delegate Sub PostDocumentEventHandler (
    sender As Object,
    e As PostDocumentEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.ScriptingPostDocumentEventArgs
The Kofax.AscentCapture.Scripting.PostDocumentEventArgs object that contains the Kofax.AscentCaptureModule.Document object. Handles this event to perform cleanup before the document is closed.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PostFieldEventArgs Class

PostFieldEventArgs Class

This class represents the event arguments for the FieldScript.FieldPostProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingPostFieldEventArgs

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PostFieldEventArgs
Public NotInheritable Class PostFieldEventArgs

The PostFieldEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PostFieldEventArgs(BatchField, String) | Initializes a new instance of the Kofax.AscentCapture.Scripting.PostFieldEventArgs class.
Public method | PostFieldEventArgs(IndexField, String) | Initializes a new instance of the Kofax.AscentCapture.Scripting.PostFieldEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | PreviousValue | Gets the value entered when the validation operator tabs out of the field.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PostFieldEventArgs Constructor

PostFieldEventArgs Constructor
Overload List
 | Name | Description
Public method | PostFieldEventArgs(BatchField, String) | Initializes a new instance of the Kofax.AscentCapture.Scripting.PostFieldEventArgs class.
Public method | PostFieldEventArgs(IndexField, String) | Initializes a new instance of the Kofax.AscentCapture.Scripting.PostFieldEventArgs class.
Top
See Also

Reference

PostFieldEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostFieldEventArgs Constructor (BatchField, String)

PostFieldEventArgs Constructor (BatchField, String)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.Scripting.PostFieldEventArgs class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PostFieldEventArgs(
    BatchField oIndexField,
    string strEnteredValue
)
Public Sub New (
    oIndexField As BatchField,
    strEnteredValue As String
)

Parameters

oIndexField
Type: BatchField
IndexField object.
strEnteredValue
Type: SystemString
Entered value.
See Also

Reference

PostFieldEventArgs Class
PostFieldEventArgs Overload
Kofax.AscentCapture.Scripting Namespace


PostFieldEventArgs Constructor (IndexField, String)

PostFieldEventArgs Constructor (IndexField, String)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.Scripting.PostFieldEventArgs class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PostFieldEventArgs(
    IndexField oIndexField,
    string strEnteredValue
)
Public Sub New (
    oIndexField As IndexField,
    strEnteredValue As String
)

Parameters

oIndexField
Type: IndexField
IndexField object.
strEnteredValue
Type: SystemString
Entered value.
See Also

Reference

PostFieldEventArgs Class
PostFieldEventArgs Overload
Kofax.AscentCapture.Scripting Namespace


PostFieldEventArgs Methods

PostFieldEventArgs Methods

The PostFieldEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PostFieldEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostFieldEventArgs Properties

PostFieldEventArgs Properties

The PostFieldEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | PreviousValue | Gets the value entered when the validation operator tabs out of the field.
Top
See Also

Reference

PostFieldEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostFieldEventArgs.PreviousValue Property

PostFieldEventArgsPreviousValue Property

Gets the value entered when the validation operator tabs out of the field.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string PreviousValue { get; }
Public ReadOnly Property PreviousValue As String
    Get

Property Value

Type: String
See Also

Reference

PostFieldEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostFieldEventHandler Delegate

PostFieldEventHandler Delegate

Defines callback for the FieldPostProcessing event.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PostFieldEventHandler(
    Object sender,
    PostFieldEventArgs e
)
Public Delegate Sub PostFieldEventHandler (
    sender As Object,
    e As PostFieldEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.ScriptingPostFieldEventArgs
The Kofax.AscentCapture.Scripting.PostFieldEventArgs object that contains the Kofax.AscentCaptureModule.IndexField object. Handles this event to perform post-field processing.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PostFolderEventArgs Class

PostFolderEventArgs Class

This class represents the event arguments for the FolderValidationScript.FolderPostProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingPostFolderEventArgs

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PostFolderEventArgs
Public NotInheritable Class PostFolderEventArgs

The PostFolderEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PostFolderEventArgs | Initializes a new instance of the Kofax.AscentCapture.Scripting.PostFolderEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DataAccepted | Indicates whether the operator accepted or rejected the data.
Public property | Folder | Gets the Folder object.
Top
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PostFolderEventArgs Constructor

PostFolderEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.Scripting.PostFolderEventArgs class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PostFolderEventArgs(
    Folder oFolder,
    bool bDataAccepted
)
Public Sub New (
    oFolder As Folder,
    bDataAccepted As Boolean
)

Parameters

oFolder
Type: Folder
Folder object.
bDataAccepted
Type: SystemBoolean
Whether the data is accepted.
See Also

Reference

PostFolderEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostFolderEventArgs Methods

PostFolderEventArgs Methods

The PostFolderEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PostFolderEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostFolderEventArgs Properties

PostFolderEventArgs Properties

The PostFolderEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | DataAccepted | Indicates whether the operator accepted or rejected the data.
Public property | Folder | Gets the Folder object.
Top
See Also

Reference

PostFolderEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostFolderEventArgs.DataAccepted Property

PostFolderEventArgsDataAccepted Property

Indicates whether the operator accepted or rejected the data.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool DataAccepted { get; }
Public ReadOnly Property DataAccepted As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PostFolderEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostFolderEventArgs.Folder Property

PostFolderEventArgsFolder Property

Gets the Folder object.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Folder Folder { get; }
Public ReadOnly Property Folder As Folder
    Get

Property Value

Type: Folder
See Also

Reference

PostFolderEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostFolderEventHandler Delegate

PostFolderEventHandler Delegate

Defines callback for the FolderPostProcessing event.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PostFolderEventHandler(
    Object sender,
    PostFolderEventArgs e
)
Public Delegate Sub PostFolderEventHandler (
    sender As Object,
    e As PostFolderEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.ScriptingPostFolderEventArgs
The Kofax.AscentCapture.Scripting.PostFolderEventArgs object that contains the Kofax.AscentCaptureModule.Folder object. Handles this event to perform cleanup before the folder is closed.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PostRecognitionEventArgs Class

PostRecognitionEventArgs Class

This class represents the event arguments for the RecognitionScript.RecognitionPostProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingPostRecognitionEventArgs

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PostRecognitionEventArgs
Public NotInheritable Class PostRecognitionEventArgs

The PostRecognitionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PostRecognitionEventArgs | Initializes a new instance of the Kofax.AscentCapture.Scripting.PostRecognitionEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
Name Description
Public property Confidence

The confidence level of the recognition engine. It is an integer between 0-100, with 100 being the highest confidence. If you perform recognition with a custom engine, you are responsible for setting this value.

Public property ImageFile

The file name of the zone snippet currently being processed. Image processing has already been performed by the time the script gets access to this file. Note that this is a temporary file and is read-only; attempting to modify the file may have unpredictable consequences. The value is empty if the RecognitionScript.ImageFileRequired property is set to False. Otherwise, it contains the image file name.

Public property RegistrationHorizBMU

Gets or sets the horizontal registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). Registration offsets are only produced by the Kofax OCR and Kofax High Performance OCR/ICR engines. If you want to design a custom profile that produces registration offsets, you must derive your custom profile from the profile of one of those engines (you can skip the default engine logic by setting the SaveAndSkip property to True). Registration offsets may be generated by any zone type, but the values are ignored unless the zone is a registration zone. If you are customizing a registration zone and want to guarantee success, the script must have the Value property set to SearchText, Confidence set to 100, and the two offset variables set to a value >= 0. These values default to -1 if the default engine has not yet been run, or does not generate offsets.

Public property RegistrationVertBMU

Gets or sets the vertical registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). See RegistrationHorizBMU property for more information.

Public property SearchText

The search text is the expected search string set in the Administration module for a separation, form identification, or registration zone. Additionally, if the field type for an index zone has exactly one suggested value, and is marked as Force Match, then the search text exposes that value.

Public property Value

The current recognized value. It is null or Nothing in the PreRecognitionEventArgs object and is overwritten in the PostRecognitionEventArgs object by the Kofax recognition engine unless PreRecognitionEventArgs.SaveAndSkip is set to True. It can be modified in the PostRecognitionEventArgs object.

Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PostRecognitionEventArgs Constructor

PostRecognitionEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.Scripting.PostRecognitionEventArgs class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PostRecognitionEventArgs(
    int nConfidence,
    string strImageFile,
    int nRegistrationHorizBMU,
    int nRegistrationVertBMU,
    string strSearchText,
    string strValue
)
Public Sub New (
    nConfidence As Integer,
    strImageFile As String,
    nRegistrationHorizBMU As Integer,
    nRegistrationVertBMU As Integer,
    strSearchText As String,
    strValue As String
)

Parameters

nConfidence
Type: SystemInt32
Confidence.
strImageFile
Type: SystemString
ImageFile.
nRegistrationHorizBMU
Type: SystemInt32
RegistrationHorizBMU.
nRegistrationVertBMU
Type: SystemInt32
RegistrationVertBMU.
strSearchText
Type: SystemString
SearchText.
strValue
Type: SystemString
Value.
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostRecognitionEventArgs Methods

PostRecognitionEventArgs Methods

The PostRecognitionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostRecognitionEventArgs Properties

PostRecognitionEventArgs Properties

The PostRecognitionEventArgs type exposes the following members.

Properties
Name Description
Public property Confidence

The confidence level of the recognition engine. It is an integer between 0-100, with 100 being the highest confidence. If you perform recognition with a custom engine, you are responsible for setting this value.

Public property ImageFile

The file name of the zone snippet currently being processed. Image processing has already been performed by the time the script gets access to this file. Note that this is a temporary file and is read-only; attempting to modify the file may have unpredictable consequences. The value is empty if the RecognitionScript.ImageFileRequired property is set to False. Otherwise, it contains the image file name.

Public property RegistrationHorizBMU

Gets or sets the horizontal registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). Registration offsets are only produced by the Kofax OCR and Kofax High Performance OCR/ICR engines. If you want to design a custom profile that produces registration offsets, you must derive your custom profile from the profile of one of those engines (you can skip the default engine logic by setting the SaveAndSkip property to True). Registration offsets may be generated by any zone type, but the values are ignored unless the zone is a registration zone. If you are customizing a registration zone and want to guarantee success, the script must have the Value property set to SearchText, Confidence set to 100, and the two offset variables set to a value >= 0. These values default to -1 if the default engine has not yet been run, or does not generate offsets.

Public property RegistrationVertBMU

Gets or sets the vertical registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). See RegistrationHorizBMU property for more information.

Public property SearchText

The search text is the expected search string set in the Administration module for a separation, form identification, or registration zone. Additionally, if the field type for an index zone has exactly one suggested value, and is marked as Force Match, then the search text exposes that value.

Public property Value

The current recognized value. It is null or Nothing in the PreRecognitionEventArgs object and is overwritten in the PostRecognitionEventArgs object by the Kofax recognition engine unless PreRecognitionEventArgs.SaveAndSkip is set to True. It can be modified in the PostRecognitionEventArgs object.

Top
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostRecognitionEventArgs.Confidence Property

PostRecognitionEventArgsConfidence Property

The confidence level of the recognition engine. It is an integer between 0-100, with 100 being the highest confidence. If you perform recognition with a custom engine, you are responsible for setting this value.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Confidence { get; set; }
Public Property Confidence As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostRecognitionEventArgs.ImageFile Property

PostRecognitionEventArgsImageFile Property

The file name of the zone snippet currently being processed. Image processing has already been performed by the time the script gets access to this file. Note that this is a temporary file and is read-only; attempting to modify the file may have unpredictable consequences. The value is empty if the RecognitionScript.ImageFileRequired property is set to False. Otherwise, it contains the image file name.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ImageFile { get; }
Public ReadOnly Property ImageFile As String
    Get

Property Value

Type: String
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostRecognitionEventArgs.RegistrationHorizBMU Property

PostRecognitionEventArgsRegistrationHorizBMU Property

Gets or sets the horizontal registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). Registration offsets are only produced by the Kofax OCR and Kofax High Performance OCR/ICR engines. If you want to design a custom profile that produces registration offsets, you must derive your custom profile from the profile of one of those engines (you can skip the default engine logic by setting the SaveAndSkip property to True). Registration offsets may be generated by any zone type, but the values are ignored unless the zone is a registration zone. If you are customizing a registration zone and want to guarantee success, the script must have the Value property set to SearchText, Confidence set to 100, and the two offset variables set to a value >= 0. These values default to -1 if the default engine has not yet been run, or does not generate offsets.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int RegistrationHorizBMU { get; set; }
Public Property RegistrationHorizBMU As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostRecognitionEventArgs.RegistrationVertBMU Property

PostRecognitionEventArgsRegistrationVertBMU Property

Gets or sets the vertical registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). See RegistrationHorizBMU property for more information.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int RegistrationVertBMU { get; set; }
Public Property RegistrationVertBMU As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostRecognitionEventArgs.SearchText Property

PostRecognitionEventArgsSearchText Property

The search text is the expected search string set in the Administration module for a separation, form identification, or registration zone. Additionally, if the field type for an index zone has exactly one suggested value, and is marked as Force Match, then the search text exposes that value.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string SearchText { get; }
Public ReadOnly Property SearchText As String
    Get

Property Value

Type: String
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostRecognitionEventArgs.Value Property

PostRecognitionEventArgsValue Property

The current recognized value. It is null or Nothing in the PreRecognitionEventArgs object and is overwritten in the PostRecognitionEventArgs object by the Kofax recognition engine unless PreRecognitionEventArgs.SaveAndSkip is set to True. It can be modified in the PostRecognitionEventArgs object.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PostRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PostRecognitionEventHandler Delegate

PostRecognitionEventHandler Delegate

Defines callback for RecognitionPostProcessing event.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PostRecognitionEventHandler(
    Object sender,
    PostRecognitionEventArgs e
)
Public Delegate Sub PostRecognitionEventHandler (
    sender As Object,
    e As PostRecognitionEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.ScriptingPostRecognitionEventArgs
The Kofax.AscentCapture.Scripting.PostRecognitionEventArgs object containing the recognition information.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PreDocumentEventArgs Class

PreDocumentEventArgs Class

This class represents the event arguments for the DocumentValidationScript.DocumentPreProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingPreDocumentEventArgs

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PreDocumentEventArgs
Public NotInheritable Class PreDocumentEventArgs

The PreDocumentEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PreDocumentEventArgs | Initializes a new instance of the Kofax.AscentCapture.Scripting.PreDocumentEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AlreadyProcessed | Indicates whether the document is being processed for the first time or if it has already been processed.
Public property | Document | Gets the Document object.
Public property | SaveAndSkip | Gets or sets the SaveAndSkip flag. True indicates that all data fields should be saved and the Validation or Verification module should advance to the next document. Typically used to automatically skip a document that does not need to be validated by an operator (for example, because the confidence level of all the fields is high). The FieldScript.FieldPreProcessing and FieldScript.FieldPostProcessing objects for all remaining fields are not called, but the DocumentValidationScript.DocumentPostProcessing event is called.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PreDocumentEventArgs Constructor

PreDocumentEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.Scripting.PreDocumentEventArgs class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PreDocumentEventArgs(
    Document oDocument,
    bool bAlreadyProcessed
)
Public Sub New (
    oDocument As Document,
    bAlreadyProcessed As Boolean
)

Parameters

oDocument
Type: Document
Document object.
bAlreadyProcessed
Type: SystemBoolean
Indicates whether the document is already processed.
See Also

Reference

PreDocumentEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreDocumentEventArgs Methods

PreDocumentEventArgs Methods

The PreDocumentEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PreDocumentEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreDocumentEventArgs Properties

PreDocumentEventArgs Properties

The PreDocumentEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AlreadyProcessed | Indicates whether the document is being processed for the first time or if it has already been processed.
Public property | Document | Gets the Document object.
Public property | SaveAndSkip | Gets or sets the SaveAndSkip flag. True indicates that all data fields should be saved and the Validation or Verification module should advance to the next document. Typically used to automatically skip a document that does not need to be validated by an operator (for example, because the confidence level of all the fields is high). The FieldScript.FieldPreProcessing and FieldScript.FieldPostProcessing objects for all remaining fields are not called, but the DocumentValidationScript.DocumentPostProcessing event is called.
Top
See Also

Reference

PreDocumentEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreDocumentEventArgs.AlreadyProcessed Property

PreDocumentEventArgsAlreadyProcessed Property

Indicates whether the document is being processed for the first time or if it has already been processed.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool AlreadyProcessed { get; }
Public ReadOnly Property AlreadyProcessed As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PreDocumentEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreDocumentEventArgs.Document Property

PreDocumentEventArgsDocument Property

Gets the Document object.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Document Document { get; }
Public ReadOnly Property Document As Document
    Get

Property Value

Type: Document
See Also

Reference

PreDocumentEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreDocumentEventArgs.SaveAndSkip Property

PreDocumentEventArgsSaveAndSkip Property

Gets or sets the SaveAndSkip flag. True indicates that all data fields should be saved and the Validation or Verification module should advance to the next document. Typically used to automatically skip a document that does not need to be validated by an operator (for example, because the confidence level of all the fields is high). The FieldScript.FieldPreProcessing and FieldScript.FieldPostProcessing objects for all remaining fields are not called, but the DocumentValidationScript.DocumentPostProcessing event is called.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SaveAndSkip { get; set; }
Public Property SaveAndSkip As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PreDocumentEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreDocumentEventHandler Delegate

PreDocumentEventHandler Delegate

Defines callback for the DocumentPreProcessing event.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PreDocumentEventHandler(
    Object sender,
    PreDocumentEventArgs e
)
Public Delegate Sub PreDocumentEventHandler (
    sender As Object,
    e As PreDocumentEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.ScriptingPreDocumentEventArgs
The Kofax.AscentCapture.Scripting.PreDocumentEventArgs object that contains the Kofax.AscentCaptureModule.Document object.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PreFieldEventArgs Class

PreFieldEventArgs Class

This class represents the event arguments for the FieldScript.FieldPreProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingPreFieldEventArgs

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PreFieldEventArgs
Public NotInheritable Class PreFieldEventArgs

The PreFieldEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PreFieldEventArgs(BatchField) | Initializes a new instance of the Kofax.AscentCapture.Scripting.PreFieldEventArgs class.
Public method | PreFieldEventArgs(IndexField) | Initializes a new instance of the Kofax.AscentCapture.Scripting.PreFieldEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SkipMode | Indicates whether to skip the current field, document, or folder. Default is NoSkip.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PreFieldEventArgs Constructor

PreFieldEventArgs Constructor
Overload List
 | Name | Description
Public method | PreFieldEventArgs(BatchField) | Initializes a new instance of the Kofax.AscentCapture.Scripting.PreFieldEventArgs class.
Public method | PreFieldEventArgs(IndexField) | Initializes a new instance of the Kofax.AscentCapture.Scripting.PreFieldEventArgs class.
Top
See Also

Reference

PreFieldEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreFieldEventArgs Constructor (BatchField)

PreFieldEventArgs Constructor (BatchField)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.Scripting.PreFieldEventArgs class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PreFieldEventArgs(
    BatchField oIndexField
)
Public Sub New (
    oIndexField As BatchField
)

Parameters

oIndexField
Type: BatchField
IndexField object.
See Also

Reference

PreFieldEventArgs Class
PreFieldEventArgs Overload
Kofax.AscentCapture.Scripting Namespace


PreFieldEventArgs Constructor (IndexField)

PreFieldEventArgs Constructor (IndexField)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.Scripting.PreFieldEventArgs class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PreFieldEventArgs(
    IndexField oIndexField
)
Public Sub New (
    oIndexField As IndexField
)

Parameters

oIndexField
Type: IndexField
IndexField object.
See Also

Reference

PreFieldEventArgs Class
PreFieldEventArgs Overload
Kofax.AscentCapture.Scripting Namespace


PreFieldEventArgs Methods

PreFieldEventArgs Methods

The PreFieldEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PreFieldEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreFieldEventArgs Properties

PreFieldEventArgs Properties

The PreFieldEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | SkipMode | Indicates whether to skip the current field, document, or folder. Default is NoSkip.
Top
See Also

Reference

PreFieldEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreFieldEventArgs.SkipMode Property

PreFieldEventArgsSkipMode Property

Indicates whether to skip the current field, document, or folder. Default is NoSkip.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PreFieldEventArgsSkipModeEnum SkipMode { get; set; }
Public Property SkipMode As PreFieldEventArgsSkipModeEnum
    Get
    Set

Property Value

Type: PreFieldEventArgsSkipModeEnum
See Also

Reference

PreFieldEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreFieldEventArgs.SkipModeEnum Enumeration

PreFieldEventArgsSkipModeEnum Enumeration

Skips mode enumeration.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public enum SkipModeEnum
Public Enumeration SkipModeEnum
Members
Member name | Value | Description
NoSkip | 0 | Does not skip.
SaveAndSkipDocumentOrFolder | 1 | Saves and skips the document or folder.
SaveAndSkipField | 2 | Saves and skips the field.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PreFieldEventHandler Delegate

PreFieldEventHandler Delegate

Defines callback for the FieldPreProcessing event.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PreFieldEventHandler(
    Object sender,
    PreFieldEventArgs e
)
Public Delegate Sub PreFieldEventHandler (
    sender As Object,
    e As PreFieldEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.ScriptingPreFieldEventArgs
The Kofax.AscentCapture.Scripting.PreFieldEventArgs object that contains the Kofax.AscentCaptureModule.IndexField object. Handles this event to perform pre-field processing.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PreFolderEventArgs Class

PreFolderEventArgs Class

This class represents the event arguments for the FolderValidationScript.FolderPreProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingPreFolderEventArgs

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PreFolderEventArgs
Public NotInheritable Class PreFolderEventArgs

The PreFolderEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PreFolderEventArgs | Initializes a new instance of the Kofax.AscentCapture.Scripting.PreFolderEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AlreadyProcessed | Indicates whether the folder is being processed for the first time or if it has already been processed.
Public property | Folder | Gets the Folder object.
Public property | SaveAndSkip | Gets or sets the SaveAndSkip flag. True indicates that all data fields should be saved and the Validation or Verification module should advance to the next folder. Typically used to automatically skip a folder that does not need to be validated by an operator (for example, because the confidence level of all the fields is high). The FieldScript.FieldPreProcessing and FieldScript.FieldPostProcessing objects for all remaining fields are not called, but the FolderValidationScript.FolderPostProcessing event is called.
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PreFolderEventArgs Constructor

PreFolderEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.Scripting.PreFolderEventArgs class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PreFolderEventArgs(
    Folder oFolder,
    bool bAlreadyProcessed
)
Public Sub New (
    oFolder As Folder,
    bAlreadyProcessed As Boolean
)

Parameters

oFolder
Type: Folder
Folder object.
bAlreadyProcessed
Type: SystemBoolean
Whether the folder is already processed.
See Also

Reference

PreFolderEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreFolderEventArgs Methods

PreFolderEventArgs Methods

The PreFolderEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PreFolderEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreFolderEventArgs Properties

PreFolderEventArgs Properties

The PreFolderEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AlreadyProcessed | Indicates whether the folder is being processed for the first time or if it has already been processed.
Public property | Folder | Gets the Folder object.
Public property | SaveAndSkip | Gets or sets the SaveAndSkip flag. True indicates that all data fields should be saved and the Validation or Verification module should advance to the next folder. Typically used to automatically skip a folder that does not need to be validated by an operator (for example, because the confidence level of all the fields is high). The FieldScript.FieldPreProcessing and FieldScript.FieldPostProcessing objects for all remaining fields are not called, but the FolderValidationScript.FolderPostProcessing event is called.
Top
See Also

Reference

PreFolderEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreFolderEventArgs.AlreadyProcessed Property

PreFolderEventArgsAlreadyProcessed Property

Indicates whether the folder is being processed for the first time or if it has already been processed.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool AlreadyProcessed { get; }
Public ReadOnly Property AlreadyProcessed As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

PreFolderEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreFolderEventArgs.Folder Property

PreFolderEventArgsFolder Property

Gets the Folder object.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Folder Folder { get; }
Public ReadOnly Property Folder As Folder
    Get

Property Value

Type: Folder
See Also

Reference

PreFolderEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreFolderEventArgs.SaveAndSkip Property

PreFolderEventArgsSaveAndSkip Property

Gets or sets the SaveAndSkip flag. True indicates that all data fields should be saved and the Validation or Verification module should advance to the next folder. Typically used to automatically skip a folder that does not need to be validated by an operator (for example, because the confidence level of all the fields is high). The FieldScript.FieldPreProcessing and FieldScript.FieldPostProcessing objects for all remaining fields are not called, but the FolderValidationScript.FolderPostProcessing event is called.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SaveAndSkip { get; set; }
Public Property SaveAndSkip As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PreFolderEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreFolderEventHandler Delegate

PreFolderEventHandler Delegate

Defines callback for the FolderPreProcessing event.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PreFolderEventHandler(
    Object sender,
    PreFolderEventArgs e
)
Public Delegate Sub PreFolderEventHandler (
    sender As Object,
    e As PreFolderEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.ScriptingPreFolderEventArgs
The Kofax.AscentCapture.Scripting.PreFolderEventArgs object that contains the Kofax.AscentCaptureModule.Folder object.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PreRecognitionEventArgs Class

PreRecognitionEventArgs Class

This class represents the event arguments for the RecognitionScript.RecognitionPreProcessing event.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingPreRecognitionEventArgs

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public sealed class PreRecognitionEventArgs
Public NotInheritable Class PreRecognitionEventArgs

The PreRecognitionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | PreRecognitionEventArgs | Initializes a new instance of the Kofax.AscentCapture.Scripting.PreRecognitionEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
Name Description
Public property Confidence

The confidence level of the recognition engine. It is an integer between 0-100, with 100 being the highest confidence. If you perform recognition with a custom engine, you are responsible for setting this value.

Public property ImageFile

The file name of the zone snippet currently being processed. Image processing has already been performed by the time the script gets access to this file. Note that this is a temporary file and is read-only; attempting to modify the file may have unpredictable consequences. The value is empty if the RecognitionScript.ImageFileRequired property is set to false. Otherwise, it contains the image file name.

Public property RegistrationHorizBMU

Gets or sets the horizontal registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). Registration offsets are only produced by the Kofax OCR and Kofax High Performance OCR/ICR engines. If you want to design a custom profile that produces registration offsets, you must derive your custom profile from the profile of one of those engines (you can skip the default engine logic by setting the SaveAndSkip property to True). Registration offsets may be generated by any zone type, but the values are ignored unless the zone is a registration zone. If you are customizing a registration zone and want to guarantee success, the script must have the Value property set to SearchText, Confidence set to 100, and the two offset variables set to a value >= 0. These values default to -1 if the default engine has not yet been run, or does not generate offsets.

Public property RegistrationVertBMU

Gets or sets the vertical registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). See RegistrationHorizBMU property for more information.

Public property SaveAndSkip

Gets or sets the SaveAndSkip flag. If True, sets the recognition information and skips the Kofax recognition. The RecognitionScript.RecognitionPostProcessing event is still called if it’s set in RecognitionScript.RecognitionPreProcessing event.

Public property SearchText

The search text is the expected search string set in the Administration module for a separation, form identification, or registration zone. Additionally, if the field type for an index zone has exactly one suggested value, and is marked as Force Match, then the search text exposes that value.

Public property Value

The current recognized value. It is null or Nothing in the PreRecognitionEventArgs object and is overwritten in the PostRecognitionEventArgs object by the Kofax recognition engine unless PreRecognitionEventArgs.SaveAndSkip is set to true. It can be modified in the PostRecognitionEventArgs object.

Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


PreRecognitionEventArgs Constructor

PreRecognitionEventArgs Constructor

Initializes a new instance of the Kofax.AscentCapture.Scripting.PreRecognitionEventArgs class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public PreRecognitionEventArgs(
    int nConfidence,
    string strImageFile,
    int nRegistrationHorizBMU,
    int nRegistrationVertBMU,
    bool bSaveAndSkip,
    string strSearchText,
    string strValue
)
Public Sub New (
    nConfidence As Integer,
    strImageFile As String,
    nRegistrationHorizBMU As Integer,
    nRegistrationVertBMU As Integer,
    bSaveAndSkip As Boolean,
    strSearchText As String,
    strValue As String
)

Parameters

nConfidence
Type: SystemInt32
Confidence.
strImageFile
Type: SystemString
ImageFile.
nRegistrationHorizBMU
Type: SystemInt32
RegistrationHorizBMU.
nRegistrationVertBMU
Type: SystemInt32
RegistrationVertBMU.
bSaveAndSkip
Type: SystemBoolean
SaveAndSkip.
strSearchText
Type: SystemString
SearchText.
strValue
Type: SystemString
Value.
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreRecognitionEventArgs Methods

PreRecognitionEventArgs Methods

The PreRecognitionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreRecognitionEventArgs Properties

PreRecognitionEventArgs Properties

The PreRecognitionEventArgs type exposes the following members.

Properties
Name Description
Public property Confidence

The confidence level of the recognition engine. It is an integer between 0-100, with 100 being the highest confidence. If you perform recognition with a custom engine, you are responsible for setting this value.

Public property ImageFile

The file name of the zone snippet currently being processed. Image processing has already been performed by the time the script gets access to this file. Note that this is a temporary file and is read-only; attempting to modify the file may have unpredictable consequences. The value is empty if the RecognitionScript.ImageFileRequired property is set to false. Otherwise, it contains the image file name.

Public property RegistrationHorizBMU

Gets or sets the horizontal registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). Registration offsets are only produced by the Kofax OCR and Kofax High Performance OCR/ICR engines. If you want to design a custom profile that produces registration offsets, you must derive your custom profile from the profile of one of those engines (you can skip the default engine logic by setting the SaveAndSkip property to True). Registration offsets may be generated by any zone type, but the values are ignored unless the zone is a registration zone. If you are customizing a registration zone and want to guarantee success, the script must have the Value property set to SearchText, Confidence set to 100, and the two offset variables set to a value >= 0. These values default to -1 if the default engine has not yet been run, or does not generate offsets.

Public property RegistrationVertBMU

Gets or sets the vertical registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). See RegistrationHorizBMU property for more information.

Public property SaveAndSkip

Gets or sets the SaveAndSkip flag. If True, sets the recognition information and skips the Kofax recognition. The RecognitionScript.RecognitionPostProcessing event is still called if it’s set in RecognitionScript.RecognitionPreProcessing event.

Public property SearchText

The search text is the expected search string set in the Administration module for a separation, form identification, or registration zone. Additionally, if the field type for an index zone has exactly one suggested value, and is marked as Force Match, then the search text exposes that value.

Public property Value

The current recognized value. It is null or Nothing in the PreRecognitionEventArgs object and is overwritten in the PostRecognitionEventArgs object by the Kofax recognition engine unless PreRecognitionEventArgs.SaveAndSkip is set to true. It can be modified in the PostRecognitionEventArgs object.

Top
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreRecognitionEventArgs.Confidence Property

PreRecognitionEventArgsConfidence Property

The confidence level of the recognition engine. It is an integer between 0-100, with 100 being the highest confidence. If you perform recognition with a custom engine, you are responsible for setting this value.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Confidence { get; set; }
Public Property Confidence As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreRecognitionEventArgs.ImageFile Property

PreRecognitionEventArgsImageFile Property

The file name of the zone snippet currently being processed. Image processing has already been performed by the time the script gets access to this file. Note that this is a temporary file and is read-only; attempting to modify the file may have unpredictable consequences. The value is empty if the RecognitionScript.ImageFileRequired property is set to false. Otherwise, it contains the image file name.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ImageFile { get; }
Public ReadOnly Property ImageFile As String
    Get

Property Value

Type: String
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreRecognitionEventArgs.RegistrationHorizBMU Property

PreRecognitionEventArgsRegistrationHorizBMU Property

Gets or sets the horizontal registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). Registration offsets are only produced by the Kofax OCR and Kofax High Performance OCR/ICR engines. If you want to design a custom profile that produces registration offsets, you must derive your custom profile from the profile of one of those engines (you can skip the default engine logic by setting the SaveAndSkip property to True). Registration offsets may be generated by any zone type, but the values are ignored unless the zone is a registration zone. If you are customizing a registration zone and want to guarantee success, the script must have the Value property set to SearchText, Confidence set to 100, and the two offset variables set to a value >= 0. These values default to -1 if the default engine has not yet been run, or does not generate offsets.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int RegistrationHorizBMU { get; set; }
Public Property RegistrationHorizBMU As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreRecognitionEventArgs.RegistrationVertBMU Property

PreRecognitionEventArgsRegistrationVertBMU Property

Gets or sets the vertical registration offsets returned by the default engine. Defines the offset of the lower-left pixel for the first character in the search text found in the zone. The offsets are defined from the upper-left area of the zone in increments of 1/1200 of an inch (BMUs). See RegistrationHorizBMU property for more information.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int RegistrationVertBMU { get; set; }
Public Property RegistrationVertBMU As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreRecognitionEventArgs.SaveAndSkip Property

PreRecognitionEventArgsSaveAndSkip Property

Gets or sets the SaveAndSkip flag. If True, sets the recognition information and skips the Kofax recognition. The RecognitionScript.RecognitionPostProcessing event is still called if it’s set in RecognitionScript.RecognitionPreProcessing event.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SaveAndSkip { get; set; }
Public Property SaveAndSkip As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreRecognitionEventArgs.SearchText Property

PreRecognitionEventArgsSearchText Property

The search text is the expected search string set in the Administration module for a separation, form identification, or registration zone. Additionally, if the field type for an index zone has exactly one suggested value, and is marked as Force Match, then the search text exposes that value.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string SearchText { get; }
Public ReadOnly Property SearchText As String
    Get

Property Value

Type: String
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreRecognitionEventArgs.Value Property

PreRecognitionEventArgsValue Property

The current recognized value. It is null or Nothing in the PreRecognitionEventArgs object and is overwritten in the PostRecognitionEventArgs object by the Kofax recognition engine unless PreRecognitionEventArgs.SaveAndSkip is set to true. It can be modified in the PostRecognitionEventArgs object.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
See Also

Reference

PreRecognitionEventArgs Class
Kofax.AscentCapture.Scripting Namespace


PreRecognitionEventHandler Delegate

PreRecognitionEventHandler Delegate

Defines callback for RecognitionPreProcessing event.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void PreRecognitionEventHandler(
    Object sender,
    PreRecognitionEventArgs e
)
Public Delegate Sub PreRecognitionEventHandler (
    sender As Object,
    e As PreRecognitionEventArgs
)

Parameters

sender
Type: SystemObject
Object that raises this event.
e
Type: Kofax.AscentCapture.ScriptingPreRecognitionEventArgs
The Kofax.AscentCapture.Scripting.PreRecognitionEventArgs object containing the recognition information.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


RecognitionBatchLoadingHandler Delegate

RecognitionBatchLoadingHandler Delegate

Defines callback for RecognitionBatchLoading event.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void RecognitionBatchLoadingHandler(
    Object sender,
    ref bool ImageFileRequired
)
Public Delegate Sub RecognitionBatchLoadingHandler (
    sender As Object,
    ByRef ImageFileRequired As Boolean
)

Parameters

sender
Type: SystemObject
Object that raises this event.
ImageFileRequired
Type: SystemBoolean
Indicates whether the file name of the zone snippet currently being processed should be provided. The default is False. Note: This parameter default is False for performance reasons. Generating the zone TIFF file accounts for about 10% of zone execution time. In most cases, the zone image does not need to be generated for built-in engine execution. Setting it to True forces the zone image to be created every time. Therefore, do not set this parameter to True unless you actually need access to the image.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


RecognitionBatchUnloadingHandler Delegate

RecognitionBatchUnloadingHandler Delegate

Defines callback for RecognitionBatchUnloading event.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void RecognitionBatchUnloadingHandler(
    Object sender
)
Public Delegate Sub RecognitionBatchUnloadingHandler (
    sender As Object
)

Parameters

sender
Type: SystemObject
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


RecognitionScript Class

RecognitionScript Class

Base class for the recognition script.

Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingRecognitionScript

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public abstract class RecognitionScript
Public MustInherit Class RecognitionScript

The RecognitionScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Events
 | Name | Description
Public event | BatchLoading | Called when a batch is opened.
Public event | BatchUnloading | Called when a batch is closed.
Public event | RecognitionPostProcessing | Called after each zone snippet is processed.
Public event | RecognitionPreProcessing | Called before each zone snippet is processed.
Top
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


RecognitionScript Methods

RecognitionScript Methods

The RecognitionScript type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RecognitionScript Class
Kofax.AscentCapture.Scripting Namespace


RecognitionScript Events

RecognitionScript Events

The RecognitionScript type exposes the following members.

Events
 | Name | Description
Public event | BatchLoading | Called when a batch is opened.
Public event | BatchUnloading | Called when a batch is closed.
Public event | RecognitionPostProcessing | Called after each zone snippet is processed.
Public event | RecognitionPreProcessing | Called before each zone snippet is processed.
Top
See Also

Reference

RecognitionScript Class
Kofax.AscentCapture.Scripting Namespace


RecognitionScript.BatchLoading Event

RecognitionScriptBatchLoading Event

Called when a batch is opened.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event RecognitionBatchLoadingHandler BatchLoading
Public Event BatchLoading As RecognitionBatchLoadingHandler

Value

Type: Kofax.AscentCapture.ScriptingRecognitionBatchLoadingHandler
See Also

Reference

RecognitionScript Class
Kofax.AscentCapture.Scripting Namespace


RecognitionScript.BatchUnloading Event

RecognitionScriptBatchUnloading Event

Called when a batch is closed.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event RecognitionBatchUnloadingHandler BatchUnloading
Public Event BatchUnloading As RecognitionBatchUnloadingHandler

Value

Type: Kofax.AscentCapture.ScriptingRecognitionBatchUnloadingHandler
See Also

Reference

RecognitionScript Class
Kofax.AscentCapture.Scripting Namespace


RecognitionScript.RecognitionPostProcessing Event

RecognitionScriptRecognitionPostProcessing Event

Called after each zone snippet is processed.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PostRecognitionEventHandler RecognitionPostProcessing
Public Event RecognitionPostProcessing As PostRecognitionEventHandler

Value

Type: Kofax.AscentCapture.ScriptingPostRecognitionEventHandler
See Also

Reference

RecognitionScript Class
Kofax.AscentCapture.Scripting Namespace


RecognitionScript.RecognitionPreProcessing Event

RecognitionScriptRecognitionPreProcessing Event

Called before each zone snippet is processed.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event PreRecognitionEventHandler RecognitionPreProcessing
Public Event RecognitionPreProcessing As PreRecognitionEventHandler

Value

Type: Kofax.AscentCapture.ScriptingPreRecognitionEventHandler
See Also

Reference

RecognitionScript Class
Kofax.AscentCapture.Scripting Namespace


RejectAndSkipDocumentException Class

RejectAndSkipDocumentException Class

Rejects and skips a document. This exception is to be thrown in document validation scripts only. It is treated as a FatalErrorException if thrown from other script types. Note: Folder validation script doesn’t have an equivalent exception, as folder cannot be rejected.

Inheritance Hierarchy
SystemObject
SystemException
Kofax.AscentCapture.ScriptingRejectAndSkipDocumentException

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class RejectAndSkipDocumentException : Exception
Public Class RejectAndSkipDocumentException
    Inherits Exception

The RejectAndSkipDocumentException type exposes the following members.

Constructors
 | Name | Description
Public method | RejectAndSkipDocumentException | Initializes a new instance of the Kofax.AscentCapture.Scripting.RejectAndSkipDocumentException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)
Top
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


RejectAndSkipDocumentException Constructor

RejectAndSkipDocumentException Constructor

Initializes a new instance of the Kofax.AscentCapture.Scripting.RejectAndSkipDocumentException class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public RejectAndSkipDocumentException(
    string strErrorMessage
)
Public Sub New (
    strErrorMessage As String
)

Parameters

strErrorMessage
Type: SystemString
Error message.
See Also

Reference

RejectAndSkipDocumentException Class
Kofax.AscentCapture.Scripting Namespace


RejectAndSkipDocumentException Methods

RejectAndSkipDocumentException Methods

The RejectAndSkipDocumentException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

RejectAndSkipDocumentException Class
Kofax.AscentCapture.Scripting Namespace


RejectAndSkipDocumentException Properties

RejectAndSkipDocumentException Properties

The RejectAndSkipDocumentException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)
Top
See Also

Reference

RejectAndSkipDocumentException Class
Kofax.AscentCapture.Scripting Namespace


ScriptUtils Class

ScriptUtils Class
Supply the validation and formatting the number methods
Inheritance Hierarchy
SystemObject
Kofax.AscentCapture.ScriptingScriptUtils

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ScriptUtils
Public Class ScriptUtils

The ScriptUtils type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptUtils | Initializes a new instance of the ScriptUtils class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | KfxFormatDecimal | Formats a decimal or numeric value.
 | KfxFormatDouble | Formats a double value.
 | KfxFormatReal | Formats a real or float value.
 | KfxRoundInteger | This function will round a double value to an integer as follows: If the decimal part of the number is >= 0.5, the number is rounded up, otherwise, it is rounded down.
 | KfxRoundSmallInteger | This function will round a double value to a small integer as follows: If the decimal part of the number is >= 0.5, the number is rounded up, otherwise, it is rounded down.
 | KfxValidateDecimal | Validates a decimal or numeric value.
 | KfxValidateDouble | Validates a double value.
 | KfxValidateReal | Validates a real or float value.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


ScriptUtils Constructor

ScriptUtils Constructor
Initializes a new instance of the ScriptUtils class

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ScriptUtils()
Public Sub New
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.Scripting Namespace


ScriptUtils Methods

ScriptUtils Methods

The ScriptUtils type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | KfxFormatDecimal | Formats a decimal or numeric value.
 | KfxFormatDouble | Formats a double value.
 | KfxFormatReal | Formats a real or float value.
 | KfxRoundInteger | This function will round a double value to an integer as follows: If the decimal part of the number is >= 0.5, the number is rounded up, otherwise, it is rounded down.
 | KfxRoundSmallInteger | This function will round a double value to a small integer as follows: If the decimal part of the number is >= 0.5, the number is rounded up, otherwise, it is rounded down.
 | KfxValidateDecimal | Validates a decimal or numeric value.
 | KfxValidateDouble | Validates a double value.
 | KfxValidateReal | Validates a real or float value.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.Scripting Namespace


ScriptUtils.KfxFormatDecimal Method

ScriptUtilsKfxFormatDecimal Method

Formats a decimal or numeric value.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxFormatDecimal(
    ref string strValue,
    int nPrecision,
    int nScale
)
Public Shared Function KfxFormatDecimal (
    ByRef strValue As String,
    nPrecision As Integer,
    nScale As Integer
) As Boolean

Parameters

strValue
Type: SystemString
The value to be formatted.
nPrecision
Type: SystemInt32
The number of digits.
nScale
Type: SystemInt32
The number of decimal places.

Return Value

Type: Boolean
True if the value has been formatted successfully. Otherwise, False.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.Scripting Namespace


ScriptUtils.KfxFormatDouble Method

ScriptUtilsKfxFormatDouble Method

Formats a double value.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxFormatDouble(
    ref string strValue
)
Public Shared Function KfxFormatDouble (
    ByRef strValue As String
) As Boolean

Parameters

strValue
Type: SystemString
The value to be formatted.

Return Value

Type: Boolean
True if the value has been formatted successfully. Otherwise, False.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.Scripting Namespace


ScriptUtils.KfxFormatReal Method

ScriptUtilsKfxFormatReal Method

Formats a real or float value.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxFormatReal(
    ref string strValue
)
Public Shared Function KfxFormatReal (
    ByRef strValue As String
) As Boolean

Parameters

strValue
Type: SystemString
The value to be formatted.

Return Value

Type: Boolean
True if the value has been formatted successfully. Otherwise, False.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.Scripting Namespace


ScriptUtils.KfxRoundInteger Method

ScriptUtilsKfxRoundInteger Method
This function will round a double value to an integer as follows: If the decimal part of the number is >= 0.5, the number is rounded up, otherwise, it is rounded down.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxRoundInteger(
    string strIntVal,
    ref int outVal
)
Public Shared Function KfxRoundInteger (
    strIntVal As String,
    ByRef outVal As Integer
) As Boolean

Parameters

strIntVal
Type: SystemString
double value in string
outVal
Type: SystemInt32

Return Value

Type: Boolean
True if strIntVal is a valid string and the double value in the integer range. Otherwise, false.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.Scripting Namespace


ScriptUtils.KfxRoundSmallInteger Method

ScriptUtilsKfxRoundSmallInteger Method
This function will round a double value to a small integer as follows: If the decimal part of the number is >= 0.5, the number is rounded up, otherwise, it is rounded down.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxRoundSmallInteger(
    string strIntVal,
    ref short outVal
)
Public Shared Function KfxRoundSmallInteger (
    strIntVal As String,
    ByRef outVal As Short
) As Boolean

Parameters

strIntVal
Type: SystemString
double value in string
outVal
Type: SystemInt16

Return Value

Type: Boolean
True if strIntVal is a valid string and the double value in the integer range. Otherwise, false.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.Scripting Namespace


ScriptUtils.KfxValidateDecimal Method

ScriptUtilsKfxValidateDecimal Method

Validates a decimal or numeric value.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxValidateDecimal(
    ref string strValue,
    int nPrecision,
    int nScale
)
Public Shared Function KfxValidateDecimal (
    ByRef strValue As String,
    nPrecision As Integer,
    nScale As Integer
) As Boolean

Parameters

strValue
Type: SystemString
The value to be validated.
nPrecision
Type: SystemInt32
The number of digits.
nScale
Type: SystemInt32
The number of decimal places.

Return Value

Type: Boolean
True if the value has been validated successfully. Otherwise, False.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.Scripting Namespace


ScriptUtils.KfxValidateDouble Method

ScriptUtilsKfxValidateDouble Method

Validates a double value.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxValidateDouble(
    ref string strValue
)
Public Shared Function KfxValidateDouble (
    ByRef strValue As String
) As Boolean

Parameters

strValue
Type: SystemString
The value to be validated.

Return Value

Type: Boolean
True if the value has been validated successfully. Otherwise, False.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.Scripting Namespace


ScriptUtils.KfxValidateReal Method

ScriptUtilsKfxValidateReal Method

Validates a real or float value.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool KfxValidateReal(
    ref string strValue
)
Public Shared Function KfxValidateReal (
    ByRef strValue As String
) As Boolean

Parameters

strValue
Type: SystemString
The value to be validated.

Return Value

Type: Boolean
True if the value has been validated successfully. Otherwise, False.
See Also

Reference

ScriptUtils Class
Kofax.AscentCapture.Scripting Namespace


SuppressFieldEventsOnDocCloseAttribute Class

SuppressFieldEventsOnDocCloseAttribute Class

Defines the suppress field event on document close event class.

Inheritance Hierarchy
SystemObject
SystemAttribute
Kofax.AscentCapture.ScriptingSuppressFieldEventsOnDocCloseAttribute

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[AttributeUsageAttribute(AttributeTargets.Class)]
public sealed class SuppressFieldEventsOnDocCloseAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class)>
Public NotInheritable Class SuppressFieldEventsOnDocCloseAttribute
    Inherits Attribute

The SuppressFieldEventsOnDocCloseAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | SuppressFieldEventsOnDocCloseAttribute | Initializes a new instance of the Kofax.AscentCapture.Scripting.SuppressFieldEventsOnDocCloseAttribute class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SuppressFieldEventsOnDocClose | Gets the script attribute.
Public property | TypeId | (Inherited from Attribute.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | (Inherited from Attribute.)
Top
Remarks
This class cannot be inherited.
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


SuppressFieldEventsOnDocCloseAttribute Constructor

SuppressFieldEventsOnDocCloseAttribute Constructor

Initializes a new instance of the Kofax.AscentCapture.Scripting.SuppressFieldEventsOnDocCloseAttribute class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public SuppressFieldEventsOnDocCloseAttribute(
    bool bSuppress
)
Public Sub New (
    bSuppress As Boolean
)

Parameters

bSuppress
Type: SystemBoolean
See Also

Reference

SuppressFieldEventsOnDocCloseAttribute Class
Kofax.AscentCapture.Scripting Namespace


SuppressFieldEventsOnDocCloseAttribute Methods

SuppressFieldEventsOnDocCloseAttribute Methods

The SuppressFieldEventsOnDocCloseAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Public method | ToString | (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | (Inherited from Attribute.)
Top
See Also

Reference

SuppressFieldEventsOnDocCloseAttribute Class
Kofax.AscentCapture.Scripting Namespace


SuppressFieldEventsOnDocCloseAttribute Properties

SuppressFieldEventsOnDocCloseAttribute Properties

The SuppressFieldEventsOnDocCloseAttribute type exposes the following members.

Properties
 | Name | Description
Public property | SuppressFieldEventsOnDocClose | Gets the script attribute.
Public property | TypeId | (Inherited from Attribute.)
Top
See Also

Reference

SuppressFieldEventsOnDocCloseAttribute Class
Kofax.AscentCapture.Scripting Namespace


SuppressFieldEventsOnDocCloseAttribute.SuppressFieldEventsOnDocClose Property

SuppressFieldEventsOnDocCloseAttributeSuppressFieldEventsOnDocClose Property
Kofax Capture API Reference

Gets the script attribute.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SuppressFieldEventsOnDocClose { get; }
Public ReadOnly Property SuppressFieldEventsOnDocClose As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

SuppressFieldEventsOnDocCloseAttribute Class
Kofax.AscentCapture.Scripting Namespace


ValidationErrorException Class

ValidationErrorException Class

Signals a validation error. This exception is to be thrown in validation scripts only. It is treated as a FatalErrorException if the Recognition Server receives this exception.

Inheritance Hierarchy
SystemObject
SystemException
Kofax.AscentCapture.ScriptingValidationErrorException

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ValidationErrorException : Exception
Public Class ValidationErrorException
    Inherits Exception

The ValidationErrorException type exposes the following members.

Constructors
 | Name | Description
Public method | ValidationErrorException(String) | Initializes a new instance of the Kofax.AscentCapture.Scripting.ValidationErrorException class.
Public method | ValidationErrorException(String, IndexField) | Initializes a new instance of the Kofax.AscentCapture.Scripting.ValidationErrorException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | ActiveField | Gets the index field that will receive focus.
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)
Top
See Also

Reference

Kofax.AscentCapture.Scripting Namespace


ValidationErrorException Constructor

ValidationErrorException Constructor
Overload List
 | Name | Description
Public method | ValidationErrorException(String) | Initializes a new instance of the Kofax.AscentCapture.Scripting.ValidationErrorException class.
Public method | ValidationErrorException(String, IndexField) | Initializes a new instance of the Kofax.AscentCapture.Scripting.ValidationErrorException class.
Top
See Also

Reference

ValidationErrorException Class
Kofax.AscentCapture.Scripting Namespace


ValidationErrorException Constructor (String)

ValidationErrorException Constructor (String)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.Scripting.ValidationErrorException class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ValidationErrorException(
    string strErrorMessage
)
Public Sub New (
    strErrorMessage As String
)

Parameters

strErrorMessage
Type: SystemString
Error message.
See Also

Reference

ValidationErrorException Class
ValidationErrorException Overload
Kofax.AscentCapture.Scripting Namespace


ValidationErrorException Constructor (String, IndexField)

ValidationErrorException Constructor (String, IndexField)
Kofax Capture API Reference

Initializes a new instance of the Kofax.AscentCapture.Scripting.ValidationErrorException class.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ValidationErrorException(
    string strErrorMessage,
    IndexField oActiveIndexField
)
Public Sub New (
    strErrorMessage As String,
    oActiveIndexField As IndexField
)

Parameters

strErrorMessage
Type: SystemString
Error message.
oActiveIndexField
Type: IndexField
Index field to receive focus.
See Also

Reference

ValidationErrorException Class
ValidationErrorException Overload
Kofax.AscentCapture.Scripting Namespace


ValidationErrorException Methods

ValidationErrorException Methods

The ValidationErrorException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | (Inherited from Exception.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from Exception.)
Top
See Also

Reference

ValidationErrorException Class
Kofax.AscentCapture.Scripting Namespace


ValidationErrorException Properties

ValidationErrorException Properties

The ValidationErrorException type exposes the following members.

Properties
 | Name | Description
Public property | ActiveField | Gets the index field that will receive focus.
Public property | Data | (Inherited from Exception.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | (Inherited from Exception.)
Public property | Source | (Inherited from Exception.)
Public property | StackTrace | (Inherited from Exception.)
Public property | TargetSite | (Inherited from Exception.)
Top
See Also

Reference

ValidationErrorException Class
Kofax.AscentCapture.Scripting Namespace


ValidationErrorException.ActiveField Property

ValidationErrorExceptionActiveField Property

Gets the index field that will receive focus.

Namespace: Kofax.AscentCapture.Scripting
Assembly: ScriptInterface (in ScriptInterface.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IndexField ActiveField { get; }
Public ReadOnly Property ActiveField As IndexField
    Get

Property Value

Type: IndexField
See Also

Reference

ValidationErrorException Class
Kofax.AscentCapture.Scripting Namespace


Kofax.Capture.ACWFLib Namespace

Kofax.Capture.ACWFLib Namespace

The runtime portion of the workflow agent must be a registered COM server. The relevant project must first reference the Tungsten Capture Custom Workflow .NET Type Interface Library (Kofax.Capture.SDK.Workflow.dll) and Tungsten Capture Custom Workflow .NET Type Implementation Library (Kofax.Capture.ACWFLib.dll).

Classes
 | Class | Description
Public class | ACWorkflowCentralSites | Defines a collection of ACWorkflowSite objects representing the various central sites.
Public class | ACWorkflowData | Contains all the parameters to process the workflow.
Public class | ACWorkflowModule | Represents a module within the batch class.
Public class | ACWorkflowModules | Defines a collection of ACWorkflowModule objects. The collection is ordered by the module order setup in the corresponding batch class properties for the current batch.
Public class | ACWorkflowSite | Represents a site in the Tungsten Capture workflow.
Public class | ACWorkflowSites | Defines a collection of ACWorkflowSite objects representing the various sites.
Public class | ACWorkflowState | Indicates a possible batch state.
Public class | ACWorkflowStates | Defines a collection of ACWorkflow state objects representing the various states.
Remarks

To run safely and efficiently in all Tungsten Capture modules, including the TCN Service, you should set the project properties "Unattended Execution" and "Retained in Memory."

A workflow agent runtime should never bring up a user interface. There is no ability to directly prevent this from occurring. However, there may be problems if a workflow agent attempts to invoke a user interface in certain modules (such as the TCN Service, or the Recognition Server when running as a service), because in such cases there is no user to interact with the interface.

Next, the programmer must create a COM class that implements the interface "IACWorkflowAgent." To do this in Visual Basic, create a new class that is externally creatable. At the top of this class, add the text: "Implements Kofax.Capture.SDK.Workflow.IACWorkflowAgent"

It is now possible to use the drop-down list in the upper-left corner of the text editor to select "IACWorkflowAgent" and the drop-down list in the upper-right to select the desired method of IACWorkflowAgent to implement.

Load Behavior

Tungsten Capture attempts to call a registered workflow agent runtime COM module on each station as it closes, rejects, or suspends a batch of the applicable batch class. By default, if Tungsten Capture cannot load the COM object, the batch is sent to the Quality Control module in error.

However, if the workflow agent has been registered with the WorkflowAgentSkipIfCantLoad flag set, then no error occurs if the workflow agent cannot be loaded.

In this case, the default workflow occurs. This may be useful if an Administrator knows that a workflow agent need only affect a particular module transition, and that such a transition only occurs on certain machines.

Calling Order

A workflow agent, if registered, is called after all default Tungsten Capture workflow processing. However, the workflow agent is invoked prior to updating batch history information. Therefore, since the workflow agent has already been invoked, the batch history information reflects changes that were made (if applicable) to the module and state due to running the agent.


ACWorkflowCentralSites Class

ACWorkflowCentralSites Class

Defines a collection of ACWorkflowSite objects representing the various central sites.

Inheritance Hierarchy
SystemObject
Kofax.Capture.ACWFLibACWorkflowCentralSites

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ACWorkflowCentralSites : IACWorkflowCentralSites
Public Class ACWorkflowCentralSites
    Implements IACWorkflowCentralSites

The ACWorkflowCentralSites type exposes the following members.

Constructors
 | Name | Description
Public method | ACWorkflowCentralSites | Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowCentralSites class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of Kofax.Capture.SDK.Workflow.IACWorkflowSite in the collection.
Public property | Item | Returns the IACWorkflowSite object specified by index or site name.
Top
Remarks
See Also

Reference

Kofax.Capture.ACWFLib Namespace


ACWorkflowCentralSites Constructor

ACWorkflowCentralSites Constructor

Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowCentralSites class.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ACWorkflowCentralSites()
Public Sub New
Remarks
See Also

Reference

ACWorkflowCentralSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowCentralSites Methods

ACWorkflowCentralSites Methods

The ACWorkflowCentralSites type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ACWorkflowCentralSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowCentralSites.Dispose Method

ACWorkflowCentralSitesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

ACWorkflowCentralSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowCentralSites.GetEnumerator Method

ACWorkflowCentralSitesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.SDK.Workflow.IACWorkflowCentralSites object.

Implements

IEnumerableGetEnumerator
Remarks
See Also

Reference

ACWorkflowCentralSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowCentralSites Properties

ACWorkflowCentralSites Properties

The ACWorkflowCentralSites type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of Kofax.Capture.SDK.Workflow.IACWorkflowSite in the collection.
Public property | Item | Returns the IACWorkflowSite object specified by index or site name.
Top
See Also

Reference

ACWorkflowCentralSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowCentralSites.Count Property

ACWorkflowCentralSitesCount Property

Returns the number of Kofax.Capture.SDK.Workflow.IACWorkflowSite in the collection.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IACWorkflowCentralSitesCount
Remarks
See Also

Reference

ACWorkflowCentralSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowCentralSites.Item Property

ACWorkflowCentralSitesItem Property

Returns the IACWorkflowSite object specified by index or site name.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowSite this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IACWorkflowSite
    Get

Parameters

vntIndexKey
Type: SystemObject
The index can either be a site name, or its (1-based) numeric index in the collection.

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite

Implements

IACWorkflowCentralSitesItemObject
Remarks
For each … Next is the standard Visual Basic iteration method. When using this property, the client code iterates through the collection of all central sites, ordered by the site's priority.
See Also

Reference

ACWorkflowCentralSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData Class

ACWorkflowData Class

Contains all the parameters to process the workflow.

Inheritance Hierarchy
SystemObject
Kofax.Capture.ACWFLibACWorkflowData

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ACWorkflowData : IACWorkflowData
Public Class ACWorkflowData
    Implements IACWorkflowData

The ACWorkflowData type exposes the following members.

Constructors
 | Name | Description
Public method | ACWorkflowData | Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowData class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | ExtractRuntimeACDataElement | Returns the Kofax.Capture.SDK.Data.IACDataElement API object for the batch data.
Public method | ExtractSetupACDataElement | Returns the Kofax.Capture.SDK.Data.IACDataElement API object for the batch class.
Public method | FeatureSupported | Check if the feature was supported or not.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | SendSnmpNotification | Generates an SNMP notification message.
Public method | ToString | (Inherited from Object.)
Public method | TranslateAscentCaptureValues | Any Tungsten Capture Value (enclosed in curly brackets) in strText is translated into the corresponding value.
Public method | UseAlternateCentralSite | Overrides the remote site behavior so that the batch is sent to the alternate central site that is specified by oSite.
Top
Properties
 | Name | Description
Public property | AvailableRemoteSites | Returns a collection of Kofax.Capture.SDK.Workflow.IACWorkflowSite objects.
Public property | BatchCustomStorageString | Allows the workflow agent to read and/or modify batch-level custom storage strings.
Public property | BatchType | Returns a normal batch or a batch that is assinged to users/groups.
Public property | CurrentModule | Returns the current module that is closing the batch.
Public property | ErrorCode | Gets or sets the error code. It is ignored unless the state is in error.
Public property | ErrorText | Gets or sets the error string. It is ignored unless the state is in error.
Public property | GrantGroupAccessToBatch | Grants group access rights to a batch. Only the granted group can process the batch in the subsequent queue.
Public property | GrantGroupAccessToBatch2 | Grants group access rights to a batch even if the subsequent queue is unchanged.
Public property | GrantUserAccessToBatch | Grants user access rights to a batch. Only the granted user can process the batch in the subsequent queue.
Public property | GrantUserAccessToBatch2 | Grants user access rights to a batch even if subsequent queue is unchanged.
Public property | NextModule | Gets or sets the next expected module based on the client batch close.
Public property | NextSite | Gets or sets the next site that will process the batch based on the routing rules configured in the Administration module.
Public property | NextState | The next state based on how the current module has attempted to close the batch.
Public property | PossibleCentralSites | Returns a collection of available central sites to which a workflow agent can choose to upload the batch.
Public property | PossibleModules | Returns a collection of modules that can be used for this batch class.
Public property | PossibleStates | Returns a collection of ACWorkflowStates objects, which enumerate the available states for this batch class.
Public property | Recalled | Indicates whether or not the batch has been recalled by the central site.
Public property | ServicePackVersion | Returns the currently installed service pack.
Top
Remarks
See Also

Reference

Kofax.Capture.ACWFLib Namespace


ACWorkflowData Constructor

ACWorkflowData Constructor

Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowData class.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ACWorkflowData()
Public Sub New
Remarks
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData Methods

ACWorkflowData Methods

The ACWorkflowData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | ExtractRuntimeACDataElement | Returns the Kofax.Capture.SDK.Data.IACDataElement API object for the batch data.
Public method | ExtractSetupACDataElement | Returns the Kofax.Capture.SDK.Data.IACDataElement API object for the batch class.
Public method | FeatureSupported | Check if the feature was supported or not.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | SendSnmpNotification | Generates an SNMP notification message.
Public method | ToString | (Inherited from Object.)
Public method | TranslateAscentCaptureValues | Any Tungsten Capture Value (enclosed in curly brackets) in strText is translated into the corresponding value.
Public method | UseAlternateCentralSite | Overrides the remote site behavior so that the batch is sent to the alternate central site that is specified by oSite.
Top
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.Dispose Method

ACWorkflowDataDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.ExtractRuntimeACDataElement Method

ACWorkflowDataExtractRuntimeACDataElement Method

Returns the Kofax.Capture.SDK.Data.IACDataElement API object for the batch data.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElement ExtractRuntimeACDataElement(
    int lHints
)
Public Function ExtractRuntimeACDataElement (
    lHints As Integer
) As IACDataElement

Parameters

lHints
Type: SystemInt32
Starting with Ascent Capture 7.0, hints are deprecated. Tungsten Capture behaves as if the hints were always specified, providing the same performance gains in all cases (it is no longer necessary to use hints to improve performance). Hints are retained for backward compatibility, but no longer perform any useful function.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement

Implements

IACWorkflowDataExtractRuntimeACDataElement(Int32)
Remarks
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.ExtractSetupACDataElement Method

ACWorkflowDataExtractSetupACDataElement Method

Returns the Kofax.Capture.SDK.Data.IACDataElement API object for the batch class.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElement ExtractSetupACDataElement(
    int lHints
)
Public Function ExtractSetupACDataElement (
    lHints As Integer
) As IACDataElement

Parameters

lHints
Type: SystemInt32

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement

Implements

IACWorkflowDataExtractSetupACDataElement(Int32)
Remarks
Starting with Ascent Capture 7.0, hints are deprecated. Tungsten Capture behaves as if the hints were always specified, providing the same performance gains in all cases (it is no longer necessary to use hints to improve performance). Hints are retained for backward compatibility, but no longer perform any useful function.
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.FeatureSupported Method

ACWorkflowDataFeatureSupported Method

Check if the feature was supported or not.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool FeatureSupported(
    int nFeatureNumber
)
Public Function FeatureSupported (
    nFeatureNumber As Integer
) As Boolean

Parameters

nFeatureNumber
Type: SystemInt32
Feature Number

Return Value

Type: Boolean

Implements

IACWorkflowDataFeatureSupported(Int32)
Remarks
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.SendSnmpNotification Method

ACWorkflowDataSendSnmpNotification Method

Generates an SNMP notification message.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void SendSnmpNotification(
    string strMessage
)
Public Sub SendSnmpNotification (
    strMessage As String
)

Parameters

strMessage
Type: SystemString
The message to send.

Implements

IACWorkflowDataSendSnmpNotification(String)
Remarks
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.TranslateAscentCaptureValues Method

ACWorkflowDataTranslateAscentCaptureValues Method

Any Tungsten Capture Value (enclosed in curly brackets) in strText is translated into the corresponding value.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void TranslateAscentCaptureValues(
    ref string strText
)
Public Sub TranslateAscentCaptureValues (
    ByRef strText As String
)

Parameters

strText
Type: SystemString
The original string to translate.

Implements

IACWorkflowDataTranslateAscentCaptureValues(String)
Remarks

For example: "This is the current document’s form type: {Document Form Name}."

Assuming a current document with a form exists, the "{Document Form Name}" text is replaced with the appropriate form name.

Tungsten Capture values may also be used to get batch field values. In this case, the batch field name is preceded by a dollar sign and enclosed in curly brackets.

For example: "This is the value of batch field name0: '{$name0}."

See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.UseAlternateCentralSite Method

ACWorkflowDataUseAlternateCentralSite Method

Overrides the remote site behavior so that the batch is sent to the alternate central site that is specified by oSite.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void UseAlternateCentralSite(
    IACWorkflowSite oSite
)
Public Sub UseAlternateCentralSite (
    oSite As IACWorkflowSite
)

Parameters

oSite
Type: Kofax.Capture.SDK.WorkflowIACWorkflowSite
The specified alternate central site.

Implements

IACWorkflowDataUseAlternateCentralSite(IACWorkflowSite)
Remarks

The oSite can be selected from the return collection when you call PossibleCentralSites.

See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData Properties

ACWorkflowData Properties

The ACWorkflowData type exposes the following members.

Properties
 | Name | Description
Public property | AvailableRemoteSites | Returns a collection of Kofax.Capture.SDK.Workflow.IACWorkflowSite objects.
Public property | BatchCustomStorageString | Allows the workflow agent to read and/or modify batch-level custom storage strings.
Public property | BatchType | Returns a normal batch or a batch that is assinged to users/groups.
Public property | CurrentModule | Returns the current module that is closing the batch.
Public property | ErrorCode | Gets or sets the error code. It is ignored unless the state is in error.
Public property | ErrorText | Gets or sets the error string. It is ignored unless the state is in error.
Public property | GrantGroupAccessToBatch | Grants group access rights to a batch. Only the granted group can process the batch in the subsequent queue.
Public property | GrantGroupAccessToBatch2 | Grants group access rights to a batch even if the subsequent queue is unchanged.
Public property | GrantUserAccessToBatch | Grants user access rights to a batch. Only the granted user can process the batch in the subsequent queue.
Public property | GrantUserAccessToBatch2 | Grants user access rights to a batch even if subsequent queue is unchanged.
Public property | NextModule | Gets or sets the next expected module based on the client batch close.
Public property | NextSite | Gets or sets the next site that will process the batch based on the routing rules configured in the Administration module.
Public property | NextState | The next state based on how the current module has attempted to close the batch.
Public property | PossibleCentralSites | Returns a collection of available central sites to which a workflow agent can choose to upload the batch.
Public property | PossibleModules | Returns a collection of modules that can be used for this batch class.
Public property | PossibleStates | Returns a collection of ACWorkflowStates objects, which enumerate the available states for this batch class.
Public property | Recalled | Indicates whether or not the batch has been recalled by the central site.
Public property | ServicePackVersion | Returns the currently installed service pack.
Top
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.AvailableRemoteSites Property

ACWorkflowDataAvailableRemoteSites Property

Returns a collection of Kofax.Capture.SDK.Workflow.IACWorkflowSite objects.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowSites AvailableRemoteSites { get; }
Public ReadOnly Property AvailableRemoteSites As IACWorkflowSites
    Get

Property Value

Type: IACWorkflowSites

Return Value

Type: IACWorkflowSites
Kofax.Capture.SDK.Workflow.IACWorkflowSites

Implements

IACWorkflowDataAvailableRemoteSites
Remarks
Without ACI Server enabled (or at ACI Server remote sites), there will be no remote sites available. In this case, an empty collection will be returned.
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.BatchCustomStorageString Property

ACWorkflowDataBatchCustomStorageString Property

Allows the workflow agent to read and/or modify batch-level custom storage strings.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property BatchCustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The custom storage string name.

Property Value

Type: String

Return Value

Type: String
String

Implements

IACWorkflowDataBatchCustomStorageStringString
Remarks
These elements are not available through the batch data information (ExtractRuntimeACDataElement method).
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.BatchType Property

ACWorkflowDataBatchType Property

Returns a normal batch or a batch that is assinged to users/groups.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int BatchType { get; }
Public ReadOnly Property BatchType As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IACWorkflowDataBatchType
Remarks
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.CurrentModule Property

ACWorkflowDataCurrentModule Property

Returns the current module that is closing the batch.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowModule CurrentModule { get; }
Public ReadOnly Property CurrentModule As IACWorkflowModule
    Get

Property Value

Type: IACWorkflowModule

Return Value

Type: IACWorkflowModule
Kofax.Capture.SDK.Workflow.IACWorkflowModule

Implements

IACWorkflowDataCurrentModule
Remarks

This module is Tungsten Capture Network Server when a batch is processed by either the RSA or by the TCN Service.

A workflow agent can tell the difference by detecting if AvailableModules includes TCN Server (in which case it is a remote TCN Server batch).

See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.ErrorCode Property

ACWorkflowDataErrorCode Property

Gets or sets the error code. It is ignored unless the state is in error.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ErrorCode { get; set; }
Public Property ErrorCode As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IACWorkflowDataErrorCode
Remarks
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.ErrorText Property

ACWorkflowDataErrorText Property

Gets or sets the error string. It is ignored unless the state is in error.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ErrorText { get; set; }
Public Property ErrorText As String
    Get
    Set

Property Value

Type: String
The error string.

Return Value

Type: String
String

Implements

IACWorkflowDataErrorText
Remarks

The maximum length is 255 characters. An error is thrown if the ErrorText exceeds this length.

See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.GrantGroupAccessToBatch Property

ACWorkflowDataGrantGroupAccessToBatch Property

Grants group access rights to a batch. Only the granted group can process the batch in the subsequent queue.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string GrantGroupAccessToBatch { set; }
Public WriteOnly Property GrantGroupAccessToBatch As String
    Set

Property Value

Type: String
The group name and domain.

Implements

IACWorkflowDataGrantGroupAccessToBatch
Remarks
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.GrantGroupAccessToBatch2 Property

ACWorkflowDataGrantGroupAccessToBatch2 Property

Grants group access rights to a batch even if the subsequent queue is unchanged.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string GrantGroupAccessToBatch2 { set; }
Public WriteOnly Property GrantGroupAccessToBatch2 As String
    Set

Property Value

Type: String
The group name and domain.

Implements

IACWorkflowDataGrantGroupAccessToBatch2
Remarks
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.GrantUserAccessToBatch Property

ACWorkflowDataGrantUserAccessToBatch Property

Grants user access rights to a batch. Only the granted user can process the batch in the subsequent queue.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string GrantUserAccessToBatch { set; }
Public WriteOnly Property GrantUserAccessToBatch As String
    Set

Property Value

Type: String
The user ID and domain.

Implements

IACWorkflowDataGrantUserAccessToBatch
Remarks
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.GrantUserAccessToBatch2 Property

ACWorkflowDataGrantUserAccessToBatch2 Property

Grants user access rights to a batch even if subsequent queue is unchanged.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string GrantUserAccessToBatch2 { set; }
Public WriteOnly Property GrantUserAccessToBatch2 As String
    Set

Property Value

Type: String
The user ID and domain.

Implements

IACWorkflowDataGrantUserAccessToBatch2
Remarks
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.NextModule Property

ACWorkflowDataNextModule Property

Gets or sets the next expected module based on the client batch close.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowModule NextModule { get; set; }
Public Property NextModule As IACWorkflowModule
    Get
    Set

Property Value

Type: IACWorkflowModule

Return Value

Type: IACWorkflowModule
Kofax.Capture.SDK.Workflow.IACWorkflowModule

Implements

IACWorkflowDataNextModule
Remarks

If the batch is in error, this property is ignored and the batch will go the Quality Control module.

This state is a reference to one of the objects in ACWorkflow states. The user code can modify this to a different state, if desired to affect workflow.

If the NextModule and NextState parameters are left unchanged, then the batch experiences the default workflow behavior.

When using a remote TCN Server batch, the workflow agent can cause the batch to be sent to the central site by setting NextModule to TCN Server.

Invalid state/module combinations are not checked until the ProcessWorkflow routine exists (at which time the batch will be routed to the Quality Control module if there is an error).

Workflow agents must be very careful to set valid state and module combinations.

See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.NextSite Property

ACWorkflowDataNextSite Property

Gets or sets the next site that will process the batch based on the routing rules configured in the Administration module.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowSite NextSite { get; set; }
Public Property NextSite As IACWorkflowSite
    Get
    Set

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite

Implements

IACWorkflowDataNextSite
Remarks

This value is a reference to one of the objects in ACWorkflowSites.

The workflow agent can change this to a different value, if desired, to affect workflow.

Invalid site selections are not caught until the routine exits.

If TCN Server is not enabled, this property always returns the current site.

See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.NextState Property

ACWorkflowDataNextState Property

The next state based on how the current module has attempted to close the batch.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowState NextState { get; set; }
Public Property NextState As IACWorkflowState
    Get
    Set

Property Value

Type: IACWorkflowState

Return Value

Type: IACWorkflowState
Kofax.Capture.SDK.Workflow.IACWorkflowState

Implements

IACWorkflowDataNextState
Remarks
This state is a reference to one of the objects in ACWorkflow states.

The user code can modify this to a different state, if desired to affect workflow.

Invalid state/module combinations are not checked until the ProcessWorkflow routine exists (at which time the batch will be routed to Quality Control if there is an error).

Workflow agents must be very careful to set valid state and module combinations.

See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.PossibleCentralSites Property

ACWorkflowDataPossibleCentralSites Property

Returns a collection of available central sites to which a workflow agent can choose to upload the batch.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowCentralSites PossibleCentralSites { get; }
Public ReadOnly Property PossibleCentralSites As IACWorkflowCentralSites
    Get

Property Value

Type: IACWorkflowCentralSites

Return Value

Type: IACWorkflowCentralSites
Kofax.Capture.SDK.Workflow.IACWorkflowCentralSites

Implements

IACWorkflowDataPossibleCentralSites
Remarks

The return collection contains all available central sites when the working batch is a new batch that has not yet been uploaded to any central site. For a batch that has already been sent to a central site, this property returns an empty collection.

See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.PossibleModules Property

ACWorkflowDataPossibleModules Property

Returns a collection of modules that can be used for this batch class.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowModules PossibleModules { get; }
Public ReadOnly Property PossibleModules As IACWorkflowModules
    Get

Property Value

Type: IACWorkflowModules

Return Value

Type: IACWorkflowModules
Kofax.Capture.SDK.Workflow.IACWorkflowModules

Implements

IACWorkflowDataPossibleModules
Remarks
This collection is in order of the default workflow; for instance, the first module will always be "Scan.exe".

On a TCN Server remote site, this list always includes the TCN Server module. The TCN Server module does not appear for TCN Server batches being processed at the central site.

See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.PossibleStates Property

ACWorkflowDataPossibleStates Property

Returns a collection of ACWorkflowStates objects, which enumerate the available states for this batch class.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowStates PossibleStates { get; }
Public ReadOnly Property PossibleStates As IACWorkflowStates
    Get

Property Value

Type: IACWorkflowStates

Return Value

Type: IACWorkflowStates
Kofax.Capture.SDK.Workflow.IACWorkflowStates

Implements

IACWorkflowDataPossibleStates
Remarks
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.Recalled Property

ACWorkflowDataRecalled Property

Indicates whether or not the batch has been recalled by the central site.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Recalled { get; }
Public ReadOnly Property Recalled As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IACWorkflowDataRecalled
Remarks
When a batch is recalled, the multi-site routing setting for the batch is removed (if the batch is configured for multi-site routing). The batch routing is limited to the central site after recall.

However, the workflow agent can be programmed to route to any available site that is returned by the AvailableRemoteSites property.

For example, the workflow agent can check to see if a batch has been recalled, and route it to the central site. Once routed to the central site, the workflow agent can subsequently override the recall and route the batch to a remote site.

See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowData.ServicePackVersion Property

ACWorkflowDataServicePackVersion Property

Returns the currently installed service pack.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public short ServicePackVersion { get; }
Public ReadOnly Property ServicePackVersion As Short
    Get

Property Value

Type: Int16
The service pack version.

Return Value

Type: Int16
Short

Implements

IACWorkflowDataServicePackVersion
Remarks
See Also

Reference

ACWorkflowData Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowModule Class

ACWorkflowModule Class

Represents a module within the batch class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.ACWFLibACWorkflowModule

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ACWorkflowModule : IACWorkflowModule
Public Class ACWorkflowModule
    Implements IACWorkflowModule

The ACWorkflowModule type exposes the following members.

Constructors
 | Name | Description
Public method | ACWorkflowModule | Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowModule class.
Public method | ACWorkflowModule(String, String, IACWorkflowSite) | Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowModule class with specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ID | Returns the module's unique identifier. If checking for specific module identifiers, it is best to use this property rather than the Name.
Public property | Name | Returns the module name. This name is typically used for display purposes only.
Public property | ProcessID | Returns the internal ProcessID of the module.
Public property | QueueID | Returns the internal QueueID of the module.
Top
Remarks

The following list shows the names and IDs of the built-in modules. Only some of these modules are assigned to any particular batch class.

  • Scan: scan.exe
  • Quality Control: qc.exe
  • Recognition Server: fp.exe
  • Validation: index.exe
  • Verification: verify.exe
  • OCR Full Text: ocr.exe
  • Export: release.exe
  • Batch Manager: ops.exe
  • PDF Generator: kfxpdf.exe
  • ACI Server: ACIRSA.exe
    This module is used for both the ACI Server RSA (Remote Synchronization Agent) and the TCN Service.
  • Custom Module: ModuleID for the Custom Module
See Also

Reference

Kofax.Capture.ACWFLib Namespace


ACWorkflowModule Constructor

ACWorkflowModule Constructor
Overload List
 | Name | Description
Public method | ACWorkflowModule | Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowModule class.
Public method | ACWorkflowModule(String, String, IACWorkflowSite) | Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowModule class with specified parameters.
Top
See Also

Reference

ACWorkflowModule Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowModule Constructor

ACWorkflowModule Constructor

Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowModule class.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ACWorkflowModule()
Public Sub New
Remarks
See Also

Reference

ACWorkflowModule Class
ACWorkflowModule Overload
Kofax.Capture.ACWFLib Namespace


ACWorkflowModule Constructor (String, String, IACWorkflowSite)

ACWorkflowModule Constructor (String, String, IACWorkflowSite)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowModule class with specified parameters.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ACWorkflowModule(
    string strName,
    string strModuleID,
    IACWorkflowSite oDefaultSite
)
Public Sub New (
    strName As String,
    strModuleID As String,
    oDefaultSite As IACWorkflowSite
)

Parameters

strName
Type: SystemString
The module name.
strModuleID
Type: SystemString
The module ID.
oDefaultSite
Type: Kofax.Capture.SDK.WorkflowIACWorkflowSite
Remarks
See Also

Reference

ACWorkflowModule Class
ACWorkflowModule Overload
Kofax.Capture.ACWFLib Namespace


ACWorkflowModule Methods

ACWorkflowModule Methods

The ACWorkflowModule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ACWorkflowModule Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowModule Properties

ACWorkflowModule Properties

The ACWorkflowModule type exposes the following members.

Properties
 | Name | Description
Public property | ID | Returns the module's unique identifier. If checking for specific module identifiers, it is best to use this property rather than the Name.
Public property | Name | Returns the module name. This name is typically used for display purposes only.
Public property | ProcessID | Returns the internal ProcessID of the module.
Public property | QueueID | Returns the internal QueueID of the module.
Top
See Also

Reference

ACWorkflowModule Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowModule.ID Property

ACWorkflowModuleID Property

Returns the module's unique identifier. If checking for specific module identifiers, it is best to use this property rather than the Name.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ID { get; }
Public ReadOnly Property ID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IACWorkflowModuleID
Remarks
See Also

Reference

ACWorkflowModule Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowModule.Name Property

ACWorkflowModuleName Property

Returns the module name. This name is typically used for display purposes only.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IACWorkflowModuleName
Remarks
See Also

Reference

ACWorkflowModule Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowModule.ProcessID Property

ACWorkflowModuleProcessID Property

Returns the internal ProcessID of the module.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ProcessID { get; }
Public ReadOnly Property ProcessID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IACWorkflowModuleProcessID
Remarks
See Also

Reference

ACWorkflowModule Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowModule.QueueID Property

ACWorkflowModuleQueueID Property

Returns the internal QueueID of the module.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int QueueID { get; }
Public ReadOnly Property QueueID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IACWorkflowModuleQueueID
Remarks
See Also

Reference

ACWorkflowModule Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowModules Class

ACWorkflowModules Class

Defines a collection of ACWorkflowModule objects. The collection is ordered by the module order setup in the corresponding batch class properties for the current batch.

Inheritance Hierarchy
SystemObject
Kofax.Capture.ACWFLibACWorkflowModules

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ACWorkflowModules : IACWorkflowModules
Public Class ACWorkflowModules
    Implements IACWorkflowModules

The ACWorkflowModules type exposes the following members.

Constructors
 | Name | Description
Public method | ACWorkflowModules | Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowModules class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowModule in the collection.
Public property | Item | Returns the Kofax.Capture.SDK.Workflow.IACWorkflowModule object specified by index.
Top
Remarks

If the batch class does not contain the Quality Control module, the Quality Control module is not available in this collection. However, it is still possible to route a batch to the Quality Control module for an error by setting the next state to "error."

The ACWorkflowModules for Kofax Capture Network Server batches contains a list of the modules (queues) assigned to the batch class, in the order they were assigned in the Administration module. Some special situations occur when TCN Server is involved.

For a TCN Server batch at the remote site, ACWorkflowModules contains all of the modules slated to execute on the remote site (often just the Scan module) as well as the special TCN Server module representing the RSA.

For a KCN Server batch at the central site, ACWorkflowModules is identical to what would be seen for a non-TCN Server batch (i.e. it exactly matches what was set up in the Administration module).

Care must be taken when writing special routing rules if the workflow agent is expected to work in a TCN Server environment. It may be necessary to modify the rules to take into account a TCN Server exchange with the central site.

See Also

Reference

Kofax.Capture.ACWFLib Namespace


ACWorkflowModules Constructor

ACWorkflowModules Constructor

Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowModules class.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ACWorkflowModules()
Public Sub New
Remarks
See Also

Reference

ACWorkflowModules Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowModules Methods

ACWorkflowModules Methods

The ACWorkflowModules type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ACWorkflowModules Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowModules.GetEnumerator Method

ACWorkflowModulesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.SDK.Workflow.IACWorkflowModules object.

Implements

IEnumerableGetEnumerator
Remarks
See Also

Reference

ACWorkflowModules Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowModules Properties

ACWorkflowModules Properties

The ACWorkflowModules type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowModule in the collection.
Public property | Item | Returns the Kofax.Capture.SDK.Workflow.IACWorkflowModule object specified by index.
Top
See Also

Reference

ACWorkflowModules Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowModules.Count Property

ACWorkflowModulesCount Property

Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowModule in the collection.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IACWorkflowModulesCount
Remarks
See Also

Reference

ACWorkflowModules Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowModules.Item Property

ACWorkflowModulesItem Property

Returns the Kofax.Capture.SDK.Workflow.IACWorkflowModule object specified by index.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowModule this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IACWorkflowModule
    Get

Parameters

vntIndexKey
Type: SystemObject
The index can either be a module ID, a module name, or its (1-based) numeric index in the collection.

Property Value

Type: IACWorkflowModule

Return Value

Type: IACWorkflowModule
Kofax.Capture.SDK.Workflow.IACWorkflowModule

Implements

IACWorkflowModulesItemObject
Remarks

Referencing by module ID is most portable to other languages if searching for a specific module.

For each ... Next is the standard Visual Basic iteration method. When using this property, the client code iterates over the collection based on the queue ordering assigned to the batch class in the Administration module.

See Also

Reference

ACWorkflowModules Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSite Class

ACWorkflowSite Class

Represents a site in the Tungsten Capture workflow.

Inheritance Hierarchy
SystemObject
Kofax.Capture.ACWFLibACWorkflowSite

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ACWorkflowSite : IACWorkflowSite
Public Class ACWorkflowSite
    Implements IACWorkflowSite

The ACWorkflowSite type exposes the following members.

Constructors
 | Name | Description
Public method | ACWorkflowSite | Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowSite class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Returns the name of the site.
Public property | SiteGUID | Returns the globally unique ID representing the site.
Top
Remarks
See Also

Reference

Kofax.Capture.ACWFLib Namespace


ACWorkflowSite Constructor

ACWorkflowSite Constructor

Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowSite class.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ACWorkflowSite(
    string strSiteGuid,
    string strName
)
Public Sub New (
    strSiteGuid As String,
    strName As String
)

Parameters

strSiteGuid
Type: SystemString
strName
Type: SystemString
Remarks
See Also

Reference

ACWorkflowSite Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSite Methods

ACWorkflowSite Methods

The ACWorkflowSite type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ACWorkflowSite Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSite Properties

ACWorkflowSite Properties

The ACWorkflowSite type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the site.
Public property | SiteGUID | Returns the globally unique ID representing the site.
Top
See Also

Reference

ACWorkflowSite Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSite.Name Property

ACWorkflowSiteName Property

Returns the name of the site.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IACWorkflowSiteName
Remarks
See Also

Reference

ACWorkflowSite Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSite.SiteGUID Property

ACWorkflowSiteSiteGUID Property

Returns the globally unique ID representing the site.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string SiteGUID { get; }
Public ReadOnly Property SiteGUID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IACWorkflowSiteSiteGUID
Remarks
See Also

Reference

ACWorkflowSite Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSites Class

ACWorkflowSites Class

Defines a collection of ACWorkflowSite objects representing the various sites.

Inheritance Hierarchy
SystemObject
Kofax.Capture.ACWFLibACWorkflowSites

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ACWorkflowSites : IACWorkflowSites
Public Class ACWorkflowSites
    Implements IACWorkflowSites

The ACWorkflowSites type exposes the following members.

Constructors
 | Name | Description
Public method | ACWorkflowSites | Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowSites class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BatchCreationSite | Returns an object that represents the site that originally scanned the batch.
Public property | CentralSite | Returns an object that represents the central site.
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowSite in the collection.
Public property | CurrentSite | Returns an object that represents the current site.
Public property | Item | Returns the Kofax.Capture.SDK.Workflow.IACWorkflowSite object specified by index.
Public property | RescanSite | Returns an object that represents the site where rescan should be running.
Top
Remarks
See Also

Reference

Kofax.Capture.ACWFLib Namespace


ACWorkflowSites Constructor

ACWorkflowSites Constructor

Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowSites class.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ACWorkflowSites()
Public Sub New
Remarks
See Also

Reference

ACWorkflowSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSites Methods

ACWorkflowSites Methods

The ACWorkflowSites type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ACWorkflowSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSites.Dispose Method

ACWorkflowSitesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

ACWorkflowSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSites.GetEnumerator Method

ACWorkflowSitesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.SDK.Workflow.IACWorkflowSites object.

Implements

IEnumerableGetEnumerator
Remarks
See Also

Reference

ACWorkflowSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSites Properties

ACWorkflowSites Properties

The ACWorkflowSites type exposes the following members.

Properties
 | Name | Description
Public property | BatchCreationSite | Returns an object that represents the site that originally scanned the batch.
Public property | CentralSite | Returns an object that represents the central site.
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowSite in the collection.
Public property | CurrentSite | Returns an object that represents the current site.
Public property | Item | Returns the Kofax.Capture.SDK.Workflow.IACWorkflowSite object specified by index.
Public property | RescanSite | Returns an object that represents the site where rescan should be running.
Top
See Also

Reference

ACWorkflowSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSites.BatchCreationSite Property

ACWorkflowSitesBatchCreationSite Property

Returns an object that represents the site that originally scanned the batch.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowSite BatchCreationSite { get; }
Public ReadOnly Property BatchCreationSite As IACWorkflowSite
    Get

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite

Implements

IACWorkflowSitesBatchCreationSite
Remarks

If TCN Server is not enabled, this property always returns the current site.

See Also

Reference

ACWorkflowSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSites.CentralSite Property

ACWorkflowSitesCentralSite Property

Returns an object that represents the central site.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowSite CentralSite { get; }
Public ReadOnly Property CentralSite As IACWorkflowSite
    Get

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite

Implements

IACWorkflowSitesCentralSite
Remarks

Without TCN Server enabled, it is implied that this is always the current site.

See Also

Reference

ACWorkflowSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSites.Count Property

ACWorkflowSitesCount Property

Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowSite in the collection.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IACWorkflowSitesCount
Remarks
See Also

Reference

ACWorkflowSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSites.CurrentSite Property

ACWorkflowSitesCurrentSite Property

Returns an object that represents the current site.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowSite CurrentSite { get; }
Public ReadOnly Property CurrentSite As IACWorkflowSite
    Get

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite

Implements

IACWorkflowSitesCurrentSite
Remarks
See Also

Reference

ACWorkflowSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSites.Item Property

ACWorkflowSitesItem Property

Returns the Kofax.Capture.SDK.Workflow.IACWorkflowSite object specified by index.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowSite this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IACWorkflowSite
    Get

Parameters

vntIndexKey
Type: SystemObject
The index can either be a site name, a site GUID, or its (1-based) numeric index in the collection.

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite

Implements

IACWorkflowSitesItemObject
Remarks

Referencing by Site GUID is most portable to other languages if searching for a specific site.

For each … Next is the standard Visual Basic iteration method. When using this property, the client code iterates over the collection based on the alphabetic order of all remote site names.

See Also

Reference

ACWorkflowSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowSites.RescanSite Property

ACWorkflowSitesRescanSite Property

Returns an object that represents the site where rescan should be running.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowSite RescanSite { get; }
Public ReadOnly Property RescanSite As IACWorkflowSite
    Get

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite

Implements

IACWorkflowSitesRescanSite
Remarks
See Also

Reference

ACWorkflowSites Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowState Class

ACWorkflowState Class

Indicates a possible batch state.

Inheritance Hierarchy
SystemObject
Kofax.Capture.ACWFLibACWorkflowState

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ACWorkflowState : IACWorkflowState
Public Class ACWorkflowState
    Implements IACWorkflowState

The ACWorkflowState type exposes the following members.

Constructors
 | Name | Description
Public method | ACWorkflowState | Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowState class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Returns the name of the state.
Public property | StateID | Returns the internal State ID.
Top
Remarks
See Also

Reference

Kofax.Capture.ACWFLib Namespace


ACWorkflowState Constructor

ACWorkflowState Constructor

Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowState class.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ACWorkflowState(
    string strName,
    int lStateID
)
Public Sub New (
    strName As String,
    lStateID As Integer
)

Parameters

strName
Type: SystemString
The state name.
lStateID
Type: SystemInt32
The state ID.
Remarks
See Also

Reference

ACWorkflowState Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowState Methods

ACWorkflowState Methods

The ACWorkflowState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ACWorkflowState Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowState Properties

ACWorkflowState Properties

The ACWorkflowState type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the state.
Public property | StateID | Returns the internal State ID.
Top
See Also

Reference

ACWorkflowState Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowState.Name Property

ACWorkflowStateName Property

Returns the name of the state.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IACWorkflowStateName
Remarks
See Also

Reference

ACWorkflowState Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowState.StateID Property

ACWorkflowStateStateID Property

Returns the internal State ID.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int StateID { get; }
Public ReadOnly Property StateID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IACWorkflowStateStateID
Remarks
See Also

Reference

ACWorkflowState Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowStates Class

ACWorkflowStates Class

Defines a collection of ACWorkflow state objects representing the various states.

Inheritance Hierarchy
SystemObject
Kofax.Capture.ACWFLibACWorkflowStates

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ACWorkflowStates : IACWorkflowStates
Public Class ACWorkflowStates
    Implements IACWorkflowStates

The ACWorkflowStates type exposes the following members.

Constructors
 | Name | Description
Public method | ACWorkflowStates | Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowStates class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowState in the collection.
Public property | Item | Returns the ACWorkflowState object specified by the index.
Top
Remarks
See Also

Reference

Kofax.Capture.ACWFLib Namespace


ACWorkflowStates Constructor

ACWorkflowStates Constructor

Initializes a new instance of the Kofax.Capture.ACWFLib.ACWorkflowStates class.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ACWorkflowStates()
Public Sub New
Remarks
See Also

Reference

ACWorkflowStates Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowStates Methods

ACWorkflowStates Methods

The ACWorkflowStates type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ACWorkflowStates Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowStates.Dispose Method

ACWorkflowStatesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

ACWorkflowStates Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowStates.GetEnumerator Method

ACWorkflowStatesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.SDK.Workflow.IACWorkflowStates object.

Implements

IEnumerableGetEnumerator
Remarks
See Also

Reference

ACWorkflowStates Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowStates Properties

ACWorkflowStates Properties

The ACWorkflowStates type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowState in the collection.
Public property | Item | Returns the ACWorkflowState object specified by the index.
Top
See Also

Reference

ACWorkflowStates Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowStates.Count Property

ACWorkflowStatesCount Property

Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowState in the collection.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IACWorkflowStatesCount
Remarks
See Also

Reference

ACWorkflowStates Class
Kofax.Capture.ACWFLib Namespace


ACWorkflowStates.Item Property

ACWorkflowStatesItem Property

Returns the ACWorkflowState object specified by the index.

Namespace: Kofax.Capture.ACWFLib
Assembly: Kofax.Capture.ACWFLib (in Kofax.Capture.ACWFLib.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACWorkflowState this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IACWorkflowState
    Get

Parameters

vntIndexKey
Type: SystemObject
The index can either be a state name, or its (1-based) numeric index in the collection.

Property Value

Type: IACWorkflowState

Return Value

Type: IACWorkflowState
Kofax.Capture.SDK.Workflow.IACWorkflowState

Implements

IACWorkflowStatesItemObject
Remarks

"For Each ... Next" is the standard Visual Basic iteration method. When using this approach, the client code iterates over the collection based on the ordering defined below. This ordering is subject to change and you should not rely on any specific ordering for this collection.

The list of states, their ordering, and rules of usage are as follows.

  • Ready - The batch is ready for the next module.
  • Suspended - The batch is suspended in the current module. Suspension may occur if an operator is in the middle of processing a batch, but must suspend processing (such as to take a lunch break).
  • Error - The batch is in error. Setting this status causes the batch to be routed to the Quality Control module irrespective of the next module set, or whether Quality Control has been explicitly assigned to this batch class. The ErrorCode and ErrorText properties of the ACWorkflowData object are ignored unless the batch is set to the Error state.
  • Completed - This is an unusual status that occurs only when Export is not assigned to a batch class. In this case, after the batch finishes processing in the final module, its state is set to "Completed." Setting the Error state causes an error unless the module is the last module in the ACWorkflowModules list and this module is neither Export nor TCN Server.
  • Reserved - This status is available only in Batch Manager. This status is occasionally used by administrators to temporarily take a batch offline. It can be interpreted as a long-term form of the suspended state.

Invalid state and module combinations will cause an error when ProcessWorkflow completes. This error will cause the batch to be routed to the Quality Control module.

See Also

Reference

ACWorkflowStates Class
Kofax.Capture.ACWFLib Namespace


Kofax.Capture.AdminModule Namespace

Kofax.Capture.AdminModule Namespace

Provides utility classes for working with Tungsten Capture Administration API objects.

Classes
Class Description
ApiObjectWrapperT
Represents a strongly typed wrapper of Tungsten Capture .NET API objects that can be accessed by WrappedObject property. Provides methods to determine if wrapped object is Nothing or null, and automatically makes a call to the wrapped object's Dispose method when this object is being disposed.
Usage:
Examples
The following example demonstrates the use of this class.
C#
VB
Copy
using Kofax.Capture.AdminModule;   // Working with Tungsten Capture's Administration module
...
// Retrieves the active batch class
InteropServices.IBatchClass oBatchClass = m_oAdminApp.ActiveBatchClass;
using (ApiObjectWrapper <InteropServices.IBatchClass> oApiObjectWrapper = new ApiObjectWrapper<InteropServices.IBatchClass>(oBatchClass))
{
  if (!oApiObjectWrapper.IsNull)
  {
     // Do something with the oBatchClass via oApiObjectWrapper.WrappedObject property
     ...
  }
} // oBatchClass.Dispose() will be called automatically.
Imports Kofax.Capture.AdminModule   ' Working with Tungsten Capture's Administration module
...

' Retrieves the active batch class
Dim oBatchClass as InteropServices.IBatchClass = m_oAdminApp.ActiveBatchClass
Using oApiObjectWrapper As New ApiObjectWrapper(Of InteropServices.IBatchClass)(oBatchClass)
   If Not oApiObjectWrapper.IsNull Then
      ' Do something with oBatchClass via oApiObjectWrapper.WrappedObject property
      ...
   End If
End Using  ' oBatchClass.Dispose() will be called automatically.
C#
VB
Copy
using Kofax.Capture.CaptureModule; // Working with Tungsten Capture's modules
...

// Retrieves the currently active batch
InteropServices.IBatch oBatch = m_oApp.ActiveBatch;
using (ApiObjectWrapper <InteropServices.IBatch> oApiObjectWrapper = new ApiObjectWrapper<InteropServices.IBatch>(oBatch))
{
  if (!oApiObjectWrapper.IsNull)
  {
     // Do something with the oBatch via oApiObjectWrapper.WrappedObject property
     ...
  }
} // oBatch.Dispose() will be called automatically.
Imports Kofax.Capture.CaptureModule ' Working with Tungsten Capture's modules
...

' Retrieves the currently active batch
Dim oBatch as InteropServices.IBatch = m_oApp.ActiveBatch
Using oApiObjectWrapper As New ApiObjectWrapper(Of InteropServices.IBatch)(oBatch)
   If Not oApiObjectWrapper.IsNull Then
      ' Do something with oBatch via oApiObjectWrapper.WrappedObject property
      ...
   End If
End Using  ' oBatch.Dispose() will be called automatically.
Remarks


ApiObjectWrapper(T) Class

ApiObjectWrapperT Class
Represents a strongly typed wrapper of Tungsten Capture .NET API objects that can be accessed by WrappedObject property. Provides methods to determine if wrapped object is Nothing or null, and automatically makes a call to the wrapped object's Dispose method when this object is being disposed.
Usage:
Examples
The following example demonstrates the use of this class.
C#
VB
Copy
using Kofax.Capture.AdminModule;   // Working with Tungsten Capture's Administration module
...
// Retrieves the active batch class
InteropServices.IBatchClass oBatchClass = m_oAdminApp.ActiveBatchClass;
using (ApiObjectWrapper <InteropServices.IBatchClass> oApiObjectWrapper = new ApiObjectWrapper<InteropServices.IBatchClass>(oBatchClass))
{
  if (!oApiObjectWrapper.IsNull)
  {
     // Do something with the oBatchClass via oApiObjectWrapper.WrappedObject property
     ...
  }
} // oBatchClass.Dispose() will be called automatically.
Imports Kofax.Capture.AdminModule   ' Working with Tungsten Capture's Administration module
...

' Retrieves the active batch class
Dim oBatchClass as InteropServices.IBatchClass = m_oAdminApp.ActiveBatchClass
Using oApiObjectWrapper As New ApiObjectWrapper(Of InteropServices.IBatchClass)(oBatchClass)
   If Not oApiObjectWrapper.IsNull Then
      ' Do something with oBatchClass via oApiObjectWrapper.WrappedObject property
      ...
   End If
End Using  ' oBatchClass.Dispose() will be called automatically.
C#
VB
Copy
using Kofax.Capture.CaptureModule; // Working with Tungsten Capture's modules
...

// Retrieves the currently active batch
InteropServices.IBatch oBatch = m_oApp.ActiveBatch;
using (ApiObjectWrapper <InteropServices.IBatch> oApiObjectWrapper = new ApiObjectWrapper<InteropServices.IBatch>(oBatch))
{
  if (!oApiObjectWrapper.IsNull)
  {
     // Do something with the oBatch via oApiObjectWrapper.WrappedObject property
     ...
  }
} // oBatch.Dispose() will be called automatically.
Imports Kofax.Capture.CaptureModule ' Working with Tungsten Capture's modules
...

' Retrieves the currently active batch
Dim oBatch as InteropServices.IBatch = m_oApp.ActiveBatch
Using oApiObjectWrapper As New ApiObjectWrapper(Of InteropServices.IBatch)(oBatch)
   If Not oApiObjectWrapper.IsNull Then
      ' Do something with oBatch via oApiObjectWrapper.WrappedObject property
      ...
   End If
End Using  ' oBatch.Dispose() will be called automatically.
Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModuleApiObjectWrapperT

Namespace: Kofax.Capture.AdminModule
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(false)]
public class ApiObjectWrapper<T> : IDisposable

<ComVisibleAttribute(false)>
Public Class ApiObjectWrapper(Of T)
    Implements IDisposable

Type Parameters

T
The type of element wrapped by this class. Must implement System.IDisposable interface.

The ApiObjectWrapperT type exposes the following members.

Constructors
 | Name | Description
Public method | ApiObjectWrapperT | Constructor that takes generic type argument T.
Top
Methods
 | Name | Description
Public method | Dispose | Perform class-defined tasks associated with freeing, releasing or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsNull | Determines if the held object is Nothing or null.
Public property | WrappedObject | Returns an instance of held object as type specified by generic type argument T.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule Namespace


ApiObjectWrapper(T) Constructor

ApiObjectWrapperT Constructor
Constructor that takes generic type argument T.

Namespace: Kofax.Capture.AdminModule
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ApiObjectWrapper(
    T oObj
)
Public Sub New (
    oObj As T
)

Parameters

oObj
Type: T
Any object type that implements System.IDisposable interface.
Remarks
See Also

Reference

ApiObjectWrapperT Class
Kofax.Capture.AdminModule Namespace


ApiObjectWrapper(T) Methods

ApiObjectWrapperT Methods

The ApiObjectWrapperT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Perform class-defined tasks associated with freeing, releasing or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ApiObjectWrapperT Class
Kofax.Capture.AdminModule Namespace


ApiObjectWrapper(T).Dispose Method

ApiObjectWrapperTDispose Method
Perform class-defined tasks associated with freeing, releasing or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

ApiObjectWrapperT Class
Kofax.Capture.AdminModule Namespace


ApiObjectWrapper(T) Properties

ApiObjectWrapperT Properties

The ApiObjectWrapperT generic type exposes the following members.

Properties
 | Name | Description
Public property | IsNull | Determines if the held object is Nothing or null.
Public property | WrappedObject | Returns an instance of held object as type specified by generic type argument T.
Top
See Also

Reference

ApiObjectWrapperT Class
Kofax.Capture.AdminModule Namespace


ApiObjectWrapper(T).IsNull Property

ApiObjectWrapperTIsNull Property
Determines if the held object is Nothing or null.

Namespace: Kofax.Capture.AdminModule
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool IsNull { get; }
Public ReadOnly Property IsNull As Boolean
    Get

Property Value

Type: Boolean
Boolean in Visual Basic or bool in C# programming languages.

Return Value

Type: Boolean
True if the wrapped object is Nothing or null.
Remarks
See Also

Reference

ApiObjectWrapperT Class
Kofax.Capture.AdminModule Namespace


ApiObjectWrapper(T).WrappedObject Property

ApiObjectWrapperTWrappedObject Property
Returns an instance of held object as type specified by generic type argument T.

Namespace: Kofax.Capture.AdminModule
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public T WrappedObject { get; }
Public ReadOnly Property WrappedObject As T
    Get

Property Value

Type: T
Returns the instance of object that this class is currently holding.

Return Value

Type: T
Generic type argument T.
Remarks
See Also

Reference

ApiObjectWrapperT Class
Kofax.Capture.AdminModule Namespace


Kofax.Capture.AdminModule.InteropServices Namespace

Kofax.Capture.AdminModule.InteropServices Namespace

You can implement a setup OCX to customize batch class setup options available in the Administration module. With a setup OCX, you can define custom menus, configuration settings, and publish checks.
A setup OCX can be associated with a custom extension, or designed without a custom extension:

  • A setup OCX with an associated custom module allows you to customize the batch class set up process for batch classes that contain the custom module as part of their workflow. Items defined in the setup OCX are available only for batch classes that contain the custom module.
  • A setup OCX with an associated workflow agent allows you to create custom user interfaces that you can use to configure any runtime parameters that the workflow agent may require. Items defined in the setup OCX are available only for batch classes that contain the workflow agent.
  • A setup OCX without an associated custom extension allows you to customize the batch class set up process for all batch classes. Items defined in the setup OCX are available for all batch classes.
While it is possible to use the standard configuration settings and publish checks available from Administration with a custom extension, it is likely that you will want to use a custom setup OCX.

Classes
 | Class | Description
Public class | AdminApplication | AdminApplication COM implementation class. When a setup OCX is loaded, a reference to an AdminApplication object is passed to the OCX. An AdminApplication object is valid until the calling application shuts down (or, if called from the OCX, when the OCX terminate event is completed).
Public class | AdminLogin | AdminLogin COM implementation class. Defines a COM object that coordinates logging in and logging out of Tungsten Capture. This is the only object that can be created using New or CreateObject in Visual Basic.
Public class | BatchClass | BatchClass COM implementation class. Defines information about a batch class.
Public class | BatchClasses | BatchClasses COM implementation class. Defines a COM collection of BatchClass objects.
Public class | BatchField | BatchField COM implementation class. Defines information about a batch field.
Public class | BatchFields | BatchFields COM implementation class. Defines a COM collection of IBatchField objects associated with a batch class.
Public class | DocumentClass | DocumentClass COM implementation class. Defines information about a document class.
Public class | DocumentClasses | DocumentClasses COM implementation class. Defines a COM collection of DocumentClass objects associated with a batch class.
Public class | ExportEventArgs | ExportEventArgs COM implementation class. The setup OCX receives the specified action event before a batch class is exported.
Public class | FieldType | FieldType COM implementation class. Defines information about a field type.
Public class | FieldTypes | FieldTypes COM implementation class. Defines a COM collection of FieldType objects.
Public class | FolderClass | FolderClass COM implementation class. Defines information about a folder class.
Public class | FolderClasses | FolderClasses COM implementation class. Defines a collection of FolderClass objects associated with folder classes.
Public class | FormIdZone | FormIdZone COM implementation class. Defines information about a form identification zone.
Public class | FormIdZoneColl | FormIdZoneColl COM implementation class. Defines a COM collection of FormIDZone objects on a sample page.
Public class | FormType | FormType COM implementation class. Defines information about a form type.
Public class | FormTypes | FormTypes COM implementation class. Defines a COM collection of FormType objects.
Public class | Group | Group COM implementation class. Defines information about a Group object.
Public class | Groups | Groups COM implementation class. Defines a COM collection of Group objects.
Public class | Implementation |
Public class | ImportEventArgs | ImportEventArgs COM implementation class. The setup OCX receives the ImportCustomFiles action event during a batch class import.
Public class | IndexField | IndexField COM implementation class. Defines information about a document or folder index field.
Public class | IndexFields | IndexFields COM implementation class. Defines a COM collection of IndexField objects associated with document and folder classes.
Public class | IndexGroupZone | IndexGroupZone COM implementation class. Defines information about an Index Group Zone.
Public class | IndexGroupZones | IndexGroupZones COM implementation class. Defines a COM collection of IndexGroupZone objects associated with the document class.
Public class | IndexGrpMemZone | IndexGrpMemZone COM implementation class. Defines a member of a group zone.
Public class | IndexGrpMemZones | IndexGrpMemZones COM implementation class. Defines a COM collection of IndexGrpMemZone objects associated with the index group zone.
Public class | IndexZone | IndexZone COM implementation class. Defines information about an index zone.
Public class | IndexZones | IndexZones COM implementation class. Defines COM collection of IndexZone objects associated with the document class.
Public class | PageLevelBarcode | PageLevelBarcode COM implementation class. Defines a field assigned for page level bar codes.
Public class | PgLvlBarcodeColl | PgLvlBarcodeColl COM implementation class. Defines a COM collection of PageLevelBarcode objects.
Public class | Queue | Queue COM implementation class. Defines information about a Queue.
Public class | QueueProperties | QueueProperties COM implementation class. Defines a COM collection of QueueProperty objects.
Public class | QueueProperty | QueueProperty COM implementation class. Defines the information for one custom queue property.
Public class | Queues | Queues COM implementation class. Defines a COM collection of Queue objects associated with the application.
Public class | RecognitionProf | RecognitionProf COM implementation class. Defines information about a Recognition Profile.
Public class | RecognitionProfs | RecognitionProfs COM implementation class. Defines a COM collection of RecognitionProf objects.
Public class | RegistrationZone | RegistrationZone COM implementation class. Defines information about a registration zone.
Public class | RegZoneColl | RegZoneColl COM implementation class. Defines a COM collection of RegistrationZone objects.
Public class | RemoteSite | RemoteSite COM implementation class. Defines information about a RemoteSite object.
Public class | RemoteSites | RemoteSites COM implementation class. Defines a COM collection of RemoteSite objects.
Public class | RenameEventArgs | RenameEventArgs COM implementation class. Defines an object that is passed to the OCX for the rename action events.
Public class | RGB | RGB COM implementation class. Contains the red, green, and blue values of a color.
Public class | SamplePage | SamplePage COM implementation class. Defines information about the sample page.
Public class | SamplePages | SamplePages COM implementation class. Defines a COM collection of SamplePage objects associated with a form type.
Public class | SepAndFormIDProf | SepAndFormIDProf COM implementation class. Defines information about a separation and form ID profile.
Public class | SepAndFormIDProfs | SepAndFormIDProfs COM implementation class. Defines a COM collection of ISepAndFormIDProf objects associated with the application.
Public class | SeparationZone | SeparationZone COM implementation class. Defines information about a separation zone.
Public class | SuggestedValue | SuggestedValue COM implementation class. Defines information about a suggested value.
Public class | SuggestedValues | SuggestedValues COM implementation class. Defines a COM collection of SuggestedValue objects.
Public class | TableDefinition | TableDefinition COM implementation class. Defines a table in a document class.
Public class | TableDefinitions | TableDefinitions COM implementation class. Defines a collection of tables defined in a document class.
Public class | Theme | Theme COM implementation class. A COM object that provides access to the theme of the Tungsten Capture system.
Public class | User | User COM implementation class. Defines information about a User object.
Public class | Users | Users COM implementation class. Defines a COM collection of User objects.
Interfaces
 | Interface | Description
Public interface | IAdminApplication | IAdminApplication COM Interface. When a setup OCX is loaded, a reference to an AdminApplication object is passed to the OCX. An AdminApplication object is valid until the calling application shuts down (or, if called from the OCX, when the OCX terminate event is completed).
Public interface | IAdminLogin | IAdminLogin COM interface. Defines a COM object that coordinates logging in and logging out of Tungsten Capture. This is the only object that can be created using New or CreateObject in Visual Basic.
Public interface | IBatchClass | IBatchClass COM Interface. Defines information about a batch class.
Public interface | IBatchClasses | IBatchClasses COM Interface. Defines a COM collection of BatchClass objects.
Public interface | IBatchField | IBatchField COM Interface. Defines information about a batch field.
Public interface | IBatchFields | IBatchFields COM Interface. Defines a COM collection of BatchField objects associated with a batch class.
Public interface | IDocumentClass | IDocumentClass COM Interface. Defines information about a document class.
Public interface | IDocumentClasses | IDocumentClasses COM Interface. Defines a COM collection of DocumentClass objects associated with a batch class.
Public interface | IExportEventArgs | IExportEventArgs COM Interface. The setup OCX receives the specified action event before a batch class is exported.
Public interface | IFieldType | IFieldType COM Interface. Defines information about a field type.
Public interface | IFieldTypes | IFieldTypes COM Interface. Defines a COM collection of FieldType objects.
Public interface | IFolderClass | IFolderClass COM Interface. Defines information about a folder class.
Public interface | IFolderClasses | IFolderClasses COM Interface. Defines a collection of FolderClass objects associated with folder classes.
Public interface | IFormIdZone | IFormIdZone COM Interface. Defines information about a form identification zone.
Public interface | IFormIdZoneColl | IFormIdZoneColl COM Interface. Defines a COM collection of FormIDZone objects on a sample page.
Public interface | IFormType | IFormType COM Interface. Defines information about a form type.
Public interface | IFormTypes | IFormTypes COM Interface. Defines a COM collection of FormType objects.
Public interface | IGroup | IGroup COM Interface. Defines information about a Group object.
Public interface | IGroups | IGroups COM Interface. Defines a COM collection of Group objects.
Public interface | IImportEventArgs | IImportEventArgs COM Interface. The setup OCX receives the ImportCustomFiles action event during a batch class import.
Public interface | IIndexField | IIndexField COM Interface. Defines information about a document or folder index field.
Public interface | IIndexFields | IIndexFields COM Interface. Defines a COM collection of IndexField objects associated with document and folder classes.
Public interface | IIndexGroupZone | IIndexGroupZone COM Interface. Defines information about an Index Group Zone.
Public interface | IIndexGroupZones | IIndexGroupZones COM Interface. Defines a COM collection of IndexGroupZone objects associated with the document class.
Public interface | IIndexGrpMemZone | IIndexGrpMemZone COM Interface. Defines a member of a group zone.
Public interface | IIndexGrpMemZones | IIndexGrpMemZones COM Interface. Defines a COM collection of IndexGrpMemZone objects associated with the index group zone.
Public interface | IIndexZone | IIndexZone COM Interface. Defines information about an index zone.
Public interface | IIndexZones | IIndexZones COM Interface. Defines COM collection of IndexZone objects associated with the document class.
Public interface | IPageLevelBarcode | IPageLevelBarcode COM Interface. Defines a field assigned for page level bar codes.
Public interface | IPgLvlBarcodeColl | IPgLvlBarcodeColl COM Interface. Defines a COM collection of PageLevelBarcode objects.
Public interface | IQueue | IQueue COM Interface. Defines information about a Queue.
Public interface | IQueueProperties | IQueueProperties COM Interface. Defines a COM collection of QueueProperty objects.
Public interface | IQueueProperty | IQueueProperty COM Interface. Defines the information for one custom queue property.
Public interface | IQueues | IQueues COM Interface. Defines a COM collection of Queue objects associated with the application.
Public interface | IRecognitionProf | IRecognitionProf COM Interface. Defines information about a Recognition Profile.
Public interface | IRecognitionProfs | IRecognitionProfs COM Interface. Defines a COM collection of RecognitionProf objects.
Public interface | IRegistrationZone | IRegistrationZone COM Interface. Defines information about a registration zone.
Public interface | IRegZoneColl | IRegZoneColl COM Interface. Defines a COM collection of RegistrationZone objects.
Public interface | IRemoteSite | IRemoteSite COM Interface. Defines information about a RemoteSite object.
Public interface | IRemoteSites | IRemoteSites COM Interface. Defines a COM collection of RemoteSite objects.
Public interface | IRenameEventArgs | IRenameEventArgs COM Interface. Defines an object that is passed to the OCX for the rename action events.
Public interface | IRGB | IRGB COM Interface. Contains the red, green, and blue values of a color.
Public interface | ISamplePage | ISamplePage COM Interface. Defines information about the sample page.
Public interface | ISamplePages | ISamplePages COM Interface. Defines a COM collection of SamplePage objects associated with a form type.
Public interface | ISepAndFormIDProf | ISepAndFormIDProf COM Interface. Defines information about a separation and form ID profile.
Public interface | ISepAndFormIDProfs | ISepAndFormIDProfs COM Interface. Defines a COM collection of ISepAndFormIDProf objects associated with the application.
Public interface | ISeparationZone | ISeparationZone COM Interface. Defines information about a separation zone.
Public interface | ISuggestedValue | ISuggestedValue COM Interface. Defines information about a suggested value.
Public interface | ISuggestedValues | ISuggestedValues COM Interface. Defines a COM collection of SuggestedValue objects.
Public interface | ITableDefinition | ITableDefinition COM Interface. Defines a table in a document class.
Public interface | ITableDefinitions | ITableDefinitions COM Interface. Defines a collection of tables defined in a document class.
Public interface | ITheme | ITheme COM Interface. A COM object that provides access to the theme of the Tungsten Capture system.
Public interface | IUser | IUser COM Interface. Defines information about a User object.
Public interface | IUsers | IUsers COM Interface. Defines a COM collection of User objects.
Enumerations
 | Enumeration | Description
Public enumeration | KfxApiAdminMenuItems | This enumeration represents Administration menu items.
Public enumeration | KfxApiAdminObjectType | Defines object types that is used by Administration module to identify the type of object that has focus after a context change.
Public enumeration | KfxApiAdminShapeType | Defines shape type object used by Administration module.
Public enumeration | KfxApiAdminTabPanel | Defines constant that is used by Administration module to identify the current active tab panel.
Public enumeration | KfxAPIApplicationFunctionList | Defines the function list that can be blocked or restored menu bar items, context menu items, toolbar buttons, and keyboard accelerators.
Public enumeration | KfxApiBatchState | This enumeration represents Batch states.
Public enumeration | KfxApiCustomAdminPanel | Defines kind of custom admin panel can enable/disable import/export event.
Public enumeration | KfxApiErr | Defines the possible errors. All errors are exposed in the KfxApiErr enum value within the Tungsten Capture Module Type Library.
Public enumeration | KfxApiKCNSProfilesImportMode | Defines TCNS profiles import mode.
Public enumeration | KfxApiQCMenuItems | This enumeration represents Quality Control menu items.
Public enumeration | KfxApiScanMenuItems | This enumeration represents Scan menu items.
Public enumeration | KfxApiTransferMode | Defines transfer mode for import batch class.
Public enumeration | KfxApiValidationMenuItems | This enumeration represents Validation menu items.
Public enumeration | KfxApiValidationMode | This enumeration represents Validation modes.
Public enumeration | KfxApiVerificationMenuItems | This enumeration represents Verification menu items.
Public enumeration | KfxDataEvent | Defines the various different data events. Data events are essentially function calls to the OCX to get data-source information and to communicate changes in data.
Public enumeration | KfxDataEventReturnCode | Defines the enumeration that represents the return code for a data event.
Public enumeration | KfxDataEventType | Defines data type event enumeration.
Public enumeration | KfxMenuEnable | Defines a possible state of Enabled/Grayed for a menu item.
Public enumeration | KfxOcxEvent | All application events are passed to the OCX via a single function call.
Public enumeration | KfxShowMenu | Defines the possible menu showing state.
Public enumeration | KfxSqlDataType | Defines SQL data types supported by the API.
Remarks


AdminApplication Class

AdminApplication Class

AdminApplication COM implementation class.

When a setup OCX is loaded, a reference to an AdminApplication object is passed to the OCX. An AdminApplication object is valid until the calling application shuts down (or, if called from the OCX, when the OCX terminate event is completed).

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesAdminApplication

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638CFFF4-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class AdminApplication : IAdminApplication,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638CFFF4-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class AdminApplication
    Implements IAdminApplication, IDisposable

The AdminApplication type exposes the following members.

Constructors
 | Name | Description
Public method | AdminApplication | Initializes a new instance of the Kofax.Capture.AdminModule.InteropServices.AdminApplication class.
Top
Methods
 | Name | Description
Public method | AddMenu | Adds a menu to Administration's main menu bar.
Public method | AddMenuEx | Adds a menu to the application.
Public method | CreateBatchClass | Adds the batch class.
Public method | CreateDocumentClass | Adds the document class.
Public method | CreateFieldType | Creates a new field type. The data type is VARCHAR with a length of 254 characters.
Public method | CreateFolderClass | Adds the folder class.
Public method | CustomDataFolder | Returns a global custom data path based on the provided module ID.
Public method | DeleteBatchClass | Deletes the specified batch class.
Public method | DeleteDocumentClass | Deletes the specified document class.
Public method | DeleteFieldType | Deletes the specified field type.
Public method | DeleteFolderClass | Deletes the folder class.
Public method | DisableExportEvents | Disable/Enable the export events sending to custom administration panels when exporting a batch class.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EnableMenu | Enables or disables (grays) a menu.
Public method | Equals | (Inherited from Object.)
Public method | ExportBatchClasses | Export batch classes to a CAB file.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ImportBatchClasses | Imports batch classes from a CAB file and preserves the KTM project assignment if it exists.
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | SelectMenuItem | Selects a menu item.
Public method | ShowMenu | Shows or hides a menu.
Public method | ShowWindow | Shows or hides a panel.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ActiveBatchClass | Returns the currently selected batch class.
Public property | ActiveDocumentClass | Returns the currently selected document class.
Public property | ActiveFieldType | Returns the currently selected field type.
Public property | ActiveFolderClass | Returns the currently active folder class or nothing.
Public property | ActiveFormIdZone | Returns the currently selected form ID zone.
Public property | ActiveFormIdZoneColl | Returns collection object for Form ID Zones.
Public property | ActiveFormType | Returns the currently selected form type.
Public property | ActiveIndexGroupZone | Returns the currently selected index group zone.
Public property | ActiveIndexGrpMemZone | Returns the currently selected group member zone.
Public property | ActiveIndexZone | Returns the currently selected index zone.
Public property | ActiveIndexZoneColl | Returns the currently selected collection of index zones.
Public property | ActiveObjectType | Returns the type of the currently selected node or nothing.
Public property | ActivePageLevelBarcode | Returns the currently selected page level bar code.
Public property | ActivePageLevelBarcodeColl | Returns the currently selected collection of page level bar codes.
Public property | ActiveRegistrationZone | Returns the currently selected registration zone.
Public property | ActiveRegZoneColl | Returns the currently selected collection of registration zones.
Public property | ActiveSamplePage | Returns the currently selected sample page.
Public property | ActiveSeparationZone | Returns the currently selected separation zone.
Public property | ActiveTabPanel | Returns the tab displayed in the Definitions panel.
Public property | BatchClasses | Returns collection of batch classes.
Public property | DisableFieldEvents | Disable sending field change events from the current custom administration panel.
Public property | DocumentClasses | Returns collection of document classes.
Public property | FieldTypes | Returns collection of field types.
Public property | FolderClasses | Returns collection of system-wide folder classes.
Public property | Groups | Collection of available groups.
Public property | IsUserTrackingEnabled | Indicates if user tracking is enabled for Tungsten Capture system
Public property | ModuleID | The Module ID is a unique identifier for the corresponding custom module.
Public property | Queues | Returns collection of available queues (modules).
Public property | RecognitionProfs | Returns collection of recognition profiles.
Public property | RemoteSiteProfileNames | Collection of Remote site profile names.
Public property | RemoteSites | Collection of available remote sites.
Public property | SepAndFormIDProfs | Returns collection of Separation and Form ID profiles.
Public property | ServicePackVersion | Returns currently installed service pack.
Public property | Theme | Gets the current theme that is being used in Tungsten Capture system.
Public property | Users | Collection of available users.
Top
Remarks

The AdminApplication object also exposes a number of properties, allowing the OCX to examine the current batch class, current document class, etc. All of these properties are read-only. If the requested object is the selected node, or a parent of the selected node, that object is returned. Otherwise, nothing is returned.

Although they have the same name, this AdminApplication object is not the same as the Application object in the Kofax Capture Module .NET Type Library API. This is True for other objects, properties, or methods in this API that may have the same name as an equivalent item in the Tungsten Capture Module .NET Type Library API.

The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication Constructor

AdminApplication Constructor

Initializes a new instance of the Kofax.Capture.AdminModule.InteropServices.AdminApplication class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public AdminApplication()
Public Sub New
Remarks
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication Methods

AdminApplication Methods

The AdminApplication type exposes the following members.

Methods
 | Name | Description
Public method | AddMenu | Adds a menu to Administration's main menu bar.
Public method | AddMenuEx | Adds a menu to the application.
Public method | CreateBatchClass | Adds the batch class.
Public method | CreateDocumentClass | Adds the document class.
Public method | CreateFieldType | Creates a new field type. The data type is VARCHAR with a length of 254 characters.
Public method | CreateFolderClass | Adds the folder class.
Public method | CustomDataFolder | Returns a global custom data path based on the provided module ID.
Public method | DeleteBatchClass | Deletes the specified batch class.
Public method | DeleteDocumentClass | Deletes the specified document class.
Public method | DeleteFieldType | Deletes the specified field type.
Public method | DeleteFolderClass | Deletes the folder class.
Public method | DisableExportEvents | Disable/Enable the export events sending to custom administration panels when exporting a batch class.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | EnableMenu | Enables or disables (grays) a menu.
Public method | Equals | (Inherited from Object.)
Public method | ExportBatchClasses | Export batch classes to a CAB file.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ImportBatchClasses | Imports batch classes from a CAB file and preserves the KTM project assignment if it exists.
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | SelectMenuItem | Selects a menu item.
Public method | ShowMenu | Shows or hides a menu.
Public method | ShowWindow | Shows or hides a panel.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.AddMenu Method

AdminApplicationAddMenu Method

Adds a menu to Administration's main menu bar.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool AddMenu(
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = ""
)
Public Function AddMenu (
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = ""
) As Boolean

Parameters

strEventText
Type: SystemString
Sets the internal name of the menu; it will be the value of Argument for a MenuClicked event.
strMenuText
Type: SystemString
The display text for the menu item.
strMenuLocation
Type: SystemString

Specifies where the menu will appear. It can be: MenuBar (add to frame menu)

The remaining values add the item to the context menu for a specific node type:

  • BatchClass
  • DocumentClass
  • FieldType
  • FormIdZone
  • FormType
  • IndexGroupZone
  • IndexGroupZoneCollection
  • IndexZone
  • IndexZoneCollection
  • PageLevelBarcode
  • PageLevelBarcodeCollection
  • RegistrationZone
  • RegistrationZoneCollection
  • SamplePage
  • SeparationZone
strMenuBarText (Optional)
Type: SystemString

Return Value

Type: Boolean
Boolean - True, menu added otherwise False.

Implements

IAdminApplicationAddMenu(String, String, String, String)
Remarks
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.AddMenuEx Method

AdminApplicationAddMenuEx Method

Adds a menu to the application.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool AddMenuEx(
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = "",
    bool bLarge = false,
    string strIconPath = "",
    string strGroupName = ""
)
Public Function AddMenuEx (
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = "",
    Optional bLarge As Boolean = false,
    Optional strIconPath As String = "",
    Optional strGroupName As String = ""
) As Boolean

Parameters

strEventText
Type: SystemString
Returned to the OCX when the menu is selected.
strMenuText
Type: SystemString
Text displayed in the menu item.
strMenuLocation
Type: SystemString

Location for the menu to appear.

The locations supported are as follows:

VB
Copy
' Declares an array of 4 strings elements
Dim m_MenuLocationKeys(3) As String ' Index can vary from 0 to 3
m_MenuLocationKeys(0) = "MenuBar"
m_MenuLocationKeys(1) = "Batch"
m_MenuLocationKeys(2) = "Document"
m_MenuLocationKeys(3) ="Page"
strMenuBarText (Optional)
Type: SystemString
The text displayed on the main frame. Only required if the location is "MenuBar".
bLarge (Optional)
Type: SystemBoolean
A large button or small one.
strIconPath (Optional)
Type: SystemString
The path to the icon file.
strGroupName (Optional)
Type: SystemString
The specific group for menu items.

Return Value

Type: Boolean
Boolean - True, menu added, otherwise False, no more resources.

Implements

IAdminApplicationAddMenuEx(String, String, String, String, Boolean, String, String)
Remarks
This method can only be used with OCX.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.CreateBatchClass Method

AdminApplicationCreateBatchClass Method

Adds the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void CreateBatchClass(
    string strName
)
Public Sub CreateBatchClass (
    strName As String
)

Parameters

strName
Type: SystemString
The name of the new batch class.

Implements

IAdminApplicationCreateBatchClass(String)
Remarks
The batch class has identical default settings to a batch class created interactively.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.CreateDocumentClass Method

AdminApplicationCreateDocumentClass Method

Adds the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void CreateDocumentClass(
    string strName
)
Public Sub CreateDocumentClass (
    strName As String
)

Parameters

strName
Type: SystemString
The name of the new document class.

Implements

IAdminApplicationCreateDocumentClass(String)
Remarks
The document class is created as not being attached to a batch class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.CreateFieldType Method

AdminApplicationCreateFieldType Method

Creates a new field type. The data type is VARCHAR with a length of 254 characters.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void CreateFieldType(
    string strName
)
Public Sub CreateFieldType (
    strName As String
)

Parameters

strName
Type: SystemString
The name of the new field type.

Implements

IAdminApplicationCreateFieldType(String)
Remarks

Errors:

(KfxApiErrBadParameterRange) if strName is "(TABLE)" (or localized equivalent). The comparison is case-insensitive.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.CreateFolderClass Method

AdminApplicationCreateFolderClass Method

Adds the folder class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void CreateFolderClass(
    string strName
)
Public Sub CreateFolderClass (
    strName As String
)

Parameters

strName
Type: SystemString
The name of the new folder class.

Implements

IAdminApplicationCreateFolderClass(String)
Remarks
The folder class has identical default settings to a folder class created interactively.

This function throws:

(KfxApiErrDuplicateObject) on a duplicate folder class name.

(KfxApiErrBadParameterRange) on an illegal folder class name.

(KfxApiErrAppIsBusy) if the application is in the middle of a user event.

See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.CustomDataFolder Method

AdminApplicationCustomDataFolder Method

Returns a global custom data path based on the provided module ID.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string CustomDataFolder(
    ref string strModuleID
)
Public Function CustomDataFolder (
    ByRef strModuleID As String
) As String

Parameters

strModuleID
Type: SystemString
The subfolder to be used as a custom data storage folder.

Return Value

Type: String
String

Implements

IAdminApplicationCustomDataFolder(String)
Remarks
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.DeleteBatchClass Method

AdminApplicationDeleteBatchClass Method

Deletes the specified batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteBatchClass(
    ref IBatchClass oBatchClass
)
Public Sub DeleteBatchClass (
    ByRef oBatchClass As IBatchClass
)

Parameters

oBatchClass
Type: Kofax.Capture.AdminModule.InteropServicesIBatchClass
The batch class to delete.

Implements

IAdminApplicationDeleteBatchClass(IBatchClass)
Remarks
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.DeleteDocumentClass Method

AdminApplicationDeleteDocumentClass Method

Deletes the specified document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteDocumentClass(
    ref IDocumentClass oDocumentClass
)
Public Sub DeleteDocumentClass (
    ByRef oDocumentClass As IDocumentClass
)

Parameters

oDocumentClass
Type: Kofax.Capture.AdminModule.InteropServicesIDocumentClass
The document class to delete.

Implements

IAdminApplicationDeleteDocumentClass(IDocumentClass)
Remarks
Delete a document class including any sub-objects.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.DeleteFieldType Method

AdminApplicationDeleteFieldType Method

Deletes the specified field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteFieldType(
    ref IFieldType oFieldType
)
Public Sub DeleteFieldType (
    ByRef oFieldType As IFieldType
)

Parameters

oFieldType
Type: Kofax.Capture.AdminModule.InteropServicesIFieldType
The field type to delete.

Implements

IAdminApplicationDeleteFieldType(IFieldType)
Remarks
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.DeleteFolderClass Method

AdminApplicationDeleteFolderClass Method

Deletes the folder class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteFolderClass(
    ref IFolderClass oFolderClass
)
Public Sub DeleteFolderClass (
    ByRef oFolderClass As IFolderClass
)

Parameters

oFolderClass
Type: Kofax.Capture.AdminModule.InteropServicesIFolderClass
The folder class to delete.

Implements

IAdminApplicationDeleteFolderClass(IFolderClass)
Remarks

This function throws:

(KfxApiErrObjectInUse) if the folder class is in use elsewhere.

(KfxApiErrAppIsBusy) if the application is in the middle of a user event.

See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.DisableExportEvents Method

AdminApplicationDisableExportEvents Method

Disable/Enable the export events sending to custom administration panels when exporting a batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DisableExportEvents(
    KfxApiCustomAdminPanel eAdminCustomPanel,
    bool bDisable
)
Public Sub DisableExportEvents (
    eAdminCustomPanel As KfxApiCustomAdminPanel,
    bDisable As Boolean
)

Parameters

eAdminCustomPanel
Type: Kofax.Capture.AdminModule.InteropServicesKfxApiCustomAdminPanel
The administration panel where the export events will be disabled/enabled sending to
bDisable
Type: SystemBoolean
Disable/Enable sending export events.

Implements

IAdminApplicationDisableExportEvents(KfxApiCustomAdminPanel, Boolean)
Remarks
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.Dispose Method

AdminApplicationDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.EnableMenu Method

AdminApplicationEnableMenu Method

Enables or disables (grays) a menu.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void EnableMenu(
    KfxMenuEnable eState,
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = ""
)
Public Sub EnableMenu (
    eState As KfxMenuEnable,
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = ""
)

Parameters

eState
Type: Kofax.Capture.AdminModule.InteropServicesKfxMenuEnable

The next four parameters specify the menu to show/hide, and should match the values passed to the AddMenu method (if that was how the menu was created)

strEventText
Type: SystemString
The internal name of the menu item.
strMenuText
Type: SystemString
The display name of the menu item.
strMenuLocation
Type: SystemString
Specifies the location of the menu (see AddMenu).
strMenuBarText (Optional)
Type: SystemString
The main frame menu the item is under.

Implements

IAdminApplicationEnableMenu(KfxMenuEnable, String, String, String, String)
Remarks
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ExportBatchClasses Method

AdminApplicationExportBatchClasses Method

Export batch classes to a CAB file.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void ExportBatchClasses(
    IKfxCollection oBatchClasses,
    bool bExportUserProfiles,
    bool bExportKCNSProfiles,
    string strCabFile,
    bool bShowProgressDialog
)
Public Sub ExportBatchClasses (
    oBatchClasses As IKfxCollection,
    bExportUserProfiles As Boolean,
    bExportKCNSProfiles As Boolean,
    strCabFile As String,
    bShowProgressDialog As Boolean
)

Parameters

oBatchClasses
Type: IKfxCollection
List of batch class names to be exported.
bExportUserProfiles
Type: SystemBoolean
True to export user profiles.
bExportKCNSProfiles
Type: SystemBoolean
True to export TCNS profiles.
strCabFile
Type: SystemString
Path to the CAB file.
bShowProgressDialog
Type: SystemBoolean
True to show the progress dialog or False to hide it.

Implements

IAdminApplicationExportBatchClasses(IKfxCollection, Boolean, Boolean, String, Boolean)
Remarks
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ImportBatchClasses Method

AdminApplicationImportBatchClasses Method

Imports batch classes from a CAB file and preserves the KTM project assignment if it exists.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void ImportBatchClasses(
    string strCabFile,
    IKfxCollection oBatchClasses,
    KfxApiTransferMode eTransferMode,
    bool bImportAssignments,
    bool bImportUserProfiles,
    KfxApiKCNSProfilesImportMode eKCNSProfilesImportMode,
    bool bShowProgressDialog
)
Public Sub ImportBatchClasses (
    strCabFile As String,
    oBatchClasses As IKfxCollection,
    eTransferMode As KfxApiTransferMode,
    bImportAssignments As Boolean,
    bImportUserProfiles As Boolean,
    eKCNSProfilesImportMode As KfxApiKCNSProfilesImportMode,
    bShowProgressDialog As Boolean
)

Parameters

strCabFile
Type: SystemString
Path to the cab file.
oBatchClasses
Type: IKfxCollection
List of batch class names to be imported. Empty if import all.
eTransferMode
Type: Kofax.Capture.AdminModule.InteropServicesKfxApiTransferMode
The trasfer mode.
bImportAssignments
Type: SystemBoolean
True to import users/groups assignment, or False to skip import users/groups assignment.
bImportUserProfiles
Type: SystemBoolean
True to import user profiles or False to skip import user profile.
eKCNSProfilesImportMode
Type: Kofax.Capture.AdminModule.InteropServicesKfxApiKCNSProfilesImportMode
KCNS transfer mode.
bShowProgressDialog
Type: SystemBoolean
True to show the progress dialog or False to hide it.

Implements

IAdminApplicationImportBatchClasses(String, IKfxCollection, KfxApiTransferMode, Boolean, Boolean, KfxApiKCNSProfilesImportMode, Boolean)
Remarks
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.LogError Method

AdminApplicationLogError Method

Logs an error to the Tungsten Capture error log.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void LogError(
    int Err1,
    int Err2,
    int Err3,
    string ErrorMessage,
    string CodeModule,
    int LineNumber
)
Public Sub LogError (
    Err1 As Integer,
    Err2 As Integer,
    Err3 As Integer,
    ErrorMessage As String,
    CodeModule As String,
    LineNumber As Integer
)

Parameters

Err1
Type: SystemInt32
The primary error code.
Err2
Type: SystemInt32
Subcode.
Err3
Type: SystemInt32
Subcode.
ErrorMessage
Type: SystemString
The string message.
CodeModule
Type: SystemString
The source code module where the problem occurred.
LineNumber
Type: SystemInt32
The line number within the source where the error occurred.

Implements

IAdminApplicationLogError(Int32, Int32, Int32, String, String, Int32)
Remarks
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.SelectMenuItem Method

AdminApplicationSelectMenuItem Method

Selects a menu item.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SelectMenuItem(
    int lResourceID,
    bool bSendImmediate = false
)
Public Function SelectMenuItem (
    lResourceID As Integer,
    Optional bSendImmediate As Boolean = false
) As Boolean

Parameters

lResourceID
Type: SystemInt32
The menu item from the enumeration KfxAdminMenuItems.
bSendImmediate (Optional)
Type: SystemBoolean
When True, internally calls the Windows SendMessage API. False calls the Windows PostMessage API. Refer to your Microsoft documentation for more information.

Return Value

Type: Boolean
Boolean - Returns False if the menu could not be selected.

Implements

IAdminApplicationSelectMenuItem(Int32, Boolean)
Remarks
Flase will be returned in the following cases.
  • The application is currently processing an event SendMessage will return False
  • If the menu item is disabled
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ShowMenu Method

AdminApplicationShowMenu Method

Shows or hides a menu.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void ShowMenu(
    KfxShowMenu eState,
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = ""
)
Public Sub ShowMenu (
    eState As KfxShowMenu,
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = ""
)

Parameters

eState
Type: Kofax.Capture.AdminModule.InteropServicesKfxShowMenu
If KfxMenuShow, the specified menu will be shown. If KfxMenuHide, the specified menu will be hidden.

The last four parameters specify the menu to show/hide, and should match the values passed to the AddMenu method (if that was how the menu was created).
strEventText
Type: SystemString
The internal name of the menu item.
strMenuText
Type: SystemString
The display name of the menu item.
strMenuLocation
Type: SystemString
Specifies the location of the menu (AddMenu(String, String, String, String)).
strMenuBarText (Optional)
Type: SystemString
The main frame menu the item is under.

Implements

IAdminApplicationShowMenu(KfxShowMenu, String, String, String, String)
Remarks
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ShowWindow Method

AdminApplicationShowWindow Method

Shows or hides a panel.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool ShowWindow(
    bool Show
)
Public Function ShowWindow (
    Show As Boolean
) As Boolean

Parameters

Show
Type: SystemBoolean
IfTrue (non-zero), the panel is shown. If False (zero) the panel is hidden.

Return Value

Type: Boolean
Boolean

Implements

IAdminApplicationShowWindow(Boolean)
Remarks
A return value of True (success) indicates completion of the function. If the panel is already in the requested state, the return value will be False.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication Properties

AdminApplication Properties

The AdminApplication type exposes the following members.

Properties
 | Name | Description
Public property | ActiveBatchClass | Returns the currently selected batch class.
Public property | ActiveDocumentClass | Returns the currently selected document class.
Public property | ActiveFieldType | Returns the currently selected field type.
Public property | ActiveFolderClass | Returns the currently active folder class or nothing.
Public property | ActiveFormIdZone | Returns the currently selected form ID zone.
Public property | ActiveFormIdZoneColl | Returns collection object for Form ID Zones.
Public property | ActiveFormType | Returns the currently selected form type.
Public property | ActiveIndexGroupZone | Returns the currently selected index group zone.
Public property | ActiveIndexGrpMemZone | Returns the currently selected group member zone.
Public property | ActiveIndexZone | Returns the currently selected index zone.
Public property | ActiveIndexZoneColl | Returns the currently selected collection of index zones.
Public property | ActiveObjectType | Returns the type of the currently selected node or nothing.
Public property | ActivePageLevelBarcode | Returns the currently selected page level bar code.
Public property | ActivePageLevelBarcodeColl | Returns the currently selected collection of page level bar codes.
Public property | ActiveRegistrationZone | Returns the currently selected registration zone.
Public property | ActiveRegZoneColl | Returns the currently selected collection of registration zones.
Public property | ActiveSamplePage | Returns the currently selected sample page.
Public property | ActiveSeparationZone | Returns the currently selected separation zone.
Public property | ActiveTabPanel | Returns the tab displayed in the Definitions panel.
Public property | BatchClasses | Returns collection of batch classes.
Public property | DisableFieldEvents | Disable sending field change events from the current custom administration panel.
Public property | DocumentClasses | Returns collection of document classes.
Public property | FieldTypes | Returns collection of field types.
Public property | FolderClasses | Returns collection of system-wide folder classes.
Public property | Groups | Collection of available groups.
Public property | IsUserTrackingEnabled | Indicates if user tracking is enabled for Tungsten Capture system
Public property | ModuleID | The Module ID is a unique identifier for the corresponding custom module.
Public property | Queues | Returns collection of available queues (modules).
Public property | RecognitionProfs | Returns collection of recognition profiles.
Public property | RemoteSiteProfileNames | Collection of Remote site profile names.
Public property | RemoteSites | Collection of available remote sites.
Public property | SepAndFormIDProfs | Returns collection of Separation and Form ID profiles.
Public property | ServicePackVersion | Returns currently installed service pack.
Public property | Theme | Gets the current theme that is being used in Tungsten Capture system.
Public property | Users | Collection of available users.
Top
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveBatchClass Property

AdminApplicationActiveBatchClass Property

Returns the currently selected batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchClass ActiveBatchClass { get; }
Public ReadOnly Property ActiveBatchClass As IBatchClass
    Get

Property Value

Type: IBatchClass
The currently active batch class or nothing.

Return Value

Type: IBatchClass
IBatchClass

Implements

IAdminApplicationActiveBatchClass
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveDocumentClass Property

AdminApplicationActiveDocumentClass Property

Returns the currently selected document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocumentClass ActiveDocumentClass { get; }
Public ReadOnly Property ActiveDocumentClass As IDocumentClass
    Get

Property Value

Type: IDocumentClass
The currently active document class or nothing.

Return Value

Type: IDocumentClass
IDocumentClass

Implements

IAdminApplicationActiveDocumentClass
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveFieldType Property

AdminApplicationActiveFieldType Property

Returns the currently selected field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFieldType ActiveFieldType { get; }
Public ReadOnly Property ActiveFieldType As IFieldType
    Get

Property Value

Type: IFieldType

Return Value

Type: IFieldType
IFieldType

Implements

IAdminApplicationActiveFieldType
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveFolderClass Property

AdminApplicationActiveFolderClass Property

Returns the currently active folder class or nothing.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolderClass ActiveFolderClass { get; }
Public ReadOnly Property ActiveFolderClass As IFolderClass
    Get

Property Value

Type: IFolderClass
The currently active folder class or nothing.

Return Value

Type: IFolderClass
IFolderClass

Implements

IAdminApplicationActiveFolderClass
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveFormIdZone Property

AdminApplicationActiveFormIdZone Property

Returns the currently selected form ID zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFormIdZone ActiveFormIdZone { get; }
Public ReadOnly Property ActiveFormIdZone As IFormIdZone
    Get

Property Value

Type: IFormIdZone

Return Value

Type: IFormIdZone
IFormIdZone

Implements

IAdminApplicationActiveFormIdZone
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveFormIdZoneColl Property

AdminApplicationActiveFormIdZoneColl Property

Returns collection object for Form ID Zones.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFormIdZoneColl ActiveFormIdZoneColl { get; }
Public ReadOnly Property ActiveFormIdZoneColl As IFormIdZoneColl
    Get

Property Value

Type: IFormIdZoneColl

Return Value

Type: IFormIdZoneColl
IFormIdZoneColl

Implements

IAdminApplicationActiveFormIdZoneColl
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveFormType Property

AdminApplicationActiveFormType Property

Returns the currently selected form type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFormType ActiveFormType { get; }
Public ReadOnly Property ActiveFormType As IFormType
    Get

Property Value

Type: IFormType

Return Value

Type: IFormType
IFormType

Implements

IAdminApplicationActiveFormType
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveIndexGroupZone Property

AdminApplicationActiveIndexGroupZone Property

Returns the currently selected index group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexGroupZone ActiveIndexGroupZone { get; }
Public ReadOnly Property ActiveIndexGroupZone As IIndexGroupZone
    Get

Property Value

Type: IIndexGroupZone

Return Value

Type: IIndexGroupZone
IIndexGroupZone

Implements

IAdminApplicationActiveIndexGroupZone
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveIndexGrpMemZone Property

AdminApplicationActiveIndexGrpMemZone Property

Returns the currently selected group member zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexGrpMemZone ActiveIndexGrpMemZone { get; }
Public ReadOnly Property ActiveIndexGrpMemZone As IIndexGrpMemZone
    Get

Property Value

Type: IIndexGrpMemZone

Return Value

Type: IIndexGrpMemZone
IIndexGrpMemZone

Implements

IAdminApplicationActiveIndexGrpMemZone
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveIndexZone Property

AdminApplicationActiveIndexZone Property

Returns the currently selected index zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexZone ActiveIndexZone { get; }
Public ReadOnly Property ActiveIndexZone As IIndexZone
    Get

Property Value

Type: IIndexZone

Return Value

Type: IIndexZone
IIndexZone

Implements

IAdminApplicationActiveIndexZone
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveIndexZoneColl Property

AdminApplicationActiveIndexZoneColl Property

Returns the currently selected collection of index zones.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexZones ActiveIndexZoneColl { get; }
Public ReadOnly Property ActiveIndexZoneColl As IIndexZones
    Get

Property Value

Type: IIndexZones

Return Value

Type: IIndexZones
IIndexZones

Implements

IAdminApplicationActiveIndexZoneColl
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveObjectType Property

AdminApplicationActiveObjectType Property

Returns the type of the currently selected node or nothing.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public KfxApiAdminObjectType ActiveObjectType { get; }
Public ReadOnly Property ActiveObjectType As KfxApiAdminObjectType
    Get

Property Value

Type: KfxApiAdminObjectType

Return Value

Type: KfxApiAdminObjectType
KfxApiAdminObjectType

Implements

IAdminApplicationActiveObjectType
Remarks

If no node is selected, Nothing is returned. Otherwise, one of the following is returned:

  • KfxAdminObjectTypeDocumentClass
  • KfxAdminObjectTypeFieldType
  • KfxAdminObjectTypeFormIdZone
  • KfxAdminObjectTypeFormType
  • KfxAdminObjectTypeIndexGroupMemberZone
  • KfxAdminObjectTypeIndexGroupZone
  • KfxAdminObjectTypeIndexZone
  • KfxAdminObjectTypeIndexZones
  • KfxAdminObjectTypePageLevelBarcode
  • KfxAdminObjectTypePageLevelBarcodes
  • KfxAdminObjectTypeRegistrationZone
  • KfxAdminObjectTypeRegistrationZones
  • KfxAdminObjectTypeSamplePage
  • KfxAdminObjectTypeSeparationZone

See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActivePageLevelBarcode Property

AdminApplicationActivePageLevelBarcode Property

Returns the currently selected page level bar code.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPageLevelBarcode ActivePageLevelBarcode { get; }
Public ReadOnly Property ActivePageLevelBarcode As IPageLevelBarcode
    Get

Property Value

Type: IPageLevelBarcode

Return Value

Type: IPageLevelBarcode
IPageLevelBarcode

Implements

IAdminApplicationActivePageLevelBarcode
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActivePageLevelBarcodeColl Property

AdminApplicationActivePageLevelBarcodeColl Property

Returns the currently selected collection of page level bar codes.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPgLvlBarcodeColl ActivePageLevelBarcodeColl { get; }
Public ReadOnly Property ActivePageLevelBarcodeColl As IPgLvlBarcodeColl
    Get

Property Value

Type: IPgLvlBarcodeColl

Return Value

Type: IPgLvlBarcodeColl
IPgLvlBarcodeColl

Implements

IAdminApplicationActivePageLevelBarcodeColl
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveRegistrationZone Property

AdminApplicationActiveRegistrationZone Property

Returns the currently selected registration zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRegistrationZone ActiveRegistrationZone { get; }
Public ReadOnly Property ActiveRegistrationZone As IRegistrationZone
    Get

Property Value

Type: IRegistrationZone

Return Value

Type: IRegistrationZone
IRegistrationZone

Implements

IAdminApplicationActiveRegistrationZone
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveRegZoneColl Property

AdminApplicationActiveRegZoneColl Property

Returns the currently selected collection of registration zones.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRegZoneColl ActiveRegZoneColl { get; }
Public ReadOnly Property ActiveRegZoneColl As IRegZoneColl
    Get

Property Value

Type: IRegZoneColl

Return Value

Type: IRegZoneColl
IRegZoneColl

Implements

IAdminApplicationActiveRegZoneColl
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveSamplePage Property

AdminApplicationActiveSamplePage Property

Returns the currently selected sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ISamplePage ActiveSamplePage { get; }
Public ReadOnly Property ActiveSamplePage As ISamplePage
    Get

Property Value

Type: ISamplePage

Return Value

Type: ISamplePage
ISamplePage

Implements

IAdminApplicationActiveSamplePage
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveSeparationZone Property

AdminApplicationActiveSeparationZone Property

Returns the currently selected separation zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ISeparationZone ActiveSeparationZone { get; }
Public ReadOnly Property ActiveSeparationZone As ISeparationZone
    Get

Property Value

Type: ISeparationZone

Return Value

Type: ISeparationZone
ISeparationZone

Implements

IAdminApplicationActiveSeparationZone
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ActiveTabPanel Property

AdminApplicationActiveTabPanel Property

Returns the tab displayed in the Definitions panel.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public KfxApiAdminTabPanel ActiveTabPanel { get; }
Public ReadOnly Property ActiveTabPanel As KfxApiAdminTabPanel
    Get

Property Value

Type: KfxApiAdminTabPanel

Return Value

Type: KfxApiAdminTabPanel
KfxApiAdminTabPanel

Implements

IAdminApplicationActiveTabPanel
Remarks

One of the following is returned:

  • KfxAdminPanelBatchClass
  • KfxAdminPanelDocumentClass
  • KfxAdminPanelFieldType

See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.BatchClasses Property

AdminApplicationBatchClasses Property

Returns collection of batch classes.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchClasses BatchClasses { get; }
Public ReadOnly Property BatchClasses As IBatchClasses
    Get

Property Value

Type: IBatchClasses

Return Value

Type: IBatchClasses
IBatchClasses

Implements

IAdminApplicationBatchClasses
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.DisableFieldEvents Property

AdminApplicationDisableFieldEvents Property

Disable sending field change events from the current custom administration panel.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool DisableFieldEvents { get; set; }
Public Property DisableFieldEvents As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Value of DisableFieldEvents.

Implements

IAdminApplicationDisableFieldEvents
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.DocumentClasses Property

AdminApplicationDocumentClasses Property

Returns collection of document classes.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocumentClasses DocumentClasses { get; }
Public ReadOnly Property DocumentClasses As IDocumentClasses
    Get

Property Value

Type: IDocumentClasses

Return Value

Type: IDocumentClasses
IDocumentClasses

Implements

IAdminApplicationDocumentClasses
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.FieldTypes Property

AdminApplicationFieldTypes Property

Returns collection of field types.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFieldTypes FieldTypes { get; }
Public ReadOnly Property FieldTypes As IFieldTypes
    Get

Property Value

Type: IFieldTypes

Return Value

Type: IFieldTypes
IFieldTypes

Implements

IAdminApplicationFieldTypes
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.FolderClasses Property

AdminApplicationFolderClasses Property

Returns collection of system-wide folder classes.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolderClasses FolderClasses { get; }
Public ReadOnly Property FolderClasses As IFolderClasses
    Get

Property Value

Type: IFolderClasses

Return Value

Type: IFolderClasses
IFolderClasses

Implements

IAdminApplicationFolderClasses
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.Groups Property

AdminApplicationGroups Property

Collection of available groups.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IGroups Groups { get; }
Public ReadOnly Property Groups As IGroups
    Get

Property Value

Type: IGroups

Return Value

Type: IGroups
IGroups

Implements

IAdminApplicationGroups
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.IsUserTrackingEnabled Property

AdminApplicationIsUserTrackingEnabled Property
Indicates if user tracking is enabled for Tungsten Capture system

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool IsUserTrackingEnabled { get; }
Public ReadOnly Property IsUserTrackingEnabled As Boolean
    Get

Return Value

Type: Boolean
Boolean

Implements

IAdminApplicationIsUserTrackingEnabled
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ModuleID Property

AdminApplicationModuleID Property

The Module ID is a unique identifier for the corresponding custom module.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ModuleID { get; }
Public ReadOnly Property ModuleID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IAdminApplicationModuleID
Remarks

Each custom module defines its Module ID in the .aex file.

If this property is used from an OCX that is not bound to a custom module, then the property returns an empty string.

Even though shared OCX instances may share the same code, each one can determine its uniqueness by checking the ModuleID property.

See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.Queues Property

AdminApplicationQueues Property

Returns collection of available queues (modules).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IQueues Queues { get; }
Public ReadOnly Property Queues As IQueues
    Get

Property Value

Type: IQueues

Return Value

Type: IQueues
IQueues

Implements

IAdminApplicationQueues
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.RecognitionProfs Property

AdminApplicationRecognitionProfs Property

Returns collection of recognition profiles.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRecognitionProfs RecognitionProfs { get; }
Public ReadOnly Property RecognitionProfs As IRecognitionProfs
    Get

Property Value

Type: IRecognitionProfs

Return Value

Type: IRecognitionProfs
IRecognitionProfs

Implements

IAdminApplicationRecognitionProfs
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.RemoteSiteProfileNames Property

AdminApplicationRemoteSiteProfileNames Property

Collection of Remote site profile names.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IKfxCollection RemoteSiteProfileNames { get; }
Public ReadOnly Property RemoteSiteProfileNames As IKfxCollection
    Get

Property Value

Type: IKfxCollection

Return Value

Type: IKfxCollection
Collection.IKfxCollection

Implements

IAdminApplicationRemoteSiteProfileNames
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.RemoteSites Property

AdminApplicationRemoteSites Property

Collection of available remote sites.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRemoteSites RemoteSites { get; }
Public ReadOnly Property RemoteSites As IRemoteSites
    Get

Property Value

Type: IRemoteSites

Return Value

Type: IRemoteSites
IRemoteSites

Implements

IAdminApplicationRemoteSites
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.SepAndFormIDProfs Property

AdminApplicationSepAndFormIDProfs Property

Returns collection of Separation and Form ID profiles.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ISepAndFormIDProfs SepAndFormIDProfs { get; }
Public ReadOnly Property SepAndFormIDProfs As ISepAndFormIDProfs
    Get

Property Value

Type: ISepAndFormIDProfs

Return Value

Type: ISepAndFormIDProfs
ISepAndFormIDProfs

Implements

IAdminApplicationSepAndFormIDProfs
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.ServicePackVersion Property

AdminApplicationServicePackVersion Property

Returns currently installed service pack.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public short ServicePackVersion { get; }
Public ReadOnly Property ServicePackVersion As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16

Implements

IAdminApplicationServicePackVersion
Remarks
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.Theme Property

AdminApplicationTheme Property

Gets the current theme that is being used in Tungsten Capture system.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ITheme Theme { get; }
Public ReadOnly Property Theme As ITheme
    Get

Property Value

Type: ITheme

Return Value

Type: ITheme
ITheme

Implements

IAdminApplicationTheme
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminApplication.Users Property

AdminApplicationUsers Property

Collection of available users.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IUsers Users { get; }
Public ReadOnly Property Users As IUsers
    Get

Property Value

Type: IUsers

Return Value

Type: IUsers
IUsers

Implements

IAdminApplicationUsers
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

AdminApplication Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminLogin Class

AdminLogin Class

AdminLogin COM implementation class.

Defines a COM object that coordinates logging in and logging out of Tungsten Capture. This is the only object that can be created using New or CreateObject in Visual Basic.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesAdminLogin

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB613-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class AdminLogin : IAdminLogin, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB613-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class AdminLogin
    Implements IAdminLogin, IDisposable

The AdminLogin type exposes the following members.

Constructors
 | Name | Description
Public method | AdminLogin | Initializes a new instance of the Kofax.Capture.AdminModule.InteropServices.AdminLogin class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Login | Starts a session with Tungsten Capture and then sets the ActiveApplication property.
Public method | Logout | Ends the session with Tungsten Capture.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ActiveApplication | Get current admin application object
Public property | RequiresLogin | If True, a UserID and password must be supplied for a Tungsten Capture login.
Public property | SharedUserProfileModel | Gets or sets the shared profile model. If True, the user privileges are shared across all processes on the computer.
Top
Remarks

The COM ProgID is CaptureAdminModule.AdminLogin.

The AdminLogin object is not necessary when using an OCX because the host Tungsten Capture Administration module already manages logging in. Since there is no host Tungsten Capture Administration module in this API, it is necessary to create the AdminLogin object and use it to login and access an Application object.

There is no limit to the number of AdminLogin objects that can be opened on a given computer. However, each AdminLogin uses resources, so the total number of logins that can be supported may vary between different computers.

While one or more AdminLogin objects are active, the user may also run zero or one instances of Tungsten Capture Administration on the same computer concurrently.

Although the AdminLogin object uses some facilities of Tungsten Capture Administration module, the system does not load any user configured OCXs when running the system via the AdminLogin.

Note that the creation of an AdminLogin object may take a second or two because it has to load a large amount of code. Because of this delay, AdminLogin should be placed within an application so that the time lag is not noticeable, or at least minimized.

Your application should create one instance of AdminLogin and keep it through the application life-time. Also, be aware that an AdminLogin object uses several megabytes of virtual memory and some machines may run slowly when it is in use.

See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


AdminLogin Constructor

AdminLogin Constructor

Initializes a new instance of the Kofax.Capture.AdminModule.InteropServices.AdminLogin class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public AdminLogin()
Public Sub New
Remarks
See Also

Reference

AdminLogin Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminLogin Methods

AdminLogin Methods

The AdminLogin type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Login | Starts a session with Tungsten Capture and then sets the ActiveApplication property.
Public method | Logout | Ends the session with Tungsten Capture.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AdminLogin Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminLogin.Dispose Method

AdminLoginDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

AdminLogin Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminLogin.Login Method

AdminLoginLogin Method

Starts a session with Tungsten Capture and then sets the ActiveApplication property.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IAdminApplication Login(
    string UserID,
    string UserPwd
)
Public Function Login (
    UserID As String,
    UserPwd As String
) As IAdminApplication

Parameters

UserID
Type: SystemString
The User ID.
UserPwd
Type: SystemString
The User password.

Return Value

Type: IAdminApplication

Implements

IAdminLoginLogin(String, String)
Remarks

Returns ActiveApplication.

To hinder attempts to determine the password, after a set of three KfxApiErrInvalidLogin errors, the method waits ten seconds before returning the ActiveApplication. If the AdminLogin is already logged in, this method automatically logs out and back in. The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.

See Also

Reference

AdminLogin Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminLogin.Logout Method

AdminLoginLogout Method

Ends the session with Tungsten Capture.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Logout()
Public Sub Logout

Implements

IAdminLoginLogout
Remarks
ActiveApplication is made invalid.
Be sure to call Logout method when your application is terminating.
See Also

Reference

AdminLogin Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminLogin Properties

AdminLogin Properties

The AdminLogin type exposes the following members.

Properties
 | Name | Description
Public property | ActiveApplication | Get current admin application object
Public property | RequiresLogin | If True, a UserID and password must be supplied for a Tungsten Capture login.
Public property | SharedUserProfileModel | Gets or sets the shared profile model. If True, the user privileges are shared across all processes on the computer.
Top
See Also

Reference

AdminLogin Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminLogin.ActiveApplication Property

AdminLoginActiveApplication Property
Get current admin application object

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IAdminApplication ActiveApplication { get; }
Public ReadOnly Property ActiveApplication As IAdminApplication
    Get

Property Value

Type: IAdminApplication

Return Value

Type: IAdminApplication

Implements

IAdminLoginActiveApplication
Remarks
See Also

Reference

AdminLogin Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminLogin.RequiresLogin Property

AdminLoginRequiresLogin Property

If True, a UserID and password must be supplied for a Tungsten Capture login.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool RequiresLogin { get; }
Public ReadOnly Property RequiresLogin As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IAdminLoginRequiresLogin
Remarks

This returns True if user profiles have been enabled in Administration, or if you are using a shared user profile model and some other application is already connected.

Even when this property returns False, the caller must still call the Login method, but it may pass empty strings for the parameters.

See Also

Reference

AdminLogin Class
Kofax.Capture.AdminModule.InteropServices Namespace


AdminLogin.SharedUserProfileModel Property

AdminLoginSharedUserProfileModel Property

Gets or sets the shared profile model. If True, the user privileges are shared across all processes on the computer.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SharedUserProfileModel { get; set; }
Public Property SharedUserProfileModel As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IAdminLoginSharedUserProfileModel
Remarks
Defaults is False. Note that this default is different than the default for interactive Tungsten Capture applications.
See Also

Reference

AdminLogin Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass Class

BatchClass Class

BatchClass COM implementation class.

Defines information about a batch class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesBatchClass

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638CFFF6-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class BatchClass : IBatchClass, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638CFFF6-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class BatchClass
    Implements IBatchClass, IDisposable

The BatchClass type exposes the following members.

Methods
 | Name | Description
Public method | AssignGroups | Assigns the specified users to the batch class.
Public method | AssignQueue | Assigns the specified queue to the batch class.
Public method | AssignQueueDefaultOrder | Assigns the specified queue to the batch class.
Public method | AssignRemoteSiteProfile | Assigns the specified groups to the batch class.
Public method | AssignUsers | Assigns the specified users to the batch class.
Public method | CreateBatchField | Creates a new batch field associated with the batch class.
Public method | CustomDataFolder | Returns a custom data path based on the batch class and the provided module ID.
Public method | DeleteBatchField | Deletes an existing batch field.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | ExportClassDefinition | An XML file representing the current batch class definition will be written to the file strFileName.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetReleaseSetupData | Returns a ReleaseSetupData object based on document class name and export connector name.
Public method | GetType | (Inherited from Object.)
Public method | InsertDocumentClass | Inserts an existing document class into the batch class.
Public method | InsertFolderClass | Inserts an existing folder class into the batch class.
Public method | IsInvokeWFAOnBatchDelete | Returns true if strWorkflowAgentId was added to the batch class and the WFAOnBatchDelete of that WFA is true. Otherwise it return false.
Public method | Publish | Attempts to publish the batch class.
Public method | RemoveAssignedQueue | Removes the assigned queue from the batch class.
Public method | RemoveDocumentClass | Removes an existing document class from the batch class.
Public method | RemoveFolderClass | Removes an existing folder class from the batch class.
Public method | ToString | (Inherited from Object.)
Public method | UnassignGroups | Assigns the specified users to the batch class.
Public method | UnassignRemoteSiteProfile | Unassigns the specified groups to the batch class.
Public method | UnassignUsers | Assigns the specified users to the batch class.
Public method | UnPublish | Disables the batch class.
Top
Properties
 | Name | Description
Public property | AssignedGroups | The collection of groups assigned to this batch class.
Public property | AssignedQueues | The collection of queues in the work flow for this batch class.
Public property | AssignedRemoteSiteProfiles | The collection of remote site profiles assigned to this batch class.
Public property | AssignedUsers | The collection of users assigned to this batch class.
Public property | BatchFields | The batch fields assigned to this batch class.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Batch class description.
Public property | DocumentClasses | Collection of document classes that are assigned to the batch class.
Public property | FolderClasses | Collection of the folder classes that are assigned to the batch class.
Public property | ImageFolder | The image folder used to store temporary images; not to be confused with the image folder used to export images.
Public property | Name | Batch class name.
Public property | NonImageFileSupport | True if non-image files are supported for this batch class.
Public property | Priority | The default priority for batches created from this batch class.
Public property | PublishErrors | Collection of strings, one for each error from the previous Publish operation.
Public property | PublishStatus | Returns True if the previous Publish operation was successful.
Public property | PublishWarnings | Collection of strings, one for each warning from the previous Publish operation.
Public property | QueueProperties | Collection of batch class custom properties for this custom extension.
Public property | SepAndFormIDProf | The separation and form identification profile for this batch class.
Public property | SingleDocProcessing | If True, an individual batch is created for each new document.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass Methods

BatchClass Methods

The BatchClass type exposes the following members.

Methods
 | Name | Description
Public method | AssignGroups | Assigns the specified users to the batch class.
Public method | AssignQueue | Assigns the specified queue to the batch class.
Public method | AssignQueueDefaultOrder | Assigns the specified queue to the batch class.
Public method | AssignRemoteSiteProfile | Assigns the specified groups to the batch class.
Public method | AssignUsers | Assigns the specified users to the batch class.
Public method | CreateBatchField | Creates a new batch field associated with the batch class.
Public method | CustomDataFolder | Returns a custom data path based on the batch class and the provided module ID.
Public method | DeleteBatchField | Deletes an existing batch field.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | ExportClassDefinition | An XML file representing the current batch class definition will be written to the file strFileName.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetReleaseSetupData | Returns a ReleaseSetupData object based on document class name and export connector name.
Public method | GetType | (Inherited from Object.)
Public method | InsertDocumentClass | Inserts an existing document class into the batch class.
Public method | InsertFolderClass | Inserts an existing folder class into the batch class.
Public method | IsInvokeWFAOnBatchDelete | Returns true if strWorkflowAgentId was added to the batch class and the WFAOnBatchDelete of that WFA is true. Otherwise it return false.
Public method | Publish | Attempts to publish the batch class.
Public method | RemoveAssignedQueue | Removes the assigned queue from the batch class.
Public method | RemoveDocumentClass | Removes an existing document class from the batch class.
Public method | RemoveFolderClass | Removes an existing folder class from the batch class.
Public method | ToString | (Inherited from Object.)
Public method | UnassignGroups | Assigns the specified users to the batch class.
Public method | UnassignRemoteSiteProfile | Unassigns the specified groups to the batch class.
Public method | UnassignUsers | Assigns the specified users to the batch class.
Public method | UnPublish | Disables the batch class.
Top
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.AssignGroups Method

BatchClassAssignGroups Method

Assigns the specified users to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void AssignGroups(
    IKfxCollection oNames
)
Public Sub AssignGroups (
    oNames As IKfxCollection
)

Parameters

oNames
Type: IKfxCollection
List of user names would be assigned to batch class. If oNames is empty or nothing, all available users will be assigned to batch class.

Implements

IBatchClassAssignGroups(IKfxCollection)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.AssignQueue Method

BatchClassAssignQueue Method

Assigns the specified queue to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void AssignQueue(
    ref IQueue oQueue,
    ref IQueue oPrevQueue
)
Public Sub AssignQueue (
    ByRef oQueue As IQueue,
    ByRef oPrevQueue As IQueue
)

Parameters

oQueue
Type: Kofax.Capture.AdminModule.InteropServicesIQueue
The queue to insert.
oPrevQueue
Type: Kofax.Capture.AdminModule.InteropServicesIQueue
The new queue is inserted after oPrevQueue. If oPrevQueue is Nothing, then it is added as the first item in the workflow.

Implements

IBatchClassAssignQueue(IQueue, IQueue)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.AssignQueueDefaultOrder Method

BatchClassAssignQueueDefaultOrder Method

Assigns the specified queue to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void AssignQueueDefaultOrder(
    ref IQueue oQueue
)
Public Sub AssignQueueDefaultOrder (
    ByRef oQueue As IQueue
)

Parameters

oQueue
Type: Kofax.Capture.AdminModule.InteropServicesIQueue
The queue to insert.

Implements

IBatchClassAssignQueueDefaultOrder(IQueue)
Remarks
The location in the workflow is the same as the default location when adding interactively.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.AssignRemoteSiteProfile Method

BatchClassAssignRemoteSiteProfile Method

Assigns the specified groups to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void AssignRemoteSiteProfile(
    string strRSProfileName
)
Public Sub AssignRemoteSiteProfile (
    strRSProfileName As String
)

Parameters

strRSProfileName
Type: SystemString

Implements

IBatchClassAssignRemoteSiteProfile(String)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.AssignUsers Method

BatchClassAssignUsers Method

Assigns the specified users to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void AssignUsers(
    IKfxCollection oNames
)
Public Sub AssignUsers (
    oNames As IKfxCollection
)

Parameters

oNames
Type: IKfxCollection
List of user names would be assigned to batch class. If oNames is empty or nothing, all available users will be assigned to batch class.

Implements

IBatchClassAssignUsers(IKfxCollection)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.CreateBatchField Method

BatchClassCreateBatchField Method

Creates a new batch field associated with the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void CreateBatchField(
    ref string strName,
    ref IFieldType oFieldType
)
Public Sub CreateBatchField (
    ByRef strName As String,
    ByRef oFieldType As IFieldType
)

Parameters

strName
Type: SystemString
The name of the new batch field.
oFieldType
Type: Kofax.Capture.AdminModule.InteropServicesIFieldType
The type of the field.

Implements

IBatchClassCreateBatchField(String, IFieldType)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.CustomDataFolder Method

BatchClassCustomDataFolder Method

Returns a custom data path based on the batch class and the provided module ID.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string CustomDataFolder(
    ref string strModuleID
)
Public Function CustomDataFolder (
    ByRef strModuleID As String
) As String

Parameters

strModuleID
Type: SystemString
The subfolder to be used as a custom data storage folder.

Return Value

Type: String
String

Implements

IBatchClassCustomDataFolder(String)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.DeleteBatchField Method

BatchClassDeleteBatchField Method

Deletes an existing batch field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteBatchField(
    ref IBatchField oBatchField
)
Public Sub DeleteBatchField (
    ByRef oBatchField As IBatchField
)

Parameters

oBatchField
Type: Kofax.Capture.AdminModule.InteropServicesIBatchField
The batch field to delete.

Implements

IBatchClassDeleteBatchField(IBatchField)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.Dispose Method

BatchClassDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.ExportClassDefinition Method

BatchClassExportClassDefinition Method

An XML file representing the current batch class definition will be written to the file strFileName.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool ExportClassDefinition(
    string strFileName
)
Public Function ExportClassDefinition (
    strFileName As String
) As Boolean

Parameters

strFileName
Type: SystemString
The full path and file name to the output XML.

Return Value

Type: Boolean
Boolean

Implements

IBatchClassExportClassDefinition(String)
Remarks
This function call may be slow.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.GetReleaseSetupData Method

BatchClassGetReleaseSetupData Method

Returns a ReleaseSetupData object based on document class name and export connector name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IKfxCollection GetReleaseSetupData(
    ref string strDocumentClassName
)
Public Function GetReleaseSetupData (
    ByRef strDocumentClassName As String
) As IKfxCollection

Parameters

strDocumentClassName
Type: SystemString
Document class name.

Return Value

Type: IKfxCollection

Implements

IBatchClassGetReleaseSetupData(String)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.InsertDocumentClass Method

BatchClassInsertDocumentClass Method

Inserts an existing document class into the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void InsertDocumentClass(
    ref IDocumentClass oDocClass
)
Public Sub InsertDocumentClass (
    ByRef oDocClass As IDocumentClass
)

Parameters

oDocClass
Type: Kofax.Capture.AdminModule.InteropServicesIDocumentClass
The document class to insert.

Implements

IBatchClassInsertDocumentClass(IDocumentClass)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.InsertFolderClass Method

BatchClassInsertFolderClass Method

Inserts an existing folder class into the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void InsertFolderClass(
    ref IFolderClass oFolderClass
)
Public Sub InsertFolderClass (
    ByRef oFolderClass As IFolderClass
)

Parameters

oFolderClass
Type: Kofax.Capture.AdminModule.InteropServicesIFolderClass
The folder class to insert.

Implements

IBatchClassInsertFolderClass(IFolderClass)
Remarks

This function throws:

(KfxApiErrAppIsBusy) if the application is in the middle of a user event.

(KfxApiErrDuplicateObject) duplicate folder class.

See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.IsInvokeWFAOnBatchDelete Method

BatchClassIsInvokeWFAOnBatchDelete Method

Returns true if strWorkflowAgentId was added to the batch class and the WFAOnBatchDelete of that WFA is true. Otherwise it return false.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool IsInvokeWFAOnBatchDelete(
    string strWorkflowAgentId
)
Public Function IsInvokeWFAOnBatchDelete (
    strWorkflowAgentId As String
) As Boolean

Parameters

strWorkflowAgentId
Type: SystemString
Id of workflow agent.

Return Value

Type: Boolean

Implements

IBatchClassIsInvokeWFAOnBatchDelete(String)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.Publish Method

BatchClassPublish Method

Attempts to publish the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Publish()
Public Sub Publish

Implements

IBatchClassPublish
Remarks
Information on the results of this operation are available from other properties (PublishErrors, PublishStats, and PublishWarnings).
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.RemoveAssignedQueue Method

BatchClassRemoveAssignedQueue Method

Removes the assigned queue from the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void RemoveAssignedQueue(
    ref IQueue oQueue
)
Public Sub RemoveAssignedQueue (
    ByRef oQueue As IQueue
)

Parameters

oQueue
Type: Kofax.Capture.AdminModule.InteropServicesIQueue
The queue to remove.

Implements

IBatchClassRemoveAssignedQueue(IQueue)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.RemoveDocumentClass Method

BatchClassRemoveDocumentClass Method

Removes an existing document class from the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void RemoveDocumentClass(
    ref IDocumentClass oDocClass
)
Public Sub RemoveDocumentClass (
    ByRef oDocClass As IDocumentClass
)

Parameters

oDocClass
Type: Kofax.Capture.AdminModule.InteropServicesIDocumentClass
The document class to remove.

Implements

IBatchClassRemoveDocumentClass(IDocumentClass)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.RemoveFolderClass Method

BatchClassRemoveFolderClass Method

Removes an existing folder class from the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void RemoveFolderClass(
    ref IFolderClass oFolderClass
)
Public Sub RemoveFolderClass (
    ByRef oFolderClass As IFolderClass
)

Parameters

oFolderClass
Type: Kofax.Capture.AdminModule.InteropServicesIFolderClass
The folder class to remove.

Implements

IBatchClassRemoveFolderClass(IFolderClass)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.UnassignGroups Method

BatchClassUnassignGroups Method

Assigns the specified users to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void UnassignGroups(
    IKfxCollection oNames
)
Public Sub UnassignGroups (
    oNames As IKfxCollection
)

Parameters

oNames
Type: IKfxCollection
List of user names would be assigned to batch class. If oNames is empty or nothing, all available users will be assigned to batch class.

Implements

IBatchClassUnassignGroups(IKfxCollection)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.UnassignRemoteSiteProfile Method

BatchClassUnassignRemoteSiteProfile Method

Unassigns the specified groups to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void UnassignRemoteSiteProfile(
    string strRSProfileName
)
Public Sub UnassignRemoteSiteProfile (
    strRSProfileName As String
)

Parameters

strRSProfileName
Type: SystemString

Implements

IBatchClassUnassignRemoteSiteProfile(String)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.UnassignUsers Method

BatchClassUnassignUsers Method

Assigns the specified users to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void UnassignUsers(
    IKfxCollection oNames
)
Public Sub UnassignUsers (
    oNames As IKfxCollection
)

Parameters

oNames
Type: IKfxCollection
List of user names would be assigned to batch class. If oNames is empty or nothing, all available users will be assigned to batch class.

Implements

IBatchClassUnassignUsers(IKfxCollection)
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.UnPublish Method

BatchClassUnPublish Method

Disables the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void UnPublish()
Public Sub UnPublish

Implements

IBatchClassUnPublish
Remarks
No error if the batch was not already published.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass Properties

BatchClass Properties

The BatchClass type exposes the following members.

Properties
 | Name | Description
Public property | AssignedGroups | The collection of groups assigned to this batch class.
Public property | AssignedQueues | The collection of queues in the work flow for this batch class.
Public property | AssignedRemoteSiteProfiles | The collection of remote site profiles assigned to this batch class.
Public property | AssignedUsers | The collection of users assigned to this batch class.
Public property | BatchFields | The batch fields assigned to this batch class.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Batch class description.
Public property | DocumentClasses | Collection of document classes that are assigned to the batch class.
Public property | FolderClasses | Collection of the folder classes that are assigned to the batch class.
Public property | ImageFolder | The image folder used to store temporary images; not to be confused with the image folder used to export images.
Public property | Name | Batch class name.
Public property | NonImageFileSupport | True if non-image files are supported for this batch class.
Public property | Priority | The default priority for batches created from this batch class.
Public property | PublishErrors | Collection of strings, one for each error from the previous Publish operation.
Public property | PublishStatus | Returns True if the previous Publish operation was successful.
Public property | PublishWarnings | Collection of strings, one for each warning from the previous Publish operation.
Public property | QueueProperties | Collection of batch class custom properties for this custom extension.
Public property | SepAndFormIDProf | The separation and form identification profile for this batch class.
Public property | SingleDocProcessing | If True, an individual batch is created for each new document.
Top
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.AssignedGroups Property

BatchClassAssignedGroups Property

The collection of groups assigned to this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IGroups AssignedGroups { get; }
Public ReadOnly Property AssignedGroups As IGroups
    Get

Property Value

Type: IGroups

Return Value

Type: IGroups
IGroups

Implements

IBatchClassAssignedGroups
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.AssignedQueues Property

BatchClassAssignedQueues Property

The collection of queues in the work flow for this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IQueues AssignedQueues { get; }
Public ReadOnly Property AssignedQueues As IQueues
    Get

Property Value

Type: IQueues

Return Value

Type: IQueues
IQueues

Implements

IBatchClassAssignedQueues
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.AssignedRemoteSiteProfiles Property

BatchClassAssignedRemoteSiteProfiles Property

The collection of remote site profiles assigned to this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IKfxCollection AssignedRemoteSiteProfiles { get; }
Public ReadOnly Property AssignedRemoteSiteProfiles As IKfxCollection
    Get

Property Value

Type: IKfxCollection

Return Value

Type: IKfxCollection
IGroups

Implements

IBatchClassAssignedRemoteSiteProfiles
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.AssignedUsers Property

BatchClassAssignedUsers Property

The collection of users assigned to this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IUsers AssignedUsers { get; }
Public ReadOnly Property AssignedUsers As IUsers
    Get

Property Value

Type: IUsers

Return Value

Type: IUsers
IUsers

Implements

IBatchClassAssignedUsers
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.BatchFields Property

BatchClassBatchFields Property

The batch fields assigned to this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchFields BatchFields { get; }
Public ReadOnly Property BatchFields As IBatchFields
    Get

Property Value

Type: IBatchFields

Return Value

Type: IBatchFields
IBatchFields

Implements

IBatchClassBatchFields
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.CustomStorageString Property

BatchClassCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the batch class.

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchClassCustomStorageStringString
Remarks
Custom Storage strings are custom text strings that are bound to a specific batch class. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.Description Property

BatchClassDescription Property

Batch class description.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchClassDescription
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.DocumentClasses Property

BatchClassDocumentClasses Property

Collection of document classes that are assigned to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocumentClasses DocumentClasses { get; }
Public ReadOnly Property DocumentClasses As IDocumentClasses
    Get

Property Value

Type: IDocumentClasses

Return Value

Type: IDocumentClasses
IDocumentClasses

Implements

IBatchClassDocumentClasses
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.FolderClasses Property

BatchClassFolderClasses Property

Collection of the folder classes that are assigned to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolderClasses FolderClasses { get; }
Public ReadOnly Property FolderClasses As IFolderClasses
    Get

Property Value

Type: IFolderClasses

Return Value

Type: IFolderClasses
IFolderClasses

Implements

IBatchClassFolderClasses
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.ImageFolder Property

BatchClassImageFolder Property

The image folder used to store temporary images; not to be confused with the image folder used to export images.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ImageFolder { get; set; }
Public Property ImageFolder As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchClassImageFolder
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.Name Property

BatchClassName Property

Batch class name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchClassName
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.NonImageFileSupport Property

BatchClassNonImageFileSupport Property

True if non-image files are supported for this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool NonImageFileSupport { get; set; }
Public Property NonImageFileSupport As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchClassNonImageFileSupport
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.Priority Property

BatchClassPriority Property

The default priority for batches created from this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Priority { get; set; }
Public Property Priority As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Long

Implements

IBatchClassPriority
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.PublishErrors Property

BatchClassPublishErrors Property

Collection of strings, one for each error from the previous Publish operation.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IKfxCollection PublishErrors { get; }
Public ReadOnly Property PublishErrors As IKfxCollection
    Get

Property Value

Type: IKfxCollection

Return Value

Type: IKfxCollection
Kofax.Collection.IKfxCollection

Implements

IBatchClassPublishErrors
Remarks
Empty if there were no warnings. Empty if there was not a previous call to Publish for this object instance.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.PublishStatus Property

BatchClassPublishStatus Property

Returns True if the previous Publish operation was successful.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool PublishStatus { get; }
Public ReadOnly Property PublishStatus As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchClassPublishStatus
Remarks
False if there was not a previous call to Publish for this object instance.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.PublishWarnings Property

BatchClassPublishWarnings Property

Collection of strings, one for each warning from the previous Publish operation.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IKfxCollection PublishWarnings { get; }
Public ReadOnly Property PublishWarnings As IKfxCollection
    Get

Property Value

Type: IKfxCollection

Return Value

Type: IKfxCollection
Kofax.Collection.IKfxCollection

Implements

IBatchClassPublishWarnings
Remarks
Empty if there were no warnings. Empty if there was not a previous call to Publish for this object instance.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.QueueProperties Property

BatchClassQueueProperties Property

Collection of batch class custom properties for this custom extension.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IQueueProperties QueueProperties { get; }
Public ReadOnly Property QueueProperties As IQueueProperties
    Get

Property Value

Type: IQueueProperties

Return Value

Type: IQueueProperties
IQueueProperties

Implements

IBatchClassQueueProperties
Remarks
There is no "Set" for this property, but its contents can be changed by calling methods of the QueueProperties class.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.SepAndFormIDProf Property

BatchClassSepAndFormIDProf Property

The separation and form identification profile for this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ISepAndFormIDProf SepAndFormIDProf { get; set; }
Public Property SepAndFormIDProf As ISepAndFormIDProf
    Get
    Set

Property Value

Type: ISepAndFormIDProf

Return Value

Type: ISepAndFormIDProf
ISepAndFormIDProf

Implements

IBatchClassSepAndFormIDProf
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClass.SingleDocProcessing Property

BatchClassSingleDocProcessing Property

If True, an individual batch is created for each new document.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SingleDocProcessing { get; set; }
Public Property SingleDocProcessing As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchClassSingleDocProcessing
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClasses Class

BatchClasses Class

BatchClasses COM implementation class.

Defines a COM collection of BatchClass objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesBatchClasses

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638CFFF8-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class BatchClasses : IBatchClasses,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638CFFF8-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class BatchClasses
    Implements IBatchClasses, IEnumerable, IDisposable

The BatchClasses type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of BatchClass objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
A BatchClass object is valid until it is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


BatchClasses Methods

BatchClasses Methods

The BatchClasses type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClasses.Dispose Method

BatchClassesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

BatchClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClasses.GetEnumerator Method

BatchClassesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IBatchClasses object.

Implements

IBatchClassesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

BatchClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClasses Properties

BatchClasses Properties

The BatchClasses type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of BatchClass objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

BatchClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClasses.Count Property

BatchClassesCount Property

Returns the number of BatchClass objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchClassesCount
Remarks
See Also

Reference

BatchClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchClasses.Item Property

BatchClassesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchClass this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IBatchClass
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IBatchClass

Return Value

Type: IBatchClass
IBatchClass

Implements

IBatchClassesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

BatchClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchField Class

BatchField Class

BatchField COM implementation class.

Defines information about a batch field.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesBatchField

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638CFFFA-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class BatchField : IBatchField, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638CFFFA-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class BatchField
    Implements IBatchField, IDisposable

The BatchField type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Default | The default value of the batch field.
Public property | DisplayLabel | Reads and writes the value of a supported batch field display label.
Public property | FieldType | The field type assigned to the batch field.
Public property | Hidden | The hidden flag of the batch field.
Public property | Name | The batch field name.
Public property | Required | The required flag of the batch field.
Top
Remarks
A BatchField object is valid until it is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


BatchField Methods

BatchField Methods

The BatchField type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchField Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchField.Dispose Method

BatchFieldDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

BatchField Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchField Properties

BatchField Properties

The BatchField type exposes the following members.

Properties
 | Name | Description
Public property | Default | The default value of the batch field.
Public property | DisplayLabel | Reads and writes the value of a supported batch field display label.
Public property | FieldType | The field type assigned to the batch field.
Public property | Hidden | The hidden flag of the batch field.
Public property | Name | The batch field name.
Public property | Required | The required flag of the batch field.
Top
See Also

Reference

BatchField Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchField.Default Property

BatchFieldDefault Property

The default value of the batch field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Default { get; set; }
Public Property Default As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchFieldDefault
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchField.DisplayLabel Property

BatchFieldDisplayLabel Property

Reads and writes the value of a supported batch field display label.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string DisplayLabel { get; set; }
Public Property DisplayLabel As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchFieldDisplayLabel
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchField.FieldType Property

BatchFieldFieldType Property

The field type assigned to the batch field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFieldType FieldType { get; set; }
Public Property FieldType As IFieldType
    Get
    Set

Property Value

Type: IFieldType

Return Value

Type: IFieldType
IFieldType

Implements

IBatchFieldFieldType
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

BatchField Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchField.Hidden Property

BatchFieldHidden Property

The hidden flag of the batch field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Hidden { get; set; }
Public Property Hidden As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchFieldHidden
Remarks
If this is set to True, the Required property will be set to False, if it is not already.
See Also

Reference

BatchField Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchField.Name Property

BatchFieldName Property

The batch field name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchFieldName
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchField.Required Property

BatchFieldRequired Property

The required flag of the batch field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Required { get; set; }
Public Property Required As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchFieldRequired
Remarks
If True, batches of this batch class cannot be created until this batch field has a value. If this is set to True, the Hidden property will be set to False, if it is not already.
See Also

Reference

BatchField Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchFields Class

BatchFields Class

BatchFields COM implementation class.

Defines a COM collection of IBatchField objects associated with a batch class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesBatchFields

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638CFFFC-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class BatchFields : IBatchFields,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638CFFFC-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class BatchFields
    Implements IBatchFields, IEnumerable, IDisposable

The BatchFields type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | The number of BatchFields objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks

Iteration and extraction by order number (with the item function) are supported. Extraction by name is also supported. Passing an out-of-range, or invalid parameter to the item function causes it to generate an error.

The BatchFields object is sorted in the same order as displayed on the General tab of the Batch Class Properties dialog. The BatchFields object is valid as long as the parent BatchClass is valid.

The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


BatchFields Methods

BatchFields Methods

The BatchFields type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchFields Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchFields.Dispose Method

BatchFieldsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

BatchFields Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchFields.GetEnumerator Method

BatchFieldsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IBatchFields object.

Implements

IBatchFieldsGetEnumerator
IEnumerableGetEnumerator
See Also

Reference

BatchFields Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchFields Properties

BatchFields Properties

The BatchFields type exposes the following members.

Properties
 | Name | Description
Public property | Count | The number of BatchFields objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

BatchFields Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchFields.Count Property

BatchFieldsCount Property

The number of BatchFields objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchFieldsCount
Remarks
See Also

Reference

BatchFields Class
Kofax.Capture.AdminModule.InteropServices Namespace


BatchFields.Item Property

BatchFieldsItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchField this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IBatchField
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IBatchField

Return Value

Type: IBatchField
IBatchField

Implements

IBatchFieldsItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

BatchFields Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass Class

DocumentClass Class

DocumentClass COM implementation class.

Defines information about a document class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesDocumentClass

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638CFFFE-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class DocumentClass : IDocumentClass,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638CFFFE-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class DocumentClass
    Implements IDocumentClass, IDisposable

The DocumentClass type exposes the following members.

Methods
 | Name | Description
Public method | CreateFormType | Creates a new form type for the document class.
Public method | CreateIndexField | Creates a new index field for the document class.
Public method | CreateTableDefinition | Creates a new TableDefinition with the specified name.
Public method | DeleteFormType | Deletes an existing form type.
Public method | DeleteIndexField | Deletes an existing index field.
Public method | DeleteTableDefinition | Deletes the specified table definition.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Document class description.
Public property | FormTypes | Returns the collection of form types associated with the document class.
Public property | IndexFields | Returns the Collection of index fields associated with the document class.
Public property | Name | Document class name.
Public property | TableDefinitions | Collection of tables associated with the document class.
Top
Remarks
A DocumentClass object is valid until it is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass Methods

DocumentClass Methods

The DocumentClass type exposes the following members.

Methods
 | Name | Description
Public method | CreateFormType | Creates a new form type for the document class.
Public method | CreateIndexField | Creates a new index field for the document class.
Public method | CreateTableDefinition | Creates a new TableDefinition with the specified name.
Public method | DeleteFormType | Deletes an existing form type.
Public method | DeleteIndexField | Deletes an existing index field.
Public method | DeleteTableDefinition | Deletes the specified table definition.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass.CreateFormType Method

DocumentClassCreateFormType Method

Creates a new form type for the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Object CreateFormType(
    string strName
)
Public Function CreateFormType (
    strName As String
) As Object

Parameters

strName
Type: SystemString
The name of the new form type.

Return Value

Type: Object

Implements

IDocumentClassCreateFormType(String)
Remarks
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass.CreateIndexField Method

DocumentClassCreateIndexField Method

Creates a new index field for the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void CreateIndexField(
    string strName,
    ref IFieldType oFieldType
)
Public Sub CreateIndexField (
    strName As String,
    ByRef oFieldType As IFieldType
)

Parameters

strName
Type: SystemString
The name of the new index field.
oFieldType
Type: Kofax.Capture.AdminModule.InteropServicesIFieldType
The field type used.

Implements

IDocumentClassCreateIndexField(String, IFieldType)
Remarks
This function pre-validates the index field.
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass.CreateTableDefinition Method

DocumentClassCreateTableDefinition Method

Creates a new TableDefinition with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void CreateTableDefinition(
    string strName,
    ref IIndexField oIndexField,
    ref IIndexField oNextIndexField
)
Public Sub CreateTableDefinition (
    strName As String,
    ByRef oIndexField As IIndexField,
    ByRef oNextIndexField As IIndexField
)

Parameters

strName
Type: SystemString
The name of the new table.
oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
Becomes a table field for the new table.
oNextIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The table is inserted before oNextIndexField. If that field is a table field, the new table is inserted before the table. If Nothing, the table is added at the current location of oIndexField.

Implements

IDocumentClassCreateTableDefinition(String, IIndexField, IIndexField)
Remarks
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass.DeleteFormType Method

DocumentClassDeleteFormType Method

Deletes an existing form type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteFormType(
    ref IFormType oFormType
)
Public Sub DeleteFormType (
    ByRef oFormType As IFormType
)

Parameters

oFormType
Type: Kofax.Capture.AdminModule.InteropServicesIFormType
The form type to delete.

Implements

IDocumentClassDeleteFormType(IFormType)
Remarks
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass.DeleteIndexField Method

DocumentClassDeleteIndexField Method

Deletes an existing index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteIndexField(
    ref IIndexField oIndexField
)
Public Sub DeleteIndexField (
    ByRef oIndexField As IIndexField
)

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The index field to delete. If oIndexField is the only index field for a table, that table is also deleted.

Implements

IDocumentClassDeleteIndexField(IIndexField)
Remarks
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass.DeleteTableDefinition Method

DocumentClassDeleteTableDefinition Method

Deletes the specified table definition.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteTableDefinition(
    ref ITableDefinition oTableDefinition
)
Public Sub DeleteTableDefinition (
    ByRef oTableDefinition As ITableDefinition
)

Parameters

oTableDefinition
Type: Kofax.Capture.AdminModule.InteropServicesITableDefinition
The table definition to delete.

Implements

IDocumentClassDeleteTableDefinition(ITableDefinition)
Remarks
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass.Dispose Method

DocumentClassDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass Properties

DocumentClass Properties

The DocumentClass type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Document class description.
Public property | FormTypes | Returns the collection of form types associated with the document class.
Public property | IndexFields | Returns the Collection of index fields associated with the document class.
Public property | Name | Document class name.
Public property | TableDefinitions | Collection of tables associated with the document class.
Top
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass.CustomStorageString Property

DocumentClassCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the document class.

Property Value

Type: String

Return Value

Type: String

Implements

IDocumentClassCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific document class. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass.Description Property

DocumentClassDescription Property

Document class description.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IDocumentClassDescription
Remarks
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass.FormTypes Property

DocumentClassFormTypes Property

Returns the collection of form types associated with the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFormTypes FormTypes { get; }
Public ReadOnly Property FormTypes As IFormTypes
    Get

Property Value

Type: IFormTypes

Return Value

Type: IFormTypes
IFormTypes

Implements

IDocumentClassFormTypes
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass.IndexFields Property

DocumentClassIndexFields Property

Returns the Collection of index fields associated with the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexFields IndexFields { get; }
Public ReadOnly Property IndexFields As IIndexFields
    Get

Property Value

Type: IIndexFields

Return Value

Type: IIndexFields
IIndexFields

Implements

IDocumentClassIndexFields
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass.Name Property

DocumentClassName Property

Document class name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IDocumentClassName
Remarks
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClass.TableDefinitions Property

DocumentClassTableDefinitions Property

Collection of tables associated with the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ITableDefinitions TableDefinitions { get; }
Public ReadOnly Property TableDefinitions As ITableDefinitions
    Get

Property Value

Type: ITableDefinitions

Return Value

Type: ITableDefinitions
ITableDefinitions

Implements

IDocumentClassTableDefinitions
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

DocumentClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClasses Class

DocumentClasses Class

DocumentClasses COM implementation class.

Defines a COM collection of DocumentClass objects associated with a batch class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesDocumentClasses

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0000-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class DocumentClasses : IDocumentClasses,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0000-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class DocumentClasses
    Implements IDocumentClasses, IEnumerable, IDisposable

The DocumentClasses type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of IDocumentClass objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClasses Methods

DocumentClasses Methods

The DocumentClasses type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DocumentClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClasses.Dispose Method

DocumentClassesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

DocumentClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClasses.GetEnumerator Method

DocumentClassesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IDocumentClasses object.

Implements

IDocumentClassesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

DocumentClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClasses Properties

DocumentClasses Properties

The DocumentClasses type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of IDocumentClass objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

DocumentClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClasses.Count Property

DocumentClassesCount Property

Returns the number of IDocumentClass objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IDocumentClassesCount
Remarks
See Also

Reference

DocumentClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


DocumentClasses.Item Property

DocumentClassesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocumentClass this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IDocumentClass
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IDocumentClass

Return Value

Type: IDocumentClass
IDocumentClass

Implements

IDocumentClassesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

DocumentClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


ExportEventArgs Class

ExportEventArgs Class

ExportEventArgs COM implementation class.

The setup OCX receives the specified action event before a batch class is exported.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesExportEventArgs

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0002-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class ExportEventArgs : IExportEventArgs,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0002-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class ExportEventArgs
    Implements IExportEventArgs, IDisposable

The ExportEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ExportEventArgs | Initializes a new instance of the Kofax.Capture.AdminModule.InteropServices.ExportEventArgs class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BatchClass | The batch class that is being exported.
Public property | ExportFolder | A batch class\setup module specific folder.
Top
Remarks

The setup OCX can copy any setup data into an Export folder specified by Tungsten Capture. The setup OCX does this before returning from the event. The folder and any subfolders are stored within the Kofax Capture "cab" file. The folder hierarchy is maintained.

The Export folder is deleted by Tungsten Capture after the KfxOcxEventBatchClassExport event. This event occurs prior to the physical export of a batch class. Registered setup OCXs without an associated runtime module do not receive this event.

Registered setup OCXs with an associated runtime module receive this event whenever export occurs on a batch class which is a part of that OCX's associated runtime module.

Each setup OCX will each receive an event; however, it is not possible to predict the order in which the setup OCXs will receive it. When an export event occurs, an ExportEventArgs object is received as the second parameter of the action event.

The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


ExportEventArgs Constructor

ExportEventArgs Constructor

Initializes a new instance of the Kofax.Capture.AdminModule.InteropServices.ExportEventArgs class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ExportEventArgs()
Public Sub New
Remarks
See Also

Reference

ExportEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


ExportEventArgs Methods

ExportEventArgs Methods

The ExportEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ExportEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


ExportEventArgs.Dispose Method

ExportEventArgsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

ExportEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


ExportEventArgs Properties

ExportEventArgs Properties

The ExportEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BatchClass | The batch class that is being exported.
Public property | ExportFolder | A batch class\setup module specific folder.
Top
See Also

Reference

ExportEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


ExportEventArgs.BatchClass Property

ExportEventArgsBatchClass Property

The batch class that is being exported.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchClass BatchClass { get; }
Public ReadOnly Property BatchClass As IBatchClass
    Get

Property Value

Type: IBatchClass

Return Value

Type: IBatchClass
IBatchClass

Implements

IExportEventArgsBatchClass
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

ExportEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


ExportEventArgs.ExportFolder Property

ExportEventArgsExportFolder Property

A batch class\setup module specific folder.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ExportFolder { get; }
Public ReadOnly Property ExportFolder As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IExportEventArgsExportFolder
Remarks
The folder will be created before the event is received by the OCX. After the export is complete, the folder is deleted.

The folder will be off of the workstation local path. It will be similar to:

C:\Documents and Settings\All Users\Application Data\Kofax\Capture\AdminDb\MyModuleId

Or

C:\Documents and Settings\All Users\Application Data\Kofax\CaptureSV\AdminDb\MyModuleId

See Also

Reference

ExportEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType Class

FieldType Class

FieldType COM implementation class.

Defines information about a field type.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesFieldType

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0004-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class FieldType : IFieldType, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0004-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class FieldType
    Implements IFieldType, IDisposable

The FieldType type exposes the following members.

Methods
 | Name | Description
Public method | CreateSuggestedValue | Adds a suggested value.
Public method | DeleteSuggestedValue | Deletes a suggested value.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Gets or sets the Field type description.
Public property | Dictionary | Gets or sets the dictionary used by the field type.
Public property | Length | The length of the field type.
Public property | Name | Gets the field type name.
Public property | Numeric | Returns True if the field type is numeric.
Public property | NumericPrecision | Returns the precision of the field type.
Public property | NumericScale | Returns the scale of the field type.
Public property | OrderType | Indicates the sort type
Public property | SortAlphabetically | Indicates the suggested values are sorted.
Public property | SqlType | Returns the data type of the field type.
Public property | SuggestedValues | Returns a collection of SuggestedValues, which is a collection of alphabetically sorted strings.
Public property | SuggestedValuesForceMatch | Read - Returns True if "force match" is set. Write - Sets the value.
Public property | SuggestedValuesForceMatchCaseSensitive | Read - Returns True if "case sensitive" is set. Write - Sets the value.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


FieldType Methods

FieldType Methods

The FieldType type exposes the following members.

Methods
 | Name | Description
Public method | CreateSuggestedValue | Adds a suggested value.
Public method | DeleteSuggestedValue | Deletes a suggested value.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.CreateSuggestedValue Method

FieldTypeCreateSuggestedValue Method

Adds a suggested value.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void CreateSuggestedValue(
    string strValue
)
Public Sub CreateSuggestedValue (
    strValue As String
)

Parameters

strValue
Type: SystemString
The new value.

Implements

IFieldTypeCreateSuggestedValue(String)
Remarks
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.DeleteSuggestedValue Method

FieldTypeDeleteSuggestedValue Method

Deletes a suggested value.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteSuggestedValue(
    string strValue
)
Public Sub DeleteSuggestedValue (
    strValue As String
)

Parameters

strValue
Type: SystemString
The value to delete.

Implements

IFieldTypeDeleteSuggestedValue(String)
Remarks
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.Dispose Method

FieldTypeDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType Properties

FieldType Properties

The FieldType type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Gets or sets the Field type description.
Public property | Dictionary | Gets or sets the dictionary used by the field type.
Public property | Length | The length of the field type.
Public property | Name | Gets the field type name.
Public property | Numeric | Returns True if the field type is numeric.
Public property | NumericPrecision | Returns the precision of the field type.
Public property | NumericScale | Returns the scale of the field type.
Public property | OrderType | Indicates the sort type
Public property | SortAlphabetically | Indicates the suggested values are sorted.
Public property | SqlType | Returns the data type of the field type.
Public property | SuggestedValues | Returns a collection of SuggestedValues, which is a collection of alphabetically sorted strings.
Public property | SuggestedValuesForceMatch | Read - Returns True if "force match" is set. Write - Sets the value.
Public property | SuggestedValuesForceMatchCaseSensitive | Read - Returns True if "case sensitive" is set. Write - Sets the value.
Top
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.CustomStorageString Property

FieldTypeCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the field type.

Property Value

Type: String

Return Value

Type: String
String

Implements

IFieldTypeCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific field type. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.Description Property

FieldTypeDescription Property

Gets or sets the Field type description.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String
String

Return Value

Type: String
String

Implements

IFieldTypeDescription
Remarks
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.Dictionary Property

FieldTypeDictionary Property

Gets or sets the dictionary used by the field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Dictionary { get; set; }
Public Property Dictionary As String
    Get
    Set

Property Value

Type: String
The path and file name for a dictionary file.

Return Value

Type: String
Returns the path and file name for a dictionary file.

Implements

IFieldTypeDictionary
Remarks
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.Length Property

FieldTypeLength Property

The length of the field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Length { get; set; }
Public Property Length As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFieldTypeLength
Remarks

Read - Returns the maximum number of characters for following data types:

KFX_OLE_CHAR
KFX_OLE_VARCHAR

Write - Sets the maximum number of characters for the data types listed above.

See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.Name Property

FieldTypeName Property

Gets the field type name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IFieldTypeName
Remarks
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.Numeric Property

FieldTypeNumeric Property

Returns True if the field type is numeric.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Numeric { get; }
Public ReadOnly Property Numeric As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IFieldTypeNumeric
Remarks
ReturnsTrue if the value is not one of the following:

KFX_OLE_CHAR
KFX_OLE_VARCHAR

See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.NumericPrecision Property

FieldTypeNumericPrecision Property

Returns the precision of the field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int NumericPrecision { get; set; }
Public Property NumericPrecision As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFieldTypeNumericPrecision
Remarks

Read - Returns the number of digits of precision for the following data types:

KFX_OLE_DECIMAL
KFX_OLE_DOUBLE
KFX_OLE_FLOAT
KFX_OLE_INTEGER
KFX_OLE_NUMERIC
KFX_OLE_REAL
KFX_OLE_SMALLINT

Write - Sets the precision for the following data types:

KFX_OLE_DECIMAL
KFX_OLE_NUMERIC

All other data types are read-only.

See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.NumericScale Property

FieldTypeNumericScale Property

Returns the scale of the field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int NumericScale { get; set; }
Public Property NumericScale As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFieldTypeNumericScale
Remarks

Read - Returns the number of digits to the right of the decimal for numeric data types.

Write - Sets the number of digits to the right of the decimal for numeric data types. The only numeric data types that support the setting of this property are:

KFX_OLE_DECIMAL
KFX_OLE_NUMERIC

Valid values for NumericScale are 1-15, inclusive. NumericScale cannot be greater than NumericPrecision.

See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.OrderType Property

FieldTypeOrderType Property
Indicates the sort type

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int OrderType { get; set; }
Public Property OrderType As Integer
    Get
    Set

Return Value

Type: Int32
0 – Ascending, 1 – Descending

Implements

IFieldTypeOrderType
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.SortAlphabetically Property

FieldTypeSortAlphabetically Property
Indicates the suggested values are sorted.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SortAlphabetically { get; set; }
Public Property SortAlphabetically As Boolean
    Get
    Set

Return Value

Type: Boolean
True – The values is sorted alphabetically False – The values' order is custom

Implements

IFieldTypeSortAlphabetically
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.SqlType Property

FieldTypeSqlType Property

Returns the data type of the field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int SqlType { get; set; }
Public Property SqlType As Integer
    Get
    Set

Property Value

Type: Int32
The data type enumeration.

Return Value

Type: Int32
Returns the data type enumeration.

Implements

IFieldTypeSqlType
Remarks
Read - Returns the data type enumeration.
Write - Sets the data type enumeration.
Data type enumeration:

KFX_OLE_CHAR
KFX_OLE_DATE
KFX_OLE_DECIMAL
KFX_OLE_DOUBLE
KFX_OLE_FLOAT
KFX_OLE_INTEGER
KFX_OLE_NUMERIC
KFX_OLE_REAL
KFX_OLE_SMALLINT
KFX_OLE_TIME
KFX_OLE_VARCHAR

See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.SuggestedValues Property

FieldTypeSuggestedValues Property

Returns a collection of SuggestedValues, which is a collection of alphabetically sorted strings.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ISuggestedValues SuggestedValues { get; }
Public ReadOnly Property SuggestedValues As ISuggestedValues
    Get

Property Value

Type: ISuggestedValues

Return Value

Type: ISuggestedValues
ISuggestedValues

Implements

IFieldTypeSuggestedValues
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.SuggestedValuesForceMatch Property

FieldTypeSuggestedValuesForceMatch Property

Read - Returns True if "force match" is set.
Write - Sets the value.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SuggestedValuesForceMatch { get; set; }
Public Property SuggestedValuesForceMatch As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IFieldTypeSuggestedValuesForceMatch
Remarks
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldType.SuggestedValuesForceMatchCaseSensitive Property

FieldTypeSuggestedValuesForceMatchCaseSensitive Property

Read - Returns True if "case sensitive" is set.
Write - Sets the value.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SuggestedValuesForceMatchCaseSensitive { get; set; }
Public Property SuggestedValuesForceMatchCaseSensitive As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IFieldTypeSuggestedValuesForceMatchCaseSensitive
Remarks
See Also

Reference

FieldType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldTypes Class

FieldTypes Class

FieldTypes COM implementation class.

Defines a COM collection of FieldType objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesFieldTypes

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0006-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class FieldTypes : IFieldTypes, IEnumerable,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0006-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class FieldTypes
    Implements IFieldTypes, IEnumerable, IDisposable

The FieldTypes type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | The number of FieldType objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
The FieldTypes object is always valid while the Administration module is running.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


FieldTypes Methods

FieldTypes Methods

The FieldTypes type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FieldTypes Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldTypes.Dispose Method

FieldTypesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

FieldTypes Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldTypes.GetEnumerator Method

FieldTypesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IFieldTypes object.

Implements

IFieldTypesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

FieldTypes Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldTypes Properties

FieldTypes Properties

The FieldTypes type exposes the following members.

Properties
 | Name | Description
Public property | Count | The number of FieldType objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

FieldTypes Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldTypes.Count Property

FieldTypesCount Property

The number of FieldType objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFieldTypesCount
Remarks
See Also

Reference

FieldTypes Class
Kofax.Capture.AdminModule.InteropServices Namespace


FieldTypes.Item Property

FieldTypesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFieldType this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFieldType
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IFieldType

Return Value

Type: IFieldType
IFieldType

Implements

IFieldTypesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

FieldTypes Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClass Class

FolderClass Class

FolderClass COM implementation class.

Defines information about a folder class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesFolderClass

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0008-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class FolderClass : IFolderClass,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0008-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class FolderClass
    Implements IFolderClass, IDisposable

The FolderClass type exposes the following members.

Methods
 | Name | Description
Public method | CreateIndexField | Creates a new folder index field.
Public method | DeleteIndexField | Deletes an existing folder index field.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomStorageString | The folder class storage string with the specified name.
Public property | Description | The folder class description.
Public property | IndexFields | Ordered list of folder index fields associated with the folder class.
Public property | Name | The folder class name.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


FolderClass Methods

FolderClass Methods

The FolderClass type exposes the following members.

Methods
 | Name | Description
Public method | CreateIndexField | Creates a new folder index field.
Public method | DeleteIndexField | Deletes an existing folder index field.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FolderClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClass.CreateIndexField Method

FolderClassCreateIndexField Method

Creates a new folder index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void CreateIndexField(
    string strName,
    ref IFieldType oFieldType
)
Public Sub CreateIndexField (
    strName As String,
    ByRef oFieldType As IFieldType
)

Parameters

strName
Type: SystemString
The name of the new folder index field.
oFieldType
Type: Kofax.Capture.AdminModule.InteropServicesIFieldType
The field type used.

Implements

IFolderClassCreateIndexField(String, IFieldType)
Remarks
This function pre-validates the folder index field and throws the following errors:

(KfxApiErrDuplicateObject) duplicate folder index field.

(KfxApiErrBadParameterRange) illegal folder index field name.

(KfxApiErrAppIsBusy) if the application is in the middle of a user event.

See Also

Reference

FolderClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClass.DeleteIndexField Method

FolderClassDeleteIndexField Method

Deletes an existing folder index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteIndexField(
    ref IIndexField oIndexField
)
Public Sub DeleteIndexField (
    ByRef oIndexField As IIndexField
)

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The folder index field to delete.

Implements

IFolderClassDeleteIndexField(IIndexField)
Remarks
Delete a Folder class (including any sub-objects).

The following error is thrown:

(KfxApiErrAppIsBusy) if the application is in the middle of a user event.

See Also

Reference

FolderClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClass.Dispose Method

FolderClassDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

FolderClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClass Properties

FolderClass Properties

The FolderClass type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The folder class storage string with the specified name.
Public property | Description | The folder class description.
Public property | IndexFields | Ordered list of folder index fields associated with the folder class.
Public property | Name | The folder class name.
Top
See Also

Reference

FolderClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClass.CustomStorageString Property

FolderClassCustomStorageString Property

The folder class storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the folder class.

Property Value

Type: String

Return Value

Type: String
String

Implements

IFolderClassCustomStorageStringString
Remarks

Setup OCXs can read custom strings stored by other Setup OCXs. If set to an empty string, the storage string is deleted.

Custom Storage strings are custom text strings that are bound to a specific folder class. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large (over 2 billion characters).
See Also

Reference

FolderClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClass.Description Property

FolderClassDescription Property

The folder class description.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IFolderClassDescription
Remarks
See Also

Reference

FolderClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClass.IndexFields Property

FolderClassIndexFields Property

Ordered list of folder index fields associated with the folder class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexFields IndexFields { get; }
Public ReadOnly Property IndexFields As IIndexFields
    Get

Property Value

Type: IIndexFields

Return Value

Type: IIndexFields
IIndexFields

Implements

IFolderClassIndexFields
Remarks

The list is ordered according to the display order in the Folder Class Properties dialog.

This is the same IndexFields collection that a document returns except that it represents a folder index field collection.

The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

FolderClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClass.Name Property

FolderClassName Property

The folder class name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IFolderClassName
Remarks
See Also

Reference

FolderClass Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClasses Class

FolderClasses Class

FolderClasses COM implementation class.

Defines a collection of FolderClass objects associated with folder classes.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesFolderClasses

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D000A-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class FolderClasses : IFolderClasses,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D000A-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class FolderClasses
    Implements IFolderClasses, IEnumerable, IDisposable

The FolderClasses type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of FolderClass objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


FolderClasses Methods

FolderClasses Methods

The FolderClasses type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FolderClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClasses.Dispose Method

FolderClassesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

FolderClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClasses.GetEnumerator Method

FolderClassesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IFolderClasses object.

Implements

IFolderClassesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

FolderClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClasses Properties

FolderClasses Properties

The FolderClasses type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of FolderClass objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

FolderClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClasses.Count Property

FolderClassesCount Property

Returns the number of FolderClass objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFolderClassesCount
Remarks
See Also

Reference

FolderClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


FolderClasses.Item Property

FolderClassesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolderClass this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFolderClass
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IFolderClass

Return Value

Type: IFolderClass
IFolderClass

Implements

IFolderClassesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

FolderClasses Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZone Class

FormIdZone Class

FormIdZone COM implementation class.

Defines information about a form identification zone.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesFormIdZone

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D000C-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class FormIdZone : IFormIdZone, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D000C-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class FormIdZone
    Implements IFormIdZone, IDisposable

The FormIdZone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SearchText | Search text for the form ID zone.
Public property | ZoneHeight | The height of the zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | The left coordinate of the zone in BMUs.
Public property | ZoneTop | The top coordinate of the zone in BMUs.
Public property | ZoneWidth | The width of the zone in BMUs.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZone Methods

FormIdZone Methods

The FormIdZone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FormIdZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZone.Dispose Method

FormIdZoneDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

FormIdZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZone Properties

FormIdZone Properties

The FormIdZone type exposes the following members.

Properties
 | Name | Description
Public property | SearchText | Search text for the form ID zone.
Public property | ZoneHeight | The height of the zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | The left coordinate of the zone in BMUs.
Public property | ZoneTop | The top coordinate of the zone in BMUs.
Public property | ZoneWidth | The width of the zone in BMUs.
Top
See Also

Reference

FormIdZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZone.SearchText Property

FormIdZoneSearchText Property

Search text for the form ID zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string SearchText { get; }
Public ReadOnly Property SearchText As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IFormIdZoneSearchText
Remarks
See Also

Reference

FormIdZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZone.ZoneHeight Property

FormIdZoneZoneHeight Property

The height of the zone in BMUs (1/1200th of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneHeight { get; }
Public ReadOnly Property ZoneHeight As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFormIdZoneZoneHeight
Remarks
See Also

Reference

FormIdZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZone.ZoneLeft Property

FormIdZoneZoneLeft Property

The left coordinate of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneLeft { get; }
Public ReadOnly Property ZoneLeft As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFormIdZoneZoneLeft
Remarks
See Also

Reference

FormIdZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZone.ZoneTop Property

FormIdZoneZoneTop Property

The top coordinate of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneTop { get; }
Public ReadOnly Property ZoneTop As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFormIdZoneZoneTop
Remarks
See Also

Reference

FormIdZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZone.ZoneWidth Property

FormIdZoneZoneWidth Property

The width of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneWidth { get; }
Public ReadOnly Property ZoneWidth As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFormIdZoneZoneWidth
Remarks
See Also

Reference

FormIdZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZoneColl Class

FormIdZoneColl Class

FormIdZoneColl COM implementation class.

Defines a COM collection of FormIDZone objects on a sample page.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesFormIdZoneColl

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D000E-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class FormIdZoneColl : IFormIdZoneColl,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D000E-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class FormIdZoneColl
    Implements IFormIdZoneColl, IEnumerable, IDisposable

The FormIdZoneColl type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of FormIDZone items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
The FormIDZoneColl object is valid as long as the page is not deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZoneColl Methods

FormIdZoneColl Methods

The FormIdZoneColl type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FormIdZoneColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZoneColl.Dispose Method

FormIdZoneCollDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

FormIdZoneColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZoneColl.GetEnumerator Method

FormIdZoneCollGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IFormIdZoneColl object.

Implements

IFormIdZoneCollGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

FormIdZoneColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZoneColl Properties

FormIdZoneColl Properties

The FormIdZoneColl type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of FormIDZone items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

FormIdZoneColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZoneColl.Count Property

FormIdZoneCollCount Property

Returns the number of FormIDZone items in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFormIdZoneCollCount
Remarks
See Also

Reference

FormIdZoneColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormIdZoneColl.Item Property

FormIdZoneCollItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFormIdZone this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFormIdZone
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IFormIdZone

Return Value

Type: IFormIdZone
IFormIdZone

Implements

IFormIdZoneCollItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

FormIdZoneColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormType Class

FormType Class

FormType COM implementation class.

Defines information about a form type.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesFormType

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0010-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class FormType : IFormType, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0010-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class FormType
    Implements IFormType, IDisposable

The FormType type exposes the following members.

Methods
 | Name | Description
Public method | DeleteSamplePage | Deletes the sample page (including any sub-objects).
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ImportSamplePage | Imports an image to become a sample page.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Form type description.
Public property | FixedPageCount | The number of pages for the FormType; 0 if fixed pages not used.
Public property | HorizontalDPI | The horizontal DPI for all sample pages of the form type.
Public property | Name | Form type name.
Public property | SamplePages | Collection of sample pages for the form type.
Public property | VerticalDPI | The vertical DPI for all sample pages of the form type.
Top
Remarks
The FormType object is valid until it, or the parent document class, is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


FormType Methods

FormType Methods

The FormType type exposes the following members.

Methods
 | Name | Description
Public method | DeleteSamplePage | Deletes the sample page (including any sub-objects).
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ImportSamplePage | Imports an image to become a sample page.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FormType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormType.DeleteSamplePage Method

FormTypeDeleteSamplePage Method

Deletes the sample page (including any sub-objects).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteSamplePage(
    ref ISamplePage oSamplePage
)
Public Sub DeleteSamplePage (
    ByRef oSamplePage As ISamplePage
)

Parameters

oSamplePage
Type: Kofax.Capture.AdminModule.InteropServicesISamplePage
The sample page to delete.

Implements

IFormTypeDeleteSamplePage(ISamplePage)
Remarks
See Also

Reference

FormType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormType.Dispose Method

FormTypeDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

FormType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormType.ImportSamplePage Method

FormTypeImportSamplePage Method

Imports an image to become a sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void ImportSamplePage(
    string strName
)
Public Sub ImportSamplePage (
    strName As String
)

Parameters

strName
Type: SystemString
The filepath of the image.

Implements

IFormTypeImportSamplePage(String)
Remarks
See Also

Reference

FormType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormType Properties

FormType Properties

The FormType type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Form type description.
Public property | FixedPageCount | The number of pages for the FormType; 0 if fixed pages not used.
Public property | HorizontalDPI | The horizontal DPI for all sample pages of the form type.
Public property | Name | Form type name.
Public property | SamplePages | Collection of sample pages for the form type.
Public property | VerticalDPI | The vertical DPI for all sample pages of the form type.
Top
See Also

Reference

FormType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormType.CustomStorageString Property

FormTypeCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the form type.

Property Value

Type: String

Return Value

Type: String
String

Implements

IFormTypeCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific form type. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.
See Also

Reference

FormType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormType.Description Property

FormTypeDescription Property

Form type description.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IFormTypeDescription
Remarks
See Also

Reference

FormType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormType.FixedPageCount Property

FormTypeFixedPageCount Property

The number of pages for the FormType; 0 if fixed pages not used.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int FixedPageCount { get; set; }
Public Property FixedPageCount As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFormTypeFixedPageCount
Remarks
If 0 or less, indicates that fixed pages are not used.
See Also

Reference

FormType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormType.HorizontalDPI Property

FormTypeHorizontalDPI Property

The horizontal DPI for all sample pages of the form type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int HorizontalDPI { get; }
Public ReadOnly Property HorizontalDPI As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFormTypeHorizontalDPI
Remarks
See Also

Reference

FormType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormType.Name Property

FormTypeName Property

Form type name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IFormTypeName
Remarks
See Also

Reference

FormType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormType.SamplePages Property

FormTypeSamplePages Property

Collection of sample pages for the form type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ISamplePages SamplePages { get; }
Public ReadOnly Property SamplePages As ISamplePages
    Get

Property Value

Type: ISamplePages

Return Value

Type: ISamplePages
ISamplePages

Implements

IFormTypeSamplePages
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

FormType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormType.VerticalDPI Property

FormTypeVerticalDPI Property

The vertical DPI for all sample pages of the form type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int VerticalDPI { get; }
Public ReadOnly Property VerticalDPI As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFormTypeVerticalDPI
Remarks
See Also

Reference

FormType Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormTypes Class

FormTypes Class

FormTypes COM implementation class.

Defines a COM collection of FormType objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesFormTypes

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0012-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class FormTypes : IFormTypes, IEnumerable,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0012-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class FormTypes
    Implements IFormTypes, IEnumerable, IDisposable

The FormTypes type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of elements in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
The FormType object is always valid while the Administration module is running.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


FormTypes Methods

FormTypes Methods

The FormTypes type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FormTypes Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormTypes.Dispose Method

FormTypesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

FormTypes Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormTypes.GetEnumerator Method

FormTypesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IFormTypes object.

Implements

IFormTypesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

FormTypes Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormTypes Properties

FormTypes Properties

The FormTypes type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of elements in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

FormTypes Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormTypes.Count Property

FormTypesCount Property

Returns the number of elements in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFormTypesCount
Remarks
See Also

Reference

FormTypes Class
Kofax.Capture.AdminModule.InteropServices Namespace


FormTypes.Item Property

FormTypesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFormType this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFormType
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IFormType

Return Value

Type: IFormType
IFormType

Implements

IFormTypesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

FormTypes Class
Kofax.Capture.AdminModule.InteropServices Namespace


Group Class

Group Class

Group COM implementation class.

Defines information about a Group object.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesGroup

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0014-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Group : IGroup, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0014-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Group
    Implements IGroup, IDisposable

The Group type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Returns the group name of a Tungsten Capture group.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


Group Methods

Group Methods

The Group type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Group Class
Kofax.Capture.AdminModule.InteropServices Namespace


Group.Dispose Method

GroupDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Group Class
Kofax.Capture.AdminModule.InteropServices Namespace


Group Properties

Group Properties

The Group type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the group name of a Tungsten Capture group.
Top
See Also

Reference

Group Class
Kofax.Capture.AdminModule.InteropServices Namespace


Group.Name Property

GroupName Property

Returns the group name of a Tungsten Capture group.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IGroupName
Remarks
See Also

Reference

Group Class
Kofax.Capture.AdminModule.InteropServices Namespace


Groups Class

Groups Class

Groups COM implementation class.

Defines a COM collection of Group objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesGroups

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0016-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Groups : IGroups, IEnumerable,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0016-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Groups
    Implements IGroups, IEnumerable, IDisposable

The Groups type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of objects contained in the collection of Group objects.
Public property | Item | Retrieves an object from the collection of Group objects, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


Groups Methods

Groups Methods

The Groups type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Groups Class
Kofax.Capture.AdminModule.InteropServices Namespace


Groups.Dispose Method

GroupsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Groups Class
Kofax.Capture.AdminModule.InteropServices Namespace


Groups.GetEnumerator Method

GroupsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IGroups object.

Implements

IGroupsGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Groups Class
Kofax.Capture.AdminModule.InteropServices Namespace


Groups Properties

Groups Properties

The Groups type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of objects contained in the collection of Group objects.
Public property | Item | Retrieves an object from the collection of Group objects, by index or by key.
Top
See Also

Reference

Groups Class
Kofax.Capture.AdminModule.InteropServices Namespace


Groups.Count Property

GroupsCount Property

Returns the number of objects contained in the collection of Group objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IGroupsCount
Remarks
See Also

Reference

Groups Class
Kofax.Capture.AdminModule.InteropServices Namespace


Groups.Item Property

GroupsItem Property

Retrieves an object from the collection of Group objects, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IGroup this[
    Object vntIndexKey
] { get; }
Public ReadOnly Property Item (
    vntIndexKey As Object
) As IGroup
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IGroup

Return Value

Type: IGroup
IGroup

Implements

IGroupsItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Groups Class
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication Interface

IAdminApplication Interface

IAdminApplication COM Interface.

When a setup OCX is loaded, a reference to an AdminApplication object is passed to the OCX. An AdminApplication object is valid until the calling application shuts down (or, if called from the OCX, when the OCX terminate event is completed).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638CFFF3-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IAdminApplication
<ComVisibleAttribute(true)>
<GuidAttribute("638CFFF3-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IAdminApplication

The IAdminApplication type exposes the following members.

Methods
 | Name | Description
Public method | AddMenu | Adds a menu to Administration's main menu bar.
Public method | AddMenuEx | Adds a menu to the application.
Public method | CreateBatchClass | Adds the batch class.
Public method | CreateDocumentClass | Adds the document class.
Public method | CreateFieldType | Creates a new field type. The data type is VARCHAR with a length of 254 characters.
Public method | CreateFolderClass | Adds the folder class.
Public method | CustomDataFolder | Returns a global custom data path based on the provided module ID.
Public method | DeleteBatchClass | Deletes the specified batch class.
Public method | DeleteDocumentClass | Deletes the specified document class.
Public method | DeleteFieldType | Deletes the specified field type.
Public method | DeleteFolderClass | Deletes the folder class.
Public method | DisableExportEvents | Sets disable/enable events when batch class is exporting/importing.
Public method | EnableMenu | Enables or disables (grays) a menu.
Public method | ExportBatchClasses | Export batch classes to a CAB file.
Public method | ImportBatchClasses | Imports batch classes from a CAB file and preserves the KTM project assignment if it exists.
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | SelectMenuItem | Selects a menu item.
Public method | ShowMenu | Shows or hides a menu.
Public method | ShowWindow | Shows or hides a panel.
Top
Properties
 | Name | Description
Public property | ActiveBatchClass | Returns the currently selected batch class.
Public property | ActiveDocumentClass | Returns the currently selected document class.
Public property | ActiveFieldType | Returns the currently selected field type.
Public property | ActiveFolderClass | Returns the currently active folder class or nothing.
Public property | ActiveFormIdZone | Returns the currently selected form ID zone.
Public property | ActiveFormIdZoneColl | Collection object for Form ID Zones.
Public property | ActiveFormType | Returns the currently selected form type.
Public property | ActiveIndexGroupZone | Returns the currently selected index group zone.
Public property | ActiveIndexGrpMemZone | Returns the currently selected group member zone.
Public property | ActiveIndexZone | Returns the currently selected index zone.
Public property | ActiveIndexZoneColl | Returns the currently selected collection of index zones.
Public property | ActiveObjectType | Returns the type of the currently selected node or nothing.
Public property | ActivePageLevelBarcode | Returns the currently selected page level bar code.
Public property | ActivePageLevelBarcodeColl | Returns the currently selected collection of page level bar codes.
Public property | ActiveRegistrationZone | Returns the currently selected registration zone.
Public property | ActiveRegZoneColl | Returns the currently selected collection of registration zones.
Public property | ActiveSamplePage | Returns the currently selected sample page.
Public property | ActiveSeparationZone | Returns the currently selected separation zone.
Public property | ActiveTabPanel | Returns the tab displayed in the Definitions panel.
Public property | BatchClasses | Collection of batch classes.
Public property | DisableFieldEvents | Diable sending field change events from the current custom administration panel.
Public property | DocumentClasses | Collection of document classes.
Public property | FieldTypes | Collection of field types.
Public property | FolderClasses | Collection of system-wide folder classes.
Public property | Groups | Collection of available groups.
Public property | IsUserTrackingEnabled | Indicates if user tracking is enabled for Tungsten Capture system
Public property | ModuleID | The Module ID is a unique identifier for the corresponding custom module.
Public property | Queues | Collection of available queues (modules).
Public property | RecognitionProfs | Collection of recognition profiles.
Public property | RemoteSiteProfileNames | Collection of Remote site profile names.
Public property | RemoteSites | Collection of available remote sites.
Public property | SepAndFormIDProfs | Collection of Separation and Form ID profiles.
Public property | ServicePackVersion | Currently installed service pack.
Public property | Theme | Gets the current theme that is being used in Tungsten Capture system.
Public property | Users | Collection of available users.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication Methods

IAdminApplication Methods

The IAdminApplication type exposes the following members.

Methods
 | Name | Description
Public method | AddMenu | Adds a menu to Administration's main menu bar.
Public method | AddMenuEx | Adds a menu to the application.
Public method | CreateBatchClass | Adds the batch class.
Public method | CreateDocumentClass | Adds the document class.
Public method | CreateFieldType | Creates a new field type. The data type is VARCHAR with a length of 254 characters.
Public method | CreateFolderClass | Adds the folder class.
Public method | CustomDataFolder | Returns a global custom data path based on the provided module ID.
Public method | DeleteBatchClass | Deletes the specified batch class.
Public method | DeleteDocumentClass | Deletes the specified document class.
Public method | DeleteFieldType | Deletes the specified field type.
Public method | DeleteFolderClass | Deletes the folder class.
Public method | DisableExportEvents | Sets disable/enable events when batch class is exporting/importing.
Public method | EnableMenu | Enables or disables (grays) a menu.
Public method | ExportBatchClasses | Export batch classes to a CAB file.
Public method | ImportBatchClasses | Imports batch classes from a CAB file and preserves the KTM project assignment if it exists.
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | SelectMenuItem | Selects a menu item.
Public method | ShowMenu | Shows or hides a menu.
Public method | ShowWindow | Shows or hides a panel.
Top
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.AddMenu Method

IAdminApplicationAddMenu Method

Adds a menu to Administration's main menu bar.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool AddMenu(
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = ""
)
Function AddMenu (
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = ""
) As Boolean

Parameters

strEventText
Type: SystemString
Sets the internal name of the menu; it will be the value of Argument for a MenuClicked event.
strMenuText
Type: SystemString
The display text for the menu item.
strMenuLocation
Type: SystemString

Specifies where the menu will appear. It can be: MenuBar (add to frame menu)

The remaining values add the item to the context menu for a specific node type:

  • BatchClass
  • DocumentClass
  • FieldType
  • FormIdZone
  • FormType
  • IndexGroupZone
  • IndexGroupZoneCollection
  • IndexZone
  • IndexZoneCollection
  • PageLevelBarcode
  • PageLevelBarcodeCollection
  • RegistrationZone
  • RegistrationZoneCollection
  • SamplePage
  • SeparationZone
strMenuBarText (Optional)
Type: SystemString

Return Value

Type: Boolean
Boolean - True, menu added otherwise False.
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.AddMenuEx Method

IAdminApplicationAddMenuEx Method

Adds a menu to the application.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool AddMenuEx(
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = "",
    bool bLarge = false,
    string strIconPath = "",
    string strGroupName = ""
)
Function AddMenuEx (
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = "",
    Optional bLarge As Boolean = false,
    Optional strIconPath As String = "",
    Optional strGroupName As String = ""
) As Boolean

Parameters

strEventText
Type: SystemString
Returned to the OCX when the menu is selected.
strMenuText
Type: SystemString
Text displayed in the menu item.
strMenuLocation
Type: SystemString

Location for the menu to appear.

The locations supported are as follows:

VB
Copy
' Declares an array of 4 strings
Dim m_MenuLocationKeys(3) As String  ' Index can vary from 0 to 3
m_MenuLocationKeys(0) = "MenuBar"
m_MenuLocationKeys(1) = "Batch"
m_MenuLocationKeys(2) = "Document"
m_MenuLocationKeys(3) ="Page"
strMenuBarText (Optional)
Type: SystemString
The text displayed on the main frame. Only required if the location is "MenuBar".
bLarge (Optional)
Type: SystemBoolean
A large button or small one.
strIconPath (Optional)
Type: SystemString
The path to the icon file.
strGroupName (Optional)
Type: SystemString
The specific group for menu items.

Return Value

Type: Boolean
Boolean - TRUE, menu added, otherwise FALSE, no more resources.
Remarks
This method can only be used with OCX.
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.CreateBatchClass Method

IAdminApplicationCreateBatchClass Method

Adds the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void CreateBatchClass(
    string strName
)
Sub CreateBatchClass (
    strName As String
)

Parameters

strName
Type: SystemString
The name of the new batch class.
Remarks
The batch class has identical default settings to a batch class created interactively.
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.CreateDocumentClass Method

IAdminApplicationCreateDocumentClass Method

Adds the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void CreateDocumentClass(
    string strName
)
Sub CreateDocumentClass (
    strName As String
)

Parameters

strName
Type: SystemString
The name of the new document class.
Remarks
The document class is created as not being attached to a batch class.
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.CreateFieldType Method

IAdminApplicationCreateFieldType Method

Creates a new field type. The data type is VARCHAR with a length of 254 characters.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void CreateFieldType(
    string strName
)
Sub CreateFieldType (
    strName As String
)

Parameters

strName
Type: SystemString
The name of the new field type.
Remarks

Errors:

(KfxApiErrBadParameterRange) if strName is "(TABLE)" (or localized equivalent). The comparison is case-insensitive.
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.CreateFolderClass Method

IAdminApplicationCreateFolderClass Method

Adds the folder class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void CreateFolderClass(
    string strName
)
Sub CreateFolderClass (
    strName As String
)

Parameters

strName
Type: SystemString
The name of the new folder class.
Remarks
The folder class has identical default settings to a folder class created interactively.

This function throws:

(KfxApiErrDuplicateObject) on a duplicate folder class name.

(KfxApiErrBadParameterRange) on an illegal folder class name.

(KfxApiErrAppIsBusy) if the application is in the middle of a user event.

See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.CustomDataFolder Method

IAdminApplicationCustomDataFolder Method

Returns a global custom data path based on the provided module ID.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string CustomDataFolder(
    ref string strModuleID
)
Function CustomDataFolder (
    ByRef strModuleID As String
) As String

Parameters

strModuleID
Type: SystemString
The subfolder to be used as a custom data storage folder.

Return Value

Type: String
String
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.DeleteBatchClass Method

IAdminApplicationDeleteBatchClass Method

Deletes the specified batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteBatchClass(
    ref IBatchClass oBatchClass
)
Sub DeleteBatchClass (
    ByRef oBatchClass As IBatchClass
)

Parameters

oBatchClass
Type: Kofax.Capture.AdminModule.InteropServicesIBatchClass
The batch class to delete.
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.DeleteDocumentClass Method

IAdminApplicationDeleteDocumentClass Method

Deletes the specified document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteDocumentClass(
    ref IDocumentClass oDocumentClass
)
Sub DeleteDocumentClass (
    ByRef oDocumentClass As IDocumentClass
)

Parameters

oDocumentClass
Type: Kofax.Capture.AdminModule.InteropServicesIDocumentClass
The document class to delete.
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.DeleteFieldType Method

IAdminApplicationDeleteFieldType Method

Deletes the specified field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteFieldType(
    ref IFieldType oFieldType
)
Sub DeleteFieldType (
    ByRef oFieldType As IFieldType
)

Parameters

oFieldType
Type: Kofax.Capture.AdminModule.InteropServicesIFieldType
The field type to delete.
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.DeleteFolderClass Method

IAdminApplicationDeleteFolderClass Method

Deletes the folder class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteFolderClass(
    ref IFolderClass oFolderClass
)
Sub DeleteFolderClass (
    ByRef oFolderClass As IFolderClass
)

Parameters

oFolderClass
Type: Kofax.Capture.AdminModule.InteropServicesIFolderClass
The folder class to delete.
Remarks

This function throws:

(KfxApiErrObjectInUse) if the folder class is in use elsewhere.

(KfxApiErrAppIsBusy) if the application is in the middle of a user event.

See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.DisableExportEvents Method

IAdminApplicationDisableExportEvents Method

Sets disable/enable events when batch class is exporting/importing.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DisableExportEvents(
    KfxApiCustomAdminPanel eAdminCustomPanel,
    bool bDisable
)
Sub DisableExportEvents (
    eAdminCustomPanel As KfxApiCustomAdminPanel,
    bDisable As Boolean
)

Parameters

eAdminCustomPanel
Type: Kofax.Capture.AdminModule.InteropServicesKfxApiCustomAdminPanel
Type of panel need to enable/disable import/export events.
bDisable
Type: SystemBoolean
Disable/Enable events.
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.EnableMenu Method

IAdminApplicationEnableMenu Method

Enables or disables (grays) a menu.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void EnableMenu(
    KfxMenuEnable eState,
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = ""
)
Sub EnableMenu (
    eState As KfxMenuEnable,
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = ""
)

Parameters

eState
Type: Kofax.Capture.AdminModule.InteropServicesKfxMenuEnable

The next four parameters specify the menu to show/hide, and should match the values passed to the AddMenu method (if that was how the menu was created)

strEventText
Type: SystemString
The internal name of the menu item.
strMenuText
Type: SystemString
The display name of the menu item.
strMenuLocation
Type: SystemString
Specifies the location of the menu (see AddMenu).
strMenuBarText (Optional)
Type: SystemString
The main frame menu the item is under.
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ExportBatchClasses Method

IAdminApplicationExportBatchClasses Method

Export batch classes to a CAB file.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void ExportBatchClasses(
    IKfxCollection oBatchClasses,
    bool bExportUserProfiles,
    bool bExportKCNSProfiles,
    string strCabFile,
    bool bShowProgressDialog
)
Sub ExportBatchClasses (
    oBatchClasses As IKfxCollection,
    bExportUserProfiles As Boolean,
    bExportKCNSProfiles As Boolean,
    strCabFile As String,
    bShowProgressDialog As Boolean
)

Parameters

oBatchClasses
Type: IKfxCollection
List of batch class names to be exported.
bExportUserProfiles
Type: SystemBoolean
True to export user profiles.
bExportKCNSProfiles
Type: SystemBoolean
True to export KCNS profiles.
strCabFile
Type: SystemString
Path to the CAB file.
bShowProgressDialog
Type: SystemBoolean
True to show the progress dialog or False to hide it.
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ImportBatchClasses Method

IAdminApplicationImportBatchClasses Method

Imports batch classes from a CAB file and preserves the KTM project assignment if it exists.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void ImportBatchClasses(
    string strCabFile,
    IKfxCollection oBatchClasses,
    KfxApiTransferMode eTransferMode,
    bool bImportAssignments,
    bool bImportUserProfiles,
    KfxApiKCNSProfilesImportMode eKCNSProfilesImportMode,
    bool bShowProgressDialog
)
Sub ImportBatchClasses (
    strCabFile As String,
    oBatchClasses As IKfxCollection,
    eTransferMode As KfxApiTransferMode,
    bImportAssignments As Boolean,
    bImportUserProfiles As Boolean,
    eKCNSProfilesImportMode As KfxApiKCNSProfilesImportMode,
    bShowProgressDialog As Boolean
)

Parameters

strCabFile
Type: SystemString
Path to the cab file.
oBatchClasses
Type: IKfxCollection
List of batch class names to be imported. Empty if import all.
eTransferMode
Type: Kofax.Capture.AdminModule.InteropServicesKfxApiTransferMode
The trasfer mode.
bImportAssignments
Type: SystemBoolean
True to import users/groups assignment, or False to skip import users/groups assignment.
bImportUserProfiles
Type: SystemBoolean
True to import user profiles or False to skip import user profile.
eKCNSProfilesImportMode
Type: Kofax.Capture.AdminModule.InteropServicesKfxApiKCNSProfilesImportMode
TCNS transfer mode.
bShowProgressDialog
Type: SystemBoolean
True to show the progress dialog or False to hide it.
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.LogError Method

IAdminApplicationLogError Method

Logs an error to the Tungsten Capture error log.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void LogError(
    int Err1,
    int Err2,
    int Err3,
    string ErrorMessage,
    string CodeModule,
    int LineNumber
)
Sub LogError (
    Err1 As Integer,
    Err2 As Integer,
    Err3 As Integer,
    ErrorMessage As String,
    CodeModule As String,
    LineNumber As Integer
)

Parameters

Err1
Type: SystemInt32
The primary error code.
Err2
Type: SystemInt32
Subcode.
Err3
Type: SystemInt32
Subcode.
ErrorMessage
Type: SystemString
The string message.
CodeModule
Type: SystemString
The source code module where the problem occurred.
LineNumber
Type: SystemInt32
The line number within the source where the error occurred.
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.SelectMenuItem Method

IAdminApplicationSelectMenuItem Method

Selects a menu item.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SelectMenuItem(
    int lResourceID,
    bool bSendImmediate = false
)
Function SelectMenuItem (
    lResourceID As Integer,
    Optional bSendImmediate As Boolean = false
) As Boolean

Parameters

lResourceID
Type: SystemInt32
The menu item from the enumeration KfxAdminMenuItems.
bSendImmediate (Optional)
Type: SystemBoolean
When True, internally calls the Windows SendMessage API. False calls the Windows PostMessage API. Refer to your Microsoft documentation for more information.

Return Value

Type: Boolean
Boolean - Returns False if the menu could not be selected.
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ShowMenu Method

IAdminApplicationShowMenu Method

Shows or hides a menu.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void ShowMenu(
    KfxShowMenu eState,
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = ""
)
Sub ShowMenu (
    eState As KfxShowMenu,
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = ""
)

Parameters

eState
Type: Kofax.Capture.AdminModule.InteropServicesKfxShowMenu
If KfxMenuShow, the specified menu will be shown. If KfxMenuHide, the specified menu will be hidden.

The last four parameters specify the menu to show/hide, and should match the values passed to the AddMenu method (if that was how the menu was created).
strEventText
Type: SystemString
The internal name of the menu item.
strMenuText
Type: SystemString
The display name of the menu item.
strMenuLocation
Type: SystemString
Specifies the location of the menu (see AddMenu method).
strMenuBarText (Optional)
Type: SystemString
The main frame menu the item is under.
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ShowWindow Method

IAdminApplicationShowWindow Method

Shows or hides a panel.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool ShowWindow(
    bool Show
)
Function ShowWindow (
    Show As Boolean
) As Boolean

Parameters

Show
Type: SystemBoolean
IfTrue (non-zero), the panel is shown. If False (zero) the panel is hidden.

Return Value

Type: Boolean
Boolean
Remarks
A return value ofTrue (success) indicates completion of the function. If the panel is already in the requested state, the return value will be False.
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication Properties

IAdminApplication Properties

The IAdminApplication type exposes the following members.

Properties
 | Name | Description
Public property | ActiveBatchClass | Returns the currently selected batch class.
Public property | ActiveDocumentClass | Returns the currently selected document class.
Public property | ActiveFieldType | Returns the currently selected field type.
Public property | ActiveFolderClass | Returns the currently active folder class or nothing.
Public property | ActiveFormIdZone | Returns the currently selected form ID zone.
Public property | ActiveFormIdZoneColl | Collection object for Form ID Zones.
Public property | ActiveFormType | Returns the currently selected form type.
Public property | ActiveIndexGroupZone | Returns the currently selected index group zone.
Public property | ActiveIndexGrpMemZone | Returns the currently selected group member zone.
Public property | ActiveIndexZone | Returns the currently selected index zone.
Public property | ActiveIndexZoneColl | Returns the currently selected collection of index zones.
Public property | ActiveObjectType | Returns the type of the currently selected node or nothing.
Public property | ActivePageLevelBarcode | Returns the currently selected page level bar code.
Public property | ActivePageLevelBarcodeColl | Returns the currently selected collection of page level bar codes.
Public property | ActiveRegistrationZone | Returns the currently selected registration zone.
Public property | ActiveRegZoneColl | Returns the currently selected collection of registration zones.
Public property | ActiveSamplePage | Returns the currently selected sample page.
Public property | ActiveSeparationZone | Returns the currently selected separation zone.
Public property | ActiveTabPanel | Returns the tab displayed in the Definitions panel.
Public property | BatchClasses | Collection of batch classes.
Public property | DisableFieldEvents | Diable sending field change events from the current custom administration panel.
Public property | DocumentClasses | Collection of document classes.
Public property | FieldTypes | Collection of field types.
Public property | FolderClasses | Collection of system-wide folder classes.
Public property | Groups | Collection of available groups.
Public property | IsUserTrackingEnabled | Indicates if user tracking is enabled for Tungsten Capture system
Public property | ModuleID | The Module ID is a unique identifier for the corresponding custom module.
Public property | Queues | Collection of available queues (modules).
Public property | RecognitionProfs | Collection of recognition profiles.
Public property | RemoteSiteProfileNames | Collection of Remote site profile names.
Public property | RemoteSites | Collection of available remote sites.
Public property | SepAndFormIDProfs | Collection of Separation and Form ID profiles.
Public property | ServicePackVersion | Currently installed service pack.
Public property | Theme | Gets the current theme that is being used in Tungsten Capture system.
Public property | Users | Collection of available users.
Top
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveBatchClass Property

IAdminApplicationActiveBatchClass Property

Returns the currently selected batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchClass ActiveBatchClass { get; }
ReadOnly Property ActiveBatchClass As IBatchClass
    Get

Property Value

Type: IBatchClass
The currently active batch class or nothing.

Return Value

Type: IBatchClass
IBatchClass
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveDocumentClass Property

IAdminApplicationActiveDocumentClass Property

Returns the currently selected document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocumentClass ActiveDocumentClass { get; }
ReadOnly Property ActiveDocumentClass As IDocumentClass
    Get

Property Value

Type: IDocumentClass
The currently active document class or nothing.

Return Value

Type: IDocumentClass
IDocumentClass
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveFieldType Property

IAdminApplicationActiveFieldType Property

Returns the currently selected field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFieldType ActiveFieldType { get; }
ReadOnly Property ActiveFieldType As IFieldType
    Get

Property Value

Type: IFieldType

Return Value

Type: IFieldType
IFieldType
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveFolderClass Property

IAdminApplicationActiveFolderClass Property

Returns the currently active folder class or nothing.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolderClass ActiveFolderClass { get; }
ReadOnly Property ActiveFolderClass As IFolderClass
    Get

Property Value

Type: IFolderClass
The currently active folder class or nothing.

Return Value

Type: IFolderClass
IFolderClass
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveFormIdZone Property

IAdminApplicationActiveFormIdZone Property

Returns the currently selected form ID zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFormIdZone ActiveFormIdZone { get; }
ReadOnly Property ActiveFormIdZone As IFormIdZone
    Get

Property Value

Type: IFormIdZone

Return Value

Type: IFormIdZone
IFormIdZone
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveFormIdZoneColl Property

IAdminApplicationActiveFormIdZoneColl Property

Collection object for Form ID Zones.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFormIdZoneColl ActiveFormIdZoneColl { get; }
ReadOnly Property ActiveFormIdZoneColl As IFormIdZoneColl
    Get

Property Value

Type: IFormIdZoneColl

Return Value

Type: IFormIdZoneColl
IFormIdZoneColl
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveFormType Property

IAdminApplicationActiveFormType Property

Returns the currently selected form type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFormType ActiveFormType { get; }
ReadOnly Property ActiveFormType As IFormType
    Get

Property Value

Type: IFormType

Return Value

Type: IFormType
IFormType
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveIndexGroupZone Property

IAdminApplicationActiveIndexGroupZone Property

Returns the currently selected index group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexGroupZone ActiveIndexGroupZone { get; }
ReadOnly Property ActiveIndexGroupZone As IIndexGroupZone
    Get

Property Value

Type: IIndexGroupZone

Return Value

Type: IIndexGroupZone
IIndexGroupZone
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveIndexGrpMemZone Property

IAdminApplicationActiveIndexGrpMemZone Property

Returns the currently selected group member zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexGrpMemZone ActiveIndexGrpMemZone { get; }
ReadOnly Property ActiveIndexGrpMemZone As IIndexGrpMemZone
    Get

Property Value

Type: IIndexGrpMemZone

Return Value

Type: IIndexGrpMemZone
IIndexGrpMemZone
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveIndexZone Property

IAdminApplicationActiveIndexZone Property

Returns the currently selected index zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexZone ActiveIndexZone { get; }
ReadOnly Property ActiveIndexZone As IIndexZone
    Get

Property Value

Type: IIndexZone

Return Value

Type: IIndexZone
IIndexZone
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveIndexZoneColl Property

IAdminApplicationActiveIndexZoneColl Property

Returns the currently selected collection of index zones.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexZones ActiveIndexZoneColl { get; }
ReadOnly Property ActiveIndexZoneColl As IIndexZones
    Get

Property Value

Type: IIndexZones

Return Value

Type: IIndexZones
IIndexZones
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveObjectType Property

IAdminApplicationActiveObjectType Property

Returns the type of the currently selected node or nothing.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
KfxApiAdminObjectType ActiveObjectType { get; }
ReadOnly Property ActiveObjectType As KfxApiAdminObjectType
    Get

Property Value

Type: KfxApiAdminObjectType

Return Value

Type: KfxApiAdminObjectType
KfxApiAdminObjectType
Remarks

If no node is selected, Nothing is returned. Otherwise, one of the following is returned:

  • KfxAdminObjectTypeDocumentClass
  • KfxAdminObjectTypeFieldType
  • KfxAdminObjectTypeFormIdZone
  • KfxAdminObjectTypeFormType
  • KfxAdminObjectTypeIndexGroupMemberZone
  • KfxAdminObjectTypeIndexGroupZone
  • KfxAdminObjectTypeIndexZone
  • KfxAdminObjectTypeIndexZones
  • KfxAdminObjectTypePageLevelBarcode
  • KfxAdminObjectTypePageLevelBarcodes
  • KfxAdminObjectTypeRegistrationZone
  • KfxAdminObjectTypeRegistrationZones
  • KfxAdminObjectTypeSamplePage
  • KfxAdminObjectTypeSeparationZone

See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActivePageLevelBarcode Property

IAdminApplicationActivePageLevelBarcode Property

Returns the currently selected page level bar code.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPageLevelBarcode ActivePageLevelBarcode { get; }
ReadOnly Property ActivePageLevelBarcode As IPageLevelBarcode
    Get

Property Value

Type: IPageLevelBarcode

Return Value

Type: IPageLevelBarcode
IPageLevelBarcode
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActivePageLevelBarcodeColl Property

IAdminApplicationActivePageLevelBarcodeColl Property

Returns the currently selected collection of page level bar codes.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPgLvlBarcodeColl ActivePageLevelBarcodeColl { get; }
ReadOnly Property ActivePageLevelBarcodeColl As IPgLvlBarcodeColl
    Get

Property Value

Type: IPgLvlBarcodeColl

Return Value

Type: IPgLvlBarcodeColl
IPgLvlBarcodeColl
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveRegistrationZone Property

IAdminApplicationActiveRegistrationZone Property

Returns the currently selected registration zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRegistrationZone ActiveRegistrationZone { get; }
ReadOnly Property ActiveRegistrationZone As IRegistrationZone
    Get

Property Value

Type: IRegistrationZone

Return Value

Type: IRegistrationZone
IRegistrationZone
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveRegZoneColl Property

IAdminApplicationActiveRegZoneColl Property

Returns the currently selected collection of registration zones.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRegZoneColl ActiveRegZoneColl { get; }
ReadOnly Property ActiveRegZoneColl As IRegZoneColl
    Get

Property Value

Type: IRegZoneColl

Return Value

Type: IRegZoneColl
IRegZoneColl
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveSamplePage Property

IAdminApplicationActiveSamplePage Property

Returns the currently selected sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ISamplePage ActiveSamplePage { get; }
ReadOnly Property ActiveSamplePage As ISamplePage
    Get

Property Value

Type: ISamplePage

Return Value

Type: ISamplePage
ISamplePage
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveSeparationZone Property

IAdminApplicationActiveSeparationZone Property

Returns the currently selected separation zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ISeparationZone ActiveSeparationZone { get; }
ReadOnly Property ActiveSeparationZone As ISeparationZone
    Get

Property Value

Type: ISeparationZone

Return Value

Type: ISeparationZone
ISeparationZone
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ActiveTabPanel Property

IAdminApplicationActiveTabPanel Property

Returns the tab displayed in the Definitions panel.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
KfxApiAdminTabPanel ActiveTabPanel { get; }
ReadOnly Property ActiveTabPanel As KfxApiAdminTabPanel
    Get

Property Value

Type: KfxApiAdminTabPanel

Return Value

Type: KfxApiAdminTabPanel
KfxApiAdminTabPanel
Remarks

One of the following is returned:

  • KfxAdminPanelBatchClass
  • KfxAdminPanelDocumentClass
  • KfxAdminPanelFieldType

See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.BatchClasses Property

IAdminApplicationBatchClasses Property

Collection of batch classes.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchClasses BatchClasses { get; }
ReadOnly Property BatchClasses As IBatchClasses
    Get

Property Value

Type: IBatchClasses

Return Value

Type: IBatchClasses
IBatchClasses
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.DisableFieldEvents Property

IAdminApplicationDisableFieldEvents Property

Diable sending field change events from the current custom administration panel.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool DisableFieldEvents { get; set; }
Property DisableFieldEvents As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Value of DisableFieldEvents.
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.DocumentClasses Property

IAdminApplicationDocumentClasses Property

Collection of document classes.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocumentClasses DocumentClasses { get; }
ReadOnly Property DocumentClasses As IDocumentClasses
    Get

Property Value

Type: IDocumentClasses

Return Value

Type: IDocumentClasses
IDocumentClasses
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.FieldTypes Property

IAdminApplicationFieldTypes Property

Collection of field types.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFieldTypes FieldTypes { get; }
ReadOnly Property FieldTypes As IFieldTypes
    Get

Property Value

Type: IFieldTypes

Return Value

Type: IFieldTypes
IFieldTypes
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.FolderClasses Property

IAdminApplicationFolderClasses Property

Collection of system-wide folder classes.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolderClasses FolderClasses { get; }
ReadOnly Property FolderClasses As IFolderClasses
    Get

Property Value

Type: IFolderClasses

Return Value

Type: IFolderClasses
IFolderClasses
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.Groups Property

IAdminApplicationGroups Property

Collection of available groups.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IGroups Groups { get; }
ReadOnly Property Groups As IGroups
    Get

Property Value

Type: IGroups

Return Value

Type: IGroups
IGroups
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.IsUserTrackingEnabled Property

IAdminApplicationIsUserTrackingEnabled Property

Indicates if user tracking is enabled for Tungsten Capture system

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool IsUserTrackingEnabled { get; }
ReadOnly Property IsUserTrackingEnabled As Boolean
    Get

Return Value

Type: Boolean
Boolean
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ModuleID Property

IAdminApplicationModuleID Property

The Module ID is a unique identifier for the corresponding custom module.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ModuleID { get; }
ReadOnly Property ModuleID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks

Each custom module defines its Module ID in the .aex file.

If this property is used from an OCX that is not bound to a custom module, then the property returns an empty string.

Even though shared OCX instances may share the same code, each one can determine its uniqueness by checking the ModuleID property.

See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.Queues Property

IAdminApplicationQueues Property

Collection of available queues (modules).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IQueues Queues { get; }
ReadOnly Property Queues As IQueues
    Get

Property Value

Type: IQueues

Return Value

Type: IQueues
IQueues
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.RecognitionProfs Property

IAdminApplicationRecognitionProfs Property

Collection of recognition profiles.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRecognitionProfs RecognitionProfs { get; }
ReadOnly Property RecognitionProfs As IRecognitionProfs
    Get

Property Value

Type: IRecognitionProfs

Return Value

Type: IRecognitionProfs
IRecognitionProfs
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.RemoteSiteProfileNames Property

IAdminApplicationRemoteSiteProfileNames Property

Collection of Remote site profile names.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IKfxCollection RemoteSiteProfileNames { get; }
ReadOnly Property RemoteSiteProfileNames As IKfxCollection
    Get

Property Value

Type: IKfxCollection

Return Value

Type: IKfxCollection
Collection.IKfxCollection
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.RemoteSites Property

IAdminApplicationRemoteSites Property

Collection of available remote sites.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRemoteSites RemoteSites { get; }
ReadOnly Property RemoteSites As IRemoteSites
    Get

Property Value

Type: IRemoteSites

Return Value

Type: IRemoteSites
IRemoteSites
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.SepAndFormIDProfs Property

IAdminApplicationSepAndFormIDProfs Property

Collection of Separation and Form ID profiles.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ISepAndFormIDProfs SepAndFormIDProfs { get; }
ReadOnly Property SepAndFormIDProfs As ISepAndFormIDProfs
    Get

Property Value

Type: ISepAndFormIDProfs

Return Value

Type: ISepAndFormIDProfs
ISepAndFormIDProfs
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.ServicePackVersion Property

IAdminApplicationServicePackVersion Property

Currently installed service pack.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
short ServicePackVersion { get; }
ReadOnly Property ServicePackVersion As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.Theme Property

IAdminApplicationTheme Property

Gets the current theme that is being used in Tungsten Capture system.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ITheme Theme { get; }
ReadOnly Property Theme As ITheme
    Get

Property Value

Type: ITheme

Return Value

Type: ITheme
ITheme
Remarks
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminApplication.Users Property

IAdminApplicationUsers Property

Collection of available users.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IUsers Users { get; }
ReadOnly Property Users As IUsers
    Get

Property Value

Type: IUsers

Return Value

Type: IUsers
IUsers
See Also

Reference

IAdminApplication Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminLogin Interface

IAdminLogin Interface

IAdminLogin COM interface.

Defines a COM object that coordinates logging in and logging out of Tungsten Capture. This is the only object that can be created using New or CreateObject in Visual Basic.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB612-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IAdminLogin
<ComVisibleAttribute(true)>
<GuidAttribute("646AB612-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IAdminLogin

The IAdminLogin type exposes the following members.

Methods
 | Name | Description
Public method | Login | Starts a session with Tungsten Capture and then sets the ActiveApplication property.
Public method | Logout | Ends the session with Tungsten Capture.
Top
Properties
 | Name | Description
Public property | ActiveApplication | Returns the instance of the current application.
Public property | RequiresLogin | If True, a UserID and password must be supplied for a Tungsten Capture login.
Public property | SharedUserProfileModel | Gets or sets the shared profile model. If True, the user privileges are shared across all processes on the computer.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IAdminLogin Methods

IAdminLogin Methods

The IAdminLogin type exposes the following members.

Methods
 | Name | Description
Public method | Login | Starts a session with Tungsten Capture and then sets the ActiveApplication property.
Public method | Logout | Ends the session with Tungsten Capture.
Top
See Also

Reference

IAdminLogin Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminLogin.Login Method

IAdminLoginLogin Method

Starts a session with Tungsten Capture and then sets the ActiveApplication property.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IAdminApplication Login(
    string UserID,
    string UserPwd
)
Function Login (
    UserID As String,
    UserPwd As String
) As IAdminApplication

Parameters

UserID
Type: SystemString
The User ID.
UserPwd
Type: SystemString
The User password.

Return Value

Type: IAdminApplication
Remarks

Returns ActiveApplication.

To hinder attempts to determine the password, after a set of three KfxApiErrInvalidLogin errors, the method waits ten seconds before returning the ActiveApplication. If the AdminLogin is already logged in, this method automatically logs out and back in. The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.

See Also

Reference

IAdminLogin Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminLogin.Logout Method

IAdminLoginLogout Method

Ends the session with Tungsten Capture.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Logout()
Sub Logout
Remarks
ActiveApplication is made invalid.
Be sure to call Logout method when your application is terminating.
See Also

Reference

IAdminLogin Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminLogin Properties

IAdminLogin Properties

The IAdminLogin type exposes the following members.

Properties
 | Name | Description
Public property | ActiveApplication | Returns the instance of the current application.
Public property | RequiresLogin | If True, a UserID and password must be supplied for a Tungsten Capture login.
Public property | SharedUserProfileModel | Gets or sets the shared profile model. If True, the user privileges are shared across all processes on the computer.
Top
See Also

Reference

IAdminLogin Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminLogin.ActiveApplication Property

IAdminLoginActiveApplication Property

Returns the instance of the current application.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IAdminApplication ActiveApplication { get; }
ReadOnly Property ActiveApplication As IAdminApplication
    Get

Property Value

Type: IAdminApplication

Return Value

Type: IAdminApplication
Remarks
If you are not logged in, then it returns Nothing.
See Also

Reference

IAdminLogin Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminLogin.RequiresLogin Property

IAdminLoginRequiresLogin Property

If True, a UserID and password must be supplied for a Tungsten Capture login.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool RequiresLogin { get; }
ReadOnly Property RequiresLogin As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

This returns True if user profiles have been enabled in Administration, or if you are using a shared user profile model and some other application is already connected.

Even when this property returns False, the caller must still call the Login method, but it may pass empty strings for the parameters.

See Also

Reference

IAdminLogin Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IAdminLogin.SharedUserProfileModel Property

IAdminLoginSharedUserProfileModel Property

Gets or sets the shared profile model. If True, the user privileges are shared across all processes on the computer.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SharedUserProfileModel { get; set; }
Property SharedUserProfileModel As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
Defaults is False. Note that this default is different than the default for interactive Tungsten Capture applications.
See Also

Reference

IAdminLogin Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass Interface

IBatchClass Interface

IBatchClass COM Interface.

Defines information about a batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638CFFF5-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IBatchClass
<ComVisibleAttribute(true)>
<GuidAttribute("638CFFF5-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IBatchClass

The IBatchClass type exposes the following members.

Methods
 | Name | Description
Public method | AssignGroups | Assigns the specified groups to the batch class.
Public method | AssignQueue | Assigns the specified queue to the batch class.
Public method | AssignQueueDefaultOrder | Assigns the specified queue to the batch class.
Public method | AssignRemoteSiteProfile | Assigns the specified groups to the batch class.
Public method | AssignUsers | Assigns the specified users to the batch class.
Public method | CreateBatchField | Creates a new batch field associated with the batch class.
Public method | CustomDataFolder | Returns a custom data path based on the batch class and the provided module ID.
Public method | DeleteBatchField | Deletes an existing batch field.
Public method | ExportClassDefinition | An XML file representing the current batch class definition will be written to the file strFileName.
Public method | GetReleaseSetupData | Returns a ReleaseSetupData object in Object type based on the document class and the provided export connector name.
Public method | InsertDocumentClass | Inserts an existing document class into the batch class.
Public method | InsertFolderClass | Inserts an existing folder class into the batch class.
Public method | IsInvokeWFAOnBatchDelete | Returns true if strWorkflowAgentId was added to the batch class and the WFAOnBatchDelete of that WFA is true. Otherwise it return false.
Public method | Publish | Attempts to publish the batch class.
Public method | RemoveAssignedQueue | Removes the assigned queue from the batch class.
Public method | RemoveDocumentClass | Removes an existing document class from the batch class.
Public method | RemoveFolderClass | Removes an existing folder class from the batch class.
Public method | UnassignGroups | Assigns the specified groups to the batch class.
Public method | UnassignRemoteSiteProfile | Unassigns the specified groups to the batch class.
Public method | UnassignUsers | Unassigns the specified users to the batch class.
Public method | UnPublish | Disables the batch class.
Top
Properties
 | Name | Description
Public property | AssignedGroups | The collection of groups assigned to this batch class.
Public property | AssignedQueues | The collection of queues in the work flow for this batch class.
Public property | AssignedRemoteSiteProfiles | The collection of remote site profiles assigned to this batch class.
Public property | AssignedUsers | The collection of users assigned to this batch class.
Public property | BatchFields | The batch fields assigned to this batch class.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Batch class description.
Public property | DocumentClasses | Collection of document classes that are assigned to the batch class.
Public property | FolderClasses | Collection of the folder classes that are assigned to the batch class.
Public property | ImageFolder | The image folder used to store temporary images; not to be confused with the image folder used to export images.
Public property | Name | Batch class name.
Public property | NonImageFileSupport | True if non-image files are supported for this batch class.
Public property | Priority | The default priority for batches created from this batch class.
Public property | PublishErrors | Collection of strings, one for each error from the previous Publish operation.
Public property | PublishStatus | Returns True if the previous Publish operation was successful.
Public property | PublishWarnings | Collection of strings, one for each warning from the previous Publish operation.
Public property | QueueProperties | Collection of batch class custom properties for this custom extension.
Public property | SepAndFormIDProf | The separation and form identification profile for this batch class.
Public property | SingleDocProcessing | If True, an individual batch is created for each new document.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass Methods

IBatchClass Methods

The IBatchClass type exposes the following members.

Methods
 | Name | Description
Public method | AssignGroups | Assigns the specified groups to the batch class.
Public method | AssignQueue | Assigns the specified queue to the batch class.
Public method | AssignQueueDefaultOrder | Assigns the specified queue to the batch class.
Public method | AssignRemoteSiteProfile | Assigns the specified groups to the batch class.
Public method | AssignUsers | Assigns the specified users to the batch class.
Public method | CreateBatchField | Creates a new batch field associated with the batch class.
Public method | CustomDataFolder | Returns a custom data path based on the batch class and the provided module ID.
Public method | DeleteBatchField | Deletes an existing batch field.
Public method | ExportClassDefinition | An XML file representing the current batch class definition will be written to the file strFileName.
Public method | GetReleaseSetupData | Returns a ReleaseSetupData object in Object type based on the document class and the provided export connector name.
Public method | InsertDocumentClass | Inserts an existing document class into the batch class.
Public method | InsertFolderClass | Inserts an existing folder class into the batch class.
Public method | IsInvokeWFAOnBatchDelete | Returns true if strWorkflowAgentId was added to the batch class and the WFAOnBatchDelete of that WFA is true. Otherwise it return false.
Public method | Publish | Attempts to publish the batch class.
Public method | RemoveAssignedQueue | Removes the assigned queue from the batch class.
Public method | RemoveDocumentClass | Removes an existing document class from the batch class.
Public method | RemoveFolderClass | Removes an existing folder class from the batch class.
Public method | UnassignGroups | Assigns the specified groups to the batch class.
Public method | UnassignRemoteSiteProfile | Unassigns the specified groups to the batch class.
Public method | UnassignUsers | Unassigns the specified users to the batch class.
Public method | UnPublish | Disables the batch class.
Top
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.AssignGroups Method

IBatchClassAssignGroups Method

Assigns the specified groups to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void AssignGroups(
    IKfxCollection oNames
)
Sub AssignGroups (
    oNames As IKfxCollection
)

Parameters

oNames
Type: IKfxCollection
List of group names would be assigned to batch class. If oNames is empty or nothing, all available groups will be assigned to batch class.
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.AssignQueue Method

IBatchClassAssignQueue Method

Assigns the specified queue to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void AssignQueue(
    ref IQueue oQueue,
    ref IQueue oPrevQueue
)
Sub AssignQueue (
    ByRef oQueue As IQueue,
    ByRef oPrevQueue As IQueue
)

Parameters

oQueue
Type: Kofax.Capture.AdminModule.InteropServicesIQueue
The queue to insert.
oPrevQueue
Type: Kofax.Capture.AdminModule.InteropServicesIQueue
The new queue is inserted after oPrevQueue. If oPrevQueue is Nothing, then it is added as the first item in the workflow.
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.AssignQueueDefaultOrder Method

IBatchClassAssignQueueDefaultOrder Method

Assigns the specified queue to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void AssignQueueDefaultOrder(
    ref IQueue oQueue
)
Sub AssignQueueDefaultOrder (
    ByRef oQueue As IQueue
)

Parameters

oQueue
Type: Kofax.Capture.AdminModule.InteropServicesIQueue
The queue to insert.
Remarks
The location in the workflow is the same as the default location when adding interactively.
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.AssignRemoteSiteProfile Method

IBatchClassAssignRemoteSiteProfile Method

Assigns the specified groups to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void AssignRemoteSiteProfile(
    string strRSProfileName
)
Sub AssignRemoteSiteProfile (
    strRSProfileName As String
)

Parameters

strRSProfileName
Type: SystemString
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.AssignUsers Method

IBatchClassAssignUsers Method

Assigns the specified users to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void AssignUsers(
    IKfxCollection oNames
)
Sub AssignUsers (
    oNames As IKfxCollection
)

Parameters

oNames
Type: IKfxCollection
List of user names would be assigned to batch class. If oNames is empty or nothing, all available users will be assigned to batch class.
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.CreateBatchField Method

IBatchClassCreateBatchField Method

Creates a new batch field associated with the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void CreateBatchField(
    ref string strName,
    ref IFieldType oFieldType
)
Sub CreateBatchField (
    ByRef strName As String,
    ByRef oFieldType As IFieldType
)

Parameters

strName
Type: SystemString
The name of the new batch field.
oFieldType
Type: Kofax.Capture.AdminModule.InteropServicesIFieldType
The type of the field.
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.CustomDataFolder Method

IBatchClassCustomDataFolder Method

Returns a custom data path based on the batch class and the provided module ID.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string CustomDataFolder(
    ref string strModuleID
)
Function CustomDataFolder (
    ByRef strModuleID As String
) As String

Parameters

strModuleID
Type: SystemString
The subfolder to be used as a custom data storage folder.

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.DeleteBatchField Method

IBatchClassDeleteBatchField Method

Deletes an existing batch field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteBatchField(
    ref IBatchField oBatchField
)
Sub DeleteBatchField (
    ByRef oBatchField As IBatchField
)

Parameters

oBatchField
Type: Kofax.Capture.AdminModule.InteropServicesIBatchField
The batch field to delete.
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.ExportClassDefinition Method

IBatchClassExportClassDefinition Method

An XML file representing the current batch class definition will be written to the file strFileName.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool ExportClassDefinition(
    string strFileName
)
Function ExportClassDefinition (
    strFileName As String
) As Boolean

Parameters

strFileName
Type: SystemString
The full path and file name to the output XML.

Return Value

Type: Boolean
Boolean
Remarks
This function call may be slow.
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.GetReleaseSetupData Method

IBatchClassGetReleaseSetupData Method

Returns a ReleaseSetupData object in Object type based on the document class and the provided export connector name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IKfxCollection GetReleaseSetupData(
    ref string strDocumentClassName
)
Function GetReleaseSetupData (
    ByRef strDocumentClassName As String
) As IKfxCollection

Parameters

strDocumentClassName
Type: SystemString

Return Value

Type: IKfxCollection
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.InsertDocumentClass Method

IBatchClassInsertDocumentClass Method

Inserts an existing document class into the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void InsertDocumentClass(
    ref IDocumentClass oDocClass
)
Sub InsertDocumentClass (
    ByRef oDocClass As IDocumentClass
)

Parameters

oDocClass
Type: Kofax.Capture.AdminModule.InteropServicesIDocumentClass
The document class to insert.
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.InsertFolderClass Method

IBatchClassInsertFolderClass Method

Inserts an existing folder class into the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void InsertFolderClass(
    ref IFolderClass oFolderClass
)
Sub InsertFolderClass (
    ByRef oFolderClass As IFolderClass
)

Parameters

oFolderClass
Type: Kofax.Capture.AdminModule.InteropServicesIFolderClass
The folder class to insert.
Remarks

This function throws:

(KfxApiErrAppIsBusy) if the application is in the middle of a user event.

(KfxApiErrDuplicateObject) duplicate folder class.

See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.IsInvokeWFAOnBatchDelete Method

IBatchClassIsInvokeWFAOnBatchDelete Method

Returns true if strWorkflowAgentId was added to the batch class and the WFAOnBatchDelete of that WFA is true. Otherwise it return false.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool IsInvokeWFAOnBatchDelete(
    string strWorkflowAgentId
)
Function IsInvokeWFAOnBatchDelete (
    strWorkflowAgentId As String
) As Boolean

Parameters

strWorkflowAgentId
Type: SystemString
Id of workflow agent.

Return Value

Type: Boolean
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.Publish Method

IBatchClassPublish Method

Attempts to publish the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Publish()
Sub Publish
Remarks
Information on the results of this operation are available from other properties (PublishErrors, PublishStats, and PublishWarnings).
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.RemoveAssignedQueue Method

IBatchClassRemoveAssignedQueue Method

Removes the assigned queue from the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void RemoveAssignedQueue(
    ref IQueue oQueue
)
Sub RemoveAssignedQueue (
    ByRef oQueue As IQueue
)

Parameters

oQueue
Type: Kofax.Capture.AdminModule.InteropServicesIQueue
The queue to remove.
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.RemoveDocumentClass Method

IBatchClassRemoveDocumentClass Method

Removes an existing document class from the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void RemoveDocumentClass(
    ref IDocumentClass oDocClass
)
Sub RemoveDocumentClass (
    ByRef oDocClass As IDocumentClass
)

Parameters

oDocClass
Type: Kofax.Capture.AdminModule.InteropServicesIDocumentClass
The document class to remove.
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.RemoveFolderClass Method

IBatchClassRemoveFolderClass Method

Removes an existing folder class from the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void RemoveFolderClass(
    ref IFolderClass oFolderClass
)
Sub RemoveFolderClass (
    ByRef oFolderClass As IFolderClass
)

Parameters

oFolderClass
Type: Kofax.Capture.AdminModule.InteropServicesIFolderClass
The folder class to remove.
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.UnassignGroups Method

IBatchClassUnassignGroups Method

Assigns the specified groups to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void UnassignGroups(
    IKfxCollection oNames
)
Sub UnassignGroups (
    oNames As IKfxCollection
)

Parameters

oNames
Type: IKfxCollection
List of user names would be assigned to batch class. If oNames is empty or nothing, all available groups will be unassigned to batch class.
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.UnassignRemoteSiteProfile Method

IBatchClassUnassignRemoteSiteProfile Method

Unassigns the specified groups to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void UnassignRemoteSiteProfile(
    string strRSProfileName
)
Sub UnassignRemoteSiteProfile (
    strRSProfileName As String
)

Parameters

strRSProfileName
Type: SystemString
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.UnassignUsers Method

IBatchClassUnassignUsers Method

Unassigns the specified users to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void UnassignUsers(
    IKfxCollection oNames
)
Sub UnassignUsers (
    oNames As IKfxCollection
)

Parameters

oNames
Type: IKfxCollection
List of user names would be assigned to batch class. If oNames is empty or nothing, all available users will be unassigned to batch class.
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.UnPublish Method

IBatchClassUnPublish Method

Disables the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void UnPublish()
Sub UnPublish
Remarks
No error if the batch was not already published.
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass Properties

IBatchClass Properties

The IBatchClass type exposes the following members.

Properties
 | Name | Description
Public property | AssignedGroups | The collection of groups assigned to this batch class.
Public property | AssignedQueues | The collection of queues in the work flow for this batch class.
Public property | AssignedRemoteSiteProfiles | The collection of remote site profiles assigned to this batch class.
Public property | AssignedUsers | The collection of users assigned to this batch class.
Public property | BatchFields | The batch fields assigned to this batch class.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Batch class description.
Public property | DocumentClasses | Collection of document classes that are assigned to the batch class.
Public property | FolderClasses | Collection of the folder classes that are assigned to the batch class.
Public property | ImageFolder | The image folder used to store temporary images; not to be confused with the image folder used to export images.
Public property | Name | Batch class name.
Public property | NonImageFileSupport | True if non-image files are supported for this batch class.
Public property | Priority | The default priority for batches created from this batch class.
Public property | PublishErrors | Collection of strings, one for each error from the previous Publish operation.
Public property | PublishStatus | Returns True if the previous Publish operation was successful.
Public property | PublishWarnings | Collection of strings, one for each warning from the previous Publish operation.
Public property | QueueProperties | Collection of batch class custom properties for this custom extension.
Public property | SepAndFormIDProf | The separation and form identification profile for this batch class.
Public property | SingleDocProcessing | If True, an individual batch is created for each new document.
Top
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.AssignedGroups Property

IBatchClassAssignedGroups Property

The collection of groups assigned to this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IGroups AssignedGroups { get; }
ReadOnly Property AssignedGroups As IGroups
    Get

Property Value

Type: IGroups

Return Value

Type: IGroups
IGroups
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.AssignedQueues Property

IBatchClassAssignedQueues Property

The collection of queues in the work flow for this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IQueues AssignedQueues { get; }
ReadOnly Property AssignedQueues As IQueues
    Get

Property Value

Type: IQueues

Return Value

Type: IQueues
IQueues
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.AssignedRemoteSiteProfiles Property

IBatchClassAssignedRemoteSiteProfiles Property

The collection of remote site profiles assigned to this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IKfxCollection AssignedRemoteSiteProfiles { get; }
ReadOnly Property AssignedRemoteSiteProfiles As IKfxCollection
    Get

Property Value

Type: IKfxCollection

Return Value

Type: IKfxCollection
IGroups
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.AssignedUsers Property

IBatchClassAssignedUsers Property

The collection of users assigned to this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IUsers AssignedUsers { get; }
ReadOnly Property AssignedUsers As IUsers
    Get

Property Value

Type: IUsers

Return Value

Type: IUsers
IUsers
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.BatchFields Property

IBatchClassBatchFields Property

The batch fields assigned to this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchFields BatchFields { get; }
ReadOnly Property BatchFields As IBatchFields
    Get

Property Value

Type: IBatchFields

Return Value

Type: IBatchFields
IBatchFields
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.CustomStorageString Property

IBatchClassCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the batch class.

Property Value

Type: String

Return Value

Type: String
String
Remarks
Custom Storage strings are custom text strings that are bound to a specific batch class. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.Description Property

IBatchClassDescription Property

Batch class description.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; set; }
Property Description As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.DocumentClasses Property

IBatchClassDocumentClasses Property

Collection of document classes that are assigned to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocumentClasses DocumentClasses { get; }
ReadOnly Property DocumentClasses As IDocumentClasses
    Get

Property Value

Type: IDocumentClasses

Return Value

Type: IDocumentClasses
IDocumentClasses
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.FolderClasses Property

IBatchClassFolderClasses Property

Collection of the folder classes that are assigned to the batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolderClasses FolderClasses { get; }
ReadOnly Property FolderClasses As IFolderClasses
    Get

Property Value

Type: IFolderClasses

Return Value

Type: IFolderClasses
IFolderClasses
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.ImageFolder Property

IBatchClassImageFolder Property

The image folder used to store temporary images; not to be confused with the image folder used to export images.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ImageFolder { get; set; }
Property ImageFolder As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.Name Property

IBatchClassName Property

Batch class name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.NonImageFileSupport Property

IBatchClassNonImageFileSupport Property

True if non-image files are supported for this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool NonImageFileSupport { get; set; }
Property NonImageFileSupport As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.Priority Property

IBatchClassPriority Property

The default priority for batches created from this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Priority { get; set; }
Property Priority As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Long
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.PublishErrors Property

IBatchClassPublishErrors Property

Collection of strings, one for each error from the previous Publish operation.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IKfxCollection PublishErrors { get; }
ReadOnly Property PublishErrors As IKfxCollection
    Get

Property Value

Type: IKfxCollection

Return Value

Type: IKfxCollection
Kofax.Collection.IKfxCollection
Remarks
Empty if there were no warnings. Empty if there was not a previous call to Publish for this object instance.
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.PublishStatus Property

IBatchClassPublishStatus Property

Returns True if the previous Publish operation was successful.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool PublishStatus { get; }
ReadOnly Property PublishStatus As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
False if there was not a previous call to Publish for this object instance.
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.PublishWarnings Property

IBatchClassPublishWarnings Property

Collection of strings, one for each warning from the previous Publish operation.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IKfxCollection PublishWarnings { get; }
ReadOnly Property PublishWarnings As IKfxCollection
    Get

Property Value

Type: IKfxCollection

Return Value

Type: IKfxCollection
Kofax.Collection.IKfxCollection
Remarks
Empty if there were no warnings. Empty if there was not a previous call to Publish for this object instance.
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.QueueProperties Property

IBatchClassQueueProperties Property

Collection of batch class custom properties for this custom extension.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IQueueProperties QueueProperties { get; }
ReadOnly Property QueueProperties As IQueueProperties
    Get

Property Value

Type: IQueueProperties

Return Value

Type: IQueueProperties
IQueueProperties
Remarks
There is no "Set" for this property, but its contents can be changed by calling methods of the QueueProperties class.
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.SepAndFormIDProf Property

IBatchClassSepAndFormIDProf Property

The separation and form identification profile for this batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ISepAndFormIDProf SepAndFormIDProf { get; set; }
Property SepAndFormIDProf As ISepAndFormIDProf
    Get
    Set

Property Value

Type: ISepAndFormIDProf

Return Value

Type: ISepAndFormIDProf
ISepAndFormIDProf
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClass.SingleDocProcessing Property

IBatchClassSingleDocProcessing Property

If True, an individual batch is created for each new document.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SingleDocProcessing { get; set; }
Property SingleDocProcessing As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClasses Interface

IBatchClasses Interface

IBatchClasses COM Interface.

Defines a COM collection of BatchClass objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638CFFF7-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IBatchClasses
<ComVisibleAttribute(true)>
<GuidAttribute("638CFFF7-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IBatchClasses

The IBatchClasses type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of BatchClass objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
A BatchClass object is valid until it is deleted.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClasses Methods

IBatchClasses Methods

The IBatchClasses type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IBatchClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClasses.GetEnumerator Method

IBatchClassesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IBatchClasses object.
See Also

Reference

IBatchClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClasses Properties

IBatchClasses Properties

The IBatchClasses type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of BatchClass objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IBatchClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClasses.Count Property

IBatchClassesCount Property

Returns the number of BatchClass objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatchClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchClasses.Item Property

IBatchClassesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchClass this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IBatchClass
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IBatchClass

Return Value

Type: IBatchClass
IBatchClass
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IBatchClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchField Interface

IBatchField Interface

IBatchField COM Interface.

Defines information about a batch field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638CFFF9-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IBatchField
<ComVisibleAttribute(true)>
<GuidAttribute("638CFFF9-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IBatchField

The IBatchField type exposes the following members.

Properties
 | Name | Description
Public property | Default | The default value of the batch field.
Public property | DisplayLabel | Reads and writes the value of a supported batch field display label.
Public property | FieldType | The field type assigned to the batch field.
Public property | Hidden | Gets or sets Hidden property of BatchField.
Public property | Name | The batch field name.
Public property | Required | Gets or sets Required property of BatchField.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IBatchField Properties

IBatchField Properties

The IBatchField type exposes the following members.

Properties
 | Name | Description
Public property | Default | The default value of the batch field.
Public property | DisplayLabel | Reads and writes the value of a supported batch field display label.
Public property | FieldType | The field type assigned to the batch field.
Public property | Hidden | Gets or sets Hidden property of BatchField.
Public property | Name | The batch field name.
Public property | Required | Gets or sets Required property of BatchField.
Top
See Also

Reference

IBatchField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchField.Default Property

IBatchFieldDefault Property

The default value of the batch field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Default { get; set; }
Property Default As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchField.DisplayLabel Property

IBatchFieldDisplayLabel Property

Reads and writes the value of a supported batch field display label.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string DisplayLabel { get; set; }
Property DisplayLabel As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchField.FieldType Property

IBatchFieldFieldType Property

The field type assigned to the batch field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFieldType FieldType { get; set; }
Property FieldType As IFieldType
    Get
    Set

Property Value

Type: IFieldType

Return Value

Type: IFieldType
IFieldType
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchField.Hidden Property

IBatchFieldHidden Property

Gets or sets Hidden property of BatchField.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Hidden { get; set; }
Property Hidden As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchField.Name Property

IBatchFieldName Property

The batch field name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchField.Required Property

IBatchFieldRequired Property

Gets or sets Required property of BatchField.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Required { get; set; }
Property Required As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchFields Interface

IBatchFields Interface

IBatchFields COM Interface.

Defines a COM collection of BatchField objects associated with a batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638CFFFB-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IBatchFields
<ComVisibleAttribute(true)>
<GuidAttribute("638CFFFB-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IBatchFields

The IBatchFields type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | The number of BatchFields objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IBatchFields Methods

IBatchFields Methods

The IBatchFields type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IBatchFields Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchFields.GetEnumerator Method

IBatchFieldsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IBatchFields object.
See Also

Reference

IBatchFields Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchFields Properties

IBatchFields Properties

The IBatchFields type exposes the following members.

Properties
 | Name | Description
Public property | Count | The number of BatchFields objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IBatchFields Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchFields.Count Property

IBatchFieldsCount Property

The number of BatchFields objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatchFields Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IBatchFields.Item Property

IBatchFieldsItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchField this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IBatchField
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IBatchField

Return Value

Type: IBatchField
IBatchField
Remarks
See Also

Reference

IBatchFields Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass Interface

IDocumentClass Interface

IDocumentClass COM Interface.

Defines information about a document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638CFFFD-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IDocumentClass
<ComVisibleAttribute(true)>
<GuidAttribute("638CFFFD-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IDocumentClass

The IDocumentClass type exposes the following members.

Methods
 | Name | Description
Public method | CreateFormType | Creates a new form type for the document class.
Public method | CreateIndexField | Creates a new index field for the document class.
Public method | CreateTableDefinition | Creates a new TableDefinition with the specified name.
Public method | DeleteFormType | Deletes an existing form type.
Public method | DeleteIndexField | Deletes an existing index field.
Public method | DeleteTableDefinition | Deletes the specified table definition.
Top
Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Document class description.
Public property | FormTypes | Returns the collection of form types associated with the document class.
Public property | IndexFields | Returns the Collection of index fields associated with the document class.
Public property | Name | Document class name.
Public property | TableDefinitions | Collection of tables associated with the document class.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass Methods

IDocumentClass Methods

The IDocumentClass type exposes the following members.

Methods
 | Name | Description
Public method | CreateFormType | Creates a new form type for the document class.
Public method | CreateIndexField | Creates a new index field for the document class.
Public method | CreateTableDefinition | Creates a new TableDefinition with the specified name.
Public method | DeleteFormType | Deletes an existing form type.
Public method | DeleteIndexField | Deletes an existing index field.
Public method | DeleteTableDefinition | Deletes the specified table definition.
Top
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass.CreateFormType Method

IDocumentClassCreateFormType Method

Creates a new form type for the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
Object CreateFormType(
    string strName
)
Function CreateFormType (
    strName As String
) As Object

Parameters

strName
Type: SystemString
The name of the new form type.

Return Value

Type: Object
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass.CreateIndexField Method

IDocumentClassCreateIndexField Method

Creates a new index field for the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void CreateIndexField(
    string strName,
    ref IFieldType oFieldType
)
Sub CreateIndexField (
    strName As String,
    ByRef oFieldType As IFieldType
)

Parameters

strName
Type: SystemString
The name of the new index field.
oFieldType
Type: Kofax.Capture.AdminModule.InteropServicesIFieldType
The field type used.
Remarks
This function pre-validates the index field.
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass.CreateTableDefinition Method

IDocumentClassCreateTableDefinition Method

Creates a new TableDefinition with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void CreateTableDefinition(
    string strName,
    ref IIndexField oIndexField,
    ref IIndexField oNextIndexField
)
Sub CreateTableDefinition (
    strName As String,
    ByRef oIndexField As IIndexField,
    ByRef oNextIndexField As IIndexField
)

Parameters

strName
Type: SystemString
The name of the new table.
oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
Becomes a table field for the new table.
oNextIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The table is inserted before oNextIndexField. If that field is a table field, the new table is inserted before the table. If Nothing, the table is added at the current location of oIndexField.
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass.DeleteFormType Method

IDocumentClassDeleteFormType Method

Deletes an existing form type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteFormType(
    ref IFormType oFormType
)
Sub DeleteFormType (
    ByRef oFormType As IFormType
)

Parameters

oFormType
Type: Kofax.Capture.AdminModule.InteropServicesIFormType
The form type to delete.
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass.DeleteIndexField Method

IDocumentClassDeleteIndexField Method

Deletes an existing index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteIndexField(
    ref IIndexField oIndexField
)
Sub DeleteIndexField (
    ByRef oIndexField As IIndexField
)

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The index field to delete. If oIndexField is the only index field for a table, that table is also deleted.
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass.DeleteTableDefinition Method

IDocumentClassDeleteTableDefinition Method

Deletes the specified table definition.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteTableDefinition(
    ref ITableDefinition oTableDefinition
)
Sub DeleteTableDefinition (
    ByRef oTableDefinition As ITableDefinition
)

Parameters

oTableDefinition
Type: Kofax.Capture.AdminModule.InteropServicesITableDefinition
The table definition to delete.
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass Properties

IDocumentClass Properties

The IDocumentClass type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Document class description.
Public property | FormTypes | Returns the collection of form types associated with the document class.
Public property | IndexFields | Returns the Collection of index fields associated with the document class.
Public property | Name | Document class name.
Public property | TableDefinitions | Collection of tables associated with the document class.
Top
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass.CustomStorageString Property

IDocumentClassCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the document class.

Property Value

Type: String

Return Value

Type: String
Remarks

Custom Storage strings are custom text strings that are bound to a specific document class. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass.Description Property

IDocumentClassDescription Property

Document class description.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass.FormTypes Property

IDocumentClassFormTypes Property

Returns the collection of form types associated with the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFormTypes FormTypes { get; }
ReadOnly Property FormTypes As IFormTypes
    Get

Property Value

Type: IFormTypes

Return Value

Type: IFormTypes
IFormTypes
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass.IndexFields Property

IDocumentClassIndexFields Property

Returns the Collection of index fields associated with the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexFields IndexFields { get; }
ReadOnly Property IndexFields As IIndexFields
    Get

Property Value

Type: IIndexFields

Return Value

Type: IIndexFields
IIndexFields
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass.Name Property

IDocumentClassName Property

Document class name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClass.TableDefinitions Property

IDocumentClassTableDefinitions Property

Collection of tables associated with the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ITableDefinitions TableDefinitions { get; }
ReadOnly Property TableDefinitions As ITableDefinitions
    Get

Property Value

Type: ITableDefinitions

Return Value

Type: ITableDefinitions
ITableDefinitions
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClasses Interface

IDocumentClasses Interface

IDocumentClasses COM Interface.

Defines a COM collection of DocumentClass objects associated with a batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638CFFFF-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IDocumentClasses
<ComVisibleAttribute(true)>
<GuidAttribute("638CFFFF-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IDocumentClasses

The IDocumentClasses type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of IDocumentClass objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClasses Methods

IDocumentClasses Methods

The IDocumentClasses type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IDocumentClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClasses.GetEnumerator Method

IDocumentClassesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IDocumentClasses object.
See Also

Reference

IDocumentClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClasses Properties

IDocumentClasses Properties

The IDocumentClasses type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of IDocumentClass objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IDocumentClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClasses.Count Property

IDocumentClassesCount Property

Returns the number of IDocumentClass objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IDocumentClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IDocumentClasses.Item Property

IDocumentClassesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocumentClass this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IDocumentClass
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IDocumentClass

Return Value

Type: IDocumentClass
IDocumentClass
Remarks
See Also

Reference

IDocumentClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IExportEventArgs Interface

IExportEventArgs Interface

IExportEventArgs COM Interface.

The setup OCX receives the specified action event before a batch class is exported.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0001-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IExportEventArgs
<ComVisibleAttribute(true)>
<GuidAttribute("638D0001-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IExportEventArgs

The IExportEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BatchClass | The batch class that is being exported.
Public property | ExportFolder | A batch class\setup module specific folder.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IExportEventArgs Properties

IExportEventArgs Properties

The IExportEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BatchClass | The batch class that is being exported.
Public property | ExportFolder | A batch class\setup module specific folder.
Top
See Also

Reference

IExportEventArgs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IExportEventArgs.BatchClass Property

IExportEventArgsBatchClass Property

The batch class that is being exported.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchClass BatchClass { get; }
ReadOnly Property BatchClass As IBatchClass
    Get

Property Value

Type: IBatchClass

Return Value

Type: IBatchClass
IBatchClass
See Also

Reference

IExportEventArgs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IExportEventArgs.ExportFolder Property

IExportEventArgsExportFolder Property

A batch class\setup module specific folder.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ExportFolder { get; }
ReadOnly Property ExportFolder As String
    Get

Property Value

Type: String

Return Value

Type: String
String
See Also

Reference

IExportEventArgs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType Interface

IFieldType Interface

IFieldType COM Interface.

Defines information about a field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0003-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFieldType
<ComVisibleAttribute(true)>
<GuidAttribute("638D0003-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFieldType

The IFieldType type exposes the following members.

Methods
 | Name | Description
Public method | CreateSuggestedValue | Adds a suggested value.
Public method | DeleteSuggestedValue | Deletes a suggested value.
Top
Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Gets or sets the Field type description.
Public property | Dictionary | Gets or sets the dictionary used by the field type.
Public property | Length | The length of the field type.
Public property | Name | Gets the field type name.
Public property | Numeric | Returns True if the field type is numeric.
Public property | NumericPrecision | Returns the precision of the field type.
Public property | NumericScale | Returns the scale of the field type.
Public property | OrderType | Indicates the sort type
Public property | SortAlphabetically | Indicates the suggested values are sorted.
Public property | SqlType | Returns the data type of the field type.
Public property | SuggestedValues | Returns a collection of SuggestedValues, which is a collection of alphabetically sorted strings.
Public property | SuggestedValuesForceMatch | Read - ReturnsTrue if "force match" is set. Write - Sets the value.
Public property | SuggestedValuesForceMatchCaseSensitive | Read - ReturnsTrue if "case sensitive" is set. Write - Sets the value.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType Methods

IFieldType Methods

The IFieldType type exposes the following members.

Methods
 | Name | Description
Public method | CreateSuggestedValue | Adds a suggested value.
Public method | DeleteSuggestedValue | Deletes a suggested value.
Top
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.CreateSuggestedValue Method

IFieldTypeCreateSuggestedValue Method

Adds a suggested value.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void CreateSuggestedValue(
    string strValue
)
Sub CreateSuggestedValue (
    strValue As String
)

Parameters

strValue
Type: SystemString
The new value.
Remarks
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.DeleteSuggestedValue Method

IFieldTypeDeleteSuggestedValue Method

Deletes a suggested value.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteSuggestedValue(
    string strValue
)
Sub DeleteSuggestedValue (
    strValue As String
)

Parameters

strValue
Type: SystemString
The value to delete.
Remarks
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType Properties

IFieldType Properties

The IFieldType type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Gets or sets the Field type description.
Public property | Dictionary | Gets or sets the dictionary used by the field type.
Public property | Length | The length of the field type.
Public property | Name | Gets the field type name.
Public property | Numeric | Returns True if the field type is numeric.
Public property | NumericPrecision | Returns the precision of the field type.
Public property | NumericScale | Returns the scale of the field type.
Public property | OrderType | Indicates the sort type
Public property | SortAlphabetically | Indicates the suggested values are sorted.
Public property | SqlType | Returns the data type of the field type.
Public property | SuggestedValues | Returns a collection of SuggestedValues, which is a collection of alphabetically sorted strings.
Public property | SuggestedValuesForceMatch | Read - ReturnsTrue if "force match" is set. Write - Sets the value.
Public property | SuggestedValuesForceMatchCaseSensitive | Read - ReturnsTrue if "case sensitive" is set. Write - Sets the value.
Top
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.CustomStorageString Property

IFieldTypeCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the field type.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific field type. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.Description Property

IFieldTypeDescription Property

Gets or sets the Field type description.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; set; }
Property Description As String
    Get
    Set

Property Value

Type: String
String

Return Value

Type: String
String
Remarks
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.Dictionary Property

IFieldTypeDictionary Property

Gets or sets the dictionary used by the field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Dictionary { get; set; }
Property Dictionary As String
    Get
    Set

Property Value

Type: String
The path and file name for a dictionary file.

Return Value

Type: String
Returns the path and file name for a dictionary file.
Remarks
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.Length Property

IFieldTypeLength Property

The length of the field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Length { get; set; }
Property Length As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.Name Property

IFieldTypeName Property

Gets the field type name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.Numeric Property

IFieldTypeNumeric Property

Returns True if the field type is numeric.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Numeric { get; }
ReadOnly Property Numeric As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.NumericPrecision Property

IFieldTypeNumericPrecision Property

Returns the precision of the field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int NumericPrecision { get; set; }
Property NumericPrecision As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.NumericScale Property

IFieldTypeNumericScale Property

Returns the scale of the field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int NumericScale { get; set; }
Property NumericScale As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.OrderType Property

IFieldTypeOrderType Property
Indicates the sort type

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int OrderType { get; set; }
Property OrderType As Integer
    Get
    Set

Return Value

Type: Int32
0 – Ascending, 1 – Descending
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.SortAlphabetically Property

IFieldTypeSortAlphabetically Property
Indicates the suggested values are sorted.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SortAlphabetically { get; set; }
Property SortAlphabetically As Boolean
    Get
    Set

Return Value

Type: Boolean
True – The values is sorted alphabetically False – The values' order is custom
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.SqlType Property

IFieldTypeSqlType Property

Returns the data type of the field type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int SqlType { get; set; }
Property SqlType As Integer
    Get
    Set

Property Value

Type: Int32
The data type enumeration.

Return Value

Type: Int32
Returns the data type enumeration.
Remarks
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.SuggestedValues Property

IFieldTypeSuggestedValues Property

Returns a collection of SuggestedValues, which is a collection of alphabetically sorted strings.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ISuggestedValues SuggestedValues { get; }
ReadOnly Property SuggestedValues As ISuggestedValues
    Get

Property Value

Type: ISuggestedValues

Return Value

Type: ISuggestedValues
ISuggestedValues
Remarks
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.SuggestedValuesForceMatch Property

IFieldTypeSuggestedValuesForceMatch Property

Read - ReturnsTrue if "force match" is set.
Write - Sets the value.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SuggestedValuesForceMatch { get; set; }
Property SuggestedValuesForceMatch As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldType.SuggestedValuesForceMatchCaseSensitive Property

IFieldTypeSuggestedValuesForceMatchCaseSensitive Property

Read - ReturnsTrue if "case sensitive" is set.
Write - Sets the value.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SuggestedValuesForceMatchCaseSensitive { get; set; }
Property SuggestedValuesForceMatchCaseSensitive As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IFieldType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldTypes Interface

IFieldTypes Interface

IFieldTypes COM Interface.

Defines a COM collection of FieldType objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0005-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFieldTypes
<ComVisibleAttribute(true)>
<GuidAttribute("638D0005-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFieldTypes

The IFieldTypes type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | The number of FieldType objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IFieldTypes Methods

IFieldTypes Methods

The IFieldTypes type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IFieldTypes Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldTypes.GetEnumerator Method

IFieldTypesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IFieldTypes object.
See Also

Reference

IFieldTypes Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldTypes Properties

IFieldTypes Properties

The IFieldTypes type exposes the following members.

Properties
 | Name | Description
Public property | Count | The number of FieldType objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IFieldTypes Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldTypes.Count Property

IFieldTypesCount Property

The number of FieldType objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFieldTypes Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFieldTypes.Item Property

IFieldTypesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFieldType this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFieldType
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IFieldType

Return Value

Type: IFieldType
IFieldType
Remarks
See Also

Reference

IFieldTypes Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClass Interface

IFolderClass Interface

IFolderClass COM Interface.

Defines information about a folder class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0007-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFolderClass
<ComVisibleAttribute(true)>
<GuidAttribute("638D0007-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFolderClass

The IFolderClass type exposes the following members.

Methods
 | Name | Description
Public method | CreateIndexField | Creates a new folder index field.
Public method | DeleteIndexField | Deletes an existing folder index field.
Top
Properties
 | Name | Description
Public property | CustomStorageString | The folder class storage string with the specified name.
Public property | Description | The folder class description.
Public property | IndexFields | Ordered list of folder index fields associated with the folder class.
Public property | Name | The folder class name.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClass Methods

IFolderClass Methods

The IFolderClass type exposes the following members.

Methods
 | Name | Description
Public method | CreateIndexField | Creates a new folder index field.
Public method | DeleteIndexField | Deletes an existing folder index field.
Top
See Also

Reference

IFolderClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClass.CreateIndexField Method

IFolderClassCreateIndexField Method

Creates a new folder index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void CreateIndexField(
    string strName,
    ref IFieldType oFieldType
)
Sub CreateIndexField (
    strName As String,
    ByRef oFieldType As IFieldType
)

Parameters

strName
Type: SystemString
The name of the new folder index field.
oFieldType
Type: Kofax.Capture.AdminModule.InteropServicesIFieldType
The field type used.
Remarks
This function pre-validates the folder index field and throws the following errors:

(KfxApiErrDuplicateObject) duplicate folder index field.

(KfxApiErrBadParameterRange) illegal folder index field name.

(KfxApiErrAppIsBusy) if the application is in the middle of a user event.

See Also

Reference

IFolderClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClass.DeleteIndexField Method

IFolderClassDeleteIndexField Method

Deletes an existing folder index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteIndexField(
    ref IIndexField oIndexField
)
Sub DeleteIndexField (
    ByRef oIndexField As IIndexField
)

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The folder index field to delete.
Remarks
Delete a Folder class (including any sub-objects).

The following error is thrown:

(KfxApiErrAppIsBusy) if the application is in the middle of a user event.

See Also

Reference

IFolderClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClass Properties

IFolderClass Properties

The IFolderClass type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The folder class storage string with the specified name.
Public property | Description | The folder class description.
Public property | IndexFields | Ordered list of folder index fields associated with the folder class.
Public property | Name | The folder class name.
Top
See Also

Reference

IFolderClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClass.CustomStorageString Property

IFolderClassCustomStorageString Property

The folder class storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the folder class.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Setup OCXs can read custom strings stored by other Setup OCXs. If set to an empty string, the storage string is deleted.

Custom Storage strings are custom text strings that are bound to a specific folder class. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large (over 2 billion characters).
See Also

Reference

IFolderClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClass.Description Property

IFolderClassDescription Property

The folder class description.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IFolderClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClass.IndexFields Property

IFolderClassIndexFields Property

Ordered list of folder index fields associated with the folder class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexFields IndexFields { get; }
ReadOnly Property IndexFields As IIndexFields
    Get

Property Value

Type: IIndexFields

Return Value

Type: IIndexFields
IIndexFields
Remarks
See Also

Reference

IFolderClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClass.Name Property

IFolderClassName Property

The folder class name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IFolderClass Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClasses Interface

IFolderClasses Interface

IFolderClasses COM Interface.

Defines a collection of FolderClass objects associated with folder classes.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0009-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFolderClasses
<ComVisibleAttribute(true)>
<GuidAttribute("638D0009-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFolderClasses

The IFolderClasses type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of FolderClass objects contained in the collection.
Public property | Item | Returns a collection element given a key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClasses Methods

IFolderClasses Methods

The IFolderClasses type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IFolderClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClasses.GetEnumerator Method

IFolderClassesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IFolderClasses object.
See Also

Reference

IFolderClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClasses Properties

IFolderClasses Properties

The IFolderClasses type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of FolderClass objects contained in the collection.
Public property | Item | Returns a collection element given a key.
Top
See Also

Reference

IFolderClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClasses.Count Property

IFolderClassesCount Property

Returns the number of FolderClass objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFolderClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFolderClasses.Item Property

IFolderClassesItem Property

Returns a collection element given a key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolderClass this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFolderClass
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IFolderClass

Return Value

Type: IFolderClass
Remarks
See Also

Reference

IFolderClasses Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormIdZone Interface

IFormIdZone Interface

IFormIdZone COM Interface.

Defines information about a form identification zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D000B-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFormIdZone
<ComVisibleAttribute(true)>
<GuidAttribute("638D000B-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFormIdZone

The IFormIdZone type exposes the following members.

Properties
 | Name | Description
Public property | SearchText | Search text for the form ID zone.
Public property | ZoneHeight | The height of the zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | The left coordinate of the zone in BMUs.
Public property | ZoneTop | The top coordinate of the zone in BMUs.
Public property | ZoneWidth | The width of the zone in BMUs.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IFormIdZone Properties

IFormIdZone Properties

The IFormIdZone type exposes the following members.

Properties
 | Name | Description
Public property | SearchText | Search text for the form ID zone.
Public property | ZoneHeight | The height of the zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | The left coordinate of the zone in BMUs.
Public property | ZoneTop | The top coordinate of the zone in BMUs.
Public property | ZoneWidth | The width of the zone in BMUs.
Top
See Also

Reference

IFormIdZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormIdZone.SearchText Property

IFormIdZoneSearchText Property

Search text for the form ID zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string SearchText { get; }
ReadOnly Property SearchText As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IFormIdZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormIdZone.ZoneHeight Property

IFormIdZoneZoneHeight Property

The height of the zone in BMUs (1/1200th of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneHeight { get; }
ReadOnly Property ZoneHeight As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFormIdZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormIdZone.ZoneLeft Property

IFormIdZoneZoneLeft Property

The left coordinate of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneLeft { get; }
ReadOnly Property ZoneLeft As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFormIdZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormIdZone.ZoneTop Property

IFormIdZoneZoneTop Property

The top coordinate of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneTop { get; }
ReadOnly Property ZoneTop As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFormIdZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormIdZone.ZoneWidth Property

IFormIdZoneZoneWidth Property

The width of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneWidth { get; }
ReadOnly Property ZoneWidth As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFormIdZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormIdZoneColl Interface

IFormIdZoneColl Interface

IFormIdZoneColl COM Interface.

Defines a COM collection of FormIDZone objects on a sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D000D-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFormIdZoneColl
<ComVisibleAttribute(true)>
<GuidAttribute("638D000D-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFormIdZoneColl

The IFormIdZoneColl type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of FormIDZone items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IFormIdZoneColl Methods

IFormIdZoneColl Methods

The IFormIdZoneColl type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IFormIdZoneColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormIdZoneColl.GetEnumerator Method

IFormIdZoneCollGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IFormIdZoneColl object.
See Also

Reference

IFormIdZoneColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormIdZoneColl Properties

IFormIdZoneColl Properties

The IFormIdZoneColl type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of FormIDZone items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IFormIdZoneColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormIdZoneColl.Count Property

IFormIdZoneCollCount Property

Returns the number of FormIDZone items in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFormIdZoneColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormIdZoneColl.Item Property

IFormIdZoneCollItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFormIdZone this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFormIdZone
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IFormIdZone

Return Value

Type: IFormIdZone
IFormIdZone
Remarks
See Also

Reference

IFormIdZoneColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormType Interface

IFormType Interface

IFormType COM Interface.

Defines information about a form type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D000F-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFormType
<ComVisibleAttribute(true)>
<GuidAttribute("638D000F-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFormType

The IFormType type exposes the following members.

Methods
 | Name | Description
Public method | DeleteSamplePage | Deletes the sample page (including any sub-objects).
Public method | ImportSamplePage | Imports an image to become a sample page.
Top
Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Form type description.
Public property | FixedPageCount | The number of pages for the FormType; 0 if fixed pages not used.
Public property | HorizontalDPI | The horizontal DPI for all sample pages of the form type.
Public property | Name | Form type name.
Public property | SamplePages | Collection of sample pages for the form type.
Public property | VerticalDPI | The vertical DPI for all sample pages of the form type.
Top
Remarks
The FormType object is valid until it, or the parent document class, is deleted.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IFormType Methods

IFormType Methods

The IFormType type exposes the following members.

Methods
 | Name | Description
Public method | DeleteSamplePage | Deletes the sample page (including any sub-objects).
Public method | ImportSamplePage | Imports an image to become a sample page.
Top
See Also

Reference

IFormType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormType.DeleteSamplePage Method

IFormTypeDeleteSamplePage Method

Deletes the sample page (including any sub-objects).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteSamplePage(
    ref ISamplePage oSamplePage
)
Sub DeleteSamplePage (
    ByRef oSamplePage As ISamplePage
)

Parameters

oSamplePage
Type: Kofax.Capture.AdminModule.InteropServicesISamplePage
The sample page to delete.
Remarks
See Also

Reference

IFormType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormType.ImportSamplePage Method

IFormTypeImportSamplePage Method

Imports an image to become a sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void ImportSamplePage(
    string strName
)
Sub ImportSamplePage (
    strName As String
)

Parameters

strName
Type: SystemString
The filepath of the image.
Remarks
See Also

Reference

IFormType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormType Properties

IFormType Properties

The IFormType type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Form type description.
Public property | FixedPageCount | The number of pages for the FormType; 0 if fixed pages not used.
Public property | HorizontalDPI | The horizontal DPI for all sample pages of the form type.
Public property | Name | Form type name.
Public property | SamplePages | Collection of sample pages for the form type.
Public property | VerticalDPI | The vertical DPI for all sample pages of the form type.
Top
See Also

Reference

IFormType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormType.CustomStorageString Property

IFormTypeCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the form type.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific form type. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.
See Also

Reference

IFormType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormType.Description Property

IFormTypeDescription Property

Form type description.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IFormType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormType.FixedPageCount Property

IFormTypeFixedPageCount Property

The number of pages for the FormType; 0 if fixed pages not used.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int FixedPageCount { get; set; }
Property FixedPageCount As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFormType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormType.HorizontalDPI Property

IFormTypeHorizontalDPI Property

The horizontal DPI for all sample pages of the form type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int HorizontalDPI { get; }
ReadOnly Property HorizontalDPI As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFormType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormType.Name Property

IFormTypeName Property

Form type name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IFormType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormType.SamplePages Property

IFormTypeSamplePages Property

Collection of sample pages for the form type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ISamplePages SamplePages { get; }
ReadOnly Property SamplePages As ISamplePages
    Get

Property Value

Type: ISamplePages

Return Value

Type: ISamplePages
ISamplePages
Remarks
See Also

Reference

IFormType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormType.VerticalDPI Property

IFormTypeVerticalDPI Property

The vertical DPI for all sample pages of the form type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int VerticalDPI { get; }
ReadOnly Property VerticalDPI As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFormType Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormTypes Interface

IFormTypes Interface

IFormTypes COM Interface.

Defines a COM collection of FormType objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0011-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFormTypes
<ComVisibleAttribute(true)>
<GuidAttribute("638D0011-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFormTypes

The IFormTypes type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of elements in the collection.
Public property | Item | Returns a collection element given a key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IFormTypes Methods

IFormTypes Methods

The IFormTypes type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IFormTypes Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormTypes.GetEnumerator Method

IFormTypesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IFormTypes object.
See Also

Reference

IFormTypes Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormTypes Properties

IFormTypes Properties

The IFormTypes type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of elements in the collection.
Public property | Item | Returns a collection element given a key.
Top
See Also

Reference

IFormTypes Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormTypes.Count Property

IFormTypesCount Property

Returns the number of elements in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Remarks
See Also

Reference

IFormTypes Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IFormTypes.Item Property

IFormTypesItem Property

Returns a collection element given a key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFormType this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFormType
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IFormType

Return Value

Type: IFormType
Remarks
See Also

Reference

IFormTypes Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IGroup Interface

IGroup Interface

IGroup COM Interface.

Defines information about a Group object.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0013-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IGroup
<ComVisibleAttribute(true)>
<GuidAttribute("638D0013-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IGroup

The IGroup type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the group name of a Tungsten Capture group.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IGroup Properties

IGroup Properties

The IGroup type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the group name of a Tungsten Capture group.
Top
See Also

Reference

IGroup Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IGroup.Name Property

IGroupName Property

Returns the group name of a Tungsten Capture group.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
See Also

Reference

IGroup Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IGroups Interface

IGroups Interface

IGroups COM Interface.

Defines a COM collection of Group objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0015-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IGroups
<ComVisibleAttribute(true)>
<GuidAttribute("638D0015-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IGroups

The IGroups type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of objects contained in the collection of Group objects.
Public property | Item | Retrieves an object from the collection of Group objects, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IGroups Methods

IGroups Methods

The IGroups type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IGroups Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IGroups.GetEnumerator Method

IGroupsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IGroups object.
See Also

Reference

IGroups Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IGroups Properties

IGroups Properties

The IGroups type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of objects contained in the collection of Group objects.
Public property | Item | Retrieves an object from the collection of Group objects, by index or by key.
Top
See Also

Reference

IGroups Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IGroups.Count Property

IGroupsCount Property

Returns the number of objects contained in the collection of Group objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IGroups Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IGroups.Item Property

IGroupsItem Property

Retrieves an object from the collection of Group objects, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IGroup this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IGroup
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IGroup

Return Value

Type: IGroup
IGroup
Remarks
See Also

Reference

IGroups Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IImportEventArgs Interface

IImportEventArgs Interface

IImportEventArgs COM Interface.

The setup OCX receives the ImportCustomFiles action event during a batch class import.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0019-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IImportEventArgs
<ComVisibleAttribute(true)>
<GuidAttribute("638D0019-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IImportEventArgs

The IImportEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BatchClass | The batch class that is being imported.
Public property | ImportFolder | A folder specified by Tungsten Capture, created before triggering the event.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IImportEventArgs Properties

IImportEventArgs Properties

The IImportEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BatchClass | The batch class that is being imported.
Public property | ImportFolder | A folder specified by Tungsten Capture, created before triggering the event.
Top
See Also

Reference

IImportEventArgs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IImportEventArgs.BatchClass Property

IImportEventArgsBatchClass Property

The batch class that is being imported.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchClass BatchClass { get; }
ReadOnly Property BatchClass As IBatchClass
    Get

Property Value

Type: IBatchClass

Return Value

Type: IBatchClass
IBatchClass
See Also

Reference

IImportEventArgs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IImportEventArgs.ImportFolder Property

IImportEventArgsImportFolder Property

A folder specified by Tungsten Capture, created before triggering the event.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ImportFolder { get; }
ReadOnly Property ImportFolder As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks

After the import is complete, the folder is deleted.

The folder will be off the workstation local path. It will be similar to:

C:\Documents and Settings\All Users\Application Data\Kofax\Capture\AdminDb\MyModuleId

Or

C:\Documents and Settings\All Users\Application Data\Kofax\CaptureSV\AdminDb\MyModuleId
See Also

Reference

IImportEventArgs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField Interface

IIndexField Interface

IIndexField COM Interface.

Defines information about a document or folder index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D001B-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IIndexField
<ComVisibleAttribute(true)>
<GuidAttribute("638D001B-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IIndexField

The IIndexField type exposes the following members.

Methods
 | Name | Description
Public method | MoveIndexFieldTo | Moves the index field from its current location to the position before oNextIndexField.
Public method | MoveIndexFieldToTable | Moves this index field to the specified table, prior to oNextIndexField.
Top
Properties
 | Name | Description
Public property | CustomStorageString | Sets or gets the storage string with the specified name.
Public property | Default | Gets the index field default value.
Public property | DisplayLabel | Sets or gets the value of a supported index field display label.
Public property | FieldType | The field type of the index field.
Public property | Hidden | Gets or sets the "Hidden" value of the index field.
Public property | Name | Returns the index field name.
Public property | Required | Gets or sets the "Required" value of the index field.
Public property | Sticky | Gets or sets the "Sticky" value of the index field.
Public property | TableDefinition | Returns the table definition associated with the index field.
Public property | Total | Sets or gets the "Total" value of the index field.
Public property | Verify | Gets or sets the "Verify" value of the index field.
Top
Remarks
An IndexField object is valid until it is deleted.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField Methods

IIndexField Methods

The IIndexField type exposes the following members.

Methods
 | Name | Description
Public method | MoveIndexFieldTo | Moves the index field from its current location to the position before oNextIndexField.
Public method | MoveIndexFieldToTable | Moves this index field to the specified table, prior to oNextIndexField.
Top
See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField.MoveIndexFieldTo Method

IIndexFieldMoveIndexFieldTo Method

Moves the index field from its current location to the position before oNextIndexField.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void MoveIndexFieldTo(
    ref IIndexField oNextIndexField = null
)
Sub MoveIndexFieldTo (
    Optional ByRef oNextIndexField As IIndexField = Nothing
)

Parameters

oNextIndexField (Optional)
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
If oNextIndexField is Nothing, the index field is moved to the end. Otherwise, it is added before oNextIndexField.
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField.MoveIndexFieldToTable Method

IIndexFieldMoveIndexFieldToTable Method

Moves this index field to the specified table, prior to oNextIndexField.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void MoveIndexFieldToTable(
    ref ITableDefinition oTableDefinition,
    ref IIndexField oNextIndexField = null
)
Sub MoveIndexFieldToTable (
    ByRef oTableDefinition As ITableDefinition,
    Optional ByRef oNextIndexField As IIndexField = Nothing
)

Parameters

oTableDefinition
Type: Kofax.Capture.AdminModule.InteropServicesITableDefinition
Move the index field into this table.
oNextIndexField (Optional)
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
If oNextIndexField is Nothing, moved to the end of the table. If the old location of this index field was a table, and it was the only index field, that table is deleted.
Remarks

Errors:

(KfxApiErrBadParameterRange) oNextIndexField is not Nothing and is not in oTableDef.

See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField Properties

IIndexField Properties

The IIndexField type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | Sets or gets the storage string with the specified name.
Public property | Default | Gets the index field default value.
Public property | DisplayLabel | Sets or gets the value of a supported index field display label.
Public property | FieldType | The field type of the index field.
Public property | Hidden | Gets or sets the "Hidden" value of the index field.
Public property | Name | Returns the index field name.
Public property | Required | Gets or sets the "Required" value of the index field.
Public property | Sticky | Gets or sets the "Sticky" value of the index field.
Public property | TableDefinition | Returns the table definition associated with the index field.
Public property | Total | Sets or gets the "Total" value of the index field.
Public property | Verify | Gets or sets the "Verify" value of the index field.
Top
See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField.CustomStorageString Property

IIndexFieldCustomStorageString Property

Sets or gets the storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the index field.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific index field. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField.Default Property

IIndexFieldDefault Property

Gets the index field default value.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Default { get; set; }
Property Default As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks

Read - Returns the default value, if one is specified.

Write - The value is validated against the FieldType.

See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField.DisplayLabel Property

IIndexFieldDisplayLabel Property

Sets or gets the value of a supported index field display label.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string DisplayLabel { get; set; }
Property DisplayLabel As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField.FieldType Property

IIndexFieldFieldType Property

The field type of the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFieldType FieldType { get; set; }
Property FieldType As IFieldType
    Get
    Set

Property Value

Type: IFieldType

Return Value

Type: IFieldType
IFieldType
Remarks

Read - Returns a FieldType object. If an invalid default value is present, it is replaced with the default value for the data type.

Write - When a FieldType is written to an IndexField, several other properties are modified:Default will be set to the default for the field type.
Total will be set to False if the field type is not numeric.

See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField.Hidden Property

IIndexFieldHidden Property

Gets or sets the "Hidden" value of the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Hidden { get; set; }
Property Hidden As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

Read - ReturnsTrue if the field is hidden in Validation and Verification.
Write - Sets the value. If Hidden is True, Required, Verify, Sticky, and Total are set to False.

See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField.Name Property

IIndexFieldName Property

Returns the index field name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField.Required Property

IIndexFieldRequired Property

Gets or sets the "Required" value of the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Required { get; set; }
Property Required As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

Read - Returns True if a value is required in Validation and Verification.

Write - Sets the value. If Required is True, Hidden is set to False.

See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField.Sticky Property

IIndexFieldSticky Property

Gets or sets the "Sticky" value of the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Sticky { get; set; }
Property Sticky As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

Read - ReturnsTrue or False. If True, the value of the index field for a document is carried over to the next document. The Validation or Verification operators can override the value in the subsequent document if necessary.

Write - Sets the value. If Sticky is True, Hidden is set to False.

This function throws:

(KfxApiErrBadParameterRange) if setting for a table field.

See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField.TableDefinition Property

IIndexFieldTableDefinition Property

Returns the table definition associated with the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ITableDefinition TableDefinition { get; }
ReadOnly Property TableDefinition As ITableDefinition
    Get

Property Value

Type: ITableDefinition

Return Value

Type: ITableDefinition
ITableDefinition
Remarks
Nothing if not a table field.
See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField.Total Property

IIndexFieldTotal Property

Sets or gets the "Total" value of the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Total { get; set; }
Property Total As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

Read - Returns True or False. If True, the Scan operator is solicited for an expected value for the total. Has no meaning for folder index fields.

Write - Sets the value. True is valid only for numeric index fields.

This function throws:

(KfxApiErrBadParameterRange) if setting for a table field.

See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexField.Verify Property

IIndexFieldVerify Property

Gets or sets the "Verify" value of the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Verify { get; set; }
Property Verify As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

Read - Returns True if the field should appear in Verification.

Write - Sets the value. If Verify is True, Hidden is set to False.

See Also

Reference

IIndexField Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexFields Interface

IIndexFields Interface

IIndexFields COM Interface.

Defines a COM collection of IndexField objects associated with document and folder classes.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D001F-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IIndexFields
<ComVisibleAttribute(true)>
<GuidAttribute("638D001F-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IIndexFields

The IIndexFields type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of IndexField objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IIndexFields Methods

IIndexFields Methods

The IIndexFields type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IIndexFields Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexFields.GetEnumerator Method

IIndexFieldsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IIndexFields object.
See Also

Reference

IIndexFields Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexFields Properties

IIndexFields Properties

The IIndexFields type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of IndexField objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IIndexFields Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexFields.Count Property

IIndexFieldsCount Property

Returns the number of IndexField objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexFields Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexFields.Item Property

IIndexFieldsItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexField this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IIndexField
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IIndexField

Return Value

Type: IIndexField
IIndexField
Remarks
See Also

Reference

IIndexFields Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone Interface

IIndexGroupZone Interface

IIndexGroupZone COM Interface.

Defines information about an Index Group Zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0021-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IIndexGroupZone
<ComVisibleAttribute(true)>
<GuidAttribute("638D0021-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IIndexGroupZone

The IIndexGroupZone type exposes the following members.

Methods
 | Name | Description
Public method | ShowPropertiesDialog | Displays the Index Group Zone Properties dialog for the zone.
Top
Properties
 | Name | Description
Public property | ConcatenateCharacter | If GroupZonePickBest is False, this character is used to delimit the results from each field.
Public property | Count | Returns the number of index zones belonging to this index group zone.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Field | Returns the name of the index field for the index group zone.
Public property | IndexField | Returns the index field for the index group zone.
Public property | IndexGrpMemZones | Returns the index group member zones belonging to this index group zone.
Public property | MaximumResultSet | Returns the maximum number of non-blank child zones needed to produce a non-blank result.
Public property | MinimumResultSet | Returns the minimum number of non-blank child zones needed to produce a non-blank result.
Public property | PickBest | If True, the result will be the single child zone with the highest confidence. If False, the results from all zones will be concatenated.
Public property | ValidationDisplay | If True, the group zone will be displayed in Validation. If False, the most confident child zone is displayed.
Public property | ZoneHeight | Returns the height of the index group zone, in BMUs.
Public property | ZoneLeft | Returns the x coordinate of the upper-left corner of the index group zone, in BMUs.
Public property | ZoneTop | Returns the y coordinate of the upper-left corner of the index group zone, in BMUs.
Public property | ZoneWidth | Returns the width of the index group zone, in BMUs.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone Methods

IIndexGroupZone Methods

The IIndexGroupZone type exposes the following members.

Methods
 | Name | Description
Public method | ShowPropertiesDialog | Displays the Index Group Zone Properties dialog for the zone.
Top
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.ShowPropertiesDialog Method

IIndexGroupZoneShowPropertiesDialog Method

Displays the Index Group Zone Properties dialog for the zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool ShowPropertiesDialog(
    ref BatchClass oBatchClass
)
Function ShowPropertiesDialog (
    ByRef oBatchClass As BatchClass
) As Boolean

Parameters

oBatchClass
Type: Kofax.Capture.AdminModule.InteropServicesBatchClass
Identifies the batch class containing the document class. If Nothing or null, Zone Test is not available.

Return Value

Type: Boolean
Remarks

True if the user exited by pressing the OK button.

False if the user cancelled the dialog.

Modifications made in the Index Group Zone Properties dialog are committed to the database when OK or Apply are pressed. The new values are immediately accessible to the Index Group Zone object.
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone Properties

IIndexGroupZone Properties

The IIndexGroupZone type exposes the following members.

Properties
 | Name | Description
Public property | ConcatenateCharacter | If GroupZonePickBest is False, this character is used to delimit the results from each field.
Public property | Count | Returns the number of index zones belonging to this index group zone.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Field | Returns the name of the index field for the index group zone.
Public property | IndexField | Returns the index field for the index group zone.
Public property | IndexGrpMemZones | Returns the index group member zones belonging to this index group zone.
Public property | MaximumResultSet | Returns the maximum number of non-blank child zones needed to produce a non-blank result.
Public property | MinimumResultSet | Returns the minimum number of non-blank child zones needed to produce a non-blank result.
Public property | PickBest | If True, the result will be the single child zone with the highest confidence. If False, the results from all zones will be concatenated.
Public property | ValidationDisplay | If True, the group zone will be displayed in Validation. If False, the most confident child zone is displayed.
Public property | ZoneHeight | Returns the height of the index group zone, in BMUs.
Public property | ZoneLeft | Returns the x coordinate of the upper-left corner of the index group zone, in BMUs.
Public property | ZoneTop | Returns the y coordinate of the upper-left corner of the index group zone, in BMUs.
Public property | ZoneWidth | Returns the width of the index group zone, in BMUs.
Top
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.ConcatenateCharacter Property

IIndexGroupZoneConcatenateCharacter Property

If GroupZonePickBest is False, this character is used to delimit the results from each field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ConcatenateCharacter { get; set; }
Property ConcatenateCharacter As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
Remarks
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.Count Property

IIndexGroupZoneCount Property

Returns the number of index zones belonging to this index group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.CustomStorageString Property

IIndexGroupZoneCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the index group zone.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific index group zone. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.Field Property

IIndexGroupZoneField Property

Returns the name of the index field for the index group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Field { get; }
ReadOnly Property Field As String
    Get

Property Value

Type: String

Return Value

Type: String
String
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.IndexField Property

IIndexGroupZoneIndexField Property

Returns the index field for the index group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexField IndexField { get; set; }
Property IndexField As IIndexField
    Get
    Set

Property Value

Type: IIndexField

Return Value

Type: IIndexField
IIndexField
Remarks
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.IndexGrpMemZones Property

IIndexGroupZoneIndexGrpMemZones Property

Returns the index group member zones belonging to this index group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexGrpMemZones IndexGrpMemZones { get; }
ReadOnly Property IndexGrpMemZones As IIndexGrpMemZones
    Get

Property Value

Type: IIndexGrpMemZones

Return Value

Type: IIndexGrpMemZones
IIndexGrpMemZones
Remarks
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.MaximumResultSet Property

IIndexGroupZoneMaximumResultSet Property

Returns the maximum number of non-blank child zones needed to produce a non-blank result.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int MaximumResultSet { get; set; }
Property MaximumResultSet As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.MinimumResultSet Property

IIndexGroupZoneMinimumResultSet Property

Returns the minimum number of non-blank child zones needed to produce a non-blank result.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int MinimumResultSet { get; set; }
Property MinimumResultSet As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.PickBest Property

IIndexGroupZonePickBest Property

If True, the result will be the single child zone with the highest confidence. If False, the results from all zones will be concatenated.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool PickBest { get; set; }
Property PickBest As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.ValidationDisplay Property

IIndexGroupZoneValidationDisplay Property

If True, the group zone will be displayed in Validation. If False, the most confident child zone is displayed.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool ValidationDisplay { get; set; }
Property ValidationDisplay As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.ZoneHeight Property

IIndexGroupZoneZoneHeight Property

Returns the height of the index group zone, in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneHeight { get; set; }
Property ZoneHeight As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.ZoneLeft Property

IIndexGroupZoneZoneLeft Property

Returns the x coordinate of the upper-left corner of the index group zone, in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneLeft { get; set; }
Property ZoneLeft As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.ZoneTop Property

IIndexGroupZoneZoneTop Property

Returns the y coordinate of the upper-left corner of the index group zone, in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneTop { get; set; }
Property ZoneTop As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZone.ZoneWidth Property

IIndexGroupZoneZoneWidth Property

Returns the width of the index group zone, in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneWidth { get; set; }
Property ZoneWidth As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexGroupZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZones Interface

IIndexGroupZones Interface

IIndexGroupZones COM Interface.

Defines a COM collection of IndexGroupZone objects associated with the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0023-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IIndexGroupZones
<ComVisibleAttribute(true)>
<GuidAttribute("638D0023-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IIndexGroupZones

The IIndexGroupZones type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of IndexGroupZone objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZones Methods

IIndexGroupZones Methods

The IIndexGroupZones type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IIndexGroupZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZones.GetEnumerator Method

IIndexGroupZonesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IIndexGroupZones object.
See Also

Reference

IIndexGroupZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZones Properties

IIndexGroupZones Properties

The IIndexGroupZones type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of IndexGroupZone objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IIndexGroupZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZones.Count Property

IIndexGroupZonesCount Property

Returns the number of IndexGroupZone objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexGroupZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGroupZones.Item Property

IIndexGroupZonesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexGroupZone this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IIndexGroupZone
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IIndexGroupZone

Return Value

Type: IIndexGroupZone
IIndexGroupZone
Remarks
See Also

Reference

IIndexGroupZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZone Interface

IIndexGrpMemZone Interface

IIndexGrpMemZone COM Interface.

Defines a member of a group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0025-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IIndexGrpMemZone
<ComVisibleAttribute(true)>
<GuidAttribute("638D0025-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IIndexGrpMemZone

The IIndexGrpMemZone type exposes the following members.

Methods
 | Name | Description
Public method | ShowPropertiesDialog | Displays the Index Zone Properties dialog for the zone.
Top
Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Field | Returns the field name of index group member zone.
Public property | IndexField | Returns the index field for the index group member zone.
Public property | RecognitionProf | RecognitionProf object of the IndexGrpMemZone; Nothing if manual zone.
Public property | ZoneHeight | Returns the height of the index group member zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the index group member zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the index group member zone in BMUs.
Public property | ZoneWidth | Returns the width of the index group member zone in BMUs.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZone Methods

IIndexGrpMemZone Methods

The IIndexGrpMemZone type exposes the following members.

Methods
 | Name | Description
Public method | ShowPropertiesDialog | Displays the Index Zone Properties dialog for the zone.
Top
See Also

Reference

IIndexGrpMemZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZone.ShowPropertiesDialog Method

IIndexGrpMemZoneShowPropertiesDialog Method

Displays the Index Zone Properties dialog for the zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool ShowPropertiesDialog(
    ref BatchClass oBatchClass
)
Function ShowPropertiesDialog (
    ByRef oBatchClass As BatchClass
) As Boolean

Parameters

oBatchClass
Type: Kofax.Capture.AdminModule.InteropServicesBatchClass
Identifies the batch class containing the document class. If Nothing or null, Zone Test is not available.

Return Value

Type: Boolean
Remarks

True if the user exited by pressing the OK button.

False if the user cancelled the dialog.

Modifications made in the Index Group Zone Properties dialog are committed to the database when OK or Apply are pressed. The new values are immediately accessible to the Index Group Zone Member object.

This is the same dialog that is displayed by the Index Zone.
See Also

Reference

IIndexGrpMemZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZone Properties

IIndexGrpMemZone Properties

The IIndexGrpMemZone type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Field | Returns the field name of index group member zone.
Public property | IndexField | Returns the index field for the index group member zone.
Public property | RecognitionProf | RecognitionProf object of the IndexGrpMemZone; Nothing if manual zone.
Public property | ZoneHeight | Returns the height of the index group member zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the index group member zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the index group member zone in BMUs.
Public property | ZoneWidth | Returns the width of the index group member zone in BMUs.
Top
See Also

Reference

IIndexGrpMemZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZone.CustomStorageString Property

IIndexGrpMemZoneCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the index zone.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific index group member zone. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

A group member zone is a type of index zone using the same Index field as a group zone. If the index field is changed, the customs storage string is not deleted. It remains as a property of the zone.

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.
See Also

Reference

IIndexGrpMemZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZone.Field Property

IIndexGrpMemZoneField Property

Returns the field name of index group member zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Field { get; }
ReadOnly Property Field As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IIndexGrpMemZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZone.IndexField Property

IIndexGrpMemZoneIndexField Property

Returns the index field for the index group member zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexField IndexField { get; set; }
Property IndexField As IIndexField
    Get
    Set

Property Value

Type: IIndexField

Return Value

Type: IIndexField
IIndexField
Remarks
See Also

Reference

IIndexGrpMemZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZone.RecognitionProf Property

IIndexGrpMemZoneRecognitionProf Property

RecognitionProf object of the IndexGrpMemZone; Nothing if manual zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRecognitionProf RecognitionProf { get; set; }
Property RecognitionProf As IRecognitionProf
    Get
    Set

Property Value

Type: IRecognitionProf

Return Value

Type: IRecognitionProf
Remarks
See Also

Reference

IIndexGrpMemZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZone.ZoneHeight Property

IIndexGrpMemZoneZoneHeight Property

Returns the height of the index group member zone in BMUs (1/1200th of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneHeight { get; set; }
Property ZoneHeight As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexGrpMemZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZone.ZoneLeft Property

IIndexGrpMemZoneZoneLeft Property

Returns the left coordinate of the index group member zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneLeft { get; set; }
Property ZoneLeft As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexGrpMemZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZone.ZoneTop Property

IIndexGrpMemZoneZoneTop Property

Returns the top coordinate of the index group member zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneTop { get; set; }
Property ZoneTop As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexGrpMemZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZone.ZoneWidth Property

IIndexGrpMemZoneZoneWidth Property

Returns the width of the index group member zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneWidth { get; set; }
Property ZoneWidth As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexGrpMemZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZones Interface

IIndexGrpMemZones Interface

IIndexGrpMemZones COM Interface.

Defines a COM collection of IndexGrpMemZone objects associated with the index group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0027-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IIndexGrpMemZones
<ComVisibleAttribute(true)>
<GuidAttribute("638D0027-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IIndexGrpMemZones

The IIndexGrpMemZones type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of IndexGrpMemZone objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZones Methods

IIndexGrpMemZones Methods

The IIndexGrpMemZones type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IIndexGrpMemZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZones.GetEnumerator Method

IIndexGrpMemZonesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IIndexGrpMemZones object.
See Also

Reference

IIndexGrpMemZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZones Properties

IIndexGrpMemZones Properties

The IIndexGrpMemZones type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of IndexGrpMemZone objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IIndexGrpMemZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZones.Count Property

IIndexGrpMemZonesCount Property

Returns the number of IndexGrpMemZone objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexGrpMemZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexGrpMemZones.Item Property

IIndexGrpMemZonesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexGrpMemZone this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IIndexGrpMemZone
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IIndexGrpMemZone

Return Value

Type: IIndexGrpMemZone
IIndexGrpMemZone
Remarks
See Also

Reference

IIndexGrpMemZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZone Interface

IIndexZone Interface

IIndexZone COM Interface.

Defines information about an index zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0029-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IIndexZone
<ComVisibleAttribute(true)>
<GuidAttribute("638D0029-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IIndexZone

The IIndexZone type exposes the following members.

Methods
 | Name | Description
Public method | ShowPropertiesDialog | Displays the Index Zone Properties dialog for the zone.
Top
Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Field | Returns the index zone field name.
Public property | IndexField | Returns the index field for the index zone.
Public property | RecognitionProf | Returns the recognition profile specified for the index zone.
Public property | ZoneHeight | Returns the height of the zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the zone in BMUs.
Public property | ZoneWidth | Returns the width of the zone in BMUs.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZone Methods

IIndexZone Methods

The IIndexZone type exposes the following members.

Methods
 | Name | Description
Public method | ShowPropertiesDialog | Displays the Index Zone Properties dialog for the zone.
Top
See Also

Reference

IIndexZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZone.ShowPropertiesDialog Method

IIndexZoneShowPropertiesDialog Method

Displays the Index Zone Properties dialog for the zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool ShowPropertiesDialog(
    ref BatchClass oBatchClass
)
Function ShowPropertiesDialog (
    ByRef oBatchClass As BatchClass
) As Boolean

Parameters

oBatchClass
Type: Kofax.Capture.AdminModule.InteropServicesBatchClass
Identifies the batch class containing the document class. If Nothing or null, Zone Test is not available.

Return Value

Type: Boolean
Remarks

True if the user exited by pressing the OK button.

False if the user cancelled the dialog.

Modifications made in the Index Group Zone Properties dialog are committed to the database when OK or Apply are pressed. The new values are immediately accessible to the Index Zone object.

See Also

Reference

IIndexZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZone Properties

IIndexZone Properties

The IIndexZone type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Field | Returns the index zone field name.
Public property | IndexField | Returns the index field for the index zone.
Public property | RecognitionProf | Returns the recognition profile specified for the index zone.
Public property | ZoneHeight | Returns the height of the zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the zone in BMUs.
Public property | ZoneWidth | Returns the width of the zone in BMUs.
Top
See Also

Reference

IIndexZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZone.CustomStorageString Property

IIndexZoneCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the index field.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific index zone. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IIndexZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZone.Field Property

IIndexZoneField Property

Returns the index zone field name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Field { get; }
ReadOnly Property Field As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IIndexZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZone.IndexField Property

IIndexZoneIndexField Property

Returns the index field for the index zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexField IndexField { get; set; }
Property IndexField As IIndexField
    Get
    Set

Property Value

Type: IIndexField

Return Value

Type: IIndexField
IIndexField
Remarks
See Also

Reference

IIndexZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZone.RecognitionProf Property

IIndexZoneRecognitionProf Property

Returns the recognition profile specified for the index zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRecognitionProf RecognitionProf { get; set; }
Property RecognitionProf As IRecognitionProf
    Get
    Set

Property Value

Type: IRecognitionProf

Return Value

Type: IRecognitionProf
IRecognitionProf
Remarks
Nothing indicates that the zone has manual recognition.
See Also

Reference

IIndexZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZone.ZoneHeight Property

IIndexZoneZoneHeight Property

Returns the height of the zone in BMUs (1/1200th of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneHeight { get; set; }
Property ZoneHeight As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZone.ZoneLeft Property

IIndexZoneZoneLeft Property

Returns the left coordinate of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneLeft { get; set; }
Property ZoneLeft As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZone.ZoneTop Property

IIndexZoneZoneTop Property

Returns the top coordinate of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneTop { get; set; }
Property ZoneTop As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZone.ZoneWidth Property

IIndexZoneZoneWidth Property

Returns the width of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneWidth { get; set; }
Property ZoneWidth As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZones Interface

IIndexZones Interface

IIndexZones COM Interface.

Defines COM collection of IndexZone objects associated with the document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5C6-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IIndexZones
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5C6-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IIndexZones

The IIndexZones type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of IndexZone objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZones Methods

IIndexZones Methods

The IIndexZones type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IIndexZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZones.GetEnumerator Method

IIndexZonesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IIndexZones object.
See Also

Reference

IIndexZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZones Properties

IIndexZones Properties

The IIndexZones type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of IndexZone objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IIndexZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZones.Count Property

IIndexZonesCount Property

Returns the number of IndexZone objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IIndexZones.Item Property

IIndexZonesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexZone this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IIndexZone
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IIndexZone

Return Value

Type: IIndexZone
IIndexZone
Remarks
See Also

Reference

IIndexZones Interface
Kofax.Capture.AdminModule.InteropServices Namespace


Implementation Class

Implementation Class
Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesImplementation

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB611-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public sealed class Implementation : IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB611-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public NotInheritable Class Implementation
    Implements IDisposable

The Implementation type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Implements Dispose method.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


Implementation Methods

Implementation Methods

The Implementation type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Implements Dispose method.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Implementation Class
Kofax.Capture.AdminModule.InteropServices Namespace


Implementation.Dispose Method

ImplementationDispose Method

Implements Dispose method.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

Implementation Class
Kofax.Capture.AdminModule.InteropServices Namespace


ImportEventArgs Class

ImportEventArgs Class

ImportEventArgs COM implementation class.

The setup OCX receives the ImportCustomFiles action event during a batch class import.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesImportEventArgs

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D001A-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class ImportEventArgs : IImportEventArgs,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D001A-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class ImportEventArgs
    Implements IImportEventArgs, IDisposable

The ImportEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | ImportEventArgs | Initializes a new instance of the Kofax.Capture.AdminModule.InteropServices.ImportEventArgs class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BatchClass | The batch class that is being imported.
Public property | ImportFolder | A folder specified by Tungsten Capture, created before triggering the event.
Top
Remarks
The event occurs after the batch class is imported and the setup information has extracted to a unique folder. The folder hierarchy is the same as what was exported by the Setup OCX during Batch Class Export.

The Setup OCX can copy any setup data from the Import folder before returning from the event. The Import folder is deleted by Kofax Capture after returning from the KfxOcxEventBatchClassImportevent.

Registered setup OCXs with an associated runtime module receive this event whenever batch class import occurs.

When an import event occurs, an ImportEventArgs object is received as the second parameter of the action event.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


ImportEventArgs Constructor

ImportEventArgs Constructor

Initializes a new instance of the Kofax.Capture.AdminModule.InteropServices.ImportEventArgs class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ImportEventArgs()
Public Sub New
Remarks
See Also

Reference

ImportEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


ImportEventArgs Methods

ImportEventArgs Methods

The ImportEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ImportEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


ImportEventArgs.Dispose Method

ImportEventArgsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

ImportEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


ImportEventArgs Properties

ImportEventArgs Properties

The ImportEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | BatchClass | The batch class that is being imported.
Public property | ImportFolder | A folder specified by Tungsten Capture, created before triggering the event.
Top
See Also

Reference

ImportEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


ImportEventArgs.BatchClass Property

ImportEventArgsBatchClass Property

The batch class that is being imported.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchClass BatchClass { get; }
Public ReadOnly Property BatchClass As IBatchClass
    Get

Property Value

Type: IBatchClass

Return Value

Type: IBatchClass
IBatchClass

Implements

IImportEventArgsBatchClass
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

ImportEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


ImportEventArgs.ImportFolder Property

ImportEventArgsImportFolder Property

A folder specified by Tungsten Capture, created before triggering the event.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ImportFolder { get; }
Public ReadOnly Property ImportFolder As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IImportEventArgsImportFolder
Remarks

After the import is complete, the folder is deleted.

The folder will be off the workstation local path. It will be similar to:

C:\Documents and Settings\All Users\Application Data\Kofax\Capture\AdminDb\MyModuleId

Or

C:\Documents and Settings\All Users\Application Data\Kofax\CaptureSV\AdminDb\MyModuleId
See Also

Reference

ImportEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField Class

IndexField Class

IndexField COM implementation class.

Defines information about a document or folder index field.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesIndexField

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D001C-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class IndexField : IIndexField, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D001C-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class IndexField
    Implements IIndexField, IDisposable

The IndexField type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | MoveIndexFieldTo | Moves the index field from its current location to the position before oNextIndexField.
Public method | MoveIndexFieldToTable | Moves this index field to the specified table, prior to oNextIndexField.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomStorageString | Sets or gets the storage string with the specified name.
Public property | Default | Gets the index field default value.
Public property | DisplayLabel | Sets or gets the value of a supported index field display label.
Public property | FieldType | The field type of the index field.
Public property | Hidden | Gets or sets the "Hidden" value of the index field.
Public property | Name | Returns the index field name.
Public property | Required | Gets or sets the "Required" value of the index field.
Public property | Sticky | Gets or sets the "Sticky" value of the index field.
Public property | TableDefinition | Returns the table definition associated with the index field.
Public property | Total | Sets or gets the "Total" value of the index field.
Public property | Verify | Gets or sets the "Verify" value of the index field.
Top
Remarks
An IndexField object is valid until it is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IndexField Methods

IndexField Methods

The IndexField type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | MoveIndexFieldTo | Moves the index field from its current location to the position before oNextIndexField.
Public method | MoveIndexFieldToTable | Moves this index field to the specified table, prior to oNextIndexField.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.Dispose Method

IndexFieldDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.MoveIndexFieldTo Method

IndexFieldMoveIndexFieldTo Method

Moves the index field from its current location to the position before oNextIndexField.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void MoveIndexFieldTo(
    ref IIndexField oNextIndexField = null
)
Public Sub MoveIndexFieldTo (
    Optional ByRef oNextIndexField As IIndexField = Nothing
)

Parameters

oNextIndexField (Optional)
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
If oNextIndexField is Nothing, the index field is moved to the end. Otherwise, it is added before oNextIndexField.

Implements

IIndexFieldMoveIndexFieldTo(IIndexField)
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.MoveIndexFieldToTable Method

IndexFieldMoveIndexFieldToTable Method

Moves this index field to the specified table, prior to oNextIndexField.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void MoveIndexFieldToTable(
    ref ITableDefinition oTableDefinition,
    ref IIndexField oNextIndexField = null
)
Public Sub MoveIndexFieldToTable (
    ByRef oTableDefinition As ITableDefinition,
    Optional ByRef oNextIndexField As IIndexField = Nothing
)

Parameters

oTableDefinition
Type: Kofax.Capture.AdminModule.InteropServicesITableDefinition
Move the index field into this table.
oNextIndexField (Optional)
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
If oNextIndexField is Nothing, moved to the end of the table. If the old location of this index field was a table, and it was the only index field, that table is deleted.

Implements

IIndexFieldMoveIndexFieldToTable(ITableDefinition, IIndexField)
Remarks

Errors:

(KfxApiErrBadParameterRange) oNextIndexField is not Nothing and is not in oTableDef.

See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField Properties

IndexField Properties

The IndexField type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | Sets or gets the storage string with the specified name.
Public property | Default | Gets the index field default value.
Public property | DisplayLabel | Sets or gets the value of a supported index field display label.
Public property | FieldType | The field type of the index field.
Public property | Hidden | Gets or sets the "Hidden" value of the index field.
Public property | Name | Returns the index field name.
Public property | Required | Gets or sets the "Required" value of the index field.
Public property | Sticky | Gets or sets the "Sticky" value of the index field.
Public property | TableDefinition | Returns the table definition associated with the index field.
Public property | Total | Sets or gets the "Total" value of the index field.
Public property | Verify | Gets or sets the "Verify" value of the index field.
Top
See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.CustomStorageString Property

IndexFieldCustomStorageString Property

Sets or gets the storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the index field.

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexFieldCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific index field. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.Default Property

IndexFieldDefault Property

Gets the index field default value.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Default { get; set; }
Public Property Default As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexFieldDefault
Remarks

Read - Returns the default value, if one is specified.

Write - The value is validated against the FieldType.

See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.DisplayLabel Property

IndexFieldDisplayLabel Property

Sets or gets the value of a supported index field display label.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string DisplayLabel { get; set; }
Public Property DisplayLabel As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexFieldDisplayLabel
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.FieldType Property

IndexFieldFieldType Property

The field type of the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFieldType FieldType { get; set; }
Public Property FieldType As IFieldType
    Get
    Set

Property Value

Type: IFieldType

Return Value

Type: IFieldType
IFieldType

Implements

IIndexFieldFieldType
Remarks

Read - Returns a FieldType object. If an invalid default value is present, it is replaced with the default value for the data type.

Write - When a FieldType is written to an IndexField, several other properties are modified:Default will be set to the default for the field type.
Total will be set to False if the field type is not numeric.

The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.Hidden Property

IndexFieldHidden Property

Gets or sets the "Hidden" value of the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Hidden { get; set; }
Public Property Hidden As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IIndexFieldHidden
Remarks

Read - ReturnsTrue if the field is hidden in Validation and Verification.
Write - Sets the value. If Hidden is True, Required, Verify, Sticky, and Total are set to False.

See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.Name Property

IndexFieldName Property

Returns the index field name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexFieldName
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.Required Property

IndexFieldRequired Property

Gets or sets the "Required" value of the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Required { get; set; }
Public Property Required As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IIndexFieldRequired
Remarks

Read - Returns True if a value is required in Validation and Verification.

Write - Sets the value. If Required is True, Hidden is set to False.

See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.Sticky Property

IndexFieldSticky Property

Gets or sets the "Sticky" value of the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Sticky { get; set; }
Public Property Sticky As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IIndexFieldSticky
Remarks

Read - ReturnsTrue or False. If True, the value of the index field for a document is carried over to the next document. The Validation or Verification operators can override the value in the subsequent document if necessary.

Write - Sets the value. If Sticky is True, Hidden is set to False.

This function throws:

(KfxApiErrBadParameterRange) if setting for a table field.

See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.TableDefinition Property

IndexFieldTableDefinition Property

Returns the table definition associated with the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ITableDefinition TableDefinition { get; }
Public ReadOnly Property TableDefinition As ITableDefinition
    Get

Property Value

Type: ITableDefinition

Return Value

Type: ITableDefinition
ITableDefinition

Implements

IIndexFieldTableDefinition
Remarks
Nothing if not a table field.
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.Total Property

IndexFieldTotal Property

Sets or gets the "Total" value of the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Total { get; set; }
Public Property Total As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IIndexFieldTotal
Remarks

Read - Returns True or False. If True, the Scan operator is solicited for an expected value for the total. Has no meaning for folder index fields.

Write - Sets the value. True is valid only for numeric index fields.

This function throws:

(KfxApiErrBadParameterRange) if setting for a table field.

See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexField.Verify Property

IndexFieldVerify Property

Gets or sets the "Verify" value of the index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Verify { get; set; }
Public Property Verify As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IIndexFieldVerify
Remarks

Read - Returns True if the field should appear in Verification.

Write - Sets the value. If Verify is True, Hidden is set to False.

See Also

Reference

IndexField Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexFields Class

IndexFields Class

IndexFields COM implementation class.

Defines a COM collection of IndexField objects associated with document and folder classes.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesIndexFields

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0020-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class IndexFields : IIndexFields,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0020-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class IndexFields
    Implements IIndexFields, IEnumerable, IDisposable

The IndexFields type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of IndexField objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
The IndexFields object is valid until the document class or folder class is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IndexFields Methods

IndexFields Methods

The IndexFields type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndexFields Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexFields.Dispose Method

IndexFieldsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

IndexFields Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexFields.GetEnumerator Method

IndexFieldsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IIndexFields object.

Implements

IIndexFieldsGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexFields Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexFields Properties

IndexFields Properties

The IndexFields type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of IndexField objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IndexFields Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexFields.Count Property

IndexFieldsCount Property

Returns the number of IndexField objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexFieldsCount
Remarks
See Also

Reference

IndexFields Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexFields.Item Property

IndexFieldsItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexField this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IIndexField
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IIndexField

Return Value

Type: IIndexField
IIndexField

Implements

IIndexFieldsItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexFields Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone Class

IndexGroupZone Class

IndexGroupZone COM implementation class.

Defines information about an Index Group Zone.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesIndexGroupZone

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0022-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class IndexGroupZone : IIndexGroupZone,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0022-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class IndexGroupZone
    Implements IIndexGroupZone, IDisposable

The IndexGroupZone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ShowPropertiesDialog | Displays the Index Group Zone Properties dialog for the zone.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ConcatenateCharacter | If GroupZonePickBest is False, this character is used to delimit the results from each field.
Public property | Count | Returns the number of index zones belonging to this index group zone.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Field | Returns the name of the index field for the index group zone.
Public property | IndexField | Returns the index field for the index group zone.
Public property | IndexGrpMemZones | Returns the index group member zones belonging to this index group zone.
Public property | MaximumResultSet | Returns the maximum number of non-blank child zones needed to produce a non-blank result.
Public property | MinimumResultSet | Returns the minimum number of non-blank child zones needed to produce a non-blank result.
Public property | PickBest | If True, the result will be the single child zone with the highest confidence. If False, the results from all zones will be concatenated.
Public property | ValidationDisplay | If True, the group zone will be displayed in Validation. If False, the most confident child zone is displayed.
Public property | ZoneHeight | Returns the height of the index group zone, in BMUs.
Public property | ZoneLeft | Returns the x coordinate of the upper-left corner of the index group zone, in BMUs.
Public property | ZoneTop | Returns the y coordinate of the upper-left corner of the index group zone, in BMUs.
Public property | ZoneWidth | Returns the width of the index group zone, in BMUs.
Top
Remarks
A IndexGroupZone object is valid until it is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone Methods

IndexGroupZone Methods

The IndexGroupZone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ShowPropertiesDialog | Displays the Index Group Zone Properties dialog for the zone.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.Dispose Method

IndexGroupZoneDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.ShowPropertiesDialog Method

IndexGroupZoneShowPropertiesDialog Method

Displays the Index Group Zone Properties dialog for the zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool ShowPropertiesDialog(
    ref BatchClass oBatchClass
)
Public Function ShowPropertiesDialog (
    ByRef oBatchClass As BatchClass
) As Boolean

Parameters

oBatchClass
Type: Kofax.Capture.AdminModule.InteropServicesBatchClass
Identifies the batch class containing the document class. If Nothing or null, Zone Test is not available.

Return Value

Type: Boolean

Implements

IIndexGroupZoneShowPropertiesDialog(BatchClass)
Remarks

True if the user exited by pressing the OK button.

False if the user cancelled the dialog.

Modifications made in the Index Group Zone Properties dialog are committed to the database when OK or Apply are pressed. The new values are immediately accessible to the Index Group Zone object.
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone Properties

IndexGroupZone Properties

The IndexGroupZone type exposes the following members.

Properties
 | Name | Description
Public property | ConcatenateCharacter | If GroupZonePickBest is False, this character is used to delimit the results from each field.
Public property | Count | Returns the number of index zones belonging to this index group zone.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Field | Returns the name of the index field for the index group zone.
Public property | IndexField | Returns the index field for the index group zone.
Public property | IndexGrpMemZones | Returns the index group member zones belonging to this index group zone.
Public property | MaximumResultSet | Returns the maximum number of non-blank child zones needed to produce a non-blank result.
Public property | MinimumResultSet | Returns the minimum number of non-blank child zones needed to produce a non-blank result.
Public property | PickBest | If True, the result will be the single child zone with the highest confidence. If False, the results from all zones will be concatenated.
Public property | ValidationDisplay | If True, the group zone will be displayed in Validation. If False, the most confident child zone is displayed.
Public property | ZoneHeight | Returns the height of the index group zone, in BMUs.
Public property | ZoneLeft | Returns the x coordinate of the upper-left corner of the index group zone, in BMUs.
Public property | ZoneTop | Returns the y coordinate of the upper-left corner of the index group zone, in BMUs.
Public property | ZoneWidth | Returns the width of the index group zone, in BMUs.
Top
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.ConcatenateCharacter Property

IndexGroupZoneConcatenateCharacter Property

If GroupZonePickBest is False, this character is used to delimit the results from each field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ConcatenateCharacter { get; set; }
Public Property ConcatenateCharacter As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexGroupZoneConcatenateCharacter
Remarks
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.Count Property

IndexGroupZoneCount Property

Returns the number of index zones belonging to this index group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexGroupZoneCount
Remarks
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.CustomStorageString Property

IndexGroupZoneCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the index group zone.

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexGroupZoneCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific index group zone. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.Field Property

IndexGroupZoneField Property

Returns the name of the index field for the index group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Field { get; }
Public ReadOnly Property Field As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexGroupZoneField
Remarks
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.IndexField Property

IndexGroupZoneIndexField Property

Returns the index field for the index group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexField IndexField { get; set; }
Public Property IndexField As IIndexField
    Get
    Set

Property Value

Type: IIndexField

Return Value

Type: IIndexField
IIndexField

Implements

IIndexGroupZoneIndexField
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.IndexGrpMemZones Property

IndexGroupZoneIndexGrpMemZones Property

Returns the index group member zones belonging to this index group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexGrpMemZones IndexGrpMemZones { get; }
Public ReadOnly Property IndexGrpMemZones As IIndexGrpMemZones
    Get

Property Value

Type: IIndexGrpMemZones

Return Value

Type: IIndexGrpMemZones
IIndexGrpMemZones

Implements

IIndexGroupZoneIndexGrpMemZones
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.MaximumResultSet Property

IndexGroupZoneMaximumResultSet Property

Returns the maximum number of non-blank child zones needed to produce a non-blank result.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int MaximumResultSet { get; set; }
Public Property MaximumResultSet As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexGroupZoneMaximumResultSet
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.MinimumResultSet Property

IndexGroupZoneMinimumResultSet Property

Returns the minimum number of non-blank child zones needed to produce a non-blank result.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int MinimumResultSet { get; set; }
Public Property MinimumResultSet As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexGroupZoneMinimumResultSet
Remarks
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.PickBest Property

IndexGroupZonePickBest Property

If True, the result will be the single child zone with the highest confidence. If False, the results from all zones will be concatenated.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool PickBest { get; set; }
Public Property PickBest As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IIndexGroupZonePickBest
Remarks
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.ValidationDisplay Property

IndexGroupZoneValidationDisplay Property

If True, the group zone will be displayed in Validation. If False, the most confident child zone is displayed.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool ValidationDisplay { get; set; }
Public Property ValidationDisplay As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IIndexGroupZoneValidationDisplay
Remarks
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.ZoneHeight Property

IndexGroupZoneZoneHeight Property

Returns the height of the index group zone, in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneHeight { get; set; }
Public Property ZoneHeight As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexGroupZoneZoneHeight
Remarks
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.ZoneLeft Property

IndexGroupZoneZoneLeft Property

Returns the x coordinate of the upper-left corner of the index group zone, in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneLeft { get; set; }
Public Property ZoneLeft As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexGroupZoneZoneLeft
Remarks
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.ZoneTop Property

IndexGroupZoneZoneTop Property

Returns the y coordinate of the upper-left corner of the index group zone, in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneTop { get; set; }
Public Property ZoneTop As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexGroupZoneZoneTop
Remarks
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZone.ZoneWidth Property

IndexGroupZoneZoneWidth Property

Returns the width of the index group zone, in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneWidth { get; set; }
Public Property ZoneWidth As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexGroupZoneZoneWidth
Remarks
See Also

Reference

IndexGroupZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZones Class

IndexGroupZones Class

IndexGroupZones COM implementation class.

Defines a COM collection of IndexGroupZone objects associated with the document class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesIndexGroupZones

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0024-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class IndexGroupZones : IIndexGroupZones,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0024-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class IndexGroupZones
    Implements IIndexGroupZones, IEnumerable, IDisposable

The IndexGroupZones type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of IndexGroupZone objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
Iteration and extraction by order number (with the item function) are supported. Extraction by name is also supported. Passing an out-of-range, or invalid parameter to the item function causes it to generate an error.

IndexGroupZone are sorted in the same order as they appear under the index zone node under the sample page. The IndexGroupZones object is valid until the parent sample page is deleted.

The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZones Methods

IndexGroupZones Methods

The IndexGroupZones type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndexGroupZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZones.Dispose Method

IndexGroupZonesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

IndexGroupZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZones.GetEnumerator Method

IndexGroupZonesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IIndexGroupZones object.

Implements

IIndexGroupZonesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexGroupZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZones Properties

IndexGroupZones Properties

The IndexGroupZones type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of IndexGroupZone objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IndexGroupZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZones.Count Property

IndexGroupZonesCount Property

Returns the number of IndexGroupZone objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexGroupZonesCount
Remarks
See Also

Reference

IndexGroupZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGroupZones.Item Property

IndexGroupZonesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexGroupZone this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IIndexGroupZone
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IIndexGroupZone

Return Value

Type: IIndexGroupZone
IIndexGroupZone

Implements

IIndexGroupZonesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexGroupZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZone Class

IndexGrpMemZone Class

IndexGrpMemZone COM implementation class.

Defines a member of a group zone.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesIndexGrpMemZone

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0026-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class IndexGrpMemZone : IIndexGrpMemZone,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0026-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class IndexGrpMemZone
    Implements IIndexGrpMemZone, IDisposable

The IndexGrpMemZone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ShowPropertiesDialog | Displays the Index Zone Properties dialog for the zone.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Field | Returns the field name of index group member zone.
Public property | IndexField | Returns the index field for the index group member zone.
Public property | RecognitionProf | Returns the recognition profile specified for the index group member zone.
Public property | ZoneHeight | Returns the height of the index group member zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the index group member zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the index group member zone in BMUs.
Public property | ZoneWidth | Returns the width of the index group member zone in BMUs.
Top
Remarks
An IndexGrpMemZone object is valid until it is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZone Methods

IndexGrpMemZone Methods

The IndexGrpMemZone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ShowPropertiesDialog | Displays the Index Zone Properties dialog for the zone.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndexGrpMemZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZone.Dispose Method

IndexGrpMemZoneDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

IndexGrpMemZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZone.ShowPropertiesDialog Method

IndexGrpMemZoneShowPropertiesDialog Method

Displays the Index Zone Properties dialog for the zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool ShowPropertiesDialog(
    ref BatchClass oBatchClass
)
Public Function ShowPropertiesDialog (
    ByRef oBatchClass As BatchClass
) As Boolean

Parameters

oBatchClass
Type: Kofax.Capture.AdminModule.InteropServicesBatchClass
Identifies the batch class containing the document class. If Nothing or null, Zone Test is not available.

Return Value

Type: Boolean

Implements

IIndexGrpMemZoneShowPropertiesDialog(BatchClass)
Remarks

True if the user exited by pressing the OK button.

False if the user cancelled the dialog.

Modifications made in the Index Group Zone Properties dialog are committed to the database when OK or Apply are pressed. The new values are immediately accessible to the Index Group Zone Member object.

This is the same dialog that is displayed by the Index Zone.
See Also

Reference

IndexGrpMemZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZone Properties

IndexGrpMemZone Properties

The IndexGrpMemZone type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Field | Returns the field name of index group member zone.
Public property | IndexField | Returns the index field for the index group member zone.
Public property | RecognitionProf | Returns the recognition profile specified for the index group member zone.
Public property | ZoneHeight | Returns the height of the index group member zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the index group member zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the index group member zone in BMUs.
Public property | ZoneWidth | Returns the width of the index group member zone in BMUs.
Top
See Also

Reference

IndexGrpMemZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZone.CustomStorageString Property

IndexGrpMemZoneCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the index zone.

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexGrpMemZoneCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific index group member zone. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

A group member zone is a type of index zone using the same Index field as a group zone. If the index field is changed, the customs storage string is not deleted. It remains as a property of the zone.

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.
See Also

Reference

IndexGrpMemZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZone.Field Property

IndexGrpMemZoneField Property

Returns the field name of index group member zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Field { get; }
Public ReadOnly Property Field As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexGrpMemZoneField
Remarks
See Also

Reference

IndexGrpMemZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZone.IndexField Property

IndexGrpMemZoneIndexField Property

Returns the index field for the index group member zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexField IndexField { get; set; }
Public Property IndexField As IIndexField
    Get
    Set

Property Value

Type: IIndexField

Return Value

Type: IIndexField
IIndexField

Implements

IIndexGrpMemZoneIndexField
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexGrpMemZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZone.RecognitionProf Property

IndexGrpMemZoneRecognitionProf Property

Returns the recognition profile specified for the index group member zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRecognitionProf RecognitionProf { get; set; }
Public Property RecognitionProf As IRecognitionProf
    Get
    Set

Property Value

Type: IRecognitionProf

Return Value

Type: IRecognitionProf
IRecognitionProf

Implements

IIndexGrpMemZoneRecognitionProf
Remarks
Nothing if manual zone.
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexGrpMemZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZone.ZoneHeight Property

IndexGrpMemZoneZoneHeight Property

Returns the height of the index group member zone in BMUs (1/1200th of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneHeight { get; set; }
Public Property ZoneHeight As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexGrpMemZoneZoneHeight
Remarks
See Also

Reference

IndexGrpMemZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZone.ZoneLeft Property

IndexGrpMemZoneZoneLeft Property

Returns the left coordinate of the index group member zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneLeft { get; set; }
Public Property ZoneLeft As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexGrpMemZoneZoneLeft
Remarks
See Also

Reference

IndexGrpMemZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZone.ZoneTop Property

IndexGrpMemZoneZoneTop Property

Returns the top coordinate of the index group member zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneTop { get; set; }
Public Property ZoneTop As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexGrpMemZoneZoneTop
Remarks
See Also

Reference

IndexGrpMemZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZone.ZoneWidth Property

IndexGrpMemZoneZoneWidth Property

Returns the width of the index group member zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneWidth { get; set; }
Public Property ZoneWidth As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexGrpMemZoneZoneWidth
Remarks
See Also

Reference

IndexGrpMemZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZones Class

IndexGrpMemZones Class

IndexGrpMemZones COM implementation class.

Defines a COM collection of IndexGrpMemZone objects associated with the index group zone.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesIndexGrpMemZones

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("638D0028-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class IndexGrpMemZones : IIndexGrpMemZones,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("638D0028-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class IndexGrpMemZones
    Implements IIndexGrpMemZones, IEnumerable, IDisposable

The IndexGrpMemZones type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of IndexGrpMemZone objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
Iteration and extraction by order number (with the item function) are supported. Extraction by name is also supported. Passing an out-of-range, or invalid parameter to the item function causes it to generate an error.

IndexGrpMemZones are sorted in the same order as they appear under the index group zone node under the index zones node.

The IndexGrpMemZones object is valid until the parent index group zone is deleted.

The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZones Methods

IndexGrpMemZones Methods

The IndexGrpMemZones type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndexGrpMemZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZones.Dispose Method

IndexGrpMemZonesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

IndexGrpMemZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZones.GetEnumerator Method

IndexGrpMemZonesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IIndexGrpMemZones object.

Implements

IIndexGrpMemZonesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexGrpMemZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZones Properties

IndexGrpMemZones Properties

The IndexGrpMemZones type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of IndexGrpMemZone objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IndexGrpMemZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZones.Count Property

IndexGrpMemZonesCount Property

Returns the number of IndexGrpMemZone objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexGrpMemZonesCount
Remarks
See Also

Reference

IndexGrpMemZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexGrpMemZones.Item Property

IndexGrpMemZonesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexGrpMemZone this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IIndexGrpMemZone
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IIndexGrpMemZone

Return Value

Type: IIndexGrpMemZone
IIndexGrpMemZone

Implements

IIndexGrpMemZonesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexGrpMemZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZone Class

IndexZone Class

IndexZone COM implementation class.

Defines information about an index zone.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesIndexZone

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5C3-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class IndexZone : IIndexZone, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5C3-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class IndexZone
    Implements IIndexZone, IDisposable

The IndexZone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ShowPropertiesDialog | Displays the Index Zone Properties dialog for the zone.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Field | Returns the index zone field name.
Public property | IndexField | Returns the index field for the index zone.
Public property | RecognitionProf | Returns the recognition profile specified for the index zone.
Public property | ZoneHeight | Returns the height of the zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the zone in BMUs.
Public property | ZoneWidth | Returns the width of the zone in BMUs.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IndexZone Methods

IndexZone Methods

The IndexZone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ShowPropertiesDialog | Displays the Index Zone Properties dialog for the zone.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndexZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZone.Dispose Method

IndexZoneDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

IndexZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZone.ShowPropertiesDialog Method

IndexZoneShowPropertiesDialog Method

Displays the Index Zone Properties dialog for the zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool ShowPropertiesDialog(
    ref BatchClass oBatchClass
)
Public Function ShowPropertiesDialog (
    ByRef oBatchClass As BatchClass
) As Boolean

Parameters

oBatchClass
Type: Kofax.Capture.AdminModule.InteropServicesBatchClass
Identifies the batch class containing the document class. If Nothing or null, Zone Test is not available.

Return Value

Type: Boolean

Implements

IIndexZoneShowPropertiesDialog(BatchClass)
Remarks

True if the user exited by pressing the OK button.

False if the user cancelled the dialog.

Modifications made in the Index Group Zone Properties dialog are committed to the database when OK or Apply are pressed. The new values are immediately accessible to the Index Zone object.

See Also

Reference

IndexZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZone Properties

IndexZone Properties

The IndexZone type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Field | Returns the index zone field name.
Public property | IndexField | Returns the index field for the index zone.
Public property | RecognitionProf | Returns the recognition profile specified for the index zone.
Public property | ZoneHeight | Returns the height of the zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the zone in BMUs.
Public property | ZoneWidth | Returns the width of the zone in BMUs.
Top
See Also

Reference

IndexZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZone.CustomStorageString Property

IndexZoneCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the index field.

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexZoneCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific index zone. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IndexZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZone.Field Property

IndexZoneField Property

Returns the index zone field name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Field { get; }
Public ReadOnly Property Field As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexZoneField
Remarks
See Also

Reference

IndexZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZone.IndexField Property

IndexZoneIndexField Property

Returns the index field for the index zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexField IndexField { get; set; }
Public Property IndexField As IIndexField
    Get
    Set

Property Value

Type: IIndexField

Return Value

Type: IIndexField
IIndexField

Implements

IIndexZoneIndexField
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZone.RecognitionProf Property

IndexZoneRecognitionProf Property

Returns the recognition profile specified for the index zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRecognitionProf RecognitionProf { get; set; }
Public Property RecognitionProf As IRecognitionProf
    Get
    Set

Property Value

Type: IRecognitionProf

Return Value

Type: IRecognitionProf
IRecognitionProf

Implements

IIndexZoneRecognitionProf
Remarks
Nothing indicates that the zone has manual recognition.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZone.ZoneHeight Property

IndexZoneZoneHeight Property

Returns the height of the zone in BMUs (1/1200th of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneHeight { get; set; }
Public Property ZoneHeight As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexZoneZoneHeight
Remarks
See Also

Reference

IndexZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZone.ZoneLeft Property

IndexZoneZoneLeft Property

Returns the left coordinate of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneLeft { get; set; }
Public Property ZoneLeft As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexZoneZoneLeft
Remarks
See Also

Reference

IndexZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZone.ZoneTop Property

IndexZoneZoneTop Property

Returns the top coordinate of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneTop { get; set; }
Public Property ZoneTop As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexZoneZoneTop
Remarks
See Also

Reference

IndexZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZone.ZoneWidth Property

IndexZoneZoneWidth Property

Returns the width of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneWidth { get; set; }
Public Property ZoneWidth As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexZoneZoneWidth
Remarks
See Also

Reference

IndexZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZones Class

IndexZones Class

IndexZones COM implementation class.

Defines COM collection of IndexZone objects associated with the document class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesIndexZones

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5C7-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class IndexZones : IIndexZones, IEnumerable,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5C7-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class IndexZones
    Implements IIndexZones, IEnumerable, IDisposable

The IndexZones type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of IndexZone objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
Iteration and extraction by order number (with the item function) are supported. Extraction by name is also supported. Passing an out-of-range, or invalid parameter to the item function causes it to generate an error.

IndexZones objects are sorted in the same order as they appear under the index zone node under the sample page. The IndexZones object is valid until the parent sample page is deleted.

The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IndexZones Methods

IndexZones Methods

The IndexZones type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndexZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZones.Dispose Method

IndexZonesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

IndexZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZones.GetEnumerator Method

IndexZonesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IIndexZones object.

Implements

IIndexZonesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZones Properties

IndexZones Properties

The IndexZones type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of IndexZone objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IndexZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZones.Count Property

IndexZonesCount Property

Returns the number of IndexZone objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexZonesCount
Remarks
See Also

Reference

IndexZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IndexZones.Item Property

IndexZonesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexZone this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IIndexZone
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IIndexZone

Return Value

Type: IIndexZone
IIndexZone

Implements

IIndexZonesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

IndexZones Class
Kofax.Capture.AdminModule.InteropServices Namespace


IPageLevelBarcode Interface

IPageLevelBarcode Interface

IPageLevelBarcode COM Interface.

Defines a field assigned for page level bar codes.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5C8-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IPageLevelBarcode
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5C8-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IPageLevelBarcode

The IPageLevelBarcode type exposes the following members.

Properties
 | Name | Description
Public property | Field | Gets the Field name of the PageLevelBarcode.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IPageLevelBarcode Properties

IPageLevelBarcode Properties

The IPageLevelBarcode type exposes the following members.

Properties
 | Name | Description
Public property | Field | Gets the Field name of the PageLevelBarcode.
Top
See Also

Reference

IPageLevelBarcode Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IPageLevelBarcode.Field Property

IPageLevelBarcodeField Property

Gets the Field name of the PageLevelBarcode.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Field { get; }
ReadOnly Property Field As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IPageLevelBarcode Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IPgLvlBarcodeColl Interface

IPgLvlBarcodeColl Interface

IPgLvlBarcodeColl COM Interface.

Defines a COM collection of PageLevelBarcode objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5CA-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IPgLvlBarcodeColl
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5CA-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IPgLvlBarcodeColl

The IPgLvlBarcodeColl type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IPgLvlBarcodeColl Methods

IPgLvlBarcodeColl Methods

The IPgLvlBarcodeColl type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IPgLvlBarcodeColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IPgLvlBarcodeColl.GetEnumerator Method

IPgLvlBarcodeCollGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IPgLvlBarcodeColl object.
See Also

Reference

IPgLvlBarcodeColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IPgLvlBarcodeColl Properties

IPgLvlBarcodeColl Properties

The IPgLvlBarcodeColl type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IPgLvlBarcodeColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IPgLvlBarcodeColl.Count Property

IPgLvlBarcodeCollCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IPgLvlBarcodeColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IPgLvlBarcodeColl.Item Property

IPgLvlBarcodeCollItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPageLevelBarcode this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IPageLevelBarcode
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IPageLevelBarcode

Return Value

Type: IPageLevelBarcode
IPageLevelBarcode
Remarks
See Also

Reference

IPgLvlBarcodeColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueue Interface

IQueue Interface

IQueue COM Interface.

Defines information about a Queue.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5CC-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IQueue
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5CC-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IQueue

The IQueue type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the Queue.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IQueue Properties

IQueue Properties

The IQueue type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the Queue.
Top
See Also

Reference

IQueue Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueue.Name Property

IQueueName Property

Returns the name of the Queue.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IQueue Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueueProperties Interface

IQueueProperties Interface

IQueueProperties COM Interface.

Defines a COM collection of QueueProperty objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5CE-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IQueueProperties
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5CE-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IQueueProperties

The IQueueProperties type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a custom queue property to the collection.
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | Remove | Removes a property from the collection.
Top
Properties
 | Name | Description
Public property | Count | Returns number of custom queue properties in the collection.
Public property | Item | Returns the custom queue property specified by index.
Top
Remarks
A QueueProperty object is valid until it is deleted.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IQueueProperties Methods

IQueueProperties Methods

The IQueueProperties type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a custom queue property to the collection.
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | Remove | Removes a property from the collection.
Top
See Also

Reference

IQueueProperties Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueueProperties.Add Method

IQueuePropertiesAdd Method

Adds a custom queue property to the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IQueueProperty Add(
    ref string Name
)
Function Add (
    ByRef Name As String
) As IQueueProperty

Parameters

Name
Type: SystemString
An error is generated if Name matches an object already in the collection.

Return Value

Type: IQueueProperty
IQueueProperty
Remarks
See Also

Reference

IQueueProperties Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueueProperties.GetEnumerator Method

IQueuePropertiesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IQueueProperties object.
See Also

Reference

IQueueProperties Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueueProperties.Remove Method

IQueuePropertiesRemove Method

Removes a property from the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Remove(
    Object index
)
Sub Remove (
    index As Object
)

Parameters

index
Type: SystemObject
Remarks
See Also

Reference

IQueueProperties Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueueProperties Properties

IQueueProperties Properties

The IQueueProperties type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns number of custom queue properties in the collection.
Public property | Item | Returns the custom queue property specified by index.
Top
See Also

Reference

IQueueProperties Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueueProperties.Count Property

IQueuePropertiesCount Property

Returns number of custom queue properties in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IQueueProperties Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueueProperties.Item Property

IQueuePropertiesItem Property

Returns the custom queue property specified by index.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IQueueProperty this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IQueueProperty
    Get

Parameters

vntIndexKey
Type: SystemObject
If index is Long, the indexed property is returned, with the index range being 1 to Count. If index is a String, the property with the matching name is returned. An error is generated for an invalid index.

Property Value

Type: IQueueProperty

Return Value

Type: IQueueProperty
IQueueProperty
See Also

Reference

IQueueProperties Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueueProperty Interface

IQueueProperty Interface

IQueueProperty COM Interface.

Defines the information for one custom queue property.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5D0-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IQueueProperty
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5D0-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IQueueProperty

The IQueueProperty type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns Property name.
Public property | Value | Gets or sets the value of a property.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IQueueProperty Properties

IQueueProperty Properties

The IQueueProperty type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns Property name.
Public property | Value | Gets or sets the value of a property.
Top
See Also

Reference

IQueueProperty Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueueProperty.Name Property

IQueuePropertyName Property

Returns Property name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
Maximum length is 254.
See Also

Reference

IQueueProperty Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueueProperty.Value Property

IQueuePropertyValue Property

Gets or sets the value of a property.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Value { get; set; }
Property Value As String
    Get
    Set

Property Value

Type: String
The value of a property.

Return Value

Type: String
String
Remarks
Maximum length is 254.
See Also

Reference

IQueueProperty Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueues Interface

IQueues Interface

IQueues COM Interface.

Defines a COM collection of Queue objects associated with the application.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5D2-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IQueues
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5D2-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IQueues

The IQueues type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of Queue objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IQueues Methods

IQueues Methods

The IQueues type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IQueues Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueues.GetEnumerator Method

IQueuesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IQueues object.
See Also

Reference

IQueues Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueues Properties

IQueues Properties

The IQueues type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of Queue objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IQueues Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueues.Count Property

IQueuesCount Property

Returns the number of Queue objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IQueues Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IQueues.Item Property

IQueuesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IQueue this[
    Object vntIndexKey
] { get; }
ReadOnly Property Item (
    vntIndexKey As Object
) As IQueue
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IQueue

Return Value

Type: IQueue
IQueue
Remarks
See Also

Reference

IQueues Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRecognitionProf Interface

IRecognitionProf Interface

IRecognitionProf COM Interface.

Defines information about a Recognition Profile.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5D4-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IRecognitionProf
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5D4-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IRecognitionProf

The IRecognitionProf type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the Name of the recognition profile.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IRecognitionProf Properties

IRecognitionProf Properties

The IRecognitionProf type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the Name of the recognition profile.
Top
See Also

Reference

IRecognitionProf Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRecognitionProf.Name Property

IRecognitionProfName Property

Returns the Name of the recognition profile.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IRecognitionProf Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRecognitionProfs Interface

IRecognitionProfs Interface

IRecognitionProfs COM Interface.

Defines a COM collection of RecognitionProf objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5D6-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IRecognitionProfs
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5D6-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IRecognitionProfs

The IRecognitionProfs type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of RecognitionProf objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
Iteration and extraction by order number (with the item function) are supported. Extraction by name is also supported. Passing an out-of-range, or invalid parameter to the item function causes it generate an error. RecognitionProf objects are sorted alphabetically.

The RecognitionProf object is always valid while Admin is running.

See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IRecognitionProfs Methods

IRecognitionProfs Methods

The IRecognitionProfs type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IRecognitionProfs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRecognitionProfs.GetEnumerator Method

IRecognitionProfsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IRecognitionProfs object.
See Also

Reference

IRecognitionProfs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRecognitionProfs Properties

IRecognitionProfs Properties

The IRecognitionProfs type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of RecognitionProf objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IRecognitionProfs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRecognitionProfs.Count Property

IRecognitionProfsCount Property

Returns the number of RecognitionProf objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IRecognitionProfs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRecognitionProfs.Item Property

IRecognitionProfsItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRecognitionProf this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IRecognitionProf
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IRecognitionProf

Return Value

Type: IRecognitionProf
IRecognitionProf
Remarks
See Also

Reference

IRecognitionProfs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRegistrationZone Interface

IRegistrationZone Interface

IRegistrationZone COM Interface.

Defines information about a registration zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5D8-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IRegistrationZone
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5D8-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IRegistrationZone

The IRegistrationZone type exposes the following members.

Properties
 | Name | Description
Public property | SearchText | Returns text to search for within the zone during the registration process.
Public property | ShapeType | Returns the shape type of the registration zone.
Public property | ZoneHeight | Returns the height of the registration zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the registration zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the registration zone in BMUs.
Public property | ZoneWidth | Returns the width of the registration zone in BMUs.
Top
Remarks
A RegistrationZone object is valid until it is deleted.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IRegistrationZone Properties

IRegistrationZone Properties

The IRegistrationZone type exposes the following members.

Properties
 | Name | Description
Public property | SearchText | Returns text to search for within the zone during the registration process.
Public property | ShapeType | Returns the shape type of the registration zone.
Public property | ZoneHeight | Returns the height of the registration zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the registration zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the registration zone in BMUs.
Public property | ZoneWidth | Returns the width of the registration zone in BMUs.
Top
See Also

Reference

IRegistrationZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRegistrationZone.SearchText Property

IRegistrationZoneSearchText Property

Returns text to search for within the zone during the registration process.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string SearchText { get; }
ReadOnly Property SearchText As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IRegistrationZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRegistrationZone.ShapeType Property

IRegistrationZoneShapeType Property

Returns the shape type of the registration zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
KfxApiAdminShapeType ShapeType { get; }
ReadOnly Property ShapeType As KfxApiAdminShapeType
    Get

Property Value

Type: KfxApiAdminShapeType

Return Value

Type: KfxApiAdminShapeType
KfxApiAdminShapeType
Remarks
See Also

Reference

IRegistrationZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRegistrationZone.ZoneHeight Property

IRegistrationZoneZoneHeight Property

Returns the height of the registration zone in BMUs (1/1200th of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneHeight { get; }
ReadOnly Property ZoneHeight As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IRegistrationZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRegistrationZone.ZoneLeft Property

IRegistrationZoneZoneLeft Property

Returns the left coordinate of the registration zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneLeft { get; }
ReadOnly Property ZoneLeft As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IRegistrationZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRegistrationZone.ZoneTop Property

IRegistrationZoneZoneTop Property

Returns the top coordinate of the registration zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneTop { get; }
ReadOnly Property ZoneTop As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IRegistrationZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRegistrationZone.ZoneWidth Property

IRegistrationZoneZoneWidth Property

Returns the width of the registration zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneWidth { get; }
ReadOnly Property ZoneWidth As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IRegistrationZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRegZoneColl Interface

IRegZoneColl Interface

IRegZoneColl COM Interface.

Defines a COM collection of RegistrationZone objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5DA-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IRegZoneColl
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5DA-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IRegZoneColl

The IRegZoneColl type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Returns a collection element given a key.
Top
Remarks
Each RegistrationZone object is valid unless the sample page is deleted, or the zone is deleted. The collection itself is valid until the sample page is deleted.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IRegZoneColl Methods

IRegZoneColl Methods

The IRegZoneColl type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IRegZoneColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRegZoneColl.GetEnumerator Method

IRegZoneCollGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IRegZoneColl object.
See Also

Reference

IRegZoneColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRegZoneColl Properties

IRegZoneColl Properties

The IRegZoneColl type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Returns a collection element given a key.
Top
See Also

Reference

IRegZoneColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRegZoneColl.Count Property

IRegZoneCollCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IRegZoneColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRegZoneColl.Item Property

IRegZoneCollItem Property

Returns a collection element given a key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRegistrationZone this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IRegistrationZone
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IRegistrationZone

Return Value

Type: IRegistrationZone
Remarks
See Also

Reference

IRegZoneColl Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRemoteSite Interface

IRemoteSite Interface

IRemoteSite COM Interface.

Defines information about a RemoteSite object.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5DC-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IRemoteSite
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5DC-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IRemoteSite

The IRemoteSite type exposes the following members.

Properties
 | Name | Description
Public property | GUID | Returns the remote site GUID.
Public property | Name | Returns the remote site name.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IRemoteSite Properties

IRemoteSite Properties

The IRemoteSite type exposes the following members.

Properties
 | Name | Description
Public property | GUID | Returns the remote site GUID.
Public property | Name | Returns the remote site name.
Top
See Also

Reference

IRemoteSite Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRemoteSite.GUID Property

IRemoteSiteGUID Property

Returns the remote site GUID.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string GUID { get; }
ReadOnly Property GUID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IRemoteSite Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRemoteSite.Name Property

IRemoteSiteName Property

Returns the remote site name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IRemoteSite Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRemoteSites Interface

IRemoteSites Interface

IRemoteSites COM Interface.

Defines a COM collection of RemoteSite objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5DE-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IRemoteSites
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5DE-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IRemoteSites

The IRemoteSites type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of objects contained in the collection of IRemoteSite objects.
Public property | Item | Retrieves an object from the collection of IRemoteSite objects, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IRemoteSites Methods

IRemoteSites Methods

The IRemoteSites type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IRemoteSites Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRemoteSites.GetEnumerator Method

IRemoteSitesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IRemoteSites object.
See Also

Reference

IRemoteSites Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRemoteSites Properties

IRemoteSites Properties

The IRemoteSites type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of objects contained in the collection of IRemoteSite objects.
Public property | Item | Retrieves an object from the collection of IRemoteSite objects, by index or by key.
Top
See Also

Reference

IRemoteSites Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRemoteSites.Count Property

IRemoteSitesCount Property

Returns the number of objects contained in the collection of IRemoteSite objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IRemoteSites Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRemoteSites.Item Property

IRemoteSitesItem Property

Retrieves an object from the collection of IRemoteSite objects, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRemoteSite this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IRemoteSite
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IRemoteSite

Return Value

Type: IRemoteSite
IRemoteSite
Remarks
See Also

Reference

IRemoteSites Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRenameEventArgs Interface

IRenameEventArgs Interface

IRenameEventArgs COM Interface.

Defines an object that is passed to the OCX for the rename action events.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5E0-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IRenameEventArgs
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5E0-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IRenameEventArgs

The IRenameEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewName | Returns the newly assigned object name.
Public property | OldName | Returns the already existing object name.
Public property | ParentName | The name of the parent object.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IRenameEventArgs Properties

IRenameEventArgs Properties

The IRenameEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewName | Returns the newly assigned object name.
Public property | OldName | Returns the already existing object name.
Public property | ParentName | The name of the parent object.
Top
See Also

Reference

IRenameEventArgs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRenameEventArgs.NewName Property

IRenameEventArgsNewName Property

Returns the newly assigned object name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string NewName { get; }
ReadOnly Property NewName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IRenameEventArgs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRenameEventArgs.OldName Property

IRenameEventArgsOldName Property

Returns the already existing object name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string OldName { get; }
ReadOnly Property OldName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IRenameEventArgs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRenameEventArgs.ParentName Property

IRenameEventArgsParentName Property

The name of the parent object.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ParentName { get; }
ReadOnly Property ParentName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
For a batch field, this is the batch class name. For an index field or form type, this is the document class name. For other objects, an empty string is passed.
See Also

Reference

IRenameEventArgs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRGB Interface

IRGB Interface

IRGB COM Interface.

Contains the red, green, and blue values of a color.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5E2-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IRGB
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5E2-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IRGB

The IRGB type exposes the following members.

Properties
 | Name | Description
Public property | Blue | Returns the blue value of the color.
Public property | Green | Returns the green value of the color.
Public property | Red | Returns the red value of the color.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IRGB Properties

IRGB Properties

The IRGB type exposes the following members.

Properties
 | Name | Description
Public property | Blue | Returns the blue value of the color.
Public property | Green | Returns the green value of the color.
Public property | Red | Returns the red value of the color.
Top
See Also

Reference

IRGB Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRGB.Blue Property

IRGBBlue Property

Returns the blue value of the color.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
short Blue { get; }
ReadOnly Property Blue As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short
Remarks
See Also

Reference

IRGB Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRGB.Green Property

IRGBGreen Property

Returns the green value of the color.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
short Green { get; }
ReadOnly Property Green As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short
Remarks
See Also

Reference

IRGB Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IRGB.Red Property

IRGBRed Property

Returns the red value of the color.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
short Red { get; }
ReadOnly Property Red As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short
Remarks
See Also

Reference

IRGB Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage Interface

ISamplePage Interface

ISamplePage COM Interface.

Defines information about the sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5E4-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ISamplePage
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5E4-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ISamplePage

The ISamplePage type exposes the following members.

Methods
 | Name | Description
Public method | CreateAutoIndexZone | Creates an index zone with the specified recognition profile.
Public method | CreateAutoIndexZoneEx | Creates an index zone and returns an index zone object.
Public method | CreateIndexGroupZone | Creates an index group zone, associated with the specified index field.
Public method | CreateIndexGroupZoneEx | Creates an index group zone, associated with the specified index field.
Public method | CreateManualIndexZone | Creates a manual index zone, associated with the specified index field.
Public method | CreateManualIndexZoneEx | Creates an index zone and returns an index zone object.
Public method | DeleteIndexGroupZone | Deletes the index group zone from the sample page.
Public method | DeleteIndexGrpMemZone | Deletes the index group member zone from the sample page.
Public method | DeleteIndexZone | Deletes the index zone from the sample page.
Public method | ReplaceImageFile | Attempts to replace the image in the sample page with the specified file.
Top
Properties
 | Name | Description
Public property | Filename | Returns the Image file name of the sample page.
Public property | IndexGroupZones | Returns the collection of index group zones for the sample page.
Public property | IndexZones | Returns the collection of index zones for the sample page. Does not include zones assigned to a group zone.
Public property | IndexZonesByField | Returns the collection of index zones for the sample page assigned to the specified index field.
Public property | PageHeight | Returns the height of the sample page, measured in BMUs (1/1200 of an inch).
Public property | PageNumber | Returns the page order within the sample document.
Public property | PageWidth | Returns the width of the sample page, measured in BMUs (1/1200 of an inch).
Top
Remarks
The SamplePage object is valid until it, or the parent form type, is deleted.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage Methods

ISamplePage Methods

The ISamplePage type exposes the following members.

Methods
 | Name | Description
Public method | CreateAutoIndexZone | Creates an index zone with the specified recognition profile.
Public method | CreateAutoIndexZoneEx | Creates an index zone and returns an index zone object.
Public method | CreateIndexGroupZone | Creates an index group zone, associated with the specified index field.
Public method | CreateIndexGroupZoneEx | Creates an index group zone, associated with the specified index field.
Public method | CreateManualIndexZone | Creates a manual index zone, associated with the specified index field.
Public method | CreateManualIndexZoneEx | Creates an index zone and returns an index zone object.
Public method | DeleteIndexGroupZone | Deletes the index group zone from the sample page.
Public method | DeleteIndexGrpMemZone | Deletes the index group member zone from the sample page.
Public method | DeleteIndexZone | Deletes the index zone from the sample page.
Public method | ReplaceImageFile | Attempts to replace the image in the sample page with the specified file.
Top
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.CreateAutoIndexZone Method

ISamplePageCreateAutoIndexZone Method

Creates an index zone with the specified recognition profile.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void CreateAutoIndexZone(
    ref IIndexField oIndexField,
    ref IRecognitionProf oRecognitionProf,
    ref int lLeft,
    ref int lTop,
    ref int lWidth,
    ref int lHeight
)
Sub CreateAutoIndexZone (
    ByRef oIndexField As IIndexField,
    ByRef oRecognitionProf As IRecognitionProf,
    ByRef lLeft As Integer,
    ByRef lTop As Integer,
    ByRef lWidth As Integer,
    ByRef lHeight As Integer
)

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The associated index field.
oRecognitionProf
Type: Kofax.Capture.AdminModule.InteropServicesIRecognitionProf
The recognition profile for the zone.
lLeft
Type: SystemInt32
The x coordinate of the top-left corner of the zone.
lTop
Type: SystemInt32
The y coordinate of the top-left corner of the zone.
lWidth
Type: SystemInt32
The width of the zone (in BMUs).
lHeight
Type: SystemInt32
The height of the zone (in BMUs).
Remarks
The dimensions of the zone are in BMUs (1/1200 of an inch).
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.CreateAutoIndexZoneEx Method

ISamplePageCreateAutoIndexZoneEx Method

Creates an index zone and returns an index zone object.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexZone CreateAutoIndexZoneEx(
    ref IIndexField oIndexField,
    ref IRecognitionProf oRecognitionProf,
    ref int lLeft,
    ref int lTop,
    ref int lWidth,
    ref int lHeight
)
Function CreateAutoIndexZoneEx (
    ByRef oIndexField As IIndexField,
    ByRef oRecognitionProf As IRecognitionProf,
    ByRef lLeft As Integer,
    ByRef lTop As Integer,
    ByRef lWidth As Integer,
    ByRef lHeight As Integer
) As IIndexZone

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The associated index field.
oRecognitionProf
Type: Kofax.Capture.AdminModule.InteropServicesIRecognitionProf
The recognition profile for the zone.
lLeft
Type: SystemInt32
The x coordinate of the top-left corner of the zone.
lTop
Type: SystemInt32
The y coordinate of the top-left corner of the zone.
lWidth
Type: SystemInt32
The width of the zone (in BMUs).
lHeight
Type: SystemInt32
The height of the zone (in BMUs).

Return Value

Type: IIndexZone
IIndexZone
Remarks

Creates an index zone with auto recognition, using the specified profile. Is otherwise similar to CreateManualZone.

This function throws:

(KfxApiErrInvalidIndexField) if a zone cannot be assigned to the specified field.

(KfxApiErrInvalidZoneCoordinates) if any portion of the zone rectangle is out of the image bounds.

(KfxApiErrInvalidRecognitionProfile) if the recognition profile is invalid for index zones.
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.CreateIndexGroupZone Method

ISamplePageCreateIndexGroupZone Method

Creates an index group zone, associated with the specified index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void CreateIndexGroupZone(
    ref IIndexField oIndexField,
    ref int lLeft,
    ref int lTop,
    ref int lWidth,
    ref int lHeight
)
Sub CreateIndexGroupZone (
    ByRef oIndexField As IIndexField,
    ByRef lLeft As Integer,
    ByRef lTop As Integer,
    ByRef lWidth As Integer,
    ByRef lHeight As Integer
)

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The associated index field.
lLeft
Type: SystemInt32
The x coordinate of the top-left corner of the zone.
lTop
Type: SystemInt32
The y coordinate of the top-left corner of the zone.
lWidth
Type: SystemInt32
The width of the zone (in BMUs).
lHeight
Type: SystemInt32
The height of the zone (in BMUs).
Remarks
Creates the zone with the same default parameters as in the interactive session. Any existing, and all subsequent, index zones associated with the same index field become children of this group zone. The dimensions of the zone are in BMUs (1/1200 of an inch).
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.CreateIndexGroupZoneEx Method

ISamplePageCreateIndexGroupZoneEx Method

Creates an index group zone, associated with the specified index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexGroupZone CreateIndexGroupZoneEx(
    ref IIndexField oIndexField,
    ref int lLeft,
    ref int lTop,
    ref int lWidth,
    ref int lHeight
)
Function CreateIndexGroupZoneEx (
    ByRef oIndexField As IIndexField,
    ByRef lLeft As Integer,
    ByRef lTop As Integer,
    ByRef lWidth As Integer,
    ByRef lHeight As Integer
) As IIndexGroupZone

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The associated index field.
lLeft
Type: SystemInt32
The x coordinate of the top-left corner of the zone.
lTop
Type: SystemInt32
The y coordinate of the top-left corner of the zone.
lWidth
Type: SystemInt32
The width of the zone (in BMUs).
lHeight
Type: SystemInt32
The height of the zone (in BMUs).

Return Value

Type: IIndexGroupZone
IIndexGroupZone
Remarks
Creates the zone with the same default parameters as in the interactive session. Any existing, and all subsequent, index zones associated with the same index field become children of this group zone. The dimensions of the zone are in BMUs (1/1200 of an inch).

This function throws:

(KfxApiErrInvalidIndexField) if a group zone cannot be assigned to the specified field.

(KfxApiErrInvalidZoneCoordinates) if any portion of the zone rectangle is out of the image bounds.
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.CreateManualIndexZone Method

ISamplePageCreateManualIndexZone Method

Creates a manual index zone, associated with the specified index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void CreateManualIndexZone(
    ref IIndexField oIndexField,
    ref int lLeft,
    ref int lTop,
    ref int lWidth,
    ref int lHeight
)
Sub CreateManualIndexZone (
    ByRef oIndexField As IIndexField,
    ByRef lLeft As Integer,
    ByRef lTop As Integer,
    ByRef lWidth As Integer,
    ByRef lHeight As Integer
)

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The associated index field.
lLeft
Type: SystemInt32
The x coordinate of the top-left corner of the zone.
lTop
Type: SystemInt32
The y coordinate of the top-left corner of the zone.
lWidth
Type: SystemInt32
The width of the zone (in BMUs).
lHeight
Type: SystemInt32
The height of the zone (in BMUs).
Remarks
The dimensions of the zone are in BMUs (1/1200 of an inch).
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.CreateManualIndexZoneEx Method

ISamplePageCreateManualIndexZoneEx Method

Creates an index zone and returns an index zone object.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexZone CreateManualIndexZoneEx(
    ref IIndexField oIndexField,
    ref int lLeft,
    ref int lTop,
    ref int lWidth,
    ref int lHeight
)
Function CreateManualIndexZoneEx (
    ByRef oIndexField As IIndexField,
    ByRef lLeft As Integer,
    ByRef lTop As Integer,
    ByRef lWidth As Integer,
    ByRef lHeight As Integer
) As IIndexZone

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The associated index field.
lLeft
Type: SystemInt32
The x coordinate of the top-left corner of the zone.
lTop
Type: SystemInt32
The y coordinate of the top-left corner of the zone.
lWidth
Type: SystemInt32
The width of the zone (in BMUs).
lHeight
Type: SystemInt32
The height of the zone (in BMUs).

Return Value

Type: IIndexZone
IIndexZone
Remarks

Creates an index zone, associated with the specified index field. The dimensions of the zone are in BMUs (1/1200 of an inch).

This function throws:

(KfxApiErrInvalidIndexField) if a zone cannot be assigned to the specified field.

(KfxApiErrInvalidZoneCoordinates) if any portion of the zone rectangle is out of the image bounds.
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.DeleteIndexGroupZone Method

ISamplePageDeleteIndexGroupZone Method

Deletes the index group zone from the sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteIndexGroupZone(
    ref IIndexGroupZone oIndexGroupZone
)
Sub DeleteIndexGroupZone (
    ByRef oIndexGroupZone As IIndexGroupZone
)

Parameters

oIndexGroupZone
Type: Kofax.Capture.AdminModule.InteropServicesIIndexGroupZone
The index zone to delete.
Remarks
All children of the group zone become children of the sample page.
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.DeleteIndexGrpMemZone Method

ISamplePageDeleteIndexGrpMemZone Method

Deletes the index group member zone from the sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteIndexGrpMemZone(
    ref IIndexGrpMemZone oIndexGrpMemZone
)
Sub DeleteIndexGrpMemZone (
    ByRef oIndexGrpMemZone As IIndexGrpMemZone
)

Parameters

oIndexGrpMemZone
Type: Kofax.Capture.AdminModule.InteropServicesIIndexGrpMemZone
The index zone to delete.
Remarks
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.DeleteIndexZone Method

ISamplePageDeleteIndexZone Method

Deletes the index zone from the sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteIndexZone(
    ref IIndexZone oIndexZone
)
Sub DeleteIndexZone (
    ByRef oIndexZone As IIndexZone
)

Parameters

oIndexZone
Type: Kofax.Capture.AdminModule.InteropServicesIIndexZone
The index zone to delete.
Remarks
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.ReplaceImageFile Method

ISamplePageReplaceImageFile Method

Attempts to replace the image in the sample page with the specified file.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void ReplaceImageFile(
    ref string strPath
)
Sub ReplaceImageFile (
    ByRef strPath As String
)

Parameters

strPath
Type: SystemString
The path name for the new image file.
Remarks
If there is an error, the previous image is preserved. If the file has multiple pages, only the first page is read.
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage Properties

ISamplePage Properties

The ISamplePage type exposes the following members.

Properties
 | Name | Description
Public property | Filename | Returns the Image file name of the sample page.
Public property | IndexGroupZones | Returns the collection of index group zones for the sample page.
Public property | IndexZones | Returns the collection of index zones for the sample page. Does not include zones assigned to a group zone.
Public property | IndexZonesByField | Returns the collection of index zones for the sample page assigned to the specified index field.
Public property | PageHeight | Returns the height of the sample page, measured in BMUs (1/1200 of an inch).
Public property | PageNumber | Returns the page order within the sample document.
Public property | PageWidth | Returns the width of the sample page, measured in BMUs (1/1200 of an inch).
Top
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.Filename Property

ISamplePageFilename Property

Returns the Image file name of the sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Filename { get; }
ReadOnly Property Filename As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.IndexGroupZones Property

ISamplePageIndexGroupZones Property

Returns the collection of index group zones for the sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexGroupZones IndexGroupZones { get; }
ReadOnly Property IndexGroupZones As IIndexGroupZones
    Get

Property Value

Type: IIndexGroupZones

Return Value

Type: IIndexGroupZones
IIndexGroupZones
Remarks
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.IndexZones Property

ISamplePageIndexZones Property

Returns the collection of index zones for the sample page. Does not include zones assigned to a group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexZones IndexZones { get; }
ReadOnly Property IndexZones As IIndexZones
    Get

Property Value

Type: IIndexZones

Return Value

Type: IIndexZones
IIndexZones
Remarks
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.IndexZonesByField Property

ISamplePageIndexZonesByField Property

Returns the collection of index zones for the sample page assigned to the specified index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexZones this[
    IIndexField oIndexField
] { get; }
ReadOnly Property IndexZonesByField (
    oIndexField As IIndexField
) As IIndexZones
    Get

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField

Property Value

Type: IIndexZones

Return Value

Type: IIndexZones
IIndexZones
Remarks
Does not include zones assigned to a group zone. Returns an empty collection if no zones are defined for the given field.
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.PageHeight Property

ISamplePagePageHeight Property

Returns the height of the sample page, measured in BMUs (1/1200 of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int PageHeight { get; }
ReadOnly Property PageHeight As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.PageNumber Property

ISamplePagePageNumber Property

Returns the page order within the sample document.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int PageNumber { get; }
ReadOnly Property PageNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePage.PageWidth Property

ISamplePagePageWidth Property

Returns the width of the sample page, measured in BMUs (1/1200 of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int PageWidth { get; }
ReadOnly Property PageWidth As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ISamplePage Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePages Interface

ISamplePages Interface

ISamplePages COM Interface.

Defines a COM collection of SamplePage objects associated with a form type.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5E6-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ISamplePages
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5E6-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ISamplePages

The ISamplePages type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of SamplePage objects contained in the collection.
Public property | Item | Returns the ISamplePage object specified by a numeric one-based index into the collection.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePages Methods

ISamplePages Methods

The ISamplePages type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

ISamplePages Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePages.GetEnumerator Method

ISamplePagesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.ISamplePages object.
See Also

Reference

ISamplePages Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePages Properties

ISamplePages Properties

The ISamplePages type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of SamplePage objects contained in the collection.
Public property | Item | Returns the ISamplePage object specified by a numeric one-based index into the collection.
Top
See Also

Reference

ISamplePages Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePages.Count Property

ISamplePagesCount Property

Returns the number of SamplePage objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ISamplePages Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISamplePages.Item Property

ISamplePagesItem Property

Returns the ISamplePage object specified by a numeric one-based index into the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ISamplePage this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As ISamplePage
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: ISamplePage

Return Value

Type: ISamplePage
ISamplePage
Remarks
The numeric one-based index is the sort order seen on the tree control, Batch or Document tab, under a Form Type tree item.
See Also

Reference

ISamplePages Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISepAndFormIDProf Interface

ISepAndFormIDProf Interface

ISepAndFormIDProf COM Interface.

Defines information about a separation and form ID profile.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5E8-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ISepAndFormIDProf
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5E8-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ISepAndFormIDProf

The ISepAndFormIDProf type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the profile name.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


ISepAndFormIDProf Properties

ISepAndFormIDProf Properties

The ISepAndFormIDProf type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the profile name.
Top
See Also

Reference

ISepAndFormIDProf Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISepAndFormIDProf.Name Property

ISepAndFormIDProfName Property

Returns the profile name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

ISepAndFormIDProf Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISepAndFormIDProfs Interface

ISepAndFormIDProfs Interface

ISepAndFormIDProfs COM Interface.

Defines a COM collection of ISepAndFormIDProf objects associated with the application.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5EA-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ISepAndFormIDProfs
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5EA-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ISepAndFormIDProfs

The ISepAndFormIDProfs type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of SepAndFormIDProfs objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks

Iteration and extraction by order number (with the item function) are supported. Extraction by name is also supported. Passing an out-of-range, or invalid parameter to the item function causes it to generate an error.

The SepAndFormIDProfs object is sorted alphabetically. The SepAndFormIDProfs object is valid as long as Administration module is running.

See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


ISepAndFormIDProfs Methods

ISepAndFormIDProfs Methods

The ISepAndFormIDProfs type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

ISepAndFormIDProfs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISepAndFormIDProfs.GetEnumerator Method

ISepAndFormIDProfsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.ISepAndFormIDProfs object.
See Also

Reference

ISepAndFormIDProfs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISepAndFormIDProfs Properties

ISepAndFormIDProfs Properties

The ISepAndFormIDProfs type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of SepAndFormIDProfs objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

ISepAndFormIDProfs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISepAndFormIDProfs.Count Property

ISepAndFormIDProfsCount Property

Returns the number of SepAndFormIDProfs objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ISepAndFormIDProfs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISepAndFormIDProfs.Item Property

ISepAndFormIDProfsItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ISepAndFormIDProf this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As ISepAndFormIDProf
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: ISepAndFormIDProf

Return Value

Type: ISepAndFormIDProf
ISepAndFormIDProf
Remarks
See Also

Reference

ISepAndFormIDProfs Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISeparationZone Interface

ISeparationZone Interface

ISeparationZone COM Interface.

Defines information about a separation zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5EC-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ISeparationZone
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5EC-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ISeparationZone

The ISeparationZone type exposes the following members.

Properties
 | Name | Description
Public property | SearchText | Returns text to search for within the zone during the separation process.
Public property | ZoneHeight | Returns the height of the zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the zone in BMUs.
Public property | ZoneWidth | Returns the width of the zone in BMUs.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


ISeparationZone Properties

ISeparationZone Properties

The ISeparationZone type exposes the following members.

Properties
 | Name | Description
Public property | SearchText | Returns text to search for within the zone during the separation process.
Public property | ZoneHeight | Returns the height of the zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the zone in BMUs.
Public property | ZoneWidth | Returns the width of the zone in BMUs.
Top
See Also

Reference

ISeparationZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISeparationZone.SearchText Property

ISeparationZoneSearchText Property

Returns text to search for within the zone during the separation process.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string SearchText { get; }
ReadOnly Property SearchText As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

ISeparationZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISeparationZone.ZoneHeight Property

ISeparationZoneZoneHeight Property

Returns the height of the zone in BMUs (1/1200th of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneHeight { get; }
ReadOnly Property ZoneHeight As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ISeparationZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISeparationZone.ZoneLeft Property

ISeparationZoneZoneLeft Property

Returns the left coordinate of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneLeft { get; }
ReadOnly Property ZoneLeft As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ISeparationZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISeparationZone.ZoneTop Property

ISeparationZoneZoneTop Property

Returns the top coordinate of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneTop { get; }
ReadOnly Property ZoneTop As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ISeparationZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISeparationZone.ZoneWidth Property

ISeparationZoneZoneWidth Property

Returns the width of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneWidth { get; }
ReadOnly Property ZoneWidth As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ISeparationZone Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISuggestedValue Interface

ISuggestedValue Interface

ISuggestedValue COM Interface.

Defines information about a suggested value.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5EE-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ISuggestedValue
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5EE-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ISuggestedValue

The ISuggestedValue type exposes the following members.

Properties
 | Name | Description
Public property | FieldTypeValue | Returns the suggested value.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


ISuggestedValue Properties

ISuggestedValue Properties

The ISuggestedValue type exposes the following members.

Properties
 | Name | Description
Public property | FieldTypeValue | Returns the suggested value.
Top
See Also

Reference

ISuggestedValue Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISuggestedValue.FieldTypeValue Property

ISuggestedValueFieldTypeValue Property

Returns the suggested value.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string FieldTypeValue { get; }
ReadOnly Property FieldTypeValue As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

ISuggestedValue Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISuggestedValues Interface

ISuggestedValues Interface

ISuggestedValues COM Interface.

Defines a COM collection of SuggestedValue objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5F0-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ISuggestedValues
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5F0-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ISuggestedValues

The ISuggestedValues type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of SuggestedValue objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
The SuggestedValues object is always valid while the field type is not deleted.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


ISuggestedValues Methods

ISuggestedValues Methods

The ISuggestedValues type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

ISuggestedValues Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISuggestedValues.GetEnumerator Method

ISuggestedValuesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.ISuggestedValues object.
See Also

Reference

ISuggestedValues Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISuggestedValues Properties

ISuggestedValues Properties

The ISuggestedValues type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of SuggestedValue objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

ISuggestedValues Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISuggestedValues.Count Property

ISuggestedValuesCount Property

Returns the number of SuggestedValue objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ISuggestedValues Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ISuggestedValues.Item Property

ISuggestedValuesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ISuggestedValue this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As ISuggestedValue
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: ISuggestedValue

Return Value

Type: ISuggestedValue
ISuggestedValue
Remarks
See Also

Reference

ISuggestedValues Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ITableDefinition Interface

ITableDefinition Interface

ITableDefinition COM Interface.

Defines a table in a document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5F2-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ITableDefinition
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5F2-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ITableDefinition

The ITableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DisplayLabel | Returns the display label of the table.
Public property | IndexFields | Returns the collection of index fields assigned to this table.
Public property | Name | The name of the table.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


ITableDefinition Properties

ITableDefinition Properties

The ITableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DisplayLabel | Returns the display label of the table.
Public property | IndexFields | Returns the collection of index fields assigned to this table.
Public property | Name | The name of the table.
Top
See Also

Reference

ITableDefinition Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ITableDefinition.DisplayLabel Property

ITableDefinitionDisplayLabel Property

Returns the display label of the table.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string DisplayLabel { get; set; }
Property DisplayLabel As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

ITableDefinition Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ITableDefinition.IndexFields Property

ITableDefinitionIndexFields Property

Returns the collection of index fields assigned to this table.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexFields IndexFields { get; }
ReadOnly Property IndexFields As IIndexFields
    Get

Property Value

Type: IIndexFields

Return Value

Type: IIndexFields
IIndexFields
Remarks
See Also

Reference

ITableDefinition Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ITableDefinition.Name Property

ITableDefinitionName Property

The name of the table.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; set; }
Property Name As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks

Errors:

(KfxApiErrBadParameterRange) if setting an empty string.

(KfxApiErrDuplicateObject) if setting a name that matches that of an existing table in the document class.
See Also

Reference

ITableDefinition Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ITableDefinitions Interface

ITableDefinitions Interface

ITableDefinitions COM Interface.

Defines a collection of tables defined in a document class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5F4-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ITableDefinitions
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5F4-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ITableDefinitions

The ITableDefinitions type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | The number of TableDefinition objects contained in the collection.
Public property | Item | Default property. The default COM collection Item property that returns the specified TableDefinition object specified.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


ITableDefinitions Methods

ITableDefinitions Methods

The ITableDefinitions type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

ITableDefinitions Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ITableDefinitions.GetEnumerator Method

ITableDefinitionsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.ITableDefinitions object.
See Also

Reference

ITableDefinitions Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ITableDefinitions Properties

ITableDefinitions Properties

The ITableDefinitions type exposes the following members.

Properties
 | Name | Description
Public property | Count | The number of TableDefinition objects contained in the collection.
Public property | Item | Default property. The default COM collection Item property that returns the specified TableDefinition object specified.
Top
See Also

Reference

ITableDefinitions Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ITableDefinitions.Count Property

ITableDefinitionsCount Property

The number of TableDefinition objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ITableDefinitions Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ITableDefinitions.Item Property

ITableDefinitionsItem Property

Default property. The default COM collection Item property that returns the specified TableDefinition object specified.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ITableDefinition this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As ITableDefinition
    Get

Parameters

vntIndexKey
Type: SystemObject
Index can either be a table name or a numeric one-based index into the collection.

Property Value

Type: ITableDefinition

Return Value

Type: ITableDefinition
ITableDefinition
Remarks

Errors:

(KfxApiErrBadParameterRange) illegal index value.
See Also

Reference

ITableDefinitions Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ITheme Interface

ITheme Interface

ITheme COM Interface.

A COM object that provides access to the theme of the Tungsten Capture system.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5F6-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ITheme
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5F6-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ITheme

The ITheme type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Returns the background color of the theme.
Public property | Name | Returns the name of the theme.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


ITheme Properties

ITheme Properties

The ITheme type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Returns the background color of the theme.
Public property | Name | Returns the name of the theme.
Top
See Also

Reference

ITheme Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ITheme.BackgroundColor Property

IThemeBackgroundColor Property

Returns the background color of the theme.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRGB BackgroundColor { get; }
ReadOnly Property BackgroundColor As IRGB
    Get

Property Value

Type: IRGB

Return Value

Type: IRGB
IRGB
Remarks
See Also

Reference

ITheme Interface
Kofax.Capture.AdminModule.InteropServices Namespace


ITheme.Name Property

IThemeName Property

Returns the name of the theme.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

ITheme Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IUser Interface

IUser Interface

IUser COM Interface.

Defines information about a User object.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5F8-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IUser
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5F8-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IUser

The IUser type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the user name.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IUser Properties

IUser Properties

The IUser type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the user name.
Top
See Also

Reference

IUser Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IUser.Name Property

IUserName Property

Returns the user name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IUser Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IUsers Interface

IUsers Interface

IUsers COM Interface.

Defines a COM collection of User objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5FA-A63C-11E1-B6C6-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IUsers
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5FA-A63C-11E1-B6C6-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IUsers

The IUsers type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of objects contained in the collection of User objects.
Public property | Item | Retrieves an object from the collection of Users, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


IUsers Methods

IUsers Methods

The IUsers type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IUsers Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IUsers.GetEnumerator Method

IUsersGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IUsers object.
See Also

Reference

IUsers Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IUsers Properties

IUsers Properties

The IUsers type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of objects contained in the collection of User objects.
Public property | Item | Retrieves an object from the collection of Users, by index or by key.
Top
See Also

Reference

IUsers Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IUsers.Count Property

IUsersCount Property

Returns the number of objects contained in the collection of User objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IUsers Interface
Kofax.Capture.AdminModule.InteropServices Namespace


IUsers.Item Property

IUsersItem Property

Retrieves an object from the collection of Users, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IUser this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IUser
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IUser

Return Value

Type: IUser
IUser
See Also

Reference

IUsers Interface
Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiAdminMenuItems Enumeration

KfxApiAdminMenuItems Enumeration

This enumeration represents Administration menu items.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB607-A63C-11E1-B6C6-005056C00008")]
public enum KfxApiAdminMenuItems
<ComVisibleAttribute(true)>
<GuidAttribute("646AB607-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiAdminMenuItems
Members
Member name | Value | Description
KfxAdminMenuFileNewBatchClass | 32780 |
KfxAdminMenuFileNewDocumentClass | 32782 |
KfxAdminMenuFileNewFolderClass | 32871 |
KfxAdminMenuFileNewFormType | 32783 |
KfxAdminMenuFileNewFieldType | 32781 |
KfxAdminMenuFileInsertDocumentClass | 32787 |
KfxAdminMenuFileInsertFolderClass | 32872 |
KfxAdminMenuFileInsertSamplesPage | 32788 |
KfxAdminMenuFileImport | 32773 |
KfxAdminMenuFileExport | 32772 |
KfxAdminMenuFilePublish | 32831 |
KfxAdminMenuFileExit | 57665 |
KfxAdminMenuEditUserTracking | 32857 |
KfxAdminMenuEditUserProfiles | 32858 |
KfxAdminMenuEditACIServerCentralSiteProfile | 32870 |
KfxAdminMenuEditACIServerRemoteSiteProfiles | 61604 |
KfxAdminMenuEditRecognitionProfiles | 32840 |
KfxAdminMenuEditImageCleanUpProfiles | 32841 |
KfxAdminMenuEditSeparationAndFormIDProfiles | 32853 |
KfxAdminMenuEditReservePatchCode | 32856 |
KfxAdminMenuEditAssignedUserProfiles | 32859 |
KfxAdminMenuEditDelete | 55041 |
KfxAdminMenuEditReplaceSamplePage | 57641 |
KfxAdminMenuEditRename | 32862 |
KfxAdminMenuEditRemoveDocument | 55052 |
KfxAdminMenuEditRemoveFolder | 55052 |
KfxAdminMenuEditDeleteAllSamplePages | 32786 |
KfxAdminMenuEditDatabaseValidation | 32861 |
KfxAdminMenuEditProperties | 55043 |
KfxAdminMenuScanStart | 27151 |
KfxAdminMenuScanStop | 27153 |
KfxAdminMenuScanPage | 27152 |
KfxAdminMenuScanSelectScanner | 54534 | Obsolete.
KfxAdminMenuScanReset | 54535 |
KfxAdminMenuScanScannerProfilesLoad | 54531 |
KfxAdminMenuScanScannerProfilesSave | 54532 |
KfxAdminMenuScanProperties | 54530 | Obsolete.
KfxAdminMenuScanDeskewSampleImages | 32864 |
KfxAdminMenuViewLastZoom | 54024 |
KfxAdminMenuViewPageWidth | 54026 |
KfxAdminMenuViewPageHeight | 54027 |
KfxAdminMenuViewWholePage | 54028 |
KfxAdminMenuViewZoom200 | 54033 |
KfxAdminMenuViewZoom150 | 54034 |
KfxAdminMenuViewZoom100 | 54035 |
KfxAdminMenuViewZoom75 | 54036 |
KfxAdminMenuViewZoom50 | 54037 |
KfxAdminMenuViewZoomCustom | 54038 |
KfxAdminMenuViewScaleToGray | 54017 |
KfxAdminMenuViewToolBarsDefinitions | 32771 |
KfxAdminMenuViewToolBarsStandardTools | 32842 | Obsolete.
KfxAdminMenuViewToolBarsZoneTools | 32790 | Obsolete.
KfxAdminMenuViewToolBarsImageTools | 54039 |
KfxAdminMenuViewToolBarsScanControls | 54529 |
KfxAdminMenuViewToolBarsStatusBar | 59393 |
KfxAdminMenuViewRefresh | 32849 |
KfxAdminMenuScriptsFieldMacro | 32850 |
KfxAdminMenuScriptsValidation | 32851 |
KfxAdminMenuScriptsRelease | 32847 |
KfxAdminMenuScriptsRecognition | 32852 |
KfxAdminMenuScriptsFolder | 32873 |
KfxAdminMenuToolsReleaseScriptManager | 32848 |
KfxAdminMenuToolsCustomModuleManager | 32855 |
KfxAdminMenuToolsWorkflowAgentManager | 61600 |
KfxAdminMenuToolsRemoteSiteManager | 61601 |
KfxAdminMenuToolsUserProfileConversionUtility | 61602 | Obsolete.
KfxAdminMenuToolsResetRegistrationPoint | 32863 |
KfxAdminMenuToolsZoneTest | 32860 |
KfxAdminMenuHelpAscentCaptureHelpTopics | 57667 |
KfxAdminMenuHelpAboutAscentCapture | 57664 |
KfxAdminMenuScanAddScanner | 54546 |
KfxAdminMenuScanColorModeBw | 63146 |
KfxAdminMenuScanColorModeGrey | 63147 |
KfxAdminMenuScanColorModeColor | 63148 |
KfxAdminMenuScanDpi | 63054 |
KfxAdminMenuScanFeederFlatbed | 63152 |
KfxAdminMenuScanFeederFeeder | 63151 |
KfxAdminMenuScanSidesSingle | 63070 |
KfxAdminMenuScanSidesDuplex | 63072 |
KfxAdminMenuScanPageSize | 63056 |
KfxAdminMenuScanOrientationPortrait | 63160 |
KfxAdminMenuScanOrientationLandscape | 63159 |
KfxAdminMenuScanAdvancedSrcProp | 63011 |
KfxAdminMenuScanScannerProfilesDelete | 54547 |
KfxAdminMenuScanSaveProfileAsShared | 54548 |
KfxAdminMenuScanRevertToSharedProfiles | 54549 |
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiAdminObjectType Enumeration

KfxApiAdminObjectType Enumeration

Defines object types that is used by Administration module to identify the type of object that has focus after a context change.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5FC-A63C-11E1-B6C6-005056C00008")]
public enum KfxApiAdminObjectType
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5FC-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiAdminObjectType
Members
Member name | Value | Description
KfxAdminObjectTypeBatchClass | 1 | Batch class object type.
KfxAdminObjectTypeDocumentClass | 2 | Document class object type.
KfxAdminObjectTypeFormType | 3 | Form type object type.
KfxAdminObjectTypeSamplePage | 4 | Sample page object type.
KfxAdminObjectTypeSeparationZone | 5 | Separation zone object type.
KfxAdminObjectTypeRegistrationZone | 6 | Registration zone object type.
KfxAdminObjectTypeFormIdZone | 7 | Form identification zone object type.
KfxAdminObjectTypeIndexZone | 8 | Index zone object type.
KfxAdminObjectTypePageLevelBarcode | 9 | Page level Barcode object type.
KfxAdminObjectTypeIndexGroupZone | 14 | Index group zone object type.
KfxAdminObjectTypeIndexGroupMemberZone | 15 | Member of a group zone object type.
KfxAdminObjectTypeFieldType | 10 | Field type object type.
KfxAdminObjectTypeIndexZones | 11 | Index zone collection object type.
KfxAdminObjectTypePageLevelBarcodes | 12 | Page level barcode collection object type.
KfxAdminObjectTypeRegistrationZones | 13 | Registration zone collection object type.
KfxAdminObjectTypeFormIdZones | 16 | Form identification zone object type.
KfxAdminObjectTypeShapeRegistrationZone | 17 | Registration zone object type.
KfxAdminObjectTypeFolderClass | 18 | Folder class object type.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiAdminShapeType Enumeration

KfxApiAdminShapeType Enumeration

Defines shape type object used by Administration module.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5FE-A63C-11E1-B6C6-005056C00008")]
public enum KfxApiAdminShapeType
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5FE-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiAdminShapeType
Members
Member name | Value | Description
KfxAdminShapeTypeLineIntersection | 1 | Line intersection.
KfxAdminShapeTypeTopIntersection | 10 | Top intersection.
KfxAdminShapeTypeBottomIntersection | 11 | Bottom intersection.
KfxAdminShapeTypeLeftIntersection | 12 | Left intersection.
KfxAdminShapeTypeRightIntersection | 13 | Right intersection.
KfxAdminShapeTypeLowerLeftCorner | 20 | Lower-left corner.
KfxAdminShapeTypeLowerRightCorner | 21 | Lower-right corner.
KfxAdminShapeTypeUpperLeftCorner | 22 | Upper-left corner.
KfxAdminShapeTypeUpperRightCorner | 23 | Upper-right corner.
KfxAdminShapeTypeLowerLeftEdge | 30 | Lower-left edge.
KfxAdminShapeTypeLowerRightEdge | 31 | Lower-right edge.
KfxAdminShapeTypeUpperLeftEdge | 32 | Upper-left edge.
KfxAdminShapeTypeUpperRightEdge | 33 | Upper-right edge.
KfxAdminShapeTypeGeneral | 100 | General.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiAdminTabPanel Enumeration

KfxApiAdminTabPanel Enumeration

Defines constant that is used by Administration module to identify the current active tab panel.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5FD-A63C-11E1-B6C6-005056C00008")]
public enum KfxApiAdminTabPanel
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5FD-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiAdminTabPanel
Members
Member name | Value | Description
KfxAdminPanelBatchClass | 1 | Tab batch class.
KfxAdminPanelDocumentClass | 2 | Tab document class.
KfxAdminPanelFieldType | 3 | Tab field type.
KfxAdminPanelFolderClass | 4 | Tab folder class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxAPIApplicationFunctionList Enumeration

KfxAPIApplicationFunctionList Enumeration

Defines the function list that can be blocked or restored menu bar items, context menu items, toolbar buttons, and keyboard accelerators.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB60E-A63C-11E1-B6C6-005056C00008")]
public enum KfxAPIApplicationFunctionList
<ComVisibleAttribute(true)>
<GuidAttribute("646AB60E-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxAPIApplicationFunctionList
Members
Member name | Value | Description
KfxApiBlockGroupBatchFunctions | 62001 |
KfxApiBlockBatchNew | 54784 |
KfxApiBlockBatchOpen | 54785 |
KfxApiBlockBatchClose | 54786 |
KfxApiBlockBatchSuspend | 54788 |
KfxApiBlockBatchDelete | 54787 |
KfxApiBlockBatchExecuteAutoFoldering | 62003 |
KfxApiBlockBatchCreateChildFolder | 54894 |
KfxApiBlockBatchProperties | 54794 |
KfxApiBlockBatchExit | 57665 |
KfxApiBlockBatchUnreleaseDocuments | 32772 |
KfxApiBlockBatchPartialReleaseErrors | 32773 |
KfxApiBlockGroupFolderFunctions | 62006 |
KfxApiBlockFolderCreateChildFolder | 56510 |
KfxApiBlockFolderChangeFolderClass | 56506 |
KfxApiBlockFolderDelete | 54895 |
KfxApiBlockFolderNext | 54898 |
KfxApiBlockFolderPrevious | 54899 |
KfxApiBlockFolderFirst | 54896 |
KfxApiBlockFolderLast | 54897 |
KfxApiBlockGroupDocumentFunctions | 62007 |
KfxApiBlockDocumentCombine | 54978 |
KfxApiBlockDocumentChangeFormType | 54977 |
KfxApiBlockDocumentReject | 55001 |
KfxApiBlockDocumentUnreject | 55003 |
KfxApiBlockDocumentRotateAndSaveLeft | 55007 |
KfxApiBlockDocumentRotateAndSaveRight | 55005 |
KfxApiBlockDocumentDelete | 55009 |
KfxApiBlockDocumentNext | 54903 |
KfxApiBlockDocumentPrevious | 54904 |
KfxApiBlockDocumentFirst | 54901 |
KfxApiBlockDocumentLast | 54902 |
KfxApiBlockDocumentGoto | 54900 |
KfxApiBlockDocumentProperties | 55044 |
KfxApiBlockDocumentCreateFolder | 56507 |
KfxApiBlockDocumentSaveDocument | 54799 |
KfxApiBlockDocumentUnprocessed | 62008 |
KfxApiBlockDocumentVerify | 62009 |
KfxApiBlockGroupPageFunctions | 62010 |
KfxApiBlockPageCreateDocument | 54970 |
KfxApiBlockPageSplitDocument | 54939 |
KfxApiBlockPageReject | 62011 |
KfxApiBlockPageUnreject | 62012 |
KfxApiBlockPageVRSQCLater | 56505 |
KfxApiBlockPageRotateAndSaveLeft | 55006 |
KfxApiBlockPageRotateAndSaveRight | 55004 |
KfxApiBlockPageReplace | 54795 |
KfxApiBlockPageDelete | 55008 |
KfxApiBlockPageInsert | 54792 |
KfxApiBlockPageNext | 54944 |
KfxApiBlockPagePrevious | 54945 |
KfxApiBlockPageFirst | 54946 |
KfxApiBlockPageLast | 54947 |
KfxApiBlockPageGoto | 54948 |
KfxApiBlockPageProperties | 55045 |
KfxApiBlockPageReview | 54961 |
KfxApiBlockGroupFieldFunctions | 62013 |
KfxApiBlockFieldNext | 54980 |
KfxApiBlockFieldPrevious | 54981 |
KfxApiBlockFieldInsertRowAbove | 56514 |
KfxApiBlockFieldInsertRowBelow | 56515 |
KfxApiBlockFieldDeleteRow | 56516 |
KfxApiBlockGroupScanFunctions | 62014 |
KfxApiBlockScanSource | 62015 |
KfxApiBlockScanStart | 27151 |
KfxApiBlockScanStop | 27153 |
KfxApiBlockScanScanPage | 27152 |
KfxApiBlockScanUnattendedMode | 54540 |
KfxApiBlockScanReset | 54535 |
KfxApiBlockScanEnableDuplexOnSimplex | 54536 |
KfxApiBlockScanScannerProfilesLoad | 54531 |
KfxApiBlockScanScannerProfilesSave | 54532 |
KfxApiBlockScanProperties | 54530 | Obsolete.
KfxApiBlockScanAddScanner | 54546 |
KfxApiBlockScanColorModeBw | 63146 |
KfxApiBlockScanColorModeGrey | 63147 |
KfxApiBlockScanColorModeColor | 63148 |
KfxApiBlockScanDpi | 63054 |
KfxApiBlockScanFeederFlatbed | 63152 |
KfxApiBlockScanFeederFeeder | 63151 |
KfxApiBlockScanSidesSingle | 63070 |
KfxApiBlockScanSidesDuplex | 63072 |
KfxApiBlockScanPageSize | 63056 |
KfxApiBlockScanOrientationPortrait | 63160 |
KfxApiBlockScanOrientationLandscape | 63159 |
KfxApiBlockScanAdvancedSrcProp | 63011 |
KfxApiBlockScanScannerProfilesDelete | 54547 |
KfxApiBlockScanSaveProfilesAsShared | 54548 |
KfxApiBlockScanRevertToSharedProfiles | 54549 |
KfxApiBlockGroupViewFunctions | 62016 |
KfxApiBlockGroupViewZoomFunctions | 62017 |
KfxApiBlockViewZoomCombo | 62018 |
KfxApiBlockViewZoom200 | 54033 |
KfxApiBlockViewZoom150 | 54034 |
KfxApiBlockViewZoom100 | 54035 |
KfxApiBlockViewZoom75 | 54036 |
KfxApiBlockViewZoom50 | 54037 |
KfxApiBlockViewCustomZoom | 54038 |
KfxApiBlockViewZoomButtonPan | 62019 |
KfxApiBlockViewZoomButtonZoom | 62020 |
KfxApiBlockViewZoomButtonIn | 62021 |
KfxApiBlockViewZoomButtonOut | 62022 |
KfxApiBlockViewPageWidth | 54026 |
KfxApiBlockViewPageHeight | 54027 |
KfxApiBlockViewWholePage | 54028 |
KfxApiBlockViewScaleToGray | 62023 |
KfxApiBlockViewViewBitonalImage | 54050 |
KfxApiBlockViewExpandBatchContentsTree | 56502 |
KfxApiBlockGroupViewToolBarsFunctions | 62024 |
KfxApiBlockViewToolBarsBatchContents | 62025 |
KfxApiBlockViewToolBarsBatchThumbnails | 62026 |
KfxApiBlockViewToolBarsNotes | 62027 |
KfxApiBlockViewToolBarsBatchNavigation | 62028 |
KfxApiBlockViewToolBarsBatchFilters | 62029 | Obsolete.
KfxApiBlockViewToolBarsImageTools | 62030 |
KfxApiBlockViewToolBarsBatchTools | 62031 | Obsolete.
KfxApiBlockViewToolBarsScanControls | 62032 |
KfxApiBlockViewToolBarsStatusBar | 62033 |
KfxApiBlockViewToolbarsLockToolbars | 62034 |
KfxApiBlockViewToolBarsValidationNavigation | 62035 | Obsolete.
KfxApiBlockViewToolBarsIndexPanel | 62036 |
KfxApiBlockViewRestoreToolbarDefaults | 62037 |
KfxApiBlockViewValidationModeDataEntry | 54982 |
KfxApiBlockViewValidationModeBatchEditing | 54983 |
KfxApiBlockViewMagnifyZone | 54029 |
KfxApiBlockViewAnchorZone | 54030 |
KfxApiBlockViewPanToZone | 54031 |
KfxApiBlockViewManualZoom | 54032 |
KfxApiBlockViewRetainZoom | 54045 |
KfxApiBlockGroupToolsFunctions | 62038 |
KfxApiBlockGroupToolsFilterFunctions | 62039 |
KfxApiBlockToolsFilterCombo | 62040 |
KfxApiBlockToolsFilterAll | 54953 |
KfxApiBlockToolsFilterRejected | 54954 |
KfxApiBlockToolsFilterUnprocessed | 54962 |
KfxApiBlockToolsFilterUnreviewed | 54955 |
KfxApiBlockToolsFilterUnverifiedForm | 54963 |
KfxApiBlockToolsCut | 62041 |
KfxApiBlockToolsPaste | 62042 |
KfxApiBlockToolsOptions | 55042 |
KfxApiBlockGroupHelpFunctions | 62043 |
KfxApiBlockHelpAscentCaptureHelpTopics | 62044 |
KfxApiBlockHelpAboutAscentCapture | 57664 |
KfxApiBlockGroupDeleteFunctions | 62047 |
KfxApiBlockGroupViewLayoutFunctions | 62048 |
KfxApiBlockViewDisplayLayoutAll | 27198 |
KfxApiBlockViewDisplayLayoutBox | 27600 |
KfxApiBlockViewDisplayLayoutTwoRows | 27601 |
KfxApiBlockViewDisplayLayoutThreeRows | 27602 |
KfxApiBlockViewDisplayLayoutTwoColumns | 27603 |
KfxApiBlockViewDisplayLayoutSplitBottom | 27604 |
KfxApiBlockViewDisplayLayoutSplitSize | 27605 |
KfxApiBlockViewZoomSlider | 54553 |
KfxApiBlockViewZoomGroupZoom | 27329 |
KfxApiBlockViewPanMode | 54291 |
KfxApiBlockBatchFilter | 54790 |
KfxApiBlockHomeScanFront | 29000 |
KfxApiBlockHomeScanBack | 29001 |
KfxApiBlockScanSettingsDisplayBlankPages | 54566 |
KfxApiBlockInsertToolPaste | 57637 |
KfxApiBlockInsertToolCopy | 57634 |
KfxApiBlockInsertToolCut | 57635 |
KfxApiBlockHomeModeRubberBand | 54046 |
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiBatchState Enumeration

KfxApiBatchState Enumeration

This enumeration represents Batch states.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB60D-A63C-11E1-B6C6-005056C00008")]
public enum KfxApiBatchState
<ComVisibleAttribute(true)>
<GuidAttribute("646AB60D-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiBatchState
Members
Member name | Value | Description
KfxApiBatchStateReady | 2 | Batch is ready.
KfxApiBatchStateInProgress | 4 | Batch is in progress.
KfxApiBatchStateSuspended | 8 | Batch is suspended.
KfxApiBatchStateError | 32 | Batch is in error.
KfxApiBatchStateCompleted | 64 | Batch is in the completed state.
KfxApiBatchStateReserved | 128 | Reserved.
KfxApiBatchStateInProgress2 | 512 | Reserved.
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiCustomAdminPanel Enumeration

KfxApiCustomAdminPanel Enumeration

Defines kind of custom admin panel can enable/disable import/export event.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB610-A64C-11E1-B6C6-005056C00008")]
public enum KfxApiCustomAdminPanel
<ComVisibleAttribute(true)>
<GuidAttribute("646AB610-A64C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiCustomAdminPanel
Members
Member name | Value | Description
KfxApiCustomAdminPanelKTM | 1 | Disable export event for KTM project
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiErr Enumeration

KfxApiErr Enumeration

Defines the possible errors. All errors are exposed in the KfxApiErr enum value within the Tungsten Capture Module Type Library.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB602-A63C-11E1-B6C6-005056C00008")]
public enum KfxApiErr
<ComVisibleAttribute(true)>
<GuidAttribute("646AB602-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiErr
Members
Member name | Value | Description
KfxApiErrNullParameter | 2100 | A property received an invalid, null value.
KfxApiErrBadParameterType | 2101 | Parameter type mismatch.
KfxApiErrBadParameterArray | 2102 | Internal parameter array error.
KfxApiErrBadParameterRange | 2104 | Parameter out of range.
KfxApiErrInvalidObject | 2105 | The object is no longer valid.
KfxApiErrNotDataEntryMode | 2106 | The operation is only valid in data entry mode with the current document.
KfxApiErrRequiresNumericField | 2107 | The operation is only valid on a numeric field.
KfxApiErrRequiresCharacterField | 2108 | The operation is only valid on a character field.
KfxApiErrNoFormType | 2109 | No form type has been assigned.
KfxApiErrNoReleaseScript | 2110 | No export connector has been assigned.
KfxApiErrInternal | 2111 | Internal API error.
KfxApiErrUnknown | 2112 | Unknown API exception.
KfxApiErrNotDuringEvent | 2113 | Operation not allowed while processing an event.
KfxApiErrDupliateMenuItem | 2114 | Duplicate menu item. The menu cannot be added.
KfxApiErrNoMenuResources | 2115 | Menu resources have been used up. New menus cannot be added.
KfxApiErrNoAcWorkFlow | 2116 | Not available in this application.
KfxApiErrXmlExport | 2117 | XML export failed.
KfxApiErrMenuItemGrayedOut | 2118 | The selected menu item is currently unavailable.
KfxApiErrAppIsBusy | 2119 | The application is busy. The operation was ignored.
KfxApiErrExitNSendImmediate | 2120 | The selected menu item does not handle the immediate option set to true.
KfxApiErrInvalidLogin | 2121 | The user or password is not valid.
KfxApiErrNotPrivileged | 2122 | Insufficient privilege to perform operation.
KfxApiErrBatchOpened | 2123 | A batch is already opened.
KfxApiErrRequiredBatchField | 2124 | A required batch field is not set.
KfxApiErrExpectedBatchTotal | 2125 | An expected batch total is not set.
KfxApiErrNoPagesOrDocs | 2126 | The batch contains no pages or documents.
KfxApiErrEmptyDocs | 2127 | The batch contains empty documents.
KfxApiErrFileNotFound | 2128 | File not found or is not accessible.
KfxApiErrFileFormat | 2129 | File is not of an acceptable format.
KfxApiErrNoMorePages | 2130 | No more pages are left on the license.
KfxApiErrWrongModule | 2131 |
KfxApiErrDuplicateObject | 2132 | A duplicate object already exists.
KfxApiErrOperationCanceled | 2133 | Operation canceled.
KfxApiErrBatchTotals | 2134 | Batch totals mismatch.
KfxApiErrRejectedObject | 2135 | The batch contains rejected documents or pages.
KfxApiErrUnreviewedPages | 2136 | The batch contains unreviewed pages.
KfxApiErrUnverifiedDocs | 2137 | The batch contains unverified documents.
KfxApiErrEmptyBacksides | 2138 | The batch contains empty backside pages.
KfxApiErrPageCountMismatch | 2139 | Expected page count does not match actual page count.
KfxApiErrDocCountMismatch | 2140 | Expected document count does not match actual document count.
KfxApiErrBatchNotOpened | 2141 | A batch is not opened.
KfxApiErrInDataEntryMode | 2142 | Operation not available in data-entry mode.
KfxApiErrUnprocessedDocs | 2143 | The batch contains unprocessed documents.
KfxApiErrObjectinUse | 2144 | The object is in use and cannot be deleted.
KfxApiErrSuggestedValuesSet | 2145 | Suggested values must be removed before SQL type can be modified.
KfxApiErrObjectUnavailable | 2146 | Queue properties are only available to Setup OCX's.
KfxApiErrForceMatchReqSugValues | 2147 | The property SuggestedValuesForceMatchCaseSensitive cannot be set because the SuggestedValues collection is empty.
KfxApiErrForceMatchCaseSensitiveReqSugValues | 2148 | The property SuggestedValuesForceMatch cannot be set because the SuggestedValues collection is empty.
KfxApiErrForceMatchNotSet | 2149 | The property SuggestedValuesForceMatchCaseSensitive cannot be set because SuggestedValuesForceMatch is false.
KfxApiErrInvalidIndexField | 2151 | The specified index field cannot be assigned to this zone.
KfxApiErrDpiChange | 2152 | Image DPI differs from first sample page.
KfxApiErrInvalidZoneCoordinates | 2153 | Zone coordinates out of range.
KfxApiErrInvalidRecognitionProf | 2154 | The recognition profile is not valid for this index zone.
KfxApiErrNotInWorkflow | 2155 | The specified queue is not in the workflow.
KfxApiErrNoEndorsing | 2156 | Endorsing is not enabled.
KfxApiErrNotFixedPages | 2157 | This batch class does not use fixed page separation.
KfxApiErrLoggedIn | 2158 | That operation is not valid when the system is logged in.
KfxApiErrNoAvailableBatches | 2159 |
KfxApiErrSecurityBoostNoPermOnWin2k | 2160 | No batches are available for processing by the current queue.
KfxApiErrAlterActiveTable | 2163 | The operation is not valid when the table contains the active field.
KfxApiErrObjectLocked | 2164 | Unable to seize a required semaphore.
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiKCNSProfilesImportMode Enumeration

KfxApiKCNSProfilesImportMode Enumeration

Defines TCNS profiles import mode.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB610-A63C-11E1-B6C6-005056C00008")]
public enum KfxApiKCNSProfilesImportMode
<ComVisibleAttribute(true)>
<GuidAttribute("646AB610-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiKCNSProfilesImportMode
Members
Member name | Value | Description
KfxKCNSProfilesImportModeNotImported | 1 | Does not import profiles.
KfxKCNSProfilesImportModeSkipDuplicates | 2 | Imports profiles and skip duplicates.
KfxKCNSProfilesImportModeReplaceDuplicates | 3 | Imports profiles and replace duplicates.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiQCMenuItems Enumeration

KfxApiQCMenuItems Enumeration

This enumeration represents Quality Control menu items.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB609-A63C-11E1-B6C6-005056C00008")]
public enum KfxApiQCMenuItems
<ComVisibleAttribute(true)>
<GuidAttribute("646AB609-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiQCMenuItems
Members
Member name | Value | Description
KfxQCMenuBatchOpen | 54785 |
KfxQCMenuBatchClose | 54786 |
KfxQCMenuBatchSuspend | 54788 |
KfxQCMenuBatchDelete | 54787 |
KfxQCMenuBatchUnreleaseDocuments | 32772 |
KfxQCMenuBatchProperties | 54794 |
KfxQCMenuBatchExit | 57665 |
KfxQCMenuDocumentCombine | 54978 |
KfxQCMenuDocumentChangeFormType | 54977 |
KfxQCMenuDocumentReject | 55001 |
KfxQCMenuDocumentUnreject | 55003 |
KfxQCMenuDocumentVerify | 54960 |
KfxQCMenuDocumentRotateAndSaveRight | 55005 |
KfxQCMenuDocumentRotateAndSaveLeft | 55007 |
KfxQCMenuDocumentDelete | 55009 |
KfxQCMenuDocumentNext | 54903 |
KfxQCMenuDocumentPrevious | 54904 |
KfxQCMenuDocumentFirst | 54901 |
KfxQCMenuDocumentLast | 54902 |
KfxQCMenuDocumentGoto | 54900 |
KfxQCMenuDocumentProperties | 55044 |
KfxQCMenuPageCreateDocument | 54970 |
KfxQCMenuPageSplitDocument | 54939 |
KfxQCMenuPageReject | 55000 |
KfxQCMenuPageUnreject | 55002 |
KfxQCMenuPageReview | 54961 |
KfxQCMenuPageRotateAndSaveRight | 55004 |
KfxQCMenuPageRotateAndSaveLeft | 55006 |
KfxQCMenuPageDelete | 55008 |
KfxQCMenuPageReplace | 54795 |
KfxQCMenuPageInsert | 54792 |
KfxQCMenuPageNext | 54944 |
KfxQCMenuPagePrevious | 54945 |
KfxQCMenuPageFirst | 54946 |
KfxQCMenuPageLast | 54947 |
KfxQCMenuPageGoto | 54948 |
KfxQCMenuPageProperties | 55045 |
KfxQCMenuScanStart | 27151 |
KfxQCMenuScanStop | 27153 |
KfxQCMenuScanScanPage | 27152 |
KfxQCMenuScanReset | 54535 |
KfxQCMenuScanEnableDuplexOnSimplex | 54536 |
KfxQCMenuScanScannerProfilesLoad | 54531 |
KfxQCMenuScanScannerProfilesSave | 54532 |
KfxQCMenuScanProperites | 54530 | Obsolete.
KfxQCMenuViewLastZoom | 54024 |
KfxQCMenuViewPageWidth | 54026 |
KfxQCMenuViewPageHeight | 54027 |
KfxQCMenuViewWholePage | 54028 |
KfxQCMenuViewZoom200 | 54033 |
KfxQCMenuViewZoom150 | 54034 |
KfxQCMenuViewZoom100 | 54035 |
KfxQCMenuViewZoom75 | 54036 |
KfxQCMenuViewZoom50 | 54037 |
KfxQCMenuViewZoomCustom | 54038 |
KfxQCMenuViewScaleToGray | 54017 |
KfxQCMenuViewViewBitonalImage | 54050 |
KfxQCMenuViewExpandBatchContentsTree | 56502 |
KfxQCMenuViewToolBarsBatchContents | 54921 |
KfxQCMenuViewToolBarsBatchThumbnails | 54925 |
KfxQCMenuViewToolBarsBatchTools | 54923 | Obsolete.
KfxQCMenuViewToolBarsBatchNavigation | 54924 |
KfxQCMenuViewToolBarsBatchFilter | 54956 | Obsolete.
KfxQCMenuViewToolBarsImageTools | 54039 |
KfxQCMenuViewToolBarsScanControls | 54529 |
KfxQCMenuViewToolBarsNotes | 54922 |
KfxQCMenuViewToolBarsStatusBar | 59393 |
KfxQCMenuToolsFilterAll | 54953 |
KfxQCMenuToolsFilterRejected | 54954 |
KfxQCMenuToolsFilterUnreviewedPages | 54955 |
KfxQCMenuToolsFilterUnreviewedDocs | 54963 |
KfxQCMenuToolsOptions | 55042 |
KfxQCMenuHelpAscentCaptureHelpTopics | 57667 |
KfxQCMenuHelpAboutAscentCapture | 57664 |
KfxQCMenuBatchPartialReleaseErrors | 32773 |
KfxQCMenuPageVRSQCLater | 56505 |
KfxQCMenuBatchExecuteAutoFoldering | 56504 |
KfxQCMenuBatchCreateChildFolder | 54894 |
KfxQCMenuFolderCreateChildFolder | 56510 |
KfxQCMenuFolderChangeFolderClass | 56506 |
KfxQCMenuFolderDelete | 54895 |
KfxQCMenuFolderNext | 54898 |
KfxQCMenuFolderPrevious | 54899 |
KfxQCMenuFolderFirst | 54896 |
KfxQCMenuFolderLast | 54897 |
KfxQCMenuDocumentCreateFolder | 56507 |
KfxQCMenuScanAddScanner | 54546 |
KfxQCMenuScanColorModeBw | 63146 |
KfxQCMenuScanColorModeGrey | 63147 |
KfxQCMenuScanColorModeColor | 63148 |
KfxQCMenuScanDpi | 63054 |
KfxQCMenuScanFeederFlatbed | 63152 |
KfxQCMenuScanFeederFeeder | 63151 |
KfxQCMenuScanSidesSingle | 63070 |
KfxQCMenuScanSidesDuplex | 63072 |
KfxQCMenuScanPageSize | 63056 |
KfxQCMenuScanOrientationPortrait | 63160 |
KfxQCMenuScanOrientationLandscape | 63159 |
KfxQCMenuScanAdvancedSrcProp | 63011 |
KfxQCMenuScanScannerProfilesDelete | 54547 |
KfxQCMenuScanSaveProfileAsShared | 54548 |
KfxQCMenuScanRevertToSharedProfiles | 54549 |
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiScanMenuItems Enumeration

KfxApiScanMenuItems Enumeration

This enumeration represents Scan menu items.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB608-A63C-11E1-B6C6-005056C00008")]
public enum KfxApiScanMenuItems
<ComVisibleAttribute(true)>
<GuidAttribute("646AB608-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiScanMenuItems
Members
Member name | Value | Description
KfxScanMenuBatchNew | 54784 |
KfxScanMenuBatchOpen | 54785 |
KfxScanMenuBatchClose | 54786 |
KfxScanMenuBatchSuspend | 54788 |
KfxScanMenuBatchDelete | 54787 |
KfxScanMenuBatchProperties | 54794 |
KfxScanMenuBatchExit | 57665 |
KfxScanMenuDocumentCombine | 54978 |
KfxScanMenuDocumentChangeFormType | 54977 |
KfxScanMenuDocumentReject | 55001 |
KfxScanMenuDocumentUnreject | 55003 |
KfxScanMenuDocumentRotateAndSaveRight | 55005 |
KfxScanMenuDocumentRotateAndSaveLeft | 55007 |
KfxScanMenuDocumentDelete | 55009 |
KfxScanMenuDocumentNext | 54903 |
KfxScanMenuDocumentPrevious | 54904 |
KfxScanMenuDocumentFirst | 54901 |
KfxScanMenuDocumentLast | 54902 |
KfxScanMenuDocumentGoto | 54900 |
KfxScanMenuDocumentProperties | 55044 |
KfxScanMenuPageCreateDocument | 54970 |
KfxScanMenuPageSplitDocument | 54939 |
KfxScanMenuPageReject | 55000 |
KfxScanMenuPageUnreject | 55002 |
KfxScanMenuPageRotateAndSaveRight | 55004 |
KfxScanMenuPageRotateAndSaveLeft | 55006 |
KfxScanMenuPageDelete | 55008 |
KfxScanMenuPageReplace | 54795 |
KfxScanMenuPageInsert | 54792 |
KfxScanMenuPageNext | 54944 |
KfxScanMenuPagePrevious | 54945 |
KfxScanMenuPageFirst | 54946 |
KfxScanMenuPageLast | 54947 |
KfxScanMenuPageGoto | 54948 |
KfxScanMenuPageProperties | 55045 |
KfxScanMenuScanStart | 27151 |
KfxScanMenuScanStop | 27153 |
KfxScanMenuScanScanPage | 27152 |
KfxScanMenuScanUnattendedMode | 54540 |
KfxScanMenuScanReset | 54535 |
KfxScanMenuScanEnableDuplexOnSimplex | 54536 |
KfxScanMenuScanScannerProfilesLoad | 54531 |
KfxScanMenuScanScannerProfilesSave | 54532 |
KfxScanMenuScanProperties | 54530 | Obsolete.
KfxScanMenuViewLastZoom | 54024 |
KfxScanMenuViewPageWidth | 54026 |
KfxScanMenuViewPageHeight | 54027 |
KfxScanMenuViewWholePage | 54028 |
KfxScanMenuViewZoom200 | 54033 |
KfxScanMenuViewZoom150 | 54034 |
KfxScanMenuViewZoom100 | 54035 |
KfxScanMenuViewZoom75 | 54036 |
KfxScanMenuViewZoom50 | 54037 |
KfxScanMenuViewCustomZoom | 54038 |
KfxScanMenuViewScaleToGray | 54017 |
KfxScanMenuViewViewBitonalImage | 54050 |
KfxScanMenuViewExpandBatchContentsTree | 56502 |
KfxScanMenuViewToolBarsBatchContents | 54921 |
KfxScanMenuViewToolBarsBatchThumbnails | 54925 |
KfxScanMenuViewToolBarsBatchTools | 54923 | Obsolete.
KfxScanMenuViewToolBarsBatchNavigation | 54924 |
KfxScanMenuViewToolBarsBatchFilters | 54956 | Obsolete.
KfxScanMenuViewToolBarsImageTools | 54039 |
KfxScanMenuViewToolBarsScanControls | 54529 |
KfxScanMenuViewToolBarsNotes | 54922 |
KfxScanMenuViewStatusBar | 59393 |
KfxScanMenuToolsFilterAll | 54953 |
KfxScanMenuToolsFilterRejected | 54954 |
KfxScanMenuToolsOptions | 55042 |
KfxScanMenuHelpAscentCaptureHelpTopics | 57667 |
KfxScanMenuHelpAboutAscentCapture | 57664 |
KfxScanMenuPageVRSQCLater | 56505 |
KfxScanMenuBatchExecuteAutoFoldering | 56504 |
KfxScanMenuBatchCreateChildFolder | 54894 |
KfxScanMenuFolderCreateChildFolder | 56510 |
KfxScanMenuFolderChangeFolderClass | 56506 |
KfxScanMenuFolderDelete | 54895 |
KfxScanMenuFolderNext | 54898 |
KfxScanMenuFolderPrevious | 54899 |
KfxScanMenuFolderFirst | 54896 |
KfxScanMenuFolderLast | 54897 |
KfxScanMenuDocumentCreateFolder | 56507 |
KfxScanMenuScanAddScanner | 54546 |
KfxScanMenuScanColorModeBw | 63146 |
KfxScanMenuScanColorModeGrey | 63147 |
KfxScanMenuScanColorModeColor | 63148 |
KfxScanMenuScanDpi | 63054 |
KfxScanMenuScanFeederFlatbed | 63152 |
KfxScanMenuScanFeederFeeder | 63151 |
KfxScanMenuScanSidesSingle | 63070 |
KfxScanMenuScanSidesDuplex | 63072 |
KfxScanMenuScanPageSize | 63056 |
KfxScanMenuScanOrientationPortrait | 63160 |
KfxScanMenuScanOrientationLandscape | 63159 |
KfxScanMenuScanAdvancedSrcProp | 63011 |
KfxScanMenuScanScannerProfilesDelete | 54547 |
KfxScanMenuScanSaveProfileAsShared | 54548 |
KfxScanMenuScanRevertToSharedProfiles | 54549 |
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiTransferMode Enumeration

KfxApiTransferMode Enumeration

Defines transfer mode for import batch class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB60F-A63C-11E1-B6C6-005056C00008")]
public enum KfxApiTransferMode
<ComVisibleAttribute(true)>
<GuidAttribute("646AB60F-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiTransferMode
Members
Member name | Value | Description
KfxTransferModeIngoreDuplicates | 1 | Ignores duplicates.
KfxTransferModeRenameDuplicates | 2 | Renames duplicates.
KfxTransferModeReplaceDuplicates | 3 | Replaces duplicates.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiValidationMenuItems Enumeration

KfxApiValidationMenuItems Enumeration

This enumeration represents Validation menu items.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB60A-A63C-11E1-B6C6-005056C00008")]
public enum KfxApiValidationMenuItems
<ComVisibleAttribute(true)>
<GuidAttribute("646AB60A-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiValidationMenuItems
Members
Member name | Value | Description
KfxValidationMenuBatchOpen | 54785 |
KfxValidationMenuBatchClose | 54786 |
KfxValidationMenuBatchSuspend | 54788 |
KfxValidationMenuBatchDelete | 54787 |
KfxValidationMenuBatchProperties | 54794 |
KfxValidationMenuBatchExit | 57665 |
KfxValidationMenuDocumentSaveDocument | 54799 |
KfxValidationMenuDocumentCombine | 54978 |
KfxValidationMenuDocumentChangeFormType | 54977 |
KfxValidationMenuDocumentReject | 55001 |
KfxValidationMenuDocumentUnreject | 55003 |
KfxValidationMenuDocumentRotateAndSaveRight | 55005 |
KfxValidationMenuDocumentRotateAndSaveLeft | 55007 |
KfxValidationMenuDocumentDelete | 55009 |
KfxValidationMenuDocumentNext | 54903 |
KfxValidationMenuDocumentPrevious | 54904 |
KfxValidationMenuDocumentFirst | 54901 |
KfxValidationMenuDocumentLast | 54902 |
KfxValidationMenuDocumentGoto | 54900 |
KfxValidationMenuDocumentNextUnprocessed | 54905 |
KfxValidationMenuDocumentProperties | 55044 |
KfxValidationMenuPageCreateDocument | 54970 |
KfxValidationMenuPageSplitDocument | 54939 |
KfxValidationMenuPageReject | 55000 |
KfxValidationMenuPageUnreject | 55002 |
KfxValidationMenuPageRotateAndSaveRight | 55004 |
KfxValidationMenuPageRotateAndSaveLeft | 55006 |
KfxValidationMenuPageDelete | 55008 |
KfxValidationMenuPageNext | 54944 |
KfxValidationMenuPagePrevious | 54945 |
KfxValidationMenuPageFirst | 54946 |
KfxValidationMenuPageLast | 54947 |
KfxValidationMenuPageGoto | 54948 |
KfxValidationMenuPageProperties | 55045 |
KfxValidationMenuFieldNext | 54980 |
KfxValidationMenuFieldPrevious | 54981 |
KfxValidationMenuViewLastZoom | 54024 |
KfxValidationMenuViewPageWidth | 54026 |
KfxValidationMenuViewPageHeight | 54027 |
KfxValidationMenuViewWholePage | 54028 |
KfxValidationMenuViewZoom200 | 54033 |
KfxValidationMenuViewZoom150 | 54034 |
KfxValidationMenuViewZoom100 | 54035 |
KfxValidationMenuViewZoom75 | 54036 |
KfxValidationMenuViewZoom50 | 54037 |
KfxValidationMenuViewZoomCustom | 54038 |
KfxValidationMenuViewMagnifyZone | 54029 |
KfxValidationMenuViewAnchorZone | 54030 |
KfxValidationMenuViewPanToZone | 54031 |
KfxValidationMenuViewManualZoom | 54032 |
KfxValidationMenuViewRetainZoom | 54045 |
KfxValidationMenuViewScaleToGray | 54017 |
KfxValidationMenuViewViewBitonalImage | 54050 |
KfxValidationMenuViewExpandBatchContentsTree | 56502 |
KfxValidationMenuViewToolBarsBatchContents | 54921 |
KfxValidationMenuViewToolBarsBatchThumbnails | 54925 |
KfxValidationMenuViewToolBarsBatchTools | 54923 | Obsolete.
KfxValidationMenuViewToolBarsBatchNavigation | 54924 |
KfxValidationMenuViewToolBarsBatchFilters | 54956 | Obsolete.
KfxValidationMenuViewToolBarsImageTools | 54039 |
KfxValidationMenuViewToolBarsNotes | 54922 |
KfxValidationMenuViewToolBarsValidationNavigation | 54984 | Obsolete.
KfxValidationMenuViewToolBarsIndexFields | 54272 |
KfxValidationMenuViewToolBarsStatusBar | 59393 |
KfxValidationMenuToolsFilterAll | 54953 |
KfxValidationMenuToolsFilterRejected | 54954 |
KfxValidationMenuToolsFilterUnprocessed | 54962 |
KfxValidationMenuToolsOptions | 55042 |
KfxValidationMenuHelpAscentCaptureHelpTopics | 57667 |
KfxValidationMenuHelpAboutAscentCapture | 57664 |
KfxValidationMenuViewValidationModeDataEntry | 54982 |
KfxValidationMenuViewValidationModeBatchEditing | 54983 |
KfxValidationMenuBatchExecuteAutoFoldering | 56504 |
KfxValidationMenuBatchCreateChildFolder | 54894 |
KfxValidationMenuFolderCreateChildFolder | 56510 |
KfxValidationMenuFolderChangeFolderClass | 56506 |
KfxValidationMenuFolderDelete | 54895 |
KfxValidationMenuFolderNext | 54898 |
KfxValidationMenuFolderPrevious | 54899 |
KfxValidationMenuFolderFirst | 54896 |
KfxValidationMenuFolderLast | 54897 |
KfxValidationMenuDocumentCreateFolder | 56507 |
KfxValidationMenuFieldInsertRowAbove | 56514 |
KfxValidationMenuFieldInsertRowBelow | 56515 |
KfxValidationMenuFieldDeleteRow | 56516 |
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiValidationMode Enumeration

KfxApiValidationMode Enumeration

This enumeration represents Validation modes.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB60C-A63C-11E1-B6C6-005056C00008")]
public enum KfxApiValidationMode
<ComVisibleAttribute(true)>
<GuidAttribute("646AB60C-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiValidationMode
Members
Member name | Value | Description
KfxApiValidationModeDataEntry | 0 | Mode data entry.
KfxApiValidationModeBatchEditing | 1 | Mode batch editting.
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxApiVerificationMenuItems Enumeration

KfxApiVerificationMenuItems Enumeration

This enumeration represents Verification menu items.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB60B-A63C-11E1-B6C6-005056C00008")]
public enum KfxApiVerificationMenuItems
<ComVisibleAttribute(true)>
<GuidAttribute("646AB60B-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxApiVerificationMenuItems
Members
Member name | Value | Description
KfxVerificationMenuBatchOpen | 54785 |
KfxVerificationMenuBatchClose | 54786 |
KfxVerificationMenuBatchSuspend | 54788 |
KfxVerificationMenuBatchDelete | 54787 |
KfxVerificationMenuBatchProperties | 54794 |
KfxVerificationMenuBatchExit | 57665 |
KfxVerificationMenuDocumentSaveDocument | 54799 |
KfxVerificationMenuDocumentCombine | 54978 |
KfxVerificationMenuDocumentChangeFormType | 54977 |
KfxVerificationMenuDocumentReject | 55001 |
KfxVerificationMenuDocumentUnreject | 55003 |
KfxVerificationMenuDocumentRotateAndSaveRight | 55005 |
KfxVerificationMenuDocumentRotateAndSaveLeft | 55007 |
KfxVerificationMenuDocumentDelete | 55009 |
KfxVerificationMenuDocumentNext | 54903 |
KfxVerificationMenuDocumentPrevious | 54904 |
KfxVerificationMenuDocumentFirst | 54901 |
KfxVerificationMenuDocumentLast | 54902 |
KfxVerificationMenuDocumentGoto | 54900 |
KfxVerificationMenuDocumentUnprocessed | 54905 |
KfxVerificationMenuDocumentProperties | 55044 |
KfxVerificationMenuPageCreateDocument | 54970 |
KfxVerificationMenuPageSplitDocument | 54939 |
KfxVerificationMenuPageReject | 55000 |
KfxVerificationMenuPageUnreject | 55002 |
KfxVerificationMenuPageRotateAndSaveRight | 55004 |
KfxVerificationMenuPageRotateAndSaveLeft | 55006 |
KfxVerificationMenuPageDelete | 55008 |
KfxVerificationMenuPageNext | 54944 |
KfxVerificationMenuPagePrevious | 54945 |
KfxVerificationMenuPageFirst | 54946 |
KfxVerificationMenuPageLast | 54947 |
KfxVerificationMenuPageGoto | 54948 |
KfxVerificationMenuPageProperties | 55045 |
KfxVerificationMenuFieldNext | 54911 |
KfxVerificationMenuFieldPrevious | 54912 |
KfxVerificationMenuViewLastZoom | 54024 |
KfxVerificationMenuViewPageWidth | 54026 |
KfxVerificationMenuViewPageHeight | 54027 |
KfxVerificationMenuViewWholePage | 54028 |
KfxVerificationMenuViewZoom200 | 54033 |
KfxVerificationMenuViewZoom150 | 54034 |
KfxVerificationMenuViewZoom100 | 54035 |
KfxVerificationMenuViewZoom75 | 54036 |
KfxVerificationMenuViewZoom50 | 54037 |
KfxVerificationMenuViewZoomCustom | 54038 |
KfxVerificationMenuViewMagnifyZone | 54029 |
KfxVerificationMenuViewAnchorZone | 54030 |
KfxVerificationMenuViewPanToZone | 54031 |
KfxVerificationMenuViewManualZoom | 54032 |
KfxVerificationMenuViewRetainZoom | 54045 |
KfxVerificationMenuViewScaleToGray | 54017 |
KfxVerificationMenuViewViewBitonalImage | 54050 |
KfxVerificationMenuViewExpandBatchContentsTree | 56502 |
KfxVerificationMenuViewToolBarsBatchContents | 54921 |
KfxVerificationMenuViewToolBarsBatchThumbnails | 54925 |
KfxVerificationMenuViewToolBarsBatchTools | 54923 | Obsolete.
KfxVerificationMenuViewToolBarsBatchNavigation | 54924 |
KfxVerificationMenuViewToolBarsBatchFilters | 54956 | Obsolete.
KfxVerificationMenuViewToolBarsImageTools | 54039 |
KfxVerificationMenuViewToolBarsNotes | 54922 |
KfxVerificationMenuViewToolBarsValidationNavigation | 54984 | Obsolete.
KfxVerificationMenuViewToolBarsIndexFields | 54272 |
KfxVerificationMenuViewToolBarsStatusBar | 59393 |
KfxVerificationMenuToolsFilterAll | 54953 |
KfxVerificationMenuToolsFilterRejected | 54954 |
KfxVerificationMenuToolsFilterUnprocessed | 54962 |
KfxVerificationMenuToolsOptions | 55042 |
KfxVerificationMenuHelpAscentCaptureHelpTopics | 57667 |
KfxVerificationMenuHelpAboutAscentCapture | 57664 |
KfxVerificationMenuViewValidationModeDataEntry | 54982 |
KfxVerificationMenuViewValidationModeBatchEditing | 54983 |
KfxVerificationMenuBatchExecuteAutoFoldering | 56504 |
KfxVerificationMenuBatchCreateChildFolder | 54894 |
KfxVerificationMenuFolderCreateChildFolder | 56510 |
KfxVerificationMenuFolderChangeFolderClass | 56506 |
KfxVerificationMenuFolderDelete | 54895 |
KfxVerificationMenuFolderNext | 54898 |
KfxVerificationMenuFolderPrevious | 54899 |
KfxVerificationMenuFolderFirst | 54896 |
KfxVerificationMenuFolderLast | 54897 |
KfxVerificationMenuDocumentCreateFolder | 56507 |
KfxVerificationMenuFieldInsertRowAbove | 56514 |
KfxVerificationMenuFieldInsertRowBelow | 56515 |
KfxVerificationMenuFieldDeleteRow | 56516 |
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxDataEvent Enumeration

KfxDataEvent Enumeration
Defines the various different data events. Data events are essentially function calls to the OCX to get data-source information and to communicate changes in data.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB606-A63C-11E1-B6C6-005056C00008")]
public enum KfxDataEvent
<ComVisibleAttribute(true)>
<GuidAttribute("646AB606-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxDataEvent
Members
Member name | Value | Description
KfxDataEventAppActionEvent | 65537 | Application action event.
KfxDataEventAppThemeChanged | 1023 | Application theme change event.
KfxDataEventBatchWantRuntimeData | 131587 | Request batch runtime data event.
KfxDataEventBatchSetRuntimeData | 131331 | Set batch runtime data event.
KfxDataEventBatchGetRuntimeData | 131075 | Get batch runtime data event.
KfxDataEventBatchGetClassData | 131074 | Get batch class data for a batch event.
KfxDataEventBatchGetSetupData | 131073 | Get setup data for a batch event.
KfxDataEventBatchUnreleaseDocuments | 131076 | Prevent batch export event.
KfxDataEventDocCreate | 196613 | Create a document event.
KfxDataEventDocDelete | 196612 | Delete a document event.
KfxDataEventDocSetNote | 196867 | Set note for a document event.
KfxDataEventDocSetRejected | 196866 | Set document as rejected event.
KfxDataEventDocSetFormType | 196865 | Set form type for a document event.
KfxDataEventPageCreateStart | 262149 | Start page creation event.
KfxDataEventPageCreateDone | 262150 | Finish page creation event.
KfxDataEventPageGetFilename | 262145 | Get file name for a page event.
KfxDataEventPageFileChange | 262153 | Change file for a page event.
KfxDataEventPageMoveDoc | 262152 | Move document event.
KfxDataEventPageMoveLoose | 262151 | Move loose page event.
KfxDataEventPageDelete | 262148 | Delete page event.
KfxDataEventPageSetOriginalFileName | 262413 | Set page to the original file name event.
KfxDataEventPageSetNote | 262403 | Set note for a page event.
KfxDataEventPageSetRejected | 262402 | Set page as rejected event.
KfxDataEventPageSetEndorsingString | 262410 | Set endorsing string for page event.
KfxDataEventPageSetImageAddress | 262411 | Set image address for page event.
KfxDataEventPageSetRollNumber | 262412 | Set roll number for page event.
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxDataEventReturnCode Enumeration

KfxDataEventReturnCode Enumeration
Defines the enumeration that represents the return code for a data event.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB604-A63C-11E1-B6C6-005056C00008")]
public enum KfxDataEventReturnCode
<ComVisibleAttribute(true)>
<GuidAttribute("646AB604-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxDataEventReturnCode
Members
Member name | Value | Description
KfxDataEventReturnCodeCancel | 1 | Action was cancelled.
KfxDataEventReturnCodeSuccess | 0 | Action was succeed.
KfxDataEventReturnCodeFail | -1 | Action was failed.
KfxDataEventReturnCodeFatal | -100 | Fatal error.
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxDataEventType Enumeration

KfxDataEventType Enumeration

Defines data type event enumeration.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB605-A63C-11E1-B6C6-005056C00008")]
public enum KfxDataEventType
<ComVisibleAttribute(true)>
<GuidAttribute("646AB605-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxDataEventType
Members
Member name | Value | Description
KfxDataEventTypeApp | 1 | Application.
KfxDataEventTypeBatch | 2 | Batch.
KfxDataEventTypeDoc | 3 | Document.
KfxDataEventTypePage | 4 | Page.
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxMenuEnable Enumeration

KfxMenuEnable Enumeration

Defines a possible state of Enabled/Grayed for a menu item.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB601-A63C-11E1-B6C6-005056C00008")]
public enum KfxMenuEnable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB601-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxMenuEnable
Members
Member name | Value | Description
KfxMenuEnabled | 0 | Menu item is enabled.
KfxMenuGrayed | 1 | Menu item is grayed.
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxOcxEvent Enumeration

KfxOcxEvent Enumeration

All application events are passed to the OCX via a single function call.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB603-A63C-11E1-B6C6-005056C00008")]
public enum KfxOcxEvent
<ComVisibleAttribute(true)>
<GuidAttribute("646AB603-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxOcxEvent
Members
Member name Value Description
KfxOcxEventBatchOpened 1

Event raised after a new batch is opened.

KfxOcxEventBatchClosing 2

Event raised before a batch is closed. OCX may cancel.

KfxOcxEventDocumentOpened 3

Event raised after a document is opened. This occurs whenever the user selects or navigates to a different document.

KfxOcxEventDocumentValidating 19

Event raised prior to validating a document on a close in Validation/Verification. Occurs prior to prompt to exit document and final validation, data save, and DocumentClosing event.

KfxOcxEventDocumentClosing 4

Event raised prior to leaving a document. This occurs when the user (or validation script) transitions to another document (or a loose page, or the batch node). Also occurs when switching to batch edit mode in Validation. In Validation/Verification, occurs after any SBL (deprecated) or .NET scripts (for example, PostDocument) have run.

KfxOcxEventFieldEntered 5

Event raised after a field is entered in Validation/Verification. This occurs when a document is selected in Validation, and when the user navigates to a new field. This event occurs before any SBL (deprecated) or .NET scripts (for example, the pre-field) have run.

KfxOcxEventFieldExiting 6

Event raised before a field is exited in Validation/Verification. OCX may cancel. This is called when physically exiting a field to move to another field, to go to a new document, or to close the batch.

KfxOcxEventContextChanged 7

Event raised after the application has moved to a new folder/document/page/field. This event fires after the "entered" events when navigating between objects in Scan, Quality Control, Validation, Verification.

KfxOcxEventContentChanged 9

Event raised after a structural batch editing operation. Note that a "batch editing" operation indicates some sort of change in the page/document/folder hierarchy, such as deleting/adding a page, creating a document, deleting a folder, etc. Index field changes do not trigger this event.

KfxOcxEventBatchEditModeEntered 10

Event raised when the user changes to batch edit mode in Validation/Verification. Occurs when "Data Entry/Batch Edit" is selected.

KfxOcxEventDataEntryModeEntered 11

Event raised when the user changes from batch edit mode to data entry mode in Validation/Verification. Occurs when the "Data Entry/Batch Edit" combo box is selected. By default, Validation/Verification are in data entry mode. No DataEntryModeEntered event fires when those modules start up. The status can be found by checking the DataEntryMode property from the Application API object.

KfxOcxEventPropertyChanged 8

Event raised after a property is changed on a document or page. Specifically, this includes changing the note, reject flag, reviewed flag (Quality Control), and the verified flag (Quality Control). Page/document rotations are also included in this event. Any other batch editing operation (not including index field changes) causes the ContentChanged event to occur instead.

KfxOcxEventBatchRejecting 12

Event raised before a batch is rejected. OCX may cancel. The reason for rejection is passed as a String in vArgument.

KfxOcxEventBatchSuspending 13

Event raised before a batch is suspended. OCX may cancel.

KfxOcxEventBatchDeleting 14

Event raised before batch deletion. OCX may cancel.

KfxOcxEventMenuClicked 15

Event raised when an OCX-defined menu is selected.

KfxOcxEventScanBatchStarted 16

Event raised before scanning starts.

KfxOcxEventScanPageStarted 17

Event raised before scanning a page starts.

KfxOcxEventScanStopped 18

Event raised after scanning stops.

KfxOcxEventBatchCreating 20

OCX must display a create batch dialog. Cancel can be passed if no create is desired. Cancel is passed if the user cancels.

KfxOcxEventBatchCreatingAutoImport 21

Event raised when creating a batch in Auto Import.

KfxOcxEventBatchPropertiesDisplaying 22

OCX must display its Batch Properties dialog. Cancel will cancel the Batch Properties dialog.

KfxOcxEventErrorLogging 23

Event raised whenever an exception that should be logged is thrown. The OCX can cancel to avoid logging the error. The argument parameter is an array with the following elements:

VB
Copy
Argument(1) As Long - ' Error code 1
Argument(2) As Long - ' Error code 2
Argument(3) As Long - ' Error code 3
Argument(4) As String - ' Error message
Argument(5) As String '- Module where error occurred
Argument(6) As Long - ' Line number where error occurred

Errors are sent to the OCX after the it has been created. The OCX is created while the application frame is being generated (but is not yet shown).

KfxOcxEventAboutBoxDisplaying 24

Event raised immediately before displaying the Tungsten Capture About box. If the OCX cancels the event, the Tungsten Capture About box is not displayed.

KfxOcxEventLoggingIn 25

OCX may display a login screen. If Cancel is passed, the application shuts down without ever displaying the main screen.

KfxOcxEventLoggedOut 29

The application is about to shut down. This event is only issued to an OCX that has received and not cancelled a KfxOcxEventLoggingIn event.

KfxOcxEventBatchOpeningNext 26

OCX must open the next available batch. If the OCX does not support this feature, or wishes to cause an interactive open, then it must cancel this event. Failure to cancel will cause the application to assume that a batch should be opened, and the data source will be queried for the batch data.

KfxOcxEventBatchOpeningSelect 27

OCX must display an Open Batch dialog. Cancel can be passed if no open is desired. Cancel is passed if the user cancels.

KfxOcxEventBatchOpeningID 28

This event is used when a batch is opened by batch ID. It passes the internal batch ID as a Long in vArgument. If the OCX cancels this event, the open batch dialog is displayed (after getting the KfxOcxEventBatch SelectOpening event).

KfxOcxEventBatchOpeningCheck 30

Event raised before attempting to open a batch. Canceling opens the Create Batch dialog box.

KfxOcxEventResetFocus 31

This occurs when an eDocument is displayed. In this case, the internal Windows Explorer panel forcibly takes focus. Tungsten Capture regains focus and sets it back to the main OCX window.

If the OCX wishes to set focus to a subcontrol, then it must do so during this event. The runtime OCX is not allowed to perform any actions that modify setup data during any user event. If the OCX tries to perform an action, an error is generated.

KfxOcxEventRowInserted 32

Event raised when a row has been added to a table. The value of Argument is the RowNumber of the added TableRow.

KfxOcxEventRowDeleted 33

Event raised when a row has been removed from a table. The value of Argument is the RowNumber of the deleted TableRow.

KfxOcxEventFolderClosing 34

Event raised prior to leaving a folder. This occurs when the user (or validation script) transitions to another folder (or a document, or a loose page, or the batch node). Also occurs when switching to batch edit mode in Validation. In Validation/ Verification, occurs after any SBL (deprecated) or .NET scripts (for example, PostDocument) have run.

KfxOcxEventFolderOpened 35

Event raised after a folder is opened. This occurs whenever the user selects or navigates to a different folder.

KfxOcxEventFolderValidating 36

Event raised in Validation/Verification prior to validating a folder on a close. Occurs prior to prompt to exit document and final validation, data save, and FolderClosing event.

KfxOcxEventShowingHelp 37

Event raised whenever the F1 or a Help button is pressed.
The argument is 0 for application level help. It is non-zero for context level help.
The HelpID is also referred to as the context ID. A mapping of Help IDs and help topic mappings are provided on the installation CD.
When using a custom standard module, if no cancellation of the event is received, the Help topic for Quality control is displayed.

KfxOcxEventRubberBandOCR 38

Event raised when Rubber Band OCR is performed.

KfxOcxEventBatchNameCreated 39

Event raised when Tungsten Capture generates a batch name. If this event is handled, an OCX will have the ability to override the batch name that was generated.

KfxOcxEventBatchNameCollision 40

Event raised if the new batch name collides with an existing batch name.

KfxOcxEventScanPageEnd 41

Event raised when a page is scanned.

KfxOcxEventScanBatchPreScan 42

Event raised just before a batch scanning.

kfxOcxEventScannerProfileChanged 45

Event raised when a scanner profile is changed.

KfxOcxEventScanDocumentCreated 43

Event raised just after a document is created.

KfxOcxEventBatchEnd 44

Event raised just after the batch scanning is ended.

KfxOcxEventPublishWarningsGet 1000

Event raised just before the end of a batch class Publish operation. Each string added to the collection parameter is displayed as a warning in the Results box when you publish a batch class.

Customization needs to modify the vArgument collection parameter as in the following sample:

C#
VB
Copy
// Adds at least 2 or more elements to the object that is an instance of Kofax.Collection.KfxCollection.
// The first element is an error code that will be ignored, and all other elements will be displayed as warning messages from the Administration module.
if (oArgument is Kofax.Collection.KfxCollection)
{
     Kofax.Collection.KfxCollection oKfxCollection = (Kofax.Collection.KfxCollection)oArgument;
    oKfxCollection.Add(0); // Error code, is currently ignored by Administration
    oKfxCollection.Add("This is a warning 1 from custom panel.");
    oKfxCollection.Add("This is a warning 2 from custom panel.");
}
' Adds at least 2 or more elements to the object that is an instance of Kofax.Collection.KfxCollection.
' The first element is an error code that will be ignored, and all other elements will be displayed as warning messages from the Administration module.
If TypeOf oArgument Is Kofax.Collection.KfxCollection Then
    Dim oKfxCollection As Kofax.Collection.KfxCollection = CType(oArgument, Kofax.Collection.KfxCollection)
    oKfxCollection.Add(0) ' Error code, is currently ignored by Administration
    oKfxCollection.Add("This is a warning 1 from custom panel.")
    oKfxCollection.Add("This is a warning 2 from custom panel.")
End If

KfxOcxEventPublishErrorsGet 1001

Event raised just before the end of a batch class Publish operation. Each string added to the collection parameter is displayed as an error in the Results box when you publish a batch class. Any errors result in a Publish failure.

Customization needs to modify the vArgument collection parameter as in the following sample:

C#
VB
Copy
// Adds at least 2 or more elements to the object that is instance of Kofax.Collection.KfxCollection. The first element is an error code that will be ignored,
// and all other elements will be displayed as error messages from the Administration module.
if (oArgument is Kofax.Collection.KfxCollection)
{
     Kofax.Collection.KfxCollection oKfxCollection = (Kofax.Collection.KfxCollection)oArgument;
    oKfxCollection.Add(0); // Error code, is currently ignored by Administration
    oKfxCollection.Add("This is an error 1 from custom panel.");
    oKfxCollection.Add("This is an error 2 from custom panel.");
}
' Adds at least 2 or more elements to the object that is instance of Kofax.Collection.KfxCollection. The first element is an error code that will be ignored,
' and all other elements will be displayed as error messages from the Administration module.
If TypeOf oArgument Is Kofax.Collection.KfxCollection Then
    Dim oKfxCollection As Kofax.Collection.KfxCollection = CType(oArgument, Kofax.Collection.KfxCollection)
    oKfxCollection.Add(0) ' Error code, is currently ignored by Administration
    oKfxCollection.Add("This is an error 1 from custom panel.")
    oKfxCollection.Add("This is an error 2 from custom panel.")
End If

KfxOcxEventBatchClassRenamed 1010

Event raised before a batch class is renamed.

KfxOcxEventBatchFieldRenamed 1011

Event raised before a batch field is renamed.

KfxOcxEventDocumentClassRenamed 1012

Event raised before a document class is renamed.

KfxOcxEventIndexFieldRenamed 1013

Event raised before a field is renamed.

KfxOcxEventFieldTypeRenamed 1014

Event raised before a field type is renamed.

KfxOcxEventFormTypeRenamed 1015

Event raised before a form type is renamed.

KfxOcxEventBatchClassImport 1016

Event raised when a batch class is imported.

KfxOcxEventBatchClassExport 1017

Event raised when a batch class is exported.

KfxOcxEventFolderClassRenamed 1018

Event raised when a folder class is renamed.

KfxOcxEventBatchClassPaste 1019

Event raised when a batch class is pasted.

KfxOcxEventDocumentClassPaste 1020

Event raised when a document class is pasted.

KfxOcxEventFolderClassPaste 1021

Event raised when a folder class is pasted.

KfxOcxEventFormTypePaste 1022

Event raised when a form type is pasted.

KfxOcxEventAppThemeChanged 1023

Application theme change event.

C#
VB
Copy
// The following sample shows event handling to update the panel’s background color according to the application theme.
if ((int)KfxOcxEvent.KfxOcxEventAppThemeChanged == nActionNumber)
{
    var oColor = m_oApp.Theme.BackgroundColor;
    this.BackColor = System.Drawing.Color.FromArgb(oColor.Red, oColor.Green, oColor.Blue);
}
' The following sample shows event handling to update the panel’s background color according to the application theme.
If KfxOcxEvent.KfxOcxEventAppThemeChanged = nActionNumber Then
    Dim oColor As InteropServices.IRGB = m_oApp.Theme.BackgroundColor
    Me.BackColor = Drawing.Color.FromArgb(oColor.Red, oColor.Green, oColor.Blue)
End If

KfxOcxEventMainWindowCreated 1024

Event raised after the main window is created.

Remarks

Operations that are canceled act as if the event was never initiated.

Note In the warning/error strings passed back to the Administration module, each string should end with a period, in order to conform to the standard warnings and errors.

See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxShowMenu Enumeration

KfxShowMenu Enumeration

Defines the possible menu showing state.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB600-A63C-11E1-B6C6-005056C00008")]
public enum KfxShowMenu
<ComVisibleAttribute(true)>
<GuidAttribute("646AB600-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxShowMenu
Members
Member name | Value | Description
KfxMenuShow | 0 | Shows the menu.
KfxMenuHide | 1 | Hides the menu.
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


KfxSqlDataType Enumeration

KfxSqlDataType Enumeration

Defines SQL data types supported by the API.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5FF-A63C-11E1-B6C6-005056C00008")]
public enum KfxSqlDataType
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5FF-A63C-11E1-B6C6-005056C00008")>
Public Enumeration KfxSqlDataType
Members
Member name | Value | Description
KfxOleChar | 1 | Defines CHAR data type.
KfxOleDate | 9 | Defines DATE data type.
KfxOleDecimal | 3 | Defines DECIMAL data type.
KfxOleDouble | 8 | Defines DOUBLE data type.
KfxOleFloat | 6 | Defines FLOAT data type.
KfxOleInteger | 4 | Defines INTEGER data type.
KfxOleNumeric | 2 | Defines NUMERIC data type.
KfxOleReal | 7 | Defines REAL data type.
KfxOleSmallint | 5 | Defines SMALLINT data type.
KfxOleTime | 10 | Defines TIME data type.
KfxOleVarchar | 12 | Defines VARCHAR data type.
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


PageLevelBarcode Class

PageLevelBarcode Class

PageLevelBarcode COM implementation class.

Defines a field assigned for page level bar codes.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesPageLevelBarcode

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5C9-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class PageLevelBarcode : IPageLevelBarcode,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5C9-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class PageLevelBarcode
    Implements IPageLevelBarcode, IDisposable

The PageLevelBarcode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Field | Gets the Field name of the PageLevelBarcode.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


PageLevelBarcode Methods

PageLevelBarcode Methods

The PageLevelBarcode type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PageLevelBarcode Class
Kofax.Capture.AdminModule.InteropServices Namespace


PageLevelBarcode.Dispose Method

PageLevelBarcodeDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

PageLevelBarcode Class
Kofax.Capture.AdminModule.InteropServices Namespace


PageLevelBarcode Properties

PageLevelBarcode Properties

The PageLevelBarcode type exposes the following members.

Properties
 | Name | Description
Public property | Field | Gets the Field name of the PageLevelBarcode.
Top
See Also

Reference

PageLevelBarcode Class
Kofax.Capture.AdminModule.InteropServices Namespace


PageLevelBarcode.Field Property

PageLevelBarcodeField Property

Gets the Field name of the PageLevelBarcode.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Field { get; }
Public ReadOnly Property Field As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IPageLevelBarcodeField
Remarks
See Also

Reference

PageLevelBarcode Class
Kofax.Capture.AdminModule.InteropServices Namespace


PgLvlBarcodeColl Class

PgLvlBarcodeColl Class

PgLvlBarcodeColl COM implementation class.

Defines a COM collection of PageLevelBarcode objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesPgLvlBarcodeColl

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5CB-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class PgLvlBarcodeColl : IPgLvlBarcodeColl,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5CB-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class PgLvlBarcodeColl
    Implements IPgLvlBarcodeColl, IEnumerable, IDisposable

The PgLvlBarcodeColl type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
The PageLevelBarcode object is valid as long as the sample page is not deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


PgLvlBarcodeColl Methods

PgLvlBarcodeColl Methods

The PgLvlBarcodeColl type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PgLvlBarcodeColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


PgLvlBarcodeColl.Dispose Method

PgLvlBarcodeCollDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

PgLvlBarcodeColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


PgLvlBarcodeColl.GetEnumerator Method

PgLvlBarcodeCollGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IPgLvlBarcodeColl object.

Implements

IPgLvlBarcodeCollGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

PgLvlBarcodeColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


PgLvlBarcodeColl Properties

PgLvlBarcodeColl Properties

The PgLvlBarcodeColl type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

PgLvlBarcodeColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


PgLvlBarcodeColl.Count Property

PgLvlBarcodeCollCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IPgLvlBarcodeCollCount
Remarks
See Also

Reference

PgLvlBarcodeColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


PgLvlBarcodeColl.Item Property

PgLvlBarcodeCollItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPageLevelBarcode this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IPageLevelBarcode
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IPageLevelBarcode

Return Value

Type: IPageLevelBarcode
IPageLevelBarcode

Implements

IPgLvlBarcodeCollItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

PgLvlBarcodeColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


Queue Class

Queue Class

Queue COM implementation class.

Defines information about a Queue.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesQueue

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5CD-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Queue : IQueue, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5CD-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Queue
    Implements IQueue, IDisposable

The Queue type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Returns the name of the Queue.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


Queue Methods

Queue Methods

The Queue type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Queue Class
Kofax.Capture.AdminModule.InteropServices Namespace


Queue.Dispose Method

QueueDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Queue Class
Kofax.Capture.AdminModule.InteropServices Namespace


Queue Properties

Queue Properties

The Queue type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the Queue.
Top
See Also

Reference

Queue Class
Kofax.Capture.AdminModule.InteropServices Namespace


Queue.Name Property

QueueName Property

Returns the name of the Queue.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IQueueName
See Also

Reference

Queue Class
Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperties Class

QueueProperties Class

QueueProperties COM implementation class.

Defines a COM collection of QueueProperty objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesQueueProperties

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5CF-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class QueueProperties : IQueueProperties,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5CF-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class QueueProperties
    Implements IQueueProperties, IEnumerable, IDisposable

The QueueProperties type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a custom queue property to the collection.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Remove | Removes a custom queue property from the collection.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns number of custom queue properties in the collection.
Public property | Item | Returns the custom queue property specified by index.
Top
Remarks
A QueueProperty object is valid until it is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperties Methods

QueueProperties Methods

The QueueProperties type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a custom queue property to the collection.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Remove | Removes a custom queue property from the collection.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

QueueProperties Class
Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperties.Add Method

QueuePropertiesAdd Method

Adds a custom queue property to the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IQueueProperty Add(
    ref string Name
)
Public Function Add (
    ByRef Name As String
) As IQueueProperty

Parameters

Name
Type: SystemString
An error is generated if Name matches an object already in the collection.

Return Value

Type: IQueueProperty
IQueueProperty

Implements

IQueuePropertiesAdd(String)
Remarks
The returned object of this function should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

QueueProperties Class
Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperties.Dispose Method

QueuePropertiesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

QueueProperties Class
Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperties.GetEnumerator Method

QueuePropertiesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IQueueProperties object.

Implements

IQueuePropertiesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

QueueProperties Class
Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperties.Remove Method

QueuePropertiesRemove Method

Removes a custom queue property from the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Remove(
    Object index
)
Public Sub Remove (
    index As Object
)

Parameters

index
Type: SystemObject
If index is Long, the indexed property is returned, with the index range being 1 to Count. If index is a String, the property with the matching name is returned. An error is generated for an invalid index.

Implements

IQueuePropertiesRemove(Object)
Remarks
See Also

Reference

QueueProperties Class
Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperties Properties

QueueProperties Properties

The QueueProperties type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns number of custom queue properties in the collection.
Public property | Item | Returns the custom queue property specified by index.
Top
See Also

Reference

QueueProperties Class
Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperties.Count Property

QueuePropertiesCount Property

Returns number of custom queue properties in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IQueuePropertiesCount
Remarks
See Also

Reference

QueueProperties Class
Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperties.Item Property

QueuePropertiesItem Property

Returns the custom queue property specified by index.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IQueueProperty this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IQueueProperty
    Get

Parameters

vntIndexKey
Type: SystemObject
If index is Long, the indexed property is returned, with the index range being 1 to Count. If index is a String, the property with the matching name is returned. An error is generated for an invalid index.

Property Value

Type: IQueueProperty

Return Value

Type: IQueueProperty
IQueueProperty

Implements

IQueuePropertiesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

QueueProperties Class
Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperty Class

QueueProperty Class

QueueProperty COM implementation class.

Defines the information for one custom queue property.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesQueueProperty

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5D1-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class QueueProperty : IQueueProperty,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5D1-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class QueueProperty
    Implements IQueueProperty, IDisposable

The QueueProperty type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Returns Property name.
Public property | Value | Gets or sets the value of a property.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperty Methods

QueueProperty Methods

The QueueProperty type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

QueueProperty Class
Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperty.Dispose Method

QueuePropertyDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

QueueProperty Class
Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperty Properties

QueueProperty Properties

The QueueProperty type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns Property name.
Public property | Value | Gets or sets the value of a property.
Top
See Also

Reference

QueueProperty Class
Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperty.Name Property

QueuePropertyName Property

Returns Property name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IQueuePropertyName
Remarks
Maximum length is 254.
See Also

Reference

QueueProperty Class
Kofax.Capture.AdminModule.InteropServices Namespace


QueueProperty.Value Property

QueuePropertyValue Property

Gets or sets the value of a property.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
The value of a property.

Return Value

Type: String
String

Implements

IQueuePropertyValue
Remarks
Maximum length is 254.
See Also

Reference

QueueProperty Class
Kofax.Capture.AdminModule.InteropServices Namespace


Queues Class

Queues Class

Queues COM implementation class.

Defines a COM collection of Queue objects associated with the application.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesQueues

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5D3-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Queues : IQueues, IEnumerable,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5D3-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Queues
    Implements IQueues, IEnumerable, IDisposable

The Queues type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of Queue objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
Iteration and extraction by order number (with the item function) are supported. Extraction by name is also supported; the name is the localized version. Passing an out-of-range, or invalid parameter to the item function causes it to generate an error.

The Queues object is sorted in the same order as would be displayed on the Available Queues list of the Queues tab of the Batch Class Properties dialog, assuming no queues had already been assigned. The Queues object is valid as long as Admin is running.

The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


Queues Methods

Queues Methods

The Queues type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Queues Class
Kofax.Capture.AdminModule.InteropServices Namespace


Queues.Dispose Method

QueuesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Queues Class
Kofax.Capture.AdminModule.InteropServices Namespace


Queues.GetEnumerator Method

QueuesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IQueues object.

Implements

IQueuesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Queues Class
Kofax.Capture.AdminModule.InteropServices Namespace


Queues Properties

Queues Properties

The Queues type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of Queue objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

Queues Class
Kofax.Capture.AdminModule.InteropServices Namespace


Queues.Count Property

QueuesCount Property

Returns the number of Queue objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IQueuesCount
Remarks
See Also

Reference

Queues Class
Kofax.Capture.AdminModule.InteropServices Namespace


Queues.Item Property

QueuesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IQueue this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IQueue
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IQueue

Return Value

Type: IQueue
IQueue

Implements

IQueuesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Queues Class
Kofax.Capture.AdminModule.InteropServices Namespace


RecognitionProf Class

RecognitionProf Class

RecognitionProf COM implementation class.

Defines information about a Recognition Profile.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesRecognitionProf

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5D5-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class RecognitionProf : IRecognitionProf,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5D5-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class RecognitionProf
    Implements IRecognitionProf, IDisposable

The RecognitionProf type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Returns the Name of the recognition profile.
Top
Remarks
A RecognitionProf object is valid until it is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


RecognitionProf Methods

RecognitionProf Methods

The RecognitionProf type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RecognitionProf Class
Kofax.Capture.AdminModule.InteropServices Namespace


RecognitionProf.Dispose Method

RecognitionProfDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

RecognitionProf Class
Kofax.Capture.AdminModule.InteropServices Namespace


RecognitionProf Properties

RecognitionProf Properties

The RecognitionProf type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the Name of the recognition profile.
Top
See Also

Reference

RecognitionProf Class
Kofax.Capture.AdminModule.InteropServices Namespace


RecognitionProf.Name Property

RecognitionProfName Property

Returns the Name of the recognition profile.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IRecognitionProfName
Remarks
See Also

Reference

RecognitionProf Class
Kofax.Capture.AdminModule.InteropServices Namespace


RecognitionProfs Class

RecognitionProfs Class

RecognitionProfs COM implementation class.

Defines a COM collection of RecognitionProf objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesRecognitionProfs

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5D7-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class RecognitionProfs : IRecognitionProfs,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5D7-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class RecognitionProfs
    Implements IRecognitionProfs, IEnumerable, IDisposable

The RecognitionProfs type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of RecognitionProf objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
Iteration and extraction by order number (with the item function) are supported. Extraction by name is also supported. Passing an out-of-range, or invalid parameter to the item function causes it generate an error. RecognitionProf objects are sorted alphabetically.

The RecognitionProf object is always valid while Admin is running.

The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


RecognitionProfs Methods

RecognitionProfs Methods

The RecognitionProfs type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RecognitionProfs Class
Kofax.Capture.AdminModule.InteropServices Namespace


RecognitionProfs.Dispose Method

RecognitionProfsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

RecognitionProfs Class
Kofax.Capture.AdminModule.InteropServices Namespace


RecognitionProfs.GetEnumerator Method

RecognitionProfsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IRecognitionProfs object.

Implements

IRecognitionProfsGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

RecognitionProfs Class
Kofax.Capture.AdminModule.InteropServices Namespace


RecognitionProfs Properties

RecognitionProfs Properties

The RecognitionProfs type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of RecognitionProf objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

RecognitionProfs Class
Kofax.Capture.AdminModule.InteropServices Namespace


RecognitionProfs.Count Property

RecognitionProfsCount Property

Returns the number of RecognitionProf objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IRecognitionProfsCount
Remarks
See Also

Reference

RecognitionProfs Class
Kofax.Capture.AdminModule.InteropServices Namespace


RecognitionProfs.Item Property

RecognitionProfsItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRecognitionProf this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IRecognitionProf
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IRecognitionProf

Return Value

Type: IRecognitionProf
IRecognitionProf

Implements

IRecognitionProfsItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

RecognitionProfs Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegistrationZone Class

RegistrationZone Class

RegistrationZone COM implementation class.

Defines information about a registration zone.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesRegistrationZone

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5D9-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class RegistrationZone : IRegistrationZone,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5D9-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class RegistrationZone
    Implements IRegistrationZone, IDisposable

The RegistrationZone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SearchText | Returns text to search for within the zone during the registration process.
Public property | ShapeType | Returns the shape type of the registration zone.
Public property | ZoneHeight | Returns the height of the registration zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the registration zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the registration zone in BMUs.
Public property | ZoneWidth | Returns the width of the registration zone in BMUs.
Top
Remarks
A RegistrationZone object is valid until it is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


RegistrationZone Methods

RegistrationZone Methods

The RegistrationZone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RegistrationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegistrationZone.Dispose Method

RegistrationZoneDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

RegistrationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegistrationZone Properties

RegistrationZone Properties

The RegistrationZone type exposes the following members.

Properties
 | Name | Description
Public property | SearchText | Returns text to search for within the zone during the registration process.
Public property | ShapeType | Returns the shape type of the registration zone.
Public property | ZoneHeight | Returns the height of the registration zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the registration zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the registration zone in BMUs.
Public property | ZoneWidth | Returns the width of the registration zone in BMUs.
Top
See Also

Reference

RegistrationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegistrationZone.SearchText Property

RegistrationZoneSearchText Property

Returns text to search for within the zone during the registration process.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string SearchText { get; }
Public ReadOnly Property SearchText As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IRegistrationZoneSearchText
Remarks
See Also

Reference

RegistrationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegistrationZone.ShapeType Property

RegistrationZoneShapeType Property

Returns the shape type of the registration zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public KfxApiAdminShapeType ShapeType { get; }
Public ReadOnly Property ShapeType As KfxApiAdminShapeType
    Get

Property Value

Type: KfxApiAdminShapeType

Return Value

Type: KfxApiAdminShapeType
KfxApiAdminShapeType

Implements

IRegistrationZoneShapeType
Remarks
See Also

Reference

RegistrationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegistrationZone.ZoneHeight Property

RegistrationZoneZoneHeight Property

Returns the height of the registration zone in BMUs (1/1200th of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneHeight { get; }
Public ReadOnly Property ZoneHeight As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IRegistrationZoneZoneHeight
See Also

Reference

RegistrationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegistrationZone.ZoneLeft Property

RegistrationZoneZoneLeft Property

Returns the left coordinate of the registration zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneLeft { get; }
Public ReadOnly Property ZoneLeft As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IRegistrationZoneZoneLeft
Remarks
See Also

Reference

RegistrationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegistrationZone.ZoneTop Property

RegistrationZoneZoneTop Property

Returns the top coordinate of the registration zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneTop { get; }
Public ReadOnly Property ZoneTop As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IRegistrationZoneZoneTop
Remarks
See Also

Reference

RegistrationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegistrationZone.ZoneWidth Property

RegistrationZoneZoneWidth Property

Returns the width of the registration zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneWidth { get; }
Public ReadOnly Property ZoneWidth As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IRegistrationZoneZoneWidth
See Also

Reference

RegistrationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegZoneColl Class

RegZoneColl Class

RegZoneColl COM implementation class.

Defines a COM collection of RegistrationZone objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesRegZoneColl

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5DB-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class RegZoneColl : IRegZoneColl,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5DB-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class RegZoneColl
    Implements IRegZoneColl, IEnumerable, IDisposable

The RegZoneColl type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Returns a collection element given a key.
Top
Remarks
Each RegistrationZone object is valid unless the sample page is deleted, or the zone is deleted. The collection itself is valid until the sample page is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


RegZoneColl Methods

RegZoneColl Methods

The RegZoneColl type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RegZoneColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegZoneColl.Dispose Method

RegZoneCollDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

RegZoneColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegZoneColl.GetEnumerator Method

RegZoneCollGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IRegZoneColl object.

Implements

IRegZoneCollGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

RegZoneColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegZoneColl Properties

RegZoneColl Properties

The RegZoneColl type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Returns a collection element given a key.
Top
See Also

Reference

RegZoneColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegZoneColl.Count Property

RegZoneCollCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IRegZoneCollCount
Remarks
See Also

Reference

RegZoneColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


RegZoneColl.Item Property

RegZoneCollItem Property

Returns a collection element given a key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRegistrationZone this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IRegistrationZone
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IRegistrationZone

Return Value

Type: IRegistrationZone

Implements

IRegZoneCollItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

RegZoneColl Class
Kofax.Capture.AdminModule.InteropServices Namespace


RemoteSite Class

RemoteSite Class

RemoteSite COM implementation class.

Defines information about a RemoteSite object.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesRemoteSite

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5DD-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class RemoteSite : IRemoteSite, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5DD-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class RemoteSite
    Implements IRemoteSite, IDisposable

The RemoteSite type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | GUID | Returns the remote site GUID.
Public property | Name | Returns the remote site name.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


RemoteSite Methods

RemoteSite Methods

The RemoteSite type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RemoteSite Class
Kofax.Capture.AdminModule.InteropServices Namespace


RemoteSite.Dispose Method

RemoteSiteDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

RemoteSite Class
Kofax.Capture.AdminModule.InteropServices Namespace


RemoteSite Properties

RemoteSite Properties

The RemoteSite type exposes the following members.

Properties
 | Name | Description
Public property | GUID | Returns the remote site GUID.
Public property | Name | Returns the remote site name.
Top
See Also

Reference

RemoteSite Class
Kofax.Capture.AdminModule.InteropServices Namespace


RemoteSite.GUID Property

RemoteSiteGUID Property

Returns the remote site GUID.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string GUID { get; }
Public ReadOnly Property GUID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IRemoteSiteGUID
See Also

Reference

RemoteSite Class
Kofax.Capture.AdminModule.InteropServices Namespace


RemoteSite.Name Property

RemoteSiteName Property

Returns the remote site name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IRemoteSiteName
Remarks
See Also

Reference

RemoteSite Class
Kofax.Capture.AdminModule.InteropServices Namespace


RemoteSites Class

RemoteSites Class

RemoteSites COM implementation class.

Defines a COM collection of RemoteSite objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesRemoteSites

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5DF-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class RemoteSites : IRemoteSites,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5DF-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class RemoteSites
    Implements IRemoteSites, IEnumerable, IDisposable

The RemoteSites type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of objects contained in the collection of IRemoteSite objects.
Public property | Item | Retrieves an object from the collection of IRemoteSite objects, by index or by key.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


RemoteSites Methods

RemoteSites Methods

The RemoteSites type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RemoteSites Class
Kofax.Capture.AdminModule.InteropServices Namespace


RemoteSites.Dispose Method

RemoteSitesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

RemoteSites Class
Kofax.Capture.AdminModule.InteropServices Namespace


RemoteSites.GetEnumerator Method

RemoteSitesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IRemoteSites object.

Implements

IRemoteSitesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

RemoteSites Class
Kofax.Capture.AdminModule.InteropServices Namespace


RemoteSites Properties

RemoteSites Properties

The RemoteSites type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of objects contained in the collection of IRemoteSite objects.
Public property | Item | Retrieves an object from the collection of IRemoteSite objects, by index or by key.
Top
See Also

Reference

RemoteSites Class
Kofax.Capture.AdminModule.InteropServices Namespace


RemoteSites.Count Property

RemoteSitesCount Property

Returns the number of objects contained in the collection of IRemoteSite objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IRemoteSitesCount
Remarks
See Also

Reference

RemoteSites Class
Kofax.Capture.AdminModule.InteropServices Namespace


RemoteSites.Item Property

RemoteSitesItem Property

Retrieves an object from the collection of IRemoteSite objects, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRemoteSite this[
    Object vntIndexKey
] { get; }
Public ReadOnly Property Item (
    vntIndexKey As Object
) As IRemoteSite
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IRemoteSite

Return Value

Type: IRemoteSite
IRemoteSite

Implements

IRemoteSitesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

RemoteSites Class
Kofax.Capture.AdminModule.InteropServices Namespace


RenameEventArgs Class

RenameEventArgs Class

RenameEventArgs COM implementation class.

Defines an object that is passed to the OCX for the rename action events.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesRenameEventArgs

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5E1-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class RenameEventArgs : IRenameEventArgs,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5E1-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class RenameEventArgs
    Implements IRenameEventArgs, IDisposable

The RenameEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | RenameEventArgs | Initializes a new instance of the Kofax.Capture.AdminModule.InteropServices.RenameEventArgs class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | NewName | Returns the newly assigned object name.
Public property | OldName | Returns the already existing object name.
Public property | ParentName | The name of the parent object.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


RenameEventArgs Constructor

RenameEventArgs Constructor

Initializes a new instance of the Kofax.Capture.AdminModule.InteropServices.RenameEventArgs class.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public RenameEventArgs()
Public Sub New
Remarks
See Also

Reference

RenameEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


RenameEventArgs Methods

RenameEventArgs Methods

The RenameEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RenameEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


RenameEventArgs.Dispose Method

RenameEventArgsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

RenameEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


RenameEventArgs Properties

RenameEventArgs Properties

The RenameEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | NewName | Returns the newly assigned object name.
Public property | OldName | Returns the already existing object name.
Public property | ParentName | The name of the parent object.
Top
See Also

Reference

RenameEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


RenameEventArgs.NewName Property

RenameEventArgsNewName Property

Returns the newly assigned object name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string NewName { get; }
Public ReadOnly Property NewName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IRenameEventArgsNewName
Remarks
See Also

Reference

RenameEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


RenameEventArgs.OldName Property

RenameEventArgsOldName Property

Returns the already existing object name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string OldName { get; }
Public ReadOnly Property OldName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IRenameEventArgsOldName
Remarks
See Also

Reference

RenameEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


RenameEventArgs.ParentName Property

RenameEventArgsParentName Property

The name of the parent object.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ParentName { get; }
Public ReadOnly Property ParentName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IRenameEventArgsParentName
Remarks
For a batch field, this is the batch class name. For an index field or form type, this is the document class name. For other objects, an empty string is passed.
See Also

Reference

RenameEventArgs Class
Kofax.Capture.AdminModule.InteropServices Namespace


RGB Class

RGB Class

RGB COM implementation class.

Contains the red, green, and blue values of a color.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesRGB

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5E3-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class RGB : IRGB
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5E3-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class RGB
    Implements IRGB

The RGB type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Blue | Returns the blue value of the color.
Public property | Green | Returns the green value of the color.
Public property | Red | Returns the red value of the color.
Top
Remarks
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


RGB Methods

RGB Methods

The RGB type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RGB Class
Kofax.Capture.AdminModule.InteropServices Namespace


RGB Properties

RGB Properties

The RGB type exposes the following members.

Properties
 | Name | Description
Public property | Blue | Returns the blue value of the color.
Public property | Green | Returns the green value of the color.
Public property | Red | Returns the red value of the color.
Top
See Also

Reference

RGB Class
Kofax.Capture.AdminModule.InteropServices Namespace


RGB.Blue Property

RGBBlue Property

Returns the blue value of the color.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public short Blue { get; }
Public ReadOnly Property Blue As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short

Implements

IRGBBlue
Remarks
See Also

Reference

RGB Class
Kofax.Capture.AdminModule.InteropServices Namespace


RGB.Green Property

RGBGreen Property

Returns the green value of the color.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public short Green { get; }
Public ReadOnly Property Green As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short

Implements

IRGBGreen
Remarks
See Also

Reference

RGB Class
Kofax.Capture.AdminModule.InteropServices Namespace


RGB.Red Property

RGBRed Property

Returns the red value of the color.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public short Red { get; }
Public ReadOnly Property Red As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short

Implements

IRGBRed
Remarks
See Also

Reference

RGB Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage Class

SamplePage Class

SamplePage COM implementation class.

Defines information about the sample page.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesSamplePage

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5E5-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class SamplePage : ISamplePage, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5E5-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class SamplePage
    Implements ISamplePage, IDisposable

The SamplePage type exposes the following members.

Methods
 | Name | Description
Public method | CreateAutoIndexZone | Creates an index zone with the specified recognition profile.
Public method | CreateAutoIndexZoneEx | Creates an index zone and returns an index zone object.
Public method | CreateIndexGroupZone | Creates an index group zone, associated with the specified index field.
Public method | CreateIndexGroupZoneEx | Creates an index group zone, associated with the specified index field.
Public method | CreateManualIndexZone | Creates a manual index zone, associated with the specified index field.
Public method | CreateManualIndexZoneEx | Creates an index zone and returns an index zone object.
Public method | DeleteIndexGroupZone | Deletes the index group zone from the sample page.
Public method | DeleteIndexGrpMemZone | Deletes the index group member zone from the sample page.
Public method | DeleteIndexZone | Deletes the index zone from the sample page.
Public method | Dispose | Releases all resources used by the SamplePage
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ReplaceImageFile | Attempts to replace the image in the sample page with the specified file.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Filename | Returns the Image file name of the sample page.
Public property | IndexGroupZones | Returns the collection of index group zones for the sample page.
Public property | IndexZones | Returns the collection of index zones for the sample page. Does not include zones assigned to a group zone.
Public property | IndexZonesByField | Returns the collection of index zones for the sample page assigned to the specified index field.
Public property | PageHeight | Returns the height of the sample page, measured in BMUs (1/1200 of an inch).
Public property | PageNumber | Returns the page order within the sample document.
Public property | PageWidth | Returns the width of the sample page, measured in BMUs (1/1200 of an inch).
Top
Remarks
The SamplePage object is valid until it, or the parent form type, is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage Methods

SamplePage Methods

The SamplePage type exposes the following members.

Methods
 | Name | Description
Public method | CreateAutoIndexZone | Creates an index zone with the specified recognition profile.
Public method | CreateAutoIndexZoneEx | Creates an index zone and returns an index zone object.
Public method | CreateIndexGroupZone | Creates an index group zone, associated with the specified index field.
Public method | CreateIndexGroupZoneEx | Creates an index group zone, associated with the specified index field.
Public method | CreateManualIndexZone | Creates a manual index zone, associated with the specified index field.
Public method | CreateManualIndexZoneEx | Creates an index zone and returns an index zone object.
Public method | DeleteIndexGroupZone | Deletes the index group zone from the sample page.
Public method | DeleteIndexGrpMemZone | Deletes the index group member zone from the sample page.
Public method | DeleteIndexZone | Deletes the index zone from the sample page.
Public method | Dispose |
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ReplaceImageFile | Attempts to replace the image in the sample page with the specified file.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.CreateAutoIndexZone Method

SamplePageCreateAutoIndexZone Method

Creates an index zone with the specified recognition profile.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void CreateAutoIndexZone(
    ref IIndexField oIndexField,
    ref IRecognitionProf oRecognitionProf,
    ref int lLeft,
    ref int lTop,
    ref int lWidth,
    ref int lHeight
)
Public Sub CreateAutoIndexZone (
    ByRef oIndexField As IIndexField,
    ByRef oRecognitionProf As IRecognitionProf,
    ByRef lLeft As Integer,
    ByRef lTop As Integer,
    ByRef lWidth As Integer,
    ByRef lHeight As Integer
)

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The associated index field.
oRecognitionProf
Type: Kofax.Capture.AdminModule.InteropServicesIRecognitionProf
The recognition profile for the zone.
lLeft
Type: SystemInt32
The x coordinate of the top-left corner of the zone.
lTop
Type: SystemInt32
The y coordinate of the top-left corner of the zone.
lWidth
Type: SystemInt32
The width of the zone (in BMUs).
lHeight
Type: SystemInt32
The height of the zone (in BMUs).

Implements

ISamplePageCreateAutoIndexZone(IIndexField, IRecognitionProf, Int32, Int32, Int32, Int32)
Remarks
The dimensions of the zone are in BMUs (1/1200 of an inch).
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.CreateAutoIndexZoneEx Method

SamplePageCreateAutoIndexZoneEx Method

Creates an index zone and returns an index zone object.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexZone CreateAutoIndexZoneEx(
    ref IIndexField oIndexField,
    ref IRecognitionProf oRecognitionProf,
    ref int lLeft,
    ref int lTop,
    ref int lWidth,
    ref int lHeight
)
Public Function CreateAutoIndexZoneEx (
    ByRef oIndexField As IIndexField,
    ByRef oRecognitionProf As IRecognitionProf,
    ByRef lLeft As Integer,
    ByRef lTop As Integer,
    ByRef lWidth As Integer,
    ByRef lHeight As Integer
) As IIndexZone

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The associated index field.
oRecognitionProf
Type: Kofax.Capture.AdminModule.InteropServicesIRecognitionProf
The recognition profile for the zone.
lLeft
Type: SystemInt32
The x coordinate of the top-left corner of the zone.
lTop
Type: SystemInt32
The y coordinate of the top-left corner of the zone.
lWidth
Type: SystemInt32
The width of the zone (in BMUs).
lHeight
Type: SystemInt32
The height of the zone (in BMUs).

Return Value

Type: IIndexZone
IIndexZone

Implements

ISamplePageCreateAutoIndexZoneEx(IIndexField, IRecognitionProf, Int32, Int32, Int32, Int32)
Remarks

Creates an index zone with auto recognition, using the specified profile. Is otherwise similar to CreateManualZone.

This function throws:

(KfxApiErrInvalidIndexField) if a zone cannot be assigned to the specified field.

(KfxApiErrInvalidZoneCoordinates) if any portion of the zone rectangle is out of the image bounds.

(KfxApiErrInvalidRecognitionProfile) if the recognition profile is invalid for index zones.
The returned object of this function should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.CreateIndexGroupZone Method

SamplePageCreateIndexGroupZone Method

Creates an index group zone, associated with the specified index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void CreateIndexGroupZone(
    ref IIndexField oIndexField,
    ref int lLeft,
    ref int lTop,
    ref int lWidth,
    ref int lHeight
)
Public Sub CreateIndexGroupZone (
    ByRef oIndexField As IIndexField,
    ByRef lLeft As Integer,
    ByRef lTop As Integer,
    ByRef lWidth As Integer,
    ByRef lHeight As Integer
)

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The associated index field.
lLeft
Type: SystemInt32
The x coordinate of the top-left corner of the zone.
lTop
Type: SystemInt32
The y coordinate of the top-left corner of the zone.
lWidth
Type: SystemInt32
The width of the zone (in BMUs).
lHeight
Type: SystemInt32
The height of the zone (in BMUs).

Implements

ISamplePageCreateIndexGroupZone(IIndexField, Int32, Int32, Int32, Int32)
Remarks
Creates the zone with the same default parameters as in the interactive session. Any existing, and all subsequent, index zones associated with the same _ index field become children of this group zone. The dimensions of the zone are _ in BMUs (1/1200 of an inch).
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.CreateIndexGroupZoneEx Method

SamplePageCreateIndexGroupZoneEx Method

Creates an index group zone, associated with the specified index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexGroupZone CreateIndexGroupZoneEx(
    ref IIndexField oIndexField,
    ref int lLeft,
    ref int lTop,
    ref int lWidth,
    ref int lHeight
)
Public Function CreateIndexGroupZoneEx (
    ByRef oIndexField As IIndexField,
    ByRef lLeft As Integer,
    ByRef lTop As Integer,
    ByRef lWidth As Integer,
    ByRef lHeight As Integer
) As IIndexGroupZone

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The associated index field.
lLeft
Type: SystemInt32
The x coordinate of the top-left corner of the zone.
lTop
Type: SystemInt32
The y coordinate of the top-left corner of the zone.
lWidth
Type: SystemInt32
The width of the zone (in BMUs).
lHeight
Type: SystemInt32
The height of the zone (in BMUs).

Return Value

Type: IIndexGroupZone
IIndexGroupZone

Implements

ISamplePageCreateIndexGroupZoneEx(IIndexField, Int32, Int32, Int32, Int32)
Remarks
Creates the zone with the same default parameters as in the interactive session. Any existing, and all subsequent, index zones associated with the same index field become children of this group zone. The dimensions of the zone are in BMUs (1/1200 of an inch).

This function throws:

(KfxApiErrInvalidIndexField) if a group zone cannot be assigned to the specified field.

(KfxApiErrInvalidZoneCoordinates) if any portion of the zone rectangle is out of the image bounds.
The returned object of this function should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.CreateManualIndexZone Method

SamplePageCreateManualIndexZone Method

Creates a manual index zone, associated with the specified index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void CreateManualIndexZone(
    ref IIndexField oIndexField,
    ref int lLeft,
    ref int lTop,
    ref int lWidth,
    ref int lHeight
)
Public Sub CreateManualIndexZone (
    ByRef oIndexField As IIndexField,
    ByRef lLeft As Integer,
    ByRef lTop As Integer,
    ByRef lWidth As Integer,
    ByRef lHeight As Integer
)

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The associated index field.
lLeft
Type: SystemInt32
The x coordinate of the top-left corner of the zone.
lTop
Type: SystemInt32
The y coordinate of the top-left corner of the zone.
lWidth
Type: SystemInt32
The width of the zone (in BMUs).
lHeight
Type: SystemInt32
The height of the zone (in BMUs).

Implements

ISamplePageCreateManualIndexZone(IIndexField, Int32, Int32, Int32, Int32)
Remarks
The dimensions of the zone are in BMUs (1/1200 of an inch).
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.CreateManualIndexZoneEx Method

SamplePageCreateManualIndexZoneEx Method

Creates an index zone and returns an index zone object.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexZone CreateManualIndexZoneEx(
    ref IIndexField oIndexField,
    ref int lLeft,
    ref int lTop,
    ref int lWidth,
    ref int lHeight
)
Public Function CreateManualIndexZoneEx (
    ByRef oIndexField As IIndexField,
    ByRef lLeft As Integer,
    ByRef lTop As Integer,
    ByRef lWidth As Integer,
    ByRef lHeight As Integer
) As IIndexZone

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField
The associated index field.
lLeft
Type: SystemInt32
The x coordinate of the top-left corner of the zone.
lTop
Type: SystemInt32
The y coordinate of the top-left corner of the zone.
lWidth
Type: SystemInt32
The width of the zone (in BMUs).
lHeight
Type: SystemInt32
The height of the zone (in BMUs).

Return Value

Type: IIndexZone
IIndexZone

Implements

ISamplePageCreateManualIndexZoneEx(IIndexField, Int32, Int32, Int32, Int32)
Remarks

Creates an index zone, associated with the specified index field. The dimensions of the zone are in BMUs (1/1200 of an inch).

This function throws:

(KfxApiErrInvalidIndexField) if a zone cannot be assigned to the specified field.

(KfxApiErrInvalidZoneCoordinates) if any portion of the zone rectangle is out of the image bounds.
The returned object of this function should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.DeleteIndexGroupZone Method

SamplePageDeleteIndexGroupZone Method

Deletes the index group zone from the sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteIndexGroupZone(
    ref IIndexGroupZone oIndexGroupZone
)
Public Sub DeleteIndexGroupZone (
    ByRef oIndexGroupZone As IIndexGroupZone
)

Parameters

oIndexGroupZone
Type: Kofax.Capture.AdminModule.InteropServicesIIndexGroupZone
The index zone to delete.

Implements

ISamplePageDeleteIndexGroupZone(IIndexGroupZone)
Remarks
All children of the group zone become children of the sample page.
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.DeleteIndexGrpMemZone Method

SamplePageDeleteIndexGrpMemZone Method

Deletes the index group member zone from the sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteIndexGrpMemZone(
    ref IIndexGrpMemZone oIndexGrpMemZone
)
Public Sub DeleteIndexGrpMemZone (
    ByRef oIndexGrpMemZone As IIndexGrpMemZone
)

Parameters

oIndexGrpMemZone
Type: Kofax.Capture.AdminModule.InteropServicesIIndexGrpMemZone
The index zone to delete.

Implements

ISamplePageDeleteIndexGrpMemZone(IIndexGrpMemZone)
Remarks
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.DeleteIndexZone Method

SamplePageDeleteIndexZone Method

Deletes the index zone from the sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteIndexZone(
    ref IIndexZone oIndexZone
)
Public Sub DeleteIndexZone (
    ByRef oIndexZone As IIndexZone
)

Parameters

oIndexZone
Type: Kofax.Capture.AdminModule.InteropServicesIIndexZone
The index zone to delete.

Implements

ISamplePageDeleteIndexZone(IIndexZone)
Remarks
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.Dispose Method

SamplePageDispose Method
Releases all resources used by the SamplePage

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.ReplaceImageFile Method

SamplePageReplaceImageFile Method

Attempts to replace the image in the sample page with the specified file.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void ReplaceImageFile(
    ref string strPath
)
Public Sub ReplaceImageFile (
    ByRef strPath As String
)

Parameters

strPath
Type: SystemString
The path name for the new image file.

Implements

ISamplePageReplaceImageFile(String)
Remarks
If there is an error, the previous image is preserved. If the file has multiple pages, only the first page is read.
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage Properties

SamplePage Properties

The SamplePage type exposes the following members.

Properties
 | Name | Description
Public property | Filename | Returns the Image file name of the sample page.
Public property | IndexGroupZones | Returns the collection of index group zones for the sample page.
Public property | IndexZones | Returns the collection of index zones for the sample page. Does not include zones assigned to a group zone.
Public property | IndexZonesByField | Returns the collection of index zones for the sample page assigned to the specified index field.
Public property | PageHeight | Returns the height of the sample page, measured in BMUs (1/1200 of an inch).
Public property | PageNumber | Returns the page order within the sample document.
Public property | PageWidth | Returns the width of the sample page, measured in BMUs (1/1200 of an inch).
Top
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.Filename Property

SamplePageFilename Property

Returns the Image file name of the sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Filename { get; }
Public ReadOnly Property Filename As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

ISamplePageFilename
Remarks
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.IndexGroupZones Property

SamplePageIndexGroupZones Property

Returns the collection of index group zones for the sample page.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexGroupZones IndexGroupZones { get; }
Public ReadOnly Property IndexGroupZones As IIndexGroupZones
    Get

Property Value

Type: IIndexGroupZones

Return Value

Type: IIndexGroupZones
IIndexGroupZones

Implements

ISamplePageIndexGroupZones
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.IndexZones Property

SamplePageIndexZones Property

Returns the collection of index zones for the sample page. Does not include zones assigned to a group zone.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexZones IndexZones { get; }
Public ReadOnly Property IndexZones As IIndexZones
    Get

Property Value

Type: IIndexZones

Return Value

Type: IIndexZones
IIndexZones

Implements

ISamplePageIndexZones
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.IndexZonesByField Property

SamplePageIndexZonesByField Property

Returns the collection of index zones for the sample page assigned to the specified index field.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexZones this[
    IIndexField oIndexField
] { get; }
Public ReadOnly Property IndexZonesByField (
    oIndexField As IIndexField
) As IIndexZones
    Get

Parameters

oIndexField
Type: Kofax.Capture.AdminModule.InteropServicesIIndexField

Property Value

Type: IIndexZones

Return Value

Type: IIndexZones
IIndexZones

Implements

ISamplePageIndexZonesByFieldIIndexField
Remarks
Does not include zones assigned to a group zone. Returns an empty collection if no zones are defined for the given field.
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.PageHeight Property

SamplePagePageHeight Property

Returns the height of the sample page, measured in BMUs (1/1200 of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int PageHeight { get; }
Public ReadOnly Property PageHeight As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ISamplePagePageHeight
Remarks
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.PageNumber Property

SamplePagePageNumber Property

Returns the page order within the sample document.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int PageNumber { get; }
Public ReadOnly Property PageNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ISamplePagePageNumber
Remarks
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePage.PageWidth Property

SamplePagePageWidth Property

Returns the width of the sample page, measured in BMUs (1/1200 of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int PageWidth { get; }
Public ReadOnly Property PageWidth As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ISamplePagePageWidth
Remarks
See Also

Reference

SamplePage Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePages Class

SamplePages Class

SamplePages COM implementation class.

Defines a COM collection of SamplePage objects associated with a form type.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesSamplePages

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5E7-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class SamplePages : ISamplePages,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5E7-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class SamplePages
    Implements ISamplePages, IEnumerable, IDisposable

The SamplePages type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of SamplePage objects contained in the collection.
Public property | Item | Returns the ISamplePage object specified by a numeric one-based index into the collection.
Top
Remarks
Iteration and extraction by order number (with the item function) are supported. Passing an out-of-range, or invalid parameter to the item function causes an error. Note that extraction by name is not supported, since sample pages are not named.

SamplePages are sorted in the same order they appear in under the form type in the tree control. The SamplePages object is valid until the parent form type is deleted.

The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


SamplePages Methods

SamplePages Methods

The SamplePages type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SamplePages Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePages.Dispose Method

SamplePagesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

SamplePages Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePages.GetEnumerator Method

SamplePagesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.ISamplePages object.

Implements

ISamplePagesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

SamplePages Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePages Properties

SamplePages Properties

The SamplePages type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of SamplePage objects contained in the collection.
Public property | Item | Returns the ISamplePage object specified by a numeric one-based index into the collection.
Top
See Also

Reference

SamplePages Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePages.Count Property

SamplePagesCount Property

Returns the number of SamplePage objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ISamplePagesCount
Remarks
See Also

Reference

SamplePages Class
Kofax.Capture.AdminModule.InteropServices Namespace


SamplePages.Item Property

SamplePagesItem Property

Returns the ISamplePage object specified by a numeric one-based index into the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ISamplePage this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As ISamplePage
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: ISamplePage

Return Value

Type: ISamplePage
ISamplePage

Implements

ISamplePagesItemObject
Remarks
The numeric one-based index is the sort order seen on the tree control, Batch or Document tab, under a Form Type tree item.
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

SamplePages Class
Kofax.Capture.AdminModule.InteropServices Namespace


SepAndFormIDProf Class

SepAndFormIDProf Class

SepAndFormIDProf COM implementation class.

Defines information about a separation and form ID profile.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesSepAndFormIDProf

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5E9-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class SepAndFormIDProf : ISepAndFormIDProf,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5E9-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class SepAndFormIDProf
    Implements ISepAndFormIDProf, IDisposable

The SepAndFormIDProf type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Returns the profile name.
Top
Remarks
A SepAndFormIDProf object is valid until it is deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


SepAndFormIDProf Methods

SepAndFormIDProf Methods

The SepAndFormIDProf type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SepAndFormIDProf Class
Kofax.Capture.AdminModule.InteropServices Namespace


SepAndFormIDProf.Dispose Method

SepAndFormIDProfDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

SepAndFormIDProf Class
Kofax.Capture.AdminModule.InteropServices Namespace


SepAndFormIDProf Properties

SepAndFormIDProf Properties

The SepAndFormIDProf type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the profile name.
Top
See Also

Reference

SepAndFormIDProf Class
Kofax.Capture.AdminModule.InteropServices Namespace


SepAndFormIDProf.Name Property

SepAndFormIDProfName Property

Returns the profile name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

ISepAndFormIDProfName
Remarks
See Also

Reference

SepAndFormIDProf Class
Kofax.Capture.AdminModule.InteropServices Namespace


SepAndFormIDProfs Class

SepAndFormIDProfs Class

SepAndFormIDProfs COM implementation class.

Defines a COM collection of ISepAndFormIDProf objects associated with the application.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesSepAndFormIDProfs

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5EB-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class SepAndFormIDProfs : ISepAndFormIDProfs,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5EB-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class SepAndFormIDProfs
    Implements ISepAndFormIDProfs, IEnumerable, IDisposable

The SepAndFormIDProfs type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of SepAndFormIDProfs objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks

Iteration and extraction by order number (with the item function) are supported. Extraction by name is also supported. Passing an out-of-range, or invalid parameter to the item function causes it to generate an error.

The SepAndFormIDProfs object is sorted alphabetically. The SepAndFormIDProfs object is valid as long as Administration module is running.

The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


SepAndFormIDProfs Methods

SepAndFormIDProfs Methods

The SepAndFormIDProfs type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SepAndFormIDProfs Class
Kofax.Capture.AdminModule.InteropServices Namespace


SepAndFormIDProfs.Dispose Method

SepAndFormIDProfsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

SepAndFormIDProfs Class
Kofax.Capture.AdminModule.InteropServices Namespace


SepAndFormIDProfs.GetEnumerator Method

SepAndFormIDProfsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.ISepAndFormIDProfs object.

Implements

ISepAndFormIDProfsGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

SepAndFormIDProfs Class
Kofax.Capture.AdminModule.InteropServices Namespace


SepAndFormIDProfs Properties

SepAndFormIDProfs Properties

The SepAndFormIDProfs type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of SepAndFormIDProfs objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

SepAndFormIDProfs Class
Kofax.Capture.AdminModule.InteropServices Namespace


SepAndFormIDProfs.Count Property

SepAndFormIDProfsCount Property

Returns the number of SepAndFormIDProfs objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ISepAndFormIDProfsCount
Remarks
See Also

Reference

SepAndFormIDProfs Class
Kofax.Capture.AdminModule.InteropServices Namespace


SepAndFormIDProfs.Item Property

SepAndFormIDProfsItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ISepAndFormIDProf this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As ISepAndFormIDProf
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: ISepAndFormIDProf

Return Value

Type: ISepAndFormIDProf
ISepAndFormIDProf

Implements

ISepAndFormIDProfsItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

SepAndFormIDProfs Class
Kofax.Capture.AdminModule.InteropServices Namespace


SeparationZone Class

SeparationZone Class

SeparationZone COM implementation class.

Defines information about a separation zone.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesSeparationZone

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5ED-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class SeparationZone : ISeparationZone,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5ED-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class SeparationZone
    Implements ISeparationZone, IDisposable

The SeparationZone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | SearchText | Returns text to search for within the zone during the separation process.
Public property | ZoneHeight | Returns the height of the zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the zone in BMUs.
Public property | ZoneWidth | Returns the width of the zone in BMUs.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


SeparationZone Methods

SeparationZone Methods

The SeparationZone type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SeparationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


SeparationZone.Dispose Method

SeparationZoneDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

SeparationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


SeparationZone Properties

SeparationZone Properties

The SeparationZone type exposes the following members.

Properties
 | Name | Description
Public property | SearchText | Returns text to search for within the zone during the separation process.
Public property | ZoneHeight | Returns the height of the zone in BMUs (1/1200th of an inch).
Public property | ZoneLeft | Returns the left coordinate of the zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the zone in BMUs.
Public property | ZoneWidth | Returns the width of the zone in BMUs.
Top
See Also

Reference

SeparationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


SeparationZone.SearchText Property

SeparationZoneSearchText Property

Returns text to search for within the zone during the separation process.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string SearchText { get; }
Public ReadOnly Property SearchText As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

ISeparationZoneSearchText
Remarks
See Also

Reference

SeparationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


SeparationZone.ZoneHeight Property

SeparationZoneZoneHeight Property

Returns the height of the zone in BMUs (1/1200th of an inch).

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneHeight { get; }
Public ReadOnly Property ZoneHeight As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ISeparationZoneZoneHeight
See Also

Reference

SeparationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


SeparationZone.ZoneLeft Property

SeparationZoneZoneLeft Property

Returns the left coordinate of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneLeft { get; }
Public ReadOnly Property ZoneLeft As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ISeparationZoneZoneLeft
Remarks
See Also

Reference

SeparationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


SeparationZone.ZoneTop Property

SeparationZoneZoneTop Property

Returns the top coordinate of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneTop { get; }
Public ReadOnly Property ZoneTop As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ISeparationZoneZoneTop
Remarks
See Also

Reference

SeparationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


SeparationZone.ZoneWidth Property

SeparationZoneZoneWidth Property

Returns the width of the zone in BMUs.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneWidth { get; }
Public ReadOnly Property ZoneWidth As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ISeparationZoneZoneWidth
See Also

Reference

SeparationZone Class
Kofax.Capture.AdminModule.InteropServices Namespace


SuggestedValue Class

SuggestedValue Class

SuggestedValue COM implementation class.

Defines information about a suggested value.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesSuggestedValue

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5EF-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class SuggestedValue : ISuggestedValue,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5EF-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class SuggestedValue
    Implements ISuggestedValue, IDisposable

The SuggestedValue type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FieldTypeValue | Returns the suggested value.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


SuggestedValue Methods

SuggestedValue Methods

The SuggestedValue type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SuggestedValue Class
Kofax.Capture.AdminModule.InteropServices Namespace


SuggestedValue.Dispose Method

SuggestedValueDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

SuggestedValue Class
Kofax.Capture.AdminModule.InteropServices Namespace


SuggestedValue Properties

SuggestedValue Properties

The SuggestedValue type exposes the following members.

Properties
 | Name | Description
Public property | FieldTypeValue | Returns the suggested value.
Top
See Also

Reference

SuggestedValue Class
Kofax.Capture.AdminModule.InteropServices Namespace


SuggestedValue.FieldTypeValue Property

SuggestedValueFieldTypeValue Property

Returns the suggested value.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string FieldTypeValue { get; }
Public ReadOnly Property FieldTypeValue As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

ISuggestedValueFieldTypeValue
Remarks
The value may only be changed by deleting it from the collection and adding the new value in.
See Also

Reference

SuggestedValue Class
Kofax.Capture.AdminModule.InteropServices Namespace


SuggestedValues Class

SuggestedValues Class

SuggestedValues COM implementation class.

Defines a COM collection of SuggestedValue objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesSuggestedValues

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5F1-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class SuggestedValues : ISuggestedValues,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5F1-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class SuggestedValues
    Implements ISuggestedValues, IEnumerable, IDisposable

The SuggestedValues type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of SuggestedValue objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
The SuggestedValues object is always valid while the field type is not deleted.
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


SuggestedValues Methods

SuggestedValues Methods

The SuggestedValues type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SuggestedValues Class
Kofax.Capture.AdminModule.InteropServices Namespace


SuggestedValues.Dispose Method

SuggestedValuesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

SuggestedValues Class
Kofax.Capture.AdminModule.InteropServices Namespace


SuggestedValues.GetEnumerator Method

SuggestedValuesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.ISuggestedValues object.

Implements

ISuggestedValuesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

SuggestedValues Class
Kofax.Capture.AdminModule.InteropServices Namespace


SuggestedValues Properties

SuggestedValues Properties

The SuggestedValues type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of SuggestedValue objects contained in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

SuggestedValues Class
Kofax.Capture.AdminModule.InteropServices Namespace


SuggestedValues.Count Property

SuggestedValuesCount Property

Returns the number of SuggestedValue objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ISuggestedValuesCount
Remarks
See Also

Reference

SuggestedValues Class
Kofax.Capture.AdminModule.InteropServices Namespace


SuggestedValues.Item Property

SuggestedValuesItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ISuggestedValue this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As ISuggestedValue
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: ISuggestedValue

Return Value

Type: ISuggestedValue
ISuggestedValue

Implements

ISuggestedValuesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

SuggestedValues Class
Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinition Class

TableDefinition Class

TableDefinition COM implementation class.

Defines a table in a document class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesTableDefinition

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5F3-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class TableDefinition : ITableDefinition,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5F3-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class TableDefinition
    Implements ITableDefinition, IDisposable

The TableDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DisplayLabel | Returns the display label of the table.
Public property | IndexFields | Returns the collection of index fields assigned to this table.
Public property | Name | Returns the name of the table.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinition Methods

TableDefinition Methods

The TableDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TableDefinition Class
Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinition.Dispose Method

TableDefinitionDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

TableDefinition Class
Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinition Properties

TableDefinition Properties

The TableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DisplayLabel | Returns the display label of the table.
Public property | IndexFields | Returns the collection of index fields assigned to this table.
Public property | Name | Returns the name of the table.
Top
See Also

Reference

TableDefinition Class
Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinition.DisplayLabel Property

TableDefinitionDisplayLabel Property

Returns the display label of the table.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string DisplayLabel { get; set; }
Public Property DisplayLabel As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

ITableDefinitionDisplayLabel
Remarks
See Also

Reference

TableDefinition Class
Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinition.IndexFields Property

TableDefinitionIndexFields Property

Returns the collection of index fields assigned to this table.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexFields IndexFields { get; }
Public ReadOnly Property IndexFields As IIndexFields
    Get

Property Value

Type: IIndexFields

Return Value

Type: IIndexFields
IIndexFields

Implements

ITableDefinitionIndexFields
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

TableDefinition Class
Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinition.Name Property

TableDefinitionName Property

Returns the name of the table.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

ITableDefinitionName
Remarks

Errors:

(KfxApiErrBadParameterRange) if setting an empty string.

(KfxApiErrDuplicateObject) if setting a name that matches that of an existing table in the document class.
See Also

Reference

TableDefinition Class
Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinitions Class

TableDefinitions Class

TableDefinitions COM implementation class.

Defines a collection of tables defined in a document class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesTableDefinitions

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5F5-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class TableDefinitions : ITableDefinitions,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5F5-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class TableDefinitions
    Implements ITableDefinitions, IEnumerable, IDisposable

The TableDefinitions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | The number of TableDefinition objects contained in the collection.
Public property | Item | Default property. The default COM collection Item property that returns the specified TableDefinition object specified.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinitions Methods

TableDefinitions Methods

The TableDefinitions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TableDefinitions Class
Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinitions.Dispose Method

TableDefinitionsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

TableDefinitions Class
Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinitions.GetEnumerator Method

TableDefinitionsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.ITableDefinitions object.

Implements

ITableDefinitionsGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

TableDefinitions Class
Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinitions Properties

TableDefinitions Properties

The TableDefinitions type exposes the following members.

Properties
 | Name | Description
Public property | Count | The number of TableDefinition objects contained in the collection.
Public property | Item | Default property. The default COM collection Item property that returns the specified TableDefinition object specified.
Top
See Also

Reference

TableDefinitions Class
Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinitions.Count Property

TableDefinitionsCount Property

The number of TableDefinition objects contained in the collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ITableDefinitionsCount
Remarks
See Also

Reference

TableDefinitions Class
Kofax.Capture.AdminModule.InteropServices Namespace


TableDefinitions.Item Property

TableDefinitionsItem Property

Default property. The default COM collection Item property that returns the specified TableDefinition object specified.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ITableDefinition this[
    Object vntIndexKey
] { get; }
Public ReadOnly Property Item (
    vntIndexKey As Object
) As ITableDefinition
    Get

Parameters

vntIndexKey
Type: SystemObject
Index can either be a table name or a numeric one-based index into the collection.

Property Value

Type: ITableDefinition

Return Value

Type: ITableDefinition
ITableDefinition

Implements

ITableDefinitionsItemObject
Remarks

Errors:

(KfxApiErrBadParameterRange) illegal index value.
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

TableDefinitions Class
Kofax.Capture.AdminModule.InteropServices Namespace


Theme Class

Theme Class

Theme COM implementation class.

A COM object that provides access to the theme of the Tungsten Capture system.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesTheme

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5F7-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Theme : ITheme, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5F7-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Theme
    Implements ITheme, IDisposable

The Theme type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BackgroundColor | Returns the background color of the theme.
Public property | Name | Returns the name of the theme.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


Theme Methods

Theme Methods

The Theme type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Theme Class
Kofax.Capture.AdminModule.InteropServices Namespace


Theme.Dispose Method

ThemeDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Theme Class
Kofax.Capture.AdminModule.InteropServices Namespace


Theme Properties

Theme Properties

The Theme type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Returns the background color of the theme.
Public property | Name | Returns the name of the theme.
Top
See Also

Reference

Theme Class
Kofax.Capture.AdminModule.InteropServices Namespace


Theme.BackgroundColor Property

ThemeBackgroundColor Property

Returns the background color of the theme.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRGB BackgroundColor { get; }
Public ReadOnly Property BackgroundColor As IRGB
    Get

Property Value

Type: IRGB

Return Value

Type: IRGB
IRGB

Implements

IThemeBackgroundColor
Remarks
See Also

Reference

Theme Class
Kofax.Capture.AdminModule.InteropServices Namespace


Theme.Name Property

ThemeName Property

Returns the name of the theme.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IThemeName
Remarks
See Also

Reference

Theme Class
Kofax.Capture.AdminModule.InteropServices Namespace


User Class

User Class

User COM implementation class.

Defines information about a User object.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesUser

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5F9-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class User : IUser, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5F9-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class User
    Implements IUser, IDisposable

The User type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Returns the user name.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


User Methods

User Methods

The User type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

User Class
Kofax.Capture.AdminModule.InteropServices Namespace


User.Dispose Method

UserDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

User Class
Kofax.Capture.AdminModule.InteropServices Namespace


User Properties

User Properties

The User type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the user name.
Top
See Also

Reference

User Class
Kofax.Capture.AdminModule.InteropServices Namespace


User.Name Property

UserName Property

Returns the user name.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IUserName
Remarks
See Also

Reference

User Class
Kofax.Capture.AdminModule.InteropServices Namespace


Users Class

Users Class

Users COM implementation class.

Defines a COM collection of User objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.AdminModule.InteropServicesUsers

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("646AB5FB-A63C-11E1-B6C6-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Users : IUsers, IEnumerable,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("646AB5FB-A63C-11E1-B6C6-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Users
    Implements IUsers, IEnumerable, IDisposable

The Users type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of objects contained in the collection of User objects.
Public property | Item | Retrieves an object from the collection of Users, by index or by key.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.AdminModule.InteropServices Namespace


Users Methods

Users Methods

The Users type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Users Class
Kofax.Capture.AdminModule.InteropServices Namespace


Users.Dispose Method

UsersDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Users Class
Kofax.Capture.AdminModule.InteropServices Namespace


Users.GetEnumerator Method

UsersGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.AdminModule.InteropServices.IUsers object.

Implements

IUsersGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Users Class
Kofax.Capture.AdminModule.InteropServices Namespace


Users Properties

Users Properties

The Users type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of objects contained in the collection of User objects.
Public property | Item | Retrieves an object from the collection of Users, by index or by key.
Top
See Also

Reference

Users Class
Kofax.Capture.AdminModule.InteropServices Namespace


Users.Count Property

UsersCount Property

Returns the number of objects contained in the collection of User objects.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IUsersCount
Remarks
See Also

Reference

Users Class
Kofax.Capture.AdminModule.InteropServices Namespace


Users.Item Property

UsersItem Property

Retrieves an object from the collection of Users, by index or by key.

Namespace: Kofax.Capture.AdminModule.InteropServices
Assembly: Kofax.Capture.AdminModule (in Kofax.Capture.AdminModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IUser this[
    Object vntIndexKey
] { get; }
Public ReadOnly Property Item (
    vntIndexKey As Object
) As IUser
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IUser

Return Value

Type: IUser
IUser

Implements

IUsersItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.AdminModule.ApiObjectWrapper class.
See Also

Reference

Users Class
Kofax.Capture.AdminModule.InteropServices Namespace


Kofax.Capture.CaptureModule Namespace

Kofax.Capture.CaptureModule Namespace

Provides utility classes for working with Tungsten Capture API objects.

Classes
Class | Description
ApiObjectWrapperT
Represents a strongly typed wrapper of Tungsten Capture .NET API objects that can be accessed by WrappedObject property. Provides methods to determine if wrapped object is Nothing or null, and automatically makes a call to the wrapped object's Dispose method when this object is being disposed.
Usage:
Examples
The following example demonstrates the use of this class.
C#
VB
Copy
using Kofax.Capture.AdminModule;   // Working with Tungsten Capture's Administration module
...
// Retrieves the active batch class
InteropServices.IBatchClass oBatchClass = m_oAdminApp.ActiveBatchClass;
using (ApiObjectWrapper <InteropServices.IBatchClass> oApiObjectWrapper = new ApiObjectWrapper<InteropServices.IBatchClass>(oBatchClass))
{
  if (!oApiObjectWrapper.IsNull)
  {
     // Do something with the oBatchClass via oApiObjectWrapper.WrappedObject property
     ...
  }
} // oBatchClass.Dispose() will be called automatically.
Imports Kofax.Capture.AdminModule   ' Working with Tungsten Capture's Administration module
...

' Retrieves the active batch class
Dim oBatchClass as InteropServices.IBatchClass = m_oAdminApp.ActiveBatchClass
Using oApiObjectWrapper As New ApiObjectWrapper(Of InteropServices.IBatchClass)(oBatchClass)
   If Not oApiObjectWrapper.IsNull Then
      ' Do something with oBatchClass via oApiObjectWrapper.WrappedObject property
      ...
   End If
End Using  ' oBatchClass.Dispose() will be called automatically.
C#
VB
Copy
using Kofax.Capture.CaptureModule; // Working with Tungsten Capture's modules
...

// Retrieves the currently active batch
InteropServices.IBatch oBatch = m_oApp.ActiveBatch;
using (ApiObjectWrapper <InteropServices.IBatch> oApiObjectWrapper = new ApiObjectWrapper<InteropServices.IBatch>(oBatch))
{
  if (!oApiObjectWrapper.IsNull)
  {
     // Do something with the oBatch via oApiObjectWrapper.WrappedObject property
     ...
  }
} // oBatch.Dispose() will be called automatically.
Imports Kofax.Capture.CaptureModule ' Working with Tungsten Capture's modules
...

' Retrieves the currently active batch
Dim oBatch as InteropServices.IBatch = m_oApp.ActiveBatch
Using oApiObjectWrapper As New ApiObjectWrapper(Of InteropServices.IBatch)(oBatch)
   If Not oApiObjectWrapper.IsNull Then
      ' Do something with oBatch via oApiObjectWrapper.WrappedObject property
      ...
   End If
End Using  ' oBatch.Dispose() will be called automatically.
Public class | AttributeValueColl
Public class | BulkUpdateDataColl
Public class | NameValuePair
Remarks


ApiObjectWrapper(T) Class

ApiObjectWrapperT Class
Represents a strongly typed wrapper of Tungsten Capture .NET API objects that can be accessed by WrappedObject property. Provides methods to determine if wrapped object is Nothing or null, and automatically makes a call to the wrapped object's Dispose method when this object is being disposed.
Usage:
Examples
The following example demonstrates the use of this class.
C#
VB
Copy
using Kofax.Capture.AdminModule;   // Working with Tungsten Capture's Administration module
...
// Retrieves the active batch class
InteropServices.IBatchClass oBatchClass = m_oAdminApp.ActiveBatchClass;
using (ApiObjectWrapper <InteropServices.IBatchClass> oApiObjectWrapper = new ApiObjectWrapper<InteropServices.IBatchClass>(oBatchClass))
{
  if (!oApiObjectWrapper.IsNull)
  {
     // Do something with the oBatchClass via oApiObjectWrapper.WrappedObject property
     ...
  }
} // oBatchClass.Dispose() will be called automatically.
Imports Kofax.Capture.AdminModule   ' Working with Tungsten Capture's Administration module
...

' Retrieves the active batch class
Dim oBatchClass as InteropServices.IBatchClass = m_oAdminApp.ActiveBatchClass
Using oApiObjectWrapper As New ApiObjectWrapper(Of InteropServices.IBatchClass)(oBatchClass)
   If Not oApiObjectWrapper.IsNull Then
      ' Do something with oBatchClass via oApiObjectWrapper.WrappedObject property
      ...
   End If
End Using  ' oBatchClass.Dispose() will be called automatically.
C#
VB
Copy
using Kofax.Capture.CaptureModule; // Working with Tungsten Capture's modules
...

// Retrieves the currently active batch
InteropServices.IBatch oBatch = m_oApp.ActiveBatch;
using (ApiObjectWrapper <InteropServices.IBatch> oApiObjectWrapper = new ApiObjectWrapper<InteropServices.IBatch>(oBatch))
{
  if (!oApiObjectWrapper.IsNull)
  {
     // Do something with the oBatch via oApiObjectWrapper.WrappedObject property
     ...
  }
} // oBatch.Dispose() will be called automatically.
Imports Kofax.Capture.CaptureModule ' Working with Tungsten Capture's modules
...

' Retrieves the currently active batch
Dim oBatch as InteropServices.IBatch = m_oApp.ActiveBatch
Using oApiObjectWrapper As New ApiObjectWrapper(Of InteropServices.IBatch)(oBatch)
   If Not oApiObjectWrapper.IsNull Then
      ' Do something with oBatch via oApiObjectWrapper.WrappedObject property
      ...
   End If
End Using  ' oBatch.Dispose() will be called automatically.
Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModuleApiObjectWrapperT

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(false)]
public class ApiObjectWrapper<T> : IDisposable

<ComVisibleAttribute(false)>
Public Class ApiObjectWrapper(Of T)
    Implements IDisposable

Type Parameters

T
The type of element wrapped by this class. Must implement System.IDisposable interface.

The ApiObjectWrapperT type exposes the following members.

Constructors
 | Name | Description
Public method | ApiObjectWrapperT | Constructor that takes generic type argument T.
Top
Methods
 | Name | Description
Public method | Dispose | Perform class-defined tasks associated with freeing, releasing or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IsNull | Determines if the held object is Nothing or null.
Public property | WrappedObject | Returns an instance of held object as type specified by generic type argument T.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule Namespace


ApiObjectWrapper(T) Constructor

ApiObjectWrapperT Constructor
Constructor that takes generic type argument T.

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ApiObjectWrapper(
    T oObj
)
Public Sub New (
    oObj As T
)

Parameters

oObj
Type: T
Any object type that implements System.IDisposable interface.
Remarks
See Also

Reference

ApiObjectWrapperT Class
Kofax.Capture.CaptureModule Namespace


ApiObjectWrapper(T) Methods

ApiObjectWrapperT Methods

The ApiObjectWrapperT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Perform class-defined tasks associated with freeing, releasing or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ApiObjectWrapperT Class
Kofax.Capture.CaptureModule Namespace


ApiObjectWrapper(T).Dispose Method

ApiObjectWrapperTDispose Method
Perform class-defined tasks associated with freeing, releasing or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

ApiObjectWrapperT Class
Kofax.Capture.CaptureModule Namespace


ApiObjectWrapper(T) Properties

ApiObjectWrapperT Properties

The ApiObjectWrapperT generic type exposes the following members.

Properties
 | Name | Description
Public property | IsNull | Determines if the held object is Nothing or null.
Public property | WrappedObject | Returns an instance of held object as type specified by generic type argument T.
Top
See Also

Reference

ApiObjectWrapperT Class
Kofax.Capture.CaptureModule Namespace


ApiObjectWrapper(T).IsNull Property

ApiObjectWrapperTIsNull Property
Determines if the held object is Nothing or null.

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool IsNull { get; }
Public ReadOnly Property IsNull As Boolean
    Get

Property Value

Type: Boolean
Boolean in Visual Basic or bool in C# programming languages.

Return Value

Type: Boolean
True if the wrapped object is Nothing or null.
Remarks
See Also

Reference

ApiObjectWrapperT Class
Kofax.Capture.CaptureModule Namespace


ApiObjectWrapper(T).WrappedObject Property

ApiObjectWrapperTWrappedObject Property
Returns an instance of held object as type specified by generic type argument T.

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public T WrappedObject { get; }
Public ReadOnly Property WrappedObject As T
    Get

Property Value

Type: T
Returns the instance of object that this class is currently holding.

Return Value

Type: T
Generic type argument T.
Remarks
See Also

Reference

ApiObjectWrapperT Class
Kofax.Capture.CaptureModule Namespace


AttributeValueColl Class

AttributeValueColl Class
Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModuleAttributeValueColl

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class AttributeValueColl : IAttributeValueColl
Public Class AttributeValueColl
    Implements IAttributeValueColl

The AttributeValueColl type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeValueColl | Initializes a new instance of the AttributeValueColl class
Top
Methods
 | Name | Description
Public method | Add |
Public method | Count |
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Item |
Public method | Remove |
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Kofax.Capture.CaptureModule Namespace


AttributeValueColl Constructor

AttributeValueColl Constructor
Initializes a new instance of the AttributeValueColl class

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public AttributeValueColl()
Public Sub New
See Also

Reference

AttributeValueColl Class
Kofax.Capture.CaptureModule Namespace


AttributeValueColl Methods

AttributeValueColl Methods

The AttributeValueColl type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Count |
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Item |
Public method | Remove |
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AttributeValueColl Class
Kofax.Capture.CaptureModule Namespace


AttributeValueColl.Add Method

AttributeValueCollAdd Method

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Add(
    INameValuePair oItem
)
Public Sub Add (
    oItem As INameValuePair
)

Parameters

oItem
Type: Kofax.Capture.SDK.DataINameValuePair

Implements

IAttributeValueCollAdd(INameValuePair)
See Also

Reference

AttributeValueColl Class
Kofax.Capture.CaptureModule Namespace


AttributeValueColl.Count Method

AttributeValueCollCount Method

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count()
Public Function Count As Integer

Return Value

Type: Int32

Implements

IAttributeValueCollCount
See Also

Reference

AttributeValueColl Class
Kofax.Capture.CaptureModule Namespace


AttributeValueColl.GetEnumerator Method

AttributeValueCollGetEnumerator Method

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

AttributeValueColl Class
Kofax.Capture.CaptureModule Namespace


AttributeValueColl.Item Method

AttributeValueCollItem Method

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public INameValuePair Item(
    ref int nIndex
)
Public Function Item (
    ByRef nIndex As Integer
) As INameValuePair

Parameters

nIndex
Type: SystemInt32

Return Value

Type: INameValuePair

Implements

IAttributeValueCollItem(Int32)
See Also

Reference

AttributeValueColl Class
Kofax.Capture.CaptureModule Namespace


AttributeValueColl.Remove Method

AttributeValueCollRemove Method

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Remove(
    ref int nIndex
)
Public Sub Remove (
    ByRef nIndex As Integer
)

Parameters

nIndex
Type: SystemInt32

Implements

IAttributeValueCollRemove(Int32)
See Also

Reference

AttributeValueColl Class
Kofax.Capture.CaptureModule Namespace


BulkUpdateDataColl Class

BulkUpdateDataColl Class
Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModuleBulkUpdateDataColl

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class BulkUpdateDataColl : IBulkUpdateDataColl
Public Class BulkUpdateDataColl
    Implements IBulkUpdateDataColl

The BulkUpdateDataColl type exposes the following members.

Constructors
 | Name | Description
Public method | BulkUpdateDataColl | Initializes a new instance of the BulkUpdateDataColl class
Top
Methods
 | Name | Description
Public method | Add |
Public method | Count |
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Item |
Public method | Remove |
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Kofax.Capture.CaptureModule Namespace


BulkUpdateDataColl Constructor

BulkUpdateDataColl Constructor
Initializes a new instance of the BulkUpdateDataColl class

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public BulkUpdateDataColl()
Public Sub New
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.CaptureModule Namespace


BulkUpdateDataColl Methods

BulkUpdateDataColl Methods

The BulkUpdateDataColl type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Count |
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Item |
Public method | Remove |
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.CaptureModule Namespace


BulkUpdateDataColl.Add Method

BulkUpdateDataCollAdd Method

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Add(
    IAttributeValueColl oItem
)
Public Sub Add (
    oItem As IAttributeValueColl
)

Parameters

oItem
Type: Kofax.Capture.SDK.DataIAttributeValueColl

Implements

IBulkUpdateDataCollAdd(IAttributeValueColl)
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.CaptureModule Namespace


BulkUpdateDataColl.Count Method

BulkUpdateDataCollCount Method

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count()
Public Function Count As Integer

Return Value

Type: Int32

Implements

IBulkUpdateDataCollCount
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.CaptureModule Namespace


BulkUpdateDataColl.GetEnumerator Method

BulkUpdateDataCollGetEnumerator Method

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.CaptureModule Namespace


BulkUpdateDataColl.Item Method

BulkUpdateDataCollItem Method

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IAttributeValueColl Item(
    ref int nIndex
)
Public Function Item (
    ByRef nIndex As Integer
) As IAttributeValueColl

Parameters

nIndex
Type: SystemInt32

Return Value

Type: IAttributeValueColl

Implements

IBulkUpdateDataCollItem(Int32)
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.CaptureModule Namespace


BulkUpdateDataColl.Remove Method

BulkUpdateDataCollRemove Method

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Remove(
    ref int nIndex
)
Public Sub Remove (
    ByRef nIndex As Integer
)

Parameters

nIndex
Type: SystemInt32

Implements

IBulkUpdateDataCollRemove(Int32)
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.CaptureModule Namespace


NameValuePair Class

NameValuePair Class
Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModuleNameValuePair

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class NameValuePair : INameValuePair
Public Class NameValuePair
    Implements INameValuePair

The NameValuePair type exposes the following members.

Constructors
 | Name | Description
Public method | NameValuePair | Initializes a new instance of the NameValuePair class
Public method | NameValuePair(String, String) | Initializes a new instance of the NameValuePair class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
See Also

Reference

Kofax.Capture.CaptureModule Namespace


NameValuePair Constructor

NameValuePair Constructor
Overload List
 | Name | Description
Public method | NameValuePair | Initializes a new instance of the NameValuePair class
Public method | NameValuePair(String, String) | Initializes a new instance of the NameValuePair class
Top
See Also

Reference

NameValuePair Class
Kofax.Capture.CaptureModule Namespace


NameValuePair Constructor

NameValuePair Constructor
Initializes a new instance of the NameValuePair class

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public NameValuePair()
Public Sub New
See Also

Reference

NameValuePair Class
NameValuePair Overload
Kofax.Capture.CaptureModule Namespace


NameValuePair Constructor (String, String)

NameValuePair Constructor (String, String)
Kofax Capture API Reference
Initializes a new instance of the NameValuePair class

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public NameValuePair(
    string strName,
    string strValue
)
Public Sub New (
    strName As String,
    strValue As String
)

Parameters

strName
Type: SystemString
strValue
Type: SystemString
See Also

Reference

NameValuePair Class
NameValuePair Overload
Kofax.Capture.CaptureModule Namespace


NameValuePair Methods

NameValuePair Methods

The NameValuePair type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NameValuePair Class
Kofax.Capture.CaptureModule Namespace


NameValuePair Properties

NameValuePair Properties

The NameValuePair type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
See Also

Reference

NameValuePair Class
Kofax.Capture.CaptureModule Namespace


NameValuePair.Name Property

NameValuePairName Property

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Implements

INameValuePairName
See Also

Reference

NameValuePair Class
Kofax.Capture.CaptureModule Namespace


NameValuePair.Value Property

NameValuePairValue Property

Namespace: Kofax.Capture.CaptureModule
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String

Implements

INameValuePairValue
See Also

Reference

NameValuePair Class
Kofax.Capture.CaptureModule Namespace


Kofax.Capture.CaptureModule.InteropServices Namespace

Kofax.Capture.CaptureModule.InteropServices Namespace

With the Tungsten Capture Module .NET Type Library, you can add custom panels, menu items and import applications to the Scan, Quality Control, Validation, and/or Verification modules.

Classes
 | Class | Description
Public class | Application | Application COM implementation class. Serves as a root for a dynamic hierarchy of application objects.
Public class | AsnReleaseScript | AsnReleaseScript COM implementation class. Defines information about export connectors. An AsnReleaseScript object is invalidated when a content change event occurs.
Public class | AsnReleaseScripts | AsnReleaseScripts COM implementation class. Defines a COM collection of AsnReleaseScript objects.
Public class | AvailableBatch | AvailableBatch COM implementation class. Defines a COM object that refers to batches in process by Tungsten Capture.
Public class | AvailableBatches | AvailableBatches COM implementation class. Defines a COM collection of batches that are either ready or suspended, are routed to the current module, and can be opened by the current user.
Public class | Batch | Batch COM implementation class. Defines information about the currently opened batch.
Public class | BatchChanges | BatchChanges COM implementation class. Defines information about changes made to a batch in custom modules.
Public class | BatchClass | BatchClass COM implementation class. Defines a COM object that refers to a batch class published by Tungsten Capture.
Public class | BatchClasses | BatchClasses COM implementation class. Defines a COM collection of published batch class objects.
Public class | BatchField | BatchField COM implementation class. Defines a COM object that contains a value associated with a batch.
Public class | BatchFields | BatchFields COM implementation class. Defines a COM collection of BatchField objects.
Public class | BatchNameCreator | BatchNameCreator COM implementation class. Defines a COM object that allows an OCX to generate its own batch name.
Public class | CustomProperties | CustomProperties COM implementation class. Defines a COM collection of CustomProperty objects.
Public class | CustomProperty | CustomProperty COM implementation class. Defines information about custom properties.
Public class | Document | Document COM implementation class. Defines information about the currently opened document.
Public class | DocumentClass | DocumentClass COM implementation class. Defines a COM object that refers to a Tungsten Capture document class.
Public class | DocumentClasses | DocumentClasses COM implementation class. Defines a COM collection of DocumentClass objects.
Public class | Documents | Documents COM implementation class. Defines a COM collection of Document objects.
Public class | ExpectedBatchTotal | ExpectedBatchTotal COM implementation class. Defines a COM object that contains the sum of a certain document index fields.
Public class | ExpectedBatchTotals | ExpectedBatchTotals COM implementation class. Defines a COM collection of ExpectedBatchTotal objects.
Public class | Folder | Folder COM implementation class. Defines information about the currently opened folder.
Public class | FolderClass | FolderClass COM implementation class. Defines a COM object that refers to a Tungsten Capture folder class.
Public class | FolderClasses | FolderClasses COM implementation class. Defines a collection of folder classes.
Public class | Folders | Folders COM implementation class. Defines a COM collection of Folder objects.
Public class | FormType | FormType COM implementation class. Defines a COM object that refers to a Tungsten Capture form type.
Public class | FormTypes | FormTypes COM implementation class. Defines a COM collection of FormType objects.
Public class | Implementation |
Public class | ImportLogin | ImportLogin COM implementation class. Defines a COM object that coordinates logging in and logging out of Tungsten Capture. This is the only object that can be created using New or CreateObject in Visual Basic.
Public class | IndexField | IndexField COM implementation class. Defines information about an index field.
Public class | IndexFields | IndexFields COM implementation class. Defines a COM collection of IndexField objects.
Public class | NewBatchParameters | Obsolete. NewBatchParameters COM implementation class.
Public class | ObjectID | ObjectID COM implementation class. Contains the ID for an object of type Document, Page or Folder.
Public class | ObjectIDs | ObjectIDs COM implementation class. Defines a COM collection of ObjectID objects.
Public class | Page | Page COM implementation class. Defines information about a page.
Public class | Pages | Pages COM implementation class. Defines a COM collection of Page objects.
Public class | RGB | RGB COM implementation class. Defines Red, Green, and Blue values of a color.
Public class | ScannerProfile | ScannerProfile COM implementation class. Defines a COM object that contains a ScannerProfile.
Public class | ScannerProfiles | ScannerProfiles COM implementation class. Defines a COM collection of ScannerProfile objects.
Public class | SuggestedValue | SuggestedValue COM implementation class. Defines a COM object that contains a possible choice for batch field or index field values.
Public class | SuggestedValues | SuggestedValues COM implementation class. Defines a COM collection of SuggestedValue objects.
Public class | Table | Table COM implementation class. Defines a COM object that defines a table in a document.
Public class | TableDefinition | TableDefinition COM implementation class. Defines a table definition.
Public class | TableDefinitions | TableDefinitions COM implementation class. Defines a COM object that defines a collection of tables in a document class.
Public class | TableRow | TableRow COM implementation class. Defines a COM object that represents a row in a table.
Public class | TableRows | TableRows COM implementation class. Defines a COM object that represents the collection of rows in a table.
Public class | Tables | Tables COM implementation class. Defines a COM object that defines a collection of tables in a document.
Public class | Theme | Theme COM implementation class. Defines a COM object that provides access to the theme of the Tungsten Capture system.
Interfaces
 | Interface | Description
Public interface | IApplication | IApplication COM Interface. Serves as a root for a dynamic hierarchy of application objects.
Public interface | IAsnReleaseScript | IAsnReleaseScript COM Interface. Defines information about export connectors. An AsnReleaseScript object is invalidated when a content change event occurs.
Public interface | IAsnReleaseScripts | IAsnReleaseScripts COM Interface. Defines a COM collection of AsnReleaseScript objects.
Public interface | IAvailableBatch | IAvailableBatch COM Interface. Defines a COM object that refers to batches in process by Tungsten Capture.
Public interface | IAvailableBatches | IAvailableBatches COM Interface. Defines a COM collection of batches that are either ready or suspended, are routed to the current module, and can be opened by the current user.
Public interface | IBatch | IBatch COM Interface. Defines information about the currently opened batch.
Public interface | IBatchChanges | IBatchChanges COM Interface. Defines information about changes made to a batch in custom modules.
Public interface | IBatchClass | IBatchClass COM Interface. Defines a COM object that refers to a batch class published by Tungsten Capture.
Public interface | IBatchClasses | IBatchClasses COM Interface. Defines a COM collection of published batch class objects.
Public interface | IBatchField | IBatchField COM Interface. Defines a COM object that contains a value associated with a batch.
Public interface | IBatchFields | IBatchFields COM Interface. Defines a COM collection of BatchField objects.
Public interface | IBatchNameCreator | IBatchNameCreator COM Interface. Defines a COM object that allows an OCX to generate its own batch name.
Public interface | ICustomProperties | ICustomProperties COM Interface. Defines a COM collection of CustomProperty objects.
Public interface | ICustomProperty | ICustomProperty COM Interface. Defines information about custom properties.
Public interface | IDocument | IDocument COM Interface. Defines information about the currently opened document.
Public interface | IDocumentClass | IDocumentClass COM Interface. Defines a COM object that refers to a Tungsten Capture document class.
Public interface | IDocumentClasses | IDocumentClasses COM Interface. Defines a COM collection of DocumentClass objects.
Public interface | IDocuments | IDocuments COM Interface. Defines a COM collection of Document objects.
Public interface | IExpectedBatchTotal | IExpectedBatchTotal COM Interface. Defines a COM object that contains the sum of a certain document index fields.
Public interface | IExpectedBatchTotals | IExpectedBatchTotals COM Interface. Defines a COM collection of ExpectedBatchTotal objects.
Public interface | IFolder | IFolder COM Interface. Defines information about the currently opened folder.
Public interface | IFolderClass | IFolderClass COM Interface. Defines a COM object that refers to a Tungsten Capture folder class.
Public interface | IFolderClasses | IFolderClasses COM Interface. Defines a collection of folder classes.
Public interface | IFolders | IFolders COM Interface. Defines a COM collection of Folder objects.
Public interface | IFormType | IFormType COM Interface. Defines a COM object that refers to a Tungsten Capture form type.
Public interface | IFormTypes | IFormTypes COM Interface. Defines a COM collection of FormType objects.
Public interface | IImportLogin | IImportLogin COM Interface. Defines a COM object that coordinates logging in and logging out of Tungsten Capture. This is the only object that can be created using New or CreateObject in Visual Basic.
Public interface | IIndexField | IIndexField COM Interface. Defines information about an index field.
Public interface | IIndexFields | IIndexFields COM Interface. Defines a COM collection of IndexField objects.
Public interface | INewBatchParameters | Obsolete. INewBatchParameters COM Interface.
Public interface | IObjectID | IObjectID COM Interface. Contains the ID for an object of type Document, Page or Folder.
Public interface | IObjectIDs | IObjectIDs COM Interface. Defines a COM collection of ObjectID objects.
Public interface | IPage | IPage COM Interface. Defines information about a page.
Public interface | IPages | IPages COM Interface. Defines a COM collection of Page objects.
Public interface | IRGB | IRGB COM Interface. Defines Red, Green, and Blue values of a color.
Public interface | IScannerProfile | IScannerProfile COM Interface. Defines a COM object that contains a ScannerProfile.
Public interface | IScannerProfiles | IScannerProfiles COM Interface. Defines a COM collection of ScannerProfile objects.
Public interface | ISuggestedValue | ISuggestedValue COM Interface. Defines a COM object that contains a possible choice for batch field or index field values.
Public interface | ISuggestedValues | ISuggestedValues COM Interface. Defines a COM collection of SuggestedValue objects.
Public interface | ITable | ITable COM Interface. Defines a COM object that defines a table in a document.
Public interface | ITableDefinition | ITableDefinition COM Interface. Defines a table definition.
Public interface | ITableDefinitions | ITableDefinitions COM Interface. Defines a COM object that defines a collection of tables in a document class.
Public interface | ITableRow | ITableRow COM Interface. Defines a COM object that represents a row in a table.
Public interface | ITableRows | ITableRows COM Interface. Defines a COM object that represents the collection of rows in a table.
Public interface | ITables | ITables COM Interface. Defines a COM object that defines a collection of tables in a document.
Public interface | ITheme | ITheme COM Interface. Defines a COM object that provides access to the theme of the Tungsten Capture system.
Enumerations
 | Enumeration | Description
Public enumeration | KfxApiAdminMenuItems | This enumeration represents Administration menu items.
Public enumeration | KfxAPIApplicationFunctionList | Defines the function list that can be blocked or restored menu bar items, context menu items, toolbar buttons, and keyboard accelerators.
Public enumeration | KfxApiBatchState | This enumeration represents Batch states.
Public enumeration | KfxApiErr | Defines the possible errors. All errors are exposed in the KfxApiErr enum value within the Tungsten Capture Module Type Library.
Public enumeration | KfxApiQCMenuItems | This enumeration represents Quality Control menu items.
Public enumeration | KfxApiScanMenuItems | This enumeration represents Scan menu items.
Public enumeration | KfxApiValidationMenuItems | This enumeration represents Validation menu items.
Public enumeration | KfxApiValidationMode | This enumeration represents Validation modes.
Public enumeration | KfxApiVerificationMenuItems | This enumeration represents Verification menu items.
Public enumeration | KfxDataEvent | Defines the various different data events. Data events are essentially function calls to the OCX to get data-source information and to communicate changes in data.
Public enumeration | KfxDataEventReturnCode | Defines the enumeration that represents the return code for a data event.
Public enumeration | KfxDataEventType | Defines data type event enumeration.
Public enumeration | KfxMenuEnable | Defines a possible state of Enabled/Grayed for a menu item.
Public enumeration | KfxOcxEvent | All application events are passed to the OCX via a single function call.
Public enumeration | KfxShowMenu | Defines the possible menu showing state.
Public enumeration | KfxSqlDataType | Defines SQL data types supported by the API.
Remarks


Application Class

Application Class

Application COM implementation class.

Serves as a root for a dynamic hierarchy of application objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesApplication

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC2F-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Application : IApplication,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC2F-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Application
    Implements IApplication, IDisposable

The Application type exposes the following members.

Constructors
 | Name | Description
Public method | Application | Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.Application class.
Top
Methods
 | Name | Description
Public method | AddMenu | Adds a menu to the application.
Public method | AddMenuEx | Adds a menu to the application.
Public method | BlockFunction | Blocks menu bar items, context menu items, toolbar buttons, and keyboard accelerators. Returns True if the function was successfully blocked and False otherwise.
Public method | CloseBatch | Closes the active batch so that Tungsten Capture can process it. The ActiveBatch property is set to Nothing.
Public method | CreateBatch | Creates a batch using the batch class referenced by oBatchClass. This batch becomes the active batch and is referenced by ActiveBatch.
Public method | CreateBatch2 | Creates a new batch that uses default batch field values based on the oBatchFields parameter.
Public method | CreateBatchWithID | Creates a batch using the batch class referenced by oBatchClass. This batch becomes the active batch and is referenced by ActiveBatch.
Public method | DeleteBatch | Deletes the active batch. The ActiveBatch property is set to Nothing.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | LogMonitoringMessage | Logs a string that can be retrieved via SNMP.
Public method | OpenBatch | Opens the specified batch.
Public method | OpenNextBatch | Opens the next batch, based on the input parameters.
Public method | RejectBatch | Sets the error message on the active batch, and then rejects and closes it. The ActiveBatch property is set to Nothing.
Public method | RestoreFunction | Restores blocked menu bar items, context menu items, toolbar buttons, and keyboard accelerators. Returns True if the function was successfully restored and False otherwise.
Public method | SelectMenuItem | Causes the menu item with the specified resource ID to be triggered.
Public method | SetActiveContext | Obsolete. This method is deprecated and the use of this method should be replaced with ActiveDocument, ActiveFolder, ActiveIndexField, and ActivePage in Batch object.
Public method | ShowMenu | Shows or hides a menu in the application.
Public method | ShowWindow | Shows or hides a panel in the application.
Public method | SuspendBatch | Suspends the active batch. The ActiveBatch property is set to Nothing.
Public method | ToString | (Inherited from Object.)
Public method | TranslateAscentCaptureValues | Any Tungsten Capture Value (enclosed in curly brackets) in strText is translated into the corresponding value.
Top
Properties
 | Name | Description
Public property | ActiveBatch | Returns the current batch.
Public property | AllowBatchEditing | This property is True if batch editing is allowed in the application.
Public property | AvailableBatches | Returns a collection of the batches that are either ready or suspended, are routed to the current module, and can be opened by the current user.
Public property | BatchClasses | Returns a collection of the batch classes available for creating a batch.
Public property | DataEntryMode | This property is deprecated in favor of ValidationMode.
Public property | HasAscentCaptureFeatures | Returns True if running Tungsten Capture.
Public property | IgnoreDocumentNavigationValidationError | Use this property if you want to set the ValidationMode to KfxValidationModeBatchEditing and avoid validation error messages while navigating from one document to another.
Public property | MultipleItemsSelected | Returns True if the user has selected multiple items on the tree viewer.
Public property | PanelName | Returns the internal (registry) name of the panel.
Public property | RemainingEDocumentCount | Returns the sum of all available Import eDocument count volume.
Public property | RemainingPageCount | Based on licensing and the hardware key, this is the number of remaining pages (excluding eDocument pages) that can be processed by Tungsten Capture.
Public property | ScannerProfile | Gets or sets currently selected scanner profile.
Public property | ScannerProfiles | Returns the current list of available scanner profiles.
Public property | ServicePackVersion | Returns the currently installed service pack version.
Public property | Theme | Returns the current theme of the Tungsten Capture system.
Public property | UseCustomScanAPI | Set to True to overwrite any separation behavior based on the configuration of the batch class. In this case, the separation method is provided via a custom panel.
Public property | ValidationMode | Setting this property changes the Validation Mode, but does not cause the "Save changes before closing document?" message to be displayed.
Top
Remarks

This object is automatically created when a user OCX is detected and the Application object is passed to the OCX, or when it is referenced in a custom application.

The API is COM-based and supports the COM IDispatch interface.

The type library name is "Kofax_Capture_CaptureModule," and the description is "Tungsten Capture Module .NET Type Library."

The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


Application Constructor

Application Constructor

Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.Application class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Application()
Public Sub New
Remarks
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application Methods

Application Methods

The Application type exposes the following members.

Methods
 | Name | Description
Public method | AddMenu | Adds a menu to the application.
Public method | AddMenuEx | Adds a menu to the application.
Public method | BlockFunction | Blocks menu bar items, context menu items, toolbar buttons, and keyboard accelerators. Returns True if the function was successfully blocked and False otherwise.
Public method | CloseBatch | Closes the active batch so that Tungsten Capture can process it. The ActiveBatch property is set to Nothing.
Public method | CreateBatch | Creates a batch using the batch class referenced by oBatchClass. This batch becomes the active batch and is referenced by ActiveBatch.
Public method | CreateBatch2 | Creates a new batch that uses default batch field values based on the oBatchFields parameter.
Public method | CreateBatchWithID | Creates a batch using the batch class referenced by oBatchClass. This batch becomes the active batch and is referenced by ActiveBatch.
Public method | DeleteBatch | Deletes the active batch. The ActiveBatch property is set to Nothing.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | LogMonitoringMessage | Logs a string that can be retrieved via SNMP.
Public method | OpenBatch | Opens the specified batch.
Public method | OpenNextBatch | Opens the next batch, based on the input parameters.
Public method | RejectBatch | Sets the error message on the active batch, and then rejects and closes it. The ActiveBatch property is set to Nothing.
Public method | RestoreFunction | Restores blocked menu bar items, context menu items, toolbar buttons, and keyboard accelerators. Returns True if the function was successfully restored and False otherwise.
Public method | SelectMenuItem | Causes the menu item with the specified resource ID to be triggered.
Public method | SetActiveContext | Obsolete. This method is deprecated and the use of this method should be replaced with ActiveDocument, ActiveFolder, ActiveIndexField, and ActivePage in Batch object.
Public method | ShowMenu | Shows or hides a menu in the application.
Public method | ShowWindow | Shows or hides a panel in the application.
Public method | SuspendBatch | Suspends the active batch. The ActiveBatch property is set to Nothing.
Public method | ToString | (Inherited from Object.)
Public method | TranslateAscentCaptureValues | Any Tungsten Capture Value (enclosed in curly brackets) in strText is translated into the corresponding value.
Top
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.AddMenu Method

ApplicationAddMenu Method

Adds a menu to the application.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool AddMenu(
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = ""
)
Public Function AddMenu (
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = ""
) As Boolean

Parameters

strEventText
Type: SystemString
Returned to the OCX when the menu is selected.
strMenuText
Type: SystemString
Text displayed in the menu item.
strMenuLocation
Type: SystemString

Location for the menu to appear.

The locations supported are as follows:

VB
Copy
Dim m_MenuLocationKeys(0 To 4) As String
m_MenuLocationKeys(0) = "MenuBar"
m_MenuLocationKeys(1) = "Batch"
m_MenuLocationKeys(2) = "Document"
m_MenuLocationKeys(3) = "Page"
strMenuBarText (Optional)
Type: SystemString
The text displayed on the main frame. Only required if the location is "MenuBar".

Return Value

Type: Boolean
BooleanTrue - Menu added, otherwise False.

Implements

IApplicationAddMenu(String, String, String, String)
Remarks
This method can only be used with OCX.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.AddMenuEx Method

ApplicationAddMenuEx Method

Adds a menu to the application.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool AddMenuEx(
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = "",
    bool bLarge = false,
    string strIconPath = "",
    string strGroupName = ""
)
Public Function AddMenuEx (
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = "",
    Optional bLarge As Boolean = false,
    Optional strIconPath As String = "",
    Optional strGroupName As String = ""
) As Boolean

Parameters

strEventText
Type: SystemString
Returned to the OCX when the menu is selected.
strMenuText
Type: SystemString
Text displayed in the menu item.
strMenuLocation
Type: SystemString
Location to place the menu. The locations supported are as follows:
VB
Copy
Dim m_MenuLocationKeys(0 To 4) As String
m_MenuLocationKeys(0) = "MenuBar"
m_MenuLocationKeys(1) =  "Batch"
m_MenuLocationKeys(2) = "Document"
m_MenuLocationKeys(3) = "Page"
strMenuBarText (Optional)
Type: SystemString
The text displayed on the Ribbon; only required if the location is "MenuBar".
bLarge (Optional)
Type: SystemBoolean
A large button (True), or a small one (False).
strIconPath (Optional)
Type: SystemString
The path to the icon file used for the button.
strGroupName (Optional)
Type: SystemString
The specific group for menu items (commands).

Return Value

Type: Boolean
BooleanTrue - Menu added, otherwise False.

Implements

IApplicationAddMenuEx(String, String, String, String, Boolean, String, String)
Remarks
This method can only be used with OCX. Note that some parameters are the same as the AddMenu method to preserve backwards compatibility. The extended parameters are provided for use with the Fluent UI (Ribbon).
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.BlockFunction Method

ApplicationBlockFunction Method

Blocks menu bar items, context menu items, toolbar buttons, and keyboard accelerators. Returns True if the function was successfully blocked and False otherwise.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool BlockFunction(
    KfxAPIApplicationFunctionList eFunctionID
)
Public Function BlockFunction (
    eFunctionID As KfxAPIApplicationFunctionList
) As Boolean

Parameters

eFunctionID
Type: Kofax.Capture.CaptureModule.InteropServicesKfxAPIApplicationFunctionList
The function to block.

Return Value

Type: Boolean
Boolean

Implements

IApplicationBlockFunction(KfxAPIApplicationFunctionList)
Remarks
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.CloseBatch Method

ApplicationCloseBatch Method

Closes the active batch so that Tungsten Capture can process it. The ActiveBatch property is set to Nothing.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void CloseBatch()
Public Sub CloseBatch

Implements

IApplicationCloseBatch
Remarks
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.CreateBatch Method

ApplicationCreateBatch Method

Creates a batch using the batch class referenced by oBatchClass. This batch becomes the active batch and is referenced by ActiveBatch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch CreateBatch(
    ref IBatchClass oBatchClass,
    string strBatchName
)
Public Function CreateBatch (
    ByRef oBatchClass As IBatchClass,
    strBatchName As String
) As IBatch

Parameters

oBatchClass
Type: Kofax.Capture.CaptureModule.InteropServicesIBatchClass
The batch class used to create the new batch.
strBatchName
Type: SystemString
The name of the new batch.

Return Value

Type: IBatch
IBatch

Implements

IApplicationCreateBatch(IBatchClass, String)
Remarks

If an empty batch name is specified (only from Scan or an import script), then a batch name is generated using the same algorithm as the default batch names in the Tungsten Capture New Batch dialog box in Batch Manager or Scan.

The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.CreateBatch2 Method

ApplicationCreateBatch2 Method
Creates a new batch that uses default batch field values based on the oBatchFields parameter.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch CreateBatch2(
    ref IBatchClass oBatchClass,
    string strBatchName,
    Object oBatchFields,
    ref IKfxCollection oOutputBatchFields = null
)
Public Function CreateBatch2 (
    ByRef oBatchClass As IBatchClass,
    strBatchName As String,
    oBatchFields As Object,
    Optional ByRef oOutputBatchFields As IKfxCollection = Nothing
) As IBatch

Parameters

oBatchClass
Type: Kofax.Capture.CaptureModule.InteropServicesIBatchClass
The batch class used to create the new batch.
strBatchName
Type: SystemString
The name of the new batch.
oBatchFields
Type: SystemObject
The collection of collections with the respective batch field names and values.
oOutputBatchFields (Optional)
Type: IKfxCollection
The output list of batch field names.

Return Value

Type: IBatch
IBatch

Implements

IApplicationCreateBatch2(IBatchClass, String, Object, IKfxCollection)
Remarks
If the batch name is empty, a default batch name is assigned, based on the name format defined in Batch Class Properties – Batch Naming.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.CreateBatchWithID Method

ApplicationCreateBatchWithID Method

Creates a batch using the batch class referenced by oBatchClass. This batch becomes the active batch and is referenced by ActiveBatch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch CreateBatchWithID(
    ref IBatchClass oBatchClass,
    string strBatchName,
    string strGUID
)
Public Function CreateBatchWithID (
    ByRef oBatchClass As IBatchClass,
    strBatchName As String,
    strGUID As String
) As IBatch

Parameters

oBatchClass
Type: Kofax.Capture.CaptureModule.InteropServicesIBatchClass
The batch class used to create the new batch.
strBatchName
Type: SystemString
The name of the new batch.
strGUID
Type: SystemString
The unique GUID of the new batch.

Return Value

Type: IBatch
IBatch
Remarks

If an empty batch name is specified (only from Scan or an import script), then a batch name is generated using the same algorithm as the default batch names in the Tungsten Capture New Batch dialog box in Batch Manager or Scan.

The returned object of this function should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.DeleteBatch Method

ApplicationDeleteBatch Method

Deletes the active batch. The ActiveBatch property is set to Nothing.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteBatch()
Public Sub DeleteBatch

Implements

IApplicationDeleteBatch
Remarks
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.Dispose Method

ApplicationDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.LogError Method

ApplicationLogError Method

Logs an error to the Tungsten Capture error log.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void LogError(
    int Err1,
    int Err2,
    int Err3,
    string ErrorMessage,
    string CodeModule,
    int LineNumber
)
Public Sub LogError (
    Err1 As Integer,
    Err2 As Integer,
    Err3 As Integer,
    ErrorMessage As String,
    CodeModule As String,
    LineNumber As Integer
)

Parameters

Err1
Type: SystemInt32
The primary error code.
Err2
Type: SystemInt32
Sub-code.
Err3
Type: SystemInt32
Sub-code.
ErrorMessage
Type: SystemString
The string message.
CodeModule
Type: SystemString
The source code module where the problem occurred.
LineNumber
Type: SystemInt32
The line number within the source where the problem occurred.

Implements

IApplicationLogError(Int32, Int32, Int32, String, String, Int32)
Remarks
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.LogMonitoringMessage Method

ApplicationLogMonitoringMessage Method

Logs a string that can be retrieved via SNMP.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void LogMonitoringMessage(
    string Message
)
Public Sub LogMonitoringMessage (
    Message As String
)

Parameters

Message
Type: SystemString
The string that will be logged.

Implements

IApplicationLogMonitoringMessage(String)
Remarks
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.OpenBatch Method

ApplicationOpenBatch Method

Opens the specified batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch OpenBatch(
    ref IAvailableBatch oAvailableBatch
)
Public Function OpenBatch (
    ByRef oAvailableBatch As IAvailableBatch
) As IBatch

Parameters

oAvailableBatch
Type: Kofax.Capture.CaptureModule.InteropServicesIAvailableBatch
The batch to open.

Return Value

Type: IBatch
IBatch

Implements

IApplicationOpenBatch(IAvailableBatch)
Remarks

The returned object of this function should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.OpenNextBatch Method

ApplicationOpenNextBatch Method

Opens the next batch, based on the input parameters.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch OpenNextBatch(
    ref bool bFilterPriorityDescending,
    ref KfxApiBatchState eState
)
Public Function OpenNextBatch (
    ByRef bFilterPriorityDescending As Boolean,
    ByRef eState As KfxApiBatchState
) As IBatch

Parameters

bFilterPriorityDescending
Type: SystemBoolean
If True, returns the highest priority batch.
eState
Type: Kofax.Capture.CaptureModule.InteropServicesKfxApiBatchState
Valid eState values are limited to:
  • KfxApiBatchStateReady
  • KfxApiBatchStateSuspend
  • KfxApiBatchStateError

If eState is any other value a "Parameter out of Range" error occurs.

Return Value

Type: IBatch
IBatch

Implements

IApplicationOpenNextBatch(Boolean, KfxApiBatchState)
Remarks
The returned object of this function should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.RejectBatch Method

ApplicationRejectBatch Method

Sets the error message on the active batch, and then rejects and closes it. The ActiveBatch property is set to Nothing.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void RejectBatch(
    string strErrorMessage
)
Public Sub RejectBatch (
    strErrorMessage As String
)

Parameters

strErrorMessage
Type: SystemString
The error message to set.

Implements

IApplicationRejectBatch(String)
Remarks
Because this is a critical operation and the message is used for debugging, the string is truncated if necessary to fit in the database.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.RestoreFunction Method

ApplicationRestoreFunction Method

Restores blocked menu bar items, context menu items, toolbar buttons, and keyboard accelerators. Returns True if the function was successfully restored and False otherwise.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool RestoreFunction(
    KfxAPIApplicationFunctionList eFunctionID
)
Public Function RestoreFunction (
    eFunctionID As KfxAPIApplicationFunctionList
) As Boolean

Parameters

eFunctionID
Type: Kofax.Capture.CaptureModule.InteropServicesKfxAPIApplicationFunctionList
The function ID to restore.

Return Value

Type: Boolean
Boolean

Implements

IApplicationRestoreFunction(KfxAPIApplicationFunctionList)
Remarks
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.SelectMenuItem Method

ApplicationSelectMenuItem Method

Causes the menu item with the specified resource ID to be triggered.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SelectMenuItem(
    int lResourceID,
    bool bSendImmediate = false
)
Public Function SelectMenuItem (
    lResourceID As Integer,
    Optional bSendImmediate As Boolean = false
) As Boolean

Parameters

lResourceID
Type: SystemInt32
The resource ID of the menu item to trigger.
bSendImmediate (Optional)
Type: SystemBoolean
Used in an action event, otherwise the menu is triggered after the event.

Return Value

Type: Boolean
Boolean. Returns False if the menu could not be selected due to the following cases:
1) The application is currently processing an event SendMessage will return False
2) If the menu item is disabled

Implements

IApplicationSelectMenuItem(Int32, Boolean)
Remarks

You can use a custom OCX panel to invoke Tungsten Capture menu items in the Administration, Scan, Quality Control, Validation, and Verification modules through this function.

Tungsten Capture menu items are passed to the module through the SelectMenuItem function. A separate set of menu items is available for each Tungsten Capture module.

If successful, SelectMenuItem returns a nonzero value. In the case of an unexpected system error, it returns a value of zero. SelectMenuItem will throw an error if any of the following are true:

  • You specify an invalid resource ID for the menu item
  • The item is currently grayed in the target module
  • You execute an exit menu item immediately (bSendImmediate is True)
  • The application is busy
The bSendImmediate parameter is optional, and it can be set to True or False.
  • If True, bSendImmediate invokes the Windows API call "SendMessage," which executes the menu command instantly and fails if the module is processing another event.
  • If False, bSendImmediate invokes the Windows API call "PostMessage," which posts the menu command so it is executed when other events are completed.
The following sample passes a menu item from a custom OCX to the Scan module. The menu item shown here displays the last page in a batch.
VB
Copy
Private Sub ScanStopped()
  Dim bResult As Boolean
  Dim lMenuResourceNumber As Long
  Dim bSendImmediate As Boolean
  bResult=False
On Error GoTo MenuSelectError:
  lMenuResourceNumber=KfxApiScanMenuItems.KfxScanMenuPageLast
  bSendImmediate=False
  bResult=m_oApp.SelectMenuItem(lMenuResourceNumber, bSendImmediate)
  Exit Sub
MenuSelectError:
MsgBox "Unable to select menu:" & Err.Description
End Sub
In the following code, the OCX Menu Selection invokes the About Tungsten Capture menu selection in the Administration module.
VB
Copy
Dim bSendImmediate As Boolean
bSendImmediate=False
' Display the about box
bResult=m_oApp.SelectMenuItem(KfxApiAdminMenuItems.KfxAdminMenuHelpAboutAscentCapture, bSendImmediate)
In the above example, KfxAdminMenuHelpAboutAscentCapture is the item for the Administration module About Tungsten Capture menu item. A separate set of menu items is available for each Tungsten Capture module.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.SetActiveContext Method

ApplicationSetActiveContext Method

Note: This API is now obsolete.

This method is deprecated and the use of this method should be replaced with ActiveDocument, ActiveFolder, ActiveIndexField, and ActivePage in Batch object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is deprecated and the use of this method should be replaced with ActiveDocument, ActiveFolder, ActiveIndexField, and ActivePage in Batch object.")]
public bool SetActiveContext(
    int DocumentNumber,
    int PageNumber,
    int IndexFieldNumber
)
<ObsoleteAttribute("This method is deprecated and the use of this method should be replaced with ActiveDocument, ActiveFolder, ActiveIndexField, and ActivePage in Batch object.")>
Public Function SetActiveContext (
    DocumentNumber As Integer,
    PageNumber As Integer,
    IndexFieldNumber As Integer
) As Boolean

Parameters

DocumentNumber
Type: SystemInt32
The one-based index of the desired document.
PageNumber
Type: SystemInt32
The index of the pages. If the application is currently in a document, then this navigates to a document page. If the application is currently on a loose page or on the batch node, then it navigates to a loose page.
IndexFieldNumber
Type: SystemInt32
Defines the desired field. The application must already be positioned on a document.

Return Value

Type: Boolean
Boolean

Implements

IApplicationSetActiveContext(Int32, Int32, Int32)
Remarks

This method only works for objects that are not in folders.

This function, only valid when a batch is opened, navigates to some object within the batch. It returns True if the context change was successful. Note that the context change can fail because of a validation script failure. Passing an out-of-range, or invalid parameter to this function causes it to throw the error "Invalid Parameter" to the caller. Attempting to call the function prior to the batch being opened raises the error "Not Available" to the caller.

Only one parameter can be passed as non-zero. Passing multiple parameters as non-zero fires the exception "Illegal parameter range."

Passing all parameters as 0 causes the application to navigate to the batch node (as viewed on the tree control). Attempting to navigate to a hidden index field fires the error "Illegal parameter range."

See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.ShowMenu Method

ApplicationShowMenu Method

Shows or hides a menu in the application.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void ShowMenu(
    KfxShowMenu eState,
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = ""
)
Public Sub ShowMenu (
    eState As KfxShowMenu,
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = ""
)

Parameters

eState
Type: Kofax.Capture.CaptureModule.InteropServicesKfxShowMenu
The state of the menu item.
strEventText
Type: SystemString
String returned to OCX when menu is selected.
strMenuText
Type: SystemString
Text to be put in menu, can contain hotkeys.
strMenuLocation
Type: SystemString
Location for menu to appear.
strMenuBarText (Optional)
Type: SystemString
Required for MenuBar text.

Implements

IApplicationShowMenu(KfxShowMenu, String, String, String, String)
Remarks
Only valid in OCX.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.ShowWindow Method

ApplicationShowWindow Method

Shows or hides a panel in the application.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool ShowWindow(
    bool bShow
)
Public Function ShowWindow (
    bShow As Boolean
) As Boolean

Parameters

bShow
Type: SystemBoolean

Same for all modules:

FALSE (0) means hide the panel.

TRUE not 0 means show the panel.

Return Value

Type: Boolean
Boolean. Returns False if we were unable to complete because window was already in the correct state.

Implements

IApplicationShowWindow(Boolean)
Remarks
Only valid in OCX.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.SuspendBatch Method

ApplicationSuspendBatch Method

Suspends the active batch. The ActiveBatch property is set to Nothing.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void SuspendBatch()
Public Sub SuspendBatch

Implements

IApplicationSuspendBatch
Remarks
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.TranslateAscentCaptureValues Method

ApplicationTranslateAscentCaptureValues Method

Any Tungsten Capture Value (enclosed in curly brackets) in strText is translated into the corresponding value.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void TranslateAscentCaptureValues(
    ref string strText
)
Public Sub TranslateAscentCaptureValues (
    ByRef strText As String
)

Parameters

strText
Type: SystemString
The original string to translate.

Implements

IApplicationTranslateAscentCaptureValues(String)
Remarks

For example: "This is the current document’s form type: {Document Form Name}."

Assuming a current document with a form exists, the "{Document Form Name}" text is replaced with the appropriate form name.

Tungsten Capture values may also be used to get batch field values. In this case, the batch field name is preceded by a dollar sign and enclosed in curly brackets.

For example: "This is the value of batch field name0: '{$name0}."

See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application Properties

Application Properties

The Application type exposes the following members.

Properties
 | Name | Description
Public property | ActiveBatch | Returns the current batch.
Public property | AllowBatchEditing | This property is True if batch editing is allowed in the application.
Public property | AvailableBatches | Returns a collection of the batches that are either ready or suspended, are routed to the current module, and can be opened by the current user.
Public property | BatchClasses | Returns a collection of the batch classes available for creating a batch.
Public property | DataEntryMode | This property is deprecated in favor of ValidationMode.
Public property | HasAscentCaptureFeatures | Returns True if running Tungsten Capture.
Public property | IgnoreDocumentNavigationValidationError | Use this property if you want to set the ValidationMode to KfxValidationModeBatchEditing and avoid validation error messages while navigating from one document to another.
Public property | MultipleItemsSelected | Returns True if the user has selected multiple items on the tree viewer.
Public property | PanelName | Returns the internal (registry) name of the panel.
Public property | RemainingEDocumentCount | Returns the sum of all available Import eDocument count volume.
Public property | RemainingPageCount | Based on licensing and the hardware key, this is the number of remaining pages (excluding eDocument pages) that can be processed by Tungsten Capture.
Public property | ScannerProfile | Gets or sets currently selected scanner profile.
Public property | ScannerProfiles | Returns the current list of available scanner profiles.
Public property | ServicePackVersion | Returns the currently installed service pack version.
Public property | Theme | Returns the current theme of the Tungsten Capture system.
Public property | UseCustomScanAPI | Set to True to overwrite any separation behavior based on the configuration of the batch class. In this case, the separation method is provided via a custom panel.
Public property | ValidationMode | Setting this property changes the Validation Mode, but does not cause the "Save changes before closing document?" message to be displayed.
Top
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.ActiveBatch Property

ApplicationActiveBatch Property

Returns the current batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch ActiveBatch { get; }
Public ReadOnly Property ActiveBatch As IBatch
    Get

Property Value

Type: IBatch

Return Value

Type: IBatch
IBatch

Implements

IApplicationActiveBatch
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.AllowBatchEditing Property

ApplicationAllowBatchEditing Property

This property is True if batch editing is allowed in the application.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool AllowBatchEditing { get; }
Public ReadOnly Property AllowBatchEditing As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean

Implements

IApplicationAllowBatchEditing
Remarks
For the Validation and Verification modules, this property is True if the batch class allows batch editing in the respective module and (when the User Profiles feature is enabled) if the user has batch editing rights. The property is False otherwise. For all other modules, this property is True.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.AvailableBatches Property

ApplicationAvailableBatches Property

Returns a collection of the batches that are either ready or suspended, are routed to the current module, and can be opened by the current user.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IAvailableBatches AvailableBatches { get; }
Public ReadOnly Property AvailableBatches As IAvailableBatches
    Get

Property Value

Type: IAvailableBatches

Return Value

Type: IAvailableBatches
IAvailableBatches

Implements

IApplicationAvailableBatches
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.BatchClasses Property

ApplicationBatchClasses Property

Returns a collection of the batch classes available for creating a batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchClasses BatchClasses { get; }
Public ReadOnly Property BatchClasses As IBatchClasses
    Get

Property Value

Type: IBatchClasses

Return Value

Type: IBatchClasses
IBatchClasses

Implements

IApplicationBatchClasses
Remarks
This property is refreshed each time it is accessed.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.DataEntryMode Property

ApplicationDataEntryMode Property

This property is deprecated in favor of ValidationMode.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool DataEntryMode { get; }
Public ReadOnly Property DataEntryMode As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean. Returns True when in Validation/Verification and data entry mode is enabled.

Implements

IApplicationDataEntryMode
Remarks
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.HasAscentCaptureFeatures Property

ApplicationHasAscentCaptureFeatures Property

Returns True if running Tungsten Capture.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool HasAscentCaptureFeatures { get; }
Public ReadOnly Property HasAscentCaptureFeatures As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IApplicationHasAscentCaptureFeatures
Remarks
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.IgnoreDocumentNavigationValidationError Property

ApplicationIgnoreDocumentNavigationValidationError Property

Use this property if you want to set the ValidationMode to KfxValidationModeBatchEditing and avoid validation error messages while navigating from one document to another.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool IgnoreDocumentNavigationValidationError { get; set; }
Public Property IgnoreDocumentNavigationValidationError As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IApplicationIgnoreDocumentNavigationValidationError
Remarks

This property is False by default.

If this property is False and a validation error occurs, a validation error message is displayed.

If this property is True, index field validation errors are ignored and no error messages are displayed.

In addition, if True, no validation checks are performed. Any changes to document index fields are saved, but the document is not regarded as processed.

See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.MultipleItemsSelected Property

ApplicationMultipleItemsSelected Property

Returns True if the user has selected multiple items on the tree viewer.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool MultipleItemsSelected { get; }
Public ReadOnly Property MultipleItemsSelected As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IApplicationMultipleItemsSelected
Remarks
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.PanelName Property

ApplicationPanelName Property

Returns the internal (registry) name of the panel.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string PanelName { get; }
Public ReadOnly Property PanelName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IApplicationPanelName
Remarks
Useful so you can have the same OCX that acts differently depending on how it's registered.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.RemainingEDocumentCount Property

ApplicationRemainingEDocumentCount Property

Returns the sum of all available Import eDocument count volume.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int RemainingEDocumentCount { get; }
Public ReadOnly Property RemainingEDocumentCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IApplicationRemainingEDocumentCount
Remarks
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.RemainingPageCount Property

ApplicationRemainingPageCount Property

Based on licensing and the hardware key, this is the number of remaining pages (excluding eDocument pages) that can be processed by Tungsten Capture.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int RemainingPageCount { get; }
Public ReadOnly Property RemainingPageCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IApplicationRemainingPageCount
Remarks

This property returns the sum of all available Scanned/Imported Pages volume.

See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.ScannerProfile Property

ApplicationScannerProfile Property

Gets or sets currently selected scanner profile.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IScannerProfile ScannerProfile { get; set; }
Public Property ScannerProfile As IScannerProfile
    Get
    Set

Property Value

Type: IScannerProfile

Return Value

Type: IScannerProfile

Implements

IApplicationScannerProfile
Remarks

Cannot be set during an action event.

The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.ScannerProfiles Property

ApplicationScannerProfiles Property

Returns the current list of available scanner profiles.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IScannerProfiles ScannerProfiles { get; }
Public ReadOnly Property ScannerProfiles As IScannerProfiles
    Get

Property Value

Type: IScannerProfiles

Return Value

Type: IScannerProfiles
IScannerProfiles

Implements

IApplicationScannerProfiles
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.ServicePackVersion Property

ApplicationServicePackVersion Property

Returns the currently installed service pack version.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public short ServicePackVersion { get; }
Public ReadOnly Property ServicePackVersion As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short

Implements

IApplicationServicePackVersion
Remarks
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.Theme Property

ApplicationTheme Property

Returns the current theme of the Tungsten Capture system.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ITheme Theme { get; }
Public ReadOnly Property Theme As ITheme
    Get

Property Value

Type: ITheme

Return Value

Type: ITheme
ITheme

Implements

IApplicationTheme
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.UseCustomScanAPI Property

ApplicationUseCustomScanAPI Property

Set to True to overwrite any separation behavior based on the configuration of the batch class. In this case, the separation method is provided via a custom panel.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool UseCustomScanAPI { set; }
Public WriteOnly Property UseCustomScanAPI As Boolean
    Set

Property Value

Type: Boolean

Implements

IApplicationUseCustomScanAPI
Remarks

This property can be set during an event and the changes will take effect on all subsequent scanned batches. However, for the change to take effect on the active batch, it must be set before that batch is opened or created. This property is not reset after each batch, but only the next time the Scan module is open.

See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Application.ValidationMode Property

ApplicationValidationMode Property

Setting this property changes the Validation Mode, but does not cause the "Save changes before closing document?" message to be displayed.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public KfxApiValidationMode ValidationMode { get; set; }
Public Property ValidationMode As KfxApiValidationMode
    Get
    Set

Property Value

Type: KfxApiValidationMode

Return Value

Type: KfxApiValidationMode
KfxApiValidationMode

Implements

IApplicationValidationMode
Remarks

In the Validation and Verification modules, the default value is KfxValidationModeDataEntry. In other modules, the default value is KfxValidationModeBatchEditing.

This property can be set during a KfxOcxEventBatchOpened event. For any other event, an KfxApiErrAppIsBusy error is thrown (similar to other, similar properties and methods).

If the property is set during the batch opened event, the mode switch will not occur until after the event is finished. Likewise, if (within an event) the application gets the ValidationMode property after setting it, the ValidationMode will still be the old value, since the change hasn't yet occurred.

Changing the application mode to batch editing in Validation is identical to selecting the corresponding item in the user interface toolbar (or menu item). The mode changes back to Data Entry upon opening another batch. Therefore, an OCX that wants to keep the system in batch editing mode needs to repeatedly set the mode whenever a batch is opened.

See Also

Reference

Application Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScript Class

AsnReleaseScript Class

AsnReleaseScript COM implementation class.

Defines information about export connectors. An AsnReleaseScript object is invalidated when a content change event occurs.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesAsnReleaseScript

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC31-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class AsnReleaseScript : IAsnReleaseScript,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC31-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class AsnReleaseScript
    Implements IAsnReleaseScript, IDisposable

The AsnReleaseScript type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomProperties | Returns the CustomProperty objects belonging to this export connector destination.
Public property | CustomPropertyCount | Returns the number of custom properties for this export connector assignment.
Public property | Name | Returns the assignment name, which is the name the user gives when assigning an export connector to a document class.
Public property | OrderNumber | Returns the order number, within the document class, of this export connector assignment.
Public property | ReleaseScriptName | Returns the name of the export connector.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScript Methods

AsnReleaseScript Methods

The AsnReleaseScript type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AsnReleaseScript Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScript.Dispose Method

AsnReleaseScriptDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

AsnReleaseScript Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScript Properties

AsnReleaseScript Properties

The AsnReleaseScript type exposes the following members.

Properties
 | Name | Description
Public property | CustomProperties | Returns the CustomProperty objects belonging to this export connector destination.
Public property | CustomPropertyCount | Returns the number of custom properties for this export connector assignment.
Public property | Name | Returns the assignment name, which is the name the user gives when assigning an export connector to a document class.
Public property | OrderNumber | Returns the order number, within the document class, of this export connector assignment.
Public property | ReleaseScriptName | Returns the name of the export connector.
Top
See Also

Reference

AsnReleaseScript Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScript.CustomProperties Property

AsnReleaseScriptCustomProperties Property

Returns the CustomProperty objects belonging to this export connector destination.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ICustomProperties CustomProperties { get; }
Public ReadOnly Property CustomProperties As ICustomProperties
    Get

Property Value

Type: ICustomProperties

Return Value

Type: ICustomProperties
ICustomProperties

Implements

IAsnReleaseScriptCustomProperties
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

AsnReleaseScript Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScript.CustomPropertyCount Property

AsnReleaseScriptCustomPropertyCount Property

Returns the number of custom properties for this export connector assignment.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int CustomPropertyCount { get; }
Public ReadOnly Property CustomPropertyCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IAsnReleaseScriptCustomPropertyCount
See Also

Reference

AsnReleaseScript Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScript.Name Property

AsnReleaseScriptName Property

Returns the assignment name, which is the name the user gives when assigning an export connector to a document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IAsnReleaseScriptName
Remarks
See Also

Reference

AsnReleaseScript Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScript.OrderNumber Property

AsnReleaseScriptOrderNumber Property

Returns the order number, within the document class, of this export connector assignment.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int OrderNumber { get; }
Public ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IAsnReleaseScriptOrderNumber
Remarks
See Also

Reference

AsnReleaseScript Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScript.ReleaseScriptName Property

AsnReleaseScriptReleaseScriptName Property

Returns the name of the export connector.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ReleaseScriptName { get; }
Public ReadOnly Property ReleaseScriptName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IAsnReleaseScriptReleaseScriptName
Remarks
See Also

Reference

AsnReleaseScript Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScripts Class

AsnReleaseScripts Class

AsnReleaseScripts COM implementation class.

Defines a COM collection of AsnReleaseScript objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesAsnReleaseScripts

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC33-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class AsnReleaseScripts : IAsnReleaseScripts,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC33-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class AsnReleaseScripts
    Implements IAsnReleaseScripts, IEnumerable, IDisposable

The AsnReleaseScripts type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of AsnReleaseScript objects contained in the collection.
Public property | Item | Returns the AsnReleaseScript object by order number or assignment name.
Top
Remarks
Iteration and extraction by order number or property name (with the item function) are supported. Passing an out-of-range, or invalid, parameter to the item function causes it to throw the error "Invalid Parameter" to the caller.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScripts Methods

AsnReleaseScripts Methods

The AsnReleaseScripts type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AsnReleaseScripts Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScripts.Dispose Method

AsnReleaseScriptsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

AsnReleaseScripts Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScripts.GetEnumerator Method

AsnReleaseScriptsGetEnumerator Method

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator

Implements

IAsnReleaseScriptsGetEnumerator
IEnumerableGetEnumerator
See Also

Reference

AsnReleaseScripts Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScripts Properties

AsnReleaseScripts Properties

The AsnReleaseScripts type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of AsnReleaseScript objects contained in the collection.
Public property | Item | Returns the AsnReleaseScript object by order number or assignment name.
Top
See Also

Reference

AsnReleaseScripts Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScripts.Count Property

AsnReleaseScriptsCount Property

Returns the number of AsnReleaseScript objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IAsnReleaseScriptsCount
Remarks
See Also

Reference

AsnReleaseScripts Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AsnReleaseScripts.Item Property

AsnReleaseScriptsItem Property

Returns the AsnReleaseScript object by order number or assignment name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IAsnReleaseScript this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IAsnReleaseScript
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IAsnReleaseScript

Return Value

Type: IAsnReleaseScript
IAsnReleaseScript

Implements

IAsnReleaseScriptsItemObject
Remarks
This is the default method. Note that the "name" is the name of the assignment, not the export connector name.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

AsnReleaseScripts Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatch Class

AvailableBatch Class

AvailableBatch COM implementation class.

Defines a COM object that refers to batches in process by Tungsten Capture.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesAvailableBatch

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC35-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class AvailableBatch : IAvailableBatch,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC35-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class AvailableBatch
    Implements IAvailableBatch, IDisposable

The AvailableBatch type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BatchClassName | Returns the name of the batch class used to create the batch.
Public property | ContainsErrors | Returns True if the batch contains errors.
Public property | CreationDate | Returns the date the batch was created.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Name | Returns the name of the batch.
Public property | Priority | Returns the priority of the batch.
Public property | State | Returns the status of the batch.
Public property | StationID | Returns the ID of the last station opening the batch.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatch Methods

AvailableBatch Methods

The AvailableBatch type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AvailableBatch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatch.Dispose Method

AvailableBatchDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

AvailableBatch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatch Properties

AvailableBatch Properties

The AvailableBatch type exposes the following members.

Properties
 | Name | Description
Public property | BatchClassName | Returns the name of the batch class used to create the batch.
Public property | ContainsErrors | Returns True if the batch contains errors.
Public property | CreationDate | Returns the date the batch was created.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Name | Returns the name of the batch.
Public property | Priority | Returns the priority of the batch.
Public property | State | Returns the status of the batch.
Public property | StationID | Returns the ID of the last station opening the batch.
Top
See Also

Reference

AvailableBatch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatch.BatchClassName Property

AvailableBatchBatchClassName Property

Returns the name of the batch class used to create the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string BatchClassName { get; }
Public ReadOnly Property BatchClassName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IAvailableBatchBatchClassName
Remarks
See Also

Reference

AvailableBatch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatch.ContainsErrors Property

AvailableBatchContainsErrors Property

Returns True if the batch contains errors.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool ContainsErrors { get; }
Public ReadOnly Property ContainsErrors As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IAvailableBatchContainsErrors
Remarks
See Also

Reference

AvailableBatch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatch.CreationDate Property

AvailableBatchCreationDate Property

Returns the date the batch was created.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public DateTime CreationDate { get; }
Public ReadOnly Property CreationDate As DateTime
    Get

Property Value

Type: DateTime

Return Value

Type: DateTime
Date

Implements

IAvailableBatchCreationDate
Remarks
See Also

Reference

AvailableBatch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatch.CustomStorageString Property

AvailableBatchCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString

Property Value

Type: String

Return Value

Type: String
String

Implements

IAvailableBatchCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific batch. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name. If set to an empty string, the storage string is deleted.

This function throws:(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

AvailableBatch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatch.Name Property

AvailableBatchName Property

Returns the name of the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IAvailableBatchName
Remarks
See Also

Reference

AvailableBatch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatch.Priority Property

AvailableBatchPriority Property

Returns the priority of the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Priority { get; }
Public ReadOnly Property Priority As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IAvailableBatchPriority
Remarks
See Also

Reference

AvailableBatch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatch.State Property

AvailableBatchState Property

Returns the status of the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public KfxApiBatchState State { get; }
Public ReadOnly Property State As KfxApiBatchState
    Get

Property Value

Type: KfxApiBatchState

Return Value

Type: KfxApiBatchState
KfxApiBatchState

Implements

IAvailableBatchState
Remarks
Only read or suspended batches are available.
See Also

Reference

AvailableBatch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatch.StationID Property

AvailableBatchStationID Property

Returns the ID of the last station opening the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string StationID { get; }
Public ReadOnly Property StationID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IAvailableBatchStationID
Remarks
See Also

Reference

AvailableBatch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatches Class

AvailableBatches Class

AvailableBatches COM implementation class.

Defines a COM collection of batches that are either ready or suspended, are routed to the current module, and can be opened by the current user.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesAvailableBatches

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC37-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class AvailableBatches : IAvailableBatches,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC37-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class AvailableBatches
    Implements IAvailableBatches, IEnumerable, IDisposable

The AvailableBatches type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of batches contained in the collection.
Public property | Item | Returns an available batch by name.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatches Methods

AvailableBatches Methods

The AvailableBatches type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AvailableBatches Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatches.Dispose Method

AvailableBatchesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

AvailableBatches Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatches.GetEnumerator Method

AvailableBatchesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IAvailableBatches object.

Implements

IAvailableBatchesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

AvailableBatches Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatches Properties

AvailableBatches Properties

The AvailableBatches type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of batches contained in the collection.
Public property | Item | Returns an available batch by name.
Top
See Also

Reference

AvailableBatches Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatches.Count Property

AvailableBatchesCount Property

Returns the number of batches contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IAvailableBatchesCount
Remarks
See Also

Reference

AvailableBatches Class
Kofax.Capture.CaptureModule.InteropServices Namespace


AvailableBatches.Item Property

AvailableBatchesItem Property

Returns an available batch by name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IAvailableBatch this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IAvailableBatch
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IAvailableBatch

Return Value

Type: IAvailableBatch
IAvailableBatch

Implements

IAvailableBatchesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

AvailableBatches Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch Class

Batch Class

Batch COM implementation class.

Defines information about the currently opened batch.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesBatch

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC39-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Batch : IBatch, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC39-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Batch
    Implements IBatch, IDisposable

The Batch type exposes the following members.

Methods
 | Name | Description
Public method | CreateDocument | Creates a document.
Public method | CreateDocumentWithID | Creates a document.
Public method | CreateFolder | Creates a folder after the last folder in the batch.
Public method | CreateFolderWithID | Creates a folder after the last folder in the batch.
Public method | DeleteDocument | Deletes a document and its pages.
Public method | DeleteFolder | Deletes a folder and its documents.
Public method | DeletePage | Deletes a page.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ImportFile | Imports the specified file.
Public method | ImportFileWithID | Imports the specified file(s).
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ActiveDocument | Gets or sets the currently active document.
Public property | ActiveFolder | Gets or sets the currently active folder.
Public property | ActiveIndexField | Gets or sets the currently active index field.
Public property | ActiveLoosePage | Returns the currently active loose page, if a loose page is selected. Otherwise, returns Nothing.
Public property | ActivePage | Gets or sets the active page (irrespective of it being a loose page or document page).
Public property | AutomaticSeparationAndFormID | Indicates whether automatic separation and form ID is enabled on the batch.
Public property | BatchClass | Returns the Batch Class of this batch.
Public property | BatchEndorsingNumber | Gets or sets the endorsing number. This property is used by endorsing scanners and cannot be set during an event. Endorsing must be enabled for the batch class in order to set this property.
Public property | BatchFields | Returns a list of batch fields contained in the batch.
Public property | BatchGUID | Returns the GUID string that represents the unique batch ID.
Public property | ClassID | Returns the batch class ID.
Public property | ClassName | Returns the batch class name.
Public property | CreateTime | Returns the date and time the batch was created.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Gets or sets the batch description.
Public property | DocumentClasses | Returns the document classes that are supported by the batch as defined by the Tungsten Capture batch class.
Public property | DocumentCount | Returns the total document count.
Public property | Documents | Returns the current set of documents.
Public property | DocumentsPerBatch | Gets or sets the number of documents in a batch.
Public property | ExpectedBatchTotals | Returns a list of the expected batch totals contained in the batch.
Public property | ExternalID | Returns the external batch ID.
Public property | FolderClasses | Gets the folder classes that are supported by the batch as defined by the Tungsten Capture batch class.
Public property | FolderCount | Gets the total folder count of the immediate child folders under the batch (not including indirect child folders of a folder).
Public property | Folders | Gets the current set of immediate folders under the batch (not including indirect child folders of a folder).
Public property | FormTypes | Returns the form types that are supported by the batch as defined by the Tungsten Capture batch class.
Public property | LoosePageCount | Returns the current number of loose pages.
Public property | LoosePages | Returns the current set of loose pages.
Public property | Name | Returns the batch name.
Public property | PagesPerBatch | Gets or sets the number of pages per batch.
Public property | PagesPerDoc | Gets or sets PagesPerDoc. Used by scan to create documents.
Public property | Priority | Gets or sets the batch class priority.
Public property | PublishTime | Returns the date and time the batch class used when the batch was published.
Public property | RowSeparator | Returns the legacy table field delimiter.
Public property | SelectedDocuments | Returns the selected documents
Public property | SelectedFolders | Returns the selected folders
Public property | SelectedPages | Returns the selected pages
Public property | SingleDocProcessing | Indicates whether single document processing is activated for the batch class.
Public property | SupportsAutomaticSeparationAndFormID | Indicates whether automatic separation and form ID can be enabled on the batch.
Public property | SupportsSingleDocProcessing | Indicates whether the batch class supports single document processing.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


Batch Methods

Batch Methods

The Batch type exposes the following members.

Methods
 | Name | Description
Public method | CreateDocument | Creates a document.
Public method | CreateDocumentWithID | Creates a document.
Public method | CreateFolder | Creates a folder after the last folder in the batch.
Public method | CreateFolderWithID | Creates a folder after the last folder in the batch.
Public method | DeleteDocument | Deletes a document and its pages.
Public method | DeleteFolder | Deletes a folder and its documents.
Public method | DeletePage | Deletes a page.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ImportFile | Imports the specified file.
Public method | ImportFileWithID | Imports the specified file(s).
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.CreateDocument Method

BatchCreateDocument Method

Creates a document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocument CreateDocument(
    ref IDocument oNextDocument = null
)
Public Function CreateDocument (
    Optional ByRef oNextDocument As IDocument = Nothing
) As IDocument

Parameters

oNextDocument (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
If oNextDocument is Nothing, the new document is the last document. Otherwise, it is inserted before oNextDocument.

Return Value

Type: IDocument

Implements

IBatchCreateDocument(IDocument)
Remarks

The created document does not contain a form type. Does not work in Validation or Verification if Data Entry mode is selected.

The returned object of this function should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.CreateDocumentWithID Method

BatchCreateDocumentWithID Method

Creates a document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocument CreateDocumentWithID(
    string strGUID,
    ref IDocument oNextDocument = null
)
Public Function CreateDocumentWithID (
    strGUID As String,
    Optional ByRef oNextDocument As IDocument = Nothing
) As IDocument

Parameters

strGUID
Type: SystemString
The document unique ID.
oNextDocument (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
If oNextDocument is Nothing, the new document is the last document. Otherwise, it is inserted before oNextDocument.

Return Value

Type: IDocument
IDocument

Implements

IBatchCreateDocumentWithID(String, IDocument)
Remarks

The created document does not contain a form type. Does not work in Validation or Verification if Data Entry mode is selected.

The returned object of this function should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.CreateFolder Method

BatchCreateFolder Method

Creates a folder after the last folder in the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolder CreateFolder()
Public Function CreateFolder As IFolder

Return Value

Type: IFolder
IFolder

Implements

IBatchCreateFolder
Remarks
This method does not work in Validation or Verification if Data Entry mode is selected.
The returned object of this function should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.CreateFolderWithID Method

BatchCreateFolderWithID Method

Creates a folder after the last folder in the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolder CreateFolderWithID(
    string strGUID
)
Public Function CreateFolderWithID (
    strGUID As String
) As IFolder

Parameters

strGUID
Type: SystemString
The folder unique ID.

Return Value

Type: IFolder
IFolder

Implements

IBatchCreateFolderWithID(String)
Remarks
This method does not work in Validation or Verification if Data Entry mode is selected.
The returned object of this function should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.DeleteDocument Method

BatchDeleteDocument Method

Deletes a document and its pages.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteDocument(
    ref IDocument oDocument
)
Public Sub DeleteDocument (
    ByRef oDocument As IDocument
)

Parameters

oDocument
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
The document to delete.

Implements

IBatchDeleteDocument(IDocument)
Remarks

Does not work in Validation or Verification if Data Entry mode is selected.

See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.DeleteFolder Method

BatchDeleteFolder Method

Deletes a folder and its documents.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteFolder(
    ref IFolder oFolder
)
Public Sub DeleteFolder (
    ByRef oFolder As IFolder
)

Parameters

oFolder
Type: Kofax.Capture.CaptureModule.InteropServicesIFolder
The folder to delete.

Implements

IBatchDeleteFolder(IFolder)
Remarks
Does not work in Validation or Verification if Data Entry mode is selected.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.DeletePage Method

BatchDeletePage Method

Deletes a page.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeletePage(
    ref IPage oPage
)
Public Sub DeletePage (
    ByRef oPage As IPage
)

Parameters

oPage
Type: Kofax.Capture.CaptureModule.InteropServicesIPage
The page to delete.

Implements

IBatchDeletePage(IPage)
Remarks

This method works with both loose and document pages.

Does not work in Validation or Verification if Data Entry mode is selected.

See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.Dispose Method

BatchDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.ImportFile Method

BatchImportFile Method

Imports the specified file.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPages ImportFile(
    string strFileName
)
Public Function ImportFile (
    strFileName As String
) As IPages

Parameters

strFileName
Type: SystemString
The file(s) to be imported.

Return Value

Type: IPages
IPages

Implements

IBatchImportFile(String)
Remarks

Returns the pages that were created.

Optionally, the user may pass a list of file names for strFileName provided that each file name is enclosed in quotation marks. Passing multiple files to a single ImportFile command may yield significant performance gains (from 30%-100% faster). However, error handling and separation may be more complex for the user to implement in such a case.

Only works in Scan, Quality Control, and customized standard modules, or with import scripts.

See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.ImportFileWithID Method

BatchImportFileWithID Method

Imports the specified file(s).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPages ImportFileWithID(
    string strFileName,
    string strIDs
)
Public Function ImportFileWithID (
    strFileName As String,
    strIDs As String
) As IPages

Parameters

strFileName
Type: SystemString
The file(s) to be imported.
strIDs
Type: SystemString
The page ID(s) to be imported.

Return Value

Type: IPages
IPages

Implements

IBatchImportFileWithID(String, String)
Remarks

Returns the pages that were created.

Optionally, the user may pass a list of file names for strFileName provided that each file name is enclosed in quotation marks. Passing multiple files to a single ImportFile command may yield significant performance gains (from 30%-100% faster). However, error handling and separation may be more complex for the user to implement in such a case.

Only works in Scan, Quality Control, and customized standard modules, or with import scripts.

The returned object of this function should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch Properties

Batch Properties

The Batch type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDocument | Gets or sets the currently active document.
Public property | ActiveFolder | Gets or sets the currently active folder.
Public property | ActiveIndexField | Gets or sets the currently active index field.
Public property | ActiveLoosePage | Returns the currently active loose page, if a loose page is selected. Otherwise, returns Nothing.
Public property | ActivePage | Gets or sets the active page (irrespective of it being a loose page or document page).
Public property | AutomaticSeparationAndFormID | Indicates whether automatic separation and form ID is enabled on the batch.
Public property | BatchClass | Returns the Batch Class of this batch.
Public property | BatchEndorsingNumber | Gets or sets the endorsing number. This property is used by endorsing scanners and cannot be set during an event. Endorsing must be enabled for the batch class in order to set this property.
Public property | BatchFields | Returns a list of batch fields contained in the batch.
Public property | BatchGUID | Returns the GUID string that represents the unique batch ID.
Public property | ClassID | Returns the batch class ID.
Public property | ClassName | Returns the batch class name.
Public property | CreateTime | Returns the date and time the batch was created.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Gets or sets the batch description.
Public property | DocumentClasses | Returns the document classes that are supported by the batch as defined by the Tungsten Capture batch class.
Public property | DocumentCount | Returns the total document count.
Public property | Documents | Returns the current set of documents.
Public property | DocumentsPerBatch | Gets or sets the number of documents in a batch.
Public property | ExpectedBatchTotals | Returns a list of the expected batch totals contained in the batch.
Public property | ExternalID | Returns the external batch ID.
Public property | FolderClasses | Gets the folder classes that are supported by the batch as defined by the Tungsten Capture batch class.
Public property | FolderCount | Gets the total folder count of the immediate child folders under the batch (not including indirect child folders of a folder).
Public property | Folders | Gets the current set of immediate folders under the batch (not including indirect child folders of a folder).
Public property | FormTypes | Returns the form types that are supported by the batch as defined by the Tungsten Capture batch class.
Public property | LoosePageCount | Returns the current number of loose pages.
Public property | LoosePages | Returns the current set of loose pages.
Public property | Name | Returns the batch name.
Public property | PagesPerBatch | Gets or sets the number of pages per batch.
Public property | PagesPerDoc | Gets or sets PagesPerDoc. Used by scan to create documents.
Public property | Priority | Gets or sets the batch class priority.
Public property | PublishTime | Returns the date and time the batch class used when the batch was published.
Public property | RowSeparator | Returns the legacy table field delimiter.
Public property | SelectedDocuments | Returns the selected documents
Public property | SelectedFolders | Returns the selected folders
Public property | SelectedPages | Returns the selected pages
Public property | SingleDocProcessing | Indicates whether single document processing is activated for the batch class.
Public property | SupportsAutomaticSeparationAndFormID | Indicates whether automatic separation and form ID can be enabled on the batch.
Public property | SupportsSingleDocProcessing | Indicates whether the batch class supports single document processing.
Top
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.ActiveDocument Property

BatchActiveDocument Property

Gets or sets the currently active document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocument ActiveDocument { get; set; }
Public Property ActiveDocument As IDocument
    Get
    Set

Property Value

Type: IDocument

Return Value

Type: IDocument
IDocument

Implements

IBatchActiveDocument
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.ActiveFolder Property

BatchActiveFolder Property

Gets or sets the currently active folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolder ActiveFolder { get; set; }
Public Property ActiveFolder As IFolder
    Get
    Set

Property Value

Type: IFolder

Return Value

Type: IFolder
IFolder

Implements

IBatchActiveFolder
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.ActiveIndexField Property

BatchActiveIndexField Property

Gets or sets the currently active index field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexField ActiveIndexField { get; set; }
Public Property ActiveIndexField As IIndexField
    Get
    Set

Property Value

Type: IIndexField

Return Value

Type: IIndexField
IIndexField

Implements

IBatchActiveIndexField
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.ActiveLoosePage Property

BatchActiveLoosePage Property

Returns the currently active loose page, if a loose page is selected. Otherwise, returns Nothing.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPage ActiveLoosePage { get; }
Public ReadOnly Property ActiveLoosePage As IPage
    Get

Property Value

Type: IPage

Return Value

Type: IPage
IPage

Implements

IBatchActiveLoosePage
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.ActivePage Property

BatchActivePage Property

Gets or sets the active page (irrespective of it being a loose page or document page).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPage ActivePage { get; set; }
Public Property ActivePage As IPage
    Get
    Set

Property Value

Type: IPage

Return Value

Type: IPage
IPage

Implements

IBatchActivePage
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.AutomaticSeparationAndFormID Property

BatchAutomaticSeparationAndFormID Property

Indicates whether automatic separation and form ID is enabled on the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool AutomaticSeparationAndFormID { get; set; }
Public Property AutomaticSeparationAndFormID As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchAutomaticSeparationAndFormID
Remarks
Only affects import file.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.BatchClass Property

BatchBatchClass Property

Returns the Batch Class of this batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchClass BatchClass { get; }
Public ReadOnly Property BatchClass As IBatchClass
    Get

Property Value

Type: IBatchClass

Return Value

Type: IBatchClass
IBatchClass

Implements

IBatchBatchClass
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.BatchEndorsingNumber Property

BatchBatchEndorsingNumber Property

Gets or sets the endorsing number. This property is used by endorsing scanners and cannot be set during an event. Endorsing must be enabled for the batch class in order to set this property.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int BatchEndorsingNumber { get; set; }
Public Property BatchEndorsingNumber As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchBatchEndorsingNumber
Remarks
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.BatchFields Property

BatchBatchFields Property

Returns a list of batch fields contained in the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchFields BatchFields { get; }
Public ReadOnly Property BatchFields As IBatchFields
    Get

Property Value

Type: IBatchFields

Return Value

Type: IBatchFields
IBatchFields

Implements

IBatchBatchFields
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.BatchGUID Property

BatchBatchGUID Property

Returns the GUID string that represents the unique batch ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string BatchGUID { get; }
Public ReadOnly Property BatchGUID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchBatchGUID
Remarks
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.ClassID Property

BatchClassID Property

Returns the batch class ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ClassID { get; }
Public ReadOnly Property ClassID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchClassID
Remarks
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.ClassName Property

BatchClassName Property

Returns the batch class name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ClassName { get; }
Public ReadOnly Property ClassName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchClassName
Remarks
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.CreateTime Property

BatchCreateTime Property

Returns the date and time the batch was created.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public DateTime CreateTime { get; }
Public ReadOnly Property CreateTime As DateTime
    Get

Property Value

Type: DateTime

Return Value

Type: DateTime
Date

Implements

IBatchCreateTime
Remarks
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.CustomStorageString Property

BatchCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the batch class.

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific batch. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.Description Property

BatchDescription Property

Gets or sets the batch description.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchDescription
Remarks
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.DocumentClasses Property

BatchDocumentClasses Property

Returns the document classes that are supported by the batch as defined by the Tungsten Capture batch class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocumentClasses DocumentClasses { get; }
Public ReadOnly Property DocumentClasses As IDocumentClasses
    Get

Property Value

Type: IDocumentClasses

Return Value

Type: IDocumentClasses
IDocumentClasses

Implements

IBatchDocumentClasses
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.DocumentCount Property

BatchDocumentCount Property

Returns the total document count.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int DocumentCount { get; }
Public ReadOnly Property DocumentCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchDocumentCount
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.Documents Property

BatchDocuments Property

Returns the current set of documents.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocuments Documents { get; }
Public ReadOnly Property Documents As IDocuments
    Get

Property Value

Type: IDocuments

Return Value

Type: IDocuments
IDocuments

Implements

IBatchDocuments
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.DocumentsPerBatch Property

BatchDocumentsPerBatch Property

Gets or sets the number of documents in a batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int DocumentsPerBatch { get; set; }
Public Property DocumentsPerBatch As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchDocumentsPerBatch
Remarks
This property cannot be set during an event.

Valid values are 0 to 99,999.

See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.ExpectedBatchTotals Property

BatchExpectedBatchTotals Property

Returns a list of the expected batch totals contained in the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IExpectedBatchTotals ExpectedBatchTotals { get; }
Public ReadOnly Property ExpectedBatchTotals As IExpectedBatchTotals
    Get

Property Value

Type: IExpectedBatchTotals

Return Value

Type: IExpectedBatchTotals
IExpectedBatchTotals

Implements

IBatchExpectedBatchTotals
Remarks
All expected batch total values must be assigned before the batch is closed.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.ExternalID Property

BatchExternalID Property

Returns the external batch ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ExternalID { get; }
Public ReadOnly Property ExternalID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchExternalID
Remarks
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.FolderClasses Property

BatchFolderClasses Property

Gets the folder classes that are supported by the batch as defined by the Tungsten Capture batch class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolderClasses FolderClasses { get; }
Public ReadOnly Property FolderClasses As IFolderClasses
    Get

Property Value

Type: IFolderClasses

Return Value

Type: IFolderClasses
IFolderClasses

Implements

IBatchFolderClasses
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.FolderCount Property

BatchFolderCount Property

Gets the total folder count of the immediate child folders under the batch (not including indirect child folders of a folder).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int FolderCount { get; }
Public ReadOnly Property FolderCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchFolderCount
Remarks
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.Folders Property

BatchFolders Property

Gets the current set of immediate folders under the batch (not including indirect child folders of a folder).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolders Folders { get; }
Public ReadOnly Property Folders As IFolders
    Get

Property Value

Type: IFolders

Return Value

Type: IFolders
IFolders

Implements

IBatchFolders
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.FormTypes Property

BatchFormTypes Property

Returns the form types that are supported by the batch as defined by the Tungsten Capture batch class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFormTypes FormTypes { get; }
Public ReadOnly Property FormTypes As IFormTypes
    Get

Property Value

Type: IFormTypes

Return Value

Type: IFormTypes
IFormTypes

Implements

IBatchFormTypes
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.LoosePageCount Property

BatchLoosePageCount Property

Returns the current number of loose pages.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int LoosePageCount { get; }
Public ReadOnly Property LoosePageCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchLoosePageCount
Remarks
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.LoosePages Property

BatchLoosePages Property

Returns the current set of loose pages.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPages LoosePages { get; }
Public ReadOnly Property LoosePages As IPages
    Get

Property Value

Type: IPages

Return Value

Type: IPages
IPages

Implements

IBatchLoosePages
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.Name Property

BatchName Property

Returns the batch name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchName
Remarks
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.PagesPerBatch Property

BatchPagesPerBatch Property

Gets or sets the number of pages per batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int PagesPerBatch { get; set; }
Public Property PagesPerBatch As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchPagesPerBatch
Remarks

This property cannot be set during an event.

Valid values are 0 to 99,999.

See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.PagesPerDoc Property

BatchPagesPerDoc Property

Gets or sets PagesPerDoc. Used by scan to create documents.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int PagesPerDoc { get; set; }
Public Property PagesPerDoc As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchPagesPerDoc
Remarks
This property cannot be set during an event.

Valid values are 0 to 99,999.

See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.Priority Property

BatchPriority Property

Gets or sets the batch class priority.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Priority { get; set; }
Public Property Priority As Integer
    Get
    Set

Property Value

Type: Int32
The Priority of the batch.

Return Value

Type: Int32
Integer

Implements

IBatchPriority
Remarks
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.PublishTime Property

BatchPublishTime Property

Returns the date and time the batch class used when the batch was published.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public DateTime PublishTime { get; }
Public ReadOnly Property PublishTime As DateTime
    Get

Property Value

Type: DateTime

Return Value

Type: DateTime
Date

Implements

IBatchPublishTime
Remarks

This is useful for cross-checking externally saved data. When utilizing batch class data, the user should save the batch class publish time.

After creating a batch, the publish time on the batch should be checked against the stored value. If the values are different, then the batch has been republished, and the user's program should re-verify that all settings are still valid.

See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.RowSeparator Property

BatchRowSeparator Property

Returns the legacy table field delimiter.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string RowSeparator { get; }
Public ReadOnly Property RowSeparator As String
    Get

Property Value

Type: String

Return Value

Type: String

Implements

IBatchRowSeparator
Remarks
This is needed for XMLAI.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.SelectedDocuments Property

BatchSelectedDocuments Property
Returns the selected documents

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocuments SelectedDocuments { get; }
Public ReadOnly Property SelectedDocuments As IDocuments
    Get

Return Value

Type: IDocuments
IDocuments

Implements

IBatchSelectedDocuments
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.SelectedFolders Property

BatchSelectedFolders Property
Returns the selected folders

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolders SelectedFolders { get; }
Public ReadOnly Property SelectedFolders As IFolders
    Get

Return Value

Type: IFolders
IFolders

Implements

IBatchSelectedFolders
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.SelectedPages Property

BatchSelectedPages Property
Returns the selected pages

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPages SelectedPages { get; }
Public ReadOnly Property SelectedPages As IPages
    Get

Return Value

Type: IPages
IPages

Implements

IBatchSelectedPages
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.SingleDocProcessing Property

BatchSingleDocProcessing Property

Indicates whether single document processing is activated for the batch class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SingleDocProcessing { get; set; }
Public Property SingleDocProcessing As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchSingleDocProcessing
Remarks
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.SupportsAutomaticSeparationAndFormID Property

BatchSupportsAutomaticSeparationAndFormID Property

Indicates whether automatic separation and form ID can be enabled on the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SupportsAutomaticSeparationAndFormID { get; }
Public ReadOnly Property SupportsAutomaticSeparationAndFormID As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchSupportsAutomaticSeparationAndFormID
Remarks
Returns True if the batch supports auto separation and form ID.
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Batch.SupportsSingleDocProcessing Property

BatchSupportsSingleDocProcessing Property

Indicates whether the batch class supports single document processing.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SupportsSingleDocProcessing { get; }
Public ReadOnly Property SupportsSingleDocProcessing As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchSupportsSingleDocProcessing
Remarks
See Also

Reference

Batch Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges Class

BatchChanges Class

BatchChanges COM implementation class.

Defines information about changes made to a batch in custom modules.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesBatchChanges

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC3B-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class BatchChanges : IBatchChanges,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC3B-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class BatchChanges
    Implements IBatchChanges, IDisposable

The BatchChanges type exposes the following members.

Constructors
 | Name | Description
Public method | BatchChanges | Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.BatchChanges class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DocumentsAdded | Returns a collection of Document objects that have been added to the batch.
Public property | DocumentsDeleted | Returns a collection of Document IDs that have been deleted from the batch. The ID is a property of the Document object.
Public property | DocumentsModified | Returns a collection of Document objects that have been modified.
Public property | FoldersAdded | Returns a collection of Folder objects that have been added to the batch.
Public property | FoldersDeleted | Returns a collection of Folder IDs that have been deleted from the batch. The ID is a property of the Folder object.
Public property | FoldersModified | Returns a collection of Folder objects that have been modified.
Public property | PagesAdded | Returns a collection of Page objects that have been added to the batch.
Public property | PagesDeleted | Returns a collection of Page IDs that have been deleted from the batch. The ID is a property of the Page object.
Public property | PagesModified | Returns a collection of Page objects that have been modified.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges Constructor

BatchChanges Constructor

Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.BatchChanges class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public BatchChanges()
Public Sub New
Remarks
See Also

Reference

BatchChanges Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges Methods

BatchChanges Methods

The BatchChanges type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchChanges Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges.Dispose Method

BatchChangesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

BatchChanges Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges Properties

BatchChanges Properties

The BatchChanges type exposes the following members.

Properties
 | Name | Description
Public property | DocumentsAdded | Returns a collection of Document objects that have been added to the batch.
Public property | DocumentsDeleted | Returns a collection of Document IDs that have been deleted from the batch. The ID is a property of the Document object.
Public property | DocumentsModified | Returns a collection of Document objects that have been modified.
Public property | FoldersAdded | Returns a collection of Folder objects that have been added to the batch.
Public property | FoldersDeleted | Returns a collection of Folder IDs that have been deleted from the batch. The ID is a property of the Folder object.
Public property | FoldersModified | Returns a collection of Folder objects that have been modified.
Public property | PagesAdded | Returns a collection of Page objects that have been added to the batch.
Public property | PagesDeleted | Returns a collection of Page IDs that have been deleted from the batch. The ID is a property of the Page object.
Public property | PagesModified | Returns a collection of Page objects that have been modified.
Top
See Also

Reference

BatchChanges Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges.DocumentsAdded Property

BatchChangesDocumentsAdded Property

Returns a collection of Document objects that have been added to the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocuments DocumentsAdded { get; }
Public ReadOnly Property DocumentsAdded As IDocuments
    Get

Property Value

Type: IDocuments

Return Value

Type: IDocuments
IDocuments

Implements

IBatchChangesDocumentsAdded
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchChanges Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges.DocumentsDeleted Property

BatchChangesDocumentsDeleted Property

Returns a collection of Document IDs that have been deleted from the batch. The ID is a property of the Document object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IObjectIDs DocumentsDeleted { get; }
Public ReadOnly Property DocumentsDeleted As IObjectIDs
    Get

Property Value

Type: IObjectIDs

Return Value

Type: IObjectIDs
IObjectIDs

Implements

IBatchChangesDocumentsDeleted
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchChanges Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges.DocumentsModified Property

BatchChangesDocumentsModified Property

Returns a collection of Document objects that have been modified.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocuments DocumentsModified { get; }
Public ReadOnly Property DocumentsModified As IDocuments
    Get

Property Value

Type: IDocuments

Return Value

Type: IDocuments
IDocuments

Implements

IBatchChangesDocumentsModified
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchChanges Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges.FoldersAdded Property

BatchChangesFoldersAdded Property

Returns a collection of Folder objects that have been added to the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolders FoldersAdded { get; }
Public ReadOnly Property FoldersAdded As IFolders
    Get

Property Value

Type: IFolders

Return Value

Type: IFolders
IFolders

Implements

IBatchChangesFoldersAdded
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchChanges Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges.FoldersDeleted Property

BatchChangesFoldersDeleted Property

Returns a collection of Folder IDs that have been deleted from the batch. The ID is a property of the Folder object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IObjectIDs FoldersDeleted { get; }
Public ReadOnly Property FoldersDeleted As IObjectIDs
    Get

Property Value

Type: IObjectIDs

Return Value

Type: IObjectIDs
IObjectIDs

Implements

IBatchChangesFoldersDeleted
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchChanges Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges.FoldersModified Property

BatchChangesFoldersModified Property

Returns a collection of Folder objects that have been modified.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolders FoldersModified { get; }
Public ReadOnly Property FoldersModified As IFolders
    Get

Property Value

Type: IFolders

Return Value

Type: IFolders
IFolders

Implements

IBatchChangesFoldersModified
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchChanges Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges.PagesAdded Property

BatchChangesPagesAdded Property

Returns a collection of Page objects that have been added to the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPages PagesAdded { get; }
Public ReadOnly Property PagesAdded As IPages
    Get

Property Value

Type: IPages

Return Value

Type: IPages
IPages

Implements

IBatchChangesPagesAdded
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchChanges Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges.PagesDeleted Property

BatchChangesPagesDeleted Property

Returns a collection of Page IDs that have been deleted from the batch. The ID is a property of the Page object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IObjectIDs PagesDeleted { get; }
Public ReadOnly Property PagesDeleted As IObjectIDs
    Get

Property Value

Type: IObjectIDs

Return Value

Type: IObjectIDs
IObjectIDs

Implements

IBatchChangesPagesDeleted
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchChanges Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchChanges.PagesModified Property

BatchChangesPagesModified Property

Returns a collection of Page objects that have been modified.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPages PagesModified { get; }
Public ReadOnly Property PagesModified As IPages
    Get

Property Value

Type: IPages

Return Value

Type: IPages
IPages

Implements

IBatchChangesPagesModified
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchChanges Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClass Class

BatchClass Class

BatchClass COM implementation class.

Defines a COM object that refers to a batch class published by Tungsten Capture.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesBatchClass

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC3D-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class BatchClass : IBatchClass, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC3D-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class BatchClass
    Implements IBatchClass, IDisposable

The BatchClass type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomStorageString | The batch class storage string with the specified name.
Public property | Description | Returns the description of the batch class.
Public property | Name | Returns the unique name of the batch class.
Public property | PublishTime | Returns the date and time the batch class was published.
Public property | XmlFile | Returns the path and filename of the file that contains the entire batch class setup in XML format.
Top
Remarks

A BatchClass object is valid as long as the parent Application object is valid.

Unlike Batch objects, there is no "active" BatchClass object.

The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClass Methods

BatchClass Methods

The BatchClass type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClass.Dispose Method

BatchClassDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

BatchClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClass Properties

BatchClass Properties

The BatchClass type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The batch class storage string with the specified name.
Public property | Description | Returns the description of the batch class.
Public property | Name | Returns the unique name of the batch class.
Public property | PublishTime | Returns the date and time the batch class was published.
Public property | XmlFile | Returns the path and filename of the file that contains the entire batch class setup in XML format.
Top
See Also

Reference

BatchClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClass.CustomStorageString Property

BatchClassCustomStorageString Property

The batch class storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; }
Public ReadOnly Property CustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the batch class. Strings stored by one component can be read by another. If set to an empty string, the storage string is deleted.

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchClassCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific batch class. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

BatchClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClass.Description Property

BatchClassDescription Property

Returns the description of the batch class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchClassDescription
See Also

Reference

BatchClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClass.Name Property

BatchClassName Property

Returns the unique name of the batch class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchClassName
Remarks
See Also

Reference

BatchClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClass.PublishTime Property

BatchClassPublishTime Property

Returns the date and time the batch class was published.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public DateTime PublishTime { get; }
Public ReadOnly Property PublishTime As DateTime
    Get

Property Value

Type: DateTime

Return Value

Type: DateTime
Date

Implements

IBatchClassPublishTime
See Also

Reference

BatchClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClass.XmlFile Property

BatchClassXmlFile Property

Returns the path and filename of the file that contains the entire batch class setup in XML format.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string XmlFile { get; }
Public ReadOnly Property XmlFile As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchClassXmlFile
See Also

Reference

BatchClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClasses Class

BatchClasses Class

BatchClasses COM implementation class.

Defines a COM collection of published batch class objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesBatchClasses

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC3F-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class BatchClasses : IBatchClasses,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC3F-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class BatchClasses
    Implements IBatchClasses, IEnumerable, IDisposable

The BatchClasses type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of batch classes contained in the collection.
Public property | Item | Returns a collection element given a key.
Top
Remarks
A BatchClasses object is valid as long as the parent Application object is valid.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClasses Methods

BatchClasses Methods

The BatchClasses type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClasses.Dispose Method

BatchClassesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

BatchClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClasses.GetEnumerator Method

BatchClassesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IBatchClasses object.

Implements

IBatchClassesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClasses Properties

BatchClasses Properties

The BatchClasses type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of batch classes contained in the collection.
Public property | Item | Returns a collection element given a key.
Top
See Also

Reference

BatchClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClasses.Count Property

BatchClassesCount Property

Returns the number of batch classes contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchClassesCount
Remarks
See Also

Reference

BatchClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchClasses.Item Property

BatchClassesItem Property

Returns a collection element given a key.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchClass this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IBatchClass
    Get

Parameters

vntIndexKey
Type: SystemObject
Index can either be a batch class name or a numeric one-based index into the collection.

Property Value

Type: IBatchClass

Return Value

Type: IBatchClass
IBatchClass

Implements

IBatchClassesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField Class

BatchField Class

BatchField COM implementation class.

Defines a COM object that contains a value associated with a batch.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesBatchField

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC41-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class BatchField : IBatchField, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC41-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class BatchField
    Implements IBatchField, IDisposable

The BatchField type exposes the following members.

Constructors
 | Name | Description
Public method | BatchField | Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.BatchField class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DefaultValue | Returns the default value for the batch field.
Public property | Description | Gets the description of the associated field type.
Public property | DisplayLabel | Gets or sets the value of a supported batch field display label.
Public property | Hidden | Returns True if the field is not displayed.
Public property | Length | Gets the length of a non-numeric batch field.
Public property | Name | Returns the name of the batch field.
Public property | Numeric | Returns True if the field is numeric.
Public property | NumericPrecision | Returns the number of decimal places of a numeric batch field.
Public property | NumericScale | Returns the number of digits, including decimals, of a numeric batch field.
Public property | OrderNumber | Gets the order of the field within the set of batch fields.
Public property | Required | Returns True if the field is required.
Public property | SqlType | Returns the data type of the batch field.
Public property | SuggestedValueCount | Returns the number of suggested values.
Public property | SuggestedValues | Returns the list of suggested values.
Public property | SuggestedValuesForceMatch | Gets or sets the Suggested Values Force Match flag. If True, the value must be one of the suggested values or an error will occur when the batch is closed.
Public property | SuggestedValuesForceMatchCaseSensitive | Gets or sets the Suggested Values Force Match Case Sensitive flag. If True, a force-matched value must match with regard to upper and lower case.
Public property | TypeCustomStorageString | The storage string with the specified name.
Public property | TypeName | Gets the name of the Tungsten Capture field type that is associated with the batch field.
Public property | UserChanged | Marks the field as changed by the user.
Public property | Value | Gets or sets the value of the batch field. By default, contains batch field default value if it exists, otherwise, it is empty.
Top
Remarks
A BatchField object is valid as long as the parent batch is open.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField Constructor

BatchField Constructor

Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.BatchField class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public BatchField()
Public Sub New
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField Methods

BatchField Methods

The BatchField type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.Dispose Method

BatchFieldDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField Properties

BatchField Properties

The BatchField type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Returns the default value for the batch field.
Public property | Description | Gets the description of the associated field type.
Public property | DisplayLabel | Gets or sets the value of a supported batch field display label.
Public property | Hidden | Returns True if the field is not displayed.
Public property | Length | Gets the length of a non-numeric batch field.
Public property | Name | Returns the name of the batch field.
Public property | Numeric | Returns True if the field is numeric.
Public property | NumericPrecision | Returns the number of decimal places of a numeric batch field.
Public property | NumericScale | Returns the number of digits, including decimals, of a numeric batch field.
Public property | OrderNumber | Gets the order of the field within the set of batch fields.
Public property | Required | Returns True if the field is required.
Public property | SqlType | Returns the data type of the batch field.
Public property | SuggestedValueCount | Returns the number of suggested values.
Public property | SuggestedValues | Returns the list of suggested values.
Public property | SuggestedValuesForceMatch | Gets or sets the Suggested Values Force Match flag. If True, the value must be one of the suggested values or an error will occur when the batch is closed.
Public property | SuggestedValuesForceMatchCaseSensitive | Gets or sets the Suggested Values Force Match Case Sensitive flag. If True, a force-matched value must match with regard to upper and lower case.
Public property | TypeCustomStorageString | The storage string with the specified name.
Public property | TypeName | Gets the name of the Tungsten Capture field type that is associated with the batch field.
Public property | UserChanged | Marks the field as changed by the user.
Public property | Value | Gets or sets the value of the batch field. By default, contains batch field default value if it exists, otherwise, it is empty.
Top
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.DefaultValue Property

BatchFieldDefaultValue Property

Returns the default value for the batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string DefaultValue { get; }
Public ReadOnly Property DefaultValue As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchFieldDefaultValue
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.Description Property

BatchFieldDescription Property

Gets the description of the associated field type.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchFieldDescription
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.DisplayLabel Property

BatchFieldDisplayLabel Property

Gets or sets the value of a supported batch field display label.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string DisplayLabel { get; }
Public ReadOnly Property DisplayLabel As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchFieldDisplayLabel
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.Hidden Property

BatchFieldHidden Property

Returns True if the field is not displayed.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Hidden { get; }
Public ReadOnly Property Hidden As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchFieldHidden
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.Length Property

BatchFieldLength Property

Gets the length of a non-numeric batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchFieldLength
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.Name Property

BatchFieldName Property

Returns the name of the batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchFieldName
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.Numeric Property

BatchFieldNumeric Property

Returns True if the field is numeric.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Numeric { get; }
Public ReadOnly Property Numeric As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchFieldNumeric
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.NumericPrecision Property

BatchFieldNumericPrecision Property

Returns the number of decimal places of a numeric batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int NumericPrecision { get; }
Public ReadOnly Property NumericPrecision As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchFieldNumericPrecision
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.NumericScale Property

BatchFieldNumericScale Property

Returns the number of digits, including decimals, of a numeric batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int NumericScale { get; }
Public ReadOnly Property NumericScale As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchFieldNumericScale
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.OrderNumber Property

BatchFieldOrderNumber Property

Gets the order of the field within the set of batch fields.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int OrderNumber { get; }
Public ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchFieldOrderNumber
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.Required Property

BatchFieldRequired Property

Returns True if the field is required.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Required { get; }
Public ReadOnly Property Required As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchFieldRequired
Remarks
If True, and the value is empty, an error occurs.
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.SqlType Property

BatchFieldSqlType Property

Returns the data type of the batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int SqlType { get; }
Public ReadOnly Property SqlType As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchFieldSqlType
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.SuggestedValueCount Property

BatchFieldSuggestedValueCount Property

Returns the number of suggested values.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int SuggestedValueCount { get; }
Public ReadOnly Property SuggestedValueCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchFieldSuggestedValueCount
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.SuggestedValues Property

BatchFieldSuggestedValues Property

Returns the list of suggested values.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ISuggestedValues SuggestedValues { get; }
Public ReadOnly Property SuggestedValues As ISuggestedValues
    Get

Property Value

Type: ISuggestedValues

Return Value

Type: ISuggestedValues
ISuggestedValues

Implements

IBatchFieldSuggestedValues
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.SuggestedValuesForceMatch Property

BatchFieldSuggestedValuesForceMatch Property

Gets or sets the Suggested Values Force Match flag. If True, the value must be one of the suggested values or an error will occur when the batch is closed.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SuggestedValuesForceMatch { get; set; }
Public Property SuggestedValuesForceMatch As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchFieldSuggestedValuesForceMatch
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.SuggestedValuesForceMatchCaseSensitive Property

BatchFieldSuggestedValuesForceMatchCaseSensitive Property

Gets or sets the Suggested Values Force Match Case Sensitive flag. If True, a force-matched value must match with regard to upper and lower case.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SuggestedValuesForceMatchCaseSensitive { get; }
Public ReadOnly Property SuggestedValuesForceMatchCaseSensitive As Boolean
    Get

Return Value

Type: Boolean
Boolean

Implements

IBatchFieldSuggestedValuesForceMatchCaseSensitive
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.TypeCustomStorageString Property

BatchFieldTypeCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; }
Public ReadOnly Property TypeCustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString

The storage string name does not need to match the name of the batch class.

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchFieldTypeCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific field type. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.TypeName Property

BatchFieldTypeName Property

Gets the name of the Tungsten Capture field type that is associated with the batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchFieldTypeName
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.UserChanged Property

BatchFieldUserChanged Property
Marks the field as changed by the user.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool UserChanged { get; set; }
Public Property UserChanged As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean

Implements

IBatchFieldUserChanged
Remarks
See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchField.Value Property

BatchFieldValue Property

Gets or sets the value of the batch field. By default, contains batch field default value if it exists, otherwise, it is empty.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchFieldValue
Remarks

Batch field values are checked for validity when the value is set. The validity check follows the same rules as if the user was typing the value into the batch properties dialog.

Errors:

KfxApiErrBadParameterRange invalid value (write only).

See Also

Reference

BatchField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchFields Class

BatchFields Class

BatchFields COM implementation class.

Defines a COM collection of BatchField objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesBatchFields

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC43-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class BatchFields : IBatchFields,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC43-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class BatchFields
    Implements IBatchFields, IEnumerable, IDisposable

The BatchFields type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of BatchField objects contained in the collection.
Public property | Item | Returns a collection element given a key.
Top
Remarks
A BatchFields object is valid as long as the parent batch is open.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


BatchFields Methods

BatchFields Methods

The BatchFields type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchFields Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchFields.Dispose Method

BatchFieldsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

BatchFields Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchFields.GetEnumerator Method

BatchFieldsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IBatchFields object.

Implements

IBatchFieldsGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchFields Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchFields Properties

BatchFields Properties

The BatchFields type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of BatchField objects contained in the collection.
Public property | Item | Returns a collection element given a key.
Top
See Also

Reference

BatchFields Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchFields.Count Property

BatchFieldsCount Property

Returns the number of BatchField objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchFieldsCount
Remarks
See Also

Reference

BatchFields Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchFields.Item Property

BatchFieldsItem Property

Returns a collection element given a key.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchField this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IBatchField
    Get

Parameters

vntIndexKey
Type: SystemObject
Index can either be a form type name or a numeric one-based index into the collection.

Property Value

Type: IBatchField

Return Value

Type: IBatchField
IBatchField

Implements

IBatchFieldsItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchFields Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchNameCreator Class

BatchNameCreator Class

BatchNameCreator COM implementation class.

Defines a COM object that allows an OCX to generate its own batch name.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesBatchNameCreator

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC45-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class BatchNameCreator : IBatchNameCreator,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC45-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class BatchNameCreator
    Implements IBatchNameCreator, IDisposable

The BatchNameCreator type exposes the following members.

Constructors
 | Name | Description
Public method | BatchNameCreator | Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.BatchNameCreator class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BatchClass | Returns the batch class associated with the batch being created.
Public property | BatchName | Gets or sets the batch name initially generated by Tungsten Capture. This property can also be used to set the name of the batch being created.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


BatchNameCreator Constructor

BatchNameCreator Constructor

Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.BatchNameCreator class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public BatchNameCreator()
Public Sub New
Remarks
See Also

Reference

BatchNameCreator Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchNameCreator Methods

BatchNameCreator Methods

The BatchNameCreator type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchNameCreator Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchNameCreator.Dispose Method

BatchNameCreatorDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

BatchNameCreator Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchNameCreator Properties

BatchNameCreator Properties

The BatchNameCreator type exposes the following members.

Properties
 | Name | Description
Public property | BatchClass | Returns the batch class associated with the batch being created.
Public property | BatchName | Gets or sets the batch name initially generated by Tungsten Capture. This property can also be used to set the name of the batch being created.
Top
See Also

Reference

BatchNameCreator Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchNameCreator.BatchClass Property

BatchNameCreatorBatchClass Property

Returns the batch class associated with the batch being created.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchClass BatchClass { get; }
Public ReadOnly Property BatchClass As IBatchClass
    Get

Property Value

Type: IBatchClass

Return Value

Type: IBatchClass
IBatchClass

Implements

IBatchNameCreatorBatchClass
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

BatchNameCreator Class
Kofax.Capture.CaptureModule.InteropServices Namespace


BatchNameCreator.BatchName Property

BatchNameCreatorBatchName Property

Gets or sets the batch name initially generated by Tungsten Capture. This property can also be used to set the name of the batch being created.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string BatchName { get; set; }
Public Property BatchName As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchNameCreatorBatchName
Remarks
See Also

Reference

BatchNameCreator Class
Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperties Class

CustomProperties Class

CustomProperties COM implementation class.

Defines a COM collection of CustomProperty objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesCustomProperties

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC47-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class CustomProperties : ICustomProperties,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC47-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class CustomProperties
    Implements ICustomProperties, IEnumerable, IDisposable

The CustomProperties type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of CustomProperties objects contained in the collection.
Public property | Item | Returns the CustomProperties object by order number or assignment name.
Top
Remarks
Iteration and extraction by order number or property name (with the item function) are supported. Passing an out-of-range, or invalid, parameter to the item function causes it to throw the error "Invalid Parameter" to the caller.

A CustomProperties object is invalidated when a content change event occurs.

The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperties Methods

CustomProperties Methods

The CustomProperties type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CustomProperties Class
Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperties.Dispose Method

CustomPropertiesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

CustomProperties Class
Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperties.GetEnumerator Method

CustomPropertiesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.ICustomProperties object.

Implements

ICustomPropertiesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

CustomProperties Class
Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperties Properties

CustomProperties Properties

The CustomProperties type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of CustomProperties objects contained in the collection.
Public property | Item | Returns the CustomProperties object by order number or assignment name.
Top
See Also

Reference

CustomProperties Class
Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperties.Count Property

CustomPropertiesCount Property

Returns the number of CustomProperties objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ICustomPropertiesCount
Remarks
See Also

Reference

CustomProperties Class
Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperties.Item Property

CustomPropertiesItem Property

Returns the CustomProperties object by order number or assignment name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ICustomProperty this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As ICustomProperty
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: ICustomProperty

Return Value

Type: ICustomProperty
ICustomProperty

Implements

ICustomPropertiesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

CustomProperties Class
Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperty Class

CustomProperty Class

CustomProperty COM implementation class.

Defines information about custom properties.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesCustomProperty

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC49-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class CustomProperty : ICustomProperty,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC49-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class CustomProperty
    Implements ICustomProperty, IDisposable

The CustomProperty type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Returns the name of the custom property entry.
Public property | OrderNumber | Returns the order number of the property.
Public property | Value | Gets or sets the custom property value.
Top
Remarks
CustomProperty object is invalidated when a content change event occurs.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperty Methods

CustomProperty Methods

The CustomProperty type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CustomProperty Class
Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperty.Dispose Method

CustomPropertyDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

CustomProperty Class
Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperty Properties

CustomProperty Properties

The CustomProperty type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the custom property entry.
Public property | OrderNumber | Returns the order number of the property.
Public property | Value | Gets or sets the custom property value.
Top
See Also

Reference

CustomProperty Class
Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperty.Name Property

CustomPropertyName Property

Returns the name of the custom property entry.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

ICustomPropertyName
Remarks
See Also

Reference

CustomProperty Class
Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperty.OrderNumber Property

CustomPropertyOrderNumber Property

Returns the order number of the property.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int OrderNumber { get; }
Public ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ICustomPropertyOrderNumber
Remarks
See Also

Reference

CustomProperty Class
Kofax.Capture.CaptureModule.InteropServices Namespace


CustomProperty.Value Property

CustomPropertyValue Property

Gets or sets the custom property value.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String
The custom property value.

Return Value

Type: String
String

Implements

ICustomPropertyValue
Remarks
This property can be up to 65,536 characters.
See Also

Reference

CustomProperty Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document Class

Document Class

Document COM implementation class.

Defines information about the currently opened document.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesDocument

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC4B-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Document : IDocument, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC4B-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Document
    Implements IDocument, IDisposable

The Document type exposes the following members.

Constructors
 | Name | Description
Public method | Document | Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.Document class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | MoveToBatch | Moves this document to a batch.
Public method | MoveToFolder | Moves this document to a folder.
Public method | RunValidationPlugin | Executes a validation plug-in, such as database validation.
Public method | ToString | (Inherited from Object.)
Public method | UpdateCustomStorageStrings |
Top
Properties
 | Name | Description
Public property | ActiveIndexField | Returns the currently active index field in the document.
Public property | ActivePage | Returns the currently active page in the document.
Public property | AsnReleaseScripts | Gets the list of assigned export connectors.
Public property | AutoIndexed | True sets a document as auto-indexed. The document is skipped while auto-indexing the Recognition Server.
Public property | Batch | Returns the parent batch in which the document resides.
Public property | BatchDocGUID | Returns the Document unique ID.
Public property | Caption | Gets or sets the document label. This value is displayed in the tree view.
Public property | ClassID | Returns the document class ID.
Public property | ClassName | Returns the document class name.
Public property | CustomProperties | Returns the custom property collection for the document class.
Public property | CustomPropertyCount | Returns the number of custom properties for the document class.
Public property | CustomStorageString | The document storage string with the specified name.
Public property | Folder | Returns the parent folder in which the document resides. Nothing is returned if the document is the direct child of a batch.
Public property | FormIDConfidence | Gets the form identification confidence. This is filled in by the Recognition Server if automatic form identification is enabled.
Public property | FormIDDifference | Gets the difference between the form identification confidence and the confidence of the next best match. This is filled in by the Recognition Server if automatic form identification is enabled.
Public property | FormName | Returns the document form type name.
Public property | FormType | Gets or sets the document form type. Set this property to Nothing to assign no form type to a document.
Public property | ID | Returns the internal Document ID set by the data source (internal database).
Public property | IndexFieldCount | Returns the number of index fields in the document.
Public property | IndexFields | Returns the collection of index fields in the document.
Public property | Note | Gets or sets the document note.
Public property | OrderNumber | The document order number within the batch (if the current document is a direct child of a batch) or folder (if the parent is a folder).
Public property | PageCount | Returns the number of pages in the document.
Public property | Pages | Returns the collection of pages in the document.
Public property | Rejected | Gets or sets the document rejected flag.
Public property | Tables | Returns a collection of Table objects, corresponding to the tables in this document.
Public property | UniqueID | Returns the document unique ID. This ID is unique across all batches.
Public property | Validated | Gets or sets the document validated flag. True sets a document as validated. This document is skipped in the Validation module.
Public property | Verified | Gets or sets the document verified flag. True sets a document as verified. This document is skipped in the Verification module.
Top
Remarks

A document object is valid until a content change event occurs or a batch is closed.

Index field properties are available from any supported application on any document, if the document has a form type. If index field updates are done in Validation or Verification on the active document, and data entry mode is active, then the updates are performed on the data entry panel. This causes an SBL (deprecated) or .NET script validation to occur. Otherwise, any field updates change the database directly without SBL (deprecated) or .NET script validation.

See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


Document Constructor

Document Constructor

Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.Document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Document()
Public Sub New
Remarks
Public constructor for initialize in COM client
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document Methods

Document Methods

The Document type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | MoveToBatch | Moves this document to a batch.
Public method | MoveToFolder | Moves this document to a folder.
Public method | RunValidationPlugin | Executes a validation plug-in, such as database validation.
Public method | ToString | (Inherited from Object.)
Public method | UpdateCustomStorageStrings |
Top
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.Dispose Method

DocumentDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.MoveToBatch Method

DocumentMoveToBatch Method

Moves this document to a batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void MoveToBatch(
    ref IDocument oNextDocument = null
)
Public Sub MoveToBatch (
    Optional ByRef oNextDocument As IDocument = Nothing
)

Parameters

oNextDocument (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
The moved document will be inserted before the document specified by this parameter. The document will be moved to the end of the batch (before folders) if this parameter is not specified.

Implements

IDocumentMoveToBatch(IDocument)
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.MoveToFolder Method

DocumentMoveToFolder Method

Moves this document to a folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void MoveToFolder(
    ref IFolder oFolder,
    ref IDocument oNextDocument = null
)
Public Sub MoveToFolder (
    ByRef oFolder As IFolder,
    Optional ByRef oNextDocument As IDocument = Nothing
)

Parameters

oFolder
Type: Kofax.Capture.CaptureModule.InteropServicesIFolder
The parent folder.
oNextDocument (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
The moved document will be inserted before the document specified by this parameter. The document will be moved to the end of the document list if this parameter is not specified.

Implements

IDocumentMoveToFolder(IFolder, IDocument)
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.RunValidationPlugin Method

DocumentRunValidationPlugin Method

Executes a validation plug-in, such as database validation.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string RunValidationPlugin(
    string strName,
    string strParam = ""
)
Public Function RunValidationPlugin (
    strName As String,
    Optional strParam As String = ""
) As String

Parameters

strName
Type: SystemString
Specify the name of the plug-in to execute.
strParam (Optional)
Type: SystemString
Reserved.

Return Value

Type: String
String - The results are defined by the plug-in. For a database validation, the results are an XML string representing the record set returned by the validation.

Implements

IDocumentRunValidationPlugin(String, String)
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.UpdateCustomStorageStrings Method

DocumentUpdateCustomStorageStrings Method

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void UpdateCustomStorageStrings(
    IBulkUpdateDataColl oData
)
Public Sub UpdateCustomStorageStrings (
    oData As IBulkUpdateDataColl
)

Parameters

oData
Type: Kofax.Capture.SDK.DataIBulkUpdateDataColl

Implements

IDocumentUpdateCustomStorageStrings(IBulkUpdateDataColl)
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document Properties

Document Properties

The Document type exposes the following members.

Properties
 | Name | Description
Public property | ActiveIndexField | Returns the currently active index field in the document.
Public property | ActivePage | Returns the currently active page in the document.
Public property | AsnReleaseScripts | Gets the list of assigned export connectors.
Public property | AutoIndexed | True sets a document as auto-indexed. The document is skipped while auto-indexing the Recognition Server.
Public property | Batch | Returns the parent batch in which the document resides.
Public property | BatchDocGUID | Returns the Document unique ID.
Public property | Caption | Gets or sets the document label. This value is displayed in the tree view.
Public property | ClassID | Returns the document class ID.
Public property | ClassName | Returns the document class name.
Public property | CustomProperties | Returns the custom property collection for the document class.
Public property | CustomPropertyCount | Returns the number of custom properties for the document class.
Public property | CustomStorageString | The document storage string with the specified name.
Public property | Folder | Returns the parent folder in which the document resides. Nothing is returned if the document is the direct child of a batch.
Public property | FormIDConfidence | Gets the form identification confidence. This is filled in by the Recognition Server if automatic form identification is enabled.
Public property | FormIDDifference | Gets the difference between the form identification confidence and the confidence of the next best match. This is filled in by the Recognition Server if automatic form identification is enabled.
Public property | FormName | Returns the document form type name.
Public property | FormType | Gets or sets the document form type. Set this property to Nothing to assign no form type to a document.
Public property | ID | Returns the internal Document ID set by the data source (internal database).
Public property | IndexFieldCount | Returns the number of index fields in the document.
Public property | IndexFields | Returns the collection of index fields in the document.
Public property | Note | Gets or sets the document note.
Public property | OrderNumber | The document order number within the batch (if the current document is a direct child of a batch) or folder (if the parent is a folder).
Public property | PageCount | Returns the number of pages in the document.
Public property | Pages | Returns the collection of pages in the document.
Public property | Rejected | Gets or sets the document rejected flag.
Public property | Tables | Returns a collection of Table objects, corresponding to the tables in this document.
Public property | UniqueID | Returns the document unique ID. This ID is unique across all batches.
Public property | Validated | Gets or sets the document validated flag. True sets a document as validated. This document is skipped in the Validation module.
Public property | Verified | Gets or sets the document verified flag. True sets a document as verified. This document is skipped in the Verification module.
Top
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.ActiveIndexField Property

DocumentActiveIndexField Property

Returns the currently active index field in the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexField ActiveIndexField { get; }
Public ReadOnly Property ActiveIndexField As IIndexField
    Get

Property Value

Type: IIndexField

Return Value

Type: IIndexField
IIndexField

Implements

IDocumentActiveIndexField
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.ActivePage Property

DocumentActivePage Property

Returns the currently active page in the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPage ActivePage { get; }
Public ReadOnly Property ActivePage As IPage
    Get

Property Value

Type: IPage

Return Value

Type: IPage
IPage

Implements

IDocumentActivePage
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.AsnReleaseScripts Property

DocumentAsnReleaseScripts Property

Gets the list of assigned export connectors.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IAsnReleaseScripts AsnReleaseScripts { get; }
Public ReadOnly Property AsnReleaseScripts As IAsnReleaseScripts
    Get

Property Value

Type: IAsnReleaseScripts

Return Value

Type: IAsnReleaseScripts
IAsnReleaseScripts

Implements

IDocumentAsnReleaseScripts
Remarks
Use this collection to get the custom properties.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.AutoIndexed Property

DocumentAutoIndexed Property

True sets a document as auto-indexed. The document is skipped while auto-indexing the Recognition Server.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool AutoIndexed { get; set; }
Public Property AutoIndexed As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IDocumentAutoIndexed
Remarks

False clears the auto-indexed state.

This property is somewhat slower than Verified or Validated.

See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.Batch Property

DocumentBatch Property

Returns the parent batch in which the document resides.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch Batch { get; }
Public ReadOnly Property Batch As IBatch
    Get

Property Value

Type: IBatch

Return Value

Type: IBatch
IBatch

Implements

IDocumentBatch
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.BatchDocGUID Property

DocumentBatchDocGUID Property

Returns the Document unique ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string BatchDocGUID { get; }
Public ReadOnly Property BatchDocGUID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IDocumentBatchDocGUID
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.Caption Property

DocumentCaption Property

Gets or sets the document label. This value is displayed in the tree view.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Caption { get; set; }
Public Property Caption As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String

Implements

IDocumentCaption
Remarks
The default value is the form type name.
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.ClassID Property

DocumentClassID Property

Returns the document class ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ClassID { get; }
Public ReadOnly Property ClassID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IDocumentClassID
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.ClassName Property

DocumentClassName Property

Returns the document class name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ClassName { get; }
Public ReadOnly Property ClassName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IDocumentClassName
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.CustomProperties Property

DocumentCustomProperties Property

Returns the custom property collection for the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ICustomProperties CustomProperties { get; }
Public ReadOnly Property CustomProperties As ICustomProperties
    Get

Property Value

Type: ICustomProperties

Return Value

Type: ICustomProperties
ICustomProperties

Implements

IDocumentCustomProperties
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.CustomPropertyCount Property

DocumentCustomPropertyCount Property

Returns the number of custom properties for the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int CustomPropertyCount { get; }
Public ReadOnly Property CustomPropertyCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IDocumentCustomPropertyCount
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.CustomStorageString Property

DocumentCustomStorageString Property

The document storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the document. Strings stored by one component can be read by another. If set to an empty string, the storage string is deleted.

Property Value

Type: String

Return Value

Type: String
String

Implements

IDocumentCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific document. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.Folder Property

DocumentFolder Property

Returns the parent folder in which the document resides. Nothing is returned if the document is the direct child of a batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolder Folder { get; }
Public ReadOnly Property Folder As IFolder
    Get

Property Value

Type: IFolder

Return Value

Type: IFolder
IFolder

Implements

IDocumentFolder
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.FormIDConfidence Property

DocumentFormIDConfidence Property

Gets the form identification confidence. This is filled in by the Recognition Server if automatic form identification is enabled.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int FormIDConfidence { get; }
Public ReadOnly Property FormIDConfidence As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IDocumentFormIDConfidence
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.FormIDDifference Property

DocumentFormIDDifference Property

Gets the difference between the form identification confidence and the confidence of the next best match. This is filled in by the Recognition Server if automatic form identification is enabled.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int FormIDDifference { get; }
Public ReadOnly Property FormIDDifference As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IDocumentFormIDDifference
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.FormName Property

DocumentFormName Property

Returns the document form type name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string FormName { get; }
Public ReadOnly Property FormName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IDocumentFormName
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.FormType Property

DocumentFormType Property

Gets or sets the document form type. Set this property to Nothing to assign no form type to a document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFormType FormType { get; set; }
Public Property FormType As IFormType
    Get
    Set

Property Value

Type: IFormType

Return Value

Type: IFormType
IFormType

Implements

IDocumentFormType
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.ID Property

DocumentID Property

Returns the internal Document ID set by the data source (internal database).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ID { get; }
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IDocumentID
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.IndexFieldCount Property

DocumentIndexFieldCount Property

Returns the number of index fields in the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int IndexFieldCount { get; }
Public ReadOnly Property IndexFieldCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IDocumentIndexFieldCount
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.IndexFields Property

DocumentIndexFields Property

Returns the collection of index fields in the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexFields IndexFields { get; }
Public ReadOnly Property IndexFields As IIndexFields
    Get

Property Value

Type: IIndexFields

Return Value

Type: IIndexFields
IIndexFields

Implements

IDocumentIndexFields
Remarks

Returns the list of IndexField objects for this document. This list includes single-value fields and table fields, in the order specified in the document class properties. Note that while table fields are included in this collection, tables themselves are not.

The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.Note Property

DocumentNote Property

Gets or sets the document note.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Note { get; set; }
Public Property Note As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IDocumentNote
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.OrderNumber Property

DocumentOrderNumber Property

The document order number within the batch (if the current document is a direct child of a batch) or folder (if the parent is a folder).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int OrderNumber { get; }
Public ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IDocumentOrderNumber
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.PageCount Property

DocumentPageCount Property

Returns the number of pages in the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int PageCount { get; }
Public ReadOnly Property PageCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IDocumentPageCount
Remarks
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.Pages Property

DocumentPages Property

Returns the collection of pages in the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPages Pages { get; }
Public ReadOnly Property Pages As IPages
    Get

Property Value

Type: IPages

Return Value

Type: IPages
IPages

Implements

IDocumentPages
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.Rejected Property

DocumentRejected Property

Gets or sets the document rejected flag.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Rejected { get; set; }
Public Property Rejected As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean

Implements

IDocumentRejected
Remarks
Returns True if the document is rejected.
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.Tables Property

DocumentTables Property

Returns a collection of Table objects, corresponding to the tables in this document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ITables Tables { get; }
Public ReadOnly Property Tables As ITables
    Get

Property Value

Type: ITables

Return Value

Type: ITables
ITables

Implements

IDocumentTables
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.UniqueID Property

DocumentUniqueID Property

Returns the document unique ID. This ID is unique across all batches.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int UniqueID { get; }
Public ReadOnly Property UniqueID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IDocumentUniqueID
See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.Validated Property

DocumentValidated Property

Gets or sets the document validated flag. True sets a document as validated. This document is skipped in the Validation module.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Validated { get; set; }
Public Property Validated As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IDocumentValidated
Remarks

False clears the validated state. The document is not skipped in the Validation module.

Clearing this flag does not cause the associated fields to be reprocessed in the Recognition Server.

See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Document.Verified Property

DocumentVerified Property

Gets or sets the document verified flag. True sets a document as verified. This document is skipped in the Verification module.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Verified { get; set; }
Public Property Verified As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IDocumentVerified
Remarks

False clears the verified state. The document is not skipped in the Validation module.

Clearing this flag does not cause the associated fields to be reprocessed in the Recognition Server.

See Also

Reference

Document Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClass Class

DocumentClass Class

DocumentClass COM implementation class.

Defines a COM object that refers to a Tungsten Capture document class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesDocumentClass

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC4D-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class DocumentClass : IDocumentClass,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC4D-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class DocumentClass
    Implements IDocumentClass, IDisposable

The DocumentClass type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name for the document class.
Public property | Description | Gets the description of the document class.
Public property | FormTypes | Gets the form types that are supported by the document class.
Public property | Name | Gets the unique name of the document class.
Public property | TableDefinitions | Returns a collection of TableDefinition objects, corresponding to the tables defined in this document class.
Top
Remarks
A DocumentClass object is valid as long as its parent batch is open.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClass Methods

DocumentClass Methods

The DocumentClass type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DocumentClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClass.Dispose Method

DocumentClassDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

DocumentClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClass Properties

DocumentClass Properties

The DocumentClass type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name for the document class.
Public property | Description | Gets the description of the document class.
Public property | FormTypes | Gets the form types that are supported by the document class.
Public property | Name | Gets the unique name of the document class.
Public property | TableDefinitions | Returns a collection of TableDefinition objects, corresponding to the tables defined in this document class.
Top
See Also

Reference

DocumentClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClass.CustomStorageString Property

DocumentClassCustomStorageString Property

The storage string with the specified name for the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; }
Public ReadOnly Property CustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the document class.

Property Value

Type: String

Return Value

Type: String
String

Implements

IDocumentClassCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific document class. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

DocumentClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClass.Description Property

DocumentClassDescription Property

Gets the description of the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IDocumentClassDescription
Remarks
See Also

Reference

DocumentClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClass.FormTypes Property

DocumentClassFormTypes Property

Gets the form types that are supported by the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFormTypes FormTypes { get; }
Public ReadOnly Property FormTypes As IFormTypes
    Get

Property Value

Type: IFormTypes

Return Value

Type: IFormTypes
IFormTypes

Implements

IDocumentClassFormTypes
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

DocumentClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClass.Name Property

DocumentClassName Property

Gets the unique name of the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IDocumentClassName
Remarks
See Also

Reference

DocumentClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClass.TableDefinitions Property

DocumentClassTableDefinitions Property

Returns a collection of TableDefinition objects, corresponding to the tables defined in this document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ITableDefinitions TableDefinitions { get; }
Public ReadOnly Property TableDefinitions As ITableDefinitions
    Get

Property Value

Type: ITableDefinitions

Return Value

Type: ITableDefinitions
ITableDefinitions

Implements

IDocumentClassTableDefinitions
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

DocumentClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClasses Class

DocumentClasses Class

DocumentClasses COM implementation class.

Defines a COM collection of DocumentClass objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesDocumentClasses

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC4F-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class DocumentClasses : IDocumentClasses,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC4F-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class DocumentClasses
    Implements IDocumentClasses, IEnumerable, IDisposable

The DocumentClasses type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of DocumentClass objects contained in the collection.
Public property | Item | Returns the specified DocumentClass object.
Top
Remarks
A DocumentClasses object is valid as long as its parent batch is open.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClasses Methods

DocumentClasses Methods

The DocumentClasses type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

DocumentClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClasses.Dispose Method

DocumentClassesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

DocumentClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClasses.GetEnumerator Method

DocumentClassesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IDocumentClasses object.

Implements

IDocumentClassesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

DocumentClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClasses Properties

DocumentClasses Properties

The DocumentClasses type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of DocumentClass objects contained in the collection.
Public property | Item | Returns the specified DocumentClass object.
Top
See Also

Reference

DocumentClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClasses.Count Property

DocumentClassesCount Property

Returns the number of DocumentClass objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IDocumentClassesCount
Remarks
See Also

Reference

DocumentClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


DocumentClasses.Item Property

DocumentClassesItem Property

Returns the specified DocumentClass object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocumentClass this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IDocumentClass
    Get

Parameters

vntIndexKey
Type: SystemObject
Index can either be a document class name or a numeric one-based index into the collection.

Property Value

Type: IDocumentClass

Return Value

Type: IDocumentClass
IDocumentClass

Implements

IDocumentClassesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

DocumentClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Documents Class

Documents Class

Documents COM implementation class.

Defines a COM collection of Document objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesDocuments

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC51-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Documents : IDocuments, IEnumerable,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC51-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Documents
    Implements IDocuments, IEnumerable, IDisposable

The Documents type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of Document objects contained in the collection.
Public property | Item | Returns the specified Document object.
Top
Remarks

Iteration and extraction by order number (with the item function) is supported. Passing an out-of-range or invalid parameter to the item function causes it to throw the error "Invalid Parameter" to the caller.

The Documents's object is invalidated when the current batch is closed.

The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


Documents Methods

Documents Methods

The Documents type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Documents Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Documents.Dispose Method

DocumentsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Documents Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Documents.GetEnumerator Method

DocumentsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IDocuments object.

Implements

IDocumentsGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Documents Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Documents Properties

Documents Properties

The Documents type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of Document objects contained in the collection.
Public property | Item | Returns the specified Document object.
Top
See Also

Reference

Documents Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Documents.Count Property

DocumentsCount Property

Returns the number of Document objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IDocumentsCount
Remarks
See Also

Reference

Documents Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Documents.Item Property

DocumentsItem Property

Returns the specified Document object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocument this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IDocument
    Get

Parameters

vntIndexKey
Type: SystemObject
Index must be a numeric one-based index into the collection.

Property Value

Type: IDocument

Return Value

Type: IDocument
IDocument

Implements

IDocumentsItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Documents Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal Class

ExpectedBatchTotal Class

ExpectedBatchTotal COM implementation class.

Defines a COM object that contains the sum of a certain document index fields.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesExpectedBatchTotal

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC53-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class ExpectedBatchTotal : IExpectedBatchTotal,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC53-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class ExpectedBatchTotal
    Implements IExpectedBatchTotal, IDisposable

The ExpectedBatchTotal type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Description | Returns the field type description.
Public property | Length | Returns the length of the field.
Public property | Name | Returns the name of the expected batch total.
Public property | Numeric | Returns True if the field type is numeric.
Public property | NumericPrecision | Returns the number of decimal places of the expected batch total.
Public property | NumericScale | Returns the number of digits, including decimals, of the expected batch total.
Public property | OrderNumber | Returns the order of the expected batch total field within the set of fields.
Public property | SqlType | Returns the data type of the expected batch total.
Public property | TypeName | Returns the name of the Tungsten Capture field type associated with the expected batch total.
Public property | Value | Gets or sets the value of the expected batch total.
Top
Remarks
An ExcectedBatchTotal object is valid as long as the parent batch is open.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal Methods

ExpectedBatchTotal Methods

The ExpectedBatchTotal type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ExpectedBatchTotal Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal.Dispose Method

ExpectedBatchTotalDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

ExpectedBatchTotal Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal Properties

ExpectedBatchTotal Properties

The ExpectedBatchTotal type exposes the following members.

Properties
 | Name | Description
Public property | Description | Returns the field type description.
Public property | Length | Returns the length of the field.
Public property | Name | Returns the name of the expected batch total.
Public property | Numeric | Returns True if the field type is numeric.
Public property | NumericPrecision | Returns the number of decimal places of the expected batch total.
Public property | NumericScale | Returns the number of digits, including decimals, of the expected batch total.
Public property | OrderNumber | Returns the order of the expected batch total field within the set of fields.
Public property | SqlType | Returns the data type of the expected batch total.
Public property | TypeName | Returns the name of the Tungsten Capture field type associated with the expected batch total.
Public property | Value | Gets or sets the value of the expected batch total.
Top
See Also

Reference

ExpectedBatchTotal Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal.Description Property

ExpectedBatchTotalDescription Property

Returns the field type description.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IExpectedBatchTotalDescription
See Also

Reference

ExpectedBatchTotal Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal.Length Property

ExpectedBatchTotalLength Property

Returns the length of the field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IExpectedBatchTotalLength
See Also

Reference

ExpectedBatchTotal Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal.Name Property

ExpectedBatchTotalName Property

Returns the name of the expected batch total.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IExpectedBatchTotalName
Remarks
See Also

Reference

ExpectedBatchTotal Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal.Numeric Property

ExpectedBatchTotalNumeric Property

Returns True if the field type is numeric.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Numeric { get; }
Public ReadOnly Property Numeric As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IExpectedBatchTotalNumeric
See Also

Reference

ExpectedBatchTotal Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal.NumericPrecision Property

ExpectedBatchTotalNumericPrecision Property

Returns the number of decimal places of the expected batch total.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int NumericPrecision { get; }
Public ReadOnly Property NumericPrecision As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IExpectedBatchTotalNumericPrecision
See Also

Reference

ExpectedBatchTotal Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal.NumericScale Property

ExpectedBatchTotalNumericScale Property

Returns the number of digits, including decimals, of the expected batch total.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int NumericScale { get; }
Public ReadOnly Property NumericScale As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IExpectedBatchTotalNumericScale
See Also

Reference

ExpectedBatchTotal Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal.OrderNumber Property

ExpectedBatchTotalOrderNumber Property

Returns the order of the expected batch total field within the set of fields.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int OrderNumber { get; }
Public ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IExpectedBatchTotalOrderNumber
Remarks
See Also

Reference

ExpectedBatchTotal Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal.SqlType Property

ExpectedBatchTotalSqlType Property

Returns the data type of the expected batch total.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int SqlType { get; }
Public ReadOnly Property SqlType As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IExpectedBatchTotalSqlType
See Also

Reference

ExpectedBatchTotal Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal.TypeName Property

ExpectedBatchTotalTypeName Property

Returns the name of the Tungsten Capture field type associated with the expected batch total.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IExpectedBatchTotalTypeName
See Also

Reference

ExpectedBatchTotal Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotal.Value Property

ExpectedBatchTotalValue Property

Gets or sets the value of the expected batch total.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IExpectedBatchTotalValue
Remarks
By default, the value is empty. When a value is assigned, it is checked to ensure that it is the proper numeric type.
See Also

Reference

ExpectedBatchTotal Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotals Class

ExpectedBatchTotals Class

ExpectedBatchTotals COM implementation class.

Defines a COM collection of ExpectedBatchTotal objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesExpectedBatchTotals

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC55-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class ExpectedBatchTotals : IExpectedBatchTotals,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC55-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class ExpectedBatchTotals
    Implements IExpectedBatchTotals, IEnumerable, IDisposable

The ExpectedBatchTotals type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of ExpectedBatchTotal objects contained in the collection.
Public property | Item | Returns the specified ExpectedBatchTotal from the collection.
Top
Remarks
An ExpectedBatchTotals object is valid as long as the parent batch is open.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotals Methods

ExpectedBatchTotals Methods

The ExpectedBatchTotals type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ExpectedBatchTotals Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotals.Dispose Method

ExpectedBatchTotalsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

ExpectedBatchTotals Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotals.GetEnumerator Method

ExpectedBatchTotalsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IExpectedBatchTotals object.

Implements

IExpectedBatchTotalsGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

ExpectedBatchTotals Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotals Properties

ExpectedBatchTotals Properties

The ExpectedBatchTotals type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of ExpectedBatchTotal objects contained in the collection.
Public property | Item | Returns the specified ExpectedBatchTotal from the collection.
Top
See Also

Reference

ExpectedBatchTotals Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotals.Count Property

ExpectedBatchTotalsCount Property

Returns the number of ExpectedBatchTotal objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IExpectedBatchTotalsCount
Remarks
See Also

Reference

ExpectedBatchTotals Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ExpectedBatchTotals.Item Property

ExpectedBatchTotalsItem Property

Returns the specified ExpectedBatchTotal from the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IExpectedBatchTotal this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IExpectedBatchTotal
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's indexed or key.

Property Value

Type: IExpectedBatchTotal

Return Value

Type: IExpectedBatchTotal

Implements

IExpectedBatchTotalsItemObject
Remarks
Index can either be a form type name or a numeric one-based index into the collection.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

ExpectedBatchTotals Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder Class

Folder Class

Folder COM implementation class.

Defines information about the currently opened folder.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesFolder

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC57-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Folder : IFolder, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC57-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Folder
    Implements IFolder, IDisposable

The Folder type exposes the following members.

Constructors
 | Name | Description
Public method | Folder | Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.Folder class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | MoveToBatch | Moves this folder to a batch.
Public method | MoveToFolder | Moves this folder to another folder.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Batch | Returns the parent Batch in which the folder resides.
Public property | ClassID | Gets the folder class ID.
Public property | ClassName | Returns the folder class name.
Public property | CustomStorageString | The folder storage string with the specified name.
Public property | Documents | Returns the collection of documents within the folder.
Public property | Folder | Gets or sets the parent folder where the current folder resides.
Public property | FolderClass | Gets or sets the FolderClass object.
Public property | FolderGUID | Returns the read only Folder unique ID.
Public property | Folders | Returns a collection of immediate child folders under the current folder (not including indirect child folders).
Public property | ID | Returns the internal Folder ID set by the data source (internal database).
Public property | IndexFieldCount | Returns the number of index fields in the folder.
Public property | IndexFields | Returns the collection of index fields in the folder.
Public property | OrderNumber | The folder order number within the batch (if the current folder is a direct child of a batch) or folder (if the parent is a folder).
Public property | Validated | True sets a folder as validated. This folder is skipped in the Validation module.
Public property | Verified | True sets a folder as verified. This folder is skipped in the Verification module.
Top
Remarks
A folder object is valid until a content change event occurs or a batch is closed.

Index field properties are available on any folder. If index field updates are done in Validation or Verification on the active folder, and data entry mode is active, then the updates are performed on the data entry panel. This causes SBL (deprecated) or .NET script validation to occur. Otherwise, any field updates change the database directly without SBL (deprecated) or .NET script validation.

The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


Folder Constructor

Folder Constructor

Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.Folder class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Folder()
Public Sub New
Remarks
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder Methods

Folder Methods

The Folder type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | MoveToBatch | Moves this folder to a batch.
Public method | MoveToFolder | Moves this folder to another folder.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.Dispose Method

FolderDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.MoveToBatch Method

FolderMoveToBatch Method

Moves this folder to a batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void MoveToBatch(
    ref IFolder oNextFolder = null
)
Public Sub MoveToBatch (
    Optional ByRef oNextFolder As IFolder = Nothing
)

Parameters

oNextFolder (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIFolder
The moved folder will be inserted before the folder specified by this parameter. The folder will be moved to the end of the folder list if this parameter is not specified.

Implements

IFolderMoveToBatch(IFolder)
Remarks
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.MoveToFolder Method

FolderMoveToFolder Method

Moves this folder to another folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void MoveToFolder(
    ref IFolder oFolder,
    ref IFolder oNextFolder = null
)
Public Sub MoveToFolder (
    ByRef oFolder As IFolder,
    Optional ByRef oNextFolder As IFolder = Nothing
)

Parameters

oFolder
Type: Kofax.Capture.CaptureModule.InteropServicesIFolder
The parent folder.
oNextFolder (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIFolder
The moved folder will be inserted before the folder specified by this parameter. The folder will be moved to the end of the folder list if this parameter is not specified.

Implements

IFolderMoveToFolder(IFolder, IFolder)
Remarks
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder Properties

Folder Properties

The Folder type exposes the following members.

Properties
 | Name | Description
Public property | Batch | Returns the parent Batch in which the folder resides.
Public property | ClassID | Gets the folder class ID.
Public property | ClassName | Returns the folder class name.
Public property | CustomStorageString | The folder storage string with the specified name.
Public property | Documents | Returns the collection of documents within the folder.
Public property | Folder | Gets or sets the parent folder where the current folder resides.
Public property | FolderClass | Gets or sets the FolderClass object.
Public property | FolderGUID | Returns the read only Folder unique ID.
Public property | Folders | Returns a collection of immediate child folders under the current folder (not including indirect child folders).
Public property | ID | Returns the internal Folder ID set by the data source (internal database).
Public property | IndexFieldCount | Returns the number of index fields in the folder.
Public property | IndexFields | Returns the collection of index fields in the folder.
Public property | OrderNumber | The folder order number within the batch (if the current folder is a direct child of a batch) or folder (if the parent is a folder).
Public property | Validated | True sets a folder as validated. This folder is skipped in the Validation module.
Public property | Verified | True sets a folder as verified. This folder is skipped in the Verification module.
Top
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.Batch Property

FolderBatch Property

Returns the parent Batch in which the folder resides.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch Batch { get; }
Public ReadOnly Property Batch As IBatch
    Get

Property Value

Type: IBatch

Return Value

Type: IBatch
IBatch

Implements

IFolderBatch
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.ClassID Property

FolderClassID Property

Gets the folder class ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ClassID { get; }
Public ReadOnly Property ClassID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFolderClassID
Remarks
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.ClassName Property

FolderClassName Property

Returns the folder class name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ClassName { get; }
Public ReadOnly Property ClassName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IFolderClassName
Remarks
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.CustomStorageString Property

FolderCustomStorageString Property

The folder storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
If set to an empty string, the storage string is deleted.

Property Value

Type: String

Return Value

Type: String
String

Implements

IFolderCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific folder. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.Documents Property

FolderDocuments Property

Returns the collection of documents within the folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocuments Documents { get; }
Public ReadOnly Property Documents As IDocuments
    Get

Property Value

Type: IDocuments

Return Value

Type: IDocuments
IDocuments

Implements

IFolderDocuments
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.Folder Property

FolderFolder Property

Gets or sets the parent folder where the current folder resides.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolder Folder { get; set; }
Public Property Folder As IFolder
    Get
    Set

Property Value

Type: IFolder

Return Value

Type: IFolder
IFolder

Implements

IFolderFolder
Remarks
Nothing if the current folder has no parent folder.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.FolderClass Property

FolderFolderClass Property

Gets or sets the FolderClass object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolderClass FolderClass { get; set; }
Public Property FolderClass As IFolderClass
    Get
    Set

Property Value

Type: IFolderClass

Return Value

Type: IFolderClass
IFolderClass

Implements

IFolderFolderClass
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.FolderGUID Property

FolderFolderGUID Property

Returns the read only Folder unique ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string FolderGUID { get; }
Public ReadOnly Property FolderGUID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IFolderFolderGUID
Remarks
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.Folders Property

FolderFolders Property

Returns a collection of immediate child folders under the current folder (not including indirect child folders).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolders Folders { get; }
Public ReadOnly Property Folders As IFolders
    Get

Property Value

Type: IFolders

Return Value

Type: IFolders
IFolders

Implements

IFolderFolders
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.ID Property

FolderID Property

Returns the internal Folder ID set by the data source (internal database).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ID { get; }
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFolderID
Remarks
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.IndexFieldCount Property

FolderIndexFieldCount Property

Returns the number of index fields in the folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int IndexFieldCount { get; }
Public ReadOnly Property IndexFieldCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFolderIndexFieldCount
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.IndexFields Property

FolderIndexFields Property

Returns the collection of index fields in the folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexFields IndexFields { get; }
Public ReadOnly Property IndexFields As IIndexFields
    Get

Property Value

Type: IIndexFields

Return Value

Type: IIndexFields
IIndexFields

Implements

IFolderIndexFields
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.OrderNumber Property

FolderOrderNumber Property

The folder order number within the batch (if the current folder is a direct child of a batch) or folder (if the parent is a folder).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int OrderNumber { get; }
Public ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFolderOrderNumber
Remarks
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.Validated Property

FolderValidated Property

True sets a folder as validated. This folder is skipped in the Validation module.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Validated { get; set; }
Public Property Validated As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IFolderValidated
Remarks
False clears the validated state. The folder is not skipped in the Validation module.
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folder.Verified Property

FolderVerified Property

True sets a folder as verified. This folder is skipped in the Verification module.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Verified { get; set; }
Public Property Verified As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IFolderVerified
Remarks
False clears the verified state. The folder is not skipped in the Verification module.
See Also

Reference

Folder Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClass Class

FolderClass Class

FolderClass COM implementation class.

Defines a COM object that refers to a Tungsten Capture folder class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesFolderClass

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC59-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class FolderClass : IFolderClass,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC59-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class FolderClass
    Implements IFolderClass, IDisposable

The FolderClass type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomStorageString | The folder storage string with the specified name.
Public property | Description | Gets the folder class description.
Public property | Name | Gets the folder class name.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClass Methods

FolderClass Methods

The FolderClass type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FolderClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClass.Dispose Method

FolderClassDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

FolderClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClass Properties

FolderClass Properties

The FolderClass type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The folder storage string with the specified name.
Public property | Description | Gets the folder class description.
Public property | Name | Gets the folder class name.
Top
See Also

Reference

FolderClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClass.CustomStorageString Property

FolderClassCustomStorageString Property

The folder storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; }
Public ReadOnly Property CustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString
If set to an empty string, the storage string is deleted.

Property Value

Type: String

Return Value

Type: String
String

Implements

IFolderClassCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific folder class. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

FolderClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClass.Description Property

FolderClassDescription Property

Gets the folder class description.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IFolderClassDescription
Remarks

This function throws:

(KfxApiErrBadParameterRange) on an illegal description; the maximum length is 80 characters.
See Also

Reference

FolderClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClass.Name Property

FolderClassName Property

Gets the folder class name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IFolderClassName
Remarks

This is the default property for the FolderClass object.

This function throws:

(KfxApiErrBadParameterRange) on an illegal description; the maximum length is 32 characters.

See Also

Reference

FolderClass Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClasses Class

FolderClasses Class

FolderClasses COM implementation class.

Defines a collection of folder classes.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesFolderClasses

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC5B-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class FolderClasses : IFolderClasses,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC5B-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class FolderClasses
    Implements IFolderClasses, IEnumerable, IDisposable

The FolderClasses type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of folder classes contained in the collection.
Public property | Item | Returns the specified FolderClass from the collection.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClasses Methods

FolderClasses Methods

The FolderClasses type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FolderClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClasses.Dispose Method

FolderClassesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

FolderClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClasses.GetEnumerator Method

FolderClassesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IFolderClasses object.

Implements

IFolderClassesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

FolderClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClasses Properties

FolderClasses Properties

The FolderClasses type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of folder classes contained in the collection.
Public property | Item | Returns the specified FolderClass from the collection.
Top
See Also

Reference

FolderClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClasses.Count Property

FolderClassesCount Property

Returns the number of folder classes contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFolderClassesCount
Remarks
See Also

Reference

FolderClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FolderClasses.Item Property

FolderClassesItem Property

Returns the specified FolderClass from the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolderClass this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFolderClass
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IFolderClass

Return Value

Type: IFolderClass
IFolderClass

Implements

IFolderClassesItemObject
Remarks
Index can be either a folder class name or a numeric one-based index into the collection.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

FolderClasses Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folders Class

Folders Class

Folders COM implementation class.

Defines a COM collection of Folder objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesFolders

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC5D-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Folders : IFolders, IEnumerable,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC5D-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Folders
    Implements IFolders, IEnumerable, IDisposable

The Folders type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of Folder objects contained in the collection.
Public property | Item | Returns the specified Folder object.
Top
Remarks
Iteration and extraction by order number (with the item function) is supported. Passing an out-of-range or invalid parameter to the item function causes it to throw the error "Invalid Parameter" to the caller. The Folders object is invalidated when the current batch is closed.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


Folders Methods

Folders Methods

The Folders type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Folders Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folders.Dispose Method

FoldersDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Folders Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folders.GetEnumerator Method

FoldersGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IFolders object.

Implements

IFoldersGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Folders Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folders Properties

Folders Properties

The Folders type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of Folder objects contained in the collection.
Public property | Item | Returns the specified Folder object.
Top
See Also

Reference

Folders Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folders.Count Property

FoldersCount Property

Returns the number of Folder objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFoldersCount
Remarks
See Also

Reference

Folders Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Folders.Item Property

FoldersItem Property

Returns the specified Folder object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolder this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFolder
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IFolder

Return Value

Type: IFolder

Implements

IFoldersItemObject
Remarks
Index can be either a folder class name or a numeric one-based index into the collection.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Folders Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FormType Class

FormType Class

FormType COM implementation class.

Defines a COM object that refers to a Tungsten Capture form type.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesFormType

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC5F-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class FormType : IFormType, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC5F-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class FormType
    Implements IFormType, IDisposable

The FormType type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Returns the description of the form type.
Public property | DocumentClass | Returns the document class that contains the form type.
Public property | Name | Returns the name of the form type.
Top
Remarks
A FormType object is valid as long as its parent Batch is open.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


FormType Methods

FormType Methods

The FormType type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FormType Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FormType.Dispose Method

FormTypeDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

FormType Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FormType Properties

FormType Properties

The FormType type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Returns the description of the form type.
Public property | DocumentClass | Returns the document class that contains the form type.
Public property | Name | Returns the name of the form type.
Top
See Also

Reference

FormType Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FormType.CustomStorageString Property

FormTypeCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; }
Public ReadOnly Property CustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the form type.

Property Value

Type: String

Return Value

Type: String
String

Implements

IFormTypeCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific form type. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

FormType Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FormType.Description Property

FormTypeDescription Property

Returns the description of the form type.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IFormTypeDescription
See Also

Reference

FormType Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FormType.DocumentClass Property

FormTypeDocumentClass Property

Returns the document class that contains the form type.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocumentClass DocumentClass { get; }
Public ReadOnly Property DocumentClass As IDocumentClass
    Get

Property Value

Type: IDocumentClass

Return Value

Type: IDocumentClass
IDocumentClass

Implements

IFormTypeDocumentClass
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

FormType Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FormType.Name Property

FormTypeName Property

Returns the name of the form type.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IFormTypeName
Remarks
See Also

Reference

FormType Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FormTypes Class

FormTypes Class

FormTypes COM implementation class.

Defines a COM collection of FormType objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesFormTypes

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC61-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class FormTypes : IFormTypes, IEnumerable,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC61-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class FormTypes
    Implements IFormTypes, IEnumerable, IDisposable

The FormTypes type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of FormType objects contained in the collection.
Public property | Item | Returns the specified FormType object.
Top
Remarks
A FormTypes object is valid as long as its parent Batch object is open.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


FormTypes Methods

FormTypes Methods

The FormTypes type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

FormTypes Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FormTypes.Dispose Method

FormTypesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

FormTypes Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FormTypes.GetEnumerator Method

FormTypesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IFormTypes object.

Implements

IFormTypesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

FormTypes Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FormTypes Properties

FormTypes Properties

The FormTypes type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of FormType objects contained in the collection.
Public property | Item | Returns the specified FormType object.
Top
See Also

Reference

FormTypes Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FormTypes.Count Property

FormTypesCount Property

Returns the number of FormType objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IFormTypesCount
Remarks
See Also

Reference

FormTypes Class
Kofax.Capture.CaptureModule.InteropServices Namespace


FormTypes.Item Property

FormTypesItem Property

Returns the specified FormType object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFormType this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFormType
    Get

Parameters

vntIndexKey
Type: SystemObject

Property Value

Type: IFormType

Return Value

Type: IFormType
IFormType

Implements

IFormTypesItemObject
Remarks
Index can either be a form type name or a numeric one-based index into the collection.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

FormTypes Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication Interface

IApplication Interface

IApplication COM Interface.

Serves as a root for a dynamic hierarchy of application objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC2E-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IApplication
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC2E-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IApplication

The IApplication type exposes the following members.

Methods
 | Name | Description
Public method | AddMenu | Adds a menu to the application.
Public method | AddMenuEx | Adds a menu to the application.
Public method | BlockFunction | Blocks menu bar items, context menu items, toolbar buttons, and keyboard accelerators. Returns True if the function was successfully blocked and False otherwise.
Public method | CloseBatch | Closes the active batch so that Tungsten Capture can process it. The ActiveBatch property is set to Nothing.
Public method | CreateBatch | Creates a batch using the batch class referenced by oBatchClass. This batch becomes the active batch and is referenced by ActiveBatch.
Public method | CreateBatch2 | Creates a new batch that uses default batch field values based on the oBatchFields parameter.
Public method | DeleteBatch | Deletes the active batch. The ActiveBatch property is set to Nothing.
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | LogMonitoringMessage | Logs a string that can be retrieved via SNMP.
Public method | OpenBatch | Opens the specified batch.
Public method | OpenNextBatch | Opens the next batch, based on the input parameters.
Public method | RejectBatch | Sets the error message on the active batch, and then rejects and closes it. The ActiveBatch property is set to Nothing.
Public method | RestoreFunction | Restores blocked menu bar items, context menu items, toolbar buttons, and keyboard accelerators. Returns True if the function was successfully restored and False otherwise.
Public method | SelectMenuItem | Causes the menu item with the specified resource ID to be triggered.
Public method | SetActiveContext | Obsolete. This method is deprecated and the use of this method should be replaced with ActiveDocument, ActiveFolder, ActiveIndexField, and ActivePage in Batch object.
Public method | ShowMenu | Shows or hides a menu in the application.
Public method | ShowWindow | Shows or hides a panel in the application.
Public method | SuspendBatch | Suspends the active batch. The ActiveBatch property is set to Nothing.
Public method | TranslateAscentCaptureValues | Any Tungsten Capture Value (enclosed in curly brackets) in strText is translated into the corresponding value.
Top
Properties
 | Name | Description
Public property | ActiveBatch | Returns the current batch.
Public property | AllowBatchEditing | This property is True if batch editing is allowed in the application.
Public property | AvailableBatches | Returns a collection of the batches that are either ready or suspended, are routed to the current module, and can be opened by the current user.
Public property | BatchClasses | Returns a collection of the batch classes available for creating a batch.
Public property | DataEntryMode | This property is deprecated in favor of ValidationMode.
Public property | HasAscentCaptureFeatures | Returns True if running Tungsten Capture.
Public property | IgnoreDocumentNavigationValidationError | Use this property if you want to set the ValidationMode to KfxValidationModeBatchEditing and avoid validation error messages while navigating from one document to another.
Public property | MultipleItemsSelected | Returns True if the user has selected multiple items on the tree viewer.
Public property | PanelName | Returns the internal (registry) name of the panel.
Public property | RemainingEDocumentCount | Returns the sum of all available Import eDocument count volume.
Public property | RemainingPageCount | Based on licensing and the hardware key, this is the number of remaining pages (excluding eDocument pages) that can be processed by Tungsten Capture.
Public property | ScannerProfile | Gets or sets currently selected scanner profile.
Public property | ScannerProfiles | Returns the current list of available scanner profiles.
Public property | ServicePackVersion | Returns the currently installed service pack version.
Public property | Theme | Returns the current theme of the Tungsten Capture system.
Public property | UseCustomScanAPI | Set to True to overwrite any separation behavior based on the configuration of the batch class. In this case, the separation method is provided via a custom panel.
Public property | ValidationMode | Setting this property changes the Validation Mode, but does not cause the "Save changes before closing document?" message to be displayed.
Top
Remarks

This object is automatically created when a user OCX is detected and the Application object is passed to the OCX, or when it is referenced in a custom application.

The API is COM-based and supports the COM IDispatch interface.

The type library name is "Kofax_Capture_CaptureModule," and the description is "Tungsten Capture Module .NET Type Library."

See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication Methods

IApplication Methods

The IApplication type exposes the following members.

Methods
 | Name | Description
Public method | AddMenu | Adds a menu to the application.
Public method | AddMenuEx | Adds a menu to the application.
Public method | BlockFunction | Blocks menu bar items, context menu items, toolbar buttons, and keyboard accelerators. Returns True if the function was successfully blocked and False otherwise.
Public method | CloseBatch | Closes the active batch so that Tungsten Capture can process it. The ActiveBatch property is set to Nothing.
Public method | CreateBatch | Creates a batch using the batch class referenced by oBatchClass. This batch becomes the active batch and is referenced by ActiveBatch.
Public method | CreateBatch2 | Creates a new batch that uses default batch field values based on the oBatchFields parameter.
Public method | DeleteBatch | Deletes the active batch. The ActiveBatch property is set to Nothing.
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | LogMonitoringMessage | Logs a string that can be retrieved via SNMP.
Public method | OpenBatch | Opens the specified batch.
Public method | OpenNextBatch | Opens the next batch, based on the input parameters.
Public method | RejectBatch | Sets the error message on the active batch, and then rejects and closes it. The ActiveBatch property is set to Nothing.
Public method | RestoreFunction | Restores blocked menu bar items, context menu items, toolbar buttons, and keyboard accelerators. Returns True if the function was successfully restored and False otherwise.
Public method | SelectMenuItem | Causes the menu item with the specified resource ID to be triggered.
Public method | SetActiveContext | Obsolete. This method is deprecated and the use of this method should be replaced with ActiveDocument, ActiveFolder, ActiveIndexField, and ActivePage in Batch object.
Public method | ShowMenu | Shows or hides a menu in the application.
Public method | ShowWindow | Shows or hides a panel in the application.
Public method | SuspendBatch | Suspends the active batch. The ActiveBatch property is set to Nothing.
Public method | TranslateAscentCaptureValues | Any Tungsten Capture Value (enclosed in curly brackets) in strText is translated into the corresponding value.
Top
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.AddMenu Method

IApplicationAddMenu Method

Adds a menu to the application.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool AddMenu(
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = ""
)
Function AddMenu (
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = ""
) As Boolean

Parameters

strEventText
Type: SystemString
Returned to the OCX when the menu is selected.
strMenuText
Type: SystemString
Text displayed in the menu item.
strMenuLocation
Type: SystemString

Location for the menu to appear.

The locations supported are as follows:

VB
Copy
Dim m_MenuLocationKeys(0 To 4) As String
m_MenuLocationKeys(0) = "MenuBar"
m_MenuLocationKeys(1) = "Batch"
m_MenuLocationKeys(2) = "Document"
m_MenuLocationKeys(3) = "Page"
strMenuBarText (Optional)
Type: SystemString
The text displayed on the main frame. Only required if the location is "MenuBar".

Return Value

Type: Boolean
BooleanTrue - Menu added, otherwise False.
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.AddMenuEx Method

IApplicationAddMenuEx Method

Adds a menu to the application.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool AddMenuEx(
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = "",
    bool bLarge = false,
    string strIconPath = "",
    string strGroupName = ""
)
Function AddMenuEx (
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = "",
    Optional bLarge As Boolean = false,
    Optional strIconPath As String = "",
    Optional strGroupName As String = ""
) As Boolean

Parameters

strEventText
Type: SystemString
Returned to the OCX when the menu is selected.
strMenuText
Type: SystemString
Text displayed in the menu item.
strMenuLocation
Type: SystemString
Location to place the menu. The locations supported are as follows:
VB
Copy
Dim m_MenuLocationKeys(0 To 4) As String
m_MenuLocationKeys(0) = "MenuBar"
m_MenuLocationKeys(1) =  "Batch"
m_MenuLocationKeys(2) = "Document"
m_MenuLocationKeys(3) = "Page"
strMenuBarText (Optional)
Type: SystemString
The text displayed on the Ribbon; only required if the location is "MenuBar".
bLarge (Optional)
Type: SystemBoolean
A large button (True), or a small one (False).
strIconPath (Optional)
Type: SystemString
The path to the icon file used for the button.
strGroupName (Optional)
Type: SystemString
The specific group for menu items (commands).

Return Value

Type: Boolean
BooleanTrue - Menu added, otherwise False.
Remarks
This method can only be used with OCX. Note that some parameters are the same as the AddMenu method to preserve backwards compatibility. The extended parameters are provided for use with the Fluent UI (Ribbon).
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.BlockFunction Method

IApplicationBlockFunction Method

Blocks menu bar items, context menu items, toolbar buttons, and keyboard accelerators. Returns True if the function was successfully blocked and False otherwise.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool BlockFunction(
    KfxAPIApplicationFunctionList eFunctionID
)
Function BlockFunction (
    eFunctionID As KfxAPIApplicationFunctionList
) As Boolean

Parameters

eFunctionID
Type: Kofax.Capture.CaptureModule.InteropServicesKfxAPIApplicationFunctionList
The function to block.

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.CloseBatch Method

IApplicationCloseBatch Method

Closes the active batch so that Tungsten Capture can process it. The ActiveBatch property is set to Nothing.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void CloseBatch()
Sub CloseBatch
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.CreateBatch Method

IApplicationCreateBatch Method

Creates a batch using the batch class referenced by oBatchClass. This batch becomes the active batch and is referenced by ActiveBatch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch CreateBatch(
    ref IBatchClass oBatchClass,
    string strBatchName
)
Function CreateBatch (
    ByRef oBatchClass As IBatchClass,
    strBatchName As String
) As IBatch

Parameters

oBatchClass
Type: Kofax.Capture.CaptureModule.InteropServicesIBatchClass
The batch class used to create the new batch.
strBatchName
Type: SystemString
The name of the new batch.

Return Value

Type: IBatch
IBatch
Remarks

If an empty batch name is specified (only from Scan or an import script), then a batch name is generated using the same algorithm as the default batch names in the Tungsten Capture New Batch dialog box in Batch Manager or Scan.

See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.CreateBatch2 Method

IApplicationCreateBatch2 Method
Creates a new batch that uses default batch field values based on the oBatchFields parameter.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch CreateBatch2(
    ref IBatchClass oBatchClass,
    string strBatchName,
    Object oBatchFields,
    ref IKfxCollection oOutputBatchFields = null
)
Function CreateBatch2 (
    ByRef oBatchClass As IBatchClass,
    strBatchName As String,
    oBatchFields As Object,
    Optional ByRef oOutputBatchFields As IKfxCollection = Nothing
) As IBatch

Parameters

oBatchClass
Type: Kofax.Capture.CaptureModule.InteropServicesIBatchClass
The batch class used to create the new batch.
strBatchName
Type: SystemString
The name of the new batch.
oBatchFields
Type: SystemObject
The collection of collections with the respective batch field names and values.
oOutputBatchFields (Optional)
Type: IKfxCollection
The output list of batch field names.

Return Value

Type: IBatch
IBatch
Remarks
If the batch name is empty, a default batch name is assigned, based on the name format defined in Batch Class Properties – Batch Naming.
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.DeleteBatch Method

IApplicationDeleteBatch Method

Deletes the active batch. The ActiveBatch property is set to Nothing.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteBatch()
Sub DeleteBatch
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.LogError Method

IApplicationLogError Method

Logs an error to the Tungsten Capture error log.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void LogError(
    int Err1,
    int Err2,
    int Err3,
    string ErrorMessage,
    string CodeModule,
    int LineNumber
)
Sub LogError (
    Err1 As Integer,
    Err2 As Integer,
    Err3 As Integer,
    ErrorMessage As String,
    CodeModule As String,
    LineNumber As Integer
)

Parameters

Err1
Type: SystemInt32
The primary error code.
Err2
Type: SystemInt32
Sub-code.
Err3
Type: SystemInt32
Sub-code.
ErrorMessage
Type: SystemString
The string message.
CodeModule
Type: SystemString
The source code module where the problem occurred.
LineNumber
Type: SystemInt32
The line number within the source where the problem occurred.
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.LogMonitoringMessage Method

IApplicationLogMonitoringMessage Method

Logs a string that can be retrieved via SNMP.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void LogMonitoringMessage(
    string Message
)
Sub LogMonitoringMessage (
    Message As String
)

Parameters

Message
Type: SystemString
The string that will be logged.
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.OpenBatch Method

IApplicationOpenBatch Method

Opens the specified batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch OpenBatch(
    ref IAvailableBatch oAvailableBatch
)
Function OpenBatch (
    ByRef oAvailableBatch As IAvailableBatch
) As IBatch

Parameters

oAvailableBatch
Type: Kofax.Capture.CaptureModule.InteropServicesIAvailableBatch
The batch to open.

Return Value

Type: IBatch
IBatch
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.OpenNextBatch Method

IApplicationOpenNextBatch Method

Opens the next batch, based on the input parameters.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch OpenNextBatch(
    ref bool bFilterPriorityDescending,
    ref KfxApiBatchState eState
)
Function OpenNextBatch (
    ByRef bFilterPriorityDescending As Boolean,
    ByRef eState As KfxApiBatchState
) As IBatch

Parameters

bFilterPriorityDescending
Type: SystemBoolean
If True, returns the highest priority batch.
eState
Type: Kofax.Capture.CaptureModule.InteropServicesKfxApiBatchState
Valid eState values are limited to:
  • KfxApiBatchStateReady
  • KfxApiBatchStateSuspend
  • KfxApiBatchStateError

If eState is any other value a "Parameter out of Range" error occurs.

Return Value

Type: IBatch
IBatch
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.RejectBatch Method

IApplicationRejectBatch Method

Sets the error message on the active batch, and then rejects and closes it. The ActiveBatch property is set to Nothing.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void RejectBatch(
    string strErrorMessage
)
Sub RejectBatch (
    strErrorMessage As String
)

Parameters

strErrorMessage
Type: SystemString
The error message to set.
Remarks
Because this is a critical operation and the message is used for debugging, the string is truncated if necessary to fit in the database.
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.RestoreFunction Method

IApplicationRestoreFunction Method

Restores blocked menu bar items, context menu items, toolbar buttons, and keyboard accelerators. Returns True if the function was successfully restored and False otherwise.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool RestoreFunction(
    KfxAPIApplicationFunctionList eFunctionID
)
Function RestoreFunction (
    eFunctionID As KfxAPIApplicationFunctionList
) As Boolean

Parameters

eFunctionID
Type: Kofax.Capture.CaptureModule.InteropServicesKfxAPIApplicationFunctionList
The function ID to restore.

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.SelectMenuItem Method

IApplicationSelectMenuItem Method

Causes the menu item with the specified resource ID to be triggered.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SelectMenuItem(
    int lResourceID,
    bool bSendImmediate = false
)
Function SelectMenuItem (
    lResourceID As Integer,
    Optional bSendImmediate As Boolean = false
) As Boolean

Parameters

lResourceID
Type: SystemInt32
The resource ID of the menu item to trigger.
bSendImmediate (Optional)
Type: SystemBoolean
Used in an action event, otherwise the menu is triggered after the event.

Return Value

Type: Boolean
Boolean. Returns False if the menu could not be selected due to the following cases:
1) The application is currently processing an event SendMessage will return False
2) If the menu item is disabled
Remarks

You can use a custom OCX panel to invoke Tungsten Capture menu items in the Administration, Scan, Quality Control, Validation, and Verification modules through this function.

Tungsten Capture menu items are passed to the module through the SelectMenuItem function. A separate set of menu items is available for each Tungsten Capture module.

If successful, SelectMenuItem returns a nonzero value. In the case of an unexpected system error, it returns a value of zero. SelectMenuItem will throw an error if any of the following are true:

  • You specify an invalid resource ID for the menu item
  • The item is currently grayed in the target module
  • You execute an exit menu item immediately (bSendImmediate is True)
  • The application is busy
The bSendImmediate parameter is optional, and it can be set to True or False.
  • If True, bSendImmediate invokes the Windows API call "SendMessage," which executes the menu command instantly and fails if the module is processing another event.
  • If False, bSendImmediate invokes the Windows API call "PostMessage," which posts the menu command so it is executed when other events are completed.
The following sample passes a menu item from a custom OCX to the Scan module. The menu item shown here displays the last page in a batch.
VB
Copy
Private Sub ScanStopped()
  Dim bResult As Boolean
  Dim lMenuResourceNumber As Long
  Dim bSendImmediate As Boolean
  bResult=False
On Error GoTo MenuSelectError:
  lMenuResourceNumber=KfxApiScanMenuItems.KfxScanMenuPageLast
  bSendImmediate=False
  bResult=m_oApp.SelectMenuItem(lMenuResourceNumber, bSendImmediate)
  Exit Sub
MenuSelectError:
MsgBox "Unable to select menu:" & Err.Description
End Sub
In the following code, the OCX Menu Selection invokes the About Tungsten Capture menu selection in the Administration module.
VB
Copy
Dim bSendImmediate As Boolean
bSendImmediate=False
' Display the about box
bResult=m_oApp.SelectMenuItem(KfxApiAdminMenuItems.KfxAdminMenuHelpAboutAscentCapture, bSendImmediate)
In the above example, KfxAdminMenuHelpAboutAscentCapture is the item for the Administration module About Tungsten Capture menu item. A separate set of menu items is available for each Tungsten Capture module.
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.SetActiveContext Method

IApplicationSetActiveContext Method

Note: This API is now obsolete.

This method is deprecated and the use of this method should be replaced with ActiveDocument, ActiveFolder, ActiveIndexField, and ActivePage in Batch object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ObsoleteAttribute("This method is deprecated and the use of this method should be replaced with ActiveDocument, ActiveFolder, ActiveIndexField, and ActivePage in Batch object.")]
bool SetActiveContext(
    int DocumentNumber,
    int PageNumber,
    int IndexFieldNumber
)
<ObsoleteAttribute("This method is deprecated and the use of this method should be replaced with ActiveDocument, ActiveFolder, ActiveIndexField, and ActivePage in Batch object.")>
Function SetActiveContext (
    DocumentNumber As Integer,
    PageNumber As Integer,
    IndexFieldNumber As Integer
) As Boolean

Parameters

DocumentNumber
Type: SystemInt32
The one-based index of the desired document.
PageNumber
Type: SystemInt32
The index of the pages. If the application is currently in a document, then this navigates to a document page. If the application is currently on a loose page or on the batch node, then it navigates to a loose page.
IndexFieldNumber
Type: SystemInt32
Defines the desired field. The application must already be positioned on a document.

Return Value

Type: Boolean
Boolean
Remarks

This method only works for objects that are not in folders.

This function, only valid when a batch is opened, navigates to some object within the batch. It returns True if the context change was successful. Note that the context change can fail because of a validation script failure. Passing an out-of-range, or invalid parameter to this function causes it to throw the error "Invalid Parameter" to the caller. Attempting to call the function prior to the batch being opened raises the error "Not Available" to the caller.

Only one parameter can be passed as non-zero. Passing multiple parameters as non-zero fires the exception "Illegal parameter range."

Passing all parameters as 0 causes the application to navigate to the batch node (as viewed on the tree control). Attempting to navigate to a hidden index field fires the error "Illegal parameter range."

See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.ShowMenu Method

IApplicationShowMenu Method

Shows or hides a menu in the application.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void ShowMenu(
    KfxShowMenu eState,
    string strEventText,
    string strMenuText,
    string strMenuLocation,
    string strMenuBarText = ""
)
Sub ShowMenu (
    eState As KfxShowMenu,
    strEventText As String,
    strMenuText As String,
    strMenuLocation As String,
    Optional strMenuBarText As String = ""
)

Parameters

eState
Type: Kofax.Capture.CaptureModule.InteropServicesKfxShowMenu
The state of the menu item.
strEventText
Type: SystemString
String returned to OCX when menu is selected.
strMenuText
Type: SystemString
Text to be put in menu, can contain hotkeys.
strMenuLocation
Type: SystemString
Location for menu to appear.
strMenuBarText (Optional)
Type: SystemString
Required for MenuBar text.
Remarks
Only valid in OCX.
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.ShowWindow Method

IApplicationShowWindow Method

Shows or hides a panel in the application.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool ShowWindow(
    bool bShow
)
Function ShowWindow (
    bShow As Boolean
) As Boolean

Parameters

bShow
Type: SystemBoolean

Same for all modules:

FALSE (0) means hide the panel.

TRUE not 0 means show the panel.

Return Value

Type: Boolean
Boolean. Returns False if we were unable to complete because window was already in the correct state.
Remarks
Only valid in OCX.
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.SuspendBatch Method

IApplicationSuspendBatch Method

Suspends the active batch. The ActiveBatch property is set to Nothing.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void SuspendBatch()
Sub SuspendBatch
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.TranslateAscentCaptureValues Method

IApplicationTranslateAscentCaptureValues Method

Any Tungsten Capture Value (enclosed in curly brackets) in strText is translated into the corresponding value.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void TranslateAscentCaptureValues(
    ref string strText
)
Sub TranslateAscentCaptureValues (
    ByRef strText As String
)

Parameters

strText
Type: SystemString
The original string to translate.
Remarks

For example: "This is the current document’s form type: {Document Form Name}."

Assuming a current document with a form exists, the "{Document Form Name}" text is replaced with the appropriate form name.

Tungsten Capture values may also be used to get batch field values. In this case, the batch field name is preceded by a dollar sign and enclosed in curly brackets.

For example: "This is the value of batch field name0: '{$name0}."

See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication Properties

IApplication Properties

The IApplication type exposes the following members.

Properties
 | Name | Description
Public property | ActiveBatch | Returns the current batch.
Public property | AllowBatchEditing | This property is True if batch editing is allowed in the application.
Public property | AvailableBatches | Returns a collection of the batches that are either ready or suspended, are routed to the current module, and can be opened by the current user.
Public property | BatchClasses | Returns a collection of the batch classes available for creating a batch.
Public property | DataEntryMode | This property is deprecated in favor of ValidationMode.
Public property | HasAscentCaptureFeatures | Returns True if running Tungsten Capture.
Public property | IgnoreDocumentNavigationValidationError | Use this property if you want to set the ValidationMode to KfxValidationModeBatchEditing and avoid validation error messages while navigating from one document to another.
Public property | MultipleItemsSelected | Returns True if the user has selected multiple items on the tree viewer.
Public property | PanelName | Returns the internal (registry) name of the panel.
Public property | RemainingEDocumentCount | Returns the sum of all available Import eDocument count volume.
Public property | RemainingPageCount | Based on licensing and the hardware key, this is the number of remaining pages (excluding eDocument pages) that can be processed by Tungsten Capture.
Public property | ScannerProfile | Gets or sets currently selected scanner profile.
Public property | ScannerProfiles | Returns the current list of available scanner profiles.
Public property | ServicePackVersion | Returns the currently installed service pack version.
Public property | Theme | Returns the current theme of the Tungsten Capture system.
Public property | UseCustomScanAPI | Set to True to overwrite any separation behavior based on the configuration of the batch class. In this case, the separation method is provided via a custom panel.
Public property | ValidationMode | Setting this property changes the Validation Mode, but does not cause the "Save changes before closing document?" message to be displayed.
Top
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.ActiveBatch Property

IApplicationActiveBatch Property

Returns the current batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch ActiveBatch { get; }
ReadOnly Property ActiveBatch As IBatch
    Get

Property Value

Type: IBatch

Return Value

Type: IBatch
IBatch
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.AllowBatchEditing Property

IApplicationAllowBatchEditing Property

This property is True if batch editing is allowed in the application.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool AllowBatchEditing { get; }
ReadOnly Property AllowBatchEditing As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Remarks
For the Validation and Verification modules, this property is True if the batch class allows batch editing in the respective module and (when the User Profiles feature is enabled) if the user has batch editing rights. The property is False otherwise. For all other modules, this property is True.
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.AvailableBatches Property

IApplicationAvailableBatches Property

Returns a collection of the batches that are either ready or suspended, are routed to the current module, and can be opened by the current user.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IAvailableBatches AvailableBatches { get; }
ReadOnly Property AvailableBatches As IAvailableBatches
    Get

Property Value

Type: IAvailableBatches

Return Value

Type: IAvailableBatches
IAvailableBatches
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.BatchClasses Property

IApplicationBatchClasses Property

Returns a collection of the batch classes available for creating a batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchClasses BatchClasses { get; }
ReadOnly Property BatchClasses As IBatchClasses
    Get

Property Value

Type: IBatchClasses

Return Value

Type: IBatchClasses
IBatchClasses
Remarks
This property is refreshed each time it is accessed.
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.DataEntryMode Property

IApplicationDataEntryMode Property

This property is deprecated in favor of ValidationMode.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool DataEntryMode { get; }
ReadOnly Property DataEntryMode As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean. Returns True when in Validation/Verification and data entry mode is enabled.
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.HasAscentCaptureFeatures Property

IApplicationHasAscentCaptureFeatures Property

Returns True if running Tungsten Capture.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool HasAscentCaptureFeatures { get; }
ReadOnly Property HasAscentCaptureFeatures As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.IgnoreDocumentNavigationValidationError Property

IApplicationIgnoreDocumentNavigationValidationError Property

Use this property if you want to set the ValidationMode to KfxValidationModeBatchEditing and avoid validation error messages while navigating from one document to another.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool IgnoreDocumentNavigationValidationError { get; set; }
Property IgnoreDocumentNavigationValidationError As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

This property is False by default.

If this property is False and a validation error occurs, a validation error message is displayed.

If this property is True, index field validation errors are ignored and no error messages are displayed.

In addition, if True, no validation checks are performed. Any changes to document index fields are saved, but the document is not regarded as processed.

See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.MultipleItemsSelected Property

IApplicationMultipleItemsSelected Property

Returns True if the user has selected multiple items on the tree viewer.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool MultipleItemsSelected { get; }
ReadOnly Property MultipleItemsSelected As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.PanelName Property

IApplicationPanelName Property

Returns the internal (registry) name of the panel.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string PanelName { get; }
ReadOnly Property PanelName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.RemainingEDocumentCount Property

IApplicationRemainingEDocumentCount Property

Returns the sum of all available Import eDocument count volume.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int RemainingEDocumentCount { get; }
ReadOnly Property RemainingEDocumentCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.RemainingPageCount Property

IApplicationRemainingPageCount Property

Based on licensing and the hardware key, this is the number of remaining pages (excluding eDocument pages) that can be processed by Tungsten Capture.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int RemainingPageCount { get; }
ReadOnly Property RemainingPageCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks

This property returns the sum of all available Scanned/Imported Pages volume.

See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.ScannerProfile Property

IApplicationScannerProfile Property

Gets or sets currently selected scanner profile.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IScannerProfile ScannerProfile { get; set; }
Property ScannerProfile As IScannerProfile
    Get
    Set

Property Value

Type: IScannerProfile

Return Value

Type: IScannerProfile
Remarks

Cannot be set during an action event.

See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.ScannerProfiles Property

IApplicationScannerProfiles Property

Returns the current list of available scanner profiles.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IScannerProfiles ScannerProfiles { get; }
ReadOnly Property ScannerProfiles As IScannerProfiles
    Get

Property Value

Type: IScannerProfiles

Return Value

Type: IScannerProfiles
IScannerProfiles
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.ServicePackVersion Property

IApplicationServicePackVersion Property

Returns the currently installed service pack version.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
short ServicePackVersion { get; }
ReadOnly Property ServicePackVersion As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.Theme Property

IApplicationTheme Property

Returns the current theme of the Tungsten Capture system.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ITheme Theme { get; }
ReadOnly Property Theme As ITheme
    Get

Property Value

Type: ITheme

Return Value

Type: ITheme
ITheme
Remarks
See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.UseCustomScanAPI Property

IApplicationUseCustomScanAPI Property

Set to True to overwrite any separation behavior based on the configuration of the batch class. In this case, the separation method is provided via a custom panel.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool UseCustomScanAPI { set; }
WriteOnly Property UseCustomScanAPI As Boolean
    Set

Property Value

Type: Boolean
Remarks

This property can be set during an event and the changes will take effect on all subsequent scanned batches. However, for the change to take effect on the active batch, it must be set before that batch is opened or created. This property is not reset after each batch, but only the next time the Scan module is open.

See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IApplication.ValidationMode Property

IApplicationValidationMode Property

Setting this property changes the Validation Mode, but does not cause the "Save changes before closing document?" message to be displayed.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
KfxApiValidationMode ValidationMode { get; set; }
Property ValidationMode As KfxApiValidationMode
    Get
    Set

Property Value

Type: KfxApiValidationMode

Return Value

Type: KfxApiValidationMode
KfxApiValidationMode
Remarks

In the Validation and Verification modules, the default value is KfxValidationModeDataEntry. In other modules, the default value is KfxValidationModeBatchEditing.

This property can be set during a KfxOcxEventBatchOpened event. For any other event, an KfxApiErrAppIsBusy error is thrown (similar to other, similar properties and methods).

If the property is set during the batch opened event, the mode switch will not occur until after the event is finished. Likewise, if (within an event) the application gets the ValidationMode property after setting it, the ValidationMode will still be the old value, since the change hasn't yet occurred.

Changing the application mode to batch editing in Validation is identical to selecting the corresponding item in the user interface toolbar (or menu item). The mode changes back to Data Entry upon opening another batch. Therefore, an OCX that wants to keep the system in batch editing mode needs to repeatedly set the mode whenever a batch is opened.

See Also

Reference

IApplication Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAsnReleaseScript Interface

IAsnReleaseScript Interface

IAsnReleaseScript COM Interface.

Defines information about export connectors. An AsnReleaseScript object is invalidated when a content change event occurs.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC30-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IAsnReleaseScript
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC30-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IAsnReleaseScript

The IAsnReleaseScript type exposes the following members.

Properties
 | Name | Description
Public property | CustomProperties | Returns the CustomProperty objects belonging to this export connector destination.
Public property | CustomPropertyCount | Returns the number of custom properties for this export connector assignment.
Public property | Name | Returns the assignment name, which is the name the user gives when assigning an export connector to a document class.
Public property | OrderNumber | Returns the order number, within the document class, of this export connector assignment.
Public property | ReleaseScriptName | Returns the name of the export connector.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IAsnReleaseScript Properties

IAsnReleaseScript Properties

The IAsnReleaseScript type exposes the following members.

Properties
 | Name | Description
Public property | CustomProperties | Returns the CustomProperty objects belonging to this export connector destination.
Public property | CustomPropertyCount | Returns the number of custom properties for this export connector assignment.
Public property | Name | Returns the assignment name, which is the name the user gives when assigning an export connector to a document class.
Public property | OrderNumber | Returns the order number, within the document class, of this export connector assignment.
Public property | ReleaseScriptName | Returns the name of the export connector.
Top
See Also

Reference

IAsnReleaseScript Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAsnReleaseScript.CustomProperties Property

IAsnReleaseScriptCustomProperties Property

Returns the CustomProperty objects belonging to this export connector destination.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ICustomProperties CustomProperties { get; }
ReadOnly Property CustomProperties As ICustomProperties
    Get

Property Value

Type: ICustomProperties

Return Value

Type: ICustomProperties
ICustomProperties
See Also

Reference

IAsnReleaseScript Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAsnReleaseScript.CustomPropertyCount Property

IAsnReleaseScriptCustomPropertyCount Property

Returns the number of custom properties for this export connector assignment.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int CustomPropertyCount { get; }
ReadOnly Property CustomPropertyCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
See Also

Reference

IAsnReleaseScript Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAsnReleaseScript.Name Property

IAsnReleaseScriptName Property

Returns the assignment name, which is the name the user gives when assigning an export connector to a document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IAsnReleaseScript Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAsnReleaseScript.OrderNumber Property

IAsnReleaseScriptOrderNumber Property

Returns the order number, within the document class, of this export connector assignment.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int OrderNumber { get; }
ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
See Also

Reference

IAsnReleaseScript Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAsnReleaseScript.ReleaseScriptName Property

IAsnReleaseScriptReleaseScriptName Property

Returns the name of the export connector.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ReleaseScriptName { get; }
ReadOnly Property ReleaseScriptName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
See Also

Reference

IAsnReleaseScript Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAsnReleaseScripts Interface

IAsnReleaseScripts Interface

IAsnReleaseScripts COM Interface.

Defines a COM collection of AsnReleaseScript objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC32-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IAsnReleaseScripts
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC32-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IAsnReleaseScripts

The IAsnReleaseScripts type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of AsnReleaseScript objects contained in the collection.
Public property | Item | Returns the AsnReleaseScript object by order number or assignment name.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IAsnReleaseScripts Methods

IAsnReleaseScripts Methods

The IAsnReleaseScripts type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IAsnReleaseScripts Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAsnReleaseScripts.GetEnumerator Method

IAsnReleaseScriptsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IAsnReleaseScripts object.
See Also

Reference

IAsnReleaseScripts Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAsnReleaseScripts Properties

IAsnReleaseScripts Properties

The IAsnReleaseScripts type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of AsnReleaseScript objects contained in the collection.
Public property | Item | Returns the AsnReleaseScript object by order number or assignment name.
Top
See Also

Reference

IAsnReleaseScripts Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAsnReleaseScripts.Count Property

IAsnReleaseScriptsCount Property

Returns the number of AsnReleaseScript objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IAsnReleaseScripts Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAsnReleaseScripts.Item Property

IAsnReleaseScriptsItem Property

Returns the AsnReleaseScript object by order number or assignment name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IAsnReleaseScript this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IAsnReleaseScript
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IAsnReleaseScript

Return Value

Type: IAsnReleaseScript
IAsnReleaseScript
See Also

Reference

IAsnReleaseScripts Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatch Interface

IAvailableBatch Interface

IAvailableBatch COM Interface.

Defines a COM object that refers to batches in process by Tungsten Capture.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC34-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IAvailableBatch
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC34-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IAvailableBatch

The IAvailableBatch type exposes the following members.

Properties
 | Name | Description
Public property | BatchClassName | Returns the name of the batch class used to create the batch.
Public property | ContainsErrors | Returns True if the batch contains errors.
Public property | CreationDate | Returns the date the batch was created.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Name | Returns the name of the batch.
Public property | Priority | Returns the priority of the batch.
Public property | State | Returns the status of the batch.
Public property | StationID | Returns the ID of the last station opening the batch.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatch Properties

IAvailableBatch Properties

The IAvailableBatch type exposes the following members.

Properties
 | Name | Description
Public property | BatchClassName | Returns the name of the batch class used to create the batch.
Public property | ContainsErrors | Returns True if the batch contains errors.
Public property | CreationDate | Returns the date the batch was created.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Name | Returns the name of the batch.
Public property | Priority | Returns the priority of the batch.
Public property | State | Returns the status of the batch.
Public property | StationID | Returns the ID of the last station opening the batch.
Top
See Also

Reference

IAvailableBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatch.BatchClassName Property

IAvailableBatchBatchClassName Property

Returns the name of the batch class used to create the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string BatchClassName { get; }
ReadOnly Property BatchClassName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IAvailableBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatch.ContainsErrors Property

IAvailableBatchContainsErrors Property

Returns True if the batch contains errors.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool ContainsErrors { get; }
ReadOnly Property ContainsErrors As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IAvailableBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatch.CreationDate Property

IAvailableBatchCreationDate Property

Returns the date the batch was created.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
DateTime CreationDate { get; }
ReadOnly Property CreationDate As DateTime
    Get

Property Value

Type: DateTime

Return Value

Type: DateTime
Date
Remarks
See Also

Reference

IAvailableBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatch.CustomStorageString Property

IAvailableBatchCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific batch. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name. If set to an empty string, the storage string is deleted.

This function throws:(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IAvailableBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatch.Name Property

IAvailableBatchName Property

Returns the name of the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IAvailableBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatch.Priority Property

IAvailableBatchPriority Property

Returns the priority of the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Priority { get; }
ReadOnly Property Priority As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IAvailableBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatch.State Property

IAvailableBatchState Property

Returns the status of the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
KfxApiBatchState State { get; }
ReadOnly Property State As KfxApiBatchState
    Get

Property Value

Type: KfxApiBatchState

Return Value

Type: KfxApiBatchState
KfxApiBatchState
Remarks
Only read or suspended batches are available.
See Also

Reference

IAvailableBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatch.StationID Property

IAvailableBatchStationID Property

Returns the ID of the last station opening the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string StationID { get; }
ReadOnly Property StationID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IAvailableBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatches Interface

IAvailableBatches Interface

IAvailableBatches COM Interface.

Defines a COM collection of batches that are either ready or suspended, are routed to the current module, and can be opened by the current user.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC36-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IAvailableBatches
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC36-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IAvailableBatches

The IAvailableBatches type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of batches contained in the collection.
Public property | Item | Returns an available batch by name.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatches Methods

IAvailableBatches Methods

The IAvailableBatches type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IAvailableBatches Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatches.GetEnumerator Method

IAvailableBatchesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IAvailableBatches object.
See Also

Reference

IAvailableBatches Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatches Properties

IAvailableBatches Properties

The IAvailableBatches type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of batches contained in the collection.
Public property | Item | Returns an available batch by name.
Top
See Also

Reference

IAvailableBatches Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatches.Count Property

IAvailableBatchesCount Property

Returns the number of batches contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IAvailableBatches Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IAvailableBatches.Item Property

IAvailableBatchesItem Property

Returns an available batch by name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IAvailableBatch this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IAvailableBatch
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IAvailableBatch

Return Value

Type: IAvailableBatch
IAvailableBatch
Remarks
See Also

Reference

IAvailableBatches Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch Interface

IBatch Interface

IBatch COM Interface.

Defines information about the currently opened batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC38-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IBatch
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC38-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IBatch

The IBatch type exposes the following members.

Methods
 | Name | Description
Public method | CreateDocument | Creates a document.
Public method | CreateDocumentWithID | Creates a document.
Public method | CreateFolder | Creates a folder after the last folder in the batch.
Public method | CreateFolderWithID | Creates a folder after the last folder in the batch.
Public method | DeleteDocument | Deletes a document and its pages.
Public method | DeleteFolder | Deletes a folder and its documents.
Public method | DeletePage | Deletes a page.
Public method | ImportFile | Imports the specified file.
Public method | ImportFileWithID | Imports the specified file(s).
Top
Properties
 | Name | Description
Public property | ActiveDocument | Gets or sets the currently active document.
Public property | ActiveFolder | Gets or sets the currently active folder.
Public property | ActiveIndexField | Gets or sets the currently active index field.
Public property | ActiveLoosePage | Returns the currently active loose page, if a loose page is selected. Otherwise, returns Nothing.
Public property | ActivePage | Gets or sets the active page (irrespective of it being a loose page or document page).
Public property | AutomaticSeparationAndFormID | Indicates whether automatic separation and form ID is enabled on the batch.
Public property | BatchClass | Returns the Batch Class of this batch.
Public property | BatchEndorsingNumber | Gets or sets the endorsing number. This property is used by endorsing scanners and cannot be set during an event. Endorsing must be enabled for the batch class in order to set this property.
Public property | BatchFields | Returns a list of batch fields contained in the batch.
Public property | BatchGUID | Returns the GUID string that represents the unique batch ID.
Public property | ClassID | Returns the batch class ID.
Public property | ClassName | Returns the batch class name.
Public property | CreateTime | Returns the date and time the batch was created.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Gets or sets the batch description.
Public property | DocumentClasses | Returns the document classes that are supported by the batch as defined by the Tungsten Capture batch class.
Public property | DocumentCount | Returns the total document count.
Public property | Documents | Returns the current set of documents.
Public property | DocumentsPerBatch | Gets or sets the number of documents in a batch.
Public property | ExpectedBatchTotals | Returns a list of the expected batch totals contained in the batch.
Public property | ExternalID | Returns the external batch ID.
Public property | FolderClasses | Gets the folder classes that are supported by the batch as defined by the Tungsten Capture batch class.
Public property | FolderCount | Gets the total folder count of the immediate child folders under the batch (not including indirect child folders of a folder).
Public property | Folders | Gets the current set of immediate folders under the batch (not including indirect child folders of a folder).
Public property | FormTypes | Returns the form types that are supported by the batch as defined by the Tungsten Capture batch class.
Public property | LoosePageCount | Returns the current number of loose pages.
Public property | LoosePages | Returns the current set of loose pages.
Public property | Name | Returns the batch name.
Public property | PagesPerBatch | Gets or sets the number of pages per batch.
Public property | PagesPerDoc | Gets or sets PagesPerDoc. Used by scan to create documents.
Public property | Priority | Gets or sets the batch class priority.
Public property | PublishTime | Returns the date and time the batch class used when the batch was published.
Public property | RowSeparator | Returns the legacy table field delimiter.
Public property | SelectedDocuments | Gets the currently-selected documents
Public property | SelectedFolders | Gets the currently-selected folders
Public property | SelectedPages | Gets the currently-selected pages
Public property | SingleDocProcessing | Indicates whether single document processing is activated for the batch class.
Public property | SupportsAutomaticSeparationAndFormID | Indicates whether automatic separation and form ID can be enabled on the batch.
Public property | SupportsSingleDocProcessing | Indicates whether the batch class supports single document processing.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch Methods

IBatch Methods

The IBatch type exposes the following members.

Methods
 | Name | Description
Public method | CreateDocument | Creates a document.
Public method | CreateDocumentWithID | Creates a document.
Public method | CreateFolder | Creates a folder after the last folder in the batch.
Public method | CreateFolderWithID | Creates a folder after the last folder in the batch.
Public method | DeleteDocument | Deletes a document and its pages.
Public method | DeleteFolder | Deletes a folder and its documents.
Public method | DeletePage | Deletes a page.
Public method | ImportFile | Imports the specified file.
Public method | ImportFileWithID | Imports the specified file(s).
Top
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.CreateDocument Method

IBatchCreateDocument Method

Creates a document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocument CreateDocument(
    ref IDocument oNextDocument = null
)
Function CreateDocument (
    Optional ByRef oNextDocument As IDocument = Nothing
) As IDocument

Parameters

oNextDocument (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
If oNextDocument is Nothing, the new document is the last document. Otherwise, it is inserted before oNextDocument.

Return Value

Type: IDocument
Remarks

The created document does not contain a form type. Does not work in Validation or Verification if Data Entry mode is selected.

See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.CreateDocumentWithID Method

IBatchCreateDocumentWithID Method

Creates a document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocument CreateDocumentWithID(
    string strGUID,
    ref IDocument oNextDocument = null
)
Function CreateDocumentWithID (
    strGUID As String,
    Optional ByRef oNextDocument As IDocument = Nothing
) As IDocument

Parameters

strGUID
Type: SystemString
The document unique ID.
oNextDocument (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
If oNextDocument is Nothing, the new document is the last document. Otherwise, it is inserted before oNextDocument.

Return Value

Type: IDocument
IDocument
Remarks

The created document does not contain a form type. Does not work in Validation or Verification if Data Entry mode is selected.

See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.CreateFolder Method

IBatchCreateFolder Method

Creates a folder after the last folder in the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolder CreateFolder()
Function CreateFolder As IFolder

Return Value

Type: IFolder
IFolder
Remarks
This method does not work in Validation or Verification if Data Entry mode is selected.
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.CreateFolderWithID Method

IBatchCreateFolderWithID Method

Creates a folder after the last folder in the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolder CreateFolderWithID(
    string strGUID
)
Function CreateFolderWithID (
    strGUID As String
) As IFolder

Parameters

strGUID
Type: SystemString
The folder unique ID.

Return Value

Type: IFolder
IFolder
Remarks
This method does not work in Validation or Verification if Data Entry mode is selected.
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.DeleteDocument Method

IBatchDeleteDocument Method

Deletes a document and its pages.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteDocument(
    ref IDocument oDocument
)
Sub DeleteDocument (
    ByRef oDocument As IDocument
)

Parameters

oDocument
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
The document to delete.
Remarks

Does not work in Validation or Verification if Data Entry mode is selected.

See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.DeleteFolder Method

IBatchDeleteFolder Method

Deletes a folder and its documents.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteFolder(
    ref IFolder oFolder
)
Sub DeleteFolder (
    ByRef oFolder As IFolder
)

Parameters

oFolder
Type: Kofax.Capture.CaptureModule.InteropServicesIFolder
The folder to delete.
Remarks
Does not work in Validation or Verification if Data Entry mode is selected.
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.DeletePage Method

IBatchDeletePage Method

Deletes a page.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeletePage(
    ref IPage oPage
)
Sub DeletePage (
    ByRef oPage As IPage
)

Parameters

oPage
Type: Kofax.Capture.CaptureModule.InteropServicesIPage
The page to delete.
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.ImportFile Method

IBatchImportFile Method

Imports the specified file.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPages ImportFile(
    string strFileName
)
Function ImportFile (
    strFileName As String
) As IPages

Parameters

strFileName
Type: SystemString
The file(s) to be imported.

Return Value

Type: IPages
IPages
Remarks

Returns the pages that were created.

Optionally, the user may pass a list of file names for strFileName provided that each file name is enclosed in quotation marks. Passing multiple files to a single ImportFile command may yield significant performance gains (from 30%-100% faster). However, error handling and separation may be more complex for the user to implement in such a case.

Only works in Scan, Quality Control, and customized standard modules, or with import scripts.

See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.ImportFileWithID Method

IBatchImportFileWithID Method

Imports the specified file(s).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPages ImportFileWithID(
    string strFileName,
    string strIDs
)
Function ImportFileWithID (
    strFileName As String,
    strIDs As String
) As IPages

Parameters

strFileName
Type: SystemString
The file(s) to be imported.
strIDs
Type: SystemString
The page ID(s) to be imported.

Return Value

Type: IPages
IPages
Remarks

Returns the pages that were created.

Optionally, the user may pass a list of file names for strFileName provided that each file name is enclosed in quotation marks. Passing multiple files to a single ImportFile command may yield significant performance gains (from 30%-100% faster). However, error handling and separation may be more complex for the user to implement in such a case.

Only works in Scan, Quality Control, and customized standard modules, or with import scripts.

See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch Properties

IBatch Properties

The IBatch type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDocument | Gets or sets the currently active document.
Public property | ActiveFolder | Gets or sets the currently active folder.
Public property | ActiveIndexField | Gets or sets the currently active index field.
Public property | ActiveLoosePage | Returns the currently active loose page, if a loose page is selected. Otherwise, returns Nothing.
Public property | ActivePage | Gets or sets the active page (irrespective of it being a loose page or document page).
Public property | AutomaticSeparationAndFormID | Indicates whether automatic separation and form ID is enabled on the batch.
Public property | BatchClass | Returns the Batch Class of this batch.
Public property | BatchEndorsingNumber | Gets or sets the endorsing number. This property is used by endorsing scanners and cannot be set during an event. Endorsing must be enabled for the batch class in order to set this property.
Public property | BatchFields | Returns a list of batch fields contained in the batch.
Public property | BatchGUID | Returns the GUID string that represents the unique batch ID.
Public property | ClassID | Returns the batch class ID.
Public property | ClassName | Returns the batch class name.
Public property | CreateTime | Returns the date and time the batch was created.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Gets or sets the batch description.
Public property | DocumentClasses | Returns the document classes that are supported by the batch as defined by the Tungsten Capture batch class.
Public property | DocumentCount | Returns the total document count.
Public property | Documents | Returns the current set of documents.
Public property | DocumentsPerBatch | Gets or sets the number of documents in a batch.
Public property | ExpectedBatchTotals | Returns a list of the expected batch totals contained in the batch.
Public property | ExternalID | Returns the external batch ID.
Public property | FolderClasses | Gets the folder classes that are supported by the batch as defined by the Tungsten Capture batch class.
Public property | FolderCount | Gets the total folder count of the immediate child folders under the batch (not including indirect child folders of a folder).
Public property | Folders | Gets the current set of immediate folders under the batch (not including indirect child folders of a folder).
Public property | FormTypes | Returns the form types that are supported by the batch as defined by the Tungsten Capture batch class.
Public property | LoosePageCount | Returns the current number of loose pages.
Public property | LoosePages | Returns the current set of loose pages.
Public property | Name | Returns the batch name.
Public property | PagesPerBatch | Gets or sets the number of pages per batch.
Public property | PagesPerDoc | Gets or sets PagesPerDoc. Used by scan to create documents.
Public property | Priority | Gets or sets the batch class priority.
Public property | PublishTime | Returns the date and time the batch class used when the batch was published.
Public property | RowSeparator | Returns the legacy table field delimiter.
Public property | SelectedDocuments | Gets the currently-selected documents
Public property | SelectedFolders | Gets the currently-selected folders
Public property | SelectedPages | Gets the currently-selected pages
Public property | SingleDocProcessing | Indicates whether single document processing is activated for the batch class.
Public property | SupportsAutomaticSeparationAndFormID | Indicates whether automatic separation and form ID can be enabled on the batch.
Public property | SupportsSingleDocProcessing | Indicates whether the batch class supports single document processing.
Top
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.ActiveDocument Property

IBatchActiveDocument Property

Gets or sets the currently active document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocument ActiveDocument { get; set; }
Property ActiveDocument As IDocument
    Get
    Set

Property Value

Type: IDocument

Return Value

Type: IDocument
IDocument
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.ActiveFolder Property

IBatchActiveFolder Property

Gets or sets the currently active folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolder ActiveFolder { get; set; }
Property ActiveFolder As IFolder
    Get
    Set

Property Value

Type: IFolder

Return Value

Type: IFolder
IFolder
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.ActiveIndexField Property

IBatchActiveIndexField Property

Gets or sets the currently active index field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexField ActiveIndexField { get; set; }
Property ActiveIndexField As IIndexField
    Get
    Set

Property Value

Type: IIndexField

Return Value

Type: IIndexField
IIndexField
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.ActiveLoosePage Property

IBatchActiveLoosePage Property

Returns the currently active loose page, if a loose page is selected. Otherwise, returns Nothing.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPage ActiveLoosePage { get; }
ReadOnly Property ActiveLoosePage As IPage
    Get

Property Value

Type: IPage

Return Value

Type: IPage
IPage
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.ActivePage Property

IBatchActivePage Property

Gets or sets the active page (irrespective of it being a loose page or document page).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPage ActivePage { get; set; }
Property ActivePage As IPage
    Get
    Set

Property Value

Type: IPage

Return Value

Type: IPage
IPage
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.AutomaticSeparationAndFormID Property

IBatchAutomaticSeparationAndFormID Property

Indicates whether automatic separation and form ID is enabled on the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool AutomaticSeparationAndFormID { get; set; }
Property AutomaticSeparationAndFormID As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
Only affects import file.
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.BatchClass Property

IBatchBatchClass Property

Returns the Batch Class of this batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchClass BatchClass { get; }
ReadOnly Property BatchClass As IBatchClass
    Get

Property Value

Type: IBatchClass

Return Value

Type: IBatchClass
IBatchClass
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.BatchEndorsingNumber Property

IBatchBatchEndorsingNumber Property

Gets or sets the endorsing number. This property is used by endorsing scanners and cannot be set during an event. Endorsing must be enabled for the batch class in order to set this property.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int BatchEndorsingNumber { get; set; }
Property BatchEndorsingNumber As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.BatchFields Property

IBatchBatchFields Property

Returns a list of batch fields contained in the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchFields BatchFields { get; }
ReadOnly Property BatchFields As IBatchFields
    Get

Property Value

Type: IBatchFields

Return Value

Type: IBatchFields
IBatchFields
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.BatchGUID Property

IBatchBatchGUID Property

Returns the GUID string that represents the unique batch ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string BatchGUID { get; }
ReadOnly Property BatchGUID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.ClassID Property

IBatchClassID Property

Returns the batch class ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ClassID { get; }
ReadOnly Property ClassID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.ClassName Property

IBatchClassName Property

Returns the batch class name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ClassName { get; }
ReadOnly Property ClassName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.CreateTime Property

IBatchCreateTime Property

Returns the date and time the batch was created.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
DateTime CreateTime { get; }
ReadOnly Property CreateTime As DateTime
    Get

Property Value

Type: DateTime

Return Value

Type: DateTime
Date
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.CustomStorageString Property

IBatchCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the batch class.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific batch. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.Description Property

IBatchDescription Property

Gets or sets the batch description.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; set; }
Property Description As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.DocumentClasses Property

IBatchDocumentClasses Property

Returns the document classes that are supported by the batch as defined by the Tungsten Capture batch class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocumentClasses DocumentClasses { get; }
ReadOnly Property DocumentClasses As IDocumentClasses
    Get

Property Value

Type: IDocumentClasses

Return Value

Type: IDocumentClasses
IDocumentClasses
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.DocumentCount Property

IBatchDocumentCount Property

Returns the total document count.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int DocumentCount { get; }
ReadOnly Property DocumentCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.Documents Property

IBatchDocuments Property

Returns the current set of documents.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocuments Documents { get; }
ReadOnly Property Documents As IDocuments
    Get

Property Value

Type: IDocuments

Return Value

Type: IDocuments
IDocuments
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.DocumentsPerBatch Property

IBatchDocumentsPerBatch Property

Gets or sets the number of documents in a batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int DocumentsPerBatch { get; set; }
Property DocumentsPerBatch As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
This property cannot be set during an event.

Valid values are 0 to 99,999.

See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.ExpectedBatchTotals Property

IBatchExpectedBatchTotals Property

Returns a list of the expected batch totals contained in the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IExpectedBatchTotals ExpectedBatchTotals { get; }
ReadOnly Property ExpectedBatchTotals As IExpectedBatchTotals
    Get

Property Value

Type: IExpectedBatchTotals

Return Value

Type: IExpectedBatchTotals
IExpectedBatchTotals
Remarks
All expected batch total values must be assigned before the batch is closed.
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.ExternalID Property

IBatchExternalID Property

Returns the external batch ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ExternalID { get; }
ReadOnly Property ExternalID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.FolderClasses Property

IBatchFolderClasses Property

Gets the folder classes that are supported by the batch as defined by the Tungsten Capture batch class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolderClasses FolderClasses { get; }
ReadOnly Property FolderClasses As IFolderClasses
    Get

Property Value

Type: IFolderClasses

Return Value

Type: IFolderClasses
IFolderClasses
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.FolderCount Property

IBatchFolderCount Property

Gets the total folder count of the immediate child folders under the batch (not including indirect child folders of a folder).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int FolderCount { get; }
ReadOnly Property FolderCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.Folders Property

IBatchFolders Property

Gets the current set of immediate folders under the batch (not including indirect child folders of a folder).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolders Folders { get; }
ReadOnly Property Folders As IFolders
    Get

Property Value

Type: IFolders

Return Value

Type: IFolders
IFolders
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.FormTypes Property

IBatchFormTypes Property

Returns the form types that are supported by the batch as defined by the Tungsten Capture batch class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFormTypes FormTypes { get; }
ReadOnly Property FormTypes As IFormTypes
    Get

Property Value

Type: IFormTypes

Return Value

Type: IFormTypes
IFormTypes
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.LoosePageCount Property

IBatchLoosePageCount Property

Returns the current number of loose pages.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int LoosePageCount { get; }
ReadOnly Property LoosePageCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.LoosePages Property

IBatchLoosePages Property

Returns the current set of loose pages.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPages LoosePages { get; }
ReadOnly Property LoosePages As IPages
    Get

Property Value

Type: IPages

Return Value

Type: IPages
IPages
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.Name Property

IBatchName Property

Returns the batch name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.PagesPerBatch Property

IBatchPagesPerBatch Property

Gets or sets the number of pages per batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int PagesPerBatch { get; set; }
Property PagesPerBatch As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks

This property cannot be set during an event.

Valid values are 0 to 99,999.

See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.PagesPerDoc Property

IBatchPagesPerDoc Property

Gets or sets PagesPerDoc. Used by scan to create documents.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int PagesPerDoc { get; set; }
Property PagesPerDoc As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
This property cannot be set during an event.

Valid values are 0 to 99,999.

See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.Priority Property

IBatchPriority Property

Gets or sets the batch class priority.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Priority { get; set; }
Property Priority As Integer
    Get
    Set

Property Value

Type: Int32
The Priority of the batch.

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.PublishTime Property

IBatchPublishTime Property

Returns the date and time the batch class used when the batch was published.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
DateTime PublishTime { get; }
ReadOnly Property PublishTime As DateTime
    Get

Property Value

Type: DateTime

Return Value

Type: DateTime
Date
Remarks

This is useful for cross-checking externally saved data. When utilizing batch class data, the user should save the batch class publish time.

After creating a batch, the publish time on the batch should be checked against the stored value. If the values are different, then the batch has been republished, and the user's program should re-verify that all settings are still valid.

See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.RowSeparator Property

IBatchRowSeparator Property

Returns the legacy table field delimiter.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string RowSeparator { get; }
ReadOnly Property RowSeparator As String
    Get

Property Value

Type: String

Return Value

Type: String
Remarks
This is needed for XMLAI.
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.SelectedDocuments Property

IBatchSelectedDocuments Property

Gets the currently-selected documents

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocuments SelectedDocuments { get; }
ReadOnly Property SelectedDocuments As IDocuments
    Get

Return Value

Type: IDocuments
IDocuments
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.SelectedFolders Property

IBatchSelectedFolders Property

Gets the currently-selected folders

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolders SelectedFolders { get; }
ReadOnly Property SelectedFolders As IFolders
    Get

Return Value

Type: IFolders
IFolders
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.SelectedPages Property

IBatchSelectedPages Property

Gets the currently-selected pages

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPages SelectedPages { get; }
ReadOnly Property SelectedPages As IPages
    Get

Return Value

Type: IPages
IPages
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.SingleDocProcessing Property

IBatchSingleDocProcessing Property

Indicates whether single document processing is activated for the batch class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SingleDocProcessing { get; set; }
Property SingleDocProcessing As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.SupportsAutomaticSeparationAndFormID Property

IBatchSupportsAutomaticSeparationAndFormID Property

Indicates whether automatic separation and form ID can be enabled on the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SupportsAutomaticSeparationAndFormID { get; }
ReadOnly Property SupportsAutomaticSeparationAndFormID As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatch.SupportsSingleDocProcessing Property

IBatchSupportsSingleDocProcessing Property

Indicates whether the batch class supports single document processing.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SupportsSingleDocProcessing { get; }
ReadOnly Property SupportsSingleDocProcessing As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchChanges Interface

IBatchChanges Interface

IBatchChanges COM Interface.

Defines information about changes made to a batch in custom modules.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC3A-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IBatchChanges
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC3A-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IBatchChanges

The IBatchChanges type exposes the following members.

Properties
 | Name | Description
Public property | DocumentsAdded | Returns a collection of Document objects that have been added to the batch.
Public property | DocumentsDeleted | Returns a collection of Document IDs that have been deleted from the batch. The ID is a property of the Document object.
Public property | DocumentsModified | Returns a collection of Document objects that have been modified.
Public property | FoldersAdded | Returns a collection of Folder objects that have been added to the batch.
Public property | FoldersDeleted | Returns a collection of Folder IDs that have been deleted from the batch. The ID is a property of the Folder object.
Public property | FoldersModified | Returns a collection of Folder objects that have been modified.
Public property | PagesAdded | Returns a collection of Page objects that have been added to the batch.
Public property | PagesDeleted | Returns a collection of Page IDs that have been deleted from the batch. The ID is a property of the Page object.
Public property | PagesModified | Returns a collection of Page objects that have been modified.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchChanges Properties

IBatchChanges Properties

The IBatchChanges type exposes the following members.

Properties
 | Name | Description
Public property | DocumentsAdded | Returns a collection of Document objects that have been added to the batch.
Public property | DocumentsDeleted | Returns a collection of Document IDs that have been deleted from the batch. The ID is a property of the Document object.
Public property | DocumentsModified | Returns a collection of Document objects that have been modified.
Public property | FoldersAdded | Returns a collection of Folder objects that have been added to the batch.
Public property | FoldersDeleted | Returns a collection of Folder IDs that have been deleted from the batch. The ID is a property of the Folder object.
Public property | FoldersModified | Returns a collection of Folder objects that have been modified.
Public property | PagesAdded | Returns a collection of Page objects that have been added to the batch.
Public property | PagesDeleted | Returns a collection of Page IDs that have been deleted from the batch. The ID is a property of the Page object.
Public property | PagesModified | Returns a collection of Page objects that have been modified.
Top
See Also

Reference

IBatchChanges Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchChanges.DocumentsAdded Property

IBatchChangesDocumentsAdded Property

Returns a collection of Document objects that have been added to the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocuments DocumentsAdded { get; }
ReadOnly Property DocumentsAdded As IDocuments
    Get

Property Value

Type: IDocuments

Return Value

Type: IDocuments
IDocuments
Remarks
See Also

Reference

IBatchChanges Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchChanges.DocumentsDeleted Property

IBatchChangesDocumentsDeleted Property

Returns a collection of Document IDs that have been deleted from the batch. The ID is a property of the Document object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IObjectIDs DocumentsDeleted { get; }
ReadOnly Property DocumentsDeleted As IObjectIDs
    Get

Property Value

Type: IObjectIDs

Return Value

Type: IObjectIDs
IObjectIDs
Remarks
See Also

Reference

IBatchChanges Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchChanges.DocumentsModified Property

IBatchChangesDocumentsModified Property

Returns a collection of Document objects that have been modified.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocuments DocumentsModified { get; }
ReadOnly Property DocumentsModified As IDocuments
    Get

Property Value

Type: IDocuments

Return Value

Type: IDocuments
IDocuments
Remarks
See Also

Reference

IBatchChanges Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchChanges.FoldersAdded Property

IBatchChangesFoldersAdded Property

Returns a collection of Folder objects that have been added to the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolders FoldersAdded { get; }
ReadOnly Property FoldersAdded As IFolders
    Get

Property Value

Type: IFolders

Return Value

Type: IFolders
IFolders
Remarks
See Also

Reference

IBatchChanges Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchChanges.FoldersDeleted Property

IBatchChangesFoldersDeleted Property

Returns a collection of Folder IDs that have been deleted from the batch. The ID is a property of the Folder object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IObjectIDs FoldersDeleted { get; }
ReadOnly Property FoldersDeleted As IObjectIDs
    Get

Property Value

Type: IObjectIDs

Return Value

Type: IObjectIDs
IObjectIDs
Remarks
See Also

Reference

IBatchChanges Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchChanges.FoldersModified Property

IBatchChangesFoldersModified Property

Returns a collection of Folder objects that have been modified.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolders FoldersModified { get; }
ReadOnly Property FoldersModified As IFolders
    Get

Property Value

Type: IFolders

Return Value

Type: IFolders
IFolders
Remarks
See Also

Reference

IBatchChanges Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchChanges.PagesAdded Property

IBatchChangesPagesAdded Property

Returns a collection of Page objects that have been added to the batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPages PagesAdded { get; }
ReadOnly Property PagesAdded As IPages
    Get

Property Value

Type: IPages

Return Value

Type: IPages
IPages
Remarks
See Also

Reference

IBatchChanges Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchChanges.PagesDeleted Property

IBatchChangesPagesDeleted Property

Returns a collection of Page IDs that have been deleted from the batch. The ID is a property of the Page object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IObjectIDs PagesDeleted { get; }
ReadOnly Property PagesDeleted As IObjectIDs
    Get

Property Value

Type: IObjectIDs

Return Value

Type: IObjectIDs
IObjectIDs
Remarks
See Also

Reference

IBatchChanges Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchChanges.PagesModified Property

IBatchChangesPagesModified Property

Returns a collection of Page objects that have been modified.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPages PagesModified { get; }
ReadOnly Property PagesModified As IPages
    Get

Property Value

Type: IPages

Return Value

Type: IPages
IPages
Remarks
See Also

Reference

IBatchChanges Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchClass Interface

IBatchClass Interface

IBatchClass COM Interface.

Defines a COM object that refers to a batch class published by Tungsten Capture.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC3C-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IBatchClass
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC3C-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IBatchClass

The IBatchClass type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The batch class storage string with the specified name.
Public property | Description | Returns the description of the batch class.
Public property | Name | Returns the unique name of the batch class.
Public property | PublishTime | Returns the date and time the batch class was published.
Public property | XmlFile | Returns the path and filename of the file that contains the entire batch class setup in XML format.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchClass Properties

IBatchClass Properties

The IBatchClass type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The batch class storage string with the specified name.
Public property | Description | Returns the description of the batch class.
Public property | Name | Returns the unique name of the batch class.
Public property | PublishTime | Returns the date and time the batch class was published.
Public property | XmlFile | Returns the path and filename of the file that contains the entire batch class setup in XML format.
Top
See Also

Reference

IBatchClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchClass.CustomStorageString Property

IBatchClassCustomStorageString Property

The batch class storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; }
ReadOnly Property CustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the batch class. Strings stored by one component can be read by another. If set to an empty string, the storage string is deleted.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific batch class. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IBatchClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchClass.Description Property

IBatchClassDescription Property

Returns the description of the batch class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String
See Also

Reference

IBatchClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchClass.Name Property

IBatchClassName Property

Returns the unique name of the batch class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchClass.PublishTime Property

IBatchClassPublishTime Property

Returns the date and time the batch class was published.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
DateTime PublishTime { get; }
ReadOnly Property PublishTime As DateTime
    Get

Property Value

Type: DateTime

Return Value

Type: DateTime
Date
See Also

Reference

IBatchClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchClass.XmlFile Property

IBatchClassXmlFile Property

Returns the path and filename of the file that contains the entire batch class setup in XML format.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string XmlFile { get; }
ReadOnly Property XmlFile As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchClasses Interface

IBatchClasses Interface

IBatchClasses COM Interface.

Defines a COM collection of published batch class objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC3E-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IBatchClasses
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC3E-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IBatchClasses

The IBatchClasses type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of batch classes contained in the collection.
Public property | Item | Returns a collection element given a key.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchClasses Methods

IBatchClasses Methods

The IBatchClasses type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IBatchClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchClasses.GetEnumerator Method

IBatchClassesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IBatchClasses object.
See Also

Reference

IBatchClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchClasses Properties

IBatchClasses Properties

The IBatchClasses type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of batch classes contained in the collection.
Public property | Item | Returns a collection element given a key.
Top
See Also

Reference

IBatchClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchClasses.Count Property

IBatchClassesCount Property

Returns the number of batch classes contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatchClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchClasses.Item Property

IBatchClassesItem Property

Returns a collection element given a key.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchClass this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IBatchClass
    Get

Parameters

vntIndexKey
Type: SystemObject
Index can either be a batch class name or a numeric one-based index into the collection.

Property Value

Type: IBatchClass

Return Value

Type: IBatchClass
IBatchClass
See Also

Reference

IBatchClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField Interface

IBatchField Interface

IBatchField COM Interface.

Defines a COM object that contains a value associated with a batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC40-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IBatchField
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC40-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IBatchField

The IBatchField type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Returns the default value for the batch field.
Public property | Description | Gets the description of the associated field type.
Public property | DisplayLabel | Gets or sets the value of a supported batch field display label.
Public property | Hidden | Returns True if the field is not displayed.
Public property | Length | Gets the length of a non-numeric batch field.
Public property | Name | Returns the name of the batch field.
Public property | Numeric | Returns True if the field is numeric.
Public property | NumericPrecision | Returns the number of decimal places of a numeric batch field.
Public property | NumericScale | Returns the number of digits, including decimals, of a numeric batch field.
Public property | OrderNumber | Gets the order of the field within the set of batch fields.
Public property | Required | Returns True if the field is required.
Public property | SqlType | Returns the data type of the batch field.
Public property | SuggestedValueCount | Returns the number of suggested values.
Public property | SuggestedValues | Returns the list of suggested values.
Public property | SuggestedValuesForceMatch | Gets or sets the Suggested Values Force Match flag. If True, the value must be one of the suggested values or an error will occur when the batch is closed.
Public property | SuggestedValuesForceMatchCaseSensitive | Gets or sets the Suggested Values Force Match Case Sensitive flag. If True, a force-matched value must match with regard to upper and lower case.
Public property | TypeCustomStorageString | The storage string with the specified name.
Public property | TypeName | Gets the name of the Tungsten Capture field type that is associated with the batch field.
Public property | UserChanged | Marks the field as changed by the user.
Public property | Value | Gets or sets the value of the batch field. By default, contains batch field default value if it exists, otherwise, it is empty.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField Properties

IBatchField Properties

The IBatchField type exposes the following members.

Properties
 | Name | Description
Public property | DefaultValue | Returns the default value for the batch field.
Public property | Description | Gets the description of the associated field type.
Public property | DisplayLabel | Gets or sets the value of a supported batch field display label.
Public property | Hidden | Returns True if the field is not displayed.
Public property | Length | Gets the length of a non-numeric batch field.
Public property | Name | Returns the name of the batch field.
Public property | Numeric | Returns True if the field is numeric.
Public property | NumericPrecision | Returns the number of decimal places of a numeric batch field.
Public property | NumericScale | Returns the number of digits, including decimals, of a numeric batch field.
Public property | OrderNumber | Gets the order of the field within the set of batch fields.
Public property | Required | Returns True if the field is required.
Public property | SqlType | Returns the data type of the batch field.
Public property | SuggestedValueCount | Returns the number of suggested values.
Public property | SuggestedValues | Returns the list of suggested values.
Public property | SuggestedValuesForceMatch | Gets or sets the Suggested Values Force Match flag. If True, the value must be one of the suggested values or an error will occur when the batch is closed.
Public property | SuggestedValuesForceMatchCaseSensitive | Gets or sets the Suggested Values Force Match Case Sensitive flag. If True, a force-matched value must match with regard to upper and lower case.
Public property | TypeCustomStorageString | The storage string with the specified name.
Public property | TypeName | Gets the name of the Tungsten Capture field type that is associated with the batch field.
Public property | UserChanged | Marks the field as changed by the user.
Public property | Value | Gets or sets the value of the batch field. By default, contains batch field default value if it exists, otherwise, it is empty.
Top
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.DefaultValue Property

IBatchFieldDefaultValue Property

Returns the default value for the batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string DefaultValue { get; }
ReadOnly Property DefaultValue As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.Description Property

IBatchFieldDescription Property

Gets the description of the associated field type.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.DisplayLabel Property

IBatchFieldDisplayLabel Property

Gets or sets the value of a supported batch field display label.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string DisplayLabel { get; }
ReadOnly Property DisplayLabel As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.Hidden Property

IBatchFieldHidden Property

Returns True if the field is not displayed.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Hidden { get; }
ReadOnly Property Hidden As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.Length Property

IBatchFieldLength Property

Gets the length of a non-numeric batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.Name Property

IBatchFieldName Property

Returns the name of the batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.Numeric Property

IBatchFieldNumeric Property

Returns True if the field is numeric.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Numeric { get; }
ReadOnly Property Numeric As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.NumericPrecision Property

IBatchFieldNumericPrecision Property

Returns the number of decimal places of a numeric batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int NumericPrecision { get; }
ReadOnly Property NumericPrecision As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.NumericScale Property

IBatchFieldNumericScale Property

Returns the number of digits, including decimals, of a numeric batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int NumericScale { get; }
ReadOnly Property NumericScale As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.OrderNumber Property

IBatchFieldOrderNumber Property

Gets the order of the field within the set of batch fields.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int OrderNumber { get; }
ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.Required Property

IBatchFieldRequired Property

Returns True if the field is required.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Required { get; }
ReadOnly Property Required As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.SqlType Property

IBatchFieldSqlType Property

Returns the data type of the batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int SqlType { get; }
ReadOnly Property SqlType As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.SuggestedValueCount Property

IBatchFieldSuggestedValueCount Property

Returns the number of suggested values.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int SuggestedValueCount { get; }
ReadOnly Property SuggestedValueCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.SuggestedValues Property

IBatchFieldSuggestedValues Property

Returns the list of suggested values.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ISuggestedValues SuggestedValues { get; }
ReadOnly Property SuggestedValues As ISuggestedValues
    Get

Property Value

Type: ISuggestedValues

Return Value

Type: ISuggestedValues
ISuggestedValues
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.SuggestedValuesForceMatch Property

IBatchFieldSuggestedValuesForceMatch Property

Gets or sets the Suggested Values Force Match flag. If True, the value must be one of the suggested values or an error will occur when the batch is closed.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SuggestedValuesForceMatch { get; set; }
Property SuggestedValuesForceMatch As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.SuggestedValuesForceMatchCaseSensitive Property

IBatchFieldSuggestedValuesForceMatchCaseSensitive Property

Gets or sets the Suggested Values Force Match Case Sensitive flag. If True, a force-matched value must match with regard to upper and lower case.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SuggestedValuesForceMatchCaseSensitive { get; }
ReadOnly Property SuggestedValuesForceMatchCaseSensitive As Boolean
    Get

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.TypeCustomStorageString Property

IBatchFieldTypeCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; }
ReadOnly Property TypeCustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString

The storage string name does not need to match the name of the batch class.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific field type. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.TypeName Property

IBatchFieldTypeName Property

Gets the name of the Tungsten Capture field type that is associated with the batch field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string TypeName { get; }
ReadOnly Property TypeName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.UserChanged Property

IBatchFieldUserChanged Property
Marks the field as changed by the user.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool UserChanged { get; set; }
Property UserChanged As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Remarks
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchField.Value Property

IBatchFieldValue Property

Gets or sets the value of the batch field. By default, contains batch field default value if it exists, otherwise, it is empty.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Value { get; set; }
Property Value As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
See Also

Reference

IBatchField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchFields Interface

IBatchFields Interface

IBatchFields COM Interface.

Defines a COM collection of BatchField objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC42-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IBatchFields
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC42-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IBatchFields

The IBatchFields type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of BatchField objects contained in the collection.
Public property | Item | Returns a collection element given a key.
Top
Remarks
A BatchFields object is valid as long as the parent batch is open.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchFields Methods

IBatchFields Methods

The IBatchFields type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IBatchFields Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchFields.GetEnumerator Method

IBatchFieldsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IBatchFields object.
See Also

Reference

IBatchFields Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchFields Properties

IBatchFields Properties

The IBatchFields type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of BatchField objects contained in the collection.
Public property | Item | Returns a collection element given a key.
Top
See Also

Reference

IBatchFields Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchFields.Count Property

IBatchFieldsCount Property

Returns the number of BatchField objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatchFields Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchFields.Item Property

IBatchFieldsItem Property

Returns a collection element given a key.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchField this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IBatchField
    Get

Parameters

vntIndexKey
Type: SystemObject
Index can either be a form type name or a numeric one-based index into the collection.

Property Value

Type: IBatchField

Return Value

Type: IBatchField
IBatchField
See Also

Reference

IBatchFields Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchNameCreator Interface

IBatchNameCreator Interface

IBatchNameCreator COM Interface.

Defines a COM object that allows an OCX to generate its own batch name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC44-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IBatchNameCreator
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC44-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IBatchNameCreator

The IBatchNameCreator type exposes the following members.

Properties
 | Name | Description
Public property | BatchClass | Returns the batch class associated with the batch being created.
Public property | BatchName | Gets or sets the batch name initially generated by Tungsten Capture. This property can also be used to set the name of the batch being created.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchNameCreator Properties

IBatchNameCreator Properties

The IBatchNameCreator type exposes the following members.

Properties
 | Name | Description
Public property | BatchClass | Returns the batch class associated with the batch being created.
Public property | BatchName | Gets or sets the batch name initially generated by Tungsten Capture. This property can also be used to set the name of the batch being created.
Top
See Also

Reference

IBatchNameCreator Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchNameCreator.BatchClass Property

IBatchNameCreatorBatchClass Property

Returns the batch class associated with the batch being created.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchClass BatchClass { get; }
ReadOnly Property BatchClass As IBatchClass
    Get

Property Value

Type: IBatchClass

Return Value

Type: IBatchClass
IBatchClass
Remarks
See Also

Reference

IBatchNameCreator Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IBatchNameCreator.BatchName Property

IBatchNameCreatorBatchName Property

Gets or sets the batch name initially generated by Tungsten Capture. This property can also be used to set the name of the batch being created.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string BatchName { get; set; }
Property BatchName As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchNameCreator Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ICustomProperties Interface

ICustomProperties Interface

ICustomProperties COM Interface.

Defines a COM collection of CustomProperty objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC46-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ICustomProperties
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC46-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ICustomProperties

The ICustomProperties type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of CustomProperties objects contained in the collection.
Public property | Item | Returns the CustomProperties object by order number or assignment name.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ICustomProperties Methods

ICustomProperties Methods

The ICustomProperties type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

ICustomProperties Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ICustomProperties.GetEnumerator Method

ICustomPropertiesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.ICustomProperties object.
See Also

Reference

ICustomProperties Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ICustomProperties Properties

ICustomProperties Properties

The ICustomProperties type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of CustomProperties objects contained in the collection.
Public property | Item | Returns the CustomProperties object by order number or assignment name.
Top
See Also

Reference

ICustomProperties Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ICustomProperties.Count Property

ICustomPropertiesCount Property

Returns the number of CustomProperties objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ICustomProperties Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ICustomProperties.Item Property

ICustomPropertiesItem Property

Returns the CustomProperties object by order number or assignment name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ICustomProperty this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As ICustomProperty
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: ICustomProperty

Return Value

Type: ICustomProperty
ICustomProperty
Remarks
See Also

Reference

ICustomProperties Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ICustomProperty Interface

ICustomProperty Interface

ICustomProperty COM Interface.

Defines information about custom properties.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC48-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ICustomProperty
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC48-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ICustomProperty

The ICustomProperty type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the custom property entry.
Public property | OrderNumber | Returns the order number of the property.
Public property | Value | Gets or sets the custom property value.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ICustomProperty Properties

ICustomProperty Properties

The ICustomProperty type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the custom property entry.
Public property | OrderNumber | Returns the order number of the property.
Public property | Value | Gets or sets the custom property value.
Top
See Also

Reference

ICustomProperty Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ICustomProperty.Name Property

ICustomPropertyName Property

Returns the name of the custom property entry.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

ICustomProperty Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ICustomProperty.OrderNumber Property

ICustomPropertyOrderNumber Property

Returns the order number of the property.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int OrderNumber { get; }
ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ICustomProperty Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ICustomProperty.Value Property

ICustomPropertyValue Property

Gets or sets the custom property value.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Value { get; set; }
Property Value As String
    Get
    Set

Property Value

Type: String
The custom property value.

Return Value

Type: String
String
Remarks
This property can be up to 65,536 characters.
See Also

Reference

ICustomProperty Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument Interface

IDocument Interface

IDocument COM Interface.

Defines information about the currently opened document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC4A-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IDocument
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC4A-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IDocument

The IDocument type exposes the following members.

Methods
 | Name | Description
Public method | MoveToBatch | Moves this document to a batch.
Public method | MoveToFolder | Moves this document to a folder.
Public method | RunValidationPlugin | Executes a validation plug-in, such as database validation.
Public method | UpdateCustomStorageStrings | Updates custom storage strings.
Top
Properties
 | Name | Description
Public property | ActiveIndexField | Returns the currently active index field in the document.
Public property | ActivePage | Returns the currently active page in the document.
Public property | AsnReleaseScripts | Gets the list of assigned export connectors.
Public property | AutoIndexed | True sets a document as auto-indexed. The document is skipped while auto-indexing the Recognition Server.
Public property | Batch | Returns the parent batch in which the document resides.
Public property | BatchDocGUID | Returns the Document unique ID.
Public property | Caption | Gets or sets the document label. This value is displayed in the tree view.
Public property | ClassID | Returns the document class ID.
Public property | ClassName | Returns the document class name.
Public property | CustomProperties | Returns the custom property collection for the document class.
Public property | CustomPropertyCount | Returns the number of custom properties for the document class.
Public property | CustomStorageString | The document storage string with the specified name.
Public property | Folder | Returns the parent folder in which the document resides. Nothing is returned if the document is the direct child of a batch.
Public property | FormIDConfidence | Gets the form identification confidence. This is filled in by the Recognition Server if automatic form identification is enabled.
Public property | FormIDDifference | Gets the difference between the form identification confidence and the confidence of the next best match. This is filled in by the Recognition Server if automatic form identification is enabled.
Public property | FormName | Returns the document form type name.
Public property | FormType | Gets or sets the document form type. Set this property to Nothing to assign no form type to a document.
Public property | ID | Returns the internal Document ID set by the data source (internal database).
Public property | IndexFieldCount | Returns the number of index fields in the document.
Public property | IndexFields | Returns the collection of index fields in the document.
Public property | Note | Gets or sets the document note.
Public property | OrderNumber | The document order number within the batch (if the current document is a direct child of a batch) or folder (if the parent is a folder).
Public property | PageCount | Returns the number of pages in the document.
Public property | Pages | Returns the collection of pages in the document.
Public property | Rejected | Gets or sets the document rejected flag.
Public property | Tables | Returns a collection of Table objects, corresponding to the tables in this document.
Public property | UniqueID | Returns the document unique ID. This ID is unique across all batches.
Public property | Validated | Gets or sets the document validated flag. True sets a document as validated. This document is skipped in the Validation module.
Public property | Verified | Gets or sets the document verified flag. True sets a document as verified. This document is skipped in the Verification module.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument Methods

IDocument Methods

The IDocument type exposes the following members.

Methods
 | Name | Description
Public method | MoveToBatch | Moves this document to a batch.
Public method | MoveToFolder | Moves this document to a folder.
Public method | RunValidationPlugin | Executes a validation plug-in, such as database validation.
Public method | UpdateCustomStorageStrings | Updates custom storage strings.
Top
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.MoveToBatch Method

IDocumentMoveToBatch Method

Moves this document to a batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void MoveToBatch(
    ref IDocument oNextDocument = null
)
Sub MoveToBatch (
    Optional ByRef oNextDocument As IDocument = Nothing
)

Parameters

oNextDocument (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
The moved document will be inserted before the document specified by this parameter. The document will be moved to the end of the batch (before folders) if this parameter is not specified.
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.MoveToFolder Method

IDocumentMoveToFolder Method

Moves this document to a folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void MoveToFolder(
    ref IFolder oFolder,
    ref IDocument oNextDocument = null
)
Sub MoveToFolder (
    ByRef oFolder As IFolder,
    Optional ByRef oNextDocument As IDocument = Nothing
)

Parameters

oFolder
Type: Kofax.Capture.CaptureModule.InteropServicesIFolder
The parent folder.
oNextDocument (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
The moved document will be inserted before the document specified by this parameter. The document will be moved to the end of the document list if this parameter is not specified.
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.RunValidationPlugin Method

IDocumentRunValidationPlugin Method

Executes a validation plug-in, such as database validation.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string RunValidationPlugin(
    string strName,
    string strParam = ""
)
Function RunValidationPlugin (
    strName As String,
    Optional strParam As String = ""
) As String

Parameters

strName
Type: SystemString
Specify the name of the plug-in to execute.
strParam (Optional)
Type: SystemString
Reserved.

Return Value

Type: String
String - The results are defined by the plug-in. For a database validation, the results are an XML string representing the record set returned by the validation.
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.UpdateCustomStorageStrings Method

IDocumentUpdateCustomStorageStrings Method

Updates custom storage strings.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void UpdateCustomStorageStrings(
    IBulkUpdateDataColl oData
)
Sub UpdateCustomStorageStrings (
    oData As IBulkUpdateDataColl
)

Parameters

oData
Type: Kofax.Capture.SDK.DataIBulkUpdateDataColl
Dictionary of key-value.
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument Properties

IDocument Properties

The IDocument type exposes the following members.

Properties
 | Name | Description
Public property | ActiveIndexField | Returns the currently active index field in the document.
Public property | ActivePage | Returns the currently active page in the document.
Public property | AsnReleaseScripts | Gets the list of assigned export connectors.
Public property | AutoIndexed | True sets a document as auto-indexed. The document is skipped while auto-indexing the Recognition Server.
Public property | Batch | Returns the parent batch in which the document resides.
Public property | BatchDocGUID | Returns the Document unique ID.
Public property | Caption | Gets or sets the document label. This value is displayed in the tree view.
Public property | ClassID | Returns the document class ID.
Public property | ClassName | Returns the document class name.
Public property | CustomProperties | Returns the custom property collection for the document class.
Public property | CustomPropertyCount | Returns the number of custom properties for the document class.
Public property | CustomStorageString | The document storage string with the specified name.
Public property | Folder | Returns the parent folder in which the document resides. Nothing is returned if the document is the direct child of a batch.
Public property | FormIDConfidence | Gets the form identification confidence. This is filled in by the Recognition Server if automatic form identification is enabled.
Public property | FormIDDifference | Gets the difference between the form identification confidence and the confidence of the next best match. This is filled in by the Recognition Server if automatic form identification is enabled.
Public property | FormName | Returns the document form type name.
Public property | FormType | Gets or sets the document form type. Set this property to Nothing to assign no form type to a document.
Public property | ID | Returns the internal Document ID set by the data source (internal database).
Public property | IndexFieldCount | Returns the number of index fields in the document.
Public property | IndexFields | Returns the collection of index fields in the document.
Public property | Note | Gets or sets the document note.
Public property | OrderNumber | The document order number within the batch (if the current document is a direct child of a batch) or folder (if the parent is a folder).
Public property | PageCount | Returns the number of pages in the document.
Public property | Pages | Returns the collection of pages in the document.
Public property | Rejected | Gets or sets the document rejected flag.
Public property | Tables | Returns a collection of Table objects, corresponding to the tables in this document.
Public property | UniqueID | Returns the document unique ID. This ID is unique across all batches.
Public property | Validated | Gets or sets the document validated flag. True sets a document as validated. This document is skipped in the Validation module.
Public property | Verified | Gets or sets the document verified flag. True sets a document as verified. This document is skipped in the Verification module.
Top
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.ActiveIndexField Property

IDocumentActiveIndexField Property

Returns the currently active index field in the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexField ActiveIndexField { get; }
ReadOnly Property ActiveIndexField As IIndexField
    Get

Property Value

Type: IIndexField

Return Value

Type: IIndexField
IIndexField
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.ActivePage Property

IDocumentActivePage Property

Returns the currently active page in the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPage ActivePage { get; }
ReadOnly Property ActivePage As IPage
    Get

Property Value

Type: IPage

Return Value

Type: IPage
IPage
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.AsnReleaseScripts Property

IDocumentAsnReleaseScripts Property

Gets the list of assigned export connectors.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IAsnReleaseScripts AsnReleaseScripts { get; }
ReadOnly Property AsnReleaseScripts As IAsnReleaseScripts
    Get

Property Value

Type: IAsnReleaseScripts

Return Value

Type: IAsnReleaseScripts
IAsnReleaseScripts
Remarks
Use this collection to get the custom properties.
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.AutoIndexed Property

IDocumentAutoIndexed Property

True sets a document as auto-indexed. The document is skipped while auto-indexing the Recognition Server.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool AutoIndexed { get; set; }
Property AutoIndexed As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

False clears the auto-indexed state.

This property is somewhat slower than Verified or Validated.

See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.Batch Property

IDocumentBatch Property

Returns the parent batch in which the document resides.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch Batch { get; }
ReadOnly Property Batch As IBatch
    Get

Property Value

Type: IBatch

Return Value

Type: IBatch
IBatch
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.BatchDocGUID Property

IDocumentBatchDocGUID Property

Returns the Document unique ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string BatchDocGUID { get; }
ReadOnly Property BatchDocGUID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.Caption Property

IDocumentCaption Property

Gets or sets the document label. This value is displayed in the tree view.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Caption { get; set; }
Property Caption As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
Remarks
The default value is the form type name.
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.ClassID Property

IDocumentClassID Property

Returns the document class ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ClassID { get; }
ReadOnly Property ClassID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.ClassName Property

IDocumentClassName Property

Returns the document class name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ClassName { get; }
ReadOnly Property ClassName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.CustomProperties Property

IDocumentCustomProperties Property

Returns the custom property collection for the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ICustomProperties CustomProperties { get; }
ReadOnly Property CustomProperties As ICustomProperties
    Get

Property Value

Type: ICustomProperties

Return Value

Type: ICustomProperties
ICustomProperties
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.CustomPropertyCount Property

IDocumentCustomPropertyCount Property

Returns the number of custom properties for the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int CustomPropertyCount { get; }
ReadOnly Property CustomPropertyCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.CustomStorageString Property

IDocumentCustomStorageString Property

The document storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the document. Strings stored by one component can be read by another. If set to an empty string, the storage string is deleted.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific document. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.Folder Property

IDocumentFolder Property

Returns the parent folder in which the document resides. Nothing is returned if the document is the direct child of a batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolder Folder { get; }
ReadOnly Property Folder As IFolder
    Get

Property Value

Type: IFolder

Return Value

Type: IFolder
IFolder
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.FormIDConfidence Property

IDocumentFormIDConfidence Property

Gets the form identification confidence. This is filled in by the Recognition Server if automatic form identification is enabled.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int FormIDConfidence { get; }
ReadOnly Property FormIDConfidence As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.FormIDDifference Property

IDocumentFormIDDifference Property

Gets the difference between the form identification confidence and the confidence of the next best match. This is filled in by the Recognition Server if automatic form identification is enabled.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int FormIDDifference { get; }
ReadOnly Property FormIDDifference As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.FormName Property

IDocumentFormName Property

Returns the document form type name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string FormName { get; }
ReadOnly Property FormName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.FormType Property

IDocumentFormType Property

Gets or sets the document form type. Set this property to Nothing to assign no form type to a document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFormType FormType { get; set; }
Property FormType As IFormType
    Get
    Set

Property Value

Type: IFormType

Return Value

Type: IFormType
IFormType
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.ID Property

IDocumentID Property

Returns the internal Document ID set by the data source (internal database).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ID { get; }
ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.IndexFieldCount Property

IDocumentIndexFieldCount Property

Returns the number of index fields in the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int IndexFieldCount { get; }
ReadOnly Property IndexFieldCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.IndexFields Property

IDocumentIndexFields Property

Returns the collection of index fields in the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexFields IndexFields { get; }
ReadOnly Property IndexFields As IIndexFields
    Get

Property Value

Type: IIndexFields

Return Value

Type: IIndexFields
IIndexFields
Remarks

Returns the list of IndexField objects for this document. This list includes single-value fields and table fields, in the order specified in the document class properties. Note that while table fields are included in this collection, tables themselves are not.

See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.Note Property

IDocumentNote Property

Gets or sets the document note.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Note { get; set; }
Property Note As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.OrderNumber Property

IDocumentOrderNumber Property

The document order number within the batch (if the current document is a direct child of a batch) or folder (if the parent is a folder).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int OrderNumber { get; }
ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.PageCount Property

IDocumentPageCount Property

Returns the number of pages in the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int PageCount { get; }
ReadOnly Property PageCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.Pages Property

IDocumentPages Property

Returns the collection of pages in the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPages Pages { get; }
ReadOnly Property Pages As IPages
    Get

Property Value

Type: IPages

Return Value

Type: IPages
IPages
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.Rejected Property

IDocumentRejected Property

Gets or sets the document rejected flag.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Rejected { get; set; }
Property Rejected As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Remarks
Returns True if the document is rejected.
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.Tables Property

IDocumentTables Property

Returns a collection of Table objects, corresponding to the tables in this document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ITables Tables { get; }
ReadOnly Property Tables As ITables
    Get

Property Value

Type: ITables

Return Value

Type: ITables
ITables
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.UniqueID Property

IDocumentUniqueID Property

Returns the document unique ID. This ID is unique across all batches.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int UniqueID { get; }
ReadOnly Property UniqueID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.Validated Property

IDocumentValidated Property

Gets or sets the document validated flag. True sets a document as validated. This document is skipped in the Validation module.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Validated { get; set; }
Property Validated As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

False clears the validated state. The document is not skipped in the Validation module.

Clearing this flag does not cause the associated fields to be reprocessed in the Recognition Server.

See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocument.Verified Property

IDocumentVerified Property

Gets or sets the document verified flag. True sets a document as verified. This document is skipped in the Verification module.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Verified { get; set; }
Property Verified As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

False clears the verified state. The document is not skipped in the Validation module.

Clearing this flag does not cause the associated fields to be reprocessed in the Recognition Server.

See Also

Reference

IDocument Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocumentClass Interface

IDocumentClass Interface

IDocumentClass COM Interface.

Defines a COM object that refers to a Tungsten Capture document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC4C-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IDocumentClass
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC4C-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IDocumentClass

The IDocumentClass type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name for the document class.
Public property | Description | Gets the description of the document class.
Public property | FormTypes | Gets the form types that are supported by the document class.
Public property | Name | Gets the unique name of the document class.
Public property | TableDefinitions | Returns a collection of TableDefinition objects, corresponding to the tables defined in this document class.
Top
Remarks
A DocumentClass object is valid as long as its parent batch is open.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IDocumentClass Properties

IDocumentClass Properties

The IDocumentClass type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name for the document class.
Public property | Description | Gets the description of the document class.
Public property | FormTypes | Gets the form types that are supported by the document class.
Public property | Name | Gets the unique name of the document class.
Public property | TableDefinitions | Returns a collection of TableDefinition objects, corresponding to the tables defined in this document class.
Top
See Also

Reference

IDocumentClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocumentClass.CustomStorageString Property

IDocumentClassCustomStorageString Property

The storage string with the specified name for the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; }
ReadOnly Property CustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the document class.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific document class. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IDocumentClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocumentClass.Description Property

IDocumentClassDescription Property

Gets the description of the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocumentClass.FormTypes Property

IDocumentClassFormTypes Property

Gets the form types that are supported by the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFormTypes FormTypes { get; }
ReadOnly Property FormTypes As IFormTypes
    Get

Property Value

Type: IFormTypes

Return Value

Type: IFormTypes
IFormTypes
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocumentClass.Name Property

IDocumentClassName Property

Gets the unique name of the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocumentClass.TableDefinitions Property

IDocumentClassTableDefinitions Property

Returns a collection of TableDefinition objects, corresponding to the tables defined in this document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ITableDefinitions TableDefinitions { get; }
ReadOnly Property TableDefinitions As ITableDefinitions
    Get

Property Value

Type: ITableDefinitions

Return Value

Type: ITableDefinitions
ITableDefinitions
Remarks
See Also

Reference

IDocumentClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocumentClasses Interface

IDocumentClasses Interface

IDocumentClasses COM Interface.

Defines a COM collection of DocumentClass objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC4E-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IDocumentClasses
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC4E-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IDocumentClasses

The IDocumentClasses type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of DocumentClass objects contained in the collection.
Public property | Item | Returns the specified DocumentClass object.
Top
Remarks
A DocumentClasses object is valid as long as its parent batch is open.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IDocumentClasses Methods

IDocumentClasses Methods

The IDocumentClasses type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IDocumentClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocumentClasses.GetEnumerator Method

IDocumentClassesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IDocumentClasses object.
See Also

Reference

IDocumentClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocumentClasses Properties

IDocumentClasses Properties

The IDocumentClasses type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of DocumentClass objects contained in the collection.
Public property | Item | Returns the specified DocumentClass object.
Top
See Also

Reference

IDocumentClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocumentClasses.Count Property

IDocumentClassesCount Property

Returns the number of DocumentClass objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IDocumentClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocumentClasses.Item Property

IDocumentClassesItem Property

Returns the specified DocumentClass object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocumentClass this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IDocumentClass
    Get

Parameters

vntIndexKey
Type: SystemObject
Index can either be a document class name or a numeric one-based index into the collection.

Property Value

Type: IDocumentClass

Return Value

Type: IDocumentClass
IDocumentClass
See Also

Reference

IDocumentClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocuments Interface

IDocuments Interface

IDocuments COM Interface.

Defines a COM collection of Document objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC50-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IDocuments
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC50-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IDocuments

The IDocuments type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of Document objects contained in the collection.
Public property | Item | Returns the specified Document object.
Top
Remarks

Iteration and extraction by order number (with the item function) is supported. Passing an out-of-range or invalid parameter to the item function causes it to throw the error "Invalid Parameter" to the caller.

The Documents's object is invalidated when the current batch is closed.

See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IDocuments Methods

IDocuments Methods

The IDocuments type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IDocuments Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocuments.GetEnumerator Method

IDocumentsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IDocuments object.
See Also

Reference

IDocuments Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocuments Properties

IDocuments Properties

The IDocuments type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of Document objects contained in the collection.
Public property | Item | Returns the specified Document object.
Top
See Also

Reference

IDocuments Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocuments.Count Property

IDocumentsCount Property

Returns the number of Document objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IDocuments Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IDocuments.Item Property

IDocumentsItem Property

Returns the specified Document object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocument this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IDocument
    Get

Parameters

vntIndexKey
Type: SystemObject
Index must be a numeric one-based index into the collection.

Property Value

Type: IDocument

Return Value

Type: IDocument
IDocument
See Also

Reference

IDocuments Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotal Interface

IExpectedBatchTotal Interface

IExpectedBatchTotal COM Interface.

Defines a COM object that contains the sum of a certain document index fields.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC52-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IExpectedBatchTotal
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC52-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IExpectedBatchTotal

The IExpectedBatchTotal type exposes the following members.

Properties
 | Name | Description
Public property | Description | Returns the field type description.
Public property | Length | Returns the length of the field.
Public property | Name | Returns the name of the expected batch total.
Public property | Numeric | Returns True if the field type is numeric.
Public property | NumericPrecision | Returns the number of decimal places of the expected batch total.
Public property | NumericScale | Returns the number of digits, including decimals, of the expected batch total.
Public property | OrderNumber | Returns the order of the expected batch total field within the set of fields.
Public property | SqlType | Returns the data type of the expected batch total.
Public property | TypeName | Returns the name of the Tungsten Capture field type associated with the expected batch total.
Public property | Value | Gets or sets the value of the expected batch total.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotal Properties

IExpectedBatchTotal Properties

The IExpectedBatchTotal type exposes the following members.

Properties
 | Name | Description
Public property | Description | Returns the field type description.
Public property | Length | Returns the length of the field.
Public property | Name | Returns the name of the expected batch total.
Public property | Numeric | Returns True if the field type is numeric.
Public property | NumericPrecision | Returns the number of decimal places of the expected batch total.
Public property | NumericScale | Returns the number of digits, including decimals, of the expected batch total.
Public property | OrderNumber | Returns the order of the expected batch total field within the set of fields.
Public property | SqlType | Returns the data type of the expected batch total.
Public property | TypeName | Returns the name of the Tungsten Capture field type associated with the expected batch total.
Public property | Value | Gets or sets the value of the expected batch total.
Top
See Also

Reference

IExpectedBatchTotal Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotal.Description Property

IExpectedBatchTotalDescription Property

Returns the field type description.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String
See Also

Reference

IExpectedBatchTotal Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotal.Length Property

IExpectedBatchTotalLength Property

Returns the length of the field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
See Also

Reference

IExpectedBatchTotal Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotal.Name Property

IExpectedBatchTotalName Property

Returns the name of the expected batch total.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
See Also

Reference

IExpectedBatchTotal Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotal.Numeric Property

IExpectedBatchTotalNumeric Property

Returns True if the field type is numeric.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Numeric { get; }
ReadOnly Property Numeric As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
See Also

Reference

IExpectedBatchTotal Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotal.NumericPrecision Property

IExpectedBatchTotalNumericPrecision Property

Returns the number of decimal places of the expected batch total.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int NumericPrecision { get; }
ReadOnly Property NumericPrecision As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
See Also

Reference

IExpectedBatchTotal Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotal.NumericScale Property

IExpectedBatchTotalNumericScale Property

Returns the number of digits, including decimals, of the expected batch total.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int NumericScale { get; }
ReadOnly Property NumericScale As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
See Also

Reference

IExpectedBatchTotal Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotal.OrderNumber Property

IExpectedBatchTotalOrderNumber Property

Returns the order of the expected batch total field within the set of fields.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int OrderNumber { get; }
ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IExpectedBatchTotal Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotal.SqlType Property

IExpectedBatchTotalSqlType Property

Returns the data type of the expected batch total.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int SqlType { get; }
ReadOnly Property SqlType As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
See Also

Reference

IExpectedBatchTotal Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotal.TypeName Property

IExpectedBatchTotalTypeName Property

Returns the name of the Tungsten Capture field type associated with the expected batch total.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string TypeName { get; }
ReadOnly Property TypeName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IExpectedBatchTotal Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotal.Value Property

IExpectedBatchTotalValue Property

Gets or sets the value of the expected batch total.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Value { get; set; }
Property Value As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
By default, the value is empty. When a value is assigned, it is checked to ensure that it is the proper numeric type.
See Also

Reference

IExpectedBatchTotal Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotals Interface

IExpectedBatchTotals Interface

IExpectedBatchTotals COM Interface.

Defines a COM collection of ExpectedBatchTotal objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC54-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IExpectedBatchTotals
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC54-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IExpectedBatchTotals

The IExpectedBatchTotals type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of ExpectedBatchTotal objects contained in the collection.
Public property | Item | Returns the specified ExpectedBatchTotal from the collection.
Top
Remarks
An ExpectedBatchTotals object is valid as long as the parent batch is open.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotals Methods

IExpectedBatchTotals Methods

The IExpectedBatchTotals type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IExpectedBatchTotals Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotals.GetEnumerator Method

IExpectedBatchTotalsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IExpectedBatchTotals object.
See Also

Reference

IExpectedBatchTotals Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotals Properties

IExpectedBatchTotals Properties

The IExpectedBatchTotals type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of ExpectedBatchTotal objects contained in the collection.
Public property | Item | Returns the specified ExpectedBatchTotal from the collection.
Top
See Also

Reference

IExpectedBatchTotals Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotals.Count Property

IExpectedBatchTotalsCount Property

Returns the number of ExpectedBatchTotal objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IExpectedBatchTotals Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IExpectedBatchTotals.Item Property

IExpectedBatchTotalsItem Property

Returns the specified ExpectedBatchTotal from the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IExpectedBatchTotal this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IExpectedBatchTotal
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's indexed or key.

Property Value

Type: IExpectedBatchTotal

Return Value

Type: IExpectedBatchTotal
Remarks
Index can either be a form type name or a numeric one-based index into the collection.
See Also

Reference

IExpectedBatchTotals Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder Interface

IFolder Interface

IFolder COM Interface.

Defines information about the currently opened folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC56-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFolder
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC56-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFolder

The IFolder type exposes the following members.

Methods
 | Name | Description
Public method | MoveToBatch | Moves this folder to a batch.
Public method | MoveToFolder | Moves this folder to another folder.
Top
Properties
 | Name | Description
Public property | Batch | Returns the parent Batch in which the folder resides.
Public property | ClassID | Gets the folder class ID.
Public property | ClassName | Returns the folder class name.
Public property | CustomStorageString | The folder storage string with the specified name.
Public property | Documents | Returns the collection of documents within the folder.
Public property | Folder | Gets or sets the parent folder where the current folder resides.
Public property | FolderClass | Gets or sets the FolderClass object.
Public property | FolderGUID | Returns the read only Folder unique ID.
Public property | Folders | Returns a collection of immediate child folders under the current folder (not including indirect child folders).
Public property | ID | Returns the internal Folder ID set by the data source (internal database).
Public property | IndexFieldCount | Returns the number of index fields in the folder.
Public property | IndexFields | Returns the collection of index fields in the folder.
Public property | OrderNumber | The folder order number within the batch (if the current folder is a direct child of a batch) or folder (if the parent is a folder).
Public property | Validated | True sets a folder as validated. This folder is skipped in the Validation module.
Public property | Verified | True sets a folder as verified. This folder is skipped in the Verification module.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder Methods

IFolder Methods

The IFolder type exposes the following members.

Methods
 | Name | Description
Public method | MoveToBatch | Moves this folder to a batch.
Public method | MoveToFolder | Moves this folder to another folder.
Top
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.MoveToBatch Method

IFolderMoveToBatch Method

Moves this folder to a batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void MoveToBatch(
    ref IFolder oNextFolder = null
)
Sub MoveToBatch (
    Optional ByRef oNextFolder As IFolder = Nothing
)

Parameters

oNextFolder (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIFolder
The moved folder will be inserted before the folder specified by this parameter. The folder will be moved to the end of the folder list if this parameter is not specified.
Remarks
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.MoveToFolder Method

IFolderMoveToFolder Method

Moves this folder to another folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void MoveToFolder(
    ref IFolder oFolder,
    ref IFolder oNextFolder = null
)
Sub MoveToFolder (
    ByRef oFolder As IFolder,
    Optional ByRef oNextFolder As IFolder = Nothing
)

Parameters

oFolder
Type: Kofax.Capture.CaptureModule.InteropServicesIFolder
The parent folder.
oNextFolder (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIFolder
The moved folder will be inserted before the folder specified by this parameter. The folder will be moved to the end of the folder list if this parameter is not specified.
Remarks
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder Properties

IFolder Properties

The IFolder type exposes the following members.

Properties
 | Name | Description
Public property | Batch | Returns the parent Batch in which the folder resides.
Public property | ClassID | Gets the folder class ID.
Public property | ClassName | Returns the folder class name.
Public property | CustomStorageString | The folder storage string with the specified name.
Public property | Documents | Returns the collection of documents within the folder.
Public property | Folder | Gets or sets the parent folder where the current folder resides.
Public property | FolderClass | Gets or sets the FolderClass object.
Public property | FolderGUID | Returns the read only Folder unique ID.
Public property | Folders | Returns a collection of immediate child folders under the current folder (not including indirect child folders).
Public property | ID | Returns the internal Folder ID set by the data source (internal database).
Public property | IndexFieldCount | Returns the number of index fields in the folder.
Public property | IndexFields | Returns the collection of index fields in the folder.
Public property | OrderNumber | The folder order number within the batch (if the current folder is a direct child of a batch) or folder (if the parent is a folder).
Public property | Validated | True sets a folder as validated. This folder is skipped in the Validation module.
Public property | Verified | True sets a folder as verified. This folder is skipped in the Verification module.
Top
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.Batch Property

IFolderBatch Property

Returns the parent Batch in which the folder resides.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch Batch { get; }
ReadOnly Property Batch As IBatch
    Get

Property Value

Type: IBatch

Return Value

Type: IBatch
IBatch
Remarks
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.ClassID Property

IFolderClassID Property

Gets the folder class ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ClassID { get; }
ReadOnly Property ClassID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.ClassName Property

IFolderClassName Property

Returns the folder class name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ClassName { get; }
ReadOnly Property ClassName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.CustomStorageString Property

IFolderCustomStorageString Property

The folder storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
If set to an empty string, the storage string is deleted.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific folder. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.Documents Property

IFolderDocuments Property

Returns the collection of documents within the folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocuments Documents { get; }
ReadOnly Property Documents As IDocuments
    Get

Property Value

Type: IDocuments

Return Value

Type: IDocuments
IDocuments
Remarks
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.Folder Property

IFolderFolder Property

Gets or sets the parent folder where the current folder resides.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolder Folder { get; set; }
Property Folder As IFolder
    Get
    Set

Property Value

Type: IFolder

Return Value

Type: IFolder
IFolder
Remarks
Nothing if the current folder has no parent folder.
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.FolderClass Property

IFolderFolderClass Property

Gets or sets the FolderClass object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolderClass FolderClass { get; set; }
Property FolderClass As IFolderClass
    Get
    Set

Property Value

Type: IFolderClass

Return Value

Type: IFolderClass
IFolderClass
Remarks
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.FolderGUID Property

IFolderFolderGUID Property

Returns the read only Folder unique ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string FolderGUID { get; }
ReadOnly Property FolderGUID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.Folders Property

IFolderFolders Property

Returns a collection of immediate child folders under the current folder (not including indirect child folders).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolders Folders { get; }
ReadOnly Property Folders As IFolders
    Get

Property Value

Type: IFolders

Return Value

Type: IFolders
IFolders
Remarks
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.ID Property

IFolderID Property

Returns the internal Folder ID set by the data source (internal database).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ID { get; }
ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.IndexFieldCount Property

IFolderIndexFieldCount Property

Returns the number of index fields in the folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int IndexFieldCount { get; }
ReadOnly Property IndexFieldCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.IndexFields Property

IFolderIndexFields Property

Returns the collection of index fields in the folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexFields IndexFields { get; }
ReadOnly Property IndexFields As IIndexFields
    Get

Property Value

Type: IIndexFields

Return Value

Type: IIndexFields
IIndexFields
Remarks
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.OrderNumber Property

IFolderOrderNumber Property

The folder order number within the batch (if the current folder is a direct child of a batch) or folder (if the parent is a folder).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int OrderNumber { get; }
ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.Validated Property

IFolderValidated Property

True sets a folder as validated. This folder is skipped in the Validation module.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Validated { get; set; }
Property Validated As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
False clears the validated state. The folder is not skipped in the Validation module.
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolder.Verified Property

IFolderVerified Property

True sets a folder as verified. This folder is skipped in the Verification module.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Verified { get; set; }
Property Verified As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
False clears the verified state. The folder is not skipped in the Verification module.
See Also

Reference

IFolder Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolderClass Interface

IFolderClass Interface

IFolderClass COM Interface.

Defines a COM object that refers to a Tungsten Capture folder class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC58-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFolderClass
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC58-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFolderClass

The IFolderClass type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The folder storage string with the specified name.
Public property | Description | Gets the folder class description.
Public property | Name | Gets the folder class name.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IFolderClass Properties

IFolderClass Properties

The IFolderClass type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The folder storage string with the specified name.
Public property | Description | Gets the folder class description.
Public property | Name | Gets the folder class name.
Top
See Also

Reference

IFolderClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolderClass.CustomStorageString Property

IFolderClassCustomStorageString Property

The folder storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; }
ReadOnly Property CustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString
If set to an empty string, the storage string is deleted.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific folder class. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IFolderClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolderClass.Description Property

IFolderClassDescription Property

Gets the folder class description.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks

This function throws:

(KfxApiErrBadParameterRange) on an illegal description; the maximum length is 80 characters.
See Also

Reference

IFolderClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolderClass.Name Property

IFolderClassName Property

Gets the folder class name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks

This is the default property for the FolderClass object.

This function throws:

(KfxApiErrBadParameterRange) on an illegal description; the maximum length is 32 characters.

See Also

Reference

IFolderClass Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolderClasses Interface

IFolderClasses Interface

IFolderClasses COM Interface.

Defines a collection of folder classes.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC5A-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFolderClasses
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC5A-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFolderClasses

The IFolderClasses type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of folder classes contained in the collection.
Public property | Item | Returns the specified FolderClass from the collection.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IFolderClasses Methods

IFolderClasses Methods

The IFolderClasses type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IFolderClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolderClasses.GetEnumerator Method

IFolderClassesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IFolderClasses object.
See Also

Reference

IFolderClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolderClasses Properties

IFolderClasses Properties

The IFolderClasses type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of folder classes contained in the collection.
Public property | Item | Returns the specified FolderClass from the collection.
Top
See Also

Reference

IFolderClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolderClasses.Count Property

IFolderClassesCount Property

Returns the number of folder classes contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFolderClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolderClasses.Item Property

IFolderClassesItem Property

Returns the specified FolderClass from the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolderClass this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFolderClass
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IFolderClass

Return Value

Type: IFolderClass
IFolderClass
Remarks
Index can be either a folder class name or a numeric one-based index into the collection.
See Also

Reference

IFolderClasses Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolders Interface

IFolders Interface

IFolders COM Interface.

Defines a COM collection of Folder objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC5C-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFolders
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC5C-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFolders

The IFolders type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of Folder objects contained in the collection.
Public property | Item | Returns the specified Folder object.
Top
Remarks
Iteration and extraction by order number (with the item function) is supported. Passing an out-of-range or invalid parameter to the item function causes it to throw the error "Invalid Parameter" to the caller. The Folders object is invalidated when the current batch is closed.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IFolders Methods

IFolders Methods

The IFolders type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IFolders Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolders.GetEnumerator Method

IFoldersGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IFolders object.
See Also

Reference

IFolders Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolders Properties

IFolders Properties

The IFolders type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of Folder objects contained in the collection.
Public property | Item | Returns the specified Folder object.
Top
See Also

Reference

IFolders Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolders.Count Property

IFoldersCount Property

Returns the number of Folder objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IFolders Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFolders.Item Property

IFoldersItem Property

Returns the specified Folder object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolder this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFolder
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IFolder

Return Value

Type: IFolder
Remarks
Index can be either a folder class name or a numeric one-based index into the collection.
See Also

Reference

IFolders Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFormType Interface

IFormType Interface

IFormType COM Interface.

Defines a COM object that refers to a Tungsten Capture form type.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC5E-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFormType
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC5E-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFormType

The IFormType type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Returns the description of the form type.
Public property | DocumentClass | Returns the document class that contains the form type.
Public property | Name | Returns the name of the form type.
Top
Remarks
A FormType object is valid as long as its parent Batch is open.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IFormType Properties

IFormType Properties

The IFormType type exposes the following members.

Properties
 | Name | Description
Public property | CustomStorageString | The storage string with the specified name.
Public property | Description | Returns the description of the form type.
Public property | DocumentClass | Returns the document class that contains the form type.
Public property | Name | Returns the name of the form type.
Top
See Also

Reference

IFormType Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFormType.CustomStorageString Property

IFormTypeCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; }
ReadOnly Property CustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the form type.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific form type. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IFormType Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFormType.Description Property

IFormTypeDescription Property

Returns the description of the form type.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IFormType Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFormType.DocumentClass Property

IFormTypeDocumentClass Property

Returns the document class that contains the form type.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocumentClass DocumentClass { get; }
ReadOnly Property DocumentClass As IDocumentClass
    Get

Property Value

Type: IDocumentClass

Return Value

Type: IDocumentClass
IDocumentClass
Remarks
See Also

Reference

IFormType Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFormType.Name Property

IFormTypeName Property

Returns the name of the form type.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IFormType Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFormTypes Interface

IFormTypes Interface

IFormTypes COM Interface.

Defines a COM collection of FormType objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC60-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IFormTypes
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC60-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IFormTypes

The IFormTypes type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of FormType objects contained in the collection.
Public property | Item | Returns the specified FormType object.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IFormTypes Methods

IFormTypes Methods

The IFormTypes type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IFormTypes Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFormTypes.GetEnumerator Method

IFormTypesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IFormTypes object.
See Also

Reference

IFormTypes Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFormTypes Properties

IFormTypes Properties

The IFormTypes type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of FormType objects contained in the collection.
Public property | Item | Returns the specified FormType object.
Top
See Also

Reference

IFormTypes Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFormTypes.Count Property

IFormTypesCount Property

Returns the number of FormType objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
See Also

Reference

IFormTypes Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IFormTypes.Item Property

IFormTypesItem Property

Returns the specified FormType object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFormType this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IFormType
    Get

Parameters

vntIndexKey
Type: SystemObject

Property Value

Type: IFormType

Return Value

Type: IFormType
IFormType
Remarks
Index can either be a form type name or a numeric one-based index into the collection.
See Also

Reference

IFormTypes Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IImportLogin Interface

IImportLogin Interface

IImportLogin COM Interface.

Defines a COM object that coordinates logging in and logging out of Tungsten Capture. This is the only object that can be created using New or CreateObject in Visual Basic.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC62-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IImportLogin
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC62-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IImportLogin

The IImportLogin type exposes the following members.

Methods
 | Name | Description
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | Login | Starts a session with Tungsten Capture and then sets the ActiveApplication property.
Public method | Logout | Ends the session with Tungsten Capture.
Public method | SetLicInstanceID | Sets the application instance ID.
Top
Properties
 | Name | Description
Public property | ActiveApplication | Returns the instance of the current application.
Public property | EnableSecurityBoost | Enables or disables SecurityBoost if it is enabled globally.
Public property | RequiresLogin | If True, an UserID and password must be supplied for a Tungsten Capture login.
Public property | SharedUserProfileModel | Gets or sets the shared profile model. If True, the user privileges are shared across all processes on the computer.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IImportLogin Methods

IImportLogin Methods

The IImportLogin type exposes the following members.

Methods
 | Name | Description
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | Login | Starts a session with Tungsten Capture and then sets the ActiveApplication property.
Public method | Logout | Ends the session with Tungsten Capture.
Public method | SetLicInstanceID | Sets the application instance ID.
Top
See Also

Reference

IImportLogin Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IImportLogin.LogError Method

IImportLoginLogError Method

Logs an error to the Tungsten Capture error log.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void LogError(
    int Err1,
    int Err2,
    int Err3,
    string ErrorMessage,
    string CodeModule,
    int LineNumber
)
Sub LogError (
    Err1 As Integer,
    Err2 As Integer,
    Err3 As Integer,
    ErrorMessage As String,
    CodeModule As String,
    LineNumber As Integer
)

Parameters

Err1
Type: SystemInt32
The primary error code.
Err2
Type: SystemInt32
Sub-code.
Err3
Type: SystemInt32
Sub-code.
ErrorMessage
Type: SystemString
The string message.
CodeModule
Type: SystemString
The source code module where the problem occurred.
LineNumber
Type: SystemInt32
The line number within the source where the problem happened.
Remarks
See Also

Reference

IImportLogin Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IImportLogin.Login Method

IImportLoginLogin Method

Starts a session with Tungsten Capture and then sets the ActiveApplication property.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IApplication Login(
    string UserID,
    string UserPwd
)
Function Login (
    UserID As String,
    UserPwd As String
) As IApplication

Parameters

UserID
Type: SystemString
The User ID.
UserPwd
Type: SystemString
The User password.

Return Value

Type: IApplication
IApplication
Remarks

Returns ActiveApplication.

To hinder attempts to determine the password, after a set of three KfxApiErrInvalidLogin errors, the method waits ten seconds before returning the ActiveApplication.

If the ImportLogin is already logged in, this method automatically logs out and back in.

See Also

Reference

IImportLogin Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IImportLogin.Logout Method

IImportLoginLogout Method

Ends the session with Tungsten Capture.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Logout()
Sub Logout
Remarks
ActiveApplication is made invalid. If a batch is active, it is automatically deleted.
Be sure to call Logout method when your application is terminating.
See Also

Reference

IImportLogin Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IImportLogin.SetLicInstanceID Method

IImportLoginSetLicInstanceID Method

Sets the application instance ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void SetLicInstanceID(
    int lInstanceID
)
Sub SetLicInstanceID (
    lInstanceID As Integer
)

Parameters

lInstanceID
Type: SystemInt32
The instance ID to be set.
Remarks
See Also

Reference

IImportLogin Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IImportLogin Properties

IImportLogin Properties

The IImportLogin type exposes the following members.

Properties
 | Name | Description
Public property | ActiveApplication | Returns the instance of the current application.
Public property | EnableSecurityBoost | Enables or disables SecurityBoost if it is enabled globally.
Public property | RequiresLogin | If True, an UserID and password must be supplied for a Tungsten Capture login.
Public property | SharedUserProfileModel | Gets or sets the shared profile model. If True, the user privileges are shared across all processes on the computer.
Top
See Also

Reference

IImportLogin Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IImportLogin.ActiveApplication Property

IImportLoginActiveApplication Property

Returns the instance of the current application.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IApplication ActiveApplication { get; }
ReadOnly Property ActiveApplication As IApplication
    Get

Property Value

Type: IApplication

Return Value

Type: IApplication
IApplication
Remarks
If you are not logged in, then it returns Nothing.
See Also

Reference

IImportLogin Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IImportLogin.EnableSecurityBoost Property

IImportLoginEnableSecurityBoost Property

Enables or disables SecurityBoost if it is enabled globally.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool EnableSecurityBoost { get; set; }
Property EnableSecurityBoost As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

By default SecurityBoost is disabled. This property always defaults to "false," even if SecurityBoost is enabled globally.

Setting the property to "true" only enables SecurityBoost if it is enabled for the entire system. Otherwise, the property is still set to "true," but SecurityBoost does not take effect.

This property can be read at any time, but can only be written before logging in (with the Login method). Attempting to write it at any other time causes an error.

See Also

Reference

IImportLogin Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IImportLogin.RequiresLogin Property

IImportLoginRequiresLogin Property

If True, an UserID and password must be supplied for a Tungsten Capture login.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool RequiresLogin { get; }
ReadOnly Property RequiresLogin As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

This returns True if user profiles have been enabled in Administration, or if you are using a shared user profile model and some other application is already connected.

Even when this property returns False, the caller must still call the Login method, but it may pass empty strings for the parameters.

See Also

Reference

IImportLogin Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IImportLogin.SharedUserProfileModel Property

IImportLoginSharedUserProfileModel Property

Gets or sets the shared profile model. If True, the user privileges are shared across all processes on the computer.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SharedUserProfileModel { get; set; }
Property SharedUserProfileModel As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
Defaults is False. Note that this default is different than the default for interactive Tungsten Capture applications.
See Also

Reference

IImportLogin Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField Interface

IIndexField Interface

IIndexField COM Interface.

Defines information about an index field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC64-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IIndexField
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC64-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IIndexField

The IIndexField type exposes the following members.

Properties
 | Name | Description
Public property | Batch | Returns the batch associated with the index field.
Public property | Confidence | Gets or sets the field confidence.
Public property | CustomStorageString | The storage string with the specified name for the index field or table field for this object.
Public property | DefaultValue | Gets the default value for the field.
Public property | Description | Returns the field description.
Public property | DisplayLabel | Reads and writes the value of a supported index field display label.
Public property | Document | Returns the document associated with the index field.
Public property | Folder | Returns the folder associated with the index field.
Public property | Hidden | Returns the field hidden flag.
Public property | Length | Returns the maximum number of characters configured for the index field by the user. The field must be non-numeric.
Public property | Name | The index field name.
Public property | Numeric | Returns True if the field is a numeric type.
Public property | NumericPrecision | Returns the field numeric precision.
Public property | NumericScale | Returns the field numeric scale.
Public property | OrderNumber | The field order within the document.
Public property | Page | Gets the page on which the index field resides.
Public property | ReadOnly | Gets or sets the read-only flag.
Public property | Required | Returns the field required flag.
Public property | SqlType | Returns the field SQL type.
Public property | Sticky | Returns the field sticky flag.
Public property | SuggestedValueCount | Returns the number of values for the field type, if any.
Public property | SuggestedValues | Returns the collection of suggested values.
Public property | SuggestedValuesForceMatch | Gets or sets the force match flag for the values.
Public property | SuggestedValuesForceMatchCaseSensitive | Gets or sets the case-sensitive flag for the values.
Public property | Table | The table associated with the index field.
Public property | Total | Returns True if the field is a total field.
Public property | TypeCustomStorageString | The storage string with the specified name for the field type for this object.
Public property | TypeName | The field type name.
Public property | UserChanged | Marks the field as changed by the user.
Public property | Value | Gets or sets the field value.
Public property | ZoneHeight | Returns the height of the zone in BMUs (1200ths of an inch).
Public property | ZoneLeft | Returns the left coordinate of the zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the zone in BMUs.
Public property | ZoneWidth | Returns the width of the zone in BMUs.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField Properties

IIndexField Properties

The IIndexField type exposes the following members.

Properties
 | Name | Description
Public property | Batch | Returns the batch associated with the index field.
Public property | Confidence | Gets or sets the field confidence.
Public property | CustomStorageString | The storage string with the specified name for the index field or table field for this object.
Public property | DefaultValue | Gets the default value for the field.
Public property | Description | Returns the field description.
Public property | DisplayLabel | Reads and writes the value of a supported index field display label.
Public property | Document | Returns the document associated with the index field.
Public property | Folder | Returns the folder associated with the index field.
Public property | Hidden | Returns the field hidden flag.
Public property | Length | Returns the maximum number of characters configured for the index field by the user. The field must be non-numeric.
Public property | Name | The index field name.
Public property | Numeric | Returns True if the field is a numeric type.
Public property | NumericPrecision | Returns the field numeric precision.
Public property | NumericScale | Returns the field numeric scale.
Public property | OrderNumber | The field order within the document.
Public property | Page | Gets the page on which the index field resides.
Public property | ReadOnly | Gets or sets the read-only flag.
Public property | Required | Returns the field required flag.
Public property | SqlType | Returns the field SQL type.
Public property | Sticky | Returns the field sticky flag.
Public property | SuggestedValueCount | Returns the number of values for the field type, if any.
Public property | SuggestedValues | Returns the collection of suggested values.
Public property | SuggestedValuesForceMatch | Gets or sets the force match flag for the values.
Public property | SuggestedValuesForceMatchCaseSensitive | Gets or sets the case-sensitive flag for the values.
Public property | Table | The table associated with the index field.
Public property | Total | Returns True if the field is a total field.
Public property | TypeCustomStorageString | The storage string with the specified name for the field type for this object.
Public property | TypeName | The field type name.
Public property | UserChanged | Marks the field as changed by the user.
Public property | Value | Gets or sets the field value.
Public property | ZoneHeight | Returns the height of the zone in BMUs (1200ths of an inch).
Public property | ZoneLeft | Returns the left coordinate of the zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the zone in BMUs.
Public property | ZoneWidth | Returns the width of the zone in BMUs.
Top
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Batch Property

IIndexFieldBatch Property

Returns the batch associated with the index field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch Batch { get; }
ReadOnly Property Batch As IBatch
    Get

Property Value

Type: IBatch

Return Value

Type: IBatch
Remarks
Nothing, if not a batch field.
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Confidence Property

IIndexFieldConfidence Property

Gets or sets the field confidence.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Confidence { get; set; }
Property Confidence As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
Values less than zero are truncated to 0, and values greater than 100 are set to 100. No error is generated in such cases.
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.CustomStorageString Property

IIndexFieldCustomStorageString Property

The storage string with the specified name for the index field or table field for this object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; }
ReadOnly Property CustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the form type.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific index zone. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

In a table, when the IndexField is retrieved through the Document object, the strings correspond to the first row of the table.

When the IndexField object is retrieved through the TableRow object, the strings correspond to a specific row.

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.DefaultValue Property

IIndexFieldDefaultValue Property

Gets the default value for the field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string DefaultValue { get; }
ReadOnly Property DefaultValue As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Description Property

IIndexFieldDescription Property

Returns the field description.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.DisplayLabel Property

IIndexFieldDisplayLabel Property

Reads and writes the value of a supported index field display label.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string DisplayLabel { get; set; }
Property DisplayLabel As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Document Property

IIndexFieldDocument Property

Returns the document associated with the index field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocument Document { get; }
ReadOnly Property Document As IDocument
    Get

Property Value

Type: IDocument

Return Value

Type: IDocument
IDocument
Remarks
Nothing, if not a document index field.
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Folder Property

IIndexFieldFolder Property

Returns the folder associated with the index field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IFolder Folder { get; }
ReadOnly Property Folder As IFolder
    Get

Property Value

Type: IFolder

Return Value

Type: IFolder
IFolder
Remarks
Nothing, if not a folder index field.
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Hidden Property

IIndexFieldHidden Property

Returns the field hidden flag.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Hidden { get; }
ReadOnly Property Hidden As Boolean
    Get

Property Value

Type: Boolean
True if the field is hidden.

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Length Property

IIndexFieldLength Property

Returns the maximum number of characters configured for the index field by the user. The field must be non-numeric.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Length { get; }
ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Name Property

IIndexFieldName Property

The index field name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Numeric Property

IIndexFieldNumeric Property

Returns True if the field is a numeric type.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Numeric { get; }
ReadOnly Property Numeric As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.NumericPrecision Property

IIndexFieldNumericPrecision Property

Returns the field numeric precision.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int NumericPrecision { get; }
ReadOnly Property NumericPrecision As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.NumericScale Property

IIndexFieldNumericScale Property

Returns the field numeric scale.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int NumericScale { get; }
ReadOnly Property NumericScale As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.OrderNumber Property

IIndexFieldOrderNumber Property

The field order within the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int OrderNumber { get; }
ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Page Property

IIndexFieldPage Property

Gets the page on which the index field resides.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPage Page { get; }
ReadOnly Property Page As IPage
    Get

Property Value

Type: IPage

Return Value

Type: IPage
IPage
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.ReadOnly Property

IIndexFieldReadOnly Property

Gets or sets the read-only flag.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool ReadOnly { get; set; }
Property ReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
Returns True if the field is read-only.
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Required Property

IIndexFieldRequired Property

Returns the field required flag.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Required { get; }
ReadOnly Property Required As Boolean
    Get

Property Value

Type: Boolean
True if the field is required.

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.SqlType Property

IIndexFieldSqlType Property

Returns the field SQL type.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int SqlType { get; }
ReadOnly Property SqlType As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Sticky Property

IIndexFieldSticky Property

Returns the field sticky flag.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Sticky { get; }
ReadOnly Property Sticky As Boolean
    Get

Property Value

Type: Boolean
True if the field is sticky.

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.SuggestedValueCount Property

IIndexFieldSuggestedValueCount Property

Returns the number of values for the field type, if any.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int SuggestedValueCount { get; }
ReadOnly Property SuggestedValueCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.SuggestedValues Property

IIndexFieldSuggestedValues Property

Returns the collection of suggested values.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ISuggestedValues SuggestedValues { get; }
ReadOnly Property SuggestedValues As ISuggestedValues
    Get

Property Value

Type: ISuggestedValues

Return Value

Type: ISuggestedValues
ISuggestedValues
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.SuggestedValuesForceMatch Property

IIndexFieldSuggestedValuesForceMatch Property

Gets or sets the force match flag for the values.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SuggestedValuesForceMatch { get; set; }
Property SuggestedValuesForceMatch As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean.
Remarks
Returns True if the field is force-matched to the suggested values.
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.SuggestedValuesForceMatchCaseSensitive Property

IIndexFieldSuggestedValuesForceMatchCaseSensitive Property

Gets or sets the case-sensitive flag for the values.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SuggestedValuesForceMatchCaseSensitive { get; set; }
Property SuggestedValuesForceMatchCaseSensitive As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
Returns True if the field is force-matched to the suggested values in case-sensitive mode.
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Table Property

IIndexFieldTable Property

The table associated with the index field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ITable Table { get; }
ReadOnly Property Table As ITable
    Get

Property Value

Type: ITable

Return Value

Type: ITable
ITable
Remarks
Nothing, if a single-value index field.
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Total Property

IIndexFieldTotal Property

Returns True if the field is a total field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Total { get; }
ReadOnly Property Total As Boolean
    Get

Property Value

Type: Boolean
True if the field is required.

Return Value

Type: Boolean
Boolean
Remarks
When this object is used as a folder index field, this property has no meaning.
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.TypeCustomStorageString Property

IIndexFieldTypeCustomStorageString Property

The storage string with the specified name for the field type for this object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; }
ReadOnly Property TypeCustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the form type.

Property Value

Type: String

Return Value

Type: String
Remarks

Custom Storage strings are custom text strings that are bound to a specific field type. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist.
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.TypeName Property

IIndexFieldTypeName Property

The field type name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string TypeName { get; }
ReadOnly Property TypeName As String
    Get

Property Value

Type: String

Return Value

Type: String
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.UserChanged Property

IIndexFieldUserChanged Property
Marks the field as changed by the user.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool UserChanged { get; set; }
Property UserChanged As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.Value Property

IIndexFieldValue Property

Gets or sets the field value.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Value { get; set; }
Property Value As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
Values more than 254 characters are automatically truncated with no error. Setting the value of a field does not affect the database until the document is exited and the user elects to save the data. Values that do not pass validation (script failure, length restrictions, required, etc.) display an error message when the document is exited or the active field is changed. The focus is repositioned to the offending field in this case.

In a table, when the IndexField is retrieved through the Document object, the Value corresponds to the first row of the table.

When the IndexField object is retrieved through the TableRow object, the Value corresponds to a specific row.

See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.ZoneHeight Property

IIndexFieldZoneHeight Property

Returns the height of the zone in BMUs (1200ths of an inch).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneHeight { get; }
ReadOnly Property ZoneHeight As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.ZoneLeft Property

IIndexFieldZoneLeft Property

Returns the left coordinate of the zone in BMUs.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneLeft { get; }
ReadOnly Property ZoneLeft As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.ZoneTop Property

IIndexFieldZoneTop Property

Returns the top coordinate of the zone in BMUs.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneTop { get; }
ReadOnly Property ZoneTop As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexField.ZoneWidth Property

IIndexFieldZoneWidth Property

Returns the width of the zone in BMUs.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ZoneWidth { get; }
ReadOnly Property ZoneWidth As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexField Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexFields Interface

IIndexFields Interface

IIndexFields COM Interface.

Defines a COM collection of IndexField objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC66-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IIndexFields
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC66-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IIndexFields

The IIndexFields type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of IndexField objects contained in the collection.
Public property | Item | Returns the specified IndexField object.
Top
Remarks

Iteration and extraction by order number (with the item function) are supported. Passing an out-of-range or invalid parameter to the item function causes it to throw the error "Invalid Parameter" to the caller.

Note that the IndexFields collection contains both hidden and visible fields. As a result, more items may exist in the IndexFields collection than are shown on the data entry panel.

An IndexFields object is invalidated when a content change event occurs.

IndexFields can be accessed for any document, irrespective of the data entry status, in Scan, Quality Control, Validation, and Verification.

See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexFields Methods

IIndexFields Methods

The IIndexFields type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IIndexFields Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexFields.GetEnumerator Method

IIndexFieldsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IIndexFields object.
See Also

Reference

IIndexFields Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexFields Properties

IIndexFields Properties

The IIndexFields type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of IndexField objects contained in the collection.
Public property | Item | Returns the specified IndexField object.
Top
See Also

Reference

IIndexFields Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexFields.Count Property

IIndexFieldsCount Property

Returns the number of IndexField objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IIndexFields Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IIndexFields.Item Property

IIndexFieldsItem Property

Returns the specified IndexField object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexField this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IIndexField
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IIndexField

Return Value

Type: IIndexField
Remarks
Index can either be an index field name or a numeric one-based index into the collection.
See Also

Reference

IIndexFields Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


Implementation Class

Implementation Class
Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesImplementation

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[GuidAttribute("F797DC9A-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
[ComVisibleAttribute(true)]
public sealed class Implementation : IDisposable
<GuidAttribute("F797DC9A-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
<ComVisibleAttribute(true)>
Public NotInheritable Class Implementation
    Implements IDisposable

The Implementation type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Implements Dispose method.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


Implementation Methods

Implementation Methods

The Implementation type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Implements Dispose method.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Implementation Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Implementation.Dispose Method

ImplementationDispose Method

Implements Dispose method.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

Implementation Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ImportLogin Class

ImportLogin Class

ImportLogin COM implementation class.

Defines a COM object that coordinates logging in and logging out of Tungsten Capture. This is the only object that can be created using New or CreateObject in Visual Basic.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesImportLogin

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC63-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class ImportLogin : IImportLogin,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC63-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class ImportLogin
    Implements IImportLogin, IDisposable

The ImportLogin type exposes the following members.

Constructors
 | Name | Description
Public method | ImportLogin | Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.ImportLogin class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | Login | Starts a session with Tungsten Capture and then sets the ActiveApplication property.
Public method | Logout | Ends the session with Tungsten Capture.
Public method | SetLicInstanceID | Sets the application instance ID.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ActiveApplication | Returns the ID of the current application.
Public property | EnableSecurityBoost | Enables or disables SecurityBoost if it is enabled globally.
Public property | RequiresLogin | If True, an UserID and password must be supplied for a Tungsten Capture login.
Public property | SharedUserProfileModel | Gets or sets the shared profile model. If True, the user privileges are shared across all processes on the computer.
Top
Remarks

The COM ProgID is CaptureModule.ImportLogin.

The ImportLogin object is not necessary when using an OCX because the host Tungsten Capture module already manages logging in. Since there is no host Tungsten Capture module in this API, it is necessary to create the ImportLogin object and use it to login and access an Application object.

There is no limit to the number of ImportLogins that can be open in a given process or on a given computer. However, each ImportLogin uses resources, so the total number of logins that can be supported may vary between different computers.

While one or more ImportLogins are active, the user may also run zero or one instances of Kofax Capture Scan on the same computer concurrently.

Although the ImportLogin uses some facilities of Tungsten Capture Scan, the system does not load any user configured OCXs when running the system via the ImportLogin.

To connect to an ImportLogin, it is necessary to have at least a Scan/Quality Control License. Pages imported are limited by this license in the same way as in Kofax Capture Scan.

Note that the creation of an ImportLogin object may take a second or two because it has to load a large amount of code. Because of this delay, ImportLogin should be placed within an application so that the time lag is not noticeable, or at least minimized.

Your application may create as many ImportLogin objects as desired, and each may be connected with independent user profile objects and each may hold a separate batch open. However, be aware that an ImportLogin object uses several megabytes of virtual memory and some machines may run slowly when more than one is in use.

See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ImportLogin Constructor

ImportLogin Constructor

Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.ImportLogin class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ImportLogin()
Public Sub New
Remarks
See Also

Reference

ImportLogin Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ImportLogin Methods

ImportLogin Methods

The ImportLogin type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | Login | Starts a session with Tungsten Capture and then sets the ActiveApplication property.
Public method | Logout | Ends the session with Tungsten Capture.
Public method | SetLicInstanceID | Sets the application instance ID.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ImportLogin Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ImportLogin.Dispose Method

ImportLoginDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

ImportLogin Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ImportLogin.LogError Method

ImportLoginLogError Method

Logs an error to the Tungsten Capture error log.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public virtual void LogError(
    int Err1,
    int Err2,
    int Err3,
    string ErrorMessage,
    string CodeModule,
    int LineNumber
)
Public Overridable Sub LogError (
    Err1 As Integer,
    Err2 As Integer,
    Err3 As Integer,
    ErrorMessage As String,
    CodeModule As String,
    LineNumber As Integer
)

Parameters

Err1
Type: SystemInt32
The primary error code.
Err2
Type: SystemInt32
Sub-code.
Err3
Type: SystemInt32
Sub-code.
ErrorMessage
Type: SystemString
The string message.
CodeModule
Type: SystemString
The source code module where the problem occurred.
LineNumber
Type: SystemInt32
The line number within the source where the problem happened.

Implements

IImportLoginLogError(Int32, Int32, Int32, String, String, Int32)
Remarks
See Also

Reference

ImportLogin Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ImportLogin.Login Method

ImportLoginLogin Method

Starts a session with Tungsten Capture and then sets the ActiveApplication property.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IApplication Login(
    string UserID,
    string UserPwd
)
Public Function Login (
    UserID As String,
    UserPwd As String
) As IApplication

Parameters

UserID
Type: SystemString
The User ID.
UserPwd
Type: SystemString
The User password.

Return Value

Type: IApplication
IApplication

Implements

IImportLoginLogin(String, String)
Remarks

Returns ActiveApplication.

To hinder attempts to determine the password, after a set of three KfxApiErrInvalidLogin errors, the method waits ten seconds before returning the ActiveApplication.

If the ImportLogin is already logged in, this method automatically logs out and back in.

The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

ImportLogin Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ImportLogin.Logout Method

ImportLoginLogout Method

Ends the session with Tungsten Capture.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Logout()
Public Sub Logout

Implements

IImportLoginLogout
Remarks
ActiveApplication is made invalid. If a batch is active, it is automatically deleted.
Be sure to call Logout method when your application is terminating.
See Also

Reference

ImportLogin Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ImportLogin.SetLicInstanceID Method

ImportLoginSetLicInstanceID Method

Sets the application instance ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void SetLicInstanceID(
    int lInstanceID
)
Public Sub SetLicInstanceID (
    lInstanceID As Integer
)

Parameters

lInstanceID
Type: SystemInt32
The instance ID to be set.

Implements

IImportLoginSetLicInstanceID(Int32)
Remarks
See Also

Reference

ImportLogin Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ImportLogin Properties

ImportLogin Properties

The ImportLogin type exposes the following members.

Properties
 | Name | Description
Public property | ActiveApplication | Returns the ID of the current application.
Public property | EnableSecurityBoost | Enables or disables SecurityBoost if it is enabled globally.
Public property | RequiresLogin | If True, an UserID and password must be supplied for a Tungsten Capture login.
Public property | SharedUserProfileModel | Gets or sets the shared profile model. If True, the user privileges are shared across all processes on the computer.
Top
See Also

Reference

ImportLogin Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ImportLogin.ActiveApplication Property

ImportLoginActiveApplication Property

Returns the ID of the current application.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IApplication ActiveApplication { get; }
Public ReadOnly Property ActiveApplication As IApplication
    Get

Property Value

Type: IApplication

Return Value

Type: IApplication
IApplication

Implements

IImportLoginActiveApplication
Remarks
If you are not logged in, then it returns Nothing.
See Also

Reference

ImportLogin Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ImportLogin.EnableSecurityBoost Property

ImportLoginEnableSecurityBoost Property

Enables or disables SecurityBoost if it is enabled globally.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool EnableSecurityBoost { get; set; }
Public Property EnableSecurityBoost As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IImportLoginEnableSecurityBoost
Remarks

By default SecurityBoost is disabled. This property always defaults to "false," even if SecurityBoost is enabled globally.

Setting the property to "true" only enables SecurityBoost if it is enabled for the entire system. Otherwise, the property is still set to "true," but SecurityBoost does not take effect.

This property can be read at any time, but can only be written before logging in (with the Login method). Attempting to write it at any other time causes an error.

See Also

Reference

ImportLogin Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ImportLogin.RequiresLogin Property

ImportLoginRequiresLogin Property

If True, an UserID and password must be supplied for a Tungsten Capture login.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool RequiresLogin { get; }
Public ReadOnly Property RequiresLogin As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IImportLoginRequiresLogin
Remarks

This returns True if user profiles have been enabled in Administration, or if you are using a shared user profile model and some other application is already connected.

Even when this property returns False, the caller must still call the Login method, but it may pass empty strings for the parameters.

See Also

Reference

ImportLogin Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ImportLogin.SharedUserProfileModel Property

ImportLoginSharedUserProfileModel Property

Gets or sets the shared profile model. If True, the user privileges are shared across all processes on the computer.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SharedUserProfileModel { get; set; }
Public Property SharedUserProfileModel As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IImportLoginSharedUserProfileModel
Remarks
Defaults is False. Note that this default is different than the default for interactive Tungsten Capture applications.
See Also

Reference

ImportLogin Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField Class

IndexField Class

IndexField COM implementation class.

Defines information about an index field.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesIndexField

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC65-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class IndexField : IIndexField, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC65-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class IndexField
    Implements IIndexField, IDisposable

The IndexField type exposes the following members.

Constructors
 | Name | Description
Public method | IndexField | Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.IndexField class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Batch | Returns the batch associated with the index field.
Public property | Confidence | Gets or sets the field confidence.
Public property | CustomStorageString | The storage string with the specified name for the index field or table field for this object.
Public property | DefaultValue | Gets the default value for the field.
Public property | Description | Returns the field description.
Public property | DisplayLabel | Sets or gets the value of a supported index field display label.
Public property | Document | Returns the document associated with the index field.
Public property | Folder | Returns the folder associated with the index field.
Public property | HasTypeCustomStorageString | Checks if the index field has a specific custom storage string
Public property | Hidden | Returns the field hidden flag.
Public property | Length | Returns the maximum number of characters configured for the index field by the user. The field must be non-numeric.
Public property | Name | Returns the index field name.
Public property | Numeric | Returns True if the field is a numeric type.
Public property | NumericPrecision | Returns the field numeric precision.
Public property | NumericScale | Returns the field numeric scale.
Public property | OrderNumber | Gets the field order within the document.
Public property | Page | Gets the page on which the index field resides.
Public property | ReadOnly | Gets or sets the read-only flag.
Public property | Required | Returns the field required flag.
Public property | SqlType | Returns the field SQL type.
Public property | Sticky | Returns the field sticky flag.
Public property | SuggestedValueCount | Returns the number of values for the field type, if any.
Public property | SuggestedValues | Returns the collection of suggested values.
Public property | SuggestedValuesForceMatch | Gets or sets the force match flag for the values.
Public property | SuggestedValuesForceMatchCaseSensitive | Gets or sets the case-sensitive flag for the values.
Public property | Table | The table associated with the index field.
Public property | Total | Returns True if the field is a total field.
Public property | TypeCustomStorageString | The storage string with the specified name for the field type for this object.
Public property | TypeName | Gets the field type name.
Public property | UserChanged | Marks the field as changed by the user.
Public property | Value | Gets or sets the field value.
Public property | ZoneHeight | Returns the height of the zone in BMUs (1200ths of an inch).
Public property | ZoneLeft | Returns the left coordinate of the zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the zone in BMUs.
Public property | ZoneWidth | Returns the width of the zone in BMUs.
Top
Remarks

When running in Verification, fields not marked for verification return "True" for the hidden property (since they are not displayed on the data entry panel).

An IndexField object is invalidated when a content change event occurs.

This object can be a document index field or a folder index field. It is a document index field if referenced from a Document object or a folder index field if referenced from a Folder object.

IndexField can be accessed for any document or folder, irrespective of the data entry status, in Scan, Quality Control, Validation, and Verification.

For table fields, if the index field is retrieved through the Document Object, then the properties refer to the first row of the table.

An index field object is invalidated when a content change event occurs.

The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField Constructor

IndexField Constructor

Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.IndexField class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IndexField()
Public Sub New
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField Methods

IndexField Methods

The IndexField type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Dispose Method

IndexFieldDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField Properties

IndexField Properties

The IndexField type exposes the following members.

Properties
 | Name | Description
Public property | Batch | Returns the batch associated with the index field.
Public property | Confidence | Gets or sets the field confidence.
Public property | CustomStorageString | The storage string with the specified name for the index field or table field for this object.
Public property | DefaultValue | Gets the default value for the field.
Public property | Description | Returns the field description.
Public property | DisplayLabel | Sets or gets the value of a supported index field display label.
Public property | Document | Returns the document associated with the index field.
Public property | Folder | Returns the folder associated with the index field.
Public property | HasTypeCustomStorageString | Checks if the index field has a specific custom storage string
Public property | Hidden | Returns the field hidden flag.
Public property | Length | Returns the maximum number of characters configured for the index field by the user. The field must be non-numeric.
Public property | Name | Returns the index field name.
Public property | Numeric | Returns True if the field is a numeric type.
Public property | NumericPrecision | Returns the field numeric precision.
Public property | NumericScale | Returns the field numeric scale.
Public property | OrderNumber | Gets the field order within the document.
Public property | Page | Gets the page on which the index field resides.
Public property | ReadOnly | Gets or sets the read-only flag.
Public property | Required | Returns the field required flag.
Public property | SqlType | Returns the field SQL type.
Public property | Sticky | Returns the field sticky flag.
Public property | SuggestedValueCount | Returns the number of values for the field type, if any.
Public property | SuggestedValues | Returns the collection of suggested values.
Public property | SuggestedValuesForceMatch | Gets or sets the force match flag for the values.
Public property | SuggestedValuesForceMatchCaseSensitive | Gets or sets the case-sensitive flag for the values.
Public property | Table | The table associated with the index field.
Public property | Total | Returns True if the field is a total field.
Public property | TypeCustomStorageString | The storage string with the specified name for the field type for this object.
Public property | TypeName | Gets the field type name.
Public property | UserChanged | Marks the field as changed by the user.
Public property | Value | Gets or sets the field value.
Public property | ZoneHeight | Returns the height of the zone in BMUs (1200ths of an inch).
Public property | ZoneLeft | Returns the left coordinate of the zone in BMUs.
Public property | ZoneTop | Returns the top coordinate of the zone in BMUs.
Public property | ZoneWidth | Returns the width of the zone in BMUs.
Top
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Batch Property

IndexFieldBatch Property

Returns the batch associated with the index field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch Batch { get; }
Public ReadOnly Property Batch As IBatch
    Get

Property Value

Type: IBatch

Return Value

Type: IBatch

Implements

IIndexFieldBatch
Remarks
Nothing, if not a batch field.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Confidence Property

IndexFieldConfidence Property

Gets or sets the field confidence.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Confidence { get; set; }
Public Property Confidence As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexFieldConfidence
Remarks
Values less than zero are truncated to 0, and values greater than 100 are set to 100. No error is generated in such cases.
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.CustomStorageString Property

IndexFieldCustomStorageString Property

The storage string with the specified name for the index field or table field for this object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; }
Public ReadOnly Property CustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the form type.

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexFieldCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific index zone. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

In a table, when the IndexField is retrieved through the Document object, the strings correspond to the first row of the table.

When the IndexField object is retrieved through the TableRow object, the strings correspond to a specific row.

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.DefaultValue Property

IndexFieldDefaultValue Property

Gets the default value for the field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string DefaultValue { get; }
Public ReadOnly Property DefaultValue As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexFieldDefaultValue
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Description Property

IndexFieldDescription Property

Returns the field description.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexFieldDescription
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.DisplayLabel Property

IndexFieldDisplayLabel Property

Sets or gets the value of a supported index field display label.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string DisplayLabel { get; set; }
Public Property DisplayLabel As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexFieldDisplayLabel
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Document Property

IndexFieldDocument Property

Returns the document associated with the index field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocument Document { get; }
Public ReadOnly Property Document As IDocument
    Get

Property Value

Type: IDocument

Return Value

Type: IDocument
IDocument

Implements

IIndexFieldDocument
Remarks
Nothing, if not a document index field.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Folder Property

IndexFieldFolder Property

Returns the folder associated with the index field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IFolder Folder { get; }
Public ReadOnly Property Folder As IFolder
    Get

Property Value

Type: IFolder

Return Value

Type: IFolder
IFolder

Implements

IIndexFieldFolder
Remarks
Nothing, if not a folder index field.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.HasTypeCustomStorageString Property

IndexFieldHasTypeCustomStorageString Property
Checks if the index field has a specific custom storage string

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool this[
    string strName
] { get; }
Public ReadOnly Property HasTypeCustomStorageString (
    strName As String
) As Boolean
    Get

Parameters

strName
Type: SystemString

Property Value

Type: Boolean

Return Value

Type: Boolean
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Hidden Property

IndexFieldHidden Property

Returns the field hidden flag.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Hidden { get; }
Public ReadOnly Property Hidden As Boolean
    Get

Property Value

Type: Boolean
True if the field is hidden.

Return Value

Type: Boolean
Boolean

Implements

IIndexFieldHidden
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Length Property

IndexFieldLength Property

Returns the maximum number of characters configured for the index field by the user. The field must be non-numeric.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexFieldLength
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Name Property

IndexFieldName Property

Returns the index field name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexFieldName
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Numeric Property

IndexFieldNumeric Property

Returns True if the field is a numeric type.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Numeric { get; }
Public ReadOnly Property Numeric As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IIndexFieldNumeric
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.NumericPrecision Property

IndexFieldNumericPrecision Property

Returns the field numeric precision.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int NumericPrecision { get; }
Public ReadOnly Property NumericPrecision As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexFieldNumericPrecision
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.NumericScale Property

IndexFieldNumericScale Property

Returns the field numeric scale.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int NumericScale { get; }
Public ReadOnly Property NumericScale As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexFieldNumericScale
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.OrderNumber Property

IndexFieldOrderNumber Property

Gets the field order within the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int OrderNumber { get; }
Public ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexFieldOrderNumber
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Page Property

IndexFieldPage Property

Gets the page on which the index field resides.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPage Page { get; }
Public ReadOnly Property Page As IPage
    Get

Property Value

Type: IPage

Return Value

Type: IPage
IPage

Implements

IIndexFieldPage
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.ReadOnly Property

IndexFieldReadOnly Property

Gets or sets the read-only flag.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool ReadOnly { get; set; }
Public Property ReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IIndexFieldReadOnly
Remarks
Returns True if the field is read-only.
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Required Property

IndexFieldRequired Property

Returns the field required flag.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Required { get; }
Public ReadOnly Property Required As Boolean
    Get

Property Value

Type: Boolean
True if the field is required.

Return Value

Type: Boolean
Boolean

Implements

IIndexFieldRequired
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.SqlType Property

IndexFieldSqlType Property

Returns the field SQL type.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int SqlType { get; }
Public ReadOnly Property SqlType As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexFieldSqlType
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Sticky Property

IndexFieldSticky Property

Returns the field sticky flag.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Sticky { get; }
Public ReadOnly Property Sticky As Boolean
    Get

Property Value

Type: Boolean
True if the field is sticky.

Return Value

Type: Boolean
Boolean

Implements

IIndexFieldSticky
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.SuggestedValueCount Property

IndexFieldSuggestedValueCount Property

Returns the number of values for the field type, if any.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int SuggestedValueCount { get; }
Public ReadOnly Property SuggestedValueCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexFieldSuggestedValueCount
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.SuggestedValues Property

IndexFieldSuggestedValues Property

Returns the collection of suggested values.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ISuggestedValues SuggestedValues { get; }
Public ReadOnly Property SuggestedValues As ISuggestedValues
    Get

Property Value

Type: ISuggestedValues

Return Value

Type: ISuggestedValues
ISuggestedValues

Implements

IIndexFieldSuggestedValues
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.SuggestedValuesForceMatch Property

IndexFieldSuggestedValuesForceMatch Property

Gets or sets the force match flag for the values.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SuggestedValuesForceMatch { get; set; }
Public Property SuggestedValuesForceMatch As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean.

Implements

IIndexFieldSuggestedValuesForceMatch
Remarks
Returns True if the field is force-matched to the suggested values.
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.SuggestedValuesForceMatchCaseSensitive Property

IndexFieldSuggestedValuesForceMatchCaseSensitive Property

Gets or sets the case-sensitive flag for the values.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SuggestedValuesForceMatchCaseSensitive { get; set; }
Public Property SuggestedValuesForceMatchCaseSensitive As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IIndexFieldSuggestedValuesForceMatchCaseSensitive
Remarks
Returns True if the field is force-matched to the suggested values in case-sensitive mode.
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Table Property

IndexFieldTable Property

The table associated with the index field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ITable Table { get; }
Public ReadOnly Property Table As ITable
    Get

Property Value

Type: ITable

Return Value

Type: ITable
ITable

Implements

IIndexFieldTable
Remarks
Nothing, if a single-value index field.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Total Property

IndexFieldTotal Property

Returns True if the field is a total field.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Total { get; }
Public ReadOnly Property Total As Boolean
    Get

Property Value

Type: Boolean
True if the field is required.

Return Value

Type: Boolean
Boolean

Implements

IIndexFieldTotal
Remarks
When this object is used as a folder index field, this property has no meaning.
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.TypeCustomStorageString Property

IndexFieldTypeCustomStorageString Property

The storage string with the specified name for the field type for this object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; }
Public ReadOnly Property TypeCustomStorageString (
    strName As String
) As String
    Get

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the form type.

Property Value

Type: String

Return Value

Type: String

Implements

IIndexFieldTypeCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific field type. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist.
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.TypeName Property

IndexFieldTypeName Property

Gets the field type name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string TypeName { get; }
Public ReadOnly Property TypeName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexFieldTypeName
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.UserChanged Property

IndexFieldUserChanged Property
Marks the field as changed by the user.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool UserChanged { get; set; }
Public Property UserChanged As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean

Implements

IIndexFieldUserChanged
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.Value Property

IndexFieldValue Property

Gets or sets the field value.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IIndexFieldValue
Remarks
Values more than 254 characters are automatically truncated with no error. Setting the value of a field does not affect the database until the document is exited and the user elects to save the data. Values that do not pass validation (script failure, length restrictions, required, etc.) display an error message when the document is exited or the active field is changed. The focus is repositioned to the offending field in this case.

In a table, when the IndexField is retrieved through the Document object, the Value corresponds to the first row of the table.

When the IndexField object is retrieved through the TableRow object, the Value corresponds to a specific row.

See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.ZoneHeight Property

IndexFieldZoneHeight Property

Returns the height of the zone in BMUs (1200ths of an inch).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneHeight { get; }
Public ReadOnly Property ZoneHeight As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexFieldZoneHeight
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.ZoneLeft Property

IndexFieldZoneLeft Property

Returns the left coordinate of the zone in BMUs.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneLeft { get; }
Public ReadOnly Property ZoneLeft As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexFieldZoneLeft
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.ZoneTop Property

IndexFieldZoneTop Property

Returns the top coordinate of the zone in BMUs.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneTop { get; }
Public ReadOnly Property ZoneTop As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexFieldZoneTop
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexField.ZoneWidth Property

IndexFieldZoneWidth Property

Returns the width of the zone in BMUs.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ZoneWidth { get; }
Public ReadOnly Property ZoneWidth As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexFieldZoneWidth
Remarks
See Also

Reference

IndexField Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexFields Class

IndexFields Class

IndexFields COM implementation class.

Defines a COM collection of IndexField objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesIndexFields

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC67-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class IndexFields : IIndexFields,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC67-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class IndexFields
    Implements IIndexFields, IEnumerable, IDisposable

The IndexFields type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of IndexField objects contained in the collection.
Public property | Item | Returns the specified IndexField object.
Top
Remarks

Iteration and extraction by order number (with the item function) are supported. Passing an out-of-range or invalid parameter to the item function causes it to throw the error "Invalid Parameter" to the caller.

Note that the IndexFields collection contains both hidden and visible fields. As a result, more items may exist in the IndexFields collection than are shown on the data entry panel.

An IndexFields object is invalidated when a content change event occurs.

IndexFields can be accessed for any document, irrespective of the data entry status, in Scan, Quality Control, Validation, and Verification.

The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IndexFields Methods

IndexFields Methods

The IndexFields type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

IndexFields Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexFields.Dispose Method

IndexFieldsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

IndexFields Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexFields.GetEnumerator Method

IndexFieldsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IIndexFields object.

Implements

IIndexFieldsGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

IndexFields Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexFields Properties

IndexFields Properties

The IndexFields type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of IndexField objects contained in the collection.
Public property | Item | Returns the specified IndexField object.
Top
See Also

Reference

IndexFields Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexFields.Count Property

IndexFieldsCount Property

Returns the number of IndexField objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IIndexFieldsCount
Remarks
See Also

Reference

IndexFields Class
Kofax.Capture.CaptureModule.InteropServices Namespace


IndexFields.Item Property

IndexFieldsItem Property

Returns the specified IndexField object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexField this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IIndexField
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IIndexField

Return Value

Type: IIndexField

Implements

IIndexFieldsItemObject
Remarks
Index can either be an index field name or a numeric one-based index into the collection.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

IndexFields Class
Kofax.Capture.CaptureModule.InteropServices Namespace


INewBatchParameters Interface

INewBatchParameters Interface

Note: This API is now obsolete.

INewBatchParameters COM Interface.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ObsoleteAttribute("This interface is no longer supported.")]
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC68-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface INewBatchParameters
<ObsoleteAttribute("This interface is no longer supported.")>
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC68-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface INewBatchParameters

The INewBatchParameters type exposes the following members.

Properties
 | Name | Description
Public property | BatchClassName | Gets or sets the batch class name.
Public property | BatchName | Gets or sets the batch name.
Top
Remarks
This interface was designed for Titan project. It is no longer supported.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


INewBatchParameters Properties

INewBatchParameters Properties

The INewBatchParameters type exposes the following members.

Properties
 | Name | Description
Public property | BatchClassName | Gets or sets the batch class name.
Public property | BatchName | Gets or sets the batch name.
Top
See Also

Reference

INewBatchParameters Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


INewBatchParameters.BatchClassName Property

INewBatchParametersBatchClassName Property

Gets or sets the batch class name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string BatchClassName { get; set; }
Property BatchClassName As String
    Get
    Set

Property Value

Type: String
Batch class name for creating a batch.

Return Value

Type: String
String
Remarks
See Also

Reference

INewBatchParameters Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


INewBatchParameters.BatchName Property

INewBatchParametersBatchName Property

Gets or sets the batch name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string BatchName { get; set; }
Property BatchName As String
    Get
    Set

Property Value

Type: String
Batch name for a new batch.

Return Value

Type: String
String
Remarks
See Also

Reference

INewBatchParameters Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IObjectID Interface

IObjectID Interface

IObjectID COM Interface.

Contains the ID for an object of type Document, Page or Folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC6A-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IObjectID
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC6A-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IObjectID

The IObjectID type exposes the following members.

Properties
 | Name | Description
Public property | ID | The ID is a unique identifier for an object of type Document, Page or Folder.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IObjectID Properties

IObjectID Properties

The IObjectID type exposes the following members.

Properties
 | Name | Description
Public property | ID | The ID is a unique identifier for an object of type Document, Page or Folder.
Top
See Also

Reference

IObjectID Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IObjectID.ID Property

IObjectIDID Property

The ID is a unique identifier for an object of type Document, Page or Folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ID { get; }
ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Remarks
For example, the first page added to a batch has ID=1. The first document created also has ID=1. Only one page with ID=1 ever exists within a batch.
See Also

Reference

IObjectID Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IObjectIDs Interface

IObjectIDs Interface

IObjectIDs COM Interface.

Defines a COM collection of ObjectID objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC6C-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IObjectIDs
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC6C-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IObjectIDs

The IObjectIDs type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of Object ID objects contained in the collection.
Public property | Item | Returns the specified ObjectID objects.
Top
Remarks
Iteration and extraction by order number (with the Item function) are supported. Passing an out-of-range or invalid parameter to the item function causes it to throw the error "Invalid Parameter" to the caller. The ObjectID objects are not sorted. The ObjectID objects are valid while processing the Content Changed Event.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IObjectIDs Methods

IObjectIDs Methods

The IObjectIDs type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IObjectIDs Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IObjectIDs.GetEnumerator Method

IObjectIDsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IObjectIDs object.
See Also

Reference

IObjectIDs Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IObjectIDs Properties

IObjectIDs Properties

The IObjectIDs type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of Object ID objects contained in the collection.
Public property | Item | Returns the specified ObjectID objects.
Top
See Also

Reference

IObjectIDs Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IObjectIDs.Count Property

IObjectIDsCount Property

Returns the number of Object ID objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IObjectIDs Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IObjectIDs.Item Property

IObjectIDsItem Property

Returns the specified ObjectID objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IObjectID this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IObjectID
    Get

Parameters

vntIndexKey
Type: SystemObject
A numeric one-based index into the collection.

Property Value

Type: IObjectID

Return Value

Type: IObjectID
IObjectID
See Also

Reference

IObjectIDs Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage Interface

IPage Interface

IPage COM Interface.

Defines information about a page.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC6E-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IPage
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC6E-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IPage

The IPage type exposes the following members.

Methods
 | Name | Description
Public method | MoveToDocument | Removes the page from a batch or document and adds it to oDocument.
Public method | MoveToLoose | Either removes the page from its containing document and makes it into a batch loose page or moves the page to another location among loose pages in a batch.
Top
Properties
 | Name | Description
Public property | Blank | Gets or sets the blank property of the page
Public property | Color | Gets or sets the color flag for the page.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Document | Returns the parent document object (or nothing if a loose page).
Public property | EndorsingString | Returns the page note.
Public property | Extension | Returns the the file extension for eDocument files. For normal image files, this returns an empty string.
Public property | FileName | Gets the image file name.
Public property | ID | Returns the internal Page ID set by the data source (internal database).
Public property | ImageAddress | Returns the image address (used for endorsing).
Public property | ImportOrderNumber | Returns the order number of the original file from which this page was imported.
Public property | IsFront | Returns True if image is front page.
Public property | Note | Gets or sets the document note.
Public property | OrderNumber | Returns the page order within the document.
Public property | OriginalFileName | Allows reading or changing the original file name.
Public property | PageGUID | Returns the Page unique ID.
Public property | RegistrationConfidence | Returns the registration confidence for the page.
Public property | Rejected | Gets or sets the "rejected" flag for the document.
Public property | RollNumber | Roll number (used for endorsing).
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IPage Methods

IPage Methods

The IPage type exposes the following members.

Methods
 | Name | Description
Public method | MoveToDocument | Removes the page from a batch or document and adds it to oDocument.
Public method | MoveToLoose | Either removes the page from its containing document and makes it into a batch loose page or moves the page to another location among loose pages in a batch.
Top
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.MoveToDocument Method

IPageMoveToDocument Method

Removes the page from a batch or document and adds it to oDocument.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void MoveToDocument(
    ref IDocument oDocument,
    ref IPage oNextPage = null
)
Sub MoveToDocument (
    ByRef oDocument As IDocument,
    Optional ByRef oNextPage As IPage = Nothing
)

Parameters

oDocument
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
If oDocument is the original parent Document, the page is moved to a different location within the document.
oNextPage (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIPage
If oNextPage is Nothing, the page is added to the end. Otherwise, it is added before oNextPage.
Remarks
If the page was originally part of a document and this change renders the document empty, the document is automatically deleted.
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.MoveToLoose Method

IPageMoveToLoose Method

Either removes the page from its containing document and makes it into a batch loose page or moves the page to another location among loose pages in a batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void MoveToLoose(
    ref IPage oNextPage = null
)
Sub MoveToLoose (
    Optional ByRef oNextPage As IPage = Nothing
)

Parameters

oNextPage (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIPage
If oNextPage is Nothing, the page is added to the end. Otherwise it is added before oNextPage.
Remarks

If the page was originally part of a document and this change renders the document empty, then the document is automatically deleted as well.

Does not work in Validation or Verification if Data Entry mode is selected.

See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage Properties

IPage Properties

The IPage type exposes the following members.

Properties
 | Name | Description
Public property | Blank | Gets or sets the blank property of the page
Public property | Color | Gets or sets the color flag for the page.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Document | Returns the parent document object (or nothing if a loose page).
Public property | EndorsingString | Returns the page note.
Public property | Extension | Returns the the file extension for eDocument files. For normal image files, this returns an empty string.
Public property | FileName | Gets the image file name.
Public property | ID | Returns the internal Page ID set by the data source (internal database).
Public property | ImageAddress | Returns the image address (used for endorsing).
Public property | ImportOrderNumber | Returns the order number of the original file from which this page was imported.
Public property | IsFront | Returns True if image is front page.
Public property | Note | Gets or sets the document note.
Public property | OrderNumber | Returns the page order within the document.
Public property | OriginalFileName | Allows reading or changing the original file name.
Public property | PageGUID | Returns the Page unique ID.
Public property | RegistrationConfidence | Returns the registration confidence for the page.
Public property | Rejected | Gets or sets the "rejected" flag for the document.
Public property | RollNumber | Roll number (used for endorsing).
Top
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.Blank Property

IPageBlank Property
Gets or sets the blank property of the page

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Blank { get; set; }
Property Blank As Boolean
    Get
    Set

Property Value

Type: Boolean
Returns True if the page is blank

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.Color Property

IPageColor Property

Gets or sets the color flag for the page.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Color { get; set; }
Property Color As Boolean
    Get
    Set

Property Value

Type: Boolean
Returns True if the document is color image.

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.CustomStorageString Property

IPageCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the page. Strings stored by one component can be read by another. If set to an empty string, the storage string is deleted.

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific page. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.Document Property

IPageDocument Property

Returns the parent document object (or nothing if a loose page).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IDocument Document { get; }
ReadOnly Property Document As IDocument
    Get

Property Value

Type: IDocument

Return Value

Type: IDocument
IDocument
Remarks
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.EndorsingString Property

IPageEndorsingString Property

Returns the page note.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string EndorsingString { get; }
ReadOnly Property EndorsingString As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.Extension Property

IPageExtension Property

Returns the the file extension for eDocument files. For normal image files, this returns an empty string.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Extension { get; }
ReadOnly Property Extension As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.FileName Property

IPageFileName Property

Gets the image file name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string FileName { get; }
ReadOnly Property FileName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.ID Property

IPageID Property

Returns the internal Page ID set by the data source (internal database).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ID { get; }
ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.ImageAddress Property

IPageImageAddress Property

Returns the image address (used for endorsing).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ImageAddress { get; }
ReadOnly Property ImageAddress As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.ImportOrderNumber Property

IPageImportOrderNumber Property

Returns the order number of the original file from which this page was imported.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ImportOrderNumber { get; }
ReadOnly Property ImportOrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.IsFront Property

IPageIsFront Property

Returns True if image is front page.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool IsFront { get; }
ReadOnly Property IsFront As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.Note Property

IPageNote Property

Gets or sets the document note.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Note { get; set; }
Property Note As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.OrderNumber Property

IPageOrderNumber Property

Returns the page order within the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int OrderNumber { get; }
ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.OriginalFileName Property

IPageOriginalFileName Property

Allows reading or changing the original file name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string OriginalFileName { get; set; }
Property OriginalFileName As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks

This is the same file name value displayed and edited in the page properties dialog.

If length of the string exceeds 250 characters, or contains invalid characters, an error is generated.

See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.PageGUID Property

IPagePageGUID Property

Returns the Page unique ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string PageGUID { get; }
ReadOnly Property PageGUID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.RegistrationConfidence Property

IPageRegistrationConfidence Property

Returns the registration confidence for the page.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int RegistrationConfidence { get; }
ReadOnly Property RegistrationConfidence As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
This is filled in by the Recognition Server.
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.Rejected Property

IPageRejected Property

Gets or sets the "rejected" flag for the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Rejected { get; set; }
Property Rejected As Boolean
    Get
    Set

Property Value

Type: Boolean
Returns True if the document is rejected.

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPage.RollNumber Property

IPageRollNumber Property

Roll number (used for endorsing).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int RollNumber { get; }
ReadOnly Property RollNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IPage Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPages Interface

IPages Interface

IPages COM Interface.

Defines a COM collection of Page objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC70-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IPages
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC70-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IPages

The IPages type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | The number of Page objects contained in the collection.
Public property | Item | The default COM collection Item property that returns the specified Page object.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IPages Methods

IPages Methods

The IPages type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IPages Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPages.GetEnumerator Method

IPagesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IPages object.
See Also

Reference

IPages Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPages Properties

IPages Properties

The IPages type exposes the following members.

Properties
 | Name | Description
Public property | Count | The number of Page objects contained in the collection.
Public property | Item | The default COM collection Item property that returns the specified Page object.
Top
See Also

Reference

IPages Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPages.Count Property

IPagesCount Property

The number of Page objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IPages Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IPages.Item Property

IPagesItem Property

The default COM collection Item property that returns the specified Page object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPage this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IPage
    Get

Parameters

vntIndexKey
Type: SystemObject

Property Value

Type: IPage

Return Value

Type: IPage
Remarks
Index can either be a form type name or a numeric one-based index into the collection.
See Also

Reference

IPages Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IRGB Interface

IRGB Interface

IRGB COM Interface.

Defines Red, Green, and Blue values of a color.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC72-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IRGB
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC72-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IRGB

The IRGB type exposes the following members.

Properties
 | Name | Description
Public property | Blue | Gets the Blue value of the color.
Public property | Green | Gets the Green value of the color.
Public property | Red | Gets the Red value of the color.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IRGB Properties

IRGB Properties

The IRGB type exposes the following members.

Properties
 | Name | Description
Public property | Blue | Gets the Blue value of the color.
Public property | Green | Gets the Green value of the color.
Public property | Red | Gets the Red value of the color.
Top
See Also

Reference

IRGB Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IRGB.Blue Property

IRGBBlue Property

Gets the Blue value of the color.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
short Blue { get; }
ReadOnly Property Blue As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short
Remarks
See Also

Reference

IRGB Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IRGB.Green Property

IRGBGreen Property

Gets the Green value of the color.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
short Green { get; }
ReadOnly Property Green As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short
Remarks
See Also

Reference

IRGB Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IRGB.Red Property

IRGBRed Property

Gets the Red value of the color.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
short Red { get; }
ReadOnly Property Red As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short
Remarks
See Also

Reference

IRGB Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IScannerProfile Interface

IScannerProfile Interface

IScannerProfile COM Interface.

Defines a COM object that contains a ScannerProfile.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC74-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IScannerProfile
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC74-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IScannerProfile

The IScannerProfile type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the suggested scanner profile name.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IScannerProfile Properties

IScannerProfile Properties

The IScannerProfile type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the suggested scanner profile name.
Top
See Also

Reference

IScannerProfile Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IScannerProfile.Name Property

IScannerProfileName Property

Gets or sets the suggested scanner profile name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; set; }
Property Name As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IScannerProfile Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IScannerProfiles Interface

IScannerProfiles Interface

IScannerProfiles COM Interface.

Defines a COM collection of ScannerProfile objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC76-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface IScannerProfiles
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC76-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface IScannerProfiles

The IScannerProfiles type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of ScannerProfile objects contained in the collection.
Public property | Item | Returns the specified ScannerProfile object.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


IScannerProfiles Methods

IScannerProfiles Methods

The IScannerProfiles type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

IScannerProfiles Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IScannerProfiles.GetEnumerator Method

IScannerProfilesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IScannerProfiles object.
See Also

Reference

IScannerProfiles Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IScannerProfiles Properties

IScannerProfiles Properties

The IScannerProfiles type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of ScannerProfile objects contained in the collection.
Public property | Item | Returns the specified ScannerProfile object.
Top
See Also

Reference

IScannerProfiles Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IScannerProfiles.Count Property

IScannerProfilesCount Property

Returns the number of ScannerProfile objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
See Also

Reference

IScannerProfiles Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


IScannerProfiles.Item Property

IScannerProfilesItem Property

Returns the specified ScannerProfile object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IScannerProfile this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IScannerProfile
    Get

Parameters

vntIndexKey
Type: SystemObject
is a numeric one-based index into the collection.

Property Value

Type: IScannerProfile

Return Value

Type: IScannerProfile
IScannerProfile
Remarks
See Also

Reference

IScannerProfiles Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ISuggestedValue Interface

ISuggestedValue Interface

ISuggestedValue COM Interface.

Defines a COM object that contains a possible choice for batch field or index field values.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC78-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ISuggestedValue
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC78-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ISuggestedValue

The ISuggestedValue type exposes the following members.

Properties
 | Name | Description
Public property | OrderNumber | Gets the order number of the value.
Public property | Value | Gets or sets the suggested value.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ISuggestedValue Properties

ISuggestedValue Properties

The ISuggestedValue type exposes the following members.

Properties
 | Name | Description
Public property | OrderNumber | Gets the order number of the value.
Public property | Value | Gets or sets the suggested value.
Top
See Also

Reference

ISuggestedValue Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ISuggestedValue.OrderNumber Property

ISuggestedValueOrderNumber Property

Gets the order number of the value.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int OrderNumber { get; }
ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
The values are ordered the same as displayed in the Administration module.
See Also

Reference

ISuggestedValue Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ISuggestedValue.Value Property

ISuggestedValueValue Property

Gets or sets the suggested value.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Value { get; set; }
Property Value As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

ISuggestedValue Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ISuggestedValues Interface

ISuggestedValues Interface

ISuggestedValues COM Interface.

Defines a COM collection of SuggestedValue objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC7A-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ISuggestedValues
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC7A-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ISuggestedValues

The ISuggestedValues type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a suggested value to the SuggestedValues collection.
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | Remove | Removes a suggested value from the SuggestedValues collection.
Public method | RemoveAll | Removes all suggested values from the SuggestedValues collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of SuggestedValue objects contained in the collection.
Public property | Item | Returns the specified SuggestedValue from the collection.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ISuggestedValues Methods

ISuggestedValues Methods

The ISuggestedValues type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a suggested value to the SuggestedValues collection.
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | Remove | Removes a suggested value from the SuggestedValues collection.
Public method | RemoveAll | Removes all suggested values from the SuggestedValues collection.
Top
See Also

Reference

ISuggestedValues Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ISuggestedValues.Add Method

ISuggestedValuesAdd Method

Adds a suggested value to the SuggestedValues collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ISuggestedValue Add(
    Object Item
)
Function Add (
    Item As Object
) As ISuggestedValue

Parameters

Item
Type: SystemObject
Required. The SuggestedValue value to add.

Return Value

Type: ISuggestedValue
ISuggestedValue
Remarks
See Also

Reference

ISuggestedValues Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ISuggestedValues.GetEnumerator Method

ISuggestedValuesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.ISuggestedValues object.
See Also

Reference

ISuggestedValues Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ISuggestedValues.Remove Method

ISuggestedValuesRemove Method

Removes a suggested value from the SuggestedValues collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Remove(
    Object vntIndexKey
)
Sub Remove (
    vntIndexKey As Object
)

Parameters

vntIndexKey
Type: SystemObject
The object's key to remove. Index can either be a form type name or a numeric one-based index into the collection.
See Also

Reference

ISuggestedValues Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ISuggestedValues.RemoveAll Method

ISuggestedValuesRemoveAll Method

Removes all suggested values from the SuggestedValues collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void RemoveAll()
Sub RemoveAll
Remarks
See Also

Reference

ISuggestedValues Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ISuggestedValues Properties

ISuggestedValues Properties

The ISuggestedValues type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of SuggestedValue objects contained in the collection.
Public property | Item | Returns the specified SuggestedValue from the collection.
Top
See Also

Reference

ISuggestedValues Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ISuggestedValues.Count Property

ISuggestedValuesCount Property

Returns the number of SuggestedValue objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ISuggestedValues Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ISuggestedValues.Item Property

ISuggestedValuesItem Property

Returns the specified SuggestedValue from the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ISuggestedValue this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As ISuggestedValue
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key. Index can either be a form type name or a numeric one-based index into the collection.

Property Value

Type: ISuggestedValue

Return Value

Type: ISuggestedValue
ISuggestedValue
See Also

Reference

ISuggestedValues Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITable Interface

ITable Interface

ITable COM Interface.

Defines a COM object that defines a table in a document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC7C-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ITable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC7C-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ITable

The ITable type exposes the following members.

Methods
 | Name | Description
Public method | AddTableRow | Creates a new TableRow.
Public method | DeleteTableRow | Removes a TableRow from the table.
Top
Properties
 | Name | Description
Public property | DisplayLabel | Gets the display label of the table.
Public property | Name | Gets the name of the table.
Public property | TableRows | Gets the collection of ITableRow objects for this table.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ITable Methods

ITable Methods

The ITable type exposes the following members.

Methods
 | Name | Description
Public method | AddTableRow | Creates a new TableRow.
Public method | DeleteTableRow | Removes a TableRow from the table.
Top
See Also

Reference

ITable Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITable.AddTableRow Method

ITableAddTableRow Method

Creates a new TableRow.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ITableRow AddTableRow(
    ref ITableRow oPrevRow = null
)
Function AddTableRow (
    Optional ByRef oPrevRow As ITableRow = Nothing
) As ITableRow

Parameters

oPrevRow (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesITableRow
The new row is inserted after oPrevRow. If oPrevRow is Nothing, the new row is added as the first row.

Return Value

Type: ITableRow
ITableRow
Remarks

Errors:

(KfxApiErrBadParameterRange) if oPrevRow does not belong to this table.
See Also

Reference

ITable Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITable.DeleteTableRow Method

ITableDeleteTableRow Method

Removes a TableRow from the table.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void DeleteTableRow(
    ref ITableRow oRow
)
Sub DeleteTableRow (
    ByRef oRow As ITableRow
)

Parameters

oRow
Type: Kofax.Capture.CaptureModule.InteropServicesITableRow
The row to delete.
Remarks

Errors:

(KfxApiErrBadParameterRange) if oRow does not belong to this table.
See Also

Reference

ITable Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITable Properties

ITable Properties

The ITable type exposes the following members.

Properties
 | Name | Description
Public property | DisplayLabel | Gets the display label of the table.
Public property | Name | Gets the name of the table.
Public property | TableRows | Gets the collection of ITableRow objects for this table.
Top
See Also

Reference

ITable Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITable.DisplayLabel Property

ITableDisplayLabel Property

Gets the display label of the table.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string DisplayLabel { get; }
ReadOnly Property DisplayLabel As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

ITable Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITable.Name Property

ITableName Property

Gets the name of the table.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
Default property.
See Also

Reference

ITable Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITable.TableRows Property

ITableTableRows Property

Gets the collection of ITableRow objects for this table.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ITableRows TableRows { get; }
ReadOnly Property TableRows As ITableRows
    Get

Property Value

Type: ITableRows

Return Value

Type: ITableRows
ITableRows
Remarks
See Also

Reference

ITable Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableDefinition Interface

ITableDefinition Interface

ITableDefinition COM Interface.

Defines a table definition.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC7E-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ITableDefinition
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC7E-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ITableDefinition

The ITableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DisplayLabel | Returns the display label of the table defined in the document class.
Public property | Name | Returns the name of the table defined in the document class.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ITableDefinition Properties

ITableDefinition Properties

The ITableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DisplayLabel | Returns the display label of the table defined in the document class.
Public property | Name | Returns the name of the table defined in the document class.
Top
See Also

Reference

ITableDefinition Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableDefinition.DisplayLabel Property

ITableDefinitionDisplayLabel Property

Returns the display label of the table defined in the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string DisplayLabel { get; }
ReadOnly Property DisplayLabel As String
    Get

Property Value

Type: String

Return Value

Type: String
String
See Also

Reference

ITableDefinition Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableDefinition.Name Property

ITableDefinitionName Property

Returns the name of the table defined in the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
Default property.
See Also

Reference

ITableDefinition Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableDefinitions Interface

ITableDefinitions Interface

ITableDefinitions COM Interface.

Defines a COM object that defines a collection of tables in a document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC80-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ITableDefinitions
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC80-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ITableDefinitions

The ITableDefinitions type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of TableDefinition objects contained in the collection.
Public property | Item | Returns the specified TableDefinition object.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ITableDefinitions Methods

ITableDefinitions Methods

The ITableDefinitions type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

ITableDefinitions Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableDefinitions.GetEnumerator Method

ITableDefinitionsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.ITableDefinitions object.
See Also

Reference

ITableDefinitions Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableDefinitions Properties

ITableDefinitions Properties

The ITableDefinitions type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of TableDefinition objects contained in the collection.
Public property | Item | Returns the specified TableDefinition object.
Top
See Also

Reference

ITableDefinitions Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableDefinitions.Count Property

ITableDefinitionsCount Property

Returns the number of TableDefinition objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ITableDefinitions Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableDefinitions.Item Property

ITableDefinitionsItem Property

Returns the specified TableDefinition object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ITableDefinition this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As ITableDefinition
    Get

Parameters

vntIndexKey
Type: SystemObject
Index can either be a table definition name or a numeric one-based index into the collection.

Property Value

Type: ITableDefinition

Return Value

Type: ITableDefinition
Remarks

Errors:

(KfxApiErrBadParameterRange) illegal index value.
See Also

Reference

ITableDefinitions Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableRow Interface

ITableRow Interface

ITableRow COM Interface.

Defines a COM object that represents a row in a table.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC82-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ITableRow
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC82-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ITableRow

The ITableRow type exposes the following members.

Properties
 | Name | Description
Public property | IndexFields | Returns the collection of IndexFields for this row.
Public property | RowNumber | The (ordered) number for this row.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ITableRow Properties

ITableRow Properties

The ITableRow type exposes the following members.

Properties
 | Name | Description
Public property | IndexFields | Returns the collection of IndexFields for this row.
Public property | RowNumber | The (ordered) number for this row.
Top
See Also

Reference

ITableRow Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableRow.IndexFields Property

ITableRowIndexFields Property

Returns the collection of IndexFields for this row.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IIndexFields IndexFields { get; }
ReadOnly Property IndexFields As IIndexFields
    Get

Property Value

Type: IIndexFields

Return Value

Type: IIndexFields
IIndexFields
Remarks
See Also

Reference

ITableRow Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableRow.RowNumber Property

ITableRowRowNumber Property

The (ordered) number for this row.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int RowNumber { get; }
ReadOnly Property RowNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Remarks
Default property.
See Also

Reference

ITableRow Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableRows Interface

ITableRows Interface

ITableRows COM Interface.

Defines a COM object that represents the collection of rows in a table.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC84-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ITableRows
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC84-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ITableRows

The ITableRows type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of TableRow objects contained in the collection.
Public property | Item | Returns the specified TableRow object.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ITableRows Methods

ITableRows Methods

The ITableRows type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

ITableRows Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableRows.GetEnumerator Method

ITableRowsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.ITableRows object.
See Also

Reference

ITableRows Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableRows Properties

ITableRows Properties

The ITableRows type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of TableRow objects contained in the collection.
Public property | Item | Returns the specified TableRow object.
Top
See Also

Reference

ITableRows Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableRows.Count Property

ITableRowsCount Property

Returns the number of TableRow objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

ITableRows Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITableRows.Item Property

ITableRowsItem Property

Returns the specified TableRow object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ITableRow this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As ITableRow
    Get

Parameters

vntIndexKey
Type: SystemObject
The numeric one-based index into the collection.

Property Value

Type: ITableRow

Return Value

Type: ITableRow
ITableRow
Remarks

Default property.

Errors:

(KfxApiErrBadParameterRange) illegal index value.

See Also

Reference

ITableRows Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITables Interface

ITables Interface

ITables COM Interface.

Defines a COM object that defines a collection of tables in a document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC86-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ITables
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC86-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ITables

The ITables type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
Properties
 | Name | Description
Public property | Count | The number of Table objects contained in the collection.
Public property | Item | The default COM collection Item property that returns the specified Table object.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ITables Methods

ITables Methods

The ITables type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Top
See Also

Reference

ITables Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITables.GetEnumerator Method

ITablesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IEnumerator GetEnumerator()
Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.ITables object.
See Also

Reference

ITables Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITables Properties

ITables Properties

The ITables type exposes the following members.

Properties
 | Name | Description
Public property | Count | The number of Table objects contained in the collection.
Public property | Item | The default COM collection Item property that returns the specified Table object.
Top
See Also

Reference

ITables Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITables.Count Property

ITablesCount Property

The number of Table objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Remarks
See Also

Reference

ITables Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITables.Item Property

ITablesItem Property

The default COM collection Item property that returns the specified Table object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ITable this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As ITable
    Get

Parameters

vntIndexKey
Type: SystemObject
Index can either be a table name or a numeric one-based index into the collection.

Property Value

Type: ITable

Return Value

Type: ITable
Remarks
Default property.
See Also

Reference

ITables Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITheme Interface

ITheme Interface

ITheme COM Interface.

Defines a COM object that provides access to the theme of the Tungsten Capture system.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC88-EB60-11E1-9374-005056C00008")]
[InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)]
public interface ITheme
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC88-EB60-11E1-9374-005056C00008")>
<InterfaceTypeAttribute(ComInterfaceType.InterfaceIsDual)>
Public Interface ITheme

The ITheme type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Returns the background color of the theme.
Public property | Name | Returns the name of the theme.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ITheme Properties

ITheme Properties

The ITheme type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Returns the background color of the theme.
Public property | Name | Returns the name of the theme.
Top
See Also

Reference

ITheme Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITheme.BackgroundColor Property

IThemeBackgroundColor Property

Returns the background color of the theme.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRGB BackgroundColor { get; }
ReadOnly Property BackgroundColor As IRGB
    Get

Property Value

Type: IRGB

Return Value

Type: IRGB
IRGB
Remarks
See Also

Reference

ITheme Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


ITheme.Name Property

IThemeName Property

Returns the name of the theme.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

ITheme Interface
Kofax.Capture.CaptureModule.InteropServices Namespace


KfxApiAdminMenuItems Enumeration

KfxApiAdminMenuItems Enumeration

This enumeration represents Administration menu items.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC92-EB60-11E1-9374-005056C00008")]
public enum KfxApiAdminMenuItems
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC92-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxApiAdminMenuItems
Members
Member name | Value | Description
KfxAdminMenuFileNewBatchClass | 32780 |
KfxAdminMenuFileNewDocumentClass | 32782 |
KfxAdminMenuFileNewFolderClass | 32871 |
KfxAdminMenuFileNewFormType | 32783 |
KfxAdminMenuFileNewFieldType | 32781 |
KfxAdminMenuFileInsertDocumentClass | 32787 |
KfxAdminMenuFileInsertFolderClass | 32872 |
KfxAdminMenuFileInsertSamplesPage | 32788 |
KfxAdminMenuFileImport | 32773 |
KfxAdminMenuFileExport | 32772 |
KfxAdminMenuFilePublish | 32831 |
KfxAdminMenuFileExit | 57665 |
KfxAdminMenuEditUserTracking | 32857 |
KfxAdminMenuEditUserProfiles | 32858 |
KfxAdminMenuEditACIServerCentralSiteProfile | 32870 |
KfxAdminMenuEditACIServerRemoteSiteProfiles | 61604 |
KfxAdminMenuEditRecognitionProfiles | 32840 |
KfxAdminMenuEditImageCleanUpProfiles | 32841 |
KfxAdminMenuEditSeparationAndFormIDProfiles | 32853 |
KfxAdminMenuEditReservePatchCode | 32856 |
KfxAdminMenuEditAssignedUserProfiles | 32859 |
KfxAdminMenuEditDelete | 55041 |
KfxAdminMenuEditReplaceSamplePage | 57641 |
KfxAdminMenuEditRename | 32862 |
KfxAdminMenuEditRemoveDocument | 55052 |
KfxAdminMenuEditRemoveFolder | 55052 |
KfxAdminMenuEditDeleteAllSamplePages | 32786 |
KfxAdminMenuEditDatabaseValidation | 32861 |
KfxAdminMenuEditProperties | 55043 |
KfxAdminMenuScanStart | 27151 |
KfxAdminMenuScanStop | 27153 |
KfxAdminMenuScanPage | 27152 |
KfxAdminMenuScanSelectScanner | 54534 | Obsolete.
KfxAdminMenuScanReset | 54535 |
KfxAdminMenuScanScannerProfilesLoad | 54531 |
KfxAdminMenuScanScannerProfilesSave | 54532 |
KfxAdminMenuScanProperties | 54530 | Obsolete.
KfxAdminMenuScanDeskewSampleImages | 32864 |
KfxAdminMenuViewLastZoom | 54024 |
KfxAdminMenuViewPageWidth | 54026 |
KfxAdminMenuViewPageHeight | 54027 |
KfxAdminMenuViewWholePage | 54028 |
KfxAdminMenuViewZoom200 | 54033 |
KfxAdminMenuViewZoom150 | 54034 |
KfxAdminMenuViewZoom100 | 54035 |
KfxAdminMenuViewZoom75 | 54036 |
KfxAdminMenuViewZoom50 | 54037 |
KfxAdminMenuViewZoomCustom | 54038 |
KfxAdminMenuViewScaleToGray | 54017 |
KfxAdminMenuViewToolBarsDefinitions | 32771 |
KfxAdminMenuViewToolBarsStandardTools | 32842 | Obsolete.
KfxAdminMenuViewToolBarsZoneTools | 32790 | Obsolete.
KfxAdminMenuViewToolBarsImageTools | 54039 |
KfxAdminMenuViewToolBarsScanControls | 54529 |
KfxAdminMenuViewToolBarsStatusBar | 59393 |
KfxAdminMenuViewRefresh | 32849 |
KfxAdminMenuScriptsFieldMacro | 32850 |
KfxAdminMenuScriptsValidation | 32851 |
KfxAdminMenuScriptsRelease | 32847 |
KfxAdminMenuScriptsRecognition | 32852 |
KfxAdminMenuScriptsFolder | 32873 |
KfxAdminMenuToolsReleaseScriptManager | 32848 |
KfxAdminMenuToolsCustomModuleManager | 32855 |
KfxAdminMenuToolsWorkflowAgentManager | 61600 |
KfxAdminMenuToolsRemoteSiteManager | 61601 |
KfxAdminMenuToolsUserProfileConversionUtility | 61602 | Obsolete.
KfxAdminMenuToolsResetRegistrationPoint | 32863 |
KfxAdminMenuToolsZoneTest | 32860 |
KfxAdminMenuHelpAscentCaptureHelpTopics | 57667 |
KfxAdminMenuHelpAboutAscentCapture | 57664 |
KfxAdminMenuScanAddScanner | 54546 |
KfxAdminMenuScanColorModeBw | 63146 |
KfxAdminMenuScanColorModeGrey | 63147 |
KfxAdminMenuScanColorModeColor | 63148 |
KfxAdminMenuScanDpi | 63054 |
KfxAdminMenuScanFeederFlatbed | 63152 |
KfxAdminMenuScanFeederFeeder | 63151 |
KfxAdminMenuScanSidesSingle | 63070 |
KfxAdminMenuScanSidesDuplex | 63072 |
KfxAdminMenuScanPageSize | 63056 |
KfxAdminMenuScanOrientationPortrait | 63160 |
KfxAdminMenuScanOrientationLandscape | 63159 |
KfxAdminMenuScanAdvancedSrcProp | 63011 |
KfxAdminMenuScanScannerProfilesDelete | 54547 |
KfxAdminMenuScanSaveProfileAsShared | 54548 |
KfxAdminMenuScanRevertToSharedProfiles | 54549 |
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxAPIApplicationFunctionList Enumeration

KfxAPIApplicationFunctionList Enumeration

Defines the function list that can be blocked or restored menu bar items, context menu items, toolbar buttons, and keyboard accelerators.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC99-EB60-11E1-9374-005056C00008")]
public enum KfxAPIApplicationFunctionList
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC99-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxAPIApplicationFunctionList
Members
Member name | Value | Description
KfxApiBlockGroupBatchFunctions | 62001 |
KfxApiBlockBatchNew | 54784 |
KfxApiBlockBatchOpen | 54785 |
KfxApiBlockBatchClose | 54786 |
KfxApiBlockBatchSuspend | 54788 |
KfxApiBlockBatchDelete | 54787 |
KfxApiBlockBatchExecuteAutoFoldering | 62003 |
KfxApiBlockBatchCreateChildFolder | 54894 |
KfxApiBlockBatchProperties | 54794 |
KfxApiBlockBatchExit | 57665 |
KfxApiBlockBatchUnreleaseDocuments | 32772 |
KfxApiBlockBatchPartialReleaseErrors | 32773 |
KfxApiBlockGroupFolderFunctions | 62006 |
KfxApiBlockFolderCreateChildFolder | 56510 |
KfxApiBlockFolderChangeFolderClass | 56506 |
KfxApiBlockFolderDelete | 54895 |
KfxApiBlockFolderNext | 54898 |
KfxApiBlockFolderPrevious | 54899 |
KfxApiBlockFolderFirst | 54896 |
KfxApiBlockFolderLast | 54897 |
KfxApiBlockGroupDocumentFunctions | 62007 |
KfxApiBlockDocumentCombine | 54978 |
KfxApiBlockDocumentChangeFormType | 54977 |
KfxApiBlockDocumentReject | 55001 |
KfxApiBlockDocumentUnreject | 55003 |
KfxApiBlockDocumentRotateAndSaveLeft | 55007 |
KfxApiBlockDocumentRotateAndSaveRight | 55005 |
KfxApiBlockDocumentDelete | 55009 |
KfxApiBlockDocumentNext | 54903 |
KfxApiBlockDocumentPrevious | 54904 |
KfxApiBlockDocumentFirst | 54901 |
KfxApiBlockDocumentLast | 54902 |
KfxApiBlockDocumentGoto | 54900 |
KfxApiBlockDocumentProperties | 55044 |
KfxApiBlockDocumentCreateFolder | 56507 |
KfxApiBlockDocumentSaveDocument | 54799 |
KfxApiBlockDocumentUnprocessed | 62008 |
KfxApiBlockDocumentVerify | 62009 |
KfxApiBlockGroupPageFunctions | 62010 |
KfxApiBlockPageCreateDocument | 54970 |
KfxApiBlockPageSplitDocument | 54939 |
KfxApiBlockPageReject | 62011 |
KfxApiBlockPageUnreject | 62012 |
KfxApiBlockPageVRSQCLater | 56505 |
KfxApiBlockPageRotateAndSaveLeft | 55006 |
KfxApiBlockPageRotateAndSaveRight | 55004 |
KfxApiBlockPageReplace | 54795 |
KfxApiBlockPageMarkNonBlank | 40002 |
KfxApiBlockPageDelete | 55008 |
KfxApiBlockPageInsert | 54792 |
KfxApiBlockPageNext | 54944 |
KfxApiBlockPagePrevious | 54945 |
KfxApiBlockPageFirst | 54946 |
KfxApiBlockPageLast | 54947 |
KfxApiBlockPageGoto | 54948 |
KfxApiBlockPageProperties | 55045 |
KfxApiBlockPageReview | 54961 |
KfxApiBlockGroupFieldFunctions | 62013 |
KfxApiBlockFieldNext | 54980 |
KfxApiBlockFieldPrevious | 54981 |
KfxApiBlockFieldInsertRowAbove | 56514 |
KfxApiBlockFieldInsertRowBelow | 56515 |
KfxApiBlockFieldDeleteRow | 56516 |
KfxApiBlockGroupScanFunctions | 62014 |
KfxApiBlockScanSource | 62015 |
KfxApiBlockScanStart | 27151 |
KfxApiBlockScanStop | 27153 |
KfxApiBlockScanScanPage | 27152 |
KfxApiBlockScanUnattendedMode | 54540 |
KfxApiBlockScanReset | 54535 |
KfxApiBlockScanEnableDuplexOnSimplex | 54536 |
KfxApiBlockScanScannerProfilesLoad | 54531 |
KfxApiBlockScanScannerProfilesSave | 54532 |
KfxApiBlockScanProperties | 54530 | Obsolete.
KfxApiBlockScanAddScanner | 54546 |
KfxApiBlockScanColorModeBw | 63146 |
KfxApiBlockScanColorModeGrey | 63147 |
KfxApiBlockScanColorModeColor | 63148 |
KfxApiBlockScanDpi | 63054 |
KfxApiBlockScanFeederFlatbed | 63152 |
KfxApiBlockScanFeederFeeder | 63151 |
KfxApiBlockScanSidesSingle | 63070 |
KfxApiBlockScanSidesDuplex | 63072 |
KfxApiBlockScanPageSize | 63056 |
KfxApiBlockScanOrientationPortrait | 63160 |
KfxApiBlockScanOrientationLandscape | 63159 |
KfxApiBlockScanAdvancedSrcProp | 63011 |
KfxApiBlockScanScannerProfilesDelete | 54547 |
KfxApiBlockScanSaveProfilesAsShared | 54548 |
KfxApiBlockScanRevertToSharedProfiles | 54549 |
KfxApiBlockGroupViewFunctions | 62016 |
KfxApiBlockGroupViewZoomFunctions | 62017 |
KfxApiBlockViewZoomCombo | 62018 |
KfxApiBlockViewZoom200 | 54033 |
KfxApiBlockViewZoom150 | 54034 |
KfxApiBlockViewZoom100 | 54035 |
KfxApiBlockViewZoom75 | 54036 |
KfxApiBlockViewZoom50 | 54037 |
KfxApiBlockViewCustomZoom | 54038 |
KfxApiBlockViewZoomButtonPan | 62019 |
KfxApiBlockViewZoomButtonZoom | 62020 |
KfxApiBlockViewZoomButtonIn | 62021 |
KfxApiBlockViewZoomButtonOut | 62022 |
KfxApiBlockViewPageWidth | 54026 |
KfxApiBlockViewPageHeight | 54027 |
KfxApiBlockViewWholePage | 54028 |
KfxApiBlockViewScaleToGray | 62023 |
KfxApiBlockViewViewBitonalImage | 54050 |
KfxApiBlockViewExpandBatchContentsTree | 56502 |
KfxApiBlockGroupViewToolBarsFunctions | 62024 |
KfxApiBlockViewToolBarsBatchContents | 62025 |
KfxApiBlockViewToolBarsBatchThumbnails | 62026 |
KfxApiBlockViewToolBarsNotes | 62027 |
KfxApiBlockViewToolBarsBatchNavigation | 62028 |
KfxApiBlockViewToolBarsBatchFilters | 62029 | Obsolete.
KfxApiBlockViewToolBarsImageTools | 62030 |
KfxApiBlockViewToolBarsBatchTools | 62031 | Obsolete.
KfxApiBlockViewToolBarsScanControls | 62032 |
KfxApiBlockViewToolBarsStatusBar | 62033 |
KfxApiBlockViewToolbarsLockToolbars | 62034 |
KfxApiBlockViewToolBarsValidationNavigation | 62035 | Obsolete.
KfxApiBlockViewToolBarsIndexPanel | 62036 |
KfxApiBlockViewRestoreToolbarDefaults | 62037 |
KfxApiBlockViewValidationModeDataEntry | 54982 |
KfxApiBlockViewValidationModeBatchEditing | 54983 |
KfxApiBlockViewMagnifyZone | 54029 |
KfxApiBlockViewAnchorZone | 54030 |
KfxApiBlockViewPanToZone | 54031 |
KfxApiBlockViewManualZoom | 54032 |
KfxApiBlockViewRetainZoom | 54045 |
KfxApiBlockGroupToolsFunctions | 62038 |
KfxApiBlockGroupToolsFilterFunctions | 62039 |
KfxApiBlockToolsFilterCombo | 62040 |
KfxApiBlockToolsFilterAll | 54953 |
KfxApiBlockToolsFilterRejected | 54954 |
KfxApiBlockToolsFilterUnprocessed | 54962 |
KfxApiBlockToolsFilterUnreviewed | 54955 |
KfxApiBlockToolsFilterUnverifiedForm | 54963 |
KfxApiBlockToolsCut | 62041 |
KfxApiBlockToolsPaste | 62042 |
KfxApiBlockToolsOptions | 55042 |
KfxApiBlockGroupHelpFunctions | 62043 |
KfxApiBlockHelpAscentCaptureHelpTopics | 62044 |
KfxApiBlockHelpAboutAscentCapture | 57664 |
KfxApiBlockGroupDeleteFunctions | 62047 |
KfxApiBlockGroupViewLayoutFunctions | 62048 |
KfxApiBlockViewDisplayLayoutAll | 27198 |
KfxApiBlockViewDisplayLayoutBox | 27600 |
KfxApiBlockViewDisplayLayoutTwoRows | 27601 |
KfxApiBlockViewDisplayLayoutThreeRows | 27602 |
KfxApiBlockViewDisplayLayoutTwoColumns | 27603 |
KfxApiBlockViewDisplayLayoutSplitBottom | 27604 |
KfxApiBlockViewDisplayLayoutSplitSize | 27605 |
KfxApiBlockViewZoomSlider | 54553 |
KfxApiBlockViewZoomGroupZoom | 27329 |
KfxApiBlockViewPanMode | 54291 |
KfxApiBlockBatchFilter | 54790 |
KfxApiBlockHomeScanFront | 29000 |
KfxApiBlockHomeScanBack | 29001 |
KfxApiBlockScanSettingsDisplayBlankPages | 54566 |
KfxApiBlockInsertToolPaste | 57637 |
KfxApiBlockInsertToolCopy | 57634 |
KfxApiBlockInsertToolCut | 57635 |
KfxApiBlockHomeModeRubberBand | 54046 |
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxApiBatchState Enumeration

KfxApiBatchState Enumeration

This enumeration represents Batch states.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC98-EB60-11E1-9374-005056C00008")]
public enum KfxApiBatchState
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC98-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxApiBatchState
Members
Member name | Value | Description
KfxApiBatchStateReady | 2 | Batch is ready.
KfxApiBatchStateInProgress | 4 | Batch is in progress.
KfxApiBatchStateSuspended | 8 | Batch is suspended.
KfxApiBatchStateError | 32 | Batch is in error.
KfxApiBatchStateCompleted | 64 | Batch is in the completed state.
KfxApiBatchStateReserved | 128 | Reserved.
KfxApiBatchStateInProgress2 | 512 | Reserved.
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxApiErr Enumeration

KfxApiErr Enumeration

Defines the possible errors. All errors are exposed in the KfxApiErr enum value within the Tungsten Capture Module Type Library.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC8D-EB60-11E1-9374-005056C00008")]
public enum KfxApiErr
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC8D-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxApiErr
Members
Member name | Value | Description
KfxApiErrNullParameter | 2100 | A property received an invalid, null value.
KfxApiErrBadParameterType | 2101 | Parameter type mismatch.
KfxApiErrBadParameterArray | 2102 | Internal parameter array error.
KfxApiErrBadParameterRange | 2104 | Parameter out of range.
KfxApiErrInvalidObject | 2105 | The object is no longer valid.
KfxApiErrNotDataEntryMode | 2106 | The operation is only valid in data entry mode with the current document.
KfxApiErrRequiresNumericField | 2107 | The operation is only valid on a numeric field.
KfxApiErrRequiresCharacterField | 2108 | The operation is only valid on a character field.
KfxApiErrNoFormType | 2109 | No form type has been assigned.
KfxApiErrNoReleaseScript | 2110 | No export connector has been assigned.
KfxApiErrInternal | 2111 | Internal API error.
KfxApiErrUnknown | 2112 | Unknown API exception.
KfxApiErrNotDuringEvent | 2113 | Operation not allowed while processing an event.
KfxApiErrDupliateMenuItem | 2114 | Duplicate menu item. The menu cannot be added.
KfxApiErrNoMenuResources | 2115 | Menu resources have been used up. New menus cannot be added.
KfxApiErrNoAcWorkFlow | 2116 | Not available in this application.
KfxApiErrXmlExport | 2117 | XML export failed.
KfxApiErrMenuItemGrayedOut | 2118 | The selected menu item is currently unavailable.
KfxApiErrAppIsBusy | 2119 | The application is busy. The operation was ignored.
KfxApiErrExitNSendImmediate | 2120 | The selected menu item does not handle the immediate option set to true.
KfxApiErrInvalidLogin | 2121 | The user or password is not valid.
KfxApiErrNotPrivileged | 2122 | Insufficient privilege to perform operation.
KfxApiErrBatchOpened | 2123 | A batch is already opened.
KfxApiErrRequiredBatchField | 2124 | A required batch field is not set.
KfxApiErrExpectedBatchTotal | 2125 | An expected batch total is not set.
KfxApiErrNoPagesOrDocs | 2126 | The batch contains no pages or documents.
KfxApiErrEmptyDocs | 2127 | The batch contains empty documents.
KfxApiErrFileNotFound | 2128 | File not found or is not accessible.
KfxApiErrFileFormat | 2129 | File is not of an acceptable format.
KfxApiErrNoMorePages | 2130 | No more pages are left on the license.
KfxApiErrWrongModule | 2131 |
KfxApiErrDuplicateObject | 2132 | A duplicate object already exists.
KfxApiErrOperationCanceled | 2133 | Operation canceled.
KfxApiErrBatchTotals | 2134 | Batch totals mismatch.
KfxApiErrRejectedObject | 2135 | The batch contains rejected documents or pages.
KfxApiErrUnreviewedPages | 2136 | The batch contains unreviewed pages.
KfxApiErrUnverifiedDocs | 2137 | The batch contains unverified documents.
KfxApiErrEmptyBacksides | 2138 | The batch contains empty backside pages.
KfxApiErrPageCountMismatch | 2139 | Expected page count does not match actual page count.
KfxApiErrDocCountMismatch | 2140 | Expected document count does not match actual document count.
KfxApiErrBatchNotOpened | 2141 | A batch is not opened.
KfxApiErrInDataEntryMode | 2142 | Operation not available in data-entry mode.
KfxApiErrUnprocessedDocs | 2143 | The batch contains unprocessed documents.
KfxApiErrObjectinUse | 2144 | The object is in use and cannot be deleted.
KfxApiErrSuggestedValuesSet | 2145 | Suggested values must be removed before SQL type can be modified.
KfxApiErrObjectUnavailable | 2146 | Queue properties are only available to Setup OCX's.
KfxApiErrForceMatchReqSugValues | 2147 | The property SuggestedValuesForceMatchCaseSensitive cannot be set because the SuggestedValues collection is empty.
KfxApiErrForceMatchCaseSensitiveReqSugValues | 2148 | The property SuggestedValuesForceMatch cannot be set because the SuggestedValues collection is empty.
KfxApiErrForceMatchNotSet | 2149 | The property SuggestedValuesForceMatchCaseSensitive cannot be set because SuggestedValuesForceMatch is false.
KfxApiErrInvalidIndexField | 2151 | The specified index field cannot be assigned to this zone.
KfxApiErrDpiChange | 2152 | Image DPI differs from first sample page.
KfxApiErrInvalidZoneCoordinates | 2153 | Zone coordinates out of range.
KfxApiErrInvalidRecognitionProf | 2154 | The recognition profile is not valid for this index zone.
KfxApiErrNotInWorkflow | 2155 | The specified queue is not in the workflow.
KfxApiErrNoEndorsing | 2156 | Endorsing is not enabled.
KfxApiErrNotFixedPages | 2157 | This batch class does not use fixed page separation.
KfxApiErrLoggedIn | 2158 | That operation is not valid when the system is logged in.
KfxApiErrNoAvailableBatches | 2159 |
KfxApiErrSecurityBoostNoPermOnWin2k | 2160 | No batches are available for processing by the current queue.
KfxApiErrAlterActiveTable | 2163 | The operation is not valid when the table contains the active field.
KfxApiErrObjectLocked | 2164 | Unable to seize a required semaphore.
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxApiQCMenuItems Enumeration

KfxApiQCMenuItems Enumeration

This enumeration represents Quality Control menu items.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC94-EB60-11E1-9374-005056C00008")]
public enum KfxApiQCMenuItems
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC94-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxApiQCMenuItems
Members
Member name | Value | Description
KfxQCMenuBatchOpen | 54785 |
KfxQCMenuBatchClose | 54786 |
KfxQCMenuBatchSuspend | 54788 |
KfxQCMenuBatchDelete | 54787 |
KfxQCMenuBatchUnreleaseDocuments | 32772 |
KfxQCMenuBatchProperties | 54794 |
KfxQCMenuBatchExit | 57665 |
KfxQCMenuDocumentCombine | 54978 |
KfxQCMenuDocumentChangeFormType | 54977 |
KfxQCMenuDocumentReject | 55001 |
KfxQCMenuDocumentUnreject | 55003 |
KfxQCMenuDocumentVerify | 54960 |
KfxQCMenuDocumentRotateAndSaveRight | 55005 |
KfxQCMenuDocumentRotateAndSaveLeft | 55007 |
KfxQCMenuDocumentDelete | 55009 |
KfxQCMenuDocumentNext | 54903 |
KfxQCMenuDocumentPrevious | 54904 |
KfxQCMenuDocumentFirst | 54901 |
KfxQCMenuDocumentLast | 54902 |
KfxQCMenuDocumentGoto | 54900 |
KfxQCMenuDocumentProperties | 55044 |
KfxQCMenuPageCreateDocument | 54970 |
KfxQCMenuPageSplitDocument | 54939 |
KfxQCMenuPageReject | 55000 |
KfxQCMenuPageUnreject | 55002 |
KfxQCMenuPageReview | 54961 |
KfxQCMenuPageRotateAndSaveRight | 55004 |
KfxQCMenuPageRotateAndSaveLeft | 55006 |
KfxQCMenuPageDelete | 55008 |
KfxQCMenuPageReplace | 54795 |
KfxQCMenuPageInsert | 54792 |
KfxQCMenuPageNext | 54944 |
KfxQCMenuPagePrevious | 54945 |
KfxQCMenuPageFirst | 54946 |
KfxQCMenuPageLast | 54947 |
KfxQCMenuPageGoto | 54948 |
KfxQCMenuPageProperties | 55045 |
KfxQCMenuScanStart | 27151 |
KfxQCMenuScanStop | 27153 |
KfxQCMenuScanScanPage | 27152 |
KfxQCMenuScanReset | 54535 |
KfxQCMenuScanEnableDuplexOnSimplex | 54536 |
KfxQCMenuScanScannerProfilesLoad | 54531 |
KfxQCMenuScanScannerProfilesSave | 54532 |
KfxQCMenuScanProperites | 54530 | Obsolete.
KfxQCMenuViewLastZoom | 54024 |
KfxQCMenuViewPageWidth | 54026 |
KfxQCMenuViewPageHeight | 54027 |
KfxQCMenuViewWholePage | 54028 |
KfxQCMenuViewZoom200 | 54033 |
KfxQCMenuViewZoom150 | 54034 |
KfxQCMenuViewZoom100 | 54035 |
KfxQCMenuViewZoom75 | 54036 |
KfxQCMenuViewZoom50 | 54037 |
KfxQCMenuViewZoomCustom | 54038 |
KfxQCMenuViewScaleToGray | 54017 |
KfxQCMenuViewViewBitonalImage | 54050 |
KfxQCMenuViewExpandBatchContentsTree | 56502 |
KfxQCMenuViewToolBarsBatchContents | 54921 |
KfxQCMenuViewToolBarsBatchThumbnails | 54925 |
KfxQCMenuViewToolBarsBatchTools | 54923 | Obsolete.
KfxQCMenuViewToolBarsBatchNavigation | 54924 |
KfxQCMenuViewToolBarsBatchFilter | 54956 | Obsolete.
KfxQCMenuViewToolBarsImageTools | 54039 |
KfxQCMenuViewToolBarsScanControls | 54529 |
KfxQCMenuViewToolBarsNotes | 54922 |
KfxQCMenuViewToolBarsStatusBar | 59393 |
KfxQCMenuToolsFilterAll | 54953 |
KfxQCMenuToolsFilterRejected | 54954 |
KfxQCMenuToolsFilterUnreviewedPages | 54955 |
KfxQCMenuToolsFilterUnreviewedDocs | 54963 |
KfxQCMenuToolsOptions | 55042 |
KfxQCMenuHelpAscentCaptureHelpTopics | 57667 |
KfxQCMenuHelpAboutAscentCapture | 57664 |
KfxQCMenuBatchPartialReleaseErrors | 32773 |
KfxQCMenuPageVRSQCLater | 56505 |
KfxQCMenuBatchExecuteAutoFoldering | 56504 |
KfxQCMenuBatchCreateChildFolder | 54894 |
KfxQCMenuFolderCreateChildFolder | 56510 |
KfxQCMenuFolderChangeFolderClass | 56506 |
KfxQCMenuFolderDelete | 54895 |
KfxQCMenuFolderNext | 54898 |
KfxQCMenuFolderPrevious | 54899 |
KfxQCMenuFolderFirst | 54896 |
KfxQCMenuFolderLast | 54897 |
KfxQCMenuDocumentCreateFolder | 56507 |
KfxQCMenuScanAddScanner | 54546 |
KfxQCMenuScanColorModeBw | 63146 |
KfxQCMenuScanColorModeGrey | 63147 |
KfxQCMenuScanColorModeColor | 63148 |
KfxQCMenuScanDpi | 63054 |
KfxQCMenuScanFeederFlatbed | 63152 |
KfxQCMenuScanFeederFeeder | 63151 |
KfxQCMenuScanSidesSingle | 63070 |
KfxQCMenuScanSidesDuplex | 63072 |
KfxQCMenuScanPageSize | 63056 |
KfxQCMenuScanOrientationPortrait | 63160 |
KfxQCMenuScanOrientationLandscape | 63159 |
KfxQCMenuScanAdvancedSrcProp | 63011 |
KfxQCMenuScanScannerProfilesDelete | 54547 |
KfxQCMenuScanSaveProfileAsShared | 54548 |
KfxQCMenuScanRevertToSharedProfiles | 54549 |
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxApiScanMenuItems Enumeration

KfxApiScanMenuItems Enumeration

This enumeration represents Scan menu items.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC93-EB60-11E1-9374-005056C00008")]
public enum KfxApiScanMenuItems
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC93-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxApiScanMenuItems
Members
Member name | Value | Description
KfxScanMenuBatchNew | 54784 |
KfxScanMenuBatchOpen | 54785 |
KfxScanMenuBatchClose | 54786 |
KfxScanMenuBatchSuspend | 54788 |
KfxScanMenuBatchDelete | 54787 |
KfxScanMenuBatchProperties | 54794 |
KfxScanMenuBatchExit | 57665 |
KfxScanMenuDocumentCombine | 54978 |
KfxScanMenuDocumentChangeFormType | 54977 |
KfxScanMenuDocumentReject | 55001 |
KfxScanMenuDocumentUnreject | 55003 |
KfxScanMenuDocumentRotateAndSaveRight | 55005 |
KfxScanMenuDocumentRotateAndSaveLeft | 55007 |
KfxScanMenuDocumentDelete | 55009 |
KfxScanMenuDocumentNext | 54903 |
KfxScanMenuDocumentPrevious | 54904 |
KfxScanMenuDocumentFirst | 54901 |
KfxScanMenuDocumentLast | 54902 |
KfxScanMenuDocumentGoto | 54900 |
KfxScanMenuDocumentProperties | 55044 |
KfxScanMenuPageCreateDocument | 54970 |
KfxScanMenuPageSplitDocument | 54939 |
KfxScanMenuPageReject | 55000 |
KfxScanMenuPageUnreject | 55002 |
KfxScanMenuPageRotateAndSaveRight | 55004 |
KfxScanMenuPageRotateAndSaveLeft | 55006 |
KfxScanMenuPageDelete | 55008 |
KfxScanMenuPageReplace | 54795 |
KfxScanMenuPageInsert | 54792 |
KfxScanMenuPageNext | 54944 |
KfxScanMenuPagePrevious | 54945 |
KfxScanMenuPageFirst | 54946 |
KfxScanMenuPageLast | 54947 |
KfxScanMenuPageGoto | 54948 |
KfxScanMenuPageProperties | 55045 |
KfxScanMenuScanStart | 27151 |
KfxScanMenuScanStop | 27153 |
KfxScanMenuScanScanPage | 27152 |
KfxScanMenuScanUnattendedMode | 54540 |
KfxScanMenuScanReset | 54535 |
KfxScanMenuScanEnableDuplexOnSimplex | 54536 |
KfxScanMenuScanScannerProfilesLoad | 54531 |
KfxScanMenuScanScannerProfilesSave | 54532 |
KfxScanMenuScanProperties | 54530 | Obsolete.
KfxScanMenuViewLastZoom | 54024 |
KfxScanMenuViewPageWidth | 54026 |
KfxScanMenuViewPageHeight | 54027 |
KfxScanMenuViewWholePage | 54028 |
KfxScanMenuViewZoom200 | 54033 |
KfxScanMenuViewZoom150 | 54034 |
KfxScanMenuViewZoom100 | 54035 |
KfxScanMenuViewZoom75 | 54036 |
KfxScanMenuViewZoom50 | 54037 |
KfxScanMenuViewCustomZoom | 54038 |
KfxScanMenuViewScaleToGray | 54017 |
KfxScanMenuViewViewBitonalImage | 54050 |
KfxScanMenuViewExpandBatchContentsTree | 56502 |
KfxScanMenuViewToolBarsBatchContents | 54921 |
KfxScanMenuViewToolBarsBatchThumbnails | 54925 |
KfxScanMenuViewToolBarsBatchTools | 54923 | Obsolete.
KfxScanMenuViewToolBarsBatchNavigation | 54924 |
KfxScanMenuViewToolBarsBatchFilters | 54956 | Obsolete.
KfxScanMenuViewToolBarsImageTools | 54039 |
KfxScanMenuViewToolBarsScanControls | 54529 |
KfxScanMenuViewToolBarsNotes | 54922 |
KfxScanMenuViewStatusBar | 59393 |
KfxScanMenuToolsFilterAll | 54953 |
KfxScanMenuToolsFilterRejected | 54954 |
KfxScanMenuToolsOptions | 55042 |
KfxScanMenuHelpAscentCaptureHelpTopics | 57667 |
KfxScanMenuHelpAboutAscentCapture | 57664 |
KfxScanMenuPageVRSQCLater | 56505 |
KfxScanMenuBatchExecuteAutoFoldering | 56504 |
KfxScanMenuBatchCreateChildFolder | 54894 |
KfxScanMenuFolderCreateChildFolder | 56510 |
KfxScanMenuFolderChangeFolderClass | 56506 |
KfxScanMenuFolderDelete | 54895 |
KfxScanMenuFolderNext | 54898 |
KfxScanMenuFolderPrevious | 54899 |
KfxScanMenuFolderFirst | 54896 |
KfxScanMenuFolderLast | 54897 |
KfxScanMenuDocumentCreateFolder | 56507 |
KfxScanMenuScanAddScanner | 54546 |
KfxScanMenuScanColorModeBw | 63146 |
KfxScanMenuScanColorModeGrey | 63147 |
KfxScanMenuScanColorModeColor | 63148 |
KfxScanMenuScanDpi | 63054 |
KfxScanMenuScanFeederFlatbed | 63152 |
KfxScanMenuScanFeederFeeder | 63151 |
KfxScanMenuScanSidesSingle | 63070 |
KfxScanMenuScanSidesDuplex | 63072 |
KfxScanMenuScanPageSize | 63056 |
KfxScanMenuScanOrientationPortrait | 63160 |
KfxScanMenuScanOrientationLandscape | 63159 |
KfxScanMenuScanAdvancedSrcProp | 63011 |
KfxScanMenuScanScannerProfilesDelete | 54547 |
KfxScanMenuScanSaveProfileAsShared | 54548 |
KfxScanMenuScanRevertToSharedProfiles | 54549 |
KfxScanMenuScanDisplayBlankPages | 54566 |
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxApiValidationMenuItems Enumeration

KfxApiValidationMenuItems Enumeration

This enumeration represents Validation menu items.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC95-EB60-11E1-9374-005056C00008")]
public enum KfxApiValidationMenuItems
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC95-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxApiValidationMenuItems
Members
Member name | Value | Description
KfxValidationMenuBatchOpen | 54785 |
KfxValidationMenuBatchClose | 54786 |
KfxValidationMenuBatchSuspend | 54788 |
KfxValidationMenuBatchDelete | 54787 |
KfxValidationMenuBatchProperties | 54794 |
KfxValidationMenuBatchExit | 57665 |
KfxValidationMenuDocumentSaveDocument | 54799 |
KfxValidationMenuDocumentCombine | 54978 |
KfxValidationMenuDocumentChangeFormType | 54977 |
KfxValidationMenuDocumentReject | 55001 |
KfxValidationMenuDocumentUnreject | 55003 |
KfxValidationMenuDocumentRotateAndSaveRight | 55005 |
KfxValidationMenuDocumentRotateAndSaveLeft | 55007 |
KfxValidationMenuDocumentDelete | 55009 |
KfxValidationMenuDocumentNext | 54903 |
KfxValidationMenuDocumentPrevious | 54904 |
KfxValidationMenuDocumentFirst | 54901 |
KfxValidationMenuDocumentLast | 54902 |
KfxValidationMenuDocumentGoto | 54900 |
KfxValidationMenuDocumentNextUnprocessed | 54905 |
KfxValidationMenuDocumentProperties | 55044 |
KfxValidationMenuPageCreateDocument | 54970 |
KfxValidationMenuPageSplitDocument | 54939 |
KfxValidationMenuPageReject | 55000 |
KfxValidationMenuPageUnreject | 55002 |
KfxValidationMenuPageRotateAndSaveRight | 55004 |
KfxValidationMenuPageRotateAndSaveLeft | 55006 |
KfxValidationMenuPageDelete | 55008 |
KfxValidationMenuPageNext | 54944 |
KfxValidationMenuPagePrevious | 54945 |
KfxValidationMenuPageFirst | 54946 |
KfxValidationMenuPageLast | 54947 |
KfxValidationMenuPageGoto | 54948 |
KfxValidationMenuPageProperties | 55045 |
KfxValidationMenuFieldNext | 54980 |
KfxValidationMenuFieldPrevious | 54981 |
KfxValidationMenuViewLastZoom | 54024 |
KfxValidationMenuViewPageWidth | 54026 |
KfxValidationMenuViewPageHeight | 54027 |
KfxValidationMenuViewWholePage | 54028 |
KfxValidationMenuViewZoom200 | 54033 |
KfxValidationMenuViewZoom150 | 54034 |
KfxValidationMenuViewZoom100 | 54035 |
KfxValidationMenuViewZoom75 | 54036 |
KfxValidationMenuViewZoom50 | 54037 |
KfxValidationMenuViewZoomCustom | 54038 |
KfxValidationMenuViewMagnifyZone | 54029 |
KfxValidationMenuViewAnchorZone | 54030 |
KfxValidationMenuViewPanToZone | 54031 |
KfxValidationMenuViewManualZoom | 54032 |
KfxValidationMenuViewRetainZoom | 54045 |
KfxValidationMenuViewScaleToGray | 54017 |
KfxValidationMenuViewViewBitonalImage | 54050 |
KfxValidationMenuViewExpandBatchContentsTree | 56502 |
KfxValidationMenuViewToolBarsBatchContents | 54921 |
KfxValidationMenuViewToolBarsBatchThumbnails | 54925 |
KfxValidationMenuViewToolBarsBatchTools | 54923 | Obsolete.
KfxValidationMenuViewToolBarsBatchNavigation | 54924 |
KfxValidationMenuViewToolBarsBatchFilters | 54956 | Obsolete.
KfxValidationMenuViewToolBarsImageTools | 54039 |
KfxValidationMenuViewToolBarsNotes | 54922 |
KfxValidationMenuViewToolBarsValidationNavigation | 54984 | Obsolete.
KfxValidationMenuViewToolBarsIndexFields | 54272 |
KfxValidationMenuViewToolBarsStatusBar | 59393 |
KfxValidationMenuToolsFilterAll | 54953 |
KfxValidationMenuToolsFilterRejected | 54954 |
KfxValidationMenuToolsFilterUnprocessed | 54962 |
KfxValidationMenuToolsOptions | 55042 |
KfxValidationMenuHelpAscentCaptureHelpTopics | 57667 |
KfxValidationMenuHelpAboutAscentCapture | 57664 |
KfxValidationMenuViewValidationModeDataEntry | 54982 |
KfxValidationMenuViewValidationModeBatchEditing | 54983 |
KfxValidationMenuBatchExecuteAutoFoldering | 56504 |
KfxValidationMenuBatchCreateChildFolder | 54894 |
KfxValidationMenuFolderCreateChildFolder | 56510 |
KfxValidationMenuFolderChangeFolderClass | 56506 |
KfxValidationMenuFolderDelete | 54895 |
KfxValidationMenuFolderNext | 54898 |
KfxValidationMenuFolderPrevious | 54899 |
KfxValidationMenuFolderFirst | 54896 |
KfxValidationMenuFolderLast | 54897 |
KfxValidationMenuDocumentCreateFolder | 56507 |
KfxValidationMenuFieldInsertRowAbove | 56514 |
KfxValidationMenuFieldInsertRowBelow | 56515 |
KfxValidationMenuFieldDeleteRow | 56516 |
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxApiValidationMode Enumeration

KfxApiValidationMode Enumeration

This enumeration represents Validation modes.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC97-EB60-11E1-9374-005056C00008")]
public enum KfxApiValidationMode
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC97-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxApiValidationMode
Members
Member name | Value | Description
KfxApiValidationModeDataEntry | 0 | Mode data entry.
KfxApiValidationModeBatchEditing | 1 | Mode batch editting.
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxApiVerificationMenuItems Enumeration

KfxApiVerificationMenuItems Enumeration

This enumeration represents Verification menu items.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC96-EB60-11E1-9374-005056C00008")]
public enum KfxApiVerificationMenuItems
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC96-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxApiVerificationMenuItems
Members
Member name | Value | Description
KfxVerificationMenuBatchOpen | 54785 |
KfxVerificationMenuBatchClose | 54786 |
KfxVerificationMenuBatchSuspend | 54788 |
KfxVerificationMenuBatchDelete | 54787 |
KfxVerificationMenuBatchProperties | 54794 |
KfxVerificationMenuBatchExit | 57665 |
KfxVerificationMenuDocumentSaveDocument | 54799 |
KfxVerificationMenuDocumentCombine | 54978 |
KfxVerificationMenuDocumentChangeFormType | 54977 |
KfxVerificationMenuDocumentReject | 55001 |
KfxVerificationMenuDocumentUnreject | 55003 |
KfxVerificationMenuDocumentRotateAndSaveRight | 55005 |
KfxVerificationMenuDocumentRotateAndSaveLeft | 55007 |
KfxVerificationMenuDocumentDelete | 55009 |
KfxVerificationMenuDocumentNext | 54903 |
KfxVerificationMenuDocumentPrevious | 54904 |
KfxVerificationMenuDocumentFirst | 54901 |
KfxVerificationMenuDocumentLast | 54902 |
KfxVerificationMenuDocumentGoto | 54900 |
KfxVerificationMenuDocumentUnprocessed | 54905 |
KfxVerificationMenuDocumentProperties | 55044 |
KfxVerificationMenuPageCreateDocument | 54970 |
KfxVerificationMenuPageSplitDocument | 54939 |
KfxVerificationMenuPageReject | 55000 |
KfxVerificationMenuPageUnreject | 55002 |
KfxVerificationMenuPageRotateAndSaveRight | 55004 |
KfxVerificationMenuPageRotateAndSaveLeft | 55006 |
KfxVerificationMenuPageDelete | 55008 |
KfxVerificationMenuPageNext | 54944 |
KfxVerificationMenuPagePrevious | 54945 |
KfxVerificationMenuPageFirst | 54946 |
KfxVerificationMenuPageLast | 54947 |
KfxVerificationMenuPageGoto | 54948 |
KfxVerificationMenuPageProperties | 55045 |
KfxVerificationMenuFieldNext | 54911 |
KfxVerificationMenuFieldPrevious | 54912 |
KfxVerificationMenuViewLastZoom | 54024 |
KfxVerificationMenuViewPageWidth | 54026 |
KfxVerificationMenuViewPageHeight | 54027 |
KfxVerificationMenuViewWholePage | 54028 |
KfxVerificationMenuViewZoom200 | 54033 |
KfxVerificationMenuViewZoom150 | 54034 |
KfxVerificationMenuViewZoom100 | 54035 |
KfxVerificationMenuViewZoom75 | 54036 |
KfxVerificationMenuViewZoom50 | 54037 |
KfxVerificationMenuViewZoomCustom | 54038 |
KfxVerificationMenuViewMagnifyZone | 54029 |
KfxVerificationMenuViewAnchorZone | 54030 |
KfxVerificationMenuViewPanToZone | 54031 |
KfxVerificationMenuViewManualZoom | 54032 |
KfxVerificationMenuViewRetainZoom | 54045 |
KfxVerificationMenuViewScaleToGray | 54017 |
KfxVerificationMenuViewViewBitonalImage | 54050 |
KfxVerificationMenuViewExpandBatchContentsTree | 56502 |
KfxVerificationMenuViewToolBarsBatchContents | 54921 |
KfxVerificationMenuViewToolBarsBatchThumbnails | 54925 |
KfxVerificationMenuViewToolBarsBatchTools | 54923 | Obsolete.
KfxVerificationMenuViewToolBarsBatchNavigation | 54924 |
KfxVerificationMenuViewToolBarsBatchFilters | 54956 | Obsolete.
KfxVerificationMenuViewToolBarsImageTools | 54039 |
KfxVerificationMenuViewToolBarsNotes | 54922 |
KfxVerificationMenuViewToolBarsValidationNavigation | 54984 | Obsolete.
KfxVerificationMenuViewToolBarsIndexFields | 54272 |
KfxVerificationMenuViewToolBarsStatusBar | 59393 |
KfxVerificationMenuToolsFilterAll | 54953 |
KfxVerificationMenuToolsFilterRejected | 54954 |
KfxVerificationMenuToolsFilterUnprocessed | 54962 |
KfxVerificationMenuToolsOptions | 55042 |
KfxVerificationMenuHelpAscentCaptureHelpTopics | 57667 |
KfxVerificationMenuHelpAboutAscentCapture | 57664 |
KfxVerificationMenuViewValidationModeDataEntry | 54982 |
KfxVerificationMenuViewValidationModeBatchEditing | 54983 |
KfxVerificationMenuBatchExecuteAutoFoldering | 56504 |
KfxVerificationMenuBatchCreateChildFolder | 54894 |
KfxVerificationMenuFolderCreateChildFolder | 56510 |
KfxVerificationMenuFolderChangeFolderClass | 56506 |
KfxVerificationMenuFolderDelete | 54895 |
KfxVerificationMenuFolderNext | 54898 |
KfxVerificationMenuFolderPrevious | 54899 |
KfxVerificationMenuFolderFirst | 54896 |
KfxVerificationMenuFolderLast | 54897 |
KfxVerificationMenuDocumentCreateFolder | 56507 |
KfxVerificationMenuFieldInsertRowAbove | 56514 |
KfxVerificationMenuFieldInsertRowBelow | 56515 |
KfxVerificationMenuFieldDeleteRow | 56516 |
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxDataEvent Enumeration

KfxDataEvent Enumeration
Defines the various different data events. Data events are essentially function calls to the OCX to get data-source information and to communicate changes in data.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC91-EB60-11E1-9374-005056C00008")]
public enum KfxDataEvent
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC91-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxDataEvent
Members
Member name | Value | Description
KfxDataEventAppActionEvent | 65537 | Application action event.
KfxDataEventAppThemeChanged | 1023 | Application theme change event.
KfxDataEventBatchWantRuntimeData | 131587 | Request batch runtime data event.
KfxDataEventBatchSetRuntimeData | 131331 | Set batch runtime data event.
KfxDataEventBatchGetRuntimeData | 131075 | Get batch runtime data event.
KfxDataEventBatchGetClassData | 131074 | Get batch class data for a batch event.
KfxDataEventBatchGetSetupData | 131073 | Get setup data for a batch event.
KfxDataEventBatchUnreleaseDocuments | 131076 | Prevent batch export event.
KfxDataEventDocCreate | 196613 | Create a document event.
KfxDataEventDocDelete | 196612 | Delete a document event.
KfxDataEventDocSetNote | 196867 | Set note for a document event.
KfxDataEventDocSetRejected | 196866 | Set document as rejected event.
KfxDataEventDocSetFormType | 196865 | Set form type for a document event.
KfxDataEventPageCreateStart | 262149 | Start page creation event.
KfxDataEventPageCreateDone | 262150 | Finish page creation event.
KfxDataEventPageGetFilename | 262145 | Get file name for a page event.
KfxDataEventPageFileChange | 262153 | Change file for a page event.
KfxDataEventPageMoveDoc | 262152 | Move document event.
KfxDataEventPageMoveLoose | 262151 | Move loose page event.
KfxDataEventPageDelete | 262148 | Delete page event.
KfxDataEventPageSetOriginalFileName | 262413 | Set page to the original file name event.
KfxDataEventPageSetNote | 262403 | Set note for a page event.
KfxDataEventPageSetRejected | 262402 | Set page as rejected event.
KfxDataEventPageSetEndorsingString | 262410 | Set endorsing string for page event.
KfxDataEventPageSetImageAddress | 262411 | Set image address for page event.
KfxDataEventPageSetRollNumber | 262412 | Set roll number for page event.
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxDataEventReturnCode Enumeration

KfxDataEventReturnCode Enumeration
Defines the enumeration that represents the return code for a data event.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC8F-EB60-11E1-9374-005056C00008")]
public enum KfxDataEventReturnCode
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC8F-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxDataEventReturnCode
Members
Member name | Value | Description
KfxDataEventReturnCodeCancel | 1 | Action was cancelled.
KfxDataEventReturnCodeSuccess | 0 | Action was succeed.
KfxDataEventReturnCodeFail | -1 | Action was failed.
KfxDataEventReturnCodeFatal | -100 | Fatal error.
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxDataEventType Enumeration

KfxDataEventType Enumeration

Defines data type event enumeration.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC90-EB60-11E1-9374-005056C00008")]
public enum KfxDataEventType
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC90-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxDataEventType
Members
Member name | Value | Description
KfxDataEventTypeApp | 1 | Application.
KfxDataEventTypeBatch | 2 | Batch.
KfxDataEventTypeDoc | 3 | Document.
KfxDataEventTypePage | 4 | Page.
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxMenuEnable Enumeration

KfxMenuEnable Enumeration

Defines a possible state of Enabled/Grayed for a menu item.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC8C-EB60-11E1-9374-005056C00008")]
public enum KfxMenuEnable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC8C-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxMenuEnable
Members
Member name | Value | Description
KfxMenuEnabled | 0 | Menu item is enabled.
KfxMenuGrayed | 1 | Menu item is grayed.
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxOcxEvent Enumeration

KfxOcxEvent Enumeration

All application events are passed to the OCX via a single function call.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC8E-EB60-11E1-9374-005056C00008")]
public enum KfxOcxEvent
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC8E-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxOcxEvent
Members
Member name Value Description
KfxOcxEventBatchOpened 1

Event raised after a new batch is opened.

KfxOcxEventBatchClosing 2

Event raised before a batch is closed. OCX may cancel.

KfxOcxEventDocumentOpened 3

Event raised after a document is opened. This occurs whenever the user selects or navigates to a different document.

KfxOcxEventDocumentValidating 19

Event raised prior to validating a document on a close in Validation/Verification. Occurs prior to prompt to exit document and final validation, data save, and DocumentClosing event.

KfxOcxEventDocumentClosing 4

Event raised prior to leaving a document. This occurs when the user (or validation script) transitions to another document (or a loose page, or the batch node). Also occurs when switching to batch edit mode in Validation. In Validation/Verification, occurs after any SBL (deprecated) or .NET scripts (for example, PostDocument) have run.

KfxOcxEventFieldEntered 5

Event raised after a field is entered in Validation/Verification. This occurs when a document is selected in Validation, and when the user navigates to a new field. This event occurs before any SBL (deprecated) or .NET scripts (for example, the pre-field) have run.

KfxOcxEventFieldExiting 6

Event raised before a field is exited in Validation/Verification. OCX may cancel. This is called when physically exiting a field to move to another field, to go to a new document, or to close the batch.

KfxOcxEventContextChanged 7

Event raised after the application has moved to a new folder/document/page/field. This event fires after the "entered" events when navigating between objects in Scan, Quality Control, Validation, Verification.

KfxOcxEventContentChanged 9

Event raised after a structural batch editing operation. Note that a "batch editing" operation indicates some sort of change in the page/document/folder hierarchy, such as deleting/adding a page, creating a document, deleting a folder, etc. Index field changes do not trigger this event.

KfxOcxEventBatchEditModeEntered 10

Event raised when the user changes to batch edit mode in Validation/Verification. Occurs when "Data Entry/Batch Edit" is selected.

KfxOcxEventDataEntryModeEntered 11

Event raised when the user changes from batch edit mode to data entry mode in Validation/Verification. Occurs when the "Data Entry/Batch Edit" combo box is selected. By default, Validation/Verification are in data entry mode. No DataEntryModeEntered event fires when those modules start up. The status can be found by checking the DataEntryMode property from the Application API object.

KfxOcxEventPropertyChanged 8

Event raised after a property is changed on a document or page. Specifically, this includes changing the note, reject flag, reviewed flag (Quality Control), and the verified flag (Quality Control). Page/document rotations are also included in this event. Any other batch editing operation (not including index field changes) causes the ContentChanged event to occur instead.

KfxOcxEventBatchRejecting 12

Event raised before a batch is rejected. OCX may cancel. The reason for rejection is passed as a String in vArgument.

KfxOcxEventBatchSuspending 13

Event raised before a batch is suspended. OCX may cancel.

KfxOcxEventBatchDeleting 14

Event raised before batch deletion. OCX may cancel.

KfxOcxEventMenuClicked 15

Event raised when an OCX-defined menu is selected.

KfxOcxEventScanBatchStarted 16

Event raised before scanning starts.

KfxOcxEventScanPageStarted 17

Event raised before scanning a page starts.

KfxOcxEventScanStopped 18

Event raised after scanning stops.

KfxOcxEventBatchCreating 20

OCX must display a create batch dialog. Cancel can be passed if no create is desired. Cancel is passed if the user cancels.

KfxOcxEventBatchCreatingAutoImport 21

Event raised when creating a batch in Auto Import.

KfxOcxEventBatchPropertiesDisplaying 22

OCX must display its Batch Properties dialog. Cancel will cancel the Batch Properties dialog.

KfxOcxEventErrorLogging 23

Event raised whenever an exception that should be logged is thrown. The OCX can cancel to avoid logging the error. The argument parameter is an array with the following elements:

VB
Copy
Argument(1) As Long - ' Error code 1
Argument(2) As Long - ' Error code 2
Argument(3) As Long - ' Error code 3
Argument(4) As String - ' Error message
Argument(5) As String '- Module where error occurred
Argument(6) As Long - ' Line number where error occurred

Errors are sent to the OCX after the it has been created. The OCX is created while the application frame is being generated (but is not yet shown).

KfxOcxEventAboutBoxDisplaying 24

Event raised immediately before displaying the Tungsten Capture About box. If the OCX cancels the event, the Tungsten Capture About box is not displayed.

KfxOcxEventLoggingIn 25

OCX may display a login screen. If Cancel is passed, the application shuts down without ever displaying the main screen.

KfxOcxEventLoggedOut 29

The application is about to shut down. This event is only issued to an OCX that has received and not cancelled a KfxOcxEventLoggingIn event.

KfxOcxEventBatchOpeningNext 26

OCX must open the next available batch. If the OCX does not support this feature, or wishes to cause an interactive open, then it must cancel this event. Failure to cancel will cause the application to assume that a batch should be opened, and the data source will be queried for the batch data.

KfxOcxEventBatchOpeningSelect 27

OCX must display an Open Batch dialog. Cancel can be passed if no open is desired. Cancel is passed if the user cancels.

KfxOcxEventBatchOpeningID 28

This event is used when a batch is opened by batch ID. It passes the internal batch ID as a Long in vArgument. If the OCX cancels this event, the open batch dialog is displayed (after getting the KfxOcxEventBatch SelectOpening event).

KfxOcxEventBatchOpeningCheck 30

Event raised before attempting to open a batch. Canceling opens the Create Batch dialog box.

KfxOcxEventResetFocus 31

This occurs when an eDocument is displayed. In this case, the internal Windows Explorer panel forcibly takes focus. Tungsten Capture regains focus and sets it back to the main OCX window.

If the OCX wishes to set focus to a subcontrol, then it must do so during this event. The runtime OCX is not allowed to perform any actions that modify setup data during any user event. If the OCX tries to perform an action, an error is generated.

KfxOcxEventRowInserted 32

Event raised when a row has been added to a table. The value of Argument is the RowNumber of the added TableRow.

KfxOcxEventRowDeleted 33

Event raised when a row has been removed from a table. The value of Argument is the RowNumber of the deleted TableRow.

KfxOcxEventFolderClosing 34

Event raised prior to leaving a folder. This occurs when the user (or validation script) transitions to another folder (or a document, or a loose page, or the batch node). Also occurs when switching to batch edit mode in Validation. In Validation/ Verification, occurs after any SBL (deprecated) or .NET scripts (for example, PostDocument) have run.

KfxOcxEventFolderOpened 35

Event raised after a folder is opened. This occurs whenever the user selects or navigates to a different folder.

KfxOcxEventFolderValidating 36

Event raised in Validation/Verification prior to validating a folder on a close. Occurs prior to prompt to exit document and final validation, data save, and FolderClosing event.

KfxOcxEventShowingHelp 37

Event raised whenever the F1 or a Help button is pressed.
The argument is 0 for application level help. It is non-zero for context level help.
The HelpID is also referred to as the context ID. A mapping of Help IDs and help topic mappings are provided on the installation CD.
When using a custom standard module, if no cancellation of the event is received, the Help topic for Quality control is displayed.

KfxOcxEventRubberBandOCR 38

Event raised when Rubber Band OCR is performed.

KfxOcxEventBatchNameCreated 39

Event raised when Tungsten Capture generates a batch name. If this event is handled, an OCX will have the ability to override the batch name that was generated.

KfxOcxEventBatchNameCollision 40

Event raised if the new batch name collides with an existing batch name.

KfxOcxEventScanPageEnd 41

Event raised when a page is scanned.

KfxOcxEventScanBatchPreScan 42

Event raised just before a batch scanning.

kfxOcxEventScannerProfileChanged 45

Event raised when a scanner profile is changed.

KfxOcxEventScanDocumentCreated 43

Event raised just after a document is created.

KfxOcxEventBatchEnd 44

Event raised just after the batch scanning is ended.

KfxOcxEventPublishWarningsGet 1000

Event raised just before the end of a batch class Publish operation. Each string added to the collection parameter is displayed as a warning in the Results box when you publish a batch class.

Customization needs to modify the vArgument collection parameter as in the following sample:

C#
VB
Copy
// Adds at least 2 or more elements to the object that is an instance of Kofax.Collection.KfxCollection.
// The first element is an error code that will be ignored, and all other elements will be displayed as warning messages from the Administration module.
if (oArgument is Kofax.Collection.KfxCollection)
{
     Kofax.Collection.KfxCollection oKfxCollection = (Kofax.Collection.KfxCollection)oArgument;
    oKfxCollection.Add(0) // Error code, is currently ignored by Administration
    oKfxCollection.Add("This is a warning 1 from custom panel.")
    oKfxCollection.Add("This is a warning 2 from custom panel.")
}
' Adds at least 2 or more elements to the object that is an instance of Kofax.Collection.KfxCollection.
' The first element is an error code that will be ignored, and all other elements will be displayed as warning messages from the Administration module.
If TypeOf oArgument Is Kofax.Collection.KfxCollection Then
    Dim oKfxCollection As Kofax.Collection.KfxCollection = CType(oArgument, Kofax.Collection.KfxCollection)
    oKfxCollection.Add(0) ' Error code, is currently ignored by Administration
    oKfxCollection.Add("This is a warning 1 from custom panel.")
    oKfxCollection.Add("This is a warning 2 from custom panel.")
End If

KfxOcxEventPublishErrorsGet 1001

Event raised just before the end of a batch class Publish operation. Each string added to the collection parameter is displayed as an error in the Results box when you publish a batch class. Any errors result in a Publish failure.

Customization needs to modify the vArgument collection parameter as in the following sample:

C#
VB
Copy
// Adds at least 2 or more elements to the object that is instance of Kofax.Collection.KfxCollection. The first element is an error code that will be ignored,
// and all other elements will be displayed as error messages from the Administration module.
if (oArgument is Kofax.Collection.KfxCollection)
{
     Kofax.Collection.KfxCollection oKfxCollection = (Kofax.Collection.KfxCollection)oArgument;
    oKfxCollection.Add(0) // Error code, is currently ignored by Administration
    oKfxCollection.Add("This is an error 1 from custom panel.")
    oKfxCollection.Add("This is an error 2 from custom panel.")
}
' Adds at least 2 or more elements to the object that is instance of Kofax.Collection.KfxCollection. The first element is an error code that will be ignored,
' and all other elements will be displayed as error messages from the Administration module.
If TypeOf oArgument Is Kofax.Collection.KfxCollection Then
    Dim oKfxCollection As Kofax.Collection.KfxCollection = CType(oArgument, Kofax.Collection.KfxCollection)
    oKfxCollection.Add(0) ' Error code, is currently ignored by Administration
    oKfxCollection.Add("This is an error 1 from custom panel.")
    oKfxCollection.Add("This is an error 2 from custom panel.")
End If

KfxOcxEventBatchClassRenamed 1010

Event raised before a batch class is renamed.

KfxOcxEventBatchFieldRenamed 1011

Event raised before a batch field is renamed.

KfxOcxEventDocumentClassRenamed 1012

Event raised before a document class is renamed.

KfxOcxEventIndexFieldRenamed 1013

Event raised before a field is renamed.

KfxOcxEventFieldTypeRenamed 1014

Event raised before a field type is renamed.

KfxOcxEventFormTypeRenamed 1015

Event raised before a form type is renamed.

KfxOcxEventBatchClassImport 1016

Event raised when a batch class is imported.

KfxOcxEventBatchClassExport 1017

Event raised when a batch class is exported.

KfxOcxEventFolderClassRenamed 1018

Event raised when a folder class is renamed.

KfxOcxEventBatchClassPaste 1019

Event raised when a batch class is pasted.

KfxOcxEventDocumentClassPaste 1020

Event raised when a document class is pasted.

KfxOcxEventFolderClassPaste 1021

Event raised when a folder class is pasted.

KfxOcxEventFormTypePaste 1022

Event raised when a form type is pasted.

KfxOcxEventAppThemeChanged 1023

Application theme change event.

C#
VB
Copy
// The following sample shows event handling to update the panel’s background color according to the application theme.
if ((int)KfxOcxEvent.KfxOcxEventAppThemeChanged == nActionNumber)
{
    var oColor = m_oApp.Theme.BackgroundColor;
    this.BackColor = System.Drawing.Color.FromArgb(oColor.Red, oColor.Green, oColor.Blue);
}
' The following sample shows event handling to update the panel’s background color according to the application theme.
If KfxOcxEvent.KfxOcxEventAppThemeChanged = nActionNumber Then
    Dim oColor As InteropServices.IRGB = m_oApp.Theme.BackgroundColor
    Me.BackColor = Drawing.Color.FromArgb(oColor.Red, oColor.Green, oColor.Blue)
End If

KfxOcxEventMainWindowCreated 1024

Event raised after the main window is created.

KfxOcxEventMovePageLoose 46

Event raised when a loose page is being created from a document

Remarks

Operations that are canceled act as if the event was never initiated.

Note In the warning/error strings passed back to the Administration module, each string should end with a period, in order to conform to the standard warnings and errors.

See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxShowMenu Enumeration

KfxShowMenu Enumeration

Defines the possible menu showing state.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC8B-EB60-11E1-9374-005056C00008")]
public enum KfxShowMenu
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC8B-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxShowMenu
Members
Member name | Value | Description
KfxMenuShow | 0 | Shows the menu.
KfxMenuHide | 1 | Hides the menu.
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


KfxSqlDataType Enumeration

KfxSqlDataType Enumeration

Defines SQL data types supported by the API.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC8A-EB60-11E1-9374-005056C00008")]
public enum KfxSqlDataType
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC8A-EB60-11E1-9374-005056C00008")>
Public Enumeration KfxSqlDataType
Members
Member name | Value | Description
KfxOleChar | 1 | Defines CHAR data type.
KfxOleDate | 9 | Defines DATE data type.
KfxOleDecimal | 3 | Defines DECIMAL data type.
KfxOleDouble | 8 | Defines DOUBLE data type.
KfxOleFloat | 6 | Defines FLOAT data type.
KfxOleInteger | 4 | Defines INTEGER data type.
KfxOleNumeric | 2 | Defines NUMERIC data type.
KfxOleReal | 7 | Defines REAL data type.
KfxOleSmallint | 5 | Defines SMALLINT data type.
KfxOleTime | 10 | Defines TIME data type.
KfxOleVarchar | 12 | Defines VARCHAR data type.
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


NewBatchParameters Class

NewBatchParameters Class

Note: This API is now obsolete.

NewBatchParameters COM implementation class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesNewBatchParameters

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ObsoleteAttribute("This interface is no longer supported.")]
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC69-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class NewBatchParameters : INewBatchParameters
<ObsoleteAttribute("This interface is no longer supported.")>
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC69-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class NewBatchParameters
    Implements INewBatchParameters

The NewBatchParameters type exposes the following members.

Constructors
 | Name | Description
Public method | NewBatchParameters | Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.NewBatchParameters class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BatchClassName | Gets or sets the batch class name.
Public property | BatchName | Gets or sets the batch name.
Top
Remarks
This class was designed for Titan project. It is no longer supported.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


NewBatchParameters Constructor

NewBatchParameters Constructor

Initializes a new instance of the Kofax.Capture.CaptureModule.InteropServices.NewBatchParameters class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public NewBatchParameters()
Public Sub New
Remarks
See Also

Reference

NewBatchParameters Class
Kofax.Capture.CaptureModule.InteropServices Namespace


NewBatchParameters Methods

NewBatchParameters Methods

The NewBatchParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NewBatchParameters Class
Kofax.Capture.CaptureModule.InteropServices Namespace


NewBatchParameters Properties

NewBatchParameters Properties

The NewBatchParameters type exposes the following members.

Properties
 | Name | Description
Public property | BatchClassName | Gets or sets the batch class name.
Public property | BatchName | Gets or sets the batch name.
Top
See Also

Reference

NewBatchParameters Class
Kofax.Capture.CaptureModule.InteropServices Namespace


NewBatchParameters.BatchClassName Property

NewBatchParametersBatchClassName Property

Gets or sets the batch class name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string BatchClassName { get; set; }
Public Property BatchClassName As String
    Get
    Set

Property Value

Type: String
Batch class name for creating a batch.

Return Value

Type: String
String

Implements

INewBatchParametersBatchClassName
Remarks
See Also

Reference

NewBatchParameters Class
Kofax.Capture.CaptureModule.InteropServices Namespace


NewBatchParameters.BatchName Property

NewBatchParametersBatchName Property

Gets or sets the batch name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string BatchName { get; set; }
Public Property BatchName As String
    Get
    Set

Property Value

Type: String
Batch name for a new batch.

Return Value

Type: String
String

Implements

INewBatchParametersBatchName
Remarks
See Also

Reference

NewBatchParameters Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ObjectID Class

ObjectID Class

ObjectID COM implementation class.

Contains the ID for an object of type Document, Page or Folder.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesObjectID

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC6B-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class ObjectID : IObjectID, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC6B-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class ObjectID
    Implements IObjectID, IDisposable

The ObjectID type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ID | The ID is a unique identifier for an object of type Document, Page or Folder.
Top
Remarks
The ID is a unique property of the Document, Page, and Folder objects.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ObjectID Methods

ObjectID Methods

The ObjectID type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ObjectID Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ObjectID.Dispose Method

ObjectIDDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

ObjectID Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ObjectID Properties

ObjectID Properties

The ObjectID type exposes the following members.

Properties
 | Name | Description
Public property | ID | The ID is a unique identifier for an object of type Document, Page or Folder.
Top
See Also

Reference

ObjectID Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ObjectID.ID Property

ObjectIDID Property

The ID is a unique identifier for an object of type Document, Page or Folder.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ID { get; }
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32

Implements

IObjectIDID
Remarks
For example, the first page added to a batch has ID=1. The first document created also has ID=1. Only one page with ID=1 ever exists within a batch.
See Also

Reference

ObjectID Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ObjectIDs Class

ObjectIDs Class

ObjectIDs COM implementation class.

Defines a COM collection of ObjectID objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesObjectIDs

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC6D-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class ObjectIDs : IObjectIDs, IEnumerable,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC6D-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class ObjectIDs
    Implements IObjectIDs, IEnumerable, IDisposable

The ObjectIDs type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of Object ID objects contained in the collection.
Public property | Item | Returns the specified ObjectID objects.
Top
Remarks
Iteration and extraction by order number (with the Item function) are supported. Passing an out-of-range or invalid parameter to the item function causes it to throw the error "Invalid Parameter" to the caller. The ObjectID objects are not sorted. The ObjectID objects are valid while processing the Content Changed Event.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ObjectIDs Methods

ObjectIDs Methods

The ObjectIDs type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ObjectIDs Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ObjectIDs.Dispose Method

ObjectIDsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

ObjectIDs Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ObjectIDs.GetEnumerator Method

ObjectIDsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IObjectIDs object.

Implements

IObjectIDsGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

ObjectIDs Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ObjectIDs Properties

ObjectIDs Properties

The ObjectIDs type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of Object ID objects contained in the collection.
Public property | Item | Returns the specified ObjectID objects.
Top
See Also

Reference

ObjectIDs Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ObjectIDs.Count Property

ObjectIDsCount Property

Returns the number of Object ID objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IObjectIDsCount
Remarks
See Also

Reference

ObjectIDs Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ObjectIDs.Item Property

ObjectIDsItem Property

Returns the specified ObjectID objects.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IObjectID this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IObjectID
    Get

Parameters

vntIndexKey
Type: SystemObject
A numeric one-based index into the collection.

Property Value

Type: IObjectID

Return Value

Type: IObjectID
IObjectID

Implements

IObjectIDsItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

ObjectIDs Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page Class

Page Class

Page COM implementation class.

Defines information about a page.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesPage

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC6F-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Page : IPage, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC6F-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Page
    Implements IPage, IDisposable

The Page type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | MoveToDocument | Removes the page from a batch or document and adds it to oDocument.
Public method | MoveToLoose | Either removes the page from its containing document and makes it into a batch loose page or moves the page to another location among loose pages in a batch.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Blank | Gets or sets the blank property of the page
Public property | Color | Gets or sets the color flag for the page.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Document | Returns the parent document object (or nothing if a loose page).
Public property | EndorsingString | Returns the page note.
Public property | Extension | Returns the the file extension for eDocument files. For normal image files, this returns an empty string.
Public property | FileName | Gets the image file name.
Public property | ID | Returns the internal Page ID set by the data source (internal database).
Public property | ImageAddress | Returns the image address (used for endorsing).
Public property | ImportOrderNumber | Returns the order number of the original file from which this page was imported.
Public property | IsFront | Returns True if image is front page.
Public property | Note | Gets or sets the document note.
Public property | OrderNumber | Returns the page order within the document.
Public property | OriginalFileName | Allows reading or changing the original file name.
Public property | PageGUID | Returns the Page unique ID.
Public property | RegistrationConfidence | Returns the registration confidence for the page.
Public property | Rejected | Gets or sets the "rejected" flag for the document.
Public property | RollNumber | Roll number (used for endorsing).
Top
Remarks
A page object is invalidated when a content change event occurs.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


Page Methods

Page Methods

The Page type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | MoveToDocument | Removes the page from a batch or document and adds it to oDocument.
Public method | MoveToLoose | Either removes the page from its containing document and makes it into a batch loose page or moves the page to another location among loose pages in a batch.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.Dispose Method

PageDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.MoveToDocument Method

PageMoveToDocument Method

Removes the page from a batch or document and adds it to oDocument.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void MoveToDocument(
    ref IDocument oDocument,
    ref IPage oNextPage = null
)
Public Sub MoveToDocument (
    ByRef oDocument As IDocument,
    Optional ByRef oNextPage As IPage = Nothing
)

Parameters

oDocument
Type: Kofax.Capture.CaptureModule.InteropServicesIDocument
If oDocument is the original parent Document, the page is moved to a different location within the document.
oNextPage (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIPage
If oNextPage is Nothing, the page is added to the end. Otherwise, it is added before oNextPage.

Implements

IPageMoveToDocument(IDocument, IPage)
Remarks
If the page was originally part of a document and this change renders the document empty, the document is automatically deleted.
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.MoveToLoose Method

PageMoveToLoose Method

Either removes the page from its containing document and makes it into a batch loose page or moves the page to another location among loose pages in a batch.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void MoveToLoose(
    ref IPage oNextPage = null
)
Public Sub MoveToLoose (
    Optional ByRef oNextPage As IPage = Nothing
)

Parameters

oNextPage (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesIPage
If oNextPage is Nothing, the page is added to the end. Otherwise it is added before oNextPage.

Implements

IPageMoveToLoose(IPage)
Remarks

If the page was originally part of a document and this change renders the document empty, then the document is automatically deleted as well.

Does not work in Validation or Verification if Data Entry mode is active.

See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page Properties

Page Properties

The Page type exposes the following members.

Properties
 | Name | Description
Public property | Blank | Gets or sets the blank property of the page
Public property | Color | Gets or sets the color flag for the page.
Public property | CustomStorageString | The storage string with the specified name.
Public property | Document | Returns the parent document object (or nothing if a loose page).
Public property | EndorsingString | Returns the page note.
Public property | Extension | Returns the the file extension for eDocument files. For normal image files, this returns an empty string.
Public property | FileName | Gets the image file name.
Public property | ID | Returns the internal Page ID set by the data source (internal database).
Public property | ImageAddress | Returns the image address (used for endorsing).
Public property | ImportOrderNumber | Returns the order number of the original file from which this page was imported.
Public property | IsFront | Returns True if image is front page.
Public property | Note | Gets or sets the document note.
Public property | OrderNumber | Returns the page order within the document.
Public property | OriginalFileName | Allows reading or changing the original file name.
Public property | PageGUID | Returns the Page unique ID.
Public property | RegistrationConfidence | Returns the registration confidence for the page.
Public property | Rejected | Gets or sets the "rejected" flag for the document.
Public property | RollNumber | Roll number (used for endorsing).
Top
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.Blank Property

PageBlank Property

Gets or sets the blank property of the page

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Blank { get; set; }
Public Property Blank As Boolean
    Get
    Set

Property Value

Type: Boolean
Returns True if the page is blank

Return Value

Type: Boolean
Boolean

Implements

IPageBlank
Remarks
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.Color Property

PageColor Property

Gets or sets the color flag for the page.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Color { get; set; }
Public Property Color As Boolean
    Get
    Set

Property Value

Type: Boolean
Returns True if the document is color image.

Return Value

Type: Boolean
Boolean

Implements

IPageColor
Remarks
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.CustomStorageString Property

PageCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The storage string name does not need to match the name of the page. Strings stored by one component can be read by another. If set to an empty string, the storage string is deleted.

Property Value

Type: String

Return Value

Type: String
String

Implements

IPageCustomStorageStringString
Remarks

Custom Storage strings are custom text strings that are bound to a specific page. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name.

If set to an empty string, the storage string is deleted.

This function throws:

(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.Document Property

PageDocument Property

Returns the parent document object (or nothing if a loose page).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IDocument Document { get; }
Public ReadOnly Property Document As IDocument
    Get

Property Value

Type: IDocument

Return Value

Type: IDocument
IDocument

Implements

IPageDocument
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.EndorsingString Property

PageEndorsingString Property

Returns the page note.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string EndorsingString { get; }
Public ReadOnly Property EndorsingString As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IPageEndorsingString
Remarks
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.Extension Property

PageExtension Property

Returns the the file extension for eDocument files. For normal image files, this returns an empty string.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Extension { get; }
Public ReadOnly Property Extension As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IPageExtension
Remarks
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.FileName Property

PageFileName Property

Gets the image file name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IPageFileName
Remarks
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.ID Property

PageID Property

Returns the internal Page ID set by the data source (internal database).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ID { get; }
Public ReadOnly Property ID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IPageID
Remarks
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.ImageAddress Property

PageImageAddress Property

Returns the image address (used for endorsing).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ImageAddress { get; }
Public ReadOnly Property ImageAddress As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IPageImageAddress
Remarks
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.ImportOrderNumber Property

PageImportOrderNumber Property

Returns the order number of the original file from which this page was imported.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ImportOrderNumber { get; }
Public ReadOnly Property ImportOrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IPageImportOrderNumber
Remarks
Useful for correlating pages with input files if many files are imported with one ImportFile command or interactively with one click of the "scan batch" button.
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.IsFront Property

PageIsFront Property

Returns True if image is front page.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool IsFront { get; }
Public ReadOnly Property IsFront As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IPageIsFront
Remarks
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.Note Property

PageNote Property

Gets or sets the document note.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Note { get; set; }
Public Property Note As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IPageNote
Remarks
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.OrderNumber Property

PageOrderNumber Property

Returns the page order within the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int OrderNumber { get; }
Public ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IPageOrderNumber
Remarks
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.OriginalFileName Property

PageOriginalFileName Property

Allows reading or changing the original file name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string OriginalFileName { get; set; }
Public Property OriginalFileName As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IPageOriginalFileName
Remarks

This is the same file name value displayed and edited in the page properties dialog.

If length of the string exceeds 250 characters, or contains invalid characters, an error is generated.

See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.PageGUID Property

PagePageGUID Property

Returns the Page unique ID.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string PageGUID { get; }
Public ReadOnly Property PageGUID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IPagePageGUID
Remarks
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.RegistrationConfidence Property

PageRegistrationConfidence Property

Returns the registration confidence for the page.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int RegistrationConfidence { get; }
Public ReadOnly Property RegistrationConfidence As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IPageRegistrationConfidence
Remarks
This is filled in by the Recognition Server.
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.Rejected Property

PageRejected Property

Gets or sets the "rejected" flag for the document.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Rejected { get; set; }
Public Property Rejected As Boolean
    Get
    Set

Property Value

Type: Boolean
Returns True if the document is rejected.

Return Value

Type: Boolean
Boolean

Implements

IPageRejected
Remarks
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Page.RollNumber Property

PageRollNumber Property

Roll number (used for endorsing).

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int RollNumber { get; }
Public ReadOnly Property RollNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IPageRollNumber
Remarks
See Also

Reference

Page Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Pages Class

Pages Class

Pages COM implementation class.

Defines a COM collection of Page objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesPages

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC71-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Pages : IPages, IEnumerable,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC71-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Pages
    Implements IPages, IEnumerable, IDisposable

The Pages type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of Page objects contained in the collection.
Public property | Item | Returns the specified Page object from the collection.
Top
Remarks
Iteration and extraction by order number (with the item function) are supported. Passing an out-of-range or invalid parameter to the item function causes it to throw the error "Invalid Parameter" to the caller.

A Pages object is invalidated when a content change event occurs.

See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


Pages Methods

Pages Methods

The Pages type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Pages Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Pages.Dispose Method

PagesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Pages Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Pages.GetEnumerator Method

PagesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IPages object.

Implements

IPagesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Pages Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Pages Properties

Pages Properties

The Pages type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of Page objects contained in the collection.
Public property | Item | Returns the specified Page object from the collection.
Top
See Also

Reference

Pages Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Pages.Count Property

PagesCount Property

Returns the number of Page objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IPagesCount
Remarks
See Also

Reference

Pages Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Pages.Item Property

PagesItem Property

Returns the specified Page object from the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPage this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IPage
    Get

Parameters

vntIndexKey
Type: SystemObject
Can either be a form type name or a numeric one-based index into the collection.

Property Value

Type: IPage

Return Value

Type: IPage
IPage

Implements

IPagesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Pages Class
Kofax.Capture.CaptureModule.InteropServices Namespace


RGB Class

RGB Class

RGB COM implementation class.

Defines Red, Green, and Blue values of a color.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesRGB

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC73-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class RGB : IRGB
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC73-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class RGB
    Implements IRGB

The RGB type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Blue | Gets the Blue value of the color.
Public property | Green | Gets the Green value of the color.
Public property | Red | Gets the Red value of the color.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


RGB Methods

RGB Methods

The RGB type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RGB Class
Kofax.Capture.CaptureModule.InteropServices Namespace


RGB Properties

RGB Properties

The RGB type exposes the following members.

Properties
 | Name | Description
Public property | Blue | Gets the Blue value of the color.
Public property | Green | Gets the Green value of the color.
Public property | Red | Gets the Red value of the color.
Top
See Also

Reference

RGB Class
Kofax.Capture.CaptureModule.InteropServices Namespace


RGB.Blue Property

RGBBlue Property

Gets the Blue value of the color.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public short Blue { get; }
Public ReadOnly Property Blue As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short

Implements

IRGBBlue
Remarks
See Also

Reference

RGB Class
Kofax.Capture.CaptureModule.InteropServices Namespace


RGB.Green Property

RGBGreen Property

Gets the Green value of the color.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public short Green { get; }
Public ReadOnly Property Green As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short

Implements

IRGBGreen
Remarks
See Also

Reference

RGB Class
Kofax.Capture.CaptureModule.InteropServices Namespace


RGB.Red Property

RGBRed Property

Gets the Red value of the color.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public short Red { get; }
Public ReadOnly Property Red As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short

Implements

IRGBRed
Remarks
See Also

Reference

RGB Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ScannerProfile Class

ScannerProfile Class

ScannerProfile COM implementation class.

Defines a COM object that contains a ScannerProfile.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesScannerProfile

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC75-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class ScannerProfile : IScannerProfile
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC75-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class ScannerProfile
    Implements IScannerProfile

The ScannerProfile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the suggested scanner profile name.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ScannerProfile Methods

ScannerProfile Methods

The ScannerProfile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ScannerProfile Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ScannerProfile Properties

ScannerProfile Properties

The ScannerProfile type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the suggested scanner profile name.
Top
See Also

Reference

ScannerProfile Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ScannerProfile.Name Property

ScannerProfileName Property

Gets or sets the suggested scanner profile name.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IScannerProfileName
Remarks
See Also

Reference

ScannerProfile Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ScannerProfiles Class

ScannerProfiles Class

ScannerProfiles COM implementation class.

Defines a COM collection of ScannerProfile objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesScannerProfiles

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC77-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class ScannerProfiles : IScannerProfiles,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC77-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class ScannerProfiles
    Implements IScannerProfiles, IEnumerable, IDisposable

The ScannerProfiles type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of ScannerProfile objects contained in the collection.
Public property | Item | Returns the specified ScannerProfile object.
Top
Remarks
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


ScannerProfiles Methods

ScannerProfiles Methods

The ScannerProfiles type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ScannerProfiles Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ScannerProfiles.Dispose Method

ScannerProfilesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

ScannerProfiles Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ScannerProfiles.GetEnumerator Method

ScannerProfilesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.IScannerProfiles object.

Implements

IScannerProfilesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

ScannerProfiles Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ScannerProfiles Properties

ScannerProfiles Properties

The ScannerProfiles type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of ScannerProfile objects contained in the collection.
Public property | Item | Returns the specified ScannerProfile object.
Top
See Also

Reference

ScannerProfiles Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ScannerProfiles.Count Property

ScannerProfilesCount Property

Returns the number of ScannerProfile objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IScannerProfilesCount
Remarks
See Also

Reference

ScannerProfiles Class
Kofax.Capture.CaptureModule.InteropServices Namespace


ScannerProfiles.Item Property

ScannerProfilesItem Property

Returns the specified ScannerProfile object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IScannerProfile this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IScannerProfile
    Get

Parameters

vntIndexKey
Type: SystemObject
is a numeric one-based index into the collection.

Property Value

Type: IScannerProfile

Return Value

Type: IScannerProfile
IScannerProfile

Implements

IScannerProfilesItemObject
See Also

Reference

ScannerProfiles Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValue Class

SuggestedValue Class

SuggestedValue COM implementation class.

Defines a COM object that contains a possible choice for batch field or index field values.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesSuggestedValue

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC79-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class SuggestedValue : ISuggestedValue,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC79-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class SuggestedValue
    Implements ISuggestedValue, IDisposable

The SuggestedValue type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | OrderNumber | Gets the order number of the value.
Public property | Value | Gets or sets the suggested value.
Top
Remarks
A SuggestedValue object is invalidated when a content change event occurs.
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValue Methods

SuggestedValue Methods

The SuggestedValue type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SuggestedValue Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValue.Dispose Method

SuggestedValueDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

SuggestedValue Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValue Properties

SuggestedValue Properties

The SuggestedValue type exposes the following members.

Properties
 | Name | Description
Public property | OrderNumber | Gets the order number of the value.
Public property | Value | Gets or sets the suggested value.
Top
See Also

Reference

SuggestedValue Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValue.OrderNumber Property

SuggestedValueOrderNumber Property

Gets the order number of the value.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int OrderNumber { get; }
Public ReadOnly Property OrderNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ISuggestedValueOrderNumber
Remarks
The values are ordered the same as displayed in the Administration module.
See Also

Reference

SuggestedValue Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValue.Value Property

SuggestedValueValue Property

Gets or sets the suggested value.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

ISuggestedValueValue
Remarks
See Also

Reference

SuggestedValue Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValues Class

SuggestedValues Class

SuggestedValues COM implementation class.

Defines a COM collection of SuggestedValue objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesSuggestedValues

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC7B-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class SuggestedValues : ISuggestedValues,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC7B-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class SuggestedValues
    Implements ISuggestedValues, IEnumerable, IDisposable

The SuggestedValues type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a suggested value to the SuggestedValues collection.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Remove | Removes a suggested value from the SuggestedValues collection.
Public method | RemoveAll | Removes all suggested values from the SuggestedValues collection.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of SuggestedValue objects contained in the collection.
Public property | Item | Returns the specified SuggestedValue from the collection.
Top
Remarks
Iteration and extraction by order number is supported. Passing an out-of-range, or invalid parameter to the item function causes it to throw the error "Invalid Parameter" to the caller.

A SuggestedValues object is invalidated when a content change event occurs.

The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValues Methods

SuggestedValues Methods

The SuggestedValues type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a suggested value to the SuggestedValues collection.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Remove | Removes a suggested value from the SuggestedValues collection.
Public method | RemoveAll | Removes all suggested values from the SuggestedValues collection.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

SuggestedValues Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValues.Add Method

SuggestedValuesAdd Method

Adds a suggested value to the SuggestedValues collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ISuggestedValue Add(
    Object Item
)
Public Function Add (
    Item As Object
) As ISuggestedValue

Parameters

Item
Type: SystemObject
Required. The SuggestedValue value to add.

Return Value

Type: ISuggestedValue
ISuggestedValue

Implements

ISuggestedValuesAdd(Object)
Remarks
The returned object of this function should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

SuggestedValues Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValues.Dispose Method

SuggestedValuesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

SuggestedValues Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValues.GetEnumerator Method

SuggestedValuesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.ISuggestedValues object.

Implements

ISuggestedValuesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

SuggestedValues Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValues.Remove Method

SuggestedValuesRemove Method

Removes a suggested value from the SuggestedValues collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Remove(
    Object vntIndexKey
)
Public Sub Remove (
    vntIndexKey As Object
)

Parameters

vntIndexKey
Type: SystemObject
The object's key to remove. Index can either be a form type name or a numeric one-based index into the collection.

Implements

ISuggestedValuesRemove(Object)
Remarks
See Also

Reference

SuggestedValues Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValues.RemoveAll Method

SuggestedValuesRemoveAll Method

Removes all suggested values from the SuggestedValues collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void RemoveAll()
Public Sub RemoveAll

Implements

ISuggestedValuesRemoveAll
Remarks
See Also

Reference

SuggestedValues Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValues Properties

SuggestedValues Properties

The SuggestedValues type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of SuggestedValue objects contained in the collection.
Public property | Item | Returns the specified SuggestedValue from the collection.
Top
See Also

Reference

SuggestedValues Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValues.Count Property

SuggestedValuesCount Property

Returns the number of SuggestedValue objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ISuggestedValuesCount
Remarks
See Also

Reference

SuggestedValues Class
Kofax.Capture.CaptureModule.InteropServices Namespace


SuggestedValues.Item Property

SuggestedValuesItem Property

Returns the specified SuggestedValue from the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ISuggestedValue this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As ISuggestedValue
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key. Index can either be a form type name or a numeric one-based index into the collection.

Property Value

Type: ISuggestedValue

Return Value

Type: ISuggestedValue
ISuggestedValue

Implements

ISuggestedValuesItemObject
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

SuggestedValues Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Table Class

Table Class

Table COM implementation class.

Defines a COM object that defines a table in a document.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesTable

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC7D-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Table : ITable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC7D-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Table
    Implements ITable, IDisposable

The Table type exposes the following members.

Methods
 | Name | Description
Public method | AddTableRow | Creates a new TableRow.
Public method | DeleteTableRow | Removes a TableRow from the table.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DisplayLabel | Gets the display label of the table.
Public property | Name | Gets the name of the table.
Public property | TableRows | Gets the collection of ITableRow objects for this table.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


Table Methods

Table Methods

The Table type exposes the following members.

Methods
 | Name | Description
Public method | AddTableRow | Creates a new TableRow.
Public method | DeleteTableRow | Removes a TableRow from the table.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Table Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Table.AddTableRow Method

TableAddTableRow Method

Creates a new TableRow.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ITableRow AddTableRow(
    ref ITableRow oPrevRow = null
)
Public Function AddTableRow (
    Optional ByRef oPrevRow As ITableRow = Nothing
) As ITableRow

Parameters

oPrevRow (Optional)
Type: Kofax.Capture.CaptureModule.InteropServicesITableRow
The new row is inserted after oPrevRow. If oPrevRow is Nothing, the new row is added as the first row.

Return Value

Type: ITableRow
ITableRow

Implements

ITableAddTableRow(ITableRow)
Remarks

Errors:

(KfxApiErrBadParameterRange) if oPrevRow does not belong to this table.
The returned object of this function should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Table Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Table.DeleteTableRow Method

TableDeleteTableRow Method

Removes a TableRow from the table.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void DeleteTableRow(
    ref ITableRow oRow
)
Public Sub DeleteTableRow (
    ByRef oRow As ITableRow
)

Parameters

oRow
Type: Kofax.Capture.CaptureModule.InteropServicesITableRow
The row to delete.

Implements

ITableDeleteTableRow(ITableRow)
Remarks

Errors:

(KfxApiErrBadParameterRange) if oRow does not belong to this table.
See Also

Reference

Table Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Table.Dispose Method

TableDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Table Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Table Properties

Table Properties

The Table type exposes the following members.

Properties
 | Name | Description
Public property | DisplayLabel | Gets the display label of the table.
Public property | Name | Gets the name of the table.
Public property | TableRows | Gets the collection of ITableRow objects for this table.
Top
See Also

Reference

Table Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Table.DisplayLabel Property

TableDisplayLabel Property

Gets the display label of the table.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string DisplayLabel { get; }
Public ReadOnly Property DisplayLabel As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

ITableDisplayLabel
Remarks
See Also

Reference

Table Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Table.Name Property

TableName Property

Gets the name of the table.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

ITableName
Remarks
See Also

Reference

Table Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Table.TableRows Property

TableTableRows Property

Gets the collection of ITableRow objects for this table.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ITableRows TableRows { get; }
Public ReadOnly Property TableRows As ITableRows
    Get

Property Value

Type: ITableRows

Return Value

Type: ITableRows
ITableRows

Implements

ITableTableRows
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Table Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableDefinition Class

TableDefinition Class

TableDefinition COM implementation class.

Defines a table definition.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesTableDefinition

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC7F-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class TableDefinition : ITableDefinition,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC7F-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class TableDefinition
    Implements ITableDefinition, IDisposable

The TableDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | DisplayLabel | Returns the display label of the table defined in the document class.
Public property | Name | Returns the name of the table defined in the document class.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


TableDefinition Methods

TableDefinition Methods

The TableDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TableDefinition Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableDefinition.Dispose Method

TableDefinitionDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

TableDefinition Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableDefinition Properties

TableDefinition Properties

The TableDefinition type exposes the following members.

Properties
 | Name | Description
Public property | DisplayLabel | Returns the display label of the table defined in the document class.
Public property | Name | Returns the name of the table defined in the document class.
Top
See Also

Reference

TableDefinition Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableDefinition.DisplayLabel Property

TableDefinitionDisplayLabel Property

Returns the display label of the table defined in the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string DisplayLabel { get; }
Public ReadOnly Property DisplayLabel As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

ITableDefinitionDisplayLabel
Remarks
See Also

Reference

TableDefinition Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableDefinition.Name Property

TableDefinitionName Property

Returns the name of the table defined in the document class.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

ITableDefinitionName
Remarks
Default property.
See Also

Reference

TableDefinition Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableDefinitions Class

TableDefinitions Class

TableDefinitions COM implementation class.

Defines a COM object that defines a collection of tables in a document class.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesTableDefinitions

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC81-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class TableDefinitions : ITableDefinitions,
    IEnumerable, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC81-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class TableDefinitions
    Implements ITableDefinitions, IEnumerable, IDisposable

The TableDefinitions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of TableDefinition objects contained in the collection.
Public property | Item | Returns the specified TableDefinition object.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


TableDefinitions Methods

TableDefinitions Methods

The TableDefinitions type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TableDefinitions Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableDefinitions.Dispose Method

TableDefinitionsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

TableDefinitions Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableDefinitions.GetEnumerator Method

TableDefinitionsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.ITableDefinitions object.

Implements

ITableDefinitionsGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

TableDefinitions Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableDefinitions Properties

TableDefinitions Properties

The TableDefinitions type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of TableDefinition objects contained in the collection.
Public property | Item | Returns the specified TableDefinition object.
Top
See Also

Reference

TableDefinitions Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableDefinitions.Count Property

TableDefinitionsCount Property

Returns the number of TableDefinition objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ITableDefinitionsCount
Remarks
See Also

Reference

TableDefinitions Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableDefinitions.Item Property

TableDefinitionsItem Property

Returns the specified TableDefinition object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ITableDefinition this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As ITableDefinition
    Get

Parameters

vntIndexKey
Type: SystemObject
Index can either be a table definition name or a numeric one-based index into the collection.

Property Value

Type: ITableDefinition

Return Value

Type: ITableDefinition

Implements

ITableDefinitionsItemObject
Remarks

Errors:

(KfxApiErrBadParameterRange) illegal index value.
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

TableDefinitions Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableRow Class

TableRow Class

TableRow COM implementation class.

Defines a COM object that represents a row in a table.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesTableRow

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC83-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class TableRow : ITableRow, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC83-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class TableRow
    Implements ITableRow, IDisposable

The TableRow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | IndexFields | Returns the collection of IndexFields for this row.
Public property | RowNumber | The (ordered) number for this row.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


TableRow Methods

TableRow Methods

The TableRow type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TableRow Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableRow.Dispose Method

TableRowDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

TableRow Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableRow Properties

TableRow Properties

The TableRow type exposes the following members.

Properties
 | Name | Description
Public property | IndexFields | Returns the collection of IndexFields for this row.
Public property | RowNumber | The (ordered) number for this row.
Top
See Also

Reference

TableRow Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableRow.IndexFields Property

TableRowIndexFields Property

Returns the collection of IndexFields for this row.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IIndexFields IndexFields { get; }
Public ReadOnly Property IndexFields As IIndexFields
    Get

Property Value

Type: IIndexFields

Return Value

Type: IIndexFields
IIndexFields

Implements

ITableRowIndexFields
Remarks
The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

TableRow Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableRow.RowNumber Property

TableRowRowNumber Property

The (ordered) number for this row.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int RowNumber { get; }
Public ReadOnly Property RowNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32

Implements

ITableRowRowNumber
Remarks
Default property.
See Also

Reference

TableRow Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableRows Class

TableRows Class

TableRows COM implementation class.

Defines a COM object that represents the collection of rows in a table.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesTableRows

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC85-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class TableRows : ITableRows, IEnumerable,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC85-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class TableRows
    Implements ITableRows, IEnumerable, IDisposable

The TableRows type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of TableRow objects contained in the collection.
Public property | Item | Returns the specified TableRow object.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


TableRows Methods

TableRows Methods

The TableRows type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TableRows Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableRows.Dispose Method

TableRowsDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

TableRows Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableRows.GetEnumerator Method

TableRowsGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.ITableRows object.

Implements

ITableRowsGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

TableRows Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableRows Properties

TableRows Properties

The TableRows type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of TableRow objects contained in the collection.
Public property | Item | Returns the specified TableRow object.
Top
See Also

Reference

TableRows Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableRows.Count Property

TableRowsCount Property

Returns the number of TableRow objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ITableRowsCount
Remarks
See Also

Reference

TableRows Class
Kofax.Capture.CaptureModule.InteropServices Namespace


TableRows.Item Property

TableRowsItem Property

Returns the specified TableRow object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ITableRow this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As ITableRow
    Get

Parameters

vntIndexKey
Type: SystemObject
The numeric one-based index into the collection.

Property Value

Type: ITableRow

Return Value

Type: ITableRow
ITableRow

Implements

ITableRowsItemObject
Remarks

Default property.

Errors:

(KfxApiErrBadParameterRange) illegal index value.

The returned object of this property should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

TableRows Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Tables Class

Tables Class

Tables COM implementation class.

Defines a COM object that defines a collection of tables in a document.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesTables

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC87-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Tables : ITables, IEnumerable,
    IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC87-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Tables
    Implements ITables, IEnumerable, IDisposable

The Tables type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of Table objects contained in the collection.
Public property | Item | Returns the specified Table object.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


Tables Methods

Tables Methods

The Tables type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Tables Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Tables.Dispose Method

TablesDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Tables Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Tables.GetEnumerator Method

TablesGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.CaptureModule.InteropServices.ITables object.

Implements

ITablesGetEnumerator
IEnumerableGetEnumerator
Remarks
Object of this iteration should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Tables Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Tables Properties

Tables Properties

The Tables type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of Table objects contained in the collection.
Public property | Item | Returns the specified Table object.
Top
See Also

Reference

Tables Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Tables.Count Property

TablesCount Property

Returns the number of Table objects contained in the collection.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ITablesCount
Remarks
See Also

Reference

Tables Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Tables.Item Property

TablesItem Property

Returns the specified Table object.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ITable this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As ITable
    Get

Parameters

vntIndexKey
Type: SystemObject
Index can either be a table name or a numeric one-based index into the collection.

Property Value

Type: ITable

Return Value

Type: ITable

Implements

ITablesItemObject
Remarks
See Also

Reference

Tables Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Theme Class

Theme Class

Theme COM implementation class.

Defines a COM object that provides access to the theme of the Tungsten Capture system.

Inheritance Hierarchy
SystemObject
Kofax.Capture.CaptureModule.InteropServicesTheme

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ComVisibleAttribute(true)]
[GuidAttribute("F797DC89-EB60-11E1-9374-005056C00008")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class Theme : ITheme, IDisposable
<ComVisibleAttribute(true)>
<GuidAttribute("F797DC89-EB60-11E1-9374-005056C00008")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class Theme
    Implements ITheme, IDisposable

The Theme type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BackgroundColor | Returns the background color of the theme.
Public property | Name | Returns the name of the theme.
Top
Remarks
The instance of this class should be wrapped with an object type of Kofax.Capture.CaptureModule.ApiObjectWrapper class.
See Also

Reference

Kofax.Capture.CaptureModule.InteropServices Namespace


Theme Methods

Theme Methods

The Theme type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Theme Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Theme.Dispose Method

ThemeDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
This method should be called whenever the use of this class instance is done.
See Also

Reference

Theme Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Theme Properties

Theme Properties

The Theme type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Returns the background color of the theme.
Public property | Name | Returns the name of the theme.
Top
See Also

Reference

Theme Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Theme.BackgroundColor Property

ThemeBackgroundColor Property

Returns the background color of the theme.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRGB BackgroundColor { get; }
Public ReadOnly Property BackgroundColor As IRGB
    Get

Property Value

Type: IRGB

Return Value

Type: IRGB
Kofax.Capture.CaptureModule.InteropServices.RGB

Implements

IThemeBackgroundColor
Remarks
See Also

Reference

Theme Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Theme.Name Property

ThemeName Property

Returns the name of the theme.

Namespace: Kofax.Capture.CaptureModule.InteropServices
Assembly: Kofax.Capture.CaptureModule (in Kofax.Capture.CaptureModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IThemeName
Remarks
See Also

Reference

Theme Class
Kofax.Capture.CaptureModule.InteropServices Namespace


Kofax.Capture.DBLite Namespace

Kofax.Capture.DBLite Namespace

Tungsten Capture Custom Module .NET Type Interface Library and Tungsten Capture Document Access .NET Type Implementation Library are libraries that allow you to integrate a custom module into your Tungsten Capture installation. Tungsten Capture Custom Module .NET Type Interface Library and Tungsten Capture Document Access .NET Type Implementation Library make it possible for the custom module to access batch information from Tungsten Capture. Likewise, they allow your custom module to relay batch information from the custom module to Tungsten Capture. The Tungsten Capture Custom Module .NET Type Interface Library dynamic-link library (Kofax.Capture.SDK.CustomModule.dll) and Tungsten Capture Document Access .NET Type Implementation Library (Kofax.DbLite.dll), are available from the Bin folder in your Tungsten Capture installation.

Tungsten Capture Custom Module .NET Type Interface and Tungsten Capture Document Access .NET Type Implementation libraries allow you to do the following:

  • Route a Tungsten Capture batch to a custom module for processing
  • Use the Tungsten Capture Optimized Custom Module API to selectively retrieve and update data
  • Close a batch from a custom module and route it to the next module in the Tungsten Capture workflow

Although using XML transport files to export/import batch information between Tungsten Capture and a custom module is supported, this method is not recommended for large batches or large number of users due to performance degradation.

Classes
 | Class | Description
Public class | Batch | Defines an interface that contains information about an active batch.
Public class | BatchCollection | Defines a collection of batch objects.
Public class | BatchFieldNamesCollection | Defines a collection of batch field names.
Public class | BatchFieldValuesCollection | Defines a collection of batch field values.
Public class | Login | The Login object forms the basis of the entire hierarchy. The properties of Login are used for error logging. A Login object should be maintained until the calling application shuts down; additional Login objects should not be introduced while the calling application is open.
Public class | Login2 | The Login object forms the basis of the entire hierarchy. The properties of Login are used for error logging. A Login object should be maintained until the calling application shuts down; additional Login objects should not be introduced while the calling application is open.
Public class | MonitorMgr |
Public class | Process | Defines a process object that holds information about a Tungsten Capture standard process.
Public class | ProcessCollection | Defines a collection that identifies the different queues in the system. Custom modules will find their process IDs in the collection and use them for getting batches and constructing the "where " clause for the BatchCollection.
Public class | PublishedBatchClass | Defines information for published batch class event.
Public class | PublishedBatchClassCollection | Defines a collection of IPublishedBatchClass objects.
Public class | RuntimeSession | This object is required to gain access to any of the other objects in the hierarchy.
Remarks


Batch Class

Batch Class

Defines an interface that contains information about an active batch.

Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteBatch

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class Batch : IBatch
Public Class Batch
    Implements IBatch

The Batch type exposes the following members.

Methods
 | Name | Description
Public method | BatchClose | Closes and unlocks the batch.
Public method | BatchCloseWithModuleID | Closes and unlocks the batch to the specified module.
Public method | BatchDelete | Deletes the locked batch. Transfers any statistics information into the statistics file.
Public method | BatchOpen | Opens/Locks and returns a batch object.
Public method | BatchRecall | Recall a batch from a remote site back to the central site.
Public method | ChildBatchCreate | Creates a child batch based on an existing open parent batch. Each child batch uses the same published batch class as the parent batch.
Public method | ChildBatchCreate2 | Creates a child batch based on an existing open parent batch. Each child batch uses the same published batch class as the parent batch.
Public method | ChildBatchCreateWithBatchClass | Creates a child batch based on an existing open parent batch. Each child batch uses the specified published batch class.
Public method | ChildBatchCreateWithBatchClass2 | Creates a child batch based on an existing open parent batch. Each child batch uses the specified published batch class.
Public method | CustomPublishedDataFolder | Returns a custom data path based on the published batch class and the provided module ID.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | ExtractRuntimeACDataElement | Extracts the batch runtime root element for the Tungsten Capture Optimized Custom Module .NET Type Library API.
Public method | ExtractSetupACDataElement | Extracts the setup root element for the Tungsten Capture Optimized Custom Module .NET Type Library API.
Public method | GenerateDocumentUniqueID2 | Returns a unique document ID.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Refresh | Refresh the batch information properties. These are the properties that do not require the batch to be open.
Public method | ToString | (Inherited from Object.)
Public method | ValidityCheck | Does limited checking on the structure of the batch and batch class.
Public method | XMLExport | Creates an XML file from the .mdb file.
Public method | XMLExportBatchOnly | Creates an XML runtime file that contains ONLY batch information from the runtime batch.
Public method | XMLExportDocuments | Creates an XML runtime file that contains ONLY document information for a range of documents.
Public method | XMLImport | Updates the batch from the XML runtime file.
Public method | XMLImportBatchOnly | Reads runtime batch information from the XML file.
Public method | XMLImportDocuments | Reads an XML runtime document file and replaces the information in the database file.
Top
Properties
 | Name | Description
Public property | BatchClassName | Returns the name of the batch class.
Public property | BatchFieldValue | The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).
Public property | BatchFieldValueInt32 | The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).
Public property | BatchGUID | Gets the unique ID of this batch.
Public property | BatchId | Returns the batch ID.
Public property | BitonalImageFile | Returns the image file path for a bitonal image based on the image ID.
Public property | CreateDate | Returns the date and time the batch class was created.
Public property | CustomStorageString | The storage string with the specified name.
Public property | DocumentCount | Reads the batch and returns the document count.
Public property | ExternalBatchID | Returns the external batch ID.
Public property | HasError | Returns a Boolean value indicating if the batch has an error.
Public property | ImageDir | Returns the batch image folder.
Public property | ImageFile | Returns an image file path based on the image ID from the page object, to which the extension "TIF" is automatically appended.
Public property | ImageFileWithExt | Returns the image file path based on the image ID from the page object, and the extension of the file.
Public property | LastPublishedDate | The publish date of the batch class used to create this batch.
Public property | Name | Returns the name of the batch.
Public property | OCRDir | Returns the batch OCR folder.
Public property | PageCount | Reads the batch and returns the document count.
Public property | Priority | Returns the batch priority.
Public property | ProcessID | Returns the current process ID.
Public property | PubBatchDefID | Returns the published batch ID.
Public property | ScanStationID | Returns the Scan Station ID for the batch.
Public property | ScanUser | Returns the ID for the user who scanned the batch.
Public property | State | Returns the batch state. Can be mapped to the enumeration for the current state.
Public property | StationID | Returns the ID of the station/user that created the batch.
Top
Remarks
The Batch object can be used to display a list of batches available to process, similar to Batch Manager. The data is static unless the BatchOpen method is called. Batches may become active and not be available.
See Also

Reference

Kofax.Capture.DBLite Namespace


Batch Methods

Batch Methods

The Batch type exposes the following members.

Methods
 | Name | Description
Public method | BatchClose | Closes and unlocks the batch.
Public method | BatchCloseWithModuleID | Closes and unlocks the batch to the specified module.
Public method | BatchDelete | Deletes the locked batch. Transfers any statistics information into the statistics file.
Public method | BatchOpen | Opens/Locks and returns a batch object.
Public method | BatchRecall | Recall a batch from a remote site back to the central site.
Public method | ChildBatchCreate | Creates a child batch based on an existing open parent batch. Each child batch uses the same published batch class as the parent batch.
Public method | ChildBatchCreate2 | Creates a child batch based on an existing open parent batch. Each child batch uses the same published batch class as the parent batch.
Public method | ChildBatchCreateWithBatchClass | Creates a child batch based on an existing open parent batch. Each child batch uses the specified published batch class.
Public method | ChildBatchCreateWithBatchClass2 | Creates a child batch based on an existing open parent batch. Each child batch uses the specified published batch class.
Public method | CustomPublishedDataFolder | Returns a custom data path based on the published batch class and the provided module ID.
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | ExtractRuntimeACDataElement | Extracts the batch runtime root element for the Tungsten Capture Optimized Custom Module .NET Type Library API.
Public method | ExtractSetupACDataElement | Extracts the setup root element for the Tungsten Capture Optimized Custom Module .NET Type Library API.
Public method | GenerateDocumentUniqueID2 | Returns a unique document ID.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Refresh | Refresh the batch information properties. These are the properties that do not require the batch to be open.
Public method | ToString | (Inherited from Object.)
Public method | ValidityCheck | Does limited checking on the structure of the batch and batch class.
Public method | XMLExport | Creates an XML file from the .mdb file.
Public method | XMLExportBatchOnly | Creates an XML runtime file that contains ONLY batch information from the runtime batch.
Public method | XMLExportDocuments | Creates an XML runtime file that contains ONLY document information for a range of documents.
Public method | XMLImport | Updates the batch from the XML runtime file.
Public method | XMLImportBatchOnly | Reads runtime batch information from the XML file.
Public method | XMLImportDocuments | Reads an XML runtime document file and replaces the information in the database file.
Top
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.BatchClose Method

BatchBatchClose Method

Closes and unlocks the batch.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void BatchClose(
    KfxDbState eNewState,
    KfxDbQueue eQueue,
    int nErrorCode,
    string strErrorText
)
Public Sub BatchClose (
    eNewState As KfxDbState,
    eQueue As KfxDbQueue,
    nErrorCode As Integer,
    strErrorText As String
)

Parameters

eNewState
Type: Kofax.Capture.SDK.CustomModuleKfxDbState
Specifies the new state of the batch once it has been unlocked.
eQueue
Type: Kofax.Capture.SDK.CustomModuleKfxDbQueue

Allows the caller to choose where to route the batch.

If KfxDbQueueException is specified, the batch is routed to Quality Control (Rescan).

nErrorCode
Type: SystemInt32
Used only when the state is set to KfxDbBatchError. In this case, this value is recorded in the statistics record.
strErrorText
Type: SystemString
Used only when the state is set to KfxDbBatchError. In this case, this value is recorded in the statistics record.

Implements

IBatchBatchClose(KfxDbState, KfxDbQueue, Int32, String)
Remarks

Invalid state parameter for KfxDbState error if the eNewState is either KfxDbBatchReserved or KfxDbBatchInProgress2. The KfxDbBatchReserved and KfxDbBatchInProgress2 states are set internally and cannot be used as eNewState of the BatchClose method.

See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.BatchCloseWithModuleID Method

BatchBatchCloseWithModuleID Method

Closes and unlocks the batch to the specified module.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void BatchCloseWithModuleID(
    string strModuleID,
    KfxDbState eNewState
)
Public Sub BatchCloseWithModuleID (
    strModuleID As String,
    eNewState As KfxDbState
)

Parameters

strModuleID
Type: SystemString
The Unique ID (such as "ocr.exe") that specifies to which module to route the batch to.
eNewState
Type: Kofax.Capture.SDK.CustomModuleKfxDbState
Specifies the new state of the batch once it has been unlocked.

Implements

IBatchBatchCloseWithModuleID(String, KfxDbState)
Remarks

Invalid state parameter for KfxDbState error if the eNewState is either KfxDbBatchReserved or KfxDbBatchInProgress2. The KfxDbBatchReserved and KfxDbBatchInProgress2 states are set internally and cannot be used as eNewState of the BatchCloseWithModuleID method.

See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.BatchDelete Method

BatchBatchDelete Method

Deletes the locked batch. Transfers any statistics information into the statistics file.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void BatchDelete()
Public Sub BatchDelete

Implements

IBatchBatchDelete
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.BatchOpen Method

BatchBatchOpen Method

Opens/Locks and returns a batch object.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void BatchOpen(
    int nRequestingProcessId
)
Public Sub BatchOpen (
    nRequestingProcessId As Integer
)

Parameters

nRequestingProcessId
Type: SystemInt32
The process requesting the lock. For custom modules, it would be the custom module ProcessID.

Implements

IBatchBatchOpen(Int32)
Remarks
Errors: The batch is already locked.
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.BatchRecall Method

BatchBatchRecall Method

Recall a batch from a remote site back to the central site.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void BatchRecall()
Public Sub BatchRecall

Implements

IBatchBatchRecall
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ChildBatchCreate Method

BatchChildBatchCreate Method

Creates a child batch based on an existing open parent batch. Each child batch uses the same published batch class as the parent batch.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch ChildBatchCreate(
    string strBatchName = ""
)
Public Function ChildBatchCreate (
    Optional strBatchName As String = ""
) As IBatch

Parameters

strBatchName (Optional)
Type: SystemString
The name of the child batch. Optional.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch

Implements

IBatchChildBatchCreate(String)
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ChildBatchCreate2 Method

BatchChildBatchCreate2 Method

Creates a child batch based on an existing open parent batch. Each child batch uses the same published batch class as the parent batch.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch ChildBatchCreate2(
    string strBatchName = "",
    string strGUID = null
)
Public Function ChildBatchCreate2 (
    Optional strBatchName As String = "",
    Optional strGUID As String = Nothing
) As IBatch

Parameters

strBatchName (Optional)
Type: SystemString
The name of the child batch. Optional.
strGUID (Optional)
Type: SystemString
Must be a unique ID for the new batch. The ID must have the Registry GUID format {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch

Implements

IBatchChildBatchCreate2(String, String)
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ChildBatchCreateWithBatchClass Method

BatchChildBatchCreateWithBatchClass Method

Creates a child batch based on an existing open parent batch. Each child batch uses the specified published batch class.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch ChildBatchCreateWithBatchClass(
    string strBatchClassName,
    string strBatchName = ""
)
Public Function ChildBatchCreateWithBatchClass (
    strBatchClassName As String,
    Optional strBatchName As String = ""
) As IBatch

Parameters

strBatchClassName
Type: SystemString
The name of the child batch's batch class.
strBatchName (Optional)
Type: SystemString
The name of the child batch. Optional.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch

Implements

IBatchChildBatchCreateWithBatchClass(String, String)
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ChildBatchCreateWithBatchClass2 Method

BatchChildBatchCreateWithBatchClass2 Method

Creates a child batch based on an existing open parent batch. Each child batch uses the specified published batch class.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch ChildBatchCreateWithBatchClass2(
    string strBatchClassName,
    string strBatchName = "",
    string strGUID = null
)
Public Function ChildBatchCreateWithBatchClass2 (
    strBatchClassName As String,
    Optional strBatchName As String = "",
    Optional strGUID As String = Nothing
) As IBatch

Parameters

strBatchClassName
Type: SystemString
The name of the child batch's batch class.
strBatchName (Optional)
Type: SystemString
The name of the child batch. Optional.
strGUID (Optional)
Type: SystemString
Optional. If specified, must be a unique ID for the new batch. The ID must have the Registry GUID format {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch

Implements

IBatchChildBatchCreateWithBatchClass2(String, String, String)
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.CustomPublishedDataFolder Method

BatchCustomPublishedDataFolder Method

Returns a custom data path based on the published batch class and the provided module ID.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string CustomPublishedDataFolder(
    string strModuleID
)
Public Function CustomPublishedDataFolder (
    strModuleID As String
) As String

Parameters

strModuleID
Type: SystemString
The subfolder to be used as a custom data storage folder.

Return Value

Type: String
String

Implements

IBatchCustomPublishedDataFolder(String)
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.Dispose Method

BatchDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ExtractRuntimeACDataElement Method

BatchExtractRuntimeACDataElement Method

Extracts the batch runtime root element for the Tungsten Capture Optimized Custom Module .NET Type Library API.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElement ExtractRuntimeACDataElement(
    int nHints
)
Public Function ExtractRuntimeACDataElement (
    nHints As Integer
) As IACDataElement

Parameters

nHints
Type: SystemInt32

Starting with Ascent Capture 7.0, hints are deprecated. Tungsten Capture behaves as if the hints were always specified, providing the same performance gains in all cases (it is no longer necessary to use hints to improve performance). Hints are retained for backward compatibility, but no longer perform any useful function.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement

Implements

IBatchExtractRuntimeACDataElement(Int32)
Remarks
Kofax.Capture.SDK.Data.IACDataElement and all sub-elements are read-write, except where special exceptions apply, as noted here.
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ExtractSetupACDataElement Method

BatchExtractSetupACDataElement Method

Extracts the setup root element for the Tungsten Capture Optimized Custom Module .NET Type Library API.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElement ExtractSetupACDataElement(
    int nHints
)
Public Function ExtractSetupACDataElement (
    nHints As Integer
) As IACDataElement

Parameters

nHints
Type: SystemInt32

Starting with Ascent Capture 7.0, hints are deprecated. Tungsten Capture behaves as if the hints were always specified, providing the same performance gains in all cases (it is no longer necessary to use hints to improve performance). Hints are retained for backward compatibility, but no longer perform any useful function.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement

Implements

IBatchExtractSetupACDataElement(Int32)
Remarks

The returned ACDataElement and all sub-elements extracted from this call are read-only. Any attempt to update these elements causes an error.

This operation is extremely efficient as only the top element is extracted (rather than all sub-elements).

See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.GenerateDocumentUniqueID2 Method

BatchGenerateDocumentUniqueID2 Method

Returns a unique document ID.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int GenerateDocumentUniqueID2()
Public Function GenerateDocumentUniqueID2 As Integer

Return Value

Type: Int32
Integer

Implements

IBatchGenerateDocumentUniqueID2
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.Refresh Method

BatchRefresh Method

Refresh the batch information properties. These are the properties that do not require the batch to be open.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh

Implements

IBatchRefresh
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ValidityCheck Method

BatchValidityCheck Method

Does limited checking on the structure of the batch and batch class.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool ValidityCheck(
    ref Hashtable oErrorCollection = null,
    ref Hashtable oWarningCollection = null
)
Public Function ValidityCheck (
    Optional ByRef oErrorCollection As Hashtable = Nothing,
    Optional ByRef oWarningCollection As Hashtable = Nothing
) As Boolean

Parameters

oErrorCollection (Optional)
Type: System.CollectionsHashtable
Should be passed in as an empty collection of key/value pairs to get error strings.
oWarningCollection (Optional)
Type: System.CollectionsHashtable
Should be passed in as an empty collection of key/value pairs to get warning strings.

Return Value

Type: Boolean

Implements

IBatchValidityCheck(Hashtable, Hashtable)
Remarks

This is not as extensive as the checking in the Administration module; it is designed to catch simple cases and may be expanded in the future.

The collections contain error/warning strings if they were non-nothing in the originally. The function returns True if there were no errors.

See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.XMLExport Method

BatchXMLExport Method

Creates an XML file from the .mdb file.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void XMLExport(
    string strXMLRuntimeFileName,
    string strXMLSetupFileName = ""
)
Public Sub XMLExport (
    strXMLRuntimeFileName As String,
    Optional strXMLSetupFileName As String = ""
)

Parameters

strXMLRuntimeFileName
Type: SystemString
The full path and name for the XML runtime file to be created. Note that for high availability, this must be a local path.
strXMLSetupFileName (Optional)
Type: SystemString
The full path and name for the XML setup file to be created. This is an optional parameter. Custom modules should keep the batch open, so that the import and export occur during the same session. Note that for high availability, this must be a local path.

Implements

IBatchXMLExport(String, String)
Remarks
The batch must be opened prior to performing this operation.

Errors:
XML file cannot be created/opened.
XML file has a Write error.
Errors thrown by Import/Export code.
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.XMLExportBatchOnly Method

BatchXMLExportBatchOnly Method

Creates an XML runtime file that contains ONLY batch information from the runtime batch.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void XMLExportBatchOnly(
    string strXMLRuntimeFileName,
    string strXMLSetupFileName = ""
)
Public Sub XMLExportBatchOnly (
    strXMLRuntimeFileName As String,
    Optional strXMLSetupFileName As String = ""
)

Parameters

strXMLRuntimeFileName
Type: SystemString
The full path and name for XML runtime file that will contain the output XML. Note that for high availability, this must be a local path.
strXMLSetupFileName (Optional)
Type: SystemString
The full path and name for the XML setup file to be created. This is an optional parameter. Custom modules should keep the batch open, so that the import and export occur during the same session. Note that for high availability, this must be a local path.

Implements

IBatchXMLExportBatchOnly(String, String)
Remarks
This is useful for quickly obtaining batch information for individual documents.
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.XMLExportDocuments Method

BatchXMLExportDocuments Method

Creates an XML runtime file that contains ONLY document information for a range of documents.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void XMLExportDocuments(
    string strXMLRuntimeFileName,
    int nFirstDoc,
    int nLastDoc = -1
)
Public Sub XMLExportDocuments (
    strXMLRuntimeFileName As String,
    nFirstDoc As Integer,
    Optional nLastDoc As Integer = -1
)

Parameters

strXMLRuntimeFileName
Type: SystemString
The full path and name for the XML runtime file that will contain the output XML. Note that for high availability, this must be a local path.
nFirstDoc
Type: SystemInt32
The first document for document range. This is the order number and starts at 1. To export all documents, set this to -1.
nLastDoc (Optional)
Type: SystemInt32
The last document for range. If this is not set or if it is the same as the first document, only one document will be exported.

Implements

IBatchXMLExportDocuments(String, Int32, Int32)
Remarks

The documents may not be deleted. The document changes must be imported without any changes to the existing batch information.

This method is not supported when used on batches with folders. Calling this method on such a batch raises an error.

See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.XMLImport Method

BatchXMLImport Method

Updates the batch from the XML runtime file.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void XMLImport(
    string strXMLRuntimeFileName
)
Public Sub XMLImport (
    strXMLRuntimeFileName As String
)

Parameters

strXMLRuntimeFileName
Type: SystemString
The full path and name for the XML runtime file to import. Note that for high availability, this must be a local path.

Implements

IBatchXMLImport(String)
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.XMLImportBatchOnly Method

BatchXMLImportBatchOnly Method

Reads runtime batch information from the XML file.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void XMLImportBatchOnly(
    string strXMLRuntimeFileName
)
Public Sub XMLImportBatchOnly (
    strXMLRuntimeFileName As String
)

Parameters

strXMLRuntimeFileName
Type: SystemString
The full path and name of the XML file containing runtime batch information. Note that for high availability, this must be a local path.

Implements

IBatchXMLImportBatchOnly(String)
Remarks
The batch information must be imported into the same batch from which it was exported.

This XML file is designed for use with XML document import/export to quickly provide the active batch information.
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.XMLImportDocuments Method

BatchXMLImportDocuments Method

Reads an XML runtime document file and replaces the information in the database file.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void XMLImportDocuments(
    string strXMLRuntimeFileName,
    int nFirstDoc = -1,
    int nLastDoc = -1
)
Public Sub XMLImportDocuments (
    strXMLRuntimeFileName As String,
    Optional nFirstDoc As Integer = -1,
    Optional nLastDoc As Integer = -1
)

Parameters

strXMLRuntimeFileName
Type: SystemString
The full path and name of XML document runtime file to import. Note that for high availability, this must be a local path.
nFirstDoc (Optional)
Type: SystemInt32
This optional parameter is the first document for the document range (-1 means all).
nLastDoc (Optional)
Type: SystemInt32
This optional parameter is the last document for the document range.

Implements

IBatchXMLImportDocuments(String, Int32, Int32)
Remarks

The documents must be imported into the same batch from which they were exported. The number of documents may not be changed. Documents may not be deleted or added.

See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch Properties

Batch Properties

The Batch type exposes the following members.

Properties
 | Name | Description
Public property | BatchClassName | Returns the name of the batch class.
Public property | BatchFieldValue | The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).
Public property | BatchFieldValueInt32 | The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).
Public property | BatchGUID | Gets the unique ID of this batch.
Public property | BatchId | Returns the batch ID.
Public property | BitonalImageFile | Returns the image file path for a bitonal image based on the image ID.
Public property | CreateDate | Returns the date and time the batch class was created.
Public property | CustomStorageString | The storage string with the specified name.
Public property | DocumentCount | Reads the batch and returns the document count.
Public property | ExternalBatchID | Returns the external batch ID.
Public property | HasError | Returns a Boolean value indicating if the batch has an error.
Public property | ImageDir | Returns the batch image folder.
Public property | ImageFile | Returns an image file path based on the image ID from the page object, to which the extension "TIF" is automatically appended.
Public property | ImageFileWithExt | Returns the image file path based on the image ID from the page object, and the extension of the file.
Public property | LastPublishedDate | The publish date of the batch class used to create this batch.
Public property | Name | Returns the name of the batch.
Public property | OCRDir | Returns the batch OCR folder.
Public property | PageCount | Reads the batch and returns the document count.
Public property | Priority | Returns the batch priority.
Public property | ProcessID | Returns the current process ID.
Public property | PubBatchDefID | Returns the published batch ID.
Public property | ScanStationID | Returns the Scan Station ID for the batch.
Public property | ScanUser | Returns the ID for the user who scanned the batch.
Public property | State | Returns the batch state. Can be mapped to the enumeration for the current state.
Public property | StationID | Returns the ID of the station/user that created the batch.
Top
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.BatchClassName Property

BatchBatchClassName Property

Returns the name of the batch class.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string BatchClassName { get; }
Public ReadOnly Property BatchClassName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchBatchClassName
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.BatchFieldValue Property

BatchBatchFieldValue Property
Overload List
 | Name | Description
Public property | BatchFieldValue | The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).
Public property | BatchFieldValueInt32 | The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).
Top
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.BatchFieldValue Property

BatchBatchFieldValue Property

The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string BatchFieldValue { get; }
Public ReadOnly Property BatchFieldValue As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchBatchFieldValue
Remarks
To use this method, a filter must have been previously set by a call to SetBatchFilter. The specified batch filter will be applied when determining which batch to retrieve.
See Also

Reference

Batch Class
BatchFieldValue Overload
Kofax.Capture.DBLite Namespace


Batch.BatchFieldValue Property (Int32)

BatchBatchFieldValue Property (Int32)
Kofax Capture API Reference

The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    int index
] { get; }
Public ReadOnly Property BatchFieldValue (
    index As Integer
) As String
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchBatchFieldValueInt32
Remarks
To use this method, a filter must have been previously set by a call to SetBatchFilter. The specified batch filter will be applied when determining which batch to retrieve.
See Also

Reference

Batch Class
BatchFieldValue Overload
Kofax.Capture.DBLite Namespace


Batch.BatchGUID Property

BatchBatchGUID Property

Gets the unique ID of this batch.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string BatchGUID { get; }
Public ReadOnly Property BatchGUID As String
    Get

Property Value

Type: String
Unique ID String

Return Value

Type: String
String

Implements

IBatchBatchGUID
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.BatchId Property

BatchBatchId Property

Returns the batch ID.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int BatchId { get; }
Public ReadOnly Property BatchId As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchBatchId
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.BitonalImageFile Property

BatchBitonalImageFile Property

Returns the image file path for a bitonal image based on the image ID.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    int nImageID
] { get; }
Public ReadOnly Property BitonalImageFile (
    nImageID As Integer
) As String
    Get

Parameters

nImageID
Type: SystemInt32
The image ID from a page object.

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchBitonalImageFileInt32
Remarks

This function returns a file name, even if the file does not exist.

Custom modules that modify the color image should usually be inserted before Recognition Server, and custom modules that require a bitonal image must be placed after Recognition Server. This must be enforced by the custom module's registration (.aex) file.

See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.CreateDate Property

BatchCreateDate Property

Returns the date and time the batch class was created.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string CreateDate { get; }
Public ReadOnly Property CreateDate As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchCreateDate
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.CustomStorageString Property

BatchCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strName
] { get; set; }
Public Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchCustomStorageStringString
Remarks

Custom storage strings are custom text strings that are bound to a specific batch. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name or unlimited for a value. If set to an empty string, the storage string is deleted.

This function throws:(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.DocumentCount Property

BatchDocumentCount Property

Reads the batch and returns the document count.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int DocumentCount { get; }
Public ReadOnly Property DocumentCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchDocumentCount
Remarks
The batch must be locked to get the count.
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ExternalBatchID Property

BatchExternalBatchID Property

Returns the external batch ID.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ExternalBatchID { get; }
Public ReadOnly Property ExternalBatchID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchExternalBatchID
Remarks

Time-consuming: read on demand.

May fail if batch has been deleted or locked.

See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.HasError Property

BatchHasError Property

Returns a Boolean value indicating if the batch has an error.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool HasError { get; }
Public ReadOnly Property HasError As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IBatchHasError
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ImageDir Property

BatchImageDir Property

Returns the batch image folder.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ImageDir { get; }
Public ReadOnly Property ImageDir As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchImageDir
Remarks
The batch must be opened to read this property.
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ImageFile Property

BatchImageFile Property

Returns an image file path based on the image ID from the page object, to which the extension "TIF" is automatically appended.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    int nImageID
] { get; }
Public ReadOnly Property ImageFile (
    nImageID As Integer
) As String
    Get

Parameters

nImageID
Type: SystemInt32
The image ID from a page object.

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchImageFileInt32
Remarks
The batch must be open to read this property.

Use this property if the page you are processing is an image file. When processing an eDocument, use ImageFileWithExt rather than ImageFile.

See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ImageFileWithExt Property

BatchImageFileWithExt Property

Returns the image file path based on the image ID from the page object, and the extension of the file.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    int nImageID,
    string strExt
] { get; }
Public ReadOnly Property ImageFileWithExt (
    nImageID As Integer,
    strExt As String
) As String
    Get

Parameters

nImageID
Type: SystemInt32
The image ID from a page object.
strExt
Type: SystemString
The file extension.

Property Value

Type: String

Return Value

Type: String

Implements

IBatchImageFileWithExtInt32, String
Remarks
The batch must be opened to read this property.
Use this property if the page you are processing is an eDocument. For this case, the Extension attribute will be available from the Page object, and contain the extension of the file.
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.LastPublishedDate Property

BatchLastPublishedDate Property

The publish date of the batch class used to create this batch.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string LastPublishedDate { get; }
Public ReadOnly Property LastPublishedDate As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchLastPublishedDate
Remarks

The batch must be open to read this property.

This property is used for versioning.

May fail if batch has been deleted or locked.

See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.Name Property

BatchName Property

Returns the name of the batch.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchName
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.OCRDir Property

BatchOCRDir Property

Returns the batch OCR folder.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string OCRDir { get; }
Public ReadOnly Property OCRDir As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchOCRDir
Remarks
The batch must be open to read this property.
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.PageCount Property

BatchPageCount Property

Reads the batch and returns the document count.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int PageCount { get; }
Public ReadOnly Property PageCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchPageCount
Remarks
The batch must be locked to get the count.
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.Priority Property

BatchPriority Property

Returns the batch priority.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Priority { get; }
Public ReadOnly Property Priority As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchPriority
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ProcessID Property

BatchProcessID Property

Returns the current process ID.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ProcessID { get; }
Public ReadOnly Property ProcessID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchProcessID
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.PubBatchDefID Property

BatchPubBatchDefID Property

Returns the published batch ID.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int PubBatchDefID { get; }
Public ReadOnly Property PubBatchDefID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchPubBatchDefID
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ScanStationID Property

BatchScanStationID Property

Returns the Scan Station ID for the batch.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ScanStationID { get; }
Public ReadOnly Property ScanStationID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchScanStationID
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.ScanUser Property

BatchScanUser Property

Returns the ID for the user who scanned the batch.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ScanUser { get; }
Public ReadOnly Property ScanUser As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchScanUser
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.State Property

BatchState Property

Returns the batch state. Can be mapped to the enumeration for the current state.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int State { get; }
Public ReadOnly Property State As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchState
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


Batch.StationID Property

BatchStationID Property

Returns the ID of the station/user that created the batch.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string StationID { get; }
Public ReadOnly Property StationID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchStationID
Remarks
See Also

Reference

Batch Class
Kofax.Capture.DBLite Namespace


BatchCollection Class

BatchCollection Class

Defines a collection of batch objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteBatchCollection

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class BatchCollection : IBatchCollection
Public Class BatchCollection
    Implements IBatchCollection

The BatchCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Refresh | Deletes the current collection and returns a new one.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
Each batch object has data that can be obtained quickly, along with data that takes longer to obtain. Each object supports XML import and export, for which BatchOpen must be called to lock the batch.
See Also

Reference

Kofax.Capture.DBLite Namespace


BatchCollection Methods

BatchCollection Methods

The BatchCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Refresh | Deletes the current collection and returns a new one.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchCollection Class
Kofax.Capture.DBLite Namespace


BatchCollection.Dispose Method

BatchCollectionDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

BatchCollection Class
Kofax.Capture.DBLite Namespace


BatchCollection.GetEnumerator Method

BatchCollectionGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.SDK.CustomModule.IBatchCollection object.

Implements

IEnumerableGetEnumerator
Remarks
See Also

Reference

BatchCollection Class
Kofax.Capture.DBLite Namespace


BatchCollection.Refresh Method

BatchCollectionRefresh Method

Deletes the current collection and returns a new one.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Refresh(
    KfxDbFilter eFilterOptions,
    int nProcessID,
    KfxDbState eStates,
    bool bUserFilter = true
)
Public Sub Refresh (
    eFilterOptions As KfxDbFilter,
    nProcessID As Integer,
    eStates As KfxDbState,
    Optional bUserFilter As Boolean = true
)

Parameters

eFilterOptions
Type: Kofax.Capture.SDK.CustomModuleKfxDbFilter
You can specify options to limit the search scope, and/or specify sort criteria.
nProcessID
Type: SystemInt32
This parameter can be obtained from the Login object.
eStates
Type: Kofax.Capture.SDK.CustomModuleKfxDbState
If filtering on States is specified, this parameter must be passed as a nonzero value that contains a bitmask of the available States. Only batches that match the eStates mask will be considered.
bUserFilter (Optional)
Type: SystemBoolean
If this parameter is False, the collection will include all batches, even if the user does not have rights to them.

Implements

IBatchCollectionRefresh(KfxDbFilter, Int32, KfxDbState, Boolean)
Remarks
The collection returned may become quickly out of date if batches are processed at multiple sites.
See Also

Reference

BatchCollection Class
Kofax.Capture.DBLite Namespace


BatchCollection Properties

BatchCollection Properties

The BatchCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

BatchCollection Class
Kofax.Capture.DBLite Namespace


BatchCollection.Count Property

BatchCollectionCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchCollectionCount
Remarks
See Also

Reference

BatchCollection Class
Kofax.Capture.DBLite Namespace


BatchCollection.Item Property

BatchCollectionItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IBatch
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IBatch

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch

Implements

IBatchCollectionItemObject
Remarks
See Also

Reference

BatchCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldNamesCollection Class

BatchFieldNamesCollection Class

Defines a collection of batch field names.

Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteBatchFieldNamesCollection

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class BatchFieldNamesCollection : IBatchFieldNamesCollection
Public Class BatchFieldNamesCollection
    Implements IBatchFieldNamesCollection

The BatchFieldNamesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Refresh | Deletes the current collection and returns a new one.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.DBLite Namespace


BatchFieldNamesCollection Methods

BatchFieldNamesCollection Methods

The BatchFieldNamesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Refresh | Deletes the current collection and returns a new one.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchFieldNamesCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldNamesCollection.Dispose Method

BatchFieldNamesCollectionDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

BatchFieldNamesCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldNamesCollection.GetEnumerator Method

BatchFieldNamesCollectionGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.DBLite.BatchFieldNamesCollection object.

Implements

IEnumerableGetEnumerator
See Also

Reference

BatchFieldNamesCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldNamesCollection.Refresh Method

BatchFieldNamesCollectionRefresh Method

Deletes the current collection and returns a new one.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Refresh(
    bool bUserFilter = true
)
Public Sub Refresh (
    Optional bUserFilter As Boolean = true
)

Parameters

bUserFilter (Optional)
Type: SystemBoolean
If this parameter is False, the collection will include all batch field names, even if the user does not have rights to their batch classes.

Implements

IBatchFieldNamesCollectionRefresh(Boolean)
Remarks
The collection returned may become quickly obsolete if the administrator publishes batch classes or disables them.
See Also

Reference

BatchFieldNamesCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldNamesCollection Properties

BatchFieldNamesCollection Properties

The BatchFieldNamesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

BatchFieldNamesCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldNamesCollection.Count Property

BatchFieldNamesCollectionCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchFieldNamesCollectionCount
Remarks
See Also

Reference

BatchFieldNamesCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldNamesCollection.Item Property

BatchFieldNamesCollectionItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As String
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchFieldNamesCollectionItemObject
Remarks
See Also

Reference

BatchFieldNamesCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldValuesCollection Class

BatchFieldValuesCollection Class

Defines a collection of batch field values.

Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteBatchFieldValuesCollection

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class BatchFieldValuesCollection : IBatchFieldValuesCollection
Public Class BatchFieldValuesCollection
    Implements IBatchFieldValuesCollection

The BatchFieldValuesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Refresh | Deletes the current collection and returns a new one.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.DBLite Namespace


BatchFieldValuesCollection Methods

BatchFieldValuesCollection Methods

The BatchFieldValuesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Refresh | Deletes the current collection and returns a new one.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BatchFieldValuesCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldValuesCollection.Dispose Method

BatchFieldValuesCollectionDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

BatchFieldValuesCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldValuesCollection.GetEnumerator Method

BatchFieldValuesCollectionGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.SDK.CustomModule.IBatchFieldValuesCollection object.

Implements

IEnumerableGetEnumerator
See Also

Reference

BatchFieldValuesCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldValuesCollection.Refresh Method

BatchFieldValuesCollectionRefresh Method

Deletes the current collection and returns a new one.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Refresh(
    string strBatchFieldName
)
Public Sub Refresh (
    strBatchFieldName As String
)

Parameters

strBatchFieldName
Type: SystemString
If this parameter is False, the collection will include all batch field names, even if the user does not have rights to their batch classes.

Implements

IBatchFieldValuesCollectionRefresh(String)
Remarks
The collection returned may become quickly obsolete if the administrator publishes batch classes or disables them.
See Also

Reference

BatchFieldValuesCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldValuesCollection Properties

BatchFieldValuesCollection Properties

The BatchFieldValuesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

BatchFieldValuesCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldValuesCollection.Count Property

BatchFieldValuesCollectionCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IBatchFieldValuesCollectionCount
Remarks
See Also

Reference

BatchFieldValuesCollection Class
Kofax.Capture.DBLite Namespace


BatchFieldValuesCollection.Item Property

BatchFieldValuesCollectionItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As String
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: String

Return Value

Type: String
String

Implements

IBatchFieldValuesCollectionItemObject
Remarks
See Also

Reference

BatchFieldValuesCollection Class
Kofax.Capture.DBLite Namespace


Login Class

Login Class

The Login object forms the basis of the entire hierarchy. The properties of Login are used for error logging. A Login object should be maintained until the calling application shuts down; additional Login objects should not be introduced while the calling application is open.

Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteLogin

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class Login : ILogin
Public Class Login
    Implements ILogin

The Login type exposes the following members.

Constructors
 | Name | Description
Public method | Login | Initializes a new instance of the Kofax.Capture.DBLite.Login class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | Login | Logs into the system.
Public method | Logout | Cleans up internal references and releases the station license.
Public method | ToString | (Inherited from Object.)
Public method | ValidateUser | Validates the user for profiles.
Top
Properties
 | Name | Description
Public property | ApplicationName | Used in error logging.
Public property | EnableSecurityBoost | Enables SecurityBoost if it is enabled globally. By default, SecurityBoost is disabled.
Public property | ProcessID | Returns the process ID used to obtain the runtime session. Available after calling the ValidateUser method.
Public property | RuntimeSession | Returns the RuntimeSession object which is used to access other objects.
Public property | Version | Used in error logging.
Top
Remarks
See Also

Reference

Kofax.Capture.DBLite Namespace


Login Constructor

Login Constructor

Initializes a new instance of the Kofax.Capture.DBLite.Login class.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Login()
Public Sub New
Remarks
See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace


Login Methods

Login Methods

The Login type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | Login | Logs into the system.
Public method | Logout | Cleans up internal references and releases the station license.
Public method | ToString | (Inherited from Object.)
Public method | ValidateUser | Validates the user for profiles.
Top
See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace


Login.Dispose Method

LoginDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace


Login.LogError Method

LoginLogError Method

Logs an error to the Tungsten Capture error log.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void LogError(
    ref int nErrCode1,
    ref int nErrCode2,
    ref int nErrCode3,
    ref string strSource,
    ref int nLineNum,
    ref string strDesc,
    ref bool bRaise = false
)
Public Sub LogError (
    ByRef nErrCode1 As Integer,
    ByRef nErrCode2 As Integer,
    ByRef nErrCode3 As Integer,
    ByRef strSource As String,
    ByRef nLineNum As Integer,
    ByRef strDesc As String,
    Optional ByRef bRaise As Boolean = false
)

Parameters

nErrCode1
Type: SystemInt32
The primary error code.
nErrCode2
Type: SystemInt32
Subcode.
nErrCode3
Type: SystemInt32
Subcode.
strSource
Type: SystemString
The source code module where the problem occurred.
nLineNum
Type: SystemInt32
The line number within the source where the problem exists.
strDesc
Type: SystemString
The string message.
bRaise (Optional)
Type: SystemBoolean
If bRaise is True, the error will be re-raised after it is logged.

Implements

ILoginLogError(Int32, Int32, Int32, String, Int32, String, Boolean)
Remarks
See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace


Login.Login Method

LoginLogin Method

Logs into the system.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Login(
    string strRes1 = "",
    string strRes2 = ""
)
Public Sub Login (
    Optional strRes1 As String = "",
    Optional strRes2 As String = ""
)

Parameters

strRes1 (Optional)
Type: SystemString
This parameter is reserved.
strRes2 (Optional)
Type: SystemString
This parameter is reserved.

Implements

ILoginLogin(String, String)
Remarks
See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace


Login.Logout Method

LoginLogout Method

Cleans up internal references and releases the station license.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Logout()
Public Sub Logout

Implements

ILoginLogout
Remarks
See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace


Login.ValidateUser Method

LoginValidateUser Method

Validates the user for profiles.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void ValidateUser(
    string strUniqueID,
    bool bShowDlg = true,
    string strUserID = "",
    string strPwd = ""
)
Public Sub ValidateUser (
    strUniqueID As String,
    Optional bShowDlg As Boolean = true,
    Optional strUserID As String = "",
    Optional strPwd As String = ""
)

Parameters

strUniqueID
Type: SystemString
Set this parameter to the module ID of the custom module. If the module has not been registered, an error will be raised. Otherwise, the ProcessID property will be set with the process ID for the module.
bShowDlg (Optional)
Type: SystemBoolean
If this parameter is True, a dialog will prompt for user ID and password when user profiles are enabled. Set to False to validate an ID and password you have already obtained.
strUserID (Optional)
Type: SystemString
The user ID.
strPwd (Optional)
Type: SystemString
The user password.

Implements

ILoginValidateUser(String, Boolean, String, String)
Remarks
See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace


Login Properties

Login Properties

The Login type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Used in error logging.
Public property | EnableSecurityBoost | Enables SecurityBoost if it is enabled globally. By default, SecurityBoost is disabled.
Public property | ProcessID | Returns the process ID used to obtain the runtime session. Available after calling the ValidateUser method.
Public property | RuntimeSession | Returns the RuntimeSession object which is used to access other objects.
Public property | Version | Used in error logging.
Top
See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace


Login.ApplicationName Property

LoginApplicationName Property

Used in error logging.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ApplicationName { get; set; }
Public Property ApplicationName As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String - may be empty.

Implements

ILoginApplicationName
Remarks
See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace


Login.EnableSecurityBoost Property

LoginEnableSecurityBoost Property

Enables SecurityBoost if it is enabled globally. By default, SecurityBoost is disabled.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool EnableSecurityBoost { get; set; }
Public Property EnableSecurityBoost As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

ILoginEnableSecurityBoost
Remarks

This property always defaults to "False," even if SecurityBoost is enabled globally.

Setting the property to "true" only enables SecurityBoost if it is enabled for the entire system. Otherwise, the property is still set to "True," but SecurityBoost does not take effect.

This property can be read at any time, but can only be written before logging in (with the Login method). Attempting to write it at any other time causes an error.

See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace


Login.ProcessID Property

LoginProcessID Property

Returns the process ID used to obtain the runtime session. Available after calling the ValidateUser method.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ProcessID { get; }
Public ReadOnly Property ProcessID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ILoginProcessID
Remarks

The ProcessID for a custom module must be unique from the ProcessID assigned to the Tungsten Capture standard processing modules, as listed below:

  • Batch Manager: 8
  • Kofax PDF Generator: 14999
  • OCR Full Text: 6
  • Quality Control: 2
  • Recognition Server: 3
  • Export: 7
  • Scan: 1
  • Validation: 4
  • Verification: 5
See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace


Login.RuntimeSession Property

LoginRuntimeSession Property

Returns the RuntimeSession object which is used to access other objects.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRuntimeSession RuntimeSession { get; }
Public ReadOnly Property RuntimeSession As IRuntimeSession
    Get

Property Value

Type: IRuntimeSession

Return Value

Type: IRuntimeSession
Kofax.Capture.SDK.CustomModule.IRuntimeSession

Implements

ILoginRuntimeSession
Remarks
There is only 1 RuntimeSession per login. Be sure to call ValidateUser before getting the RuntimeSession.
See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace


Login.Version Property

LoginVersion Property

Used in error logging.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String - may be empty.

Implements

ILoginVersion
Remarks
See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace


Login2 Class

Login2 Class

The Login object forms the basis of the entire hierarchy. The properties of Login are used for error logging. A Login object should be maintained until the calling application shuts down; additional Login objects should not be introduced while the calling application is open.

Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteLogin2

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class Login2 : ILogin2
Public Class Login2
    Implements ILogin2

The Login2 type exposes the following members.

Constructors
 | Name | Description
Public method | Login2 | Initializes a new instance of the Kofax.Capture.DBLite.Login2 class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | Login | Logs into the system.
Public method | Logout | Cleans up internal references and releases the station license.
Public method | ToString | (Inherited from Object.)
Public method | ValidateUser | Validates the user for profiles.
Public method | ValidateUser2 | Validates the user for profiles.
Top
Properties
 | Name | Description
Public property | ApplicationName | Used in error logging.
Public property | EnableReporting | Enables/Disables reporting for Custom Module. This is enabled by default.
Public property | EnableSecurityBoost | Enables SecurityBoost if it is enabled globally. By default, SecurityBoost is disabled.
Public property | ProcessID | Returns the process ID used to obtain the runtime session. Available after calling the ValidateUser method.
Public property | RuntimeSession | Returns the RuntimeSession object which is used to access other objects.
Public property | SharedUserProfileModel | Gets or sets the shared user profile model.
Public property | SupportUserChanged | Set by a custom module to indicate that it supports the feature for tracking user interaction related to field changes.
Public property | Version | Used in error logging.
Top
Remarks
See Also

Reference

Kofax.Capture.DBLite Namespace


Login2 Constructor

Login2 Constructor

Initializes a new instance of the Kofax.Capture.DBLite.Login2 class.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Login2()
Public Sub New
Remarks
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2 Methods

Login2 Methods

The Login2 type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | Login | Logs into the system.
Public method | Logout | Cleans up internal references and releases the station license.
Public method | ToString | (Inherited from Object.)
Public method | ValidateUser | Validates the user for profiles.
Public method | ValidateUser2 | Validates the user for profiles.
Top
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.Dispose Method

Login2Dispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.LogError Method

Login2LogError Method

Logs an error to the Tungsten Capture error log.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void LogError(
    ref int nErrCode1,
    ref int nErrCode2,
    ref int nErrCode3,
    ref string strSource,
    ref int nLineNum,
    ref string strDesc,
    ref bool bRaise = false
)
Public Sub LogError (
    ByRef nErrCode1 As Integer,
    ByRef nErrCode2 As Integer,
    ByRef nErrCode3 As Integer,
    ByRef strSource As String,
    ByRef nLineNum As Integer,
    ByRef strDesc As String,
    Optional ByRef bRaise As Boolean = false
)

Parameters

nErrCode1
Type: SystemInt32
The primary error code.
nErrCode2
Type: SystemInt32
Subcode.
nErrCode3
Type: SystemInt32
Subcode.
strSource
Type: SystemString
The source code module where the problem occurred.
nLineNum
Type: SystemInt32
The line number within the source where the problem exists.
strDesc
Type: SystemString
The string message.
bRaise (Optional)
Type: SystemBoolean
If bRaise is True, the error will be re-raised after it is logged.

Implements

ILogin2LogError(Int32, Int32, Int32, String, Int32, String, Boolean)
Remarks
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.Login Method

Login2Login Method

Logs into the system.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Login(
    string strRes1 = "",
    string strRes2 = ""
)
Public Sub Login (
    Optional strRes1 As String = "",
    Optional strRes2 As String = ""
)

Parameters

strRes1 (Optional)
Type: SystemString
This parameter is reserved.
strRes2 (Optional)
Type: SystemString
This parameter is reserved.

Implements

ILogin2Login(String, String)
Remarks
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.Logout Method

Login2Logout Method

Cleans up internal references and releases the station license.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Logout()
Public Sub Logout

Implements

ILogin2Logout
Remarks
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.ValidateUser Method

Login2ValidateUser Method

Validates the user for profiles.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void ValidateUser(
    string strUniqueID,
    bool bShowDlg = true,
    string strUserID = "",
    string strPwd = ""
)
Public Sub ValidateUser (
    strUniqueID As String,
    Optional bShowDlg As Boolean = true,
    Optional strUserID As String = "",
    Optional strPwd As String = ""
)

Parameters

strUniqueID
Type: SystemString
Set this parameter to the module ID of the custom module. If the module has not been registered, an error will be raised. Otherwise, the ProcessID property will be set with the process ID for the module.
bShowDlg (Optional)
Type: SystemBoolean
If this parameter is True, a dialog will prompt for user ID and password when user profiles are enabled. Set to False to validate an ID and password you have already obtained.
strUserID (Optional)
Type: SystemString
The user ID.
strPwd (Optional)
Type: SystemString
The user password.

Implements

ILogin2ValidateUser(String, Boolean, String, String)
Remarks
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.ValidateUser2 Method

Login2ValidateUser2 Method

Validates the user for profiles.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void ValidateUser2(
    string strUsername,
    string strPassword
)
Public Sub ValidateUser2 (
    strUsername As String,
    strPassword As String
)

Parameters

strUsername
Type: SystemString
The user name.
strPassword
Type: SystemString
The user password.

Implements

ILogin2ValidateUser2(String, String)
Remarks
Throws LoginException if the user name or password does not match.
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2 Properties

Login2 Properties

The Login2 type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Used in error logging.
Public property | EnableReporting | Enables/Disables reporting for Custom Module. This is enabled by default.
Public property | EnableSecurityBoost | Enables SecurityBoost if it is enabled globally. By default, SecurityBoost is disabled.
Public property | ProcessID | Returns the process ID used to obtain the runtime session. Available after calling the ValidateUser method.
Public property | RuntimeSession | Returns the RuntimeSession object which is used to access other objects.
Public property | SharedUserProfileModel | Gets or sets the shared user profile model.
Public property | SupportUserChanged | Set by a custom module to indicate that it supports the feature for tracking user interaction related to field changes.
Public property | Version | Used in error logging.
Top
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.ApplicationName Property

Login2ApplicationName Property

Used in error logging.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ApplicationName { get; set; }
Public Property ApplicationName As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String - may be empty.

Implements

ILogin2ApplicationName
Remarks
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.EnableReporting Property

Login2EnableReporting Property

Enables/Disables reporting for Custom Module. This is enabled by default.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool EnableReporting { get; set; }
Public Property EnableReporting As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean

Implements

ILogin2EnableReporting
Remarks
This property must be set before the Login function is called.
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.EnableSecurityBoost Property

Login2EnableSecurityBoost Property

Enables SecurityBoost if it is enabled globally. By default, SecurityBoost is disabled.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool EnableSecurityBoost { get; set; }
Public Property EnableSecurityBoost As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

ILogin2EnableSecurityBoost
Remarks

This property always defaults to "False," even if SecurityBoost is enabled globally.

Setting the property to "true" only enables SecurityBoost if it is enabled for the entire system. Otherwise, the property is still set to "True," but SecurityBoost does not take effect.

This property can be read at any time, but can only be written before logging in (with the Login method). Attempting to write it at any other time causes an error.

See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.ProcessID Property

Login2ProcessID Property

Returns the process ID used to obtain the runtime session. Available after calling the ValidateUser method.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ProcessID { get; }
Public ReadOnly Property ProcessID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

ILogin2ProcessID
Remarks

The ProcessID for a custom module must be unique from the ProcessID assigned to the Tungsten Capture standard processing modules, as listed below:

  • Batch Manager: 8
  • Kofax PDF Generator: 14999
  • OCR Full Text: 6
  • Quality Control: 2
  • Recognition Server: 3
  • Export: 7
  • Scan: 1
  • Validation: 4
  • Verification: 5
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.RuntimeSession Property

Login2RuntimeSession Property

Returns the RuntimeSession object which is used to access other objects.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRuntimeSession RuntimeSession { get; }
Public ReadOnly Property RuntimeSession As IRuntimeSession
    Get

Property Value

Type: IRuntimeSession

Return Value

Type: IRuntimeSession
Kofax.Capture.SDK.CustomModule.IRuntimeSession

Implements

ILogin2RuntimeSession
Remarks
There is only 1 RuntimeSession per login. Be sure to call ValidateUser before getting the RuntimeSession.
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.SharedUserProfileModel Property

Login2SharedUserProfileModel Property

Gets or sets the shared user profile model.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SharedUserProfileModel { get; set; }
Public Property SharedUserProfileModel As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean. Returns True if using the shared user profile model.

Implements

ILogin2SharedUserProfileModel
Remarks
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.SupportUserChanged Property

Login2SupportUserChanged Property
Set by a custom module to indicate that it supports the feature for tracking user interaction related to field changes.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SupportUserChanged { get; set; }
Public Property SupportUserChanged As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean

Implements

ILogin2SupportUserChanged
Remarks
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


Login2.Version Property

Login2Version Property

Used in error logging.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String - may be empty.

Implements

ILogin2Version
Remarks
See Also

Reference

Login2 Class
Kofax.Capture.DBLite Namespace


MonitorMgr Class

MonitorMgr Class
Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteMonitorMgr

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class MonitorMgr : IDisposable
Public Class MonitorMgr
    Implements IDisposable

The MonitorMgr type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorMgr | Initializes a new instance of the MonitorMgr class
Top
Methods
 | Name | Description
Public method | AssignHandle |
Public method | Dispose | Releases all resources used by the MonitorMgr
Public method | EndMonitor |
Public method | Equals | (Inherited from Object.)
 | GetActiveWindow |
 | GetForegroundWindow |
Public method | GetHashCode | (Inherited from Object.)
 | GetTickCount |
Public method | GetType | (Inherited from Object.)
 | GetWindowThreadProcessId |
 | IsProcessActivated |
 | SendMessage |
Public method | StartMonitor(Int32) |
Public method | StartMonitor(Int32, IntPtr) |
Public method | ToString | (Inherited from Object.)
Top
Fields
Name | Description
ENDSESSION_CLOSEAPP |
ENDSESSION_LOGOFF |
WM_QUERYENDSESSION |
Top
Events
 | Name | Description
Public event | OnSessionTimeOut |
Top
See Also

Reference

Kofax.Capture.DBLite Namespace


MonitorMgr Constructor

MonitorMgr Constructor
Initializes a new instance of the MonitorMgr class

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public MonitorMgr()
Public Sub New
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr Fields

MonitorMgr Fields

The MonitorMgr type exposes the following members.

Fields
Name | Description
ENDSESSION_CLOSEAPP |
ENDSESSION_LOGOFF |
WM_QUERYENDSESSION |
Top
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.ENDSESSION_CLOSEAPP Field

MonitorMgrENDSESSION_CLOSEAPP Field

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public const int ENDSESSION_CLOSEAPP
Public Const ENDSESSION_CLOSEAPP As Integer

Field Value

Type: Int32
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.ENDSESSION_LOGOFF Field

MonitorMgrENDSESSION_LOGOFF Field

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public const int ENDSESSION_LOGOFF
Public Const ENDSESSION_LOGOFF As Integer

Field Value

Type: Int32
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.WM_QUERYENDSESSION Field

MonitorMgrWM_QUERYENDSESSION Field

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public const int WM_QUERYENDSESSION
Public Const WM_QUERYENDSESSION As Integer

Field Value

Type: Int32
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr Methods

MonitorMgr Methods

The MonitorMgr type exposes the following members.

Methods
 | Name | Description
Public method | AssignHandle |
Public method | Dispose |
Public method | EndMonitor |
Public method | Equals | (Inherited from Object.)
 | GetActiveWindow |
 | GetForegroundWindow |
Public method | GetHashCode | (Inherited from Object.)
 | GetTickCount |
Public method | GetType | (Inherited from Object.)
 | GetWindowThreadProcessId |
 | IsProcessActivated |
 | SendMessage |
Public method | StartMonitor(Int32) |
Public method | StartMonitor(Int32, IntPtr) |
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.AssignHandle Method

MonitorMgrAssignHandle Method

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void AssignHandle(
    IntPtr hWnd
)
Public Sub AssignHandle (
    hWnd As IntPtr
)

Parameters

hWnd
Type: SystemIntPtr
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.Dispose Method

MonitorMgrDispose Method
Releases all resources used by the MonitorMgr

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.EndMonitor Method

MonitorMgrEndMonitor Method

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void EndMonitor()
Public Sub EndMonitor
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.GetActiveWindow Method

MonitorMgrGetActiveWindow Method

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[DllImportAttribute("user32.dll", CharSet = CharSet.Auto, ExactSpelling = true)]
public static IntPtr GetActiveWindow()
<DllImportAttribute("user32.dll", CharSet := CharSet.Auto, ExactSpelling := true>]
Public Shared Function GetActiveWindow As IntPtr

Return Value

Type: IntPtr
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.GetForegroundWindow Method

MonitorMgrGetForegroundWindow Method

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[DllImportAttribute("user32.dll", CharSet = CharSet.Auto, ExactSpelling = true)]
public static IntPtr GetForegroundWindow()
<DllImportAttribute("user32.dll", CharSet := CharSet.Auto, ExactSpelling := true>]
Public Shared Function GetForegroundWindow As IntPtr

Return Value

Type: IntPtr
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.GetTickCount Method

MonitorMgrGetTickCount Method

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[DllImportAttribute("kernel32.dll", CharSet = CharSet.Auto, ExactSpelling = true)]
public static int GetTickCount()
<DllImportAttribute("kernel32.dll", CharSet := CharSet.Auto, ExactSpelling := true>]
Public Shared Function GetTickCount As Integer

Return Value

Type: Int32
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.GetWindowThreadProcessId Method

MonitorMgrGetWindowThreadProcessId Method

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[DllImportAttribute("user32.dll", SetLastError = true)]
public static int GetWindowThreadProcessId(
    IntPtr hwnd,
    ref int lpdwProcessId
)
<DllImportAttribute("user32.dll", SetLastError := true>]
Public Shared Function GetWindowThreadProcessId (
    hwnd As IntPtr,
    ByRef lpdwProcessId As Integer
) As Integer

Parameters

hwnd
Type: SystemIntPtr
lpdwProcessId
Type: SystemInt32

Return Value

Type: Int32
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.IsProcessActivated Method

MonitorMgrIsProcessActivated Method

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static bool IsProcessActivated()
Public Shared Function IsProcessActivated As Boolean

Return Value

Type: Boolean
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.SendMessage Method

MonitorMgrSendMessage Method

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[DllImportAttribute("user32.dll", SetLastError = true)]
public static IntPtr SendMessage(
    IntPtr hWnd,
    int Msg,
    IntPtr wParam,
    IntPtr lParam
)
<DllImportAttribute("user32.dll", SetLastError := true>]
Public Shared Function SendMessage (
    hWnd As IntPtr,
    Msg As Integer,
    wParam As IntPtr,
    lParam As IntPtr
) As IntPtr

Parameters

hWnd
Type: SystemIntPtr
Msg
Type: SystemInt32
wParam
Type: SystemIntPtr
lParam
Type: SystemIntPtr

Return Value

Type: IntPtr
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.StartMonitor Method

MonitorMgrStartMonitor Method
Overload List
 | Name | Description
Public method | StartMonitor(Int32) |
Public method | StartMonitor(Int32, IntPtr) |
Top
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.StartMonitor Method (Int32)

MonitorMgrStartMonitor Method (Int32)
Kofax Capture API Reference

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void StartMonitor(
    int waitingTime
)
Public Sub StartMonitor (
    waitingTime As Integer
)

Parameters

waitingTime
Type: SystemInt32
See Also

Reference

MonitorMgr Class
StartMonitor Overload
Kofax.Capture.DBLite Namespace


MonitorMgr.StartMonitor Method (Int32, IntPtr)

MonitorMgrStartMonitor Method (Int32, IntPtr)
Kofax Capture API Reference

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void StartMonitor(
    int waitingTime,
    IntPtr hWnd
)
Public Sub StartMonitor (
    waitingTime As Integer,
    hWnd As IntPtr
)

Parameters

waitingTime
Type: SystemInt32
hWnd
Type: SystemIntPtr
See Also

Reference

MonitorMgr Class
StartMonitor Overload
Kofax.Capture.DBLite Namespace


MonitorMgr Properties

MonitorMgr Properties
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr Events

MonitorMgr Events

The MonitorMgr type exposes the following members.

Events
 | Name | Description
Public event | OnSessionTimeOut |
Top
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


MonitorMgr.OnSessionTimeOut Event

MonitorMgrOnSessionTimeOut Event

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event TimeoutEventHandler<TimeoutEventArg> OnSessionTimeOut
Public Event OnSessionTimeOut As TimeoutEventHandler(Of TimeoutEventArg)

Value

Type: Kofax.Capture.SDK.CustomModuleTimeoutEventHandler TimeoutEventArg
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


Process Class

Process Class

Defines a process object that holds information about a Tungsten Capture standard process.

Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteProcess

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class Process : IProcess
Public Class Process
    Implements IProcess

The Process type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | CommandLineParameters | Returns the command line parameters for process.
Public property | Description | Returns the process description.
Public property | FilterName | Returns the process filter name.
Public property | ImageIndex | Returns the index of process icons.
Public property | Name | Returns the name displayed for this process.
Public property | ProcessID | Returns unique ID of the process. This is the number used in calls requiring a process ID.
Public property | Program | Returns the process executable name with the .exe extension.
Public property | SetupCommandLineParameters | Returns the command line parameters for setup program.
Public property | SetupProgram | Returns the path to process the setup executable file (OCX).
Public property | UniqueID | Returns the unique ID of the process.
Public property | VersionNumber | Returns the version of the process.
Top
Remarks
See Also

Reference

Kofax.Capture.DBLite Namespace


Process Methods

Process Methods

The Process type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


Process.Dispose Method

ProcessDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


Process Properties

Process Properties

The Process type exposes the following members.

Properties
 | Name | Description
Public property | CommandLineParameters | Returns the command line parameters for process.
Public property | Description | Returns the process description.
Public property | FilterName | Returns the process filter name.
Public property | ImageIndex | Returns the index of process icons.
Public property | Name | Returns the name displayed for this process.
Public property | ProcessID | Returns unique ID of the process. This is the number used in calls requiring a process ID.
Public property | Program | Returns the process executable name with the .exe extension.
Public property | SetupCommandLineParameters | Returns the command line parameters for setup program.
Public property | SetupProgram | Returns the path to process the setup executable file (OCX).
Public property | UniqueID | Returns the unique ID of the process.
Public property | VersionNumber | Returns the version of the process.
Top
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


Process.CommandLineParameters Property

ProcessCommandLineParameters Property

Returns the command line parameters for process.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string CommandLineParameters { get; }
Public ReadOnly Property CommandLineParameters As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IProcessCommandLineParameters
Remarks
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


Process.Description Property

ProcessDescription Property

Returns the process description.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IProcessDescription
Remarks
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


Process.FilterName Property

ProcessFilterName Property

Returns the process filter name.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string FilterName { get; }
Public ReadOnly Property FilterName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IProcessFilterName
Remarks
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


Process.ImageIndex Property

ProcessImageIndex Property

Returns the index of process icons.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ImageIndex { get; }
Public ReadOnly Property ImageIndex As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IProcessImageIndex
Remarks
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


Process.Name Property

ProcessName Property

Returns the name displayed for this process.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IProcessName
Remarks
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


Process.ProcessID Property

ProcessProcessID Property

Returns unique ID of the process. This is the number used in calls requiring a process ID.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ProcessID { get; }
Public ReadOnly Property ProcessID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IProcessProcessID
Remarks
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


Process.Program Property

ProcessProgram Property

Returns the process executable name with the .exe extension.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Program { get; }
Public ReadOnly Property Program As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IProcessProgram
Remarks
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


Process.SetupCommandLineParameters Property

ProcessSetupCommandLineParameters Property

Returns the command line parameters for setup program.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string SetupCommandLineParameters { get; }
Public ReadOnly Property SetupCommandLineParameters As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IProcessSetupCommandLineParameters
Remarks
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


Process.SetupProgram Property

ProcessSetupProgram Property

Returns the path to process the setup executable file (OCX).

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string SetupProgram { get; }
Public ReadOnly Property SetupProgram As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IProcessSetupProgram
Remarks
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


Process.UniqueID Property

ProcessUniqueID Property

Returns the unique ID of the process.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string UniqueID { get; }
Public ReadOnly Property UniqueID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IProcessUniqueID
Remarks
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


Process.VersionNumber Property

ProcessVersionNumber Property

Returns the version of the process.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int VersionNumber { get; }
Public ReadOnly Property VersionNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IProcessVersionNumber
Remarks
See Also

Reference

Process Class
Kofax.Capture.DBLite Namespace


ProcessCollection Class

ProcessCollection Class

Defines a collection that identifies the different queues in the system. Custom modules will find their process IDs in the collection and use them for getting batches and constructing the "where " clause for the BatchCollection.

Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteProcessCollection

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ProcessCollection : IProcessCollection
Public Class ProcessCollection
    Implements IProcessCollection

The ProcessCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Refresh | The collection returned may become out of date. The refresh destroys the current collection and returns a new one.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Public property | RuntimeSession | The runtime session that created the collection.
Top
Remarks
See Also

Reference

Kofax.Capture.DBLite Namespace


ProcessCollection Methods

ProcessCollection Methods

The ProcessCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Refresh | The collection returned may become out of date. The refresh destroys the current collection and returns a new one.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ProcessCollection Class
Kofax.Capture.DBLite Namespace


ProcessCollection.Dispose Method

ProcessCollectionDispose Method

Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

ProcessCollection Class
Kofax.Capture.DBLite Namespace


ProcessCollection.GetEnumerator Method

ProcessCollectionGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.SDK.CustomModule.IProcessCollection object.

Implements

IEnumerableGetEnumerator
See Also

Reference

ProcessCollection Class
Kofax.Capture.DBLite Namespace


ProcessCollection.Refresh Method

ProcessCollectionRefresh Method

The collection returned may become out of date. The refresh destroys the current collection and returns a new one.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Refresh()
Public Sub Refresh

Implements

IProcessCollectionRefresh
Remarks
See Also

Reference

ProcessCollection Class
Kofax.Capture.DBLite Namespace


ProcessCollection Properties

ProcessCollection Properties

The ProcessCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Public property | RuntimeSession | The runtime session that created the collection.
Top
See Also

Reference

ProcessCollection Class
Kofax.Capture.DBLite Namespace


ProcessCollection.Count Property

ProcessCollectionCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IProcessCollectionCount
Remarks
See Also

Reference

ProcessCollection Class
Kofax.Capture.DBLite Namespace


ProcessCollection.Item Property

ProcessCollectionItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IProcess this[
    Object vntIndexKey
] { get; }
Public ReadOnly Default Property Item (
    vntIndexKey As Object
) As IProcess
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IProcess

Return Value

Type: IProcess
Kofax.Capture.SDK.CustomModule.IProcess

Implements

IProcessCollectionItemObject
Remarks
See Also

Reference

ProcessCollection Class
Kofax.Capture.DBLite Namespace


ProcessCollection.RuntimeSession Property

ProcessCollectionRuntimeSession Property

The runtime session that created the collection.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IRuntimeSession RuntimeSession { set; }
Public WriteOnly Property RuntimeSession As IRuntimeSession
    Set

Property Value

Type: IRuntimeSession
The runtime session to set.

Implements

IProcessCollectionRuntimeSession
Remarks
Must be set before calling Refresh.
See Also

Reference

ProcessCollection Class
Kofax.Capture.DBLite Namespace


PublishedBatchClass Class

PublishedBatchClass Class

Defines information for published batch class event.

Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLitePublishedBatchClass

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class PublishedBatchClass : IPublishedBatchClass
Public Class PublishedBatchClass
    Implements IPublishedBatchClass

The PublishedBatchClass type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the published batch class.
Top
Remarks
There is no guarantee that the batch class will not be deleted or republished. New batch classes may also be published while using this object.
See Also

Reference

Kofax.Capture.DBLite Namespace


PublishedBatchClass Methods

PublishedBatchClass Methods

The PublishedBatchClass type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PublishedBatchClass Class
Kofax.Capture.DBLite Namespace


PublishedBatchClass.Dispose Method

PublishedBatchClassDispose Method
Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

PublishedBatchClass Class
Kofax.Capture.DBLite Namespace


PublishedBatchClass Properties

PublishedBatchClass Properties

The PublishedBatchClass type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the published batch class.
Top
See Also

Reference

PublishedBatchClass Class
Kofax.Capture.DBLite Namespace


PublishedBatchClass.Name Property

PublishedBatchClassName Property
Gets or sets the name of the published batch class.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String

Implements

IPublishedBatchClassName
Remarks
See Also

Reference

PublishedBatchClass Class
Kofax.Capture.DBLite Namespace


PublishedBatchClassCollection Class

PublishedBatchClassCollection Class

Defines a collection of IPublishedBatchClass objects.

Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLitePublishedBatchClassCollection

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class PublishedBatchClassCollection : IPublishedBatchClassCollection
Public Class PublishedBatchClassCollection
    Implements IPublishedBatchClassCollection

The PublishedBatchClassCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the PublishedBatchClassCollection
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Refresh | Deletes the current collection and returns a new one.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.DBLite Namespace


PublishedBatchClassCollection Methods

PublishedBatchClassCollection Methods

The PublishedBatchClassCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Refresh | Deletes the current collection and returns a new one.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

PublishedBatchClassCollection Class
Kofax.Capture.DBLite Namespace


PublishedBatchClassCollection.Dispose Method

PublishedBatchClassCollectionDispose Method
Releases all resources used by the PublishedBatchClassCollection

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

PublishedBatchClassCollection Class
Kofax.Capture.DBLite Namespace


PublishedBatchClassCollection.GetEnumerator Method

PublishedBatchClassCollectionGetEnumerator Method

Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.SDK.CustomModule.IPublishedBatchClassCollection object.

Implements

IEnumerableGetEnumerator
See Also

Reference

PublishedBatchClassCollection Class
Kofax.Capture.DBLite Namespace


PublishedBatchClassCollection.Refresh Method

PublishedBatchClassCollectionRefresh Method

Deletes the current collection and returns a new one.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Refresh(
    ref bool bUserFilter = true
)
Public Sub Refresh (
    Optional ByRef bUserFilter As Boolean = true
)

Parameters

bUserFilter (Optional)
Type: SystemBoolean
If this parameter is False, the collection will include all batch classes, even if the user does not have rights to them.

Implements

IPublishedBatchClassCollectionRefresh(Boolean)
Remarks
The collection returned may become quickly obsolete if the administrator publishes batch classes or disables them.
See Also

Reference

PublishedBatchClassCollection Class
Kofax.Capture.DBLite Namespace


PublishedBatchClassCollection Properties

PublishedBatchClassCollection Properties

The PublishedBatchClassCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

PublishedBatchClassCollection Class
Kofax.Capture.DBLite Namespace


PublishedBatchClassCollection.Count Property

PublishedBatchClassCollectionCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IPublishedBatchClassCollectionCount
Remarks
See Also

Reference

PublishedBatchClassCollection Class
Kofax.Capture.DBLite Namespace


PublishedBatchClassCollection.Item Property

PublishedBatchClassCollectionItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPublishedBatchClass this[
    Object vntIndexKey
] { get; }
Public ReadOnly Property Item (
    vntIndexKey As Object
) As IPublishedBatchClass
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IPublishedBatchClass

Return Value

Type: IPublishedBatchClass
Kofax.Capture.SDK.CustomModule.IPublishedBatchClass

Implements

IPublishedBatchClassCollectionItemObject
Remarks
See Also

Reference

PublishedBatchClassCollection Class
Kofax.Capture.DBLite Namespace


RuntimeSession Class

RuntimeSession Class

This object is required to gain access to any of the other objects in the hierarchy.

Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteRuntimeSession

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class RuntimeSession : IRuntimeSession
Public Class RuntimeSession
    Implements IRuntimeSession

The RuntimeSession type exposes the following members.

Methods
Name | Description
Public method AssignHandler

Assigns handle of the window that will be processed WM_QUERRYENDSESSION and shows custom warning message when session timeout is reached.

Public method BatchCreate

Creates, opens, or locks a batch.

Public method BatchCreate2

Creates, opens, or locks a batch.

Public method BatchOpen

Opens or locks the available batch with ID for the process.

Public method CanFilterOnBatchField

Returns a Boolean value indicating if filtering on batch field is available.

Public method CustomDataFolder

Returns a global custom data path based on the provided module ID.

Public method Dispose
Releases all resources used by the RuntimeSession
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | InitMonitorProcess
Public method LogMonitoringMessage

Logs a string that can be retrieved via SNMP.

Public method NextBatchFilteredGet

Extends the base method NextBatchGet to allow filtering.

Public method NextBatchGet

Opens or locks the next available batch for the process.

Public method SetBatchFilter

Sets the batch filter definition which will be used by the NextBatchFilteredGet and BatchCollectionFiltered methods.

The XML string that defines the filter.

The Filter string contains a root element FilterCriteriaList. The FilterCriteriaList contains one or more FilterCriteria child elements and one FilteringEnabled child element.

FilterCriteria element

  • Name – Must be present. Must be one of the following names:
    - Batch name
    - Batch class
    - Queue
    - Status
    - Priority
    - Has error
    - Station ID
    - Batch creation date/time
    - Batch field
    - Scan station ID
    - Scan user
    - Reserved01

  • BatchField - A batch field name. Only used if Name is "Batch field".

  • Operator – Must be present. Each item on the Filter Criteria list has a list of supported operators. Must be one of the following operators:
    - Contains
    - Equal to
    - Not equal to
    - Greater than
    - Less than
    - Starts with
    - Same date as
    - Bit and (supported for the Reserved01 KTM module bitfield criteria)

  • Value – A value used by this criteria. The data type must correspond to the specified criteria. All criteria except "Batch class" should only have one value.
  • ValueList – A list of values for this criteria. The value list must have one or more child Value elements. The "Batch class" criteria is the only criteria which supports the ValueList.

FilteringEnabled element
  • Must be true or false
  • If true, filter criteria will be used to filter batches.
  • If false, filter criteria will be ignored and batches will be unfiltered.

An example of an XML Filter String is as follows:

<?xml version="1.0" encoding="utf-16"?>

<FilterCriteriaList xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<FilterCriteria>

<Name>Status</Name>

<BatchField />

<Operator>Equal to</Operator>

<Value>2</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Queue</Name>

<BatchField />

<Operator>Equal to</Operator>

<Value>3</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Station ID</Name>

<BatchField />

<Operator>Contains</Operator>

<Value>mystation</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Batch class</Name>

<BatchField />

<Operator>Contains</Operator>

<ValueList>

<Value>bc1</Value>

<Value>bc2</Value>

<Value>bc2plus</Value>

<Value>bc3</Value>

</ValueList>

</FilterCriteria>

<FilterCriteria>

<Name>Batch creation date/time</Name>

<BatchField />

<Operator>Less than</Operator>

<Value>2010-12-02 14:30:50</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Batch name</Name>

<BatchField />

<Operator>Contains</Operator>

<Value>MyBatchName</Value>

</FilterCriteria>

<FilteringEnabled>true</FilteringEnabled>

</FilterCriteriaList>

Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BatchCollection | Returns the active batch information.
Public property | BatchCollectionFiltered | Extends the base property BatchCollection to allow filtering. This property will make use of a filter that was previously set in a call to SetBatchFilter property
Public property | BatchFieldNamesCollection | Allows for the retrieval of a list of batch field names.
Public property | BatchFieldValuesCollection | Allows for the retrieval of a list of batch field values for a specified batch field name.
Public property | ImportExportLog | Sets the log file name for XML logging.
Public property | InstallPath | Returns the location of the Tungsten Capture server.
Public property | ProcessCollection | Returns a collection of process objects.
Public property | ProcessID | Gets or sets the next process ID.
Public property | PublishedBatchClassCollection | Returns a collection of published batch classes.
Public property | ScanEnabled | Returns True if scanning is allowed.
Public property | ServicePackVersion | Returns the currently installed service pack.
Public property | StationID | Returns the current Tungsten Capture station ID.
Public property | UserID | Returns the ID of currently logged in user.
Public property | UserName | Returns the name of currently logged in user.
Top
Events
 | Name | Description
Public event | BatchAvailable | Event to to notify that a batch is available for processing in the next queue.
Public event | OnSessionTimeOut | Event to notify that the current session is timed out.
Top
Remarks
See Also

Reference

Kofax.Capture.DBLite Namespace


RuntimeSession Methods

RuntimeSession Methods

The RuntimeSession type exposes the following members.

Methods
Name | Description
Public method AssignHandler

Assigns handle of the window that will be processed WM_QUERRYENDSESSION and shows custom warning message when session timeout is reached.

Public method BatchCreate

Creates, opens, or locks a batch.

Public method BatchCreate2

Creates, opens, or locks a batch.

Public method BatchOpen

Opens or locks the available batch with ID for the process.

Public method CanFilterOnBatchField

Returns a Boolean value indicating if filtering on batch field is available.

Public method CustomDataFolder

Returns a global custom data path based on the provided module ID.

Public method | Dispose
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | InitMonitorProcess
Public method LogMonitoringMessage

Logs a string that can be retrieved via SNMP.

Public method NextBatchFilteredGet

Extends the base method NextBatchGet to allow filtering.

Public method NextBatchGet

Opens or locks the next available batch for the process.

Public method SetBatchFilter

Sets the batch filter definition which will be used by the NextBatchFilteredGet and BatchCollectionFiltered methods.

The XML string that defines the filter.

The Filter string contains a root element FilterCriteriaList. The FilterCriteriaList contains one or more FilterCriteria child elements and one FilteringEnabled child element.

FilterCriteria element

  • Name – Must be present. Must be one of the following names:
    - Batch name
    - Batch class
    - Queue
    - Status
    - Priority
    - Has error
    - Station ID
    - Batch creation date/time
    - Batch field
    - Scan station ID
    - Scan user
    - Reserved01

  • BatchField - A batch field name. Only used if Name is "Batch field".

  • Operator – Must be present. Each item on the Filter Criteria list has a list of supported operators. Must be one of the following operators:
    - Contains
    - Equal to
    - Not equal to
    - Greater than
    - Less than
    - Starts with
    - Same date as
    - Bit and (supported for the Reserved01 KTM module bitfield criteria)

  • Value – A value used by this criteria. The data type must correspond to the specified criteria. All criteria except "Batch class" should only have one value.
  • ValueList – A list of values for this criteria. The value list must have one or more child Value elements. The "Batch class" criteria is the only criteria which supports the ValueList.

FilteringEnabled element
  • Must be true or false
  • If true, filter criteria will be used to filter batches.
  • If false, filter criteria will be ignored and batches will be unfiltered.

An example of an XML Filter String is as follows:

<?xml version="1.0" encoding="utf-16"?>

<FilterCriteriaList xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<FilterCriteria>

<Name>Status</Name>

<BatchField />

<Operator>Equal to</Operator>

<Value>2</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Queue</Name>

<BatchField />

<Operator>Equal to</Operator>

<Value>3</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Station ID</Name>

<BatchField />

<Operator>Contains</Operator>

<Value>mystation</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Batch class</Name>

<BatchField />

<Operator>Contains</Operator>

<ValueList>

<Value>bc1</Value>

<Value>bc2</Value>

<Value>bc2plus</Value>

<Value>bc3</Value>

</ValueList>

</FilterCriteria>

<FilterCriteria>

<Name>Batch creation date/time</Name>

<BatchField />

<Operator>Less than</Operator>

<Value>2010-12-02 14:30:50</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Batch name</Name>

<BatchField />

<Operator>Contains</Operator>

<Value>MyBatchName</Value>

</FilterCriteria>

<FilteringEnabled>true</FilteringEnabled>

</FilterCriteriaList>

Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.AssignHandler Method

RuntimeSessionAssignHandler Method

Assigns handle of the window that will be processed WM_QUERRYENDSESSION and shows custom warning message when session timeout is reached.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public virtual void AssignHandler(
    IntPtr hWnd
)
Public Overridable Sub AssignHandler (
    hWnd As IntPtr
)

Parameters

hWnd
Type: SystemIntPtr
Handle of the custom module's main form.

Implements

IRuntimeSessionAssignHandler(IntPtr)
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.BatchCreate Method

RuntimeSessionBatchCreate Method

Creates, opens, or locks a batch.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch BatchCreate(
    string strBatchClassName,
    string strBatchName,
    int nProcessID
)
Public Function BatchCreate (
    strBatchClassName As String,
    strBatchName As String,
    nProcessID As Integer
) As IBatch

Parameters

strBatchClassName
Type: SystemString
The name of the published batch class used to create the batch.
strBatchName
Type: SystemString
Must be a unique name for the new batch.
nProcessID
Type: SystemInt32
If this parameter is non-zero, the process should match the first process scheduled for the batch.

This parameter is used when generating the statistics record for this operation. The batch is returned in the locked state, so you can adjust any properties you like before unlocking it and making it available to other processes in the system, or you can simply start using it directly (for example, the Scan module might create batches and start using them right away).

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch

Implements

IRuntimeSessionBatchCreate(String, String, Int32)
Remarks
The application calling this function is responsible for catching errors and creating unique batch names.
When calling this method, the nProcessID parameter must be the process ID of your custom module.
Examples
VB
Copy
'*** Get your Process ID
lProcessID = m_oLogin.ProcessID '*** Create new batch
m_oBatch = m_oRuntimeSession.BatchCreate("All Queues", txtBatchName, lProcessID)
m_oBatch.BatchClose(KfxDbBatchReady, KfxDbQueueNext, 0, "")
m_oBatch = Nothing
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.BatchCreate2 Method

RuntimeSessionBatchCreate2 Method

Creates, opens, or locks a batch.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch BatchCreate2(
    string strBatchClassName,
    string strBatchName,
    int nProcessID,
    string strGUID = null
)
Public Function BatchCreate2 (
    strBatchClassName As String,
    strBatchName As String,
    nProcessID As Integer,
    Optional strGUID As String = Nothing
) As IBatch

Parameters

strBatchClassName
Type: SystemString
The name of the published batch class used to create the batch.
strBatchName
Type: SystemString
Must be a unique name for the new batch.
nProcessID
Type: SystemInt32
If this parameter is non-zero, the process should match the first process scheduled for the batch.
This parameter is used when generating the statistics record for this operation. The batch is returned in the locked state, so you can adjust any properties you like before unlocking it and making it available to other processes in the system, or you can simply start using it directly (for example, the Scan module might create batches and start using them right away).
strGUID (Optional)
Type: SystemString
Optional. If specified, must be a unique ID for the new batch. The ID must have the Registry GUID format {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch

Implements

IRuntimeSessionBatchCreate2(String, String, Int32, String)
Remarks
The application calling this function is responsible for catching errors and creating unique batch names.
When calling this method, the lProcessId parameter must be the process ID of your custom module.
Examples
VB
Copy
'*** Get your Process Id
lProcessId = m_oLogin.ProcessId '*** Create new batch
m_oBatch = m_oRuntimeSession.BatchCreate("All Queues", txtBatchName, lProcessId)
m_oBatch.BatchClose(KfxDbBatchReady, KfxDbQueueNext, 0, "")
m_oBatch = Nothing
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.BatchOpen Method

RuntimeSessionBatchOpen Method

Opens or locks the available batch with ID for the process.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch BatchOpen(
    int nBatchID,
    int nRequestingProcessId
)
Public Function BatchOpen (
    nBatchID As Integer,
    nRequestingProcessId As Integer
) As IBatch

Parameters

nBatchID
Type: SystemInt32
The batch ID to be locked.
nRequestingProcessId
Type: SystemInt32
The process requesting that the batch be locked.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch

Implements

IRuntimeSessionBatchOpen(Int32, Int32)
Remarks
Returns Nothing if all batches have been processed.
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.CanFilterOnBatchField Method

RuntimeSessionCanFilterOnBatchField Method

Returns a Boolean value indicating if filtering on batch field is available.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool CanFilterOnBatchField()
Public Function CanFilterOnBatchField As Boolean

Return Value

Type: Boolean
Boolean

Implements

IRuntimeSessionCanFilterOnBatchField
Remarks
Return True if filtering on batch field is available.
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.CustomDataFolder Method

RuntimeSessionCustomDataFolder Method

Returns a global custom data path based on the provided module ID.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string CustomDataFolder(
    ref string strModuleID
)
Public Function CustomDataFolder (
    ByRef strModuleID As String
) As String

Parameters

strModuleID
Type: SystemString
The subfolder to be used as a custom data storage folder.

Return Value

Type: String
String

Implements

IRuntimeSessionCustomDataFolder(String)
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.Dispose Method

RuntimeSessionDispose Method
Releases all resources used by the RuntimeSession

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.InitMonitorProcess Method

RuntimeSessionInitMonitorProcess Method

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void InitMonitorProcess(
    int nSeconds
)
Public Sub InitMonitorProcess (
    nSeconds As Integer
)

Parameters

nSeconds
Type: SystemInt32
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.LogMonitoringMessage Method

RuntimeSessionLogMonitoringMessage Method

Logs a string that can be retrieved via SNMP.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void LogMonitoringMessage(
    string strMessage
)
Public Sub LogMonitoringMessage (
    strMessage As String
)

Parameters

strMessage
Type: SystemString
The string that will be logged.

Implements

IRuntimeSessionLogMonitoringMessage(String)
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.NextBatchFilteredGet Method

RuntimeSessionNextBatchFilteredGet Method

Extends the base method NextBatchGet to allow filtering.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch NextBatchFilteredGet()
Public Function NextBatchFilteredGet As IBatch

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch

Implements

IRuntimeSessionNextBatchFilteredGet
Remarks
Returns nothing if all batches have been processed. To use this method, a filter must have been previously set by a call to SetBatchFilter. The specified batch filter will be applied when determining the next batch to retrieve.
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.NextBatchGet Method

RuntimeSessionNextBatchGet Method

Opens or locks the next available batch for the process.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatch NextBatchGet(
    int nRequestingProcessId,
    KfxDbFilter eFilterOptions = KfxDbFilter.KfxDbFilterOnProcess|KfxDbFilter.KfxDbFilterOnStates|KfxDbFilter.KfxDbSortOnPriorityDescending,
    KfxDbState eStates = KfxDbState.KfxDbBatchReady
)
Public Function NextBatchGet (
    nRequestingProcessId As Integer,
    Optional eFilterOptions As KfxDbFilter = KfxDbFilter.KfxDbFilterOnProcess Or KfxDbFilter.KfxDbFilterOnStates Or KfxDbFilter.KfxDbSortOnPriorityDescending,
    Optional eStates As KfxDbState = KfxDbState.KfxDbBatchReady
) As IBatch

Parameters

nRequestingProcessId
Type: SystemInt32
The process requesting that the batch be locked.
eFilterOptions (Optional)
Type: Kofax.Capture.SDK.CustomModuleKfxDbFilter
An optional argument used to filter batches. Default input value is a combination of KfxDbFilter.KfxDbFilterOnProcess and KfxDbFilter.KfxDbFilterOnStates and KfxDbFilter.KfxDbSortOnPriorityDescending
eStates (Optional)
Type: Kofax.Capture.SDK.CustomModuleKfxDbState
An optional argument used to filter batches. Default input value is KfxDbState.KfxDbBatchReady.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch

Implements

IRuntimeSessionNextBatchGet(Int32, KfxDbFilter, KfxDbState)
Remarks
Returns Nothing if all batches have been processed.
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.SetBatchFilter Method

RuntimeSessionSetBatchFilter Method

Sets the batch filter definition which will be used by the NextBatchFilteredGet and BatchCollectionFiltered methods.

The XML string that defines the filter.

The Filter string contains a root element FilterCriteriaList. The FilterCriteriaList contains one or more FilterCriteria child elements and one FilteringEnabled child element.

FilterCriteria element

  • Name – Must be present. Must be one of the following names:
    - Batch name
    - Batch class
    - Queue
    - Status
    - Priority
    - Has error
    - Station ID
    - Batch creation date/time
    - Batch field
    - Scan station ID
    - Scan user
    - Reserved01

  • BatchField - A batch field name. Only used if Name is "Batch field".

  • Operator – Must be present. Each item on the Filter Criteria list has a list of supported operators. Must be one of the following operators:
    - Contains
    - Equal to
    - Not equal to
    - Greater than
    - Less than
    - Starts with
    - Same date as
    - Bit and (supported for the Reserved01 KTM module bitfield criteria)

  • Value – A value used by this criteria. The data type must correspond to the specified criteria. All criteria except "Batch class" should only have one value.
  • ValueList – A list of values for this criteria. The value list must have one or more child Value elements. The "Batch class" criteria is the only criteria which supports the ValueList.

FilteringEnabled element
  • Must be true or false
  • If true, filter criteria will be used to filter batches.
  • If false, filter criteria will be ignored and batches will be unfiltered.

An example of an XML Filter String is as follows:

<?xml version="1.0" encoding="utf-16"?>

<FilterCriteriaList xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<FilterCriteria>

<Name>Status</Name>

<BatchField />

<Operator>Equal to</Operator>

<Value>2</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Queue</Name>

<BatchField />

<Operator>Equal to</Operator>

<Value>3</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Station ID</Name>

<BatchField />

<Operator>Contains</Operator>

<Value>mystation</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Batch class</Name>

<BatchField />

<Operator>Contains</Operator>

<ValueList>

<Value>bc1</Value>

<Value>bc2</Value>

<Value>bc2plus</Value>

<Value>bc3</Value>

</ValueList>

</FilterCriteria>

<FilterCriteria>

<Name>Batch creation date/time</Name>

<BatchField />

<Operator>Less than</Operator>

<Value>2010-12-02 14:30:50</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Batch name</Name>

<BatchField />

<Operator>Contains</Operator>

<Value>MyBatchName</Value>

</FilterCriteria>

<FilteringEnabled>true</FilteringEnabled>

</FilterCriteriaList>

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool SetBatchFilter(
    string strFilterStringXML
)
Public Function SetBatchFilter (
    strFilterStringXML As String
) As Boolean

Parameters

strFilterStringXML
Type: SystemString

Return Value

Type: Boolean
Boolean

Implements

IRuntimeSessionSetBatchFilter(String)
Remarks
True if the filter was set successfully.
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession Properties

RuntimeSession Properties

The RuntimeSession type exposes the following members.

Properties
 | Name | Description
Public property | BatchCollection | Returns the active batch information.
Public property | BatchCollectionFiltered | Extends the base property BatchCollection to allow filtering. This property will make use of a filter that was previously set in a call to SetBatchFilter property
Public property | BatchFieldNamesCollection | Allows for the retrieval of a list of batch field names.
Public property | BatchFieldValuesCollection | Allows for the retrieval of a list of batch field values for a specified batch field name.
Public property | ImportExportLog | Sets the log file name for XML logging.
Public property | InstallPath | Returns the location of the Tungsten Capture server.
Public property | ProcessCollection | Returns a collection of process objects.
Public property | ProcessID | Gets or sets the next process ID.
Public property | PublishedBatchClassCollection | Returns a collection of published batch classes.
Public property | ScanEnabled | Returns True if scanning is allowed.
Public property | ServicePackVersion | Returns the currently installed service pack.
Public property | StationID | Returns the current Tungsten Capture station ID.
Public property | UserID | Returns the ID of currently logged in user.
Public property | UserName | Returns the name of currently logged in user.
Top
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.BatchCollection Property

RuntimeSessionBatchCollection Property

Returns the active batch information.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchCollection this[
    KfxDbFilter eFilterOptions = ,
    int nProcessID = 0,
    KfxDbState eStates = ,
    bool bUserFilter = true
] { get; }
Public ReadOnly Property BatchCollection (
    Optional eFilterOptions As KfxDbFilter = ,
    Optional nProcessID As Integer = 0,
    Optional eStates As KfxDbState = ,
    Optional bUserFilter As Boolean = true
) As IBatchCollection
    Get

Parameters

eFilterOptions (Optional)
Type: Kofax.Capture.SDK.CustomModuleKfxDbFilter
Limits the scope of the search, and/or specifies sort criteria.
nProcessID (Optional)
Type: SystemInt32
Can be obtained by using the ProcessID from the Login object. Only batches that are queued for lProcessId will be considered.
eStates (Optional)
Type: Kofax.Capture.SDK.CustomModuleKfxDbState
If you specify filtering on states, eStates must be passed as a nonzero value that contains a bitmask of the available states. Only batches that match the eStates mask will be considered.
bUserFilter (Optional)
Type: SystemBoolean
If bUserFilter is False, the collection will include all batches, even if the user does not have rights to them.

Property Value

Type: IBatchCollection

Return Value

Type: IBatchCollection
Kofax.Capture.SDK.CustomModule.IBatchCollection

Implements

IRuntimeSessionBatchCollectionKfxDbFilter, Int32, KfxDbState, Boolean
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.BatchCollectionFiltered Property

RuntimeSessionBatchCollectionFiltered Property

Extends the base property BatchCollection to allow filtering. This property will make use of a filter that was previously set in a call to SetBatchFilter property

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchCollection this[
    bool bUserFilter = true
] { get; }
Public ReadOnly Property BatchCollectionFiltered (
    Optional bUserFilter As Boolean = true
) As IBatchCollection
    Get

Parameters

bUserFilter (Optional)
Type: SystemBoolean
If this parameter is False, the collection will include all batch field names, even if the user does not have rights to them.

Property Value

Type: IBatchCollection

Return Value

Type: IBatchCollection
Kofax.Capture.SDK.CustomModule.IBatchCollection

Implements

IRuntimeSessionBatchCollectionFilteredBoolean
Remarks
To use this method, a filter must have been previously set by a call to SetBatchFilter. The specified batch filter will be applied when determining the next batch to retrieve.
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.BatchFieldNamesCollection Property

RuntimeSessionBatchFieldNamesCollection Property

Allows for the retrieval of a list of batch field names.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchFieldNamesCollection this[
    bool bUserFilter = true
] { get; }
Public ReadOnly Property BatchFieldNamesCollection (
    Optional bUserFilter As Boolean = true
) As IBatchFieldNamesCollection
    Get

Parameters

bUserFilter (Optional)
Type: SystemBoolean
If this parameter is False, the collection will include all batch field names, even if the user does not have rights to them.

Property Value

Type: IBatchFieldNamesCollection
A collection of batch field names.

Return Value

Type: IBatchFieldNamesCollection
Kofax.Capture.SDK.CustomModule.IBatchFieldNamesCollection

Implements

IRuntimeSessionBatchFieldNamesCollectionBoolean
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.BatchFieldValuesCollection Property

RuntimeSessionBatchFieldValuesCollection Property

Allows for the retrieval of a list of batch field values for a specified batch field name.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IBatchFieldValuesCollection this[
    string strBatchFieldName
] { get; }
Public ReadOnly Property BatchFieldValuesCollection (
    strBatchFieldName As String
) As IBatchFieldValuesCollection
    Get

Parameters

strBatchFieldName
Type: SystemString
Specifies the name of the batch field.

Property Value

Type: IBatchFieldValuesCollection
A collection of batch field values for the specified batch field name.

Return Value

Type: IBatchFieldValuesCollection
Kofax.Capture.SDK.CustomModule.IBatchFieldValuesCollection

Implements

IRuntimeSessionBatchFieldValuesCollectionString
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.ImportExportLog Property

RuntimeSessionImportExportLog Property

Sets the log file name for XML logging.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ImportExportLog { set; }
Public WriteOnly Property ImportExportLog As String
    Set

Property Value

Type: String
The log file name to set.

Implements

IRuntimeSessionImportExportLog
Remarks
Sets the log file name for XML logging.
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.InstallPath Property

RuntimeSessionInstallPath Property

Returns the location of the Tungsten Capture server.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string InstallPath { get; }
Public ReadOnly Property InstallPath As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IRuntimeSessionInstallPath
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.ProcessCollection Property

RuntimeSessionProcessCollection Property

Returns a collection of process objects.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IProcessCollection ProcessCollection { get; }
Public ReadOnly Property ProcessCollection As IProcessCollection
    Get

Property Value

Type: IProcessCollection

Return Value

Type: IProcessCollection
Kofax.Capture.SDK.CustomModule.IProcessCollection

Implements

IRuntimeSessionProcessCollection
Remarks
The Process object can be used by custom modules to get the custom module process ID.
The process ID is used as a parameter into several methods that retrieve batches.
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.ProcessID Property

RuntimeSessionProcessID Property

Gets or sets the next process ID.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int ProcessID { get; set; }
Public Property ProcessID As Integer
    Get
    Set

Property Value

Type: Int32
The next process ID.

Return Value

Type: Int32
Integer

Implements

IRuntimeSessionProcessID
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.PublishedBatchClassCollection Property

RuntimeSessionPublishedBatchClassCollection Property

Returns a collection of published batch classes.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IPublishedBatchClassCollection this[
    bool bUserFilter = true
] { get; }
Public ReadOnly Property PublishedBatchClassCollection (
    Optional bUserFilter As Boolean = true
) As IPublishedBatchClassCollection
    Get

Parameters

bUserFilter (Optional)
Type: SystemBoolean
Default True. If this parameter is False, the collection will include all published batch classes, even if the user does not have rights to them.

Property Value

Type: IPublishedBatchClassCollection

Return Value

Type: IPublishedBatchClassCollection
Kofax.Capture.SDK.CustomModule.IPublishedBatchClassCollection

Implements

IRuntimeSessionPublishedBatchClassCollectionBoolean
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.ScanEnabled Property

RuntimeSessionScanEnabled Property

Returns True if scanning is allowed.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool ScanEnabled { get; }
Public ReadOnly Property ScanEnabled As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean

Implements

IRuntimeSessionScanEnabled
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.ServicePackVersion Property

RuntimeSessionServicePackVersion Property

Returns the currently installed service pack.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public short ServicePackVersion { get; }
Public ReadOnly Property ServicePackVersion As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short

Implements

IRuntimeSessionServicePackVersion
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.StationID Property

RuntimeSessionStationID Property

Returns the current Tungsten Capture station ID.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string StationID { get; }
Public ReadOnly Property StationID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IRuntimeSessionStationID
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.UserID Property

RuntimeSessionUserID Property

Returns the ID of currently logged in user.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string UserID { get; }
Public ReadOnly Property UserID As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IRuntimeSessionUserID
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.UserName Property

RuntimeSessionUserName Property

Returns the name of currently logged in user.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IRuntimeSessionUserName
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession Events

RuntimeSession Events

The RuntimeSession type exposes the following members.

Events
 | Name | Description
Public event | BatchAvailable | Event to to notify that a batch is available for processing in the next queue.
Public event | OnSessionTimeOut | Event to notify that the current session is timed out.
Top
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.BatchAvailable Event

RuntimeSessionBatchAvailable Event

Event to to notify that a batch is available for processing in the next queue.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event IRuntimeSessionBatchAvailableEventHandler BatchAvailable
Public Event BatchAvailable As IRuntimeSessionBatchAvailableEventHandler

Value

Type: Kofax.Capture.SDK.CustomModuleIRuntimeSessionBatchAvailableEventHandler

Implements

IRuntimeSessionBatchAvailable
Remarks
Raised each time a batch becomes available.
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession.OnSessionTimeOut Event

RuntimeSessionOnSessionTimeOut Event

Event to notify that the current session is timed out.

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public event TimeoutEventHandler<TimeoutEventArg> OnSessionTimeOut
Public Event OnSessionTimeOut As TimeoutEventHandler(Of TimeoutEventArg)

Value

Type: Kofax.Capture.SDK.CustomModuleTimeoutEventHandler TimeoutEventArg

Implements

IRuntimeSessionOnSessionTimeOut
Remarks
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


Kofax.Capture.DBLiteOpt Namespace

Kofax.Capture.DBLiteOpt Namespace

The Tungsten Capture Optimized Custom Module .NET Type Interface Library is an easy-to-use custom module interface library that allows fast retrieval and selective update of data. This API provides a mechanism that allows use of the Tungsten Capture Document Access .NET Type Implementation Library (Kofax.DBLite.dll) to select and open a batch. However, once open, it is not necessary to export the data to XML. Instead, the code can retrieve an API object that acts like an XML element, but without XML. The code can selectively extract and update Tungsten Capture data through this API. Because the data is processed selectively, execution is faster than XML importing and exporting. The actual organization of Tungsten Capture data (the element and attribute structure) is identical between the XML and this new API.

Tungsten Capture continues to support XML, which may still be better for developers with applications that are well-suited to an XML interface. The Tungsten Capture Optimized Custom Module .NET Type Interface Library API is implemented in the Tungsten Capture Optimized Custom Module .NET Type Implementation Library (Kofax.DBLiteOpt.dll).

The Tungsten Capture Optimized Custom Module .NET Type Interface Library (Kofax.Capture.SDK.Data.dll) and Tungsten Capture Optimized Custom Module .NET Type Implementation Library (Kofax.DBLiteOpt.dll) are available from the Bin folder in your Tungsten Capture installation.

Classes
Class | Description
Public class ACDataConnection

This class implements Kofax.Capture.SDK.Data.IACDataConnection interface which serves as the global "parent" of all objects and is used to perform extractions of root ACDataElement objects (setup and runtime). It serves as the higher-level interface to the Kfxdb database connection.

ACDataElement

The ACData Element object represents a specific element in the Tungsten Capture data structure. A particular ACDataElement object corresponds to an XML element in the XML output.

The following fragment shows some sample code that moves all loose pages in a batch with the note “Put in document” into a new document.

It is included here to help you understand how you might use ACDataElement. It is not intended as an official program, and you use this code at your own risk.

Examples
VB
Copy
Set oBatch = ...'** Select And Open a batch using existing Kofax.DBLite API’s
Dim oRootElement As ACDataElement
Dim oRootSetupElement As ACDataElement
Set oRootElement = oBatch.GetRuntimeDataElement()
Set oRootSetupElement = oBatch.GetSetupDataElement()
Dim oBatchElement As ACDataElement
Set oBatchElement = oRootSetupElement.FindChildElementByName("Batch")
Dim oPagesElement As ACDataElement
Set oPagesElement = oBatchElement.FindChildElementByName("Pages")
Dim oPagesCollection As ACDataElementCollection
Set oPagesCollection = oPagesElement.FindChildElementsByName("Page")
'*** Find all pages that have a special note
Dim oPageElement As ACDataElement
Dim oNewPages As Collection
For Each oPageElement In oPagesCollection
    If oPageElement.Attribute("Note") = "Put In Document" Then
        '*** We found a page – Save a reference To it
         oNewPages.Add oPageElement
    End If
Next
'*** If we found at least one page, Then create a New document And Put the pages into it.
If oNewPages.Count > 0 Then
    Dim oDocumentsElement As ACDataElement
    Set oDocumentsElement = oBatchElement.FindChildElementByName("Documents")
    Dim oNewDocument As Document
    Set oNewDocument = oDocumentsElement.CreateChildElement("Document")
    oNewDocument.Attribute("Note") = "Automatic Pages Added:" & CStr(oNewPages.Count)
    For Each oPageElement In oNewPages
        oPageElement.MoveToBack( oNewDocument )
    Next
End If
Public class ACDataElementAttributeColl
This object allows specification of attribute sub-lists. Refer to FindPartialChildElementsByName(IACDataElementAttributeColl, String) and FindPartialChildElementsByAttribute(IACDataElementAttributeColl, String, String, String)
Public class ACDataElementCollection
Defines a collection of ACDataElement objects.
Public class | AttributeValueColl
Public class | BulkUpdateDataColl
Public class | NameValuePair
Remarks


ACDataConnection Class

ACDataConnection Class

This class implements Kofax.Capture.SDK.Data.IACDataConnection interface which serves as the global "parent" of all objects and is used to perform extractions of root ACDataElement objects (setup and runtime). It serves as the higher-level interface to the Kfxdb database connection.

Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteOptACDataConnection

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ACDataConnection : IACDataConnection
Public Class ACDataConnection
    Implements IACDataConnection

The ACDataConnection type exposes the following members.

Constructors
 | Name | Description
Public method | ACDataConnection | Initializes a new instance of the ACDataConnection class
Top
Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | FlushLicensing | Sends licensing information back to the license server.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRootNode | Retrieves the root ACDataElement to return to the client code.
Public method | GetType | (Inherited from Object.)
Public method | Init | Obsolete. Initializes members.
Public method | ToString | (Inherited from Object.)
Top
Remarks
See Also

Reference

Kofax.Capture.DBLiteOpt Namespace


ACDataConnection Constructor

ACDataConnection Constructor
Initializes a new instance of the ACDataConnection class

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ACDataConnection()
Public Sub New
See Also

Reference

ACDataConnection Class
Kofax.Capture.DBLiteOpt Namespace


ACDataConnection Methods

ACDataConnection Methods

The ACDataConnection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | (Inherited from Object.)
Public method | FlushLicensing | Sends licensing information back to the license server.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetRootNode | Retrieves the root ACDataElement to return to the client code.
Public method | GetType | (Inherited from Object.)
Public method | Init | Obsolete. Initializes members.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ACDataConnection Class
Kofax.Capture.DBLiteOpt Namespace


ACDataConnection.Dispose Method

ACDataConnectionDispose Method
Performs class-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
Remarks
See Also

Reference

ACDataConnection Class
Kofax.Capture.DBLiteOpt Namespace


ACDataConnection.FlushLicensing Method

ACDataConnectionFlushLicensing Method

Sends licensing information back to the license server.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void FlushLicensing()
Public Sub FlushLicensing

Implements

IACDataConnectionFlushLicensing
Remarks
See Also

Reference

ACDataConnection Class
Kofax.Capture.DBLiteOpt Namespace


ACDataConnection.GetRootNode Method

ACDataConnectionGetRootNode Method

Retrieves the root ACDataElement to return to the client code.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElement GetRootNode(
    ref string strRootName,
    ref int nHints,
    bool bReadOnlyMode
)
Public Function GetRootNode (
    ByRef strRootName As String,
    ByRef nHints As Integer,
    bReadOnlyMode As Boolean
) As IACDataElement

Parameters

strRootName
Type: SystemString
Name of the root element ("AscentCaptureSetup" or "AscentCaptureRuntime").
nHints
Type: SystemInt32
Information provided to the custom module API that allows it to process data more efficiently based on what the programmer expects to do. IHints are required to be bitwise or of the enums defined by ACDataElementHints enum type.
bReadOnlyMode
Type: SystemBoolean
Indicates that the element is set to read-only explicitly from callers. Otherwise, it is automatically set, depending on the root node type or the table flag defined in the schema. Used to obtain the root element from a Workflow Agent invoked upon batch deletion. Any attempts to change data would cause an exception.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement

Implements

IACDataConnectionGetRootNode(String, Int32, Boolean)
Remarks
See Also

Reference

ACDataConnection Class
Kofax.Capture.DBLiteOpt Namespace


ACDataConnection.Init Method

ACDataConnectionInit Method

Note: This API is now obsolete.

Initializes members.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
[ObsoleteAttribute("Method Init(ByRef oKdoDatabase As Kofax.IKdoLib.IKdoDatabase, ByRef oBatchStatCache As Kofax.DBCopy.BatchStatCache) is obsoleted. Uses method Init2 instead.")]
public void Init(
    ref IKdoDatabase oKdoDatabase,
    ref BatchStatCache oBatchStatCache
)
<ObsoleteAttribute("Method Init(ByRef oKdoDatabase As Kofax.IKdoLib.IKdoDatabase, ByRef oBatchStatCache As Kofax.DBCopy.BatchStatCache) is obsoleted. Uses method Init2 instead.")>
Public Sub Init (
    ByRef oKdoDatabase As IKdoDatabase,
    ByRef oBatchStatCache As BatchStatCache
)

Parameters

oKdoDatabase
Type: IKdoDatabase
The KdoDatabase object derived from an openned DAO Database.
oBatchStatCache
Type: BatchStatCache
The globally shared Kofax.DBCopy.BatchStatCache object
Remarks
This method is obsoleted.
See Also

Reference

ACDataConnection Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement Class

ACDataElement Class

The ACData Element object represents a specific element in the Tungsten Capture data structure. A particular ACDataElement object corresponds to an XML element in the XML output.

The following fragment shows some sample code that moves all loose pages in a batch with the note “Put in document” into a new document.

It is included here to help you understand how you might use ACDataElement. It is not intended as an official program, and you use this code at your own risk.

Examples
VB
Copy
Set oBatch = ...'** Select And Open a batch using existing Kofax.DBLite API’s
Dim oRootElement As ACDataElement
Dim oRootSetupElement As ACDataElement
Set oRootElement = oBatch.GetRuntimeDataElement()
Set oRootSetupElement = oBatch.GetSetupDataElement()
Dim oBatchElement As ACDataElement
Set oBatchElement = oRootSetupElement.FindChildElementByName("Batch")
Dim oPagesElement As ACDataElement
Set oPagesElement = oBatchElement.FindChildElementByName("Pages")
Dim oPagesCollection As ACDataElementCollection
Set oPagesCollection = oPagesElement.FindChildElementsByName("Page")
'*** Find all pages that have a special note
Dim oPageElement As ACDataElement
Dim oNewPages As Collection
For Each oPageElement In oPagesCollection
    If oPageElement.Attribute("Note") = "Put In Document" Then
        '*** We found a page – Save a reference To it
         oNewPages.Add oPageElement
    End If
Next
'*** If we found at least one page, Then create a New document And Put the pages into it.
If oNewPages.Count > 0 Then
    Dim oDocumentsElement As ACDataElement
    Set oDocumentsElement = oBatchElement.FindChildElementByName("Documents")
    Dim oNewDocument As Document
    Set oNewDocument = oDocumentsElement.CreateChildElement("Document")
    oNewDocument.Attribute("Note") = "Automatic Pages Added:" & CStr(oNewPages.Count)
    For Each oPageElement In oNewPages
        oPageElement.MoveToBack( oNewDocument )
    Next
End If
Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteOptACDataElement

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ACDataElement : IACDataElement
Public Class ACDataElement
    Implements IACDataElement

The ACDataElement type exposes the following members.

Methods
Name | Description
Public method AttributeExists

Indicates if an attribute exists in the selected attribute list for this element.

Public method BulkUpdate

Update a collection of Attributes for a given Element

Public method CreateChildElement

Creates a child element of the specified type.

Public method CreateChildElement2

Creates a child element of the specified type.

CreatePageChildElement

This method is functionally equivalent to calling the following sequence of existing calls:

Examples
VB
Copy
oElement = oParentElement.CreatePage("Page")
oElement.Attribute("ImageFile") = strPageFileName
Essentially, this call creates a new "Page" element and assigns the file name associated with that page in a single operation. The only difference is in licensing rules.

CreatePageChildElement2

This method is functionally equivalent to calling the following sequence of existing calls:

Examples
VB
Copy
oElement = oParentElement.CreatePage("Page")
oElement.Attribute("ImageFile") = strPageFileName
Essentially, this call creates a new "Page" element and assigns the file name associated with that page in a single operation. The only difference is in licensing rules.

Public method Delete

Deletes the current element.

Public method | Equals | (Inherited from Object.)
Public method FindChildElementByAttribute

Extracts a particular child element based on the name of that child element and the value of one of its attributes.

Public method FindChildElementByName

Extracts a particular child element based on its name.

Public method FindChildElementsByAttribute

Extracts a collection of child elements based on their names and attribute values.

Public method FindChildElementsByName

Extracts a collection of child elements based on their name.

Public method FindPartialChildElementsByAttribute

Extracts all child elements based on their names. Also, only a sub-list of possible attributes is extracted.

Public method FindPartialChildElementsByName

Extracts all child elements based on their names. Also, only a sub-list of possible attributes is extracted.

Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method MoveElementBefore

Moves an Element immediately before the passed child.

Public method MoveElementToBatch

Moves a Kofax.Capture.SDK.Data.IACDataElement (Page or Document or Folder) from one open batch to another. MoveElementToBatch automatically deletes the Kofax.Capture.SDK.Data.IACDataElement from the source batch.

Public method MoveToBack

Moves an element to be the last child of the parent.

Public method | MoveToBackInternal
Public method MoveToFront

Moves an element to be the first child of the parent.

Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AttributeNames | Returns a collection of strings corresponding to the valid attribute names for this element type.
Public property | AttributeValue | Gets or sets an attribute value.
Public property | ChildElementNames | Returns a collection of strings corresponding to the valid child element type names.
Public property | ElementName | Returns the name of this element type.
Top
Remarks

Attribute Updates

Attributes within the setup data cannot be updated. Attempting to update them causes an error.

Attributes within the runtime data can usually be updated. Exceptions occur for translated attributes and some attributes with custom actions.

After an attribute is updated, attempting to re-read the attribute from the same ACDataElement reflects the modified value. If an attribute is updated and then the ACDataElement is re-extracted from the parent (see the child extraction methods below), then the updated attribute value is also reflected.

If an ACDataElement is extracted two or more times, and then an attribute is changed in one copy, then the other copy does not reflect the change. This is because attribute data is cached for a particular ACDataElement.

Note The client code is not able to update BatchHistoryEntry elements. This is done for consistency with the existing custom module XML interface.

Translated Attributes

Translated attributes (such as "BatchClassName" on the Batch element) define the structure of the data and changing them can cause issues with subsequent Tungsten Capture modules.

With the exception of the FormTypeName attribute, attempting to change any translated attribute (even in the runtime) causes an error. The list of translated attributes can be determined via the new HTML file content.

Attributes Referencing Binary Data

Several attributes retrieve or modify binary information, such as an image file or OCR Full-Text output file. Using these attributes (ImageFile and BitonalImageFile) through the ACDataElement API offers somewhat simpler and more robust behavior as compared to the XML interface.

Statistics Attributes

Several special attributes are utilized to allow a custom module or workflow agent to collect (user tracking) statistics.

Batch Priority Attribute

The priority attribute on the Batch element is checked to ensure that it is between 1 and 10 (inclusive) when this attribute is set. Failure to set the value within this range causes an error.

Document FormTypeName Attribute

An attribute on the "Document" element called "FormTypeName" indicates the current form type.

When using the ACDataElement API, translated items such as this usually cannot be updated. However, this attribute is an exception. Users can update this attribute with a different form type name (or an empty string to un-assign the form type).

When the form name is assigned (or assigned to nothing), the child IndexField objects are updated as appropriate to match the selected form type. Any existing information in the child IndexField objects is lost. If assigning the form type name to an empty string, then all child IndexField objects are removed.

Document Unique ID Generation

As with the XML interface, the DocumentUniqueID attribute off the Document element represents a globally unique ID for that document.

However, this value is not necessarily generated by default. Tungsten Capture generates unique document IDs on demand. If the value has not been generated, then reading this attribute produces an empty string.

As with the XML interface, client code can request a new, unique ID using Batch.GenerateDocumentUniqueID2(). This value can then be assigned to the DocumentUniqueID attribute.

It is not possible to generate unique IDs in a workflow agent since the object is not available there.

Note It is up to the client code to obtain and set a valid unique document ID. Setting some other number into this attribute may have unforeseen consequences. Although Tungsten Capture is not likely to fail, the back-end may throw an error at export time if a document with that ID already exists in the backend.

Structural Editing Methods

It is possible to perform limited structural editing with this API. If more substantial modifications are required, then it may be better to use the XML interface.

Only the structural updates specified in the referenced methods can be performed to the runtime tree. Attempting any other sort of structural update causes an error.

Warning Affected ACDataElement collection elements are in an undefined state after a structural update and that they must be re-extracted, if it is necessary to re-use such collections.

See Also

Reference

Kofax.Capture.DBLiteOpt Namespace


ACDataElement Methods

ACDataElement Methods

The ACDataElement type exposes the following members.

Methods
Name | Description
Public method AttributeExists

Indicates if an attribute exists in the selected attribute list for this element.

Public method BulkUpdate

Update a collection of Attributes for a given Element

Public method CreateChildElement

Creates a child element of the specified type.

Public method CreateChildElement2

Creates a child element of the specified type.

CreatePageChildElement

This method is functionally equivalent to calling the following sequence of existing calls:

Examples
VB
Copy
oElement = oParentElement.CreatePage("Page")
oElement.Attribute("ImageFile") = strPageFileName
Essentially, this call creates a new "Page" element and assigns the file name associated with that page in a single operation. The only difference is in licensing rules.

CreatePageChildElement2

This method is functionally equivalent to calling the following sequence of existing calls:

Examples
VB
Copy
oElement = oParentElement.CreatePage("Page")
oElement.Attribute("ImageFile") = strPageFileName
Essentially, this call creates a new "Page" element and assigns the file name associated with that page in a single operation. The only difference is in licensing rules.

Public method Delete

Deletes the current element.

Public method | Equals | (Inherited from Object.)
Public method FindChildElementByAttribute

Extracts a particular child element based on the name of that child element and the value of one of its attributes.

Public method FindChildElementByName

Extracts a particular child element based on its name.

Public method FindChildElementsByAttribute

Extracts a collection of child elements based on their names and attribute values.

Public method FindChildElementsByName

Extracts a collection of child elements based on their name.

Public method FindPartialChildElementsByAttribute

Extracts all child elements based on their names. Also, only a sub-list of possible attributes is extracted.

Public method FindPartialChildElementsByName

Extracts all child elements based on their names. Also, only a sub-list of possible attributes is extracted.

Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method MoveElementBefore

Moves an Element immediately before the passed child.

Public method MoveElementToBatch

Moves a Kofax.Capture.SDK.Data.IACDataElement (Page or Document or Folder) from one open batch to another. MoveElementToBatch automatically deletes the Kofax.Capture.SDK.Data.IACDataElement from the source batch.

Public method MoveToBack

Moves an element to be the last child of the parent.

Public method | MoveToBackInternal
Public method MoveToFront

Moves an element to be the first child of the parent.

Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.AttributeExists Method

ACDataElementAttributeExists Method

Indicates if an attribute exists in the selected attribute list for this element.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool AttributeExists(
    string strAttributeName
)
Public Function AttributeExists (
    strAttributeName As String
) As Boolean

Parameters

strAttributeName
Type: SystemString
The attribute name.

Return Value

Type: Boolean
Boolean

Implements

IACDataElementAttributeExists(String)
Remarks
See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.BulkUpdate Method

ACDataElementBulkUpdate Method

Update a collection of Attributes for a given Element

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void BulkUpdate(
    string strElementName,
    IBulkUpdateDataColl oData
)
Public Sub BulkUpdate (
    strElementName As String,
    oData As IBulkUpdateDataColl
)

Parameters

strElementName
Type: SystemString
Element Name to be update - Preserved for use later, currently only IndexFields is supported.
oData
Type: Kofax.Capture.SDK.DataIBulkUpdateDataColl
The Collection Attributes to be updated.

Implements

IACDataElementBulkUpdate(String, IBulkUpdateDataColl)
Remarks
See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.CreateChildElement Method

ACDataElementCreateChildElement Method

Creates a child element of the specified type.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElement CreateChildElement(
    string strElementName
)
Public Function CreateChildElement (
    strElementName As String
) As IACDataElement

Parameters

strElementName
Type: SystemString
The name of the specified child element type.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement

Implements

IACDataElementCreateChildElement(String)
Remarks

The type name must match one of the possible child element types defined for the current element or an error is thrown.

The created element type must be one of the following:

Page

The current element must be a "Pages" type whose parent is a "Batch" element type. It is not possible to directly create a document page. To accomplish this, create the page as "loose" and then move it into a document.

Document

The current element must be a "Documents" type whose parent is a "Batch" element type. It is not possible to directly create a document as a child of a folder. To accomplish this, create the document under the batch and then move it into a folder.

Folder

The current element must be a "Folders" type whose parent is a "Batch" element type. It is not possible to directly create a folder as a child of another folder. To accomplish this, create the folder under the batch and then move it into a folder.

TableRow

The current element must be a "TableRows" type.

PageCustomStorageString

The current element must be a "PageCustomStorageStrings" type.

DocumentCustomStorageString

The current element must be a "DocumentCustomStorageStrings" type.

FolderCustomStorageString

The current element must be a "FolderCustomStorageStrings" type.

Failure to meet these constraints causes an error.

This method no longer causes an error if a hint has been used. Hints are deprecated and are now ignored.

See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.CreateChildElement2 Method

ACDataElementCreateChildElement2 Method

Creates a child element of the specified type.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElement CreateChildElement2(
    string strElementName,
    string strGUID = null
)
Public Function CreateChildElement2 (
    strElementName As String,
    Optional strGUID As String = Nothing
) As IACDataElement

Parameters

strElementName
Type: SystemString
The name of the specified child element type.
strGUID (Optional)
Type: SystemString
The GUID of the specified child element type.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement

Implements

IACDataElementCreateChildElement2(String, String)
Remarks

The type name must match one of the possible child element types defined for the current element or an error is thrown.

The created element type must be one of the following:

Page

The current element must be a "Pages" type whose parent is a "Batch" element type. It is not possible to directly create a document page. To accomplish this, create the page as "loose" and then move it into a document.

Document

The current element must be a "Documents" type whose parent is a "Batch" element type. It is not possible to directly create a document as a child of a folder. To accomplish this, create the document under the batch and then move it into a folder.

Folder

The current element must be a "Folders" type whose parent is a "Batch" element type. It is not possible to directly create a folder as a child of another folder. To accomplish this, create the folder under the batch and then move it into a folder.

TableRow

The current element must be a "TableRows" type.

PageCustomStorageString

The current element must be a "PageCustomStorageStrings" type.

DocumentCustomStorageString

The current element must be a "DocumentCustomStorageStrings" type.

FolderCustomStorageString

The current element must be a "FolderCustomStorageStrings" type.

Failure to meet these constraints causes an error.

This method no longer causes an error if a hint has been used. Hints are deprecated and are now ignored.

See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.CreatePageChildElement Method

ACDataElementCreatePageChildElement Method

This method is functionally equivalent to calling the following sequence of existing calls:

Examples
VB
Copy
oElement = oParentElement.CreatePage("Page")
oElement.Attribute("ImageFile") = strPageFileName
Essentially, this call creates a new "Page" element and assigns the file name associated with that page in a single operation. The only difference is in licensing rules.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElement CreatePageChildElement(
    string strPageFileName
)
Public Function CreatePageChildElement (
    strPageFileName As String
) As IACDataElement

Parameters

strPageFileName
Type: SystemString
The image or eDocument file to use.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement

Implements

IACDataElementCreatePageChildElement(String)
Remarks
When CreatePageChildElement is called, and a PageFileName is passed representing an eDocument (the extension is other than ".tif"), then the system attempts to use an Import eDocument count license (if present and available), instead of a Scanned/Imported page count license.

Note As with the existing CreateChildElement("Page"), the first attempt to create a page requests a Full Station License.

The attribute name "ImageFile" is misleading because it is also used to assign eDocument file names. The naming is for historical reasons and was exposed prior to the existence of eDocuments in Tungsten Capture.

See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.CreatePageChildElement2 Method

ACDataElementCreatePageChildElement2 Method

This method is functionally equivalent to calling the following sequence of existing calls:

Examples
VB
Copy
oElement = oParentElement.CreatePage("Page")
oElement.Attribute("ImageFile") = strPageFileName
Essentially, this call creates a new "Page" element and assigns the file name associated with that page in a single operation. The only difference is in licensing rules.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElement CreatePageChildElement2(
    string strPageFileName,
    string strGUID = null
)
Public Function CreatePageChildElement2 (
    strPageFileName As String,
    Optional strGUID As String = Nothing
) As IACDataElement

Parameters

strPageFileName
Type: SystemString
The image or eDocument file to use.
strGUID (Optional)
Type: SystemString
The GUID for the page.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement

Implements

IACDataElementCreatePageChildElement2(String, String)
Remarks
When CreatePageChildElement is called, and a PageFileName is passed representing an eDocument (the extension is other than ".tif"), then the system attempts to use an Import eDocument count license (if present and available), instead of a Scanned/Imported page count license.

Note As with the existing CreateChildElement("Page"), the first attempt to create a page requests a Full Station License.

The attribute name "ImageFile" is misleading because it is also used to assign eDocument file names. The naming is for historical reasons and was exposed prior to the existence of eDocuments in Tungsten Capture.

See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.Delete Method

ACDataElementDelete Method

Deletes the current element.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Delete()
Public Sub Delete

Implements

IACDataElementDelete
Remarks

The deleted element type must be one of the following:

  • Page
  • Document
  • PageCustomStorageString
  • DocumentCustomStorageString
  • TableRow

Failure to meet these constraints causes an error.

This method causes an error if a hint has been used.

See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.FindChildElementByAttribute Method

ACDataElementFindChildElementByAttribute Method

Extracts a particular child element based on the name of that child element and the value of one of its attributes.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElement FindChildElementByAttribute(
    string strChildElementName,
    string strAttributeName,
    string strAttributeValue
)
Public Function FindChildElementByAttribute (
    strChildElementName As String,
    strAttributeName As String,
    strAttributeValue As String
) As IACDataElement

Parameters

strChildElementName
Type: SystemString
The name of the child element.
strAttributeName
Type: SystemString
The attribute name.
strAttributeValue
Type: SystemString
The attribute value.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement

Implements

IACDataElementFindChildElementByAttribute(String, String, String)
Remarks

This method is particularly useful for looking up setup objects by name. For instance, a particular Document element might have the FormTypeName as an attribute.

The client code might then look up the corresponding FormType element by name.

This method can be used to extract a particular child element.

All child extractions work on the immediate children of the current element. No facility is provided for doing "deep extraction" of all elements in a hierarchy meeting a certain criteria.

If such facilities are necessary, the client code may opt to use the XML interface instead. Some XML parsers (such as DOM) provide deep extraction methods. Keep in mind that deep extraction (and using XML in general) involves a great deal of additional overhead.

If the parameters specified by this method match multiple child elements, then only the first is returned. If the function does not find a suitable child element, then it returns the "nothing" object. In this case, an exception is not generated.

There is a slight difference in the way this library handles empty sub-collections as compared to the XML. Assume that a batch has no loose pages. The XML output of this batch does not include a "Pages" node since there are no pages.

However, attempting to retrieve the "Pages" node from this API does yield a "Pages" node. This empty node is necessary in order to be able to support various structural editing capabilities (such as creating and moving pages).

See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.FindChildElementByName Method

ACDataElementFindChildElementByName Method

Extracts a particular child element based on its name.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElement FindChildElementByName(
    string strChildElementName
)
Public Function FindChildElementByName (
    strChildElementName As String
) As IACDataElement

Parameters

strChildElementName
Type: SystemString
The name of the child element.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement

Implements

IACDataElementFindChildElementByName(String)
Remarks

This method can be used to extract a particular child element.

All child extractions work on the immediate children of the current element. No facility is provided for doing "deep extraction" of all elements in a hierarchy meeting a certain criteria.

If such facilities are necessary, the client code may opt to use the XML interface instead. Some XML parsers (such as DOM) provide deep extraction methods. Keep in mind that deep extraction (and using XML in general) involves a great deal of additional overhead.

If the parameters specified by this method match multiple child elements, then only the first is returned. If the function does not find a suitable child element, then it returns the "nothing" object. In this case, an exception is not generated.

There is a slight difference in the way this library handles empty sub-collections as compared to the XML. Assume that a batch has no loose pages. The XML output of this batch does not include a "Pages" node since there are no pages.

However, attempting to retrieve the "Pages" node from this API does yield a "Pages" node. This empty node is necessary in order to be able to support various structural editing capabilities (such as creating and moving pages).

See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.FindChildElementsByAttribute Method

ACDataElementFindChildElementsByAttribute Method

Extracts a collection of child elements based on their names and attribute values.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElementCollection FindChildElementsByAttribute(
    string strChildElementName,
    string strAttributeName,
    string strAttributeValue
)
Public Function FindChildElementsByAttribute (
    strChildElementName As String,
    strAttributeName As String,
    strAttributeValue As String
) As IACDataElementCollection

Parameters

strChildElementName
Type: SystemString
The name of the child element.
strAttributeName
Type: SystemString
The attribute name.
strAttributeValue
Type: SystemString
The attribute value.

Return Value

Type: IACDataElementCollection
Kofax.Capture.SDK.Data.IACDataElementCollection

Implements

IACDataElementFindChildElementsByAttribute(String, String, String)
Remarks
See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.FindChildElementsByName Method

ACDataElementFindChildElementsByName Method

Extracts a collection of child elements based on their name.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElementCollection FindChildElementsByName(
    string strChildElementName
)
Public Function FindChildElementsByName (
    strChildElementName As String
) As IACDataElementCollection

Parameters

strChildElementName
Type: SystemString
The name of the child element.

Return Value

Type: IACDataElementCollection
Kofax.Capture.SDK.Data.IACDataElementCollection

Implements

IACDataElementFindChildElementsByName(String)
Remarks
See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.FindPartialChildElementsByAttribute Method

ACDataElementFindPartialChildElementsByAttribute Method

Extracts all child elements based on their names. Also, only a sub-list of possible attributes is extracted.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElementCollection FindPartialChildElementsByAttribute(
    ref IACDataElementAttributeColl oAttributeList,
    string strChildElementName,
    string strAttributeName,
    string strAttributeValue
)
Public Function FindPartialChildElementsByAttribute (
    ByRef oAttributeList As IACDataElementAttributeColl,
    strChildElementName As String,
    strAttributeName As String,
    strAttributeValue As String
) As IACDataElementCollection

Parameters

oAttributeList
Type: Kofax.Capture.SDK.DataIACDataElementAttributeColl
A collection of selected attribute names.
strChildElementName
Type: SystemString
The name of the child element.
strAttributeName
Type: SystemString
The attribute name.
strAttributeValue
Type: SystemString
The attribute value.

Return Value

Type: IACDataElementCollection
Kofax.Capture.SDK.Data.IACDataElementCollection

Implements

IACDataElementFindPartialChildElementsByAttribute(IACDataElementAttributeColl, String, String, String)
Remarks

When extracting collections, it may sometimes be optimal to extract only some of the attributes of a sub-element list. For example, to determine if there are any rejected loose pages, it may only be necessary to extract the "Rejected" attribute of those pages.

Attribute sub-lists impose some extra overhead that actually slows down query generation. The benefits of the optimization are only felt when many sub-elements are extracted. Therefore, it is better to use attribute sub-lists only when processing large collections of elements (a hundred or more) where only one or two attributes are needed.

See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.FindPartialChildElementsByName Method

ACDataElementFindPartialChildElementsByName Method

Extracts all child elements based on their names. Also, only a sub-list of possible attributes is extracted.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElementCollection FindPartialChildElementsByName(
    ref IACDataElementAttributeColl oAttributeList,
    string strChildElementName
)
Public Function FindPartialChildElementsByName (
    ByRef oAttributeList As IACDataElementAttributeColl,
    strChildElementName As String
) As IACDataElementCollection

Parameters

oAttributeList
Type: Kofax.Capture.SDK.DataIACDataElementAttributeColl
A collection of selected attribute names.
strChildElementName
Type: SystemString
The name of the child element.

Return Value

Type: IACDataElementCollection
Kofax.Capture.SDK.Data.IACDataElementCollection

Implements

IACDataElementFindPartialChildElementsByName(IACDataElementAttributeColl, String)
Remarks

When extracting collections, it may sometimes be optimal to extract only some of the attributes of a sub-element list. For example, to determine if there are any rejected loose pages, it may only be necessary to extract the "Rejected" attribute of those pages.

Attribute sub-lists impose some extra overhead that actually slows down query generation. The benefits of the optimization are only felt when many sub-elements are extracted. Therefore, it is better to use attribute sub-lists only when processing large collections of elements (a hundred or more) where only one or two attributes are needed.

See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.MoveElementBefore Method

ACDataElementMoveElementBefore Method

Moves an Element immediately before the passed child.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void MoveElementBefore(
    ref IACDataElement oAfterSib
)
Public Sub MoveElementBefore (
    ByRef oAfterSib As IACDataElement
)

Parameters

oAfterSib
Type: Kofax.Capture.SDK.DataIACDataElement
The child object.

Implements

IACDataElementMoveElementBefore(IACDataElement)
Remarks
The following rules are allowed:
  • Move a Page element before another Page element
  • Move a Document element before another Document element
  • Move a Folder element before another Folder element

Failure to meet these constraints causes an error.

See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.MoveElementToBatch Method

ACDataElementMoveElementToBatch Method

Moves a Kofax.Capture.SDK.Data.IACDataElement (Page or Document or Folder) from one open batch to another. MoveElementToBatch automatically deletes the Kofax.Capture.SDK.Data.IACDataElement from the source batch.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElement MoveElementToBatch(
    ref IACDataElement oElement
)
Public Function MoveElementToBatch (
    ByRef oElement As IACDataElement
) As IACDataElement

Parameters

oElement
Type: Kofax.Capture.SDK.DataIACDataElement
The element to be moved from the source batch.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement

Implements

IACDataElementMoveElementToBatch(IACDataElement)
Remarks
See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.MoveToBack Method

ACDataElementMoveToBack Method

Moves an element to be the last child of the parent.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void MoveToBack(
    ref IACDataElement oParent
)
Public Sub MoveToBack (
    ByRef oParent As IACDataElement
)

Parameters

oParent
Type: Kofax.Capture.SDK.DataIACDataElement
The parent object.

Implements

IACDataElementMoveToBack(IACDataElement)
Remarks
The following rules are allowed:
  • If the current element is a Page element, then the oParent element must be a Pages element whose parent is either a Document or a Batch element.
  • If the current element is a Document element, then the oParent element must be a Documents element whose parent is either a Folder or a Batch element.
  • If the current element is a Folder element, then the oParent element must be a Folder element whose parent is either a Folder or a Batch element.

Failure to meet these constraints causes an error.

See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.MoveToBackInternal Method

ACDataElementMoveToBackInternal Method

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void MoveToBackInternal(
    ref ACDataElement oParent
)
Public Sub MoveToBackInternal (
    ByRef oParent As ACDataElement
)

Parameters

oParent
Type: Kofax.Capture.DBLiteOptACDataElement
See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.MoveToFront Method

ACDataElementMoveToFront Method

Moves an element to be the first child of the parent.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void MoveToFront(
    ref IACDataElement oParent
)
Public Sub MoveToFront (
    ByRef oParent As IACDataElement
)

Parameters

oParent
Type: Kofax.Capture.SDK.DataIACDataElement
The parent object.

Implements

IACDataElementMoveToFront(IACDataElement)
Remarks
The following rules are allowed:
  • If the current element is a Page element, then the oParent element must be a Pages element whose parent is either a Document or a Batch element.
  • If the current element is a Document element, then the oParent element must be a Documents element whose parent is either a Folder or a Batch element.
  • If the current element is a Folder element, then the oParent element must be a Folder element whose parent is either a Folder or a Batch element.
See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement Properties

ACDataElement Properties

The ACDataElement type exposes the following members.

Properties
 | Name | Description
Public property | AttributeNames | Returns a collection of strings corresponding to the valid attribute names for this element type.
Public property | AttributeValue | Gets or sets an attribute value.
Public property | ChildElementNames | Returns a collection of strings corresponding to the valid child element type names.
Public property | ElementName | Returns the name of this element type.
Top
See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.AttributeNames Property

ACDataElementAttributeNames Property

Returns a collection of strings corresponding to the valid attribute names for this element type.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ArrayList AttributeNames { get; }
Public ReadOnly Property AttributeNames As ArrayList
    Get

Property Value

Type: ArrayList
A collection of attribute names.

Return Value

Type: ArrayList
System.Collections.ArrayList

Implements

IACDataElementAttributeNames
Remarks
See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.AttributeValue Property

ACDataElementAttributeValue Property

Gets or sets an attribute value.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    string strAttributeName
] { get; set; }
Public Default Property AttributeValue (
    strAttributeName As String
) As String
    Get
    Set

Parameters

strAttributeName
Type: SystemString
The attribute name to retrieve or modify.

Property Value

Type: String
An attribute value.

Return Value

Type: String
String

Implements

IACDataElementAttributeValueString
Remarks
Throws an error if the attribute name is not valid.
See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.ChildElementNames Property

ACDataElementChildElementNames Property

Returns a collection of strings corresponding to the valid child element type names.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ArrayList ChildElementNames { get; }
Public ReadOnly Property ChildElementNames As ArrayList
    Get

Property Value

Type: ArrayList
A collection of child element type names.

Return Value

Type: ArrayList
System.Collections.ArrayList

Implements

IACDataElementChildElementNames
Remarks
See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElement.ElementName Property

ACDataElementElementName Property

Returns the name of this element type.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ElementName { get; }
Public ReadOnly Property ElementName As String
    Get

Property Value

Type: String

Return Value

Type: String
String

Implements

IACDataElementElementName
Remarks
See Also

Reference

ACDataElement Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElementAttributeColl Class

ACDataElementAttributeColl Class
This object allows specification of attribute sub-lists. Refer to FindPartialChildElementsByName(IACDataElementAttributeColl, String) and FindPartialChildElementsByAttribute(IACDataElementAttributeColl, String, String, String)
Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteOptACDataElementAttributeColl

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ACDataElementAttributeColl : IACDataElementAttributeColl
Public Class ACDataElementAttributeColl
    Implements IACDataElementAttributeColl

The ACDataElementAttributeColl type exposes the following members.

Constructors
 | Name | Description
Public method | ACDataElementAttributeColl | Initializes a new instance of the Kofax.Capture.DBLiteOpt.ACDataElementAttributeColl class.
Top
Methods
 | Name | Description
Public method | Add | Adds the attribute to the collection.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Remove | Removes an attribute from the collection, based on its 1-based numeric index, or by name.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of attributes in the collection.
Public property | Item | Returns an attribute based on its 1-based numeric index, or by name.
Top
Remarks
See Also

Reference

Kofax.Capture.DBLiteOpt Namespace


ACDataElementAttributeColl Constructor

ACDataElementAttributeColl Constructor
Initializes a new instance of the Kofax.Capture.DBLiteOpt.ACDataElementAttributeColl class.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ACDataElementAttributeColl()
Public Sub New
Remarks
See Also

Reference

ACDataElementAttributeColl Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElementAttributeColl Methods

ACDataElementAttributeColl Methods

The ACDataElementAttributeColl type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the attribute to the collection.
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Remove | Removes an attribute from the collection, based on its 1-based numeric index, or by name.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ACDataElementAttributeColl Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElementAttributeColl.Add Method

ACDataElementAttributeCollAdd Method
Adds the attribute to the collection.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Add(
    ref string strItem
)
Public Sub Add (
    ByRef strItem As String
)

Parameters

strItem
Type: SystemString
The attribute to add.

Implements

IACDataElementAttributeCollAdd(String)
Remarks
See Also

Reference

ACDataElementAttributeColl Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElementAttributeColl.GetEnumerator Method

ACDataElementAttributeCollGetEnumerator Method
Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.DBLiteOpt.ACDataElementAttributeColl object.

Implements

IEnumerableGetEnumerator
See Also

Reference

ACDataElementAttributeColl Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElementAttributeColl.Remove Method

ACDataElementAttributeCollRemove Method
Removes an attribute from the collection, based on its 1-based numeric index, or by name.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Remove(
    ref Object oIndex
)
Public Sub Remove (
    ByRef oIndex As Object
)

Parameters

oIndex
Type: SystemObject
The key or value of the attribute to remove.

Implements

IACDataElementAttributeCollRemove(Object)
Remarks
See Also

Reference

ACDataElementAttributeColl Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElementAttributeColl Properties

ACDataElementAttributeColl Properties

The ACDataElementAttributeColl type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of attributes in the collection.
Public property | Item | Returns an attribute based on its 1-based numeric index, or by name.
Top
See Also

Reference

ACDataElementAttributeColl Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElementAttributeColl.Count Property

ACDataElementAttributeCollCount Property
Returns the number of attributes in the collection.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Return Value

Type: Int32
Integer

Implements

IACDataElementAttributeCollCount
Remarks
See Also

Reference

ACDataElementAttributeColl Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElementAttributeColl.Item Property

ACDataElementAttributeCollItem Property
Returns an attribute based on its 1-based numeric index, or by name.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string this[
    Object oIndex
] { get; }
Public ReadOnly Property Item (
    oIndex As Object
) As String
    Get

Parameters

oIndex
Type: SystemObject
The index of the item to be retrieved.

Return Value

Type: String

Implements

IACDataElementAttributeCollItemObject
Remarks
See Also

Reference

ACDataElementAttributeColl Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElementCollection Class

ACDataElementCollection Class
Defines a collection of ACDataElement objects.
Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteOptACDataElementCollection

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class ACDataElementCollection : IACDataElementCollection
Public Class ACDataElementCollection
    Implements IACDataElementCollection

The ACDataElementCollection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of elements in the collection.
Public property | Item | Retrieves an object from the collection, by 1-based numeric index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.DBLiteOpt Namespace


ACDataElementCollection Methods

ACDataElementCollection Methods

The ACDataElementCollection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through this collection.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

ACDataElementCollection Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElementCollection.GetEnumerator Method

ACDataElementCollectionGetEnumerator Method
Returns an enumerator that iterates through this collection.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator
Returns a reference to an enumerator object, which is used to iterate over a Kofax.Capture.DBLiteOpt.ACDataElementCollection object.

Implements

IEnumerableGetEnumerator
See Also

Reference

ACDataElementCollection Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElementCollection Properties

ACDataElementCollection Properties

The ACDataElementCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of elements in the collection.
Public property | Item | Retrieves an object from the collection, by 1-based numeric index or by key.
Top
See Also

Reference

ACDataElementCollection Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElementCollection.Count Property

ACDataElementCollectionCount Property
Returns the number of elements in the collection.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer

Implements

IACDataElementCollectionCount
Remarks
See Also

Reference

ACDataElementCollection Class
Kofax.Capture.DBLiteOpt Namespace


ACDataElementCollection.Item Property

ACDataElementCollectionItem Property
Retrieves an object from the collection, by 1-based numeric index or by key.

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IACDataElement this[
    int nIndex
] { get; }
Public ReadOnly Default Property Item (
    nIndex As Integer
) As IACDataElement
    Get

Parameters

nIndex
Type: SystemInt32
The index or key of the item to be retrieved.

Property Value

Type: IACDataElement

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement

Implements

IACDataElementCollectionItemInt32
Remarks

There is no support for looking up a sub-element by a key value.

To extract a sub-element by key value, use the method “FindChildElementByAttribute” on the collection parent.

See Also

Reference

ACDataElementCollection Class
Kofax.Capture.DBLiteOpt Namespace


AttributeValueColl Class

AttributeValueColl Class
Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteOptAttributeValueColl

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class AttributeValueColl : IAttributeValueColl
Public Class AttributeValueColl
    Implements IAttributeValueColl

The AttributeValueColl type exposes the following members.

Constructors
 | Name | Description
Public method | AttributeValueColl | Initializes a new instance of the AttributeValueColl class
Top
Methods
 | Name | Description
Public method | Add |
Public method | Count |
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Item |
Public method | Remove |
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Kofax.Capture.DBLiteOpt Namespace


AttributeValueColl Constructor

AttributeValueColl Constructor
Initializes a new instance of the AttributeValueColl class

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public AttributeValueColl()
Public Sub New
See Also

Reference

AttributeValueColl Class
Kofax.Capture.DBLiteOpt Namespace


AttributeValueColl Methods

AttributeValueColl Methods

The AttributeValueColl type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Count |
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Item |
Public method | Remove |
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

AttributeValueColl Class
Kofax.Capture.DBLiteOpt Namespace


AttributeValueColl.Add Method

AttributeValueCollAdd Method

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Add(
    INameValuePair oItem
)
Public Sub Add (
    oItem As INameValuePair
)

Parameters

oItem
Type: Kofax.Capture.SDK.DataINameValuePair

Implements

IAttributeValueCollAdd(INameValuePair)
See Also

Reference

AttributeValueColl Class
Kofax.Capture.DBLiteOpt Namespace


AttributeValueColl.Count Method

AttributeValueCollCount Method

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count()
Public Function Count As Integer

Return Value

Type: Int32

Implements

IAttributeValueCollCount
See Also

Reference

AttributeValueColl Class
Kofax.Capture.DBLiteOpt Namespace


AttributeValueColl.GetEnumerator Method

AttributeValueCollGetEnumerator Method

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

AttributeValueColl Class
Kofax.Capture.DBLiteOpt Namespace


AttributeValueColl.Item Method

AttributeValueCollItem Method

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public INameValuePair Item(
    ref int nIndex
)
Public Function Item (
    ByRef nIndex As Integer
) As INameValuePair

Parameters

nIndex
Type: SystemInt32

Return Value

Type: INameValuePair

Implements

IAttributeValueCollItem(Int32)
See Also

Reference

AttributeValueColl Class
Kofax.Capture.DBLiteOpt Namespace


AttributeValueColl.Remove Method

AttributeValueCollRemove Method

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Remove(
    ref int nIndex
)
Public Sub Remove (
    ByRef nIndex As Integer
)

Parameters

nIndex
Type: SystemInt32

Implements

IAttributeValueCollRemove(Int32)
See Also

Reference

AttributeValueColl Class
Kofax.Capture.DBLiteOpt Namespace


BulkUpdateDataColl Class

BulkUpdateDataColl Class
Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteOptBulkUpdateDataColl

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class BulkUpdateDataColl : IBulkUpdateDataColl
Public Class BulkUpdateDataColl
    Implements IBulkUpdateDataColl

The BulkUpdateDataColl type exposes the following members.

Constructors
 | Name | Description
Public method | BulkUpdateDataColl | Initializes a new instance of the BulkUpdateDataColl class
Top
Methods
 | Name | Description
Public method | Add |
Public method | Count |
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Item |
Public method | Remove |
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Kofax.Capture.DBLiteOpt Namespace


BulkUpdateDataColl Constructor

BulkUpdateDataColl Constructor
Initializes a new instance of the BulkUpdateDataColl class

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public BulkUpdateDataColl()
Public Sub New
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.DBLiteOpt Namespace


BulkUpdateDataColl Methods

BulkUpdateDataColl Methods

The BulkUpdateDataColl type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Count |
Public method | Equals | (Inherited from Object.)
Public method | GetEnumerator |
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | Item |
Public method | Remove |
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.DBLiteOpt Namespace


BulkUpdateDataColl.Add Method

BulkUpdateDataCollAdd Method

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Add(
    IAttributeValueColl oItem
)
Public Sub Add (
    oItem As IAttributeValueColl
)

Parameters

oItem
Type: Kofax.Capture.SDK.DataIAttributeValueColl

Implements

IBulkUpdateDataCollAdd(IAttributeValueColl)
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.DBLiteOpt Namespace


BulkUpdateDataColl.Count Method

BulkUpdateDataCollCount Method

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Count()
Public Function Count As Integer

Return Value

Type: Int32

Implements

IBulkUpdateDataCollCount
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.DBLiteOpt Namespace


BulkUpdateDataColl.GetEnumerator Method

BulkUpdateDataCollGetEnumerator Method

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator

Return Value

Type: IEnumerator

Implements

IEnumerableGetEnumerator
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.DBLiteOpt Namespace


BulkUpdateDataColl.Item Method

BulkUpdateDataCollItem Method

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public IAttributeValueColl Item(
    ref int nIndex
)
Public Function Item (
    ByRef nIndex As Integer
) As IAttributeValueColl

Parameters

nIndex
Type: SystemInt32

Return Value

Type: IAttributeValueColl

Implements

IBulkUpdateDataCollItem(Int32)
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.DBLiteOpt Namespace


BulkUpdateDataColl.Remove Method

BulkUpdateDataCollRemove Method

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public void Remove(
    ref int nIndex
)
Public Sub Remove (
    ByRef nIndex As Integer
)

Parameters

nIndex
Type: SystemInt32

Implements

IBulkUpdateDataCollRemove(Int32)
See Also

Reference

BulkUpdateDataColl Class
Kofax.Capture.DBLiteOpt Namespace


NameValuePair Class

NameValuePair Class
Inheritance Hierarchy
SystemObject
Kofax.Capture.DBLiteOptNameValuePair

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class NameValuePair : INameValuePair
Public Class NameValuePair
    Implements INameValuePair

The NameValuePair type exposes the following members.

Constructors
 | Name | Description
Public method | NameValuePair | Initializes a new instance of the NameValuePair class
Public method | NameValuePair(String, String) | Initializes a new instance of the NameValuePair class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
See Also

Reference

Kofax.Capture.DBLiteOpt Namespace


NameValuePair Constructor

NameValuePair Constructor
Overload List
 | Name | Description
Public method | NameValuePair | Initializes a new instance of the NameValuePair class
Public method | NameValuePair(String, String) | Initializes a new instance of the NameValuePair class
Top
See Also

Reference

NameValuePair Class
Kofax.Capture.DBLiteOpt Namespace


NameValuePair Constructor

NameValuePair Constructor
Initializes a new instance of the NameValuePair class

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public NameValuePair()
Public Sub New
See Also

Reference

NameValuePair Class
NameValuePair Overload
Kofax.Capture.DBLiteOpt Namespace


NameValuePair Constructor (String, String)

NameValuePair Constructor (String, String)
Kofax Capture API Reference
Initializes a new instance of the NameValuePair class

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public NameValuePair(
    string strName,
    string strValue
)
Public Sub New (
    strName As String,
    strValue As String
)

Parameters

strName
Type: SystemString
strValue
Type: SystemString
See Also

Reference

NameValuePair Class
NameValuePair Overload
Kofax.Capture.DBLiteOpt Namespace


NameValuePair Methods

NameValuePair Methods

The NameValuePair type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

NameValuePair Class
Kofax.Capture.DBLiteOpt Namespace


NameValuePair Properties

NameValuePair Properties

The NameValuePair type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
See Also

Reference

NameValuePair Class
Kofax.Capture.DBLiteOpt Namespace


NameValuePair.Name Property

NameValuePairName Property

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Implements

INameValuePairName
See Also

Reference

NameValuePair Class
Kofax.Capture.DBLiteOpt Namespace


NameValuePair.Value Property

NameValuePairValue Property

Namespace: Kofax.Capture.DBLiteOpt
Assembly: Kofax.DBLiteOpt (in Kofax.DBLiteOpt.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set

Property Value

Type: String

Implements

INameValuePairValue
See Also

Reference

NameValuePair Class
Kofax.Capture.DBLiteOpt Namespace


Kofax.Capture.SDK.CustomModule Namespace

Kofax.Capture.SDK.CustomModule Namespace

Tungsten Capture Custom Module .NET Type Interface Library and Tungsten Capture Document Access .NET Type Implementation Library are libraries that allow you to integrate a custom module into your Tungsten Capture installation. Tungsten Capture Custom Module .NET Type Interface Library and Tungsten Capture Document Access .NET Type Implementation Library make it possible for the custom module to access batch information from Tungsten Capture. Likewise, they allow your custom module to relay batch information from the custom module to Tungsten Capture. The Tungsten Capture Custom Module .NET Type Interface Library dynamic-link library (Kofax.Capture.SDK.CustomModule.dll) and Tungsten Capture Document Access .NET Type Implementation Library (Kofax.DbLite.dll), are available from the Bin folder in your Tungsten Capture installation.

Tungsten Capture Custom Module .NET Type Interface and Tungsten Capture Document Access .NET Type Implementation libraries allow you to do the following:

  • Route a Tungsten Capture batch to a custom module for processing
  • Use the Tungsten Capture Optimized Custom Module API to selectively retrieve and update data
  • Close a batch from a custom module and route it to the next module in the Tungsten Capture workflow
Although using XML transport files to export/import batch information between Tungsten Capture and a custom module is supported, this method is not recommended for large batches or large number of users due to performance degradation.
Classes
 | Class | Description
Public class | CannotCreateChildFromCurrentBatchException | Defines the exception that is thrown if an error occurs when creating child from current batch.
Public class | FailedToCreateChildBatchException | Defines the exception that is thrown when an error occurs when creating a child batch.
Public class | InvalidArgumentException | The exception that is thrown when an invalid argument is passed in.
Public class | InvalidOperationException | Defines the exception that is thrown when an invalid operation is called.
Public class | LicensingException | The exception that is thrown when a licesing issue occurs.
Public class | LoginException | The exception that is thrown when a login error occurs.
Public class | TimeoutEventArg | Defines a time-out event argument class.
Interfaces
 | Interface | Description
Public interface | IBatch | Defines an interface that contains information about an active batch.
Public interface | IBatchCollection | Defines a collection of batch objects.
Public interface | IBatchFieldNamesCollection | Defines a collection of batch field names.
Public interface | IBatchFieldValuesCollection | Defines a collection of batch field values.
Public interface | ILogin | The Login object forms the basis of the entire hierarchy. The properties of Login are used for error logging. A Login object should be maintained until the calling application shuts down; additional Login objects should not be introduced while the calling application is open.
Public interface | ILogin2 | The Login object forms the basis of the entire hierarchy. The properties of Login are used for error logging. A Login object should be maintained until the calling application shuts down; additional Login objects should not be introduced while the calling application is open.
Public interface | IProcess | Defines a process object that holds information about a Tungsten Capture standard process.
Public interface | IProcessCollection | Defines a collection that identifies the different queues in the system. Custom modules will find their process IDs in the collection and use them for getting batches and constructing the "where" clause for the BatchCollection.
Public interface | IPublishedBatchClass | Defines information for published batch class event.
Public interface | IPublishedBatchClassCollection | Defines a collection of IPublishedBatchClass objects.
Public interface | IRuntimeSession | This interface is required to gain access to any of the other objects in the hierarchy.
Delegates
 | Delegate | Description
Public delegate | IRuntimeSessionBatchAvailableEventHandler |
Public delegate | TimeoutEventHandlerTEventArgs | Delegate to be used to declare an event time out handler.
Enumerations
 | Enumeration | Description
Public enumeration | KfxDbError | Defines the possible errors.
Public enumeration | KfxDbFilter | Used to limit the scope of processing, or to specify sort criteria.
Public enumeration | KfxDbProcessId | Used to report process IDs, which indicates the current Tungsten Capture module.
Public enumeration | KfxDbQueue | Used for calculating the next state of a batch.
Public enumeration | KfxDbState | Used for the state of a batch.
Remarks


CannotCreateChildFromCurrentBatchException Class

CannotCreateChildFromCurrentBatchException Class

Defines the exception that is thrown if an error occurs when creating child from current batch.

Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.Runtime.InteropServicesCOMException
Kofax.Capture.SDK.DataKfxException
Kofax.Capture.SDK.CustomModuleCannotCreateChildFromCurrentBatchException

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class CannotCreateChildFromCurrentBatchException : KfxException
Public Class CannotCreateChildFromCurrentBatchException
    Inherits KfxException

The CannotCreateChildFromCurrentBatchException type exposes the following members.

Constructors
 | Name | Description
Public method | CannotCreateChildFromCurrentBatchException(String, KfxDbError) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.CannotCreateChildFromCurrentBatchException class.
Public method | CannotCreateChildFromCurrentBatchException(String, KfxDbError, Object) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.CannotCreateChildFromCurrentBatchException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
Remarks
One of the following error numbers should be passed in:
  • KfxDbError.KfxDbCannotCreateChildWhenThereIsBatchTotal = 4046 '*** Cannot create child batch when there is batch total.
  • KfxDbError.KfxDbCannotCreateChildFromPartialReleasedBatch = 4048 '*** Cannot create child batch when a batch has been partially released.
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


CannotCreateChildFromCurrentBatchException Constructor

CannotCreateChildFromCurrentBatchException Constructor
Overload List
 | Name | Description
Public method | CannotCreateChildFromCurrentBatchException(String, KfxDbError) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.CannotCreateChildFromCurrentBatchException class.
Public method | CannotCreateChildFromCurrentBatchException(String, KfxDbError, Object) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.CannotCreateChildFromCurrentBatchException class.
Top
See Also

Reference

CannotCreateChildFromCurrentBatchException Class
Kofax.Capture.SDK.CustomModule Namespace


CannotCreateChildFromCurrentBatchException Constructor (String, KfxDbError)

CannotCreateChildFromCurrentBatchException Constructor (String, KfxDbError)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.CustomModule.CannotCreateChildFromCurrentBatchException class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public CannotCreateChildFromCurrentBatchException(
    string strMsg,
    KfxDbError errNum
)
Public Sub New (
    strMsg As String,
    errNum As KfxDbError
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.CustomModuleKfxDbError
The original Error number.
Remarks
See Also

Reference

CannotCreateChildFromCurrentBatchException Class
CannotCreateChildFromCurrentBatchException Overload
Kofax.Capture.SDK.CustomModule Namespace


CannotCreateChildFromCurrentBatchException Constructor (String, KfxDbError, Object)

CannotCreateChildFromCurrentBatchException Constructor (String, KfxDbError, Object)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.CustomModule.CannotCreateChildFromCurrentBatchException class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public CannotCreateChildFromCurrentBatchException(
    string strMsg,
    KfxDbError errNum,
    Object oSource
)
Public Sub New (
    strMsg As String,
    errNum As KfxDbError,
    oSource As Object
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.CustomModuleKfxDbError
The original Error number.
oSource
Type: SystemObject
The source.
Remarks
See Also

Reference

CannotCreateChildFromCurrentBatchException Class
CannotCreateChildFromCurrentBatchException Overload
Kofax.Capture.SDK.CustomModule Namespace


CannotCreateChildFromCurrentBatchException Methods

CannotCreateChildFromCurrentBatchException Methods

The CannotCreateChildFromCurrentBatchException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
See Also

Reference

CannotCreateChildFromCurrentBatchException Class
Kofax.Capture.SDK.CustomModule Namespace


CannotCreateChildFromCurrentBatchException Properties

CannotCreateChildFromCurrentBatchException Properties

The CannotCreateChildFromCurrentBatchException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
See Also

Reference

CannotCreateChildFromCurrentBatchException Class
Kofax.Capture.SDK.CustomModule Namespace


FailedToCreateChildBatchException Class

FailedToCreateChildBatchException Class

Defines the exception that is thrown when an error occurs when creating a child batch.

Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.Runtime.InteropServicesCOMException
Kofax.Capture.SDK.DataKfxException
Kofax.Capture.SDK.CustomModuleFailedToCreateChildBatchException

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class FailedToCreateChildBatchException : KfxException
Public Class FailedToCreateChildBatchException
    Inherits KfxException

The FailedToCreateChildBatchException type exposes the following members.

Constructors
 | Name | Description
Public method | FailedToCreateChildBatchException(String, KfxDbError) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.FailedToCreateChildBatchException class.
Public method | FailedToCreateChildBatchException(String, KfxDbError, Object) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.FailedToCreateChildBatchException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
Remarks
One of the following error numbers should be passed in:
  • KfxDbError.KfxDbFailedToCreateChildBatch = 4049 '*** Failed to create child batch.
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


FailedToCreateChildBatchException Constructor

FailedToCreateChildBatchException Constructor
Overload List
 | Name | Description
Public method | FailedToCreateChildBatchException(String, KfxDbError) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.FailedToCreateChildBatchException class.
Public method | FailedToCreateChildBatchException(String, KfxDbError, Object) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.FailedToCreateChildBatchException class.
Top
See Also

Reference

FailedToCreateChildBatchException Class
Kofax.Capture.SDK.CustomModule Namespace


FailedToCreateChildBatchException Constructor (String, KfxDbError)

FailedToCreateChildBatchException Constructor (String, KfxDbError)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.CustomModule.FailedToCreateChildBatchException class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public FailedToCreateChildBatchException(
    string strMsg,
    KfxDbError errNum
)
Public Sub New (
    strMsg As String,
    errNum As KfxDbError
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.CustomModuleKfxDbError
The original Error number.
Remarks
See Also

Reference

FailedToCreateChildBatchException Class
FailedToCreateChildBatchException Overload
Kofax.Capture.SDK.CustomModule Namespace


FailedToCreateChildBatchException Constructor (String, KfxDbError, Object)

FailedToCreateChildBatchException Constructor (String, KfxDbError, Object)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.CustomModule.FailedToCreateChildBatchException class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public FailedToCreateChildBatchException(
    string strMsg,
    KfxDbError errNum,
    Object oSource
)
Public Sub New (
    strMsg As String,
    errNum As KfxDbError,
    oSource As Object
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.CustomModuleKfxDbError
The original Error number.
oSource
Type: SystemObject
The source.
Remarks
See Also

Reference

FailedToCreateChildBatchException Class
FailedToCreateChildBatchException Overload
Kofax.Capture.SDK.CustomModule Namespace


FailedToCreateChildBatchException Methods

FailedToCreateChildBatchException Methods

The FailedToCreateChildBatchException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
See Also

Reference

FailedToCreateChildBatchException Class
Kofax.Capture.SDK.CustomModule Namespace


FailedToCreateChildBatchException Properties

FailedToCreateChildBatchException Properties

The FailedToCreateChildBatchException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
See Also

Reference

FailedToCreateChildBatchException Class
Kofax.Capture.SDK.CustomModule Namespace


IBatch Interface

IBatch Interface

Defines an interface that contains information about an active batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IBatch : IDisposable
Public Interface IBatch
    Inherits IDisposable

The IBatch type exposes the following members.

Methods
 | Name | Description
Public method | BatchClose | Closes and unlocks the batch.
Public method | BatchCloseWithModuleID | Closes and unlocks the batch to the specified module.
Public method | BatchDelete | Deletes the locked batch. Transfers any statistics information into the statistics file.
Public method | BatchOpen | Opens/Locks and returns a batch object.
Public method | BatchRecall | Recall a batch from a remote site back to the central site
Public method | ChildBatchCreate | Creates a child batch based on an existing open parent batch. Each child batch uses the same published batch class as the parent batch.
Public method | ChildBatchCreate2 | Creates a child batch based on an existing open parent batch. Each child batch uses the same published batch class as the parent batch.
Public method | ChildBatchCreateWithBatchClass | Creates a child batch based on an existing open parent batch. Each child batch uses the specified published batch class.
Public method | ChildBatchCreateWithBatchClass2 | Creates a child batch based on an existing open parent batch. Each child batch uses the specified published batch class.
Public method | CustomPublishedDataFolder | Returns a custom data path based on the published batch class and the provided module ID.
Public method | Dispose | (Inherited from IDisposable.)
Public method | ExtractRuntimeACDataElement | Extracts the batch runtime root element for the Optimized Custom Module API.
Public method | ExtractSetupACDataElement | Extracts the setup root element for the Optimized Custom Module API.
Public method | GenerateDocumentUniqueID2 | Returns a unique document ID.
Public method | Refresh | Refresh the batch information properties. These are the properties that do not require the batch to be open.
Public method | ValidityCheck | Does limited checking on the structure of the batch and batch class.
Public method | XMLExport | Creates an XML file from the .mdb file.
Public method | XMLExportBatchOnly | Creates an XML runtime file that contains ONLY batch information from the runtime batch.
Public method | XMLExportDocuments | Creates an XML runtime file that contains ONLY document information for a range of documents.
Public method | XMLImport | Updates the batch from the XML runtime file.
Public method | XMLImportBatchOnly | Reads runtime batch information from the XML file.
Public method | XMLImportDocuments | Reads an XML runtime document file and replaces the information in the database file.
Top
Properties
 | Name | Description
Public property | BatchClassName | Returns the name of the batch class.
Public property | BatchFieldValue | The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).
Public property | BatchFieldValueInt32 | The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).
Public property | BatchGUID | Gets the unique ID of this batch.
Public property | BatchId | Returns the batch ID.
Public property | BitonalImageFile | Returns the image file path for a bitonal image based on the image ID.
Public property | CreateDate | Returns the date and time the batch class was created.
Public property | CustomStorageString | The storage string with the specified name.
Public property | DocumentCount | Reads the batch and returns the document count.
Public property | ExternalBatchID | Returns the external batch ID.
Public property | HasError | Returns a Boolean value indicating if the batch has an error.
Public property | ImageDir | Returns the batch image folder.
Public property | ImageFile | Returns an image file path based on the image ID from the page object, to which the extension "TIF" is automatically appended.
Public property | ImageFileWithExt | Returns the image file path based on the image ID from the page object, and the extension of the file.
Public property | LastPublishedDate | The publish date of the batch class used to create this batch.
Public property | Name | Returns the name of the batch.
Public property | OCRDir | Returns the batch OCR folder.
Public property | PageCount | Reads the batch and returns the page count.
Public property | Priority | Returns the batch priority.
Public property | ProcessID | Returns the current process ID.
Public property | PubBatchDefID | Returns the published batch ID.
Public property | ScanStationID | Returns the Scan Station ID for the batch.
Public property | ScanUser | Returns the ID for the user who scanned the batch.
Public property | State | Returns the batch state. Can be mapped to the enumeration for the current state.
Public property | StationID | Returns the ID of the station/user that created the batch.
Top
Remarks
The Batch object can be used to display a list of batches available to process, similar to Batch Manager. The data is static unless the BatchOpen method is called. Batches may become active and not be available.
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


IBatch Methods

IBatch Methods

The IBatch type exposes the following members.

Methods
 | Name | Description
Public method | BatchClose | Closes and unlocks the batch.
Public method | BatchCloseWithModuleID | Closes and unlocks the batch to the specified module.
Public method | BatchDelete | Deletes the locked batch. Transfers any statistics information into the statistics file.
Public method | BatchOpen | Opens/Locks and returns a batch object.
Public method | BatchRecall | Recall a batch from a remote site back to the central site
Public method | ChildBatchCreate | Creates a child batch based on an existing open parent batch. Each child batch uses the same published batch class as the parent batch.
Public method | ChildBatchCreate2 | Creates a child batch based on an existing open parent batch. Each child batch uses the same published batch class as the parent batch.
Public method | ChildBatchCreateWithBatchClass | Creates a child batch based on an existing open parent batch. Each child batch uses the specified published batch class.
Public method | ChildBatchCreateWithBatchClass2 | Creates a child batch based on an existing open parent batch. Each child batch uses the specified published batch class.
Public method | CustomPublishedDataFolder | Returns a custom data path based on the published batch class and the provided module ID.
Public method | Dispose | (Inherited from IDisposable.)
Public method | ExtractRuntimeACDataElement | Extracts the batch runtime root element for the Optimized Custom Module API.
Public method | ExtractSetupACDataElement | Extracts the setup root element for the Optimized Custom Module API.
Public method | GenerateDocumentUniqueID2 | Returns a unique document ID.
Public method | Refresh | Refresh the batch information properties. These are the properties that do not require the batch to be open.
Public method | ValidityCheck | Does limited checking on the structure of the batch and batch class.
Public method | XMLExport | Creates an XML file from the .mdb file.
Public method | XMLExportBatchOnly | Creates an XML runtime file that contains ONLY batch information from the runtime batch.
Public method | XMLExportDocuments | Creates an XML runtime file that contains ONLY document information for a range of documents.
Public method | XMLImport | Updates the batch from the XML runtime file.
Public method | XMLImportBatchOnly | Reads runtime batch information from the XML file.
Public method | XMLImportDocuments | Reads an XML runtime document file and replaces the information in the database file.
Top
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.BatchClose Method

IBatchBatchClose Method

Closes and unlocks the batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void BatchClose(
    KfxDbState eNewState,
    KfxDbQueue eQueue,
    int nErrorCode,
    string strErrorText
)
Sub BatchClose (
    eNewState As KfxDbState,
    eQueue As KfxDbQueue,
    nErrorCode As Integer,
    strErrorText As String
)

Parameters

eNewState
Type: Kofax.Capture.SDK.CustomModuleKfxDbState
Specifies the new state of the batch once it has been unlocked.
eQueue
Type: Kofax.Capture.SDK.CustomModuleKfxDbQueue

Allows the caller to choose where to route the batch.

If KfxDbQueueException is specified, the batch is routed to Quality Control (Rescan).

nErrorCode
Type: SystemInt32
Used only when the state is set to KfxDbBatchError. In this case, this value is recorded in the statistics record.
strErrorText
Type: SystemString
Used only when the state is set to KfxDbBatchError. In this case, this value is recorded in the statistics record.
Remarks

Invalid state parameter for KfxDbState error if the eNewState is either KfxDbBatchReserved or KfxDbBatchInProgress2. The KfxDbBatchReserved and KfxDbBatchInProgress2 states are set internally and cannot be used as eNewState of the BatchClose method.

See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.BatchCloseWithModuleID Method

IBatchBatchCloseWithModuleID Method

Closes and unlocks the batch to the specified module.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void BatchCloseWithModuleID(
    string strModuleID,
    KfxDbState eNewState
)
Sub BatchCloseWithModuleID (
    strModuleID As String,
    eNewState As KfxDbState
)

Parameters

strModuleID
Type: SystemString
The Unique ID (such as "ocr.exe") that specifies to which module to route the batch to.
eNewState
Type: Kofax.Capture.SDK.CustomModuleKfxDbState
Specifies the new state of the batch once it has been unlocked.
Remarks

Invalid state parameter for KfxDbState error if the eNewState is either KfxDbBatchReserved or KfxDbBatchInProgress2. The KfxDbBatchReserved and KfxDbBatchInProgress2 states are set internally and cannot be used as eNewState of the BatchCloseWithModuleID method.

See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.BatchDelete Method

IBatchBatchDelete Method

Deletes the locked batch. Transfers any statistics information into the statistics file.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void BatchDelete()
Sub BatchDelete
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.BatchOpen Method

IBatchBatchOpen Method

Opens/Locks and returns a batch object.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void BatchOpen(
    int nRequestingProcessId
)
Sub BatchOpen (
    nRequestingProcessId As Integer
)

Parameters

nRequestingProcessId
Type: SystemInt32
The process requesting the lock. For custom modules, it would be the custom module ProcessID.
Remarks
Errors: The batch is already locked.
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.BatchRecall Method

IBatchBatchRecall Method

Recall a batch from a remote site back to the central site

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void BatchRecall()
Sub BatchRecall
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ChildBatchCreate Method

IBatchChildBatchCreate Method

Creates a child batch based on an existing open parent batch. Each child batch uses the same published batch class as the parent batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch ChildBatchCreate(
    string strBatchName = ""
)
Function ChildBatchCreate (
    Optional strBatchName As String = ""
) As IBatch

Parameters

strBatchName (Optional)
Type: SystemString
Optional. The name of the child batch.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ChildBatchCreate2 Method

IBatchChildBatchCreate2 Method

Creates a child batch based on an existing open parent batch. Each child batch uses the same published batch class as the parent batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch ChildBatchCreate2(
    string strBatchName = "",
    string strGUID = null
)
Function ChildBatchCreate2 (
    Optional strBatchName As String = "",
    Optional strGUID As String = Nothing
) As IBatch

Parameters

strBatchName (Optional)
Type: SystemString
Optional. The name of the child batch.
strGUID (Optional)
Type: SystemString
Optional. If specified, must be a unique ID for the new batch. The ID must have the Registry GUID format {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ChildBatchCreateWithBatchClass Method

IBatchChildBatchCreateWithBatchClass Method

Creates a child batch based on an existing open parent batch. Each child batch uses the specified published batch class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch ChildBatchCreateWithBatchClass(
    string strBatchClassName,
    string strBatchName = ""
)
Function ChildBatchCreateWithBatchClass (
    strBatchClassName As String,
    Optional strBatchName As String = ""
) As IBatch

Parameters

strBatchClassName
Type: SystemString
The name of the child batch's batch class.
strBatchName (Optional)
Type: SystemString
The name of the child batch. Optional.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ChildBatchCreateWithBatchClass2 Method

IBatchChildBatchCreateWithBatchClass2 Method

Creates a child batch based on an existing open parent batch. Each child batch uses the specified published batch class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch ChildBatchCreateWithBatchClass2(
    string strBatchClassName,
    string strBatchName = "",
    string strGUID = null
)
Function ChildBatchCreateWithBatchClass2 (
    strBatchClassName As String,
    Optional strBatchName As String = "",
    Optional strGUID As String = Nothing
) As IBatch

Parameters

strBatchClassName
Type: SystemString
The name of the child batch's batch class.
strBatchName (Optional)
Type: SystemString
The name of the child batch. Optional.
strGUID (Optional)
Type: SystemString
Optional. If specified, must be a unique ID for the new batch. The ID must have the Registry GUID format {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.CustomPublishedDataFolder Method

IBatchCustomPublishedDataFolder Method

Returns a custom data path based on the published batch class and the provided module ID.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string CustomPublishedDataFolder(
    string strModuleID
)
Function CustomPublishedDataFolder (
    strModuleID As String
) As String

Parameters

strModuleID
Type: SystemString
The subfolder to be used as a custom data storage folder.

Return Value

Type: String
String
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ExtractRuntimeACDataElement Method

IBatchExtractRuntimeACDataElement Method

Extracts the batch runtime root element for the Optimized Custom Module API.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElement ExtractRuntimeACDataElement(
    int nHints
)
Function ExtractRuntimeACDataElement (
    nHints As Integer
) As IACDataElement

Parameters

nHints
Type: SystemInt32

Starting with Ascent Capture 7.0, hints are deprecated. Tungsten Capture behaves as if the hints were always specified, providing the same performance gains in all cases (it is no longer necessary to use hints to improve performance). Hints are retained for backward compatibility, but no longer perform any useful function.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement
Remarks
Kofax.Capture.SDK.Data.IACDataElement and all sub-elements are read-write, except where special exceptions apply, as noted here.
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ExtractSetupACDataElement Method

IBatchExtractSetupACDataElement Method

Extracts the setup root element for the Optimized Custom Module API.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElement ExtractSetupACDataElement(
    int nHints
)
Function ExtractSetupACDataElement (
    nHints As Integer
) As IACDataElement

Parameters

nHints
Type: SystemInt32

Starting with Ascent Capture 7.0, hints are deprecated. Tungsten Capture behaves as if the hints were always specified, providing the same performance gains in all cases (it is no longer necessary to use hints to improve performance). Hints are retained for backward compatibility, but no longer perform any useful function.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement
Remarks

The returned ACDataElement and all sub-elements extracted from this call are read-only. Any attempt to update these elements causes an error.

This operation is extremely efficient as only the top element is extracted (rather than all sub-elements).

See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.GenerateDocumentUniqueID2 Method

IBatchGenerateDocumentUniqueID2 Method

Returns a unique document ID.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int GenerateDocumentUniqueID2()
Function GenerateDocumentUniqueID2 As Integer

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.Refresh Method

IBatchRefresh Method

Refresh the batch information properties. These are the properties that do not require the batch to be open.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Refresh()
Sub Refresh
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ValidityCheck Method

IBatchValidityCheck Method

Does limited checking on the structure of the batch and batch class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool ValidityCheck(
    ref Hashtable oErrorCollection = null,
    ref Hashtable oWarningCollection = null
)
Function ValidityCheck (
    Optional ByRef oErrorCollection As Hashtable = Nothing,
    Optional ByRef oWarningCollection As Hashtable = Nothing
) As Boolean

Parameters

oErrorCollection (Optional)
Type: System.CollectionsHashtable
Should be passed in as an empty collection of key/value pairs to get error strings.
oWarningCollection (Optional)
Type: System.CollectionsHashtable
Should be passed in as an empty collection of key/value pairs to get warning strings.

Return Value

Type: Boolean
Remarks

This is not as extensive as the checking in the Administration module; it is designed to catch simple cases and may be expanded in the future.

The collections contain error/warning strings if they were non-nothing in the originally. The function returns True if there were no errors.

See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.XMLExport Method

IBatchXMLExport Method

Creates an XML file from the .mdb file.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void XMLExport(
    string strXMLRuntimeFileName,
    string strXMLSetupFileName = ""
)
Sub XMLExport (
    strXMLRuntimeFileName As String,
    Optional strXMLSetupFileName As String = ""
)

Parameters

strXMLRuntimeFileName
Type: SystemString
The full path and name for the XML runtime file to be created. Note that for high availability, this must be a local path.
strXMLSetupFileName (Optional)
Type: SystemString
The full path and name for the XML setup file to be created. This is an optional parameter. Custom modules should keep the batch open, so that the import and export occur during the same session. Note that for high availability, this must be a local path.
Remarks
The batch must be opened prior to performing this operation.

Errors:
XML file cannot be created/opened.
XML file has a Write error.
Errors thrown by Import/Export code.
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.XMLExportBatchOnly Method

IBatchXMLExportBatchOnly Method

Creates an XML runtime file that contains ONLY batch information from the runtime batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void XMLExportBatchOnly(
    string strXMLRuntimeFileName,
    string strXMLSetupFileName = ""
)
Sub XMLExportBatchOnly (
    strXMLRuntimeFileName As String,
    Optional strXMLSetupFileName As String = ""
)

Parameters

strXMLRuntimeFileName
Type: SystemString
The full path and name for XML runtime file that will contain the output XML. Note that for high availability, this must be a local path.
strXMLSetupFileName (Optional)
Type: SystemString
The full path and name for the XML setup file to be created. This is an optional parameter. Custom modules should keep the batch open, so that the import and export occur during the same session. Note that for high availability, this must be a local path.
Remarks
This is useful for quickly obtaining batch information for individual documents.
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.XMLExportDocuments Method

IBatchXMLExportDocuments Method

Creates an XML runtime file that contains ONLY document information for a range of documents.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void XMLExportDocuments(
    string strXMLRuntimeFileName,
    int nFirstDoc,
    int nLastDoc = -1
)
Sub XMLExportDocuments (
    strXMLRuntimeFileName As String,
    nFirstDoc As Integer,
    Optional nLastDoc As Integer = -1
)

Parameters

strXMLRuntimeFileName
Type: SystemString
The full path and name for the XML runtime file that will contain the output XML. Note that for high availability, this must be a local path.
nFirstDoc
Type: SystemInt32
The first document for document range. This is the order number and starts at 1. To export all documents, set this to -1.
nLastDoc (Optional)
Type: SystemInt32
The last document for range. If this is not set or if it is the same as the first document, only one document will be exported.
Remarks

The documents may not be deleted. The document changes must be imported without any changes to the existing batch information.

This method is not supported when used on batches with folders. Calling this method on such a batch raises an error.

See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.XMLImport Method

IBatchXMLImport Method

Updates the batch from the XML runtime file.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void XMLImport(
    string strXMLRuntimeFileName
)
Sub XMLImport (
    strXMLRuntimeFileName As String
)

Parameters

strXMLRuntimeFileName
Type: SystemString
The full path and name for the XML runtime file to import. Note that for high availability, this must be a local path.
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.XMLImportBatchOnly Method

IBatchXMLImportBatchOnly Method

Reads runtime batch information from the XML file.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void XMLImportBatchOnly(
    string strXMLRuntimeFileName
)
Sub XMLImportBatchOnly (
    strXMLRuntimeFileName As String
)

Parameters

strXMLRuntimeFileName
Type: SystemString
The full path and name of the XML file containing runtime batch information. Note that for high availability, this must be a local path.
Remarks
The batch information must be imported into the same batch from which it was exported.

This XML file is designed for use with XML document import/export to quickly provide the active batch information.
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.XMLImportDocuments Method

IBatchXMLImportDocuments Method

Reads an XML runtime document file and replaces the information in the database file.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void XMLImportDocuments(
    string strXMLRuntimeFileName,
    int nFirstDoc = -1,
    int nLastDoc = -1
)
Sub XMLImportDocuments (
    strXMLRuntimeFileName As String,
    Optional nFirstDoc As Integer = -1,
    Optional nLastDoc As Integer = -1
)

Parameters

strXMLRuntimeFileName
Type: SystemString
The full path and name of XML document runtime file to import. Note that for high availability, this must be a local path.
nFirstDoc (Optional)
Type: SystemInt32
This optional parameter is the first document for the document range (-1 means all).
nLastDoc (Optional)
Type: SystemInt32
This optional parameter is the last document for the document range.
Remarks

The documents must be imported into the same batch from which they were exported. The number of documents may not be changed. Documents may not be deleted or added.

See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch Properties

IBatch Properties

The IBatch type exposes the following members.

Properties
 | Name | Description
Public property | BatchClassName | Returns the name of the batch class.
Public property | BatchFieldValue | The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).
Public property | BatchFieldValueInt32 | The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).
Public property | BatchGUID | Gets the unique ID of this batch.
Public property | BatchId | Returns the batch ID.
Public property | BitonalImageFile | Returns the image file path for a bitonal image based on the image ID.
Public property | CreateDate | Returns the date and time the batch class was created.
Public property | CustomStorageString | The storage string with the specified name.
Public property | DocumentCount | Reads the batch and returns the document count.
Public property | ExternalBatchID | Returns the external batch ID.
Public property | HasError | Returns a Boolean value indicating if the batch has an error.
Public property | ImageDir | Returns the batch image folder.
Public property | ImageFile | Returns an image file path based on the image ID from the page object, to which the extension "TIF" is automatically appended.
Public property | ImageFileWithExt | Returns the image file path based on the image ID from the page object, and the extension of the file.
Public property | LastPublishedDate | The publish date of the batch class used to create this batch.
Public property | Name | Returns the name of the batch.
Public property | OCRDir | Returns the batch OCR folder.
Public property | PageCount | Reads the batch and returns the page count.
Public property | Priority | Returns the batch priority.
Public property | ProcessID | Returns the current process ID.
Public property | PubBatchDefID | Returns the published batch ID.
Public property | ScanStationID | Returns the Scan Station ID for the batch.
Public property | ScanUser | Returns the ID for the user who scanned the batch.
Public property | State | Returns the batch state. Can be mapped to the enumeration for the current state.
Public property | StationID | Returns the ID of the station/user that created the batch.
Top
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.BatchClassName Property

IBatchBatchClassName Property

Returns the name of the batch class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string BatchClassName { get; }
ReadOnly Property BatchClassName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.BatchFieldValue Property

IBatchBatchFieldValue Property
Overload List
 | Name | Description
Public property | BatchFieldValue | The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).
Public property | BatchFieldValueInt32 | The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).
Top
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.BatchFieldValue Property

IBatchBatchFieldValue Property

The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string BatchFieldValue { get; }
ReadOnly Property BatchFieldValue As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
To use this method, a filter must have been previously set by a call to SetBatchFilter. The specified batch filter will be applied when determining which batch to retrieve.
See Also

Reference

IBatch Interface
BatchFieldValue Overload
Kofax.Capture.SDK.CustomModule Namespace


IBatch.BatchFieldValue Property (Int32)

IBatchBatchFieldValue Property (Int32)
Kofax Capture API Reference

The value of the batch field set for filtering when Batch Filter is enabled. Note that this value is only set for batches that are retrieved from the BatchCollection object, and only when batch filter is applied (such as a call to BatchCollectionFiltered).

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    int index
] { get; }
ReadOnly Property BatchFieldValue (
    index As Integer
) As String
    Get

Parameters

index
Type: SystemInt32

Property Value

Type: String

Return Value

Type: String
String
Remarks
To use this method, a filter must have been previously set by a call to SetBatchFilter. The specified batch filter will be applied when determining which batch to retrieve.
See Also

Reference

IBatch Interface
BatchFieldValue Overload
Kofax.Capture.SDK.CustomModule Namespace


IBatch.BatchGUID Property

IBatchBatchGUID Property

Gets the unique ID of this batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string BatchGUID { get; }
ReadOnly Property BatchGUID As String
    Get

Property Value

Type: String
Unique ID String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.BatchId Property

IBatchBatchId Property

Returns the batch ID.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int BatchId { get; }
ReadOnly Property BatchId As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.BitonalImageFile Property

IBatchBitonalImageFile Property

Returns the image file path for a bitonal image based on the image ID.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    int nImageID
] { get; }
ReadOnly Property BitonalImageFile (
    nImageID As Integer
) As String
    Get

Parameters

nImageID
Type: SystemInt32
The image ID from a page object.

Property Value

Type: String

Return Value

Type: String
String
Remarks

This function returns a file name, even if the file does not exist.

Custom modules that modify the color image should usually be inserted before Recognition Server, and custom modules that require a bitonal image must be placed after Recognition Server. This must be enforced by the custom module's registration (.aex) file.

See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.CreateDate Property

IBatchCreateDate Property

Returns the date and time the batch class was created.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string CreateDate { get; }
ReadOnly Property CreateDate As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.CustomStorageString Property

IBatchCustomStorageString Property

The storage string with the specified name.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property CustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString

Property Value

Type: String

Return Value

Type: String
String
Remarks

Custom Storage strings are custom text strings that are bound to a specific batch. The name of a string is user-definable, but must be unique from names used by other customizations to avoid being overwritten. Use unique names such as "company.product.dataname" (for example, "Kofax.KofaxCapture.SpecialFlag").

The maximum length for this string is 255 characters for a name or unlimited for a value. If set to an empty string, the storage string is deleted.

This function throws:(KfxApiErrBadParameterRange) if getting a storage string that does not exist, or if setting to a value that is too large.

See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.DocumentCount Property

IBatchDocumentCount Property

Reads the batch and returns the document count.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int DocumentCount { get; }
ReadOnly Property DocumentCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
The batch must be locked to get the count.
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ExternalBatchID Property

IBatchExternalBatchID Property

Returns the external batch ID.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ExternalBatchID { get; }
ReadOnly Property ExternalBatchID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks

Time-consuming: read on demand.

May fail if batch has been deleted or locked.

See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.HasError Property

IBatchHasError Property

Returns a Boolean value indicating if the batch has an error.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool HasError { get; }
ReadOnly Property HasError As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ImageDir Property

IBatchImageDir Property

Returns the batch image folder.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ImageDir { get; }
ReadOnly Property ImageDir As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
The batch must be open to read this property.
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ImageFile Property

IBatchImageFile Property

Returns an image file path based on the image ID from the page object, to which the extension "TIF" is automatically appended.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    int nImageID
] { get; }
ReadOnly Property ImageFile (
    nImageID As Integer
) As String
    Get

Parameters

nImageID
Type: SystemInt32
The image ID from a page object.

Property Value

Type: String

Return Value

Type: String
String
Remarks
The batch must be open to read this property.

Use this property if the page you are processing is an image file. When processing an eDocument, use ImageFileWithExt rather than ImageFile.

See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ImageFileWithExt Property

IBatchImageFileWithExt Property

Returns the image file path based on the image ID from the page object, and the extension of the file.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    int nImageID,
    string strExt
] { get; }
ReadOnly Property ImageFileWithExt (
    nImageID As Integer,
    strExt As String
) As String
    Get

Parameters

nImageID
Type: SystemInt32
The image ID from a page object.
strExt
Type: SystemString
The file extension.

Property Value

Type: String

Return Value

Type: String
Remarks
The batch must be opened to read this property.
Use this property if the page you are processing is an eDocument. For this case, the Extension attribute will be available from the Page object, and contain the extension of the file.
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.LastPublishedDate Property

IBatchLastPublishedDate Property

The publish date of the batch class used to create this batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string LastPublishedDate { get; }
ReadOnly Property LastPublishedDate As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks

The batch must be open to read this property.

This property is used for versioning.

May fail if batch has been deleted or locked.

See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.Name Property

IBatchName Property

Returns the name of the batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.OCRDir Property

IBatchOCRDir Property

Returns the batch OCR folder.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string OCRDir { get; }
ReadOnly Property OCRDir As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
The batch must be open to read this property.
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.PageCount Property

IBatchPageCount Property

Reads the batch and returns the page count.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int PageCount { get; }
ReadOnly Property PageCount As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
The batch must be locked to get the count.
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.Priority Property

IBatchPriority Property

Returns the batch priority.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Priority { get; }
ReadOnly Property Priority As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ProcessID Property

IBatchProcessID Property

Returns the current process ID.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ProcessID { get; }
ReadOnly Property ProcessID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.PubBatchDefID Property

IBatchPubBatchDefID Property

Returns the published batch ID.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int PubBatchDefID { get; }
ReadOnly Property PubBatchDefID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ScanStationID Property

IBatchScanStationID Property

Returns the Scan Station ID for the batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ScanStationID { get; }
ReadOnly Property ScanStationID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.ScanUser Property

IBatchScanUser Property

Returns the ID for the user who scanned the batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ScanUser { get; }
ReadOnly Property ScanUser As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.State Property

IBatchState Property

Returns the batch state. Can be mapped to the enumeration for the current state.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int State { get; }
ReadOnly Property State As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatch.StationID Property

IBatchStationID Property

Returns the ID of the station/user that created the batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string StationID { get; }
ReadOnly Property StationID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatch Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchCollection Interface

IBatchCollection Interface
Defines a collection of batch objects.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IBatchCollection : IEnumerable,
    IDisposable
Public Interface IBatchCollection
    Inherits IEnumerable, IDisposable

The IBatchCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Refresh | Deletes the current collection and returns a new one.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
Each batch object has data that can be obtained quickly, along with data that takes longer to obtain. Each object supports XML import and export, for which BatchOpen must be called to lock the batch.
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


IBatchCollection Methods

IBatchCollection Methods

The IBatchCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Refresh | Deletes the current collection and returns a new one.
Top
See Also

Reference

IBatchCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchCollection.Refresh Method

IBatchCollectionRefresh Method

Deletes the current collection and returns a new one.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Refresh(
    KfxDbFilter eFilterOptions,
    int nProcessID,
    KfxDbState eStates,
    bool bUserFilter = true
)
Sub Refresh (
    eFilterOptions As KfxDbFilter,
    nProcessID As Integer,
    eStates As KfxDbState,
    Optional bUserFilter As Boolean = true
)

Parameters

eFilterOptions
Type: Kofax.Capture.SDK.CustomModuleKfxDbFilter
You can specify options to limit the search scope, and/or specify sort criteria.
nProcessID
Type: SystemInt32
This parameter can be obtained from the Login object.
eStates
Type: Kofax.Capture.SDK.CustomModuleKfxDbState
If filtering on States is specified, this parameter must be passed as a nonzero value that contains a bitmask of the available States. Only batches that match the eStates mask will be considered.
bUserFilter (Optional)
Type: SystemBoolean
If this parameter is False, the collection will include all batches, even if the user does not have rights to them.
Remarks
The collection returned may become quickly out of date if batches are processed at multiple sites.
See Also

Reference

IBatchCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchCollection Properties

IBatchCollection Properties

The IBatchCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IBatchCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchCollection.Count Property

IBatchCollectionCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatchCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchCollection.Item Property

IBatchCollectionItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IBatch
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IBatch

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch
Remarks
See Also

Reference

IBatchCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchFieldNamesCollection Interface

IBatchFieldNamesCollection Interface

Defines a collection of batch field names.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IBatchFieldNamesCollection : IEnumerable,
    IDisposable
Public Interface IBatchFieldNamesCollection
    Inherits IEnumerable, IDisposable

The IBatchFieldNamesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Refresh | Deletes the current collection and returns a new one.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


IBatchFieldNamesCollection Methods

IBatchFieldNamesCollection Methods

The IBatchFieldNamesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Refresh | Deletes the current collection and returns a new one.
Top
See Also

Reference

IBatchFieldNamesCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchFieldNamesCollection.Refresh Method

IBatchFieldNamesCollectionRefresh Method

Deletes the current collection and returns a new one.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Refresh(
    bool bUserFilter = true
)
Sub Refresh (
    Optional bUserFilter As Boolean = true
)

Parameters

bUserFilter (Optional)
Type: SystemBoolean
If this parameter is False, the collection will include all batch field names, even if the user does not have rights to their batch classes.
Remarks
The collection returned may become quickly obsolete if the administrator publishes batch classes or disables them.
See Also

Reference

IBatchFieldNamesCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchFieldNamesCollection Properties

IBatchFieldNamesCollection Properties

The IBatchFieldNamesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IBatchFieldNamesCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchFieldNamesCollection.Count Property

IBatchFieldNamesCollectionCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatchFieldNamesCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchFieldNamesCollection.Item Property

IBatchFieldNamesCollectionItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As String
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchFieldNamesCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchFieldValuesCollection Interface

IBatchFieldValuesCollection Interface

Defines a collection of batch field values.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IBatchFieldValuesCollection : IEnumerable,
    IDisposable
Public Interface IBatchFieldValuesCollection
    Inherits IEnumerable, IDisposable

The IBatchFieldValuesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Refresh | Deletes the current collection and returns a new one.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


IBatchFieldValuesCollection Methods

IBatchFieldValuesCollection Methods

The IBatchFieldValuesCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Refresh | Deletes the current collection and returns a new one.
Top
See Also

Reference

IBatchFieldValuesCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchFieldValuesCollection.Refresh Method

IBatchFieldValuesCollectionRefresh Method

Deletes the current collection and returns a new one.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Refresh(
    string strBatchFieldName
)
Sub Refresh (
    strBatchFieldName As String
)

Parameters

strBatchFieldName
Type: SystemString
If this parameter is False, the collection will include all batch field names, even if the user does not have rights to their batch classes.
Remarks
The collection returned may become quickly obsolete if the administrator publishes batch classes or disables them.
See Also

Reference

IBatchFieldValuesCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchFieldValuesCollection Properties

IBatchFieldValuesCollection Properties

The IBatchFieldValuesCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IBatchFieldValuesCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchFieldValuesCollection.Count Property

IBatchFieldValuesCollectionCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IBatchFieldValuesCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IBatchFieldValuesCollection.Item Property

IBatchFieldValuesCollectionItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As String
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IBatchFieldValuesCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin Interface

ILogin Interface

The Login object forms the basis of the entire hierarchy. The properties of Login are used for error logging. A Login object should be maintained until the calling application shuts down; additional Login objects should not be introduced while the calling application is open.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface ILogin : IDisposable
Public Interface ILogin
    Inherits IDisposable

The ILogin type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | Login | Logs into the system.
Public method | Logout | Cleans up internal references and releases the station license.
Public method | ValidateUser | Validates the user for profiles.
Top
Properties
 | Name | Description
Public property | ApplicationName | Used in error logging.
Public property | EnableSecurityBoost | Enables SecurityBoost if it is enabled globally. By default, SecurityBoost is disabled.
Public property | ProcessID | Returns the process ID used to obtain the runtime session. Available after calling the ValidateUser method.
Public property | RuntimeSession | Returns the RuntimeSession object which is used to access other objects.
Public property | Version | Used in error logging.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


ILogin Methods

ILogin Methods

The ILogin type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | Login | Logs into the system.
Public method | Logout | Cleans up internal references and releases the station license.
Public method | ValidateUser | Validates the user for profiles.
Top
See Also

Reference

ILogin Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin.LogError Method

ILoginLogError Method

Logs an error to the Tungsten Capture error log.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void LogError(
    ref int nErrCode1,
    ref int nErrCode2,
    ref int nErrCode3,
    ref string strSource,
    ref int nLineNum,
    ref string strDesc,
    ref bool bRaise = false
)
Sub LogError (
    ByRef nErrCode1 As Integer,
    ByRef nErrCode2 As Integer,
    ByRef nErrCode3 As Integer,
    ByRef strSource As String,
    ByRef nLineNum As Integer,
    ByRef strDesc As String,
    Optional ByRef bRaise As Boolean = false
)

Parameters

nErrCode1
Type: SystemInt32
The primary error code.
nErrCode2
Type: SystemInt32
Subcode.
nErrCode3
Type: SystemInt32
Subcode.
strSource
Type: SystemString
The source code module where the problem occurred.
nLineNum
Type: SystemInt32
The line number within the source where the problem exists.
strDesc
Type: SystemString
The string message.
bRaise (Optional)
Type: SystemBoolean
If bRaise is True, the error will be re-raised after it is logged.
Remarks
See Also

Reference

ILogin Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin.Login Method

ILoginLogin Method

Logs into the system.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Login(
    string strRes1 = "",
    string strRes2 = ""
)
Sub Login (
    Optional strRes1 As String = "",
    Optional strRes2 As String = ""
)

Parameters

strRes1 (Optional)
Type: SystemString
This parameter is reserved.
strRes2 (Optional)
Type: SystemString
This parameter is reserved.
Remarks
See Also

Reference

ILogin Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin.Logout Method

ILoginLogout Method

Cleans up internal references and releases the station license.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Logout()
Sub Logout
Remarks
See Also

Reference

ILogin Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin.ValidateUser Method

ILoginValidateUser Method

Validates the user for profiles.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void ValidateUser(
    string strUniqueID,
    bool bShowDlg = true,
    string strUserID = "",
    string strPwd = ""
)
Sub ValidateUser (
    strUniqueID As String,
    Optional bShowDlg As Boolean = true,
    Optional strUserID As String = "",
    Optional strPwd As String = ""
)

Parameters

strUniqueID
Type: SystemString
Set this parameter to the module ID of the custom module. If the module has not been registered, an error will be raised. Otherwise, the ProcessID property will be set with the process ID for the module.
bShowDlg (Optional)
Type: SystemBoolean
If this parameter is True, a dialog will prompt for user ID and password when user profiles are enabled. Set to False to validate an ID and password you have already obtained.
strUserID (Optional)
Type: SystemString
The user ID.
strPwd (Optional)
Type: SystemString
The user password.
Remarks
See Also

Reference

ILogin Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin Properties

ILogin Properties

The ILogin type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Used in error logging.
Public property | EnableSecurityBoost | Enables SecurityBoost if it is enabled globally. By default, SecurityBoost is disabled.
Public property | ProcessID | Returns the process ID used to obtain the runtime session. Available after calling the ValidateUser method.
Public property | RuntimeSession | Returns the RuntimeSession object which is used to access other objects.
Public property | Version | Used in error logging.
Top
See Also

Reference

ILogin Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin.ApplicationName Property

ILoginApplicationName Property

Used in error logging.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ApplicationName { get; set; }
Property ApplicationName As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String - may be empty.
Remarks
See Also

Reference

ILogin Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin.EnableSecurityBoost Property

ILoginEnableSecurityBoost Property

Enables SecurityBoost if it is enabled globally. By default, SecurityBoost is disabled.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool EnableSecurityBoost { get; set; }
Property EnableSecurityBoost As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

This property always defaults to "False," even if SecurityBoost is enabled globally.

Setting the property to "true" only enables SecurityBoost if it is enabled for the entire system. Otherwise, the property is still set to "True," but SecurityBoost does not take effect.

This property can be read at any time, but can only be written before logging in (with the Login method). Attempting to write it at any other time causes an error.

See Also

Reference

ILogin Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin.ProcessID Property

ILoginProcessID Property

Returns the process ID used to obtain the runtime session. Available after calling the ValidateUser method.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ProcessID { get; }
ReadOnly Property ProcessID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks

The ProcessID for a custom module must be unique from the ProcessID assigned to the Tungsten Capture standard processing modules, as listed below:

  • Batch Manager: 8
  • Kofax PDF Generator: 14999
  • OCR Full Text: 6
  • Quality Control: 2
  • Recognition Server: 3
  • Export: 7
  • Scan: 1
  • Validation: 4
  • Verification: 5
See Also

Reference

ILogin Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin.RuntimeSession Property

ILoginRuntimeSession Property

Returns the RuntimeSession object which is used to access other objects.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRuntimeSession RuntimeSession { get; }
ReadOnly Property RuntimeSession As IRuntimeSession
    Get

Property Value

Type: IRuntimeSession

Return Value

Type: IRuntimeSession
Kofax.Capture.SDK.CustomModule.IRuntimeSession
Remarks
There is only 1 RuntimeSession per login. Be sure to call ValidateUser before getting the RuntimeSession.
See Also

Reference

ILogin Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin.Version Property

ILoginVersion Property

Used in error logging.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Version { get; set; }
Property Version As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String - may be empty.
Remarks
See Also

Reference

ILogin Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2 Interface

ILogin2 Interface

The Login object forms the basis of the entire hierarchy. The properties of Login are used for error logging. A Login object should be maintained until the calling application shuts down; additional Login objects should not be introduced while the calling application is open.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface ILogin2 : IDisposable
Public Interface ILogin2
    Inherits IDisposable

The ILogin2 type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | Login | Logs into the system.
Public method | Logout | Cleans up internal references and releases the station license.
Public method | ValidateUser | Validates the user for profiles.
Public method | ValidateUser2 | Validates the user for profiles.
Top
Properties
 | Name | Description
Public property | ApplicationName | Used in error logging.
Public property | EnableReporting | Enables/Disables reporting for Custom Module. This is enabled by default.
Public property | EnableSecurityBoost | Enables SecurityBoost if it is enabled globally. By default, SecurityBoost is disabled.
Public property | ProcessID | Returns the process ID used to obtain the runtime session. Available after calling the ValidateUser method.
Public property | RuntimeSession | Returns the RuntimeSession object, which is used to access other objects.
Public property | SharedUserProfileModel | Gets or sets the shared user profile model.
Public property | SupportUserChanged | Indicates that the custom module supports the feature to track user interactions related to index fields and batch fields.
Public property | Version | Used in error logging.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


ILogin2 Methods

ILogin2 Methods

The ILogin2 type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | LogError | Logs an error to the Tungsten Capture error log.
Public method | Login | Logs into the system.
Public method | Logout | Cleans up internal references and releases the station license.
Public method | ValidateUser | Validates the user for profiles.
Public method | ValidateUser2 | Validates the user for profiles.
Top
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2.LogError Method

ILogin2LogError Method

Logs an error to the Tungsten Capture error log.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void LogError(
    ref int nErrCode1,
    ref int nErrCode2,
    ref int nErrCode3,
    ref string strSource,
    ref int nLineNum,
    ref string strDesc,
    ref bool bRaise = false
)
Sub LogError (
    ByRef nErrCode1 As Integer,
    ByRef nErrCode2 As Integer,
    ByRef nErrCode3 As Integer,
    ByRef strSource As String,
    ByRef nLineNum As Integer,
    ByRef strDesc As String,
    Optional ByRef bRaise As Boolean = false
)

Parameters

nErrCode1
Type: SystemInt32
The primary error code.
nErrCode2
Type: SystemInt32
Subcode.
nErrCode3
Type: SystemInt32
Subcode.
strSource
Type: SystemString
The source code module where the problem occurred.
nLineNum
Type: SystemInt32
The line number within the source where the problem exists.
strDesc
Type: SystemString
The string message.
bRaise (Optional)
Type: SystemBoolean
If bRaise is True, the error will be re-raised after it is logged.
Remarks
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2.Login Method

ILogin2Login Method

Logs into the system.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Login(
    string strRes1 = "",
    string strRes2 = ""
)
Sub Login (
    Optional strRes1 As String = "",
    Optional strRes2 As String = ""
)

Parameters

strRes1 (Optional)
Type: SystemString
This parameter is reserved.
strRes2 (Optional)
Type: SystemString
This parameter is reserved.
Remarks
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2.Logout Method

ILogin2Logout Method

Cleans up internal references and releases the station license.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Logout()
Sub Logout
Remarks
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2.ValidateUser Method

ILogin2ValidateUser Method

Validates the user for profiles.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void ValidateUser(
    string strUniqueID,
    bool bShowDlg = true,
    string strUserID = "",
    string strPwd = ""
)
Sub ValidateUser (
    strUniqueID As String,
    Optional bShowDlg As Boolean = true,
    Optional strUserID As String = "",
    Optional strPwd As String = ""
)

Parameters

strUniqueID
Type: SystemString
Set this parameter to the module ID of the custom module. If the module has not been registered, an error will be raised. Otherwise, the ProcessID property will be set with the process ID for the module.
bShowDlg (Optional)
Type: SystemBoolean
If this parameter is True, a dialog will prompt for user ID and password when user profiles are enabled. Set to False to validate an ID and password you have already obtained.
strUserID (Optional)
Type: SystemString
The user ID.
strPwd (Optional)
Type: SystemString
The user password.
Remarks
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2.ValidateUser2 Method

ILogin2ValidateUser2 Method

Validates the user for profiles.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void ValidateUser2(
    string strUsername,
    string strPassword
)
Sub ValidateUser2 (
    strUsername As String,
    strPassword As String
)

Parameters

strUsername
Type: SystemString
The user name.
strPassword
Type: SystemString
The user password.
Remarks
Throws LoginException if the user name or password does not match.
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2 Properties

ILogin2 Properties

The ILogin2 type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Used in error logging.
Public property | EnableReporting | Enables/Disables reporting for Custom Module. This is enabled by default.
Public property | EnableSecurityBoost | Enables SecurityBoost if it is enabled globally. By default, SecurityBoost is disabled.
Public property | ProcessID | Returns the process ID used to obtain the runtime session. Available after calling the ValidateUser method.
Public property | RuntimeSession | Returns the RuntimeSession object, which is used to access other objects.
Public property | SharedUserProfileModel | Gets or sets the shared user profile model.
Public property | SupportUserChanged | Indicates that the custom module supports the feature to track user interactions related to index fields and batch fields.
Public property | Version | Used in error logging.
Top
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2.ApplicationName Property

ILogin2ApplicationName Property

Used in error logging.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ApplicationName { get; set; }
Property ApplicationName As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String - may be empty.
Remarks
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2.EnableReporting Property

ILogin2EnableReporting Property

Enables/Disables reporting for Custom Module. This is enabled by default.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool EnableReporting { get; set; }
Property EnableReporting As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Remarks
This property must be set before the Login function is called.
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2.EnableSecurityBoost Property

ILogin2EnableSecurityBoost Property

Enables SecurityBoost if it is enabled globally. By default, SecurityBoost is disabled.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool EnableSecurityBoost { get; set; }
Property EnableSecurityBoost As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks

This property always defaults to "False," even if SecurityBoost is enabled globally.

Setting the property to "true" only enables SecurityBoost if it is enabled for the entire system. Otherwise, the property is still set to "True," but SecurityBoost does not take effect.

This property can be read at any time, but can only be written before logging in (with the Login method). Attempting to write it at any other time causes an error.

See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2.ProcessID Property

ILogin2ProcessID Property

Returns the process ID used to obtain the runtime session. Available after calling the ValidateUser method.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ProcessID { get; }
ReadOnly Property ProcessID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks

The ProcessID for a custom module must be unique from the ProcessID assigned to the Tungsten Capture standard processing modules, as listed below:

  • Batch Manager: 8
  • Kofax PDF Generator: 14999
  • OCR Full Text: 6
  • Quality Control: 2
  • Recognition Server: 3
  • Export: 7
  • Scan: 1
  • Validation: 4
  • Verification: 5
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2.RuntimeSession Property

ILogin2RuntimeSession Property

Returns the RuntimeSession object, which is used to access other objects.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRuntimeSession RuntimeSession { get; }
ReadOnly Property RuntimeSession As IRuntimeSession
    Get

Property Value

Type: IRuntimeSession

Return Value

Type: IRuntimeSession
Kofax.Capture.SDK.CustomModule.IRuntimeSession
Remarks
There is only 1 RuntimeSession per login. Be sure to call ValidateUser before getting the RuntimeSession.
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2.SharedUserProfileModel Property

ILogin2SharedUserProfileModel Property

Gets or sets the shared user profile model.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SharedUserProfileModel { get; set; }
Property SharedUserProfileModel As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean. Returns True if using the shared user profile model.
Remarks
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2.SupportUserChanged Property

ILogin2SupportUserChanged Property
Indicates that the custom module supports the feature to track user interactions related to index fields and batch fields.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SupportUserChanged { get; set; }
Property SupportUserChanged As Boolean
    Get
    Set

Property Value

Type: Boolean

Return Value

Type: Boolean
Remarks
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


ILogin2.Version Property

ILogin2Version Property

Used in error logging.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Version { get; set; }
Property Version As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String - may be empty.
Remarks
See Also

Reference

ILogin2 Interface
Kofax.Capture.SDK.CustomModule Namespace


InvalidArgumentException Class

InvalidArgumentException Class

The exception that is thrown when an invalid argument is passed in.

Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.Runtime.InteropServicesCOMException
Kofax.Capture.SDK.DataKfxException
Kofax.Capture.SDK.CustomModuleInvalidArgumentException

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class InvalidArgumentException : KfxException
Public Class InvalidArgumentException
    Inherits KfxException

The InvalidArgumentException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidArgumentException(String, KfxDbError) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.InvalidArgumentException class.
Public method | InvalidArgumentException(String, KfxDbError, Object) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.InvalidArgumentException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
Remarks
One of the following error numbers should be passed in:
  • KfxDbError.KfxDbInvalidProcessId = 4006 -- Invalid value for process ID
  • KfxDbError.KfxDbInvalidArgument = 4007 -- Invalid parameter
  • KfxDbError.KfxDbInvalidState = 4020 -- Invalid state parameter
  • KfxDbError.KfxDbInvalidFilter = 4021 -- Invalid filter parameter
  • KfxDbError.KfxDbInvalidQueue = 4022
  • KfxDbError.KfxDbInvalidPubBatchDefID = 4042 -- Invalid published batch definition ID
  • KfxDbError.KfxDbWrongProcess = 4012 -- The process id is incorrect
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


InvalidArgumentException Constructor

InvalidArgumentException Constructor
Overload List
 | Name | Description
Public method | InvalidArgumentException(String, KfxDbError) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.InvalidArgumentException class.
Public method | InvalidArgumentException(String, KfxDbError, Object) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.InvalidArgumentException class.
Top
See Also

Reference

InvalidArgumentException Class
Kofax.Capture.SDK.CustomModule Namespace


InvalidArgumentException Constructor (String, KfxDbError)

InvalidArgumentException Constructor (String, KfxDbError)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.CustomModule.InvalidArgumentException class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public InvalidArgumentException(
    string strMsg,
    KfxDbError errNum
)
Public Sub New (
    strMsg As String,
    errNum As KfxDbError
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.CustomModuleKfxDbError
The original Error number.
Remarks
See Also

Reference

InvalidArgumentException Class
InvalidArgumentException Overload
Kofax.Capture.SDK.CustomModule Namespace


InvalidArgumentException Constructor (String, KfxDbError, Object)

InvalidArgumentException Constructor (String, KfxDbError, Object)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.CustomModule.InvalidArgumentException class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public InvalidArgumentException(
    string strMsg,
    KfxDbError errNum,
    Object oSource
)
Public Sub New (
    strMsg As String,
    errNum As KfxDbError,
    oSource As Object
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.CustomModuleKfxDbError
The original Error number.
oSource
Type: SystemObject
The source.
Remarks
See Also

Reference

InvalidArgumentException Class
InvalidArgumentException Overload
Kofax.Capture.SDK.CustomModule Namespace


InvalidArgumentException Methods

InvalidArgumentException Methods

The InvalidArgumentException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
See Also

Reference

InvalidArgumentException Class
Kofax.Capture.SDK.CustomModule Namespace


InvalidArgumentException Properties

InvalidArgumentException Properties

The InvalidArgumentException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
See Also

Reference

InvalidArgumentException Class
Kofax.Capture.SDK.CustomModule Namespace


InvalidOperationException Class

InvalidOperationException Class

Defines the exception that is thrown when an invalid operation is called.

Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.Runtime.InteropServicesCOMException
Kofax.Capture.SDK.DataKfxException
Kofax.Capture.SDK.CustomModuleInvalidOperationException

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class InvalidOperationException : KfxException
Public Class InvalidOperationException
    Inherits KfxException

The InvalidOperationException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidOperationException(String, KfxDbError) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.InvalidOperationException class.
Public method | InvalidOperationException(String, KfxDbError, Object) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.InvalidOperationException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
Remarks
One of the following error numbers should be passed in:
  • KfxDbError.KfxDbNotSupported = 4008 -- Function is not yet supported
  • KfxDbError.KfxDbBatchIsAlreadyLocked = 4009 -- We only allow 1 batch to be locked
  • KfxDbError.KfxDbOnlyOneBatchMayBeLocked = 4010 -- Only 1 batch at a time may be locked
  • KfxDbError.KfxDbBatchIsNotLocked = 4011 -- Batch is not open.
  • KfxDbError.KfxDbObsoleteInterface1 = 4030 -- Interface is obsolete
  • KfxDbError.KfxDbChildBatchStillOpen = 4045 -- Unable to close this batch because a child batch is still open
  • KfxDbError.KfxDbCannotCreateChildFromChildBatch = 4047 -- Cannot create child batch from an active child batch.
  • KfxDbError.KfxDbAlreadyLoggedOut = 4044 '*** %s cannot be called after Logout. Create a new Login object or ensure Logout is the last function called by the application.
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


InvalidOperationException Constructor

InvalidOperationException Constructor
Overload List
 | Name | Description
Public method | InvalidOperationException(String, KfxDbError) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.InvalidOperationException class.
Public method | InvalidOperationException(String, KfxDbError, Object) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.InvalidOperationException class.
Top
See Also

Reference

InvalidOperationException Class
Kofax.Capture.SDK.CustomModule Namespace


InvalidOperationException Constructor (String, KfxDbError)

InvalidOperationException Constructor (String, KfxDbError)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.CustomModule.InvalidOperationException class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public InvalidOperationException(
    string strMsg,
    KfxDbError errNum
)
Public Sub New (
    strMsg As String,
    errNum As KfxDbError
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.CustomModuleKfxDbError
The original Error number.
Remarks
See Also

Reference

InvalidOperationException Class
InvalidOperationException Overload
Kofax.Capture.SDK.CustomModule Namespace


InvalidOperationException Constructor (String, KfxDbError, Object)

InvalidOperationException Constructor (String, KfxDbError, Object)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.CustomModule.InvalidOperationException class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public InvalidOperationException(
    string strMsg,
    KfxDbError errNum,
    Object oSource
)
Public Sub New (
    strMsg As String,
    errNum As KfxDbError,
    oSource As Object
)

Parameters

strMsg
Type: SystemString
The error message
errNum
Type: Kofax.Capture.SDK.CustomModuleKfxDbError
The original Error number
oSource
Type: SystemObject
The source
Remarks
See Also

Reference

InvalidOperationException Class
InvalidOperationException Overload
Kofax.Capture.SDK.CustomModule Namespace


InvalidOperationException Methods

InvalidOperationException Methods

The InvalidOperationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
See Also

Reference

InvalidOperationException Class
Kofax.Capture.SDK.CustomModule Namespace


InvalidOperationException Properties

InvalidOperationException Properties

The InvalidOperationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
See Also

Reference

InvalidOperationException Class
Kofax.Capture.SDK.CustomModule Namespace


IProcess Interface

IProcess Interface

Defines a process object that holds information about a Tungsten Capture standard process.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IProcess : IDisposable
Public Interface IProcess
    Inherits IDisposable

The IProcess type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Top
Properties
 | Name | Description
Public property | CommandLineParameters | Returns the command line parameters for process.
Public property | Description | Returns the process description.
Public property | FilterName | Returns the process filter name.
Public property | ImageIndex | Returns the index of process icons.
Public property | Name | Returns the name displayed for this process.
Public property | ProcessID | Returns unique ID of the process. This is the number used in calls requiring a process ID.
Public property | Program | Returns the process executable name with the .exe extension.
Public property | SetupCommandLineParameters | Returns the command line parameters for setup program.
Public property | SetupProgram | Returns the path to process the setup executable file (OCX).
Public property | UniqueID | Returns the unique ID of the process.
Public property | VersionNumber | Returns the version of the process.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


IProcess Methods

IProcess Methods

The IProcess type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Top
See Also

Reference

IProcess Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcess Properties

IProcess Properties

The IProcess type exposes the following members.

Properties
 | Name | Description
Public property | CommandLineParameters | Returns the command line parameters for process.
Public property | Description | Returns the process description.
Public property | FilterName | Returns the process filter name.
Public property | ImageIndex | Returns the index of process icons.
Public property | Name | Returns the name displayed for this process.
Public property | ProcessID | Returns unique ID of the process. This is the number used in calls requiring a process ID.
Public property | Program | Returns the process executable name with the .exe extension.
Public property | SetupCommandLineParameters | Returns the command line parameters for setup program.
Public property | SetupProgram | Returns the path to process the setup executable file (OCX).
Public property | UniqueID | Returns the unique ID of the process.
Public property | VersionNumber | Returns the version of the process.
Top
See Also

Reference

IProcess Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcess.CommandLineParameters Property

IProcessCommandLineParameters Property

Returns the command line parameters for process.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string CommandLineParameters { get; }
ReadOnly Property CommandLineParameters As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IProcess Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcess.Description Property

IProcessDescription Property

Returns the process description.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Description { get; }
ReadOnly Property Description As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IProcess Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcess.FilterName Property

IProcessFilterName Property

Returns the process filter name.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string FilterName { get; }
ReadOnly Property FilterName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IProcess Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcess.ImageIndex Property

IProcessImageIndex Property

Returns the index of process icons.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ImageIndex { get; }
ReadOnly Property ImageIndex As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IProcess Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcess.Name Property

IProcessName Property

Returns the name displayed for this process.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IProcess Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcess.ProcessID Property

IProcessProcessID Property

Returns unique ID of the process. This is the number used in calls requiring a process ID.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ProcessID { get; }
ReadOnly Property ProcessID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IProcess Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcess.Program Property

IProcessProgram Property

Returns the process executable name with the .exe extension.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Program { get; }
ReadOnly Property Program As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IProcess Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcess.SetupCommandLineParameters Property

IProcessSetupCommandLineParameters Property

Returns the command line parameters for setup program.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string SetupCommandLineParameters { get; }
ReadOnly Property SetupCommandLineParameters As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IProcess Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcess.SetupProgram Property

IProcessSetupProgram Property

Returns the path to process the setup executable file (OCX).

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string SetupProgram { get; }
ReadOnly Property SetupProgram As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IProcess Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcess.UniqueID Property

IProcessUniqueID Property

Returns the unique ID of the process.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string UniqueID { get; }
ReadOnly Property UniqueID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IProcess Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcess.VersionNumber Property

IProcessVersionNumber Property

Returns the version of the process.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int VersionNumber { get; }
ReadOnly Property VersionNumber As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IProcess Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcessCollection Interface

IProcessCollection Interface

Defines a collection that identifies the different queues in the system. Custom modules will find their process IDs in the collection and use them for getting batches and constructing the "where" clause for the BatchCollection.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IProcessCollection : IEnumerable,
    IDisposable
Public Interface IProcessCollection
    Inherits IEnumerable, IDisposable

The IProcessCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Refresh | The collection returned may become out of date. The refresh destroys the current collection and returns a new one.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Public property | RuntimeSession | The runtime session that created the collection.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


IProcessCollection Methods

IProcessCollection Methods

The IProcessCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Refresh | The collection returned may become out of date. The refresh destroys the current collection and returns a new one.
Top
See Also

Reference

IProcessCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcessCollection.Refresh Method

IProcessCollectionRefresh Method

The collection returned may become out of date. The refresh destroys the current collection and returns a new one.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Refresh()
Sub Refresh
Remarks
See Also

Reference

IProcessCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcessCollection Properties

IProcessCollection Properties

The IProcessCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Public property | RuntimeSession | The runtime session that created the collection.
Top
See Also

Reference

IProcessCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcessCollection.Count Property

IProcessCollectionCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IProcessCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcessCollection.Item Property

IProcessCollectionItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IProcess this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IProcess
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IProcess

Return Value

Type: IProcess
Kofax.Capture.SDK.CustomModule.IProcess
Remarks
See Also

Reference

IProcessCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IProcessCollection.RuntimeSession Property

IProcessCollectionRuntimeSession Property

The runtime session that created the collection.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IRuntimeSession RuntimeSession { set; }
WriteOnly Property RuntimeSession As IRuntimeSession
    Set

Property Value

Type: IRuntimeSession
The runtime session to set.
Remarks
Must be set before calling Refresh.
See Also

Reference

IProcessCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IPublishedBatchClass Interface

IPublishedBatchClass Interface
Defines information for published batch class event.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IPublishedBatchClass : IDisposable
Public Interface IPublishedBatchClass
    Inherits IDisposable

The IPublishedBatchClass type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the published batch class.
Top
Remarks
There is no guarantee that the batch class will not be deleted or republished. New batch classes may also be published while using this object.
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


IPublishedBatchClass Methods

IPublishedBatchClass Methods

The IPublishedBatchClass type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Top
See Also

Reference

IPublishedBatchClass Interface
Kofax.Capture.SDK.CustomModule Namespace


IPublishedBatchClass Properties

IPublishedBatchClass Properties

The IPublishedBatchClass type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the published batch class.
Top
See Also

Reference

IPublishedBatchClass Interface
Kofax.Capture.SDK.CustomModule Namespace


IPublishedBatchClass.Name Property

IPublishedBatchClassName Property
Gets or sets the name of the published batch class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; set; }
Property Name As String
    Get
    Set

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IPublishedBatchClass Interface
Kofax.Capture.SDK.CustomModule Namespace


IPublishedBatchClassCollection Interface

IPublishedBatchClassCollection Interface

Defines a collection of IPublishedBatchClass objects.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IPublishedBatchClassCollection : IEnumerable,
    IDisposable
Public Interface IPublishedBatchClassCollection
    Inherits IEnumerable, IDisposable

The IPublishedBatchClassCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Refresh | Deletes the current collection and returns a new one.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


IPublishedBatchClassCollection Methods

IPublishedBatchClassCollection Methods

The IPublishedBatchClassCollection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Refresh | Deletes the current collection and returns a new one.
Top
See Also

Reference

IPublishedBatchClassCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IPublishedBatchClassCollection.Refresh Method

IPublishedBatchClassCollectionRefresh Method

Deletes the current collection and returns a new one.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Refresh(
    ref bool bUserFilter = true
)
Sub Refresh (
    Optional ByRef bUserFilter As Boolean = true
)

Parameters

bUserFilter (Optional)
Type: SystemBoolean
If this parameter is False, the collection will include all batch classes, even if the user does not have rights to them.
Remarks
The collection returned may become quickly obsolete if the administrator publishes batch classes or disables them.
See Also

Reference

IPublishedBatchClassCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IPublishedBatchClassCollection Properties

IPublishedBatchClassCollection Properties

The IPublishedBatchClassCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of items in the collection.
Public property | Item | Retrieves an object from the collection, by index or by key.
Top
See Also

Reference

IPublishedBatchClassCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IPublishedBatchClassCollection.Count Property

IPublishedBatchClassCollectionCount Property

Returns the number of items in the collection.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IPublishedBatchClassCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IPublishedBatchClassCollection.Item Property

IPublishedBatchClassCollectionItem Property

Retrieves an object from the collection, by index or by key.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPublishedBatchClass this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IPublishedBatchClass
    Get

Parameters

vntIndexKey
Type: SystemObject
The object's index or key.

Property Value

Type: IPublishedBatchClass

Return Value

Type: IPublishedBatchClass
Kofax.Capture.SDK.CustomModule.IPublishedBatchClass
Remarks
See Also

Reference

IPublishedBatchClassCollection Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession Interface

IRuntimeSession Interface

This interface is required to gain access to any of the other objects in the hierarchy.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IRuntimeSession : IDisposable
Public Interface IRuntimeSession
    Inherits IDisposable

The IRuntimeSession type exposes the following members.

Methods
Name | Description
Public method AssignHandler

Assigns handle of the window that will be processed WM_QUERRYENDSESSION and shows custom warning message when session timeout is reached.

Public method BatchCreate

Creates, opens, or locks a batch.

Public method BatchCreate2

Creates, opens, or locks a batch.

Public method BatchOpen

Opens or locks the available batch with ID for the process.

Public method CanFilterOnBatchField

Returns a Boolean value indicating if filtering on batch field is available.

Public method CustomDataFolder

Returns a global custom data path based on the provided module ID.

Public method | Dispose | (Inherited from IDisposable.)
Public method LogMonitoringMessage

Logs a string that can be retrieved via SNMP.

Public method NextBatchFilteredGet

Extends the base method NextBatchGet to allow filtering.

Public method NextBatchGet

Opens or locks the next available batch for the process.

Public method SetBatchFilter

Sets the batch filter definition to be used by the NextBatchFilteredGet and BatchCollectionFiltered methods.

The XML string that defines the filter.

The Filter string contains a root element FilterCriteriaList. The FilterCriteriaList contains one or more FilterCriteria child elements and one FilteringEnabled child element.

FilterCriteria element

  • Name – Must be present. Must be one of the following names:
    - Batch name
    - Batch class
    - Queue
    - Status
    - Priority
    - Has error
    - Station ID
    - Batch creation date/time
    - Batch field
    - Scan station ID
    - Scan user
    - Reserved01

  • BatchField - A batch field name. Only used if Name is "Batch field".

  • Operator – Must be present. You must select from the following list of supported operators:
    - Contains
    - Equal to
    - Not equal to
    - Greater than
    - Less than
    - Starts with
    - Same date as
    - Bit and (supported for the Reserved01 KTM module bitfield criteria)

  • Value – A value used by this criteria. The data type must correspond to the specified criteria. All criteria except "Batch class" should only have one value.
  • ValueList – A list of values for this criteria. The value list must have one or more child Value elements. "Batch class" criteria is the only criteria that supports the ValueList.

FilteringEnabled element
  • Must be true or false
  • If true, filter criteria will be used to filter batches.
  • If false, filter criteria will be ignored and batches will be unfiltered.

An example of an XML Filter String is as follows:

<?xml version="1.0" encoding="utf-16"?>

<FilterCriteriaList xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<FilterCriteria>

<Name>Status</Name>

<BatchField />

<Operator>Equal to</Operator>

<Value>2</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Queue</Name>

<BatchField />

<Operator>Equal to</Operator>

<Value>3</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Station ID</Name>

<BatchField />

<Operator>Contains</Operator>

<Value>mystation</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Batch class</Name>

<BatchField />

<Operator>Contains</Operator>

<ValueList>

<Value>bc1</Value>

<Value>bc2</Value>

<Value>bc2plus</Value>

<Value>bc3</Value>

</ValueList>

</FilterCriteria>

<FilterCriteria>

<Name>Batch creation date/time</Name>

<BatchField />

<Operator>Less than</Operator>

<Value>2010-12-02 14:30:50</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Batch name</Name>

<BatchField />

<Operator>Contains</Operator>

<Value>MyBatchName</Value>

</FilterCriteria>

<FilteringEnabled>true</FilteringEnabled>

</FilterCriteriaList>

Top
Properties
 | Name | Description
Public property | BatchCollection | Returns the active batch information.
Public property | BatchCollectionFiltered | Extends the base property BatchCollection to allow filtering. This property will make use of a filter that was previously set in a call to SetBatchFilter property
Public property | BatchFieldNamesCollection | Allows for the retrieval of a list of batch field names.
Public property | BatchFieldValuesCollection | Allows for the retrieval of a list of batch field values for a specified batch field name.
Public property | ImportExportLog | Sets the log file name for XML logging.
Public property | InstallPath | Returns the location of the Tungsten Capture server.
Public property | ProcessCollection | Returns a collection of process objects.
Public property | ProcessID | Gets or sets the next process ID.
Public property | PublishedBatchClassCollection | Returns a collection of published batch classes.
Public property | ScanEnabled | Returns True if scanning is allowed.
Public property | ServicePackVersion | Returns the currently installed service pack.
Public property | StationID | Returns the current Tungsten Capture station ID.
Public property | UserID | Returns the ID of currently logged in user.
Public property | UserName | Returns the name of currently logged in user.
Top
Events
 | Name | Description
Public event | BatchAvailable | Event to to notify that a batch is available for processing in the next queue.
Public event | OnSessionTimeOut | Event to notify that the current session is timed out.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession Methods

IRuntimeSession Methods

The IRuntimeSession type exposes the following members.

Methods
Name | Description
Public method AssignHandler

Assigns handle of the window that will be processed WM_QUERRYENDSESSION and shows custom warning message when session timeout is reached.

Public method BatchCreate

Creates, opens, or locks a batch.

Public method BatchCreate2

Creates, opens, or locks a batch.

Public method BatchOpen

Opens or locks the available batch with ID for the process.

Public method CanFilterOnBatchField

Returns a Boolean value indicating if filtering on batch field is available.

Public method CustomDataFolder

Returns a global custom data path based on the provided module ID.

Public method | Dispose | (Inherited from IDisposable.)
Public method LogMonitoringMessage

Logs a string that can be retrieved via SNMP.

Public method NextBatchFilteredGet

Extends the base method NextBatchGet to allow filtering.

Public method NextBatchGet

Opens or locks the next available batch for the process.

Public method SetBatchFilter

Sets the batch filter definition to be used by the NextBatchFilteredGet and BatchCollectionFiltered methods.

The XML string that defines the filter.

The Filter string contains a root element FilterCriteriaList. The FilterCriteriaList contains one or more FilterCriteria child elements and one FilteringEnabled child element.

FilterCriteria element

  • Name – Must be present. Must be one of the following names:
    - Batch name
    - Batch class
    - Queue
    - Status
    - Priority
    - Has error
    - Station ID
    - Batch creation date/time
    - Batch field
    - Scan station ID
    - Scan user
    - Reserved01

  • BatchField - A batch field name. Only used if Name is "Batch field".

  • Operator – Must be present. You must select from the following list of supported operators:
    - Contains
    - Equal to
    - Not equal to
    - Greater than
    - Less than
    - Starts with
    - Same date as
    - Bit and (supported for the Reserved01 KTM module bitfield criteria)

  • Value – A value used by this criteria. The data type must correspond to the specified criteria. All criteria except "Batch class" should only have one value.
  • ValueList – A list of values for this criteria. The value list must have one or more child Value elements. "Batch class" criteria is the only criteria that supports the ValueList.

FilteringEnabled element
  • Must be true or false
  • If true, filter criteria will be used to filter batches.
  • If false, filter criteria will be ignored and batches will be unfiltered.

An example of an XML Filter String is as follows:

<?xml version="1.0" encoding="utf-16"?>

<FilterCriteriaList xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<FilterCriteria>

<Name>Status</Name>

<BatchField />

<Operator>Equal to</Operator>

<Value>2</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Queue</Name>

<BatchField />

<Operator>Equal to</Operator>

<Value>3</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Station ID</Name>

<BatchField />

<Operator>Contains</Operator>

<Value>mystation</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Batch class</Name>

<BatchField />

<Operator>Contains</Operator>

<ValueList>

<Value>bc1</Value>

<Value>bc2</Value>

<Value>bc2plus</Value>

<Value>bc3</Value>

</ValueList>

</FilterCriteria>

<FilterCriteria>

<Name>Batch creation date/time</Name>

<BatchField />

<Operator>Less than</Operator>

<Value>2010-12-02 14:30:50</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Batch name</Name>

<BatchField />

<Operator>Contains</Operator>

<Value>MyBatchName</Value>

</FilterCriteria>

<FilteringEnabled>true</FilteringEnabled>

</FilterCriteriaList>

Top
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.AssignHandler Method

IRuntimeSessionAssignHandler Method

Assigns handle of the window that will be processed WM_QUERRYENDSESSION and shows custom warning message when session timeout is reached.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void AssignHandler(
    IntPtr hWnd
)
Sub AssignHandler (
    hWnd As IntPtr
)

Parameters

hWnd
Type: SystemIntPtr
Handle of the custom module's main form.
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.BatchCreate Method

IRuntimeSessionBatchCreate Method

Creates, opens, or locks a batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch BatchCreate(
    string strBatchClassName,
    string strBatchName,
    int nProcessID
)
Function BatchCreate (
    strBatchClassName As String,
    strBatchName As String,
    nProcessID As Integer
) As IBatch

Parameters

strBatchClassName
Type: SystemString
The name of the published batch class used to create the batch.
strBatchName
Type: SystemString
Must be a unique name for the new batch.
nProcessID
Type: SystemInt32
If this parameter is non-zero, the process should match the first process scheduled for the batch.

This parameter is used when generating the statistics record for this operation. The batch is returned in the locked state, so you can adjust any properties you like before unlocking it and making it available to other processes in the system, or you can simply start using it directly (for example, the Scan module might create batches and start using them right away).

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch
Remarks
The application calling this function is responsible for catching errors and creating unique batch names.
When calling this method, the nProcessID parameter must be the process ID of your custom module.
Examples
VB
Copy
'*** Get your Process ID
lProcessID = m_oLogin.ProcessID '*** Create new batch
m_oBatch = m_oRuntimeSession.BatchCreate("All Queues", txtBatchName, lProcessID)
m_oBatch.BatchClose(KfxDbBatchReady, KfxDbQueueNext, 0, "")
m_oBatch = Nothing
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.BatchCreate2 Method

IRuntimeSessionBatchCreate2 Method

Creates, opens, or locks a batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch BatchCreate2(
    string strBatchClassName,
    string strBatchName,
    int nProcessID,
    string strGUID = null
)
Function BatchCreate2 (
    strBatchClassName As String,
    strBatchName As String,
    nProcessID As Integer,
    Optional strGUID As String = Nothing
) As IBatch

Parameters

strBatchClassName
Type: SystemString
The name of the published batch class used to create the batch.
strBatchName
Type: SystemString
Must be a unique name for the new batch.
nProcessID
Type: SystemInt32
If this parameter is non-zero, the process should match the first process scheduled for the batch.
This parameter is used when generating the statistics record for this operation. The batch is returned in the locked state, so you can adjust any properties you like before unlocking it and making it available to other processes in the system, or you can simply start using it directly (for example, the Scan module might create batches and start using them right away).
strGUID (Optional)
Type: SystemString
Optional. If specified, must be a unique ID for the new batch. The ID must have the Registry GUID format {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch
Remarks
The application calling this function is responsible for catching errors and creating unique batch names.
When calling this method, the lProcessId parameter must be the process ID of your custom module.
Examples
VB
Copy
'*** Get your Process Id
lProcessId = m_oLogin.ProcessId '*** Create new batch
m_oBatch = m_oRuntimeSession.BatchCreate("All Queues", txtBatchName, lProcessId)
m_oBatch.BatchClose(KfxDbBatchReady, KfxDbQueueNext, 0, "")
m_oBatch = Nothing
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.BatchOpen Method

IRuntimeSessionBatchOpen Method

Opens or locks the available batch with ID for the process.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch BatchOpen(
    int nBatchID,
    int nRequestingProcessId
)
Function BatchOpen (
    nBatchID As Integer,
    nRequestingProcessId As Integer
) As IBatch

Parameters

nBatchID
Type: SystemInt32
The batch ID to be locked.
nRequestingProcessId
Type: SystemInt32
The process requesting that the batch be locked.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch
Remarks
Returns Nothing if all batches have been processed.
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.CanFilterOnBatchField Method

IRuntimeSessionCanFilterOnBatchField Method

Returns a Boolean value indicating if filtering on batch field is available.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool CanFilterOnBatchField()
Function CanFilterOnBatchField As Boolean

Return Value

Type: Boolean
Boolean
Remarks
Return True if filtering on batch field is available.
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.CustomDataFolder Method

IRuntimeSessionCustomDataFolder Method

Returns a global custom data path based on the provided module ID.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string CustomDataFolder(
    ref string strModuleID
)
Function CustomDataFolder (
    ByRef strModuleID As String
) As String

Parameters

strModuleID
Type: SystemString
The subfolder to be used as a custom data storage folder.

Return Value

Type: String
String
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.LogMonitoringMessage Method

IRuntimeSessionLogMonitoringMessage Method

Logs a string that can be retrieved via SNMP.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void LogMonitoringMessage(
    string strMessage
)
Sub LogMonitoringMessage (
    strMessage As String
)

Parameters

strMessage
Type: SystemString
The string that will be logged.
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.NextBatchFilteredGet Method

IRuntimeSessionNextBatchFilteredGet Method

Extends the base method NextBatchGet to allow filtering.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch NextBatchFilteredGet()
Function NextBatchFilteredGet As IBatch

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch
Remarks
Returns nothing if all batches have been processed. To use this method, a filter must have been previously set by a call to SetBatchFilter. The specified batch filter will be applied when determining the next batch to retrieve.
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.NextBatchGet Method

IRuntimeSessionNextBatchGet Method

Opens or locks the next available batch for the process.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatch NextBatchGet(
    int nRequestingProcessId,
    KfxDbFilter eFilterOptions = KfxDbFilter.KfxDbFilterOnProcess|KfxDbFilter.KfxDbFilterOnStates|KfxDbFilter.KfxDbSortOnPriorityDescending,
    KfxDbState eStates = KfxDbState.KfxDbBatchReady
)
Function NextBatchGet (
    nRequestingProcessId As Integer,
    Optional eFilterOptions As KfxDbFilter = KfxDbFilter.KfxDbFilterOnProcess Or KfxDbFilter.KfxDbFilterOnStates Or KfxDbFilter.KfxDbSortOnPriorityDescending,
    Optional eStates As KfxDbState = KfxDbState.KfxDbBatchReady
) As IBatch

Parameters

nRequestingProcessId
Type: SystemInt32
The process requesting that the batch be locked.
eFilterOptions (Optional)
Type: Kofax.Capture.SDK.CustomModuleKfxDbFilter
An optional argument used to filter batches. Default input value is a combination of KfxDbFilter.KfxDbFilterOnProcess and KfxDbFilter.KfxDbFilterOnStates and KfxDbFilter.KfxDbSortOnPriorityDescending
eStates (Optional)
Type: Kofax.Capture.SDK.CustomModuleKfxDbState
An optional argument used to filter batches. Default input value is KfxDbState.KfxDbBatchReady.

Return Value

Type: IBatch
Kofax.Capture.SDK.CustomModule.IBatch
Remarks
Returns Nothing if all batches have been processed.
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.SetBatchFilter Method

IRuntimeSessionSetBatchFilter Method

Sets the batch filter definition to be used by the NextBatchFilteredGet and BatchCollectionFiltered methods.

The XML string that defines the filter.

The Filter string contains a root element FilterCriteriaList. The FilterCriteriaList contains one or more FilterCriteria child elements and one FilteringEnabled child element.

FilterCriteria element

  • Name – Must be present. Must be one of the following names:
    - Batch name
    - Batch class
    - Queue
    - Status
    - Priority
    - Has error
    - Station ID
    - Batch creation date/time
    - Batch field
    - Scan station ID
    - Scan user
    - Reserved01

  • BatchField - A batch field name. Only used if Name is "Batch field".

  • Operator – Must be present. You must select from the following list of supported operators:
    - Contains
    - Equal to
    - Not equal to
    - Greater than
    - Less than
    - Starts with
    - Same date as
    - Bit and (supported for the Reserved01 KTM module bitfield criteria)

  • Value – A value used by this criteria. The data type must correspond to the specified criteria. All criteria except "Batch class" should only have one value.
  • ValueList – A list of values for this criteria. The value list must have one or more child Value elements. "Batch class" criteria is the only criteria that supports the ValueList.

FilteringEnabled element
  • Must be true or false
  • If true, filter criteria will be used to filter batches.
  • If false, filter criteria will be ignored and batches will be unfiltered.

An example of an XML Filter String is as follows:

<?xml version="1.0" encoding="utf-16"?>

<FilterCriteriaList xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">

<FilterCriteria>

<Name>Status</Name>

<BatchField />

<Operator>Equal to</Operator>

<Value>2</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Queue</Name>

<BatchField />

<Operator>Equal to</Operator>

<Value>3</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Station ID</Name>

<BatchField />

<Operator>Contains</Operator>

<Value>mystation</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Batch class</Name>

<BatchField />

<Operator>Contains</Operator>

<ValueList>

<Value>bc1</Value>

<Value>bc2</Value>

<Value>bc2plus</Value>

<Value>bc3</Value>

</ValueList>

</FilterCriteria>

<FilterCriteria>

<Name>Batch creation date/time</Name>

<BatchField />

<Operator>Less than</Operator>

<Value>2010-12-02 14:30:50</Value>

</FilterCriteria>

<FilterCriteria>

<Name>Batch name</Name>

<BatchField />

<Operator>Contains</Operator>

<Value>MyBatchName</Value>

</FilterCriteria>

<FilteringEnabled>true</FilteringEnabled>

</FilterCriteriaList>

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool SetBatchFilter(
    string strFilterStringXML
)
Function SetBatchFilter (
    strFilterStringXML As String
) As Boolean

Parameters

strFilterStringXML
Type: SystemString

Return Value

Type: Boolean
Boolean
Remarks
True if the filter was set successfully.
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession Properties

IRuntimeSession Properties

The IRuntimeSession type exposes the following members.

Properties
 | Name | Description
Public property | BatchCollection | Returns the active batch information.
Public property | BatchCollectionFiltered | Extends the base property BatchCollection to allow filtering. This property will make use of a filter that was previously set in a call to SetBatchFilter property
Public property | BatchFieldNamesCollection | Allows for the retrieval of a list of batch field names.
Public property | BatchFieldValuesCollection | Allows for the retrieval of a list of batch field values for a specified batch field name.
Public property | ImportExportLog | Sets the log file name for XML logging.
Public property | InstallPath | Returns the location of the Tungsten Capture server.
Public property | ProcessCollection | Returns a collection of process objects.
Public property | ProcessID | Gets or sets the next process ID.
Public property | PublishedBatchClassCollection | Returns a collection of published batch classes.
Public property | ScanEnabled | Returns True if scanning is allowed.
Public property | ServicePackVersion | Returns the currently installed service pack.
Public property | StationID | Returns the current Tungsten Capture station ID.
Public property | UserID | Returns the ID of currently logged in user.
Public property | UserName | Returns the name of currently logged in user.
Top
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.BatchCollection Property

IRuntimeSessionBatchCollection Property

Returns the active batch information.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchCollection this[
    KfxDbFilter eFilterOptions = ,
    int nProcessID = 0,
    KfxDbState eStates = ,
    bool bUserFilter = true
] { get; }
ReadOnly Property BatchCollection (
    Optional eFilterOptions As KfxDbFilter = ,
    Optional nProcessID As Integer = 0,
    Optional eStates As KfxDbState = ,
    Optional bUserFilter As Boolean = true
) As IBatchCollection
    Get

Parameters

eFilterOptions (Optional)
Type: Kofax.Capture.SDK.CustomModuleKfxDbFilter
Limits the scope of the search, and/or specifies sort criteria.
nProcessID (Optional)
Type: SystemInt32
Can be obtained by using the ProcessID from the Login object. Only batches that are queued for lProcessId will be considered.
eStates (Optional)
Type: Kofax.Capture.SDK.CustomModuleKfxDbState
If you specify filtering on states, eStates must be passed as a nonzero value that contains a bitmask of the available states. Only batches that match the eStates mask will be considered.
bUserFilter (Optional)
Type: SystemBoolean
If bUserFilter is False, the collection will include all batches, even if the user does not have rights to them.

Property Value

Type: IBatchCollection

Return Value

Type: IBatchCollection
Kofax.Capture.SDK.CustomModule.IBatchCollection
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.BatchCollectionFiltered Property

IRuntimeSessionBatchCollectionFiltered Property

Extends the base property BatchCollection to allow filtering. This property will make use of a filter that was previously set in a call to SetBatchFilter property

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchCollection this[
    bool bUserFilter = true
] { get; }
ReadOnly Property BatchCollectionFiltered (
    Optional bUserFilter As Boolean = true
) As IBatchCollection
    Get

Parameters

bUserFilter (Optional)
Type: SystemBoolean
If this parameter is False, the collection will include all batch field names, even if the user does not have rights to them.

Property Value

Type: IBatchCollection

Return Value

Type: IBatchCollection
Kofax.Capture.SDK.CustomModule.IBatchCollection
Remarks
To use this method, a filter must have been previously set by a call to SetBatchFilter. The specified batch filter will be applied when determining the next batch to retrieve.
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.BatchFieldNamesCollection Property

IRuntimeSessionBatchFieldNamesCollection Property

Allows for the retrieval of a list of batch field names.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchFieldNamesCollection this[
    bool bUserFilter = true
] { get; }
ReadOnly Property BatchFieldNamesCollection (
    Optional bUserFilter As Boolean = true
) As IBatchFieldNamesCollection
    Get

Parameters

bUserFilter (Optional)
Type: SystemBoolean
If this parameter is False, the collection will include all batch field names, even if the user does not have rights to them.

Property Value

Type: IBatchFieldNamesCollection
A collection of batch field names.

Return Value

Type: IBatchFieldNamesCollection
Kofax.Capture.SDK.CustomModule.IBatchFieldNamesCollection
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.BatchFieldValuesCollection Property

IRuntimeSessionBatchFieldValuesCollection Property

Allows for the retrieval of a list of batch field values for a specified batch field name.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IBatchFieldValuesCollection this[
    string strBatchFieldName
] { get; }
ReadOnly Property BatchFieldValuesCollection (
    strBatchFieldName As String
) As IBatchFieldValuesCollection
    Get

Parameters

strBatchFieldName
Type: SystemString
Specifies the name of the batch field.

Property Value

Type: IBatchFieldValuesCollection
A collection of batch field values for the specified batch field name.

Return Value

Type: IBatchFieldValuesCollection
Kofax.Capture.SDK.CustomModule.IBatchFieldValuesCollection
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.ImportExportLog Property

IRuntimeSessionImportExportLog Property

Sets the log file name for XML logging.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ImportExportLog { set; }
WriteOnly Property ImportExportLog As String
    Set

Property Value

Type: String
The log file name to set.
Remarks
Sets the log file name for XML logging.
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.InstallPath Property

IRuntimeSessionInstallPath Property

Returns the location of the Tungsten Capture server.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string InstallPath { get; }
ReadOnly Property InstallPath As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.ProcessCollection Property

IRuntimeSessionProcessCollection Property

Returns a collection of process objects.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IProcessCollection ProcessCollection { get; }
ReadOnly Property ProcessCollection As IProcessCollection
    Get

Property Value

Type: IProcessCollection

Return Value

Type: IProcessCollection
Kofax.Capture.SDK.CustomModule.IProcessCollection
Remarks
The Process object can be used by custom modules to get the custom module process ID.
The process ID is used as a parameter into several methods that retrieve batches.
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.ProcessID Property

IRuntimeSessionProcessID Property

Gets or sets the next process ID.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ProcessID { get; set; }
Property ProcessID As Integer
    Get
    Set

Property Value

Type: Int32
The next process ID.

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.PublishedBatchClassCollection Property

IRuntimeSessionPublishedBatchClassCollection Property

Returns a collection of published batch classes.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IPublishedBatchClassCollection this[
    bool bUserFilter = true
] { get; }
ReadOnly Property PublishedBatchClassCollection (
    Optional bUserFilter As Boolean = true
) As IPublishedBatchClassCollection
    Get

Parameters

bUserFilter (Optional)
Type: SystemBoolean
Default True. If this parameter is False, the collection will include all published batch classes, even if the user does not have rights to them.

Property Value

Type: IPublishedBatchClassCollection

Return Value

Type: IPublishedBatchClassCollection
Kofax.Capture.SDK.CustomModule.IPublishedBatchClassCollection
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.ScanEnabled Property

IRuntimeSessionScanEnabled Property

Returns True if scanning is allowed.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool ScanEnabled { get; }
ReadOnly Property ScanEnabled As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.ServicePackVersion Property

IRuntimeSessionServicePackVersion Property

Returns the currently installed service pack.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
short ServicePackVersion { get; }
ReadOnly Property ServicePackVersion As Short
    Get

Property Value

Type: Int16

Return Value

Type: Int16
Short
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.StationID Property

IRuntimeSessionStationID Property

Returns the current Tungsten Capture station ID.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string StationID { get; }
ReadOnly Property StationID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.UserID Property

IRuntimeSessionUserID Property

Returns the ID of currently logged in user.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string UserID { get; }
ReadOnly Property UserID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.UserName Property

IRuntimeSessionUserName Property

Returns the name of currently logged in user.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string UserName { get; }
ReadOnly Property UserName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession Events

IRuntimeSession Events

The IRuntimeSession type exposes the following members.

Events
 | Name | Description
Public event | BatchAvailable | Event to to notify that a batch is available for processing in the next queue.
Public event | OnSessionTimeOut | Event to notify that the current session is timed out.
Top
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.BatchAvailable Event

IRuntimeSessionBatchAvailable Event

Event to to notify that a batch is available for processing in the next queue.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
event IRuntimeSessionBatchAvailableEventHandler BatchAvailable
Event BatchAvailable As IRuntimeSessionBatchAvailableEventHandler

Value

Type: Kofax.Capture.SDK.CustomModuleIRuntimeSessionBatchAvailableEventHandler
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.OnSessionTimeOut Event

IRuntimeSessionOnSessionTimeOut Event

Event to notify that the current session is timed out.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
event TimeoutEventHandler<TimeoutEventArg> OnSessionTimeOut
Event OnSessionTimeOut As TimeoutEventHandler(Of TimeoutEventArg)

Value

Type: Kofax.Capture.SDK.CustomModuleTimeoutEventHandler TimeoutEventArg
Remarks
See Also

Reference

IRuntimeSession Interface
Kofax.Capture.SDK.CustomModule Namespace


IRuntimeSession.BatchAvailableEventHandler Delegate

IRuntimeSessionBatchAvailableEventHandler Delegate

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void BatchAvailableEventHandler()
Public Delegate Sub BatchAvailableEventHandler
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


KfxDbError Enumeration

KfxDbError Enumeration

Defines the possible errors.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public enum KfxDbError
Public Enumeration KfxDbError
Members
Member name | Value | Description
KfxDbInvalidProcessId | 4006 | Invalid value for process ID.
KfxDbInvalidArgument | 4007 | Invalid parameter.
KfxDbNotSupported | 4008 | Function is not yet supported.
KfxDbBatchIsAlreadyLocked | 4009 | Batch is already opened and locked.
KfxDbOnlyOneBatchMayBeLocked | 4010 | Only one batch at a time may be locked.
KfxDbBatchIsNotLocked | 4011 | Batch is not open.
KfxDbWrongProcess | 4012 | The process ID is incorrect.
KfxDbTooManyPages | 4013 | Importing more pages is not allowed.
KfxDbInvalidState | 4020 | Invalid state parameter.
KfxDbInvalidFilter | 4021 | Invalid filter parameter.
KfxDbInvalidQueue | 4022 | Invalid queue parameter.
KfxDbInvalidUniqueId | 4023 | Invalid UniqueID parameter.
KfxDbInvalidUser | 4024 | Unable to validate user.
KfxDbNoRights | 4025 | User does not have rights to this module.
KfxDbObsoleteInterface1 | 4030 | Interface is obsolete.
KfxDbLoggedIn | 4040 | User is logged in and cannot change property.
KfxDbBadResponse | 4041 | Invalid response.
KfxDbInvalidPubBatchDefID | 4042 | Invalid published batch definition ID.
KfxDbNoVolume | 4043 | Insufficient volume licensing.
KfxDbAlreadyLoggedOut | 4044 | Function cannot be called after Logout. Create a new Login object or ensure Logout is the last function called by the application.
KfxDbChildBatchStillOpen | 4045 | Unable to close this batch because a child batch is still open.
KfxDbCannotCreateChildWhenThereIsBatchTotal | 4046 | Cannot create child batch when there is batch total.
KfxDbCannotCreateChildFromChildBatch | 4047 | Cannot create child batch from an active child batch.
KfxDbCannotCreateChildFromPartialReleasedBatch | 4048 | Cannot create child batch when a batch has been partially exported.
KfxDbFailedToCreateChildBatch | 4049 | Failed to create child batch.
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


KfxDbFilter Enumeration

KfxDbFilter Enumeration

Used to limit the scope of processing, or to specify sort criteria.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public enum KfxDbFilter
Public Enumeration KfxDbFilter
Members
Member name | Value | Description
KfxDbFilterOnProcess | 1 | Returns only batches ready for this process.
KfxDbFilterOnStates | 2 | Returns only batches based on states.
KfxDbSortOnPriorityDescending | 4 | Sorts by priority in descending order.
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


KfxDbProcessId Enumeration

KfxDbProcessId Enumeration
Used to report process IDs, which indicates the current Tungsten Capture module.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public enum KfxDbProcessId
Public Enumeration KfxDbProcessId
Members
Member name | Value | Description
KfxDbProcessNone | 0 | None – invalid process.
KfxDbProcessScan | 1 | Scan module.
KfxDbProcessQualityControl | 2 | Quality Control module.
KfxDbProcessFormsProcessing | 3 | Recognition module.
KfxDbProcessIndex | 4 | Validation module.
KfxDbProcessVerify | 5 | Verification module.
KfxDbProcessOcr | 6 | OCR Full Text module.
KfxDbProcessRelease | 7 | Export module.
KfxDbProcessOperations | 8 | Batch Manager module.
KfxDbProcessPdf | 14999 | Kofax PDF Generator module.
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


KfxDbQueue Enumeration

KfxDbQueue Enumeration
Used for calculating the next state of a batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public enum KfxDbQueue
Public Enumeration KfxDbQueue
Members
Member name | Value | Description
KfxDbQueueSame | 1 | The batch is not routed to the next queue.
KfxDbQueueNext | 2 | The batch is routed to the next queue defined for the batch class.
KfxDbQueueException | 3 | The batch is routed to Quality Control (Rescan).
KfxDbQueueForcedException | 4 | Reserved.
KfxDbQueueRollback | 5 | Reserved.
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


KfxDbState Enumeration

KfxDbState Enumeration
Used for the state of a batch.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public enum KfxDbState
Public Enumeration KfxDbState
Members
Member name | Value | Description
KfxDbBatchReady | 2 | Batch is ready.
KfxDbBatchInProgress | 4 | Batch is in progress.
KfxDbBatchSuspended | 8 | Batch is suspended.
KfxDbBatchError | 32 | Batch is in error.
KfxDbBatchCompleted | 64 | Batch is in the completed state.
KfxDbBatchReserved | 128 | Reserved.
KfxDbBatchInProgress2 | 512 | Reserved.
Remarks
Used for filtering when retrieving information about batches. It is assigned when closing a batch.
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


LicensingException Class

LicensingException Class

The exception that is thrown when a licesing issue occurs.

Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.Runtime.InteropServicesCOMException
Kofax.Capture.SDK.DataKfxException
Kofax.Capture.SDK.CustomModuleLicensingException

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class LicensingException : KfxException
Public Class LicensingException
    Inherits KfxException

The LicensingException type exposes the following members.

Constructors
 | Name | Description
Public method | LicensingException(String, KfxDbError) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.LicensingException class.
Public method | LicensingException(String, KfxDbError, Object) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.LicensingException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
Remarks
One of the following error numbers should be passed in:
  • KfxDbError.KfxDbTooManyPages = 4013 -- Import of more pages not allowed
  • KfxDbError.KfxDbBadResponse = 4041 -- Invalid response
  • KfxDbError.KfxDbNoVolume = 4043 -- Insufficient volume licensing
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


LicensingException Constructor

LicensingException Constructor
Overload List
 | Name | Description
Public method | LicensingException(String, KfxDbError) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.LicensingException class.
Public method | LicensingException(String, KfxDbError, Object) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.LicensingException class.
Top
See Also

Reference

LicensingException Class
Kofax.Capture.SDK.CustomModule Namespace


LicensingException Constructor (String, KfxDbError)

LicensingException Constructor (String, KfxDbError)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.CustomModule.LicensingException class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public LicensingException(
    string strMsg,
    KfxDbError errNum
)
Public Sub New (
    strMsg As String,
    errNum As KfxDbError
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.CustomModuleKfxDbError
The original Error number.
Remarks
See Also

Reference

LicensingException Class
LicensingException Overload
Kofax.Capture.SDK.CustomModule Namespace


LicensingException Constructor (String, KfxDbError, Object)

LicensingException Constructor (String, KfxDbError, Object)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.CustomModule.LicensingException class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public LicensingException(
    string strMsg,
    KfxDbError errNum,
    Object oSource
)
Public Sub New (
    strMsg As String,
    errNum As KfxDbError,
    oSource As Object
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.CustomModuleKfxDbError
The original Error number.
oSource
Type: SystemObject
The source.
Remarks
See Also

Reference

LicensingException Class
LicensingException Overload
Kofax.Capture.SDK.CustomModule Namespace


LicensingException Methods

LicensingException Methods

The LicensingException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
See Also

Reference

LicensingException Class
Kofax.Capture.SDK.CustomModule Namespace


LicensingException Properties

LicensingException Properties

The LicensingException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
See Also

Reference

LicensingException Class
Kofax.Capture.SDK.CustomModule Namespace


LoginException Class

LoginException Class

The exception that is thrown when a login error occurs.

Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.Runtime.InteropServicesCOMException
Kofax.Capture.SDK.DataKfxException
Kofax.Capture.SDK.CustomModuleLoginException

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class LoginException : KfxException
Public Class LoginException
    Inherits KfxException

The LoginException type exposes the following members.

Constructors
 | Name | Description
Public method | LoginException(String, KfxDbError) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.LoginException class.
Public method | LoginException(String, KfxDbError, Object) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.LoginException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
Remarks
  • KfxDbError.KfxDbInvalidUniqueId = 4023 -- Invalid UniqueID parameter.
  • KfxDbError.KfxDbInvalidUser = 4024 -- Unable to validate user.
  • KfxDbError.KfxDbNoRights = 4025 -- User does not have rights to this module.
  • KfxDbError.KfxDbLoggedIn = 4040 -- User is logged in and cannot change property.
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


LoginException Constructor

LoginException Constructor
Overload List
 | Name | Description
Public method | LoginException(String, KfxDbError) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.LoginException class.
Public method | LoginException(String, KfxDbError, Object) | Initializes a new instance of the Kofax.Capture.SDK.CustomModule.LoginException class.
Top
See Also

Reference

LoginException Class
Kofax.Capture.SDK.CustomModule Namespace


LoginException Constructor (String, KfxDbError)

LoginException Constructor (String, KfxDbError)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.CustomModule.LoginException class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public LoginException(
    string strMsg,
    KfxDbError errNum
)
Public Sub New (
    strMsg As String,
    errNum As KfxDbError
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.CustomModuleKfxDbError
The original Error number.
Remarks
See Also

Reference

LoginException Class
LoginException Overload
Kofax.Capture.SDK.CustomModule Namespace


LoginException Constructor (String, KfxDbError, Object)

LoginException Constructor (String, KfxDbError, Object)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.CustomModule.LoginException class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public LoginException(
    string strMsg,
    KfxDbError errNum,
    Object oSource
)
Public Sub New (
    strMsg As String,
    errNum As KfxDbError,
    oSource As Object
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.CustomModuleKfxDbError
The original Error number.
oSource
Type: SystemObject
The source.
Remarks
See Also

Reference

LoginException Class
LoginException Overload
Kofax.Capture.SDK.CustomModule Namespace


LoginException Methods

LoginException Methods

The LoginException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
See Also

Reference

LoginException Class
Kofax.Capture.SDK.CustomModule Namespace


LoginException Properties

LoginException Properties

The LoginException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
See Also

Reference

LoginException Class
Kofax.Capture.SDK.CustomModule Namespace


TimeoutEventArg Class

TimeoutEventArg Class

Defines a time-out event argument class.

Inheritance Hierarchy
SystemObject
SystemEventArgs
Kofax.Capture.SDK.CustomModuleTimeoutEventArg

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class TimeoutEventArg : EventArgs
Public Class TimeoutEventArg
    Inherits EventArgs

The TimeoutEventArg type exposes the following members.

Constructors
 | Name | Description
Public method | TimeoutEventArg | Initializes a new instance of the Kofax.Capture.DBLite.TimeoutEventArg class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Expire | Returns the time in minutes until the session will time out.
Public property | Processed | Gets or sets flag that indicates whether the custom module has handled the time-out event.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


TimeoutEventArg Constructor

TimeoutEventArg Constructor

Initializes a new instance of the Kofax.Capture.DBLite.TimeoutEventArg class.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public TimeoutEventArg(
    bool bProcessed,
    int nExpire
)
Public Sub New (
    bProcessed As Boolean,
    nExpire As Integer
)

Parameters

bProcessed
Type: SystemBoolean
Flag indicates whether the custom module has handled the time-out event.
nExpire
Type: SystemInt32
The time in minutes until the session will time out.
Remarks
See Also

Reference

TimeoutEventArg Class
Kofax.Capture.SDK.CustomModule Namespace


TimeoutEventArg Methods

TimeoutEventArg Methods

The TimeoutEventArg type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TimeoutEventArg Class
Kofax.Capture.SDK.CustomModule Namespace


TimeoutEventArg Properties

TimeoutEventArg Properties

The TimeoutEventArg type exposes the following members.

Properties
 | Name | Description
Public property | Expire | Returns the time in minutes until the session will time out.
Public property | Processed | Gets or sets flag that indicates whether the custom module has handled the time-out event.
Top
See Also

Reference

TimeoutEventArg Class
Kofax.Capture.SDK.CustomModule Namespace


TimeoutEventArg.Expire Property

TimeoutEventArgExpire Property

Returns the time in minutes until the session will time out.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Expire { get; }
Public ReadOnly Property Expire As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Remarks
See Also

Reference

TimeoutEventArg Class
Kofax.Capture.SDK.CustomModule Namespace


TimeoutEventArg.Processed Property

TimeoutEventArgProcessed Property

Gets or sets flag that indicates whether the custom module has handled the time-out event.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public bool Processed { get; set; }
Public Property Processed As Boolean
    Get
    Set

Property Value

Type: Boolean
If False, Tungsten Capture will show time-out warning dialog when the session reaches the configured time-out limit.

Return Value

Type: Boolean
Boolean
Remarks
See Also

Reference

TimeoutEventArg Class
Kofax.Capture.SDK.CustomModule Namespace


TimeoutEventHandler(TEventArgs) Delegate

TimeoutEventHandlerTEventArgs Delegate

Delegate to be used to declare an event time out handler.

Namespace: Kofax.Capture.SDK.CustomModule
Assembly: Kofax.Capture.SDK.CustomModule (in Kofax.Capture.SDK.CustomModule.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public delegate void TimeoutEventHandler<TEventArgs>(
    TEventArgs e
)
where TEventArgs : EventArgs

Public Delegate Sub TimeoutEventHandler(Of TEventArgs As EventArgs) (
    e As TEventArgs
)

Parameters

e
Type: TEventArgs

Type Parameters

TEventArgs
The event data.
Remarks
See Also

Reference

Kofax.Capture.SDK.CustomModule Namespace


Kofax.Capture.SDK.Data Namespace

Kofax.Capture.SDK.Data Namespace

The Tungsten Capture Optimized Custom Module .NET Type Interface Library is an easy-to-use custom module interface library that allows fast retrieval and selective update of data. This API provides a mechanism that allows use of the Tungsten Capture Document Access .NET Type Implementation Library (Kofax.DBLite.dll) to select and open a batch. However, once open, it is not necessary to export the data to XML. Instead, the code can retrieve an API object that acts like an XML element, but without XML. The code can selectively extract and update Tungsten Capture data through this API. Because the data is processed selectively, execution is faster than XML importing and exporting. The actual organization of Tungsten Capture data (the element and attribute structure) is identical between the XML and this new API.

Tungsten Capture continues to support XML, which may still be better for developers with applications that are well-suited to an XML interface. The Tungsten Capture Optimized Custom Module .NET Type Interface Library API is implemented in the Tungsten Capture Optimized Custom Module .NET Type Implementation Library (Kofax.DBLiteOpt.dll).

The Tungsten Capture Optimized Custom Module .NET Type Interface Library (Kofax.Capture.SDK.Data.dll) and Tungsten Capture Optimized Custom Module .NET Type Implementation Library (Kofax.DBLiteOpt.dll) are available from the Bin folder in your Tungsten Capture installation.

Classes
 | Class | Description
Public class | DataErrorException | Defines DataErrorException object that is thrown when data error occurs.
Public class | InvalidArgumentException | Defines InvalidArgumentException object which is thrown when invalid argument was passed in.
Public class | InvalidOperationException | InvalidOperationException is thrown when invalid operation was called.
Public class | KfxException | Defines Kofax Exception class that inherits a COMException.
Public class | LicensingException | Defines LicensingException object which is thrown when having issues with licensing.
Public class | OptimizedCustomModuleException | Defines a general exception that is thrown when a general error occurs.
Interfaces
 | Interface | Description
Public interface | IACDataConnection | This interface serves as the global "parent" of all objects and is used to perform extractions of root ACDataElement objects (setup and runtime). It serves as the higher-level interface to the KfxDb database connection.
Public interface | IACDataElement | The ACData Element object represents a specific element in the Tungsten Capture data structure. A particular ACDataElement object corresponds to an XML element in the XML output.
Public interface | IACDataElementAttributeColl | This object allows specification of attribute sub-lists. Refer to FindPartialChildElementsByName(IACDataElementAttributeColl, String) and FindPartialChildElementsByAttribute(IACDataElementAttributeColl, String, String, String).
Public interface | IACDataElementCollection | Defines a collection of ACDataElement objects.
Public interface | IAttributeValueColl |
Public interface | IBulkUpdateDataColl |
Public interface | INameValuePair |
Enumerations
 | Enumeration | Description
Public enumeration | ACDataElementErrorValue | Defines the possible errors that can be generated by this library.
Public enumeration | ACDataElementHints | Defines data element hints.
Remarks


ACDataElementErrorValue Enumeration

ACDataElementErrorValue Enumeration

Defines the possible errors that can be generated by this library.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public enum ACDataElementErrorValue
Public Enumeration ACDataElementErrorValue
Members
Member name | Value | Description
KfxDbLiteOptErrBase | 11000 | Library based error code.
ErrUnexpectedError | 11001 | Unexpected error.
ErrMissingPrimaryKey | 11002 | The primary key is missing for the associated table.
ErrHintsNotSupportedForSetup | 11003 | Hints are not supported for retrieving Tungsten Capture Setup elements.
ErrInvalidHintsForRuntime | 11004 | Invalid hints were detected.
ErrInvalidRootName | 11005 | Invalid root name was detected.
ErrInvalidRecordset | 11006 | Empty recordset was detected when creating an ACDataElement.
ErrInvalidElementName | 11007 | Empty child element name was detected when creating a child ACDataElement.
ErrMissingParentKey | 11008 | The parent key is missing for the associated table.
ErrNoAttributesExists | 11009 | No attributes exist for the associated table.
ErrNoDBAttributesExists | 11010 | No database attributes exist for the associated table.
ErrElementDeleted | 11011 | The element has been deleted.
ErrViolateReadOnly | 11012 | This attribute cannot be updated.
ErrNotAllowStructureUpdates | 11013 | Structural updates are not allowed on elements when the root node was extracted with hints.
ErrNotAllowAttributesForCollectionElement | 11014 | The specified attribute is not defined for the current collection element.
ErrAttributeNotExistInKfxSchema | 11015 | The specified attribute is not defined for the current element.
ErrAttributeNotExistInSelectedColumns | 11016 | The specified attribute is not in the selected attribute list.
ErrTranslateAttributeUpdateNotAllowed | 11017 | Updates are not allowed for the specified (translated) attribute.
ErrChildNotExist | 11018 | Invalid child element was specified for the current element.
ErrFilteringAttributeNotDatabaseField | 11019 | The specified filtering attribute does not correspond to a database field.
ErrEmptySelectAttributeList | 11020 | The collection of selected attributes must include at least one item.
ErrDuplicateNamesInSelectedAttributeList | 11021 | Duplicate attribute names are not allowed in the selected attribute list.
ErrOneDatabaseRecordExpected | 11022 | Two or more records exist in the recordset. Zero or one record is expected.
ErrNaturalKeyMissing | 11023 | Natural Key is not defined on the corresponding translate table.
ErrTranslateTableMissing | 11024 | The required translate table is not defined in the Tungsten Capture database schema.
ErrTranslateTablePrimaryKeyMissing | 11025 | Primary key is not defined on the corresponding translate table.
ErrNoRecordsExistInTranslateTable | 11026 | No records exist in the corresponding translate table.
ErrNaturalKeyLinkMissing | 11027 | NaturalKeyLink is not defined in the corresponding translate table.
ErrTranslateTableNotSpecifiedInNaturalKeyLinkField | 11028 | Translate table is not specified in the corresponding NaturalKeyLink field.
ErrInvalidPriorityValue | 11029 | The value of the Priority attribute must be between 1 and 10.
ErrRootAttributeUpdateNotAllowed | 11030 | Attribute value updates are not allowed for root elements.
ErrInvalidFormTypeName | 11031 | Invalid form type name.
ErrFilteringAttributeNotExistInKfxSchema | 11032 | The specified filtering attribute is not defined for the specified element type.
ErrSelectedAttributeNotExistInKfxSchema | 11033 | The selected attribute is not defined for the specified element type.
ErrAttributesNotAllowedForCollectionElement | 11034 | You cannot specify a list of attributes with a collection element type.
ErrInvalidAttributeValue | 11035 | You cannot update a translated value with an empty string.
ErrExpectPagesAsParent | 11036 | Invalid parent element. 'Pages' parent element expected.
ErrExpectPageAsSibling | 11037 | Invalid sibling element. 'Page' sibling element expected.
ErrNoStatistics | 11038 | Statistics attributes are not supported within this environment.
ErrNotAllowBitonalImageFile | 11039 | You cannot specify a BitonalImageFile when the current page is an eDocument.
ErrNoVolume | 12000 | Insufficient volume licensing available. Obtain a new activation code that reflects your actual licensing requirements.
ErrBadResponse | 12001 | Invalid License Server challenge.
ErrRecordsetTableType | 12002 | You cannot delete elements of this type.
ErrCreateDocPage | 12003 | Creation of document pages is not supported.
ErrInvalidChild | 12004 | The proposed element type cannot be created as a child of the parent table.
ErrInvalidSource | 12005 | The source element type is not supported for this operation.
ErrInvalidDest | 12006 | The destination element type is not supported for this operation.
ErrTableMismatch | 12007 | The table type does not match the corresponding recordset.
ErrBadParameter | 12008 | Bad parameter range.
ErrInvalidNumberOfPrimaryKeys | 12009 | Invalid number of primary keys.
ErrInvalidFolderClassName | 12010 | Invalid folder class name.
Remarks
See Also

Reference

Kofax.Capture.SDK.Data Namespace


ACDataElementHints Enumeration

ACDataElementHints Enumeration

Defines data element hints.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public enum ACDataElementHints
Public Enumeration ACDataElementHints
Members
Member name | Value | Description
HintDocumentPages | 1 | Processes all or most document pages in the entire batch.
HintDocumentIndexFields | 2 | Processes all or most index fields in the entire batch.
HintPageCustomStorageStrings | 4 | Processes all or most custom storage strings for all pages.
HintDocumentCustomStorageStrings | 8 | Processes all or most custom storage strings for all documents.
Remarks
See Also

Reference

Kofax.Capture.SDK.Data Namespace


DataErrorException Class

DataErrorException Class

Defines DataErrorException object that is thrown when data error occurs.

Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.Runtime.InteropServicesCOMException
Kofax.Capture.SDK.DataKfxException
Kofax.Capture.SDK.DataDataErrorException

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class DataErrorException : KfxException
Public Class DataErrorException
    Inherits KfxException

The DataErrorException type exposes the following members.

Constructors
 | Name | Description
Public method | DataErrorException(String, ACDataElementErrorValue) | Initializes a new instance of the Kofax.Capture.SDK.Data.DataErrorException class.
Public method | DataErrorException(String, Int32, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.DataErrorException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
Remarks
One of the following error numbers should be passed in:
  • ErrMissingPrimaryKey -- The primary key is missing for the associated table.
  • ErrMissingParentKey -- The parent key is missing for the associated table.
  • ErrNoAttributesExists -- No attributes exist for the associated table.
  • ErrNoDBAttributesExists -- No database attributes exist for the associated table.
  • ErrNaturalKeyMissing -- Natural Key is not defined on the corresponding translate table.
  • ErrOneDatabaseRecordExpected -- Two or more records exist in the recordset. Zero or one record is expected.
  • ErrTranslateTableMissing -- The required translate table is not defined in the Tungsten Capture database schema.
  • ErrTranslateTablePrimaryKeyMissing -- Primary key is not defined on the corresponding translate table.
  • ErrNoRecordsExistInTranslateTable -- No records exist in the corresponding translate table.
  • ErrNaturalKeyLinkMissing -- NaturalKeyLink is not defined in the corresponding translate table.
  • ErrTranslateTableNotSpecifiedInNaturalKeyLinkField -- Translate table is not specified in the corresponding NaturalKeyLink field.
  • ErrSelectedAttributeNotExistInKfxSchema -- The selected attribute is not defined for the specified element type.
  • ErrDuplicateNamesInSelectedAttributeList -- Duplicate attribute names are not allowed in the selected attribute list.
  • ErrInvalidNumberOfPrimaryKeys -- Invalid number of primary keys
See Also

Reference

Kofax.Capture.SDK.Data Namespace


DataErrorException Constructor

DataErrorException Constructor
Overload List
 | Name | Description
Public method | DataErrorException(String, ACDataElementErrorValue) | Initializes a new instance of the Kofax.Capture.SDK.Data.DataErrorException class.
Public method | DataErrorException(String, Int32, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.DataErrorException class.
Top
See Also

Reference

DataErrorException Class
Kofax.Capture.SDK.Data Namespace


DataErrorException Constructor (String, ACDataElementErrorValue)

DataErrorException Constructor (String, ACDataElementErrorValue)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.DataErrorException class.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public DataErrorException(
    string strMsg,
    ACDataElementErrorValue errNum
)
Public Sub New (
    strMsg As String,
    errNum As ACDataElementErrorValue
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.DataACDataElementErrorValue
The original error number.
Remarks
See Also

Reference

DataErrorException Class
DataErrorException Overload
Kofax.Capture.SDK.Data Namespace


DataErrorException Constructor (String, Int32, Object)

DataErrorException Constructor (String, Int32, Object)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.DataErrorException class.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public DataErrorException(
    string strMsg,
    int errNum,
    Object oSource
)
Public Sub New (
    strMsg As String,
    errNum As Integer,
    oSource As Object
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: SystemInt32
The original error number.
oSource
Type: SystemObject
The source.
Remarks
See Also

Reference

DataErrorException Class
DataErrorException Overload
Kofax.Capture.SDK.Data Namespace


DataErrorException Methods

DataErrorException Methods

The DataErrorException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
See Also

Reference

DataErrorException Class
Kofax.Capture.SDK.Data Namespace


DataErrorException Properties

DataErrorException Properties

The DataErrorException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
See Also

Reference

DataErrorException Class
Kofax.Capture.SDK.Data Namespace


IACDataConnection Interface

IACDataConnection Interface

This interface serves as the global "parent" of all objects and is used to perform extractions of root ACDataElement objects (setup and runtime). It serves as the higher-level interface to the KfxDb database connection.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACDataConnection : IDisposable
Public Interface IACDataConnection
    Inherits IDisposable

The IACDataConnection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | FlushLicensing | Sends licensing information back to the license server.
Public method | GetRootNode | Retrieves the root ACDataElement to return to the client code.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.Data Namespace


IACDataConnection Methods

IACDataConnection Methods

The IACDataConnection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | FlushLicensing | Sends licensing information back to the license server.
Public method | GetRootNode | Retrieves the root ACDataElement to return to the client code.
Top
See Also

Reference

IACDataConnection Interface
Kofax.Capture.SDK.Data Namespace


IACDataConnection.FlushLicensing Method

IACDataConnectionFlushLicensing Method

Sends licensing information back to the license server.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void FlushLicensing()
Sub FlushLicensing
Remarks
See Also

Reference

IACDataConnection Interface
Kofax.Capture.SDK.Data Namespace


IACDataConnection.GetRootNode Method

IACDataConnectionGetRootNode Method

Retrieves the root ACDataElement to return to the client code.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElement GetRootNode(
    ref string strRootName,
    ref int nHints,
    bool bReadOnlyMode
)
Function GetRootNode (
    ByRef strRootName As String,
    ByRef nHints As Integer,
    bReadOnlyMode As Boolean
) As IACDataElement

Parameters

strRootName
Type: SystemString
Name of the root element ("AscentCaptureSetup" or "AscentCaptureRuntime").
nHints
Type: SystemInt32
Information provided to the custom module API that allows it to process data more efficiently based on what the programmer expects to do. IHints are required to be bitwise or of the enums defined by ACDataElementHints enum type.
bReadOnlyMode
Type: SystemBoolean

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement
Remarks
See Also

Reference

IACDataConnection Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement Interface

IACDataElement Interface

The ACData Element object represents a specific element in the Tungsten Capture data structure. A particular ACDataElement object corresponds to an XML element in the XML output.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACDataElement
Public Interface IACDataElement

The IACDataElement type exposes the following members.

Methods
Name Description
Public method AttributeExists

Indicates if an attribute exists in the selected attribute list for this element.

Public method BulkUpdate

Update a collection of Attributes for a given Element

Public method CreateChildElement

Creates a child element of the specified type.

Public method CreateChildElement2

Creates a child element of the specified type.

CreatePageChildElement

This method is functionally equivalent to calling the following sequence of existing calls:

Examples
VB
Copy
oElement = oParentElement.CreatePage("Page")
oElement.Attribute("ImageFile") = strPageFileName
Essentially, this call creates a new "Page" element and assigns the file name associated with that page in a single operation. The only difference is in licensing rules.

CreatePageChildElement2

This method is functionally equivalent to calling the following sequence of existing calls:

Examples
VB
Copy
oElement = oParentElement.CreatePage("Page")
oElement.Attribute("ImageFile") = strPageFileName
Essentially, this call creates a new "Page" element and assigns the file name associated with that page in a single operation. The only difference is in licensing rules.

Public method Delete

Deletes the current element.

Public method FindChildElementByAttribute

Extracts a particular child element based on the name of that child element and the value of one of its attributes.

Public method FindChildElementByName

Extracts a particular child element based on its name.

Public method FindChildElementsByAttribute

Extracts a collection of child elements based on their names and attribute values.

Public method FindChildElementsByName

Extracts a collection of child elements based on their name.

Public method FindPartialChildElementsByAttribute

Extracts all child elements based on their names. Also, only a sub-list of possible attributes is extracted.

Public method FindPartialChildElementsByName

Extracts all child elements based on their names. Also, only a sub-list of possible attributes is extracted.

Public method MoveElementBefore

Moves an Element immediately before the passed child.

Public method MoveElementToBatch

Moves a Kofax.Capture.SDK.Data.IACDataElement (Page or Document or Folder) from one open batch to another. MoveElementToBatch automatically deletes the Kofax.Capture.SDK.Data.IACDataElement from the source batch.

Public method MoveToBack

Moves an element to be the last child of the parent.

Public method MoveToFront

Moves an element to be the first child of the parent.

Top
Properties
 | Name | Description
Public property | AttributeNames | Returns a collection of strings corresponding to the valid attribute names for this element type.
Public property | AttributeValue | Gets or sets an attribute value.
Public property | ChildElementNames | Returns a collection of strings corresponding to the valid child element type names.
Public property | ElementName | Returns the name of this element type.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.Data Namespace


IACDataElement Methods

IACDataElement Methods

The IACDataElement type exposes the following members.

Methods
Name Description
Public method AttributeExists

Indicates if an attribute exists in the selected attribute list for this element.

Public method BulkUpdate

Update a collection of Attributes for a given Element

Public method CreateChildElement

Creates a child element of the specified type.

Public method CreateChildElement2

Creates a child element of the specified type.

CreatePageChildElement

This method is functionally equivalent to calling the following sequence of existing calls:

Examples
VB
Copy
oElement = oParentElement.CreatePage("Page")
oElement.Attribute("ImageFile") = strPageFileName
Essentially, this call creates a new "Page" element and assigns the file name associated with that page in a single operation. The only difference is in licensing rules.

CreatePageChildElement2

This method is functionally equivalent to calling the following sequence of existing calls:

Examples
VB
Copy
oElement = oParentElement.CreatePage("Page")
oElement.Attribute("ImageFile") = strPageFileName
Essentially, this call creates a new "Page" element and assigns the file name associated with that page in a single operation. The only difference is in licensing rules.

Public method Delete

Deletes the current element.

Public method FindChildElementByAttribute

Extracts a particular child element based on the name of that child element and the value of one of its attributes.

Public method FindChildElementByName

Extracts a particular child element based on its name.

Public method FindChildElementsByAttribute

Extracts a collection of child elements based on their names and attribute values.

Public method FindChildElementsByName

Extracts a collection of child elements based on their name.

Public method FindPartialChildElementsByAttribute

Extracts all child elements based on their names. Also, only a sub-list of possible attributes is extracted.

Public method FindPartialChildElementsByName

Extracts all child elements based on their names. Also, only a sub-list of possible attributes is extracted.

Public method MoveElementBefore

Moves an Element immediately before the passed child.

Public method MoveElementToBatch

Moves a Kofax.Capture.SDK.Data.IACDataElement (Page or Document or Folder) from one open batch to another. MoveElementToBatch automatically deletes the Kofax.Capture.SDK.Data.IACDataElement from the source batch.

Public method MoveToBack

Moves an element to be the last child of the parent.

Public method MoveToFront

Moves an element to be the first child of the parent.

Top
See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.AttributeExists Method

IACDataElementAttributeExists Method

Indicates if an attribute exists in the selected attribute list for this element.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool AttributeExists(
    string strAttributeName
)
Function AttributeExists (
    strAttributeName As String
) As Boolean

Parameters

strAttributeName
Type: SystemString
The attribute name.

Return Value

Type: Boolean
Remarks
See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.BulkUpdate Method

IACDataElementBulkUpdate Method

Update a collection of Attributes for a given Element

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void BulkUpdate(
    string strElementName,
    IBulkUpdateDataColl oData
)
Sub BulkUpdate (
    strElementName As String,
    oData As IBulkUpdateDataColl
)

Parameters

strElementName
Type: SystemString
Element Name to be update - Preserved for use later, currently only IndexFields is supported.
oData
Type: Kofax.Capture.SDK.DataIBulkUpdateDataColl
The Collection Attributes to be updated.
Remarks
See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.CreateChildElement Method

IACDataElementCreateChildElement Method

Creates a child element of the specified type.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElement CreateChildElement(
    string strElementName
)
Function CreateChildElement (
    strElementName As String
) As IACDataElement

Parameters

strElementName
Type: SystemString
The name of the specified child element type.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement
Remarks

The type name must match one of the possible child element types defined for the current element or an error is thrown.

The created element type must be one of the following:

Page

The current element must be a "Pages" type whose parent is a "Batch" element type. It is not possible to directly create a document page. To accomplish this, create the page as "loose" and then move it into a document.

Document

The current element must be a "Documents" type whose parent is a "Batch" element type. It is not possible to directly create a document as a child of a folder. To accomplish this, create the document under the batch and then move it into a folder.

Folder

The current element must be a "Folders" type whose parent is a "Batch" element type. It is not possible to directly create a folder as a child of another folder. To accomplish this, create the folder under the batch and then move it into a folder.

TableRow

The current element must be a "TableRows" type.

PageCustomStorageString

The current element must be a "PageCustomStorageStrings" type.

DocumentCustomStorageString

The current element must be a "DocumentCustomStorageStrings" type.

FolderCustomStorageString

The current element must be a "FolderCustomStorageStrings" type.

Failure to meet these constraints causes an error.

This method no longer causes an error if a hint has been used. Hints are deprecated and are now ignored.

See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.CreateChildElement2 Method

IACDataElementCreateChildElement2 Method

Creates a child element of the specified type.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElement CreateChildElement2(
    string strElementName,
    string strGUID = null
)
Function CreateChildElement2 (
    strElementName As String,
    Optional strGUID As String = Nothing
) As IACDataElement

Parameters

strElementName
Type: SystemString
The name of the specified child element type.
strGUID (Optional)
Type: SystemString
The GUID of the specified child element type.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement
Remarks

The type name must match one of the possible child element types defined for the current element or an error is thrown.

The created element type must be one of the following:

Page

The current element must be a "Pages" type whose parent is a "Batch" element type. It is not possible to directly create a document page. To accomplish this, create the page as "loose" and then move it into a document.

Document

The current element must be a "Documents" type whose parent is a "Batch" element type. It is not possible to directly create a document as a child of a folder. To accomplish this, create the document under the batch and then move it into a folder.

Folder

The current element must be a "Folders" type whose parent is a "Batch" element type. It is not possible to directly create a folder as a child of another folder. To accomplish this, create the folder under the batch and then move it into a folder.

TableRow

The current element must be a "TableRows" type.

PageCustomStorageString

The current element must be a "PageCustomStorageStrings" type.

DocumentCustomStorageString

The current element must be a "DocumentCustomStorageStrings" type.

FolderCustomStorageString

The current element must be a "FolderCustomStorageStrings" type.

Failure to meet these constraints causes an error.

This method no longer causes an error if a hint has been used. Hints are deprecated and are now ignored.

See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.CreatePageChildElement Method

IACDataElementCreatePageChildElement Method

This method is functionally equivalent to calling the following sequence of existing calls:

Examples
VB
Copy
oElement = oParentElement.CreatePage("Page")
oElement.Attribute("ImageFile") = strPageFileName
Essentially, this call creates a new "Page" element and assigns the file name associated with that page in a single operation. The only difference is in licensing rules.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElement CreatePageChildElement(
    string strPageFileName
)
Function CreatePageChildElement (
    strPageFileName As String
) As IACDataElement

Parameters

strPageFileName
Type: SystemString
The image or eDocument file to use.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement
Remarks
When CreatePageChildElement is called, and a PageFileName is passed representing an eDocument (the extension is other than ".tif"), then the system attempts to use an Import eDocument count license (if present and available), instead of a Scanned/Imported page count license.

Note As with the existing CreateChildElement("Page"), the first attempt to create a page requests a Full Station License.

The attribute name "ImageFile" is misleading because it is also used to assign eDocument file names. The naming is for historical reasons and was exposed prior to the existence of eDocuments in Tungsten Capture.

See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.CreatePageChildElement2 Method

IACDataElementCreatePageChildElement2 Method

This method is functionally equivalent to calling the following sequence of existing calls:

Examples
VB
Copy
oElement = oParentElement.CreatePage("Page")
oElement.Attribute("ImageFile") = strPageFileName
Essentially, this call creates a new "Page" element and assigns the file name associated with that page in a single operation. The only difference is in licensing rules.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElement CreatePageChildElement2(
    string strPageFileName,
    string strGUID = null
)
Function CreatePageChildElement2 (
    strPageFileName As String,
    Optional strGUID As String = Nothing
) As IACDataElement

Parameters

strPageFileName
Type: SystemString
The image or eDocument file to use.
strGUID (Optional)
Type: SystemString
The GUID for the page.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement
Remarks
When CreatePageChildElement is called, and a PageFileName is passed representing an eDocument (the extension is other than ".tif"), then the system attempts to use an Import eDocument count license (if present and available), instead of a Scanned/Imported page count license.

Note As with the existing CreateChildElement("Page"), the first attempt to create a page requests a Full Station License.

The attribute name "ImageFile" is misleading because it is also used to assign eDocument file names. The naming is for historical reasons and was exposed prior to the existence of eDocuments in Tungsten Capture.

See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.Delete Method

IACDataElementDelete Method

Deletes the current element.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Delete()
Sub Delete
Remarks

The deleted element type must be one of the following:

  • Page
  • Document
  • PageCustomStorageString
  • DocumentCustomStorageString
  • TableRow

Failure to meet these constraints causes an error.

This method causes an error if a hint has been used.

See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.FindChildElementByAttribute Method

IACDataElementFindChildElementByAttribute Method

Extracts a particular child element based on the name of that child element and the value of one of its attributes.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElement FindChildElementByAttribute(
    string strChildElementName,
    string strAttributeName,
    string strAttributeValue
)
Function FindChildElementByAttribute (
    strChildElementName As String,
    strAttributeName As String,
    strAttributeValue As String
) As IACDataElement

Parameters

strChildElementName
Type: SystemString
The name of the child element.
strAttributeName
Type: SystemString
The attribute name.
strAttributeValue
Type: SystemString
The attribute value.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement
Remarks

This method is particularly useful for looking up setup objects by name. For instance, a particular Document element might have the FormTypeName as an attribute.

The client code might then look up the corresponding FormType element by name.

This method can be used to extract a particular child element.

All child extractions work on the immediate children of the current element. No facility is provided for doing "deep extraction" of all elements in a hierarchy meeting a certain criteria.

If such facilities are necessary, the client code may opt to use the XML interface instead. Some XML parsers (such as DOM) provide deep extraction methods. Keep in mind that deep extraction (and using XML in general) involves a great deal of additional overhead.

If the parameters specified by this method match multiple child elements, then only the first is returned. If the function does not find a suitable child element, then it returns the "nothing" object. In this case, an exception is not generated.

There is a slight difference in the way this library handles empty sub-collections as compared to the XML. Assume that a batch has no loose pages. The XML output of this batch does not include a "Pages" node since there are no pages.

However, attempting to retrieve the "Pages" node from this API does yield a "Pages" node. This empty node is necessary in order to be able to support various structural editing capabilities (such as creating and moving pages).

See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.FindChildElementByName Method

IACDataElementFindChildElementByName Method

Extracts a particular child element based on its name.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElement FindChildElementByName(
    string strChildElementName
)
Function FindChildElementByName (
    strChildElementName As String
) As IACDataElement

Parameters

strChildElementName
Type: SystemString
The name of the child element.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement
Remarks

This method can be used to extract a particular child element.

All child extractions work on the immediate children of the current element. No facility is provided for doing "deep extraction" of all elements in a hierarchy meeting a certain criteria.

If such facilities are necessary, the client code may opt to use the XML interface instead. Some XML parsers (such as DOM) provide deep extraction methods. Keep in mind that deep extraction (and using XML in general) involves a great deal of additional overhead.

If the parameters specified by this method match multiple child elements, then only the first is returned. If the function does not find a suitable child element, then it returns the "nothing" object. In this case, an exception is not generated.

There is a slight difference in the way this library handles empty sub-collections as compared to the XML. Assume that a batch has no loose pages. The XML output of this batch does not include a "Pages" node since there are no pages.

However, attempting to retrieve the "Pages" node from this API does yield a "Pages" node. This empty node is necessary in order to be able to support various structural editing capabilities (such as creating and moving pages).

See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.FindChildElementsByAttribute Method

IACDataElementFindChildElementsByAttribute Method

Extracts a collection of child elements based on their names and attribute values.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElementCollection FindChildElementsByAttribute(
    string strChildElementName,
    string strAttributeName,
    string strAttributeValue
)
Function FindChildElementsByAttribute (
    strChildElementName As String,
    strAttributeName As String,
    strAttributeValue As String
) As IACDataElementCollection

Parameters

strChildElementName
Type: SystemString
The name of the child element.
strAttributeName
Type: SystemString
The attribute name.
strAttributeValue
Type: SystemString
The attribute value.

Return Value

Type: IACDataElementCollection
Kofax.Capture.SDK.Data.IACDataElementCollection
Remarks
See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.FindChildElementsByName Method

IACDataElementFindChildElementsByName Method

Extracts a collection of child elements based on their name.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElementCollection FindChildElementsByName(
    string strChildElementName
)
Function FindChildElementsByName (
    strChildElementName As String
) As IACDataElementCollection

Parameters

strChildElementName
Type: SystemString
The name of the child element.

Return Value

Type: IACDataElementCollection
Kofax.Capture.SDK.Data.IACDataElementCollection
Remarks
See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.FindPartialChildElementsByAttribute Method

IACDataElementFindPartialChildElementsByAttribute Method

Extracts all child elements based on their names. Also, only a sub-list of possible attributes is extracted.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElementCollection FindPartialChildElementsByAttribute(
    ref IACDataElementAttributeColl oAttributeList,
    string strChildElementName,
    string strAttributeName,
    string strAttributeValue
)
Function FindPartialChildElementsByAttribute (
    ByRef oAttributeList As IACDataElementAttributeColl,
    strChildElementName As String,
    strAttributeName As String,
    strAttributeValue As String
) As IACDataElementCollection

Parameters

oAttributeList
Type: Kofax.Capture.SDK.DataIACDataElementAttributeColl
A collection of selected attribute names.
strChildElementName
Type: SystemString
The name of the child element.
strAttributeName
Type: SystemString
The attribute name.
strAttributeValue
Type: SystemString
The attribute value.

Return Value

Type: IACDataElementCollection
Kofax.Capture.SDK.Data.IACDataElementCollection
Remarks

When extracting collections, it may sometimes be optimal to extract only some of the attributes of a sub-element list. For example, to determine if there are any rejected loose pages, it may only be necessary to extract the "Rejected" attribute of those pages.

Attribute sub-lists impose some extra overhead that actually slows down query generation. The benefits of the optimization are only felt when many sub-elements are extracted. Therefore, it is better to use attribute sub-lists only when processing large collections of elements (a hundred or more) where only one or two attributes are needed.

See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.FindPartialChildElementsByName Method

IACDataElementFindPartialChildElementsByName Method

Extracts all child elements based on their names. Also, only a sub-list of possible attributes is extracted.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElementCollection FindPartialChildElementsByName(
    ref IACDataElementAttributeColl oAttributeList,
    string strChildElementName
)
Function FindPartialChildElementsByName (
    ByRef oAttributeList As IACDataElementAttributeColl,
    strChildElementName As String
) As IACDataElementCollection

Parameters

oAttributeList
Type: Kofax.Capture.SDK.DataIACDataElementAttributeColl
A collection of selected attribute names.
strChildElementName
Type: SystemString
The name of the child element.

Return Value

Type: IACDataElementCollection
Kofax.Capture.SDK.Data.IACDataElementCollection
Remarks

When extracting collections, it may sometimes be optimal to extract only some of the attributes of a sub-element list. For example, to determine if there are any rejected loose pages, it may only be necessary to extract the "Rejected" attribute of those pages.

Attribute sub-lists impose some extra overhead that actually slows down query generation. The benefits of the optimization are only felt when many sub-elements are extracted. Therefore, it is better to use attribute sub-lists only when processing large collections of elements (a hundred or more) where only one or two attributes are needed.

See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.MoveElementBefore Method

IACDataElementMoveElementBefore Method

Moves an Element immediately before the passed child.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void MoveElementBefore(
    ref IACDataElement oAfterSib
)
Sub MoveElementBefore (
    ByRef oAfterSib As IACDataElement
)

Parameters

oAfterSib
Type: Kofax.Capture.SDK.DataIACDataElement
The child object.
Remarks
The following rules are allowed:
  • Move a Page element before another Page element
  • Move a Document element before another Document element
  • Move a Folder element before another Folder element

Failure to meet these constraints causes an error.

See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.MoveElementToBatch Method

IACDataElementMoveElementToBatch Method

Moves a Kofax.Capture.SDK.Data.IACDataElement (Page or Document or Folder) from one open batch to another. MoveElementToBatch automatically deletes the Kofax.Capture.SDK.Data.IACDataElement from the source batch.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElement MoveElementToBatch(
    ref IACDataElement oElement
)
Function MoveElementToBatch (
    ByRef oElement As IACDataElement
) As IACDataElement

Parameters

oElement
Type: Kofax.Capture.SDK.DataIACDataElement
The element to be moved from the source batch.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement
Remarks
See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.MoveToBack Method

IACDataElementMoveToBack Method

Moves an element to be the last child of the parent.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void MoveToBack(
    ref IACDataElement oParent
)
Sub MoveToBack (
    ByRef oParent As IACDataElement
)

Parameters

oParent
Type: Kofax.Capture.SDK.DataIACDataElement
The parent object.
Remarks
The following rules are allowed:
  • If the current element is a Page element, then the oParent element must be a Pages element whose parent is either a Document or a Batch element.
  • If the current element is a Document element, then the oParent element must be a Documents element whose parent is either a Folder or a Batch element.
  • If the current element is a Folder element, then the oParent element must be a Folder element whose parent is either a Folder or a Batch element.

Failure to meet these constraints causes an error.

See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.MoveToFront Method

IACDataElementMoveToFront Method

Moves an element to be the first child of the parent.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void MoveToFront(
    ref IACDataElement oParent
)
Sub MoveToFront (
    ByRef oParent As IACDataElement
)

Parameters

oParent
Type: Kofax.Capture.SDK.DataIACDataElement
The parent object.
Remarks
The following rules are allowed:
  • If the current element is a Page element, then the oParent element must be a Pages element whose parent is either a Document or a Batch element.
  • If the current element is a Document element, then the oParent element must be a Documents element whose parent is either a Folder or a Batch element.
  • If the current element is a Folder element, then the oParent element must be a Folder element whose parent is either a Folder or a Batch element.
See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement Properties

IACDataElement Properties

The IACDataElement type exposes the following members.

Properties
 | Name | Description
Public property | AttributeNames | Returns a collection of strings corresponding to the valid attribute names for this element type.
Public property | AttributeValue | Gets or sets an attribute value.
Public property | ChildElementNames | Returns a collection of strings corresponding to the valid child element type names.
Public property | ElementName | Returns the name of this element type.
Top
See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.AttributeNames Property

IACDataElementAttributeNames Property

Returns a collection of strings corresponding to the valid attribute names for this element type.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ArrayList AttributeNames { get; }
ReadOnly Property AttributeNames As ArrayList
    Get

Property Value

Type: ArrayList
A collection of attribute names.

Return Value

Type: ArrayList
System.Collections.ArrayList
Remarks
See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.AttributeValue Property

IACDataElementAttributeValue Property

Gets or sets an attribute value.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strAttributeName
] { get; set; }
Default Property AttributeValue (
    strAttributeName As String
) As String
    Get
    Set

Parameters

strAttributeName
Type: SystemString
The attribute name to retrieve or modify.

Property Value

Type: String
An attribute value.

Return Value

Type: String
String
Remarks
Throws an error if the attribute name is not valid.
See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.ChildElementNames Property

IACDataElementChildElementNames Property

Returns a collection of strings corresponding to the valid child element type names.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
ArrayList ChildElementNames { get; }
ReadOnly Property ChildElementNames As ArrayList
    Get

Property Value

Type: ArrayList
A collection of child element type names.

Return Value

Type: ArrayList
System.Collections.ArrayList
Remarks
See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElement.ElementName Property

IACDataElementElementName Property

Returns the name of this element type.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ElementName { get; }
ReadOnly Property ElementName As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IACDataElement Interface
Kofax.Capture.SDK.Data Namespace


IACDataElementAttributeColl Interface

IACDataElementAttributeColl Interface

This object allows specification of attribute sub-lists. Refer to FindPartialChildElementsByName(IACDataElementAttributeColl, String) and FindPartialChildElementsByAttribute(IACDataElementAttributeColl, String, String, String).

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACDataElementAttributeColl : IEnumerable
Public Interface IACDataElementAttributeColl
    Inherits IEnumerable

The IACDataElementAttributeColl type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the attribute to the collection.
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Remove | Removes an attribute from the collection, based on its 1-based numeric index, or by name.
Top
Properties
 | Name | Description
Public property | Count | Returns the number of attributes in the collection.
Public property | Item | Returns an attribute based on its 1-based numeric index, or by name.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.Data Namespace


IACDataElementAttributeColl Methods

IACDataElementAttributeColl Methods

The IACDataElementAttributeColl type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the attribute to the collection.
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Remove | Removes an attribute from the collection, based on its 1-based numeric index, or by name.
Top
See Also

Reference

IACDataElementAttributeColl Interface
Kofax.Capture.SDK.Data Namespace


IACDataElementAttributeColl.Add Method

IACDataElementAttributeCollAdd Method

Adds the attribute to the collection.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Add(
    ref string strItem
)
Sub Add (
    ByRef strItem As String
)

Parameters

strItem
Type: SystemString
The attribute to add.
Remarks
See Also

Reference

IACDataElementAttributeColl Interface
Kofax.Capture.SDK.Data Namespace


IACDataElementAttributeColl.Remove Method

IACDataElementAttributeCollRemove Method

Removes an attribute from the collection, based on its 1-based numeric index, or by name.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Remove(
    ref Object oIndex
)
Sub Remove (
    ByRef oIndex As Object
)

Parameters

oIndex
Type: SystemObject
The key or value of the attribute to remove.
Remarks
See Also

Reference

IACDataElementAttributeColl Interface
Kofax.Capture.SDK.Data Namespace


IACDataElementAttributeColl Properties

IACDataElementAttributeColl Properties

The IACDataElementAttributeColl type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of attributes in the collection.
Public property | Item | Returns an attribute based on its 1-based numeric index, or by name.
Top
See Also

Reference

IACDataElementAttributeColl Interface
Kofax.Capture.SDK.Data Namespace


IACDataElementAttributeColl.Count Property

IACDataElementAttributeCollCount Property

Returns the number of attributes in the collection.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IACDataElementAttributeColl Interface
Kofax.Capture.SDK.Data Namespace


IACDataElementAttributeColl.Item Property

IACDataElementAttributeCollItem Property

Returns an attribute based on its 1-based numeric index, or by name.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    Object oIndex
] { get; }
ReadOnly Default Property Item (
    oIndex As Object
) As String
    Get

Parameters

oIndex
Type: SystemObject
The index of the item to be retrieved.

Return Value

Type: String
String
Remarks
See Also

Reference

IACDataElementAttributeColl Interface
Kofax.Capture.SDK.Data Namespace


IACDataElementCollection Interface

IACDataElementCollection Interface

Defines a collection of ACDataElement objects.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACDataElementCollection : IEnumerable
Public Interface IACDataElementCollection
    Inherits IEnumerable

The IACDataElementCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | (Inherited from IEnumerable.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of elements in the collection.
Public property | Item | Retrieves an object from the collection, by 1-based numeric index or by key.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.Data Namespace


IACDataElementCollection Methods

IACDataElementCollection Methods

The IACDataElementCollection type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | (Inherited from IEnumerable.)
Top
See Also

Reference

IACDataElementCollection Interface
Kofax.Capture.SDK.Data Namespace


IACDataElementCollection Properties

IACDataElementCollection Properties

The IACDataElementCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of elements in the collection.
Public property | Item | Retrieves an object from the collection, by 1-based numeric index or by key.
Top
See Also

Reference

IACDataElementCollection Interface
Kofax.Capture.SDK.Data Namespace


IACDataElementCollection.Count Property

IACDataElementCollectionCount Property

Returns the number of elements in the collection.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IACDataElementCollection Interface
Kofax.Capture.SDK.Data Namespace


IACDataElementCollection.Item Property

IACDataElementCollectionItem Property

Retrieves an object from the collection, by 1-based numeric index or by key.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElement this[
    int nIndex
] { get; }
ReadOnly Default Property Item (
    nIndex As Integer
) As IACDataElement
    Get

Parameters

nIndex
Type: SystemInt32
The index or key of the item to be retrieved.

Property Value

Type: IACDataElement

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement
Remarks

There is no support for looking up a sub-element by a key value.

To extract a sub-element by key value, use the method “FindChildElementByAttribute” on the collection parent.

See Also

Reference

IACDataElementCollection Interface
Kofax.Capture.SDK.Data Namespace


IAttributeValueColl Interface

IAttributeValueColl Interface

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IAttributeValueColl : IEnumerable
Public Interface IAttributeValueColl
    Inherits IEnumerable

The IAttributeValueColl type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Count |
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Item |
Public method | Remove |
Top
See Also

Reference

Kofax.Capture.SDK.Data Namespace


IAttributeValueColl Methods

IAttributeValueColl Methods

The IAttributeValueColl type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Count |
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Item |
Public method | Remove |
Top
See Also

Reference

IAttributeValueColl Interface
Kofax.Capture.SDK.Data Namespace


IAttributeValueColl.Add Method

IAttributeValueCollAdd Method

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Add(
    INameValuePair oItem
)
Sub Add (
    oItem As INameValuePair
)

Parameters

oItem
Type: Kofax.Capture.SDK.DataINameValuePair
See Also

Reference

IAttributeValueColl Interface
Kofax.Capture.SDK.Data Namespace


IAttributeValueColl.Count Method

IAttributeValueCollCount Method

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count()
Function Count As Integer

Return Value

Type: Int32
See Also

Reference

IAttributeValueColl Interface
Kofax.Capture.SDK.Data Namespace


IAttributeValueColl.Item Method

IAttributeValueCollItem Method

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
INameValuePair Item(
    ref int strKey
)
Function Item (
    ByRef strKey As Integer
) As INameValuePair

Parameters

strKey
Type: SystemInt32

Return Value

Type: INameValuePair
See Also

Reference

IAttributeValueColl Interface
Kofax.Capture.SDK.Data Namespace


IAttributeValueColl.Remove Method

IAttributeValueCollRemove Method

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Remove(
    ref int strKey
)
Sub Remove (
    ByRef strKey As Integer
)

Parameters

strKey
Type: SystemInt32
See Also

Reference

IAttributeValueColl Interface
Kofax.Capture.SDK.Data Namespace


IBulkUpdateDataColl Interface

IBulkUpdateDataColl Interface

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IBulkUpdateDataColl : IEnumerable
Public Interface IBulkUpdateDataColl
    Inherits IEnumerable

The IBulkUpdateDataColl type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Count |
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Item |
Public method | Remove |
Top
See Also

Reference

Kofax.Capture.SDK.Data Namespace


IBulkUpdateDataColl Methods

IBulkUpdateDataColl Methods

The IBulkUpdateDataColl type exposes the following members.

Methods
 | Name | Description
Public method | Add |
Public method | Count |
Public method | GetEnumerator | (Inherited from IEnumerable.)
Public method | Item |
Public method | Remove |
Top
See Also

Reference

IBulkUpdateDataColl Interface
Kofax.Capture.SDK.Data Namespace


IBulkUpdateDataColl.Add Method

IBulkUpdateDataCollAdd Method

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Add(
    IAttributeValueColl oItem
)
Sub Add (
    oItem As IAttributeValueColl
)

Parameters

oItem
Type: Kofax.Capture.SDK.DataIAttributeValueColl
See Also

Reference

IBulkUpdateDataColl Interface
Kofax.Capture.SDK.Data Namespace


IBulkUpdateDataColl.Count Method

IBulkUpdateDataCollCount Method

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count()
Function Count As Integer

Return Value

Type: Int32
See Also

Reference

IBulkUpdateDataColl Interface
Kofax.Capture.SDK.Data Namespace


IBulkUpdateDataColl.Item Method

IBulkUpdateDataCollItem Method

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IAttributeValueColl Item(
    ref int nIndex
)
Function Item (
    ByRef nIndex As Integer
) As IAttributeValueColl

Parameters

nIndex
Type: SystemInt32

Return Value

Type: IAttributeValueColl
See Also

Reference

IBulkUpdateDataColl Interface
Kofax.Capture.SDK.Data Namespace


IBulkUpdateDataColl.Remove Method

IBulkUpdateDataCollRemove Method

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void Remove(
    ref int nIndex
)
Sub Remove (
    ByRef nIndex As Integer
)

Parameters

nIndex
Type: SystemInt32
See Also

Reference

IBulkUpdateDataColl Interface
Kofax.Capture.SDK.Data Namespace


INameValuePair Interface

INameValuePair Interface

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface INameValuePair
Public Interface INameValuePair

The INameValuePair type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
See Also

Reference

Kofax.Capture.SDK.Data Namespace


INameValuePair Properties

INameValuePair Properties

The INameValuePair type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | Value |
Top
See Also

Reference

INameValuePair Interface
Kofax.Capture.SDK.Data Namespace


INameValuePair.Name Property

INameValuePairName Property

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; set; }
Property Name As String
    Get
    Set

Property Value

Type: String
See Also

Reference

INameValuePair Interface
Kofax.Capture.SDK.Data Namespace


INameValuePair.Value Property

INameValuePairValue Property

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Value { get; set; }
Property Value As String
    Get
    Set

Property Value

Type: String
See Also

Reference

INameValuePair Interface
Kofax.Capture.SDK.Data Namespace


InvalidArgumentException Class

InvalidArgumentException Class

Defines InvalidArgumentException object which is thrown when invalid argument was passed in.

Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.Runtime.InteropServicesCOMException
Kofax.Capture.SDK.DataKfxException
Kofax.Capture.SDK.DataInvalidArgumentException

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class InvalidArgumentException : KfxException
Public Class InvalidArgumentException
    Inherits KfxException

The InvalidArgumentException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidArgumentException(String, ACDataElementErrorValue) | Initializes a new instance of the Kofax.Capture.SDK.Data.InvalidArgumentException class.
Public method | InvalidArgumentException(String, Int32, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.InvalidArgumentException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
Remarks
One of the following error numbers should be passed in:
  • ErrHintsNotSupportedForSetup -- Hints are not supported for retrieving Tungsten Capture Setup elements.
  • ErrInvalidHintsForRuntime -- Invalid hints were detected.
  • ErrInvalidRootName -- Invalid root name was detected.
  • ErrInvalidRecordset -- Empty recordset was detected when creating an ACDataElement.
  • ErrInvalidElementName -- Empty child element name was detected when creating a child ACDataElement.
  • ErrInvalidFormTypeName -- Invalid form type name.
  • ErrInvalidFolderClassName -- Invalid folder class name.
  • ErrFilteringAttributeNotExistInKfxSchema -- The specified filtering attribute is not defined for the specified element type.
  • ErrNotAllowAttributesForCollectionElement -- The specified attribute is not defined for the current collection element.
  • ErrAttributeNotExistInKfxSchema -- The specified attribute is not defined for the current element.
  • ErrAttributeNotExistInSelectedColumns -- The specified attribute is not in the selected attribute list.
  • ErrTranslateAttributeUpdateNotAllowed -- Updates are not allowed for the specified (translated) attribute.
  • ErrChildNotExist -- Invalid child element was specified for the current element.
  • ErrFilteringAttributeNotDatabaseField -- The specified filtering attribute does not correspond to a database field.
  • ErrEmptySelectAttributeList -- The collection of selected attributes must include at least one item.
  • ErrInvalidPriorityValue -- The value of the Priority attribute must be between 1 and 10.
  • ErrAttributesNotAllowedForCollectionElement -- You cannot specify a list of attributes with a collection element type.
  • ErrInvalidAttributeValue -- You cannot update a translated value with an empty string.
  • ErrExpectPagesAsParent -- Invalid parent element. 'Pages' parent element expected.
  • ErrExpectPageAsSibling -- Invalid sibling element. 'Page' sibling element expected.
  • ErrBadParameter -- Bad parameter range.
  • ErrTableMismatch -- The table type does not match the corresponding recordset.
See Also

Reference

Kofax.Capture.SDK.Data Namespace


InvalidArgumentException Constructor

InvalidArgumentException Constructor
Overload List
 | Name | Description
Public method | InvalidArgumentException(String, ACDataElementErrorValue) | Initializes a new instance of the Kofax.Capture.SDK.Data.InvalidArgumentException class.
Public method | InvalidArgumentException(String, Int32, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.InvalidArgumentException class.
Top
See Also

Reference

InvalidArgumentException Class
Kofax.Capture.SDK.Data Namespace


InvalidArgumentException Constructor (String, ACDataElementErrorValue)

InvalidArgumentException Constructor (String, ACDataElementErrorValue)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.InvalidArgumentException class.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public InvalidArgumentException(
    string strMsg,
    ACDataElementErrorValue errNum
)
Public Sub New (
    strMsg As String,
    errNum As ACDataElementErrorValue
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.DataACDataElementErrorValue
The original error number.
Remarks
See Also

Reference

InvalidArgumentException Class
InvalidArgumentException Overload
Kofax.Capture.SDK.Data Namespace


InvalidArgumentException Constructor (String, Int32, Object)

InvalidArgumentException Constructor (String, Int32, Object)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.InvalidArgumentException class.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public InvalidArgumentException(
    string strMsg,
    int errNum,
    Object oSource
)
Public Sub New (
    strMsg As String,
    errNum As Integer,
    oSource As Object
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: SystemInt32
The original error number.
oSource
Type: SystemObject
The source.
Remarks
See Also

Reference

InvalidArgumentException Class
InvalidArgumentException Overload
Kofax.Capture.SDK.Data Namespace


InvalidArgumentException Methods

InvalidArgumentException Methods

The InvalidArgumentException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
See Also

Reference

InvalidArgumentException Class
Kofax.Capture.SDK.Data Namespace


InvalidArgumentException Properties

InvalidArgumentException Properties

The InvalidArgumentException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
See Also

Reference

InvalidArgumentException Class
Kofax.Capture.SDK.Data Namespace


InvalidOperationException Class

InvalidOperationException Class
InvalidOperationException is thrown when invalid operation was called.
Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.Runtime.InteropServicesCOMException
Kofax.Capture.SDK.DataKfxException
Kofax.Capture.SDK.DataInvalidOperationException

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class InvalidOperationException : KfxException
Public Class InvalidOperationException
    Inherits KfxException

The InvalidOperationException type exposes the following members.

Constructors
 | Name | Description
Public method | InvalidOperationException(String, ACDataElementErrorValue) | Initializes a new instance of the Kofax.Capture.SDK.Data.InvalidOperationException class.
Public method | InvalidOperationException(String, Int32, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.InvalidOperationException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
Remarks
One of the following error numbers should be passed in:
  • ErrNotAllowBitonalImageFile -- You cannot specify a BitonalImageFile when the current page is an eDocument.
  • ErrRecordsetTableType -- You cannot delete elements of this type.
  • ErrCreateDocPage -- Creation of document pages is not supported.
  • ErrInvalidChild -- The proposed element type cannot be created as a child of the parent table.
  • ErrInvalidSource -- The source element type is not supported for this operation.
  • ErrInvalidDest -- The destination element type is not supported for this operation.
  • ErrElementDeleted -- The element has been deleted.
  • ErrViolateReadOnly -- This attribute cannot be updated.
  • ErrNotAllowStructureUpdates -- Structural updates are not allowed on elements when the root node was extracted with hints.
  • ErrRootAttributeUpdateNotAllowed -- Attribute value updates are not allowed for root elements.
  • ErrNoStatistics -- Statistics attributes are not supported within this environment.
See Also

Reference

Kofax.Capture.SDK.Data Namespace


InvalidOperationException Constructor

InvalidOperationException Constructor
Overload List
 | Name | Description
Public method | InvalidOperationException(String, ACDataElementErrorValue) | Initializes a new instance of the Kofax.Capture.SDK.Data.InvalidOperationException class.
Public method | InvalidOperationException(String, Int32, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.InvalidOperationException class.
Top
See Also

Reference

InvalidOperationException Class
Kofax.Capture.SDK.Data Namespace


InvalidOperationException Constructor (String, ACDataElementErrorValue)

InvalidOperationException Constructor (String, ACDataElementErrorValue)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.InvalidOperationException class.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public InvalidOperationException(
    string strMsg,
    ACDataElementErrorValue errNum
)
Public Sub New (
    strMsg As String,
    errNum As ACDataElementErrorValue
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.DataACDataElementErrorValue
The original error number.
Remarks
See Also

Reference

InvalidOperationException Class
InvalidOperationException Overload
Kofax.Capture.SDK.Data Namespace


InvalidOperationException Constructor (String, Int32, Object)

InvalidOperationException Constructor (String, Int32, Object)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.InvalidOperationException class.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public InvalidOperationException(
    string strMsg,
    int errNum,
    Object oSource
)
Public Sub New (
    strMsg As String,
    errNum As Integer,
    oSource As Object
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: SystemInt32
The original error number.
oSource
Type: SystemObject
The source.
Remarks
See Also

Reference

InvalidOperationException Class
InvalidOperationException Overload
Kofax.Capture.SDK.Data Namespace


InvalidOperationException Methods

InvalidOperationException Methods

The InvalidOperationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
See Also

Reference

InvalidOperationException Class
Kofax.Capture.SDK.Data Namespace


InvalidOperationException Properties

InvalidOperationException Properties

The InvalidOperationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
See Also

Reference

InvalidOperationException Class
Kofax.Capture.SDK.Data Namespace


KfxException Class

KfxException Class

Defines Kofax Exception class that inherits a COMException.

Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.Runtime.InteropServicesCOMException
Kofax.Capture.SDK.DataKfxException
More...

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class KfxException : COMException
Public Class KfxException
    Inherits COMException

The KfxException type exposes the following members.

Constructors
 | Name | Description
Public method | KfxException(String, KfxException) | Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with the module ID and error number and an original exception object. The newly constructed exception will have the same Source and TargetSite property values from the original excepion.
Public method | KfxException(String, Int32, String) | Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with no object arguments to be formatted and no specified source. In this case, the source is default to the name of the calling assembly.
Public method | KfxException(String, Int32, String, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with a message and arguments and also takes an original KfxException object. The newly constructed exception will use all error info (message, error number, stack trace, etc.) except the message and arguments from the original exception.
Public method | KfxException(String, Object, Int32, String) | Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with the module ID and error number that takes an original exception object.
Public method | KfxException(String, Object, Int32, String, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with the module ID and error number that takes an original exception object.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number.
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Overrides ExceptionMessage.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted.
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters.
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message".
Public property | ModuleID | Gets the module ID.
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Overrides ExceptionSource.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Overrides ExceptionStackTrace.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property.
Top
Remarks
Derived classes should be sure to implement ISerializable for any additional data.
See Also

Reference

Kofax.Capture.SDK.Data Namespace
Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.Runtime.InteropServicesCOMException
Kofax.Capture.SDK.DataKfxException
Kofax.Capture.SDK.CustomModuleCannotCreateChildFromCurrentBatchException
Kofax.Capture.SDK.CustomModuleFailedToCreateChildBatchException
Kofax.Capture.SDK.CustomModuleInvalidArgumentException
Kofax.Capture.SDK.CustomModuleInvalidOperationException
Kofax.Capture.SDK.CustomModuleLicensingException
Kofax.Capture.SDK.CustomModuleLoginException
Kofax.Capture.SDK.DataDataErrorException
Kofax.Capture.SDK.DataInvalidArgumentException
Kofax.Capture.SDK.DataInvalidOperationException
Kofax.Capture.SDK.DataLicensingException
Kofax.Capture.SDK.DataOptimizedCustomModuleException


KfxException Constructor

KfxException Constructor
Overload List
 | Name | Description
Public method | KfxException(String, KfxException) | Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with the module ID and error number and an original exception object. The newly constructed exception will have the same Source and TargetSite property values from the original excepion.
Public method | KfxException(String, Int32, String) | Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with no object arguments to be formatted and no specified source. In this case, the source is default to the name of the calling assembly.
Public method | KfxException(String, Int32, String, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with a message and arguments and also takes an original KfxException object. The newly constructed exception will use all error info (message, error number, stack trace, etc.) except the message and arguments from the original exception.
Public method | KfxException(String, Object, Int32, String) | Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with the module ID and error number that takes an original exception object.
Public method | KfxException(String, Object, Int32, String, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with the module ID and error number that takes an original exception object.
Top
See Also

Reference

KfxException Class
Kofax.Capture.SDK.Data Namespace


KfxException Constructor (String, KfxException)

KfxException Constructor (String, KfxException)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with the module ID and error number and an original exception object. The newly constructed exception will have the same Source and TargetSite property values from the original excepion.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public KfxException(
    string strModuleID,
    KfxException oExc
)
Public Sub New (
    strModuleID As String,
    oExc As KfxException
)

Parameters

strModuleID
Type: SystemString
The module ID of the code that throws the exception.
oExc
Type: Kofax.Capture.SDK.DataKfxException
The original Exception object.
See Also

Reference

KfxException Class
KfxException Overload
Kofax.Capture.SDK.Data Namespace


KfxException Constructor (String, Int32, String)

KfxException Constructor (String, Int32, String)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with no object arguments to be formatted and no specified source. In this case, the source is default to the name of the calling assembly.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public KfxException(
    string strModuleID,
    int nError,
    string strMessage
)
Public Sub New (
    strModuleID As String,
    nError As Integer,
    strMessage As String
)

Parameters

strModuleID
Type: SystemString
The module ID of the code that throws the exception.
nError
Type: SystemInt32
The error number.
strMessage
Type: SystemString
The error message.
See Also

Reference

KfxException Class
KfxException Overload
Kofax.Capture.SDK.Data Namespace


KfxException Constructor (String, Int32, String, Object[])

KfxException Constructor (String, Int32, String, Object)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with a message and arguments and also takes an original KfxException object. The newly constructed exception will use all error info (message, error number, stack trace, etc.) except the message and arguments from the original exception.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public KfxException(
    string strModuleID,
    int nError,
    string strMessage,
    Object[] oArgArray
)
Public Sub New (
    strModuleID As String,
    nError As Integer,
    strMessage As String,
    oArgArray As Object()
)

Parameters

strModuleID
Type: SystemString
nError
Type: SystemInt32
strMessage
Type: SystemString
The error message.
oArgArray
Type: SystemObject
Includes arguments used to format the error string. Passes null if the message does not need to be formated.
See Also

Reference

KfxException Class
KfxException Overload
Kofax.Capture.SDK.Data Namespace


KfxException Constructor (String, Object, Int32, String)

KfxException Constructor (String, Object, Int32, String)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with the module ID and error number that takes an original exception object.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public KfxException(
    string strModuleID,
    Object oSource,
    int nError,
    string strMessage
)
Public Sub New (
    strModuleID As String,
    oSource As Object,
    nError As Integer,
    strMessage As String
)

Parameters

strModuleID
Type: SystemString
The module ID of the code that throws the exception.
oSource
Type: SystemObject
The source that creates the exception.
nError
Type: SystemInt32
The error number.
strMessage
Type: SystemString
The error message.
See Also

Reference

KfxException Class
KfxException Overload
Kofax.Capture.SDK.Data Namespace


KfxException Constructor (String, Object, Int32, String, Object[])

KfxException Constructor (String, Object, Int32, String, Object)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.KfxException class with the module ID and error number that takes an original exception object.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public KfxException(
    string strModuleID,
    Object oSource,
    int nError,
    string strMessage,
    Object[] oArgArray
)
Public Sub New (
    strModuleID As String,
    oSource As Object,
    nError As Integer,
    strMessage As String,
    oArgArray As Object()
)

Parameters

strModuleID
Type: SystemString
The module ID of the code that throws the exception.
oSource
Type: SystemObject
The source that creates the exception.
nError
Type: SystemInt32
The error number.
strMessage
Type: SystemString
The error message.
oArgArray
Type: SystemObject
Includes arguments used to format the error string. Passes null if the message does not need to be formated.
See Also

Reference

KfxException Class
KfxException Overload
Kofax.Capture.SDK.Data Namespace


KfxException Methods

KfxException Methods

The KfxException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
See Also

Reference

KfxException Class
Kofax.Capture.SDK.Data Namespace


KfxException.GetObjectData Method

KfxExceptionGetObjectData Method

Custom serialization required because Exception implements ISerializable.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public override void GetObjectData(
    SerializationInfo oInfo,
    StreamingContext oContext
)
Public Overrides Sub GetObjectData (
    oInfo As SerializationInfo,
    oContext As StreamingContext
)

Parameters

oInfo
Type: System.Runtime.SerializationSerializationInfo
Serialization information.
oContext
Type: System.Runtime.SerializationStreamingContext
Serialization context.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

KfxException Class
Kofax.Capture.SDK.Data Namespace


KfxException Properties

KfxException Properties

The KfxException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number.
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Overrides ExceptionMessage.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted.
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters.
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message".
Public property | ModuleID | Gets the module ID.
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Overrides ExceptionSource.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Overrides ExceptionStackTrace.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property.
Top
See Also

Reference

KfxException Class
Kofax.Capture.SDK.Data Namespace


KfxException.Error Property

KfxExceptionError Property

Gets the error number.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public int Error { get; }
Public ReadOnly Property Error As Integer
    Get

Property Value

Type: Int32
See Also

Reference

KfxException Class
Kofax.Capture.SDK.Data Namespace


KfxException.Message Property

KfxExceptionMessage Property

Gets the message, and formats it first if necessary. The module ID is alsways appended to the message.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
    Get

Property Value

Type: String

Implements

_ExceptionMessage
See Also

Reference

KfxException Class
Kofax.Capture.SDK.Data Namespace


KfxException.MessageArguments Property

KfxExceptionMessageArguments Property

Gets the message arguments and array of object items to be formatted.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Object[] MessageArguments { get; }
Public ReadOnly Property MessageArguments As Object()
    Get

Property Value

Type: Object
See Also

Reference

KfxException Class
Kofax.Capture.SDK.Data Namespace


KfxException.MessageUnformatted Property

KfxExceptionMessageUnformatted Property

Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string MessageUnformatted { get; }
Public ReadOnly Property MessageUnformatted As String
    Get

Property Value

Type: String
See Also

Reference

KfxException Class
Kofax.Capture.SDK.Data Namespace


KfxException.MessageWithNumber Property

KfxExceptionMessageWithNumber Property

Gets the message formatted as "[#]ModuleID:Message".

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string MessageWithNumber { get; }
Public ReadOnly Property MessageWithNumber As String
    Get

Property Value

Type: String
See Also

Reference

KfxException Class
Kofax.Capture.SDK.Data Namespace


KfxException.ModuleID Property

KfxExceptionModuleID Property

Gets the module ID.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ModuleID { get; }
Public ReadOnly Property ModuleID As String
    Get

Property Value

Type: String
See Also

Reference

KfxException Class
Kofax.Capture.SDK.Data Namespace


KfxException.Source Property

KfxExceptionSource Property

Gets the Source of this exception, or of the inner exception if this exception does not have the Source info.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public override string Source { get; set; }
Public Overrides Property Source As String
    Get
    Set

Property Value

Type: String

Implements

_ExceptionSource
See Also

Reference

KfxException Class
Kofax.Capture.SDK.Data Namespace


KfxException.StackTrace Property

KfxExceptionStackTrace Property

Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public override string StackTrace { get; }
Public Overrides ReadOnly Property StackTrace As String
    Get

Property Value

Type: String

Implements

_ExceptionStackTrace
See Also

Reference

KfxException Class
Kofax.Capture.SDK.Data Namespace


KfxException.TargetSiteInternal Property

KfxExceptionTargetSiteInternal Property

Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public virtual MethodBase TargetSiteInternal { get; }
Public Overridable ReadOnly Property TargetSiteInternal As MethodBase
    Get

Property Value

Type: MethodBase
See Also

Reference

KfxException Class
Kofax.Capture.SDK.Data Namespace
ExceptionTargetSite


LicensingException Class

LicensingException Class

Defines LicensingException object which is thrown when having issues with licensing.

Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.Runtime.InteropServicesCOMException
Kofax.Capture.SDK.DataKfxException
Kofax.Capture.SDK.DataLicensingException

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class LicensingException : KfxException
Public Class LicensingException
    Inherits KfxException

The LicensingException type exposes the following members.

Constructors
 | Name | Description
Public method | LicensingException(String, ACDataElementErrorValue) | Initializes a new instance of the Kofax.Capture.SDK.Data.LicensingException class.
Public method | LicensingException(String, Int32, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.LicensingException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
Remarks
One of the following error numbers should be passed in:
  • ErrNoVolume -- Insufficient volume licensing available. Obtain a new activation code that reflects your actual licensing requirements.
  • ErrBadResponse -- Invalid License Server challenge.
See Also

Reference

Kofax.Capture.SDK.Data Namespace


LicensingException Constructor

LicensingException Constructor
Overload List
 | Name | Description
Public method | LicensingException(String, ACDataElementErrorValue) | Initializes a new instance of the Kofax.Capture.SDK.Data.LicensingException class.
Public method | LicensingException(String, Int32, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.LicensingException class.
Top
See Also

Reference

LicensingException Class
Kofax.Capture.SDK.Data Namespace


LicensingException Constructor (String, ACDataElementErrorValue)

LicensingException Constructor (String, ACDataElementErrorValue)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.LicensingException class.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public LicensingException(
    string strMsg,
    ACDataElementErrorValue errNum
)
Public Sub New (
    strMsg As String,
    errNum As ACDataElementErrorValue
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.DataACDataElementErrorValue
The original error number.
Remarks
See Also

Reference

LicensingException Class
LicensingException Overload
Kofax.Capture.SDK.Data Namespace


LicensingException Constructor (String, Int32, Object)

LicensingException Constructor (String, Int32, Object)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.LicensingException class.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public LicensingException(
    string strMsg,
    int errNum,
    Object oSource
)
Public Sub New (
    strMsg As String,
    errNum As Integer,
    oSource As Object
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: SystemInt32
The original error number.
oSource
Type: SystemObject
The source.
Remarks
See Also

Reference

LicensingException Class
LicensingException Overload
Kofax.Capture.SDK.Data Namespace


LicensingException Methods

LicensingException Methods

The LicensingException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
See Also

Reference

LicensingException Class
Kofax.Capture.SDK.Data Namespace


LicensingException Properties

LicensingException Properties

The LicensingException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
See Also

Reference

LicensingException Class
Kofax.Capture.SDK.Data Namespace


OptimizedCustomModuleException Class

OptimizedCustomModuleException Class

Defines a general exception that is thrown when a general error occurs.

Inheritance Hierarchy
SystemObject
SystemException
SystemSystemException
System.Runtime.InteropServicesExternalException
System.Runtime.InteropServicesCOMException
Kofax.Capture.SDK.DataKfxException
Kofax.Capture.SDK.DataOptimizedCustomModuleException

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class OptimizedCustomModuleException : KfxException
Public Class OptimizedCustomModuleException
    Inherits KfxException

The OptimizedCustomModuleException type exposes the following members.

Constructors
 | Name | Description
Public method | OptimizedCustomModuleException(String, ACDataElementErrorValue) | Initializes a new instance of the Kofax.Capture.SDK.Data.OptimizedCustomModuleException class.
Public method | OptimizedCustomModuleException(String, Int32, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.OptimizedCustomModuleException class.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
Remarks
One of the following error numbers should be passed in:
  • KfxDbLiteOptErrBase
  • ErrUnexpectedError -- Unexpected error.
See Also

Reference

Kofax.Capture.SDK.Data Namespace


OptimizedCustomModuleException Constructor

OptimizedCustomModuleException Constructor
Overload List
 | Name | Description
Public method | OptimizedCustomModuleException(String, ACDataElementErrorValue) | Initializes a new instance of the Kofax.Capture.SDK.Data.OptimizedCustomModuleException class.
Public method | OptimizedCustomModuleException(String, Int32, Object) | Initializes a new instance of the Kofax.Capture.SDK.Data.OptimizedCustomModuleException class.
Top
See Also

Reference

OptimizedCustomModuleException Class
Kofax.Capture.SDK.Data Namespace


OptimizedCustomModuleException Constructor (String, ACDataElementErrorValue)

OptimizedCustomModuleException Constructor (String, ACDataElementErrorValue)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.OptimizedCustomModuleException class.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public OptimizedCustomModuleException(
    string strMsg,
    ACDataElementErrorValue errNum
)
Public Sub New (
    strMsg As String,
    errNum As ACDataElementErrorValue
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: Kofax.Capture.SDK.DataACDataElementErrorValue
The original error number.
Remarks
See Also

Reference

OptimizedCustomModuleException Class
OptimizedCustomModuleException Overload
Kofax.Capture.SDK.Data Namespace


OptimizedCustomModuleException Constructor (String, Int32, Object)

OptimizedCustomModuleException Constructor (String, Int32, Object)
Kofax Capture API Reference

Initializes a new instance of the Kofax.Capture.SDK.Data.OptimizedCustomModuleException class.

Namespace: Kofax.Capture.SDK.Data
Assembly: Kofax.Capture.SDK.Data (in Kofax.Capture.SDK.Data.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public OptimizedCustomModuleException(
    string strMsg,
    int errNum,
    Object oSource
)
Public Sub New (
    strMsg As String,
    errNum As Integer,
    oSource As Object
)

Parameters

strMsg
Type: SystemString
The error message.
errNum
Type: SystemInt32
The original error number.
oSource
Type: SystemObject
The source.
Remarks
See Also

Reference

OptimizedCustomModuleException Class
OptimizedCustomModuleException Overload
Kofax.Capture.SDK.Data Namespace


OptimizedCustomModuleException Methods

OptimizedCustomModuleException Methods

The OptimizedCustomModuleException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetBaseException | (Inherited from Exception.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetObjectData | Custom serialization required because Exception implements ISerializable. (Inherited from KfxException.)
Public method | GetType | (Inherited from Exception.)
Public method | ToString | (Inherited from COMException.)
Top
See Also

Reference

OptimizedCustomModuleException Class
Kofax.Capture.SDK.Data Namespace


OptimizedCustomModuleException Properties

OptimizedCustomModuleException Properties

The OptimizedCustomModuleException type exposes the following members.

Properties
 | Name | Description
Public property | Data | (Inherited from Exception.)
Public property | Error | Gets the error number. (Inherited from KfxException.)
Public property | ErrorCode | (Inherited from ExternalException.)
Public property | HelpLink | (Inherited from Exception.)
Public property | HResult | (Inherited from Exception.)
Public property | InnerException | (Inherited from Exception.)
Public property | Message | Gets the message, and formats it first if necessary. The module ID is alsways appended to the message. (Inherited from KfxException.)
Public property | MessageArguments | Gets the message arguments and array of object items to be formatted. (Inherited from KfxException.)
Public property | MessageUnformatted | Gets the raw message without the module ID prepended. The message is NOT formatted and may include all the argument parameters. (Inherited from KfxException.)
Public property | MessageWithNumber | Gets the message formatted as "[#]ModuleID:Message". (Inherited from KfxException.)
Public property | ModuleID | Gets the module ID. (Inherited from KfxException.)
Public property | Source | Gets the Source of this exception, or of the inner exception if this exception does not have the Source info. (Inherited from KfxException.)
Public property | StackTrace | Gets the stacktrace of this exception, or of the inner exception if this exception does not have a stacktrace. (Inherited from KfxException.)
Public property | TargetSite | (Inherited from Exception.)
Public property | TargetSiteInternal | Gets the method that throws the current exception. The TargetSite of the inner excepion is returned if this exception does not have the TargetSite info. This property is provided because the base class prohibits any override of the TargetSite Property. (Inherited from KfxException.)
Top
See Also

Reference

OptimizedCustomModuleException Class
Kofax.Capture.SDK.Data Namespace


Kofax.Capture.SDK.Workflow Namespace

Kofax.Capture.SDK.Workflow Namespace

The runtime portion of the workflow agent must be a registered COM server. The relevant project must first reference the Tungsten Capture Custom Workflow .NET Type Interface Library (Kofax.Capture.SDK.Workflow.dll) and Tungsten Capture Custom Workflow .NET Type Implementation Library (Kofax.Capture.ACWFLib.dll).

Interfaces
 | Interface | Description
Public interface | IACWorkflowAgent | The interface that the Workflow Agent must implement.
Public interface | IACWorkflowAgent2 |
Public interface | IACWorkflowCentralSites | Defines a collection of ACWorkflow site objects representing the various central sites.
Public interface | IACWorkflowData | Contains all the parameters to process the workflow.
Public interface | IACWorkflowModule | Represents a module within the batch class.
Public interface | IACWorkflowModules | Defines a collection of IACWorkflowModule objects. The collection is ordered by the module order setup in the corresponding batch class properties for the current batch.
Public interface | IACWorkflowSite | Represents a site in the Tungsten Capture workflow.
Public interface | IACWorkflowSites | Defines a collection of IACWorkflowSite objects representing the various sites.
Public interface | IACWorkflowState | Indicates a possible batch state.
Public interface | IACWorkflowStates | Defines a collection of IACWorkflowState objects representing the various states.
Enumerations
 | Enumeration | Description
Public enumeration | FeatureSupportedEnum | Defines the features that supported by this KC version.
Remarks

To run safely and efficiently in all Tungsten Capture modules, including the TCN Service, you should set the project properties "Unattended Execution" and "Retained in Memory."

A workflow agent runtime should never bring up a user interface. There is no ability to directly prevent this from occurring. However, there may be problems if a workflow agent attempts to invoke a user interface in certain modules (such as the TCN Service, or the Recognition Server when running as a service), because in such cases there is no user to interact with the interface.

Next, the programmer must create a COM class that implements the interface "IACWorkflowAgent." To do this in Visual Basic, create a new class that is externally creatable. At the top of this class, add the text: "Implements Kofax.Capture.SDK.Workflow.IACWorkflowAgent"

It is now possible to use the drop-down list in the upper-left corner of the text editor to select "IACWorkflowAgent" and the drop-down list in the upper-right to select the desired method of IACWorkflowAgent to implement.

Load Behavior

Tungsten Capture attempts to call a registered workflow agent runtime COM module on each station as it closes, rejects, or suspends a batch of the applicable batch class. By default, if Tungsten Capture cannot load the COM object, the batch is sent to the Quality Control module in error.

However, if the workflow agent has been registered with the WorkflowAgentSkipIfCantLoad flag set, then no error occurs if the workflow agent cannot be loaded.

In this case, the default workflow occurs. This may be useful if an Administrator knows that a workflow agent need only affect a particular module transition, and that such a transition only occurs on certain machines.

Calling Order

A workflow agent, if registered, is called after all default Tungsten Capture workflow processing. However, the workflow agent is invoked prior to updating batch history information. Therefore, since the workflow agent has already been invoked, the batch history information reflects changes that were made (if applicable) to the module and state due to running the agent.


FeatureSupportedEnum Enumeration

FeatureSupportedEnum Enumeration

Defines the features that supported by this KC version.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public enum FeatureSupportedEnum
Public Enumeration FeatureSupportedEnum
Members
Member name | Value | Description
ValidFlag | 1 | Valid Flag was set in FP or Validation Module by KC.
Remarks
See Also

Reference

Kofax.Capture.SDK.Workflow Namespace


IACWorkflowAgent Interface

IACWorkflowAgent Interface

The interface that the Workflow Agent must implement.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACWorkflowAgent
Public Interface IACWorkflowAgent

The IACWorkflowAgent type exposes the following members.

Methods
 | Name | Description
Public method | ProcessWorkflow | Tungsten Capture makes this call whenever a batch is closed, rejected, or suspended in a module (custom or standard).
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.Workflow Namespace


IACWorkflowAgent Methods

IACWorkflowAgent Methods

The IACWorkflowAgent type exposes the following members.

Methods
 | Name | Description
Public method | ProcessWorkflow | Tungsten Capture makes this call whenever a batch is closed, rejected, or suspended in a module (custom or standard).
Top
See Also

Reference

IACWorkflowAgent Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowAgent.ProcessWorkflow Method

IACWorkflowAgentProcessWorkflow Method

Tungsten Capture makes this call whenever a batch is closed, rejected, or suspended in a module (custom or standard).

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void ProcessWorkflow(
    ref IACWorkflowData oWorkflowData
)
Sub ProcessWorkflow (
    ByRef oWorkflowData As IACWorkflowData
)

Parameters

oWorkflowData
Type: Kofax.Capture.SDK.WorkflowIACWorkflowData
The oWorkflowData is a separate object that includes all the parameters needed for this call. It is possible to change certain properties on this object to affect Tungsten Capture data as well as the workflow.
Remarks

The call is made on each station closing the batch. Creating or editing a batch in Batch Manager also closes the batch and the ProcessWorkflow call is made in each case.

The ProcessWorkflow is not called when the batch is opened (causing it to transition to an In Progress state). It is also not called in certain internal situations where a batch is internally closed, but left in a special InProgress2 state.

See Also

Reference

IACWorkflowAgent Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowAgent2 Interface

IACWorkflowAgent2 Interface

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACWorkflowAgent2 : IACWorkflowAgent
Public Interface IACWorkflowAgent2
    Inherits IACWorkflowAgent

The IACWorkflowAgent2 type exposes the following members.

Methods
 | Name | Description
Public method | BatchOpen | Tungsten Capture makes this call whenever a batch is locked (opened) successfully in a module (custom or standard)
Public method | ProcessWorkflow | Tungsten Capture makes this call whenever a batch is closed, rejected, or suspended in a module (custom or standard). (Inherited from IACWorkflowAgent.)
Top
See Also

Reference

Kofax.Capture.SDK.Workflow Namespace


IACWorkflowAgent2 Methods

IACWorkflowAgent2 Methods

The IACWorkflowAgent2 type exposes the following members.

Methods
 | Name | Description
Public method | BatchOpen | Tungsten Capture makes this call whenever a batch is locked (opened) successfully in a module (custom or standard)
Public method | ProcessWorkflow | Tungsten Capture makes this call whenever a batch is closed, rejected, or suspended in a module (custom or standard). (Inherited from IACWorkflowAgent.)
Top
See Also

Reference

IACWorkflowAgent2 Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowAgent2.BatchOpen Method

IACWorkflowAgent2BatchOpen Method
Tungsten Capture makes this call whenever a batch is locked (opened) successfully in a module (custom or standard)

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void BatchOpen(
    ref IACWorkflowData oWorkflowData
)
Sub BatchOpen (
    ByRef oWorkflowData As IACWorkflowData
)

Parameters

oWorkflowData
Type: Kofax.Capture.SDK.WorkflowIACWorkflowData
The parameter containing information about the processing module and site. Any attempts to change next site or queue of batch have no effect.
See Also

Reference

IACWorkflowAgent2 Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowCentralSites Interface

IACWorkflowCentralSites Interface

Defines a collection of ACWorkflow site objects representing the various central sites.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACWorkflowCentralSites : IEnumerable,
    IDisposable
Public Interface IACWorkflowCentralSites
    Inherits IEnumerable, IDisposable

The IACWorkflowCentralSites type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowSite in the collection.
Public property | Item | Returns the Kofax.Capture.SDK.Workflow.IACWorkflowSite object specified by index or site name.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.Workflow Namespace


IACWorkflowCentralSites Methods

IACWorkflowCentralSites Methods

The IACWorkflowCentralSites type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Top
See Also

Reference

IACWorkflowCentralSites Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowCentralSites Properties

IACWorkflowCentralSites Properties

The IACWorkflowCentralSites type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowSite in the collection.
Public property | Item | Returns the Kofax.Capture.SDK.Workflow.IACWorkflowSite object specified by index or site name.
Top
See Also

Reference

IACWorkflowCentralSites Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowCentralSites.Count Property

IACWorkflowCentralSitesCount Property

Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowSite in the collection.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IACWorkflowCentralSites Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowCentralSites.Item Property

IACWorkflowCentralSitesItem Property

Returns the Kofax.Capture.SDK.Workflow.IACWorkflowSite object specified by index or site name.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowSite this[
    Object vntIndexKey
] { get; }
ReadOnly Property Item (
    vntIndexKey As Object
) As IACWorkflowSite
    Get

Parameters

vntIndexKey
Type: SystemObject
The index can either be a site name, or its (1-based) numeric index in the collection.

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite
Remarks

For each … Next is the standard Visual Basic iteration method. When using this method, the client code iterates through the collection of all central sites, ordered by the site's priority.

See Also

Reference

IACWorkflowCentralSites Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData Interface

IACWorkflowData Interface

Contains all the parameters to process the workflow.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACWorkflowData : IDisposable
Public Interface IACWorkflowData
    Inherits IDisposable

The IACWorkflowData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | ExtractRuntimeACDataElement | Returns the Kofax.Capture.SDK.Data.IACDataElement API object for the batch data.
Public method | ExtractSetupACDataElement | Returns the Kofax.Capture.SDK.Data.IACDataElement API object for the batch class.
Public method | FeatureSupported | Returns True if feature is supported by this version of Tungsten Capture.
Public method | SendSnmpNotification | Generates an SNMP notification message.
Public method | TranslateAscentCaptureValues | Any Tungsten Capture Value (enclosed in curly brackets) in strText is translated into the corresponding value.
Public method | UseAlternateCentralSite | Overrides the remote site behavior so that the batch is sent to the alternate central site specified by oSite.
Top
Properties
 | Name | Description
Public property | AvailableRemoteSites | Returns a collection of Kofax.Capture.SDK.Workflow.IACWorkflowSite objects.
Public property | BatchCustomStorageString | Allows the workflow agent to read and/or modify batch-level custom storage strings.
Public property | BatchType | Returns a normal batch or a batch that is assinged to users/groups.
Public property | CurrentModule | Returns the current module that is closing the batch.
Public property | ErrorCode | Gets or sets the error code. It is ignored unless the state is in error.
Public property | ErrorText | Gets or sets the error string. It is ignored unless the state is in error.
Public property | GrantGroupAccessToBatch | Grants group access rights to a batch. Only the granted group can process the batch in the subsequent queue.
Public property | GrantGroupAccessToBatch2 | Grants group access rights to a batch even if subsequent queue is unchanged.
Public property | GrantUserAccessToBatch | Grants user access rights to a batch. Only the granted user can process the batch in the subsequent queue.
Public property | GrantUserAccessToBatch2 | Grants user access rights to a batch even if subsequent queue is unchanged.
Public property | NextModule | Gets or sets the next expected module based on the client batch close.
Public property | NextSite | Gets or sets the next site that will process the batch based on the routing rules configured in the Administration module.
Public property | NextState | The next state based on how the current module has attempted to close the batch.
Public property | PossibleCentralSites | Returns a collection of available central sites to which a workflow agent can choose to upload the batch.
Public property | PossibleModules | Returns a collection of modules that can be used for this batch class.
Public property | PossibleStates | Returns a collection of ACWorkflowStates objects, which enumerate the available states for this batch class.
Public property | Recalled | Indicates whether or not the batch has been recalled by the central site.
Public property | ServicePackVersion | Returns the currently installed service pack.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData Methods

IACWorkflowData Methods

The IACWorkflowData type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | ExtractRuntimeACDataElement | Returns the Kofax.Capture.SDK.Data.IACDataElement API object for the batch data.
Public method | ExtractSetupACDataElement | Returns the Kofax.Capture.SDK.Data.IACDataElement API object for the batch class.
Public method | FeatureSupported | Returns True if feature is supported by this version of Tungsten Capture.
Public method | SendSnmpNotification | Generates an SNMP notification message.
Public method | TranslateAscentCaptureValues | Any Tungsten Capture Value (enclosed in curly brackets) in strText is translated into the corresponding value.
Public method | UseAlternateCentralSite | Overrides the remote site behavior so that the batch is sent to the alternate central site specified by oSite.
Top
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.ExtractRuntimeACDataElement Method

IACWorkflowDataExtractRuntimeACDataElement Method

Returns the Kofax.Capture.SDK.Data.IACDataElement API object for the batch data.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElement ExtractRuntimeACDataElement(
    int lHints
)
Function ExtractRuntimeACDataElement (
    lHints As Integer
) As IACDataElement

Parameters

lHints
Type: SystemInt32
Starting with Ascent Capture 7.0, hints are deprecated. Tungsten Capture behaves as if the hints were always specified, providing the same performance gains in all cases (it is no longer necessary to use hints to improve performance). Hints are retained for backward compatibility, but no longer perform any useful function.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement
Remarks
The property is read-only, but you are free to modify any data as allowed by the ACDataElement API.
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.ExtractSetupACDataElement Method

IACWorkflowDataExtractSetupACDataElement Method

Returns the Kofax.Capture.SDK.Data.IACDataElement API object for the batch class.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACDataElement ExtractSetupACDataElement(
    int lHints
)
Function ExtractSetupACDataElement (
    lHints As Integer
) As IACDataElement

Parameters

lHints
Type: SystemInt32
Starting with Ascent Capture 7.0, hints are deprecated. Tungsten Capture behaves as if the hints were always specified, providing the same performance gains in all cases (it is no longer necessary to use hints to improve performance). Hints are retained for backward compatibility, but no longer perform any useful function.

Return Value

Type: IACDataElement
Kofax.Capture.SDK.Data.IACDataElement
Remarks
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.FeatureSupported Method

IACWorkflowDataFeatureSupported Method
Returns True if feature is supported by this version of Tungsten Capture.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool FeatureSupported(
    int nFeatureNumber
)
Function FeatureSupported (
    nFeatureNumber As Integer
) As Boolean

Parameters

nFeatureNumber
Type: SystemInt32

Return Value

Type: Boolean
Remarks
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.SendSnmpNotification Method

IACWorkflowDataSendSnmpNotification Method

Generates an SNMP notification message.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void SendSnmpNotification(
    string strMessage
)
Sub SendSnmpNotification (
    strMessage As String
)

Parameters

strMessage
Type: SystemString
The message to send.
Remarks
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.TranslateAscentCaptureValues Method

IACWorkflowDataTranslateAscentCaptureValues Method

Any Tungsten Capture Value (enclosed in curly brackets) in strText is translated into the corresponding value.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void TranslateAscentCaptureValues(
    ref string strText
)
Sub TranslateAscentCaptureValues (
    ByRef strText As String
)

Parameters

strText
Type: SystemString
The original string to translate.
Remarks

For example: "This is the current document’s form type: {Document Form Name}."

Assuming a current document with a form exists, the "{Document Form Name}" text is replaced with the appropriate form name.

Tungsten Capture values may also be used to get batch field values. In this case, the batch field name is preceded by a dollar sign and enclosed in curly brackets.

For example: "This is the value of batch field name0: '{$name0}."

See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.UseAlternateCentralSite Method

IACWorkflowDataUseAlternateCentralSite Method

Overrides the remote site behavior so that the batch is sent to the alternate central site specified by oSite.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
void UseAlternateCentralSite(
    IACWorkflowSite oSite
)
Sub UseAlternateCentralSite (
    oSite As IACWorkflowSite
)

Parameters

oSite
Type: Kofax.Capture.SDK.WorkflowIACWorkflowSite
The specified alternate central site.
Remarks

The oSite can be selected from the return collection when you call PossibleCentralSites.

See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData Properties

IACWorkflowData Properties

The IACWorkflowData type exposes the following members.

Properties
 | Name | Description
Public property | AvailableRemoteSites | Returns a collection of Kofax.Capture.SDK.Workflow.IACWorkflowSite objects.
Public property | BatchCustomStorageString | Allows the workflow agent to read and/or modify batch-level custom storage strings.
Public property | BatchType | Returns a normal batch or a batch that is assinged to users/groups.
Public property | CurrentModule | Returns the current module that is closing the batch.
Public property | ErrorCode | Gets or sets the error code. It is ignored unless the state is in error.
Public property | ErrorText | Gets or sets the error string. It is ignored unless the state is in error.
Public property | GrantGroupAccessToBatch | Grants group access rights to a batch. Only the granted group can process the batch in the subsequent queue.
Public property | GrantGroupAccessToBatch2 | Grants group access rights to a batch even if subsequent queue is unchanged.
Public property | GrantUserAccessToBatch | Grants user access rights to a batch. Only the granted user can process the batch in the subsequent queue.
Public property | GrantUserAccessToBatch2 | Grants user access rights to a batch even if subsequent queue is unchanged.
Public property | NextModule | Gets or sets the next expected module based on the client batch close.
Public property | NextSite | Gets or sets the next site that will process the batch based on the routing rules configured in the Administration module.
Public property | NextState | The next state based on how the current module has attempted to close the batch.
Public property | PossibleCentralSites | Returns a collection of available central sites to which a workflow agent can choose to upload the batch.
Public property | PossibleModules | Returns a collection of modules that can be used for this batch class.
Public property | PossibleStates | Returns a collection of ACWorkflowStates objects, which enumerate the available states for this batch class.
Public property | Recalled | Indicates whether or not the batch has been recalled by the central site.
Public property | ServicePackVersion | Returns the currently installed service pack.
Top
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.AvailableRemoteSites Property

IACWorkflowDataAvailableRemoteSites Property

Returns a collection of Kofax.Capture.SDK.Workflow.IACWorkflowSite objects.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowSites AvailableRemoteSites { get; }
ReadOnly Property AvailableRemoteSites As IACWorkflowSites
    Get

Property Value

Type: IACWorkflowSites

Return Value

Type: IACWorkflowSites
Kofax.Capture.SDK.Workflow.IACWorkflowSites
Remarks
Without ACI Server enabled (or at ACI Server remote sites), there will be no remote sites available. In this case, an empty collection will be returned.
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.BatchCustomStorageString Property

IACWorkflowDataBatchCustomStorageString Property

Allows the workflow agent to read and/or modify batch-level custom storage strings.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string this[
    string strName
] { get; set; }
Property BatchCustomStorageString (
    strName As String
) As String
    Get
    Set

Parameters

strName
Type: SystemString
The custom storage string name.

Property Value

Type: String

Return Value

Type: String
String
Remarks
These elements are not available through the batch data information (ExtractRuntimeACDataElement method).
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.BatchType Property

IACWorkflowDataBatchType Property

Returns a normal batch or a batch that is assinged to users/groups.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int BatchType { get; }
ReadOnly Property BatchType As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.CurrentModule Property

IACWorkflowDataCurrentModule Property

Returns the current module that is closing the batch.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowModule CurrentModule { get; }
ReadOnly Property CurrentModule As IACWorkflowModule
    Get

Property Value

Type: IACWorkflowModule

Return Value

Type: IACWorkflowModule
Kofax.Capture.SDK.Workflow.IACWorkflowModule
Remarks

This module is Tungsten Capture Network Server when a batch is processed by either the RSA or by the TCN Service.

A workflow agent can tell the difference by detecting if AvailableModules includes TCN Server (in which case it is a remote TCN Server batch).

See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.ErrorCode Property

IACWorkflowDataErrorCode Property

Gets or sets the error code. It is ignored unless the state is in error.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ErrorCode { get; set; }
Property ErrorCode As Integer
    Get
    Set

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.ErrorText Property

IACWorkflowDataErrorText Property

Gets or sets the error string. It is ignored unless the state is in error.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ErrorText { get; set; }
Property ErrorText As String
    Get
    Set

Property Value

Type: String
The error string.

Return Value

Type: String
String
Remarks

The maximum length is 255 characters. An error is thrown if the ErrorText exceeds this length.

See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.GrantGroupAccessToBatch Property

IACWorkflowDataGrantGroupAccessToBatch Property

Grants group access rights to a batch. Only the granted group can process the batch in the subsequent queue.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string GrantGroupAccessToBatch { set; }
WriteOnly Property GrantGroupAccessToBatch As String
    Set

Property Value

Type: String
The group name and domain.
Remarks
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.GrantGroupAccessToBatch2 Property

IACWorkflowDataGrantGroupAccessToBatch2 Property

Grants group access rights to a batch even if subsequent queue is unchanged.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string GrantGroupAccessToBatch2 { set; }
WriteOnly Property GrantGroupAccessToBatch2 As String
    Set

Property Value

Type: String
The group name and domain.
Remarks
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.GrantUserAccessToBatch Property

IACWorkflowDataGrantUserAccessToBatch Property

Grants user access rights to a batch. Only the granted user can process the batch in the subsequent queue.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string GrantUserAccessToBatch { set; }
WriteOnly Property GrantUserAccessToBatch As String
    Set

Property Value

Type: String
The user ID and domain.
Remarks
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.GrantUserAccessToBatch2 Property

IACWorkflowDataGrantUserAccessToBatch2 Property

Grants user access rights to a batch even if subsequent queue is unchanged.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string GrantUserAccessToBatch2 { set; }
WriteOnly Property GrantUserAccessToBatch2 As String
    Set

Property Value

Type: String
The user ID and domain.
Remarks
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.NextModule Property

IACWorkflowDataNextModule Property

Gets or sets the next expected module based on the client batch close.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowModule NextModule { get; set; }
Property NextModule As IACWorkflowModule
    Get
    Set

Property Value

Type: IACWorkflowModule

Return Value

Type: IACWorkflowModule
Kofax.Capture.SDK.Workflow.IACWorkflowModule
Remarks

If the batch is in error, this property is ignored and the batch will go the Quality Control module.

This state is a reference to one of the objects in ACWorkflow states. The user code can modify this to a different state, if desired to affect workflow.

If the NextModule and NextState parameters are left unchanged, then the batch experiences the default workflow behavior.

When using a remote TCN Server batch, the workflow agent can cause the batch to be sent to the central site by setting NextModule to TCN Server.

Invalid state/module combinations are not checked until the ProcessWorkflow routine exists (at which time the batch will be routed to the Quality Control module if there is an error).

Workflow agents must be very careful to set valid state and module combinations.

See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.NextSite Property

IACWorkflowDataNextSite Property

Gets or sets the next site that will process the batch based on the routing rules configured in the Administration module.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowSite NextSite { get; set; }
Property NextSite As IACWorkflowSite
    Get
    Set

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite
Remarks

This value is a reference to one of the objects in ACWorkflowSites.

The workflow agent can change this to a different value, if desired, to affect workflow.

Invalid site selections are not caught until the routine exits.

If TCN Server is not enabled, this property always returns the current site.

See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.NextState Property

IACWorkflowDataNextState Property

The next state based on how the current module has attempted to close the batch.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowState NextState { get; set; }
Property NextState As IACWorkflowState
    Get
    Set

Property Value

Type: IACWorkflowState

Return Value

Type: IACWorkflowState
Kofax.Capture.SDK.Workflow.IACWorkflowState
Remarks
This state is a reference to one of the objects in ACWorkflow states.

The user code can modify this to a different state, if desired to affect workflow.

Invalid state/module combinations are not checked until the ProcessWorkflow routine exists (at which time the batch will be routed to Quality Control if there is an error).

Workflow agents must be very careful to set valid state and module combinations.

See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.PossibleCentralSites Property

IACWorkflowDataPossibleCentralSites Property

Returns a collection of available central sites to which a workflow agent can choose to upload the batch.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowCentralSites PossibleCentralSites { get; }
ReadOnly Property PossibleCentralSites As IACWorkflowCentralSites
    Get

Property Value

Type: IACWorkflowCentralSites

Return Value

Type: IACWorkflowCentralSites
Kofax.Capture.SDK.Workflow.IACWorkflowCentralSites
Remarks

The return collection contains all available central sites when the working batch is a new batch that has not yet been uploaded to any central site. For a batch that has already been sent to a central site, this property returns an empty collection.

See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.PossibleModules Property

IACWorkflowDataPossibleModules Property

Returns a collection of modules that can be used for this batch class.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowModules PossibleModules { get; }
ReadOnly Property PossibleModules As IACWorkflowModules
    Get

Property Value

Type: IACWorkflowModules

Return Value

Type: IACWorkflowModules
Kofax.Capture.SDK.Workflow.IACWorkflowModules
Remarks
This collection is in order of the default workflow; for instance, the first module will always be "Scan.exe".

On a TCN Server remote site, this list always includes the TCN Server module. The KCN Server module does not appear for TCN Server batches being processed at the central site.

See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.PossibleStates Property

IACWorkflowDataPossibleStates Property

Returns a collection of ACWorkflowStates objects, which enumerate the available states for this batch class.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowStates PossibleStates { get; }
ReadOnly Property PossibleStates As IACWorkflowStates
    Get

Property Value

Type: IACWorkflowStates

Return Value

Type: IACWorkflowStates
Kofax.Capture.SDK.Workflow.IACWorkflowStates
Remarks
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.Recalled Property

IACWorkflowDataRecalled Property

Indicates whether or not the batch has been recalled by the central site.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
bool Recalled { get; }
ReadOnly Property Recalled As Boolean
    Get

Property Value

Type: Boolean

Return Value

Type: Boolean
Boolean
Remarks
When a batch is recalled, the multi-site routing setting for the batch is removed (if the batch is configured for multi-site routing). The batch routing is limited to the central site after recall.

However, the workflow agent can be programmed to route to any available site that is returned by the AvailableRemoteSites property.

For example, the workflow agent can check to see if a batch has been recalled, and route it to the central site. Once routed to the central site, the workflow agent can subsequently override the recall and route the batch to a remote site.

See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowData.ServicePackVersion Property

IACWorkflowDataServicePackVersion Property

Returns the currently installed service pack.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
short ServicePackVersion { get; }
ReadOnly Property ServicePackVersion As Short
    Get

Property Value

Type: Int16
The service pack version.

Return Value

Type: Int16
Short
Remarks
See Also

Reference

IACWorkflowData Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowModule Interface

IACWorkflowModule Interface

Represents a module within the batch class.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACWorkflowModule
Public Interface IACWorkflowModule

The IACWorkflowModule type exposes the following members.

Properties
 | Name | Description
Public property | ID | Returns the module's unique identifier. If checking for specific module identifiers, it is best to use this property rather than the Name.
Public property | Name | Returns the module name. This name is typically used for display purposes only.
Public property | ProcessID | Returns the internal ProcessID of the module.
Public property | QueueID | Returns the internal QueueID of the module.
Top
Remarks

The following list shows the names and IDs of the built-in modules. Only some of these modules are assigned to any particular batch class.

  • Scan: scan.exe
  • Quality Control: qc.exe
  • Recognition Server: fp.exe
  • Validation: index.exe
  • Verification: verify.exe
  • OCR Full Text: ocr.exe
  • Export: release.exe
  • Batch Manager: ops.exe
  • PDF Generator: kfxpdf.exe
  • ACI Server: ACIRSA.exe
    This module is used for both the ACI Server RSA (Remote Synchronization Agent) and the TCN Service.
  • Custom Module: ModuleID for the Custom Module
See Also

Reference

Kofax.Capture.SDK.Workflow Namespace


IACWorkflowModule Properties

IACWorkflowModule Properties

The IACWorkflowModule type exposes the following members.

Properties
 | Name | Description
Public property | ID | Returns the module's unique identifier. If checking for specific module identifiers, it is best to use this property rather than the Name.
Public property | Name | Returns the module name. This name is typically used for display purposes only.
Public property | ProcessID | Returns the internal ProcessID of the module.
Public property | QueueID | Returns the internal QueueID of the module.
Top
See Also

Reference

IACWorkflowModule Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowModule.ID Property

IACWorkflowModuleID Property

Returns the module's unique identifier. If checking for specific module identifiers, it is best to use this property rather than the Name.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string ID { get; }
ReadOnly Property ID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IACWorkflowModule Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowModule.Name Property

IACWorkflowModuleName Property

Returns the module name. This name is typically used for display purposes only.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IACWorkflowModule Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowModule.ProcessID Property

IACWorkflowModuleProcessID Property

Returns the internal ProcessID of the module.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int ProcessID { get; }
ReadOnly Property ProcessID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IACWorkflowModule Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowModule.QueueID Property

IACWorkflowModuleQueueID Property

Returns the internal QueueID of the module.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int QueueID { get; }
ReadOnly Property QueueID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IACWorkflowModule Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowModules Interface

IACWorkflowModules Interface

Defines a collection of IACWorkflowModule objects. The collection is ordered by the module order setup in the corresponding batch class properties for the current batch.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACWorkflowModules : IEnumerable
Public Interface IACWorkflowModules
    Inherits IEnumerable

The IACWorkflowModules type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | (Inherited from IEnumerable.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowModule in the collection.
Public property | Item | Returns the Kofax.Capture.SDK.Workflow.IACWorkflowModule object specified by index.
Top
Remarks

If the batch class does not contain the Quality Control module, the Quality Control module is not available in this collection. However, it is still possible to route a batch to the Quality Control module for an error by setting the next state to "error."

The ACWorkflowModules for Kofax Capture Network Server batches contains a list of the modules (queues) assigned to the batch class, in the order they were assigned in the Administration module. Some special situations occur when TCN Server is involved.

For a TCN Server batch at the remote site, ACWorkflowModules contains all of the modules slated to execute on the remote site (often just the Scan module) as well as the special TCN Server module representing the RSA.

For a KCN Server batch at the central site, ACWorkflowModules is identical to what would be seen for a non-TCN Server batch (it exactly matches what was set up in the Administration module).

Care must be taken when writing special routing rules if the workflow agent is expected to work in a TCN Server environment. It may be necessary to modify the rules to take into account a TCN Server exchange with the central site.

See Also

Reference

Kofax.Capture.SDK.Workflow Namespace


IACWorkflowModules Methods

IACWorkflowModules Methods

The IACWorkflowModules type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | (Inherited from IEnumerable.)
Top
See Also

Reference

IACWorkflowModules Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowModules Properties

IACWorkflowModules Properties

The IACWorkflowModules type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowModule in the collection.
Public property | Item | Returns the Kofax.Capture.SDK.Workflow.IACWorkflowModule object specified by index.
Top
See Also

Reference

IACWorkflowModules Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowModules.Count Property

IACWorkflowModulesCount Property

Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowModule in the collection.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IACWorkflowModules Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowModules.Item Property

IACWorkflowModulesItem Property

Returns the Kofax.Capture.SDK.Workflow.IACWorkflowModule object specified by index.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowModule this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IACWorkflowModule
    Get

Parameters

vntIndexKey
Type: SystemObject
The index can either be a module ID, a module name, or its (1-based) numeric index in the collection.

Property Value

Type: IACWorkflowModule

Return Value

Type: IACWorkflowModule
Kofax.Capture.SDK.Workflow.IACWorkflowModule
Remarks

Referencing by module ID is most portable to other languages if searching for a specific module.

For each ... Next is the standard Visual Basic iteration method. When using this property, the client code iterates over the collection based on the queue ordering assigned to the batch class in the Administration module.

See Also

Reference

IACWorkflowModules Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowSite Interface

IACWorkflowSite Interface

Represents a site in the Tungsten Capture workflow.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACWorkflowSite
Public Interface IACWorkflowSite

The IACWorkflowSite type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the site.
Public property | SiteGUID | Returns the globally unique ID representing the site.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.Workflow Namespace


IACWorkflowSite Properties

IACWorkflowSite Properties

The IACWorkflowSite type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the site.
Public property | SiteGUID | Returns the globally unique ID representing the site.
Top
See Also

Reference

IACWorkflowSite Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowSite.Name Property

IACWorkflowSiteName Property

Returns the name of the site.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IACWorkflowSite Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowSite.SiteGUID Property

IACWorkflowSiteSiteGUID Property

Returns the globally unique ID representing the site.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string SiteGUID { get; }
ReadOnly Property SiteGUID As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IACWorkflowSite Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowSites Interface

IACWorkflowSites Interface

Defines a collection of IACWorkflowSite objects representing the various sites.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACWorkflowSites : IEnumerable,
    IDisposable
Public Interface IACWorkflowSites
    Inherits IEnumerable, IDisposable

The IACWorkflowSites type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Top
Properties
 | Name | Description
Public property | BatchCreationSite | Returns an object that represents the site that originally scanned the batch.
Public property | CentralSite | Returns an object that represents the central site.
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowSite in the collection.
Public property | CurrentSite | Returns an object that represents the current site.
Public property | Item | Returns the Kofax.Capture.SDK.Workflow.IACWorkflowSite object specified by the index.
Public property | RescanSite | Returns an object that represents the site where rescan should be running.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.Workflow Namespace


IACWorkflowSites Methods

IACWorkflowSites Methods

The IACWorkflowSites type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Top
See Also

Reference

IACWorkflowSites Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowSites Properties

IACWorkflowSites Properties

The IACWorkflowSites type exposes the following members.

Properties
 | Name | Description
Public property | BatchCreationSite | Returns an object that represents the site that originally scanned the batch.
Public property | CentralSite | Returns an object that represents the central site.
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowSite in the collection.
Public property | CurrentSite | Returns an object that represents the current site.
Public property | Item | Returns the Kofax.Capture.SDK.Workflow.IACWorkflowSite object specified by the index.
Public property | RescanSite | Returns an object that represents the site where rescan should be running.
Top
See Also

Reference

IACWorkflowSites Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowSites.BatchCreationSite Property

IACWorkflowSitesBatchCreationSite Property

Returns an object that represents the site that originally scanned the batch.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowSite BatchCreationSite { get; }
ReadOnly Property BatchCreationSite As IACWorkflowSite
    Get

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite
Remarks

If TCN Server is not enabled, this property always returns the current site.

See Also

Reference

IACWorkflowSites Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowSites.CentralSite Property

IACWorkflowSitesCentralSite Property

Returns an object that represents the central site.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowSite CentralSite { get; }
ReadOnly Property CentralSite As IACWorkflowSite
    Get

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite
Remarks

Without TCN Server enabled, it is implied that this is always the current site.

See Also

Reference

IACWorkflowSites Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowSites.Count Property

IACWorkflowSitesCount Property

Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowSite in the collection.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IACWorkflowSites Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowSites.CurrentSite Property

IACWorkflowSitesCurrentSite Property

Returns an object that represents the current site.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowSite CurrentSite { get; }
ReadOnly Property CurrentSite As IACWorkflowSite
    Get

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite
Remarks
See Also

Reference

IACWorkflowSites Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowSites.Item Property

IACWorkflowSitesItem Property

Returns the Kofax.Capture.SDK.Workflow.IACWorkflowSite object specified by the index.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowSite this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IACWorkflowSite
    Get

Parameters

vntIndexKey
Type: SystemObject
The index can either be a site name, a site GUID, or its (1-based) numeric index in the collection.

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite
Remarks

Referencing by Site GUID is most portable to other languages if searching for a specific site.

For each … Next is the standard Visual Basic iteration method. When using this property, the client code iterates over the collection based on the alphabetic order of all remote site names.

See Also

Reference

IACWorkflowSites Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowSites.RescanSite Property

IACWorkflowSitesRescanSite Property

Returns an object that represents the site where rescan should be running.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowSite RescanSite { get; }
ReadOnly Property RescanSite As IACWorkflowSite
    Get

Property Value

Type: IACWorkflowSite

Return Value

Type: IACWorkflowSite
Kofax.Capture.SDK.Workflow.IACWorkflowSite
Remarks
See Also

Reference

IACWorkflowSites Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowState Interface

IACWorkflowState Interface

Indicates a possible batch state.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACWorkflowState
Public Interface IACWorkflowState

The IACWorkflowState type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the state.
Public property | StateID | Returns the internal State ID.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.Workflow Namespace


IACWorkflowState Properties

IACWorkflowState Properties

The IACWorkflowState type exposes the following members.

Properties
 | Name | Description
Public property | Name | Returns the name of the state.
Public property | StateID | Returns the internal State ID.
Top
See Also

Reference

IACWorkflowState Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowState.Name Property

IACWorkflowStateName Property

Returns the name of the state.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String

Return Value

Type: String
String
Remarks
See Also

Reference

IACWorkflowState Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowState.StateID Property

IACWorkflowStateStateID Property

Returns the internal State ID.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int StateID { get; }
ReadOnly Property StateID As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IACWorkflowState Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowStates Interface

IACWorkflowStates Interface

Defines a collection of IACWorkflowState objects representing the various states.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public interface IACWorkflowStates : IEnumerable,
    IDisposable
Public Interface IACWorkflowStates
    Inherits IEnumerable, IDisposable

The IACWorkflowStates type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Top
Properties
 | Name | Description
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowState in the collection.
Public property | Item | Returns the ACWorkflowState object specified by index.
Top
Remarks
See Also

Reference

Kofax.Capture.SDK.Workflow Namespace


IACWorkflowStates Methods

IACWorkflowStates Methods

The IACWorkflowStates type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | (Inherited from IDisposable.)
Public method | GetEnumerator | (Inherited from IEnumerable.)
Top
See Also

Reference

IACWorkflowStates Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowStates Properties

IACWorkflowStates Properties

The IACWorkflowStates type exposes the following members.

Properties
 | Name | Description
Public property | Count | Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowState in the collection.
Public property | Item | Returns the ACWorkflowState object specified by index.
Top
See Also

Reference

IACWorkflowStates Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowStates.Count Property

IACWorkflowStatesCount Property

Returns the number of the Kofax.Capture.SDK.Workflow.IACWorkflowState in the collection.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
int Count { get; }
ReadOnly Property Count As Integer
    Get

Property Value

Type: Int32

Return Value

Type: Int32
Integer
Remarks
See Also

Reference

IACWorkflowStates Interface
Kofax.Capture.SDK.Workflow Namespace


IACWorkflowStates.Item Property

IACWorkflowStatesItem Property

Returns the ACWorkflowState object specified by index.

Namespace: Kofax.Capture.SDK.Workflow
Assembly: Kofax.Capture.SDK.Workflow (in Kofax.Capture.SDK.Workflow.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
IACWorkflowState this[
    Object vntIndexKey
] { get; }
ReadOnly Default Property Item (
    vntIndexKey As Object
) As IACWorkflowState
    Get

Parameters

vntIndexKey
Type: SystemObject
The index can either be a state name, or its (1-based) numeric index in the collection.

Property Value

Type: IACWorkflowState

Return Value

Type: IACWorkflowState
Kofax.Capture.SDK.Workflow.IACWorkflowState
Remarks

For each ... Next is the standard Visual Basic iteration method. When using this, the client code iterates over the collection based on the ordering defined below. This ordering is subject to change and you should not rely on any specific ordering for this collection.

The list of states, their ordering, and rules of usage are as follows.

  • Ready - The batch is ready for the next module.
  • Suspended - The batch is suspended in the current module. This often occurs because an operator is in the middle of processing a batch, but must suspend processing (such as to take a lunch break).
  • Error - The batch is in error. Setting this status causes the batch to be routed to the Quality Control module irrespective of the next module set, or whether Quality Control has been explicitly assigned to this batch class. The ErrorCode and ErrorText properties off the ACWorkflowData object are ignored unless the batch is set to this state.
  • Completed - This is an unusual status that occurs only when Export is not assigned to a batch class. In this case, after the batch finishes processing in the final module, its state is set to "Completed." Setting this state causes an error unless the module is the last module in the ACWorkflowModules list and this module is neither Export nor TCN Server.
  • Reserved - This is another unusual status that is only available in Batch Manager. This status is occasionally used by administrators to temporarily take a batch off-line. It can be interpreted as a stronger form of the suspended state.

Invalid state and module combinations will cause an error when ProcessWorkflow completes. This error will cause the batch to be routed to the Quality Control module.

See Also

Reference

IACWorkflowStates Interface
Kofax.Capture.SDK.Workflow Namespace


Kofax.SDK.CaptureInfo Namespace

Kofax.SDK.CaptureInfo Namespace

The Tungsten Capture Information Type Library allows customizations to query the user selected theme, language, and showing UI in the same language as Tungsten Capture standard module.
The Tungsten Capture Information Type Library dynamic-link library (Kofax.SDK.CaptureInfo.dll) is available from the Bin folder in your Tungsten Capture installation.

Tungsten Capture SDK Capture Info Type Library allows you to do the following:

  • Query the user selected application language.
  • Query the user selected application theme.
  • Apply localization for custom module and export connector names.

The AEX or INF file allows a customization to register its component name and description in multiple languages.

The following example shows how the KTM Validation module would specify its name and language in German and French languages:

 [Modules]
 KTM Validation

 [KTM Validation]
 ModuleID=LCI.Validation
 Description=The Validation module is used to review extraction results for an entire document and to ensure that all information is valid.  Documents can also be marked for online learning.
 Version=4.5
 ...

 Languages= LCI.Validation-Languages

 [LCI.Validation-Languages]
 LCI.Validation-de
 LCI.Validation-fr

 [LCI.Validation-de]
 CultureInfoName=de-DE
 Name=KTM Validatie
 Description=De validatie-module wordt gebruikt voor de winning resultaten verslag voor een volledig document en ervoor te zorgen dat alle informatie geldig is. Documenten kunnen ook worden gemarkeerd voor online leren.

 [LCI.Validation-fr]
 CultureInfoName=fr-FR
 Name=KTM Validation
 Description=Le module de Validation est utilisé pour reconsidérer des résultats d'extraction pour un document entier et garantir que tous les informations sont valides. Les documents peuvent aussi être marqués pour l'apprentissage en ligne.

The following example shows how the Text export connector would specify its name and in German and French:

 [Scripts]
 Ascent Capture Text

 [Ascent Capture Text]
 SetupModule=.\Kofax.TextRelease.dll
 SetupProgID=TextRel.kfxreleasesetupscript
 SetupVersion=10.0
 ReleaseModule=.\Kofax.TextRelease.dll
 ReleaseProgID=TextRel.kfxreleasescript
 ReleaseVersion=10.0
 SupportsNonImageFiles=True
 SupportsKofaxPDF=True
 RemainLoaded=True
 SupportsOriginalFileName=True
 SupportsMultipleInstances=True
 SupportsCustomEncryption=True
 PathSubstitution=ASCII File Name
 DisplayName=Text Export Connector
 ...

 Languages=Ascent Capture Text-Languages

 [Ascent Capture Text-Languages]
 de
 fr

 [de]
 CultureInfoName=de-DE
 DisplayName=Tungsten CaptureText

 [fr]
 CultureInfoName=fr-FR
 DisplayName=Tungsten Capture Texte
Classes
 | Class | Description
Public class | CaptureInfo | This class allows customizations to query Tungsten Capture settings information in the current system such as user selected language, executable files folder, and server files folder as well as the path to the local folder. This class also provides the SetThreadUILanguage method which takes the customization thread and updates its CurrentUICulture property with the CultureInfo of the currently selected language.
Public class | Theme | This class provides access to the current visual style and color of Tungsten Capture.
Enumerations
 | Enumeration | Description
Public enumeration | ColorScheme | This is an enumeration type that represents the Capture's defined visual style and colors for custom applications.


CaptureInfo Class

CaptureInfo Class

This class allows customizations to query Tungsten Capture settings information in the current system such as user selected language, executable files folder, and server files folder as well as the path to the local folder.

This class also provides the SetThreadUILanguage method which takes the customization thread and updates its CurrentUICulture property with the CultureInfo of the currently selected language.

Inheritance Hierarchy
SystemObject
Kofax.SDK.CaptureInfoCaptureInfo

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class CaptureInfo
Public Class CaptureInfo

The CaptureInfo type exposes the following members.

Constructors
 | Name | Description
Public method | CaptureInfo | Initializes a new instance of the CaptureInfo class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | SetThreadUILanguage | This method takes a thread and updates its UICulture info based on the current user's language setting in the registry. If the language name is not set on HKCU or HKLM, this method will detect the system's default language and switch to a suitable language, if applicable (if the Tungsten Capture language pack corresponding to the locale ID is installed).
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ExePath | Gets the executable files folder.
Public property | LocaleName | Gets the locale name that identifies the currently selected language in Tungsten Capture.
Public property | LocalPath | Gets the path to the local folder.
Public property | ServerPath | Gets the server files folder.
Public property | SiteID | Gets the site ID.
Public property | SiteName | Gets the site name.
Top
Remarks
See Also

Reference

Kofax.SDK.CaptureInfo Namespace


CaptureInfo Constructor

CaptureInfo Constructor
Initializes a new instance of the CaptureInfo class

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public CaptureInfo()
Public Sub New
See Also

Reference

CaptureInfo Class
Kofax.SDK.CaptureInfo Namespace


CaptureInfo Methods

CaptureInfo Methods

The CaptureInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
 | SetThreadUILanguage | This method takes a thread and updates its UICulture info based on the current user's language setting in the registry. If the language name is not set on HKCU or HKLM, this method will detect the system's default language and switch to a suitable language, if applicable (if the Tungsten Capture language pack corresponding to the locale ID is installed).
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

CaptureInfo Class
Kofax.SDK.CaptureInfo Namespace


CaptureInfo.SetThreadUILanguage Method

CaptureInfoSetThreadUILanguage Method
This method takes a thread and updates its UICulture info based on the current user's language setting in the registry.
If the language name is not set on HKCU or HKLM, this method will detect the system's default language and switch to a suitable language, if applicable (if the Tungsten Capture language pack corresponding to the locale ID is installed).

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public static void SetThreadUILanguage(
    Thread oThread
)
Public Shared Sub SetThreadUILanguage (
    oThread As Thread
)

Parameters

oThread
Type: System.ThreadingThread
The thread to set the UI culture.
Remarks
Customizations use this method to update the user interface language to match the currently selected language of Tungsten Capture.
See Also

Reference

CaptureInfo Class
Kofax.SDK.CaptureInfo Namespace


CaptureInfo Properties

CaptureInfo Properties

The CaptureInfo type exposes the following members.

Properties
 | Name | Description
Public property | ExePath | Gets the executable files folder.
Public property | LocaleName | Gets the locale name that identifies the currently selected language in Tungsten Capture.
Public property | LocalPath | Gets the path to the local folder.
Public property | ServerPath | Gets the server files folder.
Public property | SiteID | Gets the site ID.
Public property | SiteName | Gets the site name.
Top
See Also

Reference

CaptureInfo Class
Kofax.SDK.CaptureInfo Namespace


CaptureInfo.ExePath Property

CaptureInfoExePath Property
Gets the executable files folder.

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ExePath { get; }
Public ReadOnly Property ExePath As String
    Get

Property Value

Type: String
The folder path to Capture executable files.

Return Value

Type: String
A string value representing the folder path to Capture's executable files.
Remarks
See Also

Reference

CaptureInfo Class
Kofax.SDK.CaptureInfo Namespace


CaptureInfo.LocaleName Property

CaptureInfoLocaleName Property

Gets the locale name that identifies the currently selected language in Tungsten Capture.

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string LocaleName { get; }
Public ReadOnly Property LocaleName As String
    Get

Property Value

Type: String
The locale name identifies the language currently selected in Capture.

Return Value

Type: String
A string value representing the language currently selected in Tungsten Capture. For instance, de-DE for German.
Remarks
See Also

Reference

CaptureInfo Class
Kofax.SDK.CaptureInfo Namespace


CaptureInfo.LocalPath Property

CaptureInfoLocalPath Property
Gets the path to the local folder.

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string LocalPath { get; }
Public ReadOnly Property LocalPath As String
    Get

Property Value

Type: String
The Path to the local folder.

Return Value

Type: String
A string value representing the folder path to Tungsten Capture local files.
Remarks
See Also

Reference

CaptureInfo Class
Kofax.SDK.CaptureInfo Namespace


CaptureInfo.ServerPath Property

CaptureInfoServerPath Property
Gets the server files folder.

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string ServerPath { get; }
Public ReadOnly Property ServerPath As String
    Get

Property Value

Type: String
The folder path to the Server files.

Return Value

Type: String
A string value representing the folder path to Tungsten Capture server files.
Remarks
See Also

Reference

CaptureInfo Class
Kofax.SDK.CaptureInfo Namespace


CaptureInfo.SiteID Property

CaptureInfoSiteID Property
Gets the site ID.

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string SiteID { get; }
Public ReadOnly Property SiteID As String
    Get

Return Value

Type: String
A string value representing the site ID.
Remarks
See Also

Reference

CaptureInfo Class
Kofax.SDK.CaptureInfo Namespace


CaptureInfo.SiteName Property

CaptureInfoSiteName Property
Gets the site name.

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public string SiteName { get; }
Public ReadOnly Property SiteName As String
    Get

Return Value

Type: String
A string value representing the site name.
Remarks
See Also

Reference

CaptureInfo Class
Kofax.SDK.CaptureInfo Namespace


ColorScheme Enumeration

ColorScheme Enumeration
This is an enumeration type that represents the Capture's defined visual style and colors for custom applications.

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public enum ColorScheme
Public Enumeration ColorScheme
Members
Member name | Value | Description
XPLook | 0 | XPLook theme.
Blue | 1 | Blue theme.
Black | 2 | Black theme.
Silver | 3 | Silver theme.
Aqua | 4 | Aqua theme.
Remarks
See Also

Reference

Kofax.SDK.CaptureInfo Namespace


Theme Class

Theme Class

This class provides access to the current visual style and color of Tungsten Capture.

Inheritance Hierarchy
SystemObject
Kofax.SDK.CaptureInfoTheme

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public class Theme
Public Class Theme

The Theme type exposes the following members.

Constructors
 | Name | Description
Public method | Theme | Initializes a new instance of the Theme class
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | BackgroundColor | Gets Tungsten Capture's selected form background color from the registry.
Public property | ColorSchemeID | Gets the Tungsten Capture's selected visual style and colors ID from the registry.
Top
Remarks
See Also

Reference

Kofax.SDK.CaptureInfo Namespace


Theme Constructor

Theme Constructor
Initializes a new instance of the Theme class

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Theme()
Public Sub New
See Also

Reference

Theme Class
Kofax.SDK.CaptureInfo Namespace


Theme Methods

Theme Methods

The Theme type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

Theme Class
Kofax.SDK.CaptureInfo Namespace


Theme Properties

Theme Properties

The Theme type exposes the following members.

Properties
 | Name | Description
Public property | BackgroundColor | Gets Tungsten Capture's selected form background color from the registry.
Public property | ColorSchemeID | Gets the Tungsten Capture's selected visual style and colors ID from the registry.
Top
See Also

Reference

Theme Class
Kofax.SDK.CaptureInfo Namespace


Theme.BackgroundColor Property

ThemeBackgroundColor Property

Gets Tungsten Capture's selected form background color from the registry.

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public Color BackgroundColor { get; }
Public ReadOnly Property BackgroundColor As Color
    Get

Return Value

Type: Color
A System.Drawing.Color representing a background color defined in Kofax Capture.
Remarks
See Also

Reference

Theme Class
Kofax.SDK.CaptureInfo Namespace


Theme.ColorSchemeID Property

ThemeColorSchemeID Property

Gets the Tungsten Capture's selected visual style and colors ID from the registry.

Namespace: Kofax.SDK.CaptureInfo
Assembly: Kofax.SDK.CaptureInfo (in Kofax.SDK.CaptureInfo.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
public ColorScheme ColorSchemeID { get; }
Public ReadOnly Property ColorSchemeID As ColorScheme
    Get

Return Value

Type: ColorScheme
A ColorScheme value representing visual style and colors defined Tungsten Capture.
Remarks
See Also

Reference

Theme Class
Kofax.SDK.CaptureInfo Namespace


RuntimeSession. Property

RuntimeSession Property

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
private virtual MonitorMgr m_MonitorLogout { get; set; }
Private Overridable Property m_MonitorLogout As MonitorMgr
    Get
    Set

Property Value

Type: MonitorMgr
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


RuntimeSession. Property

RuntimeSession Property

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
private virtual BatchNotifier m_oBatchNotifier { get; set; }
Private Overridable Property m_oBatchNotifier As BatchNotifier
    Get
    Set

Property Value

Type: BatchNotifier
See Also

Reference

RuntimeSession Class
Kofax.Capture.DBLite Namespace


MonitorMgr. Property

MonitorMgr Property

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
private virtual CMHook m_Hook { get; set; }
Private Overridable Property m_Hook As CMHook
    Get
    Set

Property Value

Type: CMHook
See Also

Reference

MonitorMgr Class
Kofax.Capture.DBLite Namespace


Login. Property

Login Property

Namespace: Kofax.Capture.DBLite
Assembly: Kofax.DBLite (in Kofax.DBLite.dll) Version: 11.2.0.0.0.191
Syntax
C#
VB
Copy
private virtual Login2 m_oBaseLogin { get; set; }
Private Overridable Property m_oBaseLogin As Login2
    Get
    Set

Property Value

Type: Login2
See Also

Reference

Login Class
Kofax.Capture.DBLite Namespace