Kofax Mobile SDK API Reference: Main Page

Kofax Mobile SDK API Reference
  • Main Page
  • Related Pages
  • Packages
  • Classes
  • Files
Kofax Mobile SDK API Reference Documentation

Welcome

The Kofax Mobile SDK API Reference Guide for Android provides a detailed description of each class included in the Mobile SDK library. This guide assumes you have a detailed understanding of the development environments used to implement the APIs described here. This reference guide is designed to be used along with the Kofax Mobile SDK Developer's Guide as the primary reference documents for your development.

Main packages

Package | Functionality
Capture | Packaged Capture Experience API
Engines ImageProcessor, ImageClassifier, container for image (Image), image processing config (ImageProcessorConfiguration).
Results of operations performed like bar code data found (BarcodeResult), image classification results (ImageClassificationResult) or image quick analysis results (QuickAnalysisFeedback).
Bounding rectangle and tetragon.
Extract | Server and On Device Extraction API
Logistics Interacting with Kofax Front Office and TotalAgility Servers (CaptureServer).
UserProfile class for server account information like user name and password.
Classes to store document data:
Document, based on the definition of the document (DocumentType), contains an array of pages (Page) and methods to add and remove pages.
Page, including an array of images (Image) associated with the page, and methods to add and remove images.
Field, defining one field of data associated with the document, such as an address, account number or order selection. It references the FieldType object from which it was instantiated.
FieldType, which defines the controls and limits of the field, such as the min and max range, and whether or not it is required.
UIControls

Classes and API associated with UI controls that you can add to your mobile application.
The image capture UI control (ImageCaptureView) captures images of documents that you want to include in the business process you design in your application. You should use it with appropriate capture experience class according to document types: common DocumentCaptureExperience or specialized CheckCaptureExperience, PassportCaptureExperience or FixedAspectRatioCaptureExperience
You can control the size, aspect ratio and design of a frame that represents a visual cue to the user that shows the size and orientation of the target page. Your user would then orient the camera or the document to line up with the frame so that the picture taken has the document correctly oriented.
Additional SelfieCaptureExperience guides the user to take a clear legible photo of a selfie.

The image review and edit control (ImgReviewEditCntrl) is intended to display images of documents used as part of your business flow. It includes a rectangle that you can control to allow your user to manually indicate the page boundary for a subsequent edit process using the image processor.
The Barcode UI capture control (BarCodeCaptureView) captures single barcode data when you hover over one with the live camera view.

Utilities

Licensing, error classes, SdkVersion, AppContextProvider, etc.

Asynchronous operations, events
The Kofax Mobile SDK not only includes classes to provide the API to properties and methods, but also several events and listeners for notifying you of progress or completion of asynchronous operations. Asynchronous operations include image processing, image classification, server communications through the logistics services, and image and barcode capture etc.
Some of the top level API classes are instantiated as regular instance objects by using a public constructor, but are restricted to having only one object instance active at any given time. These "one active at a time" objects include the image processor, the image classifier and the Server objects.
The Kofax Mobile SDK events are below. Mostly listener callbacks can be registered in each of the designated classes to receive these events.

  • AppStatistics
    • AppStatsExportEvent: fires when AppStats events are being exported.
    • AppStatsSessionEvent: not fired, used to define a specific AppStats Session event.
    • AppStatsThresholdReachedEvent: fires when the size threshold is reached for either in-memory AppStats events, or AppStats events written to file.
    • AppStatsWritetoFileEvent: fires each time an AppStats event is written to file.
  • BarCodeCaptureView
    • BarCodeFoundEvent: fires with decoded barcode data and the unprocessed image that was used to read the barcode.
  • BarCodeReader
    • BarcodeReadCompleteEvent: fires processed Image object with decoded barcode data
  • DocumentBaseCaptureExperience and its children
    • ImageCapturedEvent: fires when an image is successfully captured, and returns an Image object.
    • PageDetectionEvent: fires when a page was detected in the camera preview.
  • ImageCaptureView
    • AutoFocusResultEvent: signifies whether the camera succeeded in focusing or not.
    • LevelnessEvent: fires when the pitch and roll of the device changes.
    • StabilityDelayEvent: fires in response to accelerometer changes and indicates a change in stability levels.
    • TorchLuminanceEvent: fires when torch luminance level changes.
    • CameraInitializationEvent: fires when the camera is initialized or reinitialized.
    • CameraInitializationFailedEvent: fires when the camera initialization fails.
    • PreviewFrameEvent: indicates a preview frame is available from the camera.
  • ImageClassifier
    • ImageClassificationCompleteEvent: fires upon completion of an image classification process. The event includes status information, and the Image object that was classified.
  • ImageProcessor
    • ImageOutEvent: fires in response to a processed Image being available following a call to processImage.
    • ProcessProgressEvent: fires in response to image processing progress information being available following a call to processImage.
    • AnalysisCompleteEvent: fires in response to image quick analysis results being available following a call to doQuickAnalysis.
    • AnalysisProgressEvent: fires in response to image quick analysis progress information being available following a call to doQuickAnalysis.
  • LicenseCaptureView
    • LicenseFoundEvent: indicates that a license was found.
Untitled Document © 2017 Kofax, Inc. All rights reserved. Use is subject to license terms.


Kofax Mobile SDK API Reference: Deprecated List

  • Packages
  • Classes
  • Files
Deprecated List
Class BasicSettingsProfile
Deprecated in SDK 3.3. Please use ImageProcessorConfiguration
Member DocumentDetectionSettings.DocumentEdgeDetection.ISG
As of release 3.3 the algorithm was deprecated.
Member DocumentType.getBasicSettingsProfile ()
Deprecated in SDK 3.3.
Member DocumentType.getImagePerfectionProfile ()
Deprecated in SDK 3.3.
Member DocumentType.setBasicSettingsProfile (BasicSettingsProfile basicSettingsProfile)
Deprecated in SDK 3.3.
Member DocumentType.setImagePerfectionProfile (ImagePerfectionProfile imagePerfectionProfile)
Deprecated in SDK 3.3.
Member DocumentTypeR.getBasicSettingsProfile ()
Deprecated in SDK 3.3.
Member DocumentTypeR.getImagePerfectionProfile ()
Deprecated in SDK 3.3.
Member IdExtractionParameters.getRegion ()
As of SDK 3.3 replaced by getProjectName()
Member IdExtractionParameters.IdExtractionParameters (IdRegion region, IdType idType, Image frontImage, List< BarCodeResult > frontBarcodes, Image backImage, List< BarCodeResult > backBarcodes, boolean isProcessed, IIdExtractionListener listener)
As of SDK 3.3 replaced by IdExtractionParameters(String, IdType, Image, List<BarCodeResult>, Image, List<BarCodeResult>, boolean, IIdExtractionListener)
Member Image.getBasicSettingsProfileUsed ()
Deprecated in SDK 3.3. BasicSettingsProfile is replaced by ImageProcessorConfiguration which is not stored in Image instance.
Member Image.getImagePerfectProfileUsed ()
Deprecated in SDK 3.3. ImagePerfectionProfile is replaced by ImageProcessorConfiguration which is not stored in Image instance.
Class ImagePerfectionProfile
Deprecated in SDK 3.3. Please use ImageProcessorConfiguration
Member ImageProcessor.getBasicSettingsProfile ()
Deprecated in SDK 3.3. BasicSettingsProfile is replaced by ImageProcessorConfiguration.
Member ImageProcessor.getImagePerfectionProfile ()
Deprecated in SDK 3.3. ImagePerfectionProfile is replaced by ImageProcessorConfiguration.
Member ImageProcessor.processImage (Image image)
Deprecated in SDK 3.3. Replaced by processImage(Image, ImageProcessorConfiguration)
Member ImageProcessor.setBasicSettingsProfile (BasicSettingsProfile basicSettingsProfile)
Deprecated in SDK 3.3. Please use ImageProcessorConfiguration as an argument for calling processImage(Image, ImageProcessorConfiguration)
Member ImageProcessor.setImagePerfectionProfile (ImagePerfectionProfile imagePerfectionProfile)
Deprecated in SDK 3.3. Please use ImageProcessorConfiguration as an argument for calling processImage(Image, ImageProcessorConfiguration)


Kofax Mobile SDK API Reference: Packages

Packages
Here are the packages with brief descriptions (if available):
[detail level 1234567]
▼N com
▼N kofax
▼N kmc
▼N ken
▼N engines
N data
N processing
N version
▼N klo
▼N logistics
N data
N version
▼N kui
▼N uicontrols
N captureanimations
N data
N version
▼N kut
▼N utilities
N appstats
N async
N error
N version
▼N mobile
▼N sdk
▼N capture
N bill
N check
N creditcard
N extraction
N id
N model
N parameter
N passport
N processing
▼N extract
▼N id
N bundle
N server
N logistics


Kofax Mobile SDK API Reference: Package com

Packages
Package com

Packages

package kofax


Kofax Mobile SDK API Reference: Package com.kofax

  • com
  • kofax
Packages
Package com.kofax

Packages

package | kmc
package | mobile


Kofax Mobile SDK API Reference: Package com.kofax.kmc

  • kmc
Packages
Package com.kofax.kmc

Packages

package | ken
package | klo
package | kui
package | kut


Kofax Mobile SDK API Reference: Package com.kofax.kmc.ken

  • kmc
  • ken
Packages
Package com.kofax.kmc.ken

Packages

package engines


Kofax Mobile SDK API Reference: Package com.kofax.kmc.ken.engines

  • kmc
  • ken
  • engines
Packages | Classes
Package com.kofax.kmc.ken.engines

Packages

package | data
package | processing
package | version

Classes

class | BarCodeReader
The barcode recognition engine. More...
class | CheckDetector
class | DocumentDetector
interface | ICheckDetector
interface | IDocumentDetector
interface | ImageClassificationCompletedListener
The listener interface for receiving image classification completed events. More...
class | ImageClassificationCompleteEvent
This event is raised in response to an image classification process. More...
class | ImageClassificationResult
Results from classifying an image. This object is serializable. More...
class | ImageClassifier
This class is used to classify images based on given configuration and model. More...
class | ImageProcessor
The ImageProcessor is the image processing engine. More...
interface | IPassportDetector
class | KENLogging
class | PassportDetector


Kofax Mobile SDK API Reference: Package com.kofax.kmc.ken.engines.data

  • kmc
  • ken
  • engines
  • data
Classes
Package com.kofax.kmc.ken.engines.data

Classes

enum | BarCodeDataFormat
An enum that identifies the format of the bar code found. More...
enum | BarCodeDirection
An enum that identifies the direction of the bar code found. More...
class | BarCodeResult
A single bar code found data item. This object is serializable. More...
enum | BarCodeType
An enum that identifies the type of the bar code found. More...
class | BasicSettingsProfile
The BasicSettingsProfile specifies basic image processing options. This object is serializable. More...
class | BoundingRect
The BoundingRect object holds four integer edge coordinates for a rectangle. More...
class | BoundingTetragon
The BoundingTetragon object holds four corner points for a tetragon. This object is serializable. More...
class | CheckDetectionResult
class | CheckDetectionSettings
enum | CheckSide
class | DetectionResult
class | DetectionSettings
class | DocumentDetectionResult
class | DocumentDetectionSettings
class | FixedAspectRatioDetectionSettings
enum | HorizontalGuidance
class | Image
The Image Object contains an in-memory and/or image file based representation of an image. This object is serializable. More...
class | ImagePerfectionProfile
The ImagePerfectionProfile object encapsulates advanced image processing settings. This object is serializable. More...
enum | ImageSource
enum | OrientationGuidance
class | PassportDetectionResult
class | PassportDetectionSettings
class | QuickAnalysisFeedback
The QuickAnalysisFeedback object contains the results of image quality checking using the doQuickAnalysis method of the ImageProcessor object. This object is serializable. More...
class | QuickAnalysisSettings
A configuration object for controlling the quick analysis image processing. More...
class | SelfieDetectionSettings
enum | TurnGuidance
enum | VerticalGuidance
enum | ZoomGuidance


Kofax Mobile SDK API Reference: Package com.kofax.kmc.ken.engines.processing

  • kmc
  • ken
  • engines
  • processing
Classes
Package com.kofax.kmc.ken.engines.processing

Classes

enum | ColorDepth
enum | CropType
enum | DeskewType
class | DocumentDimensions
class | ImageProcessorConfiguration
enum | RotateType
enum | TargetFrameCropType


Kofax Mobile SDK API Reference: Package com.kofax.kmc.ken.engines.version

  • kmc
  • ken
  • engines
  • version
Classes
Package com.kofax.kmc.ken.engines.version

Classes

class KenVersion


Kofax Mobile SDK API Reference: Package com.kofax.kmc.klo

  • kmc
  • klo
Packages
Package com.kofax.kmc.klo

Packages

package logistics


Kofax Mobile SDK API Reference: Package com.kofax.kmc.klo.logistics

  • kmc
  • klo
  • logistics
Packages | Classes
Package com.kofax.kmc.klo.logistics

Packages

package | data
package | version

Classes

class | KLOLogging
enum | SessionState
An enum which contains various FrontOfficeServer and TotalAgility session state information. More...


Kofax Mobile SDK API Reference: Package com.kofax.kmc.klo.logistics.data

  • kmc
  • klo
  • logistics
  • data
Classes
Package com.kofax.kmc.klo.logistics.data

Classes

class | ClassificationResult
Results from classifying a Document using an RTTI web service. This object is serializable. More...
class | Document
The Document object is instantiated as a specific DocumentType. This object is serializable. More...
class | DocumentType
The DocumentType object is a model that describes the attributes of a document. This object is serializable. More...
interface | DocumentTypeR
The DocumentTypeR Object is a model that describes the attributes of a document. This object is serializable. More...
class | Field
The Field object is instantiated using a particular FieldType object and contains a value which confirms to that Field Type. This object is serializable. More...
class | FieldType
The FieldType Object is a model that describes the attributes of a field. This object is serializable. More...
class | Page
There can be one or more Pages in a Document. This object is serializable. More...
class | UserProfile
The UserProfile Object contains login credentials for a user. More...


Kofax Mobile SDK API Reference: Package com.kofax.kmc.klo.logistics.version

  • kmc
  • klo
  • logistics
  • version
Classes
Package com.kofax.kmc.klo.logistics.version

Classes

class KloVersion


Kofax Mobile SDK API Reference: Package com.kofax.kmc.kui

  • kmc
  • kui
Packages
Package com.kofax.kmc.kui

Packages

package uicontrols


Kofax Mobile SDK API Reference: Package com.kofax.kmc.kui.uicontrols

  • kmc
  • kui
  • uicontrols
Packages | Classes
Package com.kofax.kmc.kui.uicontrols

Packages

package | captureanimations
package | data
package | version

Classes

class | AutoFocusResultEvent
This event returns the result of the camera's attempt to auto focus. More...
interface | AutoFocusResultListener
The listener interface for responding to camera focus events. More...
class | BarCodeCaptureView
class | BarCodeFoundEvent
An event that indicates a barcode has been found. More...
interface | BarCodeFoundListener
The listener interface for receiving barcode events. More...
class | CameraInitializationEvent
This event fires when the camera is initialized or reinitialized. More...
class | CameraInitializationFailedEvent
interface | CameraInitializationFailedListener
interface | CameraInitializationListener
The interface that is required to implement CameraInitializationEvent. More...
class | ImageCapturedEvent
This event is fired when an image is successfully captured. More...
interface | ImageCapturedListener
class | ImageCaptureView
class | ImgReviewEditCntrl
class | KUILogging
class | LevelnessEvent
This event fires when the orientation of the device changes. More...
interface | LevelnessListener
The interface that is required to implement StabilityDelayEvent. More...
class | LicenseCaptureView
class | LicenseFoundEvent
An event that indicates that a license was found. More...
interface | LicenseFoundListener
The listener interface for receiving license found events. More...
class | PageDetectionEvent
An event that indicates a page was detected in the camera preview. More...
interface | PageDetectionListener
interface | PreviewCallbackListener
class | PreviewFrameEvent
class | StabilityDelayEvent
This event fires when stability levels change. More...
interface | StabilityDelayListener
The interface that is required to implement StabilityDelayEvent. More...
class | TorchLuminanceEvent
This event fires when torch luminance level changes. More...
interface | TorchLuminanceListener
The interface that is required to implement TorchLuminanceEvent. More...


Kofax Mobile SDK API Reference: Package com.kofax.kmc.kui.uicontrols.captureanimations

  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes
Package com.kofax.kmc.kui.uicontrols.captureanimations

Classes

class | CaptureExperience
This class is a base class for the DocumentCaptureExperience and CheckCaptureExperience, PassportCaptureExperience and FixedAspectRatioCaptureExperience. More...
class | CaptureExperienceCriteriaHolder
class | CaptureMessage
class | CheckCaptureExperience
class | CheckCaptureExperienceCriteriaHolder
class | DocumentBaseCaptureExperience
class | DocumentBaseCaptureExperienceCriteriaHolder
class | DocumentCaptureExperience
class | DocumentCaptureExperienceCriteriaHolder
class | FixedAspectRatioCaptureExperience
class | FixedAspectRatioExperienceCriteriaHolder
class | PassportCaptureExperience
class | PassportCaptureExperienceCriteriaHolder
class | SelfieBaseCaptureExperience
class | SelfieCaptureExperience
class | SelfieCaptureExperienceCriteriaHolder


Kofax Mobile SDK API Reference: Package com.kofax.kmc.kui.uicontrols.data

  • kmc
  • kui
  • uicontrols
  • data
Classes
Package com.kofax.kmc.kui.uicontrols.data

Classes

enum | CameraType
This enum represents the camera type. More...
enum | Flash
This enum represents the various camera flash settings. More...
enum | GpsUsageLimits
enum | GuidingLine
An enum representing the rendering and orientation of a guiding line for barcode capture. More...
enum | ImageCacheType
enum | SearchDirection
An enum representing a direction or set of directions to search for barcodes. More...
enum | Symbology
An enum representing a barcode symbology. More...


Kofax Mobile SDK API Reference: Package com.kofax.kmc.kui.uicontrols.version

  • kmc
  • kui
  • uicontrols
  • version
Classes
Package com.kofax.kmc.kui.uicontrols.version

Classes

class KuiVersion


Kofax Mobile SDK API Reference: Package com.kofax.kmc.kut

  • kmc
  • kut
Packages
Package com.kofax.kmc.kut

Packages

package utilities


Kofax Mobile SDK API Reference: Package com.kofax.kmc.kut.utilities

  • kmc
  • kut
  • utilities
Packages | Classes
Package com.kofax.kmc.kut.utilities

Packages

package | appstats
package | async
package | error
package | version

Classes

class | AppContextProvider
This class keeps a reference of the application context. More...
interface | CertificateValidatorListener
class | KUTLogging
class | Licensing
This class comprises the licensing mechanism for Mobile SDK. More...
class | MicrLine
This class represents the MICR line itself. More...
class | MicrParser
This class parses the MICR data line from different check detection algorithms. More...
class | SdkVersion
This class provides access to version information for the Kofax Mobile SDK. More...
class | Size
Universal class for image size describing. More...


Kofax Mobile SDK API Reference: Package com.kofax.kmc.kut.utilities.appstats

  • kmc
  • kut
  • utilities
  • appstats
Classes
Package com.kofax.kmc.kut.utilities.appstats

Classes

class | AppStatistics
Use the AppStatistics class for creating, saving, and exporting statistics related to SDK framework usage. More...
class | AppStatsDaoField
Container for properties that define one field in a table in the datastore. More...
interface | AppStatsDsExportHandler
class | AppStatsExportEvent
This event is fired when AppStats events are being exported. More...
interface | AppStatsExportListener
class | AppStatsSessionEvent
This data-only class is used to set properties that define an AppStats Session Event. More...
class | AppStatsThresholdReachedEvent
interface | AppstatsThresholdReachedListener
interface | AppStatsWriteFileListener
class | AppStatsWritetoFileEvent
class | AppStatsWriteToFileResults


Kofax Mobile SDK API Reference: Package com.kofax.kmc.kut.utilities.async

  • kmc
  • kut
  • utilities
  • async
Classes
Package com.kofax.kmc.kut.utilities.async

Classes

enum ListenerCallbackThreadType
An enum which identifies the thread type for asynchronous callbacks. More...


Kofax Mobile SDK API Reference: Package com.kofax.kmc.kut.utilities.error

  • kmc
  • kut
  • utilities
  • error
Classes
Package com.kofax.kmc.kut.utilities.error

Classes

class | ErrGrp
The ErrGrp class contains the starting base error code values for each error group (category).
enum | ErrorInfo
The ErrorInfo enum can be used by application developers to lookup error information. More...
class | KmcException
An extended Exception class that specifies KMC errors as defined by the ErrorInfo enum. More...
class | KmcRuntimeException
An extended RuntimeException class that specifies KMC errors as defined by the ErrorInfo enum. More...


Kofax Mobile SDK API Reference: Package com.kofax.kmc.kut.utilities.version

  • kmc
  • kut
  • utilities
  • version
Classes
Package com.kofax.kmc.kut.utilities.version

Classes

class KutVersion


Kofax Mobile SDK API Reference: Package com.kofax.mobile

  • mobile
Packages
Package com.kofax.mobile

Packages

package sdk


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk

  • mobile
  • sdk
Packages | Classes
Package com.kofax.mobile.sdk

Packages

package | capture
package | extract
package | logistics

Classes

class Logging


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.capture

  • mobile
  • sdk
  • capture
Packages | Classes
Package com.kofax.mobile.sdk.capture

Packages

package | bill
package | check
package | creditcard
package | extraction
package | id
package | model
package | parameter
package | passport
package | processing

Classes

class | ApplicationContextImageStore
class | CaptureActivity
class | ContextImageStorage
class | ExtractActivity
interface | IImageStorage
class | ImageReviewActivity
class | ProcessActivity
class | WorkflowActivity


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.capture.bill

  • mobile
  • sdk
  • capture
  • bill
Classes
Package com.kofax.mobile.sdk.capture.bill

Classes

class | BillCaptureActivity
class | BillExtractActivity
class | BillExtractor
class | BillExtractorResponse
class | BillParameters
class | BillWorkflowActivity
interface | IBillDeserializer
interface | IBillExtractorListener
class | KtaBillExtractor
class | KtaJsonBill
class | RttiBillExtractor
class | RttiJsonBill


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.capture.check

  • mobile
  • sdk
  • capture
  • check
Classes
Package com.kofax.mobile.sdk.capture.check

Classes

class | CheckCaptureActivity
class | CheckExtractActivity
class | CheckExtractor
class | CheckExtractorResponse
class | CheckParameters
class | CheckWorkflowActivity
interface | ICheckDeserializer
interface | ICheckExtractionServer
interface | ICheckExtractorListener
class | KtaCheckExtractor
class | KtaJsonCheck
class | RttiCheckExtractor
class | RttiJsonCheck


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.capture.creditcard

  • mobile
  • sdk
  • capture
  • creditcard
Classes
Package com.kofax.mobile.sdk.capture.creditcard

Classes

class | CardIoWrapperActivity
class | CreditCardParameters
class | CreditCardWorkflowActivity


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.capture.extraction

  • mobile
  • sdk
  • capture
  • extraction
Classes
Package com.kofax.mobile.sdk.capture.extraction

Classes

interface | ExceptionResponse
class | ExceptionResponseImpl
class | Extractor
class | ExtractorResponse
interface | IExtractorListener


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.capture.id

  • mobile
  • sdk
  • capture
  • id
Classes
Package com.kofax.mobile.sdk.capture.id

Classes

class | ConventionBasedJsonIdDeserializer
class | IdCaptureActivity
class | IdCaptureBackActivity
class | IdExtractActivity
class | IdExtractor
class | IdExtractorResponse
class | IdParameters
class | IdWorkflowActivity
interface | IIdDeserializer
interface | IIdExtractionServer
interface | IIdExtractorListener
class | KtaIdExtractor
class | RttiIdExtractor


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.capture.model

  • mobile
  • sdk
  • capture
  • model
Classes
Package com.kofax.mobile.sdk.capture.model

Classes

class | Bill
class | CaptureData
class | Check
class | CheckIQAData
class | CheckUsabilityData
class | CreditCard
class | Field
class | FieldLocation
class | Id
class | Passport
class | PointDouble
class | SizeDouble


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.capture.parameter

  • mobile
  • sdk
  • capture
  • parameter
Classes
Package com.kofax.mobile.sdk.capture.parameter

Classes

class | ExtractionCredentials
class | ExtractionParameters
interface | IParameters
class | LookAndFeelParameters
class | ProcessingParameters


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.capture.passport

  • mobile
  • sdk
  • capture
  • passport
Classes
Package com.kofax.mobile.sdk.capture.passport

Classes

class | ConventionBasedJsonIdDeserializer
interface | IPassportDeserializer
interface | IPassportExtractorListener
class | KtaJsonPassport
class | KtaPassportExtractor
class | PassportCaptureActivity
class | PassportExtractActivity
class | PassportExtractor
class | PassportExtractorResponse
class | PassportParameters
class | PassportWorkflowActivity
class | RttiJsonPassport
class | RttiPassportExtractor


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.capture.processing

  • mobile
  • sdk
  • capture
  • processing
Classes
Package com.kofax.mobile.sdk.capture.processing

Classes

interface | IImageProcessor
interface | IImageProcessorListener


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.extract

  • mobile
  • sdk
  • extract
Packages
Package com.kofax.mobile.sdk.extract

Packages

package | id
package | server


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.extract.id

  • mobile
  • sdk
  • extract
  • id
Packages | Classes
Package com.kofax.mobile.sdk.extract.id

Packages

package bundle

Classes

class | AggregateException
class | DataField
interface | ICompletionListener
class | IdExtractionParameters
enum | IdRegion
enum | IdType
interface | IIdExtractionListener
interface | IIdExtractionResult
interface | IIdExtractor
interface | IProjectProvider
class | ListOfException
class | LocalProjectProvider
class | OnDeviceIdExtractor
class | ProjectProviderException
class | ServerProjectProvider


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.extract.id.bundle

  • mobile
  • sdk
  • extract
  • id
  • bundle
Classes
Package com.kofax.mobile.sdk.extract.id.bundle

Classes

class | BundleCacheProvider
interface | IBundle
interface | IBundleCacheProvider
interface | IBundleFile
class | ZipFileBundle
class | ZipInputStreamBundle


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.extract.server

  • mobile
  • sdk
  • extract
  • server
Classes
Package com.kofax.mobile.sdk.extract.server

Classes

class | ExtractionServerException
interface | IServerExtractor
class | LoginCredentials
class | ServerBuilder
class | ServerExtractionParameters
class | TimeOutParameters


Kofax Mobile SDK API Reference: Package com.kofax.mobile.sdk.logistics

  • mobile
  • sdk
  • logistics
Classes
Package com.kofax.mobile.sdk.logistics

Classes

class | CaptureServer
interface | ICaptureServer
interface | IProgressListener


Kofax Mobile SDK API Reference: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 123456789]
▼N com |
▼N kofax |
▼N kmc |
▼N ken |
►N engines |
►N data |
C BarCodeDataFormat | An enum that identifies the format of the bar code found
C BarCodeDirection | An enum that identifies the direction of the bar code found
C BarCodeResult | A single bar code found data item. This object is serializable
C BarCodeType | An enum that identifies the type of the bar code found
►C BasicSettingsProfile | The BasicSettingsProfile specifies basic image processing options. This object is serializable
C CropType | An enum which identifies the crop type
C OutputBitDepth | An enum which identifies the output bit depth
C RotateType | An enum which identifies the rotation type
C BoundingRect | The BoundingRect object holds four integer edge coordinates for a rectangle
►C BoundingTetragon | The BoundingTetragon object holds four corner points for a tetragon. This object is serializable
C Rotation |
C CheckDetectionResult |
C CheckDetectionSettings |
C CheckSide |
C DetectionResult |
C DetectionSettings |
C DocumentDetectionResult |
►C DocumentDetectionSettings |
C DocumentEdgeDetection | An enumeration containing the possible edge detection algorithms
C FixedAspectRatioDetectionSettings |
C HorizontalGuidance |
►C Image | The Image Object contains an in-memory and/or image file based representation of an image. This object is serializable
C FileIOEngine | An enum which optionally identifies the desired File I/O Engine used for reading and writing
C FileRestriction | An enum which specifies that ANSI X9.100-181 restrictions are needed for TIFF output
C ImageFileRep | An enum which identifies the File Representation of the image file referenced by this Image Object
C ImageMimeType | An enum which identifies the Mime Type of the image file referenced by this Image Object
C ImageRep | An enum which identifies the Image Representation(s) included in this Image Object
C OutputColor | An enum which identifies the output color desired for writing the bitmap to an image file
►C ImagePerfectionProfile | The ImagePerfectionProfile object encapsulates advanced image processing settings. This object is serializable
C UseDocumentDetectionBasedCrop | An enum used with the useDocumentDetectionBasedCrop property
C UseMRZPassportDetection | An enum used with the useMRZPassportDetection property
C UseTargetFrameCrop | An enum used with the useTargetFrameCrop property
C ImageSource |
C OrientationGuidance |
C PassportDetectionResult |
C PassportDetectionSettings |
C QuickAnalysisFeedback | The QuickAnalysisFeedback object contains the results of image quality checking using the doQuickAnalysis method of the ImageProcessor object. This object is serializable
C QuickAnalysisSettings | A configuration object for controlling the quick analysis image processing
C SelfieDetectionSettings |
C TurnGuidance |
C VerticalGuidance |
C ZoomGuidance |
►N processing |
C ColorDepth |
C CropType |
C DeskewType |
C DocumentDimensions |
C ImageProcessorConfiguration |
C RotateType |
C TargetFrameCropType |
►N version |
C KenVersion |
►C BarCodeReader | The barcode recognition engine
C BarcodeReadCompleteEvent |
C BarcodeReadCompleteListener |
C Direction |
C Symbology |
C CheckDetector |
C DocumentDetector |
C ICheckDetector |
C IDocumentDetector |
C ImageClassificationCompletedListener | The listener interface for receiving image classification completed events
C ImageClassificationCompleteEvent | This event is raised in response to an image classification process
C ImageClassificationResult | Results from classifying an image. This object is serializable
►C ImageClassifier | This class is used to classify images based on given configuration and model
C ImageClassificationStatus |
►C ImageProcessor | The ImageProcessor is the image processing engine
C AnalysisCompleteEvent | An event that indicates that image quick analysis results are available
C AnalysisCompleteListener | The listener interface for receiving analysis complete events
C AnalysisProgressEvent | An event that indicates Image processing progress information is available
C AnalysisProgressListener | The listener interface for receiving Analysis Progress events
C ImageOutEvent | An event that indicates a processed Image is available
C ImageOutListener | The listener interface for receiving Image Out events
C ProcessProgressEvent | An event that indicates Image processing progress information is available
C ProcessProgressListener | The listener interface for receiving Process Progress events
C IPassportDetector |
C KENLogging |
C PassportDetector |
▼N klo |
►N logistics |
►N data |
C ClassificationResult | Results from classifying a Document using an RTTI web service. This object is serializable
C Document | The Document object is instantiated as a specific DocumentType. This object is serializable
►C DocumentType | The DocumentType object is a model that describes the attributes of a document. This object is serializable
C SourceServer | An enum that identifies the source server from which the document was obtained
C DocumentTypeR | The DocumentTypeR Object is a model that describes the attributes of a document. This object is serializable
C Field | The Field object is instantiated using a particular FieldType object and contains a value which confirms to that Field Type. This object is serializable
►C FieldType | The FieldType Object is a model that describes the attributes of a field. This object is serializable
C DataType | An enum that defines the data type specified for this Field Type
►C Page | There can be one or more Pages in a Document. This object is serializable
C Side | Indicates whether this Page is front or back of the sheet
C UserProfile | The UserProfile Object contains login credentials for a user
►N version |
C KloVersion |
C KLOLogging |
C SessionState | An enum which contains various FrontOfficeServer and TotalAgility session state information
▼N kui |
►N uicontrols |
►N captureanimations |
C CaptureExperience | This class is a base class for the DocumentCaptureExperience and CheckCaptureExperience, PassportCaptureExperience and FixedAspectRatioCaptureExperience
C CaptureExperienceCriteriaHolder |
►C CaptureMessage |
C KUIMessageOrientation |
C CheckCaptureExperience |
C CheckCaptureExperienceCriteriaHolder |
C DocumentBaseCaptureExperience |
C DocumentBaseCaptureExperienceCriteriaHolder |
C DocumentCaptureExperience |
C DocumentCaptureExperienceCriteriaHolder |
C FixedAspectRatioCaptureExperience |
C FixedAspectRatioExperienceCriteriaHolder |
C PassportCaptureExperience |
C PassportCaptureExperienceCriteriaHolder |
C SelfieBaseCaptureExperience |
C SelfieCaptureExperience |
C SelfieCaptureExperienceCriteriaHolder |
►N data |
C CameraType | This enum represents the camera type
C Flash | This enum represents the various camera flash settings
C GpsUsageLimits |
C GuidingLine | An enum representing the rendering and orientation of a guiding line for barcode capture
C ImageCacheType |
C SearchDirection | An enum representing a direction or set of directions to search for barcodes
C Symbology | An enum representing a barcode symbology
►N version |
C KuiVersion |
C AutoFocusResultEvent | This event returns the result of the camera's attempt to auto focus
C AutoFocusResultListener | The listener interface for responding to camera focus events
C BarCodeCaptureView |
C BarCodeFoundEvent | An event that indicates a barcode has been found
C BarCodeFoundListener | The listener interface for receiving barcode events
►C CameraInitializationEvent | This event fires when the camera is initialized or reinitialized
C CameraInitStatus |
C CameraInitializationFailedEvent |
C CameraInitializationFailedListener |
C CameraInitializationListener | The interface that is required to implement CameraInitializationEvent
C ImageCapturedEvent | This event is fired when an image is successfully captured
C ImageCapturedListener |
C ImageCaptureView |
►C ImgReviewEditCntrl |
C Line_Style_Solid | An enum which lists the drawing style options the edge of the tetragon
C KUILogging |
C LevelnessEvent | This event fires when the orientation of the device changes
C LevelnessListener | The interface that is required to implement StabilityDelayEvent
C LicenseCaptureView |
C LicenseFoundEvent | An event that indicates that a license was found
C LicenseFoundListener | The listener interface for receiving license found events
C PageDetectionEvent | An event that indicates a page was detected in the camera preview
C PageDetectionListener |
C PreviewCallbackListener |
C PreviewFrameEvent |
C StabilityDelayEvent | This event fires when stability levels change
C StabilityDelayListener | The interface that is required to implement StabilityDelayEvent
C TorchLuminanceEvent | This event fires when torch luminance level changes
C TorchLuminanceListener | The interface that is required to implement TorchLuminanceEvent
▼N kut |
►N utilities |
►N appstats |
►C AppStatistics | Use the AppStatistics class for creating, saving, and exporting statistics related to SDK framework usage
C AppStatsExportFormat | Indicates the export format desired when calling the export method
C ExportStatusEvent |
C ThresholdType |
C AppStatsDaoField | Container for properties that define one field in a table in the datastore
C AppStatsDsExportHandler |
C AppStatsExportEvent | This event is fired when AppStats events are being exported
►C AppStatsExportListener |
C ExportStatus |
C AppStatsSessionEvent | This data-only class is used to set properties that define an AppStats Session Event
C AppStatsThresholdReachedEvent |
C AppstatsThresholdReachedListener |
►C AppStatsWriteFileListener |
C WriteFileStatus |
C AppStatsWritetoFileEvent |
C AppStatsWriteToFileResults |
►N async |
C ListenerCallbackThreadType | An enum which identifies the thread type for asynchronous callbacks
►N error |
C ErrorInfo | The ErrorInfo enum can be used by application developers to lookup error information
C KmcException | An extended Exception class that specifies KMC errors as defined by the ErrorInfo enum
C KmcRuntimeException | An extended RuntimeException class that specifies KMC errors as defined by the ErrorInfo enum
►N version |
C KutVersion |
C AppContextProvider | This class keeps a reference of the application context
C CertificateValidatorListener |
C KUTLogging |
►C Licensing | This class comprises the licensing mechanism for Mobile SDK
C LicenseServerType | An enum of license server types. Use with Licensing.setMobileSDKLicenseServer
C LicenseType | An enum of license types
C VolumeLicenseEventListener | The listener interface for receiving volume licensing events
C VolumeLicenseFailureData | Data class for volume licensing related failures
C VolumeLicenseResultData | Data class for volume licensing related successful operations
►C MicrLine | This class represents the MICR line itself
C CheckType | An enum which identifies the type of check
C MicrParser | This class parses the MICR data line from different check detection algorithms
C SdkVersion | This class provides access to version information for the Kofax Mobile SDK
C Size | Universal class for image size describing
▼N mobile |
▼N sdk |
►N capture |
►N bill |
C BillCaptureActivity |
C BillExtractActivity |
C BillExtractor |
C BillExtractorResponse |
C BillParameters |
C BillWorkflowActivity |
C IBillDeserializer |
C IBillExtractorListener |
C KtaBillExtractor |
C KtaJsonBill |
C RttiBillExtractor |
C RttiJsonBill |
►N check |
C CheckCaptureActivity |
C CheckExtractActivity |
C CheckExtractor |
C CheckExtractorResponse |
►C CheckParameters |
C CheckCountry |
C CheckWorkflowActivity |
C ICheckDeserializer |
C ICheckExtractionServer |
C ICheckExtractorListener |
C KtaCheckExtractor |
C KtaJsonCheck |
C RttiCheckExtractor |
C RttiJsonCheck |
►N creditcard |
C CardIoWrapperActivity |
►C CreditCardParameters |
C CardStyle |
C CreditCardWorkflowActivity |
►N extraction |
C ExceptionResponse |
C ExceptionResponseImpl |
C Extractor |
C ExtractorResponse |
C IExtractorListener |
►N id |
C ConventionBasedJsonIdDeserializer |
C IdCaptureActivity |
C IdCaptureBackActivity |
C IdExtractActivity |
C IdExtractor |
C IdExtractorResponse |
►C IdParameters |
C IdSide |
C IdState |
C IdWorkflowActivity |
C IIdDeserializer |
C IIdExtractionServer |
C IIdExtractorListener |
C KtaIdExtractor |
C RttiIdExtractor |
►N model |
C Bill |
C CaptureData |
C Check |
C CheckIQAData |
C CheckUsabilityData |
C CreditCard |
C Field |
C FieldLocation |
C Id |
C Passport |
C PointDouble |
C SizeDouble |
►N parameter |
C ExtractionCredentials |
►C ExtractionParameters |
C ExtractionType |
C IParameters |
►C LookAndFeelParameters |
C TorchMode |
►C ProcessingParameters |
C ProcessingType |
►N passport |
C IPassportDeserializer |
C IPassportExtractorListener |
C KtaJsonPassport |
C KtaPassportExtractor |
C PassportCaptureActivity |
C PassportExtractActivity |
C PassportExtractor |
C PassportExtractorResponse |
C PassportParameters |
C PassportWorkflowActivity |
C RttiJsonPassport |
C RttiPassportExtractor |
►N processing |
C IImageProcessor |
C IImageProcessorListener |
C ApplicationContextImageStore |
C CaptureActivity |
C ContextImageStorage |
C ExtractActivity |
C IImageStorage |
C ImageReviewActivity |
C ProcessActivity |
C WorkflowActivity |
►N extract |
►N id |
►N bundle |
C BundleCacheProvider |
C IBundle |
C IBundleCacheProvider |
C IBundleFile |
C ZipFileBundle |
C ZipInputStreamBundle |
C AggregateException |
C DataField |
C ICompletionListener |
C IdExtractionParameters |
C IdRegion |
C IdType |
C IIdExtractionListener |
C IIdExtractionResult |
C IIdExtractor |
C IProjectProvider |
C ListOfException |
►C LocalProjectProvider |
►C VersionTable |
C VersionList |
C OnDeviceIdExtractor |
C ProjectProviderException |
►C ServerProjectProvider |
C Error |
►N server |
C ExtractionServerException |
C IServerExtractor |
C LoginCredentials |
►C ServerBuilder |
C ServerType |
C ServerExtractionParameters |
C TimeOutParameters |
►N logistics |
C CaptureServer |
C ICaptureServer |
C IProgressListener |
C Logging |


Kofax Mobile SDK API Reference: BarCodeDataFormat Enum Reference

  • Class Members
  • kmc
  • ken
  • engines
  • data
  • BarCodeDataFormat
Public Attributes | List of all members
BarCodeDataFormat Enum Reference

An enum that identifies the format of the bar code found. More...

Public Attributes

UNKNOWN
ASCII
BASE_64

Detailed Description

An enum that identifies the format of the bar code found.

Member Data Documentation

ASCII
BASE_64
UNKNOWN
The documentation for this enum was generated from the following file:
  • BarCodeDataFormat.java


Kofax Mobile SDK API Reference: BarCodeDirection Enum Reference

  • kmc
  • ken
  • engines
  • data
  • BarCodeDirection
Public Attributes | List of all members
BarCodeDirection Enum Reference

An enum that identifies the direction of the bar code found. More...

Public Attributes

UNKNOWN
LEFT_RIGHT
TOP_DOWN
RIGHT_LEFT
BOTTOM_UP

Detailed Description

An enum that identifies the direction of the bar code found.

Member Data Documentation

BOTTOM_UP
LEFT_RIGHT
RIGHT_LEFT
TOP_DOWN
UNKNOWN
The documentation for this enum was generated from the following file:
  • BarCodeDirection.java


Kofax Mobile SDK API Reference: BarCodeResult Class Reference

  • kmc
  • ken
  • engines
  • data
  • BarCodeResult
Public Member Functions | List of all members
BarCodeResult Class Reference

A single bar code found data item. This object is serializable. More...

Inheritance diagram for BarCodeResult:

Public Member Functions

BarCodeResult ()
Constructs a new BarCodeResult instance. More...
BarCodeType getType ()
Gets the result type of the barcode. More...
void | setType (BarCodeType type)
Sets the result type of the barcode. More...
BoundingTetragon getBoundingBox ()
Gets the bounding tetragon of the barcode. More...
void | setBoundingBox (BoundingTetragon bound)
Sets the bounding tetragon of the barcode. More...
String | getValue ()
Gets the decoded barcode data. More...
void | setValue (String value)
Sets the decoded barcode data. More...
BarCodeDirection getDirection ()
Gets the direction of the barcode. More...
void | setDirection (BarCodeDirection direction)
Sets the direction of the barcode. More...
BarCodeDataFormat getDataFormat ()
Gets the encoding of the decoded barcode value. More...
void | setDataFormat (BarCodeDataFormat format)
Sets the encoding of the decoded barcode value. More...

Detailed Description

A single bar code found data item. This object is serializable.

Each instances contains one possible bar code result from a barcode reader. The result includes the type of barcode found, the location within the image where the barcode was found, and the actual value read.

BarCodeResult objects support serialization in a similar way to Image objects. The Image object documentation provides code examples for serialization and deserialization.

Constructor & Destructor Documentation

BarCodeResult ( )

Constructs a new BarCodeResult instance.

Member Function Documentation

BoundingTetragon getBoundingBox ( )

Gets the bounding tetragon of the barcode.

The bounding tetragon is the area where the barcode reader found the barcode within the input image. A tetragon is used instead of a simple rectangle because the barcode may be skewed in the original image.

A valid bounding box is not guaranteed to be provided with a barcode result. This depends on the SDK object that was used to provide the result, and can further depend on the symbology matched and the parameters used to find the match. If there is no valid bounding box, this method will return null instead.

In particular, results returned from the BarcodeCaptureView only include bounding boxes for the 2D symbologies and PDF417.

Returns
A bounding tetragon.
BarCodeDataFormat getDataFormat ( )

Gets the encoding of the decoded barcode value.

Specifies whether the string returned by getValue() is encoded as ASCII or base64. Barcode data may be encoded as base64 if it contains non-printable characters.

Returns
The encoding type of the barcode data.
BarCodeDirection getDirection ( )

Gets the direction of the barcode.

This value indicates the orientation of the barcode that was found within the source image.

Returns
The direction of the barcode relative to the orientation of the source image.
BarCodeType getType ( )

Gets the result type of the barcode.

Returns
The type (symbology) of a barcode result, such as PDF417 or Code39.
String getValue ( )

Gets the decoded barcode data.

Returns the actual barcode data decoded by the reader. The data may be encoded in either base64 or plain ASCII, depending on whether the decoded data contained non-printable characters.

Returns
decoded data as an ASCII or base64-encoded string.
See also
getDataFormat()
void setBoundingBox ( BoundingTetragon bound )

Sets the bounding tetragon of the barcode.

void setDataFormat ( BarCodeDataFormat format )

Sets the encoding of the decoded barcode value.

void setDirection ( BarCodeDirection direction )

Sets the direction of the barcode.

void setType ( BarCodeType type )

Sets the result type of the barcode.

void setValue ( String value )

Sets the decoded barcode data.

The documentation for this class was generated from the following file:
  • BarCodeResult.java


Kofax Mobile SDK API Reference: BarCodeType Enum Reference

  • kmc
  • ken
  • engines
  • data
  • BarCodeType
Public Attributes | List of all members
BarCodeType Enum Reference

An enum that identifies the type of the bar code found. More...

Public Attributes

UNKNOWN
PDF417
CODE39
QR
DATAMATRIX
CODE128
CODE25
EAN
UPC
CODABAR
AZTEC
CODE93
POSTNET

Detailed Description

An enum that identifies the type of the bar code found.

Member Data Documentation

AZTEC
CODABAR
CODE128
CODE25
CODE39
CODE93
DATAMATRIX
EAN
PDF417
POSTNET
QR
UNKNOWN
UPC
The documentation for this enum was generated from the following file:
  • BarCodeType.java


Kofax Mobile SDK API Reference: BasicSettingsProfile Class Reference

  • kmc
  • ken
  • engines
  • data
  • BasicSettingsProfile
Classes | Public Member Functions | List of all members
BasicSettingsProfile Class Reference

The BasicSettingsProfile specifies basic image processing options. This object is serializable. More...

Inheritance diagram for BasicSettingsProfile:

Classes

enum | CropType
An enum which identifies the crop type. More...
enum | OutputBitDepth
An enum which identifies the output bit depth. More...
enum | RotateType
An enum which identifies the rotation type. More...

Public Member Functions

BasicSettingsProfile ()
Create a new empty BasicSettingsProfile. More...
BasicSettingsProfile clone ()
Performs a field-for-field copy of instances of this class. More...
RotateType getRotateType ()
Gets the rotation type property. More...
void | setRotateType (RotateType rotateType)
Sets the rotation type property. More...
CropType getCropType ()
Gets the crop type property. More...
void | setCropType (CropType cropType)
Sets the crop type property. More...
BoundingTetragon getCroppingTetragon ()
Gets the cropping tetragon property. More...
void | setCroppingTetragon (BoundingTetragon croppingTetragon)
Sets the cropping tetragon property. More...
boolean | getDoDeskew ()
Gets the deskew property. More...
void | setDoDeskew (boolean doDeskew)
Sets the deskew property. More...
Integer | getOutputDPI ()
Gets the output DPI property. More...
void | setOutputDPI (Integer outputDPI)
Sets the output DPI property. More...
OutputBitDepth getOutputBitDepth ()
Gets the output bit depth property. More...
void | setOutputBitDepth (OutputBitDepth outputBitDepth)
Sets the output bit depth property. More...
Float | getInputDocLongEdge ()
Gets the input doc long edge property. More...
void | setInputDocLongEdge (Float inputDocLongEdge)
Sets the input doc long edge property. More...
Float | getInputDocShortEdge ()
Gets the input doc short edge property. More...
void | setInputDocShortEdge (Float inputDocShortEdge)
Sets the input doc short edge property. More...

Detailed Description

The BasicSettingsProfile specifies basic image processing options. This object is serializable.

An instance of this class contains the simple image processing options that you want to perform on an image. These define the standard crop, deskew and rotation options. You can also use this object to specify the output image DPI and the desired color. You specify the output color by setting OutputBitDepth to BITONAL, GRAYSCALE, or COLOR. The cropping tetragon defines bounding corner points of an area of an image that you want to crop, and override automatic page detection.

If the outputDPI is >= 300 DPI, and the OutputBitDepth is BITONAL, then the image processing includes enhanced binarization, otherwise it uses standard binarization.

BasicSettingsProfile objects support serialization in a similar way to Image objects. The Image object documentation provides code examples for serialization and deserialization.

Deprecated:
Deprecated in SDK 3.3. Please use ImageProcessorConfiguration

Constructor & Destructor Documentation

BasicSettingsProfile ( )

Create a new empty BasicSettingsProfile.

Member Function Documentation

BasicSettingsProfile clone ( )

Performs a field-for-field copy of instances of this class.

BoundingTetragon getCroppingTetragon ( )

Gets the cropping tetragon property.

Use this property combined with CropType CROP_TETRAGON to specify the corner points of a tetragon for cropping an image. If the tetragon is not a rectangle, the image will be stretched to make it into a rectangle.

CropType getCropType ( )

Gets the crop type property.

Provides a simple way to crop an image. Choose from the options specified in the CropType enum.

boolean getDoDeskew ( )

Gets the deskew property.

The deskew property specifies whether to deskew the image or not.

Float getInputDocLongEdge ( )

Gets the input doc long edge property.

Use this property to set the length of the longer edge of the original document in inches. The library uses this parameter to better estimate the output image DPI and also helps algorithms better detect document corners, especially when one is outside the boundary of the image. You need not set both short and long edges, the algorithm uses one if it is present. If you set it to 0.0 or null, then the library will not use this parameter.

Float getInputDocShortEdge ( )

Gets the input doc short edge property.

Use this property to set the length of the shorter edge of the original document in inches. The library uses this parameter to better estimate the output image DPI and also helps algorithms better detect document corners, especially when one is outside the boundary of the image. You need not set both short and long edges, the algorithm uses one if it is present. If you set it to 0.0 or null, then the library will not use this parameter.

OutputBitDepth getOutputBitDepth ( )

Gets the output bit depth property.

The output bit depth property specifies the desired bit depth of the output image using the OutputBitDepth enum.

Integer getOutputDPI ( )

Gets the output DPI property.

Use this property to set the desired output image DPI (Dots Per Inch). If you set it to 0 or null, the library will automatically detect the output image DPI and indicate it in the output object.

RotateType getRotateType ( )

Gets the rotation type property.

Provides a simple way to enable rotation using the RotateType enum.

void setCroppingTetragon ( BoundingTetragon croppingTetragon )

Sets the cropping tetragon property.

Use this property combined with CropType CROP_TETRAGON to specify the corner points of a tetragon for cropping an image. If the tetragon is not a rectangle, the image will be stretched to make it into a rectangle.

Exceptions
IllegalArgumentException (Cropping tetragon must be larger than 24 pixels).
void setCropType ( CropType cropType )

Sets the crop type property.

Provides a simple way to crop an image. Choose from the options specified in the CropType enum.

Exceptions
NullPointerException ('cropType' parameter is null).
void setDoDeskew ( boolean doDeskew )

Sets the deskew property.

The deskew property specifies whether to deskew the image or not.

Exceptions
NullPointerException ('doDeskew' parameter is null).
void setInputDocLongEdge ( Float inputDocLongEdge )

Sets the input doc long edge property.

Use this property to set the length of the longer edge of the original document in inches. The library uses this parameter to better estimate the output image DPI and also helps algorithms better detect document corners, especially when one is outside the boundary of the image. You need not set both short and long edges, the algorithm uses one if it is present. If you set it to 0.0 or null, then the library will not use this parameter.

Exceptions
KMC_GN_PARAM_NEGATIVE ('inputDocLongEdge' parameter is negative).
void setInputDocShortEdge ( Float inputDocShortEdge )

Sets the input doc short edge property.

Use this property to set the length of the shorter edge of the original document in inches. The library uses this parameter to better estimate the output image DPI and also helps algorithms better detect document corners, especially when one is outside the boundary of the image. You need not set both short and long edges, the algorithm uses one if it is present. If you set it to 0.0 or null, then the library will not use this parameter.

Exceptions
KMC_GN_PARAM_NEGATIVE ('inputDocShortEdge' parameter is negative).
void setOutputBitDepth ( OutputBitDepth outputBitDepth )

Sets the output bit depth property.

The output bit depth property specifies the desired bit depth of the output image using the OutputBitDepth enum.

void setOutputDPI ( Integer outputDPI )

Sets the output DPI property.

Use this property to set the desired output image DPI (Dots Per Inch). If you set it to 0 or null, the library will automatically detect the output image DPI and indicate it in the output object.

Exceptions
KMC_GN_PARAM_NEGATIVE ('outputDPI' parameter is negative).
void setRotateType ( RotateType rotateType )

Sets the rotation type property.

Provides a simple way to enable rotation using the RotateType enum.

Exceptions
NullPointerException ('rotateType' parameter is null).
The documentation for this class was generated from the following file:
  • BasicSettingsProfile.java


Kofax Mobile SDK API Reference: BasicSettingsProfile.CropType Enum Reference

  • kmc
  • ken
  • engines
  • data
  • BasicSettingsProfile
  • CropType
Public Attributes | List of all members
BasicSettingsProfile.CropType Enum Reference

An enum which identifies the crop type. More...

Public Attributes

CROP_NONE
CROP_AUTO
CROP_TETRAGON
CROP_QUICKANALYSIS

Detailed Description

An enum which identifies the crop type.

Member Data Documentation

CROP_AUTO
CROP_NONE
CROP_QUICKANALYSIS
CROP_TETRAGON
The documentation for this enum was generated from the following file:
  • BasicSettingsProfile.java


Kofax Mobile SDK API Reference: BasicSettingsProfile.OutputBitDepth Enum Reference

  • kmc
  • ken
  • engines
  • data
  • BasicSettingsProfile
  • OutputBitDepth
Public Attributes | List of all members
BasicSettingsProfile.OutputBitDepth Enum Reference

An enum which identifies the output bit depth. More...

Public Attributes

BITONAL
GRAYSCALE
COLOR

Detailed Description

An enum which identifies the output bit depth.

Member Data Documentation

BITONAL
COLOR
GRAYSCALE
The documentation for this enum was generated from the following file:
  • BasicSettingsProfile.java


Kofax Mobile SDK API Reference: BasicSettingsProfile.RotateType Enum Reference

  • kmc
  • ken
  • engines
  • data
  • BasicSettingsProfile
  • RotateType
Public Attributes | List of all members
BasicSettingsProfile.RotateType Enum Reference

An enum which identifies the rotation type. More...

Public Attributes

ROTATE_NONE
ROTATE_90
ROTATE_180
ROTATE_270
ROTATE_AUTO

Detailed Description

An enum which identifies the rotation type.

Member Data Documentation

ROTATE_180
ROTATE_270
ROTATE_90
ROTATE_AUTO
ROTATE_NONE
The documentation for this enum was generated from the following file:
  • BasicSettingsProfile.java


Kofax Mobile SDK API Reference: BoundingRect Class Reference

  • kmc
  • ken
  • engines
  • data
  • BoundingRect
Public Member Functions | List of all members
BoundingRect Class Reference

The BoundingRect object holds four integer edge coordinates for a rectangle. More...

Public Member Functions

BoundingRect ()
Public Constructors. More...
BoundingRect (BoundingRect r)
Create a new BoundingRect, with the coordinates copied from the specified BoundingRect. More...
BoundingRect (int left, int top, int right, int bottom)
int | getRectBottom ()
Get the bottom coordinate of the BoundingRect. More...
void | setRectBottom (int bottom)
Set the bottom coordinate of the BoundingRect. More...
int | getRectLeft ()
Get the left coordinate of the BoundingRect. More...
void | setRectLeft (int left)
Set the left coordinate of the BoundingRect. More...
int | getRectRight ()
Get the right coordinate of the BoundingRect. More...
void | setRectRight (int right)
Set the right coordinate of the BoundingRect. More...
int | getRectTop ()
Get the top coordinate of the BoundingRect. More...
void | setRectTop (int top)
Set the top coordinate of the BoundingRect. More...
int | height ()
Public Methods. More...
void | set (int left, int top, int right, int bottom)
Set this BoundingRect's coordinates to the specified values. More...
void | set (BoundingRect src)
Copy the coordinates from src into this BoundingRect. More...
void | setEmpty ()
Set this BoundingRect to (0,0,0,0). More...
String | toString ()
Returns a string containing a concise, human-readable description of this object. More...
int | width ()
Returns calculated width of the BoundingRect. More...

Detailed Description

The BoundingRect object holds four integer edge coordinates for a rectangle.

The rectangle consists of the coordinates of its left, top, right, and bottom edges. These edge coordinates are available through accessor methods.

Constructor & Destructor Documentation

BoundingRect ( )

Public Constructors.

Create a new empty BoundingRect.

BoundingRect ( BoundingRect r )

Create a new BoundingRect, with the coordinates copied from the specified BoundingRect.

BoundingRect | ( | int | left,
 |  | int | top,
 |  | int | right,
 |  | int | bottom
 | ) |  |

Member Function Documentation

int getRectBottom ( )

Get the bottom coordinate of the BoundingRect.

int getRectLeft ( )

Get the left coordinate of the BoundingRect.

int getRectRight ( )

Get the right coordinate of the BoundingRect.

int getRectTop ( )

Get the top coordinate of the BoundingRect.

int height ( )

Public Methods.

Returns calculated height of the BoundingRect.

void set | ( | int | left,
 |  | int | top,
 |  | int | right,
 |  | int | bottom
 | ) |  |

Set this BoundingRect's coordinates to the specified values.

void set ( BoundingRect src )

Copy the coordinates from src into this BoundingRect.

void setEmpty ( )

Set this BoundingRect to (0,0,0,0).

void setRectBottom ( int bottom )

Set the bottom coordinate of the BoundingRect.

void setRectLeft ( int left )

Set the left coordinate of the BoundingRect.

void setRectRight ( int right )

Set the right coordinate of the BoundingRect.

void setRectTop ( int top )

Set the top coordinate of the BoundingRect.

String toString ( )

Returns a string containing a concise, human-readable description of this object.

int width ( )

Returns calculated width of the BoundingRect.

The documentation for this class was generated from the following file:
  • BoundingRect.java


Kofax Mobile SDK API Reference: BoundingTetragon Class Reference

  • kmc
  • ken
  • engines
  • data
  • BoundingTetragon
Classes | Public Member Functions | List of all members
BoundingTetragon Class Reference

The BoundingTetragon object holds four corner points for a tetragon. This object is serializable. More...

Inheritance diagram for BoundingTetragon:

Classes

enum Rotation

Public Member Functions

BoundingTetragon ()
Public Constructors. More...
BoundingTetragon clone ()
Performs a field-for-field copy of instances of this class. More...
BoundingTetragon (int topLeftX, int topLeftY, int topRightX, int topRightY, int bottomLeftX, int bottomLeftY, int bottomRightX, int bottomRightY)
BoundingTetragon (Point topLeft, Point topRight, Point bottomLeft, Point bottomRight)
Point | getTopLeft ()
Get the topLeft point. More...
void | setTopLeft (Point topLeft)
Set the topLeft point. More...
Point | getTopRight ()
Get the topRight point. More...
void | setTopRight (Point topRight)
Set the topRight point. More...
Point | getBottomLeft ()
Get the bottomLeft point. More...
void | setBottomLeft (Point bottomLeft)
Set the bottomLeft point. More...
Point | getBottomRight ()
Get the bottomRight point. More...
void | setBottomRight (Point bottomRight)
Set the bottomRight point. More...
void | rotate (int width, int height, Rotation rotation)

Detailed Description

The BoundingTetragon object holds four corner points for a tetragon. This object is serializable.

The tetragon consists of the its top-left, top-right, bottom-left, and bottom-right points. These are available through accessor methods.

BoundingTetragon objects support serialization in a similar way to Image objects. The Image object documentation provides code examples for serialization and deserialization.

Constructor & Destructor Documentation

BoundingTetragon ( )

Public Constructors.

Create a new empty BoundingTetragon.

BoundingTetragon | ( | int | topLeftX,
 |  | int | topLeftY,
 |  | int | topRightX,
 |  | int | topRightY,
 |  | int | bottomLeftX,
 |  | int | bottomLeftY,
 |  | int | bottomRightX,
 |  | int | bottomRightY
 | ) |  |
BoundingTetragon | ( | Point | topLeft,
 |  | Point | topRight,
 |  | Point | bottomLeft,
 |  | Point | bottomRight
 | ) |  |

Member Function Documentation

BoundingTetragon clone ( )

Performs a field-for-field copy of instances of this class.

Point getBottomLeft ( )

Get the bottomLeft point.

Point getBottomRight ( )

Get the bottomRight point.

Point getTopLeft ( )

Get the topLeft point.

Point getTopRight ( )

Get the topRight point.

void rotate | ( | int | width,
 |  | int | height,
 |  | Rotation | rotation
 | ) |  |

Given a space in which to rotate, rotate the points in this BoundingTetragon Rotation#LEFT, Rotation#RIGHT or Rotation#FLIP.

Parameters
width
height
rotation
void setBottomLeft ( Point bottomLeft )

Set the bottomLeft point.

void setBottomRight ( Point bottomRight )

Set the bottomRight point.

void setTopLeft ( Point topLeft )

Set the topLeft point.

void setTopRight ( Point topRight )

Set the topRight point.

The documentation for this class was generated from the following file:
  • BoundingTetragon.java


Kofax Mobile SDK API Reference: BoundingTetragon.Rotation Enum Reference

  • kmc
  • ken
  • engines
  • data
  • BoundingTetragon
  • Rotation
Public Attributes | List of all members
BoundingTetragon.Rotation Enum Reference

Public Attributes

LEFT
RIGHT
FLIP

Member Data Documentation

FLIP
LEFT
RIGHT
The documentation for this enum was generated from the following file:
  • BoundingTetragon.java


Kofax Mobile SDK API Reference: CheckDetectionResult Class Reference

  • kmc
  • ken
  • engines
  • data
  • CheckDetectionResult
Public Member Functions | List of all members
CheckDetectionResult Class Referenceabstract
Inheritance diagram for CheckDetectionResult:
DetectionResult

Public Member Functions

final CheckSide | getCheckSide ()
- Public Member Functions inherited from DetectionResult
BoundingTetragon getBounds ()
Bitmap | getOriginalImage ()
abstract ZoomGuidance | getZoomGuidance ()
abstract TurnGuidance | getTurnGuidance ()
abstract HorizontalGuidance | getHorizontalMovementGuidance ()
abstract VerticalGuidance | getVerticalMovementGuidance ()
abstract OrientationGuidance | getOrientationGuidance ()
String | toString ()

Detailed Description

Result of check detection.

This class returns the original image the detection algorithm was run against, the bounding coordinates of the detected document, and the guidance information, e.g. zoom out/in move left/right, etc...

Member Function Documentation

final CheckSide getCheckSide ( )

Gets the check side.

Returns
Returns the enum value for the check side.
The documentation for this class was generated from the following file:
  • CheckDetectionResult.java


Kofax Mobile SDK API Reference: CheckDetectionSettings Class Reference

  • kmc
  • ken
  • engines
  • data
  • CheckDetectionSettings
Public Member Functions | List of all members
CheckDetectionSettings Class Reference
Inheritance diagram for CheckDetectionSettings:
DetectionSettings

Public Member Functions

CheckDetectionSettings ()
Default constructor creates a check detection setting object that has default values. More...
CheckDetectionSettings (DetectionSettings settings)
CheckDetectionSettings (CheckDetectionSettings settings)
CheckDetectionSettings (Point targetFrameCenter, double targetFrameAspectRatio, double targetFramePaddingPercent)
Constructor creates a check detection setting object that has specified values. More...
CheckSide getSide ()
void | setSide (CheckSide side)
double | getTargetFrameAspectRatio ()
Gets the aspect ratio of the rectangular frame that should match the passport being searched. More...
void | setTargetFrameAspectRatio (double targetFrameAspectRatio)
Sets the aspect ratio of the rectangular frame that should match the document being searched. More...
void | setAspectRatioFraction (double aspectRatioFraction)
double | getAspectRatioFraction ()
- Public Member Functions inherited from DetectionSettings
DetectionSettings (Point targetFrameCenter, double targetFrameAspectRatio, double targetFramePaddingPercent)
Constructor creates a document detection setting object that has specified values. More...
Point | getCenterPoint ()
Gets the center point within the image of the target frame. More...
void | setCenterPoint (Point targetFrameCenter)
Sets the center point within the image of the target frame. More...
double | getTargetFrameAspectRatio ()
Gets the aspect ratio of the rectangular frame that should match the document being searched. More...
void | setTargetFrameAspectRatio (double targetFrameAspectRatio)
Sets the aspect ratio of the rectangular frame that should match the document being searched. More...
double | getTargetFramePaddingPercent ()
Gets the minimum padding in percent length to be maintained between the edges of the target frame and image. More...
void | setTargetFramePaddingPercent (double paddingPercent)
Sets the minimum padding in percent length to be maintained between the edges of the target frame and image. More...
double | getMinFillFraction ()
Gets the minimum fill area as a fraction of the target frame. More...
void | setMinFillFraction (double minFillFraction)
Sets the minimum fill area as a fraction of the target frame. More...
double | getMaxFillFraction ()
Gets the maximum fill area as a fraction of the target frame. More...
void | setMaxFillFraction (double maxFillFraction)
Sets the maximum fill area as a fraction of the target frame. More...
double | getMaxSkewAngle ()
Gets the maximum angle the document can be rotated off from the target frame. More...
void | setMaxSkewAngle (double maxSkewAngle)
Sets the maximum angle the document can be rotated off from the target frame. More...
double | getToleranceFraction ()
Gets the maximum distance the document can be shifted from the target frame. More...
void | setToleranceFraction (double toleranceFraction)
Sets the maximum distance the document can be shifted from the target frame. More...

Additional Inherited Members

- Protected Member Functions inherited from DetectionSettings
DetectionSettings ()
Default constructor creates a detection setting object that has default values. More...
DetectionSettings (DetectionSettings settings)

Detailed Description

A configuration object for controlling the CheckDetector object.

Note
Target frame aspect ratio is set for Personal Check by default (6.0 / 2.75 ≈ 2.18). For Business Check use: (9.25 / 3.67) ≈ 2.52

Constructor & Destructor Documentation

CheckDetectionSettings ( )

Default constructor creates a check detection setting object that has default values.

  • Center Point: null
  • Aspect Ratio: ≈ 2.18
  • Padding: 5
  • minFillFraction: 0.65
  • maxFillFraction: 1.3
  • maxSkewAngle: 10
  • toleranceFraction: 0.15
  • side: front
  • aspectRatioFraction: 0
CheckDetectionSettings ( DetectionSettings settings )

Constructor that copies base settings defined in DetectionSettings class and sets all other settings to their default values.

Parameters
settings the settings object to copy from
CheckDetectionSettings ( CheckDetectionSettings settings )

Copy constructor.

Parameters
settings the settings object to copy from
CheckDetectionSettings | ( | Point | targetFrameCenter,
 |  | double | targetFrameAspectRatio,
 |  | double | targetFramePaddingPercent
 | ) |  |

Constructor creates a check detection setting object that has specified values.

Parameters
targetFrameCenter | Set the target rectangle center point. Should just be a point with in the bounds of the image height and width.
targetFrameAspectRatio | Set the aspect ratio the target rectangle should have. Must be greater than 0.
targetFramePaddingPercent | Set the padding around the target rectangle. must be greater than or equal to 0 and less then 100.

Member Function Documentation

double getAspectRatioFraction ( )

Returns the tolerance fraction value used for verification of aspect ratio for detected check.

Returns
the fraction value
See also
setAspectRatioFraction(double)
CheckSide getSide ( )

Returns the check side.

Returns
the check side
double getTargetFrameAspectRatio ( )

Gets the aspect ratio of the rectangular frame that should match the passport being searched.

Returns
double
See also
setTargetFrameAspectRatio(double)
void setAspectRatioFraction ( double aspectRatioFraction )

The maximum fractional error allowed between the target frame aspect ratio defined in setTargetFrameAspectRatio(double) and aspect ratio of detected check. Used to obtain the acceptable aspect ratio during detection.

This setting is applicable only for back side of check since for front side aspect ratio is calculated based on MICR.

The value 0.1 assumes that error of aspect ratio will be within 10%.

Default value 0 means that verification of aspect ratio for detected check is disabled.

Parameters
aspectRatioFraction the fraction value
void setSide ( CheckSide side )

Sets the side of a check that needs to be detected.

Parameters
side the check side
void setTargetFrameAspectRatio ( double targetFrameAspectRatio )

Sets the aspect ratio of the rectangular frame that should match the document being searched.

The aspect ratio should be in the format of longEdge/shortEdge (i.e. targetFrameAspectRatio >= 1). The long edge of the target frame is align with the long edge of the camera preview or image. If 0 < targetFrameAspectRatio < 1 it will be inverted. For example: the ratio 0.4 (or 2.0/5.0) will be inverted to 2.5 (5.0/2.0).

If the targetFrameAspectRatio is set to 0, then it will be automatically reset to an image aspect ratio.
Setting negative values has the same effect as if 0 was set.

The default value is 6.0 / 2.75 ≈ 2.18.

Parameters
targetFrameAspectRatio : double
The documentation for this class was generated from the following file:
  • CheckDetectionSettings.java


Kofax Mobile SDK API Reference: CheckSide Enum Reference

  • kmc
  • ken
  • engines
  • data
  • CheckSide
Public Attributes | List of all members
CheckSide Enum Reference

Public Attributes

FRONT
BACK
NONE

Detailed Description

Enum to indicate the check side being detected.

Member Data Documentation

BACK

A check back should be detected

FRONT

A check front should be detected.

NONE
The documentation for this enum was generated from the following file:
  • CheckSide.java


Kofax Mobile SDK API Reference: DetectionResult Class Reference

  • kmc
  • ken
  • engines
  • data
  • DetectionResult
Public Member Functions | List of all members
DetectionResult Class Referenceabstract
Inheritance diagram for DetectionResult:
CheckDetectionResult DocumentDetectionResult PassportDetectionResult

Public Member Functions

BoundingTetragon getBounds ()
Bitmap | getOriginalImage ()
abstract ZoomGuidance | getZoomGuidance ()
abstract TurnGuidance | getTurnGuidance ()
abstract HorizontalGuidance | getHorizontalMovementGuidance ()
abstract VerticalGuidance | getVerticalMovementGuidance ()
abstract OrientationGuidance | getOrientationGuidance ()
String | toString ()

Detailed Description

Base class for result of guided detection driven by target frame.

This class returns the original image the detection algorithm was run against, the bounding coordinates of the detected document, and the guidance information, e.g. zoom out/in move left/right, etc...

Member Function Documentation

BoundingTetragon getBounds ( )

Returns the bounding coordinates of the detected document.

Returns
BoundingTetragon containing the points of the polygon containing the detected document.
abstract HorizontalGuidance getHorizontalMovementGuidance ( )
abstract

Returns the horizontal guidance, e.g. the device should be moved along an x-axis depending on the detection settings values.

Returns
Returns a HorizontalGuidance object.
abstract OrientationGuidance getOrientationGuidance ( )
abstract

Returns orientation guidance, e.g. the device or the document should be rotated, so the orientation of the document matches the orientation of the target frame.

Returns
orientation guidance
Bitmap getOriginalImage ( )

Returns the bitmap representation of the image that the detector was run against.

Returns
the bitmap representation of the image that the detector was run against.
abstract TurnGuidance getTurnGuidance ( )
abstract

Returns the TurnGuidance object, e.g. the document in the image is rotated more than 10 degrees off alignment.

Returns
Returns a TurnGuidance object.
abstract VerticalGuidance getVerticalMovementGuidance ( )
abstract

Returns the vertical guidance, e.g. the device should be moved along a y-axis depending on the detection settings values.

Returns
abstract ZoomGuidance getZoomGuidance ( )
abstract

Returns the zoom guidance, e.g too close/too far away form the document.

Returns
Returns a ZoomGuidance object.
String toString ( )

Returns all of the guidance values as a string.

Returns
Returns a String object of the guidance values.
The documentation for this class was generated from the following file:
  • DetectionResult.java


Kofax Mobile SDK API Reference: DetectionSettings Class Reference

  • kmc
  • ken
  • engines
  • data
  • DetectionSettings
Public Member Functions | Protected Member Functions | List of all members
DetectionSettings Class Referenceabstract
Inheritance diagram for DetectionSettings:
CheckDetectionSettings DocumentDetectionSettings PassportDetectionSettings

Public Member Functions

DetectionSettings (Point targetFrameCenter, double targetFrameAspectRatio, double targetFramePaddingPercent)
Constructor creates a document detection setting object that has specified values. More...
Point | getCenterPoint ()
Gets the center point within the image of the target frame. More...
void | setCenterPoint (Point targetFrameCenter)
Sets the center point within the image of the target frame. More...
double | getTargetFrameAspectRatio ()
Gets the aspect ratio of the rectangular frame that should match the document being searched. More...
void | setTargetFrameAspectRatio (double targetFrameAspectRatio)
Sets the aspect ratio of the rectangular frame that should match the document being searched. More...
double | getTargetFramePaddingPercent ()
Gets the minimum padding in percent length to be maintained between the edges of the target frame and image. More...
void | setTargetFramePaddingPercent (double paddingPercent)
Sets the minimum padding in percent length to be maintained between the edges of the target frame and image. More...
double | getMinFillFraction ()
Gets the minimum fill area as a fraction of the target frame. More...
void | setMinFillFraction (double minFillFraction)
Sets the minimum fill area as a fraction of the target frame. More...
double | getMaxFillFraction ()
Gets the maximum fill area as a fraction of the target frame. More...
void | setMaxFillFraction (double maxFillFraction)
Sets the maximum fill area as a fraction of the target frame. More...
double | getMaxSkewAngle ()
Gets the maximum angle the document can be rotated off from the target frame. More...
void | setMaxSkewAngle (double maxSkewAngle)
Sets the maximum angle the document can be rotated off from the target frame. More...
double | getToleranceFraction ()
Gets the maximum distance the document can be shifted from the target frame. More...
void | setToleranceFraction (double toleranceFraction)
Sets the maximum distance the document can be shifted from the target frame. More...

Protected Member Functions

DetectionSettings ()
Default constructor creates a detection setting object that has default values. More...
DetectionSettings (DetectionSettings settings)

Detailed Description

A base class for configuration objects for controlling the guided detection driven by target frame.

The primary purpose of the settings object is to define properties of a rectangular target frame. The target frame is a rectangular area confined within the bounds of the image, and represents the the ideal area that should be covered by a document. Results returned from the document detector will provide adjustment guidance relative to the target frame.

A target frame is constructed from a center point, an aspect ratio, and a minimum edge padding. The size of the target frame is the largest possible rectangle that can be made without violating any of these constraints.

Additional settings properties set tolerances on the guidance available from a result object.

Constructor & Destructor Documentation

DetectionSettings ( )
protected

Default constructor creates a detection setting object that has default values.

  • Center Point: null
  • Aspect Ratio: 0
  • Padding: 5
  • minFillFraction: 0.65
  • maxFillFraction: 1.3
  • maxSkewAngle: 10
  • toleranceFraction: 0.15
DetectionSettings ( DetectionSettings settings )
protected

Copy constructor

Parameters
settings the settings object to copy from
DetectionSettings | ( | Point | targetFrameCenter,
 |  | double | targetFrameAspectRatio,
 |  | double | targetFramePaddingPercent
 | ) |  |

Constructor creates a document detection setting object that has specified values.

Parameters
targetFrameCenter | Set the target rectangle center point. Should just be a point with in the bounds of the image height and width.
targetFrameAspectRatio | Set the aspect ratio the target rectangle should have. Must be greater than 0.
targetFramePaddingPercent | Set the padding around the target rectangle. must be greater than or equal to 0 and less then 100.

Member Function Documentation

Point getCenterPoint ( )

Gets the center point within the image of the target frame.

Returns
Point
See also
setCenterPoint(android.graphics.Point)
double getMaxFillFraction ( )

Gets the maximum fill area as a fraction of the target frame.

Returns
double
See also
setMaxFillFraction(double)
double getMaxSkewAngle ( )

Gets the maximum angle the document can be rotated off from the target frame.

Returns
double
See also
setMaxSkewAngle(double)
double getMinFillFraction ( )

Gets the minimum fill area as a fraction of the target frame.

Returns
double
See also
setMinFillFraction(double)
double getTargetFrameAspectRatio ( )

Gets the aspect ratio of the rectangular frame that should match the document being searched.

Returns
double
See also
setTargetFrameAspectRatio(double)
double getTargetFramePaddingPercent ( )

Gets the minimum padding in percent length to be maintained between the edges of the target frame and image.

Returns
double
See also
setTargetFramePaddingPercent(double)
double getToleranceFraction ( )

Gets the maximum distance the document can be shifted from the target frame.

Returns
double
See also
setToleranceFraction(double)
void setCenterPoint ( Point targetFrameCenter )

Sets the center point within the image of the target frame.

The center point is any point within the image that the target frame will be constructed around and centered over. This value will be clamped to the valid area of the image being searched, and by default is set to the center of the image.

Parameters
targetFrameCenter : Point
void setMaxFillFraction ( double maxFillFraction )

Sets the maximum fill area as a fraction of the target frame.

The maximum fill fraction puts an upper bound on what is considered an acceptable zoom level. If the area of a detected document is greater then the area of the target frame multiplied by the maximum fill fraction, guidance will suggest zooming out from the document. Setting a negative number is ignored.

The default value is 1.3.

void setMaxSkewAngle ( double maxSkewAngle )

Sets the maximum angle the document can be rotated off from the target frame.

The skew angle tolerance puts an upper bound on how far a document can be rotated clockwise or counter-clockwise relative to the target frame and still be considered acceptable. Angles of rotation greater than the tolerance will result in guidance to turn the document. Setting a negative number is ignored.

The default value is 10, specified in degrees.

Parameters
maxSkewAngle : double
void setMinFillFraction ( double minFillFraction )

Sets the minimum fill area as a fraction of the target frame.

The minimum fill fraction puts a lower bound on what is considered an acceptable zoom level. If the area of a detected document is less then the area of the target frame multiplied by the minimum fill fraction, guidance will suggest zooming in on the document. Setting a negative number is ignored.

The default value is 0.65.

Parameters
minFillFraction : double
void setTargetFrameAspectRatio ( double targetFrameAspectRatio )

Sets the aspect ratio of the rectangular frame that should match the document being searched.

The aspect ratio is used to construct the target frame that should match the document being searched. If targetFrameAspectRatio > 1, the long edge of the target frame will align with the long edge of the camera preview. If 0 < targetFrameAspectRatio < 1, the long edge of the target frame will align with the short edge of the camera preview.

If the targetFrameAspectRatio is set to 0, then it will be automatically reset to an image aspect ratio.
Setting negative values has the same effect as if 0 was set.

The default value is 0.

Parameters
targetFrameAspectRatio : double
void setTargetFramePaddingPercent ( double paddingPercent )

Sets the minimum padding in percent length to be maintained between the edges of the target frame and image.

Values will be clamped to the range [0-50]. The default value is 5. Also, note that there is a much lower operational bound to what the padding percent could be set to behave well. For example:

  • Given detection settings with a frame center at the center of the image, and a personal check aspect ratio, the constructed frame will fill the width of the image, leaving a space on the left and right equal to the padding percent of the image width.
  • Given detection settings with a frame center shifted to the left of the image center, the gap on the right side of the constructed frame will exceed the gap on the left.
Parameters
paddingPercent : double
void setToleranceFraction ( double toleranceFraction )

Sets the maximum distance the document can be shifted from the target frame.

The movement tolerance puts an upper bound on how far a document can be shifted from the target frame and still be considered acceptable. The tolerance is specified as a fraction of the target size, and the comparison is made between the center of the target frame and the center of the detected document bounds. Setting a negative number is ignored.

The default tolerance value is 0.15.

Parameters
toleranceFraction : double
The documentation for this class was generated from the following file:
  • DetectionSettings.java


Kofax Mobile SDK API Reference: DocumentDetectionResult Class Reference

  • kmc
  • ken
  • engines
  • data
  • DocumentDetectionResult
List of all members
DocumentDetectionResult Class Referenceabstract
Inheritance diagram for DocumentDetectionResult:
DetectionResult

Additional Inherited Members

- Public Member Functions inherited from DetectionResult
BoundingTetragon getBounds ()
Bitmap | getOriginalImage ()
abstract ZoomGuidance | getZoomGuidance ()
abstract TurnGuidance | getTurnGuidance ()
abstract HorizontalGuidance | getHorizontalMovementGuidance ()
abstract VerticalGuidance | getVerticalMovementGuidance ()
abstract OrientationGuidance | getOrientationGuidance ()
String | toString ()

Detailed Description

Result of document detection.

This class returns the original image the detection algorithm was run against, the bounding coordinates of the detected document, and the guidance information, e.g. zoom out/in move left/right, etc...

The documentation for this class was generated from the following file:
  • DocumentDetectionResult.java


Kofax Mobile SDK API Reference: DocumentDetectionSettings Class Reference

  • kmc
  • ken
  • engines
  • data
  • DocumentDetectionSettings
Classes | Public Member Functions | List of all members
DocumentDetectionSettings Class Reference
Inheritance diagram for DocumentDetectionSettings:
DetectionSettings

Classes

enum DocumentEdgeDetection
An enumeration containing the possible edge detection algorithms. More...

Public Member Functions

DocumentDetectionSettings ()
Default constructor creates a document detection setting object that has default values. More...
DocumentDetectionSettings (DocumentDetectionSettings detectionSettings)
DocumentDetectionSettings (DetectionSettings detectionSettings)
double | getShortEdgeThreshold ()
void | setShortEdgeThreshold (double shortEdgeThreshold)
double | getLongEdgeThreshold ()
void | setLongEdgeThreshold (double longEdgeThreshold)
DocumentEdgeDetection getEdgeDetection ()
void | setEdgeDetection (DocumentEdgeDetection edgeDetection)
- Public Member Functions inherited from DetectionSettings
DetectionSettings (Point targetFrameCenter, double targetFrameAspectRatio, double targetFramePaddingPercent)
Constructor creates a document detection setting object that has specified values. More...
Point | getCenterPoint ()
Gets the center point within the image of the target frame. More...
void | setCenterPoint (Point targetFrameCenter)
Sets the center point within the image of the target frame. More...
double | getTargetFrameAspectRatio ()
Gets the aspect ratio of the rectangular frame that should match the document being searched. More...
void | setTargetFrameAspectRatio (double targetFrameAspectRatio)
Sets the aspect ratio of the rectangular frame that should match the document being searched. More...
double | getTargetFramePaddingPercent ()
Gets the minimum padding in percent length to be maintained between the edges of the target frame and image. More...
void | setTargetFramePaddingPercent (double paddingPercent)
Sets the minimum padding in percent length to be maintained between the edges of the target frame and image. More...
double | getMinFillFraction ()
Gets the minimum fill area as a fraction of the target frame. More...
void | setMinFillFraction (double minFillFraction)
Sets the minimum fill area as a fraction of the target frame. More...
double | getMaxFillFraction ()
Gets the maximum fill area as a fraction of the target frame. More...
void | setMaxFillFraction (double maxFillFraction)
Sets the maximum fill area as a fraction of the target frame. More...
double | getMaxSkewAngle ()
Gets the maximum angle the document can be rotated off from the target frame. More...
void | setMaxSkewAngle (double maxSkewAngle)
Sets the maximum angle the document can be rotated off from the target frame. More...
double | getToleranceFraction ()
Gets the maximum distance the document can be shifted from the target frame. More...
void | setToleranceFraction (double toleranceFraction)
Sets the maximum distance the document can be shifted from the target frame. More...

Additional Inherited Members

- Protected Member Functions inherited from DetectionSettings
DetectionSettings ()
Default constructor creates a detection setting object that has default values. More...
DetectionSettings (DetectionSettings settings)

Detailed Description

A configuration object for controlling the DocumentDetector object.

Constructor & Destructor Documentation

DocumentDetectionSettings ( )

Default constructor creates a document detection setting object that has default values.

  • Center Point: null
  • Aspect Ratio: 0
  • Padding: 5
  • minFillFraction: 0.4
  • maxFillFraction: 1.3
  • maxSkewAngle: 10
  • toleranceFraction: 0.15
  • shortEdgeThreshold: 0.85
  • longEdgeThreshold: 0.85
  • edgeDetection: GPU_BASED
DocumentDetectionSettings ( DocumentDetectionSettings detectionSettings )

Copy constructor. Creates a copy object for the document detection settings.

Parameters
detectionSettings the settings object to copy from
DocumentDetectionSettings ( DetectionSettings detectionSettings )

Constructor that copies base settings defined in DetectionSettings class and sets all other settings to their default values.

Parameters
detectionSettings the settings object to copy from

Member Function Documentation

DocumentEdgeDetection getEdgeDetection ( )

Returns edge detection algorithm.

Edge detection algorithm defines a set of techniques used for document bounds detection. The default value is GPU.

Returns
edge detection algorithm as DocumentEdgeDetection value
See also
setEdgeDetection(DocumentEdgeDetection)
DocumentEdgeDetection
double getLongEdgeThreshold ( )

Returns the minimum size threshold for the long axis of the image.

This property is a percent of the size of the target frame. The valid range is [0 - 1]. The default value is 0.85.

This property specifies the minimum size of the document that spans the long axis of image. If the detected document is rotated, it will be aligned to the closest 90 degree orientation before any comparison is made.

Returns
long edge threshold as double value
See also
setLongEdgeThreshold(double)
double getShortEdgeThreshold ( )

Returns the minimum document size threshold for the short axis of the image.

This property is a percent of the size of the target frame. The valid range is [0 - 1]. The default value is 0.85.

This property specifies the minimum size of the document that spans the short axis of the image. If the detected document is rotated in the preview, it will be aligned to the closest 90 degree orientation before any comparison is made.

Returns
short edge threshold as double value
See also
setShortEdgeThreshold(double)
void setEdgeDetection ( DocumentEdgeDetection edgeDetection )

Sets edge detection algorithm.

Edge detection algorithm defines a set of techniques used for document bounds detection. The default value is GPU.

Parameters
edgeDetection : DocumentEdgeDetection
See also
DocumentEdgeDetection
void setLongEdgeThreshold ( double longEdgeThreshold )

The minimum document size threshold for the long axis of the image.

Note: When both are set, this property is used in conjunction with setShortEdgeThreshold(double) with an OR operation to determine when edge threshold is met.

This property is a percent of the size of the target frame. The valid range is [0 - 1]. Values outside this range will throw IllegalArgumentException. The default value is 0.85.

This property specifies the minimum size of the document that spans the long axis of image. If the detected document is rotated, it will be aligned to the closest 90 degree orientation before any comparison is made.

Parameters
longEdgeThreshold : double
Exceptions
IllegalArgumentException
See also
setShortEdgeThreshold(double)
void setShortEdgeThreshold ( double shortEdgeThreshold )

The minimum document size threshold for the short axis of the image.

Note: When both are set, this property is used in conjunction with setLongEdgeThreshold(double) with an OR operation to determine when edge threshold is met.

This property is a percent of the size of the target frame. The valid range is [0 - 1]. Values outside this range will throw IllegalArgumentException. The default value is 0.85.

This property specifies the minimum size of the document that spans the short axis of the image. If the detected document is rotated in the preview, it will be aligned to the closest 90 degree orientation before any comparison is made.

Parameters
shortEdgeThreshold : double
Exceptions
IllegalArgumentException
See also
setLongEdgeThreshold(double)
The documentation for this class was generated from the following file:
  • DocumentDetectionSettings.java


Kofax Mobile SDK API Reference: DocumentDetectionSettings.DocumentEdgeDetection Enum Reference

  • kmc
  • ken
  • engines
  • data
  • DocumentDetectionSettings
  • DocumentEdgeDetection
Public Attributes | List of all members
DocumentDetectionSettings.DocumentEdgeDetection Enum Reference

An enumeration containing the possible edge detection algorithms. More...

Public Attributes

ISG
ISG document detection algorithm based on CPU, which is a legacy. More...
GPU_BASED
GPU based document detection algorithm built on top of OpenGLES 2.0. More...

Detailed Description

An enumeration containing the possible edge detection algorithms.

Use one of the values of this enumeration to set the edge detection algorithm.

Member Data Documentation

GPU_BASED

GPU based document detection algorithm built on top of OpenGLES 2.0.

ISG

ISG document detection algorithm based on CPU, which is a legacy.

Deprecated:
As of release 3.3 the algorithm was deprecated.
The documentation for this enum was generated from the following file:
  • DocumentDetectionSettings.java


Kofax Mobile SDK API Reference: FixedAspectRatioDetectionSettings Class Reference

  • kmc
  • ken
  • engines
  • data
  • FixedAspectRatioDetectionSettings
Public Member Functions | List of all members
FixedAspectRatioDetectionSettings Class Reference

Public Member Functions

FixedAspectRatioDetectionSettings ()
Default constructor creates a document detection setting object that has default values. More...
FixedAspectRatioDetectionSettings (FixedAspectRatioDetectionSettings settings)
Point | getCenterPoint ()
Gets the center point within the image of the target frame. More...
void | setCenterPoint (Point targetFrameCenter)
Sets the center point within the image of the target frame. More...
double | getTargetFrameAspectRatio ()
Gets the aspect ratio of the rectangular frame that should match the document being searched. More...
void | setTargetFrameAspectRatio (double targetFrameAspectRatio)
Sets the aspect ratio of the rectangular frame that should match the document being searched. More...
double | getTargetFramePaddingPercent ()
Gets the minimum padding in percent length to be maintained between the edges of the target frame and image. More...
void | setTargetFramePaddingPercent (double paddingPercent)
Sets the minimum padding in percent length to be maintained between the edges of the target frame and image. More...

Detailed Description

A configuration object for controlling the FixedAspectRatioDetector object.

Constructor & Destructor Documentation

FixedAspectRatioDetectionSettings ( )

Default constructor creates a document detection setting object that has default values.

  • Center Point: null
  • Aspect Ratio: 2.125 / 3.375
  • Padding: 8
FixedAspectRatioDetectionSettings ( FixedAspectRatioDetectionSettings settings )

Copy constructor. Creates a copy object for the document detection settings.

Parameters
settings the settings object to copy from

Member Function Documentation

Point getCenterPoint ( )

Gets the center point within the image of the target frame.

Returns
Point
See also
setCenterPoint(android.graphics.Point)
double getTargetFrameAspectRatio ( )

Gets the aspect ratio of the rectangular frame that should match the document being searched.

Returns
double
See also
setTargetFrameAspectRatio(double)
double getTargetFramePaddingPercent ( )

Gets the minimum padding in percent length to be maintained between the edges of the target frame and image.

Returns
double
See also
setTargetFramePaddingPercent(double)
void setCenterPoint ( Point targetFrameCenter )

Sets the center point within the image of the target frame.

The center point is any point within the image that the target frame will be constructed around and centered over. This value will be clamped to the valid area of the image being searched, and by default is set to the center of the image.

Parameters
targetFrameCenter : Point
void setTargetFrameAspectRatio ( double targetFrameAspectRatio )

Sets the aspect ratio of the rectangular frame that should match the document being searched.

The aspect ratio is used to construct the target frame that should match the document being searched. If targetFrameAspectRatio > 1, the long edge of the target frame will align with the long edge of the camera preview. If 0 < targetFrameAspectRatio < 1, the long edge of the target frame will align with the short edge of the camera preview.

If the targetFrameAspectRatio is set to 0, then it will be automatically reset to an image aspect ratio.
Setting negative values has the same effect as if 0 was set.

The default value is 0.

Parameters
targetFrameAspectRatio : double
void setTargetFramePaddingPercent ( double paddingPercent )

Sets the minimum padding in percent length to be maintained between the edges of the target frame and image.

Values will be clamped to the range [0-50]. The default value is 5. Also, note that there is a much lower operational bound to what the padding percent could be set to behave well. For example:

  • Given detection settings with a frame center at the center of the image, and a personal check aspect ratio, the constructed frame will fill the width of the image, leaving a space on the left and right equal to the padding percent of the image width.
  • Given detection settings with a frame center shifted to the left of the image center, the gap on the right side of the constructed frame will exceed the gap on the left.
Parameters
paddingPercent : double
The documentation for this class was generated from the following file:
  • FixedAspectRatioDetectionSettings.java


Kofax Mobile SDK API Reference: HorizontalGuidance Enum Reference

  • kmc
  • ken
  • engines
  • data
  • HorizontalGuidance
Public Attributes | List of all members
HorizontalGuidance Enum Reference

Public Attributes

HORIZONTAL_MOVE_LEFT
HORIZONTAL_MOVE_RIGHT
HORIZONTAL_MOVE_OK

Detailed Description

When a check front is detected, the check detector may return check guidance. This enum indicates if the user should move the camera left, right, or if the check position for capture is okay.

Member Data Documentation

HORIZONTAL_MOVE_LEFT

Move camera left

HORIZONTAL_MOVE_OK

Camera movement not required

HORIZONTAL_MOVE_RIGHT

Move camera right

The documentation for this enum was generated from the following file:
  • HorizontalGuidance.java


Kofax Mobile SDK API Reference: Image Class Reference

  • kmc
  • ken
  • engines
  • data
  • Image
Classes | Public Member Functions | Static Public Attributes | List of all members
Image Class Reference

The Image Object contains an in-memory and/or image file based representation of an image. This object is serializable. More...

Inheritance diagram for Image:

Classes

enum | FileIOEngine
An enum which optionally identifies the desired File I/O Engine used for reading and writing. More...
enum | FileRestriction
An enum which specifies that ANSI X9.100-181 restrictions are needed for TIFF output. More...
enum | ImageFileRep
An enum which identifies the File Representation of the image file referenced by this Image Object. More...
enum | ImageMimeType
An enum which identifies the Mime Type of the image file referenced by this Image Object. More...
enum | ImageRep
An enum which identifies the Image Representation(s) included in this Image Object. More...
enum | OutputColor
An enum which identifies the output color desired for writing the bitmap to an image file. More...

Public Member Functions

long | getImageSize ()
Returns the size of the image. When the representation is both returns the size of the file. More...
Image ()
The default Constructor creates an empty Image object. More...
Image (Bitmap bitmap) throws NullPointerException
This Constructor creates an Image object initialized with the Bitmap passed in. More...
Image (File file, ImageMimeType imgMimeType)
This Constructor creates an Image object initialized with the image File passed in. More...
Image (String imgFilePath, ImageMimeType imgMimeType)
This Constructor creates an Image object initialized with the image file path passed in. More...
String | getImageFilePath ()
Get the path to an image file which is represented by this Image object. More...
void | setImageFilePath (String imgFilePath) throws KmcRuntimeException
Set the path to an image file which this Image object will represent. More...
ImageMimeType getImageMimeType ()
Get the MIME type of this Image object, if an image file representation exists. More...
void | setImageMimeType (ImageMimeType imgMimeType)
Set the MIME type of this Image object, if an image file representation exists. More...
Bitmap | getImageBitmap ()
Get the Bitmap representation of the Image object. More...
void | setImageBitmap (Bitmap imgBitmap) throws KmcRuntimeException
Set the Bitmap representation of this Image object. More...
ImageRep getImageRepresentation ()
Gets the ways in which the image data is represented in this Image object. More...
Integer | getImageBitmapWidth ()
Gets the image width in pixels of the Bitmap representation of this Image object. More...
Integer | getImageBitmapHeight ()
Gets the image height in pixels of the Bitmap representation of this Image object. More...
Float | getImageBitmapScaling ()
Gets the scaling factor used to scale the bitmap when reading in from an image file. More...
Integer | getImageFileWidth ()
Gets the image width in pixels of the File representation of this Image object. More...
Integer | getImageFileHeight ()
Gets the image height in pixels of the File representation of this Image object. More...
String | getImageTag ()
Gets the application-defined tag for this Image object. More...
void | setImageTag (String imgTag)
Sets the application-defined tag for this Image object. More...
String | getImageID ()
Gets an ID which uniquely identifies this Image. More...
String | getImageSrcID ()
Gets the imageID if the original input image. More...
String | getImageMetaData ()
Gets the full image metadata generated by the ImageProcessor Engine. More...
ImagePerfectionProfile getImagePerfectProfileUsed ()
Gets the Image Perfection Profile used to generate this Image object. More...
BasicSettingsProfile getBasicSettingsProfileUsed ()
Gets the Basic Settings Profile used to generate this Image object. More...
QuickAnalysisFeedback getImageQuickAnalysisFeedBack ()
Gets the results from calling the doQuickAnalysis method on the ImageProcessor object. More...
Float | getImageLatitude ()
Gets the GPS latitude associated with the image at the time it was generated. More...
Float | getImageLongitude ()
Gets the GPS longitude associated with the image at the time it was generated. More...
List< BarCodeResult > | getImageBarCodes ()
Gets an array of BarCodeResult objects representing bar codes found on this image. More...
void | setImageBarCodes (List< BarCodeResult > imageBarCodes)
Sets an array of BarCodeResult objects representing bar codes found on this image. More...
List< ImageClassificationResult > | getImageClassifyResults ()
Gets an array of ImageClassificationResult objects representing the result of classifying this image. More...
void | setImageClassifyResults (List< ImageClassificationResult > imgClassifyResults)
Sets an array of ImageClassificationResult objects representing the result of classifying this image. More...
Float | getImagePitch ()
Gets the pitch of the camera in degrees when the image was taken. More...
Float | getImageRoll ()
Gets the roll of the camera in degrees when the image was taken. More...
String | getImageCreateDateTime ()
Gets the date and time the image was created, in ISO 8601 format. More...
void | setImageCreateDateTime (String imgCreateDateTime)
Sets the date and time the image was created, in ISO 8601 format. More...
Integer | getImageDPI ()
Get the resolution of this image in Dots Per Inch. More...
void | setImageDPI (int imgDPI)
Set the resolution of this image in Dots Per Inch. More...
Integer | getImageJpegQuality ()
Get the JPEG image quality for JPEG image files. More...
void | setImageJpegQuality (int imgJpegQuality)
Set the JPEG image quality for JPEG image files. More...
OutputColor getImageOutputColor ()
Get the bits per pixel of the image file representation of this Image object. More...
void | setImageOutputColor (OutputColor imgOutputColor)
Set the bits per pixel of the image file representation of this Image object. More...
ImageFileRep getImageFileRep ()
Gets the way in which the file is stored for this Image object. More...
ByteBuffer | getImageFileBuffer ()
Gets the in-memory ByteBuffer created by a previous call to imageWriteToFileBuffer. More...
ErrorInfo | imageWriteToFile () throws KmcException, KmcRuntimeException
Writes the bitmap in the imageBitmap property to the file specified in ImageFilePath property. More...
ErrorInfo | imageWriteToFile (FileIOEngine engine) throws KmcException, KmcRuntimeException
Writes the bitmap in the imageBitmap property to the file specified in ImageFilePath property. More...
ErrorInfo | imageWriteToFile (FileRestriction fileRestriction) throws KmcException, KmcRuntimeException
Writes the bitmap in the imageBitmap property to the file specified in ImageFilePath property. More...
ErrorInfo | imageWriteToFileBuffer () throws KmcException, KmcRuntimeException
Writes the bitmap in the imageBitmap property to the internal imageFileBuffer. More...
ErrorInfo | imageWriteToFileBuffer (FileIOEngine engine) throws KmcException, KmcRuntimeException
Writes the bitmap in the imageBitmap property to the internal imageFileBuffer. More...
ErrorInfo | imageWriteToFileBuffer (FileRestriction fileRestriction) throws KmcException, KmcRuntimeException
Writes the bitmap in the imageBitmap property to the internal imageFileBuffer. More...
ErrorInfo | imageReadFromFile () throws KmcException, KmcRuntimeException
Reads a bitmap in from an image file of MimeType specified in this object. More...
ErrorInfo | imageReadFromFile (float imgBitmapScaling) throws KmcException, KmcRuntimeException
Reads a bitmap in from an image file using the specified scaling factor. More...
ErrorInfo | imageReadFromFileBuffer () throws KmcException, KmcRuntimeException
Creates a bitmap from the image file buffer contained in this Image. More...
ErrorInfo | imageReadFromFileBuffer (float imgBitmapScaling) throws KmcException, KmcRuntimeException
Creates a bitmap from the image file buffer contained in this Image. More...
ErrorInfo | imageDeleteFile () throws KmcException, KmcRuntimeException
Deletes the image file in the native storage, and sets the FilePath property to null. More...
ErrorInfo imageClearBitmap ()
If a Bitmap representation exists, the bitmap is cleared, and the imageRepresentation property is updated accordingly. More...
ErrorInfo | imageClearFileBuffer () throws KmcException
If a file buffer representation exists, the buffer is cleared, and the imageRepresentation property is updated accordingly. More...
Bitmap | createScaledBitmap (float imgBitmapScaling) throws KmcException
If a Bitmap representation exists, a scaled copy of the bitmap is returned, using the specified scaling factor. More...
String | getMicrData () throws JSONException
void | setMicrData (String micrData) throws NullPointerException
Rect | getTargetFrame ()
void | setTargetFrame (Rect targetFrame)

Static Public Attributes

static final int | MIN_JPEG_QUALITY = 1
static final int | MAX_JPEG_QUALITY = 100
static final int | DEFAULT_JPEG_QUALITY = 90
static final float | MIN_SCALING_FACTOR = 0.1f
static final float | MAX_SCALING_FACTOR = 1.0f
static final int | MIN_DPI_VALUE = 25

Detailed Description

The Image Object contains an in-memory and/or image file based representation of an image. This object is serializable.

The Image object can also contain certain results of operations performed on the Image object by Engine or UiControl objects. An object of this class can be instantiated in three ways:

  • With a Bitmap object using the Bitmap constructor.
  • With an image file using the image file path constructor, or File object constructor.
  • As an empty Image object (no bitmap or image file).

Important: In general, mobile devices have significant memory constraints, and require careful memory management. This is particularly true with regard to images. Bitmaps, especially those taken with higher pixel-count cameras, consume large blocks of memory. When finished with an Image object, the calling application must be sure to call the imageClearBitmap() and imageClearFileBuffer() methods on the Image to avoid out-of-memory problems.

The application should never call recycle on any app reference to the internal Android Bitmap object contained within the Image object. The call to imageClearBitmap() will recycle the internal Bitmap. All application references to the internal Android Bitmap object should be set to null prior to calling the imageClearBitmap(). Not doing so may prevent garbage collection from running, thus preventing the reclaiming of memory consumed by the internal Android Bitmap.

Example of how to use and dispose of the Bitmap contained within an Image object:

Bitmap bitmap = getMyDisplayBitmap();
Image image = new Image(bitmap);
// Done with this local Bitmap reference
bitmap = null;
// Get the internal Android Bitmap object
Bitmap myDisplayBitmap = image.getImageBitmap();
// Do something useful with it
showMyBitmapInUI(myDisplayBitmap);
// Ensure I don't keep a reference to the internal Bitmap
myDisplayBitmap = null;
// Must be called else it will result in a memory leak
image.imageClearBitmap()

The following sample serializes the Image object:

File dest = new File(Environment.getExternalStorageDirectory() + File.separator + "IMAGE_REP_FILE_STORED.save");
FileOutputStream fos = null;
ObjectOutputStream out = null;
try {
String imageFilePath = "STORAGE_PATH" + File.separator + "Example.jpg";
Image myImage = new Image(imageFilePath, Image.ImageMimeType.MIMETYPE_JPEG);
fos = new FileOutputStream(dest);
out = new ObjectOutputStream(fos);
out.writeObject(myImage);
} catch (KmcRuntimeException e) {
e.printStackTrace();
} catch (Exception ex) {
ex.printStackTrace();
} finally {
// Close streams
}

The following sample deserializes the Image object:

File src = new File(Environment.getExternalStorageDirectory() + File.separator + "IMAGE_REP_FILE_STORED.save");
FileInputStream fis = null;
ObjectInputStream in = null;
try {
fis = new FileInputStream(src);
in = new ObjectInputStream(fis);
Image myImageCopy = (Image)in.readObject();
} catch (KmcRuntimeException e) {
e.printStackTrace();
} catch (Exception ex) {
ex.printStackTrace();
} finally {
// Close streams
}

Constructor & Destructor Documentation

Image ( )

The default Constructor creates an empty Image object.

Image ( Bitmap bitmap ) throws NullPointerException

This Constructor creates an Image object initialized with the Bitmap passed in.

Parameters
bitmap Must be set to a valid Android Bitmap object.
Exceptions
NullPointerException (bitmap parameter is null).
Image | ( | File | file,
 |  | ImageMimeType | imgMimeType
 | ) |  |

This Constructor creates an Image object initialized with the image File passed in.

This image file must be one of the MimeTypes included in the ImageMimeType enumeration. Only image files that are stored locally on the file system of the mobile device are supported. Image file paths which include a web address are not supported.

Parameters
file | A File object representing an image file in the local file system of the mobile device.
imgMimeType | The ImageMimeType of the image file represented by the 'file' parameter.
Exceptions
NullPointerException | (file parameter is null).
IllegalArgumentException | (imgMimeType cannot be set to UNKNOWN).
IllegalArgumentException | (file does not exist).
IllegalArgumentException | (imgMimeType does not match MIME type of file).
Image | ( | String | imgFilePath,
 |  | ImageMimeType | imgMimeType
 | ) |  |

This Constructor creates an Image object initialized with the image file path passed in.

This image file must be one of the MimeTypes included in the ImageMimeType enumeration. Only image files that are stored locally on the file system of the mobile device are supported. Image file paths which include a web address are not supported.

Parameters
imgFilePath | A file path representing an image file in the local file system of the mobile device.
imgMimeType | The ImageMimeType of the image file represented by the 'imgFilePath' parameter.
Exceptions
NullPointerException | (imgFilePath parameter is null).
IllegalArgumentException | (imgMimeType cannot be set to UNKNOWN).
IllegalArgumentException | (imgFilePath does not exist).
IllegalArgumentException | (imgMimeType does not match MIME type of imgFilePath).

Member Function Documentation

Bitmap createScaledBitmap ( float imgBitmapScaling ) throws KmcException

If a Bitmap representation exists, a scaled copy of the bitmap is returned, using the specified scaling factor.

This method will create a scaled copy of the Bitmap representation of this object. The imgBitmapScaling parameter must be greater than 0.1 and less than or equal to 1.0. For example, to scale the image by half, specify a value of 0.5. for no scaling, specify a value of 1.0.

The original bitmap stored internally as the Bitmap representation of this object is not modified (remains its original size).

Parameters
imgBitmapScaling Specifies the factor used to scale the bitmap.
Returns
Bitmap A scaled copy of the internal Bitmap representation of this object.
Exceptions
KmcRuntimeException | (KMC_ED_OBJECT_REP_NO_BITMAP).
KmcException | (KMC_GN_OUT_OF_MEMORY).
KmcRuntimeException | (KMC_ED_IMAGE_INVALID_SCALING_FACTOR).
BasicSettingsProfile getBasicSettingsProfileUsed ( )

Gets the Basic Settings Profile used to generate this Image object.

This property will be filled in by the ImageProcessor Engine when returning a processed Image object.

Deprecated:
Deprecated in SDK 3.3. BasicSettingsProfile is replaced by ImageProcessorConfiguration which is not stored in Image instance.
List<BarCodeResult> getImageBarCodes ( )

Gets an array of BarCodeResult objects representing bar codes found on this image.

This property will be filled in by the BarCodeReader Engine when returning a processed Image object.

Bitmap getImageBitmap ( )

Get the Bitmap representation of the Image object.

Integer getImageBitmapHeight ( )

Gets the image height in pixels of the Bitmap representation of this Image object.

If there is no Bitmap representation, null is returned indicating bitmap image height is uninitialized.

Float getImageBitmapScaling ( )

Gets the scaling factor used to scale the bitmap when reading in from an image file.

This value is set when imageReadFromFile, imageReadFromFileBuffer, and createScaledBitmap methods are called that take a bitmap scaling parameter.

The bitmap scaling factor must be greater than 0.1 and less than 1. For example, to scale the image by half, set a value of 0.5 as the ImageBitmapScaling property. By default, the ImageBitmapScaling is set to 1, which means no scaling is performed.

See also
imageReadFromFile(float imgBitmapScaling)
imageReadFromFileBuffer(float imgBitmapScaling)
createScaledBitmap(float imgBitmapScaling)
Integer getImageBitmapWidth ( )

Gets the image width in pixels of the Bitmap representation of this Image object.

If there is no Bitmap representation, null is returned indicating bitmap image width is uninitialized.

List<ImageClassificationResult> getImageClassifyResults ( )

Gets an array of ImageClassificationResult objects representing the result of classifying this image.

This property will be filled in by the Classifier Engine when returning a classified Image object.

String getImageCreateDateTime ( )

Gets the date and time the image was created, in ISO 8601 format.

Example of how to convert ISO 8601 formatted string to Java Date object:

Date date = DateFormatUtils.ISO_8601_EXTENDED_DATETIME_TIME_ZONE_FORMAT.parse(imgCreateDateTime);
Integer getImageDPI ( )

Get the resolution of this image in Dots Per Inch.

The ImageDPI property will be set by the Image Processor Engine, to represent the output DPI of a processed image. The DPI may also be set on a call to imageReadFromFile() method, if it can be determined based on the image file header. If the DPI is not known or never set, the getImageDPI() method will return null.

If the imageWriteToFile() is called, a default value of 72 DPI will be used when writing an in-memory bitmap to an image file, if none is specified.

ByteBuffer getImageFileBuffer ( )

Gets the in-memory ByteBuffer created by a previous call to imageWriteToFileBuffer.

Note: buffers returned by this method must not be used after imageClearFileBuffer() is called.
If necessary, data may be copied to a byte array:

ByteBuffer bb = image.getImageFileBuffer();

byte[] ba = new byte[bb.capacity()];

bb.get(ba);
Integer getImageFileHeight ( )

Gets the image height in pixels of the File representation of this Image object.

If there is no File representation, null is returned indicating file image height is uninitialized.

String getImageFilePath ( )

Get the path to an image file which is represented by this Image object.

ImageFileRep getImageFileRep ( )

Gets the way in which the file is stored for this Image object.

An image in this Image object can be stored as a file on the device or an in-memory buffer.

Integer getImageFileWidth ( )

Gets the image width in pixels of the File representation of this Image object.

If there is no File representation, null is returned indicating file image width is uninitialized.

String getImageID ( )

Gets an ID which uniquely identifies this Image.

The application can get an ID which uniquely identifies this Image.

Integer getImageJpegQuality ( )

Get the JPEG image quality for JPEG image files.

Float getImageLatitude ( )

Gets the GPS latitude associated with the image at the time it was generated.

This property is typically set by the image capture control. This property will be filled in by the ImageProcessor Engine to the imageLatitude of the input Image when returning a processed Image object

Float getImageLongitude ( )

Gets the GPS longitude associated with the image at the time it was generated.

This property is typically set by the image capture control. This property will be filled in by the ImageProcessor Engine to the imageLongitude of the input Image when returning a processed Image object

String getImageMetaData ( )

Gets the full image metadata generated by the ImageProcessor Engine.

This property will be filled in by the ImageProcessor Engine when returning a processed Image object.

ImageMimeType getImageMimeType ( )

Get the MIME type of this Image object, if an image file representation exists.

OutputColor getImageOutputColor ( )

Get the bits per pixel of the image file representation of this Image object.

The in-memory Bitmap image representation may be different from the image file representation. For example, the in-memory Bitmap may be 4 bytes per pixel, but actual pixel colors used may be only 0x00000000 and 0xFFFFFFFF. This Bitmap can be written out to an image file as a 1 bit-per-pixel packed encoding format.

ImagePerfectionProfile getImagePerfectProfileUsed ( )

Gets the Image Perfection Profile used to generate this Image object.

This property will be filled in by the ImageProcessor Engine when returning a processed Image object.

Deprecated:
Deprecated in SDK 3.3. ImagePerfectionProfile is replaced by ImageProcessorConfiguration which is not stored in Image instance.
Float getImagePitch ( )

Gets the pitch of the camera in degrees when the image was taken.

QuickAnalysisFeedback getImageQuickAnalysisFeedBack ( )

Gets the results from calling the doQuickAnalysis method on the ImageProcessor object.

ImageRep getImageRepresentation ( )

Gets the ways in which the image data is represented in this Image object.

An image in this Image object can be represented as an in-memory bitmap, an image file of MIME type ImageMimeType, or both.

Float getImageRoll ( )

Gets the roll of the camera in degrees when the image was taken.

long getImageSize ( )

Returns the size of the image. When the representation is both returns the size of the file.

Returns the size of the image when the image is a file based, buffered, both and bitmap. The size of the bitmap is in pixels, its the product of bitmap height and width and number of bytes per pixel. The size of file is in bytes.

Returns
image size
String getImageSrcID ( )

Gets the imageID if the original input image.

This property will be filled in by the ImageProcessor Engine to the imageID of the input image when returning a processed Image object.

String getImageTag ( )

Gets the application-defined tag for this Image object.

An application could use the ImageTag to distinguish a photo of scenery from a picture of a document.

String getMicrData ( ) throws JSONException

This method will search the image processing metadata for MICR data obtained by processing a check image.

Exceptions
JSONException
Returns
String: The MICR data line from processing a check image.
Rect getTargetFrame ( )

The target frame is a rectangular area confined within the bounds of the image, and represents the ideal area that should be covered by a document. This property will be initialized when image is captured using ImageCaptureView along with one of the Capture Experience.

Returns
Rect
ErrorInfo imageClearBitmap ( )

If a Bitmap representation exists, the bitmap is cleared, and the imageRepresentation property is updated accordingly.

This method will clear and release an existing bitmap representation and update the imageRepresentation property based on whether a file representation also exists, to be either IMAGE_REP_FILE, or IMAGE_REP_UNKNOWN.

Returns
ErrorInfo: (KMC_SUCCESS), or (KMC_ED_ALREADY_CLEAR).
ErrorInfo imageClearFileBuffer ( ) throws KmcException

If a file buffer representation exists, the buffer is cleared, and the imageRepresentation property is updated accordingly.

This method will clear and release an existing file buffer representation and update the imageRepresentation property based on whether a bitmap representation also exists, to be either IMAGE_REP_BITMAP, or IMAGE_REP_UNKNOWN.

Returns
ErrorInfo: (KMC_SUCCESS), or (KMC_ED_BUFFER_ALREADY_CLEARED).
Exceptions
KmcException(KMC_EV_LICENSING)
ErrorInfo imageDeleteFile ( ) throws KmcException, KmcRuntimeException

Deletes the image file in the native storage, and sets the FilePath property to null.

This method deletes the image file and updates imageMimeType and imageRepresentation properties accordingly.

Returns
ErrorInfo: (KMC_SUCCESS), or (KMC_GN_FILE_NOT_FOUND).
Exceptions
KmcRuntimeException | (KMC_ED_FILEPATH).
KmcRuntimeException | (KMC_ED_DELETE_BUFFERED_FILE).
ErrorInfo imageReadFromFile ( ) throws KmcException, KmcRuntimeException

Reads a bitmap in from an image file of MimeType specified in this object.

This method updates the imageMimeType and imageRepresentation properties accordingly. The bitmap is read in from the file specified in the ImageFilePath property.
The optimized File I/O Engine is used except for PNG file reading.

Note
When reading PNG files, the resulted bitmap will be downscaled if the full-size bitmap does not fit in memory.
The aggressive scaling progression is used, starting with an 0.5 scaling factor on an out-of-memory condition, and halving it successively until the bitmap fits in memory.
If that automatic downscale occurs ErrorInfo.KMC_ED_IMAGE_IS_SCALED will be returned.

If scaling is desired and/or other than PNG image is read, use the overloaded imageReadFromFile(float imgBitmapScaling)
Returns
ErrorInfo: (KMC_SUCCESS), or (KMC_ED_IMAGE_IS_SCALED).
Exceptions
KmcException | (KMC_ED_FILEPATH).
KmcException | (KMC_GN_FILE_NOT_FOUND).
KmcException | (KMC_GN_OUT_OF_MEMORY).
KmcException | (KMC_EV_nnnnn)
See also
imageReadFromFile(float imgBitmapScaling)
ErrorInfo imageReadFromFile ( float imgBitmapScaling ) throws KmcException, KmcRuntimeException

Reads a bitmap in from an image file using the specified scaling factor.

This method reads the bitmap in from the file specified in the ImageFilePath property.
The optimized File I/O Engine is used except for PNG file reading.
This method updates the imageRepresentation property.

Parameters
imgBitmapScaling Specifies the factor used to scale the bitmap. Must be greater than 0.1 and less than or equal to 1.0.
For example, to scale the image by half, specify a value of 0.5. For no scaling, specify a value of 1.0.
Returns
ErrorInfo: (KMC_SUCCESS).
Exceptions
KmcException | (KMC_ED_FILEPATH).
KmcException | (KMC_GN_FILE_NOT_FOUND).
KmcException | (KMC_GN_OUT_OF_MEMORY).
KmcException | (KMC_EV_nnnnn).
KmcException | (KMC_ED_IMAGELEAK).
KmcException | (KMC_ED_ALREADY_BUFFERED).
KmcRuntimeException | (KMC_ED_IMAGE_INVALID_SCALING_FACTOR).

When bitmap scaling is not an option, an alternative is to specify a larger heap size in the application Manifest using the android:largeHeap attribute as shown below:

<application
    android:allowBackup="true"
    android:largeHeap="true"
    android:icon="@drawable/ic_launcher"
    android:name="com.kofax.kmc.kut.utilities.AppContextProvider"
    android:label="@string/app_name"
    android:theme="@style/AppTheme">
    <activity
        android:name="com.example.enginestest.MainActivity"
        android:label="@string/app_name">
        <intent-filter>
            <action android:name="android.intent.action.MAIN"/>
            <category android:name="android.intent.category.LAUNCHER"/>
        </intent-filter>
    </activity>
</application>

Applications should use this option only as a last resort, since enabling large heap size does not guarantee a fixed increase in available memory, because some devices are constrained by their total available memory. It's preferable instead to focus on reducing overall memory usage for improved performance.

ErrorInfo imageReadFromFileBuffer ( ) throws KmcException, KmcRuntimeException

Creates a bitmap from the image file buffer contained in this Image.

The bitmap is created from the file buffer created by a previous call to imageWriteToFileBuffer. This method decompresses the image file buffer into the imageBitmap. After the application calls imageReadFromFileBuffer, the image object will have imageRepresentation=BOTH and imageFileRepresentation=BUFFER.
The optimized File I/O Engine is used except for PNG file reading.

Note
If scaling is desired use the overloaded imageReadFromFileBuffer(float imgBitmapScaling)
Returns
ErrorInfo: (KMC_SUCCESS).
Exceptions
KmcException | (KMC_ED_IMAGELEAK).
KmcException | (KMC_GN_OUT_OF_MEMORY).
KmcRuntimeException | (KMC_ED_NO_BUFFERED_IMAGE).
KmcRuntimeException | (KMC_EV_nnnnn).
See also
getImageFileBuffer
imageReadFromFileBuffer(float imgBitmapScaling)
ErrorInfo imageReadFromFileBuffer ( float imgBitmapScaling ) throws KmcException, KmcRuntimeException

Creates a bitmap from the image file buffer contained in this Image.

The bitmap is created from the file buffer created by a previous call to imageWriteToFileBuffer. This method decompresses the image file buffer into the imageBitmap. After the application calls imageReadFromFileBuffer, the image object will have imageRepresentation=BOTH and imageFileRepresentation=BUFFER.
The optimized File I/O Engine is used except for PNG file reading.

Parameters
imgBitmapScaling Specifies the factor used to scale the bitmap. Must be greater than 0.1 and less than or equal to 1.0.
For example, to scale the image by half, specify a value of 0.5. For no scaling, specify a value of 1.0.
Returns
ErrorInfo: (KMC_SUCCESS).
Exceptions
KmcException | (KMC_ED_IMAGELEAK).
KmcException | (KMC_GN_OUT_OF_MEMORY).
KmcRuntimeException | (KMC_ED_NO_BUFFERED_IMAGE).
KmcRuntimeException | (KMC_EV_nnnnn).
KmcRuntimeException | (KMC_ED_IMAGE_INVALID_SCALING_FACTOR).
See also
getImageFileBuffer
ErrorInfo imageWriteToFile ( ) throws KmcException, KmcRuntimeException

Writes the bitmap in the imageBitmap property to the file specified in ImageFilePath property.

This method uses the File I/O Engine defined by the FileIOEngine property for writing the bitmap. If the FileIOEngine property is not set, this method uses the default Image Processor File I/O Engine for writing the bitmap.

The imageWriteToFile and imageWriteToFileBuffer methods ("the imageWrite methods") store five EXIF (Exchangeable Image File) tags for date and time into the output image file or buffer metadata (JPEG and TIFF only):

  • DateTime (code 0x132)
  • DateTimeDigitized (code 0x9004)

  • DateTimeOriginal (code 0x9003)

    The following tags are added if available in the Image instance:

  • Location (latitude and longitude)

  • Target frame (centerX, centerY, width, height)

    If the imageReadFromFile() method has been used with this Image object, the imageWrite methods write any mentioned JPEG or TIFF metadata from the read image file "as is" into the output file or buffer metadata.

Otherwise, the imageWrite methods write internally generated EXIF date/time metadata into the new JPEG or TIFF file or buffer as follows (all times adjusted to GMT):

The EXIF tag DateTime is generated based on the date and time the image object was created.

EXIF tags DateTimeOriginal and DateTimeDigitized are normally generated the same way as the EXIF tag DateTime, but there is a difference when the given image was created as a result of image processing. In such cases, the imageWrite methods generate the DateTimeOriginal value based on the date/time of the image that was input to image processing. The input image date/time is normally the date/time that image object was created, but could also be derived from JPEG or TIFF image file metadata if the imageReadFromFile() method was used with that image object.

The date/time strings are formatted as yyyy:MM:dd HH:mm:ss, as required by the EXIF standard. This format does not accommodate time zones, so the imageWrite methods use the UTC time that the Image object was created, with the time shifted to compensate for the time zone offset.

However, when the imageReadFromFile() method has been used with the Image object, the JPEG or TIFF date/time stamp from the original image file metadata is carried "as is" into the output compressed data stream.

Note: Date/time/location/target frame metadata output is supported only with the default Image Processor File I/O Engine.

Returns
ErrorInfo: (KMC_SUCCESS), or (KMC_ED_ALTERNATE_FILEIO_ENGINE).
Exceptions
KmcException | (KMC_GN_FILE_NOT_FOUND).
KmcException | (KMC_ED_FILE_EXISTS).
KmcRuntimeException | (KMC_ED_FILEPATH).
KmcRuntimeException | (KMC_ED_NOIMAGE).
KmcRuntimeException | (KMC_ED_MIMETYPE).
KmcRuntimeException | (KMC_ED_BITMAP_WRITE_TO_FILE_FAILED).
ErrorInfo imageWriteToFile ( FileIOEngine engine ) throws KmcException, KmcRuntimeException

Writes the bitmap in the imageBitmap property to the file specified in ImageFilePath property.

This method uses the FileIOEngine passed in as a parameter for writing the bitmap.

The imageWriteToFile and imageWriteToFileBuffer methods ("the imageWrite methods") store five EXIF (Exchangeable Image File) tags for date and time into the output image file or buffer metadata (JPEG and TIFF only):

  • DateTime (code 0x132)
  • DateTimeDigitized (code 0x9004)

  • DateTimeOriginal (code 0x9003)

    The following tags are added if available in the Image instance:

  • Location (latitude and longitude)

  • Target frame (centerX, centerY, width, height)

    If the imageReadFromFile() method has been used with this Image object, the imageWrite methods write any mentioned JPEG or TIFF date and time stamps, location and target frame from the read image file "as is" into the output file or buffer metadata.

Otherwise, the imageWrite methods write internally generated EXIF date/time metadata into the new JPEG or TIFF file or buffer as follows (all times adjusted to GMT):

The EXIF tag DateTime is generated based on the date and time the image object was created.

EXIF tags DateTimeOriginal and DateTimeDigitized are normally generated the same way as the EXIF tag DateTime, but there is a difference when the given image was created as a result of image processing. In such cases, the imageWrite methods generate the DateTimeOriginal value based on the date/time of the image that was input to image processing. The input image date/time is normally the date/time that image object was created, but could also be derived from JPEG or TIFF image file metadata if the imageReadFromFile() method was used with that image object.

The date/time strings are formatted as yyyy:MM:dd HH:mm:ss, as required by the EXIF standard. This format does not accommodate time zones, so the the imageWrite methods use the UTC time that the Image object was created, with the time shifted to compensate for the time zone offset.

However, when the imageReadFromFile() method has been used with the Image object, the JPEG or TIFF date/time stamp from the original image file metadata is carried "as is" into the output compressed data stream.

Note: Date/time/location and target frame metadata output is supported only when FileIOEngine.FILE_ENG_KFIL is specified.

Parameters
engine The FileIOEngine used for writing the bitmap within this image object.
Returns
ErrorInfo: (KMC_SUCCESS), or (KMC_ED_ALTERNATE_FILEIO_ENGINE).
Exceptions
KmcException | (KMC_GN_FILE_NOT_FOUND).
KmcException | (KMC_ED_FILE_EXISTS).
KmcRuntimeException | (KMC_ED_FILEPATH).
KmcRuntimeException | (KMC_ED_NOIMAGE).
KmcRuntimeException | (KMC_ED_MIMETYPE).
KmcRuntimeException | (KMC_ED_BUFFER_EXISTS).
KmcRuntimeException | (KMC_ED_BITMAP_WRITE_TO_FILE_FAILED).
ErrorInfo imageWriteToFile ( FileRestriction fileRestriction ) throws KmcException, KmcRuntimeException

Writes the bitmap in the imageBitmap property to the file specified in ImageFilePath property.

This method uses the FILE_ENG_KFIL engine for writing the bitmap.

When the fileRestriction parameter is specified as ANSI_X9, the imageWriteToFile and imageWriteToFileBuffer methods ("the imageWrite methods") behave as follows: The methods store no EXIF (Exchangeable Image File) tags, and no GPS location information. The methods return errors if the image's Mime Type or Output Color or DPI is not compatible with ANSI X9-181 standards. These methods store the Image object creation date and time in the TIFF DateTime field (tag code 0x132).

When the fileRestriction parameter is specified as NONE, output file restrictions are not applied. The behavior is as follows:

The imageWriteToFile and imageWriteToFileBuffer methods ("the imageWrite methods") store five EXIF (Exchangeable Image File) tags for date and time into the output image file or buffer metadata (JPEG and TIFF only):

  • DateTime (code 0x132)
  • DateTimeDigitized (code 0x9004)
  • DateTimeOriginal (code 0x9003)

The following tags are added if available in the Image instance:

  • Location (latitude and longitude)
  • Target frame (centerX, centerY, width, height)

If the imageReadFromFile() method has been used with this Image object, the imageWrite methods write any mentioned JPEG or TIFF date and time stamps, location data and target frame from the read image file "as is" into the output file or buffer metadata.

Otherwise, the imageWrite methods write internally generated EXIF metadata into the new JPEG or TIFF file or buffer as follows (all times adjusted to GMT):

The EXIF tag DateTime is generated based on the date and time the image object was created.

EXIF tags DateTimeOriginal and DateTimeDigitized are normally generated the same way as the EXIF tag DateTime, but there is a difference when the given image was created as a result of image processing. In such cases, the imageWrite methods generate the DateTimeOriginal value based on the date/time of the image that was input to image processing. The input image date/time is normally the date/time that image object was created, but could also be derived from JPEG or TIFF image file metadata if the imageReadFromFile() method was used with that image object.

The date/time strings are formatted as yyyy:MM:dd HH:mm:ss, as required by the EXIF standard. This format does not accommodate time zones, so the the imageWrite methods use the UTC time that the Image object was created, with the time shifted to compensate for the time zone offset.

However, when the imageReadFromFile() method has been used with the Image object, the JPEG or TIFF date/time stamp from the original image file metadata is carried "as is" into the output compressed data stream.

Parameters
fileRestriction The FileRestriction used for writing the file.
Returns
ErrorInfo: (KMC_SUCCESS), or (KMC_ED_ALTERNATE_FILEIO_ENGINE).
Exceptions
KmcException | (KMC_GN_FILE_NOT_FOUND).
KmcException | (KMC_ED_FILE_EXISTS).
KmcRuntimeException | (KMC_ED_FILEPATH).
KmcRuntimeException | (KMC_ED_NOIMAGE).
KmcRuntimeException | (KMC_ED_MIMETYPE).
KmcRuntimeException | (KMC_ED_BUFFER_EXISTS).
KmcRuntimeException | (KMC_ED_BITMAP_WRITE_TO_FILE_FAILED).
KmcRuntimeException | (KMC_ED_FILE_RESTRICTION_MIMETYPE).
KmcRuntimeException | (KMC_ED_FILE_RESTRICTION_BITDEPTH).
KmcRuntimeException | (KMC_ED_FILE_RESTRICTION_DPI).
ErrorInfo imageWriteToFileBuffer ( ) throws KmcException, KmcRuntimeException

Writes the bitmap in the imageBitmap property to the internal imageFileBuffer.

Writes the imageBitmap to a formatted buffer consisting of the compressed data codes and any header information required to represent the image. This method uses the imageMimeType property to specify the type of compressed data codes and header to use in the file buffer. After the application calls imageWriteToFileBuffer, the image object will have imageRepresentation=BOTH and imageFileRepresentation=BUFFER. The internal imageFileBuffer can be accessed by calling getImageFileBuffer.

The imageWriteToFile and imageWriteToFileBuffer methods ("the imageWrite methods") store five EXIF (Exchangeable Image File) tags for date and time into the output image file or buffer metadata (JPEG and TIFF only):

  • DateTime (code 0x132)
  • DateTimeDigitized (code 0x9004)

  • DateTimeOriginal (code 0x9003)

    The following tags are added if available in the Image instance:

  • Location (latitude and longitude)
  • Target frame (centerX, centerY, width, height)

If the imageReadFromFile() method has been used with this Image object, the imageWrite methods write any mentioned JPEG or TIFF metadata from the read image file "as is" into the output file or buffer metadata.

Otherwise, the imageWrite methods write internally generated EXIF metadata into the new JPEG or TIFF file or buffer as follows (all times adjusted to GMT):

The EXIF tag DateTime is generated based on the date and time the image object was created.

EXIF tags DateTimeOriginal and DateTimeDigitized are normally generated the same way as the EXIF tag DateTime, but there is a difference when the given image was created as a result of image processing. In such cases, the imageWrite methods generate the DateTimeOriginal value based on the date/time of the image that was input to image processing. The input image date/time is normally the date/time that image object was created, but could also be derived from JPEG or TIFF image file metadata if the imageReadFromFile() method was used with that image object.

The date/time strings are formatted as yyyy:MM:dd HH:mm:ss, as required by the EXIF standard. This format does not accommodate time zones, so the imageWrite methods use the UTC time that the Image object was created, with the time shifted to compensate for the time zone offset.

However, when the imageReadFromFile() method has been used with the Image object, the JPEG or TIFF date/time stamp data from the original image file metadata is carried "as is" into the output compressed data stream.

Returns
ErrorInfo: (KMC_SUCCESS), or (KMC_ED_ALTERNATE_FILEIO_ENGINE).
Exceptions
KmcRuntimeException | (KMC_ED_NOIMAGE).
KmcRuntimeException | (KMC_ED_OBJECT_REP_NO_BITMAP).
KmcRuntimeException | (KMC_ED_MIMETYPE).
KmcRuntimeException | (KMC_ED_ALREADY_BUFFERED).
KmcRuntimeException | (KMC_ED_OBJECT_REP_FILE_MISMATCH).
KmcRuntimeException | (KMC_ED_NO_MEMORY_FOR_BUFFERED_FILE).
See also
Image::getImageFileBuffer
ErrorInfo imageWriteToFileBuffer ( FileIOEngine engine ) throws KmcException, KmcRuntimeException

Writes the bitmap in the imageBitmap property to the internal imageFileBuffer.

Writes the imageBitmap to a formatted buffer consisting of the compressed data codes and any header information required to represent the image. This method uses the imageMimeType property to specify the type of compressed data codes and header to use in the file buffer. After the application calls imageWriteToFileBuffer, the image object will have imageRepresentation=BOTH and imageFileRepresentation=BUFFER. The internal imageFileBuffer can be accessed by calling getImageFileBuffer.

The imageWriteToFile and imageWriteToFileBuffer methods ("the imageWrite methods") store five EXIF (Exchangeable Image File) tags for date and time into the output image file or buffer metadata (JPEG and TIFF only):

  • DateTime (code 0x132)
  • DateTimeDigitized (code 0x9004)

  • DateTimeOriginal (code 0x9003)

    The following tags are added if available in the Image instance:

    • Location (latitude and longitude)
    • Target frame (centerX, centerY, width, height)

If the imageReadFromFile() method has been used with this Image object, the imageWrite methods write any mentioned JPEG or TIFF metadata from the read image file "as is" into the output file or buffer metadata.

Otherwise, the imageWrite methods write internally generated EXIF metadata into the new JPEG or TIFF file or buffer as follows (all times adjusted to GMT):

The EXIF tag DateTime is generated based on the date and time the image object was created.

EXIF tags DateTimeOriginal and DateTimeDigitized are normally generated the same way as the EXIF tag DateTime, but there is a difference when the given image was created as a result of image processing. In such cases, the imageWrite methods generate the DateTimeOriginal value based on the date/time of the image that was input to image processing. The input image date/time is normally the date/time that image object was created, but could also be derived from JPEG or TIFF image file metadata if the imageReadFromFile() method was used with that image object.

The date/time strings are formatted as yyyy:MM:dd HH:mm:ss, as required by the EXIF standard. This format does not accommodate time zones, so the the imageWrite methods use the UTC time that the Image object was created, with the time shifted to compensate for the time zone offset.

However, when the imageReadFromFile() method has been used with the Image object, the JPEG or TIFF date/time stamp from the original image file metadata is carried "as is" into the output compressed data stream.

Note: Date/time/location and target frame metadata output is supported only when FileIOEngine.FILE_ENG_KFIL is specified.

Parameters
engine The FileIOEngine used for writing the bitmap within this image object.
Returns
ErrorInfo: (KMC_SUCCESS), or (KMC_ED_ALTERNATE_FILEIO_ENGINE).
Exceptions
KmcRuntimeException | (KMC_ED_NOIMAGE).
KmcRuntimeException | (KMC_ED_OBJECT_REP_NO_BITMAP).
KmcRuntimeException | (KMC_ED_MIMETYPE).
KmcRuntimeException | (KMC_ED_ALREADY_BUFFERED).
KmcRuntimeException | (KMC_ED_OBJECT_REP_FILE_MISMATCH).
KmcRuntimeException | (KMC_ED_NO_MEMORY_FOR_BUFFERED_FILE).
See also
Image::getImageFileBuffer
ErrorInfo imageWriteToFileBuffer ( FileRestriction fileRestriction ) throws KmcException, KmcRuntimeException

Writes the bitmap in the imageBitmap property to the internal imageFileBuffer.

Writes the imageBitmap to a formatted buffer consisting of the compressed data codes and any header information required to represent the image. This method uses the imageMimeType property to specify the type of compressed data codes and header to use in the file buffer. After the application calls imageWriteToFileBuffer, the image object will have imageRepresentation=BOTH and imageFileRepresentation=BUFFER. The internal imageFileBuffer can be accessed by calling getImageFileBuffer.

This method uses the FILE_ENG_KFIL engine for writing the bitmap.

When the fileRestriction parameter is specified as ANSI_X9, the imageWriteToFile and imageWriteToFileBuffer methods ("the imageWrite methods") behave as follows: The methods store no EXIF (Exchangeable Image File) tags, and no GPS location information. The methods return errors if the image's Mime Type or Output Color or DPI is not compatible with ANSI X9-181 standards.

When the fileRestriction parameter is specified as NONE, the behavior is as follows:

The imageWriteToFile and imageWriteToFileBuffer methods ("the imageWrite methods") store five EXIF (Exchangeable Image File) tags for date and time into the output image file or buffer metadata (JPEG and TIFF only):

  • DateTime (code 0x132)
  • DateTimeDigitized (code 0x9004)
  • DateTimeOriginal (code 0x9003)

The following tags are added if available in the Image instance:

  • Location (latitude and longitude)
  • Target frame (centerX, centerY, width, height)

If the imageReadFromFile() method has been used with this Image object, the imageWrite methods write any mentioned JPEG or TIFF from the read image file "as is" into the output file or buffer metadata.

Otherwise, the imageWrite methods write internally generated EXIF metadata into the new JPEG or TIFF file or buffer as follows (all times adjusted to GMT):

The EXIF tag DateTime is generated based on the date and time the image object was created.

EXIF tags DateTimeOriginal and DateTimeDigitized are normally generated the same way as the EXIF tag DateTime, but there is a difference when the given image was created as a result of image processing. In such cases, the imageWrite methods generate the DateTimeOriginal value based on the date/time of the image that was input to image processing. The input image date/time is normally the date/time that image object was created, but could also be derived from JPEG or TIFF image file metadata if the imageReadFromFile() method was used with that image object.

The date/time strings are formatted as yyyy:MM:dd HH:mm:ss, as required by the EXIF standard. This format does not accommodate time zones, so the the imageWrite methods use the UTC time that the Image object was created, with the time shifted to compensate for the time zone offset.

However, when the imageReadFromFile() method has been used with the Image object, the JPEG or TIFF date/time stamp from the original image file metadata is carried "as is" into the output compressed data stream.

Parameters
fileRestriction The FileRestriction used for writing the file buffer.
Returns
ErrorInfo: (KMC_SUCCESS), or (KMC_ED_ALTERNATE_FILEIO_ENGINE).
Exceptions
KmcRuntimeException | (KMC_ED_NOIMAGE).
KmcRuntimeException | (KMC_ED_OBJECT_REP_NO_BITMAP).
KmcRuntimeException | (KMC_ED_MIMETYPE).
KmcRuntimeException | (KMC_ED_ALREADY_BUFFERED).
KmcRuntimeException | (KMC_ED_OBJECT_REP_FILE_MISMATCH).
KmcRuntimeException | (KMC_ED_NO_MEMORY_FOR_BUFFERED_FILE).
KmcRuntimeException | (KMC_ED_FILE_RESTRICTION_MIMETYPE).
KmcRuntimeException | (KMC_ED_FILE_RESTRICTION_BITDEPTH).
KmcRuntimeException | (KMC_ED_FILE_RESTRICTION_DPI).
See also
Image::getImageFileBuffer
void setImageBarCodes ( List< BarCodeResult > imageBarCodes )

Sets an array of BarCodeResult objects representing bar codes found on this image.

void setImageBitmap ( Bitmap imgBitmap ) throws KmcRuntimeException

Set the Bitmap representation of this Image object.

If the Image object already has a reference to an Image file, the reference is removed, but the associated Image file is left alone and orphaned. Use the imageDeleteFile() method to explicitly delete a referenced Image file. You must first call the imageDeleteFile() before setting a new bitmap, if the current Image Representation is either IMAGE_REP_FILE, or IMAGE_REP_BOTH. Failure to do so will generate a KmcRuntimeException.

Parameters
imgBitmap Must be set to a valid Android Bitmap object.
Exceptions
KmcRuntimeException (KMC_ED_OBJECT_REP_FILE_MISMATCH).
void setImageClassifyResults ( List< ImageClassificationResult > imgClassifyResults )

Sets an array of ImageClassificationResult objects representing the result of classifying this image.

This property will be filled in by the Classifier Engine when returning a classified Image object.

void setImageCreateDateTime ( String imgCreateDateTime )

Sets the date and time the image was created, in ISO 8601 format.

Example of how to convert a Java Date object to ISO 8601 formatted string:

String imgCreateDateTime = DateFormatUtils.ISO_8601_EXTENDED_DATETIME_TIME_ZONE_FORMAT.format(new Date());
Exceptions
KmcRuntimeException (KMC_ED_INVALID_ISO_DATE_TIME_FORMAT).
void setImageDPI ( int imgDPI )

Set the resolution of this image in Dots Per Inch.

The ImageDPI property will be set by the Image Processor Engine, to represent the output DPI of a processed image. The DPI may also be set on a call to imageReadFromFile() method, if it can be determined based on the image file header. If the DPI is not known or never set, the imageDPI property defaults to null. If the imageWriteToFile() is called, a default value of 72 DPI will be used when writing an in-memory bitmap to an image file, if none is specified.

Parameters
imgDPI The Dots Per Inch resolution of the image represented by this image object. The minimum imgDPI value allowed is 25. Setting a value less than 25 will result in an KmcRuntimeException being thrown.
Exceptions
KmcRuntimeException (KMC_ED_INVALID_DPI) if imgDPI < MIN_DPI_VALUE.
void setImageFilePath ( String imgFilePath ) throws KmcRuntimeException

Set the path to an image file which this Image object will represent.

This image file must be one of the MimeTypes included in the ImageMimeType enumeration. If the image file exists, and the Image object already has a Bitmap allocated, a KmcRuntimeException is thrown. To avoid this, call imageClearBitmap() method first. Only image files that are stored locally on the file system of the mobile device are supported. Image file paths which include a web address are not supported.

Parameters
imgFilePath A file path representing an image file in the local file system of the mobile device.
Exceptions
NullPointerException | (imgFilePath parameter is null).
KmcRuntimeException | (KMC_ED_UNRECOGNIZED_MIME_TYPE).
KmcRuntimeException | (KMC_ED_OBJECT_REP_FILE_MISMATCH).
void setImageJpegQuality ( int imgJpegQuality )

Set the JPEG image quality for JPEG image files.

Parameters
imgJpegQuality Represents a JPEG compression quality value, where lower numbers indicate higher compression (smaller size), but lower image quality. Higher JPEG quality numbers indicate lower compression (larger size), but better image quality. Valid quality values are 1 to 100.

Note: Compression values less than 80 are not recommended for images that are intended for further image processing.

void setImageMimeType ( ImageMimeType imgMimeType )

Set the MIME type of this Image object, if an image file representation exists.

void setImageOutputColor ( OutputColor imgOutputColor )

Set the bits per pixel of the image file representation of this Image object.

The in-memory Bitmap image representation may be different from the image file representation. For example, the in-memory Bitmap may be 4 bytes per pixel (ARGB_8888), but actual pixel colors used may be only 0x00000000 and 0xFFFFFFFF. This Bitmap can be written out to an image file as a 1 bit-per-pixel packed encoding format. The MIME type for the image file must support the bits-per-pixel value specified.

void setImageTag ( String imgTag )

Sets the application-defined tag for this Image object.

An application could use the ImageTag to distinguish a photo from a picture of a document.

void setMicrData ( String micrData ) throws NullPointerException

Set the MICR data of the check image.

Exceptions
NullPointerException (micrData parameter is null)
void setTargetFrame ( Rect targetFrame )

Set target frame data cropping purposes.

See also
getTargetFrame()

Default value is null.

Member Data Documentation

final int DEFAULT_JPEG_QUALITY = 90
static
final int MAX_JPEG_QUALITY = 100
static
final float MAX_SCALING_FACTOR = 1.0f
static
final int MIN_DPI_VALUE = 25
static
final int MIN_JPEG_QUALITY = 1
static
final float MIN_SCALING_FACTOR = 0.1f
static
The documentation for this class was generated from the following file:
  • Image.java


Kofax Mobile SDK API Reference: Image.FileIOEngine Enum Reference

  • kmc
  • ken
  • engines
  • data
  • Image
  • FileIOEngine
Public Attributes | List of all members
Image.FileIOEngine Enum Reference

An enum which optionally identifies the desired File I/O Engine used for reading and writing. More...

Public Attributes

FILE_ENG_KFIL
FILE_ENG_ANDROID

Detailed Description

An enum which optionally identifies the desired File I/O Engine used for reading and writing.

There are two different File I/O Engines supported by the Image Class:

  • Standard Android native File I/O using Android native classes.
  • Proprietary, optimized File I/O which supports JPEG, PNG, and TIFF file formats.

Note: The optimized File I/O Engine supports PNG file writing, but not PNG file reading. The default File I/O Engine used is the optimized File I/O.

Member Data Documentation

FILE_ENG_ANDROID
FILE_ENG_KFIL
The documentation for this enum was generated from the following file:
  • Image.java


Kofax Mobile SDK API Reference: Image.FileRestriction Enum Reference

  • kmc
  • ken
  • engines
  • data
  • Image
  • FileRestriction
Public Attributes | List of all members
Image.FileRestriction Enum Reference

An enum which specifies that ANSI X9.100-181 restrictions are needed for TIFF output. More...

Public Attributes

NONE
ANSI_X9

Detailed Description

An enum which specifies that ANSI X9.100-181 restrictions are needed for TIFF output.

Use this enum with imageWriteToFile or imageWriteToFileBuffer.

  • NONE specifies restrictions are not to be used
  • ANSI_X9 specifies that ANSI X9.100-181 restrictions are needed for TIFF output

Member Data Documentation

ANSI_X9
NONE
The documentation for this enum was generated from the following file:
  • Image.java


Kofax Mobile SDK API Reference: Image.ImageFileRep Enum Reference

  • kmc
  • ken
  • engines
  • data
  • Image
  • ImageFileRep
Public Attributes | List of all members
Image.ImageFileRep Enum Reference

An enum which identifies the File Representation of the image file referenced by this Image Object. More...

Public Attributes

FILE_NONE
FILE_STORED
FILE_BUFFERED

Detailed Description

An enum which identifies the File Representation of the image file referenced by this Image Object.

Member Data Documentation

FILE_BUFFERED
FILE_NONE
FILE_STORED
The documentation for this enum was generated from the following file:
  • Image.java


Kofax Mobile SDK API Reference: Image.ImageMimeType Enum Reference

  • kmc
  • ken
  • engines
  • data
  • Image
  • ImageMimeType
Public Attributes | List of all members
Image.ImageMimeType Enum Reference

An enum which identifies the Mime Type of the image file referenced by this Image Object. More...

Public Attributes

MIMETYPE_JPEG
MIMETYPE_PNG
MIMETYPE_TIFF
MIMETYPE_UNKNOWN

Detailed Description

An enum which identifies the Mime Type of the image file referenced by this Image Object.

Member Data Documentation

MIMETYPE_JPEG
MIMETYPE_PNG
MIMETYPE_TIFF
MIMETYPE_UNKNOWN
The documentation for this enum was generated from the following file:
  • Image.java


Kofax Mobile SDK API Reference: Image.ImageRep Enum Reference

  • kmc
  • ken
  • engines
  • data
  • Image
  • ImageRep
Public Attributes | List of all members
Image.ImageRep Enum Reference

An enum which identifies the Image Representation(s) included in this Image Object. More...

Public Attributes

IMAGE_REP_NONE
IMAGE_REP_BITMAP
IMAGE_REP_FILE
IMAGE_REP_BOTH

Detailed Description

An enum which identifies the Image Representation(s) included in this Image Object.

This enumeration indicates how the Image object is represented. The Image object may contain a bitmap image, or be represented by an image in a file, or both. You end up with the representation set to both when you write the image to a file by name, or you read the image into the bitmap from a file name. The library manages this representation for you based on operations you perform on the Image object.

  • IMAGE_REP_NONE The image object has no image content.
  • IMAGE_REP_BITMAP The image object references a bitmap.
  • IMAGE_REP_FILE The image object references a file.
  • IMAGE_REP_BOTH The image object references both a bitmap and a file.

Member Data Documentation

IMAGE_REP_BITMAP
IMAGE_REP_BOTH
IMAGE_REP_FILE
IMAGE_REP_NONE
The documentation for this enum was generated from the following file:
  • Image.java


Kofax Mobile SDK API Reference: Image.OutputColor Enum Reference

  • kmc
  • ken
  • engines
  • data
  • Image
  • OutputColor
Public Member Functions | Public Attributes | List of all members
Image.OutputColor Enum Reference

An enum which identifies the output color desired for writing the bitmap to an image file. More...

Public Member Functions

OutputColor (int channels, int bitsPerChannel)
int | getChannels ()
int | getBitsPerChannel ()
int | getBitsPerPixel ()

Public Attributes

BITDEPTH_BITONAL =(1, 1)
BITDEPTH_GRAYSCALE =(1, 8)
BITDEPTH_COLOR =(3, 8)

Detailed Description

An enum which identifies the output color desired for writing the bitmap to an image file.

The supported output colors are: bitonal (black & white), grayscale, and color.

Constructor & Destructor Documentation

OutputColor | ( | int | channels,
 |  | int | bitsPerChannel
 | ) |  |

Member Function Documentation

int getBitsPerChannel ( )
int getBitsPerPixel ( )
int getChannels ( )

Member Data Documentation

BITDEPTH_BITONAL =(1, 1)
BITDEPTH_COLOR =(3, 8)
BITDEPTH_GRAYSCALE =(1, 8)
The documentation for this enum was generated from the following file:
  • Image.java


Kofax Mobile SDK API Reference: ImagePerfectionProfile Class Reference

  • kmc
  • ken
  • engines
  • data
  • ImagePerfectionProfile
Classes | Public Member Functions | List of all members
ImagePerfectionProfile Class Reference

The ImagePerfectionProfile object encapsulates advanced image processing settings. This object is serializable. More...

Inheritance diagram for ImagePerfectionProfile:

Classes

enum | UseDocumentDetectionBasedCrop
An enum used with the useDocumentDetectionBasedCrop property. More...
enum | UseMRZPassportDetection
An enum used with the useMRZPassportDetection property. More...
enum | UseTargetFrameCrop
An enum used with the useTargetFrameCrop property. More...

Public Member Functions

ImagePerfectionProfile ()
ImagePerfectionProfile clone ()
Performs a field-for-field copy of instances of this class. More...
String | getName ()
Gets the application-defined name for this ImagePerfectionProfile object. More...
void | setName (String name)
Sets the application-defined name for this ImagePerfectionProfile object. More...
String | getIpOperations ()
Gets the image processing operations string. More...
void | setIpOperations (String ipOperations)
Sets the image processing operations string. More...
String | getIpOperationsFilePath ()
Gets the image processing settings file. More...
void | setIpOperationsFilePath (String ipOperationsFilePath)
Sets the image processing settings file. More...
UseMRZPassportDetection getUseMRZPassportDetection ()
Gets the useMRZPassportDetection property. More...
void | setUseMRZPassportDetection (UseMRZPassportDetection useMRZPassportDetection)
Sets the useMRZPassportDetection property. More...
UseTargetFrameCrop getUseTargetFrameCrop ()
Gets the useTargetFrameCrop property. More...
void | setUseTargetFrameCrop (UseTargetFrameCrop useTargetFrameCrop)
Sets the useTargetFrameCrop property. More...
UseDocumentDetectionBasedCrop getUseDocumentDetectionBasedCrop ()
Gets the useDocumentDetectionBasedCrop property. More...
void | setUseDocumentDetectionBasedCrop (UseDocumentDetectionBasedCrop useDocumentDetectionBasedCrop)
Sets the useDocumentDetectionBasedCrop property. More...

Detailed Description

The ImagePerfectionProfile object encapsulates advanced image processing settings. This object is serializable.

Use this ImagePerfectionProfile object to specify advanced image processing settings to the ImageProcessor. These advanced image processing settings may have originated from a KFS Server, a TotalAgility Server or the application itself. The ImagePerfectionProfile allows for two ways of specifying those settings:

ImageProcessor operations string (ipOperations)
ImageProcessor operations XML file (ipOperationsFilePath)

If both ipOperations and ipOperationsFilePath are specified as non-blank, the ipOperations string is used and the other one is ignored.

ImagePerfectionProfile objects support serialization in a similar way to Image objects. The Image object documentation provides code examples for serialization and deserialization.

Deprecated:
Deprecated in SDK 3.3. Please use ImageProcessorConfiguration

Constructor & Destructor Documentation

ImagePerfectionProfile ( )

Member Function Documentation

ImagePerfectionProfile clone ( )

Performs a field-for-field copy of instances of this class.

String getIpOperations ( )

Gets the image processing operations string.

This specifies the image processing operations to be performed by the ImageProcessor. Please refer to the developers guide for a list of image processing operations tokens.

String getIpOperationsFilePath ( )

Gets the image processing settings file.

This specifies the file containing image processing operations to be performed by the ImageProcessor.

String getName ( )

Gets the application-defined name for this ImagePerfectionProfile object.

An application could use the name to describe the purpose of the image processing settings in this object.

UseDocumentDetectionBasedCrop getUseDocumentDetectionBasedCrop ( )

Gets the useDocumentDetectionBasedCrop property.

Use this property to enable or disable document detection based cropping using the UseDocumentDetectionBasedCrop enum. UseDocumentDetectionBasedCrop.OFF means to disable document detection based cropping (default value). UseDocumentDetectionBasedCrop.ON means to enable document detection based cropping.

UseMRZPassportDetection getUseMRZPassportDetection ( )

Gets the useMRZPassportDetection property.

Use this property to enable or disable MRZ passport detection using the UseMRZPassportDetection enum. UseMRZPassportDetection.OFF means to disable MRZ passport detection for cropping (default value). UseMRZPassportDetection.ON means to disable MRZ passport detection for cropping.

UseTargetFrameCrop getUseTargetFrameCrop ( )

Gets the useTargetFrameCrop property.

Use this property to enable or disable target frame cropping using the UseTargetFrameCrop enum. UseTargetFrameCrop.OFF means to disable target frame cropping (default value). UseTargetFrameCrop.ON means to enable target frame cropping.

void setIpOperations ( String ipOperations )

Sets the image processing operations string.

This specifies the image processing operations to be performed by the ImageProcessor. Please refer to the developers guide for a list of image processing operations tokens.

Exceptions
NullPointerException (ipOperations parameter is null).
void setIpOperationsFilePath ( String ipOperationsFilePath )

Sets the image processing settings file.

This specifies the file containing image processing operations to be performed by the ImageProcessor.

Exceptions
NullPointerException (ipOperationsFilePath parameter is null).
void setName ( String name )

Sets the application-defined name for this ImagePerfectionProfile object.

An application could use the name to describe the purpose of the image processing settings in this object.

Exceptions
NullPointerException (name parameter is null).
void setUseDocumentDetectionBasedCrop ( UseDocumentDetectionBasedCrop useDocumentDetectionBasedCrop )

Sets the useDocumentDetectionBasedCrop property.

Use this property to enable or disable document detection based cropping using the UseDocumentDetectionBasedCrop enum. UseDocumentDetectionBasedCrop.OFF means to disable document detection based cropping (default value). UseDocumentDetectionBasedCrop.ON means to enable document detection based cropping.

Exceptions
NullPointerException ('useDocumentDetectionBasedCrop' parameter is null).
void setUseMRZPassportDetection ( UseMRZPassportDetection useMRZPassportDetection )

Sets the useMRZPassportDetection property.

Use this property to enable or disable MRZ passport detection using the UseMRZPassportDetection enum. UseMRZPassportDetection.OFF means to disable MRZ passport detection for cropping (default value). UseMRZPassportDetection.ON means to disable MRZ passport detection for cropping.

Exceptions
NullPointerException ('useMRZPassportDetection' parameter is null).
void setUseTargetFrameCrop ( UseTargetFrameCrop useTargetFrameCrop )

Sets the useTargetFrameCrop property.

Use this property to enable or disable target frame cropping using the UseTargetFrameCrop enum. UseTargetFrameCrop.OFF means to disable target frame cropping (default value). UseTargetFrameCrop.ON means to enable target frame cropping.

Exceptions
NullPointerException ('useTargetFrameCrop' parameter is null).
The documentation for this class was generated from the following file:
  • ImagePerfectionProfile.java


Kofax Mobile SDK API Reference: ImagePerfectionProfile.UseDocumentDetectionBasedCrop Enum Reference

  • kmc
  • ken
  • engines
  • data
  • ImagePerfectionProfile
  • UseDocumentDetectionBasedCrop
Public Attributes | List of all members
ImagePerfectionProfile.UseDocumentDetectionBasedCrop Enum Reference

An enum used with the useDocumentDetectionBasedCrop property. More...

Public Attributes

OFF
ON

Detailed Description

An enum used with the useDocumentDetectionBasedCrop property.

Member Data Documentation

OFF
ON
The documentation for this enum was generated from the following file:
  • ImagePerfectionProfile.java


Kofax Mobile SDK API Reference: ImagePerfectionProfile.UseMRZPassportDetection Enum Reference

  • kmc
  • ken
  • engines
  • data
  • ImagePerfectionProfile
  • UseMRZPassportDetection
Public Attributes | List of all members
ImagePerfectionProfile.UseMRZPassportDetection Enum Reference

An enum used with the useMRZPassportDetection property. More...

Public Attributes

OFF
ON

Detailed Description

An enum used with the useMRZPassportDetection property.

Member Data Documentation

OFF
ON
The documentation for this enum was generated from the following file:
  • ImagePerfectionProfile.java


Kofax Mobile SDK API Reference: ImagePerfectionProfile.UseTargetFrameCrop Enum Reference

  • kmc
  • ken
  • engines
  • data
  • ImagePerfectionProfile
  • UseTargetFrameCrop
Public Attributes | List of all members
ImagePerfectionProfile.UseTargetFrameCrop Enum Reference

An enum used with the useTargetFrameCrop property. More...

Public Attributes

OFF
ON

Detailed Description

An enum used with the useTargetFrameCrop property.

Member Data Documentation

OFF
ON
The documentation for this enum was generated from the following file:
  • ImagePerfectionProfile.java


Kofax Mobile SDK API Reference: ImageSource Enum Reference

  • kmc
  • ken
  • engines
  • data
  • ImageSource
Public Attributes | List of all members
ImageSource Enum Reference

Public Attributes

IMAGE
PROCESSOR
CAPTURE

Member Data Documentation

CAPTURE
IMAGE
PROCESSOR
The documentation for this enum was generated from the following file:
  • ImageSource.java


Kofax Mobile SDK API Reference: OrientationGuidance Enum Reference

  • kmc
  • ken
  • engines
  • data
  • OrientationGuidance
Public Attributes | List of all members
OrientationGuidance Enum Reference

Public Attributes

ORIENTATION_CHANGE
ORIENTATION_OK

Detailed Description

Guidance for orientation change while capturing a document.

This enum indicates if the user should change the orientation of the device or the document, so the orientation of the document matches the orientation of the target frame.

Member Data Documentation

ORIENTATION_CHANGE

Change orientation

ORIENTATION_OK

Orientation change is not required

The documentation for this enum was generated from the following file:
  • OrientationGuidance.java


Kofax Mobile SDK API Reference: PassportDetectionResult Class Reference

  • kmc
  • ken
  • engines
  • data
  • PassportDetectionResult
Protected Member Functions | List of all members
PassportDetectionResult Class Referenceabstract
Inheritance diagram for PassportDetectionResult:
DetectionResult

Protected Member Functions

PassportDetectionResult (Rect targetRect, List< Point > corners, Frame frame)

Additional Inherited Members

- Public Member Functions inherited from DetectionResult
BoundingTetragon getBounds ()
Bitmap | getOriginalImage ()
abstract ZoomGuidance | getZoomGuidance ()
abstract TurnGuidance | getTurnGuidance ()
abstract HorizontalGuidance | getHorizontalMovementGuidance ()
abstract VerticalGuidance | getVerticalMovementGuidance ()
abstract OrientationGuidance | getOrientationGuidance ()
String | toString ()

Detailed Description

Result of passport detection.

This class returns the original image the detection algorithm was run against, the bounding coordinates of the detected document, and the guidance information, e.g. zoom out/in move left/right, etc...

Constructor & Destructor Documentation

PassportDetectionResult | ( | Rect | targetRect,
 |  | List< Point > | corners,
 |  | Frame | frame
 | ) |  |
protected
The documentation for this class was generated from the following file:
  • PassportDetectionResult.java


Kofax Mobile SDK API Reference: PassportDetectionSettings Class Reference

  • kmc
  • ken
  • engines
  • data
  • PassportDetectionSettings
Public Member Functions | List of all members
PassportDetectionSettings Class Reference
Inheritance diagram for PassportDetectionSettings:
DetectionSettings

Public Member Functions

PassportDetectionSettings ()
PassportDetectionSettings (PassportDetectionSettings detectionSettings)
double | getTargetFrameAspectRatio ()
Gets the aspect ratio of the rectangular frame that should match the passport being searched. More...
void | setTargetFrameAspectRatio (double targetFrameAspectRatio)
Sets the aspect ratio of the rectangular frame that should match the document being searched. More...
- Public Member Functions inherited from DetectionSettings
DetectionSettings (Point targetFrameCenter, double targetFrameAspectRatio, double targetFramePaddingPercent)
Constructor creates a document detection setting object that has specified values. More...
Point | getCenterPoint ()
Gets the center point within the image of the target frame. More...
void | setCenterPoint (Point targetFrameCenter)
Sets the center point within the image of the target frame. More...
double | getTargetFrameAspectRatio ()
Gets the aspect ratio of the rectangular frame that should match the document being searched. More...
void | setTargetFrameAspectRatio (double targetFrameAspectRatio)
Sets the aspect ratio of the rectangular frame that should match the document being searched. More...
double | getTargetFramePaddingPercent ()
Gets the minimum padding in percent length to be maintained between the edges of the target frame and image. More...
void | setTargetFramePaddingPercent (double paddingPercent)
Sets the minimum padding in percent length to be maintained between the edges of the target frame and image. More...
double | getMinFillFraction ()
Gets the minimum fill area as a fraction of the target frame. More...
void | setMinFillFraction (double minFillFraction)
Sets the minimum fill area as a fraction of the target frame. More...
double | getMaxFillFraction ()
Gets the maximum fill area as a fraction of the target frame. More...
void | setMaxFillFraction (double maxFillFraction)
Sets the maximum fill area as a fraction of the target frame. More...
double | getMaxSkewAngle ()
Gets the maximum angle the document can be rotated off from the target frame. More...
void | setMaxSkewAngle (double maxSkewAngle)
Sets the maximum angle the document can be rotated off from the target frame. More...
double | getToleranceFraction ()
Gets the maximum distance the document can be shifted from the target frame. More...
void | setToleranceFraction (double toleranceFraction)
Sets the maximum distance the document can be shifted from the target frame. More...

Additional Inherited Members

- Protected Member Functions inherited from DetectionSettings
DetectionSettings ()
Default constructor creates a detection setting object that has default values. More...
DetectionSettings (DetectionSettings settings)

Detailed Description

A configuration object for controlling the PassportDetector object.

Constructor & Destructor Documentation

PassportDetectionSettings ( )
PassportDetectionSettings ( PassportDetectionSettings detectionSettings )

Copy constructor. Creates a copy object for the document detection settings.

Parameters
detectionSettings the settings object to copy from

Member Function Documentation

double getTargetFrameAspectRatio ( )

Gets the aspect ratio of the rectangular frame that should match the passport being searched.

Returns
double
See also
setTargetFrameAspectRatio(double)
void setTargetFrameAspectRatio ( double targetFrameAspectRatio )

Sets the aspect ratio of the rectangular frame that should match the document being searched.

The aspect ratio should be in the format of longEdge/shortEdge (i.e. targetFrameAspectRatio >= 1). The long edge of the target frame is align with the long edge of the camera preview or image. If 0 < targetFrameAspectRatio < 1 it will be inverted. For example: the ratio 0.4 (or 2.0/5.0) will be inverted to 2.5 (5.0/2.0).

If the targetFrameAspectRatio is set to 0, then it will be automatically reset to an image aspect ratio.
Setting negative values has the same effect as if 0 was set.

The default value is 1.45.

Parameters
targetFrameAspectRatio : double
The documentation for this class was generated from the following file:
  • PassportDetectionSettings.java


Kofax Mobile SDK API Reference: QuickAnalysisFeedback Class Reference

  • kmc
  • ken
  • engines
  • data
  • QuickAnalysisFeedback
Public Member Functions | List of all members
QuickAnalysisFeedback Class Reference

The QuickAnalysisFeedback object contains the results of image quality checking using the doQuickAnalysis method of the ImageProcessor object. This object is serializable. More...

Inheritance diagram for QuickAnalysisFeedback:

Public Member Functions

QuickAnalysisFeedback ()
QuickAnalysisFeedback clone ()
Performs a field-for-field copy of instances of this class. More...
Bitmap | getViewBoundariesImage ()
Returns bitmap with tetragon boundaries drawn on the image. More...
boolean | isBlurry ()
Image may be blurry. More...
boolean | isGlareDetected ()
Image may have glare. More...
boolean | isOversaturated ()
Image may be overly lit image. More...
boolean | isUndersaturated ()
Image may be poorly lit image. More...
boolean | isOverlySkewed ()
Image may be overly skewed. More...
boolean | isShadowed ()
Image may have shadows. More...
boolean | isMissingBorders ()
Image may be missing borders. More...
boolean | isLowContrastBackground ()
Image may have uneven or low contrast background. More...
BoundingTetragon getTetragonCorners ()
Coordinates of the corners of the tetragon returned after quick analysis. More...

Detailed Description

The QuickAnalysisFeedback object contains the results of image quality checking using the doQuickAnalysis method of the ImageProcessor object. This object is serializable.

The QuickAnalysisFeedback object contains the results of image quality checking using the doQuickAnalysis method of the ImageProcessor object.

QuickAnalysisFeedback objects support serialization in a similar way to Image objects. The Image object documentation provides code examples for serialization and deserialization.

Constructor & Destructor Documentation

QuickAnalysisFeedback ( )

Member Function Documentation

QuickAnalysisFeedback clone ( )

Performs a field-for-field copy of instances of this class.

BoundingTetragon getTetragonCorners ( )

Coordinates of the corners of the tetragon returned after quick analysis.

Bitmap getViewBoundariesImage ( )

Returns bitmap with tetragon boundaries drawn on the image.

If second parameter of doQuickAnalysis() was set to true, up on callinggetViewBoundariesImage() will return a valid bitmap with green tetragon drawn over it.

Caller of this function is responsible to recycle the resultant bitmap to avoid OutOfMemoryError.

Example of how to recycle bitmap:

QuickAnalysisFeedback qafb = newImage.getImageQuickAnalysisFeedBack();
Bitmap bm = qafb.getViewBoundariesImage();
...
if (null != bm) {
bm.recycle();
}
boolean isBlurry ( )

Image may be blurry.

boolean isGlareDetected ( )

Image may have glare.

boolean isLowContrastBackground ( )

Image may have uneven or low contrast background.

Returns
true if the input image may have uneven or low contrast background (default false).
boolean isMissingBorders ( )

Image may be missing borders.

Returns
true if the input image may be missing borders (default false).
boolean isOverlySkewed ( )

Image may be overly skewed.

Returns
true if the input image may be overly skewed (default false).
boolean isOversaturated ( )

Image may be overly lit image.

The likely cause is that the flash is on, or an extremely bright light sits directly above the location where the image was taken. A dirty lens can also cause some of the same "washout"

Returns
true if the input image may be overly lit (default false).
boolean isShadowed ( )

Image may have shadows.

Returns
true if the input image may have shadows (default false).
boolean isUndersaturated ( )

Image may be poorly lit image.

The likely cause is that the image was taken in a dark room.

Returns
true if the input image may be poorly lit (default false).
The documentation for this class was generated from the following file:
  • QuickAnalysisFeedback.java


Kofax Mobile SDK API Reference: QuickAnalysisSettings Class Reference

  • kmc
  • ken
  • engines
  • data
  • QuickAnalysisSettings
Public Member Functions | List of all members
QuickAnalysisSettings Class Reference

A configuration object for controlling the quick analysis image processing. More...

Public Member Functions

QuickAnalysisSettings ()
Default constructor creates a quick analysis setting object that has default values. More...
boolean | getBlurDetection ()
Gets the status of blur detection. More...
void | setBlurDetection (boolean enabled)
Sets the status of blur detection. More...
boolean | getSaturationDetection ()
Gets the status of saturation detection. More...
void | setSaturationDetection (boolean enabled)
Sets the status of saturation detection. More...
boolean | getGlareDetection ()
Gets the status of glare detection. More...
void | setGlareDetection (boolean enabled)
Sets the status of glare detection. More...
double | getGlareDetectionIntensityFraction ()
Gets the value of intensity fraction in glare detection. More...
void | setGlareDetectionIntensityFraction (double fraction)
Sets the value of intensity fraction of glare detection. More...
double | getGlareDetectionMinimumGlareAreaFraction ()
Gets the value of minimum intensity glare area fraction in glare detection. More...
void | setGlareDetectionMinimumGlareAreaFraction (double fraction)
Sets the value of minimum glare area fraction of glare detection. More...
int | getGlareDetectionIntensityThreshold ()
Gets the value of intensity threshold in glare detection. More...
void | setGlareDetectionIntensityThreshold (int threshold)
Sets the value of intensity threshold fraction of glare detection. More...
int | getGlareDetectionNumberOfTiles ()
Gets the value of number of tiles in glare detection. More...
void | setGlareDetectionNumberOfTiles (int tiles)
Sets the value of number of tiles of glare detection. More...
double | getGlareDetectedThreshold ()
Gets the threshold for the area of the glare. More...
void | setGlareDetectedThreshold (double threshold)
Sets the threshold for the area of the glare. More...
int | getBlurThreshold ()
Gets the sensibility of the blur detection algorithm. More...
void | setBlurThreshold (int threshold)
Sets the sensibility of the blur detection algorithm. More...
int | getBlurCountPercentThreshold ()
Gets the threshold for blurry areas. More...
void | setBlurCountPercentThreshold (int threshold)
Sets the threshold for blurry areas. More...
boolean | getSkewDetection ()
Gets the status of skew detection in the quick analysis process. More...
void | setSkewDetection (boolean enabled)
Enable/disable skew detection in the quick analysis process. More...
boolean | getShadowDetection ()
Gets the status of shadow detection in the quick analysis process. More...
void | setShadowDetection (boolean enabled)
Enable/disable shadow detection in the quick analysis process. More...
boolean | getMissingBordersDetection ()
Gets the status of missing borders detection in the quick analysis process. More...
void | setMissingBordersDetection (boolean enabled)
Enable/disable missing borders detection in the quick analysis process. More...
boolean | getLowContrastBackgroundDetection ()
Gets the status of low contrast background detection in the quick analysis process. More...
void | setLowContrastBackgroundDetection (boolean enabled)
Enable/disable low contrast background detection in the quick analysis process. More...
UseMRZPassportDetection getUseMRZPassportDetection ()
Gets the status of MRZ passport detection. More...
void | setUseMRZPassportDetection (UseMRZPassportDetection useMRZPassportDetection)
Sets the value of MRZ passport detection. More...
UseTargetFrameCrop getUseTargetFrameCrop ()
Gets the value of target frame cropping. More...
void | setUseTargetFrameCrop (UseTargetFrameCrop useTargetFrameCrop)
Sets the value of target frame cropping. More...
UseDocumentDetectionBasedCrop getUseDocumentDetectionBasedCrop ()
Gets the value of document detection based cropping. More...
void | setUseDocumentDetectionBasedCrop (UseDocumentDetectionBasedCrop useDocumentDetectionBasedCrop)
Sets the value of document detection based cropping. More...

Detailed Description

A configuration object for controlling the quick analysis image processing.

The primary purpose of the settings object is to define properties for quick analysis image processing.

Constructor & Destructor Documentation

QuickAnalysisSettings ( )

Default constructor creates a quick analysis setting object that has default values.

Member Function Documentation

int getBlurCountPercentThreshold ( )

Gets the threshold for blurry areas.

An image is considered blurry when the amount of blurry areas exceeds this threshold.
The threshold should be specified as percentage of the image area.

Threshold values should be in the [0, 100] range, other values will be clamped to this range.
Defaults to 80.

Returns
the threshold for blurry areas
See also
getBlurThreshold()
boolean getBlurDetection ( )

Gets the status of blur detection.

Returns
boolean
See also
setBlurDetection(boolean)
int getBlurThreshold ( )

Gets the sensibility of the blur detection algorithm.

An image section is considered blurry when its blurriness exceeds this threshold.

Threshold values should be in the [0, 100] range, other values will be clamped to this range.
Defaults to 15.
Rising this threshold increases the number of sections marked as blurry.

Detected blurry sections are used in conjunction with blurCountPercentThreshold to calculate the percentage of blurry areas and decide if the whole image should be considered blurry.

Returns
the sensibility of the blur detection algorithm
See also
getBlurCountPercentThreshold()
double getGlareDetectedThreshold ( )

Gets the threshold for the area of the glare.

An image is considered to have a glare when the area of the glare exceeds this threshold.
The threshold should be specified as a fraction of the image area.

Threshold values should be in the [0.01, 0.99] range, other values will be clamped to this range.
Defaults to 0.05.

Returns
the threshold for the area of the glare
See also
setGlareDetectedThreshold(double)
boolean getGlareDetection ( )

Gets the status of glare detection.

Returns
boolean
See also
setGlareDetection(boolean)
double getGlareDetectionIntensityFraction ( )

Gets the value of intensity fraction in glare detection.

Return the intensity fraction value used in glare detection.

Returns
double
See also
setGlareDetectionIntensityFraction(double)
int getGlareDetectionIntensityThreshold ( )

Gets the value of intensity threshold in glare detection.

Return the intensity threshold value used in glare detection.

Returns
int
See also
setGlareDetectionIntensityThreshold(int)
double getGlareDetectionMinimumGlareAreaFraction ( )

Gets the value of minimum intensity glare area fraction in glare detection.

Return the minimum intensity glare area fraction value used in glare detection.

Returns
double
See also
setGlareDetectionMinimumGlareAreaFraction(double)
int getGlareDetectionNumberOfTiles ( )

Gets the value of number of tiles in glare detection.

Return the number of tiles value used in glare detection.

Returns
int
See also
setGlareDetectionNumberOfTiles(int)
boolean getLowContrastBackgroundDetection ( )

Gets the status of low contrast background detection in the quick analysis process.

Returns
boolean
See also
setLowContrastBackgroundDetection(boolean)
boolean getMissingBordersDetection ( )

Gets the status of missing borders detection in the quick analysis process.

Returns
boolean
See also
setMissingBordersDetection(boolean)
boolean getSaturationDetection ( )

Gets the status of saturation detection.

Returns
boolean
See also
setSaturationDetection(boolean)
boolean getShadowDetection ( )

Gets the status of shadow detection in the quick analysis process.

Returns
boolean
See also
setShadowDetection(boolean)
boolean getSkewDetection ( )

Gets the status of skew detection in the quick analysis process.

Returns
boolean
See also
setSkewDetection(boolean)
UseDocumentDetectionBasedCrop getUseDocumentDetectionBasedCrop ( )

Gets the value of document detection based cropping.

Returns
UseDocumentDetectionBasedCrop
See also
setUseDocumentDetectionBasedCrop(UseDocumentDetectionBasedCrop)
UseMRZPassportDetection getUseMRZPassportDetection ( )

Gets the status of MRZ passport detection.

Returns
UseMRZPassportDetection
See also
setSaturationDetection(boolean)
UseTargetFrameCrop getUseTargetFrameCrop ( )

Gets the value of target frame cropping.

Returns
UseTargetFrameCrop
See also
setUseTargetFrameCrop(UseTargetFrameCrop)
void setBlurCountPercentThreshold ( int threshold )

Sets the threshold for blurry areas.

An image is considered blurry when the amount of blurry areas exceeds this threshold.
The threshold should be specified as percentage of the image area.

Threshold values should be in the [0, 100] range, other values will be clamped to this range.
Defaults to 80.

Parameters
threshold the threshold for blurry areas
See also
setBlurThreshold(int)
void setBlurDetection ( boolean enabled )

Sets the status of blur detection.

This is to enable or disable blur detection in quick analysis The default value is true.

Parameters
enabled : boolean
void setBlurThreshold ( int threshold )

Sets the sensibility of the blur detection algorithm.

An image section is considered blurry when its blurriness exceeds this threshold.

Threshold values should be in the [0, 100] range, other values will be clamped to this range.
Defaults to 15.
Rising this threshold increases the number of sections marked as blurry.

Detected blurry sections are used in conjunction with blurCountPercentThreshold to calculate the percentage of blurry areas and decide if the whole image should be considered blurry.

Parameters
threshold the sensibility of the blur detection algorithm
See also
setBlurCountPercentThreshold(int)
void setGlareDetectedThreshold ( double threshold )

Sets the threshold for the area of the glare.

An image is considered to have a glare when the area of the glare exceeds this threshold.
The threshold should be specified as a fraction of the image area.

Threshold values should be in the [0.01, 0.99] range, other values will be clamped to this range.
Defaults to 0.02.

Parameters
threshold the threshold for the area of the glare
void setGlareDetection ( boolean enabled )

Sets the status of glare detection.

This is to enable or disable glare detection in quick analysis. The default value is true.

Parameters
enabled : boolean
void setGlareDetectionIntensityFraction ( double fraction )

Sets the value of intensity fraction of glare detection.

The fraction of pixels with the highest intensity that are assumed to be glare. Valid values: 0.01-0.99 The default value is 0.03d.

Parameters
fraction : double
void setGlareDetectionIntensityThreshold ( int threshold )

Sets the value of intensity threshold fraction of glare detection.

The absolute lower threshold for high intensity pixels. No pixel below this threshold is perceived as glare. Valid values: 0-255 The default value is 230.

Parameters
threshold : int
void setGlareDetectionMinimumGlareAreaFraction ( double fraction )

Sets the value of minimum glare area fraction of glare detection.

The minimum area of an image that needs to be affected by glare to be included in the glare area. Valid values: 0.01-0.99 The default value is 0.01d.

Parameters
fraction : double
void setGlareDetectionNumberOfTiles ( int tiles )

Sets the value of number of tiles of glare detection.

The number of tiles into which an edge of the image is divided for glare detection. Valid values: 1-1000 The default value is 100.

Parameters
tiles : int
void setLowContrastBackgroundDetection ( boolean enabled )

Enable/disable low contrast background detection in the quick analysis process.

When disabled, the QuickAnalysisFeedback will always return isLowContrastBackground as false. The default value is true (enabled).

Parameters
enabled : boolean
void setMissingBordersDetection ( boolean enabled )

Enable/disable missing borders detection in the quick analysis process.

When disabled, the QuickAnalysisFeedback will always return isMissingBorders as false. The default value is true (enabled).

Parameters
enabled : boolean
void setSaturationDetection ( boolean enabled )

Sets the status of saturation detection.

This is to enable or disable saturation detection in quick analysis The default value is true.

Parameters
enabled : boolean
void setShadowDetection ( boolean enabled )

Enable/disable shadow detection in the quick analysis process.

When disabled, the QuickAnalysisFeedback will always return isShadowed as false. The default value is true (enabled).

Parameters
enabled : boolean
void setSkewDetection ( boolean enabled )

Enable/disable skew detection in the quick analysis process.

When disabled, the QuickAnalysisFeedback will always return isOverlySkewed as false. The default value is true (enabled).

Parameters
enabled : boolean
void setUseDocumentDetectionBasedCrop ( UseDocumentDetectionBasedCrop useDocumentDetectionBasedCrop )

Sets the value of document detection based cropping.

Specify quick analysis to use document detection based cropping or not The default value is UseDocumentDetectionBasedCrop.OFF

Parameters
useDocumentDetectionBasedCrop : UseDocumentDetectionBasedCrop
void setUseMRZPassportDetection ( UseMRZPassportDetection useMRZPassportDetection )

Sets the value of MRZ passport detection.

Specify quick analysis to use MRZ passport detection for cropping process or not The default value is UseMRZPassportDetection.OFF

Parameters
useMRZPassportDetection : UseMRZPassportDetection
void setUseTargetFrameCrop ( UseTargetFrameCrop useTargetFrameCrop )

Sets the value of target frame cropping.

Specify quick analysis to use target frame cropping or not The default value is UseTargetFrameCrop.OFF

Parameters
useTargetFrameCrop : UseTargetFrameCrop
The documentation for this class was generated from the following file:
  • QuickAnalysisSettings.java


Kofax Mobile SDK API Reference: SelfieDetectionSettings Class Reference

  • kmc
  • ken
  • engines
  • data
  • SelfieDetectionSettings
Public Member Functions | List of all members
SelfieDetectionSettings Class Reference

Public Member Functions

SelfieDetectionSettings ()
Constructor creates a selfie detection setting object with predefined values. More...
SelfieDetectionSettings (SelfieDetectionSettings settings)
Constructor creates a selfie detection setting object that has specified values. More...
void | setMinimumFaceSize (double minimumFaceSize)
double | getMinimumFaceSize ()
Point | getCenterPoint ()
void | setCenterPoint (Point targetFrameCenter)
double | getTargetFrameAspectRatio ()
void | setTargetFrameAspectRatio (double targetFrameAspectRatio)
double | getTargetFramePaddingPercent ()
void | setTargetFramePaddingPercent (double paddingPercent)
double | getFaceAngleTolerance ()
void | setFaceAngleTolerance (double faceAngleTolerance)

Detailed Description

A configuration objects for controlling the guided detection driven by target frame.

The purpose of the settings object is to define properties of a rectangular target frame, and the minFaceSize that the face should be occupied in the display. The target frame is a rectangular area confined within the bounds of the image, and represents the the ideal area that should be covered by a face.

A target frame is constructed from a center point, an aspect ratio, and a minimum edge padding. The size of the target frame is the largest possible rectangle that can be made without violating any of these constraints.

Constructor & Destructor Documentation

SelfieDetectionSettings ( )

Constructor creates a selfie detection setting object with predefined values.

SelfieDetectionSettings ( SelfieDetectionSettings settings )

Constructor creates a selfie detection setting object that has specified values.

Member Function Documentation

Point getCenterPoint ( )

Gets the center point within the image of the target frame.

Returns
Point
See also
setCenterPoint(Point)
double getFaceAngleTolerance ( )

Returns the minimum rotation of the face about the vertical axis of the image.

Returns
double
See also
setFaceAngleTolerance(double)
double getMinimumFaceSize ( )

Returns the minFaceSize

Returns
the minFaceSize
double getTargetFrameAspectRatio ( )

Gets the aspect ratio of the rectangular frame that should match the document being searched.

Returns
double
See also
setTargetFrameAspectRatio(double)
double getTargetFramePaddingPercent ( )

Gets the minimum padding in percent length to be maintained between the edges of the target frame and image.

Returns
double
See also
setTargetFramePaddingPercent(double)
void setCenterPoint ( Point targetFrameCenter )

The center point is any point within the image that the target frame will be constructed around and centered over. This value will be clamped to the valid area of the image being searched, and by default is set to the center of the image.

Parameters
targetFrameCenter : Point
void setFaceAngleTolerance ( double faceAngleTolerance )

The face angle required to detect the face about vertical axis of the Image. The default value is 15. range is [0 to 60]. The values other than the given range will be ignored.

Parameters
faceAngleTolerance
void setMinimumFaceSize ( double minimumFaceSize )

the smallest head size to search for relative to the size of the target frame, in the range of 0.0 and 1.0. For example, a setting of 0.5 would indicate that detected face need to fill at least half of the target frame. The Default value is 0.35, the values other than the given range will be ignored.

Parameters
minimumFaceSize Sets the smallest desired face size, expressed as a proportion of the area of the head to the area of the target frame.
void setTargetFrameAspectRatio ( double targetFrameAspectRatio )

The aspect ratio is used to construct the target frame that should match the document being searched. If targetFrameAspectRatio > 1, the long edge of the target frame will align with the long edge of the camera preview. If 0 < targetFrameAspectRatio < 1, the long edge of the target frame will align with the short edge of the camera preview.

If the targetFrameAspectRatio is set to 0, then it will be automatically reset to an image aspect ratio.
Setting negative values has the same effect as if 0 was set.

The default value is 0.

Parameters
targetFrameAspectRatio : double
void setTargetFramePaddingPercent ( double paddingPercent )

Values will be clamped to the range [0-50]. The default value is 15. Also, note that there is a much lower operational bound to what the padding percent could be set to behave well. For example:

  • Given detection settings with a frame center at the center of the image, and a personal check aspect ratio, the constructed frame will fill the width of the image, leaving a space on the left and right equal to the padding percent of the image width.
  • Given detection settings with a frame center shifted to the left of the image center, the gap on the right side of the constructed frame will exceed the gap on the left.
Parameters
paddingPercent : double
The documentation for this class was generated from the following file:
  • SelfieDetectionSettings.java


Kofax Mobile SDK API Reference: TurnGuidance Enum Reference

  • kmc
  • ken
  • engines
  • data
  • TurnGuidance
Public Attributes | List of all members
TurnGuidance Enum Reference

Public Attributes

TURN_COUNTER_CLOCKWISE
TURN_CLOCKWISE
TURN_OK

Detailed Description

Guidance for which direction to turn the device while capturing a check.

When a check is detected, the check detector may return check guidance.

This enum indicates if the user should rotate the camera clockwise, counter-clockwise of if the rotation of the device is okay.

Member Data Documentation

TURN_CLOCKWISE

Turn device clockwise

TURN_COUNTER_CLOCKWISE

Turn device counter-clockwise

TURN_OK

Device rotation not required

The documentation for this enum was generated from the following file:
  • TurnGuidance.java


Kofax Mobile SDK API Reference: VerticalGuidance Enum Reference

  • kmc
  • ken
  • engines
  • data
  • VerticalGuidance
Public Attributes | List of all members
VerticalGuidance Enum Reference

Public Attributes

VERTICAL_MOVE_UP
VERTICAL_MOVE_DOWN
VERTICAL_MOVE_OK

Detailed Description

Guidance for which direction to zoom the device while capturing a check.

When a check is detected, the check detector may return check guidance.

This enum indicates if the user should move the camera up, down, or if the check position for capture is okay.

Member Data Documentation

VERTICAL_MOVE_DOWN

Move camera down

VERTICAL_MOVE_OK

Camera movement not required

VERTICAL_MOVE_UP

Move camera up

The documentation for this enum was generated from the following file:
  • VerticalGuidance.java


Kofax Mobile SDK API Reference: ZoomGuidance Enum Reference

  • kmc
  • ken
  • engines
  • data
  • ZoomGuidance
Public Attributes | List of all members
ZoomGuidance Enum Reference

Public Attributes

ZOOM_IN
ZOOM_OUT
ZOOM_OK

Detailed Description

Guidance for which direction to zoom the device while capturing a check.

When a check is detected, the check detector may return check guidance.

This enum indicates if the user should get closer, or move further away from a check or if the zoom distance is okay.

Member Data Documentation

ZOOM_IN

Get closer to the check

ZOOM_OK

Device movement not required

ZOOM_OUT

Get further from the check

The documentation for this enum was generated from the following file:
  • ZoomGuidance.java


Kofax Mobile SDK API Reference: ColorDepth Enum Reference

  • kmc
  • ken
  • engines
  • processing
  • ColorDepth
Public Member Functions | Public Attributes | List of all members
ColorDepth Enum Reference

Public Member Functions

ColorDepth (int value)

Public Attributes

BITONAL =(1)
GRAYSCALE =(8)
COLOR =(24)

Constructor & Destructor Documentation

ColorDepth ( int value )

Member Data Documentation

BITONAL =(1)
COLOR =(24)
GRAYSCALE =(8)
The documentation for this enum was generated from the following file:
  • ColorDepth.java


Kofax Mobile SDK API Reference: CropType Enum Reference

  • kmc
  • ken
  • engines
  • processing
  • CropType
Public Attributes | List of all members
CropType Enum Reference

Public Attributes

CROP_NONE
CROP_AUTO

Member Data Documentation

CROP_AUTO
CROP_NONE
The documentation for this enum was generated from the following file:
  • CropType.java


Kofax Mobile SDK API Reference: DeskewType Enum Reference

  • kmc
  • ken
  • engines
  • processing
  • DeskewType
Public Attributes | List of all members
DeskewType Enum Reference

Public Attributes

DESKEW_NONE
DESKEW_BY_DOCUMENT_EDGES
DESKEW_BY_DOCUMENT_CONTENT

Member Data Documentation

DESKEW_BY_DOCUMENT_CONTENT
DESKEW_BY_DOCUMENT_EDGES
DESKEW_NONE
The documentation for this enum was generated from the following file:
  • DeskewType.java


Kofax Mobile SDK API Reference: DocumentDimensions Class Reference

  • kmc
  • ken
  • engines
  • processing
  • DocumentDimensions
Public Member Functions | List of all members
DocumentDimensions Class Reference

Public Member Functions

DocumentDimensions (Float shortEdge, Float longEdge)
Float | getShortEdge ()
Float | getLongEdge ()
boolean | equals (Object o)
int | hashCode ()

Constructor & Destructor Documentation

DocumentDimensions | ( | Float | shortEdge,
 |  | Float | longEdge
 | ) |  |

Member Function Documentation

boolean equals ( Object o )
Float getLongEdge ( )
Float getShortEdge ( )
int hashCode ( )
The documentation for this class was generated from the following file:
  • DocumentDimensions.java


Kofax Mobile SDK API Reference: ImageProcessorConfiguration Class Reference

  • kmc
  • ken
  • engines
  • processing
  • ImageProcessorConfiguration
Public Member Functions | Public Attributes | List of all members
ImageProcessorConfiguration Class Reference
Inheritance diagram for ImageProcessorConfiguration:

Public Member Functions

ImageProcessorConfiguration clone ()
Performs a field-for-field copy of instances of this class. More...
ImageProcessorConfiguration ()
ImageProcessorConfiguration (String ipOperations) throws KmcException

Public Attributes

RotateType rotateType = RotateType.ROTATE_NONE
ColorDepth outputColorDepth = ColorDepth.COLOR
CropType cropType = CropType.CROP_NONE
TargetFrameCropType targetFrameCropType = TargetFrameCropType.TARGET_FRAME_CROP_OFF
DeskewType deskewType = DeskewType.DESKEW_NONE
DocumentDimensions | documentDimensions = null
Integer | outputDPI = 0
final String | ippString

Constructor & Destructor Documentation

ImageProcessorConfiguration ( )

Creates a new image processor configuration with default values.

ImageProcessorConfiguration ( String ipOperations ) throws KmcException

Creates a new image processor configuration based on an image perfection operation string. Applicable tokens will be converted into configuration properties. Remaining tokens will be stored, and used in a secondary processing operation.

Parameters
ipOperations Image perfection operation string
Exceptions
KmcException if ipOperations is invalid

Member Function Documentation

ImageProcessorConfiguration clone ( )

Performs a field-for-field copy of instances of this class.

Member Data Documentation

CropType cropType = CropType.CROP_NONE

Crop image to a user specified option

DeskewType deskewType = DeskewType.DESKEW_NONE

Deskew an output image

DocumentDimensions documentDimensions = null

Use this property to set the length of the short and long edges of the original document in inches.

final String ippString

The ippString that will be used for a secondary processing operation

ColorDepth outputColorDepth = ColorDepth.COLOR

Use this property to set the desired output colordepth.

Integer outputDPI = 0

Use this property to set the desired output image DPI (Dots Per Inch). If you set it to 0, then the library will automatically detect the output image DPI and indicate it in the output object. Default: 0

RotateType rotateType = RotateType.ROTATE_NONE

Rotate automatically or by 90 degree options

TargetFrameCropType targetFrameCropType = TargetFrameCropType.TARGET_FRAME_CROP_OFF

Use this property to enable or disable target frame cropping.

The documentation for this class was generated from the following file:
  • ImageProcessorConfiguration.java


Kofax Mobile SDK API Reference: RotateType Enum Reference

  • kmc
  • ken
  • engines
  • processing
  • RotateType
Public Member Functions | Public Attributes | List of all members
RotateType Enum Reference

Public Member Functions

RotateType (int type)

Public Attributes

ROTATE_NONE =(0)
ROTATE_90 =(3)
ROTATE_180 =(2)
ROTATE_270 =(1)
ROTATE_AUTO =(4)
final int type

Constructor & Destructor Documentation

RotateType ( int type )

Member Data Documentation

ROTATE_180 =(2)
ROTATE_270 =(1)
ROTATE_90 =(3)
ROTATE_AUTO =(4)
ROTATE_NONE =(0)
final int type
The documentation for this enum was generated from the following file:
  • RotateType.java


Kofax Mobile SDK API Reference: TargetFrameCropType Enum Reference

  • kmc
  • ken
  • engines
  • processing
  • TargetFrameCropType
Public Attributes | List of all members
TargetFrameCropType Enum Reference

Public Attributes

TARGET_FRAME_CROP_OFF
TARGET_FRAME_CROP_ON

Member Data Documentation

TARGET_FRAME_CROP_OFF
TARGET_FRAME_CROP_ON
The documentation for this enum was generated from the following file:
  • TargetFrameCropType.java


Kofax Mobile SDK API Reference: KenVersion Class Reference

  • kmc
  • ken
  • engines
  • version
  • KenVersion
Static Public Member Functions | List of all members
KenVersion Class Reference

Static Public Member Functions

static String getPackageVersion ()

Detailed Description

This class provides a means of retrieving the version string for the Engines package of the Kofax Mobile SDK.

Member Function Documentation

static String getPackageVersion ( )
static
Returns
The version string for the Engines package of the Mobile SDK.
The documentation for this class was generated from the following file:
  • KenVersion.java


Kofax Mobile SDK API Reference: BarCodeReader Class Reference

  • kmc
  • ken
  • engines
  • BarCodeReader
Classes | Public Member Functions | List of all members
BarCodeReader Class Reference

The barcode recognition engine. More...

Classes

class | BarcodeReadCompleteEvent
interface | BarcodeReadCompleteListener
enum | Direction
enum | Symbology

Public Member Functions

BarCodeReader ()
Default constructor. Sets everything to default values: MaxBarcodes to 1, SearchSymbology, and SearchDirection are set to All. More...
BarCodeReader (Symbology[] symbology, Direction direction, int maxBarcode)
Constructor to use when initial barcode engine setup values are specified. More...
String | getBcVersion ()
Method to acquire the version of the barcode library. More...
void | readBarcodes (Image image) throws KmcException
Scans the image using the settings specified, and appends the barcode results to the image. More...
int | getMaxBarcodes ()
Gets the maximum number of barcode results to search for. More...
void | setMaxBarcodes (int maxBarcodes)
Sets the maximum number of barcode results to search for. More...
Symbology[] getSearchSymbology ()
Gets the set of symbologies to be searched for. More...
void | setSearchSymbology (Symbology[] symbologies)
Sets the set of symbologies to be searched for. More...
Direction getSearchDirections ()
Gets the set of directions to be searched for barcodes. More...
void | setSearchDirections (Direction searchDirections)
Sets the set of directions to be searched for barcodes. More...
void | addBarcodeReadCompleteEventListener (BarcodeReadCompleteListener listener)
Adds the specified BarcodeReadCompleteListener to receive read complete events from the BarCodeReader. More...
void | removeBarcodeReadCompleteEventListener (BarcodeReadCompleteListener listener)
Removes the specified barcode read complete event listener from the BarCodeReader. More...

Detailed Description

The barcode recognition engine.

Create an instance of this class to perform barcode recognition on a standalone image. The engine can be configured to search for a specific subset of barcode symbologies, barcodes oriented in particular directions, and a maximum number of barcodes to return. For best performance, each of these criteria should be restricted as much as possible.

Any barcode results found will be populated in a property on the input Image object, and the engine will fire an event through a registered listener when recognition is completed or fails.

Constructor & Destructor Documentation

BarCodeReader ( )

Default constructor. Sets everything to default values: MaxBarcodes to 1, SearchSymbology, and SearchDirection are set to All.

The default constructor, sets the max barcodes to be found at 1, the symbology array to an empty array, and search direction to 'All'.

BarCodeReader | ( | Symbology[] | symbology,
 |  | Direction | direction,
 |  | int | maxBarcode
 | ) |  |

Constructor to use when initial barcode engine setup values are specified.

The BarCodeReader constructor. If null is passed in for any of the parameters they will be set to their respective default value.

Parameters
symbology | Pass in an array of Symbology to have the barcode reader engine look for.
direction | Pass in a Direction that the barcode reader engine will search for barcodes in.
maxBarcode | The maximum number of barcodes that will be searched for.

Member Function Documentation

void addBarcodeReadCompleteEventListener ( BarcodeReadCompleteListener listener )

Adds the specified BarcodeReadCompleteListener to receive read complete events from the BarCodeReader.

Adds a barcode reader complete event listener.

Parameters
listener An instance of a BarcodeReadCompleteListener.
String getBcVersion ( )

Method to acquire the version of the barcode library.

This method calls the barcode library and requests the build version number.

int getMaxBarcodes ( )

Gets the maximum number of barcode results to search for.

Returns
The maximum number of barcodes that will be searched for.
Direction getSearchDirections ( )

Gets the set of directions to be searched for barcodes.

Returns
The Direction value that is currently set.
See also
Direction
Symbology [] getSearchSymbology ( )

Gets the set of symbologies to be searched for.

Returns
An array of Symbology values.
See also
Symbology
void readBarcodes ( Image image ) throws KmcException

Scans the image using the settings specified, and appends the barcode results to the image.

Pass in an Image to have the barcode reader search for barcodes.

This method is asynchronous, and will return when the recognition process is started. Results and status will be returned to any registered listeners. Any located barcodes will be automatically populated into the Image object that was initially supplied to this method.

The supplied Image can be in either the file or bitmap representation. 1 bit-per-pixel images are not supported.

This feature requires a valid SDK license. For feature-based SDK licenses, the Barcode Capture feature must be enabled.

Parameters
image The image to search for barcodes.
void removeBarcodeReadCompleteEventListener ( BarcodeReadCompleteListener listener )

Removes the specified barcode read complete event listener from the BarCodeReader.

Removes a barcode reader complete event listener.

Parameters
listener An instance of a BarcodeReadCompleteListener.
void setMaxBarcodes ( int maxBarcodes )

Sets the maximum number of barcode results to search for.

Set this value to the maximum number of barcodes you expect to find in the target image.

Searching for more barcodes than exist in a document will cause the reader to fully exhaust its search space, resulting in slower recognition times.

Parameters
maxBarcodes The maximum number of barcodes to search for.
void setSearchDirections ( Direction searchDirections )

Sets the set of directions to be searched for barcodes.

Searching multiple directions slows down the speed of barcode recognition. If you expect barcodes to only be oriented in certain directions, you should specify only those directions. By default, all directions will be searched.

It is an error to search for barcodes with no directions selected.

Parameters
searchDirections A Direction value.
See also
Direction for all supported values.
void setSearchSymbology ( Symbology[] symbologies )

Sets the set of symbologies to be searched for.

Each symbology represents a class of barcodes, like UPC or PDF417. A class may match multiple subtypes, such as UPC-A and UPC-E within the UPC symbology.

Searching for multiple symbologies slows down the speed of barcode recognition. You should only specify the symbologies that you are interested in reading. The set of selected symbologies is empty by default.

It is an error to search for barcodes with no symbologies selected.

Parameters
symbologies An array of one or more Symbology values.
barcodeReader.setSymbologies(new Symbology[] { Symbology.Code39, Symbology.Pdf417 });
See also
Symbology for all supported values.
The documentation for this class was generated from the following file:
  • BarCodeReader.java


Kofax Mobile SDK API Reference: BarCodeReader.BarcodeReadCompleteEvent Class Reference

  • kmc
  • ken
  • engines
  • BarCodeReader
  • BarcodeReadCompleteEvent
Public Member Functions | List of all members
BarCodeReader.BarcodeReadCompleteEvent Class Reference
Inheritance diagram for BarCodeReader.BarcodeReadCompleteEvent:

Public Member Functions

BarcodeReadCompleteEvent (Object sender, ErrorInfo status, Image image)
ErrorInfo getStatus ()
Image getImage ()

Detailed Description

A class that is interested in processing a BarcodeReadProgressEvent should implement this interface, and then register itself with the BarCodeReader using the BarcodeReadProgressEventListener method.

Constructor & Destructor Documentation

BarcodeReadCompleteEvent | ( | Object | sender,
 |  | ErrorInfo | status,
 |  | Image | image
 | ) |  |

Class constructor.

Parameters
sender | The sender of the event, usually 'this'.
status | The status of the event.
image | The image that conatins the completed search along with barcode results.

Member Function Documentation

Image getImage ( )

Returns the Image object with the barcode results.

Returns
ErrorInfo getStatus ( )

Returns the status of the event.

Returns
An ErrorInfo.
The documentation for this class was generated from the following file:
  • BarCodeReader.java


Kofax Mobile SDK API Reference: BarCodeReader.BarcodeReadCompleteListener Interface Reference

  • kmc
  • ken
  • engines
  • BarCodeReader
  • BarcodeReadCompleteListener
Public Member Functions | List of all members
BarCodeReader.BarcodeReadCompleteListener Interface Reference

Public Member Functions

void barcodeReadComplete (BarcodeReadCompleteEvent event)
Invoked when a barcode read is complete. More...

Detailed Description

A class that is interested in processing an BarcodeReadCompleteEvent should implement this interface, and then register itself with the BarCodeReader using the addBarcodeReadCompleteEventListener method.

Member Function Documentation

void barcodeReadComplete ( BarcodeReadCompleteEvent event )

Invoked when a barcode read is complete.

The documentation for this interface was generated from the following file:
  • BarCodeReader.java


Kofax Mobile SDK API Reference: BarCodeReader.Direction Enum Reference

  • kmc
  • ken
  • engines
  • BarCodeReader
  • Direction
Public Member Functions | Public Attributes | List of all members
BarCodeReader.Direction Enum Reference

Public Member Functions

Direction (int cVal)

Public Attributes

LEFT_RIGHT =(1 << 0)
RIGHT_LEFT =(1 << 2)
TOP_DOWN =(1 << 1)
BOTTOM_UP =(1 << 3)
ALL =(LEFT_RIGHT._cVal | RIGHT_LEFT._cVal | TOP_DOWN._cVal | BOTTOM_UP._cVal)

Detailed Description

The Direction enumeration. Lists all of the directions to search for bar codes in.

Constructor & Destructor Documentation

Direction ( int cVal )

Member Data Documentation

ALL =(LEFT_RIGHT._cVal | RIGHT_LEFT._cVal | TOP_DOWN._cVal | BOTTOM_UP._cVal)
BOTTOM_UP =(1 << 3)
LEFT_RIGHT =(1 << 0)
RIGHT_LEFT =(1 << 2)
TOP_DOWN =(1 << 1)
The documentation for this enum was generated from the following file:
  • BarCodeReader.java


Kofax Mobile SDK API Reference: BarCodeReader.Symbology Enum Reference

  • kmc
  • ken
  • engines
  • BarCodeReader
  • Symbology
Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
BarCodeReader.Symbology Enum Reference

Public Member Functions

Symbology (int cVal)

Static Public Member Functions

static BarCodeType getBarCodeType (int cVal)

Public Attributes

Code128 =(1)
Ean =(1 << 1 | 1 << 2)
Upc =(1 << 3 | 1 << 4)
Code39 =(1 << 5)
Code25 =(1 << 6)
Code93 =(1 << 9)
Codabar =(1 << 10)
Postnet =(1 << 12)
Datamatrix =(1 << 20)
Pdf417 =(1 << 21)
QRCode =(1 << 22)

Detailed Description

The Symbology enumeration. Lists all of the supported bar code that the engine will search for.

Constructor & Destructor Documentation

Symbology ( int cVal )

Member Function Documentation

static BarCodeType getBarCodeType ( int cVal )
static

Member Data Documentation

Codabar =(1 << 10)
Code128 =(1)
Code25 =(1 << 6)
Code39 =(1 << 5)
Code93 =(1 << 9)
Datamatrix =(1 << 20)
Ean =(1 << 1 | 1 << 2)
Pdf417 =(1 << 21)
Postnet =(1 << 12)
QRCode =(1 << 22)
Upc =(1 << 3 | 1 << 4)
The documentation for this enum was generated from the following file:
  • BarCodeReader.java


Kofax Mobile SDK API Reference: CheckDetector Class Reference

  • kmc
  • ken
  • engines
  • CheckDetector
Public Member Functions | List of all members
CheckDetector Class Reference
Inheritance diagram for CheckDetector:
ICheckDetector IDocumentDetector< CheckDetectionSettings, CheckDetectionResult >

Public Member Functions

CheckDetector ()
final CheckDetectionResult | detect (CheckDetectionSettings settings, Bitmap image)
CheckDetectionResult | detect (CheckDetectionSettings checkDetectionSettings, byte[] data, int width, int height)
void | destroy ()
- Public Member Functions inherited from IDocumentDetector< CheckDetectionSettings, CheckDetectionResult >
U | detect (T settings, Bitmap image)
Runs the document detection algorithm. More...
U | detect (T settings, byte[] data, int width, int height)
Runs the document detection algorithm. More...
void | destroy ()
Destroys this detector instance and releases resources associated with it. More...

Detailed Description

This class provides the main entry point to run Kofax's CheckDetection algorithms against a bitmap image.

Constructor & Destructor Documentation

CheckDetector ( )

Default constructor for the CheckDetector class.

Member Function Documentation

void destroy ( )

When using the detector directly, it is necessary to call this method to allow for clean-up. Only call this method when you are done with the detector completely, i.e. in your onDestroy method of your Activity

final CheckDetectionResult detect | ( | CheckDetectionSettings | settings,
 |  | Bitmap | image
 | ) |  |

Call this method to run the check detection algorithms. Note: None of the parameter values should be null.

Parameters
settings | An instance of a CheckDetectionSettings object. CheckSide.None have not been implemented yet and will always return a null CheckDetectionResult when they are passed using setting object.
image | The bitmap image with which the check detection algorithm will run against. The bitmap must be in landscape orientation with the check in an up-right orientation (MICR in the bottom-left)
Returns
CheckDetectionResult Calling this method will return a CheckDetectResult object that contains the bounds of the check, the side of the check the detector infers the image to be of, the original image, zoom guidance, rotation guidance, horizontal guidance, and vertical guidance. A null result indicates the detector was unable to locate a check within the image.

Implements ICheckDetector.

CheckDetectionResult detect | ( | CheckDetectionSettings | checkDetectionSettings,
 |  | byte[] | data,
 |  | int | width,
 |  | int | height
 | ) |  |

Call this method to run the check detection algorithms.

Parameters
checkDetectionSettings | An instance of a CheckDetectionSettings object. CheckSide.None have not been implemented yet and will always return a null CheckDetectionResult when they are passed using setting object.
data | The image data with which the check detection algorithm will run against. The image must be in landscape orientation with the check in an up-right orientation (MICR in the bottom-left)
width | The width of the image
height | The height of the image
Returns
CheckDetectionResult Calling this method will return a CheckDetectResult object that contains the bounds of the check, the side of the check the detector infers the image to be of, the original image, zoom guidance, rotation guidance, horizontal guidance, and vertical guidance. A null result indicates the detector was unable to locate a check within the image.

Implements ICheckDetector.

The documentation for this class was generated from the following file:
  • CheckDetector.java


Kofax Mobile SDK API Reference: DocumentDetector Class Reference

  • kmc
  • ken
  • engines
  • DocumentDetector
Public Member Functions | List of all members
DocumentDetector Class Reference
Inheritance diagram for DocumentDetector:
IDocumentDetector< DocumentDetectionSettings, DocumentDetectionResult >

Public Member Functions

DocumentDetector (Context context)
DocumentDetectionResult | detect (DocumentDetectionSettings settings, Bitmap image)
Call this method to run the document detection algorithm. More...
DocumentDetectionResult | detect (DocumentDetectionSettings settings, byte[] data, int width, int height)
Call this method to run the document detection algorithm. More...
void | destroy ()
Destroys this detector instance and releases resources associated with it. More...
- Public Member Functions inherited from IDocumentDetector< DocumentDetectionSettings, DocumentDetectionResult >
U | detect (T settings, Bitmap image)
Runs the document detection algorithm. More...
U | detect (T settings, byte[] data, int width, int height)
Runs the document detection algorithm. More...
void | destroy ()
Destroys this detector instance and releases resources associated with it. More...

Detailed Description

This class provides the main entry point to run Kofax's document detection algorithms against a bitmap image or byte array. Since detection is based on a super-resolution technique, higher accuracy results will be returned after multiple executions.

Constructor & Destructor Documentation

DocumentDetector ( Context context )

Member Function Documentation

void destroy ( )

Destroys this detector instance and releases resources associated with it.

Call this method when you are done with this detector completely. A destroyed instance should not be used.

DocumentDetectionResult detect | ( | DocumentDetectionSettings | settings,
 |  | Bitmap | image
 | ) |  |

Call this method to run the document detection algorithm.

None of the parameter values should be null.

Parameters
settings | an instance of a DocumentDetectionSettings object
image | the bitmap image with which the document detection algorithm will run against
Returns
a detection result that contains the bounds of the document, the original image and the guidance, or null if the algorithm could not detect any document in the image
DocumentDetectionResult detect | ( | DocumentDetectionSettings | settings,
 |  | byte[] | data,
 |  | int | width,
 |  | int | height
 | ) |  |

Call this method to run the document detection algorithm.

None of the parameter values should be null.

Parameters
settings | an instance of a DocumentDetectionSettings object
data | the image data with which the document detection algorithm will run against
width | the width of the image
height | the height of the image
Returns
a detection result that contains the bounds of the document, the original image and the guidance, or null if the algorithm could not detect any document in the image
The documentation for this class was generated from the following file:
  • DocumentDetector.java


Kofax Mobile SDK API Reference: ICheckDetector Interface Reference

  • kmc
  • ken
  • engines
  • ICheckDetector
Public Member Functions | List of all members
ICheckDetector Interface Reference
Inheritance diagram for ICheckDetector:
IDocumentDetector< CheckDetectionSettings, CheckDetectionResult > CheckDetector

Public Member Functions

CheckDetectionResult | detect (CheckDetectionSettings settings, Bitmap image)
CheckDetectionResult | detect (CheckDetectionSettings checkDetectionSettings, byte[] data, int width, int height)
- Public Member Functions inherited from IDocumentDetector< CheckDetectionSettings, CheckDetectionResult >
U | detect (T settings, Bitmap image)
Runs the document detection algorithm. More...
U | detect (T settings, byte[] data, int width, int height)
Runs the document detection algorithm. More...
void | destroy ()
Destroys this detector instance and releases resources associated with it. More...

Detailed Description

Interface for check detection algorithms.

Member Function Documentation

CheckDetectionResult detect | ( | CheckDetectionSettings | settings,
 |  | Bitmap | image
 | ) |  |

Runs the check detection algorithm.

Parameters
settings | the settings to use during detection
image | the bitmap with which the detection algorithm will run against
Returns
the result of the detection

Implemented in CheckDetector.

CheckDetectionResult detect | ( | CheckDetectionSettings | checkDetectionSettings,
 |  | byte[] | data,
 |  | int | width,
 |  | int | height
 | ) |  |

Implemented in CheckDetector.

The documentation for this interface was generated from the following file:
  • ICheckDetector.java


Kofax Mobile SDK API Reference: IDocumentDetector< T extends DetectionSettings, U extends DetectionResult > Interface Template Reference

  • kmc
  • ken
  • engines
  • IDocumentDetector
Public Member Functions | List of all members
IDocumentDetector< T extends DetectionSettings, U extends DetectionResult > Interface Template Reference

Public Member Functions

U | detect (T settings, Bitmap image)
Runs the document detection algorithm. More...
U | detect (T settings, byte[] data, int width, int height)
Runs the document detection algorithm. More...
void | destroy ()
Destroys this detector instance and releases resources associated with it. More...

Detailed Description

Interface for document detection algorithms.

Member Function Documentation

void destroy ( )

Destroys this detector instance and releases resources associated with it.

Call this method when you are done with this detector completely. A destroyed instance should not be used.

U detect | ( | T | settings,
 |  | Bitmap | image
 | ) |  |

Runs the document detection algorithm.

Parameters
settings | the settings to use during detection
image | the bitmap with which the detection algorithm will run against
Returns
the result of the detection
U detect | ( | T | settings,
 |  | byte[] | data,
 |  | int | width,
 |  | int | height
 | ) |  |

Runs the document detection algorithm.

Parameters
settings | the settings to use during detection
data | the image data with which the detection algorithm will run against
width | the width of the image
height | the height of the image
Returns
the result of the detection
The documentation for this interface was generated from the following file:
  • IDocumentDetector.java


Kofax Mobile SDK API Reference: ImageClassificationCompletedListener Interface Reference

  • kmc
  • ken
  • engines
  • ImageClassificationCompletedListener
Public Member Functions | List of all members
ImageClassificationCompletedListener Interface Reference

The listener interface for receiving image classification completed events. More...

Public Member Functions

void onImageClassified (ImageClassificationCompleteEvent event)

Detailed Description

The listener interface for receiving image classification completed events.

A class that is interested in classifying images should implement this interface, and then register itself with a ImageClassifer using the addImageClassificationCompletedEventListener method.

See also
ImageClassifier
ImageClassifier::addImageClassificationCompletedEventListener
ImageClassifier::removeImageClassificationCompletedEventListener

Member Function Documentation

void onImageClassified ( ImageClassificationCompleteEvent event )
The documentation for this interface was generated from the following file:
  • ImageClassificationCompletedListener.java


Kofax Mobile SDK API Reference: ImageClassificationCompleteEvent Class Reference

  • kmc
  • ken
  • engines
  • ImageClassificationCompleteEvent
Public Member Functions | List of all members
ImageClassificationCompleteEvent Class Reference

This event is raised in response to an image classification process. More...

Inheritance diagram for ImageClassificationCompleteEvent:

Public Member Functions

Image getImage ()
Returns the Image object that was used for image classification with updated classification results. More...

Detailed Description

This event is raised in response to an image classification process.

The event includes status information, and the Image object that was classified.

Member Function Documentation

Image getImage ( )

Returns the Image object that was used for image classification with updated classification results.

Use the Image#getImageClassifyResults() to retrieve the results.

Returns
the Image object that was used for image classification
The documentation for this class was generated from the following file:
  • ImageClassificationCompleteEvent.java


Kofax Mobile SDK API Reference: ImageClassificationResult Class Reference

  • kmc
  • ken
  • engines
  • ImageClassificationResult
Public Member Functions | List of all members
ImageClassificationResult Class Reference

Results from classifying an image. This object is serializable. More...

Inheritance diagram for ImageClassificationResult:

Public Member Functions

ImageClassificationResult ()
ImageClassificationResult (String classId, float confidence, int orientation)
float | getConfidence ()
int | getOrientation ()
String | getClassId ()

Detailed Description

Results from classifying an image. This object is serializable.

The ImageClassificationResult object contains the results from classifying an image using the ImageClassifier Object. The results will be attached to the Image that was used for the image classification process.

ImageClassificationResult objects support serialization in a similar way to Image objects. The Image object documentation provides code examples for serialization and deserialization.

Constructor & Destructor Documentation

ImageClassificationResult ( )
ImageClassificationResult | ( | String | classId,
 |  | float | confidence,
 |  | int | orientation
 | ) |  |

The results returned from an image classification.

Parameters
classId
confidence
orientation

Member Function Documentation

String getClassId ( )

ID that identifies the classification of the image. Such as "CA2" for California Drivers license, Type 2.

Returns
the class ID
float getConfidence ( )

Value that indicates confidence of Classification operation on an image. Higher numbers > 0 indicate higher confidence. Numbers < 0 indicate lower confidence.

Returns
the classification confidence
int getOrientation ( )

Orientation of the image detected by the ImageClassifier Object.

Returns
the detected image orientation
The documentation for this class was generated from the following file:
  • ImageClassificationResult.java


Kofax Mobile SDK API Reference: ImageClassifier Class Reference

  • kmc
  • ken
  • engines
  • ImageClassifier
Classes | Public Member Functions | List of all members
ImageClassifier Class Reference

This class is used to classify images based on given configuration and model. More...

Classes

enum ImageClassificationStatus

Public Member Functions

ImageClassifier ()
Public constructor allows instantiation from other classes. More...
void | doCleanup ()
Clean up local objects. More...
ImageClassificationStatus getStatus ()
void | addImageClassificationCompletedEventListener (ImageClassificationCompletedListener listener)
Adds the specified listener to receive classification completed events. More...
void | removeImageClassificationCompletedEventListener (ImageClassificationCompletedListener listener)
Removes the specified listener from receiving classification completed events. More...
void | setMaxNumberOfResults (int maxNumberOfResults)
Set the maximum number of classification results to return for an image. More...
int | getMaxNumberOfResults ()
Returns the specified maximum number of classification results to return for an image. More...
int | loadConfigurationFile (String configFileName)
Loads a file that contains configuration values for the classifier. More...
int | loadModel (String modelFileName)
Loads a model file that contains the knowledge source for classification. More...
int | classifyImage (Image image)
Use this method to start the image classification process. More...

Detailed Description

This class is used to classify images based on given configuration and model.

An example of classification would be taking captured images of drivers licenses and classifying them by the issuing state.

The configuration files for use with this API are contained in the SDK in the "Configuration Files" folder of the SDK deliverable.
Use the configuration file driverslicense_config.xml with the loadConfigurationFile(String) method to setup the classifier to classify United States drivers licenses.
Use the model file driverslicense_model.xml with the loadModel(String) method to setup the model for the classifier.
Once these files are loaded, you can use the classifyImage(Image) method to determine what type of drivers license is contained in the Image object.

Example:

private void classificationExample() {

    String pathToClassifyConfig = getPathToClassifyConfig();

    String pathToClassifyModel = getPathToClassifyModel();

    Image imgToClassify  = getImageToClassify();

    ImageClassifier imgClass = new ImageClassifier();

    imgClass.addImageClassificationCompletedEventListener(this);

    imgClass.loadConfigurationFile(pathToClassifyConfig);

    imgClass.loadModel(pathToClassifyModel);

    imgClass.setMaxNumberOfResults(5);

    imgClass.classifyImage(imgToClassify);

}

@Override

public void onImageClassified(ImageClassificationCompleteEvent event) {

    Image imageClassified = event.getImage();

    List<ImageClassificationResult> results = imageClassified.getImageClassifyResults();

}
See also
ImageClassificationCompletedListener
ImageClassificationResult

Constructor & Destructor Documentation

ImageClassifier ( )

Public constructor allows instantiation from other classes.

Prior to SDK 2.2, ImageClassifier was a singleton object, only instantiated once from the getInstance() method. It is now a regular instance object although multiple instances are still not allowed to be used concurrently.

Member Function Documentation

void addImageClassificationCompletedEventListener ( ImageClassificationCompletedListener listener )

Adds the specified listener to receive classification completed events.

Parameters
listener the listener
See also
ImageClassificationCompletedListener
int classifyImage ( Image image )

Use this method to start the image classification process.

Call the loadModel(String) and loadConfigurationFile(String) methods before calling classifyImage(). Results are returned to objects added using the addImageClassificationCompletedEventListener() method.

Parameters
image Image to use for classification. A reference will be returned with populated results.
void doCleanup ( )

Clean up local objects.

Call this method right before setting your ImageClassifier object to null. After calling this method, your ImageClassifier object is no longer usable.

int getMaxNumberOfResults ( )

Returns the specified maximum number of classification results to return for an image.

Returns
the maximum number of classification results
ImageClassificationStatus getStatus ( )

Returns the current state of the image classification object. It could be available, or it could be processing an image classification.

Returns
the status of this classifier
int loadConfigurationFile ( String configFileName )

Loads a file that contains configuration values for the classifier.

Parameters
configFileName Path to the configuration file.
int loadModel ( String modelFileName )

Loads a model file that contains the knowledge source for classification.

Parameters
modelFileName The path to the model file.
void removeImageClassificationCompletedEventListener ( ImageClassificationCompletedListener listener )

Removes the specified listener from receiving classification completed events.

Parameters
listener the listener to remove
See also
ImageClassificationCompletedListener
void setMaxNumberOfResults ( int maxNumberOfResults )

Set the maximum number of classification results to return for an image.

Minimum = 1, Maximum: 64

Parameters
maxNumberOfResults the maximum number of classification results to return
The documentation for this class was generated from the following file:
  • ImageClassifier.java


Kofax Mobile SDK API Reference: ImageClassifier.ImageClassificationStatus Enum Reference

  • kmc
  • ken
  • engines
  • ImageClassifier
  • ImageClassificationStatus
Public Attributes | List of all members
ImageClassifier.ImageClassificationStatus Enum Reference

Public Attributes

IN_PROGRESS
COMPLETE
ERROR

Member Data Documentation

COMPLETE
ERROR
IN_PROGRESS
The documentation for this enum was generated from the following file:
  • ImageClassifier.java


Kofax Mobile SDK API Reference: ImageProcessor Class Reference

  • kmc
  • ken
  • engines
  • ImageProcessor
Classes | Public Member Functions | List of all members
ImageProcessor Class Reference

The ImageProcessor is the image processing engine. More...

Classes

class | AnalysisCompleteEvent
An event that indicates that image quick analysis results are available. More...
interface | AnalysisCompleteListener
The listener interface for receiving analysis complete events. More...
class | AnalysisProgressEvent
An event that indicates Image processing progress information is available. More...
interface | AnalysisProgressListener
The listener interface for receiving Analysis Progress events. More...
class | ImageOutEvent
An event that indicates a processed Image is available. More...
interface | ImageOutListener
The listener interface for receiving Image Out events. More...
class | ProcessProgressEvent
An event that indicates Image processing progress information is available. More...
interface | ProcessProgressListener
The listener interface for receiving Process Progress events. More...

Public Member Functions

void | cancel ()
Cancels an image processing operation that is in progress. More...
ImageProcessor ()
Public constructor allows instantiation from other classes. More...
void | doCleanup ()
Clean up local objects. More...
ImagePerfectionProfile getImagePerfectionProfile ()
Get the ImagePerfectionProfile (advanced image processing settings). More...
void | setImagePerfectionProfile (ImagePerfectionProfile imagePerfectionProfile)
Set the ImagePerfectionProfile (advanced image processing settings). More...
BasicSettingsProfile getBasicSettingsProfile ()
Get the BasicSettingsProfile (basic image processing settings). More...
void | setBasicSettingsProfile (BasicSettingsProfile basicSettingsProfile)
Set the BasicSettingsProfile (basic image processing settings). More...
ImageRep getProcessedImageRepresentation ()
Get the image representation (file, bitmap, or both) for the output image. More...
void | setProcessedImageRepresentation (ImageRep processedImageRepresentation)
Set the image representation (file, bitmap, or both) for the output image. More...
String | getProcessedImageFilePath ()
Get the output image file path. More...
void | setProcessedImageFilePath (String processedImageFilePath)
Set the output image file path. More...
ImageMimeType getProcessedImageMimeType ()
Get the output image mime type. More...
void | setProcessedImageMimeType (ImageMimeType processedImageMimeType)
Set the output image mime type. More...
int | getProcessedImageJpegQuality ()
Get the output image JPEG quality. More...
void | setProcessedImageJpegQuality (int processedImageJpegQuality)
Set the output image JPEG quality. More...
ListenerCallbackThreadType getListenerCallbackThreadType ()
Get the ListenerCallbackThreadType. More...
void | setListenerCallbackThreadType (ListenerCallbackThreadType listenerCallbackThreadType)
Set the thread type for asynchronous callbacks. More...
void | processImage (Image image) throws KmcException
Performs image processing for the specified Image. More...
void | processImage (Image image, ImageProcessorConfiguration configuration) throws KmcException
Performs image processing for the specified Image. More...
void | addImageOutEventListener (ImageOutListener listener)
Adds the specified ImageOutListener to receive Image out events from the ImageProcessor. More...
void | removeImageOutEventListener (ImageOutListener listener)
Removes the specified ImageOutListener from the ImageProcessor. More...
void | addProcessProgressEventListener (ProcessProgressListener listener)
Adds the specified ProcessProgressListener to receive ProcessProgress events from the ImageProcessor. More...
void | removeProcessProgressEventListener (ProcessProgressListener listener)
Removes the specified ProcessProgressListener from the ImageProcessor. More...
void | doQuickAnalysis (Image image, boolean returnPreviewImage) throws KmcException
Performs image quality checks and detects the page boundaries for the specified image. More...
void | doQuickAnalysis (Image image, boolean returnPreviewImage, QuickAnalysisSettings settings) throws KmcException
Performs image quality checks and detects the page boundaries for the specified image. More...
void | addAnalysisCompleteEventListener (AnalysisCompleteListener listener)
Adds the specified AnalysisCompleteListener to receive AnalysisComplete events from the ImageProcessor. More...
void | removeAnalysisCompleteEventListener (AnalysisCompleteListener listener)
Removes the specified AnalysisCompleteListener from the ImageProcessor. More...
void | addAnalysisProgressEventListener (AnalysisProgressListener listener)
Adds the specified AnalysisProgressListener to receive AnalysisProgress events from the ImageProcessor. More...
void | removeAnalysisProgressEventListener (AnalysisProgressListener listener)
Removes the specified AnalysisProgressListener from the ImageProcessor. More...

Detailed Description

The ImageProcessor is the image processing engine.

The ImageProcessor object is an image processing engine that can process a single image according to settings contained in ImageProcessingConfiguration object. The output of the processImage(Image, ImageProcessorConfiguration) is a new instance of an Image object which contains the fully processed image.

Constructor & Destructor Documentation

ImageProcessor ( )

Public constructor allows instantiation from other classes.

Note
Multiple instances are not allowed to be used concurrently.

Member Function Documentation

void addAnalysisCompleteEventListener ( AnalysisCompleteListener listener )

Adds the specified AnalysisCompleteListener to receive AnalysisComplete events from the ImageProcessor.

void addAnalysisProgressEventListener ( AnalysisProgressListener listener )

Adds the specified AnalysisProgressListener to receive AnalysisProgress events from the ImageProcessor.

void addImageOutEventListener ( ImageOutListener listener )

Adds the specified ImageOutListener to receive Image out events from the ImageProcessor.

void addProcessProgressEventListener ( ProcessProgressListener listener )

Adds the specified ProcessProgressListener to receive ProcessProgress events from the ImageProcessor.

void cancel ( )

Cancels an image processing operation that is in progress.

This operation is asynchronous. The ImageOutEvent will indicate that the operation was canceled using the ErrorInfo#KMC_EV_CANCEL_OPERATION_SUCCESS status.

If the processing has already completed or has not started yet this method has no effect.

void doCleanup ( )

Clean up local objects.

Call this method right before setting your ImageProcessor object to null. After calling this method, your ImageProcessor object is no longer usable.

void doQuickAnalysis | ( | Image | image,
 |  | boolean | returnPreviewImage
 | ) |  | throws KmcException

Performs image quality checks and detects the page boundaries for the specified image.

The doQuickAnalysis method performs image quality checks and detects the page boundaries for the specified input Image object, populates the imageQuickAnalysisFeedback property in the input Image, and fires the analysisCompleteEvent. If returnPreviewImage is true, the viewBoundariesImage property of the QuickAnalysisFeedback object is updated with the preview Bitmap which shows the found page boundaries drawn in green. Calling doQuickAnalysis while image processing or analysis is still ongoing will result in a KMC_EV_PROCESS_PAGE_BUSY KmcException.

Parameters
image | The image to be analyzed
returnPreviewImage | is a boolean. If returnPreviewImage is true, the viewBoundariesImage property of the QuickAnalysisFeedback object is updated with the preview Bitmap which shows the found page boundaries drawn in green.
Exceptions
NullPointerException | ('image' parameter is null).
KmcException | (KMC_EV_PROCESS_PAGE_BUSY).
KmcException | (KMC_ED_NONEXISTENT_FILE).
KmcRuntimeException | (KMC_ED_FILEPATH).

See also: AnalysisCompleteListener, AnalysisProgressListener

void doQuickAnalysis | ( | Image | image,
 |  | boolean | returnPreviewImage,
 |  | QuickAnalysisSettings | settings
 | ) |  | throws KmcException

Performs image quality checks and detects the page boundaries for the specified image.

The doQuickAnalysis method performs image quality checks and detects the page boundaries for the specified input Image object, populates the imageQuickAnalysisFeedback property in the input Image, and fires the analysisCompleteEvent. If returnPreviewImage is true, the viewBoundariesImage property of the QuickAnalysisFeedback object is updated with the preview Bitmap which shows the found page boundaries drawn in green. Calling doQuickAnalysis while image processing or analysis is still ongoing will result in a KMC_EV_PROCESS_PAGE_BUSY KmcException.

Parameters
image | The image to be analyzed
returnPreviewImage | is a boolean. If returnPreviewImage is true, the viewBoundariesImage property of the QuickAnalysisFeedback object is updated with the preview Bitmap which shows the found page boundaries drawn in green.
settings | a QuickAnalysisSettings class used for quick analysis algorithm setting adjustment
Exceptions
NullPointerException | ('image' parameter is null).
KmcException | (KMC_EV_PROCESS_PAGE_BUSY).
KmcException | (KMC_ED_NONEXISTENT_FILE).
KmcRuntimeException | (KMC_ED_FILEPATH).

See also: AnalysisCompleteListener, AnalysisProgressListener

BasicSettingsProfile getBasicSettingsProfile ( )

Get the BasicSettingsProfile (basic image processing settings).

Returns
the BasicSettingsProfile
Deprecated:
Deprecated in SDK 3.3. BasicSettingsProfile is replaced by ImageProcessorConfiguration.
ImagePerfectionProfile getImagePerfectionProfile ( )

Get the ImagePerfectionProfile (advanced image processing settings).

Returns
the ImagePerfectionProfile
Deprecated:
Deprecated in SDK 3.3. ImagePerfectionProfile is replaced by ImageProcessorConfiguration.
ListenerCallbackThreadType getListenerCallbackThreadType ( )

Get the ListenerCallbackThreadType.

Returns
the thread type for asynchronous callbacks
String getProcessedImageFilePath ( )

Get the output image file path.

Returns
the output image file path
int getProcessedImageJpegQuality ( )

Get the output image JPEG quality.

The output image JPEG quality specifies the JPEG quality for an output image file created by image processing. This is used only when both the following are true:

processedImageMimeType is set to ImageMimeType.MIMETYPE_JPEG, and
processedImageRepresentation is set to ImageRep.IMAGE_REP_FILE or ImageRep.IMAGE_REP_BOTH.

Returns
the output image JPEG quality
ImageMimeType getProcessedImageMimeType ( )

Get the output image mime type.

This property is used only when (1) processedImageFilePath property contains a valid image path, and (2) processedImageRepresentation is ImageRep.IMAGE_REP_FILE or ImageRep.IMAGE_REP_BOTH.

Returns
the output image mime type
ImageRep getProcessedImageRepresentation ( )

Get the image representation (file, bitmap, or both) for the output image.

Returns
the ProcessedImageRepresentation
void processImage ( Image image ) throws KmcException

Performs image processing for the specified Image.

The processImage method performs image processing for the specified Image and asynchronously returns a processed Image object. Processing is controlled by the properties that have been set. This method returns progress updates on such things as the status of the image processing.

Any errors detected during asynchronous processing are returned via the ImageOut event. For example, KMC_EV_PROCESS_PAGE_BUSY indicates processImage was called while image processing or analysis is still ongoing.

Parameters
image The image to be processed
Exceptions
NullPointerException | ('image' parameter is null).
KmcRuntimeException | (KMC_IP_NO_PROFILE).
KmcRuntimeException | (KMC_ED_NOIMAGE).
KmcRuntimeException | (KMC_ED_FILEPATH).
KmcRuntimeException | (KMC_ED_MIMETYPE).
KmcRuntimeException | (KMC_ED_IMAGE_PERFECTION_PROFILE_EMPTY).
KmcException | (KMC_ED_NONEXISTENT_FILE).
Deprecated:
Deprecated in SDK 3.3. Replaced by processImage(Image, ImageProcessorConfiguration)
void processImage | ( | Image | image,
 |  | ImageProcessorConfiguration | configuration
 | ) |  | throws KmcException

Performs image processing for the specified Image.

Performs image processing for the specified Image and asynchronously returns a processed Image object. Processing is controlled by the properties that have been set. This method returns progress updates on such things as the status of the image processing.

Any errors detected during asynchronous processing are returned via the ImageOut event. For example, KMC_EV_PROCESS_PAGE_BUSY indicates the method was called while image processing or analysis is still ongoing.

Parameters
image | The image to be processed
configuration | The configuration to process the image.
Exceptions
NullPointerException | ('image' parameter is null).
KmcRuntimeException | (KMC_IP_NO_PROFILE).
KmcRuntimeException | (KMC_ED_NOIMAGE).
KmcRuntimeException | (KMC_ED_FILEPATH).
KmcRuntimeException | (KMC_ED_MIMETYPE).
KmcRuntimeException | (KMC_ED_IMAGE_PERFECTION_PROFILE_EMPTY).
KmcException | (KMC_ED_NONEXISTENT_FILE).
void removeAnalysisCompleteEventListener ( AnalysisCompleteListener listener )

Removes the specified AnalysisCompleteListener from the ImageProcessor.

void removeAnalysisProgressEventListener ( AnalysisProgressListener listener )

Removes the specified AnalysisProgressListener from the ImageProcessor.

void removeImageOutEventListener ( ImageOutListener listener )

Removes the specified ImageOutListener from the ImageProcessor.

void removeProcessProgressEventListener ( ProcessProgressListener listener )

Removes the specified ProcessProgressListener from the ImageProcessor.

void setBasicSettingsProfile ( BasicSettingsProfile basicSettingsProfile )

Set the BasicSettingsProfile (basic image processing settings).

Deskew option applies to image with skew angle less or equal to 15 degrees.

If imagePerfectionProfile is set (not null) it takes precedence over basicSettingsProfile.

Deprecated:
Deprecated in SDK 3.3. Please use ImageProcessorConfiguration as an argument for calling processImage(Image, ImageProcessorConfiguration)
void setImagePerfectionProfile ( ImagePerfectionProfile imagePerfectionProfile )

Set the ImagePerfectionProfile (advanced image processing settings).

Set the advanced image processing settings.

Deprecated:
Deprecated in SDK 3.3. Please use ImageProcessorConfiguration as an argument for calling processImage(Image, ImageProcessorConfiguration)
void setListenerCallbackThreadType ( ListenerCallbackThreadType listenerCallbackThreadType )

Set the thread type for asynchronous callbacks.

Defaults to ListenerCallbackThreadType#UI_THREAD.

Parameters
listenerCallbackThreadType the thread type for asynchronous callbacks
void setProcessedImageFilePath ( String processedImageFilePath )

Set the output image file path.

void setProcessedImageJpegQuality ( int processedImageJpegQuality )

Set the output image JPEG quality.

The output image JPEG quality specifies the JPEG quality for an output image file created by image processing. This is used only when both the following are true:

processedImageMimeType is set to ImageMimeType.MIMETYPE_JPEG, and
processedImageRepresentation is set to ImageRep.IMAGE_REP_FILE or ImageRep.IMAGE_REP_BOTH.

Exceptions
KmcRuntimeException (KMC_ED_INVALID_JPEG_QUALITY_VALUE).
void setProcessedImageMimeType ( ImageMimeType processedImageMimeType )

Set the output image mime type.

This property is used only when (1) processedImageFilePath property contains a valid image path, and (2) processedImageRepresentation is ImageRep.IMAGE_REP_FILE or ImageRep.IMAGE_REP_BOTH.

void setProcessedImageRepresentation ( ImageRep processedImageRepresentation )

Set the image representation (file, bitmap, or both) for the output image.

The documentation for this class was generated from the following file:
  • ImageProcessor.java


Kofax Mobile SDK API Reference: ImageProcessor.AnalysisCompleteEvent Class Reference

  • kmc
  • ken
  • engines
  • ImageProcessor
  • AnalysisCompleteEvent
Public Member Functions | List of all members
ImageProcessor.AnalysisCompleteEvent Class Reference

An event that indicates that image quick analysis results are available. More...

Inheritance diagram for ImageProcessor.AnalysisCompleteEvent:

Public Member Functions

AnalysisCompleteEvent (Object sender, ErrorInfo status, Image image)
Creates a new AnalysisCompleteEvent with the given parameters. More...
ErrorInfo getStatus ()
Gets the status property for the AnalysisCompleteEvent. More...
Image getImage ()
Gets the Image property for the AnalysisCompleteEvent. More...

Detailed Description

An event that indicates that image quick analysis results are available.

This event is raised in response to image quick analysis results being available following a call to doQuickAnalysis. The event includes status information, and optionally a new preview Image object. A new preview Image is provided on this event if returnPreviewImage was true in the corresponding call to doQuickAnalysis. The preview Image object may be null when errors are reported. The preview Image will be null if returnPreviewImage was false in the call to doQuickAnalysis.

See also
ImageProcessor::doQuickAnalysis

Constructor & Destructor Documentation

AnalysisCompleteEvent | ( | Object | sender,
 |  | ErrorInfo | status,
 |  | Image | image
 | ) |  |

Creates a new AnalysisCompleteEvent with the given parameters.

Member Function Documentation

Image getImage ( )

Gets the Image property for the AnalysisCompleteEvent.

The Image property is the newly generated preview image.

Returns
ErrorInfo status
ErrorInfo getStatus ( )

Gets the status property for the AnalysisCompleteEvent.

The status property includes a status code and a message string.

Returns
ErrorInfo status
The documentation for this class was generated from the following file:
  • ImageProcessor.java


Kofax Mobile SDK API Reference: ImageProcessor.AnalysisCompleteListener Interface Reference

  • kmc
  • ken
  • engines
  • ImageProcessor
  • AnalysisCompleteListener
Public Member Functions | List of all members
ImageProcessor.AnalysisCompleteListener Interface Reference

The listener interface for receiving analysis complete events. More...

Public Member Functions

void analysisComplete (AnalysisCompleteEvent event)
Invoked when a processed Image is available. More...

Detailed Description

The listener interface for receiving analysis complete events.

A class that is interested in processing an AnalysisCompleteEvent should implement this interface, and then register itself with the ImageProcessor using the addAnalysisCompleteEventListener method.

Member Function Documentation

void analysisComplete ( AnalysisCompleteEvent event )

Invoked when a processed Image is available.

The documentation for this interface was generated from the following file:
  • ImageProcessor.java


Kofax Mobile SDK API Reference: ImageProcessor.AnalysisProgressEvent Class Reference

  • kmc
  • ken
  • engines
  • ImageProcessor
  • AnalysisProgressEvent
Public Member Functions | List of all members
ImageProcessor.AnalysisProgressEvent Class Reference

An event that indicates Image processing progress information is available. More...

Inheritance diagram for ImageProcessor.AnalysisProgressEvent:

Public Member Functions

AnalysisProgressEvent (Object sender, ErrorInfo status, String imageID, int progressPct)
Creates a new ProcessProgressEvent with the given parameters. More...
ErrorInfo getStatus ()
Gets the status property for the AnalysisProgressEvent. More...
String | getImageID ()
Gets the ImageID string for the AnalysisProgressEvent. More...
int | getProgressPct ()
Gets the analysis percentage for the progress event. More...

Detailed Description

An event that indicates Image processing progress information is available.

This event is raised in response to image processing progress information being available following a call to processImage. The event includes status information, Image ID string, and the progress percentage value. The Image ID references the Image object that was passed to processImage originally.

See also
ImageProcessor::processImage(Image, ImageProcessorConfiguration)

Constructor & Destructor Documentation

AnalysisProgressEvent | ( | Object | sender,
 |  | ErrorInfo | status,
 |  | String | imageID,
 |  | int | progressPct
 | ) |  |

Creates a new ProcessProgressEvent with the given parameters.

Member Function Documentation

String getImageID ( )

Gets the ImageID string for the AnalysisProgressEvent.

The ImageID string identifies the Image being processed.

Returns
ImageID string
int getProgressPct ( )

Gets the analysis percentage for the progress event.

The progressPct is an integer percentage value (0..100) indicating the progress of the image analysis operation.

Returns
progressPct
ErrorInfo getStatus ( )

Gets the status property for the AnalysisProgressEvent.

The status property includes a status code and a message string.

Returns
ErrorInfo status
The documentation for this class was generated from the following file:
  • ImageProcessor.java


Kofax Mobile SDK API Reference: ImageProcessor.AnalysisProgressListener Interface Reference

  • kmc
  • ken
  • engines
  • ImageProcessor
  • AnalysisProgressListener
Public Member Functions | List of all members
ImageProcessor.AnalysisProgressListener Interface Reference

The listener interface for receiving Analysis Progress events. More...

Public Member Functions

void analysisProgress (AnalysisProgressEvent event)
Invoked when process progress information is available. More...

Detailed Description

The listener interface for receiving Analysis Progress events.

A class that is interested in processing an AnalysisProgressEvent should implement this interface, and then register itself with the ImageProcessor using the addAnalysisProgressEventListener method.

Member Function Documentation

void analysisProgress ( AnalysisProgressEvent event )

Invoked when process progress information is available.

The documentation for this interface was generated from the following file:
  • ImageProcessor.java


Kofax Mobile SDK API Reference: ImageProcessor.ImageOutEvent Class Reference

  • kmc
  • ken
  • engines
  • ImageProcessor
  • ImageOutEvent
Public Member Functions | List of all members
ImageProcessor.ImageOutEvent Class Reference

An event that indicates a processed Image is available. More...

Inheritance diagram for ImageProcessor.ImageOutEvent:

Public Member Functions

ImageOutEvent (Object sender, ErrorInfo status, Image image)
Creates a new ImageOutEvent with the given parameters. More...
ErrorInfo getStatus ()
Gets the status property for the ImageOutEvent. More...
Image getImage ()
Gets the Image property for the ImageOutEvent. More...

Detailed Description

An event that indicates a processed Image is available.

This event is raised in response to a processed Image being available following a call to processImage. The event includes status information, and a new processed Image object. The processed Image object may be null when errors are reported.

See also
ImageProcessor::processImage

Constructor & Destructor Documentation

ImageOutEvent | ( | Object | sender,
 |  | ErrorInfo | status,
 |  | Image | image
 | ) |  |

Creates a new ImageOutEvent with the given parameters.

Member Function Documentation

Image getImage ( )

Gets the Image property for the ImageOutEvent.

The Image property is the newly processed image.

Returns
ErrorInfo status
ErrorInfo getStatus ( )

Gets the status property for the ImageOutEvent.

The status property includes a status code and a message string.

Returns
ErrorInfo status
The documentation for this class was generated from the following file:
  • ImageProcessor.java


Kofax Mobile SDK API Reference: ImageProcessor.ImageOutListener Interface Reference

  • kmc
  • ken
  • engines
  • ImageProcessor
  • ImageOutListener
Public Member Functions | List of all members
ImageProcessor.ImageOutListener Interface Reference

The listener interface for receiving Image Out events. More...

Public Member Functions

void imageOut (ImageOutEvent event)
Invoked when a processed Image is available. More...

Detailed Description

The listener interface for receiving Image Out events.

A class that is interested in processing an ImageOutEvent should implement this interface, and then register itself with the ImageProcessor using the addImageOutEventListener method.

Member Function Documentation

void imageOut ( ImageOutEvent event )

Invoked when a processed Image is available.

The documentation for this interface was generated from the following file:
  • ImageProcessor.java


Kofax Mobile SDK API Reference: ImageProcessor.ProcessProgressEvent Class Reference

  • kmc
  • ken
  • engines
  • ImageProcessor
  • ProcessProgressEvent
Public Member Functions | List of all members
ImageProcessor.ProcessProgressEvent Class Reference

An event that indicates Image processing progress information is available. More...

Inheritance diagram for ImageProcessor.ProcessProgressEvent:

Public Member Functions

ProcessProgressEvent (Object sender, ErrorInfo status, String imageID, int progressPct)
Creates a new ProcessProgressEvent with the given parameters. More...
ErrorInfo getStatus ()
Gets the status property for the ProcessProgressEvent. More...
String | getImageID ()
Gets the ImageID string for the ProcessProgressEvent. More...
int | getProgressPct ()
Gets the progress percentage for the progress event. More...

Detailed Description

An event that indicates Image processing progress information is available.

This event is raised in response to image processing progress information being available following a call to processImage. The event includes status information, Image ID string, and the progress percentage value. The Image ID references the Image object that was passed to processImage originally.

See also
ImageProcessor::processImage

Constructor & Destructor Documentation

ProcessProgressEvent | ( | Object | sender,
 |  | ErrorInfo | status,
 |  | String | imageID,
 |  | int | progressPct
 | ) |  |

Creates a new ProcessProgressEvent with the given parameters.

Member Function Documentation

String getImageID ( )

Gets the ImageID string for the ProcessProgressEvent.

The ImageID string identifies the Image being processed.

Returns
ImageID string
int getProgressPct ( )

Gets the progress percentage for the progress event.

The progressPct is an integer percentage value (0..100) indicating the progress if the image processing operation.

Returns
progressPct
ErrorInfo getStatus ( )

Gets the status property for the ProcessProgressEvent.

The status property includes a status code and a message string.

Returns
ErrorInfo status
The documentation for this class was generated from the following file:
  • ImageProcessor.java


Kofax Mobile SDK API Reference: ImageProcessor.ProcessProgressListener Interface Reference

  • kmc
  • ken
  • engines
  • ImageProcessor
  • ProcessProgressListener
Public Member Functions | List of all members
ImageProcessor.ProcessProgressListener Interface Reference

The listener interface for receiving Process Progress events. More...

Public Member Functions

void processProgress (ProcessProgressEvent event)
Invoked when process progress information is available. More...

Detailed Description

The listener interface for receiving Process Progress events.

A class that is interested in processing a ProcessProgressEvent should implement this interface, and then register itself with the ImageProcessor using the addProcessProgressEventListener method.

Member Function Documentation

void processProgress ( ProcessProgressEvent event )

Invoked when process progress information is available.

The documentation for this interface was generated from the following file:
  • ImageProcessor.java


Kofax Mobile SDK API Reference: IPassportDetector Interface Reference

  • kmc
  • ken
  • engines
  • IPassportDetector
Public Member Functions | List of all members
IPassportDetector Interface Reference
Inheritance diagram for IPassportDetector:
IDocumentDetector< PassportDetectionSettings, PassportDetectionResult > PassportDetector

Public Member Functions

PassportDetectionResult | detect (PassportDetectionSettings settings, Bitmap image)
PassportDetectionResult | detect (PassportDetectionSettings passportDetectionSettings, byte[] data, int width, int height)
- Public Member Functions inherited from IDocumentDetector< PassportDetectionSettings, PassportDetectionResult >
U | detect (T settings, Bitmap image)
Runs the document detection algorithm. More...
U | detect (T settings, byte[] data, int width, int height)
Runs the document detection algorithm. More...
void | destroy ()
Destroys this detector instance and releases resources associated with it. More...

Detailed Description

Interface for passport detection algorithms.

Member Function Documentation

PassportDetectionResult detect | ( | PassportDetectionSettings | settings,
 |  | Bitmap | image
 | ) |  |

Runs the passport detection algorithm.

Parameters
settings | the settings to use during detection
image | the bitmap with which the detection algorithm will run against
Returns
the result of the detection

Implemented in PassportDetector.

PassportDetectionResult detect | ( | PassportDetectionSettings | passportDetectionSettings,
 |  | byte[] | data,
 |  | int | width,
 |  | int | height
 | ) |  |
Parameters
passportDetectionSettings
data | the image data with which the detection algorithm will run against
width | the width of the image
height | the height of the image
Returns

Implemented in PassportDetector.

The documentation for this interface was generated from the following file:
  • IPassportDetector.java


Kofax Mobile SDK API Reference: KENLogging Class Reference

  • kmc
  • ken
  • engines
  • KENLogging
Static Public Member Functions | List of all members
KENLogging Class Reference

Static Public Member Functions

static void enableConsoleLogging (boolean enable)

Detailed Description

Enable or disable console logging for KEN package classes.

See also
Logging

Member Function Documentation

static void enableConsoleLogging ( boolean enable )
static

Enables Ken package console logging. Pass true to turn on library logging, and false otherwise. Disabled by default.

Parameters
enable
The documentation for this class was generated from the following file:
  • KENLogging.java


Kofax Mobile SDK API Reference: PassportDetector Class Reference

  • kmc
  • ken
  • engines
  • PassportDetector
Public Member Functions | List of all members
PassportDetector Class Reference
Inheritance diagram for PassportDetector:
IPassportDetector IDocumentDetector< PassportDetectionSettings, PassportDetectionResult >

Public Member Functions

PassportDetector ()
PassportDetectionResult | detect (PassportDetectionSettings settings, Bitmap image)
PassportDetectionResult | detect (PassportDetectionSettings settings, byte[] data, int width, int height)
void | destroy ()
- Public Member Functions inherited from IDocumentDetector< PassportDetectionSettings, PassportDetectionResult >
U | detect (T settings, Bitmap image)
Runs the document detection algorithm. More...
U | detect (T settings, byte[] data, int width, int height)
Runs the document detection algorithm. More...
void | destroy ()
Destroys this detector instance and releases resources associated with it. More...

Detailed Description

This class provides the main entry point to run Kofax's PassportDetection algorithms against a bitmap image.

Constructor & Destructor Documentation

PassportDetector ( )

Default constructor for the PassportDetector class.

Member Function Documentation

void destroy ( )

When using the detector directly, it is necessary to call this method to allow for clean-up. Only call this method when you are done with the detector completely, i.e. in your onDestroy method of your Activity

PassportDetectionResult detect | ( | PassportDetectionSettings | settings,
 |  | Bitmap | image
 | ) |  |

Call this method to run the check detection algorithms. Note: None of the parameter values should be null.

Parameters
settings | An instance of a PassportDetectionSettings object.
image | The bitmap image with which the check detection algorithm will run against. The bitmap must be in landscape orientation with the passport in an up-right orientation (MRZ in the bottom or in the top)
Returns
PassportDetectionResult Calling this method will return a PassportDetectResult object that contains the bounds of the passport, the original image, zoom guidance, rotation guidance, horizontal guidance, and vertical guidance. A null result indicates the detector was unable to locate a passport within the image.

Implements IPassportDetector.

PassportDetectionResult detect | ( | PassportDetectionSettings | settings,
 |  | byte[] | data,
 |  | int | width,
 |  | int | height
 | ) |  |

Call this method to run the check detection algorithms.

Parameters
settings | An instance of a PassportDetectionSettings object.
data | The image data with which the check detection algorithm will run against. The bitmap must be in landscape orientation with the passport in an up-right orientation (MRZ in the bottom or in the top)
width | The width of the image
height | The height of the image
Returns
PassportDetectResult Calling this method will return a PassportDetectResult object that contains the bounds of the passport, the original image, zoom guidance, rotation guidance, horizontal guidance, and vertical guidance. A null result indicates the detector was unable to locate a passport within the image.

Implements IPassportDetector.

The documentation for this class was generated from the following file:
  • PassportDetector.java


Kofax Mobile SDK API Reference: ClassificationResult Class Reference

  • kmc
  • klo
  • logistics
  • data
  • ClassificationResult
Public Member Functions | List of all members
ClassificationResult Class Reference

Results from classifying a Document using an RTTI web service. This object is serializable. More...

Inheritance diagram for ClassificationResult:

Public Member Functions

ClassificationResult (String classId, float confidence)
ClassificationResult clone ()
Performs a field-for-field copy of instances of this class. More...
float | getConfidence ()
String | getClassId ()

Detailed Description

Results from classifying a Document using an RTTI web service. This object is serializable.

The ClassificationResult object contains the results from classifying an image using an RTTI web service call which performs classification and extraction. The results can be stored as Classification alternatives in a Document object by setting the classificationAlternatives property.

ClassificationResult objects support serialization in a similar way to Image objects. The Image object documentation provides code examples for serialization and deserialization.

Constructor & Destructor Documentation

ClassificationResult | ( | String | classId,
 |  | float | confidence
 | ) |  |

The results returned from a Document classification via RTTI.

Parameters
class
confidence

Member Function Documentation

ClassificationResult clone ( )

Performs a field-for-field copy of instances of this class.

String getClassId ( )

Document classification identifier.

Returns
classification identifier.
float getConfidence ( )

Value that indicates confidence of Classification operation on a Document. Higher numbers > 0 indicate higher confidence. Numbers < 0 indicate lower confidence.

Returns
confidence value.
The documentation for this class was generated from the following file:
  • ClassificationResult.java


Kofax Mobile SDK API Reference: Document Class Reference

  • kmc
  • klo
  • logistics
  • data
  • Document
Public Member Functions | List of all members
Document Class Reference

The Document object is instantiated as a specific DocumentType. This object is serializable. More...

Inheritance diagram for Document:

Public Member Functions

Document clone ()
Performs a field-for-field copy of instances of this class. More...
Document (DocumentType documentType)
Instantiate a Document object from the specified DocumentType. More...
Document (DocumentTypeR documentTypeR)
Instantiate a Document object from the specified read-only DocumentType. More...
Document (DocumentType documentType, String documentID)
Instantiate a Document object from the specified DocumentType and ID. More...
Document (DocumentTypeR documentTypeR, String documentID)
Instantiate a Document object from the specified read-only DocumentType and ID. More...
void | addPage (Page page) throws KmcException
Adds the specified Page to this Document. More...
ErrorInfo | removePage (String pageId)
Removes the Page that matches the specified pageId from this Document. More...
String | getDocumentId ()
Return the application-defined Document ID. More...
DocumentType getDocumentType ()
Gets the DocumentType for this Document. More...
List< Field > | getFields ()
Gets the array of Field objects with values extracted from document or entered manually by user. More...
List< Page > | getPages ()
Gets the array of Page objects for this Document. More...
List< ClassificationResult > | getClassificationAlternatives ()
Gets list of ClassificationResult object alternatives, which may have been returned in an RTTI Transformation response. More...
void | setClassificationAlternatives (List< ClassificationResult > classificationAlternatives)
Sets list of ClassificationResult object alternatives, which may have been returned in an RTTI Transformation response. More...
String | getDocumentLevelError ()
Gets the Document level error contained in an RTTI web service response. More...
void | setDocumentLevelError (String documentLevelError)
Sets the Document level error returned by RTTI. More...

Detailed Description

The Document object is instantiated as a specific DocumentType. This object is serializable.

The object contains zero or more Field objects that contain the document data, and one or more Page objects that contain images.

Initialization

The Document object is the top level class of the logistics data hierarchy. It brings together the DocumentType, FieldType, Field, and Page objects and provides a vehicle for submitting case information and images to a server. An application desiring to use the SDK to submit data to a server must instantiate and populate a Document object. The Document object is instantiated with a DocumentType object, using one of the Document constructors. The DocumentType object contains an array of FieldType objects which are used to instantiate Field objects. These Field objects populate an array within the Document object.

Life Cycle

After instantiation, one or more Page objects can be added to an array maintained in the Document object. Each page object contains an array of one or more images. A method is also provided to remove pages from the Document object. Once a Document object is created with at least one page, and at least one image is included in that page, the document is ready to be sent to a server using FrontOfficeServer or TotalAgilityServer. Once the document has been successfully submitted to the server, it would normally be deleted by setting it to null. However, this should not be done until any underlying image files are deleted from the documents folder. After the object is deleted, its memory allocations are freed.

Serialization

Document objects support serialization in a similar way to Image objects. The Image object documentation provides code examples for serialization and deserialization.

Constructor & Destructor Documentation

Document ( DocumentType documentType )

Instantiate a Document object from the specified DocumentType.

A random ID is generated and used for the new Document.

Parameters
documentType : DocumentType
Document ( DocumentTypeR documentTypeR )

Instantiate a Document object from the specified read-only DocumentType.

A random ID is generated and used for the new Document.

Parameters
documentTypeR : DocumentTypeR
Document | ( | DocumentType | documentType,
 |  | String | documentID
 | ) |  |

Instantiate a Document object from the specified DocumentType and ID.

If the specified documentID string is empty, a random ID is generated and used for the new Document.

Parameters
documentType | : DocumentType
documentID | : String
Exceptions
NullPointerException (documentID parameter cannot be null).
Document | ( | DocumentTypeR | documentTypeR,
 |  | String | documentID
 | ) |  |

Instantiate a Document object from the specified read-only DocumentType and ID.

If the specified documentID string is empty, a random ID is generated and used for the new Document.

Parameters
documentTypeR | : DocumentTypeR
documentID | : String
Exceptions
NullPointerException (documentID parameter cannot be null).

Member Function Documentation

void addPage ( Page page ) throws KmcException

Adds the specified Page to this Document.

Document clone ( )

Performs a field-for-field copy of instances of this class.

List<ClassificationResult> getClassificationAlternatives ( )

Gets list of ClassificationResult object alternatives, which may have been returned in an RTTI Transformation response.

An RTTI Transformation response may include document classification results, including classification results of lower confidence. This property provides a way for the application to retrieve persisted document classification result alternatives, along with their respective confidence values.

Returns
List of ClassificationResult objects.
String getDocumentId ( )

Return the application-defined Document ID.

Returns the unique ID which identifies a particular Document. The application may invent this ID according to its own client application and back-end server architecture. Its usage in AppStats events requires this ID to be a random UUID (also known as a GUID).

Returns
documentID : String
String getDocumentLevelError ( )

Gets the Document level error contained in an RTTI web service response.

An error returned by an RTTI Transformation indicating some issue at the Document level error condition. It may indicate the Document was unconfidently classified based on the class-level classification settings. Or, there could be a server-side KTM rules failure returned in an RTTI web service response.

Returns
documentLevelError
DocumentType getDocumentType ( )

Gets the DocumentType for this Document.

Returns
DocumentType
List<Field> getFields ( )

Gets the array of Field objects with values extracted from document or entered manually by user.

Returns
List<Field>
List<Page> getPages ( )

Gets the array of Page objects for this Document.

Each Page holds one or more images.

Returns
List<Page>
ErrorInfo removePage ( String pageId )

Removes the Page that matches the specified pageId from this Document.

Parameters
pageId : String
Returns
ErrorInfo: (KMC_SUCCESS), or (KMC_LO_PAGE_NOT_FOUND). A value other than 0 indicates an error.
void setClassificationAlternatives ( List< ClassificationResult > classificationAlternatives )

Sets list of ClassificationResult object alternatives, which may have been returned in an RTTI Transformation response.

An RTTI Transformation response may include document classification results, including classification results of lower confidence. This property provides a way for the application to persist document classification result alternatives, along with their respective confidence values.

Parameters
list of classification result alternatives packaged as ClassificationResult objects.
void setDocumentLevelError ( String documentLevelError )

Sets the Document level error returned by RTTI.

Allows the application to persist errors returned by an RTTI Transformation indicating some issue at the Document level. It may indicate the Document was unconfidently classified based on the class-level classification settings. Or, there could be a server-side rules failure from KTM returned in an RTTI web service response.

Parameters
documentLevelError : String
The documentation for this class was generated from the following file:
  • Document.java


Kofax Mobile SDK API Reference: DocumentType Class Reference

  • kmc
  • klo
  • logistics
  • data
  • DocumentType
Classes | Public Member Functions | List of all members
DocumentType Class Reference

The DocumentType object is a model that describes the attributes of a document. This object is serializable. More...

Inheritance diagram for DocumentType:
DocumentTypeR

Classes

enum SourceServer
An enum that identifies the source server from which the document was obtained. More...

Public Member Functions

DocumentType clone ()
DocumentType (List< FieldType > fieldTypes)
String | getTypeName ()
Get the document type description. More...
void | setTypeName (String typeName)
Set the document type description. More...
String | getDisplayName ()
Get the human-readable document type name suitable for display in user interface controls. More...
void | setDisplayName (String displayName)
Set the human-readable document type name suitable for display in user interface controls. More...
String | getVersion ()
Get the document type version. More...
void | setVersion (String version)
Set the document type version. More...
List< FieldType > | getFieldTypes ()
Get a copy of the field types array. More...
float | getDocWidth ()
Get the width of the document in inches. This value can be used to determine the size & aspect ratio of the image capture frame. More...
void | setDocWidth (float docWidth)
Set the width of the document in inches. This value can be used to determine the size & aspect ratio of the image capture frame. More...
float | getDocHeight ()
Get the height of the document in inches. This value can be used to determine the size & aspect ratio of the image capture frame. More...
void | setDocHeight (float docHeight)
Set the height of the document in inches. This value can be used to determine the size & aspect ratio of the image capture frame. More...
ImagePerfectionProfile getImagePerfectionProfile ()
Get a reference to the image perfection profile that should be used with this document type. More...
void | setImagePerfectionProfile (ImagePerfectionProfile imagePerfectionProfile)
Set a reference to the image perfection profile that should be used with this document type. More...
BasicSettingsProfile getBasicSettingsProfile ()
Get the basic image processing settings that the designer may choose for their document, such as bit depth and DPI. More...
void | setBasicSettingsProfile (BasicSettingsProfile basicSettingsProfile)
Set the basic image processing settings that the designer may choose for their document, such as bit depth and DPI. More...
SourceServer getSourceServer ()
Get the source server from which the document was obtained. More...
void | setSourceServer (SourceServer sourceServer)
Set the source server from which the document was obtained. More...

Detailed Description

The DocumentType object is a model that describes the attributes of a document. This object is serializable.

This object can be defined at design time or obtained at run time from a server such as KFS or TotalAgility.

DocumentType objects support serialization in a similar way to Image objects. The Image object documentation provides code examples for serialization and deserialization.

Constructor & Destructor Documentation

DocumentType ( List< FieldType > fieldTypes )

This object is instantiated with an array of FieldType, which becomes the fieldTypes read-only property. Once instantiated, the fieldTypes property cannot be modified by the application.

Member Function Documentation

DocumentType clone ( )
BasicSettingsProfile getBasicSettingsProfile ( )

Get the basic image processing settings that the designer may choose for their document, such as bit depth and DPI.

Deprecated:
Deprecated in SDK 3.3.

Implements DocumentTypeR.

String getDisplayName ( )

Get the human-readable document type name suitable for display in user interface controls.

Implements DocumentTypeR.

float getDocHeight ( )

Get the height of the document in inches. This value can be used to determine the size & aspect ratio of the image capture frame.

Implements DocumentTypeR.

float getDocWidth ( )

Get the width of the document in inches. This value can be used to determine the size & aspect ratio of the image capture frame.

Implements DocumentTypeR.

List<FieldType> getFieldTypes ( )

Get a copy of the field types array.

Implements DocumentTypeR.

ImagePerfectionProfile getImagePerfectionProfile ( )

Get a reference to the image perfection profile that should be used with this document type.

Deprecated:
Deprecated in SDK 3.3.

Implements DocumentTypeR.

SourceServer getSourceServer ( )

Get the source server from which the document was obtained.

Implements DocumentTypeR.

String getTypeName ( )

Get the document type description.

Implements DocumentTypeR.

String getVersion ( )

Get the document type version.

Implements DocumentTypeR.

void setBasicSettingsProfile ( BasicSettingsProfile basicSettingsProfile )

Set the basic image processing settings that the designer may choose for their document, such as bit depth and DPI.

Deprecated:
Deprecated in SDK 3.3.
void setDisplayName ( String displayName )

Set the human-readable document type name suitable for display in user interface controls.

void setDocHeight ( float docHeight )

Set the height of the document in inches. This value can be used to determine the size & aspect ratio of the image capture frame.

void setDocWidth ( float docWidth )

Set the width of the document in inches. This value can be used to determine the size & aspect ratio of the image capture frame.

void setImagePerfectionProfile ( ImagePerfectionProfile imagePerfectionProfile )

Set a reference to the image perfection profile that should be used with this document type.

Deprecated:
Deprecated in SDK 3.3.
void setSourceServer ( SourceServer sourceServer )

Set the source server from which the document was obtained.

void setTypeName ( String typeName )

Set the document type description.

void setVersion ( String version )

Set the document type version.

The documentation for this class was generated from the following file:
  • DocumentType.java


Kofax Mobile SDK API Reference: DocumentType.SourceServer Enum Reference

  • kmc
  • klo
  • logistics
  • data
  • DocumentType
  • SourceServer
Public Attributes | List of all members
DocumentType.SourceServer Enum Reference

An enum that identifies the source server from which the document was obtained. More...

Public Attributes

SERVER_KFS
SERVER_KTA
SERVER_NONE

Detailed Description

An enum that identifies the source server from which the document was obtained.

Member Data Documentation

SERVER_KFS
SERVER_KTA
SERVER_NONE
The documentation for this enum was generated from the following file:
  • DocumentType.java


Kofax Mobile SDK API Reference: DocumentTypeR Interface Reference

  • kmc
  • klo
  • logistics
  • data
  • DocumentTypeR
Public Member Functions | List of all members
DocumentTypeR Interface Reference

The DocumentTypeR Object is a model that describes the attributes of a document. This object is serializable. More...

Inheritance diagram for DocumentTypeR:
DocumentType

Public Member Functions

String | getTypeName ()
Get the document type description. More...
String | getDisplayName ()
Get the human-readable document type name suitable for display in user interface controls. More...
String | getVersion ()
Get the document type version. More...
List< FieldType > | getFieldTypes ()
Get a copy of the field types array. More...
float | getDocWidth ()
Get the width of the document in inches. This value can be used to determine the size & aspect ratio of the image capture frame. More...
float | getDocHeight ()
Get the height of the document in inches. This value can be used to determine the size & aspect ratio of the image capture frame. More...
ImagePerfectionProfile getImagePerfectionProfile ()
Get a reference to the image perfection profile that should be used with this document type. More...
BasicSettingsProfile getBasicSettingsProfile ()
Get the basic image processing settings that the designer may choose for their document, such as bit depth and DPI. More...
SourceServer getSourceServer ()
Get the source server from which the document was obtained. More...

Detailed Description

The DocumentTypeR Object is a model that describes the attributes of a document. This object is serializable.

This object can only be obtained at run time from a server such as KFS or TotalAgility. Once obtained, it is read-only and its properties cannot be modified by the application.

Member Function Documentation

BasicSettingsProfile getBasicSettingsProfile ( )

Get the basic image processing settings that the designer may choose for their document, such as bit depth and DPI.

Deprecated:
Deprecated in SDK 3.3.

Implemented in DocumentType.

String getDisplayName ( )

Get the human-readable document type name suitable for display in user interface controls.

Implemented in DocumentType.

float getDocHeight ( )

Get the height of the document in inches. This value can be used to determine the size & aspect ratio of the image capture frame.

Implemented in DocumentType.

float getDocWidth ( )

Get the width of the document in inches. This value can be used to determine the size & aspect ratio of the image capture frame.

Implemented in DocumentType.

List<FieldType> getFieldTypes ( )

Get a copy of the field types array.

Implemented in DocumentType.

ImagePerfectionProfile getImagePerfectionProfile ( )

Get a reference to the image perfection profile that should be used with this document type.

Deprecated:
Deprecated in SDK 3.3.

Implemented in DocumentType.

SourceServer getSourceServer ( )

Get the source server from which the document was obtained.

Implemented in DocumentType.

String getTypeName ( )

Get the document type description.

Implemented in DocumentType.

String getVersion ( )

Get the document type version.

Implemented in DocumentType.

The documentation for this interface was generated from the following file:
  • DocumentTypeR.java


Kofax Mobile SDK API Reference: Field Class Reference

  • kmc
  • klo
  • logistics
  • data
  • Field
Public Member Functions | List of all members
Field Class Reference

The Field object is instantiated using a particular FieldType object and contains a value which confirms to that Field Type. This object is serializable. More...

Inheritance diagram for Field:

Public Member Functions

Field clone ()
Performs a field-for-field copy of instances of this class. More...
Field (FieldType fieldType)
The default Constructor creates an empty Field object and initializes all parameters with default values. More...
FieldType getFieldType ()
Gets the FieldType object associated with this Field. More...
String | getValue ()
Gets the value of Field Object. More...
Boolean | isValid ()
Gets the flag to determine field-level validation or field-level scripting failed. More...
String | getErrorDescription ()
Gets the error description when a field validation rule fails. More...
void | setTag (String tag)
Sets tag string to the Field Object. More...
String | getTag ()
Gets tag string from the Field Object. More...
void | updateFieldProperties (String value, boolean isValid, String errorDescription)
Sets multiple properties for the Field Object at one time. More...

Detailed Description

The Field object is instantiated using a particular FieldType object and contains a value which confirms to that Field Type. This object is serializable.

Field objects support serialization in a similar way to Image objects. The Image object documentation provides code examples for serialization and deserialization.

Constructor & Destructor Documentation

Field ( FieldType fieldType )

The default Constructor creates an empty Field object and initializes all parameters with default values.

Member Function Documentation

Field clone ( )

Performs a field-for-field copy of instances of this class.

String getErrorDescription ( )

Gets the error description when a field validation rule fails.

Return string is not empty when field validation rule fails for field-level scripting or RTTI validation.

FieldType getFieldType ( )

Gets the FieldType object associated with this Field.

This property will be filled in by the DocumentType Object.

String getTag ( )

Gets tag string from the Field Object.

String getValue ( )

Gets the value of Field Object.

Boolean isValid ( )

Gets the flag to determine field-level validation or field-level scripting failed.

void setTag ( String tag )

Sets tag string to the Field Object.

An open field for used by the application. Could be regex for example. Like a custom storage string on the field type level.

void updateFieldProperties | ( | String | value,
 |  | boolean | isValid,
 |  | String | errorDescription
 | ) |  |

Sets multiple properties for the Field Object at one time.

To ensure proper recording of AppStats events, the Field object properties are set using this single method. This method replaces individual setter methods for Value, IsValid, and ErrorDescription properties.

Parameters
value | Sets the value to the Field Object entered by the user, or extracted from an image. Must be non-null.
isValid | Sets flag to indicate if field-level validation or field-level scripting failed.
errorDescription | Sets the error description when the field validation rule fails for field-level scripting or RTTI validation. Must be non-null.
The documentation for this class was generated from the following file:
  • kmc/klo/logistics/data/Field.java


Kofax Mobile SDK API Reference: FieldType Class Reference

  • kmc
  • klo
  • logistics
  • data
  • FieldType
Classes | Public Member Functions | List of all members
FieldType Class Reference

The FieldType Object is a model that describes the attributes of a field. This object is serializable. More...

Inheritance diagram for FieldType:

Classes

enum DataType
An enum that defines the data type specified for this Field Type. More...

Public Member Functions

FieldType clone ()
Performs a field-for-field copy of instances of this class. More...
FieldType ()
The default Constructor creates an empty FieldType object and initializes all parameters with default values. More...
void | setName (String name)
Sets FieldType name. More...
String | getName ()
Gets FieldType name. More...
void | setDisplayName (String displayName)
Sets FieldType display name. More...
String | getDisplayName ()
Gets FieldType display name. More...
void | setLabel (String label)
Sets displayable label for the FieldType. More...
String | getLabel ()
Gets displayable label of the FieldType. More...
void | setRequired (Boolean isRequired)
Sets required flag for the FieldType to indicate if the value must be entered for associated Field object. More...
boolean | isRequired ()
Gets required flag of the FieldType. More...
void | setDataType (DataType dataType)
Sets data type for FieldType. More...
DataType getDataType ()
Gets data type of FieldType. More...
void | setHidden (Boolean isHidden)
Sets the hidden flag in FieldType to define weather the associated Field should be visible to user. More...
boolean | isHidden ()
Gets the hidden flag of FieldType. More...
void | setReadOnly (Boolean isReadOnly)
Sets the readonly flag in FieldType to define weather the associated Field is updatable by the user. More...
boolean | isReadOnly ()
Gets the readonly flag of FieldType. More...
void | setOptions (String[] options)
Sets the values associated with a choice list for the respective Field Object. More...
String[] | getOptions ()
Gets the values associated with a choice list for the respective Field Object. More...
void | setForceMatch (Boolean isForceMatch)
Sets the forcematch flag to specify if the user is limited to choices in the options choice list, or the other values are valid. More...
boolean | isForceMatch ()
Gets the forcematch flag to determine if the user is limited to choices in the options choice list, or the other values are valid. More...
void | setMin (String min)
Sets minimum value for the index Field. More...
String | getMin ()
Gets minimum value of the index Field. More...
void | setMax (String max)
Sets maximum value for the index Field. More...
String | getMax ()
Gets maximum value of the index Field. More...
void | setDefault (String def)
Sets default value for the associated Field Object. More...
String | getDefault ()
Gets default value of the associated Field Object. More...
void | setCustomTag (String customTag)
Sets value of the custom tag for the FieldType. Its an open field for use by the application. More...
String | getCustomTag ()
Gets value of the custom tag of the FieldType. Its an open field for use by the application. More...

Detailed Description

The FieldType Object is a model that describes the attributes of a field. This object is serializable.

An array of FieldType gets instantiated with the DocumentType Object.

FieldType objects support serialization in a similar way to Image objects. The Image object documentation provides code examples for serialization and deserialization.

Constructor & Destructor Documentation

FieldType ( )

The default Constructor creates an empty FieldType object and initializes all parameters with default values.

Member Function Documentation

FieldType clone ( )

Performs a field-for-field copy of instances of this class.

String getCustomTag ( )

Gets value of the custom tag of the FieldType. Its an open field for use by the application.

DataType getDataType ( )

Gets data type of FieldType.

String getDefault ( )

Gets default value of the associated Field Object.

String getDisplayName ( )

Gets FieldType display name.

String getLabel ( )

Gets displayable label of the FieldType.

String getMax ( )

Gets maximum value of the index Field.

String getMin ( )

Gets minimum value of the index Field.

String getName ( )

Gets FieldType name.

String [] getOptions ( )

Gets the values associated with a choice list for the respective Field Object.

boolean isForceMatch ( )

Gets the forcematch flag to determine if the user is limited to choices in the options choice list, or the other values are valid.

boolean isHidden ( )

Gets the hidden flag of FieldType.

boolean isReadOnly ( )

Gets the readonly flag of FieldType.

boolean isRequired ( )

Gets required flag of the FieldType.

void setCustomTag ( String customTag )

Sets value of the custom tag for the FieldType. Its an open field for use by the application.

void setDataType ( DataType dataType )

Sets data type for FieldType.

void setDefault ( String def )

Sets default value for the associated Field Object.

void setDisplayName ( String displayName )

Sets FieldType display name.

void setForceMatch ( Boolean isForceMatch )

Sets the forcematch flag to specify if the user is limited to choices in the options choice list, or the other values are valid.

void setHidden ( Boolean isHidden )

Sets the hidden flag in FieldType to define weather the associated Field should be visible to user.

void setLabel ( String label )

Sets displayable label for the FieldType.

void setMax ( String max )

Sets maximum value for the index Field.

For string: specifies the maximum length. For int and float: specifies the maximum allowed value. Value can be negative. For date: specifies the newest allowed date.

void setMin ( String min )

Sets minimum value for the index Field.

For string: specifies the minimum length. For int and float: specifies the minimum allowed value. Value can be negative. For date: specifies the oldest allowed date.

void setName ( String name )

Sets FieldType name.

void setOptions ( String[] options )

Sets the values associated with a choice list for the respective Field Object.

void setReadOnly ( Boolean isReadOnly )

Sets the readonly flag in FieldType to define weather the associated Field is updatable by the user.

void setRequired ( Boolean isRequired )

Sets required flag for the FieldType to indicate if the value must be entered for associated Field object.

The documentation for this class was generated from the following file:
  • FieldType.java


Kofax Mobile SDK API Reference: FieldType.DataType Enum Reference

  • kmc
  • klo
  • logistics
  • data
  • FieldType
  • DataType
Public Attributes | List of all members
FieldType.DataType Enum Reference

An enum that defines the data type specified for this Field Type. More...

Public Attributes

STRING
INT
FLOAT
BOOL
DATE
EMAIL
URL

Detailed Description

An enum that defines the data type specified for this Field Type.

Member Data Documentation

BOOL
DATE
EMAIL
FLOAT
INT
STRING
URL
The documentation for this enum was generated from the following file:
  • FieldType.java


Kofax Mobile SDK API Reference: Page Class Reference

  • kmc
  • klo
  • logistics
  • data
  • Page
Classes | Public Member Functions | Protected Member Functions | List of all members
Page Class Reference

There can be one or more Pages in a Document. This object is serializable. More...

Inheritance diagram for Page:

Classes

enum Side
Indicates whether this Page is front or back of the sheet. More...

Public Member Functions

Page ()
List< Image > | getImages ()
Array of image objects associated with the Page. More...
String | getPageID ()
Unique GUID identifying the page. Generated as part of object initialization. More...
String | getDocumentID ()
Unique Document identifier which contains this Page. Generated at the time this Page is added to a Document. More...
void | addImage (Image image)
Adds Image Object to images array property. More...
ErrorInfo | removeImage (String imageID)
Removes Image Object from images array property. More...
int | getSheetID ()
Unique ID identifying the sheet. Allows two pages that are part of a sheet to be identified. More...
void | setSheetID (int sheetID)
Unique ID identifying the sheet. Allows two pages that are part of a sheet to be identified. More...
int | getCurrentImageIndex ()
Indicates the current image of several images associated with a page. More...
void | setCurrentImageIndex (int currentImageIndex)
Specifies the current image of several images associated with a page. More...
void | setSide (Side pageSide)
Set page side as Front or Back. More...
Side getSide ()

Protected Member Functions

void setDocumentID (String documentID)

Detailed Description

There can be one or more Pages in a Document. This object is serializable.

Each Page can contain one or more Image objects. Each Page also has a Side associated with it. In order to add/remove the Images from a Page, use add/remove methods. When a Page object is instantiated a unique page id is generated.

Page objects support serialization in a similar way to Image objects. The Image object documentation provides code examples for serialization and deserialization.

Constructor & Destructor Documentation

Page ( )

Member Function Documentation

void addImage ( Image image )

Adds Image Object to images array property.

This method adds an image object to the 'images' array property. After the image is added, the currentImageIndex is updated to indicate that the most recent image is current.

Parameters
image to add.
Exceptions
IllegalArgumentException (image parameter is null).
int getCurrentImageIndex ( )

Indicates the current image of several images associated with a page.

Indicates the image index for the page from which the extraction is associated. It is especially useful for a multipage document. When an image is added using the 'addImage' method, this variable is automatically set to the index of the added image.

String getDocumentID ( )

Unique Document identifier which contains this Page. Generated at the time this Page is added to a Document.

Returns the unique ID which identifies a particular Document. The application may invent this ID according to its own client application and back-end server architecture. Its usage in AppStats events requires this ID to be a random UUID (also known as a GUID). The DocumentID property provides a way of linking each Page object to its parent Document object.

Returns
documentID
List<Image> getImages ( )

Array of image objects associated with the Page.

String getPageID ( )

Unique GUID identifying the page. Generated as part of object initialization.

int getSheetID ( )

Unique ID identifying the sheet. Allows two pages that are part of a sheet to be identified.

Side getSide ( )
ErrorInfo removeImage ( String imageID )

Removes Image Object from images array property.

Removes the image object from the page. The image to be removed is determined by matching the supplied imageID string to the contents of the images in the array. If the current image is removed, the currentImageIndex is set to 0. Otherwise, the currentImageIndex refers to the same image.

Parameters
imageID the id of the image to remove.
Returns
ErrorInfo: KMC_SUCCESS, or KMC_LO_IMAGE_NOT_FOUND.
void setCurrentImageIndex ( int currentImageIndex )

Specifies the current image of several images associated with a page.

Specifies the image index for the page from which the extraction is associated. It is especially useful for a multipage document.

void setDocumentID ( String documentID )
protected
void setSheetID ( int sheetID )

Unique ID identifying the sheet. Allows two pages that are part of a sheet to be identified.

void setSide ( Side pageSide )

Set page side as Front or Back.

The documentation for this class was generated from the following file:
  • Page.java


Kofax Mobile SDK API Reference: Page.Side Enum Reference

  • kmc
  • klo
  • logistics
  • data
  • Page
  • Side
Public Attributes | List of all members
Page.Side Enum Reference

Indicates whether this Page is front or back of the sheet. More...

Public Attributes

FRONT
BACK

Detailed Description

Indicates whether this Page is front or back of the sheet.

Member Data Documentation

BACK
FRONT
The documentation for this enum was generated from the following file:
  • Page.java


Kofax Mobile SDK API Reference: UserProfile Class Reference

  • kmc
  • klo
  • logistics
  • data
  • UserProfile
Public Member Functions | List of all members
UserProfile Class Reference

The UserProfile Object contains login credentials for a user. More...

Inheritance diagram for UserProfile:

Public Member Functions

UserProfile clone ()
String | getUsername ()
Get the user login name. More...
void | setUsername (String username)
Set the user login name. More...
String | getPassword ()
Get the user login password. More...
void | setPassword (String password)
Set the user login password. More...
String | getDomain ()
Get the user login domain. More...
void | setDomain (String domain)
Set the user login domain. More...
String | getUserEmailAddress ()
Get the user email address. More...
void | setUserEmailAddress (String userEmailAddress)
Set the user email address. More...

Detailed Description

The UserProfile Object contains login credentials for a user.

Use this object to login to either a Kofax Front Office Server (KFS), or a Kofax TotalAgility Server (TA) using the respective SDK Logistics Objects: FrontOfficeServer Object and TotalAgilityServer Object.

Member Function Documentation

UserProfile clone ( )
String getDomain ( )

Get the user login domain.

The domain string set by the user.

Returns
domain address
String getPassword ( )

Get the user login password.

The password is returned in the same form as it was set by the user.

Returns
password
String getUserEmailAddress ( )

Get the user email address.

This is the email address of the user as specified.

Returns
email adress
String getUsername ( )

Get the user login name.

String that represents the user name used to login to server.

void setDomain ( String domain )

Set the user login domain.

String that represents the domain of the server.

Exceptions
NullPointerException (domain parameter is null).
void setPassword ( String password )

Set the user login password.

String that represents the password

Exceptions
NullPointerException (password parameter is null).
void setUserEmailAddress ( String userEmailAddress )

Set the user email address.

String that represents the email address.

Exceptions
NullPointerException (email address parameter is null).
void setUsername ( String username )

Set the user login name.

String that represents the user name

Exceptions
NullPointerException (name parameter is null).
The documentation for this class was generated from the following file:
  • UserProfile.java


Kofax Mobile SDK API Reference: KloVersion Class Reference

  • kmc
  • klo
  • logistics
  • version
  • KloVersion
Static Public Member Functions | List of all members
KloVersion Class Reference

Static Public Member Functions

static String getPackageVersion ()

Detailed Description

This class provides a means of retrieving the version string for the Logistics package of the Kofax Mobile SDK.

Member Function Documentation

static String getPackageVersion ( )
static
Returns
The version string for the Logistics package of the Mobile SDK.
The documentation for this class was generated from the following file:
  • KloVersion.java


Kofax Mobile SDK API Reference: KLOLogging Class Reference

  • kmc
  • klo
  • logistics
  • KLOLogging
Static Public Member Functions | List of all members
KLOLogging Class Reference

Static Public Member Functions

static void enableConsoleLogging (boolean enable)

Detailed Description

Enable or disable console logging for KLO package classes.

See also
Logging

Member Function Documentation

static void enableConsoleLogging ( boolean enable )
static

Enables Klo package console logging. Pass true to turn on library logging, and false otherwise. Disabled by default.

Parameters
enable
The documentation for this class was generated from the following file:
  • KLOLogging.java


Kofax Mobile SDK API Reference: SessionState Enum Reference

  • kmc
  • klo
  • logistics
  • SessionState
Public Member Functions | Public Attributes | List of all members
SessionState Enum Reference

An enum which contains various FrontOfficeServer and TotalAgility session state information. More...

Public Member Functions

SessionState (StateID stateID)
ErrorInfo | isReachable (TaskType task, StateID parentState)
SessionState | getNextState (TaskType task, StateID parentState)
SessionState | getErrorState (TaskType task, StateID parentState)

Public Attributes

SESSION_UNREGISTERED =(StateID.STATE_UNREGISTERED)
SESSION_REGISTERING =(StateID.STATE_REGISTERING)
SESSION_REGISTERED =(StateID.STATE_REGISTERED)
SESSION_LOGGING_IN =(StateID.STATE_LOGGING_IN)
SESSION_LOGGED_IN =(StateID.STATE_LOGGED_IN)
SESSION_GETTING_DOCUMENT_FIELDS =(StateID.STATE_GETTING_DOCUMENT_FIELDS)
SESSION_GETTING_IP_SETTINGS =(StateID.STATE_GETTING_IP_SETTINGS)
SESSION_PREPARING_DOCUMENT_TYPE =(StateID.STATE_PREPARING_DOCUMENT_TYPE)
SESSION_DOCUMENT_TYPE_READY =(StateID.STATE_DOCUMENT_TYPE_READY)
SESSION_SUBMITTING =(StateID.STATE_SUBMITTING)
SESSION_SUBMIT_COMPLETED =(StateID.STATE_SUBMIT_COMPLETED)
SESSION_LOGGING_OUT =(StateID.STATE_LOGGING_OUT)
StateID stateID

Detailed Description

An enum which contains various FrontOfficeServer and TotalAgility session state information.

Constructor & Destructor Documentation

SessionState ( StateID stateID )

Member Function Documentation

SessionState getErrorState | ( | TaskType | task,
 |  | StateID | parentState
 | ) |  |
SessionState getNextState | ( | TaskType | task,
 |  | StateID | parentState
 | ) |  |
ErrorInfo isReachable | ( | TaskType | task,
 |  | StateID | parentState
 | ) |  |

Member Data Documentation

SESSION_DOCUMENT_TYPE_READY =(StateID.STATE_DOCUMENT_TYPE_READY)
SESSION_GETTING_DOCUMENT_FIELDS =(StateID.STATE_GETTING_DOCUMENT_FIELDS)
SESSION_GETTING_IP_SETTINGS =(StateID.STATE_GETTING_IP_SETTINGS)
SESSION_LOGGED_IN =(StateID.STATE_LOGGED_IN)
SESSION_LOGGING_IN =(StateID.STATE_LOGGING_IN)
SESSION_LOGGING_OUT =(StateID.STATE_LOGGING_OUT)
SESSION_PREPARING_DOCUMENT_TYPE =(StateID.STATE_PREPARING_DOCUMENT_TYPE)
SESSION_REGISTERED =(StateID.STATE_REGISTERED)
SESSION_REGISTERING =(StateID.STATE_REGISTERING)
SESSION_SUBMIT_COMPLETED =(StateID.STATE_SUBMIT_COMPLETED)
SESSION_SUBMITTING =(StateID.STATE_SUBMITTING)
SESSION_UNREGISTERED =(StateID.STATE_UNREGISTERED)
StateID stateID
The documentation for this enum was generated from the following file:
  • SessionState.java


Kofax Mobile SDK API Reference: CaptureExperience Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • CaptureExperience
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CaptureExperience Class Referenceabstract

This class is a base class for the DocumentCaptureExperience and CheckCaptureExperience, PassportCaptureExperience and FixedAspectRatioCaptureExperience. More...

Inheritance diagram for CaptureExperience:
StabilityDelayListener LevelnessListener AutoFocusResultListener ImageCapturedListener DocumentBaseCaptureExperience CheckCaptureExperience DocumentCaptureExperience FixedAspectRatioCaptureExperience PassportCaptureExperience

Public Member Functions

void | addOnImageCapturedListener (ImageCapturedListener listener)
void | removeOnImageCapturedListener (ImageCapturedListener listener)
void | setVibrationEnabled (boolean enable)
boolean | isVibrationEnabled ()
void | takePicture ()
void | takePictureContinually ()
void | stopCapture ()
void | onImageCaptured (ImageCapturedEvent event)
Invoked when the camera captures an image. More...
void | onAutoFocus (AutoFocusResultEvent event)
Invoked when the camera completes focusing. More...
void | onLevelness (LevelnessEvent event)
Invoked when the orientation of the device changes. More...
void | onStabilityDelay (StabilityDelayEvent event)
Invoked when stability levels change. More...
void | destroy ()

Protected Member Functions

void | invokeImageCapturedListeners (ImageCapturedEvent event)
boolean | captureCriteriaMetInternal (CaptureExperienceData data)

Protected Attributes

CaptureExperienceData | _captureExperienceData = new CaptureExperienceData()
final Object | _lock
boolean | _sdkCaptureRequested
boolean | _continuousCapture
ImageCaptureView _imageCaptureView
final Handler | _uiHandler = new Handler(Looper.getMainLooper())
float | _aspectRatio
Set< ImageCapturedListener > | _imageCapturedListeners = new LinkedHashSet<ImageCapturedListener>()
Vibrator | _vibrator
boolean | _vibrationEnabled = false

Detailed Description

This class is a base class for the DocumentCaptureExperience and CheckCaptureExperience, PassportCaptureExperience and FixedAspectRatioCaptureExperience.

This class is responsible for capturing documents once the given criteria are met

Member Function Documentation

void addOnImageCapturedListener ( ImageCapturedListener listener )

Invoked after the camera captures an image and when all capture messages were shown. To allow for every message to be played, this method should be used to set an ImageCapturedListener instead of the method on the ImageCaptureView class.

Parameters
listener The image captured listener
See also
ImageCapturedListener
boolean captureCriteriaMetInternal ( CaptureExperienceData data )
protected
void destroy ( )

Detaches from the ImageCaptureView and destroys this experience.

void invokeImageCapturedListeners ( ImageCapturedEvent event )
protected
boolean isVibrationEnabled ( )
Returns
Whether vibration availability during capturing
void onAutoFocus ( AutoFocusResultEvent event )

Invoked when the camera completes focusing.

Implements AutoFocusResultListener.

void onImageCaptured ( ImageCapturedEvent event )

Invoked when the camera captures an image.

Implements ImageCapturedListener.

void onLevelness ( LevelnessEvent event )

Invoked when the orientation of the device changes.

Implements LevelnessListener.

void onStabilityDelay ( StabilityDelayEvent event )

Invoked when stability levels change.

Implements StabilityDelayListener.

void removeOnImageCapturedListener ( ImageCapturedListener listener )

Remove ImageCapturedListener.

Parameters
listener The image captured listener
See also
ImageCapturedListener
addOnImageCapturedListener(ImageCapturedListener)
void setVibrationEnabled ( boolean enable )

Method to manage vibration availability during capturing.

Parameters
enable Whether to vibrate during capture
void stopCapture ( )

This is the counterpart to takePicture() and takePictureContinually(). Calling this method will stop automatic image capture when the criteria are satisfied.

See also
takePicture()
takePictureContinually()
void takePicture ( )

Calling this method will start the process of monitoring the capture criteria that was configured to determine when a document that meets all the criteria can be captured. The static frame will change its color to green to indicate that a document will be captured soon.

void takePictureContinually ( )

Calling this method will start the continuous capture of images. Images will automatically be captured when criteria are satisfied.

Member Data Documentation

float _aspectRatio
protected
CaptureExperienceData _captureExperienceData = new CaptureExperienceData()
protected
boolean _continuousCapture
protected
Set<ImageCapturedListener> _imageCapturedListeners = new LinkedHashSet<ImageCapturedListener>()
protected
ImageCaptureView _imageCaptureView
protected
final Object _lock
protected
boolean _sdkCaptureRequested
protected
final Handler _uiHandler = new Handler(Looper.getMainLooper())
protected
boolean _vibrationEnabled = false
protected
Vibrator _vibrator
protected
The documentation for this class was generated from the following file:
  • CaptureExperience.java


Kofax Mobile SDK API Reference: CaptureExperienceCriteriaHolder Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • CaptureExperienceCriteriaHolder
Public Member Functions | List of all members
CaptureExperienceCriteriaHolder Class Reference
Inheritance diagram for CaptureExperienceCriteriaHolder:
DocumentBaseCaptureExperienceCriteriaHolder CheckCaptureExperienceCriteriaHolder DocumentCaptureExperienceCriteriaHolder FixedAspectRatioExperienceCriteriaHolder PassportCaptureExperienceCriteriaHolder

Public Member Functions

CaptureExperienceCriteriaHolder ()
boolean | isStabilityThresholdEnabled ()
void | setStabilityThresholdEnabled (boolean stabilityThresholdEnabled)
int | getStabilityThreshold ()
void | setStabilityThreshold (int stabilityThreshold)
boolean | isPitchThresholdEnabled ()
void | setPitchThresholdEnabled (boolean pitchThresholdEnabled)
int | getPitchThreshold ()
void | setPitchThreshold (int pitchThreshold)
boolean | isRollThresholdEnabled ()
void | setRollThresholdEnabled (boolean rollThresholdEnabled)
int | getRollThreshold ()
void | setRollThreshold (int rollThreshold)
boolean | isFocusEnabled ()
void | setFocusEnabled (boolean focusEnabled)
boolean | isOrientationEnabled ()
void | setOrientationEnabled (boolean enabled)
void | setRefocusEnabled (boolean enabled)
boolean | isRefocusBeforeCaptureEnabled ()

Detailed Description

This class allows all of the capture related parameters to be configured. The criteria are met before a picture is taken. The threshold parameters in this class are not set on the image capture view directly.

Constructor & Destructor Documentation

CaptureExperienceCriteriaHolder ( )

Member Function Documentation

int getPitchThreshold ( )

Valid values are in the range [0, 45]. The default value is 15. A value of 45 disables level checking for pitch even if pitch threshold is enabled

Returns
int The pitch threshold value which needs to be met before taking a picture
See also
setPitchThreshold(int)
setPitchThresholdEnabled(boolean)
isPitchThresholdEnabled()
int getRollThreshold ( )

Valid values are in the range [0, 45]. The default value is 15. A value of 45 disables level checking for roll.

Returns
int The roll threshold value which needs to be met before taking a picture
See also
setRollThreshold(int)
setRollThresholdEnabled(boolean)
isRollThresholdEnabled()
int getStabilityThreshold ( )

If enabled the stability threshold is checked before taking a picture. The default value is 15.

Returns
The stability value which needs to be met before taking a picture
See also
setStabilityThreshold(int)
setStabilityThresholdEnabled(boolean)
isStabilityThresholdEnabled()
boolean isFocusEnabled ( )
Returns
boolean Whether the Focus constraint is enabled or not. The default value is true.
See also
setFocusEnabled(boolean)
boolean isOrientationEnabled ( )

Checks if orientation constraint is enabled.

Returns
Whether the orientation constraint is enabled or not.
See also
setOrientationEnabled(boolean)
boolean isPitchThresholdEnabled ( )
Returns
boolean Whether the pitch threshold is enabled or not
See also
setPitchThresholdEnabled(boolean)
setPitchThreshold(int)
getPitchThreshold()
boolean isRefocusBeforeCaptureEnabled ( )

Checks if refocusing is made before taking a picture. This indicates whether the camera needs to be refocused just before taking a picture when all other capture criteria are met. Default: true

Returns
Whether to refocus before taking a picture or not.
See also
setRefocusEnabled(boolean)
boolean isRollThresholdEnabled ( )
Returns
boolean Whether the Roll threshold is enabled or not. Default is enabled.
See also
setRollThresholdEnabled(boolean)
setRollThreshold(int)
getRollThreshold()
boolean isStabilityThresholdEnabled ( )
Returns
boolean Whether the stability threshold is enabled or not. Default is enabled.
See also
setStabilityThresholdEnabled(boolean)
setStabilityThreshold(int)
getStabilityThreshold()
void setFocusEnabled ( boolean focusEnabled )

A boolean that indicates whether the Focus constraint is enabled. If enabled, this criterion is checked before taking a picture. The default value is true. Leaving it enabled is advisable. Otherwise it is highly likely that out of focus images are captured.

Parameters
focusEnabled Whether the Focus constraint is enabled or not
See also
isFocusEnabled()
void setOrientationEnabled ( boolean enabled )

Enables or disables orientation constraint.

This constraint checks that the orientation of the document matches the orientation of the target frame.

Enabled by default.

Parameters
enabled true to enable and false to disable.
See also
isOrientationEnabled()
void setPitchThreshold ( int pitchThreshold )

If the pitch threshold constraint is enabled, and the device pitch is greater than the specified threshold, a picture will not be taken. Valid values are in the range [0, 45]. Values outside this range will throw KmcRuntimeException. The default value is 15. A value of 45 disables level checking for pitch.

Parameters
pitchThreshold The pitch threshold value which needs to be met before taking a picture
Exceptions
KmcRuntimeException
See also
setPitchThresholdEnabled(boolean)
getPitchThreshold()
isPitchThresholdEnabled()
void setPitchThresholdEnabled ( boolean pitchThresholdEnabled )

A boolean that specifies whether the level threshold for pitch enabled. If enabled, this criterion is checked before taking a picture. Default is enabled.

Parameters
pitchThresholdEnabled Whether the pitch threshold is enabled or not
See also
isPitchThresholdEnabled()
setPitchThreshold(int)
getPitchThreshold()
void setRefocusEnabled ( boolean enabled )

Enables or disables refocusing before taking a picture. This indicates whether the camera needs to be refocused just before taking a picture when all other capture criteria are met. Default: true

Parameters
enabled Whether to refocus before taking a picture or not.
See also
isRefocusBeforeCaptureEnabled()
void setRollThreshold ( int rollThreshold )

If the roll threshold constraint is enabled, and the device roll is greater than the specified threshold, a picture will not be taken. Valid values are in the range [0, 45]. Values outside this range will throw KmcRuntimeException. The default value is 15. A value of 45 disables level checking for roll.

Parameters
rollThreshold The level threshold value for roll which needs to be met before taking a picture
Exceptions
KmcRuntimeException
See also
getRollThreshold()
setRollThresholdEnabled(boolean)
isRollThresholdEnabled()
void setRollThresholdEnabled ( boolean rollThresholdEnabled )

A boolean that specifies whether the level threshold for roll is enabled. If enabled, this criterion is checked before taking a picture. Default is enabled.

Parameters
rollThresholdEnabled Whether the Roll threshold is enabled or not
See also
isRollThresholdEnabled()
setRollThreshold(int)
getRollThreshold()
void setStabilityThreshold ( int stabilityThreshold )

If the stability threshold constraint is enabled, and the device stability is less than the specified threshold, a picture will not be taken. Valid values are in the range [0, 100], where 100 indicates that the device must be perfectly still to take a picture and 0 indicates that stability checking is turned off. Values outside this range will throw KmcRuntimeException. The default value is 15.

Parameters
stabilityThreshold The stability value which needs to be met before taking a picture
Exceptions
KmcRuntimeException
See also
setStabilityThresholdEnabled(boolean)
isStabilityThresholdEnabled()
getStabilityThreshold()
void setStabilityThresholdEnabled ( boolean stabilityThresholdEnabled )

A boolean that specifies whether the stability threshold is enabled. If enabled, this criterion is checked before taking a picture. Default is enabled.

Parameters
stabilityThresholdEnabled Whether the stability threshold is enabled or not
See also
isStabilityThresholdEnabled()
setStabilityThreshold(int)
getStabilityThreshold()
The documentation for this class was generated from the following file:
  • CaptureExperienceCriteriaHolder.java


Kofax Mobile SDK API Reference: CaptureMessage Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • CaptureMessage
Classes | Public Member Functions | List of all members
CaptureMessage Class Reference

Classes

enum KUIMessageOrientation

Public Member Functions

CaptureMessage ()
int | getTextColor ()
void | setTextColor (int textColor)
int | getBackgroundColor ()
void | setBackgroundColor (int backgroundColor)
Drawable | getBackground ()
void | setBackground (Drawable background)
int | getPosX ()
void | setPosX (int posX)
int | getPosY ()
void | setPosY (int posY)
int | getWidth ()
void | setWidth (int width)
int | getHeight ()
void | setHeight (int height)
int | getTextSize ()
void | setTextSize (int textSize)
Typeface | getTypeface ()
void | setTypeface (Typeface typeface)
String | getMessage ()
void | setMessage (String message)
Sets the text of this message. More...
boolean | getVisibility ()
void | setVisibility (boolean visibility)
void | setOrientation (KUIMessageOrientation orientation)
KUIMessageOrientation getOrientation ()
void | setMessageIcons (Bitmap[] messageIcons)
Bitmap[] | getMessageIcons ()

Detailed Description

This class is responsible for rendering the messages on the Image Capture View. It allows the attributes of the messages to be configured and hence enhance the visual feedback to the user

Constructor & Destructor Documentation

CaptureMessage ( )

Member Function Documentation

Drawable getBackground ( )
Returns
Drawable The background Drawable behind the displayed text
See also
setBackground(Drawable)
int getBackgroundColor ( )
Returns
int The background Color of the message
See also
setBackgroundColor(int)
int getHeight ( )
Returns
int The height of the message box text
See also
setHeight(int)
String getMessage ( )
Returns
String The message
See also
setMessage(String)
Bitmap [] getMessageIcons ( )
Returns
Bitmap[] The array of images used to display an animation
See also
setMessageIcons
KUIMessageOrientation getOrientation ( )
Returns
KUIMessageOrientation The orientation of the message displayed
See also
setOrientation(KUIMessageOrientation)
int getPosX ( )
Returns
int The x position of the message
See also
setPosX(int)
int getPosY ( )
Returns
int The Y position of the message
See also
setPosY(int)
int getTextColor ( )
Returns
int The Color that the message text will be rendered with
See also
setTextColor(int)
int getTextSize ( )
Returns
int The text font size
See also
setTextSize(int)
Typeface getTypeface ( )
Returns
Typeface The text typeface
See also
setTypeface(Typeface)
boolean getVisibility ( )
Returns
boolean The message visibility
See also
setVisibility(boolean)
int getWidth ( )
Returns
int The width of the message box text
See also
setWidth(int)
void setBackground ( Drawable background )
Parameters
background The background Drawable behind the displayed text
void setBackgroundColor ( int backgroundColor )

All color values are valid. The default background is transparent.

Parameters
backgroundColor The background Color of the message
void setHeight ( int height )

Text will be contained within this boundary, and any set background color will completely cover this area. The default (-1) causes the message text height to be determined as the SDK sees fit.

Parameters
height The height of the message box text
void setMessage ( String message )

Sets the text of this message.

The default value is null (no text).

void setMessageIcons ( Bitmap[] messageIcons )

Specifies an array of images used to display an animation in additional to the text message. The animation is a repeating sequence of images. By default, this is an empty array and no animation will be displayed.

Parameters
messageIcons The array of images used to display an animation
void setOrientation ( KUIMessageOrientation orientation )

Once the orientation is set for messages, they stay in that mode even if the device rotates. By default, UserInstructionMessage, NoDocumentFoundMessage, and ZoomInMessage default to landscape. PageOrientationMessage defaults to portrait.

Parameters
orientation The orientation of the message displayed.
void setPosX ( int posX )

The message object will be displayed on top of an Image Capture View with the left of the message being located at this coordinate. Changes in the size of the capture control will usually require updating the position of the message as well. The default value (-1) causes the message to be positioned as the SDK sees fit.

Parameters
posX The x position of the message
void setPosY ( int posY )

The message object will be displayed on top of an Image Capture View with the top of the message being located at this coordinate. Changes in the size of the capture control will usually require updating the position of the message as well. The default value (-1) causes the message to be positioned as the SDK sees fit.

Parameters
posY The Y position of the message
void setTextColor ( int textColor )

All color values are valid. The default color is white.

Parameters
textColor The Color that the message text will be rendered with
void setTextSize ( int textSize )

The default is -1, which causes the message text font size to be determined as the SDK sees fit.

Parameters
textSize The text font size
void setTypeface ( Typeface typeface )

The default is null, which causes the message text typeface to be determined as the SDK sees fit.

Parameters
typeface The text typeface
void setVisibility ( boolean visibility )

A value of true will show the message, if there is nothing else to prevent it from appearing. A value of false will prevent the message from appearing. The default value is true. Some objects that use messages, like the capture experience objects, will automatically manage and update this state.

Parameters
visibility The message visibility
void setWidth ( int width )

Text will be contained within this boundary, and any set background color will completely fill this area. The default (-1) causes the message text width to be determined as the SDK sees fit.

Parameters
width The width of the message box
The documentation for this class was generated from the following file:
  • CaptureMessage.java


Kofax Mobile SDK API Reference: CaptureMessage.KUIMessageOrientation Enum Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • CaptureMessage
  • KUIMessageOrientation
Public Attributes | List of all members
CaptureMessage.KUIMessageOrientation Enum Reference

Public Attributes

PORTRAIT
LANDSCAPE
REVERSEPORTRAIT
REVERSELANDSCAPE
UNKNOWN

Detailed Description

Use setOrientation(KUIMessageOrientation) with one of the values of this enumeration to set the orientation of the messages being displayed. Once a mode is set, they stay in that orientation even if the device rotates.

Member Data Documentation

LANDSCAPE
PORTRAIT
REVERSELANDSCAPE
REVERSEPORTRAIT
UNKNOWN
The documentation for this enum was generated from the following file:
  • CaptureMessage.java


Kofax Mobile SDK API Reference: CheckCaptureExperience Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • CheckCaptureExperience
Public Member Functions | List of all members
CheckCaptureExperience Class Reference
Inheritance diagram for CheckCaptureExperience:
DocumentBaseCaptureExperience CaptureExperience StabilityDelayListener LevelnessListener AutoFocusResultListener ImageCapturedListener

Public Member Functions

CheckCaptureExperience (ImageCaptureView view)
CheckCaptureExperience (ImageCaptureView view, CheckCaptureExperienceCriteriaHolder criteria)
CaptureMessage getUserInstructionMessage ()
void | setUserInstructionMessage (CaptureMessage userInstructionsMessage)
CaptureMessage getCenterMessage ()
void | setCenterMessage (CaptureMessage centerMessage)
Bitmap | getCheckSampleImage ()
void | setCheckSampleImage (Bitmap checkSampleImage)
void | setCaptureCriteria (CheckCaptureExperienceCriteriaHolder criteria)
CheckCaptureExperienceCriteriaHolder getCaptureCriteria ()
- Public Member Functions inherited from DocumentBaseCaptureExperience
DocumentBaseCaptureExperience (ImageCaptureView view, DocumentBaseCaptureExperienceCriteriaHolder criteria)
final void | addOnImageCapturedListener (ImageCapturedListener listener)
final void | removeOnImageCapturedListener (ImageCapturedListener listener)
final void | setVibrationEnabled (boolean enable)
Manage vibration after an image is captured. More...
boolean | isVibrationEnabled ()
final void | setDiagnosticsViewEnabled (boolean enabled)
boolean | isDiagnosticsViewEnabled ()
void | takePicture ()
void | takePictureContinually ()
void | stopCapture ()
void | destroy ()
void | enableAnimationTutor (boolean enable)
Sets whether or not to show an animated tutorial about how to capture a document. More...
boolean | isAnimationTutorEnable ()
CaptureMessage getUserInstructionMessage ()
void | setUserInstructionMessage (CaptureMessage userInstructionsMessage)
CaptureMessage getTutorialDismissMessage ()
void | setTutorialDismissMessage (CaptureMessage tutorialDismissMessage)
CaptureMessage getHoldSteadyMessage ()
void | setHoldSteadyMessage (CaptureMessage holdSteadyMessage)
void | setCenterMessage (CaptureMessage centerMessage)
CaptureMessage getCenterMessage ()
void | setZoomInMessage (CaptureMessage zoomInMessage)
CaptureMessage getZoomInMessage ()
void | setZoomOutMessage (CaptureMessage zoomOutMessage)
CaptureMessage getZoomOutMessage ()
void | setRotateMessage (CaptureMessage message)
CaptureMessage getRotateMessage ()
void | setHoldParallelMessage (CaptureMessage message)
CaptureMessage getHoldParallelMessage ()
void | setCapturedMessage (CaptureMessage capturedMessage)
CaptureMessage getCapturedMessage ()
void | setOuterViewFinderColor (int colorCode)
Outer view finder color. More...
int | getOuterViewFinderColor ()
void | setGuidanceFrameColor (int colorCode)
Guidance frame color. More...
void | setSteadyGuidanceFrameColor (int colorCode)
Steady guidance frame color. More...
int | getGuidanceFrameColor ()
Bitmap | getDocumentSampleImage ()
void | setDocumentSampleImage (Bitmap documentSampleImage)
void | addPageDetectionListener (PageDetectionListener listener)
void | removePageDetectionListener (PageDetectionListener listener)
- Public Member Functions inherited from CaptureExperience
void | addOnImageCapturedListener (ImageCapturedListener listener)
void | removeOnImageCapturedListener (ImageCapturedListener listener)
void | setVibrationEnabled (boolean enable)
boolean | isVibrationEnabled ()
void | takePicture ()
void | takePictureContinually ()
void | stopCapture ()
void | onImageCaptured (ImageCapturedEvent event)
Invoked when the camera captures an image. More...
void | onAutoFocus (AutoFocusResultEvent event)
Invoked when the camera completes focusing. More...
void | onLevelness (LevelnessEvent event)
Invoked when the orientation of the device changes. More...
void | onStabilityDelay (StabilityDelayEvent event)
Invoked when stability levels change. More...
void | destroy ()

Additional Inherited Members

- Protected Member Functions inherited from DocumentBaseCaptureExperience
void | initBase (ImageCaptureView view, IDetectionAdapter adapter, DocumentBaseCaptureExperienceCriteriaHolder criteria)
- Protected Member Functions inherited from CaptureExperience
void | invokeImageCapturedListeners (ImageCapturedEvent event)
boolean | captureCriteriaMetInternal (CaptureExperienceData data)
- Protected Attributes inherited from DocumentBaseCaptureExperience
Context | _ctx
- Protected Attributes inherited from CaptureExperience
CaptureExperienceData | _captureExperienceData = new CaptureExperienceData()
final Object | _lock
boolean | _sdkCaptureRequested
boolean | _continuousCapture
ImageCaptureView _imageCaptureView
final Handler | _uiHandler = new Handler(Looper.getMainLooper())
float | _aspectRatio
Set< ImageCapturedListener > | _imageCapturedListeners = new LinkedHashSet<ImageCapturedListener>()
Vibrator | _vibrator
boolean | _vibrationEnabled = false

Detailed Description

This class is responsible for rendering the enhanced visual experience on an ImageCaptureView and provides feedback to guide the user to take a clear, legible and optimally zoomed in photo of a document. Criteria of such a document can be specified by using a setCaptureCriteria(CheckCaptureExperienceCriteriaHolder) method.

A photo will be taken automatically once the specified criteria are met, and takePicture() or takePictureContinually() has been called.

Note: CheckCaptureExperience is best used on a view that occupies the maximum possible area of its parent view.

Constructor & Destructor Documentation

CheckCaptureExperience ( ImageCaptureView view )

Constructs an experience on a given ImageCaptureView.

Parameters
view The ImageCaptureView this will be drawn onto
CheckCaptureExperience | ( | ImageCaptureView | view,
 |  | CheckCaptureExperienceCriteriaHolder | criteria
 | ) |  |

Constructs an experience on a given ImageCaptureView with specific CheckCaptureExperienceCriteriaHolder

Parameters
view | The ImageCaptureView this will be drawn onto
criteria | The criteria used to determine if a photo should be taken

Member Function Documentation

CheckCaptureExperienceCriteriaHolder getCaptureCriteria ( )

Returns the criteria used to determine if a photo should be taken.

Returns
CheckCaptureExperienceCriteriaHolder
See also
CheckCaptureExperienceCriteriaHolder
CaptureMessage getCenterMessage ( )

Returns the attributes of the message that is displayed when document is not enough centered in the target frame for capture.

Default configuration:

  • message: "Center Check"
  • text color: white
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 16
  • typeface: not specified
  • messageIcons: not specified
  • orientation: CaptureMessage.KUIMessageOrientation#LANDSCAPE
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage The center message
See also
setCenterMessage(CaptureMessage)
CaptureMessage
Bitmap getCheckSampleImage ( )

The Bitmap of a sample check that is displayed over the check frame area when the animated tutorial is enabled.

Returns
Bitmap The sample check image
See also
setDocumentSampleImage(Bitmap)
CaptureMessage getUserInstructionMessage ( )

Returns the attributes of the instruction message that is displayed on the capture control while the user is trying to capture. This instruction will be displayed during periods where other guidance is not available to correct a user. This may happen in particular when the user is holding a device far away from a document, preventing detection.

The following CaptureMessage property methods are not supported for this message: getMessageIcons() / setMessageIcons(Bitmap[]).

Default configuration:

  • message: "Fill viewable area with check"
  • text color: white
  • background color: transparent
  • background drawable: not specified
  • text size: 32
  • typeface: not specified
  • orientation: CaptureMessage.KUIMessageOrientation#LANDSCAPE
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage The instruction capture message
See also
CaptureMessage
void setCaptureCriteria ( CheckCaptureExperienceCriteriaHolder criteria )

Calling this method will cause all of the capture related parameters to be configured

Parameters
criteria The criteria used to determine if a photo should be taken
See also
CheckCaptureExperienceCriteriaHolder
void setCenterMessage ( CaptureMessage centerMessage )

This instruction will be displayed when document is not centered in the target frame

Parameters
centerMessage The center message
See also
CaptureMessage
void setCheckSampleImage ( Bitmap checkSampleImage )

The specified Bitmap of a sample check is displayed over the check frame area when the animated tutorial is enabled. The sample check image is stretched if necessary to fill the entire check frame area. While the tutorial is running, MICR and guidance animation are superimposed over the image. A default check sample image is used if this is not set by the app.

Parameters
checkSampleImage The sample check image
See also
enableAnimationTutor(boolean)
void setUserInstructionMessage ( CaptureMessage userInstructionsMessage )

A property to configure the attributes of the instruction message that is displayed on the capture control while user is trying to capture.

Parameters
userInstructionsMessage : CaptureMessage
See also
CaptureMessage
The documentation for this class was generated from the following file:
  • CheckCaptureExperience.java


Kofax Mobile SDK API Reference: CheckCaptureExperienceCriteriaHolder Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • CheckCaptureExperienceCriteriaHolder
Public Member Functions | List of all members
CheckCaptureExperienceCriteriaHolder Class Reference
Inheritance diagram for CheckCaptureExperienceCriteriaHolder:
DocumentBaseCaptureExperienceCriteriaHolder CaptureExperienceCriteriaHolder

Public Member Functions

CheckCaptureExperienceCriteriaHolder ()
void | setCheckDetectionSettings (CheckDetectionSettings detectionSettings)
CheckDetectionSettings getCheckDetectionSettings ()
- Public Member Functions inherited from DocumentBaseCaptureExperienceCriteriaHolder
DocumentBaseCaptureExperienceCriteriaHolder ()
boolean | isStabilityThresholdEnabled ()
void | setStabilityThresholdEnabled (boolean stabilityThresholdEnabled)
int | getStabilityThreshold ()
void | setStabilityThreshold (int stabilityThreshold)
boolean | isPitchThresholdEnabled ()
void | setPitchThresholdEnabled (boolean pitchThresholdEnabled)
int | getPitchThreshold ()
void | setPitchThreshold (int pitchThreshold)
boolean | isRollThresholdEnabled ()
void | setRollThresholdEnabled (boolean rollThresholdEnabled)
int | getRollThreshold ()
void | setRollThreshold (int rollThreshold)
boolean | isFocusEnabled ()
void | setFocusEnabled (boolean focusEnabled)
boolean | isOrientationEnabled ()
void | setOrientationEnabled (boolean enabled)
void | setHoldSteadyDelay (double seconds)
Sets the minimum duration in seconds the hold steady message should be shown before taking a picture. More...
double | getHoldSteadyDelay ()
Returns the minimum duration in seconds the hold steady message should be shown before taking a picture. More...
void | setPageDetectionEnabled (boolean enabled)
Manages page detection constraint. More...
boolean | isPageDetectionEnabled ()
- Public Member Functions inherited from CaptureExperienceCriteriaHolder
CaptureExperienceCriteriaHolder ()
boolean | isStabilityThresholdEnabled ()
void | setStabilityThresholdEnabled (boolean stabilityThresholdEnabled)
int | getStabilityThreshold ()
void | setStabilityThreshold (int stabilityThreshold)
boolean | isPitchThresholdEnabled ()
void | setPitchThresholdEnabled (boolean pitchThresholdEnabled)
int | getPitchThreshold ()
void | setPitchThreshold (int pitchThreshold)
boolean | isRollThresholdEnabled ()
void | setRollThresholdEnabled (boolean rollThresholdEnabled)
int | getRollThreshold ()
void | setRollThreshold (int rollThreshold)
boolean | isFocusEnabled ()
void | setFocusEnabled (boolean focusEnabled)
boolean | isOrientationEnabled ()
void | setOrientationEnabled (boolean enabled)
void | setRefocusEnabled (boolean enabled)
boolean | isRefocusBeforeCaptureEnabled ()

Detailed Description

This class allows all of the capture related parameters to be configured.

Constructor & Destructor Documentation

CheckCaptureExperienceCriteriaHolder ( )

Member Function Documentation

CheckDetectionSettings getCheckDetectionSettings ( )
Returns
The settings for controlling the detector object
See also
CheckDetectionSettings
void setCheckDetectionSettings ( CheckDetectionSettings detectionSettings )
Parameters
detectionSettings The settings for controlling the detector object
See also
CheckDetectionSettings
The documentation for this class was generated from the following file:
  • CheckCaptureExperienceCriteriaHolder.java


Kofax Mobile SDK API Reference: DocumentBaseCaptureExperience Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • DocumentBaseCaptureExperience
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
DocumentBaseCaptureExperience Class Referenceabstract
Inheritance diagram for DocumentBaseCaptureExperience:
CaptureExperience StabilityDelayListener LevelnessListener AutoFocusResultListener ImageCapturedListener CheckCaptureExperience DocumentCaptureExperience FixedAspectRatioCaptureExperience PassportCaptureExperience

Public Member Functions

DocumentBaseCaptureExperience (ImageCaptureView view, DocumentBaseCaptureExperienceCriteriaHolder criteria)
final void | addOnImageCapturedListener (ImageCapturedListener listener)
final void | removeOnImageCapturedListener (ImageCapturedListener listener)
final void | setVibrationEnabled (boolean enable)
Manage vibration after an image is captured. More...
boolean | isVibrationEnabled ()
final void | setDiagnosticsViewEnabled (boolean enabled)
boolean | isDiagnosticsViewEnabled ()
void | takePicture ()
void | takePictureContinually ()
void | stopCapture ()
void | destroy ()
void | enableAnimationTutor (boolean enable)
Sets whether or not to show an animated tutorial about how to capture a document. More...
boolean | isAnimationTutorEnable ()
CaptureMessage getUserInstructionMessage ()
void | setUserInstructionMessage (CaptureMessage userInstructionsMessage)
CaptureMessage getTutorialDismissMessage ()
void | setTutorialDismissMessage (CaptureMessage tutorialDismissMessage)
CaptureMessage getHoldSteadyMessage ()
void | setHoldSteadyMessage (CaptureMessage holdSteadyMessage)
void | setCenterMessage (CaptureMessage centerMessage)
CaptureMessage getCenterMessage ()
void | setZoomInMessage (CaptureMessage zoomInMessage)
CaptureMessage getZoomInMessage ()
void | setZoomOutMessage (CaptureMessage zoomOutMessage)
CaptureMessage getZoomOutMessage ()
void | setRotateMessage (CaptureMessage message)
CaptureMessage getRotateMessage ()
void | setHoldParallelMessage (CaptureMessage message)
CaptureMessage getHoldParallelMessage ()
void | setCapturedMessage (CaptureMessage capturedMessage)
CaptureMessage getCapturedMessage ()
void | setOuterViewFinderColor (int colorCode)
Outer view finder color. More...
int | getOuterViewFinderColor ()
void | setGuidanceFrameColor (int colorCode)
Guidance frame color. More...
void | setSteadyGuidanceFrameColor (int colorCode)
Steady guidance frame color. More...
int | getGuidanceFrameColor ()
Bitmap | getDocumentSampleImage ()
void | setDocumentSampleImage (Bitmap documentSampleImage)
void | addPageDetectionListener (PageDetectionListener listener)
void | removePageDetectionListener (PageDetectionListener listener)
- Public Member Functions inherited from CaptureExperience
void | addOnImageCapturedListener (ImageCapturedListener listener)
void | removeOnImageCapturedListener (ImageCapturedListener listener)
void | setVibrationEnabled (boolean enable)
boolean | isVibrationEnabled ()
void | takePicture ()
void | takePictureContinually ()
void | stopCapture ()
void | onImageCaptured (ImageCapturedEvent event)
Invoked when the camera captures an image. More...
void | onAutoFocus (AutoFocusResultEvent event)
Invoked when the camera completes focusing. More...
void | onLevelness (LevelnessEvent event)
Invoked when the orientation of the device changes. More...
void | onStabilityDelay (StabilityDelayEvent event)
Invoked when stability levels change. More...
void | destroy ()

Protected Member Functions

void | initBase (ImageCaptureView view, IDetectionAdapter adapter, DocumentBaseCaptureExperienceCriteriaHolder criteria)
- Protected Member Functions inherited from CaptureExperience
void | invokeImageCapturedListeners (ImageCapturedEvent event)
boolean | captureCriteriaMetInternal (CaptureExperienceData data)

Protected Attributes

Context | _ctx
- Protected Attributes inherited from CaptureExperience
CaptureExperienceData | _captureExperienceData = new CaptureExperienceData()
final Object | _lock
boolean | _sdkCaptureRequested
boolean | _continuousCapture
ImageCaptureView _imageCaptureView
final Handler | _uiHandler = new Handler(Looper.getMainLooper())
float | _aspectRatio
Set< ImageCapturedListener > | _imageCapturedListeners = new LinkedHashSet<ImageCapturedListener>()
Vibrator | _vibrator
boolean | _vibrationEnabled = false

Detailed Description

This class renders an enhanced visual experience on an ImageCaptureView and provides feedback to guide the user to take a clear, legible and optimally zoomed in photo of a document. Criteria of such a document can be specified by using a setCaptureCriteria method.

A photo will be taken automatically once the specified criteria are met, and takePicture() or takePictureContinually() has been called.

Note: DocumentBaseCaptureExperience is best used on a view that occupies the maximum possible area of its parent view.

Constructor & Destructor Documentation

DocumentBaseCaptureExperience | ( | ImageCaptureView | view,
 |  | DocumentBaseCaptureExperienceCriteriaHolder | criteria
 | ) |  |

Note: This is best used on a view that occupies tge maximum possible area of its parent view.

Parameters
view | The view this will be drawn onto
criteria | The criteria used to determine when a photo should be taken. null is an acceptable value, and will give the default experience

Member Function Documentation

final void addOnImageCapturedListener ( ImageCapturedListener listener )

Invoked after the camera captures an image and when all capture messages were shown. To allow for every message to be played, this method should be used to set an ImageCapturedListener instead of the method on the ImageCaptureView class.

Parameters
listener The image captured listener
See also
ImageCapturedListener
void addPageDetectionListener ( PageDetectionListener listener )

Adds a listener to be invoked when a page is detected.

Parameters
listener the listener
See also
PageDetectionListener
void destroy ( )

Detaches from the ImageCaptureView and destroys this experience.

void enableAnimationTutor ( boolean enable )

Sets whether or not to show an animated tutorial about how to capture a document.

By default, the tutorial isn't shown.

Parameters
enable boolean.
CaptureMessage getCapturedMessage ( )

Returns the attributes of the message that will be displayed when a document is captured.

Default configuration:

  • message: "Done!"
  • text color: green
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 16
  • typeface: not specified
  • messageIcons: checkmark icon from package resource stream
    Icon is placed inside of the balloon. Its position and size depend on the balloon and text size.
    Icon will be centered inside balloon if there is no text message, otherwise it will be horizontally centered and shifted to the top.
    Icon is scaled to fit available balloon space with fixed aspect ratio.
  • orientation: CaptureMessage.KUIMessageOrientation#LANDSCAPE
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setCapturedMessage(CaptureMessage)
CaptureMessage
CaptureMessage getCenterMessage ( )

Returns the attributes of the message that is displayed when the document is not centered enough for capture.

Default configuration:

  • message: "Center Document"
  • text color: white
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 16
  • typeface: not specified
  • messageIcons: not specified
  • orientation: CaptureMessage.KUIMessageOrientation#LANDSCAPE
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setCenterMessage(CaptureMessage)
CaptureMessage
Bitmap getDocumentSampleImage ( )

The Bitmap of a sample document that is displayed over the document frame area when the animated tutorial is enabled.

Returns
Bitmap
See also
setDocumentSampleImage(Bitmap)
int getGuidanceFrameColor ( )

Returns the color used for the guidance frame.

Returns
The color used for the guidance frame.
CaptureMessage getHoldParallelMessage ( )

Returns the attributes of the message that will be displayed when the capture experience needs to instruct the user to hold the device more level.
The levelness thresholds can be set using the CaptureExperienceCriteriaHolder#setPitchThreshold(int) and CaptureExperienceCriteriaHolder#setRollThreshold(int) methods.

Default configuration:

  • message: "Hold Device Level"
  • text color: white
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 20
  • typeface: not specified
  • messageIcons: hold parallel icons from package resource stream
    Icon is placed inside of the balloon. Its position and size depend on the balloon and text size.
    Icon will be centered inside balloon if there is no text message, otherwise it will be horizontally centered and shifted to the top.
    Icon is scaled to fit available balloon space with fixed aspect ratio.
  • orientation: CaptureMessage.KUIMessageOrientation#LANDSCAPE
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setHoldParallelMessage(CaptureMessage)
CaptureMessage
CaptureMessage getHoldSteadyMessage ( )

Returns the attributes of the message that is displayed on the capture control to direct the user to hold the device steady so that a clear focused image can be captured. This message is shown when all the constraints are met and ready to capture.

Default configuration:

  • message: "Hold Steady"
  • text color: red
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 16
  • typeface: not specified
  • messageIcons: camera icons from package resource stream
    Icon is placed inside of the balloon. Its position and size depend on the balloon and text size.
    Icon will be centered inside balloon if there is no text message, otherwise it will be horizontally centered and shifted to the top.
    Icon is scaled to fit available balloon space with fixed aspect ratio.
  • orientation: CaptureMessage.KUIMessageOrientation#LANDSCAPE
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setHoldSteadyMessage(CaptureMessage)
CaptureMessage
int getOuterViewFinderColor ( )

Returns the color used for the outer view finder background.

Returns
The color used for the outer view finder background
CaptureMessage getRotateMessage ( )

Returns the attributes of the message that will be displayed when the capture experience needs to instruct the user to rotate the device or the document.

Default configuration:

  • message: "Rotate Device"
  • text color: white
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 20
  • typeface: not specified
  • messageIcons: change orientation icon from package resource stream
    Icon is placed inside of the balloon. Its position and size depend on the balloon and text size.
    Icon will be centered inside balloon if there is no text message, otherwise it will be horizontally centered and shifted to the top.
    Icon is scaled to fit available balloon space with fixed aspect ratio.
  • orientation: CaptureMessage.KUIMessageOrientation#LANDSCAPE
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setRotateMessage(CaptureMessage)
CaptureMessage
CaptureMessage getTutorialDismissMessage ( )

A property to configure the attributes of the instruction message that is displayed when the capture experience needs to instruct the user to skip tutorial demo.

The following CaptureMessage property methods are not supported for this message: getMessageIcons() / setMessageIcons(Bitmap[]).

Default configuration:

  • message: "Tap to dismiss"
  • text color: white
  • background color: transparent
  • background drawable: not specified
  • text size: 20
  • typeface: not specified
  • orientation: CaptureMessage.KUIMessageOrientation#LANDSCAPE
    By default, the message is placed under the target frame if the position coordinates were not set.
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
CaptureMessage
CaptureMessage getUserInstructionMessage ( )

Returns the attributes of the instruction message that is displayed on the capture control while the user is trying to capture. This message will be displayed during periods where other guidance is not available to correct a user. This may happen in particular when the user is holding a device too far away from a document, preventing detection.

The following CaptureMessage property methods are not supported for this message: getMessageIcons() / setMessageIcons(Bitmap[]).

Default configuration:

  • message: "Fill viewable area with document"
  • text color: white
  • background color: transparent
  • background drawable: not specified
  • text size: 32
  • typeface: not specified
  • orientation: CaptureMessage.KUIMessageOrientation#LANDSCAPE
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
CaptureMessage
CaptureMessage getZoomInMessage ( )

Returns the attributes of the message that is displayed when the capture experience needs to instruct the user to move the device closer to the target document.

Default configuration:

  • message: "Move Closer"
  • text color: white
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 20
  • typeface: not specified
  • messageIcons: zoom in icons from package resource stream
    Icon is placed inside of the balloon. Its position and size depend on the balloon and text size.
    Icon will be centered inside balloon if there is no text message, otherwise it will be horizontally centered and shifted to the top.
    Icon is scaled to fit available balloon space with fixed aspect ratio.
  • orientation: CaptureMessage.KUIMessageOrientation#LANDSCAPE
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setZoomInMessage(CaptureMessage)
CaptureMessage
CaptureMessage getZoomOutMessage ( )

Returns the attributes of the message that will be displayed when the capture experience needs to instruct the user to move the device farther away from the target document.

Default configuration:

  • message: "Move Back"
  • text color: white
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 20
  • typeface: not specified
  • messageIcons: zoom out icons from package resource stream
    Icon is placed inside of the balloon. Its position and size depend on the balloon and text size.
    Icon will be centered inside balloon if there is no text message, otherwise it will be horizontally centered and shifted to the top.
    Icon is scaled to fit available balloon space with fixed aspect ratio.
  • orientation: CaptureMessage.KUIMessageOrientation#LANDSCAPE
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setZoomOutMessage(CaptureMessage)
CaptureMessage
void initBase | ( | ImageCaptureView | view,
 |  | IDetectionAdapter | adapter,
 |  | DocumentBaseCaptureExperienceCriteriaHolder | criteria
 | ) |  |
protected
boolean isAnimationTutorEnable ( )
Returns
Whether to show animated instructions or not. False by default.
boolean isDiagnosticsViewEnabled ( )
Returns
Whether to show diagnostics view or not. False by default.
boolean isVibrationEnabled ( )
Returns
Whether or not to vibrate after an image is captured. True by default.
final void removeOnImageCapturedListener ( ImageCapturedListener listener )

Remove ImageCapturedListener.

Parameters
listener The image captured listener
See also
ImageCapturedListener
addOnImageCapturedListener(ImageCapturedListener)
void removePageDetectionListener ( PageDetectionListener listener )

Removes page detection listener.

Parameters
listener the listener
void setCapturedMessage ( CaptureMessage capturedMessage )

This message will be displayed when the document is captured.

Parameters
capturedMessage : CaptureMessage
See also
getCapturedMessage()
CaptureMessage
void setCenterMessage ( CaptureMessage centerMessage )

This instruction will be displayed when the document is not centered enough in the target frame for capture.

Parameters
centerMessage : CaptureMessage
See also
getCenterMessage()
CaptureMessage
final void setDiagnosticsViewEnabled ( boolean enabled )

Enables diagnostics view. Following information is logging:

  • Selected camera resolution
  • Stability value and thresholds
  • Whether it is focused
  • Focus Areas
  • Pitch/roll - values and thresholds
  • Detected page
  • Pre-crop target frame

By default, the diagnostics view isn't shown.

Parameters
enabled Whether to show diagnostics view or not
void setDocumentSampleImage ( Bitmap documentSampleImage )

The specified Bitmap of a sample document is displayed over the document frame area when the animated tutorial is enabled. The sample document image is stretched if necessary to fill the entire document frame area. While the tutorial is running, MICR and guidance animation are superimposed over the image.

A default document sample image is used if it isn't set by the app. Inherited classes have own default sample images.

Parameters
documentSampleImage : Bitmap
See also
enableAnimationTutor(boolean)
void setGuidanceFrameColor ( int colorCode )

Guidance frame color.

Specifies the color that will be used for the guidance frame, for example in the case of check capture. The default color is green.

void setHoldParallelMessage ( CaptureMessage message )

This message will be displayed when the capture experience needs to instruct the user to hold the device more level.

Parameters
message CaptureMessage
See also
getHoldParallelMessage()
CaptureMessage
void setHoldSteadyMessage ( CaptureMessage holdSteadyMessage )

A property to configure the attributes of the message that is displayed on the capture control to direct the user to hold the device steady so that a clear focused image can be captured. This message is shown when all the constraints are met and ready to capture.

Parameters
holdSteadyMessage : CaptureMessage
See also
getHoldSteadyMessage()
CaptureMessage
void setOuterViewFinderColor ( int colorCode )

Outer view finder color.

Specifies the color that will be used for the outer view finder background. The default color is translucent grey.

void setRotateMessage ( CaptureMessage message )

This message will be displayed when the capture experience needs to instruct the user to rotate the device or the document.

Parameters
message CaptureMessage
See also
getRotateMessage()
CaptureMessage
void setSteadyGuidanceFrameColor ( int colorCode )

Steady guidance frame color.

Specifies the color that will be used for the guidance frame when control is ready to capture.

By default, it is equals to the guidanceFrameColor (green).

void setTutorialDismissMessage ( CaptureMessage tutorialDismissMessage )

A property to configure the attributes of the instruction message that is displayed when the capture experience needs to instruct the user to skip tutorial demo.

Parameters
tutorialDismissMessage : CaptureMessage
See also
getTutorialDismissMessage()
CaptureMessage
void setUserInstructionMessage ( CaptureMessage userInstructionsMessage )

A property to configure the attributes of the instruction message that is displayed on the capture control while the user is trying to capture.

Parameters
userInstructionsMessage : CaptureMessage
See also
getUserInstructionMessage()
CaptureMessage
final void setVibrationEnabled ( boolean enable )

Manage vibration after an image is captured.

Turn on/off vibration after an image is captured for haptic feedback.

Enabled by default.

Parameters
enable boolean
Note
android.permission.VIBRATE permission should also be granted to allow vibration.
void setZoomInMessage ( CaptureMessage zoomInMessage )

This message will be displayed when the capture experience needs to instruct the user to move the device closer to the target document.

Parameters
zoomInMessage : CaptureMessage
See also
getZoomInMessage()
CaptureMessage
void setZoomOutMessage ( CaptureMessage zoomOutMessage )

This message will be displayed when the capture experience needs to instruct the user to move the device farther away from the target document.

Parameters
zoomOutMessage : CaptureMessage
See also
getZoomOutMessage()
CaptureMessage
void stopCapture ( )

This is the counterpart to takePicture() and takePictureContinually(). Calling this method will stop automatic image capture when the criteria are satisfied.

See also
takePicture()
takePictureContinually()
void takePicture ( )

Calling this method will start the process of monitoring the capture criteria that was configured to determine when a document that meets all the criteria can be captured. The static frame will change its color to green to indicate that a document will be captured soon.

void takePictureContinually ( )

Calling this method will start the continuous capture of images. Images will automatically be captured when criteria are satisfied.

Member Data Documentation

Context _ctx
protected
The documentation for this class was generated from the following file:
  • DocumentBaseCaptureExperience.java


Kofax Mobile SDK API Reference: DocumentBaseCaptureExperienceCriteriaHolder Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • DocumentBaseCaptureExperienceCriteriaHolder
Public Member Functions | List of all members
DocumentBaseCaptureExperienceCriteriaHolder Class Referenceabstract
Inheritance diagram for DocumentBaseCaptureExperienceCriteriaHolder:
CaptureExperienceCriteriaHolder CheckCaptureExperienceCriteriaHolder DocumentCaptureExperienceCriteriaHolder FixedAspectRatioExperienceCriteriaHolder PassportCaptureExperienceCriteriaHolder

Public Member Functions

DocumentBaseCaptureExperienceCriteriaHolder ()
boolean | isStabilityThresholdEnabled ()
void | setStabilityThresholdEnabled (boolean stabilityThresholdEnabled)
int | getStabilityThreshold ()
void | setStabilityThreshold (int stabilityThreshold)
boolean | isPitchThresholdEnabled ()
void | setPitchThresholdEnabled (boolean pitchThresholdEnabled)
int | getPitchThreshold ()
void | setPitchThreshold (int pitchThreshold)
boolean | isRollThresholdEnabled ()
void | setRollThresholdEnabled (boolean rollThresholdEnabled)
int | getRollThreshold ()
void | setRollThreshold (int rollThreshold)
boolean | isFocusEnabled ()
void | setFocusEnabled (boolean focusEnabled)
boolean | isOrientationEnabled ()
void | setOrientationEnabled (boolean enabled)
void | setHoldSteadyDelay (double seconds)
Sets the minimum duration in seconds the hold steady message should be shown before taking a picture. More...
double | getHoldSteadyDelay ()
Returns the minimum duration in seconds the hold steady message should be shown before taking a picture. More...
void | setPageDetectionEnabled (boolean enabled)
Manages page detection constraint. More...
boolean | isPageDetectionEnabled ()
- Public Member Functions inherited from CaptureExperienceCriteriaHolder
CaptureExperienceCriteriaHolder ()
boolean | isStabilityThresholdEnabled ()
void | setStabilityThresholdEnabled (boolean stabilityThresholdEnabled)
int | getStabilityThreshold ()
void | setStabilityThreshold (int stabilityThreshold)
boolean | isPitchThresholdEnabled ()
void | setPitchThresholdEnabled (boolean pitchThresholdEnabled)
int | getPitchThreshold ()
void | setPitchThreshold (int pitchThreshold)
boolean | isRollThresholdEnabled ()
void | setRollThresholdEnabled (boolean rollThresholdEnabled)
int | getRollThreshold ()
void | setRollThreshold (int rollThreshold)
boolean | isFocusEnabled ()
void | setFocusEnabled (boolean focusEnabled)
boolean | isOrientationEnabled ()
void | setOrientationEnabled (boolean enabled)
void | setRefocusEnabled (boolean enabled)
boolean | isRefocusBeforeCaptureEnabled ()

Detailed Description

This class allows all of the capture related parameters to be configured. The threshold parameters in this class are not set on the image capture view directly.

Constructor & Destructor Documentation

DocumentBaseCaptureExperienceCriteriaHolder ( )

Member Function Documentation

double getHoldSteadyDelay ( )

Returns the minimum duration in seconds the hold steady message should be shown before taking a picture.

The actual hold steady duration may vary depending on capture conditions, but it should not be less than passed value.

Valid values are in the range [0.0, 3.0]. Values outside of this range are interpreted as 0.0 or 3.0.

The default value is 1.0 (1 second).

int getPitchThreshold ( )

Valid values are in the range [0, 45]. The default value is 15. A value of 45 disables level checking for pitch even if pitch threshold is enabled

Returns
int The pitch threshold value which needs to be met before taking a picture
See also
setPitchThreshold(int)
setPitchThresholdEnabled(boolean)
isPitchThresholdEnabled()
int getRollThreshold ( )

Valid values are in the range [0, 45]. A value of 45 disables level checking for roll.

Returns
int The roll threshold value which needs to be met before taking a picture
See also
setRollThreshold(int)
setRollThresholdEnabled(boolean)
isRollThresholdEnabled()
int getStabilityThreshold ( )

If enabled the stability threshold is checked before taking a picture.

Returns
The stability value which needs to be met before taking a picture
See also
setStabilityThreshold(int)
setStabilityThresholdEnabled(boolean)
isStabilityThresholdEnabled()
boolean isFocusEnabled ( )
Returns
boolean Whether the Focus constraint is enabled or not
See also
setFocusEnabled(boolean)
boolean isOrientationEnabled ( )
Returns
boolean Whether orientation constraint is enabled or not.
See also
setOrientationEnabled(boolean)
boolean isPageDetectionEnabled ( )
Returns
boolean Whether the page detection constraint is enabled or not.
See also
setPageDetectionEnabled(boolean)
boolean isPitchThresholdEnabled ( )
Returns
boolean Whether the pitch threshold is enabled or not
See also
setPitchThresholdEnabled(boolean)
setPitchThreshold(int)
getPitchThreshold()
boolean isRollThresholdEnabled ( )
Returns
boolean Whether the Roll threshold is enabled or not
See also
setRollThresholdEnabled(boolean)
setRollThreshold(int)
getRollThreshold()
boolean isStabilityThresholdEnabled ( )
Returns
boolean Whether the stability threshold is enabled or not
See also
setStabilityThresholdEnabled(boolean)
setStabilityThreshold(int)
getStabilityThreshold()
void setFocusEnabled ( boolean focusEnabled )

A boolean that indicates whether the Focus constraint is enabled. If enabled, this criterion is checked before taking a picture. The default value is true. Leaving it enabled is advisable. Otherwise it is highly likely that out of focus images are captured.

Parameters
focusEnabled whether the Focus constraint is enabled or not
See also
isFocusEnabled()
void setHoldSteadyDelay ( double seconds )

Sets the minimum duration in seconds the hold steady message should be shown before taking a picture.

The actual hold steady duration may vary depending on capture conditions, but it should not be less than passed value.

Valid values are in the range [0.0, 3.0]. Values outside of this range are interpreted as 0.0 or 3.0.

The default value is 1.0 (1 second).

void setOrientationEnabled ( boolean enabled )

Manages orientation constraint.

This constraint checks that the orientation of the document matches the orientation of the target frame.

Enabled by default.

Parameters
enabled true to enable and false to disable.
See also
isOrientationEnabled()
void setPageDetectionEnabled ( boolean enabled )

Manages page detection constraint.

This constraint checks that page is detected while capturing and it matches the target frame. It is responsible for the following guidances: center, zoomIn, zoomOut, rotate.

Enabled by default

Parameters
enabled
See also
isPageDetectionEnabled()
void setPitchThreshold ( int pitchThreshold )

If the pitch threshold constraint is enabled, and the device pitch is greater than the specified threshold, a picture will not be taken. Valid values are in the range [0, 45]. Values outside this range will throw KmcRuntimeException. The default value is 15. A value of 45 disables level checking for pitch.

Parameters
pitchThreshold The pitch threshold value which needs to be met before taking a picture
Exceptions
KmcRuntimeException
See also
setPitchThresholdEnabled(boolean)
getPitchThreshold()
isPitchThresholdEnabled()
void setPitchThresholdEnabled ( boolean pitchThresholdEnabled )

A boolean that specifies whether the level threshold for pitch enabled. If enabled, this criterion is checked before taking a picture. Default is enabled.

Parameters
pitchThresholdEnabled Whether the pitch threshold is enabled or not
See also
isPitchThresholdEnabled()
setPitchThreshold(int)
getPitchThreshold()
void setRollThreshold ( int rollThreshold )

If the roll threshold constraint is enabled, and the device roll is greater than the specified threshold, a picture will not be taken. Valid values are in the range [0, 45]. Values outside this range will throw KmcRuntimeException. The default value is 15. A value of 45 disables level checking for roll.

Parameters
rollThreshold The level threshold value for roll which needs to be met before taking a picture
Exceptions
KmcRuntimeException
See also
getRollThreshold()
setRollThresholdEnabled(boolean)
isRollThresholdEnabled()
void setRollThresholdEnabled ( boolean rollThresholdEnabled )

A boolean that specifies whether the level threshold for roll is enabled. If enabled, this criterion is checked before taking a picture. Default is enabled.

Parameters
rollThresholdEnabled Whether the Roll threshold is enabled or not
See also
isRollThresholdEnabled()
setRollThreshold(int)
getRollThreshold()
void setStabilityThreshold ( int stabilityThreshold )

If the stability threshold constraint is enabled, and the device stability is less than the specified threshold, a picture will not be taken. Valid values are in the range [0, 100], where 100 indicates that the device must be perfectly still to take a picture and 0 indicates that stability checking is turned off. Values outside this range will throw KmcRuntimeException. The default value is 15.

Parameters
stabilityThreshold The stability value which needs to be met before taking a picture
Exceptions
com.kofax.kmc.kut.utilities.error.KmcRuntimeException
See also
setStabilityThresholdEnabled(boolean)
isStabilityThresholdEnabled()
getStabilityThreshold()
void setStabilityThresholdEnabled ( boolean stabilityThresholdEnabled )

A boolean that specifies whether the stability threshold is enabled. If enabled, this criterion is checked before taking a picture. Default is enabled.

Parameters
stabilityThresholdEnabled Whether the stability threshold is enabled or not
See also
isStabilityThresholdEnabled()
setStabilityThreshold(int)
getStabilityThreshold()
The documentation for this class was generated from the following file:
  • DocumentBaseCaptureExperienceCriteriaHolder.java


Kofax Mobile SDK API Reference: DocumentCaptureExperience Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • DocumentCaptureExperience
Public Member Functions | List of all members
DocumentCaptureExperience Class Reference
Inheritance diagram for DocumentCaptureExperience:
DocumentBaseCaptureExperience CaptureExperience StabilityDelayListener LevelnessListener AutoFocusResultListener ImageCapturedListener

Public Member Functions

DocumentCaptureExperience (ImageCaptureView view)
DocumentCaptureExperience (ImageCaptureView view, DocumentCaptureExperienceCriteriaHolder criteria)
void | setCaptureCriteria (DocumentCaptureExperienceCriteriaHolder criteria)
DocumentCaptureExperienceCriteriaHolder getCaptureCriteria ()
- Public Member Functions inherited from DocumentBaseCaptureExperience
DocumentBaseCaptureExperience (ImageCaptureView view, DocumentBaseCaptureExperienceCriteriaHolder criteria)
final void | addOnImageCapturedListener (ImageCapturedListener listener)
final void | removeOnImageCapturedListener (ImageCapturedListener listener)
final void | setVibrationEnabled (boolean enable)
Manage vibration after an image is captured. More...
boolean | isVibrationEnabled ()
final void | setDiagnosticsViewEnabled (boolean enabled)
boolean | isDiagnosticsViewEnabled ()
void | takePicture ()
void | takePictureContinually ()
void | stopCapture ()
void | destroy ()
void | enableAnimationTutor (boolean enable)
Sets whether or not to show an animated tutorial about how to capture a document. More...
boolean | isAnimationTutorEnable ()
CaptureMessage getUserInstructionMessage ()
void | setUserInstructionMessage (CaptureMessage userInstructionsMessage)
CaptureMessage getTutorialDismissMessage ()
void | setTutorialDismissMessage (CaptureMessage tutorialDismissMessage)
CaptureMessage getHoldSteadyMessage ()
void | setHoldSteadyMessage (CaptureMessage holdSteadyMessage)
void | setCenterMessage (CaptureMessage centerMessage)
CaptureMessage getCenterMessage ()
void | setZoomInMessage (CaptureMessage zoomInMessage)
CaptureMessage getZoomInMessage ()
void | setZoomOutMessage (CaptureMessage zoomOutMessage)
CaptureMessage getZoomOutMessage ()
void | setRotateMessage (CaptureMessage message)
CaptureMessage getRotateMessage ()
void | setHoldParallelMessage (CaptureMessage message)
CaptureMessage getHoldParallelMessage ()
void | setCapturedMessage (CaptureMessage capturedMessage)
CaptureMessage getCapturedMessage ()
void | setOuterViewFinderColor (int colorCode)
Outer view finder color. More...
int | getOuterViewFinderColor ()
void | setGuidanceFrameColor (int colorCode)
Guidance frame color. More...
void | setSteadyGuidanceFrameColor (int colorCode)
Steady guidance frame color. More...
int | getGuidanceFrameColor ()
Bitmap | getDocumentSampleImage ()
void | setDocumentSampleImage (Bitmap documentSampleImage)
void | addPageDetectionListener (PageDetectionListener listener)
void | removePageDetectionListener (PageDetectionListener listener)
- Public Member Functions inherited from CaptureExperience
void | addOnImageCapturedListener (ImageCapturedListener listener)
void | removeOnImageCapturedListener (ImageCapturedListener listener)
void | setVibrationEnabled (boolean enable)
boolean | isVibrationEnabled ()
void | takePicture ()
void | takePictureContinually ()
void | stopCapture ()
void | onImageCaptured (ImageCapturedEvent event)
Invoked when the camera captures an image. More...
void | onAutoFocus (AutoFocusResultEvent event)
Invoked when the camera completes focusing. More...
void | onLevelness (LevelnessEvent event)
Invoked when the orientation of the device changes. More...
void | onStabilityDelay (StabilityDelayEvent event)
Invoked when stability levels change. More...
void | destroy ()

Additional Inherited Members

- Protected Member Functions inherited from DocumentBaseCaptureExperience
void | initBase (ImageCaptureView view, IDetectionAdapter adapter, DocumentBaseCaptureExperienceCriteriaHolder criteria)
- Protected Member Functions inherited from CaptureExperience
void | invokeImageCapturedListeners (ImageCapturedEvent event)
boolean | captureCriteriaMetInternal (CaptureExperienceData data)
- Protected Attributes inherited from DocumentBaseCaptureExperience
Context | _ctx
- Protected Attributes inherited from CaptureExperience
CaptureExperienceData | _captureExperienceData = new CaptureExperienceData()
final Object | _lock
boolean | _sdkCaptureRequested
boolean | _continuousCapture
ImageCaptureView _imageCaptureView
final Handler | _uiHandler = new Handler(Looper.getMainLooper())
float | _aspectRatio
Set< ImageCapturedListener > | _imageCapturedListeners = new LinkedHashSet<ImageCapturedListener>()
Vibrator | _vibrator
boolean | _vibrationEnabled = false

Detailed Description

This class is responsible for rendering an enhanced visual experience on an ImageCaptureView and provides feedback to guide the user to take a clear, legible and optimally zoomed in photo of a document. Criteria of such a document can be specified by using a setCaptureCriteria(DocumentCaptureExperienceCriteriaHolder) method.

A photo will be taken automatically once the specified criteria are met, and takePicture() or takePictureContinually() has been called.

Note: DocumentCaptureExperience is best used on a view that occupies the maximum possible area of its parent view.

Constructor & Destructor Documentation

DocumentCaptureExperience ( ImageCaptureView view )

Constructs an experience on a given ImageCaptureView.

Parameters
view The ImageCaptureView this will be drawn onto
DocumentCaptureExperience | ( | ImageCaptureView | view,
 |  | DocumentCaptureExperienceCriteriaHolder | criteria
 | ) |  |

Constructs an experience on a given ImageCaptureView with specific CheckCaptureExperienceCriteriaHolder

Parameters
view | The ImageCaptureView this will be drawn onto
criteria | The criteria used to determine if a photo should be taken

Member Function Documentation

DocumentCaptureExperienceCriteriaHolder getCaptureCriteria ( )

Returns the criteria used to determine if a photo should be taken.

Returns
DocumentCaptureExperienceCriteriaHolder
See also
DocumentCaptureExperienceCriteriaHolder
void setCaptureCriteria ( DocumentCaptureExperienceCriteriaHolder criteria )

Calling this method will cause all of the capture related parameters to be configured

Parameters
criteria The criteria used to determine if a photo should be taken
See also
DocumentCaptureExperienceCriteriaHolder
The documentation for this class was generated from the following file:
  • DocumentCaptureExperience.java


Kofax Mobile SDK API Reference: DocumentCaptureExperienceCriteriaHolder Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • DocumentCaptureExperienceCriteriaHolder
Public Member Functions | List of all members
DocumentCaptureExperienceCriteriaHolder Class Reference
Inheritance diagram for DocumentCaptureExperienceCriteriaHolder:
DocumentBaseCaptureExperienceCriteriaHolder CaptureExperienceCriteriaHolder

Public Member Functions

DocumentCaptureExperienceCriteriaHolder ()
void | setDetectionSettings (DocumentDetectionSettings detectionSettings)
DocumentDetectionSettings getDetectionSettings ()
- Public Member Functions inherited from DocumentBaseCaptureExperienceCriteriaHolder
DocumentBaseCaptureExperienceCriteriaHolder ()
boolean | isStabilityThresholdEnabled ()
void | setStabilityThresholdEnabled (boolean stabilityThresholdEnabled)
int | getStabilityThreshold ()
void | setStabilityThreshold (int stabilityThreshold)
boolean | isPitchThresholdEnabled ()
void | setPitchThresholdEnabled (boolean pitchThresholdEnabled)
int | getPitchThreshold ()
void | setPitchThreshold (int pitchThreshold)
boolean | isRollThresholdEnabled ()
void | setRollThresholdEnabled (boolean rollThresholdEnabled)
int | getRollThreshold ()
void | setRollThreshold (int rollThreshold)
boolean | isFocusEnabled ()
void | setFocusEnabled (boolean focusEnabled)
boolean | isOrientationEnabled ()
void | setOrientationEnabled (boolean enabled)
void | setHoldSteadyDelay (double seconds)
Sets the minimum duration in seconds the hold steady message should be shown before taking a picture. More...
double | getHoldSteadyDelay ()
Returns the minimum duration in seconds the hold steady message should be shown before taking a picture. More...
void | setPageDetectionEnabled (boolean enabled)
Manages page detection constraint. More...
boolean | isPageDetectionEnabled ()
- Public Member Functions inherited from CaptureExperienceCriteriaHolder
CaptureExperienceCriteriaHolder ()
boolean | isStabilityThresholdEnabled ()
void | setStabilityThresholdEnabled (boolean stabilityThresholdEnabled)
int | getStabilityThreshold ()
void | setStabilityThreshold (int stabilityThreshold)
boolean | isPitchThresholdEnabled ()
void | setPitchThresholdEnabled (boolean pitchThresholdEnabled)
int | getPitchThreshold ()
void | setPitchThreshold (int pitchThreshold)
boolean | isRollThresholdEnabled ()
void | setRollThresholdEnabled (boolean rollThresholdEnabled)
int | getRollThreshold ()
void | setRollThreshold (int rollThreshold)
boolean | isFocusEnabled ()
void | setFocusEnabled (boolean focusEnabled)
boolean | isOrientationEnabled ()
void | setOrientationEnabled (boolean enabled)
void | setRefocusEnabled (boolean enabled)
boolean | isRefocusBeforeCaptureEnabled ()

Detailed Description

This class allows all of the capture related parameters to be configured.

Constructor & Destructor Documentation

DocumentCaptureExperienceCriteriaHolder ( )

Member Function Documentation

DocumentDetectionSettings getDetectionSettings ( )

Returns the document detection settings.

Returns
the document detection settings
void setDetectionSettings ( DocumentDetectionSettings detectionSettings )

Sets the document detection settings.

Parameters
detectionSettings the document detection settings
The documentation for this class was generated from the following file:
  • DocumentCaptureExperienceCriteriaHolder.java


Kofax Mobile SDK API Reference: FixedAspectRatioCaptureExperience Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • FixedAspectRatioCaptureExperience
Public Member Functions | List of all members
FixedAspectRatioCaptureExperience Class Reference
Inheritance diagram for FixedAspectRatioCaptureExperience:
DocumentBaseCaptureExperience CaptureExperience StabilityDelayListener LevelnessListener AutoFocusResultListener ImageCapturedListener

Public Member Functions

FixedAspectRatioCaptureExperience (ImageCaptureView view)
FixedAspectRatioCaptureExperience (ImageCaptureView view, FixedAspectRatioExperienceCriteriaHolder criteria)
void | setCaptureCriteria (FixedAspectRatioExperienceCriteriaHolder criteria)
FixedAspectRatioExperienceCriteriaHolder getCaptureCriteria ()
CaptureMessage getHoldSteadyMessage ()
CaptureMessage getHoldParallelMessage ()
CaptureMessage getCapturedMessage ()
void | setCenterMessage (CaptureMessage centerMessage)
void | setZoomInMessage (CaptureMessage zoomInMessage)
void | setZoomOutMessage (CaptureMessage zoomOutMessage)
void | setRotateMessage (CaptureMessage message)
- Public Member Functions inherited from DocumentBaseCaptureExperience
DocumentBaseCaptureExperience (ImageCaptureView view, DocumentBaseCaptureExperienceCriteriaHolder criteria)
final void | addOnImageCapturedListener (ImageCapturedListener listener)
final void | removeOnImageCapturedListener (ImageCapturedListener listener)
final void | setVibrationEnabled (boolean enable)
Manage vibration after an image is captured. More...
boolean | isVibrationEnabled ()
final void | setDiagnosticsViewEnabled (boolean enabled)
boolean | isDiagnosticsViewEnabled ()
void | takePicture ()
void | takePictureContinually ()
void | stopCapture ()
void | destroy ()
void | enableAnimationTutor (boolean enable)
Sets whether or not to show an animated tutorial about how to capture a document. More...
boolean | isAnimationTutorEnable ()
CaptureMessage getUserInstructionMessage ()
void | setUserInstructionMessage (CaptureMessage userInstructionsMessage)
CaptureMessage getTutorialDismissMessage ()
void | setTutorialDismissMessage (CaptureMessage tutorialDismissMessage)
CaptureMessage getHoldSteadyMessage ()
void | setHoldSteadyMessage (CaptureMessage holdSteadyMessage)
void | setCenterMessage (CaptureMessage centerMessage)
CaptureMessage getCenterMessage ()
void | setZoomInMessage (CaptureMessage zoomInMessage)
CaptureMessage getZoomInMessage ()
void | setZoomOutMessage (CaptureMessage zoomOutMessage)
CaptureMessage getZoomOutMessage ()
void | setRotateMessage (CaptureMessage message)
CaptureMessage getRotateMessage ()
void | setHoldParallelMessage (CaptureMessage message)
CaptureMessage getHoldParallelMessage ()
void | setCapturedMessage (CaptureMessage capturedMessage)
CaptureMessage getCapturedMessage ()
void | setOuterViewFinderColor (int colorCode)
Outer view finder color. More...
int | getOuterViewFinderColor ()
void | setGuidanceFrameColor (int colorCode)
Guidance frame color. More...
void | setSteadyGuidanceFrameColor (int colorCode)
Steady guidance frame color. More...
int | getGuidanceFrameColor ()
Bitmap | getDocumentSampleImage ()
void | setDocumentSampleImage (Bitmap documentSampleImage)
void | addPageDetectionListener (PageDetectionListener listener)
void | removePageDetectionListener (PageDetectionListener listener)
- Public Member Functions inherited from CaptureExperience
void | addOnImageCapturedListener (ImageCapturedListener listener)
void | removeOnImageCapturedListener (ImageCapturedListener listener)
void | setVibrationEnabled (boolean enable)
boolean | isVibrationEnabled ()
void | takePicture ()
void | takePictureContinually ()
void | stopCapture ()
void | onImageCaptured (ImageCapturedEvent event)
Invoked when the camera captures an image. More...
void | onAutoFocus (AutoFocusResultEvent event)
Invoked when the camera completes focusing. More...
void | onLevelness (LevelnessEvent event)
Invoked when the orientation of the device changes. More...
void | onStabilityDelay (StabilityDelayEvent event)
Invoked when stability levels change. More...
void | destroy ()

Additional Inherited Members

- Protected Member Functions inherited from DocumentBaseCaptureExperience
void | initBase (ImageCaptureView view, IDetectionAdapter adapter, DocumentBaseCaptureExperienceCriteriaHolder criteria)
- Protected Member Functions inherited from CaptureExperience
void | invokeImageCapturedListeners (ImageCapturedEvent event)
boolean | captureCriteriaMetInternal (CaptureExperienceData data)
- Protected Attributes inherited from DocumentBaseCaptureExperience
Context | _ctx
- Protected Attributes inherited from CaptureExperience
CaptureExperienceData | _captureExperienceData = new CaptureExperienceData()
final Object | _lock
boolean | _sdkCaptureRequested
boolean | _continuousCapture
ImageCaptureView _imageCaptureView
final Handler | _uiHandler = new Handler(Looper.getMainLooper())
float | _aspectRatio
Set< ImageCapturedListener > | _imageCapturedListeners = new LinkedHashSet<ImageCapturedListener>()
Vibrator | _vibrator
boolean | _vibrationEnabled = false

Detailed Description

This class is responsible for rendering an enhanced visual experience on an ImageCaptureView and provides feedback to guide the user to take a clear, legible and optimally zoomed in photo of a document. Criteria of such a document can be specified by using a setCaptureCriteria(FixedAspectRatioExperienceCriteriaHolder) method.

A photo will be taken automatically once the specified criteria are met, and takePicture() or takePictureContinually() has been called.

We recommend to use this experience for ID capture and Credit cards capture.

Note: FixedAspectRatioCaptureExperience is best used on a view that occupies the maximum possible area of its parent view.

Constructor & Destructor Documentation

FixedAspectRatioCaptureExperience ( ImageCaptureView view )

Constructs an experience on a given ImageCaptureView.

Parameters
view The ImageCaptureView this will be drawn onto
FixedAspectRatioCaptureExperience | ( | ImageCaptureView | view,
 |  | FixedAspectRatioExperienceCriteriaHolder | criteria
 | ) |  |

Constructs an experience on a given ImageCaptureView with specific FixedAspectRatioExperienceCriteriaHolder

Parameters
view | The ImageCaptureView this will be drawn onto
criteria | The criteria used to determine if a photo should be taken

Member Function Documentation

FixedAspectRatioExperienceCriteriaHolder getCaptureCriteria ( )

Returns the criteria used to determine if a photo should be taken.

Returns
FixedAspectRatioCaptureExperienceCriteriaHolder
See also
FixedAspectRatioExperienceCriteriaHolder
CaptureMessage getCapturedMessage ( )

Returns the attributes of the message that will be displayed when a document is captured.

Default configuration:

  • message: "Done!"
  • text color: green
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 16
  • typeface: not specified
  • messageIcons: checkmark icon from package resource stream
    Icon is placed inside of the balloon. Its position and size depend on the balloon and text size.
    Icon will be centered inside balloon if there is no text message, otherwise it will be horizontally centered and shifted to the top.
    Icon is scaled to fit available balloon space with fixed aspect ratio.
  • orientation: CaptureMessage.KUIMessageOrientation#PORTRAIT
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setCapturedMessage(CaptureMessage)
CaptureMessage
CaptureMessage getHoldParallelMessage ( )

Returns the attributes of the message that will be displayed when the capture experience needs to instruct the user to hold the device more level.
The levelness thresholds can be set using the CaptureExperienceCriteriaHolder#setPitchThreshold(int) and CaptureExperienceCriteriaHolder#setRollThreshold(int) methods.

Default configuration:

  • message: "Hold Device Level"
  • text color: white
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 20
  • typeface: not specified
  • messageIcons: hold parallel icons from package resource stream
    Icon is placed inside of the balloon. Its position and size depend on the balloon and text size.
    Icon will be centered inside balloon if there is no text message, otherwise it will be horizontally centered and shifted to the top.
    Icon is scaled to fit available balloon space with fixed aspect ratio.
  • orientation: CaptureMessage.KUIMessageOrientation#PORTRAIT
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setHoldParallelMessage(CaptureMessage)
CaptureMessage
CaptureMessage getHoldSteadyMessage ( )

Returns the attributes of the message that is displayed on the capture control to direct the user to hold the device steady so that a clear focused image can be captured. This message is shown when all the constraints are met and ready to capture.

Default configuration:

  • message: "Hold Steady"
  • text color: red
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 16
  • typeface: not specified
  • messageIcons: camera icons from package resource stream
    Icon is placed inside of the balloon. Its position and size depend on the balloon and text size.
    Icon will be centered inside balloon if there is no text message, otherwise it will be horizontally centered and shifted to the top.
    Icon is scaled to fit available balloon space with fixed aspect ratio.
  • orientation: CaptureMessage.KUIMessageOrientation#PORTRAIT
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setHoldSteadyMessage(CaptureMessage)
CaptureMessage
void setCaptureCriteria ( FixedAspectRatioExperienceCriteriaHolder criteria )

Calling this method will cause all of the capture related parameters to be configured

Parameters
criteria The criteria used to determine if a photo should be taken
See also
FixedAspectRatioExperienceCriteriaHolder
void setCenterMessage ( CaptureMessage centerMessage )

This instruction is not supported, always set to invisible.

Parameters
centerMessage : CaptureMessage
See also
getCenterMessage()
CaptureMessage
void setRotateMessage ( CaptureMessage message )

This instruction is not supported, always set to invisible.

Parameters
message CaptureMessage
See also
getRotateMessage()
CaptureMessage
void setZoomInMessage ( CaptureMessage zoomInMessage )

This instruction is not supported, always set to invisible.

Parameters
zoomInMessage : CaptureMessage
See also
getZoomInMessage()
CaptureMessage
void setZoomOutMessage ( CaptureMessage zoomOutMessage )

This instruction is not supported, always set to invisible.

Parameters
zoomOutMessage : CaptureMessage
See also
getZoomOutMessage()
CaptureMessage
The documentation for this class was generated from the following file:
  • FixedAspectRatioCaptureExperience.java


Kofax Mobile SDK API Reference: FixedAspectRatioExperienceCriteriaHolder Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • FixedAspectRatioExperienceCriteriaHolder
Public Member Functions | List of all members
FixedAspectRatioExperienceCriteriaHolder Class Reference
Inheritance diagram for FixedAspectRatioExperienceCriteriaHolder:
DocumentBaseCaptureExperienceCriteriaHolder CaptureExperienceCriteriaHolder

Public Member Functions

FixedAspectRatioExperienceCriteriaHolder ()
void | setDetectionSettings (FixedAspectRatioDetectionSettings detectionSettings)
FixedAspectRatioDetectionSettings getDetectionSettings ()
boolean | isOrientationEnabled ()
void | setOrientationEnabled (boolean enabled)
- Public Member Functions inherited from DocumentBaseCaptureExperienceCriteriaHolder
DocumentBaseCaptureExperienceCriteriaHolder ()
boolean | isStabilityThresholdEnabled ()
void | setStabilityThresholdEnabled (boolean stabilityThresholdEnabled)
int | getStabilityThreshold ()
void | setStabilityThreshold (int stabilityThreshold)
boolean | isPitchThresholdEnabled ()
void | setPitchThresholdEnabled (boolean pitchThresholdEnabled)
int | getPitchThreshold ()
void | setPitchThreshold (int pitchThreshold)
boolean | isRollThresholdEnabled ()
void | setRollThresholdEnabled (boolean rollThresholdEnabled)
int | getRollThreshold ()
void | setRollThreshold (int rollThreshold)
boolean | isFocusEnabled ()
void | setFocusEnabled (boolean focusEnabled)
boolean | isOrientationEnabled ()
void | setOrientationEnabled (boolean enabled)
void | setHoldSteadyDelay (double seconds)
Sets the minimum duration in seconds the hold steady message should be shown before taking a picture. More...
double | getHoldSteadyDelay ()
Returns the minimum duration in seconds the hold steady message should be shown before taking a picture. More...
void | setPageDetectionEnabled (boolean enabled)
Manages page detection constraint. More...
boolean | isPageDetectionEnabled ()
- Public Member Functions inherited from CaptureExperienceCriteriaHolder
CaptureExperienceCriteriaHolder ()
boolean | isStabilityThresholdEnabled ()
void | setStabilityThresholdEnabled (boolean stabilityThresholdEnabled)
int | getStabilityThreshold ()
void | setStabilityThreshold (int stabilityThreshold)
boolean | isPitchThresholdEnabled ()
void | setPitchThresholdEnabled (boolean pitchThresholdEnabled)
int | getPitchThreshold ()
void | setPitchThreshold (int pitchThreshold)
boolean | isRollThresholdEnabled ()
void | setRollThresholdEnabled (boolean rollThresholdEnabled)
int | getRollThreshold ()
void | setRollThreshold (int rollThreshold)
boolean | isFocusEnabled ()
void | setFocusEnabled (boolean focusEnabled)
boolean | isOrientationEnabled ()
void | setOrientationEnabled (boolean enabled)
void | setRefocusEnabled (boolean enabled)
boolean | isRefocusBeforeCaptureEnabled ()

Detailed Description

This class allows all of the capture related parameters to be configured.

Constructor & Destructor Documentation

FixedAspectRatioExperienceCriteriaHolder ( )

Member Function Documentation

FixedAspectRatioDetectionSettings getDetectionSettings ( )

Returns the Fixed Aspect Ratio detection settings.

Returns
the Fixed Aspect Ratio detection settings
boolean isOrientationEnabled ( )

Not supported. Setting this property do nothing.

Returns
Returns
true
whatever was set.
See also
setOrientationEnabled(boolean)
void setDetectionSettings ( FixedAspectRatioDetectionSettings detectionSettings )

Sets the Fixed Aspect Ratio detection settings.

Parameters
detectionSettings the Fixed Aspect Ratio detection settings
void setOrientationEnabled ( boolean enabled )

Not supported. Setting this property do nothing.

Parameters
enabled true to enable and false to disable.
See also
isOrientationEnabled()
The documentation for this class was generated from the following file:
  • FixedAspectRatioExperienceCriteriaHolder.java


Kofax Mobile SDK API Reference: PassportCaptureExperience Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • PassportCaptureExperience
Public Member Functions | List of all members
PassportCaptureExperience Class Reference
Inheritance diagram for PassportCaptureExperience:
DocumentBaseCaptureExperience CaptureExperience StabilityDelayListener LevelnessListener AutoFocusResultListener ImageCapturedListener

Public Member Functions

PassportCaptureExperience (ImageCaptureView view)
PassportCaptureExperience (ImageCaptureView view, PassportCaptureExperienceCriteriaHolder criteria)
CaptureMessage getUserInstructionMessage ()
void | setUserInstructionMessage (CaptureMessage userInstructionsMessage)
CaptureMessage getCenterMessage ()
void | setCenterMessage (CaptureMessage centerMessage)
Bitmap | getPassportSampleImage ()
void | setPassportSampleImage (Bitmap passportSampleImage)
void | setCaptureCriteria (PassportCaptureExperienceCriteriaHolder criteria)
PassportCaptureExperienceCriteriaHolder getCaptureCriteria ()
- Public Member Functions inherited from DocumentBaseCaptureExperience
DocumentBaseCaptureExperience (ImageCaptureView view, DocumentBaseCaptureExperienceCriteriaHolder criteria)
final void | addOnImageCapturedListener (ImageCapturedListener listener)
final void | removeOnImageCapturedListener (ImageCapturedListener listener)
final void | setVibrationEnabled (boolean enable)
Manage vibration after an image is captured. More...
boolean | isVibrationEnabled ()
final void | setDiagnosticsViewEnabled (boolean enabled)
boolean | isDiagnosticsViewEnabled ()
void | takePicture ()
void | takePictureContinually ()
void | stopCapture ()
void | destroy ()
void | enableAnimationTutor (boolean enable)
Sets whether or not to show an animated tutorial about how to capture a document. More...
boolean | isAnimationTutorEnable ()
CaptureMessage getUserInstructionMessage ()
void | setUserInstructionMessage (CaptureMessage userInstructionsMessage)
CaptureMessage getTutorialDismissMessage ()
void | setTutorialDismissMessage (CaptureMessage tutorialDismissMessage)
CaptureMessage getHoldSteadyMessage ()
void | setHoldSteadyMessage (CaptureMessage holdSteadyMessage)
void | setCenterMessage (CaptureMessage centerMessage)
CaptureMessage getCenterMessage ()
void | setZoomInMessage (CaptureMessage zoomInMessage)
CaptureMessage getZoomInMessage ()
void | setZoomOutMessage (CaptureMessage zoomOutMessage)
CaptureMessage getZoomOutMessage ()
void | setRotateMessage (CaptureMessage message)
CaptureMessage getRotateMessage ()
void | setHoldParallelMessage (CaptureMessage message)
CaptureMessage getHoldParallelMessage ()
void | setCapturedMessage (CaptureMessage capturedMessage)
CaptureMessage getCapturedMessage ()
void | setOuterViewFinderColor (int colorCode)
Outer view finder color. More...
int | getOuterViewFinderColor ()
void | setGuidanceFrameColor (int colorCode)
Guidance frame color. More...
void | setSteadyGuidanceFrameColor (int colorCode)
Steady guidance frame color. More...
int | getGuidanceFrameColor ()
Bitmap | getDocumentSampleImage ()
void | setDocumentSampleImage (Bitmap documentSampleImage)
void | addPageDetectionListener (PageDetectionListener listener)
void | removePageDetectionListener (PageDetectionListener listener)
- Public Member Functions inherited from CaptureExperience
void | addOnImageCapturedListener (ImageCapturedListener listener)
void | removeOnImageCapturedListener (ImageCapturedListener listener)
void | setVibrationEnabled (boolean enable)
boolean | isVibrationEnabled ()
void | takePicture ()
void | takePictureContinually ()
void | stopCapture ()
void | onImageCaptured (ImageCapturedEvent event)
Invoked when the camera captures an image. More...
void | onAutoFocus (AutoFocusResultEvent event)
Invoked when the camera completes focusing. More...
void | onLevelness (LevelnessEvent event)
Invoked when the orientation of the device changes. More...
void | onStabilityDelay (StabilityDelayEvent event)
Invoked when stability levels change. More...
void | destroy ()

Additional Inherited Members

- Protected Member Functions inherited from DocumentBaseCaptureExperience
void | initBase (ImageCaptureView view, IDetectionAdapter adapter, DocumentBaseCaptureExperienceCriteriaHolder criteria)
- Protected Member Functions inherited from CaptureExperience
void | invokeImageCapturedListeners (ImageCapturedEvent event)
boolean | captureCriteriaMetInternal (CaptureExperienceData data)
- Protected Attributes inherited from DocumentBaseCaptureExperience
Context | _ctx
- Protected Attributes inherited from CaptureExperience
CaptureExperienceData | _captureExperienceData = new CaptureExperienceData()
final Object | _lock
boolean | _sdkCaptureRequested
boolean | _continuousCapture
ImageCaptureView _imageCaptureView
final Handler | _uiHandler = new Handler(Looper.getMainLooper())
float | _aspectRatio
Set< ImageCapturedListener > | _imageCapturedListeners = new LinkedHashSet<ImageCapturedListener>()
Vibrator | _vibrator
boolean | _vibrationEnabled = false

Detailed Description

This class is responsible for rendering the enhanced visual experience on an ImageCaptureView and provides feedback to guide the user to take a clear, legible and optimally zoomed in photo of a passport. Criteria of such a passport can be specified by using a setCaptureCriteria(PassportCaptureExperienceCriteriaHolder) method.

A photo will be taken automatically once the specified criteria are met, and takePicture() or takePictureContinually() has been called.

Note: PassportCaptureExperience is best used on a view that occupies the maximum possible area of its parent view.

Constructor & Destructor Documentation

PassportCaptureExperience ( ImageCaptureView view )

Constructs an experience on a given ImageCaptureView.

Parameters
view The ImageCaptureView this will be drawn onto
PassportCaptureExperience | ( | ImageCaptureView | view,
 |  | PassportCaptureExperienceCriteriaHolder | criteria
 | ) |  |

Constructs an experience on a given ImageCaptureView with specific PassportCaptureExperienceCriteriaHolder

Parameters
view | The ImageCaptureView this will be drawn onto
criteria | The criteria used to determine if a photo should be taken

Member Function Documentation

PassportCaptureExperienceCriteriaHolder getCaptureCriteria ( )

Returns the criteria used to determine if a photo should be taken.

Returns
PassportCaptureExperienceCriteriaHolder
See also
PassportCaptureExperienceCriteriaHolder
CaptureMessage getCenterMessage ( )

Returns the attributes of the message that is displayed when document is not enough centered in the target frame for capture.

Default configuration:

  • message: "Center Passport"
  • text color: white
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 16
  • typeface: not specified
  • messageIcons: not specified
  • orientation: CaptureMessage.KUIMessageOrientation#LANDSCAPE
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage The center message
See also
setCenterMessage(CaptureMessage)
CaptureMessage
Bitmap getPassportSampleImage ( )

The Bitmap of a sample passport that is displayed over the passport frame area when the animated tutorial is enabled.

Returns
Bitmap The sample passport image
See also
DocumentBaseCaptureExperience::setDocumentSampleImage(android.graphics.Bitmap)
CaptureMessage getUserInstructionMessage ( )

Returns the attributes of the instruction message that is displayed on the capture control while the user is trying to capture. This instruction will be displayed during periods where other guidance is not available to correct a user. This may happen in particular when the user is holding a device far away from a document, preventing detection.

The following CaptureMessage property methods are not supported for this message: getMessageIcons() / setMessageIcons(Bitmap[]).

Default configuration:

  • message: "Fill viewable area with passport"
  • text color: white
  • background color: transparent
  • background drawable: not specified
  • text size: 32
  • typeface: not specified
  • orientation: CaptureMessage.KUIMessageOrientation#LANDSCAPE
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage The instruction capture message
See also
CaptureMessage
void setCaptureCriteria ( PassportCaptureExperienceCriteriaHolder criteria )

Calling this method will cause all of the capture related parameters to be configured

Parameters
criteria The criteria used to determine if a photo should be taken
See also
PassportCaptureExperienceCriteriaHolder
void setCenterMessage ( CaptureMessage centerMessage )

This instruction will be displayed when document is not centered in the target frame

Parameters
centerMessage The center message
See also
CaptureMessage
void setPassportSampleImage ( Bitmap passportSampleImage )

The specified Bitmap of a sample passport is displayed over the passport frame area when the animated tutorial is enabled. The sample passport image is stretched if necessary to fill the entire passport frame area. While the tutorial is running, MICR and guidance animation are superimposed over the image. A default passport sample image is used if this is not set by the app.

Parameters
passportSampleImage The sample passport image
See also
enableAnimationTutor(boolean)
void setUserInstructionMessage ( CaptureMessage userInstructionsMessage )

A property to configure the attributes of the instruction message that is displayed on the capture control while user is trying to capture.

Parameters
userInstructionsMessage : CaptureMessage
See also
CaptureMessage
The documentation for this class was generated from the following file:
  • PassportCaptureExperience.java


Kofax Mobile SDK API Reference: PassportCaptureExperienceCriteriaHolder Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • PassportCaptureExperienceCriteriaHolder
Public Member Functions | List of all members
PassportCaptureExperienceCriteriaHolder Class Reference
Inheritance diagram for PassportCaptureExperienceCriteriaHolder:
DocumentBaseCaptureExperienceCriteriaHolder CaptureExperienceCriteriaHolder

Public Member Functions

PassportCaptureExperienceCriteriaHolder ()
PassportCaptureExperienceCriteriaHolder (PassportCaptureExperienceCriteriaHolder criteria)
void | setDetectionSettings (PassportDetectionSettings detectionSettings)
PassportDetectionSettings getPassportDetectionSettings ()
- Public Member Functions inherited from DocumentBaseCaptureExperienceCriteriaHolder
DocumentBaseCaptureExperienceCriteriaHolder ()
boolean | isStabilityThresholdEnabled ()
void | setStabilityThresholdEnabled (boolean stabilityThresholdEnabled)
int | getStabilityThreshold ()
void | setStabilityThreshold (int stabilityThreshold)
boolean | isPitchThresholdEnabled ()
void | setPitchThresholdEnabled (boolean pitchThresholdEnabled)
int | getPitchThreshold ()
void | setPitchThreshold (int pitchThreshold)
boolean | isRollThresholdEnabled ()
void | setRollThresholdEnabled (boolean rollThresholdEnabled)
int | getRollThreshold ()
void | setRollThreshold (int rollThreshold)
boolean | isFocusEnabled ()
void | setFocusEnabled (boolean focusEnabled)
boolean | isOrientationEnabled ()
void | setOrientationEnabled (boolean enabled)
void | setHoldSteadyDelay (double seconds)
Sets the minimum duration in seconds the hold steady message should be shown before taking a picture. More...
double | getHoldSteadyDelay ()
Returns the minimum duration in seconds the hold steady message should be shown before taking a picture. More...
void | setPageDetectionEnabled (boolean enabled)
Manages page detection constraint. More...
boolean | isPageDetectionEnabled ()
- Public Member Functions inherited from CaptureExperienceCriteriaHolder
CaptureExperienceCriteriaHolder ()
boolean | isStabilityThresholdEnabled ()
void | setStabilityThresholdEnabled (boolean stabilityThresholdEnabled)
int | getStabilityThreshold ()
void | setStabilityThreshold (int stabilityThreshold)
boolean | isPitchThresholdEnabled ()
void | setPitchThresholdEnabled (boolean pitchThresholdEnabled)
int | getPitchThreshold ()
void | setPitchThreshold (int pitchThreshold)
boolean | isRollThresholdEnabled ()
void | setRollThresholdEnabled (boolean rollThresholdEnabled)
int | getRollThreshold ()
void | setRollThreshold (int rollThreshold)
boolean | isFocusEnabled ()
void | setFocusEnabled (boolean focusEnabled)
boolean | isOrientationEnabled ()
void | setOrientationEnabled (boolean enabled)
void | setRefocusEnabled (boolean enabled)
boolean | isRefocusBeforeCaptureEnabled ()

Detailed Description

This class allows all of the capture related parameters to be configured.

Constructor & Destructor Documentation

PassportCaptureExperienceCriteriaHolder ( )
PassportCaptureExperienceCriteriaHolder ( PassportCaptureExperienceCriteriaHolder criteria )

Member Function Documentation

PassportDetectionSettings getPassportDetectionSettings ( )
Returns
the passport detection settings
void setDetectionSettings ( PassportDetectionSettings detectionSettings )

Sets the passport detection settings.

Parameters
detectionSettings the document detection settings
The documentation for this class was generated from the following file:
  • PassportCaptureExperienceCriteriaHolder.java


Kofax Mobile SDK API Reference: SelfieBaseCaptureExperience Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • SelfieBaseCaptureExperience
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
SelfieBaseCaptureExperience Class Reference
Inheritance diagram for SelfieBaseCaptureExperience:
SelfieCaptureExperience

Public Member Functions

SelfieBaseCaptureExperience (ImageCaptureView view, SelfieCaptureExperienceCriteriaHolder criteria)
SelfieCaptureExperienceCriteriaHolder getCaptureCriteria ()
void | setVibrationEnabled (boolean enable)
boolean | isVibrationEnabled ()
CaptureMessage getUserInstructionMessage ()
CaptureMessage getBlinkMessage ()
CaptureMessage getHoldSteadyMessage ()
CaptureMessage getCapturedMessage ()
void | setUserInstructionMessage (CaptureMessage userInstructionMessage)
void | setBlinkMessage (CaptureMessage blinkMessage)
void | setHoldSteadyMessage (CaptureMessage holdSteadyMessage)
void | setCapturedMessage (CaptureMessage capturedMessage)
void | takePicture ()
void | stopCapture ()
void | setOuterViewFinderColor (int colorCode)
int | getOuterViewFinderColor ()
void | setFrameColor (int colorCode)
int | getFrameColor ()
double | getPaddingPercent ()
final void | addOnImageCapturedListener (ImageCapturedListener listener)
final void | removeOnImageCapturedListener (ImageCapturedListener listener)
void | destroy ()

Protected Member Functions

void initBase (ImageCaptureView view, SelfieCaptureExperienceCriteriaHolder criteria)

Protected Attributes

Context _ctx

Detailed Description

This class renders an enhanced visual experience on an ImageCaptureView and provides feedback to guide the user to take a clear, legible photo of a selfie. Criteria can be specified by using a setCaptureCriteria method.

A photo will be taken automatically once the specified criteria are met, and takePicture() has been called.

Constructor & Destructor Documentation

SelfieBaseCaptureExperience | ( | ImageCaptureView | view,
 |  | SelfieCaptureExperienceCriteriaHolder | criteria
 | ) |  |

Note: This is best used on a view that occupies the maximum possible area of its parent view.

Parameters
view | The view this will be drawn onto
criteria | The criteria used to determine when a photo should be taken.

Member Function Documentation

final void addOnImageCapturedListener ( ImageCapturedListener listener )

Invoked after the camera captures an image and when all capture messages were shown. To allow for every message to be played, this method should be used to set an ImageCapturedListener instead of the method on the ImageCaptureView class.

Parameters
listener The image captured listener
See also
ImageCapturedListener
void destroy ( )

Detaches from the ImageCaptureView and destroys this experience.

CaptureMessage getBlinkMessage ( )

Returns the attributes of the instruction message that is displayed to guide the user to blink his eyes after the face aligned properly in the target frame This will be displayed after the user aligned his face properly in the target frame.

Default configuration:

  • message: "Blink now"
  • text color: white
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 20
  • typeface: not specified
  • messageIcons: not specified
  • orientation: CaptureMessage.KUIMessageOrientation#PORTRAIT
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setBlinkMessage(CaptureMessage)
CaptureMessage
SelfieCaptureExperienceCriteriaHolder getCaptureCriteria ( )

Returns the criteria used to determine if a photo should be taken.

Returns
SelfieCaptureExperienceCriteriaHolder
See also
SelfieCaptureExperienceCriteriaHolder
CaptureMessage getCapturedMessage ( )

Returns the attributes of the message that will be displayed when a selfie is captured.

Default configuration:

  • message: "Done!"
  • text color: green
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 20
  • typeface: not specified
  • messageIcons: checkmark icon from package resource stream
    Icon is placed inside of the balloon. Its position and size depend on the balloon and text size.
    Icon will be centered inside balloon if there is no text message, otherwise it will be horizontally centered and shifted to the top.
    Icon is scaled to fit available balloon space with fixed aspect ratio.
  • orientation: CaptureMessage.KUIMessageOrientation#PORTRAIT
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setCapturedMessage(CaptureMessage)
CaptureMessage
int getFrameColor ( )

Returns the target frame border color.

Returns
the target frame color
CaptureMessage getHoldSteadyMessage ( )

Returns the attributes of the message that is displayed on the capture control to direct the user to hold the device steady so that a clear focused image can be captured. This message is shown when all the constraints are met and ready to capture.

Default configuration:

  • message: "Hold Steady"
  • text color: White
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 20
  • typeface: not specified
  • messageIcons: not specified
  • orientation: CaptureMessage.KUIMessageOrientation#PORTRAIT
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setHoldSteadyMessage(CaptureMessage)
CaptureMessage
int getOuterViewFinderColor ( )

Returns the target frame outer view color.

Returns
the target frame outer view color.
double getPaddingPercent ( )

The percentage of the total width and height used as padding Valid values are [0-50].

CaptureMessage getUserInstructionMessage ( )

Returns the attributes of the instruction message that is displayed on the capture control while the user is trying to capture. This message will be displayed to instruct the user to fit his face in the frame. This may happen in particular when the user is holding a device too far away from the face or when the face is out of the target frame.

Default configuration:

  • message: "Center Face"
  • text color: white
  • background color: black with 0.7 alpha component
  • background drawable: not specified
  • text size: 20
  • typeface: not specified
  • messageIcons: not specified
  • orientation: CaptureMessage.KUIMessageOrientation#PORTRAIT
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
setUserInstructionMessage(CaptureMessage)
CaptureMessage
void initBase | ( | ImageCaptureView | view,
 |  | SelfieCaptureExperienceCriteriaHolder | criteria
 | ) |  |
protected
boolean isVibrationEnabled ( )
Returns
Whether vibration availability during capturing
final void removeOnImageCapturedListener ( ImageCapturedListener listener )

Remove ImageCapturedListener.

Parameters
listener The image captured listener
See also
ImageCapturedListener
addOnImageCapturedListener(ImageCapturedListener)
void setBlinkMessage ( CaptureMessage blinkMessage )

A property to configure the attributes of the instruction message that is displayed to blink his eyes after the user properly aligned his face in the target frame.

Parameters
blinkMessage : CaptureMessage
See also
getUserInstructionMessage()
CaptureMessage
void setCapturedMessage ( CaptureMessage capturedMessage )

This message will be displayed when the selfie is captured.

Parameters
capturedMessage : CaptureMessage
See also
getCapturedMessage()
CaptureMessage
void setFrameColor ( int colorCode )

The target frame border color can be set here.

Parameters
colorCode The target frame border color.
void setHoldSteadyMessage ( CaptureMessage holdSteadyMessage )

A property to configure the attributes of the message that is displayed on the capture control to direct the user to hold the device steady so that a clear focused image can be captured. This message is shown when all the constraints are met and ready to capture.

Parameters
holdSteadyMessage : CaptureMessage
See also
getHoldSteadyMessage()
CaptureMessage
void setOuterViewFinderColor ( int colorCode )

The target frame outer view color can be set here.

Parameters
colorCode the target frame outer view color.
void setUserInstructionMessage ( CaptureMessage userInstructionMessage )

A property to configure the attributes of the instruction message that is displayed on the capture control while the user is trying to capture.

Parameters
userInstructionMessage : CaptureMessage
See also
getUserInstructionMessage()
CaptureMessage
void setVibrationEnabled ( boolean enable )

Method to manage vibration availability during capturing.

Parameters
enable Whether to vibrate during capture
void stopCapture ( )

This is the counterpart to takePicture(). Calling this method will stop automatic image capture when the criteria are satisfied.

See also
takePicture()
void takePicture ( )

Calling this method will start the process of monitoring the capture criteria that was configured to determine when a document that meets all the criteria can be captured. The static frame will change its color to green to indicate that a document will be captured soon.

Member Data Documentation

Context _ctx
protected
The documentation for this class was generated from the following file:
  • SelfieBaseCaptureExperience.java


Kofax Mobile SDK API Reference: SelfieCaptureExperience Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • SelfieCaptureExperience
Public Member Functions | List of all members
SelfieCaptureExperience Class Reference
Inheritance diagram for SelfieCaptureExperience:
SelfieBaseCaptureExperience

Public Member Functions

SelfieCaptureExperience (ImageCaptureView view)
SelfieCaptureExperience (ImageCaptureView view, SelfieCaptureExperienceCriteriaHolder criteria)
void | setCaptureCriteria (SelfieCaptureExperienceCriteriaHolder criteria)
- Public Member Functions inherited from SelfieBaseCaptureExperience
SelfieBaseCaptureExperience (ImageCaptureView view, SelfieCaptureExperienceCriteriaHolder criteria)
SelfieCaptureExperienceCriteriaHolder getCaptureCriteria ()
void | setVibrationEnabled (boolean enable)
boolean | isVibrationEnabled ()
CaptureMessage getUserInstructionMessage ()
CaptureMessage getBlinkMessage ()
CaptureMessage getHoldSteadyMessage ()
CaptureMessage getCapturedMessage ()
void | setUserInstructionMessage (CaptureMessage userInstructionMessage)
void | setBlinkMessage (CaptureMessage blinkMessage)
void | setHoldSteadyMessage (CaptureMessage holdSteadyMessage)
void | setCapturedMessage (CaptureMessage capturedMessage)
void | takePicture ()
void | stopCapture ()
void | setOuterViewFinderColor (int colorCode)
int | getOuterViewFinderColor ()
void | setFrameColor (int colorCode)
int | getFrameColor ()
double | getPaddingPercent ()
final void | addOnImageCapturedListener (ImageCapturedListener listener)
final void | removeOnImageCapturedListener (ImageCapturedListener listener)
void | destroy ()

Additional Inherited Members

- Protected Member Functions inherited from SelfieBaseCaptureExperience
void | initBase (ImageCaptureView view, SelfieCaptureExperienceCriteriaHolder criteria)
- Protected Attributes inherited from SelfieBaseCaptureExperience
Context | _ctx

Detailed Description

This class is responsible for rendering the enhanced visual experience on an ImageCaptureView and provides feedback to guide the user to take a clear, legible photo of a Selfie. Criteria of such a Selfie can be specified by using a setCaptureCriteria(SelfieCaptureExperienceCriteriaHolder) method.

A photo will be taken automatically once the specified criteria are met, and takePicture() has been called.

Note
This class has Google Play services vision APIs dependency. Hence application needs to set up project with the Google Play services vision SDK. Recommended minimum version is com.google.android.gms:play-services-vision:10.0.1. The device should have only stable version of the google play services. All the dependencies will be downloaded at the installation time in order to run the detection. But if that download has not yet completed when your app starts, then the detector will not detect any faces (at least initially). This could happen if the user is not online, if the user lacks sufficient storage space on their device, or if the download is otherwise delayed (e.g., due to a slow network). SelfieCaptureExperience will render the same message on ImageCaptureView.

The detector will automatically become operational once the dependencies have been successfully downloaded on the device.

Constructor & Destructor Documentation

SelfieCaptureExperience ( ImageCaptureView view )

Constructs an experience on a given ImageCaptureView.

KmcRuntimeException will be thrown, if Google Play Services is not installed, up-to-date, or enabled.

Parameters
view The ImageCaptureView this will be drawn onto
Exceptions
KmcRuntimeException
SelfieCaptureExperience | ( | ImageCaptureView | view,
 |  | SelfieCaptureExperienceCriteriaHolder | criteria
 | ) |  |

Constructs an experience on a given ImageCaptureView with specific SelfieCaptureExperienceCriteriaHolder

KmcRuntimeException will be thrown, if Google Play Services is not installed, up-to-date, or enabled.

Parameters
view | The ImageCaptureView this will be drawn onto
criteria | The criteria used to determine if a photo should be taken
Exceptions
KmcRuntimeException

Member Function Documentation

void setCaptureCriteria ( SelfieCaptureExperienceCriteriaHolder criteria )

Calling this method will cause all of the capture related parameters to be configured

Parameters
criteria The criteria used to determine if a photo should be taken
See also
SelfieCaptureExperienceCriteriaHolder
The documentation for this class was generated from the following file:
  • SelfieCaptureExperience.java


Kofax Mobile SDK API Reference: SelfieCaptureExperienceCriteriaHolder Class Reference

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • SelfieCaptureExperienceCriteriaHolder
Public Member Functions | List of all members
SelfieCaptureExperienceCriteriaHolder Class Reference

Public Member Functions

SelfieCaptureExperienceCriteriaHolder ()
void | setDetectionSettings (SelfieDetectionSettings selfieDetectionSettings)
boolean | isFocusEnabled ()
void | setFocusEnabled (boolean focusEnabled)
SelfieDetectionSettings getDetectionSettings ()

Detailed Description

This class allows all of the capture related parameters to be configured.

Constructor & Destructor Documentation

SelfieCaptureExperienceCriteriaHolder ( )

Member Function Documentation

SelfieDetectionSettings getDetectionSettings ( )

Returns the selfie detection settings.

Returns
the selfie detection settings
boolean isFocusEnabled ( )
Returns
boolean Whether the Focus constraint is enabled or not
See also
setFocusEnabled(boolean)
void setDetectionSettings ( SelfieDetectionSettings selfieDetectionSettings )

Sets the document detection settings.

Parameters
selfieDetectionSettings the document detection settings
void setFocusEnabled ( boolean focusEnabled )

A boolean that indicates whether the Focus constraint is enabled. If enabled, this criterion is checked before taking a picture. The default value is true. Leaving it enabled is advisable. Otherwise it is highly likely that out of focus images are captured.

Parameters
focusEnabled whether the Focus constraint is enabled or not
See also
isFocusEnabled()
The documentation for this class was generated from the following file:
  • SelfieCaptureExperienceCriteriaHolder.java


Kofax Mobile SDK API Reference: CameraType Enum Reference

  • kmc
  • kui
  • uicontrols
  • data
  • CameraType
Public Attributes | List of all members
CameraType Enum Reference

This enum represents the camera type. More...

Public Attributes

BACK_CAMERA
FRONT_CAMERA

Detailed Description

This enum represents the camera type.

This enum represents the camera type : FRONT_CAMERA, BACK_CAMERA.

Member Data Documentation

BACK_CAMERA
FRONT_CAMERA
The documentation for this enum was generated from the following file:
  • CameraType.java


Kofax Mobile SDK API Reference: Flash Enum Reference

  • kmc
  • kui
  • uicontrols
  • data
  • Flash
Public Attributes | List of all members
Flash Enum Reference

This enum represents the various camera flash settings. More...

Public Attributes

ON
OFF
AUTO
TORCH
AUTOTORCH

Detailed Description

This enum represents the various camera flash settings.

This enum represents the various camera flash settings: ON, OFF, AUTO, TORCH, and AUTOTORCH.

Member Data Documentation

AUTO
AUTOTORCH
OFF
ON
TORCH
The documentation for this enum was generated from the following file:
  • Flash.java


Kofax Mobile SDK API Reference: GpsUsageLimits Enum Reference

  • kmc
  • kui
  • uicontrols
  • data
  • GpsUsageLimits
Public Attributes | List of all members
GpsUsageLimits Enum Reference

Public Attributes

NEVER_USE
ALWAYS_USE_IF_ENABLED

Detailed Description

Used to set GpsUsage property which defines limits on the use of GPS coordinates in captured images.

NEVER_USE : GPS coordinates will not be saved in captured images, even if GPS location services are enabled.

ALWAYS_USE_IF_ENABLED : GPS coordinates will be saved in captured images if GPS location services are enabled.

Member Data Documentation

ALWAYS_USE_IF_ENABLED

GPS coordinates will be saved in captured images if GPS location services are enabled

NEVER_USE

GPS coordinates will not be saved in captured images, even if GPS location services are enabled

The documentation for this enum was generated from the following file:
  • GpsUsageLimits.java


Kofax Mobile SDK API Reference: GuidingLine Enum Reference

  • kmc
  • kui
  • uicontrols
  • data
  • GuidingLine
Public Attributes | List of all members
GuidingLine Enum Reference

An enum representing the rendering and orientation of a guiding line for barcode capture. More...

Public Attributes

OFF
LANDSCAPE
PORTRAIT

Detailed Description

An enum representing the rendering and orientation of a guiding line for barcode capture.

Member Data Documentation

LANDSCAPE
OFF
PORTRAIT
The documentation for this enum was generated from the following file:
  • GuidingLine.java


Kofax Mobile SDK API Reference: ImageCacheType Enum Reference

  • kmc
  • kui
  • uicontrols
  • data
  • ImageCacheType
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
ImageCacheType Enum Reference

Public Member Functions

ImageCacheType (String identifier)
String getIdentifier ()

Public Attributes

MEMORY =(ImageCacheType.IMAGE_CACHE_TYPE_MEMORY)
DISK =(ImageCacheType.IMAGE_CACHE_TYPE_DISK)

Static Public Attributes

staticfinal String | IMAGE_CACHE_TYPE_MEMORY = "IMAGE_CACHE_TYPE_MEMORY"
staticfinal String | IMAGE_CACHE_TYPE_DISK = "IMAGE_CACHE_TYPE_DISK"

Detailed Description

Used to set the type of cache that will be used to retain images across re-creation(such as from a configuration change).

Constructor & Destructor Documentation

ImageCacheType ( String identifier )

Member Function Documentation

String getIdentifier ( )

Returns the String identifier for this enum value.

Member Data Documentation

DISK =(ImageCacheType.IMAGE_CACHE_TYPE_DISK)

Images will written to file. Files will be stored in the internal application cache directory. Images will not be lost if the cache is garbage collected. Images will be lost if the internal application cache is cleared.

Maximum size is 20MB.

It is not recommended to use this option if your images may contain sensitive information.

static final String IMAGE_CACHE_TYPE_DISK = "IMAGE_CACHE_TYPE_DISK"
static
static final String IMAGE_CACHE_TYPE_MEMORY = "IMAGE_CACHE_TYPE_MEMORY"
static
MEMORY =(ImageCacheType.IMAGE_CACHE_TYPE_MEMORY)

Images will be cached in memory. Images will be lost if the cache is garbage collected (such as when the application is minimized and the OS needs to free up memory).

Maximum size is 20% of total application memory.

The documentation for this enum was generated from the following file:
  • ImageCacheType.java


Kofax Mobile SDK API Reference: SearchDirection Enum Reference

  • kmc
  • kui
  • uicontrols
  • data
  • SearchDirection
Public Member Functions | Public Attributes | List of all members
SearchDirection Enum Reference

An enum representing a direction or set of directions to search for barcodes. More...

Public Member Functions

SearchDirection (int value)
int getValue ()

Public Attributes

HORIZONTAL =(1 | 2)
VERTICAL =(4 | 8)
ALL =(1 | 2 | 4 | 8)

Detailed Description

An enum representing a direction or set of directions to search for barcodes.

Constructor & Destructor Documentation

SearchDirection ( int value )

Member Function Documentation

int getValue ( )

Member Data Documentation

ALL =(1 | 2 | 4 | 8)
HORIZONTAL =(1 | 2)
VERTICAL =(4 | 8)
The documentation for this enum was generated from the following file:
  • SearchDirection.java


Kofax Mobile SDK API Reference: Symbology Enum Reference

  • kmc
  • kui
  • uicontrols
  • data
  • Symbology
Public Attributes | List of all members
Symbology Enum Reference

An enum representing a barcode symbology. More...

Public Attributes

CODE39
PDF417
QR
DATAMATRIX
CODE128
CODE25
EAN
UPC
CODABAR
AZTEC
CODE93

Detailed Description

An enum representing a barcode symbology.

Member Data Documentation

AZTEC
CODABAR
CODE128
CODE25
CODE39
CODE93
DATAMATRIX
EAN
PDF417
QR
UPC
The documentation for this enum was generated from the following file:
  • Symbology.java


Kofax Mobile SDK API Reference: KuiVersion Class Reference

  • kmc
  • kui
  • uicontrols
  • version
  • KuiVersion
Static Public Member Functions | List of all members
KuiVersion Class Reference

Static Public Member Functions

static String getPackageVersion ()

Detailed Description

This class provides a means of retrieving the version string for the UI Controls package of the Kofax Mobile SDK.

Member Function Documentation

static String getPackageVersion ( )
static
Returns
The version string for the UI Controls package of the Mobile SDK.
The documentation for this class was generated from the following file:
  • KuiVersion.java


Kofax Mobile SDK API Reference: AutoFocusResultEvent Class Reference

  • kmc
  • kui
  • uicontrols
  • AutoFocusResultEvent
Public Member Functions | List of all members
AutoFocusResultEvent Class Reference

This event returns the result of the camera's attempt to auto focus. More...

Inheritance diagram for AutoFocusResultEvent:

Public Member Functions

AutoFocusResultEvent (Object sender, boolean success)
boolean getSuccess ()
Get the result of the camera's attempt to auto focus. More...

Detailed Description

This event returns the result of the camera's attempt to auto focus.

This event returns a boolean that signifies whether the camera succeeded in focusing or not.

Constructor & Destructor Documentation

AutoFocusResultEvent | ( | Object | sender,
 |  | boolean | success
 | ) |  |

Member Function Documentation

boolean getSuccess ( )

Get the result of the camera's attempt to auto focus.

The documentation for this class was generated from the following file:
  • AutoFocusResultEvent.java


Kofax Mobile SDK API Reference: AutoFocusResultListener Interface Reference

  • kmc
  • kui
  • uicontrols
  • AutoFocusResultListener
Public Member Functions | List of all members
AutoFocusResultListener Interface Reference

The listener interface for responding to camera focus events. More...

Inheritance diagram for AutoFocusResultListener:
CaptureExperience DocumentBaseCaptureExperience CheckCaptureExperience DocumentCaptureExperience FixedAspectRatioCaptureExperience PassportCaptureExperience

Public Member Functions

void onAutoFocus (AutoFocusResultEvent event)
Invoked when the camera completes focusing. More...

Detailed Description

The listener interface for responding to camera focus events.

A class that is interested in responding to the camera's auto-focus activity should implement this interface, and then register itself with an ImageCaptureView using the view's addOnAutoFocusResultListener method.

See also
com.kofax.kmc.kui.uicontrols.ImageCaptureView
com.kofax.kmc.kui.uicontrols.ImageCaptureView::addOnAutoFocusResultListener
com.kofax.kmc.kui.uicontrols.ImageCaptureView::removeOnAutoFocusResultListener

Member Function Documentation

void onAutoFocus ( AutoFocusResultEvent event )

Invoked when the camera completes focusing.

Implemented in CaptureExperience.

The documentation for this interface was generated from the following file:
  • AutoFocusResultListener.java


Kofax Mobile SDK API Reference: BarCodeCaptureView Class Reference

  • kmc
  • kui
  • uicontrols
  • BarCodeCaptureView
Classes | Public Member Functions | Protected Member Functions | List of all members
BarCodeCaptureView Class Reference
Inheritance diagram for BarCodeCaptureView:
ImageCaptureView

Classes

class | CameraImageData
class | DecodeInfo

Public Member Functions

BarCodeCaptureView (Context context)
BarCodeCaptureView (Context context, AttributeSet set)
BarCodeCaptureView (Context context, AttributeSet set, int defStyle)
GuidingLine getGuidingLine ()
void | setGuidingLine (GuidingLine value)
Symbology[] getSymbologies ()
void | setSymbologies (Symbology[] value)
SearchDirection[] getSearchDirection ()
void | setSearchDirection (SearchDirection[] value)
void | addBarCodeFoundEventListener (BarCodeFoundListener listener)
void | removeBarCodeFoundEventListener (BarCodeFoundListener listener)
void | readBarcode ()
BoundingTetragon | calculateBound (float[] points, int rotation, int width, int height)
void | onLevelnessChanged (LevelChangedEvent evt)
void | onPreviewFrame (PreviewImageReadyBusEvent evt)
void | onLocationEvent (LocationEvent evt)
void | onLocationEnableEvent (GPSEnabledEvent evt)
- Public Member Functions inherited from ImageCaptureView
ImageCaptureView (Context context)
ImageCaptureView (Context context, AttributeSet set)
ImageCaptureView (Context context, AttributeSet set, int defStyle)
final int | getImagePreviewWidth ()
final int | getImagePreviewHeight ()
ViewGroup | getViewGroup ()
final Flash | getFlash ()
final void | setFlash (Flash flash)
final boolean | isFlashSupported (Flash flash)
final GpsUsageLimits | getGpsUsage ()
final void | setGpsUsage (GpsUsageLimits limits)
final void | setCameraType (CameraType cameraType)
final void | setImageResolution (Size resolution)
final List< Size > | getAllowableImageResolutions ()
final List< Rect > | getFocusAreas ()
final void | setFocusAreas (List< Rect > focusAreas) throws KmcRuntimeException
final int | getMaxFocusAreas ()
final boolean | getUseVideoFrame ()
final void | setUseVideoFrame (boolean useVideo)
final int | getDeviceDeclinationPitch ()
final void | setDeviceDeclinationPitch (int angle)
final int | getDeviceDeclinationRoll ()
final void | setDeviceDeclinationRoll (int angle)
final int | getLuminanceThreshold ()
final void | setLuminanceThreshold (int luminanceThreshold)
final int | getTorchDelay ()
final void | setTorchDelay (int torchDelay)
final void | muteAutoTorch ()
final void | unmuteAutoTorch ()
final void | forceTakePicture ()
final void | forceTakePicture (boolean focusAgain)
final synchronized void | sessionCreate ()
final synchronized void | sessionDismiss ()
final void | addOnAutoFocusResultListener (AutoFocusResultListener listener)
final void | removeOnAutoFocusResultListener (AutoFocusResultListener listener)
final void | addOnImageCapturedListener (ImageCapturedListener listener)
final void | removeOnImageCapturedListener (ImageCapturedListener listener)
final void | addStabilityDelayListener (StabilityDelayListener listener)
final void | removeStabilityDelayListener (StabilityDelayListener listener)
final void | addLevelnessListener (LevelnessListener listener)
final void | removeLevelnessListener (LevelnessListener listener)
final void | addCameraInitializationListener (CameraInitializationListener listener)
final void | removeCameraInitializationListener (CameraInitializationListener listener)
final void | addCameraInitializationFailedListener (CameraInitializationFailedListener listener)
final void | removeCameraInitializationFailedListener (CameraInitializationFailedListener listener)
final void | addPreviewCallbackListener (PreviewCallbackListener listener)
final void | removePreviewCallbackListener (PreviewCallbackListener listener)
final void | addTorchLuminanceListener (TorchLuminanceListener listener)
final void | removeTorchLuminanceListener (TorchLuminanceListener listener)
void | removeAllViews ()
void | surfaceChanged (SurfaceHolder holder, int format, int width, int height)
void | surfaceCreated (SurfaceHolder holder)
void | surfaceDestroyed (SurfaceHolder holder)

Protected Member Functions

void | checkLicense ()
- Protected Member Functions inherited from ImageCaptureView
void | checkLicense ()
void | onLayout (boolean changed, int l, int t, int r, int b)
void | onDetachedFromWindow ()
void | onAttachedToWindow ()

Additional Inherited Members

- Static Public Attributes inherited from ImageCaptureView
static final int | DEFAULT_LUMINANCE_THRESHOLD = 100
static final int | DEFAULT_TORCH_DELAY = 3
- Protected Attributes inherited from ImageCaptureView
IBus | _bus

Detailed Description

This view provides a capture experience optimized for barcode reading. The view provides visual guidance to the end-user to maximize the chances of correctly decoding a barcode. Once the view has been asked to read a barcode, it will search continuously until one is found.

Constructor & Destructor Documentation

BarCodeCaptureView ( Context context )
BarCodeCaptureView | ( | Context | context,
 |  | AttributeSet | set
 | ) |  |
BarCodeCaptureView | ( | Context | context,
 |  | AttributeSet | set,
 |  | int | defStyle
 | ) |  |

Member Function Documentation

void addBarCodeFoundEventListener ( BarCodeFoundListener listener )

Adds the specified barcode search listener to receive barcode events from this view.

BoundingTetragon calculateBound | ( | float[] | points,
 |  | int | rotation,
 |  | int | width,
 |  | int | height
 | ) |  |
void checkLicense ( )
protected
GuidingLine getGuidingLine ( )
Returns
The current guiding line setting.
SearchDirection [] getSearchDirection ( )
Returns
An array of directions being searched for barcodes.
Symbology [] getSymbologies ( )
Returns
An array of symbologies.
void onLevelnessChanged ( LevelChangedEvent evt )
void onLocationEnableEvent ( GPSEnabledEvent evt )
void onLocationEvent ( LocationEvent evt )
void onPreviewFrame ( PreviewImageReadyBusEvent evt )
void readBarcode ( )

This call returns immediately and starts asynchronously searching for a barcode with the current camera and barcode parameters. The search will continue indefinitely until a barcode is found, allowing time for the device to further stabilize and focus if necessary.

Once a barcode is positively read, the BarCodeFoundEvent is raised providing the decoded message and the unprocessed image that was used.

Caller needs to call readBarcode() again to start a new barcode scan.

void removeBarCodeFoundEventListener ( BarCodeFoundListener listener )

Removes the specified barcode search listener from this view.

void setGuidingLine ( GuidingLine value )

The guiding line is a visual aid for aligning barcodes within the preview. A guiding line is rendered as a straight line splitting the preview into two equal parts. The intention is for the line to cross through all the bars of a barcode, like the laser of a linear scanner. The guiding line is turned off by default.

Parameters
value Whether a guiding line should be rendered in PORTRAIT or LANDSCAPE, or turned OFF.
void setSearchDirection ( SearchDirection[] value )

Searching for multiple directions slows down the speed of barcode recognition. If you expect barcodes to only be oriented in certain directions, you should specify only those directions. By default, all directions will be searched, represented by the array [SearchDirection.Horizontal, SearchDirection.Vertical].

Parameters
value An array of search directions.
See also
SearchDirection for all supported values.
void setSymbologies ( Symbology[] value )

Searching for multiple symbologies slows down the speed of barcode recognition. You should only specify the symbologies that you are interested in reading. The set of selected symbologies is empty by default.

Parameters
value An array of symbologies.
The documentation for this class was generated from the following file:
  • BarCodeCaptureView.java


Kofax Mobile SDK API Reference: BarCodeFoundEvent Class Reference

  • kmc
  • kui
  • uicontrols
  • BarCodeFoundEvent
Public Member Functions | List of all members
BarCodeFoundEvent Class Reference

An event that indicates a barcode has been found. More...

Inheritance diagram for BarCodeFoundEvent:

Public Member Functions

BarCodeFoundEvent (Object sender, BarCodeResult barcode, Image image)
BarCodeResult getBarCode ()
Gets the barcode data from the event. More...
Image getImage ()
Gets the image that was used to read the barcode. More...

Detailed Description

An event that indicates a barcode has been found.

This event is raised in response to a barcode being found and successfully decoded by the BarCodeCaptureView following a call to readBarcode. The event includes the decoded barcode data and the unprocessed image that was used to read the barcode.

See also
BarCodeCaptureView
BarCodeCaptureView::readBarcode

Constructor & Destructor Documentation

BarCodeFoundEvent | ( | Object | sender,
 |  | BarCodeResult | barcode,
 |  | Image | image
 | ) |  |

Member Function Documentation

BarCodeResult getBarCode ( )

Gets the barcode data from the event.

BarCodeResult objects originating from BarCodeCaptureView will only include a valid bounding box on 2D symbologies and PDF417.

Returns
The barcode data.
See also
BarCodeResult
Image getImage ( )

Gets the image that was used to read the barcode.

The documentation for this class was generated from the following file:
  • BarCodeFoundEvent.java


Kofax Mobile SDK API Reference: BarCodeFoundListener Interface Reference

  • kmc
  • kui
  • uicontrols
  • BarCodeFoundListener
Public Member Functions | List of all members
BarCodeFoundListener Interface Reference

The listener interface for receiving barcode events. More...

Public Member Functions

void barCodeFound (BarCodeFoundEvent event)
Invoked when a barcode is found. More...

Detailed Description

The listener interface for receiving barcode events.

A class that is interested in processing barcode events should implement this interface, and then register itself with a BarCodeCaptureView using the view's addBarCodeFoundEventListener method.

See also
BarCodeCaptureView
BarCodeCaptureView::addBarCodeFoundEventListener
BarCodeCaptureView::removeBarCodeFoundEventListener

Member Function Documentation

void barCodeFound ( BarCodeFoundEvent event )

Invoked when a barcode is found.

The documentation for this interface was generated from the following file:
  • BarCodeFoundListener.java


Kofax Mobile SDK API Reference: CameraInitializationEvent Class Reference

  • kmc
  • kui
  • uicontrols
  • CameraInitializationEvent
Classes | Public Member Functions | List of all members
CameraInitializationEvent Class Reference

This event fires when the camera is initialized or reinitialized. More...

Inheritance diagram for CameraInitializationEvent:

Classes

enum CameraInitStatus

Public Member Functions

CameraInitializationEvent (Object source, Camera.Size defaultImageResolution, CameraInitStatus cameraInitStatus)
final Size | getDefaultImageCaptureResolution ()
Returns the auto-calculated image capture resolution which becomes the default image resolution used when capturing. More...
final CameraInitStatus | getCameraInitStatus ()
Returns the CameraInitStatus value which represents the reason the camera was initialized. More...

Detailed Description

This event fires when the camera is initialized or reinitialized.

This event fires every time the camera is initialized or reinitialized. The camera will be initialized every time the ImageCaptureView is instantiated. It will be reinitialized every time the application explicitly sets the desired resolution for image capture by calling setImageResolution(Size resolution). It will also be reinitialized every time the application toggles between 'capture video frame as captured frame', and 'capture full-resolution photo' by calling setUseVideoFrame(boolean useVideo). The property getter getDefaultImageCaptureResolution() returns the auto-calculated image capture resolution. The returned resolution is the same resolution that would be set if setImageResolution were never called.
Note: It is recommended for low-resolution devices to not exceed the megapixel value of this size.
Note: The returned resolution may differ depending on the value of getUseVideoFrame().

See also
com.kofax.kmc.kui.uicontrols.ImageCaptureView::getAllowableImageResolutions()
com.kofax.kmc.kui.uicontrols.ImageCaptureView::setImageResolution(Size)
com.kofax.kmc.kui.uicontrols.ImageCaptureView::setUseVideoFrame(boolean)

Constructor & Destructor Documentation

CameraInitializationEvent | ( | Object | source,
 |  | Camera.Size | defaultImageResolution,
 |  | CameraInitStatus | cameraInitStatus
 | ) |  |

Member Function Documentation

final CameraInitStatus getCameraInitStatus ( )

Returns the CameraInitStatus value which represents the reason the camera was initialized.

final Size getDefaultImageCaptureResolution ( )

Returns the auto-calculated image capture resolution which becomes the default image resolution used when capturing.

The documentation for this class was generated from the following file:
  • CameraInitializationEvent.java


Kofax Mobile SDK API Reference: CameraInitializationEvent.CameraInitStatus Enum Reference

  • kmc
  • kui
  • uicontrols
  • CameraInitializationEvent
  • CameraInitStatus
Public Attributes | List of all members
CameraInitializationEvent.CameraInitStatus Enum Reference

Public Attributes

CAMERA_STATUS_UNKNOWN
CAMERA_VIEW_CREATED
CAMERA_IMAGE_RESOLUTION_CHANGED
CAMERA_USE_VIDEO_FRAME_CHANGED

Detailed Description

This values of this enum represent the condition which caused the camera to be initialized, and the CameraInitializationEvent to be fired:

CAMERA_VIEW_CREATED - camera initialized when the ImageCaptureView is first created.

CAMERA_IMAGE_RESOLUTION_CHANGED - camera initialized when the selected image resolution changed.

CAMERA_USE_VIDEO_FRAME_CHANGED - camera initialized when the UseVideoFrame property changed.

Member Data Documentation

CAMERA_IMAGE_RESOLUTION_CHANGED
CAMERA_STATUS_UNKNOWN
CAMERA_USE_VIDEO_FRAME_CHANGED
CAMERA_VIEW_CREATED
The documentation for this enum was generated from the following file:
  • CameraInitializationEvent.java


Kofax Mobile SDK API Reference: CameraInitializationFailedEvent Class Reference

  • kmc
  • kui
  • uicontrols
  • CameraInitializationFailedEvent
Public Member Functions | List of all members
CameraInitializationFailedEvent Class Reference
Inheritance diagram for CameraInitializationFailedEvent:

Public Member Functions

CameraInitializationFailedEvent (Object source, Exception cause)
Exception getCause ()

Detailed Description

This event fires when the camera initialization fails

See also
CameraInitializationFailedListener

Constructor & Destructor Documentation

CameraInitializationFailedEvent | ( | Object | source,
 |  | Exception | cause
 | ) |  |
Parameters
source | the object which fired the event
cause | the cause of the failure

Member Function Documentation

Exception getCause ( )
Returns
the cause of the failure
The documentation for this class was generated from the following file:
  • CameraInitializationFailedEvent.java


Kofax Mobile SDK API Reference: CameraInitializationFailedListener Interface Reference

  • kmc
  • kui
  • uicontrols
  • CameraInitializationFailedListener
Public Member Functions | List of all members
CameraInitializationFailedListener Interface Reference

Public Member Functions

void onCameraInitializationFailed (CameraInitializationFailedEvent event)

Detailed Description

The interface that is required to implement CameraInitializationFailedEvent

See also
com.kofax.kmc.kui.uicontrols.ImageCaptureView::addCameraInitializationFailedListener(CameraInitializationFailedListener)
com.kofax.kmc.kui.uicontrols.ImageCaptureView::removeCameraInitializationFailedListener(CameraInitializationFailedListener)

Member Function Documentation

void onCameraInitializationFailed ( CameraInitializationFailedEvent event )
The documentation for this interface was generated from the following file:
  • CameraInitializationFailedListener.java


Kofax Mobile SDK API Reference: CameraInitializationListener Interface Reference

  • kmc
  • kui
  • uicontrols
  • CameraInitializationListener
Public Member Functions | List of all members
CameraInitializationListener Interface Reference

The interface that is required to implement CameraInitializationEvent. More...

Public Member Functions

void onCameraInitialized (CameraInitializationEvent event)

Detailed Description

The interface that is required to implement CameraInitializationEvent.

Member Function Documentation

void onCameraInitialized ( CameraInitializationEvent event )
The documentation for this interface was generated from the following file:
  • CameraInitializationListener.java


Kofax Mobile SDK API Reference: ImageCapturedEvent Class Reference

  • kmc
  • kui
  • uicontrols
  • ImageCapturedEvent
Public Member Functions | List of all members
ImageCapturedEvent Class Reference

This event is fired when an image is successfully captured. More...

Inheritance diagram for ImageCapturedEvent:

Public Member Functions

ImageCapturedEvent (Object sender, Image image)
final Image getImage ()

Detailed Description

This event is fired when an image is successfully captured.

This event is fired when an image is successfully captured, and returns an Image object.

Constructor & Destructor Documentation

ImageCapturedEvent | ( | Object | sender,
 |  | Image | image
 | ) |  |

Member Function Documentation

final Image getImage ( )
The documentation for this class was generated from the following file:
  • ImageCapturedEvent.java


Kofax Mobile SDK API Reference: ImageCapturedListener Interface Reference

  • kmc
  • kui
  • uicontrols
  • ImageCapturedListener
Public Member Functions | List of all members
ImageCapturedListener Interface Reference
Inheritance diagram for ImageCapturedListener:
CaptureExperience DocumentBaseCaptureExperience CheckCaptureExperience DocumentCaptureExperience FixedAspectRatioCaptureExperience PassportCaptureExperience

Public Member Functions

void onImageCaptured (ImageCapturedEvent event)
Invoked when the camera captures an image. More...

Member Function Documentation

void onImageCaptured ( ImageCapturedEvent event )

Invoked when the camera captures an image.

Implemented in CaptureExperience.

The documentation for this interface was generated from the following file:
  • ImageCapturedListener.java


Kofax Mobile SDK API Reference: ImageCaptureView Class Reference

  • kmc
  • kui
  • uicontrols
  • ImageCaptureView
Classes | Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
ImageCaptureView Class Reference
Inheritance diagram for ImageCaptureView:
BarCodeCaptureView LicenseCaptureView

Public Member Functions

ImageCaptureView (Context context)
ImageCaptureView (Context context, AttributeSet set)
ImageCaptureView (Context context, AttributeSet set, int defStyle)
final int | getImagePreviewWidth ()
final int | getImagePreviewHeight ()
ViewGroup | getViewGroup ()
final Flash | getFlash ()
final void | setFlash (Flash flash)
final boolean | isFlashSupported (Flash flash)
final GpsUsageLimits | getGpsUsage ()
final void | setGpsUsage (GpsUsageLimits limits)
final void | setCameraType (CameraType cameraType)
final void | setImageResolution (Size resolution)
final List< Size > | getAllowableImageResolutions ()
final List< Rect > | getFocusAreas ()
final void | setFocusAreas (List< Rect > focusAreas) throws KmcRuntimeException
final int | getMaxFocusAreas ()
final boolean | getUseVideoFrame ()
final void | setUseVideoFrame (boolean useVideo)
final int | getDeviceDeclinationPitch ()
final void | setDeviceDeclinationPitch (int angle)
final int | getDeviceDeclinationRoll ()
final void | setDeviceDeclinationRoll (int angle)
final int | getLuminanceThreshold ()
final void | setLuminanceThreshold (int luminanceThreshold)
final int | getTorchDelay ()
final void | setTorchDelay (int torchDelay)
final void | muteAutoTorch ()
final void | unmuteAutoTorch ()
final void | forceTakePicture ()
final void | forceTakePicture (boolean focusAgain)
final synchronized void | sessionCreate ()
final synchronized void | sessionDismiss ()
final void | addOnAutoFocusResultListener (AutoFocusResultListener listener)
final void | removeOnAutoFocusResultListener (AutoFocusResultListener listener)
final void | addOnImageCapturedListener (ImageCapturedListener listener)
final void | removeOnImageCapturedListener (ImageCapturedListener listener)
final void | addStabilityDelayListener (StabilityDelayListener listener)
final void | removeStabilityDelayListener (StabilityDelayListener listener)
final void | addLevelnessListener (LevelnessListener listener)
final void | removeLevelnessListener (LevelnessListener listener)
final void | addCameraInitializationListener (CameraInitializationListener listener)
final void | removeCameraInitializationListener (CameraInitializationListener listener)
final void | addCameraInitializationFailedListener (CameraInitializationFailedListener listener)
final void | removeCameraInitializationFailedListener (CameraInitializationFailedListener listener)
final void | addPreviewCallbackListener (PreviewCallbackListener listener)
final void | removePreviewCallbackListener (PreviewCallbackListener listener)
final void | addTorchLuminanceListener (TorchLuminanceListener listener)
final void | removeTorchLuminanceListener (TorchLuminanceListener listener)
void | removeAllViews ()
void | surfaceChanged (SurfaceHolder holder, int format, int width, int height)
void | surfaceCreated (SurfaceHolder holder)
void | surfaceDestroyed (SurfaceHolder holder)

Static Public Attributes

static final int | DEFAULT_LUMINANCE_THRESHOLD = 100
static final int | DEFAULT_TORCH_DELAY = 3

Protected Member Functions

void | checkLicense ()
void | onLayout (boolean changed, int l, int t, int r, int b)
void | onDetachedFromWindow ()
void | onAttachedToWindow ()

Protected Attributes

IBus _bus

Detailed Description

This class is responsible for rendering the camera preview.

Constructor & Destructor Documentation

ImageCaptureView ( Context context )
ImageCaptureView | ( | Context | context,
 |  | AttributeSet | set
 | ) |  |
ImageCaptureView | ( | Context | context,
 |  | AttributeSet | set,
 |  | int | defStyle
 | ) |  |

Member Function Documentation

final void addCameraInitializationFailedListener ( CameraInitializationFailedListener listener )
final void addCameraInitializationListener ( CameraInitializationListener listener )
final void addLevelnessListener ( LevelnessListener listener )
final void addOnAutoFocusResultListener ( AutoFocusResultListener listener )
final void addOnImageCapturedListener ( ImageCapturedListener listener )
final void addPreviewCallbackListener ( PreviewCallbackListener listener )
final void addStabilityDelayListener ( StabilityDelayListener listener )
final void addTorchLuminanceListener ( TorchLuminanceListener listener )
void checkLicense ( )
protected
final void forceTakePicture ( )

Description: Forces capturing an image. Calling this method will ignore other capture constraints. This is equivalent to calling forceTakePicture(false);

NOTE: Capture will not take place while an autofocus cycle is running, but will happen once it completes, whether the camera is in focus or not.

final void forceTakePicture ( boolean focusAgain )

Description: Forces capturing an image after an optional additional autofocus cycle. Calling this method will ignore other capture constraints.

NOTE: Capture will not take place while an autofocus cycle is running, but will happen once it completes, whether the camera is in focus or not.

final List<Size> getAllowableImageResolutions ( )

Returns a list of supported resolutions for image capture.

The list of resolutions returned may differ depending on the value of getUseVideoFrame()

Note: This list may be different from that returned by StreamConfigurationMap methods (Camera2 API) or Camera.Parameters methods: getSupportedPictureSizes() or getSupportedPreviewSizes()

Note: There can be resolutions returned that cannot be used if the value of getUseVideoFrame() is changed

This method should not be called until after the CameraInitializationEvent is fired.

Returns
All allowable image capture resolutions.
See also
android.hardware.Camera.getParameters().getSupportedPictureSizes()
android.hardware.Camera.getParameters().getSupportedPreviewSizes()
StreamConfigurationMap
setImageResolution(Size)
setUseVideoFrame(boolean)
getUseVideoFrame()
final int getDeviceDeclinationPitch ( )

Description: Returns the pitch angle that the Capture Control considers to be level.

Returns
An integer between -180 and 180
final int getDeviceDeclinationRoll ( )

Description: Returns the roll angle that the Capture Control considers to be level.

Returns
An integer between -180 and 180
final Flash getFlash ( )

This method should not be called until after the CameraInitializationEvent is fired.

Returns
A Flash value
See also
setFlash(Flash)
final List<Rect> getFocusAreas ( )

Gets the current focus areas

Before using this API or setFocusAreas, apps should first call getMaxFocusAreas to know the maximum number of focus areas. If the value returned is 0, focus areas is not supported.

Focus area weight is set to 1000.

This method should not be called until after the CameraInitializationEvent is fired.

Returns
The set list of FocusAreas
See also
setFocusAreas
final GpsUsageLimits getGpsUsage ( )

Defaults to GpsUsageLimits#ALWAYS_USE_IF_ENABLED.

See also
setGpsUsage(GpsUsageLimits)
final int getImagePreviewHeight ( )

Description: Returns the height of the camera preview resolution. This property is read-only, and is automatically set to the resolution that will best fit the width and height of the ImageCaptureControl.

This method should not be called until after the CameraInitializationEvent is fired.

Returns
Camera resolution height
See also
getImagePreviewHeight()
final int getImagePreviewWidth ( )

Description: Returns the width of the camera preview resolution. This property is read-only, and is automatically set to the resolution that will best fit the width and height of the ImageCaptureControl.

This method should not be called until after the CameraInitializationEvent is fired.

Returns
Camera resolution width
See also
getImagePreviewWidth()
final int getLuminanceThreshold ( )

Returns the luminance level at which the torch activates when Flash is set to AUTOTORCH. Luminance level is a measure of the brightness of the color in the image. When the detected luminance level falls below this threshold property, the torch may be activated, depending on the torch delay property. The default value of this property is 100.

Android only.

Returns
The current luminance threshold
See also
setLuminanceThreshold(int)
getTorchDelay()
setTorchDelay(int)
final int getMaxFocusAreas ( )

Returns the device's maximum number of focusable areas.

This method should not be called until after the CameraInitializationEvent is fired.

Returns
The maximum number of supported focus areas, or 0 if unsupported
See also
setFocusAreas(List<Rect>)
getFocusAreas()
final int getTorchDelay ( )

Returns the delay that controls when the torch activates when Flash is set to AUTOTORCH. This delay specifies the number of consecutive times the detected luminance must be below the configured threshold before activating the torch. The default value of this property is 3.

Android only.

Returns
The current torch delay
See also
setTorchDelay(int)
getLuminanceThreshold()
setLuminanceThreshold(int)
final boolean getUseVideoFrame ( )

Whether the control is using the video frame as the captured image

See also
setUseVideoFrame
ViewGroup getViewGroup ( )
final boolean isFlashSupported ( Flash flash )
final void muteAutoTorch ( )

When Flash is set to AUTOTORCH, the app can temporarily prevent the torch from lighting by calling this method. This might be necessary if you are attempting to capture a laminated document and activating the torch creates glare. This method can also be called when the torch is lit (via AUTOTORCH) to turn torch off and prevent it from lighting again.

Android only.

See also
unmuteAutoTorch()
void onAttachedToWindow ( )
protected
void onDetachedFromWindow ( )
protected
void onLayout | ( | boolean | changed,
 |  | int | l,
 |  | int | t,
 |  | int | r,
 |  | int | b
 | ) |  |
protected

Layout our children

void removeAllViews ( )
final void removeCameraInitializationFailedListener ( CameraInitializationFailedListener listener )
final void removeCameraInitializationListener ( CameraInitializationListener listener )
final void removeLevelnessListener ( LevelnessListener listener )
final void removeOnAutoFocusResultListener ( AutoFocusResultListener listener )
final void removeOnImageCapturedListener ( ImageCapturedListener listener )
final void removePreviewCallbackListener ( PreviewCallbackListener listener )
final void removeStabilityDelayListener ( StabilityDelayListener listener )
final void removeTorchLuminanceListener ( TorchLuminanceListener listener )
final synchronized void sessionCreate ( )
final synchronized void sessionDismiss ( )
final void setCameraType ( CameraType cameraType )

Sets the desire camera type for image capture view. The default cameraType will be BACK_CAMERA.

Parameters
cameraType the camera type.
See also
CameraType
final void setDeviceDeclinationPitch ( int angle )

Description: Sets the pitch declination of the device, which affects how far it must be tilted along the y axis of the phone in order to be considered level. By default, this is set to 0, which is considered to be the levelness of a device laying flat on its back and facing upwards.

Parameters
angle An integer value between -180 and 180.
final void setDeviceDeclinationRoll ( int angle )

Description: Sets the roll declination of the device, which affects how far it must be tilted along the x axis of the phone in order to be considered level. By default, this is set to 0, which is considered to be the levelness of a device laying flat on its back and facing upwards.

Parameters
angle An integer value between -180 and 180.
final void setFlash ( Flash flash )

This method will attempt to set the camera flash mode to the mode specified. It polls the camera for the flash modes the hardware allows; if the flash parameter given is not included in the supported flash modes, this method will throw an exception.

This method must not be called until after the CameraInitializationEvent is fired. An IllegalStateException is thrown if this method is called when the camera is not open.

Parameters
flash A Flash enum that corresponds to various flash modes
See also
getFlash()
final void setFocusAreas ( List< Rect > focusAreas ) throws KmcRuntimeException

Sets the focus areas for the control.

Before using this API or getFocusAreas, apps should first call getMaxFocusAreas to know the maximum number of focus areas. If the value returned is 0, focus areas is not supported.

Image capture focus area bounds have valid values (0,0) to a maximum of (viewWidth, viewHeight) which are then translated to valid Android focus area coordinates.

When a focus area is set that has bounds outside of the view bounds the focus area rectangle will be clamped to the nearest valid view bound.

The width and height of focus areas cannot be 0 or negative. Any Rect in the list passed in must follow the left < right, and top < bottom rule or a KmcRuntimeException will be thrown as this is an invalid focus area Rect.

A Rect in the list will also need to have a sufficient area to provide the underlying camera autofocus algorithm enough information to focus on that area. Creating a Rect that has width and height that is between 5-10% of the width and height of the preview view size is recommended. When the Rect area is too small it is likely, but this is highly device dependent, that the camera will use the entire view as the focus area.

This method should not be called until after the CameraInitializationEvent is fired.

Parameters
focusAreas A list of Rect objects representing the desired focus areas
Exceptions
KmcRuntimeException If invalid Rect
See also
getFocusAreas
final void setGpsUsage ( GpsUsageLimits limits )

Description: Calling this with a value of GpsUsageLimits#ALWAYS_USE_IF_ENABLED will cause the control to embed GPS coordinates in the captured image if Location Services are enabled. A value of GpsUsageLimits#NEVER_USE will prevent the inclusion of GPS coordinates in captured images, regardless of the availability of Location Services.

Defaults to GpsUsageLimits#ALWAYS_USE_IF_ENABLED.

See also
getGpsUsage()
final void setImageResolution ( Size resolution )

Sets the desired resolution for image capture. The actual resolution of a captured image may be reversed from what is given (e.g. a 960x1280 image may be returned for a 1280x960 request).

The resolution parameter must be one of the given resolutions returned from getAllowableImageResolutions()

After calling this method, the ImageCaptureView instance may resize itself.

This method should not be called until after the CameraInitializationEvent is fired.

Parameters
resolution a Size, one of those returned by getAllowableImageResolutions()
See also
getAllowableImageResolutions()
setUseVideoFrame(boolean)
final void setLuminanceThreshold ( int luminanceThreshold )

This method sets the luminance level (> 0) at which the torch activates when Flash is set to AUTOTORCH. Luminance level is a measure of the brightness of the color in the image. When the detected luminance level falls below this threshold property, the torch may be activated, depending on the torch delay property. The default value of this property is 100.

Android only.

Parameters
luminanceThreshold An integer that specifies the luminance threshold
See also
getLuminanceThreshold()
getTorchDelay()
setTorchDelay(int)
final void setTorchDelay ( int torchDelay )

This method sets the delay (> 0) that controls when the torch activates when Flash is set to AUTOTORCH. This delay specifies the number of consecutive times the detected luminance must be below the configured threshold before activating the torch. The default value of this property is 3.

Android only.

Parameters
torchDelay An integer that specifies the delay
See also
getTorchDelay()
getLuminanceThreshold()
setLuminanceThreshold(int)
final void setUseVideoFrame ( boolean useVideo )

Description: Calling this with a value of true will cause the control to return the video frame when takePicture() is called, or when requirements are met. The video frame will normally be of lower resolution and may not be appropriate for image processing.

Defaults to false.

Parameters
useVideo whether to use preview frames for capture or not
See also
getUseVideoFrame()
void surfaceChanged | ( | SurfaceHolder | holder,
 |  | int | format,
 |  | int | width,
 |  | int | height
 | ) |  |
void surfaceCreated ( SurfaceHolder holder )
void surfaceDestroyed ( SurfaceHolder holder )
final void unmuteAutoTorch ( )

When Flash is set to AUTOTORCH, the app can temporarily prevent the torch from lighting by calling muteAutoTorch(). Call this method to revert the auto torch functionality to configured behavior.

Android only.

See also
muteAutoTorch()

Member Data Documentation

IBus _bus
protected
final int DEFAULT_LUMINANCE_THRESHOLD = 100
static
final int DEFAULT_TORCH_DELAY = 3
static
The documentation for this class was generated from the following file:
  • ImageCaptureView.java


Kofax Mobile SDK API Reference: ImgReviewEditCntrl Class Reference

  • kmc
  • kui
  • uicontrols
  • ImgReviewEditCntrl
Classes | Public Member Functions | Public Attributes | Protected Member Functions | List of all members
ImgReviewEditCntrl Class Reference
Inheritance diagram for ImgReviewEditCntrl:

Classes

enum Line_Style_Solid
An enum which lists the drawing style options the edge of the tetragon. More...

Public Member Functions

void | setImage (Image i) throws KmcException
Image getImage ()
Image that is to be reviewed and/or edited. More...
void | showCropRectangle (boolean isVisible)
Displays cropping rectangle with draggable corner indicators. More...
int | getCropLineColor ()
The ARGB line color of the bounding rect/tetragon. More...
void | setCropLineColor (int lColor)
The ARGB line color of the bounding rect/tetragon. More...
int | getCropCornerColor ()
The ARGB corner color of the bounding rect/tetragon. More...
void | setCropCornerColor (int cColor)
The ARGB corner color of the bounding rect/tetragon. More...
void | setCropLineStyle (Line_Style_Solid myStyle)
The line style of the bounding rect/tetragon sides. More...
void | setCropTetragon (BoundingTetragon bt)
Contains coordinates of all four tetragon corners. May or may not be a rectangle. More...
void | showHighlights (BoundingRect[] rectArr)
void | clearHighlights ()
void | setHighlightColor (int color)
Returns the coordinates of all four tetragon corners. May or may not be a rectangle. More...
BoundingTetragon getCropTetragon ()
void | setRetainImage (boolean retainImage)
boolean | getRetainImage ()
void | setImageCacheType (ImageCacheType imageCacheType)
ImgReviewEditCntrl (Context context)
ImgReviewEditCntrl (Context context, AttributeSet attrs)
ImgReviewEditCntrl (Context context, AttributeSet attrs, int defStyle)
boolean | onTouch (View v, MotionEvent event)
Parcelable | onSaveInstanceState ()
void | onRestoreInstanceState (Parcelable state)
void | clearImage ()

Public Attributes

ScaleGestureDetector scaleGestureDetector

Protected Member Functions

void | onDraw (Canvas canvas)
void | onSizeChanged (int w, int h, int oldw, int oldh)

Detailed Description

This is the view which is presented to the user when either a picture is taken or chosen photo from the photo gallery. When the image processor is done processing either via quick analysis or direct processing the output image can be viewed in the control.

Constructor & Destructor Documentation

ImgReviewEditCntrl ( Context context )
ImgReviewEditCntrl | ( | Context | context,
 |  | AttributeSet | attrs
 | ) |  |
ImgReviewEditCntrl | ( | Context | context,
 |  | AttributeSet | attrs,
 |  | int | defStyle
 | ) |  |

Member Function Documentation

void clearHighlights ( )

Function to clear highlights from the widget.

void clearImage ( )

Removes the bitmap from the control.

int getCropCornerColor ( )

The ARGB corner color of the bounding rect/tetragon.

The ARGB corner color of the bounding rect/tetragon. Range = 0x00000000 0xFFFFFFFF

Returns
- tetragon corner color
int getCropLineColor ( )

The ARGB line color of the bounding rect/tetragon.

The ARGB line color of the bounding rect/tetragon. Range = 0x00000000 0xFFFFFFFF

Returns
color of the edge of the tetragon
BoundingTetragon getCropTetragon ( )

Returns a BoundingTetragon object which has four points, each point corresponds to a corner of the tetragon. The tetragon consists of the integer coordinates of its top-left, top-right, bottom-left, and bottom-right edges.

Returns
- tetragon that defines the corners of the cropped image or image
Image getImage ( )

Image that is to be reviewed and/or edited.

The image scale and size is the same as the original image The image internally is downsized for viewing purposes only

Returns
image object
boolean getRetainImage ( )
Returns
Whether or not the image shown is retained across re-creation. False by default.
void onDraw ( Canvas canvas )
protected
void onRestoreInstanceState ( Parcelable state )
Parcelable onSaveInstanceState ( )
void onSizeChanged | ( | int | w,
 |  | int | h,
 |  | int | oldw,
 |  | int | oldh
 | ) |  |
protected
boolean onTouch | ( | View | v,
 |  | MotionEvent | event
 | ) |  |
void setCropCornerColor ( int cColor )

The ARGB corner color of the bounding rect/tetragon.

The ARGB corner color of the bounding rect/tetragon. Range = 0x00000000 0xFFFFFFFF

Parameters
cColor - color for the corner of the rectangle, default is blue
void setCropLineColor ( int lColor )

The ARGB line color of the bounding rect/tetragon.

The ARGB line color of the bounding rect/tetragon. Range = 0x00000000 0xFFFFFFFF

void setCropLineStyle ( Line_Style_Solid myStyle )

The line style of the bounding rect/tetragon sides.

The line style of the bounding rect/tetragon sides.

Parameters
myStyle - This crop rectangle lines should be solid or dashed
void setCropTetragon ( BoundingTetragon bt )

Contains coordinates of all four tetragon corners. May or may not be a rectangle.

Contains coordinates of all four tetragon corners. May or may not be a rectangle. The tetragon consists of the integer coordinates of its top-left, top-right, bottom-left, and bottom-right edges.

Parameters
bt - bounding tetragon
void setHighlightColor ( int color )

Returns the coordinates of all four tetragon corners. May or may not be a rectangle.

Sets user defined color for the highlights. Default color is Yellow.

Parameters
color
void setImage ( Image i ) throws KmcException

If the size of the image is rather large and there isn't enough memory then we throw an exception asking the user to reduce the scaling factor further. If the user does not set a scaling factor the sdk will automatically down scale the image by 0.5 for viewing purposes. The original scale of the image will be maintained in the image object.

Parameters
i - image object
Exceptions
KmcException
KmcRuntimeException(ErrorInfo.KMC_UT_LICENSE_IMAGE_CAPTURE)
Note
This is an application responsibility to clear Image instance.
void setImageCacheType ( ImageCacheType imageCacheType )

Controls which type of cache will be used to store images that are retained across re-creation (such as from a configuration change). This will not affect any ImgReviewEditCntrl which has set retainImage to false.

Parameters
imageCacheType - ImageCacheType
See also
setRetainImage(boolean)

The default value is ImageCacheType::MEMORY

void setRetainImage ( boolean retainImage )

Control whether the image shown is retained across re-creation (such as from a configuration change). If set, the image data will be cached during onSaveInstanceState(). The image is restored during onRestoreInstanceState(Parcelable).

The default value is true.

Parameters
retainImage - boolean
void showCropRectangle ( boolean isVisible )

Displays cropping rectangle with draggable corner indicators.

Displays cropping rectangle with draggable corner indicators. Corners can be repositioned independently, creating a tetragon. Individual sides can be dragged to resize the rectangle and maintain the rectangular shape.

Parameters
isVisible - boolean
void showHighlights ( BoundingRect[] rectArr )

Function to show highlights on the widget.

Parameters
rectArr - Array of BoundingRect containing screen coordinates of the highlight rectangles to be drawn.

Member Data Documentation

ScaleGestureDetector scaleGestureDetector
The documentation for this class was generated from the following file:
  • ImgReviewEditCntrl.java


Kofax Mobile SDK API Reference: ImgReviewEditCntrl.Line_Style_Solid Enum Reference

  • kmc
  • kui
  • uicontrols
  • ImgReviewEditCntrl
  • Line_Style_Solid
Public Attributes | List of all members
ImgReviewEditCntrl.Line_Style_Solid Enum Reference

An enum which lists the drawing style options the edge of the tetragon. More...

Public Attributes

LINE_STYLE_SOLID
LINE_STYLE_DOTTED

Detailed Description

An enum which lists the drawing style options the edge of the tetragon.

The line style of the bounding rect/tetragon. Can be either solid line, or dotted line.

Member Data Documentation

LINE_STYLE_DOTTED
LINE_STYLE_SOLID
The documentation for this enum was generated from the following file:
  • ImgReviewEditCntrl.java


Kofax Mobile SDK API Reference: KUILogging Class Reference

  • kmc
  • kui
  • uicontrols
  • KUILogging
Static Public Member Functions | List of all members
KUILogging Class Reference

Static Public Member Functions

static void enableConsoleLogging (boolean enable)

Detailed Description

Enable or disable console logging for KUI package classes.

See also
Logging

Member Function Documentation

static void enableConsoleLogging ( boolean enable )
static

Enables Kui package console logging. Pass true to turn on library logging, and false otherwise. Disabled by default.

Parameters
enable
The documentation for this class was generated from the following file:
  • KUILogging.java


Kofax Mobile SDK API Reference: LevelnessEvent Class Reference

  • kmc
  • kui
  • uicontrols
  • LevelnessEvent
Public Member Functions | List of all members
LevelnessEvent Class Reference

This event fires when the orientation of the device changes. More...

Inheritance diagram for LevelnessEvent:

Public Member Functions

LevelnessEvent (Object source, int pitch, int roll)
int | getPitch ()
Returns in degrees the current pitch of the phone. More...
int | getRoll ()
Returns in degrees the current roll of the phone. More...

Detailed Description

This event fires when the orientation of the device changes.

This event fires when the orientation of the device changes. It contains two properties, pitch and roll, which represent the orientation of the phone along the y-axis and x-axis respectively. These properties are returned in degrees.

Constructor & Destructor Documentation

LevelnessEvent | ( | Object | source,
 |  | int | pitch,
 |  | int | roll
 | ) |  |

Member Function Documentation

int getPitch ( )

Returns in degrees the current pitch of the phone.

int getRoll ( )

Returns in degrees the current roll of the phone.

The documentation for this class was generated from the following file:
  • LevelnessEvent.java


Kofax Mobile SDK API Reference: LevelnessListener Interface Reference

  • kmc
  • kui
  • uicontrols
  • LevelnessListener
Public Member Functions | List of all members
LevelnessListener Interface Reference

The interface that is required to implement StabilityDelayEvent. More...

Inheritance diagram for LevelnessListener:
CaptureExperience DocumentBaseCaptureExperience CheckCaptureExperience DocumentCaptureExperience FixedAspectRatioCaptureExperience PassportCaptureExperience

Public Member Functions

void onLevelness (LevelnessEvent event)
Invoked when the orientation of the device changes. More...

Detailed Description

The interface that is required to implement StabilityDelayEvent.

Member Function Documentation

void onLevelness ( LevelnessEvent event )

Invoked when the orientation of the device changes.

Implemented in CaptureExperience.

The documentation for this interface was generated from the following file:
  • LevelnessListener.java


Kofax Mobile SDK API Reference: LicenseCaptureView Class Reference

  • kmc
  • kui
  • uicontrols
  • LicenseCaptureView
Public Member Functions | Protected Member Functions | List of all members
LicenseCaptureView Class Reference
Inheritance diagram for LicenseCaptureView:
ImageCaptureView

Public Member Functions

LicenseCaptureView (Context context)
LicenseCaptureView (Context context, AttributeSet set)
LicenseCaptureView (Context context, AttributeSet set, int defStyle)
void | addLicenseFoundEventListener (LicenseFoundListener listener)
void | removeLicenseFoundEventListener (LicenseFoundListener listener)
double | getViewfinderPaddingPercent ()
void | setViewfinderPaddingPercent (double paddingPercent)
int | getOuterViewFinderColor ()
void | setOuterViewFinderColor (int colorCode)
CaptureMessage getUserInstructionMessage ()
void | setUserInstructionMessage (CaptureMessage userInstructionsMessage)
void | readLicense ()
void | onPreviewFrame (PreviewImageReadyBusEvent evt)
- Public Member Functions inherited from ImageCaptureView
ImageCaptureView (Context context)
ImageCaptureView (Context context, AttributeSet set)
ImageCaptureView (Context context, AttributeSet set, int defStyle)
final int | getImagePreviewWidth ()
final int | getImagePreviewHeight ()
ViewGroup | getViewGroup ()
final Flash | getFlash ()
final void | setFlash (Flash flash)
final boolean | isFlashSupported (Flash flash)
final GpsUsageLimits | getGpsUsage ()
final void | setGpsUsage (GpsUsageLimits limits)
final void | setCameraType (CameraType cameraType)
final void | setImageResolution (Size resolution)
final List< Size > | getAllowableImageResolutions ()
final List< Rect > | getFocusAreas ()
final void | setFocusAreas (List< Rect > focusAreas) throws KmcRuntimeException
final int | getMaxFocusAreas ()
final boolean | getUseVideoFrame ()
final void | setUseVideoFrame (boolean useVideo)
final int | getDeviceDeclinationPitch ()
final void | setDeviceDeclinationPitch (int angle)
final int | getDeviceDeclinationRoll ()
final void | setDeviceDeclinationRoll (int angle)
final int | getLuminanceThreshold ()
final void | setLuminanceThreshold (int luminanceThreshold)
final int | getTorchDelay ()
final void | setTorchDelay (int torchDelay)
final void | muteAutoTorch ()
final void | unmuteAutoTorch ()
final void | forceTakePicture ()
final void | forceTakePicture (boolean focusAgain)
final synchronized void | sessionCreate ()
final synchronized void | sessionDismiss ()
final void | addOnAutoFocusResultListener (AutoFocusResultListener listener)
final void | removeOnAutoFocusResultListener (AutoFocusResultListener listener)
final void | addOnImageCapturedListener (ImageCapturedListener listener)
final void | removeOnImageCapturedListener (ImageCapturedListener listener)
final void | addStabilityDelayListener (StabilityDelayListener listener)
final void | removeStabilityDelayListener (StabilityDelayListener listener)
final void | addLevelnessListener (LevelnessListener listener)
final void | removeLevelnessListener (LevelnessListener listener)
final void | addCameraInitializationListener (CameraInitializationListener listener)
final void | removeCameraInitializationListener (CameraInitializationListener listener)
final void | addCameraInitializationFailedListener (CameraInitializationFailedListener listener)
final void | removeCameraInitializationFailedListener (CameraInitializationFailedListener listener)
final void | addPreviewCallbackListener (PreviewCallbackListener listener)
final void | removePreviewCallbackListener (PreviewCallbackListener listener)
final void | addTorchLuminanceListener (TorchLuminanceListener listener)
final void | removeTorchLuminanceListener (TorchLuminanceListener listener)
void | removeAllViews ()
void | surfaceChanged (SurfaceHolder holder, int format, int width, int height)
void | surfaceCreated (SurfaceHolder holder)
void | surfaceDestroyed (SurfaceHolder holder)

Protected Member Functions

void | checkLicense ()
- Protected Member Functions inherited from ImageCaptureView
void | checkLicense ()
void | onLayout (boolean changed, int l, int t, int r, int b)
void | onDetachedFromWindow ()
void | onAttachedToWindow ()

Additional Inherited Members

- Static Public Attributes inherited from ImageCaptureView
static final int | DEFAULT_LUMINANCE_THRESHOLD = 100
static final int | DEFAULT_TORCH_DELAY = 3
- Protected Attributes inherited from ImageCaptureView
IBus | _bus

Detailed Description

This view provides a capture experience optimized for SDK license capture in QR code format. The view provides visual guidance to the end-user to maximize the chances of correctly decoding an SDK license. Once the view has been asked to read an SDK license, it will search continuously until one is found.

Constructor & Destructor Documentation

LicenseCaptureView ( Context context )
LicenseCaptureView | ( | Context | context,
 |  | AttributeSet | set
 | ) |  |
LicenseCaptureView | ( | Context | context,
 |  | AttributeSet | set,
 |  | int | defStyle
 | ) |  |

Member Function Documentation

void addLicenseFoundEventListener ( LicenseFoundListener listener )

Adds the specified SDK license search listener to receive license found events from this view.

void checkLicense ( )
protected
int getOuterViewFinderColor ( )

Returns the color used for the outer view finder background.

Returns
The color used for the outer view finder background
CaptureMessage getUserInstructionMessage ( )

Returns the attributes of the instruction message that is displayed on the capture control while the user is trying to capture. This message will be displayed during periods where other guidance is not available to correct a user. This may happen in particular when the user is holding a device too far away from a document, preventing detection.

The following CaptureMessage property methods are not supported for this message: getMessageIcons() / setMessageIcons(Bitmap[]).

Default configuration:

  • message: "Fill viewable area with license in QR Code format"
  • text color: white
  • background color: transparent
  • background drawable: not specified
  • text size: 18
  • typeface: not specified
  • orientation: CaptureMessage.KUIMessageOrientation#PORTRAIT
  • width and height: not specified
  • position: center
  • visibility: true
Returns
CaptureMessage
See also
CaptureMessage
double getViewfinderPaddingPercent ( )

Returns padding percent required between the viewfinder and camera preview frame.

Returns
A double in the range [0-50].
void onPreviewFrame ( PreviewImageReadyBusEvent evt )
void readLicense ( )

This call returns immediately and starts asynchronously searching for an SDK license. The search will continue indefinitely until an SDK license is found. Once an SDK license is positively read, the LicenseFoundEvent is raised. If license string is valid it will be set into SDK for licensing.

void removeLicenseFoundEventListener ( LicenseFoundListener listener )

Removes the specified SDK license search listener from this view.

void setOuterViewFinderColor ( int colorCode )

Specifies the color that will be used for the outer view finder background. The default color is translucent grey.

void setUserInstructionMessage ( CaptureMessage userInstructionsMessage )

A property to configure the attributes of the instruction message that is displayed on the capture control while the user is trying to capture.

Parameters
userInstructionsMessage : CaptureMessage
See also
getUserInstructionMessage()
CaptureMessage
void setViewfinderPaddingPercent ( double paddingPercent )

This value determines how much percentage the viewfinder needs to be positioned inside the camera preview frame. Valid values are [0-50]. Default Value is 10.

Parameters
paddingPercent double in the range [0-50].
The documentation for this class was generated from the following file:
  • LicenseCaptureView.java


Kofax Mobile SDK API Reference: LicenseFoundEvent Class Reference

  • kmc
  • kui
  • uicontrols
  • LicenseFoundEvent
Public Member Functions | List of all members
LicenseFoundEvent Class Reference

An event that indicates that a license was found. More...

Inheritance diagram for LicenseFoundEvent:

Public Member Functions

LicenseFoundEvent (Object sender, ErrorInfo errorInfo, int daysRemaining, String licenseString)
ErrorInfo getErrorInfo ()
Retrieve the error info. More...
int | getDaysRemaining ()
Retrieve the number of days remaining in the found license. More...
String | getLicenseString ()
Retrieve the license string. More...

Detailed Description

An event that indicates that a license was found.

This will only be sent after the invoking readLicense for LicenseCaptureView. Once the license was found, the license string will be used for SDK licensing.

Constructor & Destructor Documentation

LicenseFoundEvent | ( | Object | sender,
 |  | ErrorInfo | errorInfo,
 |  | int | daysRemaining,
 |  | String | licenseString
 | ) |  |

Member Function Documentation

int getDaysRemaining ( )

Retrieve the number of days remaining in the found license.

Returns
The number of days remaining in the found license.
ErrorInfo getErrorInfo ( )

Retrieve the error info.

Returns
The error info.
Return values
KMC_SUCCESS | if license is valid and was setup correctly.
KMC_EV_LICENSING | if the string is invalid for setting a license.
KMC_EV_LICENSE_EXPIRED | if the time limit of your license has expired.
String getLicenseString ( )

Retrieve the license string.

Returns
The license string if getErrorInfo() returns KMC_SUCCESS, or null otherwise.
The documentation for this class was generated from the following file:
  • LicenseFoundEvent.java


Kofax Mobile SDK API Reference: LicenseFoundListener Interface Reference

  • kmc
  • kui
  • uicontrols
  • LicenseFoundListener
Public Member Functions | List of all members
LicenseFoundListener Interface Reference

The listener interface for receiving license found events. More...

Public Member Functions

void licenseFound (LicenseFoundEvent event)
Invoked when a license is found. More...

Detailed Description

The listener interface for receiving license found events.

A class that is interested in processing license found events should implement this interface, and then register itself with a LicenseCaptureView using the view's addLicenseFoundEventListener method.

See also
LicenseCaptureView
LicenseCaptureView::addLicenseFoundEventListener
LicenseCaptureView::removeLicenseFoundEventListener

Member Function Documentation

void licenseFound ( LicenseFoundEvent event )

Invoked when a license is found.

The documentation for this interface was generated from the following file:
  • LicenseFoundListener.java


Kofax Mobile SDK API Reference: PageDetectionEvent Class Reference

  • kmc
  • kui
  • uicontrols
  • PageDetectionEvent
Classes | Public Member Functions | List of all members
PageDetectionEvent Class Reference

An event that indicates a page was detected in the camera preview. More...

Inheritance diagram for PageDetectionEvent:

Public Member Functions

PageDetectionEvent (Object sender, Bitmap bitmap, BoundingTetragon bounds)
final Bitmap | getPreviewImage ()
Gets the preview image that the page was detected in. More...
final BoundingTetragon | getBound ()
Gets the bounding coordinates of the detected page. More...

Detailed Description

An event that indicates a page was detected in the camera preview.

This event is raised in response to a page being detected in the camera preview, if page detection is enabled. The event includes the preview image that was processed by page detection, and the bounding coordinates of the detected page.

See also
PageDetectionListener
DocumentBaseCaptureExperience::addPageDetectionListener

Constructor & Destructor Documentation

PageDetectionEvent | ( | Object | sender,
 |  | Bitmap | bitmap,
 |  | BoundingTetragon | bounds
 | ) |  |

Member Function Documentation

final BoundingTetragon getBound ( )

Gets the bounding coordinates of the detected page.

final Bitmap getPreviewImage ( )

Gets the preview image that the page was detected in.

The documentation for this class was generated from the following file:
  • PageDetectionEvent.java


Kofax Mobile SDK API Reference: PageDetectionListener Interface Reference

  • kmc
  • kui
  • uicontrols
  • PageDetectionListener
Public Member Functions | List of all members
PageDetectionListener Interface Reference

Public Member Functions

void pageDetected (PageDetectionEvent event)
Invoked when a page is detected in the camera preview. More...

Detailed Description

A class that is interested in processing page detection events should implement this interface, and then register itself with an DocumentBaseCaptureExperience#addPageDetectionListener(PageDetectionListener).

Member Function Documentation

void pageDetected ( PageDetectionEvent event )

Invoked when a page is detected in the camera preview.

The documentation for this interface was generated from the following file:
  • PageDetectionListener.java


Kofax Mobile SDK API Reference: PreviewCallbackListener Interface Reference

  • kmc
  • kui
  • uicontrols
  • PreviewCallbackListener
Public Member Functions | List of all members
PreviewCallbackListener Interface Reference

Public Member Functions

void onPreviewFrame (PreviewFrameEvent event)

Detailed Description

The interface that is required to implement PreviewFrameEvent.

Member Function Documentation

void onPreviewFrame ( PreviewFrameEvent event )
The documentation for this interface was generated from the following file:
  • PreviewCallbackListener.java


Kofax Mobile SDK API Reference: PreviewFrameEvent Class Reference

  • kmc
  • kui
  • uicontrols
  • PreviewFrameEvent
Public Member Functions | List of all members
PreviewFrameEvent Class Reference
Inheritance diagram for PreviewFrameEvent:

Public Member Functions

PreviewFrameEvent (Object sender, RealtimeVideoEvent evt)
Bitmap | getBitmap ()
Bitmap | getBitmap (boolean rotated)
Bitmap | getBitmapLandscape ()
int | getRotationLandscape ()
int | getRotation ()
byte[] | getData ()
int | getWidth ()
int | getHeight ()

Detailed Description

An event that indicates a preview frame is available from the camera.

The event includes the image data sent from the image sensor. A bitmap may be retrieved from this event by calling getBitmap().

This event is raised on a thread separate from the main UI thread. While this event it outstanding, no further PreviewFrameEvents will be raised.

See also
ImageCaptureView::addPreviewCallbackListener
ImageCaptureView::removePreviewCallbackListener

Constructor & Destructor Documentation

PreviewFrameEvent | ( | Object | sender,
 |  | RealtimeVideoEvent | evt
 | ) |  |

Member Function Documentation

Bitmap getBitmap ( )

Lazily loads the image data into a bitmap

Returns
properly oriented image data as a bitmap
Bitmap getBitmap ( boolean rotated )
Bitmap getBitmapLandscape ( )
byte [] getData ( )
int getHeight ( )
int getRotation ( )
int getRotationLandscape ( )
int getWidth ( )
The documentation for this class was generated from the following file:
  • PreviewFrameEvent.java


Kofax Mobile SDK API Reference: StabilityDelayEvent Class Reference

  • kmc
  • kui
  • uicontrols
  • StabilityDelayEvent
Public Member Functions | List of all members
StabilityDelayEvent Class Reference

This event fires when stability levels change. More...

Inheritance diagram for StabilityDelayEvent:

Public Member Functions

StabilityDelayEvent (Object source, int stability)
int getStability ()

Detailed Description

This event fires when stability levels change.

This event fires when stability levels change. It returns an int from 0 to 100 to indicate the current level of stability, 100 being completely stable and 0 being completely unstable. This event fires in response to accelerometer changes.

Constructor & Destructor Documentation

StabilityDelayEvent | ( | Object | source,
 |  | int | stability
 | ) |  |

Member Function Documentation

int getStability ( )
The documentation for this class was generated from the following file:
  • StabilityDelayEvent.java


Kofax Mobile SDK API Reference: StabilityDelayListener Interface Reference

  • kmc
  • kui
  • uicontrols
  • StabilityDelayListener
Public Member Functions | List of all members
StabilityDelayListener Interface Reference

The interface that is required to implement StabilityDelayEvent. More...

Inheritance diagram for StabilityDelayListener:
CaptureExperience DocumentBaseCaptureExperience CheckCaptureExperience DocumentCaptureExperience FixedAspectRatioCaptureExperience PassportCaptureExperience

Public Member Functions

void onStabilityDelay (StabilityDelayEvent event)
Invoked when stability levels change. More...

Detailed Description

The interface that is required to implement StabilityDelayEvent.

Member Function Documentation

void onStabilityDelay ( StabilityDelayEvent event )

Invoked when stability levels change.

Implemented in CaptureExperience.

The documentation for this interface was generated from the following file:
  • StabilityDelayListener.java


Kofax Mobile SDK API Reference: TorchLuminanceEvent Class Reference

  • kmc
  • kui
  • uicontrols
  • TorchLuminanceEvent
Public Member Functions | List of all members
TorchLuminanceEvent Class Reference

This event fires when torch luminance level changes. More...

Inheritance diagram for TorchLuminanceEvent:

Public Member Functions

TorchLuminanceEvent (Object sender, int luminance, boolean belowThreshold, boolean torchOn)
final int | getLuminance ()
final boolean | isBelowThreshold ()
final boolean | isTorchOn ()

Detailed Description

This event fires when torch luminance level changes.

It reports the torch luminance level, a flag indicating if the level has fallen below the threshold, and a flag indicating that torch has turned on (if AUTOTORCH was set).

Constructor & Destructor Documentation

TorchLuminanceEvent | ( | Object | sender,
 |  | int | luminance,
 |  | boolean | belowThreshold,
 |  | boolean | torchOn
 | ) |  |

Member Function Documentation

final int getLuminance ( )
final boolean isBelowThreshold ( )
final boolean isTorchOn ( )
The documentation for this class was generated from the following file:
  • TorchLuminanceEvent.java


Kofax Mobile SDK API Reference: TorchLuminanceListener Interface Reference

  • kmc
  • kui
  • uicontrols
  • TorchLuminanceListener
Public Member Functions | List of all members
TorchLuminanceListener Interface Reference

The interface that is required to implement TorchLuminanceEvent. More...

Public Member Functions

void onTorchLuminance (TorchLuminanceEvent event)

Detailed Description

The interface that is required to implement TorchLuminanceEvent.

Member Function Documentation

void onTorchLuminance ( TorchLuminanceEvent event )
The documentation for this interface was generated from the following file:
  • TorchLuminanceListener.java


Kofax Mobile SDK API Reference: AppStatistics Class Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatistics
Classes | Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
AppStatistics Class Reference

Use the AppStatistics class for creating, saving, and exporting statistics related to SDK framework usage. More...

Classes

enum | AppStatsExportFormat
Indicates the export format desired when calling the export method. More...
enum | ExportStatusEvent
enum | ThresholdType

Public Member Functions

int | getRamSizeThreshold ()
void | setRamSizeThreshold (int ramSizeThreshold)
int | getFileSizeThreshold ()
void | setFileSizeThreshold (int fileSizeThreshold)
long | getRamSize ()
Current size of available RAM. More...
long | getFileSize () throws FileNotFoundException
String | getFileName ()
Returns the filename of the datastore where AppStats events are written. More...
String | getDeviceId ()
Returns the current DeviceID which is recorded as a field in the Environment table. More...
void | setDeviceId (String userDeviceID)
Sets the current DeviceID which is recorded as a field in the Environment table. More...
ListenerCallbackThreadType getListenerCallbackThreadType ()
Get the ListenerCallbackThreadType. More...
void | setListenerCallbackThreadType (ListenerCallbackThreadType listenerCallbackThreadType)
Set the ListenerCallbackThreadType. More...
final synchronized void | initAppStats (String name)
Initialize AppStats with database file name. More...
synchronized ErrorInfo | startRecord ()
Start recording app statistics, or continues recording. More...
synchronized ErrorInfo | stopRecord ()
Stop recording data while retaining data that has been collected. More...
synchronized ErrorInfo | writeToFile ()
Writes the in-memory statistics buffer to the AppStats database. More...
void | registerExportHandler (AppStatsDsExportHandler handler)
The export method creates a SQL dump or other file format of the internal data store. More...
synchronized ErrorInfo | export (String exportFilePath, AppStatsExportFormat format)
The export method creates a SQL dump or other file of the internal data store. More...
synchronized ErrorInfo | purge ()
The purge method erases the AppStats memory buffer and the AppStats recording database file. More...
boolean | isRecording ()
Returns the status, isRecording is set to true when startRecording is. More...
synchronized void | beginSession (String sessionKey, String category)
This method tells appStats to start a "session". More...
synchronized void | logSessionEvent (AppStatsSessionEvent sessionEvent)
This method allows the application a means of recording an application-defined Session event. More...
synchronized void | endSession (boolean success, String description)
This method tells appStats to end a "session". More...
void | addAppStatsWriteFileListener (AppStatsWriteFileListener listener)
Registers an event listener for the writeToFile method. More...
void | addAppStatsExportListener (AppStatsExportListener listener)
Registers an event listener for the export method. More...
void | addAppThresholdListener (AppstatsThresholdReachedListener listener)
Registers a threshold listener. More...
void | removeAppStatsExportListener (AppStatsExportListener listener)
Removes an event listener for the export method. More...
void | removeAppStatsThresholdListener (AppstatsThresholdReachedListener listener)
Removes an event listener for the threshold detection. More...
void | removeAppStatsWriteFileListener (AppStatsWriteFileListener listener)
Removes an event listener for the writeToFile method. More...

Static Public Member Functions

static AppStatistics getInstance ()

Protected Attributes

List< AppStatsDao > appStatsDaoCurrent = appStatsDaoPrimary

Detailed Description

Use the AppStatistics class for creating, saving, and exporting statistics related to SDK framework usage.

Member Function Documentation

void addAppStatsExportListener ( AppStatsExportListener listener )

Registers an event listener for the export method.

This method registers an event listener for the export method, so the application can be notified of progress and completion of the export operation.

void addAppStatsWriteFileListener ( AppStatsWriteFileListener listener )

Registers an event listener for the writeToFile method.

This method registers an event listener for the writeToFile method, so the application can be notified of progress and completion of the writeToFile operation.

void addAppThresholdListener ( AppstatsThresholdReachedListener listener )

Registers a threshold listener.

This method registers an event listener for appStats reaching threshold levels, so that each time memory or storage crosses the next threshold level in terms of storage space, this listener will be called.

synchronized void beginSession | ( | String | sessionKey,
 |  | String | category
 | ) |  |

This method tells appStats to start a "session".

This method allows the application a means of recording an application-defined Session. Each session is a grouping in which all subsequent appStats operations will be logged with the same "sessionKey", until the next endSession call.

Parameters
sessionKey | is an application-defined string, which will be a meaningful identifier for this session. This same sessionKey should also be passed to any server-side calls, such as RTTI, so stats collected on the server can reflect the same sessionKey.
category | is an application-defined string, representing the type of session this represents. Examples of typical categories include CheckDeposit, BillPay, etc.
synchronized void endSession | ( | boolean | success,
 |  | String | description
 | ) |  |

This method tells appStats to end a "session".

This method tells appStats to stop the session. Subsequent logging calls will not include a sessionKey in the database, until the next time beginSession is called again.

Parameters
success | should be set to true if the overall operation for this session, such as a check deposit, succeeded. Only the application can know overall success or not of a session.
description | may be used to include helpful logging information, in case the session did not succeed.
synchronized ErrorInfo export | ( | String | exportFilePath,
 |  | AppStatsExportFormat | format
 | ) |  |

The export method creates a SQL dump or other file of the internal data store.

The contents of the database will be written to a sql dump file

String getDeviceId ( )

Returns the current DeviceID which is recorded as a field in the Environment table.

String getFileName ( )

Returns the filename of the datastore where AppStats events are written.

The writeToFile method will store data in a file with this name in the directory: /data/data/application_package_name/databases.

Returns
AppStats database filename
long getFileSize ( ) throws FileNotFoundException

The readonly fileSize variable is the current amount of flash memory used in the database. The database file was specified by the initAppStats method. After you call the purge method, this value is set to 0. The size of the file does not grow linearly, even after a few write to file calls, but this value gives you a relative size as statistical data is written to the data base.

Returns
Current flash storage usage
int getFileSizeThreshold ( )

fileSizeThreshold is the size in bytes at which a warning will be issued to the application. The warning indicates the file size has reached the limit established by the application.

Returns
fileSizeThreshold
static AppStatistics getInstance ( )
static

This method returns a singleton object of AppStatistics.

ListenerCallbackThreadType getListenerCallbackThreadType ( )

Get the ListenerCallbackThreadType.

Returns
the thread type for asynchronous callbacks
long getRamSize ( )

Current size of available RAM.

This readonly property keeps the current recording memory usage.

Returns
Current memory usage
int getRamSizeThreshold ( )

Get the current ram threshold size

Returns
ramSizeThreshold
final synchronized void initAppStats ( String name )

Initialize AppStats with database file name.

This method is used to initialize and open the AppStats database file. If an existing database file is opened, this method checks to see if the database schema matches the current internal app stats schema version. If it does not, the database is silently deleted and recreated.

Parameters
name - name of the database file
boolean isRecording ( )

Returns the status, isRecording is set to true when startRecording is.

Returns the recording status

Returns
- recording status
synchronized void logSessionEvent ( AppStatsSessionEvent sessionEvent )

This method allows the application a means of recording an application-defined Session event.

Each Session event may represent a "sub-Session", or single operation which defines one step in a sequence of steps which collectively define a complete session. The logSessionEvent accepts as a parameter an AppStatsSessionEvent object.

See also
beginSession and endSession.
Parameters
sessionEvent includes all the properties necessary to define a specific AppStats Session event.
synchronized ErrorInfo purge ( )

The purge method erases the AppStats memory buffer and the AppStats recording database file.

The database file was specified by the initAppstats method. Recording must be disabled before calling this method. After this call, the library AppStats is set to an uninitialized state. You must call initAppStats again to begin another session. The purge method does not delete the SQL file that was created by the export method. Your app is responsible for consuming and controlling the export data file.

Returns
KMC_UT_STATS_RECORDING_NOT_OFF if recording, else KMC_SUCCESS
void registerExportHandler ( AppStatsDsExportHandler handler )

The export method creates a SQL dump or other file format of the internal data store.

The export method allows the user to either use the built-in handler for exporting data from the datastore, or the user can write a custom handler to write their own export functionality.

In order to write a custom handler write a class that implements AppStatsDsExportHandler, register the handler, while adding the listener make sure to choose the right export format type.

Parameters
handler - Custom handler
void removeAppStatsExportListener ( AppStatsExportListener listener )

Removes an event listener for the export method.

This method removes an event listener for the export method.

void removeAppStatsThresholdListener ( AppstatsThresholdReachedListener listener )

Removes an event listener for the threshold detection.

This method removes an event listener for theshold detection.

void removeAppStatsWriteFileListener ( AppStatsWriteFileListener listener )

Removes an event listener for the writeToFile method.

This method removes an event listener for the writeToFile method.

void setDeviceId ( String userDeviceID )

Sets the current DeviceID which is recorded as a field in the Environment table.

The application is free to set any device-specific identifier. If no DeviceID is specified, a null or empty string value will be recorded and exported as the 'DeviceID' field in the Environment table.

void setFileSizeThreshold ( int fileSizeThreshold )

When the file reaches the threshold specified SizeThresholdReached event will be fired

Parameters
fileSizeThreshold
void setListenerCallbackThreadType ( ListenerCallbackThreadType listenerCallbackThreadType )

Set the ListenerCallbackThreadType.

Set the thread type for asynchronous callbacks. The application can choose whether to receive event callbacks on the worker thread used to record, write and export AppStats events, or on the main UI thread. The default value is ListenerCallbackThreadType.UI_THREAD.

void setRamSizeThreshold ( int ramSizeThreshold )

Each time a multiple of this threshold is met a SizeThresholdReached event will fire (0 turns off event triggering for file usage).

Parameters
ramSizeThreshold
synchronized ErrorInfo startRecord ( )

Start recording app statistics, or continues recording.

Use this method to start recording statistics during normal library operations. This will set the isRecording property to true, and open the SQLite database.
This method is only valid if you have initialized AppStats by calling initAppStats to create the database file.

synchronized ErrorInfo stopRecord ( )

Stop recording data while retaining data that has been collected.

Use this method to stop recording. This will set the isRecording property to false, and close the data repository to ensure anything in memory is flushed to the file system.
This method is only valid if you previously started recording.

synchronized ErrorInfo writeToFile ( )

Writes the in-memory statistics buffer to the AppStats database.

Use this asynchronous method from your thresholdReached delegate to periodically write the buffer to the database file. You may also call this method periodically while recording or after recording is turned off. This helps conserve memory. Writing AppStats data to memory improves performance.

If the database was closed, this method opens it first for writing, then closes it when finished. Else if open, the method keeps it open.

After the write is complete, the AppStats internal buffer is erased, and the filesize property may or may not increase, but reflects the size of the database file after the write completes.

Member Data Documentation

List<AppStatsDao> appStatsDaoCurrent = appStatsDaoPrimary
protected
The documentation for this class was generated from the following file:
  • AppStatistics.java


Kofax Mobile SDK API Reference: AppStatistics.AppStatsExportFormat Enum Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatistics
  • AppStatsExportFormat
Public Attributes | List of all members
AppStatistics.AppStatsExportFormat Enum Reference

Indicates the export format desired when calling the export method. More...

Public Attributes

EXP_FORMAT_SQL_SERVER
EXP_FORMAT_JSON
EXP_FORMAT_APP_DEFINED

Detailed Description

Indicates the export format desired when calling the export method.

Member Data Documentation

EXP_FORMAT_APP_DEFINED
EXP_FORMAT_JSON
EXP_FORMAT_SQL_SERVER
The documentation for this enum was generated from the following file:
  • AppStatistics.java


Kofax Mobile SDK API Reference: AppStatistics.ExportStatusEvent Enum Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatistics
  • ExportStatusEvent
Public Attributes | List of all members
AppStatistics.ExportStatusEvent Enum Reference

Public Attributes

EXPORTING
COMPLETE
FAILED

Detailed Description

Exporting is an asynchronous operation. It will periodically fire this event to alert app of progress, and status. Exporting is an asynchronous operation. It will periodically fire this event to alert the application of progress, and status.

Member Data Documentation

COMPLETE
EXPORTING
FAILED
The documentation for this enum was generated from the following file:
  • AppStatistics.java


Kofax Mobile SDK API Reference: AppStatistics.ThresholdType Enum Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatistics
  • ThresholdType
Public Attributes | List of all members
AppStatistics.ThresholdType Enum Reference

Public Attributes

THRESH_TYPE_RAM
THRESH_TYPE_FILE

Detailed Description

When a size threshold is reached this event will fire, allowing the application developer to either purge data or write to flash memory.

Member Data Documentation

THRESH_TYPE_FILE
THRESH_TYPE_RAM
The documentation for this enum was generated from the following file:
  • AppStatistics.java


Kofax Mobile SDK API Reference: AppStatsDaoField Class Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsDaoField
Public Member Functions | List of all members
AppStatsDaoField Class Reference

Container for properties that define one field in a table in the datastore. More...

Public Member Functions

String | getDsFieldName ()
AppStatsDsFieldType | getDsFieldType ()
AppStatsDbFieldType | getDbFieldType ()
AppStatsDbFieldKeyType | getDbFieldKeyType ()
String | getDsValueString ()
Float | getDsValueFloat ()
Integer | getDsValueInt ()
Long | getDsValueLong ()
Date | getDsValueDate ()

Detailed Description

Container for properties that define one field in a table in the datastore.

It's intended to be generic enough to not imply any assumptions about the underlying concrete datastore implementation. Details necessary to create database-specific SQL statements are included in the dbFieldType and dbFieldKeyType properties. For native datastore values, the dsValueString property is always populated, as the native datastore type converted to a java String type. For convenience, the dsFieldType property indicates the actual native stored java type, and the associated type-specific getter can be used to access it in its native datastore type.

Member Function Documentation

AppStatsDbFieldKeyType getDbFieldKeyType ( )
AppStatsDbFieldType getDbFieldType ( )
String getDsFieldName ( )
AppStatsDsFieldType getDsFieldType ( )
Date getDsValueDate ( )
Float getDsValueFloat ( )
Integer getDsValueInt ( )
Long getDsValueLong ( )
String getDsValueString ( )
The documentation for this class was generated from the following file:
  • AppStatsDaoField.java


Kofax Mobile SDK API Reference: AppStatsDsExportHandler Interface Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsDsExportHandler
Public Member Functions | List of all members
AppStatsDsExportHandler Interface Reference

Public Member Functions

void | onExportAppStatsRowEvent (String dsExportTblName, AppStatsDaoField[] daoFields)
This method will be called once for each row in the AppStats datastore file. More...
void | configDsExpFilePath (String dsExpFilePath)

Detailed Description

Handler interface that formats an incoming datastore row, and writes it out to the export file path. The application can implement this interface and write their own custom AppStats event export handler.

Member Function Documentation

void configDsExpFilePath ( String dsExpFilePath )

This method will be called once for each export operation, and indicates the file destination of exported AppStats events.

void onExportAppStatsRowEvent | ( | String | dsExportTblName,
 |  | AppStatsDaoField[] | daoFields
 | ) |  |

This method will be called once for each row in the AppStats datastore file.

The documentation for this interface was generated from the following file:
  • AppStatsDsExportHandler.java


Kofax Mobile SDK API Reference: AppStatsExportEvent Class Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsExportEvent
Public Member Functions | List of all members
AppStatsExportEvent Class Reference

This event is fired when AppStats events are being exported. More...

Inheritance diagram for AppStatsExportEvent:

Public Member Functions

ExportStatus getExportStatus ()
Return the on-going export status as AppStats events are being exported. More...
int getPercentComplete ()
Return the percent complete as AppStats events are being exported. More...
ErrorInfo getErrorInfo ()
Return any error status if the export operation did not complete successfully. More...

Detailed Description

This event is fired when AppStats events are being exported.

The event object includes status information, along with percent completed.

Member Function Documentation

ErrorInfo getErrorInfo ( )

Return any error status if the export operation did not complete successfully.

ExportStatus getExportStatus ( )

Return the on-going export status as AppStats events are being exported.

int getPercentComplete ( )

Return the percent complete as AppStats events are being exported.

The documentation for this class was generated from the following file:
  • AppStatsExportEvent.java


Kofax Mobile SDK API Reference: AppStatsExportListener Interface Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsExportListener
Classes | Public Member Functions | List of all members
AppStatsExportListener Interface Reference

Classes

enum ExportStatus

Public Member Functions

void exportStatusEvent (AppStatsExportEvent event)

Detailed Description

Asynchronous notifications from the export operation. The application can implement this interface, and register it with the AppStatistics object, using the addAppStatsExportListener method.

Member Function Documentation

void exportStatusEvent ( AppStatsExportEvent event )
The documentation for this interface was generated from the following file:
  • AppStatsExportListener.java


Kofax Mobile SDK API Reference: AppStatsExportListener.ExportStatus Enum Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsExportListener
  • ExportStatus
Public Attributes | List of all members
AppStatsExportListener.ExportStatus Enum Reference

Public Attributes

EXPORTING
COMPLETE
FAILED

Member Data Documentation

COMPLETE
EXPORTING
FAILED
The documentation for this enum was generated from the following file:
  • AppStatsExportListener.java


Kofax Mobile SDK API Reference: AppStatsSessionEvent Class Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsSessionEvent
Public Member Functions | List of all members
AppStatsSessionEvent Class Reference

This data-only class is used to set properties that define an AppStats Session Event. More...

Public Member Functions

AppStatsSessionEvent ()
Parameter-less default constructor. More...
AppStatsSessionEvent (String type)
Constructor which takes a Session Type as parameters. More...
AppStatsSessionEvent (String type, String response)
Constructor which takes a Session Type, and session event response as parameters. More...
String | getType ()
Return the application-defined Session Type. More...
void | setType (String sessionType)
Set the application-defined Session Type. More...
String | getResponse ()
Return the application-defined session event response (result). More...
void | setResponse (String response)
Set the application-defined session event response (result). More...

Detailed Description

This data-only class is used to set properties that define an AppStats Session Event.

The AppStatsSessionEvent data object includes all the properties necessary to define a specific AppStats Session event. It is passed as a parameter to the logSessionEvent method on the AppStatistics object.

Constructor & Destructor Documentation

AppStatsSessionEvent ( )

Parameter-less default constructor.

AppStatsSessionEvent ( String type )

Constructor which takes a Session Type as parameters.

AppStatsSessionEvent | ( | String | type,
 |  | String | response
 | ) |  |

Constructor which takes a Session Type, and session event response as parameters.

Member Function Documentation

String getResponse ( )

Return the application-defined session event response (result).

Returns the response (result) of a session event. This response is defined by the application. It typically would indicate whether the session event was successful, and if it failed, the reason for the failure.

Returns
response
String getType ( )

Return the application-defined Session Type.

Returns the specific type of Session event, or single step (a sort of sub-Session) in a sequence of steps which comprise a complete Session. Application-defined. Can be used to book-end a specific session event to calculate elapsed time, with a "session A start", and "session A end" type.

Returns
type
void setResponse ( String response )

Set the application-defined session event response (result).

Sets the response (result) of a session event. This response is defined by the application and could indicate success, failure, or some type of error condition.

Parameters
response
void setType ( String sessionType )

Set the application-defined Session Type.

Sets the specific type of Session event, or single step (a sort of sub-Session) in a sequence of steps which comprise a complete Session. Application-defined. Can be used to book-end a specific session event to calculate elapsed time, with a "session A start", and "session A end" type.

Parameters
sessionType
The documentation for this class was generated from the following file:
  • AppStatsSessionEvent.java


Kofax Mobile SDK API Reference: AppStatsThresholdReachedEvent Class Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsThresholdReachedEvent
Public Member Functions | List of all members
AppStatsThresholdReachedEvent Class Reference
Inheritance diagram for AppStatsThresholdReachedEvent:

Public Member Functions

ThresholdType getThresholdType ()
Return the type of threshold event that was triggered: either THRESH_TYPE_RAM or THRESH_TYPE_FILE. More...
long getSize ()
Return the size of AppStats memory used, or AppStats file size that triggered this event. More...

Detailed Description

This event is fired when the size threshold is reached for either in-memory AppStats events, or AppStats events written to file. It allows the application to monitor memory usage and file-based storage usage for all AppStats event recording. The application can specify the threshold at which this event will be fired, by calling setRamSizeThreshold and setFileSizeThreshold.

Member Function Documentation

long getSize ( )

Return the size of AppStats memory used, or AppStats file size that triggered this event.

ThresholdType getThresholdType ( )

Return the type of threshold event that was triggered: either THRESH_TYPE_RAM or THRESH_TYPE_FILE.

The documentation for this class was generated from the following file:
  • AppStatsThresholdReachedEvent.java


Kofax Mobile SDK API Reference: AppstatsThresholdReachedListener Interface Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppstatsThresholdReachedListener
Public Member Functions | List of all members
AppstatsThresholdReachedListener Interface Reference

Public Member Functions

void thresholdReached (AppStatsThresholdReachedEvent event)

Detailed Description

Asynchronous notifications from the recording and writing of AppStats events. The application can implement this interface, and register it with the AppStatistics object, using the addAppThresholdListener method. The thresholdReached listener method will be called every time a multiple of the threshold size is reached. The threshold size for RAM and file storage can be set using the setRamSizeThreshold and setFileSizeThreshold methods. These threshold sizes apply only to memory and/or file storage consumed by AppStats events.

Member Function Documentation

void thresholdReached ( AppStatsThresholdReachedEvent event )
The documentation for this interface was generated from the following file:
  • AppstatsThresholdReachedListener.java


Kofax Mobile SDK API Reference: AppStatsWriteFileListener Interface Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsWriteFileListener
Classes | Public Member Functions | List of all members
AppStatsWriteFileListener Interface Reference

Classes

enum WriteFileStatus

Public Member Functions

void writeFileStatusEvent (AppStatsWritetoFileEvent event)

Detailed Description

Asynchronous notifications from the writeToFile operation. The application can implement this interface, and register it with the AppStatistics object, using the addAppStatsWriteFileListener method.

Member Function Documentation

void writeFileStatusEvent ( AppStatsWritetoFileEvent event )
The documentation for this interface was generated from the following file:
  • AppStatsWriteFileListener.java


Kofax Mobile SDK API Reference: AppStatsWriteFileListener.WriteFileStatus Enum Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsWriteFileListener
  • WriteFileStatus
Public Attributes | List of all members
AppStatsWriteFileListener.WriteFileStatus Enum Reference

Public Attributes

WRITE_STATUS_WRITING
WRITE_STATUS_COMPLETE
WRITE_STATUS_FAILED

Member Data Documentation

WRITE_STATUS_COMPLETE
WRITE_STATUS_FAILED
WRITE_STATUS_WRITING
The documentation for this enum was generated from the following file:
  • AppStatsWriteFileListener.java


Kofax Mobile SDK API Reference: AppStatsWritetoFileEvent Class Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsWritetoFileEvent
Public Member Functions | List of all members
AppStatsWritetoFileEvent Class Reference
Inheritance diagram for AppStatsWritetoFileEvent:

Public Member Functions

float getPercentComplete ()
Return the percent complete as AppStats events are being written to file. More...
WriteFileStatus getWritetoFileStatus ()
Return the on-going write status as AppStats events are being written to file. More...
ErrorInfo getErrorInfo ()
Return any error status if the write to file operation did not complete successfully. More...

Detailed Description

This event is fired each time an AppStats event is written to file. The event object includes status information, along with percent completed.

Member Function Documentation

ErrorInfo getErrorInfo ( )

Return any error status if the write to file operation did not complete successfully.

float getPercentComplete ( )

Return the percent complete as AppStats events are being written to file.

WriteFileStatus getWritetoFileStatus ( )

Return the on-going write status as AppStats events are being written to file.

The documentation for this class was generated from the following file:
  • AppStatsWritetoFileEvent.java


Kofax Mobile SDK API Reference: AppStatsWriteToFileResults Class Reference

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsWriteToFileResults
Public Member Functions | List of all members
AppStatsWriteToFileResults Class Reference

Public Member Functions

AppStatsWriteToFileResults (ErrorInfo errorState, WriteFileStatus newState)
ErrorInfo isError ()
WriteFileStatus getState ()
void | setState (WriteFileStatus status)
void | setError (ErrorInfo result)

Constructor & Destructor Documentation

AppStatsWriteToFileResults | ( | ErrorInfo | errorState,
 |  | WriteFileStatus | newState
 | ) |  |

Member Function Documentation

WriteFileStatus getState ( )
ErrorInfo isError ( )
void setError ( ErrorInfo result )
void setState ( WriteFileStatus status )
The documentation for this class was generated from the following file:
  • AppStatsWriteToFileResults.java


Kofax Mobile SDK API Reference: ListenerCallbackThreadType Enum Reference

  • kmc
  • kut
  • utilities
  • async
  • ListenerCallbackThreadType
Public Attributes | List of all members
ListenerCallbackThreadType Enum Reference

An enum which identifies the thread type for asynchronous callbacks. More...

Public Attributes

UI_THREAD
The UI thread. Callbacks will be called on the UI thread. More...
WORKER_THREAD
A worker thread. Callbacks will be called on non-UI thread. More...

Detailed Description

An enum which identifies the thread type for asynchronous callbacks.

Member Data Documentation

UI_THREAD

The UI thread. Callbacks will be called on the UI thread.

This will allow you to manipulate your UI from the callback.

WORKER_THREAD

A worker thread. Callbacks will be called on non-UI thread.

This will allow you to perform additional heavy operations after the callback is received and not block the UI thread.

The documentation for this enum was generated from the following file:
  • ListenerCallbackThreadType.java


Kofax Mobile SDK API Reference: ErrorInfo Enum Reference

  • kmc
  • kut
  • utilities
  • error
  • ErrorInfo
Public Member Functions | Public Attributes | List of all members
ErrorInfo Enum Reference

The ErrorInfo enum can be used by application developers to lookup error information. More...

Public Member Functions

ErrorInfo (int errCode)
int | getErr ()
The getErr method returns the numeric error code for a given error condition. More...
String | getErrMsg ()
The getErrMsg method returns the short error description for a given error condition. More...
String | getErrDesc ()
The getErrDesc method returns the detailed description and/or cause for a given error condition. More...
String | getErrCause ()
void | setErrCause (String errorCause)

Public Attributes

KMC_SUCCESS =(0)
KMC_GN_FILE_NOT_FOUND =(ErrGrp.KMC_GN_BASE + 1)
KMC_GN_OUT_OF_MEMORY =(ErrGrp.KMC_GN_BASE + 2)
KMC_GN_UNKNOWN_ERROR =(ErrGrp.KMC_GN_BASE + 3)
KMC_GN_PARAM_NEGATIVE =(ErrGrp.KMC_GN_BASE + 4)
KMC_GN_UNSUPPORTED_OPERATION =(ErrGrp.KMC_GN_BASE + 5)
KMC_GN_BAD_APPLICATION_CONTEXT =(ErrGrp.KMC_GN_BASE + 6)
KMC_GN_DESERIALIZE_VERSION_ERROR =(ErrGrp.KMC_GN_BASE + 7)
KMC_GN_DESERIALIZE_OBJECT_ERROR =(ErrGrp.KMC_GN_BASE + 8)
KMC_GN_SESSION_CREATE_ERROR =(ErrGrp.KMC_GN_BASE + 9)
KMC_GN_SESSION_DISMISS_ERROR =(ErrGrp.KMC_GN_BASE + 10)
KMC_GN_NULL_POINTER_EXCEPTION =(ErrGrp.KMC_GN_BASE + 11)
KMC_GN_IO_EXCEPTION =(ErrGrp.KMC_GN_BASE + 12)
KMC_GN_ILLEGAL_ARGUMENT_EXCEPTION =(ErrGrp.KMC_GN_BASE + 13)
KMC_GN_INTERNAL_ERROR =(ErrGrp.KMC_GN_BASE + 14)
KMC_GN_ILLEGAL_THREAD_STATE_EXCEPTION =(ErrGrp.KMC_GN_BASE + 15)
KMC_GN_FILE_NOT_FOUND_EXCEPTION =(ErrGrp.KMC_GN_BASE + 16)
KMC_GN_LOGIN_NOT_APPLICABLE =(ErrGrp.KMC_GN_BASE + 17)
KMC_LO_INVALID_SERVER_URL =(ErrGrp.KMC_LO_BASE + 1)
KMC_LO_SERVER_URL_NOT_SET =(ErrGrp.KMC_LO_BASE + 2)
KMC_LO_USERNAME_NOT_SET =(ErrGrp.KMC_LO_BASE + 3)
KMC_LO_USER_ALREADY_LOGGED_IN =(ErrGrp.KMC_LO_BASE + 4)
KMC_LO_USER_NOT_LOGGED_IN_ON_LOGOUT =(ErrGrp.KMC_LO_BASE + 5)
KMC_LO_USER_LOGGING_IN_ON_LOGIN =(ErrGrp.KMC_LO_BASE + 6)
KMC_LO_USER_ALREADY_LOGGED_OUT =(ErrGrp.KMC_LO_BASE + 7)
KMC_LO_USER_LOGGING_OUT_ON_LOGOUT =(ErrGrp.KMC_LO_BASE + 8)
KMC_LO_DEVICE_REG_LICENSING_ERROR =(ErrGrp.KMC_LO_BASE + 9)
KMC_LO_SESSION_STATE_BUSY =(ErrGrp.KMC_LO_BASE + 10)
KMC_LO_USER_LOGIN_ERROR =(ErrGrp.KMC_LO_BASE + 11)
KMC_LO_PAGE_NOT_FOUND =(ErrGrp.KMC_LO_BASE+12)
KMC_LO_IMAGE_NOT_FOUND =(ErrGrp.KMC_LO_BASE+13)
KMC_LO_DOMAIN =(ErrGrp.KMC_LO_BASE+14)
KMC_LO_EMAIL =(ErrGrp.KMC_LO_BASE+15)
KMC_LO_NOT_REGISTERED =(ErrGrp.KMC_LO_BASE + 16)
KMC_LO_REGISTERING =(ErrGrp.KMC_LO_BASE + 17)
KMC_LO_OVERLAPPED_OPERATIONS =(ErrGrp.KMC_LO_BASE + 18)
KMC_LO_INVALID_SESSION_STATE =(ErrGrp.KMC_LO_BASE + 19)
KMC_LO_LOGIN_NOT_ALLOWED =(ErrGrp.KMC_LO_BASE + 20)
KMC_LO_NOT_LOGGED_IN =(ErrGrp.KMC_LO_BASE + 21)
KMC_LO_USER_LOGOUT_ERROR =(ErrGrp.KMC_LO_BASE + 22)
KMC_LO_TASK_LOCK_ACQUIRE_ERROR =(ErrGrp.KMC_LO_BASE + 23)
KMC_LO_NO_OPERATION_TO_CANCEL =(ErrGrp.KMC_LO_BASE + 24)
KMC_LO_OPERATION_NOT_CANCELLABLE =(ErrGrp.KMC_LO_BASE + 25)
KMC_LO_OPERATION_CANCELLED =(ErrGrp.KMC_LO_BASE + 26)
KMC_LO_INVALID_DOCUMENT_TYPE_NAME =(ErrGrp.KMC_LO_BASE + 27)
KMC_LO_DOWNLOAD_DOCUMENT_FIELDS_ERROR =(ErrGrp.KMC_LO_BASE + 28)
KMC_LO_SUBMIT_PNG =(ErrGrp.KMC_LO_BASE + 29)
KMC_LO_SUBMIT_BITMAP =(ErrGrp.KMC_LO_BASE + 30)
KMC_LO_START_SUBMIT_JOB_ERROR =(ErrGrp.KMC_LO_BASE + 31)
KMC_LO_SUBMIT_DOCUMENT_IMAGES_ERROR =(ErrGrp.KMC_LO_BASE + 32)
KMC_LO_START_SUBMIT_INVALID_JOB_ID =(ErrGrp.KMC_LO_BASE + 33)
KMC_LO_SUBMIT_DOCUMENT_FILEIO_ERROR =(ErrGrp.KMC_LO_BASE+34)
KMC_LO_SUBMIT_DOCUMENT_FILE_CLOSE_ERROR =(ErrGrp.KMC_LO_BASE+35)
KMC_LO_SUBMIT_DOCUMENT_NO_IMAGE_ERROR =(ErrGrp.KMC_LO_BASE+36)
KMC_LO_PAGE_IMAGE_INDEX_INVALID =(ErrGrp.KMC_LO_BASE+37)
KMC_LO_SUBMIT_DOCUMENT_MIMETYPE_ERROR =(ErrGrp.KMC_LO_BASE+38)
KMC_LO_SUBMIT_DOCUMENT_IMAGE_REP_ERROR =(ErrGrp.KMC_LO_BASE+39)
KMC_LO_SUBMIT_DOCUMENT_IMAGE_FILE_MISSING =(ErrGrp.KMC_LO_BASE+40)
KMC_LO_OPERATION_CANCEL_ERROR =(ErrGrp.KMC_LO_BASE+41)
KMC_LO_INVALID_SESSION_STATE_TRANSITION =(ErrGrp.KMC_LO_BASE+42)
KMC_LO_REGISTERING_NOT_ALLOWED =(ErrGrp.KMC_LO_BASE+43)
KMC_LO_DOWNLOAD_DOCUMENT_SCAN_SETTINGS_ERROR =(ErrGrp.KMC_LO_BASE + 44)
KMC_LO_EVENT_LOCK_ACQUIRE_ERROR =(ErrGrp.KMC_LO_BASE + 45)
KMC_LO_REQUEST_TIMEOUT =(ErrGrp.KMC_LO_BASE + 48)
KMC_LO_SERVER_TIMEOUT =(ErrGrp.KMC_LO_BASE + 49)
KMC_LO_REGISTER_REQUIRES_AUTH =(ErrGrp.KMC_LO_BASE + 50)
KMC_LO_INVALID_CERTIFICATE =(ErrGrp.KMC_LO_BASE + 51)
KMC_ED_FILEPATH =(ErrGrp.KMC_ED_BASE + 1)
KMC_ED_MIMETYPE =(ErrGrp.KMC_ED_BASE + 2)
KMC_ED_NOIMAGE =(ErrGrp.KMC_ED_BASE + 3)
KMC_ED_IMAGELEAK =(ErrGrp.KMC_ED_BASE + 4)
KMC_ED_NONEXISTENT_FILE =(ErrGrp.KMC_ED_BASE + 6)
KMC_ED_FILE_NOT_DELETABLE =(ErrGrp.KMC_ED_BASE + 7)
KMC_ED_FILE_STILL_REMAINS =(ErrGrp.KMC_ED_BASE + 8)
KMC_ED_MIMETYPE_MISMATCH =(ErrGrp.KMC_ED_BASE + 10)
KMC_ED_JPEG_BITDEPTH =(ErrGrp.KMC_ED_BASE + 11)
KMC_ED_FILE_EXISTS =(ErrGrp.KMC_ED_BASE + 12)
KMC_ED_IMAGE_IS_SCALED =(ErrGrp.KMC_ED_BASE + 13)
KMC_ED_OBJECT_REP_BITMAP_MISMATCH =(ErrGrp.KMC_ED_BASE + 14)
KMC_ED_OBJECT_REP_FILE_MISMATCH =(ErrGrp.KMC_ED_BASE + 15)
KMC_ED_INVALID_ISO_DATE_TIME_FORMAT =(ErrGrp.KMC_ED_BASE + 17)
KMC_ED_INVALID_JPEG_QUALITY_VALUE =(ErrGrp.KMC_ED_BASE + 18)
KMC_ED_BITMAP_WRITE_TO_FILE_FAILED =(ErrGrp.KMC_ED_BASE + 19)
KMC_ED_INVALID_DPI =(ErrGrp.KMC_ED_BASE + 20)
KMC_ED_ALREADY_CLEAR =(ErrGrp.KMC_ED_BASE + 21)
KMC_ED_ALTERNATE_FILEIO_ENGINE =(ErrGrp.KMC_ED_BASE + 22)
KMC_ED_BITMAP_READ_FROM_FILE_FAILED =(ErrGrp.KMC_ED_BASE + 23)
KMC_ED_IMAGE_WRITTEN_IS_NOT_BITONAL =(ErrGrp.KMC_ED_BASE + 32)
KMC_ED_IMAGE_WRITTEN_IS_NOT_GRAY =(ErrGrp.KMC_ED_BASE + 33)
KMC_ED_UNRECOGNIZED_MIME_TYPE =(ErrGrp.KMC_ED_BASE + 35)
KMC_ED_BITMAP_DIMENSIONS_IMMUTABLE =(ErrGrp.KMC_ED_BASE + 36)
KMC_ED_BITMAP_DIMENSIONS_NO_UPSCALE =(ErrGrp.KMC_ED_BASE + 37)
KMC_ED_IMAGE_FILE_DIMENSIONS_ERROR =(ErrGrp.KMC_ED_BASE + 38)
KMC_ED_IMAGE_INVALID_SCALING_FACTOR =(ErrGrp.KMC_ED_BASE + 39)
KMC_ED_IMAGE_PERFECTION_PROFILE_EMPTY =(ErrGrp.KMC_ED_BASE + 40)
KMC_ED_OBJECT_REP_NO_BITMAP =(ErrGrp.KMC_ED_BASE + 41)
KMC_ED_BUFFER_EXISTS =(ErrGrp.KMC_ED_BASE + 42)
KMC_ED_BUFFER =(ErrGrp.KMC_ED_BASE + 43)
KMC_ED_BUFFER_ALREADY_CLEARED =(ErrGrp.KMC_ED_BASE + 44)
KMC_ED_OBJECT_REP_MISMATCH =(ErrGrp.KMC_ED_BASE + 45)
KMC_ED_ALREADY_BUFFERED =(ErrGrp.KMC_ED_BASE + 46)
KMC_ED_DELETE_BUFFERED_FILE =(ErrGrp.KMC_ED_BASE + 47)
KMC_ED_NO_MEMORY_FOR_BUFFERED_FILE =(ErrGrp.KMC_ED_BASE + 48)
KMC_ED_BUFFERED_READ_FAILED =(ErrGrp.KMC_ED_BASE + 49)
KMC_ED_NO_BUFFERED_IMAGE =(ErrGrp.KMC_ED_BASE + 50)
KMC_ED_INVALID_FOR_OBJECT_REP =(ErrGrp.KMC_ED_BASE + 51)
KMC_ED_NONEXISTENT_LOAD_SETTINGS_FILE =(ErrGrp.KMC_ED_BASE + 52)
KMC_ED_NONEXISTENT_OCR_REGION_TYPE =(ErrGrp.KMC_ED_BASE + 53)
KMC_ED_FILE_RESTRICTION_MIMETYPE =(ErrGrp.KMC_ED_BASE + 54)
KMC_ED_FILE_RESTRICTION_BITDEPTH =(ErrGrp.KMC_ED_BASE + 55)
KMC_ED_FILE_RESTRICTION_DPI =(ErrGrp.KMC_ED_BASE + 56)
KMC_ED_INVALID_DOCUMENT_DIMENSIONS =(ErrGrp.KMC_ED_BASE + 57)
KMC_UI_FLASH_AUTO_NOT_SUPPORTED =(ErrGrp.KMC_UI_BASE + 1)
KMC_UI_FLASH_ON_NOT_SUPPORTED =(ErrGrp.KMC_UI_BASE + 2)
KMC_UI_FLASH_OFF_NOT_SUPPORTED =(ErrGrp.KMC_UI_BASE + 3)
KMC_UI_SCALING_FACTOR =(ErrGrp.KMC_UI_BASE + 4)
KMC_UI_INVALID_THRESHOLD_ARGUMENT =(ErrGrp.KMC_UI_BASE + 5)
KMC_UI_INVALID_DECLINATION_ARGUMENT =(ErrGrp.KMC_UI_BASE + 6)
KMC_UI_INVALID_STABILITY_DELAY_ARGUMENT =(ErrGrp.KMC_UI_BASE + 7)
KMC_UI_IMAGE_NULL =(ErrGrp.KMC_UI_BASE + 8)
KMC_UI_CAMERA_ALREADY_OPEN =(ErrGrp.KMC_UI_BASE + 9)
KMC_UI_CAMERA_OPERATION_FAILURE =(ErrGrp.KMC_UI_BASE + 10)
KMC_UI_CAMERA_LOCK_ACQUIRE_FAILURE =(ErrGrp.KMC_UI_BASE + 11)
KMC_UI_INVALID_AXIS_THRESHOLD_ARGUMENT =(ErrGrp.KMC_UI_BASE + 12)
KMC_UI_INVALID_PAGE_THRESHOLD_ARGUMENT =(ErrGrp.KMC_UI_BASE + 13)
KMC_UI_FOCUS_AREA_NOT_SUPPORTED =(ErrGrp.KMC_UI_BASE + 14)
KMC_UI_FOCUS_AREA_COUNT =(ErrGrp.KMC_UI_BASE + 15)
KMC_UI_FOCUS_AREA_EMPTY =(ErrGrp.KMC_UI_BASE + 16)
KMC_UI_FLASH_TORCH_NOT_SUPPORTED =(ErrGrp.KMC_UI_BASE + 17)
KMC_UI_INVALID_PADDING_PERCENTAGE_ARGUMENT =(ErrGrp.KMC_UI_BASE + 18)
KMC_UI_INVALID_ASPECT_RATIO_ARGUMENT =(ErrGrp.KMC_UI_BASE + 19)
KMC_UI_INVALID_BORDER_THICKNESS_ARGUMENT =(ErrGrp.KMC_UI_BASE + 20)
KMC_UI_INVALID_WIDTH_ARGUMENT =(ErrGrp.KMC_UI_BASE + 21)
KMC_UI_INVALID_HEIGHT_ARGUMENT =(ErrGrp.KMC_UI_BASE + 22)
KMC_UI_FOCUS_AREA_INVALID =(ErrGrp.KMC_UI_BASE + 23)
KMC_UI_VIEW_NULL =(ErrGrp.KMC_UI_BASE + 24)
KMC_UI_CREDITCARD_ARCH_NOT_SUPPORTED =(ErrGrp.KMC_UI_BASE + 25)
KMC_UI_ODE_NOT_SUPPORTED_FOR_THE_DOCUMENT_TYPE =(ErrGrp.KMC_UI_BASE + 26)
KMC_EV_MEMORY =(ErrGrp.KMC_EV_BASE + 1)
KMC_EV_FILEOPEN =(ErrGrp.KMC_EV_BASE + 2)
KMC_EV_BAD_DPI =(ErrGrp.KMC_EV_BASE + 3)
KMC_EV_BAD_WIDTH_HEIGHT =(ErrGrp.KMC_EV_BASE + 4)
KMC_EV_BAD_LINEWIDTH =(ErrGrp.KMC_EV_BASE + 5)
KMC_EV_BAD_CHANNEL =(ErrGrp.KMC_EV_BASE + 6)
KMC_EV_METADATA_OVERFLOW =(ErrGrp.KMC_EV_BASE + 7)
KMC_EV_FILE_READ_FAILED =(ErrGrp.KMC_EV_BASE + 8)
KMC_EV_IMAGE_PARM =(ErrGrp.KMC_EV_BASE + 9)
KMC_EV_IMAGE_PROCESSING =(ErrGrp.KMC_EV_BASE + 10)
KMC_EV_IMAGE_WRITE_FAILED =(ErrGrp.KMC_EV_BASE + 11)
KMC_EV_UNKNOWN_FILETYPE =(ErrGrp.KMC_EV_BASE + 12)
KMC_EV_NONEXISTANT_IMAGE =(ErrGrp.KMC_EV_BASE + 13)
KMC_EV_BAD_FILE_FORMAT =(ErrGrp.KMC_EV_BASE + 14)
KMC_EV_APPEND_TO_FILE =(ErrGrp.KMC_EV_BASE + 15)
KMC_EV_CANNOT_APPEND =(ErrGrp.KMC_EV_BASE + 16)
KMC_EV_PDF_BAD =(ErrGrp.KMC_EV_BASE + 17)
KMC_EV_APPEND_ENCRYPTED =(ErrGrp.KMC_EV_BASE + 18)
KMC_EV_PDF_TOO_LARGE =(ErrGrp.KMC_EV_BASE + 19)
KMC_EV_SPEED_ACCURACY =(ErrGrp.KMC_EV_BASE + 20)
KMC_EV_NETWORK_READ =(ErrGrp.KMC_EV_BASE + 21)
KMC_EV_FILE_METADATA =(ErrGrp.KMC_EV_BASE + 22)
KMC_EV_INVALID_HANDLE =(ErrGrp.KMC_EV_BASE + 23)
KMC_EV_EXTERNAL_PAGE =(ErrGrp.KMC_EV_BASE + 24)
KMC_EV_HISTOGRAM =(ErrGrp.KMC_EV_BASE + 26)
KMC_EV_INVALID_POINTER =(ErrGrp.KMC_EV_BASE + 27)
KMC_EV_BARCODE_DRIVER =(ErrGrp.KMC_EV_BASE + 29)
KMC_EV_LICENSING =(ErrGrp.KMC_EV_BASE + 30)
KMC_EV_LICENSE_EXPIRED =(ErrGrp.KMC_EV_BASE + 31)
KMC_EV_LOCK_CREATION_ERROR =(ErrGrp.KMC_EV_BASE + 32)
KMC_EV_FILE_IO_ACCESS_BUSY =(ErrGrp.KMC_EV_BASE + 33)
KMC_EV_PROCESS_PAGE_BUSY =(ErrGrp.KMC_EV_BASE + 34)
KMC_EV_LICENSE_ALREADY_SET =(ErrGrp.KMC_EV_BASE + 41)
KMC_EV_CANCEL_OPERATION_SUCCESS =(ErrGrp.KMC_EV_BASE + 42)
KMC_EV_UNKNOWN_VARIANT =(ErrGrp.KMC_EV_BASE + 43)
KMC_EV_OP_STRING_ERROR =(ErrGrp.KMC_EV_BASE + 44)
KMC_EV_UNSUPPORTED_BITMAP_FORMAT =(ErrGrp.KMC_EV_BASE + 45)
KMC_IP_NO_PROFILE =(ErrGrp.KMC_IP_BASE + 1)
KMC_IP_NO_REPRESENTATION =(ErrGrp.KMC_IP_BASE + 2)
KMC_IP_LICENSE_INVALID =(ErrGrp.KMC_IP_BASE + 4)
KMC_IP_LICENSE_EXPIRED =(ErrGrp.KMC_IP_BASE + 5)
KMC_IP_LICENSE_ALREADY_SET =(ErrGrp.KMC_IP_BASE + 6)
KMC_IP_FILE_AND_BUFFERED_REPRESENTATION =(ErrGrp.KMC_IP_BASE + 9)
KMC_IP_NO_CONFIGURATION =(ErrGrp.KMC_IP_BASE + 10)
KMC_CL_CONFIG_NULL =(ErrGrp.KMC_CL_BASE + 1)
KMC_CL_CONFIG_NOT_LOADED =(ErrGrp.KMC_CL_BASE + 2)
KMC_CL_MODEL_NULL =(ErrGrp.KMC_CL_BASE + 3)
KMC_CL_MODEL_NOT_LOADED =(ErrGrp.KMC_CL_BASE + 4)
KMC_CL_LISTENER_NULL =(ErrGrp.KMC_CL_BASE + 5)
KMC_CL_MAX_NUM_RESULTS_INVALID =(ErrGrp.KMC_CL_BASE + 6)
KMC_CL_CLASSIFIER_BUSY =(ErrGrp.KMC_CL_BASE + 7)
KMC_CL_CLASSIFIER_NOT_INITIALIZED =(ErrGrp.KMC_CL_BASE + 8)
KMC_CL_INVALID_IMAGE_SUPPLIED =(ErrGrp.KMC_CL_BASE + 9)
KMC_CL_NO_IMAGE_SUPPLIED =(ErrGrp.KMC_CL_BASE + 10)
KMC_CL_CLASSIFICATION_CONFIDENCE_LOW =(ErrGrp.KMC_CL_BASE + 11)
KMC_CL_INVALID_BARCODE_STRING =(ErrGrp.KMC_CL_BASE + 12)
KMC_CL_ENCRYPTED_BARCODE_STRING =(ErrGrp.KMC_CL_BASE + 13)
KMC_CL_ID_CLASS_NOT_SUPPORTED =(ErrGrp.KMC_CL_BASE + 14)
KMC_EX_PASSPORT_MRZ_DATA_NOT_FOUND =(ErrGrp.KMC_EX_BASE + 1)
KMC_UT_STATS_RECORDING_NOT_OFF =(ErrGrp.KMC_UT_BASE + 1)
KMC_UT_STATS_FILEPATH_IS_NULL =(ErrGrp.KMC_UT_BASE + 2)
KMC_UT_STATS_EXPORT_HANDLER_MISSING =(ErrGrp.KMC_UT_BASE + 3)
KMC_UT_STATS_NOTHING_TO_PURGE =(ErrGrp.KMC_UT_BASE + 4)
KMC_UT_STATS_INIT_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 5)
KMC_UT_STATS_PURGE_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 6)
KMC_UT_STATS_EXPORT_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 7)
KMC_UT_STATS_RECORD_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 8)
KMC_UT_STATS_WRITING_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 9)
KMC_UT_STATS_ALREADY_RECORDING =(ErrGrp.KMC_UT_BASE + 10)
KMC_UT_STATS_ALREADY_EXPORTING =(ErrGrp.KMC_UT_BASE + 11)
KMC_UT_STATS_ALREADY_WRITING =(ErrGrp.KMC_UT_BASE + 12)
KMC_UT_STATS_UNINITIALIZED =(ErrGrp.KMC_UT_BASE + 13)
KMC_UT_STATS_STATE_BUSY =(ErrGrp.KMC_UT_BASE + 14)
KMC_UT_STATS_INVALID_STATE_TRANSITION =(ErrGrp.KMC_UT_BASE + 15)
KMC_UT_STATS_RECORD_AND_WRITING_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 22)
KMC_UT_STATS_EVENT_THROTTLED =(ErrGrp.KMC_UT_BASE + 23)
KMC_UT_STATS_NOTHING_TO_EXPORT =(ErrGrp.KMC_UT_BASE + 24)
KMC_UT_STATS_INVALID_JSON =(ErrGrp.KMC_UT_BASE + 25)
KMC_UT_STATS_RECORDING_NOT_ON =(ErrGrp.KMC_UT_BASE + 26)
KMC_UT_STATS_DATASTORE_OUT_OF_DATE =(ErrGrp.KMC_UT_BASE + 27)
KMC_UT_STATS_DATASTORE_UPGRADE_FAILED =(ErrGrp.KMC_UT_BASE + 28)
KMC_UT_STATS_DATASTORE_NO_UPGRADE_PATH =(ErrGrp.KMC_UT_BASE + 29)
KMC_UT_STATS_DATASTORE_UPGRADE_NOT_NEEDED =(ErrGrp.KMC_UT_BASE + 30)
KMC_UT_STATS_DATASTORE_UPGRADE_WRONG_STATE =(ErrGrp.KMC_UT_BASE + 31)
KMC_UT_STATS_DATASTORE_UPGRADE_MISSING_FILE =(ErrGrp.KMC_UT_BASE + 32)
KMC_UT_STATS_LOG_SESSION_EVENT_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 33)
KMC_UT_STATS_DEVICE_ID_MISSING =(ErrGrp.KMC_UT_BASE + 34)
KMC_UT_STATS_NO_SESSION_BEGUN =(ErrGrp.KMC_UT_BASE + 36)
KMC_UT_STATS_BEGIN_SESSION_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 37)
KMC_UT_STATS_SESSION_ALREADY_BEGUN =(ErrGrp.KMC_UT_BASE + 38)
KMC_UT_STATS_END_SESSION_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 39)
KMC_UT_LICENSE_IMAGE_PROCESSING =(ErrGrp.KMC_UT_BASE + 40)
KMC_UT_LICENSE_IMAGE_CAPTURE =(ErrGrp.KMC_UT_BASE + 41)
KMC_UT_LICENSE_BARCODE_CAPTURE =(ErrGrp.KMC_UT_BASE + 42)
KMC_UT_LICENSE_LOGISTICS =(ErrGrp.KMC_UT_BASE + 43)
KMC_UT_LICENSE_ID_EXTRACTION =(ErrGrp.KMC_UT_BASE + 44)
KMC_UT_LICENSING_NULL_LICENSE_TYPE =(ErrGrp.KMC_UT_BASE + 45)
KMC_UT_LICENSING_FEATURE_NOT_LICENSED =(ErrGrp.KMC_UT_BASE + 46)
KMC_UT_LICENSING_NOT_VOLUME_LICENSE =(ErrGrp.KMC_UT_BASE + 47)
KMC_UT_LICENSING_NULL_LICENSE_SERVER =(ErrGrp.KMC_UT_BASE + 48)
KMC_UT_LICENSING_NETWORK_EXCEPTION =(ErrGrp.KMC_UT_BASE + 49)
KMC_UT_LICENSING_INVALID_SERVER_RESPONSE =(ErrGrp.KMC_UT_BASE + 50)
KMC_UT_LICENSING_NULL_LICENSE_SERVER_TYPE =(ErrGrp.KMC_UT_BASE + 51)
KMC_UT_OUT_OF_VOLUME_LICENSE =(ErrGrp.KMC_UT_BASE + 52)
KMC_UT_GOOGLE_PLAY_SERVICES_REPAIRABLE =(ErrGrp.KMC_UT_BASE + 53)
KMC_BC_UNKNOWN =(ErrGrp.KMC_BC_BASE + 2)
KMC_BC_IMAGE_BUFFERED =(ErrGrp.KMC_BC_BASE + 4)
KMC_BC_NO_REPRESENTATION =(ErrGrp.KMC_BC_BASE + 7)
KMC_BC_INVALID_IMAGE =(ErrGrp.KMC_BC_BASE + 8)
KMC_BC_BUSY =(ErrGrp.KMC_BC_BASE + 9)
KMC_BC_NO_BARCODE_FOUND =(ErrGrp.KMC_BC_BASE + 10)
KMC_BC_UNSUPPORTED_REGION =(ErrGrp.KMC_BC_BASE + 11)
KMC_OCR_INVALID_BITMAP_SIZE =(ErrGrp.KMC_OCR_BASE + 1)
KMC_OCR_ID_REGION_NOT_SET =(ErrGrp.KMC_OCR_BASE + 2)

Detailed Description

The ErrorInfo enum can be used by application developers to lookup error information.

Kofax Mobile SDK returns an ErrorInfo enum type for various methods and listener callbacks. The ErrorInfo enum provides methods for retrieving the error code, error message, and detailed error description for each error condition, which may include possible causes and suggested remedies.

Each ErroInfo enum value is based off of a starting error code number specific to a particular category or group of errors, such as Logistics component errors, or Image Processing errors.

KMC_GN_BASE = 0x1000 (4096)  // General Errors
KMC_UI_BASE = 0x2000 (8192)  // Custom UI Control Errors
KMC_LO_BASE = 0x3000 (12288) // Logistic Errors
KMC_CD_BASE = 0x4000 (16384) // Capture Data Errors
KMC_IP_BASE = 0x5000 (20480) // Image Processing Errors
KMC_ED_BASE = 0x6000 (24576) // Engine Data Errors
KMC_BC_BASE = 0xB000 (45056) // Bar Code Engine Errors
KMC_CL_BASE = 0xC000 (49152) // Classification Errors
KMC_EV_BASE = 0xE000 (57344) // EVRS (Image processor) Library Errors
KMC_UT_BASE = 0xF000 (61440) // Utilities Errors

Constructor & Destructor Documentation

ErrorInfo ( int errCode )

Member Function Documentation

int getErr ( )

The getErr method returns the numeric error code for a given error condition.

String getErrCause ( )
String getErrDesc ( )

The getErrDesc method returns the detailed description and/or cause for a given error condition.

String getErrMsg ( )

The getErrMsg method returns the short error description for a given error condition.

void setErrCause ( String errorCause )

Member Data Documentation

KMC_BC_BUSY =(ErrGrp.KMC_BC_BASE + 9)
KMC_BC_IMAGE_BUFFERED =(ErrGrp.KMC_BC_BASE + 4)
KMC_BC_INVALID_IMAGE =(ErrGrp.KMC_BC_BASE + 8)
KMC_BC_NO_BARCODE_FOUND =(ErrGrp.KMC_BC_BASE + 10)
KMC_BC_NO_REPRESENTATION =(ErrGrp.KMC_BC_BASE + 7)
KMC_BC_UNKNOWN =(ErrGrp.KMC_BC_BASE + 2)
KMC_BC_UNSUPPORTED_REGION =(ErrGrp.KMC_BC_BASE + 11)
KMC_CL_CLASSIFICATION_CONFIDENCE_LOW =(ErrGrp.KMC_CL_BASE + 11)
KMC_CL_CLASSIFIER_BUSY =(ErrGrp.KMC_CL_BASE + 7)
KMC_CL_CLASSIFIER_NOT_INITIALIZED =(ErrGrp.KMC_CL_BASE + 8)
KMC_CL_CONFIG_NOT_LOADED =(ErrGrp.KMC_CL_BASE + 2)
KMC_CL_CONFIG_NULL =(ErrGrp.KMC_CL_BASE + 1)
KMC_CL_ENCRYPTED_BARCODE_STRING =(ErrGrp.KMC_CL_BASE + 13)
KMC_CL_ID_CLASS_NOT_SUPPORTED =(ErrGrp.KMC_CL_BASE + 14)
KMC_CL_INVALID_BARCODE_STRING =(ErrGrp.KMC_CL_BASE + 12)
KMC_CL_INVALID_IMAGE_SUPPLIED =(ErrGrp.KMC_CL_BASE + 9)
KMC_CL_LISTENER_NULL =(ErrGrp.KMC_CL_BASE + 5)
KMC_CL_MAX_NUM_RESULTS_INVALID =(ErrGrp.KMC_CL_BASE + 6)
KMC_CL_MODEL_NOT_LOADED =(ErrGrp.KMC_CL_BASE + 4)
KMC_CL_MODEL_NULL =(ErrGrp.KMC_CL_BASE + 3)
KMC_CL_NO_IMAGE_SUPPLIED =(ErrGrp.KMC_CL_BASE + 10)
KMC_ED_ALREADY_BUFFERED =(ErrGrp.KMC_ED_BASE + 46)
KMC_ED_ALREADY_CLEAR =(ErrGrp.KMC_ED_BASE + 21)
KMC_ED_ALTERNATE_FILEIO_ENGINE =(ErrGrp.KMC_ED_BASE + 22)
KMC_ED_BITMAP_DIMENSIONS_IMMUTABLE =(ErrGrp.KMC_ED_BASE + 36)
KMC_ED_BITMAP_DIMENSIONS_NO_UPSCALE =(ErrGrp.KMC_ED_BASE + 37)
KMC_ED_BITMAP_READ_FROM_FILE_FAILED =(ErrGrp.KMC_ED_BASE + 23)
KMC_ED_BITMAP_WRITE_TO_FILE_FAILED =(ErrGrp.KMC_ED_BASE + 19)
KMC_ED_BUFFER =(ErrGrp.KMC_ED_BASE + 43)
KMC_ED_BUFFER_ALREADY_CLEARED =(ErrGrp.KMC_ED_BASE + 44)
KMC_ED_BUFFER_EXISTS =(ErrGrp.KMC_ED_BASE + 42)
KMC_ED_BUFFERED_READ_FAILED =(ErrGrp.KMC_ED_BASE + 49)
KMC_ED_DELETE_BUFFERED_FILE =(ErrGrp.KMC_ED_BASE + 47)
KMC_ED_FILE_EXISTS =(ErrGrp.KMC_ED_BASE + 12)
KMC_ED_FILE_NOT_DELETABLE =(ErrGrp.KMC_ED_BASE + 7)
KMC_ED_FILE_RESTRICTION_BITDEPTH =(ErrGrp.KMC_ED_BASE + 55)
KMC_ED_FILE_RESTRICTION_DPI =(ErrGrp.KMC_ED_BASE + 56)
KMC_ED_FILE_RESTRICTION_MIMETYPE =(ErrGrp.KMC_ED_BASE + 54)
KMC_ED_FILE_STILL_REMAINS =(ErrGrp.KMC_ED_BASE + 8)
KMC_ED_FILEPATH =(ErrGrp.KMC_ED_BASE + 1)
KMC_ED_IMAGE_FILE_DIMENSIONS_ERROR =(ErrGrp.KMC_ED_BASE + 38)
KMC_ED_IMAGE_INVALID_SCALING_FACTOR =(ErrGrp.KMC_ED_BASE + 39)
KMC_ED_IMAGE_IS_SCALED =(ErrGrp.KMC_ED_BASE + 13)
KMC_ED_IMAGE_PERFECTION_PROFILE_EMPTY =(ErrGrp.KMC_ED_BASE + 40)
KMC_ED_IMAGE_WRITTEN_IS_NOT_BITONAL =(ErrGrp.KMC_ED_BASE + 32)
KMC_ED_IMAGE_WRITTEN_IS_NOT_GRAY =(ErrGrp.KMC_ED_BASE + 33)
KMC_ED_IMAGELEAK =(ErrGrp.KMC_ED_BASE + 4)
KMC_ED_INVALID_DOCUMENT_DIMENSIONS =(ErrGrp.KMC_ED_BASE + 57)
KMC_ED_INVALID_DPI =(ErrGrp.KMC_ED_BASE + 20)
KMC_ED_INVALID_FOR_OBJECT_REP =(ErrGrp.KMC_ED_BASE + 51)
KMC_ED_INVALID_ISO_DATE_TIME_FORMAT =(ErrGrp.KMC_ED_BASE + 17)
KMC_ED_INVALID_JPEG_QUALITY_VALUE =(ErrGrp.KMC_ED_BASE + 18)
KMC_ED_JPEG_BITDEPTH =(ErrGrp.KMC_ED_BASE + 11)
KMC_ED_MIMETYPE =(ErrGrp.KMC_ED_BASE + 2)
KMC_ED_MIMETYPE_MISMATCH =(ErrGrp.KMC_ED_BASE + 10)
KMC_ED_NO_BUFFERED_IMAGE =(ErrGrp.KMC_ED_BASE + 50)
KMC_ED_NO_MEMORY_FOR_BUFFERED_FILE =(ErrGrp.KMC_ED_BASE + 48)
KMC_ED_NOIMAGE =(ErrGrp.KMC_ED_BASE + 3)
KMC_ED_NONEXISTENT_FILE =(ErrGrp.KMC_ED_BASE + 6)
KMC_ED_NONEXISTENT_LOAD_SETTINGS_FILE =(ErrGrp.KMC_ED_BASE + 52)
KMC_ED_NONEXISTENT_OCR_REGION_TYPE =(ErrGrp.KMC_ED_BASE + 53)
KMC_ED_OBJECT_REP_BITMAP_MISMATCH =(ErrGrp.KMC_ED_BASE + 14)
KMC_ED_OBJECT_REP_FILE_MISMATCH =(ErrGrp.KMC_ED_BASE + 15)
KMC_ED_OBJECT_REP_MISMATCH =(ErrGrp.KMC_ED_BASE + 45)
KMC_ED_OBJECT_REP_NO_BITMAP =(ErrGrp.KMC_ED_BASE + 41)
KMC_ED_UNRECOGNIZED_MIME_TYPE =(ErrGrp.KMC_ED_BASE + 35)
KMC_EV_APPEND_ENCRYPTED =(ErrGrp.KMC_EV_BASE + 18)
KMC_EV_APPEND_TO_FILE =(ErrGrp.KMC_EV_BASE + 15)
KMC_EV_BAD_CHANNEL =(ErrGrp.KMC_EV_BASE + 6)
KMC_EV_BAD_DPI =(ErrGrp.KMC_EV_BASE + 3)
KMC_EV_BAD_FILE_FORMAT =(ErrGrp.KMC_EV_BASE + 14)
KMC_EV_BAD_LINEWIDTH =(ErrGrp.KMC_EV_BASE + 5)
KMC_EV_BAD_WIDTH_HEIGHT =(ErrGrp.KMC_EV_BASE + 4)
KMC_EV_BARCODE_DRIVER =(ErrGrp.KMC_EV_BASE + 29)
KMC_EV_CANCEL_OPERATION_SUCCESS =(ErrGrp.KMC_EV_BASE + 42)
KMC_EV_CANNOT_APPEND =(ErrGrp.KMC_EV_BASE + 16)
KMC_EV_EXTERNAL_PAGE =(ErrGrp.KMC_EV_BASE + 24)
KMC_EV_FILE_IO_ACCESS_BUSY =(ErrGrp.KMC_EV_BASE + 33)
KMC_EV_FILE_METADATA =(ErrGrp.KMC_EV_BASE + 22)
KMC_EV_FILE_READ_FAILED =(ErrGrp.KMC_EV_BASE + 8)
KMC_EV_FILEOPEN =(ErrGrp.KMC_EV_BASE + 2)
KMC_EV_HISTOGRAM =(ErrGrp.KMC_EV_BASE + 26)
KMC_EV_IMAGE_PARM =(ErrGrp.KMC_EV_BASE + 9)
KMC_EV_IMAGE_PROCESSING =(ErrGrp.KMC_EV_BASE + 10)
KMC_EV_IMAGE_WRITE_FAILED =(ErrGrp.KMC_EV_BASE + 11)
KMC_EV_INVALID_HANDLE =(ErrGrp.KMC_EV_BASE + 23)
KMC_EV_INVALID_POINTER =(ErrGrp.KMC_EV_BASE + 27)
KMC_EV_LICENSE_ALREADY_SET =(ErrGrp.KMC_EV_BASE + 41)
KMC_EV_LICENSE_EXPIRED =(ErrGrp.KMC_EV_BASE + 31)
KMC_EV_LICENSING =(ErrGrp.KMC_EV_BASE + 30)
KMC_EV_LOCK_CREATION_ERROR =(ErrGrp.KMC_EV_BASE + 32)
KMC_EV_MEMORY =(ErrGrp.KMC_EV_BASE + 1)
KMC_EV_METADATA_OVERFLOW =(ErrGrp.KMC_EV_BASE + 7)
KMC_EV_NETWORK_READ =(ErrGrp.KMC_EV_BASE + 21)
KMC_EV_NONEXISTANT_IMAGE =(ErrGrp.KMC_EV_BASE + 13)
KMC_EV_OP_STRING_ERROR =(ErrGrp.KMC_EV_BASE + 44)
KMC_EV_PDF_BAD =(ErrGrp.KMC_EV_BASE + 17)
KMC_EV_PDF_TOO_LARGE =(ErrGrp.KMC_EV_BASE + 19)
KMC_EV_PROCESS_PAGE_BUSY =(ErrGrp.KMC_EV_BASE + 34)
KMC_EV_SPEED_ACCURACY =(ErrGrp.KMC_EV_BASE + 20)
KMC_EV_UNKNOWN_FILETYPE =(ErrGrp.KMC_EV_BASE + 12)
KMC_EV_UNKNOWN_VARIANT =(ErrGrp.KMC_EV_BASE + 43)
KMC_EV_UNSUPPORTED_BITMAP_FORMAT =(ErrGrp.KMC_EV_BASE + 45)
KMC_EX_PASSPORT_MRZ_DATA_NOT_FOUND =(ErrGrp.KMC_EX_BASE + 1)
KMC_GN_BAD_APPLICATION_CONTEXT =(ErrGrp.KMC_GN_BASE + 6)
KMC_GN_DESERIALIZE_OBJECT_ERROR =(ErrGrp.KMC_GN_BASE + 8)
KMC_GN_DESERIALIZE_VERSION_ERROR =(ErrGrp.KMC_GN_BASE + 7)
KMC_GN_FILE_NOT_FOUND =(ErrGrp.KMC_GN_BASE + 1)
KMC_GN_FILE_NOT_FOUND_EXCEPTION =(ErrGrp.KMC_GN_BASE + 16)
KMC_GN_ILLEGAL_ARGUMENT_EXCEPTION =(ErrGrp.KMC_GN_BASE + 13)
KMC_GN_ILLEGAL_THREAD_STATE_EXCEPTION =(ErrGrp.KMC_GN_BASE + 15)
KMC_GN_INTERNAL_ERROR =(ErrGrp.KMC_GN_BASE + 14)
KMC_GN_IO_EXCEPTION =(ErrGrp.KMC_GN_BASE + 12)
KMC_GN_LOGIN_NOT_APPLICABLE =(ErrGrp.KMC_GN_BASE + 17)
KMC_GN_NULL_POINTER_EXCEPTION =(ErrGrp.KMC_GN_BASE + 11)
KMC_GN_OUT_OF_MEMORY =(ErrGrp.KMC_GN_BASE + 2)
KMC_GN_PARAM_NEGATIVE =(ErrGrp.KMC_GN_BASE + 4)
KMC_GN_SESSION_CREATE_ERROR =(ErrGrp.KMC_GN_BASE + 9)
KMC_GN_SESSION_DISMISS_ERROR =(ErrGrp.KMC_GN_BASE + 10)
KMC_GN_UNKNOWN_ERROR =(ErrGrp.KMC_GN_BASE + 3)
KMC_GN_UNSUPPORTED_OPERATION =(ErrGrp.KMC_GN_BASE + 5)
KMC_IP_FILE_AND_BUFFERED_REPRESENTATION =(ErrGrp.KMC_IP_BASE + 9)
KMC_IP_LICENSE_ALREADY_SET =(ErrGrp.KMC_IP_BASE + 6)
KMC_IP_LICENSE_EXPIRED =(ErrGrp.KMC_IP_BASE + 5)
KMC_IP_LICENSE_INVALID =(ErrGrp.KMC_IP_BASE + 4)
KMC_IP_NO_CONFIGURATION =(ErrGrp.KMC_IP_BASE + 10)
KMC_IP_NO_PROFILE =(ErrGrp.KMC_IP_BASE + 1)
KMC_IP_NO_REPRESENTATION =(ErrGrp.KMC_IP_BASE + 2)
KMC_LO_DEVICE_REG_LICENSING_ERROR =(ErrGrp.KMC_LO_BASE + 9)
KMC_LO_DOMAIN =(ErrGrp.KMC_LO_BASE+14)
KMC_LO_DOWNLOAD_DOCUMENT_FIELDS_ERROR =(ErrGrp.KMC_LO_BASE + 28)
KMC_LO_DOWNLOAD_DOCUMENT_SCAN_SETTINGS_ERROR =(ErrGrp.KMC_LO_BASE + 44)
KMC_LO_EMAIL =(ErrGrp.KMC_LO_BASE+15)
KMC_LO_EVENT_LOCK_ACQUIRE_ERROR =(ErrGrp.KMC_LO_BASE + 45)
KMC_LO_IMAGE_NOT_FOUND =(ErrGrp.KMC_LO_BASE+13)
KMC_LO_INVALID_CERTIFICATE =(ErrGrp.KMC_LO_BASE + 51)
KMC_LO_INVALID_DOCUMENT_TYPE_NAME =(ErrGrp.KMC_LO_BASE + 27)
KMC_LO_INVALID_SERVER_URL =(ErrGrp.KMC_LO_BASE + 1)
KMC_LO_INVALID_SESSION_STATE =(ErrGrp.KMC_LO_BASE + 19)
KMC_LO_INVALID_SESSION_STATE_TRANSITION =(ErrGrp.KMC_LO_BASE+42)
KMC_LO_LOGIN_NOT_ALLOWED =(ErrGrp.KMC_LO_BASE + 20)
KMC_LO_NO_OPERATION_TO_CANCEL =(ErrGrp.KMC_LO_BASE + 24)
KMC_LO_NOT_LOGGED_IN =(ErrGrp.KMC_LO_BASE + 21)
KMC_LO_NOT_REGISTERED =(ErrGrp.KMC_LO_BASE + 16)
KMC_LO_OPERATION_CANCEL_ERROR =(ErrGrp.KMC_LO_BASE+41)
KMC_LO_OPERATION_CANCELLED =(ErrGrp.KMC_LO_BASE + 26)
KMC_LO_OPERATION_NOT_CANCELLABLE =(ErrGrp.KMC_LO_BASE + 25)
KMC_LO_OVERLAPPED_OPERATIONS =(ErrGrp.KMC_LO_BASE + 18)
KMC_LO_PAGE_IMAGE_INDEX_INVALID =(ErrGrp.KMC_LO_BASE+37)
KMC_LO_PAGE_NOT_FOUND =(ErrGrp.KMC_LO_BASE+12)
KMC_LO_REGISTER_REQUIRES_AUTH =(ErrGrp.KMC_LO_BASE + 50)
KMC_LO_REGISTERING =(ErrGrp.KMC_LO_BASE + 17)
KMC_LO_REGISTERING_NOT_ALLOWED =(ErrGrp.KMC_LO_BASE+43)
KMC_LO_REQUEST_TIMEOUT =(ErrGrp.KMC_LO_BASE + 48)
KMC_LO_SERVER_TIMEOUT =(ErrGrp.KMC_LO_BASE + 49)
KMC_LO_SERVER_URL_NOT_SET =(ErrGrp.KMC_LO_BASE + 2)
KMC_LO_SESSION_STATE_BUSY =(ErrGrp.KMC_LO_BASE + 10)
KMC_LO_START_SUBMIT_INVALID_JOB_ID =(ErrGrp.KMC_LO_BASE + 33)
KMC_LO_START_SUBMIT_JOB_ERROR =(ErrGrp.KMC_LO_BASE + 31)
KMC_LO_SUBMIT_BITMAP =(ErrGrp.KMC_LO_BASE + 30)
KMC_LO_SUBMIT_DOCUMENT_FILE_CLOSE_ERROR =(ErrGrp.KMC_LO_BASE+35)
KMC_LO_SUBMIT_DOCUMENT_FILEIO_ERROR =(ErrGrp.KMC_LO_BASE+34)
KMC_LO_SUBMIT_DOCUMENT_IMAGE_FILE_MISSING =(ErrGrp.KMC_LO_BASE+40)
KMC_LO_SUBMIT_DOCUMENT_IMAGE_REP_ERROR =(ErrGrp.KMC_LO_BASE+39)
KMC_LO_SUBMIT_DOCUMENT_IMAGES_ERROR =(ErrGrp.KMC_LO_BASE + 32)
KMC_LO_SUBMIT_DOCUMENT_MIMETYPE_ERROR =(ErrGrp.KMC_LO_BASE+38)
KMC_LO_SUBMIT_DOCUMENT_NO_IMAGE_ERROR =(ErrGrp.KMC_LO_BASE+36)
KMC_LO_SUBMIT_PNG =(ErrGrp.KMC_LO_BASE + 29)
KMC_LO_TASK_LOCK_ACQUIRE_ERROR =(ErrGrp.KMC_LO_BASE + 23)
KMC_LO_USER_ALREADY_LOGGED_IN =(ErrGrp.KMC_LO_BASE + 4)
KMC_LO_USER_ALREADY_LOGGED_OUT =(ErrGrp.KMC_LO_BASE + 7)
KMC_LO_USER_LOGGING_IN_ON_LOGIN =(ErrGrp.KMC_LO_BASE + 6)
KMC_LO_USER_LOGGING_OUT_ON_LOGOUT =(ErrGrp.KMC_LO_BASE + 8)
KMC_LO_USER_LOGIN_ERROR =(ErrGrp.KMC_LO_BASE + 11)
KMC_LO_USER_LOGOUT_ERROR =(ErrGrp.KMC_LO_BASE + 22)
KMC_LO_USER_NOT_LOGGED_IN_ON_LOGOUT =(ErrGrp.KMC_LO_BASE + 5)
KMC_LO_USERNAME_NOT_SET =(ErrGrp.KMC_LO_BASE + 3)
KMC_OCR_ID_REGION_NOT_SET =(ErrGrp.KMC_OCR_BASE + 2)
KMC_OCR_INVALID_BITMAP_SIZE =(ErrGrp.KMC_OCR_BASE + 1)
KMC_SUCCESS =(0)
KMC_UI_CAMERA_ALREADY_OPEN =(ErrGrp.KMC_UI_BASE + 9)
KMC_UI_CAMERA_LOCK_ACQUIRE_FAILURE =(ErrGrp.KMC_UI_BASE + 11)
KMC_UI_CAMERA_OPERATION_FAILURE =(ErrGrp.KMC_UI_BASE + 10)
KMC_UI_CREDITCARD_ARCH_NOT_SUPPORTED =(ErrGrp.KMC_UI_BASE + 25)
KMC_UI_FLASH_AUTO_NOT_SUPPORTED =(ErrGrp.KMC_UI_BASE + 1)
KMC_UI_FLASH_OFF_NOT_SUPPORTED =(ErrGrp.KMC_UI_BASE + 3)
KMC_UI_FLASH_ON_NOT_SUPPORTED =(ErrGrp.KMC_UI_BASE + 2)
KMC_UI_FLASH_TORCH_NOT_SUPPORTED =(ErrGrp.KMC_UI_BASE + 17)
KMC_UI_FOCUS_AREA_COUNT =(ErrGrp.KMC_UI_BASE + 15)
KMC_UI_FOCUS_AREA_EMPTY =(ErrGrp.KMC_UI_BASE + 16)
KMC_UI_FOCUS_AREA_INVALID =(ErrGrp.KMC_UI_BASE + 23)
KMC_UI_FOCUS_AREA_NOT_SUPPORTED =(ErrGrp.KMC_UI_BASE + 14)
KMC_UI_IMAGE_NULL =(ErrGrp.KMC_UI_BASE + 8)
KMC_UI_INVALID_ASPECT_RATIO_ARGUMENT =(ErrGrp.KMC_UI_BASE + 19)
KMC_UI_INVALID_AXIS_THRESHOLD_ARGUMENT =(ErrGrp.KMC_UI_BASE + 12)
KMC_UI_INVALID_BORDER_THICKNESS_ARGUMENT =(ErrGrp.KMC_UI_BASE + 20)
KMC_UI_INVALID_DECLINATION_ARGUMENT =(ErrGrp.KMC_UI_BASE + 6)
KMC_UI_INVALID_HEIGHT_ARGUMENT =(ErrGrp.KMC_UI_BASE + 22)
KMC_UI_INVALID_PADDING_PERCENTAGE_ARGUMENT =(ErrGrp.KMC_UI_BASE + 18)
KMC_UI_INVALID_PAGE_THRESHOLD_ARGUMENT =(ErrGrp.KMC_UI_BASE + 13)
KMC_UI_INVALID_STABILITY_DELAY_ARGUMENT =(ErrGrp.KMC_UI_BASE + 7)
KMC_UI_INVALID_THRESHOLD_ARGUMENT =(ErrGrp.KMC_UI_BASE + 5)
KMC_UI_INVALID_WIDTH_ARGUMENT =(ErrGrp.KMC_UI_BASE + 21)
KMC_UI_ODE_NOT_SUPPORTED_FOR_THE_DOCUMENT_TYPE =(ErrGrp.KMC_UI_BASE + 26)
KMC_UI_SCALING_FACTOR =(ErrGrp.KMC_UI_BASE + 4)
KMC_UI_VIEW_NULL =(ErrGrp.KMC_UI_BASE + 24)
KMC_UT_GOOGLE_PLAY_SERVICES_REPAIRABLE =(ErrGrp.KMC_UT_BASE + 53)
KMC_UT_LICENSE_BARCODE_CAPTURE =(ErrGrp.KMC_UT_BASE + 42)
KMC_UT_LICENSE_ID_EXTRACTION =(ErrGrp.KMC_UT_BASE + 44)
KMC_UT_LICENSE_IMAGE_CAPTURE =(ErrGrp.KMC_UT_BASE + 41)
KMC_UT_LICENSE_IMAGE_PROCESSING =(ErrGrp.KMC_UT_BASE + 40)
KMC_UT_LICENSE_LOGISTICS =(ErrGrp.KMC_UT_BASE + 43)
KMC_UT_LICENSING_FEATURE_NOT_LICENSED =(ErrGrp.KMC_UT_BASE + 46)
KMC_UT_LICENSING_INVALID_SERVER_RESPONSE =(ErrGrp.KMC_UT_BASE + 50)
KMC_UT_LICENSING_NETWORK_EXCEPTION =(ErrGrp.KMC_UT_BASE + 49)
KMC_UT_LICENSING_NOT_VOLUME_LICENSE =(ErrGrp.KMC_UT_BASE + 47)
KMC_UT_LICENSING_NULL_LICENSE_SERVER =(ErrGrp.KMC_UT_BASE + 48)
KMC_UT_LICENSING_NULL_LICENSE_SERVER_TYPE =(ErrGrp.KMC_UT_BASE + 51)
KMC_UT_LICENSING_NULL_LICENSE_TYPE =(ErrGrp.KMC_UT_BASE + 45)
KMC_UT_OUT_OF_VOLUME_LICENSE =(ErrGrp.KMC_UT_BASE + 52)
KMC_UT_STATS_ALREADY_EXPORTING =(ErrGrp.KMC_UT_BASE + 11)
KMC_UT_STATS_ALREADY_RECORDING =(ErrGrp.KMC_UT_BASE + 10)
KMC_UT_STATS_ALREADY_WRITING =(ErrGrp.KMC_UT_BASE + 12)
KMC_UT_STATS_BEGIN_SESSION_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 37)
KMC_UT_STATS_DATASTORE_NO_UPGRADE_PATH =(ErrGrp.KMC_UT_BASE + 29)
KMC_UT_STATS_DATASTORE_OUT_OF_DATE =(ErrGrp.KMC_UT_BASE + 27)
KMC_UT_STATS_DATASTORE_UPGRADE_FAILED =(ErrGrp.KMC_UT_BASE + 28)
KMC_UT_STATS_DATASTORE_UPGRADE_MISSING_FILE =(ErrGrp.KMC_UT_BASE + 32)
KMC_UT_STATS_DATASTORE_UPGRADE_NOT_NEEDED =(ErrGrp.KMC_UT_BASE + 30)
KMC_UT_STATS_DATASTORE_UPGRADE_WRONG_STATE =(ErrGrp.KMC_UT_BASE + 31)
KMC_UT_STATS_DEVICE_ID_MISSING =(ErrGrp.KMC_UT_BASE + 34)
KMC_UT_STATS_END_SESSION_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 39)
KMC_UT_STATS_EVENT_THROTTLED =(ErrGrp.KMC_UT_BASE + 23)
KMC_UT_STATS_EXPORT_HANDLER_MISSING =(ErrGrp.KMC_UT_BASE + 3)
KMC_UT_STATS_EXPORT_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 7)
KMC_UT_STATS_FILEPATH_IS_NULL =(ErrGrp.KMC_UT_BASE + 2)
KMC_UT_STATS_INIT_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 5)
KMC_UT_STATS_INVALID_JSON =(ErrGrp.KMC_UT_BASE + 25)
KMC_UT_STATS_INVALID_STATE_TRANSITION =(ErrGrp.KMC_UT_BASE + 15)
KMC_UT_STATS_LOG_SESSION_EVENT_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 33)
KMC_UT_STATS_NO_SESSION_BEGUN =(ErrGrp.KMC_UT_BASE + 36)
KMC_UT_STATS_NOTHING_TO_EXPORT =(ErrGrp.KMC_UT_BASE + 24)
KMC_UT_STATS_NOTHING_TO_PURGE =(ErrGrp.KMC_UT_BASE + 4)
KMC_UT_STATS_PURGE_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 6)
KMC_UT_STATS_RECORD_AND_WRITING_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 22)
KMC_UT_STATS_RECORD_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 8)
KMC_UT_STATS_RECORDING_NOT_OFF =(ErrGrp.KMC_UT_BASE + 1)
KMC_UT_STATS_RECORDING_NOT_ON =(ErrGrp.KMC_UT_BASE + 26)
KMC_UT_STATS_SESSION_ALREADY_BEGUN =(ErrGrp.KMC_UT_BASE + 38)
KMC_UT_STATS_STATE_BUSY =(ErrGrp.KMC_UT_BASE + 14)
KMC_UT_STATS_UNINITIALIZED =(ErrGrp.KMC_UT_BASE + 13)
KMC_UT_STATS_WRITING_NOT_ALLOWED =(ErrGrp.KMC_UT_BASE + 9)
The documentation for this enum was generated from the following file:
  • ErrorInfo.java


Kofax Mobile SDK API Reference: KmcException Class Reference

  • kmc
  • kut
  • utilities
  • error
  • KmcException
Public Member Functions | List of all members
KmcException Class Reference

An extended Exception class that specifies KMC errors as defined by the ErrorInfo enum. More...

Inheritance diagram for KmcException:

Public Member Functions

ErrorInfo getErrorInfo ()
Returns the ErrorInfo object associated with this KMC exception. More...
KmcException (ErrorInfo errorInfo)
Constructor that takes an ErrorInfo object. More...
KmcException (ErrorInfo errorInfo, Throwable cause)
Constructor that takes an ErrorInfo object and a Throwable object, which indicates a serious configuration error. More...

Detailed Description

An extended Exception class that specifies KMC errors as defined by the ErrorInfo enum.

Constructor & Destructor Documentation

KmcException ( ErrorInfo errorInfo )

Constructor that takes an ErrorInfo object.

KmcException | ( | ErrorInfo | errorInfo,
 |  | Throwable | cause
 | ) |  |

Constructor that takes an ErrorInfo object and a Throwable object, which indicates a serious configuration error.

Member Function Documentation

ErrorInfo getErrorInfo ( )

Returns the ErrorInfo object associated with this KMC exception.

The documentation for this class was generated from the following file:
  • KmcException.java


Kofax Mobile SDK API Reference: KmcRuntimeException Class Reference

  • kmc
  • kut
  • utilities
  • error
  • KmcRuntimeException
Public Member Functions | List of all members
KmcRuntimeException Class Reference

An extended RuntimeException class that specifies KMC errors as defined by the ErrorInfo enum. More...

Inheritance diagram for KmcRuntimeException:

Public Member Functions

ErrorInfo getErrorInfo ()
Returns the ErrorInfo object associated with this KMC runtime exception. More...
KmcRuntimeException (ErrorInfo errorInfo)
Constructor that takes an ErrorInfo object. More...
KmcRuntimeException (ErrorInfo errorInfo, Throwable cause)
Constructor that takes an ErrorInfo object and a Throwable object, which indicates a serious configuration error. More...

Detailed Description

An extended RuntimeException class that specifies KMC errors as defined by the ErrorInfo enum.

Constructor & Destructor Documentation

KmcRuntimeException ( ErrorInfo errorInfo )

Constructor that takes an ErrorInfo object.

KmcRuntimeException | ( | ErrorInfo | errorInfo,
 |  | Throwable | cause
 | ) |  |

Constructor that takes an ErrorInfo object and a Throwable object, which indicates a serious configuration error.

Member Function Documentation

ErrorInfo getErrorInfo ( )

Returns the ErrorInfo object associated with this KMC runtime exception.

The documentation for this class was generated from the following file:
  • KmcRuntimeException.java


Kofax Mobile SDK API Reference: KutVersion Class Reference

  • kmc
  • kut
  • utilities
  • version
  • KutVersion
Static Public Member Functions | List of all members
KutVersion Class Reference

Static Public Member Functions

static String getPackageVersion ()

Detailed Description

This class provides a means of retrieving the version string for the utilities package of the Kofax Mobile SDK.

Member Function Documentation

static String getPackageVersion ( )
static
Returns
The version string for the utilities package of the Mobile SDK.
The documentation for this class was generated from the following file:
  • KutVersion.java


Kofax Mobile SDK API Reference: AppContextProvider Class Reference

  • kmc
  • kut
  • utilities
  • AppContextProvider
Public Member Functions | Static Public Member Functions | List of all members
AppContextProvider Class Reference

This class keeps a reference of the application context. More...

Inheritance diagram for AppContextProvider:

Public Member Functions

void onCreate ()

Static Public Member Functions

static Context | getContext ()
static void | setContext (Context context)

Detailed Description

This class keeps a reference of the application context.

This class keeps a reference of the application context. In order to use the Mobile SDK, you must first set a valid application context. Alternately, you can specify the AppContextProvider class in your application's Manifest, as the name attribute of the <application> element:

<application
android:icon="@drawable/ic_launcher"
android:name="com.kofax.kmc.kut.utilities.AppContextProvider"
android:label="@string/app_name"
android:theme="@style/AppTheme" >
</application>

Member Function Documentation

static Context getContext ( )
static

Returns the application context

Returns
application context
void onCreate ( )
static void setContext ( Context context )
static

Sets the application context

Parameters
context A valid application context.
The documentation for this class was generated from the following file:
  • AppContextProvider.java


Kofax Mobile SDK API Reference: CertificateValidatorListener Interface Reference

  • kmc
  • kut
  • utilities
  • CertificateValidatorListener
Public Member Functions | List of all members
CertificateValidatorListener Interface Reference
Inheritance diagram for CertificateValidatorListener:

Public Member Functions

SSLSocketFactory getSSLSocketFactory (String hostname)

Detailed Description

This interface defines a method that you may implement for custom certificate pinning logic.

Refer to an Android Framework documentation for more details.

See also
http://developer.android.com/intl/ru/training/articles/security-ssl.html

Implementation of this method is optional, but expected for security reason.

Member Function Documentation

SSLSocketFactory getSSLSocketFactory ( String hostname )

Requests credentials from the listener in response to an authentication request from the remote server. Responding on this client may customize Certificate Pinning logic.

Parameters
hostname - the host name
Returns
SSLSocketFactory used for custom certificate pinning logic or null for default handling.
The documentation for this interface was generated from the following file:
  • CertificateValidatorListener.java


Kofax Mobile SDK API Reference: KUTLogging Class Reference

  • kmc
  • kut
  • utilities
  • KUTLogging
Static Public Member Functions | List of all members
KUTLogging Class Reference

Static Public Member Functions

static void enableConsoleLogging (boolean enable)

Detailed Description

Enable or disable console logging for KUT package classes.

See also
Logging

Member Function Documentation

static void enableConsoleLogging ( boolean enable )
static

Enables Kut package console logging. Pass true to turn on library logging, and false otherwise. Disabled by default.

Parameters
enable
The documentation for this class was generated from the following file:
  • KUTLogging.java


Kofax Mobile SDK API Reference: Licensing Class Reference

  • kmc
  • kut
  • utilities
  • Licensing
Classes | Static Public Member Functions | List of all members
Licensing Class Reference

This class comprises the licensing mechanism for Mobile SDK. More...

Classes

enum | LicenseServerType
An enum of license server types. Use with Licensing.setMobileSDKLicenseServer. More...
enum | LicenseType
An enum of license types. More...
interface | VolumeLicenseEventListener
The listener interface for receiving volume licensing events. More...
class | VolumeLicenseFailureData
Data class for volume licensing related failures. More...
class | VolumeLicenseResultData
Data class for volume licensing related successful operations. More...

Static Public Member Functions

static int | getDaysRemaining ()
Retrieve the number of days remaining in current license. More...
static ErrorInfo | setMobileSDKLicense (String licenseStr)
Set the Mobile SDK license. More...
static ErrorInfo | setMobileSDKLicenseServer (String licenseServerName, LicenseServerType licenseServerType)
Set the Mobile SDK license server name. More...
static boolean | isSdkLicensed (LicenseType licenseType)
Find out if specified license type is valid with current license. More...
static void | acquireVolumeLicenses (LicenseType licenseType, int count)
Pre-allocate units of the specified volume license type. More...
static int | getRemainingLicenseCount (LicenseType licenseType)
Get the number of license volume units available on the device. More...
static void | addVolumeLicenseEventListener (VolumeLicenseEventListener listener)
Add the specified VolumeLicenseEventListener to receive VolumeLicenseEvents. More...
static void | removeVolumeLicenseEventListener (VolumeLicenseEventListener listener)
Removes the specified VolumeLicenseEventListener. More...
static void | setCertificateValidatorListener (CertificateValidatorListener certificateValidatorListener)

Detailed Description

This class comprises the licensing mechanism for Mobile SDK.

Call the setMobileSDKLicense method with a valid license string to get access to full Mobile SDK functionality.

Member Function Documentation

static void acquireVolumeLicenses | ( | LicenseType | licenseType,
 |  | int | count
 | ) |  |
static

Pre-allocate units of the specified volume license type.

This license operation is asynchronous and the method returns immediately. To process the license event, including any errors, implement the VolumeLicenseEventListener interface in a class object and then register that object using the addVolumeLicenseEventListener method. Once the operation is complete, remove the listener.

Parameters
licenseType | type of volume license requested, LicenseType.ID_EXTRACTION is the only type supported.
count | number of volume units requested
static void addVolumeLicenseEventListener ( VolumeLicenseEventListener listener )
static

Add the specified VolumeLicenseEventListener to receive VolumeLicenseEvents.

This method must be called to establish one or more application listeners. These listeners receive events indicating status of a volume license event.

Exceptions
NullPointerException
static int getDaysRemaining ( )
static

Retrieve the number of days remaining in current license.

Returns
The number of days remaining in the current license.
static int getRemainingLicenseCount ( LicenseType licenseType )
static

Get the number of license volume units available on the device.

This method returns the number of license volume units available on the device for the specified license type. LicenseType.ID_EXTRACTION is the only type supported. Any other license type will return 0 units available. Also, if the licenseServerHostname has not been set, this method will return 0 units available.

Parameters
licenseType type of license to check
Returns
number of license volume units available
static boolean isSdkLicensed ( LicenseType licenseType )
static

Find out if specified license type is valid with current license.

Returns an indication of whether or not the specified license type is included in the license string that was previously passed to setMobileSDKLicense. Also returns false if a license string was never set.

Returns
true or false.
static void removeVolumeLicenseEventListener ( VolumeLicenseEventListener listener )
static

Removes the specified VolumeLicenseEventListener.

static void setCertificateValidatorListener ( CertificateValidatorListener certificateValidatorListener )
static

Setter for certificate validator listener. The listener receives certificate validation challenge in response to an authentication request from the remote server.

See also
CertificateValidatorListener
Parameters
certificateValidatorListener
static ErrorInfo setMobileSDKLicense ( String licenseStr )
static

Set the Mobile SDK license.

This method sets the Mobile SDK license and populates the days remaining.

Parameters
licenseStr The license string to set.
Returns
Status code
Return values
KMC_SUCCESS
KMC_EV_LICENSING invalid license
KMC_EV_LICENSE_EXPIRED
static ErrorInfo setMobileSDKLicenseServer | ( | String | licenseServerName,
 |  | LicenseServerType | licenseServerType
 | ) |  |
static

Set the Mobile SDK license server name.

This method sets the Mobile SDK license server name and type.

Parameters
licenseServerName | license server name.
licenseServerType | license server type.
Returns
Status code (normally KMC_SUCCESS)

For RTTI servers, the server name would typically look like

http://my-server-here/mobilesdk

For TotalAgility servers, the server name would typically look like

http://my-server-here/totalagility
The documentation for this class was generated from the following file:
  • Licensing.java


Kofax Mobile SDK API Reference: Licensing.LicenseServerType Enum Reference

  • kmc
  • kut
  • utilities
  • Licensing
  • LicenseServerType
Public Attributes | List of all members
Licensing.LicenseServerType Enum Reference

An enum of license server types. Use with Licensing.setMobileSDKLicenseServer. More...

Public Attributes

RTTI
TotalAgility

Detailed Description

An enum of license server types. Use with Licensing.setMobileSDKLicenseServer.

Member Data Documentation

RTTI
TotalAgility
The documentation for this enum was generated from the following file:
  • Licensing.java


Kofax Mobile SDK API Reference: Licensing.LicenseType Enum Reference

  • kmc
  • kut
  • utilities
  • Licensing
  • LicenseType
Public Attributes | List of all members
Licensing.LicenseType Enum Reference

An enum of license types. More...

Public Attributes

IMAGE_CAPTURE
IMAGE_PROCESSING
BARCODE_CAPTURE
LOGISTICS
ID_EXTRACTION

Detailed Description

An enum of license types.

Use with Licensing.isSdkLicensed, Licensing.acquireVolumeLicenses, and Licensing.getRemainingLicenseCount.

Member Data Documentation

BARCODE_CAPTURE
ID_EXTRACTION
IMAGE_CAPTURE
IMAGE_PROCESSING
LOGISTICS
The documentation for this enum was generated from the following file:
  • Licensing.java


Kofax Mobile SDK API Reference: Licensing.VolumeLicenseEventListener Interface Reference

  • kmc
  • kut
  • utilities
  • Licensing
  • VolumeLicenseEventListener
Public Member Functions | List of all members
Licensing.VolumeLicenseEventListener Interface Reference

The listener interface for receiving volume licensing events. More...

Public Member Functions

void | licenseOperationFailed (VolumeLicenseFailureData failure)
Invoked when a volume license operation fails. More...
void | licenseOperationSucceeded (VolumeLicenseResultData results)
Invoked when a volume license operation succeeds. More...

Detailed Description

The listener interface for receiving volume licensing events.

A class that is interested in processing a volume license event should implement this interface and then register itself using the Licensing.addVolumeLicenseEventListener method. Once the operation is complete remove the listener.

Member Function Documentation

void licenseOperationFailed ( VolumeLicenseFailureData failure )

Invoked when a volume license operation fails.

void licenseOperationSucceeded ( VolumeLicenseResultData results )

Invoked when a volume license operation succeeds.

The documentation for this interface was generated from the following file:
  • Licensing.java


Kofax Mobile SDK API Reference: Licensing.VolumeLicenseFailureData Class Reference

  • kmc
  • kut
  • utilities
  • Licensing
  • VolumeLicenseFailureData
Public Attributes | List of all members
Licensing.VolumeLicenseFailureData Class Reference

Data class for volume licensing related failures. More...

Public Attributes

*ErrorInfo resultCode
Result status of the volume license operation. More...
LicenseType licenseType
Type of the volume license involved in the operation (could be null) More...

Detailed Description

Data class for volume licensing related failures.

Some possible ErrorInfo failures provided in the resultCode:

  • KMC_UT_LICENSING_NULL_LICENSE_TYPE
  • KMC_UT_LICENSING_NOT_VOLUME_LICENSE
  • KMC_UT_LICENSING_FEATURE_NOT_LICENSED
  • KMC_UT_LICENSING_NULL_LICENSE_SERVER
  • KMC_UT_LICENSING_NETWORK_EXCEPTION
  • KMC_UT_LICENSING_INVALID_SERVER_RESPONSE

Member Data Documentation

LicenseType licenseType

Type of the volume license involved in the operation (could be null)

* ErrorInfo resultCode

Result status of the volume license operation.

The documentation for this class was generated from the following file:
  • Licensing.java


Kofax Mobile SDK API Reference: Licensing.VolumeLicenseResultData Class Reference

  • kmc
  • kut
  • utilities
  • Licensing
  • VolumeLicenseResultData
Public Attributes | List of all members
Licensing.VolumeLicenseResultData Class Reference

Data class for volume licensing related successful operations. More...

Public Attributes

*ErrorInfo resultCode
Result status of the volume license operation (normally KMC_SUCCESS) More...
LicenseType licenseType
Type of the volume license involved in the operation. More...
int acquiredCount
Number of volume license units that were taken from the license server. More...

Detailed Description

Data class for volume licensing related successful operations.

Member Data Documentation

int acquiredCount

Number of volume license units that were taken from the license server.

LicenseType licenseType

Type of the volume license involved in the operation.

* ErrorInfo resultCode

Result status of the volume license operation (normally KMC_SUCCESS)

The documentation for this class was generated from the following file:
  • Licensing.java


Kofax Mobile SDK API Reference: MicrLine Class Reference

  • kmc
  • kut
  • utilities
  • MicrLine
Classes | Public Member Functions | List of all members
MicrLine Class Reference

This class represents the MICR line itself. More...

Classes

enum CheckType
An enum which identifies the type of check. More...

Public Member Functions

MicrLine ()
boolean | getValueSet ()
String | getAuxiliaryOnUs ()
void | setAuxiliaryOnUs (String auxiliaryOnUs)
String | getEPC ()
void | setEPC (String epc)
String | getTransitNumber ()
void | setTransitNumber (String transitNumber)
String | getOnUs ()
Returns the On-Us field. More...
void | setOnUs (String onUs)
String | getOnUs1 ()
void | setOnUs1 (String onUs1)
String | getOnUs2 ()
void | setOnUs2 (String onUs2)
String | getAmount ()
void | setAmount (String amount)
void | setCheckType (CheckType checkType)
CheckType getCheckType ()

Detailed Description

This class represents the MICR line itself.

This class contains the following raw properties of the MICR line: AuxiliaryOnUs " When this field is present (it is usually only present on business checks) it usually contains the check number. EPC - This field is used for "specific purposes" and cannot be used without written authorization from the ASC X9B. RoutingNumber - officially this field is called the transit field, but it is only used for the routing number On-Us1, On-Us2 - The On-Us field is actually two fields in one that are separated by an On-Us symbol. The numbers to the left of the On-Us symbol (what we are calling On-Us1) contains the Account Number, the value to the right of the On-Us symbol (what we are calling On-Us2) is for "special bank use". In a personal check, the value to the right of On-Us contains the Check Number Amount - If present, this field typically contains the amount of the check.

Constructor & Destructor Documentation

MicrLine ( )

Member Function Documentation

String getAmount ( )

The amount field contains the check amount. This is generally not present unless the check has been processed by a bank. This property is empty if the field is not present.

Returns
String.
String getAuxiliaryOnUs ( )

AuxiliaryOnUs contains the contents of the Auxiliary On-Us field in the MICR. It usually contains the check number. It is generally not present on personal checks. This property is empty if this field is not present.

Returns
String.
CheckType getCheckType ( )

Returns the check type - personal or business.

Returns
CheckType
String getEPC ( )

EPC contains the contents of the External Processing Code. It is a one character field, and is usually not present in the MICR. This property is empty if the field is not present.

Returns
String.
String getOnUs ( )

Returns the On-Us field.

Returns
the On-Us field
See also
getOnUs1()
getOnUs2()
String getOnUs1 ( )

OnUS1 contains the contents of the first portion of the On-Us field in the MICR. It generally contains the account number.

Returns
String.
String getOnUs2 ( )

OnUS2 contains the contents of the second portion of the On-Us MICR field. If present, it contains the check number. This property is empty if the field is not present.

Returns
String.
String getTransitNumber ( )

Officially this field is called the transit field, but it is only used for the routing number. This field must be present in the MICR.

Returns
String.
boolean getValueSet ( )

At least one value has been set in the object.

Returns
void setAmount ( String amount )

Setter for the Amount property.

Parameters
amount
void setAuxiliaryOnUs ( String auxiliaryOnUs )

Setter for the AuxiliaryOnUs property.

Parameters
auxiliaryOnUs
void setCheckType ( CheckType checkType )

Setter for CheckType property.

Parameters
checkType
void setEPC ( String epc )

Setter for the EPC property.

Parameters
epc
void setOnUs ( String onUs )

Setter for the On-Us field.

Parameters
onUs the On-Us field
See also
setOnUs1(String)
setOnUs2(String)
void setOnUs1 ( String onUs1 )

Setter for the OnUs1 property.

Parameters
onUs1
void setOnUs2 ( String onUs2 )

Setter for the OnUs2 property.

Parameters
onUs2
void setTransitNumber ( String transitNumber )

Setter for the transit number property.

Parameters
transitNumber
The documentation for this class was generated from the following file:
  • MicrLine.java


Kofax Mobile SDK API Reference: MicrLine.CheckType Enum Reference

  • kmc
  • kut
  • utilities
  • MicrLine
  • CheckType
Public Attributes | List of all members
MicrLine.CheckType Enum Reference

An enum which identifies the type of check. More...

Public Attributes

NONE
PERSONAL_CHECK
BUSINESS_CHECK

Detailed Description

An enum which identifies the type of check.

Member Data Documentation

BUSINESS_CHECK
NONE
PERSONAL_CHECK
The documentation for this enum was generated from the following file:
  • MicrLine.java


Kofax Mobile SDK API Reference: MicrParser Class Reference

  • kmc
  • kut
  • utilities
  • MicrParser
Classes | Public Member Functions | List of all members
MicrParser Class Reference

This class parses the MICR data line from different check detection algorithms. More...

Public Member Functions

MicrParser (String micr)
The MicrParser class constructor with parameter. More...
MicrParser ()
The MicrParser class default constructor. More...
boolean | ParseMicr (String micrData) throws NullPointerException
Given the provided MICR data, parse into standard MICR fields. More...
boolean | isMicrValid ()
MicrLine getMicrLine ()
String | getAccountNumber ()
String | getTransitNumber ()
String | getCheckNumber ()

Detailed Description

This class parses the MICR data line from different check detection algorithms.

This class provides a means of retrieving the raw properties of the provided MICR data line. These properties are:

  • AuxiliaryOnUs
  • EPC
  • RoutingNumber
  • On-Us1, On-Us2
  • Amount

Constructor & Destructor Documentation

MicrParser ( String micr )

The MicrParser class constructor with parameter.

This constructor takes a String parameter that gets passed to the ParseMicr method.

Parameters
micr
MicrParser ( )

The MicrParser class default constructor.

This is the default constructor for the MicrParser class. It creates a new MicrLine object.

Member Function Documentation

String getAccountNumber ( )

Returns the account number from the parsed MICR string.

Returns
String
String getCheckNumber ( )

Returns the check number from the parsed MICR string. The source of the check number depends on the check type, either personal or business.

Returns
String
MicrLine getMicrLine ( )

Returns the associated MicrLine object containing the component MICR fields.

Returns
MicrLine
String getTransitNumber ( )

Returns the transit number from the parsed MICR string.

Returns
String
boolean isMicrValid ( )

Returns a flag indicating the provided MICR string was valid.

Returns
boolean
boolean ParseMicr ( String micrData ) throws NullPointerException

Given the provided MICR data, parse into standard MICR fields.

This is the main method of the MicrParser object. It parses the given micrData string into the component MICR fields: auxiliaryOnUs When present (usually on business check), the check number. epc Special purpose value. transitNumber Transit field used for routing number. onUs1 Account number. onUs2 Special bank use; on a personal check, the check number. amount If present, the check amount.

Parameters
micrData
Returns
boolean
Exceptions
NullPointerException (micrData parameter is null).
The documentation for this class was generated from the following file:
  • MicrParser.java


Kofax Mobile SDK API Reference: SdkVersion Class Reference

  • kmc
  • kut
  • utilities
  • SdkVersion
Static Public Member Functions | List of all members
SdkVersion Class Reference

This class provides access to version information for the Kofax Mobile SDK. More...

Static Public Member Functions

static String | getSdkVersion ()
Retrieve the current Kofax Mobile SDK version. More...
static String | getPackageVersion ()
Retrieve the version of the Utilities package. More...
static String | getIpVersion ()
Retrieve the image processor library version. More...
static String | getBcVersion ()
Retrieve the barcode library version. More...
static String | getClassifierVersion ()
Retrieve the classifier library version. More...
static Boolean | versionCompatible (String versionCurrent, String versionDeserialized)
Compare the two version strings to determine serialization compatibility. More...
static int | compare (String version1, String version2)

Detailed Description

This class provides access to version information for the Kofax Mobile SDK.

This class provides a means of retrieving the version string for the Kofax Mobile SDK as a whole. It also provides access to the version information of the Utility package and the Kofax Image Processor and Classifier libraries.

Member Function Documentation

static int compare | ( | String | version1,
 |  | String | version2
 | ) |  |
static
static String getBcVersion ( )
static

Retrieve the barcode library version.

Returns
The version string for the barcode library.
static String getClassifierVersion ( )
static

Retrieve the classifier library version.

Returns
The version string for the classifier library.
static String getIpVersion ( )
static

Retrieve the image processor library version.

Returns
The version string for the image processor library.
static String getPackageVersion ( )
static

Retrieve the version of the Utilities package.

Returns
The version string for the Utilities package.
static String getSdkVersion ( )
static

Retrieve the current Kofax Mobile SDK version.

Returns
The full version string for the Mobile SDK.
static Boolean versionCompatible | ( | String | versionCurrent,
 |  | String | versionDeserialized
 | ) |  |
static

Compare the two version strings to determine serialization compatibility.

Returns
True if current version is greater than or equal to deserialized version.
The documentation for this class was generated from the following file:
  • SdkVersion.java


Kofax Mobile SDK API Reference: Size Class Reference

  • kmc
  • kut
  • utilities
  • Size
Public Member Functions | Public Attributes | List of all members
Size Class Reference

Universal class for image size describing. More...

Public Member Functions

Size (int w, int h)
Size (Point point)
Size (Camera.Size size)
Size (android.util.Size size)
boolean | equals (Object obj)
int | hashCode ()
String | toString ()

Public Attributes

int | width
int | height

Detailed Description

Universal class for image size describing.

Class for describing width and height dimensions in pixels. It is intended to provide a single interface instead of 2 classes: deprecated in API level 21 android.hardware.Camera.Size and added android.util.Size

Constructor & Destructor Documentation

Size | ( | int | w,
 |  | int | h
 | ) |  |
Size ( Point point )
Size ( Camera.Size size )
Size ( android.util.Size size )

Member Function Documentation

boolean equals ( Object obj )

Compares obj to this size.

Parameters
obj the object to compare this size with.
Returns
True if the width and height of obj is the same as those of this size. False otherwise.
int hashCode ( )
String toString ( )

Member Data Documentation

int height
int width
The documentation for this class was generated from the following file:
  • Size.java


Kofax Mobile SDK API Reference: BillCaptureActivity Class Reference

  • mobile
  • sdk
  • capture
  • bill
  • BillCaptureActivity
Protected Member Functions | List of all members
BillCaptureActivity Class Reference
Inheritance diagram for BillCaptureActivity:
CaptureActivity

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
- Protected Member Functions inherited from CaptureActivity
void | onCreate (Bundle savedInstanceState)
void | setCaptureCriteria (CaptureCriteria criteria)
void | onResume ()
void | onPause ()
ICameraView | getCameraView ()
void | setupCameraView (ViewGroup container)
void | setupButtonBarView (LinearLayout mainView)
void | onSaveInstanceState (Bundle outState)
void | initController (IOverlayView view, IDetectionAdapter detectorAdapter)
void | saveResultAndFinish (Image image, Bundle bundle)
void | onActivityResult (int requestCode, int resultCode, Intent data)

Additional Inherited Members

- Public Member Functions inherited from CaptureActivity
void | finish ()
void | onExitButtonClick ()
void | onForceCaptureButtonClick ()
void | onGalleryButtonClick ()
void | onTorchChange (boolean checked)
- Static Public Attributes inherited from CaptureActivity
static final String | RESULT_CODE = "__result_code__"
static final int | IMAGE_CAPTURED = -42
static final int | NO_IMAGE_CAPTURED = -1

Detailed Description

Bill-specialized image capture activity. This activity is constructed automatically by the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Member Function Documentation

void onCreate ( Bundle savedInstanceState )
protected
The documentation for this class was generated from the following file:
  • BillCaptureActivity.java


Kofax Mobile SDK API Reference: BillExtractActivity Class Reference

  • mobile
  • sdk
  • capture
  • bill
  • BillExtractActivity
Protected Member Functions | List of all members
BillExtractActivity Class Reference
Inheritance diagram for BillExtractActivity:
ExtractActivity< T extends ExtractorResponse > IExtractorListener< T extends ExtractorResponse >

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
- Protected Member Functions inherited from ExtractActivity< T extends ExtractorResponse >
void | onCreate (Bundle savedInstanceState)
synchronized void | onResume ()
Image | getImageByBitmapId (String id)
void | onSaveInstanceState (Bundle outState)
void | extract (Image image)

Additional Inherited Members

- Public Member Functions inherited from ExtractActivity< T extends ExtractorResponse >
void | onExtractionComplete (T results)
void | setExtract (Extractor extractor)
- Static Public Attributes inherited from ExtractActivity< T extends ExtractorResponse >
static final String | CERTIFICATE_VALIDATOR_LISTENER
- Protected Attributes inherited from ExtractActivity< T extends ExtractorResponse >
Extractor< T > | _extractor

Detailed Description

Bill-specialized extraction activity. This activity is constructed automatically by the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Member Function Documentation

void onCreate ( Bundle savedInstanceState )
protected
The documentation for this class was generated from the following file:
  • BillExtractActivity.java


Kofax Mobile SDK API Reference: BillExtractor Class Reference

  • mobile
  • sdk
  • capture
  • bill
  • BillExtractor
Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
BillExtractor Class Reference
Inheritance diagram for BillExtractor:
Extractor< T extends Serializable >

Public Member Functions

BillExtractor ()
void | setParameters (ExtractionParameters parameters)
- Public Member Functions inherited from Extractor< T extends Serializable >
Extractor ()
void | setExtractionServer (IExtractionServer extractionServer)
void | setResultDeserializer (IDeserializer< T > resultDeserializer)
void | setExceptionResponseDeserializer (IExceptionResponseDeserializer exceptionResponseDeserializer)
void | setParameters (ExtractionParameters parameters)
void | setExtractorListener (IExtractorListener listener)
void | setCertificateValidatorListener (CertificateValidatorListener certificateValidatorListener)
void | extract (Image...images)
void | onExtractionComplete (DataUnit unit)

Static Public Attributes

static final String | BILL_EXTRACT_RTTI = "_bill_extract_rtti_"
static final String | BILL_EXTRACT_KTA = "_bill_extract_kta_"

Protected Member Functions

ExtractorResponse< Bill > | createResponse (Bill results, ExceptionResponse exceptionResponse)
String | getDefaultServerUrl (ExtractionParameters.ExtractionType extractionType)
- Protected Member Functions inherited from Extractor< T extends Serializable >
abstract ExtractorResponse< T > | createResponse (T results, ExceptionResponse exceptionResponse)
abstract String | getDefaultServerUrl (ExtractionParameters.ExtractionType extractionType)

Detailed Description

Bill-specialized data extractor. This class is constructed automatically by the WorkflowActivity and is not intended for direct use.

Constructor & Destructor Documentation

BillExtractor ( )

Member Function Documentation

ExtractorResponse<Bill> createResponse | ( | Bill | results,
 |  | ExceptionResponse | exceptionResponse
 | ) |  |
protected
String getDefaultServerUrl ( ExtractionParameters.ExtractionType extractionType )
protected
void setParameters ( ExtractionParameters parameters )

Member Data Documentation

final String BILL_EXTRACT_KTA = "_bill_extract_kta_"
static
final String BILL_EXTRACT_RTTI = "_bill_extract_rtti_"
static
The documentation for this class was generated from the following file:
  • BillExtractor.java


Kofax Mobile SDK API Reference: BillExtractorResponse Class Reference

  • mobile
  • sdk
  • capture
  • bill
  • BillExtractorResponse
Public Member Functions | List of all members
BillExtractorResponse Class Reference
Inheritance diagram for BillExtractorResponse:
ExtractorResponse< T extends Serializable >

Public Member Functions

BillExtractorResponse (Bill result, ExceptionResponse exception)

Additional Inherited Members

- Public Attributes inherited from ExtractorResponse< T extends Serializable >
T results
ExceptionResponse exceptionResponse

Detailed Description

Bill-specialized extraction response container

Constructor & Destructor Documentation

BillExtractorResponse | ( | Bill | result,
 |  | ExceptionResponse | exception
 | ) |  |
The documentation for this class was generated from the following file:
  • BillExtractorResponse.java


Kofax Mobile SDK API Reference: BillParameters Class Reference

  • mobile
  • sdk
  • capture
  • bill
  • BillParameters
Public Member Functions | List of all members
BillParameters Class Reference
Inheritance diagram for BillParameters:
IParameters

Public Member Functions

BillParameters (Context context)
ProcessingParameters getProcessingParameters ()
ExtractionParameters getExtractionParameters ()
LookAndFeelParameters getLookAndFeelParameters ()

Detailed Description

Bill-specific capture, process and extraction parameters

Constructor & Destructor Documentation

BillParameters ( Context context )

Member Function Documentation

ExtractionParameters getExtractionParameters ( )

ExtractionParameters getter

See also
ExtractionParameters

Implements IParameters.

LookAndFeelParameters getLookAndFeelParameters ( )

LookAndFeelParameters getter

See also
LookAndFeelParameters

Implements IParameters.

ProcessingParameters getProcessingParameters ( )

ProcessingParameters getter

See also
ProcessingParameters

Implements IParameters.

The documentation for this class was generated from the following file:
  • BillParameters.java


Kofax Mobile SDK API Reference: BillWorkflowActivity Class Reference

  • mobile
  • sdk
  • capture
  • bill
  • BillWorkflowActivity
Classes | Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
BillWorkflowActivity Class Reference
Inheritance diagram for BillWorkflowActivity:
WorkflowActivity< T extends IParameters >

Public Member Functions

Class<?extends Activity > | getCaptureActivityClass ()
Class<?extends Activity > | getExtractActivityClass ()
String | getDefaultProcessingString (BillParameters parameters)
CaptureData getDefaultReturnObject ()
String | getParametersKey ()
String | getResultKey ()
String | getExceptionKey ()
BillParameters getParametersInstance ()
- Public Member Functions inherited from WorkflowActivity< T extends IParameters >
abstract Class<?extends Activity > | getCaptureActivityClass ()
abstract Class<?extends Activity > | getExtractActivityClass ()
abstract String | getDefaultProcessingString (T parameters)
abstract CaptureData | getDefaultReturnObject ()
abstract String | getParametersKey ()
abstract String | getResultKey ()
abstract String | getExceptionKey ()
abstract T | getParametersInstance ()
T | getParameters (Bundle savedInstanceState)

Static Public Attributes

static final String | BILL_PARAMETERS = "_com.kofax.mobile.sdk.capture.bill_parameters_"
static final String | BILL_RESULTS = "_com.kofax.mobile.sdk.capture.bill_results_"
static final String | BILL_EXCEPTION = "_com.kofax.mobile.sdk.capture.bill_exception_"
- Static Public Attributes inherited from WorkflowActivity< T extends IParameters >
static final String | CERTIFICATE_VALIDATOR_LISTENER

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
- Protected Member Functions inherited from WorkflowActivity< T extends IParameters >
boolean | isOdeSupported ()
void | onCreate (Bundle savedInstanceState)
void | handleException (final Throwable exc)
void | tryRestoreState (Bundle savedInstanceState)
void | onSaveInstanceState (Bundle outState)
void | onDestroy ()
void | onResume ()
void | captureImage ()
void | onActivityResult (int requestCode, int resultCode, Intent data)
void | clearBitmap (String imageId)

Detailed Description

The Bill workflow specializes in capturing, processing and extracting data from a bill. To use this class, optionally construct new BillParameters, modify those parameters for your use, then start an intent for this workflow:

BillParameters _params = new BillParameters(this);

Intent intent = new Intent(this, BillWorkflowActivity.class);

_params.getLookAndFeelParameters().forceCaptureEnabled = true;

_params.getExtractionParameters().serverType = ExtractionParameters.ServerType.RTTI;

_params.getLookAndFeelParameters().galleryEnabled = true;

intent.putExtra(BillWorkflowActivity.BILL_PARAMETERS, _params);

startActivityForResult(intent, REQUEST_CODE);

New permissions model introduced in Android M

Some functions won't be available until necessary permissions are granted by the user. It's up to the developer when to ask for permissions and whether or not to show a rationale — SDK doesn't do that.

Functions that require permissions:

  • Capture requires CAMERA permission.
  • Adding location data to captured images requires ACCESS_FINE_LOCATION permission.
  • The gallery button requires READ_EXTERNAL_STORAGE permission.

Member Function Documentation

Class<? extends Activity> getCaptureActivityClass ( )

Gets the specific capture activity for this workflow

Returns
BillCaptureActivity
String getDefaultProcessingString ( BillParameters parameters )

Gets the specific processing string for this workflow

CaptureData getDefaultReturnObject ( )

Retrieves an empty bill object

Returns
Bill
String getExceptionKey ( )

Gets the specific exception key for this workflow

Returns
BILL_EXCEPTION
Class<? extends Activity> getExtractActivityClass ( )

Gets the specific extract activity for this workflow

Returns
BillExtractActivity
BillParameters getParametersInstance ( )
String getParametersKey ( )

Gets the specific parameter key for this workflow

Returns
BILL_PARAMETERS
String getResultKey ( )

Gets the specific result key for this workflow

Returns
BILL_RESULTS
void onCreate ( Bundle savedInstanceState )
protected

Member Data Documentation

final String BILL_EXCEPTION = "_com.kofax.mobile.sdk.capture.bill_exception_"
static
final String BILL_PARAMETERS = "_com.kofax.mobile.sdk.capture.bill_parameters_"
static
final String BILL_RESULTS = "_com.kofax.mobile.sdk.capture.bill_results_"
static
The documentation for this class was generated from the following file:
  • BillWorkflowActivity.java


Kofax Mobile SDK API Reference: IBillDeserializer Interface Reference

  • mobile
  • sdk
  • capture
  • bill
  • IBillDeserializer
IBillDeserializer Interface Reference
Inheritance diagram for IBillDeserializer:

Detailed Description

Interface for a bill-specialized extraction data deserializer

The documentation for this interface was generated from the following file:
  • IBillDeserializer.java


Kofax Mobile SDK API Reference: IBillExtractorListener Interface Reference

  • mobile
  • sdk
  • capture
  • bill
  • IBillExtractorListener
List of all members
IBillExtractorListener Interface Reference
Inheritance diagram for IBillExtractorListener:
IExtractorListener< T extends ExtractorResponse >

Additional Inherited Members

- Public Member Functions inherited from IExtractorListener< T extends ExtractorResponse >
void onExtractionComplete (T results)

Detailed Description

Interface for a bill-specialized extraction listener

The documentation for this interface was generated from the following file:
  • IBillExtractorListener.java


Kofax Mobile SDK API Reference: KtaBillExtractor Class Reference

  • mobile
  • sdk
  • capture
  • bill
  • KtaBillExtractor
Public Member Functions | List of all members
KtaBillExtractor Class Reference
Inheritance diagram for KtaBillExtractor:

Public Member Functions

KtaBillExtractor (IKtaSessionIdProviderFactory sessionIdProviderFactory, IImageToByteArray converter)
String getProcessName ()

Detailed Description

KTA-specialized bill data extractor. This class is constructed automatically by the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Constructor & Destructor Documentation

KtaBillExtractor | ( | IKtaSessionIdProviderFactory | sessionIdProviderFactory,
 |  | IImageToByteArray | converter
 | ) |  |

Member Function Documentation

String getProcessName ( )
The documentation for this class was generated from the following file:
  • KtaBillExtractor.java


Kofax Mobile SDK API Reference: KtaJsonBill Class Reference

  • mobile
  • sdk
  • capture
  • bill
  • KtaJsonBill
Public Member Functions | List of all members
KtaJsonBill Class Reference
Inheritance diagram for KtaJsonBill:
Bill CaptureData

Public Member Functions

KtaJsonBill (Context context, String json)
void | setJson (String json)
Field getAmount ()
Field getDueDate ()
Field getName ()
Field getAddressLine1 ()
Field getAddressLine2 ()
Field getCity ()
Field getState ()
Field getZip ()
Field getAccountNumber ()
Field getPhoneNumber ()
Field getSource ()
Field getBillers ()
String | getRawData ()
- Public Member Functions inherited from Bill
abstract Field | getAmount ()
abstract Field | getDueDate ()
abstract Field | getName ()
abstract Field | getAddressLine1 ()
abstract Field | getAddressLine2 ()
abstract Field | getCity ()
abstract Field | getState ()
abstract Field | getZip ()
abstract Field | getAccountNumber ()
abstract Field | getPhoneNumber ()
abstract Field | getSource ()
abstract Field | getBillers ()
abstract String | getRawData ()

Additional Inherited Members

- Public Attributes inherited from CaptureData
String | capturedImageId = ""
String | processedImageId = ""

Detailed Description

A JSON deserializer for KTA extraction

Constructor & Destructor Documentation

KtaJsonBill | ( | Context | context,
 |  | String | json
 | ) |  |

Member Function Documentation

Field getAccountNumber ( )
Field getAddressLine1 ( )
Field getAddressLine2 ( )
Field getAmount ( )
Field getBillers ( )
Field getCity ( )
Field getDueDate ( )
Field getName ( )
Field getPhoneNumber ( )
String getRawData ( )
Field getSource ( )
Field getState ( )
Field getZip ( )
void setJson ( String json )
The documentation for this class was generated from the following file:
  • KtaJsonBill.java


Kofax Mobile SDK API Reference: RttiBillExtractor Class Reference

  • mobile
  • sdk
  • capture
  • bill
  • RttiBillExtractor
Public Member Functions | List of all members
RttiBillExtractor Class Reference
Inheritance diagram for RttiBillExtractor:

Public Member Functions

RttiBillExtractor (IImageToByteArray converter)

Detailed Description

RTTI-specialized bill data extractor. This class is constructed automatically by the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Constructor & Destructor Documentation

RttiBillExtractor ( IImageToByteArray converter )
The documentation for this class was generated from the following file:
  • RttiBillExtractor.java


Kofax Mobile SDK API Reference: RttiJsonBill Class Reference

  • mobile
  • sdk
  • capture
  • bill
  • RttiJsonBill
Public Member Functions | List of all members
RttiJsonBill Class Reference
Inheritance diagram for RttiJsonBill:
Bill CaptureData

Public Member Functions

RttiJsonBill (Context context, String json)
void | setJson (String json)
Field getAmount ()
Field getDueDate ()
Field getName ()
Field getAddressLine1 ()
Field getAddressLine2 ()
Field getCity ()
Field getState ()
Field getZip ()
Field getAccountNumber ()
Field getPhoneNumber ()
Field getSource ()
Field getBillers ()
String | getRawData ()
- Public Member Functions inherited from Bill
abstract Field | getAmount ()
abstract Field | getDueDate ()
abstract Field | getName ()
abstract Field | getAddressLine1 ()
abstract Field | getAddressLine2 ()
abstract Field | getCity ()
abstract Field | getState ()
abstract Field | getZip ()
abstract Field | getAccountNumber ()
abstract Field | getPhoneNumber ()
abstract Field | getSource ()
abstract Field | getBillers ()
abstract String | getRawData ()

Additional Inherited Members

- Public Attributes inherited from CaptureData
String | capturedImageId = ""
String | processedImageId = ""

Detailed Description

A JSON deserializer for RTTI extraction

Constructor & Destructor Documentation

RttiJsonBill | ( | Context | context,
 |  | String | json
 | ) |  |

Member Function Documentation

Field getAccountNumber ( )
Field getAddressLine1 ( )
Field getAddressLine2 ( )
Field getAmount ( )
Field getBillers ( )
Field getCity ( )
Field getDueDate ( )
Field getName ( )
Field getPhoneNumber ( )
String getRawData ( )
Field getSource ( )
Field getState ( )
Field getZip ( )
void setJson ( String json )
The documentation for this class was generated from the following file:
  • RttiJsonBill.java


Kofax Mobile SDK API Reference: CheckCaptureActivity Class Reference

  • mobile
  • sdk
  • capture
  • check
  • CheckCaptureActivity
Protected Member Functions | List of all members
CheckCaptureActivity Class Reference
Inheritance diagram for CheckCaptureActivity:
CaptureActivity

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
- Protected Member Functions inherited from CaptureActivity
void | onCreate (Bundle savedInstanceState)
void | setCaptureCriteria (CaptureCriteria criteria)
void | onResume ()
void | onPause ()
ICameraView | getCameraView ()
void | setupCameraView (ViewGroup container)
void | setupButtonBarView (LinearLayout mainView)
void | onSaveInstanceState (Bundle outState)
void | initController (IOverlayView view, IDetectionAdapter detectorAdapter)
void | saveResultAndFinish (Image image, Bundle bundle)
void | onActivityResult (int requestCode, int resultCode, Intent data)

Additional Inherited Members

- Public Member Functions inherited from CaptureActivity
void | finish ()
void | onExitButtonClick ()
void | onForceCaptureButtonClick ()
void | onGalleryButtonClick ()
void | onTorchChange (boolean checked)
- Static Public Attributes inherited from CaptureActivity
static final String | RESULT_CODE = "__result_code__"
static final int | IMAGE_CAPTURED = -42
static final int | NO_IMAGE_CAPTURED = -1

Detailed Description

Check-specialized image capture activity. This activity is constructed automatically by the WorkflowActivity and is not intended for direct use.

Member Function Documentation

void onCreate ( Bundle savedInstanceState )
protected
The documentation for this class was generated from the following file:
  • CheckCaptureActivity.java


Kofax Mobile SDK API Reference: CheckExtractActivity Class Reference

  • mobile
  • sdk
  • capture
  • check
  • CheckExtractActivity
Protected Member Functions | List of all members
CheckExtractActivity Class Reference
Inheritance diagram for CheckExtractActivity:
ExtractActivity< T extends ExtractorResponse > IExtractorListener< T extends ExtractorResponse >

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
void | extract (Image image)
- Protected Member Functions inherited from ExtractActivity< T extends ExtractorResponse >
void | onCreate (Bundle savedInstanceState)
synchronized void | onResume ()
Image | getImageByBitmapId (String id)
void | onSaveInstanceState (Bundle outState)
void | extract (Image image)

Additional Inherited Members

- Public Member Functions inherited from ExtractActivity< T extends ExtractorResponse >
void | onExtractionComplete (T results)
void | setExtract (Extractor extractor)
- Static Public Attributes inherited from ExtractActivity< T extends ExtractorResponse >
static final String | CERTIFICATE_VALIDATOR_LISTENER
- Protected Attributes inherited from ExtractActivity< T extends ExtractorResponse >
Extractor< T > | _extractor

Detailed Description

Check-specialized extraction activity. This activity is constructed automatically by the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Member Function Documentation

void extract ( Image image )
protected
void onCreate ( Bundle savedInstanceState )
protected
The documentation for this class was generated from the following file:
  • CheckExtractActivity.java


Kofax Mobile SDK API Reference: CheckExtractor Class Reference

  • mobile
  • sdk
  • capture
  • check
  • CheckExtractor
Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
CheckExtractor Class Reference
Inheritance diagram for CheckExtractor:
Extractor< T extends Serializable >

Public Member Functions

CheckExtractor ()
void | setParameters (CheckParameters parameters)
- Public Member Functions inherited from Extractor< T extends Serializable >
Extractor ()
void | setExtractionServer (IExtractionServer extractionServer)
void | setResultDeserializer (IDeserializer< T > resultDeserializer)
void | setExceptionResponseDeserializer (IExceptionResponseDeserializer exceptionResponseDeserializer)
void | setParameters (ExtractionParameters parameters)
void | setExtractorListener (IExtractorListener listener)
void | setCertificateValidatorListener (CertificateValidatorListener certificateValidatorListener)
void | extract (Image...images)
void | onExtractionComplete (DataUnit unit)

Static Public Attributes

static final String | CHECK_EXTRACT_RTTI = "_check_extract_rtti_"
static final String | CHECK_EXTRACT_KTA = "_check_extract_kta_"

Protected Member Functions

ExtractorResponse< Check > | createResponse (Check check, ExceptionResponse exceptionResponse)
String | getDefaultServerUrl (ExtractionParameters.ExtractionType serverType)
- Protected Member Functions inherited from Extractor< T extends Serializable >
abstract ExtractorResponse< T > | createResponse (T results, ExceptionResponse exceptionResponse)
abstract String | getDefaultServerUrl (ExtractionParameters.ExtractionType extractionType)

Detailed Description

A check-specific extractor. Knows how to handle extraction results, and encapsulate those results into a CheckExtractorResponse object. This class is constructed automatically by the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Constructor & Destructor Documentation

CheckExtractor ( )

Member Function Documentation

ExtractorResponse<Check> createResponse | ( | Check | check,
 |  | ExceptionResponse | exceptionResponse
 | ) |  |
protected
String getDefaultServerUrl ( ExtractionParameters.ExtractionType serverType )
protected
void setParameters ( CheckParameters parameters )

Member Data Documentation

final String CHECK_EXTRACT_KTA = "_check_extract_kta_"
static
final String CHECK_EXTRACT_RTTI = "_check_extract_rtti_"
static
The documentation for this class was generated from the following file:
  • CheckExtractor.java


Kofax Mobile SDK API Reference: CheckExtractorResponse Class Reference

  • mobile
  • sdk
  • capture
  • check
  • CheckExtractorResponse
Public Member Functions | List of all members
CheckExtractorResponse Class Reference
Inheritance diagram for CheckExtractorResponse:
ExtractorResponse< T extends Serializable >

Public Member Functions

CheckExtractorResponse (Check check, ExceptionResponse exception)

Additional Inherited Members

- Public Attributes inherited from ExtractorResponse< T extends Serializable >
T results
ExceptionResponse exceptionResponse

Detailed Description

Check-specialized extraction response container

Constructor & Destructor Documentation

CheckExtractorResponse | ( | Check | check,
 |  | ExceptionResponse | exception
 | ) |  |
The documentation for this class was generated from the following file:
  • CheckExtractorResponse.java


Kofax Mobile SDK API Reference: CheckParameters Class Reference

  • mobile
  • sdk
  • capture
  • check
  • CheckParameters
Classes | Public Member Functions | Public Attributes | List of all members
CheckParameters Class Reference
Inheritance diagram for CheckParameters:
IParameters

Classes

enum CheckCountry

Public Member Functions

CheckParameters (Context context)
ProcessingParameters getProcessingParameters ()
ExtractionParameters getExtractionParameters ()
LookAndFeelParameters getLookAndFeelParameters ()

Public Attributes

CheckSide side = CheckSide.FRONT
Check reverseSideCheck
CheckCountry country = CheckCountry.NOT_SPECIFIED

Detailed Description

Check-specific capture, process and extraction parameters

Constructor & Destructor Documentation

CheckParameters ( Context context )

Member Function Documentation

ExtractionParameters getExtractionParameters ( )

ExtractionParameters getter

See also
ExtractionParameters

Implements IParameters.

LookAndFeelParameters getLookAndFeelParameters ( )

LookAndFeelParameters getter

See also
LookAndFeelParameters

Implements IParameters.

ProcessingParameters getProcessingParameters ( )

ProcessingParameters getter

See also
ProcessingParameters

Implements IParameters.

Member Data Documentation

CheckCountry country = CheckCountry.NOT_SPECIFIED

This value is used for the extraction. Specify one of the available values from CheckCountry enumeration.

The default value is NOT_SPECIFIED.

See also
CheckCountry
Check reverseSideCheck

Data for another side of the check. This data will be used for extraction along with the image for the current side of the check. The field supposed to be used in case of capturing both sides of the check.

See also
Check
CheckSide side = CheckSide.FRONT

The check side being captured during this capture flow

The documentation for this class was generated from the following file:
  • CheckParameters.java


Kofax Mobile SDK API Reference: CheckParameters.CheckCountry Enum Reference

  • mobile
  • sdk
  • capture
  • check
  • CheckParameters
  • CheckCountry
Public Attributes | List of all members
CheckParameters.CheckCountry Enum Reference

Public Attributes

NOT_SPECIFIED
UNITED_STATES
CANADA
SINGAPORE
HONG_KONG
AUSTRALIA
UNITED_KINGDOM

Detailed Description

The country of the bank the check is written from

Member Data Documentation

AUSTRALIA
CANADA
HONG_KONG
NOT_SPECIFIED
SINGAPORE
UNITED_KINGDOM
UNITED_STATES
The documentation for this enum was generated from the following file:
  • CheckParameters.java


Kofax Mobile SDK API Reference: CheckWorkflowActivity Class Reference

  • mobile
  • sdk
  • capture
  • check
  • CheckWorkflowActivity
Classes | Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
CheckWorkflowActivity Class Reference
Inheritance diagram for CheckWorkflowActivity:
WorkflowActivity< T extends IParameters >

Public Member Functions

Class<?extends Activity > | getCaptureActivityClass ()
Class<?extends Activity > | getExtractActivityClass ()
String | getDefaultProcessingString (CheckParameters parameters)
CaptureData getDefaultReturnObject ()
String | getParametersKey ()
String | getResultKey ()
String | getExceptionKey ()
CheckParameters getParametersInstance ()
- Public Member Functions inherited from WorkflowActivity< T extends IParameters >
abstract Class<?extends Activity > | getCaptureActivityClass ()
abstract Class<?extends Activity > | getExtractActivityClass ()
abstract String | getDefaultProcessingString (T parameters)
abstract CaptureData | getDefaultReturnObject ()
abstract String | getParametersKey ()
abstract String | getResultKey ()
abstract String | getExceptionKey ()
abstract T | getParametersInstance ()
T | getParameters (Bundle savedInstanceState)

Static Public Attributes

static final String | CHECK_PARAMETERS = "_com.kofax.mobile.sdk.capture._check_parameters_"
static final String | CHECK_RESULTS = "_com.kofax.mobile.sdk.capture._check_results_"
static final String | CHECK_EXCEPTION = "_com.kofax.mobile.sdk.capture._check_exception_"
- Static Public Attributes inherited from WorkflowActivity< T extends IParameters >
static final String | CERTIFICATE_VALIDATOR_LISTENER

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
- Protected Member Functions inherited from WorkflowActivity< T extends IParameters >
boolean | isOdeSupported ()
void | onCreate (Bundle savedInstanceState)
void | handleException (final Throwable exc)
void | tryRestoreState (Bundle savedInstanceState)
void | onSaveInstanceState (Bundle outState)
void | onDestroy ()
void | onResume ()
void | captureImage ()
void | onActivityResult (int requestCode, int resultCode, Intent data)
void | clearBitmap (String imageId)

Detailed Description

The Check workflow specializes in capturing, processing and extracting data from a Check. To use this class, optionally construct new CheckParameters, modify those parameters for your use, then start an intent for this workflow:

CheckParameters _params = new CheckParameters(this);

Intent intent = new Intent(this, CheckWorkflowActivity.class);

_params.getLookAndFeelParameters().forceCaptureEnabled = true;

_params.getExtractionParameters().serverType = ExtractionParameters.ServerType.RTTI;

_params.getLookAndFeelParameters().galleryEnabled = true;

intent.putExtra(CheckWorkflowActivity.CHECK_PARAMETERS, _params);

startActivityForResult(intent, REQUEST_CODE);

Capturing both sides of a check

Checks have important information on both sides. For improved accuracy, data extraction should be performed for both sides during the same session. To achieve that follow these steps:

  1. Start the CheckWorkflowActivity for one side with call of setExtractionType (ExtractionType.OFF).
  2. Receive and store the check data available in the result Intent when Activity.onActivityResult gets called back.
  3. Start the CheckWorkflowActivity for the other side of the check with extraction enabled and CheckWorkflowActivity.reverseSideCheck set to the check data from the step 2.

New permissions model introduced in Android M

Some functions won't be available until necessary permissions are granted by the user. It's up to the developer when to ask for permissions and whether or not to show a rationale — SDK doesn't do that.

Functions that require permissions:

  • Capture requires CAMERA permission.
  • Adding location data to captured images requires ACCESS_FINE_LOCATION permission.
  • The gallery button requires READ_EXTERNAL_STORAGE permission.

Member Function Documentation

Class<? extends Activity> getCaptureActivityClass ( )

Gets the specific capture activity for this workflow

Returns
CheckCaptureActivity
String getDefaultProcessingString ( CheckParameters parameters )

Gets the specific processing string for this workflow

CaptureData getDefaultReturnObject ( )

Retrieves an empty check object

Returns
Check
String getExceptionKey ( )

Gets the specific exception key for this workflow

Returns
CHECK_EXCEPTION
Class<? extends Activity> getExtractActivityClass ( )

Gets the specific extract activity for this workflow

Returns
CheckExtractActivity
CheckParameters getParametersInstance ( )
String getParametersKey ( )

Gets the specific parameter key for this workflow

Returns
CHECK_PARAMETERS
String getResultKey ( )

Gets the specific results key for this workflow

Returns
CHECK_RESULTS
void onCreate ( Bundle savedInstanceState )
protected

Member Data Documentation

final String CHECK_EXCEPTION = "_com.kofax.mobile.sdk.capture._check_exception_"
static
final String CHECK_PARAMETERS = "_com.kofax.mobile.sdk.capture._check_parameters_"
static
final String CHECK_RESULTS = "_com.kofax.mobile.sdk.capture._check_results_"
static
The documentation for this class was generated from the following file:
  • CheckWorkflowActivity.java


Kofax Mobile SDK API Reference: ICheckDeserializer Interface Reference

  • mobile
  • sdk
  • capture
  • check
  • ICheckDeserializer
ICheckDeserializer Interface Reference
Inheritance diagram for ICheckDeserializer:

Detailed Description

Interface for a check-specialized extraction data deserializer

The documentation for this interface was generated from the following file:
  • ICheckDeserializer.java


Kofax Mobile SDK API Reference: ICheckExtractionServer Interface Reference

  • mobile
  • sdk
  • capture
  • check
  • ICheckExtractionServer
Public Member Functions | List of all members
ICheckExtractionServer Interface Reference
Inheritance diagram for ICheckExtractionServer:
KtaCheckExtractor RttiCheckExtractor

Public Member Functions

void setCheckParameters (CheckParameters parameters)

Member Function Documentation

void setCheckParameters ( CheckParameters parameters )

Implemented in KtaCheckExtractor, and RttiCheckExtractor.

The documentation for this interface was generated from the following file:
  • ICheckExtractionServer.java


Kofax Mobile SDK API Reference: ICheckExtractorListener Interface Reference

  • mobile
  • sdk
  • capture
  • check
  • ICheckExtractorListener
List of all members
ICheckExtractorListener Interface Reference
Inheritance diagram for ICheckExtractorListener:
IExtractorListener< T extends ExtractorResponse >

Additional Inherited Members

- Public Member Functions inherited from IExtractorListener< T extends ExtractorResponse >
void onExtractionComplete (T results)

Detailed Description

Interface for a check-specialized extraction listener

The documentation for this interface was generated from the following file:
  • ICheckExtractorListener.java


Kofax Mobile SDK API Reference: KtaCheckExtractor Class Reference

  • mobile
  • sdk
  • capture
  • check
  • KtaCheckExtractor
Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
KtaCheckExtractor Class Reference
Inheritance diagram for KtaCheckExtractor:
ICheckExtractionServer

Public Member Functions

KtaCheckExtractor (IKtaSessionIdProviderFactory sessionIdProviderFactory, IImageToByteArray converter)
String | getProcessName ()
void | setCheckParameters (CheckParameters parameters)

Static Public Attributes

static final String COUNTRY = "Country"

Protected Member Functions

void updateKTARequest (JobService jobService)

Detailed Description

KTA-specialized check data extractor. This class is constructed automatically by the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Constructor & Destructor Documentation

KtaCheckExtractor | ( | IKtaSessionIdProviderFactory | sessionIdProviderFactory,
 |  | IImageToByteArray | converter
 | ) |  |

Member Function Documentation

String getProcessName ( )
void setCheckParameters ( CheckParameters parameters )

Implements ICheckExtractionServer.

void updateKTARequest ( JobService jobService )
protected

Member Data Documentation

final String COUNTRY = "Country"
static
The documentation for this class was generated from the following file:
  • KtaCheckExtractor.java


Kofax Mobile SDK API Reference: KtaJsonCheck Class Reference

  • mobile
  • sdk
  • capture
  • check
  • KtaJsonCheck
Classes | Public Member Functions | List of all members
KtaJsonCheck Class Reference
Inheritance diagram for KtaJsonCheck:
Check CaptureData

Public Member Functions

KtaJsonCheck (Context context, String json)
Field< String > | getUsable ()
Field< String > | getAmount ()
Field< String > | getCar ()
Field< String > | getLar ()
Field< String > | getPayee ()
Field< String > | getCheckNumber ()
Field< String > | getDate ()
Field< String > | getMicr ()
Field< String > | getRestrictiveEndorsementPresent ()
Field< String > | getRestrictiveEndorsement ()
Field< String > | getReasonForRejection ()
Field< String > | getOnUs1 ()
Field< String > | getTransit ()
Field< String > | getEpc ()
Field< String > | getMicrAmount ()
CheckIQAData getCheckIQAData ()
CheckUsabilityData getCheckUsabilityData ()
String | getRawData ()
Field< String > | getAuxiliaryOnUs ()
Field< String > | getOnUs2 ()
void | setJson (String json)
- Public Member Functions inherited from Check
abstract Field< String > | getMicr ()
abstract Field< String > | getAmount ()
abstract Field< String > | getCheckNumber ()
abstract Field< String > | getDate ()
abstract Field< String > | getPayee ()
abstract Field< String > | getUsable ()
abstract Field< String > | getLar ()
abstract Field< String > | getCar ()
abstract Field< String > | getTransit ()
abstract Field< String > | getOnUs1 ()
abstract Field< String > | getOnUs2 ()
abstract Field< String > | getAuxiliaryOnUs ()
abstract Field< String > | getEpc ()
abstract Field< String > | getMicrAmount ()
abstract CheckIQAData | getCheckIQAData ()
abstract CheckUsabilityData | getCheckUsabilityData ()
abstract String | getRawData ()
abstract Field< String > | getRestrictiveEndorsementPresent ()
abstract Field< String > | getRestrictiveEndorsement ()
abstract Field< String > | getReasonForRejection ()

Additional Inherited Members

- Public Attributes inherited from CaptureData
String | capturedImageId = ""
String | processedImageId = ""

Detailed Description

A JSON deserializer for KTA extraction

Constructor & Destructor Documentation

KtaJsonCheck | ( | Context | context,
 |  | String | json
 | ) |  |

Member Function Documentation

Field<String> getAmount ( )
Field<String> getAuxiliaryOnUs ( )
Field<String> getCar ( )
CheckIQAData getCheckIQAData ( )
Field<String> getCheckNumber ( )
CheckUsabilityData getCheckUsabilityData ( )
Field<String> getDate ( )
Field<String> getEpc ( )
Field<String> getLar ( )
Field<String> getMicr ( )
Field<String> getMicrAmount ( )
Field<String> getOnUs1 ( )
Field<String> getOnUs2 ( )
Field<String> getPayee ( )
String getRawData ( )
Field<String> getReasonForRejection ( )
Field<String> getRestrictiveEndorsement ( )
Field<String> getRestrictiveEndorsementPresent ( )
Field<String> getTransit ( )
Field<String> getUsable ( )
void setJson ( String json )
The documentation for this class was generated from the following file:
  • KtaJsonCheck.java


Kofax Mobile SDK API Reference: RttiCheckExtractor Class Reference

  • mobile
  • sdk
  • capture
  • check
  • RttiCheckExtractor
Public Member Functions | Protected Member Functions | List of all members
RttiCheckExtractor Class Reference
Inheritance diagram for RttiCheckExtractor:
ICheckExtractionServer

Public Member Functions

RttiCheckExtractor (IImageToByteArray converter)
void setCheckParameters (CheckParameters parameters)

Protected Member Functions

void updateRttiRequest (RttiRequest rttiRequest)

Detailed Description

RTTI-specialized check data extractor. This class is constructed automatically by the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Constructor & Destructor Documentation

RttiCheckExtractor ( IImageToByteArray converter )

Member Function Documentation

void setCheckParameters ( CheckParameters parameters )

Implements ICheckExtractionServer.

void updateRttiRequest ( RttiRequest rttiRequest )
protected
The documentation for this class was generated from the following file:
  • RttiCheckExtractor.java


Kofax Mobile SDK API Reference: RttiJsonCheck Class Reference

  • mobile
  • sdk
  • capture
  • check
  • RttiJsonCheck
Classes | Public Member Functions | List of all members
RttiJsonCheck Class Reference
Inheritance diagram for RttiJsonCheck:
Check CaptureData

Public Member Functions

void | setJson (String json)
RttiJsonCheck (Context context, String json)
Field< String > | getUsable ()
Field< String > | getAmount ()
Field< String > | getCar ()
Field< String > | getLar ()
Field< String > | getPayee ()
Field< String > | getCheckNumber ()
Field< String > | getDate ()
Field< String > | getMicr ()
Field< String > | getRestrictiveEndorsementPresent ()
Field< String > | getRestrictiveEndorsement ()
Field< String > | getReasonForRejection ()
Field< String > | getOnUs1 ()
Field< String > | getTransit ()
Field< String > | getEpc ()
Field< String > | getAuxiliaryOnUs ()
Field< String > | getOnUs2 ()
Field< String > | getMicrAmount ()
CheckIQAData getCheckIQAData ()
CheckUsabilityData getCheckUsabilityData ()
String | getRawData ()
- Public Member Functions inherited from Check
abstract Field< String > | getMicr ()
abstract Field< String > | getAmount ()
abstract Field< String > | getCheckNumber ()
abstract Field< String > | getDate ()
abstract Field< String > | getPayee ()
abstract Field< String > | getUsable ()
abstract Field< String > | getLar ()
abstract Field< String > | getCar ()
abstract Field< String > | getTransit ()
abstract Field< String > | getOnUs1 ()
abstract Field< String > | getOnUs2 ()
abstract Field< String > | getAuxiliaryOnUs ()
abstract Field< String > | getEpc ()
abstract Field< String > | getMicrAmount ()
abstract CheckIQAData | getCheckIQAData ()
abstract CheckUsabilityData | getCheckUsabilityData ()
abstract String | getRawData ()
abstract Field< String > | getRestrictiveEndorsementPresent ()
abstract Field< String > | getRestrictiveEndorsement ()
abstract Field< String > | getReasonForRejection ()

Additional Inherited Members

- Public Attributes inherited from CaptureData
String | capturedImageId = ""
String | processedImageId = ""

Detailed Description

RTTI-specialized JSON deserializer. This class is constructed automatically in the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Constructor & Destructor Documentation

RttiJsonCheck | ( | Context | context,
 |  | String | json
 | ) |  |

Member Function Documentation

Field<String> getAmount ( )
Field<String> getAuxiliaryOnUs ( )
Field<String> getCar ( )
CheckIQAData getCheckIQAData ( )
Field<String> getCheckNumber ( )
CheckUsabilityData getCheckUsabilityData ( )
Field<String> getDate ( )
Field<String> getEpc ( )
Field<String> getLar ( )
Field<String> getMicr ( )
Field<String> getMicrAmount ( )
Field<String> getOnUs1 ( )
Field<String> getOnUs2 ( )
Field<String> getPayee ( )
String getRawData ( )
Field<String> getReasonForRejection ( )
Field<String> getRestrictiveEndorsement ( )
Field<String> getRestrictiveEndorsementPresent ( )
Field<String> getTransit ( )
Field<String> getUsable ( )
void setJson ( String json )
The documentation for this class was generated from the following file:
  • RttiJsonCheck.java


Kofax Mobile SDK API Reference: CardIoWrapperActivity Class Reference

  • mobile
  • sdk
  • capture
  • creditcard
  • CardIoWrapperActivity
Static Public Attributes | Protected Member Functions | List of all members
CardIoWrapperActivity Class Reference
Inheritance diagram for CardIoWrapperActivity:

Static Public Attributes

static final String EXTRA_EXTRA_TIME_FOR_EXPIRY

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
void | onActivityResult (int requestCode, int resultCode, Intent data)

Detailed Description

This activity is constructed automatically in the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Member Function Documentation

void onActivityResult | ( | int | requestCode,
 |  | int | resultCode,
 |  | Intent | data
 | ) |  |
protected
void onCreate ( Bundle savedInstanceState )
protected

Member Data Documentation

final String EXTRA_EXTRA_TIME_FOR_EXPIRY
static
Initial value:
=
"com.kofax.mobile.sdk.capture.creditcard.CardIoWrapperActivity.extraTimeForExpiry"
The documentation for this class was generated from the following file:
  • CardIoWrapperActivity.java


Kofax Mobile SDK API Reference: CreditCardParameters Class Reference

  • mobile
  • sdk
  • capture
  • creditcard
  • CreditCardParameters
Classes | Public Member Functions | Public Attributes | List of all members
CreditCardParameters Class Reference
Inheritance diagram for CreditCardParameters:
IParameters

Classes

enum CardStyle

Public Member Functions

CreditCardParameters (Context context)
ProcessingParameters getProcessingParameters ()
ExtractionParameters getExtractionParameters ()
LookAndFeelParameters getLookAndFeelParameters ()

Public Attributes

CardStyle cardStyle = CardStyle.EMBOSSED
long extraTimeForExpiry = 1000L

Detailed Description

For future use! CreditCardParameters are ignored by the CreditCardWorkflowActivity

Constructor & Destructor Documentation

CreditCardParameters ( Context context )

Member Function Documentation

ExtractionParameters getExtractionParameters ( )

ExtractionParameters getter

See also
ExtractionParameters

Implements IParameters.

LookAndFeelParameters getLookAndFeelParameters ( )

LookAndFeelParameters getter

See also
LookAndFeelParameters

Implements IParameters.

ProcessingParameters getProcessingParameters ( )

ProcessingParameters getter

See also
ProcessingParameters

Implements IParameters.

Member Data Documentation

CardStyle cardStyle = CardStyle.EMBOSSED

The style card to capture.

The default value is com.kofax.mobile.sdk.capture.creditcard.CreditCardParameters.CardStyle#EMBOSSED

long extraTimeForExpiry = 1000L

Time in milliseconds allowed for expiry extraction once the card number has been successfully identified.

Defaults to 1000.

The documentation for this class was generated from the following file:
  • CreditCardParameters.java


Kofax Mobile SDK API Reference: CreditCardParameters.CardStyle Enum Reference

  • mobile
  • sdk
  • capture
  • creditcard
  • CreditCardParameters
  • CardStyle
Public Attributes | List of all members
CreditCardParameters.CardStyle Enum Reference

Public Attributes

EMBOSSED
FLAT

Detailed Description

An enumeration defining the different types of credit cards

Note: Only com.kofax.mobile.sdk.capture.creditcard.CreditCardParameters.CardStyle#EMBOSSED is currently supported

Member Data Documentation

EMBOSSED
FLAT
The documentation for this enum was generated from the following file:
  • CreditCardParameters.java


Kofax Mobile SDK API Reference: CreditCardWorkflowActivity Class Reference

  • mobile
  • sdk
  • capture
  • creditcard
  • CreditCardWorkflowActivity
Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
CreditCardWorkflowActivity Class Reference
Inheritance diagram for CreditCardWorkflowActivity:
WorkflowActivity< T extends IParameters >

Public Member Functions

Class<?extends Activity > | getCaptureActivityClass ()
Class<?extends Activity > | getExtractActivityClass ()
String | getDefaultProcessingString (CreditCardParameters parameters)
CaptureData getDefaultReturnObject ()
String | getParametersKey ()
String | getResultKey ()
String | getExceptionKey ()
CreditCardParameters getParametersInstance ()
- Public Member Functions inherited from WorkflowActivity< T extends IParameters >
abstract Class<?extends Activity > | getCaptureActivityClass ()
abstract Class<?extends Activity > | getExtractActivityClass ()
abstract String | getDefaultProcessingString (T parameters)
abstract CaptureData | getDefaultReturnObject ()
abstract String | getParametersKey ()
abstract String | getResultKey ()
abstract String | getExceptionKey ()
abstract T | getParametersInstance ()
T | getParameters (Bundle savedInstanceState)

Static Public Attributes

static final String | CREDIT_CARD_PARAMETERS = "_com.kofax.mobile.sdk.capture._credit_card_parameters_"
static final String | CREDIT_CARD_RESULTS = "_com.kofax.mobile.sdk.capture._credit_card_results_"
static final String | CREDIT_CARD_EXCEPTION = "_com.kofax.mobile.sdk.capture._credit_card_exception_"
- Static Public Attributes inherited from WorkflowActivity< T extends IParameters >
static final String | CERTIFICATE_VALIDATOR_LISTENER

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
void | captureImage ()
void | onActivityResult (int requestCode, int resultCode, Intent data)
- Protected Member Functions inherited from WorkflowActivity< T extends IParameters >
boolean | isOdeSupported ()
void | onCreate (Bundle savedInstanceState)
void | handleException (final Throwable exc)
void | tryRestoreState (Bundle savedInstanceState)
void | onSaveInstanceState (Bundle outState)
void | onDestroy ()
void | onResume ()
void | captureImage ()
void | onActivityResult (int requestCode, int resultCode, Intent data)
void | clearBitmap (String imageId)

Detailed Description

The CreditCard workflow specializes in capturing, processing and extracting data from a credit card. To use this class, optionally construct new CreditCardParameters, modify those parameters for your use, then start an intent for this workflow:

CreditCardParameters _params = new CreditCardParameters(this);

Intent intent = new Intent(this, CreditCardWorkflowActivity.class);

_params.getLookAndFeelParameters().forceCaptureEnabled = true;

_params.getExtractionParameters().setExtractionType(ExtractionParameters.ExtractionType.RTTI);

_params.getLookAndFeelParameters().galleryEnabled = true;

intent.putExtra(CreditCardWorkflowActivity.CREDIT_CARD_PARAMETERS, _params);

startActivityForResult(intent, REQUEST_CODE);
Note
The CreditCard workflow supports the following ABIs: armeabi-v7a, arm64-v8a, x86, x86_64.

Member Function Documentation

void captureImage ( )
protected
Class<? extends Activity> getCaptureActivityClass ( )

Gets the specific capture activity for this workflow. unused

Returns
null
String getDefaultProcessingString ( CreditCardParameters parameters )

Gets the specific processing string for this workflow. unused

Returns
null
CaptureData getDefaultReturnObject ( )

Retreives an empty credit card object

Returns
CreditCard
String getExceptionKey ( )

Gets the specific exception key for this workflow

Returns
CREDIT_CARD_EXCEPTION
Class<? extends Activity> getExtractActivityClass ( )

Gets the specific extract activity for this workflow. unused

Returns
null
CreditCardParameters getParametersInstance ( )
String getParametersKey ( )

Gets the specific parameter key for this workflow

Returns
CREDIT_CARD_PARAMETERS
String getResultKey ( )

Gets the specific result key for this workflow

Returns
CREDIT_CARD_RESULTS
void onActivityResult | ( | int | requestCode,
 |  | int | resultCode,
 |  | Intent | data
 | ) |  |
protected
void onCreate ( Bundle savedInstanceState )
protected

Member Data Documentation

final String CREDIT_CARD_EXCEPTION = "_com.kofax.mobile.sdk.capture._credit_card_exception_"
static
final String CREDIT_CARD_PARAMETERS = "_com.kofax.mobile.sdk.capture._credit_card_parameters_"
static
final String CREDIT_CARD_RESULTS = "_com.kofax.mobile.sdk.capture._credit_card_results_"
static
The documentation for this class was generated from the following file:
  • CreditCardWorkflowActivity.java


Kofax Mobile SDK API Reference: ExceptionResponse Interface Reference

  • mobile
  • sdk
  • capture
  • extraction
  • ExceptionResponse
Public Member Functions | List of all members
ExceptionResponse Interface Reference
Inheritance diagram for ExceptionResponse:
ExceptionResponseImpl

Public Member Functions

String | exceptionMessage ()
String | exceptionType ()
String | message ()
String | stackTrace ()
ExceptionResponse innerException ()

Detailed Description

Serializable response from capture workflows when an exception occurs during extraction

Member Function Documentation

String exceptionMessage ( )

The exception message from the extraction transport

Returns

Implemented in ExceptionResponseImpl.

String exceptionType ( )

The type of the exception

Returns

Implemented in ExceptionResponseImpl.

ExceptionResponse innerException ( )

The inner exception, may be null.

Returns

Implemented in ExceptionResponseImpl.

String message ( )

The message from the server

Returns

Implemented in ExceptionResponseImpl.

String stackTrace ( )

The stack trace from the server

Returns

Implemented in ExceptionResponseImpl.

The documentation for this interface was generated from the following file:
  • ExceptionResponse.java


Kofax Mobile SDK API Reference: ExceptionResponseImpl Class Reference

  • mobile
  • sdk
  • capture
  • extraction
  • ExceptionResponseImpl
Public Member Functions | List of all members
ExceptionResponseImpl Class Reference
Inheritance diagram for ExceptionResponseImpl:
ExceptionResponse

Public Member Functions

ExceptionResponseImpl (Throwable t)
String | exceptionMessage ()
String | exceptionType ()
String | message ()
String | stackTrace ()
ExceptionResponse innerException ()

Detailed Description

Implementation of ExceptionResponse class to allow for object instance.

Constructor & Destructor Documentation

ExceptionResponseImpl ( Throwable t )

Member Function Documentation

String exceptionMessage ( )

The exception message from the extraction transport

Returns

Implements ExceptionResponse.

String exceptionType ( )

The type of the exception

Returns

Implements ExceptionResponse.

ExceptionResponse innerException ( )

The inner exception, may be null.

Returns

Implements ExceptionResponse.

String message ( )

The message from the server

Returns

Implements ExceptionResponse.

String stackTrace ( )

The stack trace from the server

Returns

Implements ExceptionResponse.

The documentation for this class was generated from the following file:
  • ExceptionResponseImpl.java


Kofax Mobile SDK API Reference: Extractor< T extends Serializable > Class Template Reference

  • mobile
  • sdk
  • capture
  • extraction
  • Extractor
Public Member Functions | Protected Member Functions | List of all members
Extractor< T extends Serializable > Class Template Referenceabstract
Inheritance diagram for Extractor< T extends Serializable >:
BillExtractor CheckExtractor IdExtractor PassportExtractor

Public Member Functions

Extractor ()
void | setExtractionServer (IExtractionServer extractionServer)
void | setResultDeserializer (IDeserializer< T > resultDeserializer)
void | setExceptionResponseDeserializer (IExceptionResponseDeserializer exceptionResponseDeserializer)
void | setParameters (ExtractionParameters parameters)
void | setExtractorListener (IExtractorListener listener)
void | setCertificateValidatorListener (CertificateValidatorListener certificateValidatorListener)
void | extract (Image...images)
void | onExtractionComplete (DataUnit unit)

Protected Member Functions

abstract ExtractorResponse< T > | createResponse (T results, ExceptionResponse exceptionResponse)
abstract String | getDefaultServerUrl (ExtractionParameters.ExtractionType extractionType)

Detailed Description

Base extractor implementation.

Parameters
<T>

Constructor & Destructor Documentation

Extractor ( )

Member Function Documentation

abstract ExtractorResponse<T> createResponse | ( | T | results,
 |  | ExceptionResponse | exceptionResponse
 | ) |  |
abstractprotected
void extract ( Image... images )
abstract String getDefaultServerUrl ( ExtractionParameters.ExtractionType extractionType )
abstractprotected
void onExtractionComplete ( DataUnit unit )

Called when a DataUnit is finished processing

Parameters
unit
void setCertificateValidatorListener ( CertificateValidatorListener certificateValidatorListener )
void setExceptionResponseDeserializer ( IExceptionResponseDeserializer exceptionResponseDeserializer )

Set the deserializer for exception responses

Parameters
exceptionResponseDeserializer
void setExtractionServer ( IExtractionServer extractionServer )

Set the extraction server implementation

Parameters
extractionServer
void setExtractorListener ( IExtractorListener listener )

Set the asynchronous listener for extraction results

Parameters
listener
void setParameters ( ExtractionParameters parameters )

Set the parameters for extraction

Parameters
parameters
void setResultDeserializer ( IDeserializer< T > resultDeserializer )

Set the deserializer for responses

Parameters
resultDeserializer
The documentation for this class was generated from the following file:
  • Extractor.java


Kofax Mobile SDK API Reference: ExtractorResponse< T extends Serializable > Class Template Reference

  • mobile
  • sdk
  • capture
  • extraction
  • ExtractorResponse
Public Attributes | List of all members
ExtractorResponse< T extends Serializable > Class Template Reference
Inheritance diagram for ExtractorResponse< T extends Serializable >:
BillExtractorResponse CheckExtractorResponse IdExtractorResponse PassportExtractorResponse

Public Attributes

T results
ExceptionResponse exceptionResponse

Member Data Documentation

ExceptionResponse exceptionResponse
T results
The documentation for this class was generated from the following file:
  • ExtractorResponse.java


Kofax Mobile SDK API Reference: IExtractorListener< T extends ExtractorResponse > Interface Template Reference

  • mobile
  • sdk
  • capture
  • extraction
  • IExtractorListener
Public Member Functions | List of all members
IExtractorListener< T extends ExtractorResponse > Interface Template Reference
Inheritance diagram for IExtractorListener< T extends ExtractorResponse >:
IBillExtractorListener ICheckExtractorListener ExtractActivity< T extends ExtractorResponse > IIdExtractorListener IPassportExtractorListener BillExtractActivity CheckExtractActivity IdExtractActivity PassportExtractActivity

Public Member Functions

void onExtractionComplete (T results)

Detailed Description

The interface for a listener of extraction results

Parameters
<T>

Member Function Documentation

void onExtractionComplete ( T results )

Implemented in ExtractActivity< T extends ExtractorResponse >.

The documentation for this interface was generated from the following file:
  • IExtractorListener.java


Kofax Mobile SDK API Reference: ConventionBasedJsonIdDeserializer Class Reference

  • mobile
  • sdk
  • capture
  • id
  • ConventionBasedJsonIdDeserializer
Public Member Functions | List of all members
ConventionBasedJsonIdDeserializer Class Reference
Inheritance diagram for ConventionBasedJsonIdDeserializer:
Id CaptureData

Public Member Functions

ConventionBasedJsonIdDeserializer (IIdFieldNameConvention convention, IJsonExactionHelper helper, IBase64ImageDecoder base64ImageDecoder, String json)
String | getRawData ()
void | setJson (String json)
Field< String > | getDocumentType ()
Field< String > | getFirstName ()
Field< String > | getMiddleName ()
Field< String > | getLastName ()
Field< String > | getIdNumber ()
Field< String > | getDateOfBirth ()
Field< String > | getAddress ()
Field< String > | getGender ()
Field< String > | getZip ()
Field< String > | getState ()
Field< String > | getCity ()
Field< String > | getNameSuffix ()
Field< String > | getAddress2 ()
Field< String > | getAddress3 ()
Field< String > | getAddress4 ()
Field< String > | getAddress5 ()
Field< String > | getAddress6 ()
Field< String > | getIdClass ()
Field< String > | getCountryShort ()
Field< String > | getCountry ()
Field< String > | getExpirationDate ()
Field< String > | getEyes ()
Field< String > | getHair ()
Field< String > | getHeight ()
Field< String > | getIssueDate ()
Field< String > | getNationality ()
Field< String > | getWeight ()
Field< String > | getLicense ()
Field< String > | isBarcodeRead ()
Field< String > | isOcrRead ()
Field< String > | getDocumentVerificationConfidenceRating ()
Bitmap | getSignatureImage ()
Bitmap | getFaceImage ()
- Public Member Functions inherited from Id
abstract Field< String > | getFirstName ()
abstract Field< String > | getMiddleName ()
abstract Field< String > | getLastName ()
abstract Field< String > | getIdNumber ()
abstract Field< String > | getDateOfBirth ()
abstract Field< String > | getAddress ()
abstract Field< String > | getGender ()
abstract Field< String > | getZip ()
abstract Field< String > | getState ()
abstract Field< String > | getCity ()
abstract Field< String > | getNameSuffix ()
abstract Field< String > | getAddress2 ()
abstract Field< String > | getAddress3 ()
abstract Field< String > | getAddress4 ()
abstract Field< String > | getAddress5 ()
abstract Field< String > | getAddress6 ()
abstract Field< String > | getIdClass ()
abstract Field< String > | getCountryShort ()
abstract Field< String > | getCountry ()
abstract Field< String > | getExpirationDate ()
abstract Field< String > | getEyes ()
abstract Field< String > | getHair ()
abstract Field< String > | getHeight ()
abstract Field< String > | getIssueDate ()
abstract Field< String > | getNationality ()
abstract Field< String > | getWeight ()
abstract Field< String > | getLicense ()
abstract Field< String > | isBarcodeRead ()
abstract Field< String > | isOcrRead ()
abstract Field< String > | getDocumentVerificationConfidenceRating ()
abstract Bitmap | getSignatureImage ()
abstract Bitmap | getFaceImage ()
Field< String > | getDocumentType ()
Field< String > | getDocumentState ()
abstract String | getRawData ()

Additional Inherited Members

- Public Attributes inherited from CaptureData
String | capturedImageId = ""
String | processedImageId = ""

Constructor & Destructor Documentation

ConventionBasedJsonIdDeserializer | ( | IIdFieldNameConvention | convention,
 |  | IJsonExactionHelper | helper,
 |  | IBase64ImageDecoder | base64ImageDecoder,
 |  | String | json
 | ) |  |

Member Function Documentation

Field<String> getAddress ( )
Field<String> getAddress2 ( )
Field<String> getAddress3 ( )
Field<String> getAddress4 ( )
Field<String> getAddress5 ( )
Field<String> getAddress6 ( )
Field<String> getCity ( )
Field<String> getCountry ( )
Field<String> getCountryShort ( )
Field<String> getDateOfBirth ( )
Field<String> getDocumentType ( )
Field<String> getDocumentVerificationConfidenceRating ( )
Field<String> getExpirationDate ( )
Field<String> getEyes ( )
Bitmap getFaceImage ( )
Field<String> getFirstName ( )
Field<String> getGender ( )
Field<String> getHair ( )
Field<String> getHeight ( )
Field<String> getIdClass ( )
Field<String> getIdNumber ( )
Field<String> getIssueDate ( )
Field<String> getLastName ( )
Field<String> getLicense ( )
Field<String> getMiddleName ( )
Field<String> getNameSuffix ( )
Field<String> getNationality ( )
String getRawData ( )
Bitmap getSignatureImage ( )
Field<String> getState ( )
Field<String> getWeight ( )
Field<String> getZip ( )
Field<String> isBarcodeRead ( )
Field<String> isOcrRead ( )
void setJson ( String json )
The documentation for this class was generated from the following file:
  • id/ConventionBasedJsonIdDeserializer.java


Kofax Mobile SDK API Reference: IdCaptureActivity Class Reference

  • mobile
  • sdk
  • capture
  • id
  • IdCaptureActivity
Protected Member Functions | List of all members
IdCaptureActivity Class Reference
Inheritance diagram for IdCaptureActivity:
CaptureActivity

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
void | setCaptureCriteria (CaptureCriteria criteria)
- Protected Member Functions inherited from CaptureActivity
void | onCreate (Bundle savedInstanceState)
void | setCaptureCriteria (CaptureCriteria criteria)
void | onResume ()
void | onPause ()
ICameraView | getCameraView ()
void | setupCameraView (ViewGroup container)
void | setupButtonBarView (LinearLayout mainView)
void | onSaveInstanceState (Bundle outState)
void | initController (IOverlayView view, IDetectionAdapter detectorAdapter)
void | saveResultAndFinish (Image image, Bundle bundle)
void | onActivityResult (int requestCode, int resultCode, Intent data)

Additional Inherited Members

- Public Member Functions inherited from CaptureActivity
void | finish ()
void | onExitButtonClick ()
void | onForceCaptureButtonClick ()
void | onGalleryButtonClick ()
void | onTorchChange (boolean checked)
- Static Public Attributes inherited from CaptureActivity
static final String | RESULT_CODE = "__result_code__"
static final int | IMAGE_CAPTURED = -42
static final int | NO_IMAGE_CAPTURED = -1

Member Function Documentation

void onCreate ( Bundle savedInstanceState )
protected
void setCaptureCriteria ( CaptureCriteria criteria )
protected
The documentation for this class was generated from the following file:
  • IdCaptureActivity.java


Kofax Mobile SDK API Reference: IdCaptureBackActivity Class Reference

  • mobile
  • sdk
  • capture
  • id
  • IdCaptureBackActivity
Protected Member Functions | List of all members
IdCaptureBackActivity Class Reference
Inheritance diagram for IdCaptureBackActivity:
CaptureActivity

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
ICameraView | getCameraView ()
void | setupButtonBarView (LinearLayout mainView)
void | setupCameraView (ViewGroup container)
- Protected Member Functions inherited from CaptureActivity
void | onCreate (Bundle savedInstanceState)
void | setCaptureCriteria (CaptureCriteria criteria)
void | onResume ()
void | onPause ()
ICameraView | getCameraView ()
void | setupCameraView (ViewGroup container)
void | setupButtonBarView (LinearLayout mainView)
void | onSaveInstanceState (Bundle outState)
void | initController (IOverlayView view, IDetectionAdapter detectorAdapter)
void | saveResultAndFinish (Image image, Bundle bundle)
void | onActivityResult (int requestCode, int resultCode, Intent data)

Additional Inherited Members

- Public Member Functions inherited from CaptureActivity
void | finish ()
void | onExitButtonClick ()
void | onForceCaptureButtonClick ()
void | onGalleryButtonClick ()
void | onTorchChange (boolean checked)
- Static Public Attributes inherited from CaptureActivity
static final String | RESULT_CODE = "__result_code__"
static final int | IMAGE_CAPTURED = -42
static final int | NO_IMAGE_CAPTURED = -1

Member Function Documentation

ICameraView getCameraView ( )
protected
void onCreate ( Bundle savedInstanceState )
protected
void setupButtonBarView ( LinearLayout mainView )
protected
void setupCameraView ( ViewGroup container )
protected
The documentation for this class was generated from the following file:
  • IdCaptureBackActivity.java


Kofax Mobile SDK API Reference: IdExtractActivity Class Reference

  • mobile
  • sdk
  • capture
  • id
  • IdExtractActivity
Protected Member Functions | List of all members
IdExtractActivity Class Reference
Inheritance diagram for IdExtractActivity:
ExtractActivity< T extends ExtractorResponse > IExtractorListener< T extends ExtractorResponse >

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
Image | getImageByBitmapId (String id)
void | extract (Image image)
- Protected Member Functions inherited from ExtractActivity< T extends ExtractorResponse >
void | onCreate (Bundle savedInstanceState)
synchronized void | onResume ()
Image | getImageByBitmapId (String id)
void | onSaveInstanceState (Bundle outState)
void | extract (Image image)

Additional Inherited Members

- Public Member Functions inherited from ExtractActivity< T extends ExtractorResponse >
void | onExtractionComplete (T results)
void | setExtract (Extractor extractor)
- Static Public Attributes inherited from ExtractActivity< T extends ExtractorResponse >
static final String | CERTIFICATE_VALIDATOR_LISTENER
- Protected Attributes inherited from ExtractActivity< T extends ExtractorResponse >
Extractor< T > | _extractor

Member Function Documentation

void extract ( Image image )
protected
Image getImageByBitmapId ( String id )
protected
void onCreate ( Bundle savedInstanceState )
protected
The documentation for this class was generated from the following file:
  • IdExtractActivity.java


Kofax Mobile SDK API Reference: IdExtractor Class Reference

  • mobile
  • sdk
  • capture
  • id
  • IdExtractor
Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
IdExtractor Class Reference
Inheritance diagram for IdExtractor:
Extractor< T extends Serializable >

Public Member Functions

IdExtractor ()
void | setParameters (IdParameters parameters)
- Public Member Functions inherited from Extractor< T extends Serializable >
Extractor ()
void | setExtractionServer (IExtractionServer extractionServer)
void | setResultDeserializer (IDeserializer< T > resultDeserializer)
void | setExceptionResponseDeserializer (IExceptionResponseDeserializer exceptionResponseDeserializer)
void | setParameters (ExtractionParameters parameters)
void | setExtractorListener (IExtractorListener listener)
void | setCertificateValidatorListener (CertificateValidatorListener certificateValidatorListener)
void | extract (Image...images)
void | onExtractionComplete (DataUnit unit)

Static Public Attributes

static final String | ID_EXTRACT_RTTI = "_id_extract_rtti_"
static final String | ID_EXTRACT_KTA = "_id_extract_kta_"
static final String | ID_EXTRACT_ON_DEVICE = "_id_extract_on_device_"

Protected Member Functions

ExtractorResponse< Id > | createResponse (Id results, ExceptionResponse exceptionResponse)
String | getDefaultServerUrl (ExtractionParameters.ExtractionType extractionType)
- Protected Member Functions inherited from Extractor< T extends Serializable >
abstract ExtractorResponse< T > | createResponse (T results, ExceptionResponse exceptionResponse)
abstract String | getDefaultServerUrl (ExtractionParameters.ExtractionType extractionType)

Constructor & Destructor Documentation

IdExtractor ( )

Member Function Documentation

ExtractorResponse<Id> createResponse | ( | Id | results,
 |  | ExceptionResponse | exceptionResponse
 | ) |  |
protected
String getDefaultServerUrl ( ExtractionParameters.ExtractionType extractionType )
protected
void setParameters ( IdParameters parameters )

Member Data Documentation

final String ID_EXTRACT_KTA = "_id_extract_kta_"
static
final String ID_EXTRACT_ON_DEVICE = "_id_extract_on_device_"
static
final String ID_EXTRACT_RTTI = "_id_extract_rtti_"
static
The documentation for this class was generated from the following file:
  • IdExtractor.java


Kofax Mobile SDK API Reference: IdExtractorResponse Class Reference

  • mobile
  • sdk
  • capture
  • id
  • IdExtractorResponse
Public Member Functions | List of all members
IdExtractorResponse Class Reference
Inheritance diagram for IdExtractorResponse:
ExtractorResponse< T extends Serializable >

Public Member Functions

IdExtractorResponse (Id result, ExceptionResponse exception)

Additional Inherited Members

- Public Attributes inherited from ExtractorResponse< T extends Serializable >
T results
ExceptionResponse exceptionResponse

Constructor & Destructor Documentation

IdExtractorResponse | ( | Id | result,
 |  | ExceptionResponse | exception
 | ) |  |
The documentation for this class was generated from the following file:
  • IdExtractorResponse.java


Kofax Mobile SDK API Reference: IdParameters Class Reference

  • mobile
  • sdk
  • capture
  • id
  • IdParameters
Classes | Public Member Functions | Public Attributes | List of all members
IdParameters Class Reference
Inheritance diagram for IdParameters:
IParameters

Classes

enum | IdSide
enum | IdState

Public Member Functions

IdParameters (Context context)
ProcessingParameters getProcessingParameters ()
ExtractionParameters getExtractionParameters ()
LookAndFeelParameters getLookAndFeelParameters ()

Public Attributes

IdSide side = IdSide.FRONT
Id reverseSideId
String barcode
IdState state = IdState.NOT_SPECIFIED

Constructor & Destructor Documentation

IdParameters ( Context context )

Member Function Documentation

ExtractionParameters getExtractionParameters ( )

ExtractionParameters getter

See also
ExtractionParameters

Implements IParameters.

LookAndFeelParameters getLookAndFeelParameters ( )

LookAndFeelParameters getter

See also
LookAndFeelParameters

Implements IParameters.

ProcessingParameters getProcessingParameters ( )

ProcessingParameters getter

Default values for following parameters are differ with base class:

  • useTargetFrameCrop is true.
See also
ProcessingParameters

Implements IParameters.

Member Data Documentation

String barcode

The barcode string will be sent to extraction along with the image for front side of the ID. The barcode string supposed to be used in case of capturing both sides of the ID.

Id reverseSideId

Data for another side of the ID. This data will be used for extraction along with the image for the current side of the ID. The field supposed to be used in case of capturing both sides of the ID.

See also
Id
IdSide side = IdSide.FRONT
IdState state = IdState.NOT_SPECIFIED

This value is used for the extraction. Specify one of the available values from IdState enum.

The documentation for this class was generated from the following file:
  • IdParameters.java


Kofax Mobile SDK API Reference: IdParameters.IdSide Enum Reference

  • mobile
  • sdk
  • capture
  • id
  • IdParameters
  • IdSide
Public Attributes | List of all members
IdParameters.IdSide Enum Reference

Public Attributes

FRONT
BACK

Member Data Documentation

BACK
FRONT
The documentation for this enum was generated from the following file:
  • IdParameters.java


Kofax Mobile SDK API Reference: IdParameters.IdState Enum Reference

  • mobile
  • sdk
  • capture
  • id
  • IdParameters
  • IdState
Public Member Functions | Public Attributes | List of all members
IdParameters.IdState Enum Reference

Public Member Functions

IdState (IdRegion region)

Public Attributes

NOT_SPECIFIED =(null)
UNITED_STATES =(IdRegion.US)
CANADA =(IdRegion.CANADA)
CAMEROON =(IdRegion.AFRICA)
AFRICA_OTHER =(IdRegion.AFRICA)
CHINA =(IdRegion.ASIA)
INDIA =(IdRegion.ASIA)
SINGAPORE =(IdRegion.ASIA)
SOUTH_KOREA =(IdRegion.ASIA)
JAPAN =(IdRegion.ASIA)
ASIA_OTHER =(IdRegion.ASIA)
KEY_PASS =(IdRegion.AUSTRALIA)
AUSTRALIA_OTHER =(IdRegion.AUSTRALIA)
ALBANIA =(IdRegion.EUROPE)
GERMANY =(IdRegion.EUROPE)
LITHUANIA =(IdRegion.EUROPE)
LUXEMBOURG =(IdRegion.EUROPE)
EUROPE_OTHER =(IdRegion.EUROPE)
BRAZIL =(IdRegion.LATIN_AMERICA)
ECUADOR =(IdRegion.LATIN_AMERICA)
EL_SALVADOR =(IdRegion.LATIN_AMERICA)
GUATEMALA =(IdRegion.LATIN_AMERICA)
ST_CHRIST_NEVIS =(IdRegion.LATIN_AMERICA)
LATIN_AMERICA_OTHER =(IdRegion.LATIN_AMERICA)
final IdRegion region

Constructor & Destructor Documentation

IdState ( IdRegion region )

Member Data Documentation

AFRICA_OTHER =(IdRegion.AFRICA)
ALBANIA =(IdRegion.EUROPE)
ASIA_OTHER =(IdRegion.ASIA)
AUSTRALIA_OTHER =(IdRegion.AUSTRALIA)
BRAZIL =(IdRegion.LATIN_AMERICA)
CAMEROON =(IdRegion.AFRICA)
CANADA =(IdRegion.CANADA)
CHINA =(IdRegion.ASIA)
ECUADOR =(IdRegion.LATIN_AMERICA)
EL_SALVADOR =(IdRegion.LATIN_AMERICA)
EUROPE_OTHER =(IdRegion.EUROPE)
GERMANY =(IdRegion.EUROPE)
GUATEMALA =(IdRegion.LATIN_AMERICA)
INDIA =(IdRegion.ASIA)
JAPAN =(IdRegion.ASIA)
KEY_PASS =(IdRegion.AUSTRALIA)
LATIN_AMERICA_OTHER =(IdRegion.LATIN_AMERICA)
LITHUANIA =(IdRegion.EUROPE)
LUXEMBOURG =(IdRegion.EUROPE)
NOT_SPECIFIED =(null)
final IdRegion region
SINGAPORE =(IdRegion.ASIA)
SOUTH_KOREA =(IdRegion.ASIA)
ST_CHRIST_NEVIS =(IdRegion.LATIN_AMERICA)
UNITED_STATES =(IdRegion.US)
The documentation for this enum was generated from the following file:
  • IdParameters.java


Kofax Mobile SDK API Reference: IdWorkflowActivity Class Reference

  • mobile
  • sdk
  • capture
  • id
  • IdWorkflowActivity
Classes | Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
IdWorkflowActivity Class Reference
Inheritance diagram for IdWorkflowActivity:
WorkflowActivity< T extends IParameters >

Public Member Functions

Class<?extends Activity > | getCaptureActivityClass ()
Class<?extends Activity > | getExtractActivityClass ()
String | getDefaultProcessingString (IdParameters parameters)
CaptureData getDefaultReturnObject ()
String | getParametersKey ()
String | getResultKey ()
String | getExceptionKey ()
IdParameters getParametersInstance ()
- Public Member Functions inherited from WorkflowActivity< T extends IParameters >
abstract Class<?extends Activity > | getCaptureActivityClass ()
abstract Class<?extends Activity > | getExtractActivityClass ()
abstract String | getDefaultProcessingString (T parameters)
abstract CaptureData | getDefaultReturnObject ()
abstract String | getParametersKey ()
abstract String | getResultKey ()
abstract String | getExceptionKey ()
abstract T | getParametersInstance ()
T | getParameters (Bundle savedInstanceState)

Static Public Attributes

static final String | ID_PARAMETERS = "_com.kofax.mobile.sdk.capture._id_parameters_"
static final String | ID_RESULTS = "_com.kofax.mobile.sdk.capture._id_results_"
static final String | ID_BARCODE_RESULTS = "_com.kofax.mobile.sdk.capture._id_barcode_results_"
static final String | ID_EXCEPTION = "_com.kofax.mobile.sdk.capture._id_exception_"
- Static Public Attributes inherited from WorkflowActivity< T extends IParameters >
static final String | CERTIFICATE_VALIDATOR_LISTENER

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
boolean | isOdeSupported ()
void | onActivityResult (int requestCode, int resultCode, Intent data)
- Protected Member Functions inherited from WorkflowActivity< T extends IParameters >
boolean | isOdeSupported ()
void | onCreate (Bundle savedInstanceState)
void | handleException (final Throwable exc)
void | tryRestoreState (Bundle savedInstanceState)
void | onSaveInstanceState (Bundle outState)
void | onDestroy ()
void | onResume ()
void | captureImage ()
void | onActivityResult (int requestCode, int resultCode, Intent data)
void | clearBitmap (String imageId)

Detailed Description

The Id workflow specializes in capturing, processing and extracting data from an Id. To use this class, optionally construct new IdParameters, modify those parameters for your use, then start an intent for this workflow:

IdParameters _params = new IdParameters(this);

Intent intent = new Intent(this, IdWorkflowActivity.class);

_params.getLookAndFeelParameters().forceCaptureEnabled = true;

_params.getLookAndFeelParameters().galleryEnabled = true;

intent.putExtra(IdWorkflowActivity.ID_PARAMETERS, _params);

startActivityForResult(intent, REQUEST_CODE);

The reverse-side capture activity will capture a PDF417 barcode. You can retrieve the data extracted from the barcode from the return data:

protected void onActivityResult(int requestCode, int resultCode, Intent data) {

     if (data.hasExtra(IdWorkflowActivity.ID_BARCODE_RESULTS) {

         // Retrieve barcode data

         String barcodeData = data.getStringExtra(IdWorkflowActivity.ID_BARCODE_RESULTS);

         // ...

     }

}

Capturing both sides of an Id

Ids have important information on both sides. For improved accuracy, data extraction should be performed for both sides during the same session. To achieve that follow these steps:

  1. Start the IdWorkflowActivity for one side with call of setExtractionType (ExtractionType.OFF).
  2. Receive and store the Id data available in the result Intent when Activity.onActivityResult gets called back.
  3. Start the IdWorkflowActivity for the other side of the Id with extraction enabled and IdWorkflowActivity.reverseSideId set to the Id data from the step 2.

New permissions model introduced in Android M

Some functions won't be available until necessary permissions are granted by the user. It's up to the developer when to ask for permissions and whether or not to show a rationale — SDK doesn't do that.

Functions that require permissions:

  • Capture requires CAMERA permission.
  • Adding location data to captured images requires ACCESS_FINE_LOCATION permission.
  • The gallery button requires READ_EXTERNAL_STORAGE permission.

Member Function Documentation

Class<? extends Activity> getCaptureActivityClass ( )

Gets the specific capture activity for this workflow

Returns
IdCaptureActivity or IdCaptureBackActivity depending on parameters
String getDefaultProcessingString ( IdParameters parameters )

Gets the specific processing string for this workflow

CaptureData getDefaultReturnObject ( )

Retrieves an empty ID object

Returns
Id
String getExceptionKey ( )

Gets the specific exception key for this workflow

Returns
ID_EXCEPTION
Class<? extends Activity> getExtractActivityClass ( )

Gets the specific extract activity for this workflow

Returns
IdExtractActivity
IdParameters getParametersInstance ( )
String getParametersKey ( )

Gets the specific parameter key for this workflow

Returns
ID_PARAMETERS
String getResultKey ( )

Gets the specific result key for this workflow

Returns
ID_RESULTS
boolean isOdeSupported ( )
protected
void onActivityResult | ( | int | requestCode,
 |  | int | resultCode,
 |  | Intent | data
 | ) |  |
protected
void onCreate ( Bundle savedInstanceState )
protected

Member Data Documentation

final String ID_BARCODE_RESULTS = "_com.kofax.mobile.sdk.capture._id_barcode_results_"
static
final String ID_EXCEPTION = "_com.kofax.mobile.sdk.capture._id_exception_"
static
final String ID_PARAMETERS = "_com.kofax.mobile.sdk.capture._id_parameters_"
static
final String ID_RESULTS = "_com.kofax.mobile.sdk.capture._id_results_"
static
The documentation for this class was generated from the following file:
  • IdWorkflowActivity.java


Kofax Mobile SDK API Reference: IIdDeserializer Interface Reference

  • mobile
  • sdk
  • capture
  • id
  • IIdDeserializer
IIdDeserializer Interface Reference
Inheritance diagram for IIdDeserializer:
The documentation for this interface was generated from the following file:
  • IIdDeserializer.java


Kofax Mobile SDK API Reference: IIdExtractionServer Interface Reference

  • mobile
  • sdk
  • capture
  • id
  • IIdExtractionServer
Public Member Functions | List of all members
IIdExtractionServer Interface Reference
Inheritance diagram for IIdExtractionServer:
KtaIdExtractor RttiIdExtractor

Public Member Functions

void setIdParameters (IdParameters parameters)

Member Function Documentation

void setIdParameters ( IdParameters parameters )

Implemented in KtaIdExtractor, and RttiIdExtractor.

The documentation for this interface was generated from the following file:
  • IIdExtractionServer.java


Kofax Mobile SDK API Reference: IIdExtractorListener Interface Reference

  • mobile
  • sdk
  • capture
  • id
  • IIdExtractorListener
List of all members
IIdExtractorListener Interface Reference
Inheritance diagram for IIdExtractorListener:
IExtractorListener< T extends ExtractorResponse >

Additional Inherited Members

- Public Member Functions inherited from IExtractorListener< T extends ExtractorResponse >
void onExtractionComplete (T results)
The documentation for this interface was generated from the following file:
  • IIdExtractorListener.java


Kofax Mobile SDK API Reference: KtaIdExtractor Class Reference

  • mobile
  • sdk
  • capture
  • id
  • KtaIdExtractor
Public Member Functions | Protected Member Functions | List of all members
KtaIdExtractor Class Reference
Inheritance diagram for KtaIdExtractor:
IIdExtractionServer

Public Member Functions

KtaIdExtractor (IKtaSessionIdProviderFactory sessionIdProviderFactory, IImageToByteArray converter)
String | getProcessName ()
void | setIdParameters (IdParameters parameters)
void | extract (DataUnit unit, IDataUnitProcessedListener listener)

Protected Member Functions

void updateKTARequest (JobService jobService)

Constructor & Destructor Documentation

KtaIdExtractor | ( | IKtaSessionIdProviderFactory | sessionIdProviderFactory,
 |  | IImageToByteArray | converter
 | ) |  |

Member Function Documentation

void extract | ( | DataUnit | unit,
 |  | IDataUnitProcessedListener | listener
 | ) |  |
String getProcessName ( )
void setIdParameters ( IdParameters parameters )

Implements IIdExtractionServer.

void updateKTARequest ( JobService jobService )
protected
The documentation for this class was generated from the following file:
  • KtaIdExtractor.java


Kofax Mobile SDK API Reference: RttiIdExtractor Class Reference

  • mobile
  • sdk
  • capture
  • id
  • RttiIdExtractor
Public Member Functions | Protected Member Functions | List of all members
RttiIdExtractor Class Reference
Inheritance diagram for RttiIdExtractor:
IIdExtractionServer

Public Member Functions

RttiIdExtractor (IImageToByteArray converter)
void | setIdParameters (IdParameters parameters)
void | extract (DataUnit unit, IDataUnitProcessedListener listener)

Protected Member Functions

void updateRttiRequest (RttiRequest rttiRequest)

Constructor & Destructor Documentation

RttiIdExtractor ( IImageToByteArray converter )

Member Function Documentation

void extract | ( | DataUnit | unit,
 |  | IDataUnitProcessedListener | listener
 | ) |  |
void setIdParameters ( IdParameters parameters )

Implements IIdExtractionServer.

void updateRttiRequest ( RttiRequest rttiRequest )
protected
The documentation for this class was generated from the following file:
  • RttiIdExtractor.java


Kofax Mobile SDK API Reference: Bill Class Reference

  • mobile
  • sdk
  • capture
  • model
  • Bill
Public Member Functions | List of all members
Bill Class Referenceabstract
Inheritance diagram for Bill:
CaptureData KtaJsonBill RttiJsonBill

Public Member Functions

abstract Field | getAmount ()
abstract Field | getDueDate ()
abstract Field | getName ()
abstract Field | getAddressLine1 ()
abstract Field | getAddressLine2 ()
abstract Field | getCity ()
abstract Field | getState ()
abstract Field | getZip ()
abstract Field | getAccountNumber ()
abstract Field | getPhoneNumber ()
abstract Field | getSource ()
abstract Field | getBillers ()
abstract String | getRawData ()

Additional Inherited Members

- Public Attributes inherited from CaptureData
String | capturedImageId = ""
String | processedImageId = ""

Detailed Description

A class containing possible values returned from an extraction server

Member Function Documentation

abstract Field getAccountNumber ( )
abstract

The account number on the bill

abstract Field getAddressLine1 ( )
abstract

The first address line of the biller

abstract Field getAddressLine2 ( )
abstract

The second address line of the biller

abstract Field getAmount ( )
abstract

The amount of the bill

abstract Field getBillers ( )
abstract

Gets all the billers found

abstract Field getCity ( )
abstract

The city of the biller

abstract Field getDueDate ( )
abstract

The due date of the bill

abstract Field getName ( )
abstract

The name on the biller

abstract Field getPhoneNumber ( )
abstract

The phone number of the biller

abstract String getRawData ( )
abstract

The entire raw data

abstract Field getSource ( )
abstract

The biller source

abstract Field getState ( )
abstract

The state of the biller

abstract Field getZip ( )
abstract

The zip code of the biller

The documentation for this class was generated from the following file:
  • Bill.java


Kofax Mobile SDK API Reference: CaptureData Class Reference

  • mobile
  • sdk
  • capture
  • model
  • CaptureData
Public Attributes | List of all members
CaptureData Class Reference
Inheritance diagram for CaptureData:
Bill Check CreditCard Id Passport KtaJsonBill RttiJsonBill KtaJsonCheck RttiJsonCheck ConventionBasedJsonIdDeserializer KtaJsonPassport RttiJsonPassport

Public Attributes

String | capturedImageId = ""
String | processedImageId = ""

Detailed Description

Container class for image IDs used in conjunction with a com.kofax.mobile.sdk.capture.IImageStorage

Member Data Documentation

String capturedImageId = ""

The ID of the captured image

String processedImageId = ""

The ID of the processed image

The documentation for this class was generated from the following file:
  • CaptureData.java


Kofax Mobile SDK API Reference: Check Class Reference

  • mobile
  • sdk
  • capture
  • model
  • Check
Public Member Functions | List of all members
Check Class Referenceabstract
Inheritance diagram for Check:
CaptureData KtaJsonCheck RttiJsonCheck

Public Member Functions

abstract Field< String > | getMicr ()
abstract Field< String > | getAmount ()
abstract Field< String > | getCheckNumber ()
abstract Field< String > | getDate ()
abstract Field< String > | getPayee ()
abstract Field< String > | getUsable ()
abstract Field< String > | getLar ()
abstract Field< String > | getCar ()
abstract Field< String > | getTransit ()
abstract Field< String > | getOnUs1 ()
abstract Field< String > | getOnUs2 ()
abstract Field< String > | getAuxiliaryOnUs ()
abstract Field< String > | getEpc ()
abstract Field< String > | getMicrAmount ()
abstract CheckIQAData | getCheckIQAData ()
abstract CheckUsabilityData | getCheckUsabilityData ()
abstract String | getRawData ()
abstract Field< String > | getRestrictiveEndorsementPresent ()
abstract Field< String > | getRestrictiveEndorsement ()
abstract Field< String > | getReasonForRejection ()

Additional Inherited Members

- Public Attributes inherited from CaptureData
String | capturedImageId = ""
String | processedImageId = ""

Member Function Documentation

abstract Field<String> getAmount ( )
abstract
abstract Field<String> getAuxiliaryOnUs ( )
abstract
abstract Field<String> getCar ( )
abstract
abstract CheckIQAData getCheckIQAData ( )
abstract
abstract Field<String> getCheckNumber ( )
abstract
abstract CheckUsabilityData getCheckUsabilityData ( )
abstract
abstract Field<String> getDate ( )
abstract
abstract Field<String> getEpc ( )
abstract
abstract Field<String> getLar ( )
abstract
abstract Field<String> getMicr ( )
abstract
abstract Field<String> getMicrAmount ( )
abstract
abstract Field<String> getOnUs1 ( )
abstract
abstract Field<String> getOnUs2 ( )
abstract
abstract Field<String> getPayee ( )
abstract
abstract String getRawData ( )
abstract
abstract Field<String> getReasonForRejection ( )
abstract
abstract Field<String> getRestrictiveEndorsement ( )
abstract
abstract Field<String> getRestrictiveEndorsementPresent ( )
abstract
abstract Field<String> getTransit ( )
abstract
abstract Field<String> getUsable ( )
abstract
The documentation for this class was generated from the following file:
  • Check.java


Kofax Mobile SDK API Reference: CheckIQAData Class Reference

  • mobile
  • sdk
  • capture
  • model
  • CheckIQAData
Public Member Functions | List of all members
CheckIQAData Class Referenceabstract
Inheritance diagram for CheckIQAData:

Public Member Functions

abstract Field< String > | getImageWidth ()
abstract Field< String > | getImageHeight ()
abstract Field< String > | getTopLeftCornerWidth ()
abstract Field< String > | getTopLeftCornerHeight ()
abstract Field< String > | getBottomLeftCornerWidth ()
abstract Field< String > | getBottomLeftCornerHeight ()
abstract Field< String > | getTopRightCornerWidth ()
abstract Field< String > | getTopRightCornerHeight ()
abstract Field< String > | getBottomRightCornerWidth ()
abstract Field< String > | getBottomRightCornerHeight ()
abstract Field< String > | getTopEdgeTearWidth ()
abstract Field< String > | getTopEdgeTearHeight ()
abstract Field< String > | getRightEdgeTearWidth ()
abstract Field< String > | getRightEdgeTearHeight ()
abstract Field< String > | getBottomEdgeTearWidth ()
abstract Field< String > | getBottomEdgeTearHeight ()
abstract Field< String > | getLeftEdgeTearWidth ()
abstract Field< String > | getLeftEdgeTearHeight ()
abstract Field< String > | getAdditionalLeftScanLinesWidth ()
abstract Field< String > | getAdditionalTopScanLinesHeight ()
abstract Field< String > | getAdditionalRightScanLinesWidth ()
abstract Field< String > | getAdditionalBottomScanLinesHeight ()
abstract Field< String > | getDocumentSkewAngle ()
abstract Field< String > | getPercentBlackPixels ()
abstract Field< String > | getPercentAverageImageBrightness ()
abstract Field< String > | getPercentAverageImageContrast ()
abstract Field< String > | getBlackStreakCount ()
abstract Field< String > | getBlackStreakMaxHeight ()
abstract Field< String > | getGrayLevelStreakCount ()
abstract Field< String > | getGrayLevelStreakMaxHeight ()
abstract Field< String > | getAverageSpotNoiseGroupingsPerSquareInch ()
abstract Field< String > | getFrontRearWidthDifference ()
abstract Field< String > | getFrontRearHeightDifference ()
abstract Field< String > | getCarbonStripHeight ()
abstract Field< String > | getImageFocusScore ()
abstract Field< String > | getCompressedFrontImageSize ()
abstract Field< String > | getCompressedRearImageSize ()
abstract Field< String > | getUndersizeImage ()
abstract Field< String > | getFoldedOrTornDocumentCorners ()
abstract Field< String > | getFoldedOrTornDocumentEdges ()
abstract Field< String > | getDocumentFramingError ()
abstract Field< String > | getDocumentSkew ()
abstract Field< String > | getOversizeImage ()
abstract Field< String > | getPiggybackDocument ()
abstract Field< String > | getImageTooLight ()
abstract Field< String > | getImageTooDark ()
abstract Field< String > | getHorizontalStreaks ()
abstract Field< String > | getBelowMinFrontImageSize ()
abstract Field< String > | getAboveMaxFrontImageSize ()
abstract Field< String > | getBelowMinRearImageSize ()
abstract Field< String > | getAboveMaxRearImageSize ()
abstract Field< String > | getSpotNoise ()
abstract Field< String > | getImageDimensionMismatch ()
abstract Field< String > | getCarbonStrip ()
abstract Field< String > | getOutOfFocus ()

Detailed Description

Extended IQA data returned from a check extraction server

Member Function Documentation

abstract Field<String> getAboveMaxFrontImageSize ( )
abstract
abstract Field<String> getAboveMaxRearImageSize ( )
abstract
abstract Field<String> getAdditionalBottomScanLinesHeight ( )
abstract
abstract Field<String> getAdditionalLeftScanLinesWidth ( )
abstract
abstract Field<String> getAdditionalRightScanLinesWidth ( )
abstract
abstract Field<String> getAdditionalTopScanLinesHeight ( )
abstract
abstract Field<String> getAverageSpotNoiseGroupingsPerSquareInch ( )
abstract
abstract Field<String> getBelowMinFrontImageSize ( )
abstract
abstract Field<String> getBelowMinRearImageSize ( )
abstract
abstract Field<String> getBlackStreakCount ( )
abstract

Get the number of black streaks

abstract Field<String> getBlackStreakMaxHeight ( )
abstract

Get the largest black streak height

abstract Field<String> getBottomEdgeTearHeight ( )
abstract

The bottom-edge (Y) tear, if any

abstract Field<String> getBottomEdgeTearWidth ( )
abstract

The bottom-edge (X) tear, if any

abstract Field<String> getBottomLeftCornerHeight ( )
abstract

The bottom-left corner (Y) of the check in the image

abstract Field<String> getBottomLeftCornerWidth ( )
abstract

THe bottom-left corner (X) of the check in the image

abstract Field<String> getBottomRightCornerHeight ( )
abstract

The bottom-right corner (Y) of the check in the image

abstract Field<String> getBottomRightCornerWidth ( )
abstract

The bottom-right corner (X) of the check in the image

abstract Field<String> getCarbonStrip ( )
abstract
abstract Field<String> getCarbonStripHeight ( )
abstract
abstract Field<String> getCompressedFrontImageSize ( )
abstract
abstract Field<String> getCompressedRearImageSize ( )
abstract
abstract Field<String> getDocumentFramingError ( )
abstract
abstract Field<String> getDocumentSkew ( )
abstract
abstract Field<String> getDocumentSkewAngle ( )
abstract

The angle of skew of the check in the image

abstract Field<String> getFoldedOrTornDocumentCorners ( )
abstract
abstract Field<String> getFoldedOrTornDocumentEdges ( )
abstract
abstract Field<String> getFrontRearHeightDifference ( )
abstract
abstract Field<String> getFrontRearWidthDifference ( )
abstract
abstract Field<String> getGrayLevelStreakCount ( )
abstract

Get the

Returns
abstract Field<String> getGrayLevelStreakMaxHeight ( )
abstract
abstract Field<String> getHorizontalStreaks ( )
abstract
abstract Field<String> getImageDimensionMismatch ( )
abstract
abstract Field<String> getImageFocusScore ( )
abstract
abstract Field<String> getImageHeight ( )
abstract

The overall image height

abstract Field<String> getImageTooDark ( )
abstract
abstract Field<String> getImageTooLight ( )
abstract
abstract Field<String> getImageWidth ( )
abstract

The overall image width

abstract Field<String> getLeftEdgeTearHeight ( )
abstract

The left-edge (Y) tear, if any

abstract Field<String> getLeftEdgeTearWidth ( )
abstract

The left-edge (X) tear, if any

abstract Field<String> getOutOfFocus ( )
abstract
abstract Field<String> getOversizeImage ( )
abstract
abstract Field<String> getPercentAverageImageBrightness ( )
abstract

Get the average image brightness

abstract Field<String> getPercentAverageImageContrast ( )
abstract

Get the percent average image contrast

abstract Field<String> getPercentBlackPixels ( )
abstract

Get the percent black pixels

abstract Field<String> getPiggybackDocument ( )
abstract
abstract Field<String> getRightEdgeTearHeight ( )
abstract

The right-edge (Y) tear, if any

abstract Field<String> getRightEdgeTearWidth ( )
abstract

The right-edge (X) tear, if any

abstract Field<String> getSpotNoise ( )
abstract
abstract Field<String> getTopEdgeTearHeight ( )
abstract

The top-edge (Y) tear, if any

abstract Field<String> getTopEdgeTearWidth ( )
abstract

The top-edge (X) tear, if any

abstract Field<String> getTopLeftCornerHeight ( )
abstract

the top-left corner (Y) of the check in the image

abstract Field<String> getTopLeftCornerWidth ( )
abstract

The top-left corner (X) of the check in the image

abstract Field<String> getTopRightCornerHeight ( )
abstract

The top-right corner (Y) of the check in the image

abstract Field<String> getTopRightCornerWidth ( )
abstract

The top-right corner (X) of the check in the image

abstract Field<String> getUndersizeImage ( )
abstract
The documentation for this class was generated from the following file:
  • CheckIQAData.java


Kofax Mobile SDK API Reference: CheckUsabilityData Class Reference

  • mobile
  • sdk
  • capture
  • model
  • CheckUsabilityData
Public Member Functions | List of all members
CheckUsabilityData Class Referenceabstract
Inheritance diagram for CheckUsabilityData:

Public Member Functions

abstract Field< String > | getCAR ()
abstract Field< String > | getLAR ()
abstract Field< String > | getSignature ()
abstract Field< String > | gePayeeName ()
abstract Field< String > | getDate ()
abstract Field< String > | getCodeline ()
abstract Field< String > | getPayeeEndorsement ()

Member Function Documentation

abstract Field<String> gePayeeName ( )
abstract
abstract Field<String> getCAR ( )
abstract
abstract Field<String> getCodeline ( )
abstract
abstract Field<String> getDate ( )
abstract
abstract Field<String> getLAR ( )
abstract
abstract Field<String> getPayeeEndorsement ( )
abstract
abstract Field<String> getSignature ( )
abstract
The documentation for this class was generated from the following file:
  • CheckUsabilityData.java


Kofax Mobile SDK API Reference: CreditCard Class Reference

  • mobile
  • sdk
  • capture
  • model
  • CreditCard
Public Member Functions | Static Public Attributes | List of all members
CreditCard Class Reference
Inheritance diagram for CreditCard:
CaptureData

Public Member Functions

CreditCard ()
CreditCard (Parcel in)
String | getName ()
void | setName (String name)
String | getCardNumber ()
void | setCardNumber (String cardNumber)
String | getExpirationMonth ()
void | setExpirationMonth (String expirationMonth)
String | getExpirationYear ()
void | setExpirationYear (String expirationYear)
String | getCvv ()
void | setCvv (String cvv)
int | describeContents ()
void | writeToParcel (Parcel dest, int flags)

Static Public Attributes

static final Parcelable.Creator CREATOR

Additional Inherited Members

- Public Attributes inherited from CaptureData
String | capturedImageId = ""
String | processedImageId = ""

Constructor & Destructor Documentation

CreditCard ( )

Standard basic constructor for non-parcel object creation

CreditCard ( Parcel in )

Constructor to use when re-constructing object from a parcel

Parameters
in a parcel from which to read this object

Member Function Documentation

int describeContents ( )
String getCardNumber ( )

Gets the card number for this CreditCard object. When automatically populated, the card number is 15 or 16 digits with no spaces.

String getCvv ( )

Gets the security code for this CreditCard object. When automatically populated, the security code is a three- or four-character string.

String getExpirationMonth ( )

Gets the expiration month for this CreditCard object. When automatically populated, the expiration month is a two-digit string. This string is empty if expiration month extraction is unsuccessful.

String getExpirationYear ( )

Gets the expiration year for this CreditCard object. When automatically populated, the expiration year is a four-digit string. This string is empty if expiration year extraction is unsuccessful.

String getName ( )

Gets the cardholder name for this CreditCard object.

void setCardNumber ( String cardNumber )

Sets the card number for this CreditCard object.

void setCvv ( String cvv )

Sets the security code for this CreditCard object.

void setExpirationMonth ( String expirationMonth )

Sets the expiration month for this CreditCard object.

void setExpirationYear ( String expirationYear )

Sets the expiration year for this CreditCard object.

void setName ( String name )

Sets the cardholder name for this CreditCard object.

void writeToParcel | ( | Parcel | dest,
 |  | int | flags
 | ) |  |

Member Data Documentation

final Parcelable.Creator CREATOR
static
Initial value:
= new Parcelable.Creator() {
public CreditCard createFromParcel(Parcel in) {
return new CreditCard(in);
}
public CreditCard[] newArray(int size) {
return new CreditCard[size];
}
}

This field is needed for Android to be able to create new objects, individually or as arrays.

The documentation for this class was generated from the following file:
  • CreditCard.java


Kofax Mobile SDK API Reference: Field< T extends Serializable > Class Template Reference

  • mobile
  • sdk
  • capture
  • model
  • Field
Public Member Functions | List of all members
Field< T extends Serializable > Class Template Reference
Inheritance diagram for Field< T extends Serializable >:
DataField

Public Member Functions

Field (String name, T object, double confidence, FieldLocation location)
String | getName ()
double | getConfidence ()
T | getObject ()
FieldLocation getLocation ()
Field< T > | clone ()
String | toString ()
boolean | equals (Object o)
int | hashCode ()

Constructor & Destructor Documentation

Field | ( | String | name,
 |  | T | object,
 |  | double | confidence,
 |  | FieldLocation | location
 | ) |  |

Member Function Documentation

Field<T> clone ( )
boolean equals ( Object o )
double getConfidence ( )

Confidence is based on whether this field object (getObject()) has been verified. Verified objects receive a confidence value of 1 and should be considered a sane value that may be parsed into the desired object type (such as parsing a date); whereas fields that fail verification will receive a confidence of 0, whose object value may not be parsable as the desired type.

If this field did not pass through validation, confidence values may be any value returned by the extraction engine, including negative values.

FieldLocation getLocation ( )
Returns
The location of the field
String getName ( )
Returns
The name of the field
T getObject ( )
Returns
The value of the field
int hashCode ( )
String toString ( )
The documentation for this class was generated from the following file:
  • mobile/sdk/capture/model/Field.java


Kofax Mobile SDK API Reference: FieldLocation Class Reference

  • mobile
  • sdk
  • capture
  • model
  • FieldLocation
Public Member Functions | Public Attributes | Static Public Attributes | List of all members
FieldLocation Class Reference
Inheritance diagram for FieldLocation:

Public Member Functions

FieldLocation (double left, double top, double width, double height)
String toString ()

Public Attributes

final PointDouble | origin
final SizeDouble | size

Static Public Attributes

static final FieldLocation UNDEFINED = new FieldLocation(0d, 0d, 0d, 0d)

Constructor & Destructor Documentation

FieldLocation | ( | double | left,
 |  | double | top,
 |  | double | width,
 |  | double | height
 | ) |  |

Member Function Documentation

String toString ( )

Member Data Documentation

final PointDouble origin
final SizeDouble size
final FieldLocation UNDEFINED = new FieldLocation(0d, 0d, 0d, 0d)
static
The documentation for this class was generated from the following file:
  • FieldLocation.java


Kofax Mobile SDK API Reference: Id Class Reference

  • mobile
  • sdk
  • capture
  • model
  • Id
Public Member Functions | List of all members
Id Class Referenceabstract
Inheritance diagram for Id:
CaptureData ConventionBasedJsonIdDeserializer

Public Member Functions

abstract Field< String > | getFirstName ()
abstract Field< String > | getMiddleName ()
abstract Field< String > | getLastName ()
abstract Field< String > | getIdNumber ()
abstract Field< String > | getDateOfBirth ()
abstract Field< String > | getAddress ()
abstract Field< String > | getGender ()
abstract Field< String > | getZip ()
abstract Field< String > | getState ()
abstract Field< String > | getCity ()
abstract Field< String > | getNameSuffix ()
abstract Field< String > | getAddress2 ()
abstract Field< String > | getAddress3 ()
abstract Field< String > | getAddress4 ()
abstract Field< String > | getAddress5 ()
abstract Field< String > | getAddress6 ()
abstract Field< String > | getIdClass ()
abstract Field< String > | getCountryShort ()
abstract Field< String > | getCountry ()
abstract Field< String > | getExpirationDate ()
abstract Field< String > | getEyes ()
abstract Field< String > | getHair ()
abstract Field< String > | getHeight ()
abstract Field< String > | getIssueDate ()
abstract Field< String > | getNationality ()
abstract Field< String > | getWeight ()
abstract Field< String > | getLicense ()
abstract Field< String > | isBarcodeRead ()
abstract Field< String > | isOcrRead ()
abstract Field< String > | getDocumentVerificationConfidenceRating ()
abstract Bitmap | getSignatureImage ()
abstract Bitmap | getFaceImage ()
Field< String > | getDocumentType ()
Field< String > | getDocumentState ()
abstract String | getRawData ()

Additional Inherited Members

- Public Attributes inherited from CaptureData
String | capturedImageId = ""
String | processedImageId = ""

Detailed Description

Each of these fields returns a platform-dependent and jurisdiction-dependent value. For example getEyes() may return BLU or Blue. The fields will return what the card displays, or what is encoded in a barcode string, depending on what was passed to the extractor.

In some cases, depending on the technology being used (e.g. on-device extraction, or server extraction) the field values may be normalized. Fields such as getGender() may return M where the ID may have Male printed. Please refer to the Kofax Mobile ID Capture Administrator’s Guide for more information.

Member Function Documentation

abstract Field<String> getAddress ( )
abstract
Returns
The persons aggregate address (may contain elements from other address fields, such as getAddress2(), etc)
abstract Field<String> getAddress2 ( )
abstract
Returns
An address part, may be aggregated into getAddress()
abstract Field<String> getAddress3 ( )
abstract
Returns
An address part, may be aggregated into getAddress()
abstract Field<String> getAddress4 ( )
abstract
Returns
An address part, may be aggregated into getAddress()
abstract Field<String> getAddress5 ( )
abstract
Returns
An address part, may be aggregated into getAddress()
abstract Field<String> getAddress6 ( )
abstract
Returns
An address part, may be aggregated into getAddress()
abstract Field<String> getCity ( )
abstract
Returns
The address city
abstract Field<String> getCountry ( )
abstract
Returns
The ID country
abstract Field<String> getCountryShort ( )
abstract
Returns
The ID country abbreviation
abstract Field<String> getDateOfBirth ( )
abstract
Returns
The person's date of birth
Field<String> getDocumentState ( )
Returns
getState()
Field<String> getDocumentType ( )

The document type, e.g. "ID", "DL".

Returns
"ID" by default
abstract Field<String> getDocumentVerificationConfidenceRating ( )
abstract
Returns
The confidence rating
abstract Field<String> getExpirationDate ( )
abstract
Returns
The ID expiration date
abstract Field<String> getEyes ( )
abstract
Returns
The person's eye color
abstract Bitmap getFaceImage ( )
abstract
Returns
The ID image
abstract Field<String> getFirstName ( )
abstract
Returns
The person's first name
abstract Field<String> getGender ( )
abstract
Returns
The person's gender
abstract Field<String> getHair ( )
abstract
Returns
The person's hair color
abstract Field<String> getHeight ( )
abstract
Returns
The person's height
abstract Field<String> getIdClass ( )
abstract
Returns
The ID class
abstract Field<String> getIdNumber ( )
abstract
Returns
The ID number
abstract Field<String> getIssueDate ( )
abstract
Returns
The ID date of issue
abstract Field<String> getLastName ( )
abstract
Returns
The person's last name
abstract Field<String> getLicense ( )
abstract
Returns
The ID number field
abstract Field<String> getMiddleName ( )
abstract
Returns
The person's middle name
abstract Field<String> getNameSuffix ( )
abstract
Returns
The person's name suffix, e.g. Jr., Sr.
abstract Field<String> getNationality ( )
abstract
Returns
The person's nationality
abstract String getRawData ( )
abstract
Returns
The raw data returned from the extractor
abstract Bitmap getSignatureImage ( )
abstract
Returns
The image of the signature area
abstract Field<String> getState ( )
abstract
Returns
The address state
abstract Field<String> getWeight ( )
abstract
Returns
The person's weight
abstract Field<String> getZip ( )
abstract
Returns
The address zip code
abstract Field<String> isBarcodeRead ( )
abstract
Returns
Whether the ID Barcode was read and parsed
abstract Field<String> isOcrRead ( )
abstract
Returns
Whether Optical Character Recognition was used
The documentation for this class was generated from the following file:
  • Id.java


Kofax Mobile SDK API Reference: Passport Class Reference

  • mobile
  • sdk
  • capture
  • model
  • Passport
Public Member Functions | List of all members
Passport Class Referenceabstract
Inheritance diagram for Passport:
CaptureData KtaJsonPassport RttiJsonPassport

Public Member Functions

abstract Field< String > | getFirstName ()
abstract Field< String > | getMiddleName ()
abstract Field< String > | getLastName ()
abstract Field< String > | getDateOfBirth ()
abstract Field< String > | getGender ()
abstract Field< String > | getIssueDate ()
abstract Field< String > | getExpirationDate ()
abstract Field< String > | getPassportNumber ()
abstract Field< String > | getCountry ()
abstract Field< String > | getCountryLong ()
abstract Field< String > | getNationality ()
abstract Field< String > | getPersonalNumber ()
abstract Field< String > | getMRZ1 ()
abstract Field< String > | getMRZ2 ()
abstract String | getRawData ()

Additional Inherited Members

- Public Attributes inherited from CaptureData
String | capturedImageId = ""
String | processedImageId = ""

Member Function Documentation

abstract Field<String> getCountry ( )
abstract
abstract Field<String> getCountryLong ( )
abstract
abstract Field<String> getDateOfBirth ( )
abstract
abstract Field<String> getExpirationDate ( )
abstract
abstract Field<String> getFirstName ( )
abstract
abstract Field<String> getGender ( )
abstract
abstract Field<String> getIssueDate ( )
abstract
abstract Field<String> getLastName ( )
abstract
abstract Field<String> getMiddleName ( )
abstract
abstract Field<String> getMRZ1 ( )
abstract
abstract Field<String> getMRZ2 ( )
abstract
abstract Field<String> getNationality ( )
abstract
abstract Field<String> getPassportNumber ( )
abstract
abstract Field<String> getPersonalNumber ( )
abstract
abstract String getRawData ( )
abstract
The documentation for this class was generated from the following file:
  • Passport.java


Kofax Mobile SDK API Reference: PointDouble Class Reference

  • mobile
  • sdk
  • capture
  • model
  • PointDouble
Public Member Functions | Public Attributes | List of all members
PointDouble Class Reference
Inheritance diagram for PointDouble:

Public Member Functions

PointDouble (double left, double top)
String toString ()

Public Attributes

final double | x
final double | y

Constructor & Destructor Documentation

PointDouble | ( | double | left,
 |  | double | top
 | ) |  |

Member Function Documentation

String toString ( )

Member Data Documentation

final double x
final double y
The documentation for this class was generated from the following file:
  • PointDouble.java


Kofax Mobile SDK API Reference: SizeDouble Class Reference

  • mobile
  • sdk
  • capture
  • model
  • SizeDouble
Public Member Functions | Public Attributes | List of all members
SizeDouble Class Reference
Inheritance diagram for SizeDouble:

Public Member Functions

SizeDouble (double width, double height)
String toString ()

Public Attributes

final double | width
final double | height

Constructor & Destructor Documentation

SizeDouble | ( | double | width,
 |  | double | height
 | ) |  |

Member Function Documentation

String toString ( )

Member Data Documentation

final double height
final double width
The documentation for this class was generated from the following file:
  • SizeDouble.java


Kofax Mobile SDK API Reference: ExtractionCredentials Class Reference

  • mobile
  • sdk
  • capture
  • parameter
  • ExtractionCredentials
Public Attributes | List of all members
ExtractionCredentials Class Reference
Inheritance diagram for ExtractionCredentials:

Public Attributes

String | username
String | password
String | sessionId

Detailed Description

The extraction credentials class. This object allows specification of server credentials. If session id is set it will be used to get access to the server. Otherwise if session id is null or empty system will try log on using username and password.

See also
ExtractionParameters

Member Data Documentation

String password

Specify password if applicable.

The default value is null.

String sessionId

Specify session ID if applicable. A unique string value which allows to get access to the backend API.

The default value is null.

String username

Specify user name if applicable.

The default value is null.

The documentation for this class was generated from the following file:
  • ExtractionCredentials.java


Kofax Mobile SDK API Reference: ExtractionParameters Class Reference

  • mobile
  • sdk
  • capture
  • parameter
  • ExtractionParameters
Classes | Public Member Functions | Public Attributes | List of all members
ExtractionParameters Class Reference
Inheritance diagram for ExtractionParameters:

Classes

enum ExtractionType

Public Member Functions

ExtractionParameters ()
ExtractionType getExtractionType ()
void | setExtractionType (ExtractionType extractionType)
void | setProjectProvider (Context context, IProjectProvider projectProvider)
Sets a project provider instance. More...

Public Attributes

String | serverUrl
ExtractionCredentials | credentials = new ExtractionCredentials()

Detailed Description

The data extraction parameters class. The parameters object allows customization of image data extraction functionality.

See also
IParameters

Constructor & Destructor Documentation

ExtractionParameters ( )

Member Function Documentation

ExtractionType getExtractionType ( )

Gets the currently set extraction type parameter.

The default value is ExtractionType#RTTI

void setExtractionType ( ExtractionType extractionType )

Sets the desired extraction type

Parameters
extractionType
void setProjectProvider | ( | Context | context,
 |  | IProjectProvider | projectProvider
 | ) |  |

Sets a project provider instance.

The default value is null (the default project provider will be used).

Applicable for on-device extraction only.

Member Data Documentation

ExtractionCredentials credentials = new ExtractionCredentials()

Extraction credentials object.

The default value is null. Credentials are applicable for KTA server type only.

String serverUrl

A string value that determines extraction server URL. Specify the server URL in format: "http(s)://yourserver.com/path_to_the_service_api".

To use the default value, leave this null. The default value depends on document type and ExtractionParameters#getExtractionType().

The documentation for this class was generated from the following file:
  • ExtractionParameters.java


Kofax Mobile SDK API Reference: ExtractionParameters.ExtractionType Enum Reference

  • mobile
  • sdk
  • capture
  • parameter
  • ExtractionParameters
  • ExtractionType
Public Attributes | List of all members
ExtractionParameters.ExtractionType Enum Reference

Public Attributes

RTTI
KTA
ON_DEVICE
OFF

Member Data Documentation

KTA

KTA server.

OFF

No extraction

ON_DEVICE

On-device extraction.

RTTI

RTTI server.

The documentation for this enum was generated from the following file:
  • ExtractionParameters.java


Kofax Mobile SDK API Reference: IParameters Interface Reference

  • mobile
  • sdk
  • capture
  • parameter
  • IParameters
Public Member Functions | List of all members
IParameters Interface Reference
Inheritance diagram for IParameters:
BillParameters CheckParameters CreditCardParameters IdParameters PassportParameters

Public Member Functions

ProcessingParameters getProcessingParameters ()
ExtractionParameters getExtractionParameters ()
LookAndFeelParameters getLookAndFeelParameters ()

Detailed Description

The base class for capture parameters.

Member Function Documentation

ExtractionParameters getExtractionParameters ( )

Extraction parameters getter.

Returns
ExtractionParameters
See also
ExtractionParameters

Implemented in IdParameters, CheckParameters, CreditCardParameters, BillParameters, and PassportParameters.

LookAndFeelParameters getLookAndFeelParameters ( )

Look and feel parameters getter.

Returns
LookAndFeelParameters
See also
LookAndFeelParameters

Implemented in IdParameters, CheckParameters, CreditCardParameters, BillParameters, and PassportParameters.

ProcessingParameters getProcessingParameters ( )

Processing parameters getter.

Returns
ProcessingParameters
See also
ProcessingParameters

Implemented in IdParameters, CheckParameters, CreditCardParameters, PassportParameters, and BillParameters.

The documentation for this interface was generated from the following file:
  • IParameters.java


Kofax Mobile SDK API Reference: LookAndFeelParameters Class Reference

  • mobile
  • sdk
  • capture
  • parameter
  • LookAndFeelParameters
Classes | Public Member Functions | Public Attributes | List of all members
LookAndFeelParameters Class Reference
Inheritance diagram for LookAndFeelParameters:

Classes

enum TorchMode

Public Member Functions

LookAndFeelParameters ()

Public Attributes

boolean | galleryEnabled = false
boolean | forceCaptureEnabled = false
boolean | exitEnabled = false
int | manualCaptureTimer = 10
TorchMode torch = TorchMode.AUTO
boolean | reviewCapturedImage = false
boolean | reviewProcessedImage = false

Detailed Description

The look and feel parameters class. The parameters object allows customization of the look-and-feel during capture.

See also
IParameters

Constructor & Destructor Documentation

LookAndFeelParameters ( )

Member Data Documentation

boolean exitEnabled = false

A boolean value that determines whether the exit button is enabled. The exit button closes the capture view and cancels the current operation.

Specify true to enable the exit button; otherwise, specify false to disable it. The default value is false. If set to false, the exit button is hidden.

boolean forceCaptureEnabled = false

A boolean value that determines whether the force capture button is enabled. The force capture button allows manual capture of a document.

Specify true to enable the force capture button; otherwise, specify false to disable it. The default value is false. If set to true, the capture button will be visible depending on manualCaptureTimer timeout.

See also
manualCaptureTimer
boolean galleryEnabled = false

A boolean value that determines whether the gallery button is enabled. The gallery button launches the native photo gallery to pickup a photo of the document instead capturing it with a camera.

Specify true to enable the gallery button; otherwise, specify false to disable it. The default value is false. If the enabled state is false gallery button is hidden.

int manualCaptureTimer = 10

Once the capture view is shown, this specifies the number of seconds to wait before the force capture button is shown (if forceCaptureEnabled is set to true).

If manualCaptureTimer is less than or equal to 0 and forceCaptureEnabled state is true, the force capture button will be shown immediately after presenting the capture view. The default value is 10 seconds. If the forceCaptureEnabled state is false, the value has no affect.

See also
forceCaptureEnabled
boolean reviewCapturedImage = false

A boolean value that determines whether to show the captured image review flow. This flow allows the user to visually review the captured image and either accept it, or choose to retake the image. The default value is false, which will not show the image review flow.

boolean reviewProcessedImage = false

A boolean value that determines whether to show the processed image review flow. This flow allows the user to visually review the processed image and either accept it, or choose to retake the image. The default value is false, which will not show the processed image review flow.

TorchMode torch = TorchMode.AUTO

A torch mode value that determines camera torch behavior.

The default value is TorchMode#AUTO.

The documentation for this class was generated from the following file:
  • LookAndFeelParameters.java


Kofax Mobile SDK API Reference: LookAndFeelParameters.TorchMode Enum Reference

  • mobile
  • sdk
  • capture
  • parameter
  • LookAndFeelParameters
  • TorchMode
Public Attributes | List of all members
LookAndFeelParameters.TorchMode Enum Reference

Public Attributes

OFF
ON
AUTO

Detailed Description

An enumeration containing the possible torch mode values.

Member Data Documentation

AUTO

Torch will turn on automatically based on current lighting. Torch button is hidden.

OFF

Torch is turned off and the torch button is visible.

ON

Torch is turned on and the torch button is visible.

The documentation for this enum was generated from the following file:
  • LookAndFeelParameters.java


Kofax Mobile SDK API Reference: ProcessingParameters Class Reference

  • mobile
  • sdk
  • capture
  • parameter
  • ProcessingParameters
Classes | Public Member Functions | Public Attributes | List of all members
ProcessingParameters Class Reference
Inheritance diagram for ProcessingParameters:

Classes

enum ProcessingType

Public Member Functions

ProcessingParameters ()

Public Attributes

ProcessingType processingType = ProcessingType.ON_DEVICE
String | operations
An image processing operation string. More...
boolean | useMrzPageDetection
A boolean value that determines whether MRZ page detection is used for cropping. More...
boolean | useTargetFrameCrop
A boolean value that determines whether target frame is used for cropping. More...
CaptureData | captureData = new CaptureData()

Detailed Description

The image processing parameters class. This parameters object allows customization of image processing.

See also
IParameters

Constructor & Destructor Documentation

ProcessingParameters ( )

Member Data Documentation

CaptureData captureData = new CaptureData()

Container class for captured and processed image IDs.

String operations

An image processing operation string.

` *

App specific definition of the encoded image processing options is desired.
The string is composed of a concatenation of individual tokens, each of which enables an option. Please refer to the developers guide for a list of ImageProcessor tokens.

To use the default value, leave this null. The default value depends on document type and document side.

See also ImageProcessorConfiguration

ProcessingType processingType = ProcessingType.ON_DEVICE

A processing type value.

The default value is ProcessingType#ON_DEVICE.

boolean useMrzPageDetection

A boolean value that determines whether MRZ page detection is used for cropping.

Default value is false. See implementations of capture parameters for document-specific defaults.

boolean useTargetFrameCrop

A boolean value that determines whether target frame is used for cropping.

Default value is false. See implementations of capture parameters for document-specific defaults.

The documentation for this class was generated from the following file:
  • ProcessingParameters.java


Kofax Mobile SDK API Reference: ProcessingParameters.ProcessingType Enum Reference

  • mobile
  • sdk
  • capture
  • parameter
  • ProcessingParameters
  • ProcessingType
Public Attributes | List of all members
ProcessingParameters.ProcessingType Enum Reference

Public Attributes

OFF
ON_DEVICE

Detailed Description

Use one of the values of this enumeration to set the processing type.

Member Data Documentation

OFF

Processing is disabled.

ON_DEVICE

Processing is performed on device.

The documentation for this enum was generated from the following file:
  • ProcessingParameters.java


Kofax Mobile SDK API Reference: IPassportDeserializer Interface Reference

  • mobile
  • sdk
  • capture
  • passport
  • IPassportDeserializer
IPassportDeserializer Interface Reference
Inheritance diagram for IPassportDeserializer:

Detailed Description

Interface for a passport-specialized extraction data deserializer

The documentation for this interface was generated from the following file:
  • IPassportDeserializer.java


Kofax Mobile SDK API Reference: IPassportExtractorListener Interface Reference

  • mobile
  • sdk
  • capture
  • passport
  • IPassportExtractorListener
List of all members
IPassportExtractorListener Interface Reference
Inheritance diagram for IPassportExtractorListener:
IExtractorListener< T extends ExtractorResponse >

Additional Inherited Members

- Public Member Functions inherited from IExtractorListener< T extends ExtractorResponse >
void onExtractionComplete (T results)

Detailed Description

Interface for a passport-specialized extraction listener

The documentation for this interface was generated from the following file:
  • IPassportExtractorListener.java


Kofax Mobile SDK API Reference: KtaJsonPassport Class Reference

  • mobile
  • sdk
  • capture
  • passport
  • KtaJsonPassport
Public Member Functions | List of all members
KtaJsonPassport Class Reference
Inheritance diagram for KtaJsonPassport:
Passport CaptureData

Public Member Functions

KtaJsonPassport (Context context, String json)
void | setJson (String json)
Field< String > | getFirstName ()
Field< String > | getMiddleName ()
Field< String > | getLastName ()
Field< String > | getDateOfBirth ()
Field< String > | getGender ()
Field< String > | getIssueDate ()
Field< String > | getExpirationDate ()
Field< String > | getPassportNumber ()
Field< String > | getCountry ()
Field< String > | getCountryLong ()
Field< String > | getNationality ()
Field< String > | getPersonalNumber ()
Field< String > | getMRZ1 ()
Field< String > | getMRZ2 ()
String | getRawData ()
- Public Member Functions inherited from Passport
abstract Field< String > | getFirstName ()
abstract Field< String > | getMiddleName ()
abstract Field< String > | getLastName ()
abstract Field< String > | getDateOfBirth ()
abstract Field< String > | getGender ()
abstract Field< String > | getIssueDate ()
abstract Field< String > | getExpirationDate ()
abstract Field< String > | getPassportNumber ()
abstract Field< String > | getCountry ()
abstract Field< String > | getCountryLong ()
abstract Field< String > | getNationality ()
abstract Field< String > | getPersonalNumber ()
abstract Field< String > | getMRZ1 ()
abstract Field< String > | getMRZ2 ()
abstract String | getRawData ()

Additional Inherited Members

- Public Attributes inherited from CaptureData
String | capturedImageId = ""
String | processedImageId = ""

Detailed Description

A JSON deserializer for KTA extraction

Constructor & Destructor Documentation

KtaJsonPassport | ( | Context | context,
 |  | String | json
 | ) |  |

Member Function Documentation

Field<String> getCountry ( )
Field<String> getCountryLong ( )
Field<String> getDateOfBirth ( )
Field<String> getExpirationDate ( )
Field<String> getFirstName ( )
Field<String> getGender ( )
Field<String> getIssueDate ( )
Field<String> getLastName ( )
Field<String> getMiddleName ( )
Field<String> getMRZ1 ( )
Field<String> getMRZ2 ( )
Field<String> getNationality ( )
Field<String> getPassportNumber ( )
Field<String> getPersonalNumber ( )
String getRawData ( )
void setJson ( String json )
The documentation for this class was generated from the following file:
  • KtaJsonPassport.java


Kofax Mobile SDK API Reference: KtaPassportExtractor Class Reference

  • mobile
  • sdk
  • capture
  • passport
  • KtaPassportExtractor
Public Member Functions | Protected Member Functions | List of all members
KtaPassportExtractor Class Reference
Inheritance diagram for KtaPassportExtractor:

Public Member Functions

KtaPassportExtractor (IKtaSessionIdProviderFactory sessionIdProviderFactory, IImageToByteArray converter)
String getProcessName ()

Protected Member Functions

void updateKTARequest (JobService jobService)

Detailed Description

KTA-specialized passport data extractor. This class is constructed automatically by the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Constructor & Destructor Documentation

KtaPassportExtractor | ( | IKtaSessionIdProviderFactory | sessionIdProviderFactory,
 |  | IImageToByteArray | converter
 | ) |  |

Member Function Documentation

String getProcessName ( )
void updateKTARequest ( JobService jobService )
protected
The documentation for this class was generated from the following file:
  • KtaPassportExtractor.java


Kofax Mobile SDK API Reference: PassportCaptureActivity Class Reference

  • mobile
  • sdk
  • capture
  • passport
  • PassportCaptureActivity
Protected Member Functions | List of all members
PassportCaptureActivity Class Reference
Inheritance diagram for PassportCaptureActivity:
CaptureActivity

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
- Protected Member Functions inherited from CaptureActivity
void | onCreate (Bundle savedInstanceState)
void | setCaptureCriteria (CaptureCriteria criteria)
void | onResume ()
void | onPause ()
ICameraView | getCameraView ()
void | setupCameraView (ViewGroup container)
void | setupButtonBarView (LinearLayout mainView)
void | onSaveInstanceState (Bundle outState)
void | initController (IOverlayView view, IDetectionAdapter detectorAdapter)
void | saveResultAndFinish (Image image, Bundle bundle)
void | onActivityResult (int requestCode, int resultCode, Intent data)

Additional Inherited Members

- Public Member Functions inherited from CaptureActivity
void | finish ()
void | onExitButtonClick ()
void | onForceCaptureButtonClick ()
void | onGalleryButtonClick ()
void | onTorchChange (boolean checked)
- Static Public Attributes inherited from CaptureActivity
static final String | RESULT_CODE = "__result_code__"
static final int | IMAGE_CAPTURED = -42
static final int | NO_IMAGE_CAPTURED = -1

Detailed Description

Passport-specialized image capture activity. This activity is constructed automatically by the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Member Function Documentation

void onCreate ( Bundle savedInstanceState )
protected
The documentation for this class was generated from the following file:
  • PassportCaptureActivity.java


Kofax Mobile SDK API Reference: PassportExtractActivity Class Reference

  • mobile
  • sdk
  • capture
  • passport
  • PassportExtractActivity
Static Public Attributes | Protected Member Functions | List of all members
PassportExtractActivity Class Reference
Inheritance diagram for PassportExtractActivity:
ExtractActivity< T extends ExtractorResponse > IExtractorListener< T extends ExtractorResponse >

Static Public Attributes

static final String | PASSPORT_EXTRACT = "_passport_extract_"
- Static Public Attributes inherited from ExtractActivity< T extends ExtractorResponse >
static final String | CERTIFICATE_VALIDATOR_LISTENER

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
- Protected Member Functions inherited from ExtractActivity< T extends ExtractorResponse >
void | onCreate (Bundle savedInstanceState)
synchronized void | onResume ()
Image | getImageByBitmapId (String id)
void | onSaveInstanceState (Bundle outState)
void | extract (Image image)

Additional Inherited Members

- Public Member Functions inherited from ExtractActivity< T extends ExtractorResponse >
void | onExtractionComplete (T results)
void | setExtract (Extractor extractor)
- Protected Attributes inherited from ExtractActivity< T extends ExtractorResponse >
Extractor< T > | _extractor

Detailed Description

Passport-specialized extraction activity. This activity is constructed automatically by the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Member Function Documentation

void onCreate ( Bundle savedInstanceState )
protected

Member Data Documentation

final String PASSPORT_EXTRACT = "_passport_extract_"
static
The documentation for this class was generated from the following file:
  • PassportExtractActivity.java


Kofax Mobile SDK API Reference: PassportExtractor Class Reference

  • mobile
  • sdk
  • capture
  • passport
  • PassportExtractor
Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
PassportExtractor Class Reference
Inheritance diagram for PassportExtractor:
Extractor< T extends Serializable >

Public Member Functions

PassportExtractor ()
void | setParameters (ExtractionParameters parameters)
- Public Member Functions inherited from Extractor< T extends Serializable >
Extractor ()
void | setExtractionServer (IExtractionServer extractionServer)
void | setResultDeserializer (IDeserializer< T > resultDeserializer)
void | setExceptionResponseDeserializer (IExceptionResponseDeserializer exceptionResponseDeserializer)
void | setParameters (ExtractionParameters parameters)
void | setExtractorListener (IExtractorListener listener)
void | setCertificateValidatorListener (CertificateValidatorListener certificateValidatorListener)
void | extract (Image...images)
void | onExtractionComplete (DataUnit unit)

Static Public Attributes

static final String | PASSPORT_EXTRACT_RTTI = "_passport_extract_rtti_"
static final String | PASSPORT_EXTRACT_KTA = "_passport_extract_kta_"
static final String | PASSPORT_EXTRACT_ON_DEVICE = "_passport_extract_on_device_"

Protected Member Functions

ExtractorResponse< Passport > | createResponse (Passport results, ExceptionResponse exceptionResponse)
String | getDefaultServerUrl (ExtractionParameters.ExtractionType extractionType)
- Protected Member Functions inherited from Extractor< T extends Serializable >
abstract ExtractorResponse< T > | createResponse (T results, ExceptionResponse exceptionResponse)
abstract String | getDefaultServerUrl (ExtractionParameters.ExtractionType extractionType)

Detailed Description

Passport-specialized data extractor. This class is constructed automatically by the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Constructor & Destructor Documentation

PassportExtractor ( )

Member Function Documentation

ExtractorResponse<Passport> createResponse | ( | Passport | results,
 |  | ExceptionResponse | exceptionResponse
 | ) |  |
protected
String getDefaultServerUrl ( ExtractionParameters.ExtractionType extractionType )
protected
void setParameters ( ExtractionParameters parameters )

Member Data Documentation

final String PASSPORT_EXTRACT_KTA = "_passport_extract_kta_"
static
final String PASSPORT_EXTRACT_ON_DEVICE = "_passport_extract_on_device_"
static
final String PASSPORT_EXTRACT_RTTI = "_passport_extract_rtti_"
static
The documentation for this class was generated from the following file:
  • PassportExtractor.java


Kofax Mobile SDK API Reference: PassportExtractorResponse Class Reference

  • mobile
  • sdk
  • capture
  • passport
  • PassportExtractorResponse
Public Member Functions | List of all members
PassportExtractorResponse Class Reference
Inheritance diagram for PassportExtractorResponse:
ExtractorResponse< T extends Serializable >

Public Member Functions

PassportExtractorResponse (Passport result, ExceptionResponse exception)

Additional Inherited Members

- Public Attributes inherited from ExtractorResponse< T extends Serializable >
T results
ExceptionResponse exceptionResponse

Detailed Description

Passport-specialized extraction response container

Constructor & Destructor Documentation

PassportExtractorResponse | ( | Passport | result,
 |  | ExceptionResponse | exception
 | ) |  |
The documentation for this class was generated from the following file:
  • PassportExtractorResponse.java


Kofax Mobile SDK API Reference: PassportParameters Class Reference

  • mobile
  • sdk
  • capture
  • passport
  • PassportParameters
Public Member Functions | List of all members
PassportParameters Class Reference
Inheritance diagram for PassportParameters:
IParameters

Public Member Functions

PassportParameters (Context context)
ProcessingParameters getProcessingParameters ()
ExtractionParameters getExtractionParameters ()
LookAndFeelParameters getLookAndFeelParameters ()

Detailed Description

Passport-specific capture, process and extraction parameters

Constructor & Destructor Documentation

PassportParameters ( Context context )

Member Function Documentation

ExtractionParameters getExtractionParameters ( )

Extraction parameters getter.

Returns
ExtractionParameters
See also
ExtractionParameters

Implements IParameters.

LookAndFeelParameters getLookAndFeelParameters ( )

Look and feel parameters getter.

Returns
LookAndFeelParameters
See also
LookAndFeelParameters

Implements IParameters.

ProcessingParameters getProcessingParameters ( )

Processing parameters getter.

Passport-specific defaults:

  • useMrzPageDetection: true

Implements IParameters.

The documentation for this class was generated from the following file:
  • PassportParameters.java


Kofax Mobile SDK API Reference: PassportWorkflowActivity Class Reference

  • mobile
  • sdk
  • capture
  • passport
  • PassportWorkflowActivity
Classes | Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
PassportWorkflowActivity Class Reference
Inheritance diagram for PassportWorkflowActivity:
WorkflowActivity< T extends IParameters >

Public Member Functions

Class<?extends Activity > | getCaptureActivityClass ()
Class<?extends Activity > | getExtractActivityClass ()
String | getDefaultProcessingString (PassportParameters parameters)
CaptureData getDefaultReturnObject ()
String | getParametersKey ()
String | getResultKey ()
String | getExceptionKey ()
PassportParameters getParametersInstance ()
- Public Member Functions inherited from WorkflowActivity< T extends IParameters >
abstract Class<?extends Activity > | getCaptureActivityClass ()
abstract Class<?extends Activity > | getExtractActivityClass ()
abstract String | getDefaultProcessingString (T parameters)
abstract CaptureData | getDefaultReturnObject ()
abstract String | getParametersKey ()
abstract String | getResultKey ()
abstract String | getExceptionKey ()
abstract T | getParametersInstance ()
T | getParameters (Bundle savedInstanceState)

Static Public Attributes

static final String | PASSPORT_PARAMETERS = "_com.kofax.mobile.sdk.capture._passport_parameters_"
static final String | PASSPORT_RESULTS = "_com.kofax.mobile.sdk.capture._passport_results_"
static final String | PASSPORT_EXCEPTION = "_com.kofax.mobile.sdk.capture._passport_exception_"
- Static Public Attributes inherited from WorkflowActivity< T extends IParameters >
static final String | CERTIFICATE_VALIDATOR_LISTENER

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
boolean | isOdeSupported ()
- Protected Member Functions inherited from WorkflowActivity< T extends IParameters >
boolean | isOdeSupported ()
void | onCreate (Bundle savedInstanceState)
void | handleException (final Throwable exc)
void | tryRestoreState (Bundle savedInstanceState)
void | onSaveInstanceState (Bundle outState)
void | onDestroy ()
void | onResume ()
void | captureImage ()
void | onActivityResult (int requestCode, int resultCode, Intent data)
void | clearBitmap (String imageId)

Detailed Description

The Passport workflow specializes in capturing, processing and extracting data from a passport. To use this class, optionally construct new PassportParameters, modify those parameters for your use, then start an intent for this workflow:

PassportParameters _params = new PassportParameters(this);

Intent intent = new Intent(this, PassportWorkflowActivity.class);

_params.getLookAndFeelParameters().forceCaptureEnabled = true;

_params.getExtractionParameters().serverType = ExtractionParameters.ServerType.RTTI;

_params.getLookAndFeelParameters().galleryEnabled = true;

intent.putExtra(PassportWorkflowActivity.PASSPORT_PARAMETERS, _params);

startActivityForResult(intent, REQUEST_CODE);

New permissions model introduced in Android M

Some functions won't be available until necessary permissions are granted by the user. It's up to the developer when to ask for permissions and whether or not to show a rationale — SDK doesn't do that.

Functions that require permissions:

  • Capture requires CAMERA permission.
  • Adding location data to captured images requires ACCESS_FINE_LOCATION permission.
  • The gallery button requires READ_EXTERNAL_STORAGE permission.

Member Function Documentation

Class<? extends Activity> getCaptureActivityClass ( )
String getDefaultProcessingString ( PassportParameters parameters )
CaptureData getDefaultReturnObject ( )
String getExceptionKey ( )
Class<? extends Activity> getExtractActivityClass ( )
PassportParameters getParametersInstance ( )
String getParametersKey ( )
String getResultKey ( )
boolean isOdeSupported ( )
protected
void onCreate ( Bundle savedInstanceState )
protected

Member Data Documentation

final String PASSPORT_EXCEPTION = "_com.kofax.mobile.sdk.capture._passport_exception_"
static
final String PASSPORT_PARAMETERS = "_com.kofax.mobile.sdk.capture._passport_parameters_"
static
final String PASSPORT_RESULTS = "_com.kofax.mobile.sdk.capture._passport_results_"
static
The documentation for this class was generated from the following file:
  • PassportWorkflowActivity.java


Kofax Mobile SDK API Reference: RttiJsonPassport Class Reference

  • mobile
  • sdk
  • capture
  • passport
  • RttiJsonPassport
Public Member Functions | List of all members
RttiJsonPassport Class Reference
Inheritance diagram for RttiJsonPassport:
Passport CaptureData

Public Member Functions

RttiJsonPassport (Context context, String json)
void | setJson (String json)
Field< String > | getFirstName ()
Field< String > | getMiddleName ()
Field< String > | getLastName ()
Field< String > | getDateOfBirth ()
Field< String > | getGender ()
Field< String > | getIssueDate ()
Field< String > | getExpirationDate ()
Field< String > | getPassportNumber ()
Field< String > | getCountry ()
Field< String > | getCountryLong ()
Field< String > | getNationality ()
Field< String > | getPersonalNumber ()
Field< String > | getMRZ1 ()
Field< String > | getMRZ2 ()
String | getRawData ()
- Public Member Functions inherited from Passport
abstract Field< String > | getFirstName ()
abstract Field< String > | getMiddleName ()
abstract Field< String > | getLastName ()
abstract Field< String > | getDateOfBirth ()
abstract Field< String > | getGender ()
abstract Field< String > | getIssueDate ()
abstract Field< String > | getExpirationDate ()
abstract Field< String > | getPassportNumber ()
abstract Field< String > | getCountry ()
abstract Field< String > | getCountryLong ()
abstract Field< String > | getNationality ()
abstract Field< String > | getPersonalNumber ()
abstract Field< String > | getMRZ1 ()
abstract Field< String > | getMRZ2 ()
abstract String | getRawData ()

Additional Inherited Members

- Public Attributes inherited from CaptureData
String | capturedImageId = ""
String | processedImageId = ""

Detailed Description

RTTI-specialized JSON deserializer. This class is constructed automatically in the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Constructor & Destructor Documentation

RttiJsonPassport | ( | Context | context,
 |  | String | json
 | ) |  |

Member Function Documentation

Field<String> getCountry ( )
Field<String> getCountryLong ( )
Field<String> getDateOfBirth ( )
Field<String> getExpirationDate ( )
Field<String> getFirstName ( )
Field<String> getGender ( )
Field<String> getIssueDate ( )
Field<String> getLastName ( )
Field<String> getMiddleName ( )
Field<String> getMRZ1 ( )
Field<String> getMRZ2 ( )
Field<String> getNationality ( )
Field<String> getPassportNumber ( )
Field<String> getPersonalNumber ( )
String getRawData ( )
void setJson ( String json )
The documentation for this class was generated from the following file:
  • RttiJsonPassport.java


Kofax Mobile SDK API Reference: RttiPassportExtractor Class Reference

  • mobile
  • sdk
  • capture
  • passport
  • RttiPassportExtractor
Public Member Functions | Protected Member Functions | List of all members
RttiPassportExtractor Class Reference
Inheritance diagram for RttiPassportExtractor:

Public Member Functions

RttiPassportExtractor (IImageToByteArray converter)

Protected Member Functions

void updateRttiRequest (RttiRequest rttiRequest)

Detailed Description

RTTI-specialized passport data extractor. This class is constructed automatically by the com.kofax.mobile.sdk.capture.WorkflowActivity and is not intended for direct use.

Constructor & Destructor Documentation

RttiPassportExtractor ( IImageToByteArray converter )

Member Function Documentation

void updateRttiRequest ( RttiRequest rttiRequest )
protected
The documentation for this class was generated from the following file:
  • RttiPassportExtractor.java


Kofax Mobile SDK API Reference: IImageProcessor Interface Reference

  • mobile
  • sdk
  • capture
  • processing
  • IImageProcessor
Public Member Functions | List of all members
IImageProcessor Interface Reference

Public Member Functions

void | process (Image image)
void | process (Bitmap image)
void | cancel ()
void | setImageOutListener (IImageProcessorListener listener)
void | setParameters (ProcessingParameters parameters)

Detailed Description

Image processor interface to simplify the requirements for image processing

Member Function Documentation

void cancel ( )
void process ( Image image )
void process ( Bitmap image )
void setImageOutListener ( IImageProcessorListener listener )
void setParameters ( ProcessingParameters parameters )
The documentation for this interface was generated from the following file:
  • IImageProcessor.java


Kofax Mobile SDK API Reference: IImageProcessorListener Interface Reference

  • mobile
  • sdk
  • capture
  • processing
  • IImageProcessorListener
Public Member Functions | List of all members
IImageProcessorListener Interface Reference
Inheritance diagram for IImageProcessorListener:
ProcessActivity

Public Member Functions

void onImageProcessed (Image image)

Detailed Description

A listener that is called once image processing is complete

Member Function Documentation

void onImageProcessed ( Image image )

Implemented in ProcessActivity.

The documentation for this interface was generated from the following file:
  • IImageProcessorListener.java


Kofax Mobile SDK API Reference: ApplicationContextImageStore Class Reference

  • mobile
  • sdk
  • capture
  • ApplicationContextImageStore
Static Public Member Functions | List of all members
ApplicationContextImageStore Class Reference

Static Public Member Functions

static IImageStorage | getImageStorage ()
static void | setImageStorage (IImageStorage imageStorage)

Detailed Description

Used to get and set the IImageStorage instance used to pass images between Activities.

The default implementation is the ContextImageStorage. Please see documentation there concerning possible memory leaks if you should mis-use that implementation.

Member Function Documentation

static IImageStorage getImageStorage ( )
static
Returns
Retrieve the set IImageStorage. The default is ContextImageStorage
static void setImageStorage ( IImageStorage imageStorage )
static

Set the IImageStorage used to pass images between Activities. To provide a custom implementation for this class, implement the IImageStorage interface, and pass an instance of your custom class here prior to calling any WorkflowActivity within the com.kofax.mobile.sdk.capture namespace

Parameters
imageStorage
The documentation for this class was generated from the following file:
  • ApplicationContextImageStore.java


Kofax Mobile SDK API Reference: CaptureActivity Class Reference

  • mobile
  • sdk
  • capture
  • CaptureActivity
Classes | Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
CaptureActivity Class Referenceabstract
Inheritance diagram for CaptureActivity:
BillCaptureActivity CheckCaptureActivity IdCaptureActivity IdCaptureBackActivity PassportCaptureActivity

Public Member Functions

void | finish ()
void | onExitButtonClick ()
void | onForceCaptureButtonClick ()
void | onGalleryButtonClick ()
void | onTorchChange (boolean checked)

Static Public Attributes

static final String | RESULT_CODE = "__result_code__"
static final int | IMAGE_CAPTURED = -42
static final int | NO_IMAGE_CAPTURED = -1

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
void | setCaptureCriteria (CaptureCriteria criteria)
void | onResume ()
void | onPause ()
ICameraView | getCameraView ()
void | setupCameraView (ViewGroup container)
void | setupButtonBarView (LinearLayout mainView)
void | onSaveInstanceState (Bundle outState)
void | initController (IOverlayView view, IDetectionAdapter detectorAdapter)
void | saveResultAndFinish (Image image, Bundle bundle)
void | onActivityResult (int requestCode, int resultCode, Intent data)

Detailed Description

Manages views and logic for capture for the WorkflowActivity. This activity is constructed automatically by the WorkflowActivity and is not intended for direct use.

Member Function Documentation

void finish ( )
ICameraView getCameraView ( )
protected
void initController | ( | IOverlayView | view,
 |  | IDetectionAdapter | detectorAdapter
 | ) |  |
protected
void onActivityResult | ( | int | requestCode,
 |  | int | resultCode,
 |  | Intent | data
 | ) |  |
protected
void onCreate ( Bundle savedInstanceState )
protected
void onExitButtonClick ( )

Handle the event for when the exit button is tapped by the user.

void onForceCaptureButtonClick ( )

Handle the event for when the force capture button is tapped by the user.

void onGalleryButtonClick ( )

Handle the event for when the gallery button is tapped by the user.

void onPause ( )
protected
void onResume ( )
protected
void onSaveInstanceState ( Bundle outState )
protected
void onTorchChange ( boolean checked )
void saveResultAndFinish | ( | Image | image,
 |  | Bundle | bundle
 | ) |  |
protected
void setCaptureCriteria ( CaptureCriteria criteria )
protected
void setupButtonBarView ( LinearLayout mainView )
protected
void setupCameraView ( ViewGroup container )
protected

Member Data Documentation

final int IMAGE_CAPTURED = -42
static
final int NO_IMAGE_CAPTURED = -1
static
final String RESULT_CODE = "__result_code__"
static
The documentation for this class was generated from the following file:
  • CaptureActivity.java


Kofax Mobile SDK API Reference: ContextImageStorage Class Reference

  • mobile
  • sdk
  • capture
  • ContextImageStorage
Public Member Functions | List of all members
ContextImageStorage Class Reference
Inheritance diagram for ContextImageStorage:
IImageStorage

Public Member Functions

ContextImageStorage ()
void | setImage (Bitmap image, String id)
Bitmap | getImage (String id)
Bitmap | removeImage (String id)

Detailed Description

An implementation of IImageStorage that uses a static hashmap to store images. It is important to note that memory leaks will occur if images stored here are not properly recycled, and references cleared as soon as possible.

Constructor & Destructor Documentation

ContextImageStorage ( )

Member Function Documentation

Bitmap getImage ( String id )

Get a reference to an image of the given Id. This implementation returns a direct reference to image in memory. Calling Bitmap#recycle() will recycle the bitmap for all references.

Parameters
id The id of the image to retrieve
Returns
A bitmap, or null if the image of the given id does not exist in storage

Implements IImageStorage.

Bitmap removeImage ( String id )

Retrieves and removes the image of the given id from storage. The returned image must be recycled by the caller

Parameters
id The id of the image to remove from storage
Returns
The image associated with the specified id or null if no image for the specified id was found

Implements IImageStorage.

void setImage | ( | Bitmap | image,
 |  | String | id
 | ) |  |

Store or overwrite an image with the given Id. Null is a valid value.

Parameters
image | The image to store
id | The id of the image when storing, for later retrieval

Implements IImageStorage.

The documentation for this class was generated from the following file:
  • ContextImageStorage.java


Kofax Mobile SDK API Reference: ExtractActivity< T extends ExtractorResponse > Class Template Reference

  • mobile
  • sdk
  • capture
  • ExtractActivity
Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
ExtractActivity< T extends ExtractorResponse > Class Template Referenceabstract
Inheritance diagram for ExtractActivity< T extends ExtractorResponse >:
IExtractorListener< T extends ExtractorResponse > BillExtractActivity CheckExtractActivity IdExtractActivity PassportExtractActivity

Public Member Functions

void | onExtractionComplete (T results)
void | setExtract (Extractor extractor)

Static Public Attributes

static final String CERTIFICATE_VALIDATOR_LISTENER

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
synchronized void | onResume ()
Image | getImageByBitmapId (String id)
void | onSaveInstanceState (Bundle outState)
void | extract (Image image)

Protected Attributes

Extractor< T > _extractor

Detailed Description

Manages logic for extraction for the WorkflowActivity. This activity is constructed automatically by the WorkflowActivity and is not intended for direct use.

Member Function Documentation

void extract ( Image image )
protected
Image getImageByBitmapId ( String id )
protected
void onCreate ( Bundle savedInstanceState )
protected
void onExtractionComplete ( T results )

Implements IExtractorListener< T extends ExtractorResponse >.

synchronized void onResume ( )
protected
void onSaveInstanceState ( Bundle outState )
protected
void setExtract ( Extractor extractor )

Member Data Documentation

Extractor<T> _extractor
protected
final String CERTIFICATE_VALIDATOR_LISTENER
static
Initial value:
=
WorkflowActivity.CERTIFICATE_VALIDATOR_LISTENER
The documentation for this class was generated from the following file:
  • ExtractActivity.java


Kofax Mobile SDK API Reference: IImageStorage Interface Reference

  • mobile
  • sdk
  • capture
  • IImageStorage
Public Member Functions | List of all members
IImageStorage Interface Reference
Inheritance diagram for IImageStorage:
ContextImageStorage

Public Member Functions

void | setImage (Bitmap image, String id)
Bitmap | getImage (String id)
Bitmap | removeImage (String id)

Detailed Description

Allows storage of images

Member Function Documentation

Bitmap getImage ( String id )

Retrieve a reference to an image, but leave it in storage. How the image must be released is implementation-specific.

Parameters
id The id of the image to retrieve
Returns
A bitmap, or null if an image of the given Id does not exist in storage

Implemented in ContextImageStorage.

Bitmap removeImage ( String id )

Remove the image from storage. The returned bitmap must be freed by the caller

Parameters
id The id of the image to remove from storage
Returns
A bitmap, or null if an image of the given Id does not exist in storage

Implemented in ContextImageStorage.

void setImage | ( | Bitmap | image,
 |  | String | id
 | ) |  |

Store or overwrite an image with the given Id

Parameters
image | The image to store
id | The id of the image when storing, for later retrieval

Implemented in ContextImageStorage.

The documentation for this interface was generated from the following file:
  • IImageStorage.java


Kofax Mobile SDK API Reference: ImageReviewActivity Class Reference

  • mobile
  • sdk
  • capture
  • ImageReviewActivity
Classes | Protected Member Functions | List of all members
ImageReviewActivity Class Reference
Inheritance diagram for ImageReviewActivity:

Protected Member Functions

void onCreate (Bundle savedInstanceState)

Detailed Description

Manages views and logic for image review for the WorkflowActivity. This activity is constructed automatically by the WorkflowActivity and is not intended for direct use.

Member Function Documentation

void onCreate ( Bundle savedInstanceState )
protected
The documentation for this class was generated from the following file:
  • ImageReviewActivity.java


Kofax Mobile SDK API Reference: ProcessActivity Class Reference

  • mobile
  • sdk
  • capture
  • ProcessActivity
Public Member Functions | Protected Member Functions | List of all members
ProcessActivity Class Reference
Inheritance diagram for ProcessActivity:
IImageProcessorListener

Public Member Functions

void | onBackPressed ()
void | onImageProcessed (Image image)

Protected Member Functions

void | onCreate (Bundle savedInstanceState)
synchronized void | onResume ()
synchronized void | onPause ()
void | onSaveInstanceState (Bundle outState)

Detailed Description

Manages views and logic for processing for the WorkflowActivity. This activity is constructed automatically by the WorkflowActivity and is not intended for direct use.

Member Function Documentation

void onBackPressed ( )
void onCreate ( Bundle savedInstanceState )
protected
void onImageProcessed ( Image image )

Implements IImageProcessorListener.

synchronized void onPause ( )
protected
synchronized void onResume ( )
protected
void onSaveInstanceState ( Bundle outState )
protected
The documentation for this class was generated from the following file:
  • ProcessActivity.java


Kofax Mobile SDK API Reference: WorkflowActivity< T extends IParameters > Class Template Reference

  • mobile
  • sdk
  • capture
  • WorkflowActivity
Classes | Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
WorkflowActivity< T extends IParameters > Class Template Referenceabstract
Inheritance diagram for WorkflowActivity< T extends IParameters >:
BillWorkflowActivity CheckWorkflowActivity CreditCardWorkflowActivity IdWorkflowActivity PassportWorkflowActivity

Public Member Functions

abstract Class<?extends Activity > | getCaptureActivityClass ()
abstract Class<?extends Activity > | getExtractActivityClass ()
abstract String | getDefaultProcessingString (T parameters)
abstract CaptureData | getDefaultReturnObject ()
abstract String | getParametersKey ()
abstract String | getResultKey ()
abstract String | getExceptionKey ()
abstract T | getParametersInstance ()
T | getParameters (Bundle savedInstanceState)

Static Public Attributes

static final String CERTIFICATE_VALIDATOR_LISTENER

Protected Member Functions

boolean | isOdeSupported ()
void | onCreate (Bundle savedInstanceState)
void | handleException (final Throwable exc)
void | tryRestoreState (Bundle savedInstanceState)
void | onSaveInstanceState (Bundle outState)
void | onDestroy ()
void | onResume ()
void | captureImage ()
void | onActivityResult (int requestCode, int resultCode, Intent data)
void | clearBitmap (String imageId)

Detailed Description

The base WorkflowActivity manages the logic and parameterization of the capture, process, and extract workflow.

Please see known direct subclasses for use.

Parameters
<T>
See also
BillWorkflowActivity
CheckWorkflowActivity
CreditCardWorkflowActivity
IdWorkflowActivity
PassportWorkflowActivity

Member Function Documentation

void captureImage ( )
protected
void clearBitmap ( String imageId )
protected
abstract Class<? extends Activity> getCaptureActivityClass ( )
abstract
abstract String getDefaultProcessingString ( T parameters )
abstract
abstract CaptureData getDefaultReturnObject ( )
abstract
abstract String getExceptionKey ( )
abstract
abstract Class<? extends Activity> getExtractActivityClass ( )
abstract
T getParameters ( Bundle savedInstanceState )
abstract T getParametersInstance ( )
abstract
abstract String getParametersKey ( )
abstract
abstract String getResultKey ( )
abstract
void handleException ( final Throwable exc )
protected
boolean isOdeSupported ( )
protected
void onActivityResult | ( | int | requestCode,
 |  | int | resultCode,
 |  | Intent | data
 | ) |  |
protected
void onCreate ( Bundle savedInstanceState )
protected
void onDestroy ( )
protected
void onResume ( )
protected
void onSaveInstanceState ( Bundle outState )
protected
void tryRestoreState ( Bundle savedInstanceState )
protected

Member Data Documentation

final String CERTIFICATE_VALIDATOR_LISTENER
static
Initial value:
=
"_com.kofax.mobile.sdk.capture._certificate_validator_listener_"
The documentation for this class was generated from the following file:
  • WorkflowActivity.java


Kofax Mobile SDK API Reference: BundleCacheProvider Class Reference

  • mobile
  • sdk
  • extract
  • id
  • bundle
  • BundleCacheProvider
Public Member Functions | Static Public Attributes | Protected Member Functions | List of all members
BundleCacheProvider Class Reference
Inheritance diagram for BundleCacheProvider:
IBundleCacheProvider

Public Member Functions

BundleCacheProvider (Context context)
BundleCacheProvider (File cache)
String | getLatestModelDataBuildInfo (String projectName)
File | getProject (String projectName, String version)
File | cacheProject (String projectName, IBundle bundle, String version)
File | getVariant (String projectName, String variant, String version)
File | cacheVariant (String projectName, String variantName, IBundle bundle, String version)
String | getLatestVersionForProject (final String projectName)
- Public Member Functions inherited from IBundleCacheProvider
String | getLatestVersionForProject (String projectName)

Static Public Attributes

static final String ODE_CACHE = "_COM_KOFAX_MOBILE_SDK_EXTRACT_ID_ODE_CACHE_"

Protected Member Functions

void clearCache ()

Detailed Description

The BundleCacheProvider handles extracting/copying entries from a bundle into a cache folder. The provider is used to determine the cache location.
By default, the SDK uses the Context.getFilesDir() to save extracted bundle entries as /[app dir]/files/ODE_CACHE/[version]/{project,variant}/

Depending on where the cache is (Context.getCacheDir() or Context.getFilesDir()), the saved files may be stored temporarily, or permanently.

This implementation uses the version string, and will completely empty downloaded files if the given version string does not match what is already on disk.

Constructor & Destructor Documentation

BundleCacheProvider ( Context context )

Create a cache provider which uses context.getFilesDir() as the cache location.

Parameters
context The context
BundleCacheProvider ( File cache )

Create a cache provider specifying the cache location.

Parameters
cache The directory where this should cache files

Member Function Documentation

File cacheProject | ( | String | projectName,
 |  | IBundle | bundle,
 |  | String | version
 | ) |  |

Extracts the project parts from the given bundle and caches them in the application's local storage.

Parameters
projectName | The project to extract
bundle | The bundle from which the project will be extracted
version | The version of this bundle
Returns
The directory containing the project parts

Implements IBundleCacheProvider.

File cacheVariant | ( | String | projectName,
 |  | String | variantName,
 |  | IBundle | bundle,
 |  | String | version
 | ) |  |

Extracts the variant parts from the given bundle and caches them in the application's local storage.

Parameters
projectName | The name of the project to which this variant belongs
variantName | The variant to extract
bundle | The bundle from which the variant will be extracted
version | The version of this bundle
Returns
The directory containing the variant parts

Implements IBundleCacheProvider.

void clearCache ( )
protected

Recursively deletes the cache folder, and its contents.

String getLatestModelDataBuildInfo ( String projectName )

Get the project latest build model from cache

Parameters
projectName The name of the project to retrieve
Returns
The latest model data build info if available, otherwise a null string

Implements IBundleCacheProvider.

String getLatestVersionForProject ( final String projectName )

Gets the version of the cached project file

Parameters
projectName The name of the project to get the version string for
Returns
The version string, or null if one is not cached
Exceptions
ProjectProviderException If more than one project cache exists
File getProject | ( | String | projectName,
 |  | String | version
 | ) |  |

Get the project directory

Parameters
projectName | The name of the project to retrieve
version | The version of the project to retrieve
Returns
The directory containing the project files

Implements IBundleCacheProvider.

File getVariant | ( | String | projectName,
 |  | String | variant,
 |  | String | version
 | ) |  |

Get the variant directory

Parameters
projectName | The name of the project to which this variant belongs
variant | The variant to retrieve
version | The version of the variant to retrieve
Returns
The directory containing the variant parts

Implements IBundleCacheProvider.

Member Data Documentation

final String ODE_CACHE = "_COM_KOFAX_MOBILE_SDK_EXTRACT_ID_ODE_CACHE_"
static
The documentation for this class was generated from the following file:
  • BundleCacheProvider.java


Kofax Mobile SDK API Reference: IBundle Interface Reference

  • mobile
  • sdk
  • extract
  • id
  • bundle
  • IBundle
Public Member Functions | List of all members
IBundle Interface Reference
Inheritance diagram for IBundle:
ZipFileBundle ZipInputStreamBundle

Public Member Functions

Enumeration<?extends IBundleFile > list ()

Detailed Description

A collection of bundle files. Used to unify the interaction with varying types of storage, such as ZipFile, ZipInputStream, and regular filesystem.

Member Function Documentation

Enumeration<? extends IBundleFile> list ( )

Implemented in ZipInputStreamBundle, and ZipFileBundle.

The documentation for this interface was generated from the following file:
  • IBundle.java


Kofax Mobile SDK API Reference: IBundleCacheProvider Interface Reference

  • mobile
  • sdk
  • extract
  • id
  • bundle
  • IBundleCacheProvider
Public Member Functions | List of all members
IBundleCacheProvider Interface Reference
Inheritance diagram for IBundleCacheProvider:
BundleCacheProvider

Public Member Functions

File | getProject (String projectName, String version)
File | cacheProject (String projectName, IBundle file, String version)
File | getVariant (String projectName, String variant, String version)
File | cacheVariant (String projectName, String variant, IBundle file, String version)
String | getLatestVersionForProject (String projectName)
String | getLatestModelDataBuildInfo (String projectName)

Member Function Documentation

File cacheProject | ( | String | projectName,
 |  | IBundle | file,
 |  | String | version
 | ) |  |

Cache a project bundle

Parameters
projectName | The name of the project to cache
file | The project bundle
version | The version of the project being cached
Returns
The folder containing the newly cached project

Implemented in BundleCacheProvider.

File cacheVariant | ( | String | projectName,
 |  | String | variant,
 |  | IBundle | file,
 |  | String | version
 | ) |  |

Cache a variant bundle

Parameters
projectName | The name of the project to which this variant belongs
variant | The variant
file | The variant bundle
version | The version of the variant being cached
Returns
The folder containing the newly cached variant

Implemented in BundleCacheProvider.

String getLatestModelDataBuildInfo ( String projectName )

Get the project latest model data build information from cached project

Parameters
projectName The name of the project to retrieve
Returns
The latest model data build info if available, otherwise a null string

Implemented in BundleCacheProvider.

String getLatestVersionForProject ( String projectName )
Parameters
projectName The name of the project to get the version string for
Returns
The version string for the cached project, or null if it does not exist
File getProject | ( | String | projectName,
 |  | String | version
 | ) |  |

Retrieves a cached project directory from cache

Parameters
projectName | The name of the project to retrieve
version | The version of the project to retrieve
Returns
The folder containing the project, or null if it does not exist

Implemented in BundleCacheProvider.

File getVariant | ( | String | projectName,
 |  | String | variant,
 |  | String | version
 | ) |  |

Retrieves a cached project directory from cache

Parameters
projectName | The name of the project to which this variant belongs
variant | The variant to retrieve
version | The version of the variant to retrieve
Returns
The folder containing the variant, or null if it does not exist

Implemented in BundleCacheProvider.

The documentation for this interface was generated from the following file:
  • IBundleCacheProvider.java


Kofax Mobile SDK API Reference: IBundleFile Interface Reference

  • mobile
  • sdk
  • extract
  • id
  • bundle
  • IBundleFile
Public Member Functions | List of all members
IBundleFile Interface Reference

Public Member Functions

boolean | isDirectory ()
File | getFile ()
void | getFile (File output)
String | getAbsolutePath ()
String | getName ()

Detailed Description

An "abstract" representation of file system entity.

Member Function Documentation

String getAbsolutePath ( )

The absolute path within whatever storage container this IBundleFile resides. Implementation dependent.

Returns
The absolute path of this file
File getFile ( )

Creates a temporary file, and streams the bundle file to the temp file.

Returns
The file on disk
void getFile ( File output )

Streams the bundle file to the given file. Similar to getFile(), this override allows the caller to specify the location of the streamed file. When this method returns, it is safe to read from the file

Parameters
output The file to write to
String getName ( )

The name of this IBundleFile with no path information.

Returns
The file name
boolean isDirectory ( )

Indicates if this bundle file instance represents a directory on the underlying file system. The file may be, despite the name IBundleFile, a directory or a file.

Returns
true if this is a directory, false otherwise
The documentation for this interface was generated from the following file:
  • IBundleFile.java


Kofax Mobile SDK API Reference: ZipFileBundle Class Reference

  • mobile
  • sdk
  • extract
  • id
  • bundle
  • ZipFileBundle
Classes | Public Member Functions | List of all members
ZipFileBundle Class Reference
Inheritance diagram for ZipFileBundle:
IBundle

Public Member Functions

ZipFileBundle (ZipFile file)
Enumeration<?extends IBundleFile > | list ()
void | close () throws IOException

Constructor & Destructor Documentation

ZipFileBundle ( ZipFile file )

Member Function Documentation

void close ( ) throws IOException
Enumeration<? extends IBundleFile> list ( )

Implements IBundle.

The documentation for this class was generated from the following file:
  • ZipFileBundle.java


Kofax Mobile SDK API Reference: ZipInputStreamBundle Class Reference

  • mobile
  • sdk
  • extract
  • id
  • bundle
  • ZipInputStreamBundle
Classes | Public Member Functions | List of all members
ZipInputStreamBundle Class Reference
Inheritance diagram for ZipInputStreamBundle:
IBundle

Public Member Functions

ZipInputStreamBundle (ZipInputStream file)
ZipInputStreamBundle (InputStream file)
Enumeration<?extends IBundleFile > | list ()
boolean | hasMoreElements ()
IBundleFile nextElement ()
void | close () throws IOException

Constructor & Destructor Documentation

ZipInputStreamBundle ( ZipInputStream file )
ZipInputStreamBundle ( InputStream file )

Member Function Documentation

void close ( ) throws IOException
boolean hasMoreElements ( )
Enumeration<? extends IBundleFile> list ( )

Implements IBundle.

IBundleFile nextElement ( )
The documentation for this class was generated from the following file:
  • ZipInputStreamBundle.java


Kofax Mobile SDK API Reference: AggregateException Class Reference

  • mobile
  • sdk
  • extract
  • id
  • AggregateException
Public Member Functions | List of all members
AggregateException Class Reference
Inheritance diagram for AggregateException:

Public Member Functions

AggregateException (Exception front, Exception back)
Exception | getFrontException ()
Exception | getBackException ()

Detailed Description

An exception containing possible exception results for front, and back image extraction

Constructor & Destructor Documentation

AggregateException | ( | Exception | front,
 |  | Exception | back
 | ) |  |

Member Function Documentation

Exception getBackException ( )

Get the exception for the back image. May be null

Exception getFrontException ( )

Get the exception for the front image. May be null

The documentation for this class was generated from the following file:
  • AggregateException.java


Kofax Mobile SDK API Reference: DataField Class Reference

  • mobile
  • sdk
  • extract
  • id
  • DataField
Public Member Functions | Static Public Member Functions | List of all members
DataField Class Reference
Inheritance diagram for DataField:
Field< T extends Serializable >

Public Member Functions

DataField (String name, String object, double confidence, FieldLocation location)
double | getConfidence ()
String | getObject ()
- Public Member Functions inherited from Field< T extends Serializable >
Field (String name, T object, double confidence, FieldLocation location)
String | getName ()
double | getConfidence ()
T | getObject ()
FieldLocation getLocation ()
Field< T > | clone ()
String | toString ()
boolean | equals (Object o)
int | hashCode ()

Static Public Member Functions

static DataField fromExtractorField (com.kofax.android.abc.document.Field field)

Detailed Description

Represents a Field of data extracted from a document. This object is a direct extension of the Field type whose type parameter has been set to String. For more information on this class methods, see Field.

See also
Field

Constructor & Destructor Documentation

DataField | ( | String | name,
 |  | String | object,
 |  | double | confidence,
 |  | FieldLocation | location
 | ) |  |

Member Function Documentation

static DataField fromExtractorField ( com.kofax.android.abc.document.Field field )
static

For internal use only

double getConfidence ( )

The confidence field is a continuous value in the range (0,1) that reflects an overall estimate of the probability that the value is correct.

Returns
The field confidence
String getObject ( )
The documentation for this class was generated from the following file:
  • DataField.java


Kofax Mobile SDK API Reference: ICompletionListener< T > Interface Template Reference

  • mobile
  • sdk
  • extract
  • id
  • ICompletionListener
Public Member Functions | List of all members
ICompletionListener< T > Interface Template Reference

Public Member Functions

void onComplete (T obj, Exception e)

Detailed Description

A listener for extraction downloads.

Member Function Documentation

void onComplete | ( | T | obj,
 |  | Exception | e
 | ) |  |

Called when an asynchronous requested has completed.

Parameters
obj | The return object
e | Any exceptions that occurred
The documentation for this interface was generated from the following file:
  • ICompletionListener.java


Kofax Mobile SDK API Reference: IdExtractionParameters Class Reference

  • mobile
  • sdk
  • extract
  • id
  • IdExtractionParameters
Public Member Functions | Static Public Attributes | List of all members
IdExtractionParameters Class Reference

Public Member Functions

IdExtractionParameters (IdRegion region, IdType idType, Image frontImage, List< BarCodeResult > frontBarcodes, Image backImage, List< BarCodeResult > backBarcodes, boolean isProcessed, IIdExtractionListener listener)
IdExtractionParameters (String projectName, IdType idType, Image frontImage, List< BarCodeResult > frontBarcodes, Image backImage, List< BarCodeResult > backBarcodes, boolean isProcessed, IIdExtractionListener listener)
IIdExtractionListener getListener ()
IdRegion getRegion ()
String | getProjectName ()
IdType getIdType ()
Image getFrontImage ()
Image getBackImage ()
List< BarCodeResult > | getFrontBarcodes ()
List< BarCodeResult > | getBackBarcodes ()
boolean | isProcessed ()

Static Public Attributes

static final String | PREPROCESS_STRING = "_DeviceType_2_Do90DegreeRotation_4_DoCropCorrection__DoScaleImageToDPI_500_DoSkewCorrectionPage__DocDimLarge_3.375_DocDimSmall_2.125_LoadSetting_<Property Name=\"CSkewDetect.correct_illumination.Bool\" Value=\"0\" />"
static final String | PREPROCESS_PASSPORT_STRING = "_DeviceType_2_DoCropCorrection__DoSkewCorrectionAlt__Do90DegreeRotation_4_DoScaleImageToDPI_500_DocDimSmall_3.465_DocDimLarge_4.921_"
static final String | PREPROCESS_ID2_STRING = "_DeviceType_2_Do90DegreeRotation_4_DoCropCorrection__DoScaleImageToDPI_500_DoSkewCorrectionPage__DocDimLarge_4.134_DocDimSmall_2.913_LoadSetting_<Property Name=\"CSkewDetect.correct_illumination.Bool\" Value=\"0\" />"

Detailed Description

Parameter holder object for on-device extraction.

Any Image(s) may be pre-processed for de-skew and crop prior to sending it for extraction.

One or both images, or a barcode string is required.

Constructor & Destructor Documentation

IdExtractionParameters | ( | IdRegion | region,
 |  | IdType | idType,
 |  | Image | frontImage,
 |  | List< BarCodeResult > | frontBarcodes,
 |  | Image | backImage,
 |  | List< BarCodeResult > | backBarcodes,
 |  | boolean | isProcessed,
 |  | IIdExtractionListener | listener
 | ) |  |

Construct a new IdExtractionParameters object.

At least one of the frontImage, backImage, frontBarcode, backBarcode parameters is required. If using either image, any of the other parameters is optional. When using barcode strings, one or both of the image parameters is required.

Parameters
region | The region of the image(s) (cannot be null)
idType | The type of the document (cannot be null)
frontImage | Pass the front-side image (optional)
frontBarcodes | Pass the front-side barcode strings and types (optional)
backImage | Pass the back-side image (optional)
backBarcodes | Pass the back-side barcode strings and types (optional)
isProcessed | Whether the images passed are pre-processed or not. If true, the SDK will not pre-process both images before extraction. Otherwise, any processing required will be handled internally by the SDK.
listener | A callback that will be called with results and errors (cannot be null)
Exceptions
IllegalArgumentException When IdRegion or Listener is null, or if both the front image and barcode string are null
Deprecated:
As of SDK 3.3 replaced by IdExtractionParameters(String, IdType, Image, List<BarCodeResult>, Image, List<BarCodeResult>, boolean, IIdExtractionListener)
IdExtractionParameters | ( | String | projectName,
 |  | IdType | idType,
 |  | Image | frontImage,
 |  | List< BarCodeResult > | frontBarcodes,
 |  | Image | backImage,
 |  | List< BarCodeResult > | backBarcodes,
 |  | boolean | isProcessed,
 |  | IIdExtractionListener | listener
 | ) |  |

Construct a new IdExtractionParameters object.

At least one of the frontImage, backImage, frontBarcodes, backBarcodes parameters is required. If using either image, any of the other parameters is optional. When using barcodes, one or both of the image parameters is required for regions other than US and Canada.

Parameters
projectName | The region of the image(s) (cannot be null)
idType | The type of the document (cannot be null)
frontImage | Pass the front-side image (optional)
frontBarcodes | Pass the front-side barcode strings and types (optional)
backImage | Pass the back-side image (optional)
backBarcodes | Pass the back-side barcode strings and types (optional)
isProcessed | Whether the images passed are pre-processed or not. If true, the SDK will not pre-process both images before extraction. Otherwise, any processing required will be handled internally by the SDK.
listener | A callback that will be called with results and errors (cannot be null)
Exceptions
IllegalArgumentException | When projectName or idType or listener is null.
KmcRuntimeException | (KMC_GN_ILLEGAL_ARGUMENT_EXCEPTION) When both images and barcode lists are null.

Member Function Documentation

List<BarCodeResult> getBackBarcodes ( )
Image getBackImage ( )
List<BarCodeResult> getFrontBarcodes ( )
Image getFrontImage ( )
IdType getIdType ( )
IIdExtractionListener getListener ( )
String getProjectName ( )
IdRegion getRegion ( )
Deprecated:
As of SDK 3.3 replaced by getProjectName()
boolean isProcessed ( )

Member Data Documentation

final String PREPROCESS_ID2_STRING = "_DeviceType_2_Do90DegreeRotation_4_DoCropCorrection__DoScaleImageToDPI_500_DoSkewCorrectionPage__DocDimLarge_4.134_DocDimSmall_2.913_LoadSetting_<Property Name=\"CSkewDetect.correct_illumination.Bool\" Value=\"0\" />"
static
final String PREPROCESS_PASSPORT_STRING = "_DeviceType_2_DoCropCorrection__DoSkewCorrectionAlt__Do90DegreeRotation_4_DoScaleImageToDPI_500_DocDimSmall_3.465_DocDimLarge_4.921_"
static
final String PREPROCESS_STRING = "_DeviceType_2_Do90DegreeRotation_4_DoCropCorrection__DoScaleImageToDPI_500_DoSkewCorrectionPage__DocDimLarge_3.375_DocDimSmall_2.125_LoadSetting_<Property Name=\"CSkewDetect.correct_illumination.Bool\" Value=\"0\" />"
static
The documentation for this class was generated from the following file:
  • IdExtractionParameters.java


Kofax Mobile SDK API Reference: IdRegion Enum Reference

  • mobile
  • sdk
  • extract
  • id
  • IdRegion
Public Member Functions | Public Attributes | List of all members
IdRegion Enum Reference

Public Member Functions

IdRegion (String regionName)
String getRegionName ()

Public Attributes

US =("USIDs")
ASIA =("AsianIDs")
AUSTRALIA =("AustralianIDs")
CANADA =("CanadianIDs")
AFRICA =("AfricanIDs")
EUROPE =("EuropeanIDs")
LATIN_AMERICA =("LatinAmericanIDs")
String _regionName

Detailed Description

Used in conjunction with IdType for extraction to define which region the document being extracted is from.

Constructor & Destructor Documentation

IdRegion ( String regionName )

Member Function Documentation

String getRegionName ( )

Get the corresponding project name for this region

IdRegion.US.getRegionName() // returns "USIDs"
Returns
The project name

Member Data Documentation

String _regionName
AFRICA =("AfricanIDs")
ASIA =("AsianIDs")
AUSTRALIA =("AustralianIDs")
CANADA =("CanadianIDs")
EUROPE =("EuropeanIDs")
LATIN_AMERICA =("LatinAmericanIDs")
US =("USIDs")
The documentation for this enum was generated from the following file:
  • IdRegion.java


Kofax Mobile SDK API Reference: IdType Enum Reference

  • mobile
  • sdk
  • extract
  • id
  • IdType
Public Attributes | List of all members
IdType Enum Reference

Public Attributes

Id
Passport

Detailed Description

Used in conjunction with IdRegion to define what type of document is being sent for extraction

Member Data Documentation

Id
Passport
The documentation for this enum was generated from the following file:
  • IdType.java


Kofax Mobile SDK API Reference: IIdExtractionListener Interface Reference

  • mobile
  • sdk
  • extract
  • id
  • IIdExtractionListener
Public Member Functions | List of all members
IIdExtractionListener Interface Reference

Public Member Functions

void onExtractionComplete (IIdExtractionResult result, AggregateException exceptions)

Detailed Description

The listener interface for on-device extraction. Pass an implementation of this to the IIdExtractor#extractFields(IdExtractionParameters) method

Member Function Documentation

void onExtractionComplete | ( | IIdExtractionResult | result,
 |  | AggregateException | exceptions
 | ) |  |

The listener method called when on-device extraction has completed or cancellation was successful.

The documentation for this interface was generated from the following file:
  • IIdExtractionListener.java


Kofax Mobile SDK API Reference: IIdExtractionResult Interface Reference

  • mobile
  • sdk
  • extract
  • id
  • IIdExtractionResult
Public Member Functions | List of all members
IIdExtractionResult Interface Reference
Inheritance diagram for IIdExtractionResult:

Public Member Functions

String | classification ()
float | classificationConfidence ()
boolean | isBarcodeRead ()
boolean | isOcrRead ()
double | getDocumentVerificationConfidenceRating ()
List< DataField > | getFields ()

Detailed Description

Results from a call to on-device extraction.

Member Function Documentation

String classification ( )
Returns
The classification string
float classificationConfidence ( )
Returns
The confidence value for classification
double getDocumentVerificationConfidenceRating ( )

The verification rating is a combination of whether the front OCR succeeded, and whether the back bacode extraction and parsing completed. Furthermore, if the front and back extraction do succeed, their data are compared to further refine the confidence.

List<DataField> getFields ( )

The unified fields extracted from the front and back images or barcode.

boolean isBarcodeRead ( )

Whether the barcode was read or parsed

boolean isOcrRead ( )

Whether OCR was run on the front image

The documentation for this interface was generated from the following file:
  • IIdExtractionResult.java


Kofax Mobile SDK API Reference: IIdExtractor Interface Reference

  • mobile
  • sdk
  • extract
  • id
  • IIdExtractor
Public Member Functions | List of all members
IIdExtractor Interface Reference
Inheritance diagram for IIdExtractor:
OnDeviceIdExtractor

Public Member Functions

void | extractFields (IdExtractionParameters parameters)
void | cancel ()

Detailed Description

Defines an interface for on-device extraction

Member Function Documentation

void cancel ( )

Implemented in OnDeviceIdExtractor.

void extractFields ( IdExtractionParameters parameters )

Implemented in OnDeviceIdExtractor.

The documentation for this interface was generated from the following file:
  • IIdExtractor.java


Kofax Mobile SDK API Reference: IProjectProvider Interface Reference

  • mobile
  • sdk
  • extract
  • id
  • IProjectProvider
Public Member Functions | List of all members
IProjectProvider Interface Reference
Inheritance diagram for IProjectProvider:
LocalProjectProvider ServerProjectProvider

Public Member Functions

void | getHighestVersion (final String projectName, final String sdkVersion, final ICompletionListener< String > listener)
void | getProject (final String projectName, final String version, final ICompletionListener< File > listener)
void | getVariant (final String projectName, final String variantName, final String version, final ICompletionListener< File > listener)
String | getLatestCachedModelDataBuildInfo (String projectName)

Detailed Description

Specifies the interface required to satisfy extraction dependencies

Member Function Documentation

void getHighestVersion | ( | final String | projectName,
 |  | final String | sdkVersion,
 |  | final ICompletionListener< String > | listener
 | ) |  |

Get the highest version string for the given project that is compatible with the given SDK version

Note: The listener's object parameter will be null, or a string representing the highest compatible version

Parameters
projectName | The name of the project
sdkVersion | The version of the SDK that must be compatible
listener | A completion listener. If this is null, no work will be done.

Implemented in ServerProjectProvider, and LocalProjectProvider.

String getLatestCachedModelDataBuildInfo ( String projectName )

Get the project latest model data build information from cached project

Parameters
projectName The name of the project to retrieve
Returns
The latest model data build info if available, otherwise a null string

Implemented in ServerProjectProvider, and LocalProjectProvider.

void getProject | ( | final String | projectName,
 |  | final String | version,
 |  | final ICompletionListener< File > | listener
 | ) |  |

Get the project bundle for the given version

Note: The listener's object parameter will be a ZIP containing the top-level project files, including the fields.xml, classifier configurations, and cities.zip, and a file listing the available variants

Parameters
projectName | The name of the project
version | The version of the project
listener | A completion listener. If this is null, no work will be done.

Implemented in ServerProjectProvider, and LocalProjectProvider.

void getVariant | ( | final String | projectName,
 |  | final String | variantName,
 |  | final String | version,
 |  | final ICompletionListener< File > | listener
 | ) |  |

Get a variant for the given version for the given project

Note: The listener's object parameter will be a ZIP containing the variant-specific files

Parameters
projectName | The name of the project
variantName | The name of the variant
version | The version of the variant (this should match the same version string retrieved from getHighestVersion(String, String, ICompletionListener)
listener | A completion listener. If this is null, no work will be done.

Implemented in ServerProjectProvider, and LocalProjectProvider.

The documentation for this interface was generated from the following file:
  • IProjectProvider.java


Kofax Mobile SDK API Reference: ListOfException Class Reference

  • mobile
  • sdk
  • extract
  • id
  • ListOfException
Public Member Functions | List of all members
ListOfException Class Reference
Inheritance diagram for ListOfException:

Public Member Functions

ListOfException (String detailMessage, Throwable[] innerThrowables)
ListOfException (String detailMessage, List<?extends Throwable > innerThrowables)
ListOfException (List<?extends Throwable > innerThrowables)
List< Throwable > | getInnerThrowables ()
void | printStackTrace (PrintStream err)
void | printStackTrace (PrintWriter err)

Detailed Description

Aggregates multiple

Throwable

s that may be thrown in the process of a task's execution.

Constructor & Destructor Documentation

ListOfException | ( | String | detailMessage,
 |  | Throwable[] | innerThrowables
 | ) |  |

Constructs a new

ListOfException

with the current stack trace, the specified detail message and with references to the inner throwables that are the cause of this exception.

Parameters
detailMessage | The detail message for this exception.
innerThrowables | The exceptions that are the cause of the current exception.
ListOfException | ( | String | detailMessage,
 |  | List<?extends Throwable > | innerThrowables
 | ) |  |

Constructs a new

ListOfException

with the current stack trace, the specified detail message and with references to the inner throwables that are the cause of this exception.

Parameters
detailMessage | The detail message for this exception.
innerThrowables | The exceptions that are the cause of the current exception.
ListOfException ( List<?extends Throwable > innerThrowables )

Constructs a new

ListOfException

with the current stack trace and with references to the inner throwables that are the cause of this exception.

Parameters
innerThrowables The exceptions that are the cause of the current exception.

Member Function Documentation

List<Throwable> getInnerThrowables ( )

Returns a read-only List of the Throwable instances that caused the current exception.

void printStackTrace ( PrintStream err )
void printStackTrace ( PrintWriter err )
The documentation for this class was generated from the following file:
  • ListOfException.java


Kofax Mobile SDK API Reference: LocalProjectProvider Class Reference

  • mobile
  • sdk
  • extract
  • id
  • LocalProjectProvider
Classes | Public Member Functions | Protected Member Functions | List of all members
LocalProjectProvider Class Reference
Inheritance diagram for LocalProjectProvider:
IProjectProvider

Classes

class VersionTable

Public Member Functions

LocalProjectProvider (Context ctx)
LocalProjectProvider (Context ctx, InputStream projectZipStream, IBundleCacheProvider cacheProvider)
void | getHighestVersion (final String projectName, final String sdkVersion, final ICompletionListener< String > listener)
void | getProject (final String projectName, final String version, final ICompletionListener< File > listener)
void | getVariant (final String projectName, final String variantName, final String version, final ICompletionListener< File > listener)
String | getLatestCachedModelDataBuildInfo (String projectName)

Protected Member Functions

String | getBundleVersion (String projectName)
String | readVersion (File versionTable)
String | readVersion (String jsonContent)
String | sdkVersion ()
Task< File > | getProjectAsync (final String projectName, final String version)
Task< File > | getVariantAsync (final String projectName, final String variantName, final String version)
void | finalize () throws Throwable

Detailed Description

A reference implementation of IProjectProvider that uses a project zip input stream, or reads the project zip from assets.

Constructor & Destructor Documentation

LocalProjectProvider ( Context ctx )

This constructor will create an instance using the default IBundleCacheProvider. This implementation will assume a project zip exists in the root of the project's assets, named according to the project name. E.g. IdRegion#getRegionName().zip ("USIDs.zip").

Parameters
ctx This context
LocalProjectProvider | ( | Context | ctx,
 |  | InputStream | projectZipStream,
 |  | IBundleCacheProvider | cacheProvider
 | ) |  |

This constructor allows specification of the project input stream and a IBundleCacheProvider. It's possible when using this constructor to place the project bundle anywhere on, or off the device, by providing its stream here.

Note
It is the callers responsibility to close the input stream object.
Parameters
ctx | This context
projectZipStream | An input stream to the project zip file
cacheProvider | The cache provider used to store files

Member Function Documentation

void finalize ( ) throws Throwable
protected

Deletes the temporary working file if one exists.

Exceptions
Throwable
String getBundleVersion ( String projectName )
protected

Retrieves the project bundle's version string.

Parameters
projectName The name of the project to get the version for
Returns
The version string
void getHighestVersion | ( | final String | projectName,
 |  | final String | sdkVersion,
 |  | final ICompletionListener< String > | listener
 | ) |  |

Get the highest version string for the given project that is compatible with the given SDK version

Note: The listener's object parameter will be null, or a string representing the highest compatible version

Parameters
projectName | The name of the project
sdkVersion | The version of the SDK that must be compatible
listener | A completion listener. If this is null, no work will be done.

Implements IProjectProvider.

String getLatestCachedModelDataBuildInfo ( String projectName )

Get the project latest model data build information from cached project

Parameters
projectName The name of the project to retrieve
Returns
The latest model data build info if available, otherwise a null string

Implements IProjectProvider.

void getProject | ( | final String | projectName,
 |  | final String | version,
 |  | final ICompletionListener< File > | listener
 | ) |  |

Get the project bundle for the given version

Note: The listener's object parameter will be a ZIP containing the top-level project files, including the fields.xml, classifier configurations, and cities.zip, and a file listing the available variants

Parameters
projectName | The name of the project
version | The version of the project
listener | A completion listener. If this is null, no work will be done.

Implements IProjectProvider.

Task<File> getProjectAsync | ( | final String | projectName,
 |  | final String | version
 | ) |  |
protected
void getVariant | ( | final String | projectName,
 |  | final String | variantName,
 |  | final String | version,
 |  | final ICompletionListener< File > | listener
 | ) |  |

Get a variant for the given version for the given project

Note: The listener's object parameter will be a ZIP containing the variant-specific files

Parameters
projectName | The name of the project
variantName | The name of the variant
version | The version of the variant (this should match the same version string retrieved from getHighestVersion(String, String, ICompletionListener)
listener | A completion listener. If this is null, no work will be done.

Implements IProjectProvider.

Task<File> getVariantAsync | ( | final String | projectName,
 |  | final String | variantName,
 |  | final String | version
 | ) |  |
protected
String readVersion ( File versionTable )
protected

Given the file of the version table, parses the table, and retrieves the version compatible with this SDK version.

Normally, a project bundle will only include a single version. This implementation simply ensures the bundle is formatted properly.

Parameters
versionTable The version table
Returns
The compatible version.
String readVersion ( String jsonContent )
protected
String sdkVersion ( )
protected
The documentation for this class was generated from the following file:
  • LocalProjectProvider.java


Kofax Mobile SDK API Reference: LocalProjectProvider.VersionTable Class Reference

  • mobile
  • sdk
  • extract
  • id
  • LocalProjectProvider
  • VersionTable
Classes | Public Attributes | List of all members
LocalProjectProvider.VersionTable Class Reference

Classes

class VersionList

Public Attributes

VersionList[] VersionList

Detailed Description

Represents the JSON layout of the version table for parsing with GSON.

Member Data Documentation

VersionList [] VersionList
The documentation for this class was generated from the following file:
  • LocalProjectProvider.java


Kofax Mobile SDK API Reference: LocalProjectProvider.VersionTable.VersionList Class Reference

  • mobile
  • sdk
  • extract
  • id
  • LocalProjectProvider
  • VersionTable
  • VersionList
Public Attributes | List of all members
LocalProjectProvider.VersionTable.VersionList Class Reference

Public Attributes

String | sdkMajor
String | sdkMinor
String | dataVersion

Member Data Documentation

String dataVersion
String sdkMajor
String sdkMinor
The documentation for this class was generated from the following file:
  • LocalProjectProvider.java


Kofax Mobile SDK API Reference: OnDeviceIdExtractor Class Reference

  • mobile
  • sdk
  • extract
  • id
  • OnDeviceIdExtractor
Classes | Public Member Functions | List of all members
OnDeviceIdExtractor Class Reference
Inheritance diagram for OnDeviceIdExtractor:
IIdExtractor

Public Member Functions

OnDeviceIdExtractor (Context ctx)
OnDeviceIdExtractor (Context ctx, IProjectProvider projectProvider)
void | extractFields (IdExtractionParameters parameters)
void | cancel ()

Detailed Description

On-device ID extractor.

This class enables field extraction of images of ID documents without having to call to a remote server.

Constructor & Destructor Documentation

OnDeviceIdExtractor ( Context ctx )

Create an extractor using the default IProjectProvider.

Parameters
ctx This context
OnDeviceIdExtractor | ( | Context | ctx,
 |  | IProjectProvider | projectProvider
 | ) |  |

Create an extractor using the given IProjectProvider.

To override the default project provider, create one, and pass it to the extractor constructor (this configuration uses the default):

IProjectProvider projectProvider = new ServerProjectProvider(myActivity.this, "http://someServer.com/api/path");
new OnDeviceIdExtractor(MyActivity.this, projectProvider).extractFields(...);

To override the default project provider, cache or both, create custom classes and pass the custom project provider the extractor:

public class MyCustomProjectProvider implements IProjectProvider { ... }
public class MyCustomCacheProvider implements MyCustomCacheInterface { ... }
IProjectProvider projectProvider = new MyCustomProjectProvider(new MyCustomCacheProvider(), "http://someServer.com/api/path");
new OnDeviceIdExtractor(MyActivity.this, projectProvider).extractFields(...);

Here's an example of customizing just the IProjectProvider, but using default cache:

public class MyCustomProjectProvider implements IProjectProvider {
public MyCustomProjectProvider(IBundleCacheProvider cacheProvider);
...
}
File cacheFolder = new File('/storage/path/folder');
IProjectProvider projectProvider = new MyCustomProjectProvider(new BundleCacheProvider(cacheFolder), "http://someServer.com/api/path");
new OnDeviceIdExtractor(MyActivity.this, projectProvider).extractFields(...);
Parameters
ctx | This context
projectProvider | The IProjectProvider to use for config/models

Member Function Documentation

void cancel ( )

Cancel an outstanding extraction process. If this method is called while no extraction is outstanding a ErrorInfo#KMC_EV_CANCEL_OPERATION_SUCCESS exception is thrown directly.

If cancellation was not possible, the listener is called with results and/or AggregateException as normal.

If cancellation was successful, the listener is called with null results, and ErrorInfo#KMC_EV_CANCEL_OPERATION_SUCCESS as the exception returned from AggregateException#getFrontException()

Implements IIdExtractor.

void extractFields ( IdExtractionParameters parameters )

It is required to have an On-device extraction license before calling this method.

This method is asynchronous and will call the listener within the parameters object.

This method is not re-entrant. An exception will be thrown if the method is entered while extraction is outstanding.

Passing an image of a passport requires that you use a IdExtractionParameters constructor with the IdType value set to IdType#Passport. Regardless of whether classification succeeds, the MRZ data on the passport image may be parsed. MRZ data overrides any OCR data extracted from any passport.

In the situations where the region and ID type dictate that the image (front and/or back) contains a barcode, that barcode may be read and parsed. Barcode data overrides any MRZ or OCR image data if there are conflicts.

Images passed to this method may be pre-processed for crop and de-skew; however, pre-processing can lower the reliability of reading any barcodes that may be present. When sending raw images, any processing required will be handled internally by the SDK. If images are to be pre-processed using the com.kofax.kmc.ken.engines.ImageProcessor, the image must be processed by loading the IdExtractionParameters#PREPROCESS_STRING string into your com.kofax.kmc.ken.engines.data.ImagePerfectionProfile

Parameters
parameters The extraction parameters
See also
Licensing#addVolumeLicenseEventListener(VolumeLicenseEventListener)
cancel()

Implements IIdExtractor.

The documentation for this class was generated from the following file:
  • OnDeviceIdExtractor.java


Kofax Mobile SDK API Reference: ProjectProviderException Class Reference

  • mobile
  • sdk
  • extract
  • id
  • ProjectProviderException
Public Member Functions | List of all members
ProjectProviderException Class Reference
Inheritance diagram for ProjectProviderException:

Public Member Functions

ProjectProviderException (Exception e)
ProjectProviderException (Throwable t)
ProjectProviderException (String e)

Detailed Description

Exception thrown by the IProjectProviders

Constructor & Destructor Documentation

ProjectProviderException ( Exception e )
ProjectProviderException ( Throwable t )
ProjectProviderException ( String e )
The documentation for this class was generated from the following file:
  • ProjectProviderException.java


Kofax Mobile SDK API Reference: ServerProjectProvider Class Reference

  • mobile
  • sdk
  • extract
  • id
  • ServerProjectProvider
Classes | Public Member Functions | Protected Member Functions | List of all members
ServerProjectProvider Class Reference
Inheritance diagram for ServerProjectProvider:
IProjectProvider

Classes

class | Error
class | HttpClientHolder

Public Member Functions

ServerProjectProvider (Context ctx, String baseUrl) throws MalformedURLException
ServerProjectProvider (Context ctx, IBundleCacheProvider cacheProvider, String baseUrl, ConnectivityManager connectivityManager) throws MalformedURLException
void | setCertificateValidatorListener (CertificateValidatorListener certificateValidatorListener)
void | setRequestTimeout (long duration, TimeUnit timeUnit)
void | getHighestVersion (final String projectName, final String sdkVersion, final ICompletionListener< String > listener)
String | getLatestCachedModelDataBuildInfo (String projectName)
void | getProject (final String projectName, final String version, final ICompletionListener< File > listener)
void | getVariant (final String projectName, final String variantName, final String version, final ICompletionListener< File > listener)
void | loadAllVariantsForProject (final String projectName, final ICompletionListener< Void > listener)
void | cancelLoadAllVariants ()

Protected Member Functions

Task< String > | getHighestVersionAsync (final String projectName, final String sdkVersion, final boolean bulk)
String | sdkVersion ()

Detailed Description

A reference implementation of IProjectProvider that downloads assets from a Kofax Quick Updater service instance

Note: it is required for the app or user to have android.permission.ACCESS_NETWORK_STATE permission before calling any method in this class

Constructor & Destructor Documentation

ServerProjectProvider | ( | Context | ctx,
 |  | String | baseUrl
 | ) |  | throws MalformedURLException

Create a new ServerProjectProvider using the Kofax Quick Updater server instance at the given base URL.

Parameters
ctx | This context
baseUrl | The Kofax Quick Updater instance URL

Unfortunately, because of this constructor, we cannot check the validity of the cache provider and connectivity parameters.

ServerProjectProvider | ( | Context | ctx,
 |  | IBundleCacheProvider | cacheProvider,
 |  | String | baseUrl,
 |  | ConnectivityManager | connectivityManager
 | ) |  | throws MalformedURLException

Create a new ServerProjectProvider using a custom cache provider, using the Kofax Quick Updater server instance at the given base URL.

Parameters
ctx | This context
cacheProvider | The cache provider
baseUrl | The Kofax Quick Updater instance URL
connectivityManager | A connectivity manager for checking network status

Member Function Documentation

void cancelLoadAllVariants ( )

Cancels any outstanding tasks related to loadAllVariantsForProject(String, ICompletionListener)

This function will do nothing if no tasks are outstanding.

If there are outstanding tasks, the ICompletionListener passed to loadAllVariantsForProject(String, ICompletionListener) will be called with a cancel success message

void getHighestVersion | ( | final String | projectName,
 |  | final String | sdkVersion,
 |  | final ICompletionListener< String > | listener
 | ) |  |

This implementation keeps a map of project names to a map of sdk versions to model versions. If the map contains an entry for the key pair {projectName, sdkVersion}, that value is returned, and no work is done.

If no entry exists, the network connection is checked. If a network connection exists, a server call is attempted. If that value is returned, it is stored in the map and returned.

If a server response is not acquired, local cached is checked. If a local version exists, that version is stored in the map and returned.

If no map entry exists, no network connection exists or a server call fails, and finally no cache exists, a ProjectProviderException is thrown with a message indicating work cannot continue.

Parameters
projectName | The name of the project
sdkVersion | The version of the SDK that must be compatible
listener | A completion listener. If this is null, no work will be done.

Implements IProjectProvider.

Task<String> getHighestVersionAsync | ( | final String | projectName,
 |  | final String | sdkVersion,
 |  | final boolean | bulk
 | ) |  |
protected
String getLatestCachedModelDataBuildInfo ( String projectName )

Get the project latest model data build information from cached project

Parameters
projectName The name of the project to retrieve
Returns
The latest model data build info if available, otherwise a null string

Implements IProjectProvider.

void getProject | ( | final String | projectName,
 |  | final String | version,
 |  | final ICompletionListener< File > | listener
 | ) |  |

Returns the directory containing the project files. If the project files already exist in the provided IBundleCacheProvider, those will be used.

If no cache version exists, the network connection is checked. If a network connection exists, a server call is attempted. If the files are acquired from the server, they are cached and returned.

If no cache exists, and either there's no network connection or a server error, an exception is thrown with a message indicating work cannot continue.

Parameters
projectName | The name of the project
version | The version of the project
listener | A completion listener. If this is null, no work will be done.

Implements IProjectProvider.

void getVariant | ( | final String | projectName,
 |  | final String | variantName,
 |  | final String | version,
 |  | final ICompletionListener< File > | listener
 | ) |  |

Returns the directory containing the variant files. If the variant files already exist in the provided IBundleCacheProvider, those will be used.

If no cache version exists, the network connection is checked. If a network connection exists, a server call is attempted. If the files are acquired from the server, they are cached and returned.

If no cache exists, and either there's no network connection or a server error, an exception is thrown with a message indicating work cannot continue.

Parameters
projectName | The name of the project
variantName | The name of the variant
version | The version of the variant (this should match the same version string retrieved from getHighestVersion(String, String, ICompletionListener)
listener | A completion listener. If this is null, no work will be done.

Implements IProjectProvider.

void loadAllVariantsForProject | ( | final String | projectName,
 |  | final ICompletionListener< Void > | listener
 | ) |  |

Loads all the variants for a given project. This method uses the SdkVersion#getSdkVersion() when calling getHighestVersion(String, String, ICompletionListener). Subsequently, it retrieves the project files, and uses the contained variants list to download each variant.

If a variant already exists in the provided IBundleCacheProvider, it will not be re-downloaded.

Parameters
projectName | The name of the project to load
listener | A listener to call when loading is complete. The type argument is Void because no object is returned.
String sdkVersion ( )
protected
void setCertificateValidatorListener ( CertificateValidatorListener certificateValidatorListener )

Sets the SSL certificate validator listener.

The listener receives certificate validation challenges in response to an authentication request from the Kofax Quick Updater instance.

Parameters
certificateValidatorListener
See also
CertificateValidatorListener
void setRequestTimeout | ( | long | duration,
 |  | TimeUnit | timeUnit
 | ) |  |

Change the connection timeout.

This parameter corresponds to all connection timeouts: connect, read and write. If any operation exceeds the timeout, the process is cancelled, and an exception will be raised.

Note: This sets the timeout for new connections. A value of 0 means no timeout, otherwise values must be between 1 and Integer::MAX_VALUE when converted to milliseconds.

Parameters
duration | The amount of the timeout
timeUnit | The time unit associated with the duration
Exceptions
IllegalArgumentException
The documentation for this class was generated from the following file:
  • ServerProjectProvider.java


Kofax Mobile SDK API Reference: ServerProjectProvider.Error Class Reference

  • mobile
  • sdk
  • extract
  • id
  • ServerProjectProvider
  • Error
Public Attributes | List of all members
ServerProjectProvider.Error Class Reference

Public Attributes

String | message
String | Message

Member Data Documentation

String message
String Message
The documentation for this class was generated from the following file:
  • ServerProjectProvider.java


Kofax Mobile SDK API Reference: ExtractionServerException Class Reference

  • mobile
  • sdk
  • extract
  • server
  • ExtractionServerException
Public Member Functions | List of all members
ExtractionServerException Class Reference
Inheritance diagram for ExtractionServerException:

Public Member Functions

ExtractionServerException (int _code, String _message)
String | getMessage ()
int | getCode ()

Detailed Description

Exception thrown by the ExtractionServerException

Constructor & Destructor Documentation

ExtractionServerException | ( | int | _code,
 |  | String | _message
 | ) |  |

Member Function Documentation

int getCode ( )
String getMessage ( )
The documentation for this class was generated from the following file:
  • ExtractionServerException.java


Kofax Mobile SDK API Reference: IServerExtractor Interface Reference

  • mobile
  • sdk
  • extract
  • server
  • IServerExtractor
Public Member Functions | List of all members
IServerExtractor Interface Reference

Public Member Functions

void | login (LoginCredentials loginCredentials, ICompletionListener< String > completionListener)
void | extractData (ServerExtractionParameters serverExtractionParameters, ICompletionListener< String > completionListener)
void | cancelExtraction ()

Detailed Description

Specifies the interface required to satisfy RTTI/KTA dependencies.

Member Function Documentation

void cancelExtraction ( )

Cancel an outstanding extraction process. If this method is called while no extraction is outstanding a ErrorInfo#KMC_EV_CANCEL_OPERATION_SUCCESS exception is thrown directly.

If cancellation was not possible, the listener is called with results and/or Exception as normal.

If cancellation was successful, the listener is called with null results, and ErrorInfo#KMC_EV_CANCEL_OPERATION_SUCCESS as the exception.

void extractData | ( | ServerExtractionParameters | serverExtractionParameters,
 |  | ICompletionListener< String > | completionListener
 | ) |  |

Extracts the data from the given images in the ServerExtractionParameters. If extraction fails ExtractionServerException will be thrown with a proper message and code.

Parameters
serverExtractionParameters | - The data extraction parameters.
completionListener | - A completion listener, return result as well as Exception if it fails.
void login | ( | LoginCredentials | loginCredentials,
 |  | ICompletionListener< String > | completionListener
 | ) |  |

Login to the server and returns sessionID, required for KtaServer. If login fails ExtractionServerException will be thrown with a proper message and code.

Login not required for RttiServer, An ErrorInfo#KMC_GN_LOGIN_NOT_APPLICABLE exception will be thrown directly.

Parameters
loginCredentials | - Contains the username, password, and serverUrl.
completionListener | - A completion listener, return result as well as Exception if it fails.
The documentation for this interface was generated from the following file:
  • IServerExtractor.java


Kofax Mobile SDK API Reference: LoginCredentials Class Reference

  • mobile
  • sdk
  • extract
  • server
  • LoginCredentials
Public Member Functions | List of all members
LoginCredentials Class Reference

Public Member Functions

LoginCredentials (String ktaUserName, String ktaPassword, String serverUrl, CertificateValidatorListener certificateValidatorListener, TimeOutParameters timeOutParameters)
String | getKtaUserName ()
String | getKtaPassword ()
String | getServerUrl ()
CertificateValidatorListener getCertificateValidatorListener ()
TimeOutParameters getTimeOutParameters ()

Detailed Description

The LoginCredentials class. This Object allows specification of server credentials.

Constructor & Destructor Documentation

LoginCredentials | ( | String | ktaUserName,
 |  | String | ktaPassword,
 |  | String | serverUrl,
 |  | CertificateValidatorListener | certificateValidatorListener,
 |  | TimeOutParameters | timeOutParameters
 | ) |  |
Parameters
ktaUserName | - The Kta UserName.
ktaPassword | - The Kta Password.
serverUrl | - The URL of the server.
certificateValidatorListener | - This Interface defines a method that you may implement for custom certificate pinning logic.
timeOutParameters | - This contains time out parameters. -

Member Function Documentation

CertificateValidatorListener getCertificateValidatorListener ( )
String getKtaPassword ( )
String getKtaUserName ( )
String getServerUrl ( )
TimeOutParameters getTimeOutParameters ( )
The documentation for this class was generated from the following file:
  • LoginCredentials.java


Kofax Mobile SDK API Reference: ServerBuilder Class Reference

  • mobile
  • sdk
  • extract
  • server
  • ServerBuilder
Classes | Static Public Member Functions | List of all members
ServerBuilder Class Reference

Classes

enum ServerType

Static Public Member Functions

static IServerExtractor build (Context context, ServerType type)

Detailed Description

This class will create a reference implementation depending on the ServerType(RTTI/KTA)

Member Function Documentation

static IServerExtractor build | ( | Context | context,
 |  | ServerType | type
 | ) |  |
static

This method will provide the IServerExtractor reference implementation.

Parameters
context | - this context
type | - ServerType (RTTI/KTA)
The documentation for this class was generated from the following file:
  • ServerBuilder.java


Kofax Mobile SDK API Reference: ServerBuilder.ServerType Enum Reference

  • mobile
  • sdk
  • extract
  • server
  • ServerBuilder
  • ServerType
Public Attributes | List of all members
ServerBuilder.ServerType Enum Reference

Public Attributes

RTTI
KTA

Member Data Documentation

KTA
RTTI
The documentation for this enum was generated from the following file:
  • ServerBuilder.java


Kofax Mobile SDK API Reference: ServerExtractionParameters Class Reference

  • mobile
  • sdk
  • extract
  • server
  • ServerExtractionParameters
Public Member Functions | List of all members
ServerExtractionParameters Class Reference

Public Member Functions

ServerExtractionParameters (String serverUrl, List< Image > images, List< byte[]> imageBytes, CertificateValidatorListener certificateValidationListener, HashMap< String, String > parameters, TimeOutParameters timeOutParameters)
String | getServerUrl ()
List< Image > | getImages ()
List< byte[]> | getImageBytes ()
CertificateValidatorListener getCertificateValidationListener ()
HashMap< String, String > | getParameters ()
TimeOutParameters getTimeOutParameters ()

Detailed Description

Parameter holder object for server extraction.

Images (or) ImageBytes should be present for extraction, If both are present then the priority will be given to ImageBytes

Constructor & Destructor Documentation

ServerExtractionParameters | ( | String | serverUrl,
 |  | List< Image > | images,
 |  | List< byte[]> | imageBytes,
 |  | CertificateValidatorListener | certificateValidationListener,
 |  | HashMap< String, String > | parameters,
 |  | TimeOutParameters | timeOutParameters
 | ) |  |

Construct a new ServerExtractionParameters object

If the connection is RTTI then the 'x' parameters need to be sent as key-value pairs using the java.util.HashMap. If the connection is KTA, below are the recommendations.

The KTA supports the following key-value pairs: "DocumentName","DocumentTypeId","FilePath","FolderId","FolderTypeId","ReturnFullTextOcr" in the Documents section. "ReturnAllFields" is set to true always and hence there is no support for the key "RunTimeFields", "sessionId" - retrieved from successful login to KTA server "processIdentityName" - the name of the process identity. (For example, KofaxMobileIDSync) "StartDate" and "StoreFolderAndDocuments" are supported.

KTA API : you can add a key "syncProcessMap" which takes a boolean value to specify the KTA API to be used. Two main APIs are supported i.e. CreateJobSyncWithDocuments and CreateJobWithDocumentsAndProgress2. If the value is set to true, "CreateJobSyncWithDocuments" is used and if it is set to false "CreateJobWithDocumentsAndProgress2" is used. On a general note, extraction uses "CreateJobSyncWithDocuments". So it is recommended to set this value true for extraction. If this key is not added, a default true value is assumed.

If the response from the server needs to contain certain variables you can set the key "variablesToReturn" and value as json array in java.lang.String format.

JSONArray _jsonArray = new JSONArray();
HashMap _hashMap = new HashMap();
_hashMap.put("sessionId", "xxx-xxx-xxx");
_hashMap.put("variablesToReturn", _jsonArray.toString());
Parameters
serverUrl | The URL of the Server (cannot be null).
images | List of Image Objects.
imageBytes | List of ImageBytes.
certificateValidationListener | This Interface defines a method that you may implement for custom certificate pinning logic.
parameters | This contains the parameters that are to be sent in the request to server.
timeOutParameters | This contains time out parameters. -

Member Function Documentation

CertificateValidatorListener getCertificateValidationListener ( )
List<byte[]> getImageBytes ( )
List<Image> getImages ( )
HashMap<String, String> getParameters ( )
String getServerUrl ( )
TimeOutParameters getTimeOutParameters ( )
The documentation for this class was generated from the following file:
  • ServerExtractionParameters.java


Kofax Mobile SDK API Reference: TimeOutParameters Class Reference

  • mobile
  • sdk
  • extract
  • server
  • TimeOutParameters
Public Member Functions | List of all members
TimeOutParameters Class Reference

Public Member Functions

TimeOutParameters (long duration, TimeUnit timeUnit)
long | getTimeOut ()
TimeUnit | getUnit ()

Detailed Description

The TimeOutParameters class. This class corresponds to all connection timeouts: connect, read and write. If any operation exceeds the timeout, the process is cancelled, and an exception will be raised. A value of 0 means no timeout, otherwise values must be between 1 and Integer::MAX_VALUE when converted to milliseconds.

Constructor & Destructor Documentation

TimeOutParameters | ( | long | duration,
 |  | TimeUnit | timeUnit
 | ) |  |
Parameters
duration | The amount of the timeout
timeUnit | The time unit associated with the duration
Exceptions
IllegalArgumentException

Member Function Documentation

long getTimeOut ( )
TimeUnit getUnit ( )
The documentation for this class was generated from the following file:
  • TimeOutParameters.java


Kofax Mobile SDK API Reference: CaptureServer Class Reference

  • mobile
  • sdk
  • logistics
  • CaptureServer
Public Member Functions | List of all members
CaptureServer Class Reference
Inheritance diagram for CaptureServer:
ICaptureServer

Public Member Functions

CaptureServer (String serverURL, SourceServer sourceServer)
void | setCertificateValidatorListener (CertificateValidatorListener certificateValidatorListener)
void | setServerTimeout (int timeout)
Change the connection timeout. More...
int | getServerTimeout ()
Get the connection timeout (in seconds). More...
void | registerDevice (final ICompletionListener< Void > completionListener)
Register a mobile device with the server and obtain a license, if available. More...
void | login (UserProfile userProfile, final ICompletionListener< List< String >> completionListener)
Login to the server using credentials from the UserProfile object. More...
void | loginAnonymously (final ICompletionListener< List< String >> completionListener)
Fetches the device profile shortcuts from the server. More...
void | logout (final ICompletionListener< Void > completionListener)
Logout from the Server if logged in. More...
void | getDocumentType (String documentTypeName, final ICompletionListener< DocumentType > completionListener)
Returns the DocumentType object which corresponds to the documentTypeName Specified. More...
void | startJobService (final ICompletionListener< String > completionListener)
This will start a new document submission job on the server. More...
void | sendImageService (Document document, String jobID, Image image, int ImageIndex, boolean lastImage, final ICompletionListener< Void > completionListener)
Sends an Image to the server. More...
void | submitDocument (Document document, IProgressListener iProgressListener, final ICompletionListener iCompletionListener)
ErrorInfo | cancelSubmission (String submitJobID)
- Public Member Functions inherited from ICaptureServer
void | registerDevice (ICompletionListener< Void > completionListener)
void | login (UserProfile userProfile, ICompletionListener< List< String >> completionListener)
void | loginAnonymously (ICompletionListener< List< String >> completionListener)
void | logout (ICompletionListener< Void > completionListener)
void | getDocumentType (String documentTypeName, ICompletionListener< DocumentType > completionListener)
void | startJobService (ICompletionListener< String > completionListener)
void | sendImageService (Document document, String jobID, Image image, int ImageIndex, boolean lastImage, ICompletionListener< Void > completionListener)
void | submitDocument (Document document, IProgressListener iProgressListener, ICompletionListener iCompletionListener)

Detailed Description

A reference implementation of ICaptureServer that allows you to login, download a list of Document Types from the server and submit application-created documents to the server. Server communication requires a valid license to be set.

Constructor & Destructor Documentation

CaptureServer | ( | String | serverURL,
 |  | SourceServer | sourceServer
 | ) |  |

Create a new CaptureServer using the given server URL and SourceServer.

Parameters
serverURL | The URL of the server.
sourceServer | Type of the Server
Exceptions
KmcRuntimeException | (KMC_UT_LICENSE_LOGISTICS)
IllegalArgumentException | ("server url is null")
IllegalArgumentException | ("SourceServer is null")

Member Function Documentation

ErrorInfo cancelSubmission ( String submitJobID )

The only operation that is currently cancellable is the submitDocument method.

Parameters
submitJobID JobID of the submission operation from progress listener results.
Returns
An ErrorInfo result indicating whether the cancel task was successfully started.

Implements ICaptureServer.

void getDocumentType | ( | String | documentTypeName,
 |  | final ICompletionListener< DocumentType > | completionListener
 | ) |  |

Returns the DocumentType object which corresponds to the documentTypeName Specified.

The DocumentType object is created based on the corresponding DocumentType downloaded from Server. The documentTypeName indicates which DocumentType to download from Server. Returns the DocumentType object, and is fired once the DocumentType object has been successfully downloaded from Server.

Parameters
documentTypeName | This indicates which DocumentType to download.
completionListener | A completion listener, return results as well as any Exceptions.
Exceptions
IllegalArgumentException ("CompletionListener cannot be null")
int getServerTimeout ( )

Get the connection timeout (in seconds).

Timeout defaults to 20 seconds.

See also
setServerTimeout(int)
void login | ( | UserProfile | userProfile,
 |  | final ICompletionListener< List< String >> | completionListener
 | ) |  |

Login to the server using credentials from the UserProfile object.

The login() method returns List of document type names. You must first call registerDevice() to obtain a license, before calling login(). You may need to register your device after login, if registration requires authentication. The UserProfile object passed in as a parameter must contain valid user credentials, in order for the login() method to succeed.

Parameters
userProfile | This contains the login credentials of the user.
completionListener | A completion listener, return results as well as any Exceptions.
Exceptions
IllegalArgumentException ("CompletionListener cannot be null")
void loginAnonymously ( final ICompletionListener< List< String >> completionListener )

Fetches the device profile shortcuts from the server.

loginAnonymously() returns list of document names. You can only fetch the shortcuts if you have previously registered your device. You may need to register your device after login, if registration requires authentication.

Parameters
completionListener A completion listener, return results as well as any Exceptions.
Exceptions
IllegalArgumentException ("CompletionListener cannot be null")
void logout ( final ICompletionListener< Void > completionListener )

Logout from the Server if logged in.

The logout() method can only be called after calling the login() method.

Parameters
completionListener A completion listener, return results as well as any Exceptions.
Exceptions
IllegalArgumentException ("CompletionListener cannot be null")
void registerDevice ( final ICompletionListener< Void > completionListener )

Register a mobile device with the server and obtain a license, if available.

The registerDevice() method must be called prior to calling login() or any other methods in the CaptureServer object which initiate communication with the server. If device registration fails then the listener is called with KmcRuntimeException. If you receive the following ErrorInfo#KMC_LO_REGISTER_REQUIRES_AUTH in the Exception, it indicates device registration requires authentication. Hence login needs to be called before registering the device.

sample code to call register device :

ICaptureServer captureServer = new CaptureServer("http:sampleServer.com/path", serverType);

 captureServer.registerDevice(new ICompletionListener<Void>(){

   @literal @Override

   public void onComplete(Void ignore, Exception e) {

    if(e == null){

      // device registered successfully.

    }

   }

});
Parameters
completionListener A completion listener, return results as well as any Exceptions.
Exceptions
IllegalArgumentException ("CompletionListener cannot be null")
void sendImageService | ( | Document | document,
 |  | String | jobID,
 |  | Image | image,
 |  | int | ImageIndex,
 |  | boolean | lastImage,
 |  | final ICompletionListener< Void > | completionListener
 | ) |  |

Sends an Image to the server.

SendImageService method will be used to send the single image to the server using the given JobID.

Parameters
document | This contains the document data.
jobID | The unique ID of the document submission job.
image | The image field.
ImageIndex | The image index in the document submission job, should start with 0.
lastImage | This indicates the last image in the job submission.
completionListener | A completion listener, return results as well as any Exceptions.
Exceptions
IllegalArgumentException ("CompletionListener cannot be null")
void setCertificateValidatorListener ( CertificateValidatorListener certificateValidatorListener )

Setter for certificate validator listener. The listener receives certificate validation challenge in response to an authentication request from the remote server.

Parameters
certificateValidatorListener
See also
CertificateValidatorListener
void setServerTimeout ( int timeout )

Change the connection timeout.

This parameter corresponds to all connection timeouts, specified in seconds: connect, read, and write. If any operation exceeds the timeout, the process is cancelled, and an exception will be raised.

Timeout defaults to 20 seconds. Note that providing an invalid value (such as 0 or any negative number) will reset the timeout to the default value.

void startJobService ( final ICompletionListener< String > completionListener )

This will start a new document submission job on the server.

This will start a new document submission job by calling the startJob method on the server. This will return a unique job ID, which can be used to concurrently submit documents. Submit the images in the document by calling the sendImageService() after getting the job ID.

Parameters
completionListener A completion listener, return results as well as any Exceptions.
Exceptions
IllegalArgumentException ("CompletionListener cannot be null")
void submitDocument | ( | Document | document,
 |  | IProgressListener | iProgressListener,
 |  | final ICompletionListener | iCompletionListener
 | ) |  |

The submitDocument method submits a Document to KFS/KTA, including all fields and pages. Within each page, only the image indicated by the property currentImageIndex is included in the Document submission.

Parameters
document | this contains the docuement data.
iProgressListener | A progress listener, return progress results and submitJobID.
iCompletionListener | A completion listener, return results as well as any Exceptions.
The documentation for this class was generated from the following file:
  • CaptureServer.java


Kofax Mobile SDK API Reference: ICaptureServer Interface Reference

  • mobile
  • sdk
  • logistics
  • ICaptureServer
Public Member Functions | List of all members
ICaptureServer Interface Reference
Inheritance diagram for ICaptureServer:
CaptureServer

Public Member Functions

void | registerDevice (ICompletionListener< Void > completionListener)
void | login (UserProfile userProfile, ICompletionListener< List< String >> completionListener)
void | loginAnonymously (ICompletionListener< List< String >> completionListener)
void | logout (ICompletionListener< Void > completionListener)
void | getDocumentType (String documentTypeName, ICompletionListener< DocumentType > completionListener)
void | startJobService (ICompletionListener< String > completionListener)
void | sendImageService (Document document, String jobID, Image image, int ImageIndex, boolean lastImage, ICompletionListener< Void > completionListener)
void | submitDocument (Document document, IProgressListener iProgressListener, ICompletionListener iCompletionListener)
ErrorInfo | cancelSubmission (String submitJobID)

Detailed Description

Specifies the interface required to satisfy KFS/KTA dependencies.

Member Function Documentation

ErrorInfo cancelSubmission ( String submitJobID )

The only operation that is currently cancellable is the submitDocument method.

Parameters
submitJobID JobID of the submission operation from progress listener results.
Returns
An ErrorInfo result indicating whether the cancel task was successfully started.

Implemented in CaptureServer.

void getDocumentType | ( | String | documentTypeName,
 |  | ICompletionListener< DocumentType > | completionListener
 | ) |  |

Returns the DocumentType object which corresponds to the DocumentType name specified.

Note: The listener's object parameter will be DocumentType.

Parameters
documentTypeName | This indicates which DocumentType to download.
completionListener | A completion listener, return results as well as any Exceptions.
void login | ( | UserProfile | userProfile,
 |  | ICompletionListener< List< String >> | completionListener
 | ) |  |

Login to the server using credentials from the UserProfile object.

Note: The listener's object parameter will be a list if the user logged into the server successfully

Parameters
userProfile | This contains login credentials of the user.
completionListener | A completion listener, return results as well as any Exceptions.
void loginAnonymously ( ICompletionListener< List< String >> completionListener )

Fetches the device profile shortcuts from the server.

Note: The listener's object parameter will be a list if the user successfully fetches the profile shortcuts.

Parameters
completionListener A completion listener, return results as well as any Exceptions.
void logout ( ICompletionListener< Void > completionListener )

Logout from the server if previously called login(UserProfile, ICompletionListener) or loginAnonymously(ICompletionListener).

Note: The listener's exception object will be empty if the device logged out successfully.

Parameters
completionListener A completion listener, return results as well as any Exceptions.
void registerDevice ( ICompletionListener< Void > completionListener )

Register a mobile device with the server and obtain a license, if available. If device registration fails then the listener is called with KmcRuntimeException. If you receive the following ErrorInfo#KMC_LO_REGISTER_REQUIRES_AUTH in the Exception, it indicates device registration requires authentication. Hence login needs to be called before registering the device.

Note: The listener's exception object will be empty if device registered successfully.

Parameters
completionListener A completion listener, return results as well as any Exceptions.
void sendImageService | ( | Document | document,
 |  | String | jobID,
 |  | Image | image,
 |  | int | ImageIndex,
 |  | boolean | lastImage,
 |  | ICompletionListener< Void > | completionListener
 | ) |  |

SendImageService method will be used to send the single image to the server using the given JobID.

Note: The listener's exception object will be empty if the Image sent to the server without any error.

Parameters
document | This contains the document data.
jobID | The UniqueID of the document submission job.
image | The image field.
ImageIndex | The image index in the document submission job, should start with 0.
lastImage | This indicates the last image in the job submission.
completionListener | A completion listener, return results as well as any Exceptions.
void startJobService ( ICompletionListener< String > completionListener )

This will start a new document submission job by calling the startJob method on the server. This will return a unique job ID that is different from any job ID used by any other input device. Documents can be submitted concurrently, by using the different job IDs. Submit the images in the document, by calling the sendImageService() after getting the job ID.

Note: The listener's object parameter will be job ID.

Parameters
completionListener A completion listener, return results as well as any Exceptions.
void submitDocument | ( | Document | document,
 |  | IProgressListener | iProgressListener,
 |  | ICompletionListener | iCompletionListener
 | ) |  |

The submitDocument method submits a Document to KFS/KTA, including all fields and pages. Within each page, only the image indicated by the property currentImageIndex is included in the Document submission.

Parameters
document | this contains the docuement data.
iCompletionListener | A completion listener, return results as well as any Exceptions.
iProgressListener | A progress listener, return progress results and submitJobID.
The documentation for this interface was generated from the following file:
  • ICaptureServer.java


Kofax Mobile SDK API Reference: IProgressListener Interface Reference

  • mobile
  • sdk
  • logistics
  • IProgressListener
Public Member Functions | List of all members
IProgressListener Interface Reference

Public Member Functions

void onProgress (int progressPercent, String jobID)

Detailed Description

Listener for progress update

Member Function Documentation

void onProgress | ( | int | progressPercent,
 |  | String | jobID
 | ) |  |
Parameters
progressPercent | Returned progress percentage.
jobID | Returns jobID.
The documentation for this interface was generated from the following file:
  • IProgressListener.java


Kofax Mobile SDK API Reference: Logging Class Reference

  • mobile
  • sdk
  • Logging
Static Public Member Functions | List of all members
Logging Class Reference

Static Public Member Functions

static void enableConsoleLogging (boolean enable)

Detailed Description

Enable or disable console logging for all of the Mobile SDK. Individual package-level logging can also be managed through each package-level *Logging class

See also
KENLogging
KLOLogging
KUILogging
KUTLogging

Member Function Documentation

static void enableConsoleLogging ( boolean enable )
static

Enables Mobile SDK library console logging. Pass true to turn on library logging, and false otherwise. Disabled by default.

Parameters
enable
The documentation for this class was generated from the following file:
  • Logging.java


Kofax Mobile SDK API Reference: Class Index

Class Index
A | B | C | D | E | F | G | H | I | K | L | M | O | P | Q | R | S | T | U | V | W | Z
A
CheckDetector (com.kofax.kmc.ken.engines)
H
KenVersion (com.kofax.kmc.ken.engines.version)
Q
CheckExtractActivity (com.kofax.mobile.sdk.capture.check) KLOLogging (com.kofax.kmc.klo.logistics)
AggregateException (com.kofax.mobile.sdk.extract.id) CheckExtractor (com.kofax.mobile.sdk.capture.check) HorizontalGuidance (com.kofax.kmc.ken.engines.data) KloVersion (com.kofax.kmc.klo.logistics.version) QuickAnalysisFeedback (com.kofax.kmc.ken.engines.data)
ImageProcessor.AnalysisCompleteEvent (com.kofax.kmc.ken.engines) CheckExtractorResponse (com.kofax.mobile.sdk.capture.check)
I
KmcException (com.kofax.kmc.kut.utilities.error) QuickAnalysisSettings (com.kofax.kmc.ken.engines.data)
ImageProcessor.AnalysisCompleteListener (com.kofax.kmc.ken.engines) CheckIQAData (com.kofax.mobile.sdk.capture.model) KmcRuntimeException (com.kofax.kmc.kut.utilities.error)
R
ImageProcessor.AnalysisProgressEvent (com.kofax.kmc.ken.engines) CheckParameters (com.kofax.mobile.sdk.capture.check) IBillDeserializer (com.kofax.mobile.sdk.capture.bill) KtaBillExtractor (com.kofax.mobile.sdk.capture.bill)
ImageProcessor.AnalysisProgressListener (com.kofax.kmc.ken.engines) CheckSide (com.kofax.kmc.ken.engines.data) IBillExtractorListener (com.kofax.mobile.sdk.capture.bill) KtaCheckExtractor (com.kofax.mobile.sdk.capture.check) RotateType (com.kofax.kmc.ken.engines.processing)
AppContextProvider (com.kofax.kmc.kut.utilities) MicrLine.CheckType (com.kofax.kmc.kut.utilities) IBundle (com.kofax.mobile.sdk.extract.id.bundle) KtaIdExtractor (com.kofax.mobile.sdk.capture.id) BasicSettingsProfile.RotateType (com.kofax.kmc.ken.engines.data)
ApplicationContextImageStore (com.kofax.mobile.sdk.capture) CheckUsabilityData (com.kofax.mobile.sdk.capture.model) IBundleCacheProvider (com.kofax.mobile.sdk.extract.id.bundle) KtaJsonBill (com.kofax.mobile.sdk.capture.bill) BoundingTetragon.Rotation (com.kofax.kmc.ken.engines.data)
AppStatistics (com.kofax.kmc.kut.utilities.appstats) CheckWorkflowActivity (com.kofax.mobile.sdk.capture.check) IBundleFile (com.kofax.mobile.sdk.extract.id.bundle) KtaJsonCheck (com.kofax.mobile.sdk.capture.check) RttiBillExtractor (com.kofax.mobile.sdk.capture.bill)
AppStatsDaoField (com.kofax.kmc.kut.utilities.appstats) ClassificationResult (com.kofax.kmc.klo.logistics.data) ICaptureServer (com.kofax.mobile.sdk.logistics) KtaJsonPassport (com.kofax.mobile.sdk.capture.passport) RttiCheckExtractor (com.kofax.mobile.sdk.capture.check)
AppStatsDsExportHandler (com.kofax.kmc.kut.utilities.appstats) ColorDepth (com.kofax.kmc.ken.engines.processing) ICheckDeserializer (com.kofax.mobile.sdk.capture.check) KtaPassportExtractor (com.kofax.mobile.sdk.capture.passport) RttiIdExtractor (com.kofax.mobile.sdk.capture.id)
AppStatsExportEvent (com.kofax.kmc.kut.utilities.appstats) ContextImageStorage (com.kofax.mobile.sdk.capture) ICheckDetector (com.kofax.kmc.ken.engines) KUILogging (com.kofax.kmc.kui.uicontrols) RttiJsonBill (com.kofax.mobile.sdk.capture.bill)
AppStatistics.AppStatsExportFormat (com.kofax.kmc.kut.utilities.appstats) ConventionBasedJsonIdDeserializer (com.kofax.mobile.sdk.capture.id) ICheckExtractionServer (com.kofax.mobile.sdk.capture.check) CaptureMessage.KUIMessageOrientation (com.kofax.kmc.kui.uicontrols.captureanimations) RttiJsonCheck (com.kofax.mobile.sdk.capture.check)
AppStatsExportListener (com.kofax.kmc.kut.utilities.appstats) CreditCard (com.kofax.mobile.sdk.capture.model) ICheckExtractorListener (com.kofax.mobile.sdk.capture.check) KuiVersion (com.kofax.kmc.kui.uicontrols.version) RttiJsonPassport (com.kofax.mobile.sdk.capture.passport)
AppStatsSessionEvent (com.kofax.kmc.kut.utilities.appstats) CreditCardParameters (com.kofax.mobile.sdk.capture.creditcard) ICompletionListener (com.kofax.mobile.sdk.extract.id) KUTLogging (com.kofax.kmc.kut.utilities) RttiPassportExtractor (com.kofax.mobile.sdk.capture.passport)
AppStatsThresholdReachedEvent (com.kofax.kmc.kut.utilities.appstats) CreditCardWorkflowActivity (com.kofax.mobile.sdk.capture.creditcard) Id (com.kofax.mobile.sdk.capture.model) KutVersion (com.kofax.kmc.kut.utilities.version)
S
AppstatsThresholdReachedListener (com.kofax.kmc.kut.utilities.appstats) BasicSettingsProfile.CropType (com.kofax.kmc.ken.engines.data) IdCaptureActivity (com.kofax.mobile.sdk.capture.id)
L
AppStatsWriteFileListener (com.kofax.kmc.kut.utilities.appstats) CropType (com.kofax.kmc.ken.engines.processing) IdCaptureBackActivity (com.kofax.mobile.sdk.capture.id) SdkVersion (com.kofax.kmc.kut.utilities)
AppStatsWritetoFileEvent (com.kofax.kmc.kut.utilities.appstats)
D
IdExtractActivity (com.kofax.mobile.sdk.capture.id) LevelnessEvent (com.kofax.kmc.kui.uicontrols) SearchDirection (com.kofax.kmc.kui.uicontrols.data)
AppStatsWriteToFileResults (com.kofax.kmc.kut.utilities.appstats) IdExtractionParameters (com.kofax.mobile.sdk.extract.id) LevelnessListener (com.kofax.kmc.kui.uicontrols) SelfieBaseCaptureExperience (com.kofax.kmc.kui.uicontrols.captureanimations)
AutoFocusResultEvent (com.kofax.kmc.kui.uicontrols) DataField (com.kofax.mobile.sdk.extract.id) IdExtractor (com.kofax.mobile.sdk.capture.id) LicenseCaptureView (com.kofax.kmc.kui.uicontrols) SelfieCaptureExperience (com.kofax.kmc.kui.uicontrols.captureanimations)
AutoFocusResultListener (com.kofax.kmc.kui.uicontrols) FieldType.DataType (com.kofax.kmc.klo.logistics.data) IdExtractorResponse (com.kofax.mobile.sdk.capture.id) LicenseFoundEvent (com.kofax.kmc.kui.uicontrols) SelfieCaptureExperienceCriteriaHolder (com.kofax.kmc.kui.uicontrols.captureanimations)
B
DeskewType (com.kofax.kmc.ken.engines.processing) IDocumentDetector (com.kofax.kmc.ken.engines) LicenseFoundListener (com.kofax.kmc.kui.uicontrols) SelfieDetectionSettings (com.kofax.kmc.ken.engines.data)
DetectionResult (com.kofax.kmc.ken.engines.data) IdParameters (com.kofax.mobile.sdk.capture.id) Licensing.LicenseServerType (com.kofax.kmc.kut.utilities) ServerBuilder (com.kofax.mobile.sdk.extract.server)
BarCodeCaptureView (com.kofax.kmc.kui.uicontrols) DetectionSettings (com.kofax.kmc.ken.engines.data) IdRegion (com.kofax.mobile.sdk.extract.id) Licensing.LicenseType (com.kofax.kmc.kut.utilities) ServerExtractionParameters (com.kofax.mobile.sdk.extract.server)
BarCodeDataFormat (com.kofax.kmc.ken.engines.data) BarCodeReader.Direction (com.kofax.kmc.ken.engines) IdParameters.IdSide (com.kofax.mobile.sdk.capture.id) Licensing (com.kofax.kmc.kut.utilities) ServerProjectProvider (com.kofax.mobile.sdk.extract.id)
BarCodeDirection (com.kofax.kmc.ken.engines.data) Document (com.kofax.kmc.klo.logistics.data) IdParameters.IdState (com.kofax.mobile.sdk.capture.id) ImgReviewEditCntrl.Line_Style_Solid (com.kofax.kmc.kui.uicontrols) ServerBuilder.ServerType (com.kofax.mobile.sdk.extract.server)
BarCodeFoundEvent (com.kofax.kmc.kui.uicontrols) DocumentBaseCaptureExperience (com.kofax.kmc.kui.uicontrols.captureanimations) IdType (com.kofax.mobile.sdk.extract.id) ListenerCallbackThreadType (com.kofax.kmc.kut.utilities.async) SessionState (com.kofax.kmc.klo.logistics)
BarCodeFoundListener (com.kofax.kmc.kui.uicontrols) DocumentBaseCaptureExperienceCriteriaHolder (com.kofax.kmc.kui.uicontrols.captureanimations) IdWorkflowActivity (com.kofax.mobile.sdk.capture.id) ListOfException (com.kofax.mobile.sdk.extract.id) Page.Side (com.kofax.kmc.klo.logistics.data)
BarCodeReader.BarcodeReadCompleteEvent (com.kofax.kmc.ken.engines) DocumentCaptureExperience (com.kofax.kmc.kui.uicontrols.captureanimations) IExtractorListener (com.kofax.mobile.sdk.capture.extraction) LocalProjectProvider (com.kofax.mobile.sdk.extract.id) Size (com.kofax.kmc.kut.utilities)
BarCodeReader.BarcodeReadCompleteListener (com.kofax.kmc.ken.engines) DocumentCaptureExperienceCriteriaHolder (com.kofax.kmc.kui.uicontrols.captureanimations) IIdDeserializer (com.kofax.mobile.sdk.capture.id) Logging (com.kofax.mobile.sdk) SizeDouble (com.kofax.mobile.sdk.capture.model)
BarCodeReader (com.kofax.kmc.ken.engines) DocumentDetectionResult (com.kofax.kmc.ken.engines.data) IIdExtractionListener (com.kofax.mobile.sdk.extract.id) LoginCredentials (com.kofax.mobile.sdk.extract.server) DocumentType.SourceServer (com.kofax.kmc.klo.logistics.data)
BarCodeResult (com.kofax.kmc.ken.engines.data) DocumentDetectionSettings (com.kofax.kmc.ken.engines.data) IIdExtractionResult (com.kofax.mobile.sdk.extract.id) LookAndFeelParameters (com.kofax.mobile.sdk.capture.parameter) StabilityDelayEvent (com.kofax.kmc.kui.uicontrols)
BarCodeType (com.kofax.kmc.ken.engines.data) DocumentDetector (com.kofax.kmc.ken.engines) IIdExtractionServer (com.kofax.mobile.sdk.capture.id)
M
StabilityDelayListener (com.kofax.kmc.kui.uicontrols)
BasicSettingsProfile (com.kofax.kmc.ken.engines.data) DocumentDimensions (com.kofax.kmc.ken.engines.processing) IIdExtractor (com.kofax.mobile.sdk.extract.id) BarCodeReader.Symbology (com.kofax.kmc.ken.engines)
Bill (com.kofax.mobile.sdk.capture.model) DocumentDetectionSettings.DocumentEdgeDetection (com.kofax.kmc.ken.engines.data) IIdExtractorListener (com.kofax.mobile.sdk.capture.id) MicrLine (com.kofax.kmc.kut.utilities) Symbology (com.kofax.kmc.kui.uicontrols.data)
BillCaptureActivity (com.kofax.mobile.sdk.capture.bill) DocumentType (com.kofax.kmc.klo.logistics.data) IImageProcessor (com.kofax.mobile.sdk.capture.processing) MicrParser (com.kofax.kmc.kut.utilities)
T
BillExtractActivity (com.kofax.mobile.sdk.capture.bill) DocumentTypeR (com.kofax.kmc.klo.logistics.data) IImageProcessorListener (com.kofax.mobile.sdk.capture.processing)
O
BillExtractor (com.kofax.mobile.sdk.capture.bill)
E
IImageStorage (com.kofax.mobile.sdk.capture) TargetFrameCropType (com.kofax.kmc.ken.engines.processing)
BillExtractorResponse (com.kofax.mobile.sdk.capture.bill) Image (com.kofax.kmc.ken.engines.data) OnDeviceIdExtractor (com.kofax.mobile.sdk.extract.id) AppStatistics.ThresholdType (com.kofax.kmc.kut.utilities.appstats)
BillParameters (com.kofax.mobile.sdk.capture.bill) ServerProjectProvider.Error (com.kofax.mobile.sdk.extract.id) ImageCacheType (com.kofax.kmc.kui.uicontrols.data) OrientationGuidance (com.kofax.kmc.ken.engines.data) TimeOutParameters (com.kofax.mobile.sdk.extract.server)
BillWorkflowActivity (com.kofax.mobile.sdk.capture.bill) ErrorInfo (com.kofax.kmc.kut.utilities.error) ImageCapturedEvent (com.kofax.kmc.kui.uicontrols) BasicSettingsProfile.OutputBitDepth (com.kofax.kmc.ken.engines.data) TorchLuminanceEvent (com.kofax.kmc.kui.uicontrols)
BoundingRect (com.kofax.kmc.ken.engines.data) ExceptionResponse (com.kofax.mobile.sdk.capture.extraction) ImageCapturedListener (com.kofax.kmc.kui.uicontrols) Image.OutputColor (com.kofax.kmc.ken.engines.data) TorchLuminanceListener (com.kofax.kmc.kui.uicontrols)
BoundingTetragon (com.kofax.kmc.ken.engines.data) ExceptionResponseImpl (com.kofax.mobile.sdk.capture.extraction) ImageCaptureView (com.kofax.kmc.kui.uicontrols)
P
LookAndFeelParameters.TorchMode (com.kofax.mobile.sdk.capture.parameter)
BundleCacheProvider (com.kofax.mobile.sdk.extract.id.bundle) AppStatsExportListener.ExportStatus (com.kofax.kmc.kut.utilities.appstats) ImageClassificationCompletedListener (com.kofax.kmc.ken.engines) TurnGuidance (com.kofax.kmc.ken.engines.data)
C
AppStatistics.ExportStatusEvent (com.kofax.kmc.kut.utilities.appstats) ImageClassificationCompleteEvent (com.kofax.kmc.ken.engines) Page (com.kofax.kmc.klo.logistics.data)
U
ExtractActivity (com.kofax.mobile.sdk.capture) ImageClassificationResult (com.kofax.kmc.ken.engines) PageDetectionEvent (com.kofax.kmc.kui.uicontrols)
CameraInitializationEvent (com.kofax.kmc.kui.uicontrols) ExtractionCredentials (com.kofax.mobile.sdk.capture.parameter) ImageClassifier.ImageClassificationStatus (com.kofax.kmc.ken.engines) PageDetectionListener (com.kofax.kmc.kui.uicontrols) ImagePerfectionProfile.UseDocumentDetectionBasedCrop (com.kofax.kmc.ken.engines.data)
CameraInitializationFailedEvent (com.kofax.kmc.kui.uicontrols) ExtractionParameters (com.kofax.mobile.sdk.capture.parameter) ImageClassifier (com.kofax.kmc.ken.engines) Passport (com.kofax.mobile.sdk.capture.model) ImagePerfectionProfile.UseMRZPassportDetection (com.kofax.kmc.ken.engines.data)
CameraInitializationFailedListener (com.kofax.kmc.kui.uicontrols) ExtractionServerException (com.kofax.mobile.sdk.extract.server) Image.ImageFileRep (com.kofax.kmc.ken.engines.data) PassportCaptureActivity (com.kofax.mobile.sdk.capture.passport) UserProfile (com.kofax.kmc.klo.logistics.data)
CameraInitializationListener (com.kofax.kmc.kui.uicontrols) ExtractionParameters.ExtractionType (com.kofax.mobile.sdk.capture.parameter) Image.ImageMimeType (com.kofax.kmc.ken.engines.data) PassportCaptureExperience (com.kofax.kmc.kui.uicontrols.captureanimations) ImagePerfectionProfile.UseTargetFrameCrop (com.kofax.kmc.ken.engines.data)
CameraInitializationEvent.CameraInitStatus (com.kofax.kmc.kui.uicontrols) Extractor (com.kofax.mobile.sdk.capture.extraction) ImageProcessor.ImageOutEvent (com.kofax.kmc.ken.engines) PassportCaptureExperienceCriteriaHolder (com.kofax.kmc.kui.uicontrols.captureanimations)
V
CameraType (com.kofax.kmc.kui.uicontrols.data) ExtractorResponse (com.kofax.mobile.sdk.capture.extraction) ImageProcessor.ImageOutListener (com.kofax.kmc.ken.engines) PassportDetectionResult (com.kofax.kmc.ken.engines.data)
CaptureActivity (com.kofax.mobile.sdk.capture)
F
ImagePerfectionProfile (com.kofax.kmc.ken.engines.data) PassportDetectionSettings (com.kofax.kmc.ken.engines.data) LocalProjectProvider.VersionTable.VersionList (com.kofax.mobile.sdk.extract.id)
CaptureData (com.kofax.mobile.sdk.capture.model) ImageProcessor (com.kofax.kmc.ken.engines) PassportDetector (com.kofax.kmc.ken.engines) LocalProjectProvider.VersionTable (com.kofax.mobile.sdk.extract.id)
CaptureExperience (com.kofax.kmc.kui.uicontrols.captureanimations) Field (com.kofax.mobile.sdk.capture.model) ImageProcessorConfiguration (com.kofax.kmc.ken.engines.processing) PassportExtractActivity (com.kofax.mobile.sdk.capture.passport) VerticalGuidance (com.kofax.kmc.ken.engines.data)
CaptureExperienceCriteriaHolder (com.kofax.kmc.kui.uicontrols.captureanimations) Field (com.kofax.kmc.klo.logistics.data) Image.ImageRep (com.kofax.kmc.ken.engines.data) PassportExtractor (com.kofax.mobile.sdk.capture.passport) Licensing.VolumeLicenseEventListener (com.kofax.kmc.kut.utilities)
CaptureMessage (com.kofax.kmc.kui.uicontrols.captureanimations) FieldLocation (com.kofax.mobile.sdk.capture.model) ImageReviewActivity (com.kofax.mobile.sdk.capture) PassportExtractorResponse (com.kofax.mobile.sdk.capture.passport) Licensing.VolumeLicenseFailureData (com.kofax.kmc.kut.utilities)
CaptureServer (com.kofax.mobile.sdk.logistics) FieldType (com.kofax.kmc.klo.logistics.data) ImageSource (com.kofax.kmc.ken.engines.data) PassportParameters (com.kofax.mobile.sdk.capture.passport) Licensing.VolumeLicenseResultData (com.kofax.kmc.kut.utilities)
CardIoWrapperActivity (com.kofax.mobile.sdk.capture.creditcard) Image.FileIOEngine (com.kofax.kmc.ken.engines.data) ImgReviewEditCntrl (com.kofax.kmc.kui.uicontrols) PassportWorkflowActivity (com.kofax.mobile.sdk.capture.passport)
W
CreditCardParameters.CardStyle (com.kofax.mobile.sdk.capture.creditcard) Image.FileRestriction (com.kofax.kmc.ken.engines.data) IParameters (com.kofax.mobile.sdk.capture.parameter) PointDouble (com.kofax.mobile.sdk.capture.model)
CertificateValidatorListener (com.kofax.kmc.kut.utilities) FixedAspectRatioCaptureExperience (com.kofax.kmc.kui.uicontrols.captureanimations) IPassportDeserializer (com.kofax.mobile.sdk.capture.passport) PreviewCallbackListener (com.kofax.kmc.kui.uicontrols) WorkflowActivity (com.kofax.mobile.sdk.capture)
Check (com.kofax.mobile.sdk.capture.model) FixedAspectRatioDetectionSettings (com.kofax.kmc.ken.engines.data) IPassportDetector (com.kofax.kmc.ken.engines) PreviewFrameEvent (com.kofax.kmc.kui.uicontrols) AppStatsWriteFileListener.WriteFileStatus (com.kofax.kmc.kut.utilities.appstats)
CheckCaptureActivity (com.kofax.mobile.sdk.capture.check) FixedAspectRatioExperienceCriteriaHolder (com.kofax.kmc.kui.uicontrols.captureanimations) IPassportExtractorListener (com.kofax.mobile.sdk.capture.passport) ProcessActivity (com.kofax.mobile.sdk.capture)
Z
CheckCaptureExperience (com.kofax.kmc.kui.uicontrols.captureanimations) Flash (com.kofax.kmc.kui.uicontrols.data) IProgressListener (com.kofax.mobile.sdk.logistics) ProcessingParameters (com.kofax.mobile.sdk.capture.parameter)
CheckCaptureExperienceCriteriaHolder (com.kofax.kmc.kui.uicontrols.captureanimations)
G
IProjectProvider (com.kofax.mobile.sdk.extract.id) ProcessingParameters.ProcessingType (com.kofax.mobile.sdk.capture.parameter) ZipFileBundle (com.kofax.mobile.sdk.extract.id.bundle)
CheckParameters.CheckCountry (com.kofax.mobile.sdk.capture.check) IServerExtractor (com.kofax.mobile.sdk.extract.server) ImageProcessor.ProcessProgressEvent (com.kofax.kmc.ken.engines) ZipInputStreamBundle (com.kofax.mobile.sdk.extract.id.bundle)
CheckDetectionResult (com.kofax.kmc.ken.engines.data) GpsUsageLimits (com.kofax.kmc.kui.uicontrols.data)
K
ImageProcessor.ProcessProgressListener (com.kofax.kmc.ken.engines) ZoomGuidance (com.kofax.kmc.ken.engines.data)
CheckDetectionSettings (com.kofax.kmc.ken.engines.data) GuidingLine (com.kofax.kmc.kui.uicontrols.data) ProjectProviderException (com.kofax.mobile.sdk.extract.id)


Kofax Mobile SDK API Reference: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 1234]
C ImageProcessor.AnalysisCompleteListener | The listener interface for receiving analysis complete events
C ImageProcessor.AnalysisProgressListener | The listener interface for receiving Analysis Progress events
C ApplicationContextImageStore |
C AppStatistics | Use the AppStatistics class for creating, saving, and exporting statistics related to SDK framework usage
C AppStatsDaoField | Container for properties that define one field in a table in the datastore
C AppStatsDsExportHandler |
C AppStatistics.AppStatsExportFormat | Indicates the export format desired when calling the export method
C AppStatsExportListener |
C AppStatsSessionEvent | This data-only class is used to set properties that define an AppStats Session Event
C AppstatsThresholdReachedListener |
C AppStatsWriteFileListener |
C AppStatsWriteToFileResults |
►C AutoFocusResultListener | The listener interface for responding to camera focus events
►C CaptureExperience | This class is a base class for the DocumentCaptureExperience and CheckCaptureExperience, PassportCaptureExperience and FixedAspectRatioCaptureExperience
►C DocumentBaseCaptureExperience |
C CheckCaptureExperience |
C DocumentCaptureExperience |
C FixedAspectRatioCaptureExperience |
C PassportCaptureExperience |
C BarCodeDataFormat | An enum that identifies the format of the bar code found
C BarCodeDirection | An enum that identifies the direction of the bar code found
C BarCodeFoundListener | The listener interface for receiving barcode events
C BarCodeReader.BarcodeReadCompleteListener |
C BarCodeReader | The barcode recognition engine
C BarCodeType | An enum that identifies the type of the bar code found
C BoundingRect | The BoundingRect object holds four integer edge coordinates for a rectangle
C CameraInitializationFailedListener |
C CameraInitializationListener | The interface that is required to implement CameraInitializationEvent
C CameraInitializationEvent.CameraInitStatus |
C CameraType | This enum represents the camera type
►C CaptureExperienceCriteriaHolder |
►C DocumentBaseCaptureExperienceCriteriaHolder |
C CheckCaptureExperienceCriteriaHolder |
C DocumentCaptureExperienceCriteriaHolder |
C FixedAspectRatioExperienceCriteriaHolder |
C PassportCaptureExperienceCriteriaHolder |
C CaptureMessage |
C CreditCardParameters.CardStyle |
C CheckParameters.CheckCountry |
C CheckSide |
C MicrLine.CheckType | An enum which identifies the type of check
►C Cloneable |
C BasicSettingsProfile | The BasicSettingsProfile specifies basic image processing options. This object is serializable
C BoundingTetragon | The BoundingTetragon object holds four corner points for a tetragon. This object is serializable
C ImagePerfectionProfile | The ImagePerfectionProfile object encapsulates advanced image processing settings. This object is serializable
C QuickAnalysisFeedback | The QuickAnalysisFeedback object contains the results of image quality checking using the doQuickAnalysis method of the ImageProcessor object. This object is serializable
C ImageProcessorConfiguration |
C ClassificationResult | Results from classifying a Document using an RTTI web service. This object is serializable
C Document | The Document object is instantiated as a specific DocumentType. This object is serializable
►C DocumentTypeR | The DocumentTypeR Object is a model that describes the attributes of a document. This object is serializable
C DocumentType | The DocumentType object is a model that describes the attributes of a document. This object is serializable
C Field | The Field object is instantiated using a particular FieldType object and contains a value which confirms to that Field Type. This object is serializable
C FieldType | The FieldType Object is a model that describes the attributes of a field. This object is serializable
C Page | There can be one or more Pages in a Document. This object is serializable
C UserProfile | The UserProfile Object contains login credentials for a user
C ColorDepth |
C BasicSettingsProfile.CropType | An enum which identifies the crop type
C CropType |
C FieldType.DataType | An enum that defines the data type specified for this Field Type
C DeskewType |
►C DetectionResult |
C CheckDetectionResult |
C DocumentDetectionResult |
C PassportDetectionResult |
►C DetectionSettings |
C CheckDetectionSettings |
C DocumentDetectionSettings |
C PassportDetectionSettings |
C BarCodeReader.Direction |
C DocumentDimensions |
C DocumentDetectionSettings.DocumentEdgeDetection | An enumeration containing the possible edge detection algorithms
C ServerProjectProvider.Error |
C ErrorInfo | The ErrorInfo enum can be used by application developers to lookup error information
►C Exception |
C KmcException | An extended Exception class that specifies KMC errors as defined by the ErrorInfo enum
C ListOfException |
C AppStatsExportListener.ExportStatus |
C AppStatistics.ExportStatusEvent |
C ExtractActivity< BillExtractorResponse > |
C ExtractActivity< CheckExtractorResponse > |
C ExtractActivity< IdExtractorResponse > |
C ExtractActivity< PassportExtractorResponse > |
C ExtractionParameters.ExtractionType |
C Extractor< Bill > |
C Extractor< Check > |
C Extractor< Id > |
C Extractor< Passport > |
C Extractor< T > |
C ExtractorResponse< Bill > |
C ExtractorResponse< Check > |
C ExtractorResponse< Id > |
C ExtractorResponse< Passport > |
C Field< String > |
C Image.FileIOEngine | An enum which optionally identifies the desired File I/O Engine used for reading and writing
C Image.FileRestriction | An enum which specifies that ANSI X9.100-181 restrictions are needed for TIFF output
C FixedAspectRatioDetectionSettings |
C Flash | This enum represents the various camera flash settings
C GpsUsageLimits |
C GuidingLine | An enum representing the rendering and orientation of a guiding line for barcode capture
C HorizontalGuidance |
►C IBundleCacheProvider |
C BundleCacheProvider |
C IBundleFile |
►C ICaptureServer |
C CaptureServer |
C ICompletionListener< T > |
C IdExtractionParameters |
C IDocumentDetector< T extends DetectionSettings, U extends DetectionResult > |
►C IDocumentDetector< CheckDetectionSettings, CheckDetectionResult > |
►C ICheckDetector |
C CheckDetector |
►C IDocumentDetector< DocumentDetectionSettings, DocumentDetectionResult > |
C DocumentDetector |
►C IDocumentDetector< PassportDetectionSettings, PassportDetectionResult > |
►C IPassportDetector |
C PassportDetector |
C IdRegion |
C IdParameters.IdSide |
C IdParameters.IdState |
C IdType |
►C IExtractorListener< T extends ExtractorResponse > |
C IBillExtractorListener |
C ICheckExtractorListener |
►C ExtractActivity< T extends ExtractorResponse > |
C BillExtractActivity |
C CheckExtractActivity |
C IdExtractActivity |
C PassportExtractActivity |
C IIdExtractorListener |
C IPassportExtractorListener |
C IExtractorListener< BillExtractorResponse > |
C IExtractorListener< CheckExtractorResponse > |
C IExtractorListener< IdExtractorResponse > |
C IExtractorListener< PassportExtractorResponse > |
C IExtractorListener< T > |
C IIdExtractionListener |
►C IIdExtractor |
C OnDeviceIdExtractor |
C IImageProcessor |
►C IImageProcessorListener |
C ProcessActivity |
►C IImageStorage |
C ContextImageStorage |
C ImageCacheType |
►C ImageCapturedListener |
C CaptureExperience | This class is a base class for the DocumentCaptureExperience and CheckCaptureExperience, PassportCaptureExperience and FixedAspectRatioCaptureExperience
C ImageClassificationCompletedListener | The listener interface for receiving image classification completed events
C ImageClassifier.ImageClassificationStatus |
C ImageClassifier | This class is used to classify images based on given configuration and model
C Image.ImageFileRep | An enum which identifies the File Representation of the image file referenced by this Image Object
C Image.ImageMimeType | An enum which identifies the Mime Type of the image file referenced by this Image Object
C ImageProcessor.ImageOutListener | The listener interface for receiving Image Out events
C ImageProcessor | The ImageProcessor is the image processing engine
C Image.ImageRep | An enum which identifies the Image Representation(s) included in this Image Object
C ImageSource |
C IProgressListener |
►C IProjectProvider |
C LocalProjectProvider |
C ServerProjectProvider |
C IServerExtractor |
C KENLogging |
C KenVersion |
C KLOLogging |
C KloVersion |
C KUILogging |
C CaptureMessage.KUIMessageOrientation |
C KuiVersion |
C KUTLogging |
C KutVersion |
►C LevelnessListener | The interface that is required to implement StabilityDelayEvent
C CaptureExperience | This class is a base class for the DocumentCaptureExperience and CheckCaptureExperience, PassportCaptureExperience and FixedAspectRatioCaptureExperience
C LicenseFoundListener | The listener interface for receiving license found events
C Licensing.LicenseServerType | An enum of license server types. Use with Licensing.setMobileSDKLicenseServer
C Licensing.LicenseType | An enum of license types
C Licensing | This class comprises the licensing mechanism for Mobile SDK
C ImgReviewEditCntrl.Line_Style_Solid | An enum which lists the drawing style options the edge of the tetragon
C ListenerCallbackThreadType | An enum which identifies the thread type for asynchronous callbacks
C Logging |
C LoginCredentials |
C MicrLine | This class represents the MICR line itself
C MicrParser | This class parses the MICR data line from different check detection algorithms
C OrientationGuidance |
C BasicSettingsProfile.OutputBitDepth | An enum which identifies the output bit depth
C Image.OutputColor | An enum which identifies the output color desired for writing the bitmap to an image file
C PageDetectionListener |
C PreviewCallbackListener |
C ProcessingParameters.ProcessingType |
C ImageProcessor.ProcessProgressListener | The listener interface for receiving Process Progress events
C QuickAnalysisSettings | A configuration object for controlling the quick analysis image processing
C RotateType |
C BasicSettingsProfile.RotateType | An enum which identifies the rotation type
C BoundingTetragon.Rotation |
►C RuntimeException |
C KmcRuntimeException | An extended RuntimeException class that specifies KMC errors as defined by the ErrorInfo enum
C AggregateException |
C ProjectProviderException |
C ExtractionServerException |
C SdkVersion | This class provides access to version information for the Kofax Mobile SDK
C SearchDirection | An enum representing a direction or set of directions to search for barcodes
►C SelfieBaseCaptureExperience |
C SelfieCaptureExperience |
C SelfieCaptureExperienceCriteriaHolder |
C SelfieDetectionSettings |
C ServerBuilder |
C ServerExtractionParameters |
C ServerBuilder.ServerType |
C SessionState | An enum which contains various FrontOfficeServer and TotalAgility session state information
C Page.Side | Indicates whether this Page is front or back of the sheet
C Size | Universal class for image size describing
C DocumentType.SourceServer | An enum that identifies the source server from which the document was obtained
►C StabilityDelayListener | The interface that is required to implement StabilityDelayEvent
C CaptureExperience | This class is a base class for the DocumentCaptureExperience and CheckCaptureExperience, PassportCaptureExperience and FixedAspectRatioCaptureExperience
C BarCodeReader.Symbology |
C Symbology | An enum representing a barcode symbology
C TargetFrameCropType |
C AppStatistics.ThresholdType |
C TimeOutParameters |
C TorchLuminanceListener | The interface that is required to implement TorchLuminanceEvent
C LookAndFeelParameters.TorchMode |
C TurnGuidance |
C ImagePerfectionProfile.UseDocumentDetectionBasedCrop | An enum used with the useDocumentDetectionBasedCrop property
C ImagePerfectionProfile.UseMRZPassportDetection | An enum used with the useMRZPassportDetection property
C ImagePerfectionProfile.UseTargetFrameCrop | An enum used with the useTargetFrameCrop property
C LocalProjectProvider.VersionTable.VersionList |
C LocalProjectProvider.VersionTable |
C VerticalGuidance |
C Licensing.VolumeLicenseEventListener | The listener interface for receiving volume licensing events
C Licensing.VolumeLicenseFailureData | Data class for volume licensing related failures
C Licensing.VolumeLicenseResultData | Data class for volume licensing related successful operations
C WorkflowActivity< BillParameters > |
C WorkflowActivity< CheckParameters > |
C WorkflowActivity< CreditCardParameters > |
C WorkflowActivity< IdParameters > |
C WorkflowActivity< PassportParameters > |
C AppStatsWriteFileListener.WriteFileStatus |
C ZoomGuidance |
►C Activity |
►C CaptureActivity |
C BillCaptureActivity |
C CheckCaptureActivity |
C IdCaptureActivity |
C IdCaptureBackActivity |
C PassportCaptureActivity |
C CardIoWrapperActivity |
C ExtractActivity< T extends ExtractorResponse > |
C ImageReviewActivity |
C ProcessActivity |
►C WorkflowActivity< T extends IParameters > |
C BillWorkflowActivity |
C CheckWorkflowActivity |
C CreditCardWorkflowActivity |
C IdWorkflowActivity |
C PassportWorkflowActivity |
►C Application |
C AppContextProvider | This class keeps a reference of the application context
►C Callback |
►C ImageCaptureView |
C BarCodeCaptureView |
C LicenseCaptureView |
►C Closeable |
►C IBundle |
C ZipFileBundle |
C ZipInputStreamBundle |
►C Enumeration |
C ZipInputStreamBundle |
►C EventObject |
C BarCodeReader.BarcodeReadCompleteEvent |
C ImageClassificationCompleteEvent | This event is raised in response to an image classification process
C ImageProcessor.AnalysisCompleteEvent | An event that indicates that image quick analysis results are available
C ImageProcessor.AnalysisProgressEvent | An event that indicates Image processing progress information is available
C ImageProcessor.ImageOutEvent | An event that indicates a processed Image is available
C ImageProcessor.ProcessProgressEvent | An event that indicates Image processing progress information is available
C AutoFocusResultEvent | This event returns the result of the camera's attempt to auto focus
C BarCodeFoundEvent | An event that indicates a barcode has been found
C CameraInitializationEvent | This event fires when the camera is initialized or reinitialized
C CameraInitializationFailedEvent |
C ImageCapturedEvent | This event is fired when an image is successfully captured
C LevelnessEvent | This event fires when the orientation of the device changes
C LicenseFoundEvent | An event that indicates that a license was found
C PageDetectionEvent | An event that indicates a page was detected in the camera preview
C PreviewFrameEvent |
C StabilityDelayEvent | This event fires when stability levels change
C TorchLuminanceEvent | This event fires when torch luminance level changes
C AppStatsExportEvent | This event is fired when AppStats events are being exported
C AppStatsThresholdReachedEvent |
C AppStatsWritetoFileEvent |
►C ICameraView |
C ImageCaptureView |
►C ICaptureMenuListener |
C CaptureActivity |
►C IDataUnitProcessedListener |
C BillExtractor |
C CheckExtractor |
►C Extractor< T extends Serializable > |
C BillExtractor |
C CheckExtractor |
C IdExtractor |
C PassportExtractor |
C IdExtractor |
C PassportExtractor |
►C IDeserializer |
C IBillDeserializer |
C ICheckDeserializer |
C IIdDeserializer |
C IPassportDeserializer |
►C IExtractionServer |
►C ICheckExtractionServer |
C KtaCheckExtractor |
C RttiCheckExtractor |
►C IIdExtractionServer |
C KtaIdExtractor |
C RttiIdExtractor |
►C JsonDeserializer |
C KtaJsonBill |
C RttiJsonBill |
C KtaJsonCheck |
C RttiJsonCheck |
C ConventionBasedJsonIdDeserializer |
C KtaJsonPassport |
C RttiJsonPassport |
►C KtaExtractor |
C KtaBillExtractor |
C KtaCheckExtractor |
C KtaIdExtractor |
C KtaPassportExtractor |
►C OnTouchListener |
C ImgReviewEditCntrl |
►C Parcelable |
C CreditCard |
►C RelativeLayout |
C ImageCaptureView |
►C RttiExtractor |
C RttiBillExtractor |
C RttiCheckExtractor |
C RttiIdExtractor |
C RttiPassportExtractor |
►C Serializable |
C BarCodeResult | A single bar code found data item. This object is serializable
C BasicSettingsProfile | The BasicSettingsProfile specifies basic image processing options. This object is serializable
C BoundingTetragon | The BoundingTetragon object holds four corner points for a tetragon. This object is serializable
C Image | The Image Object contains an in-memory and/or image file based representation of an image. This object is serializable
C ImagePerfectionProfile | The ImagePerfectionProfile object encapsulates advanced image processing settings. This object is serializable
C QuickAnalysisFeedback | The QuickAnalysisFeedback object contains the results of image quality checking using the doQuickAnalysis method of the ImageProcessor object. This object is serializable
C ImageClassificationResult | Results from classifying an image. This object is serializable
C ImageProcessorConfiguration |
C ClassificationResult | Results from classifying a Document using an RTTI web service. This object is serializable
C Document | The Document object is instantiated as a specific DocumentType. This object is serializable
C DocumentTypeR | The DocumentTypeR Object is a model that describes the attributes of a document. This object is serializable
C Field | The Field object is instantiated using a particular FieldType object and contains a value which confirms to that Field Type. This object is serializable
C FieldType | The FieldType Object is a model that describes the attributes of a field. This object is serializable
C Page | There can be one or more Pages in a Document. This object is serializable
C CertificateValidatorListener |
C BillExtractorResponse |
C CheckExtractorResponse |
►C ExceptionResponse |
C ExceptionResponseImpl |
►C ExtractorResponse< T extends Serializable > |
C BillExtractorResponse |
C CheckExtractorResponse |
C IdExtractorResponse |
C PassportExtractorResponse |
C IdExtractorResponse |
►C CaptureData |
►C Bill |
C KtaJsonBill |
C RttiJsonBill |
►C Check |
C KtaJsonCheck |
C RttiJsonCheck |
C CreditCard |
►C Id |
C ConventionBasedJsonIdDeserializer |
►C Passport |
C KtaJsonPassport |
C RttiJsonPassport |
C CheckIQAData |
C CheckUsabilityData |
►C Field< T extends Serializable > |
C DataField |
C FieldLocation |
C PointDouble |
C SizeDouble |
C ExtractionCredentials |
C ExtractionParameters |
►C IParameters |
C BillParameters |
C CheckParameters |
C CreditCardParameters |
C IdParameters |
C PassportParameters |
C LookAndFeelParameters |
C ProcessingParameters |
C PassportExtractorResponse |
C DataField |
C IIdExtractionResult |
►C View |
C ImgReviewEditCntrl |


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- _ -

  • _aspectRatio : CaptureExperience
  • _bus : ImageCaptureView
  • _captureExperienceData : CaptureExperience
  • _continuousCapture : CaptureExperience
  • _ctx : DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • _extractor : ExtractActivity< T extends ExtractorResponse >
  • _imageCapturedListeners : CaptureExperience
  • _imageCaptureView : CaptureExperience
  • _lock : CaptureExperience
  • _regionName : IdRegion
  • _sdkCaptureRequested : CaptureExperience
  • _uiHandler : CaptureExperience
  • _vibrationEnabled : CaptureExperience
  • _vibrator : CaptureExperience


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- a -

  • acquiredCount : Licensing.VolumeLicenseResultData
  • acquireVolumeLicenses() : Licensing
  • addAnalysisCompleteEventListener() : ImageProcessor
  • addAnalysisProgressEventListener() : ImageProcessor
  • addAppStatsExportListener() : AppStatistics
  • addAppStatsWriteFileListener() : AppStatistics
  • addAppThresholdListener() : AppStatistics
  • addBarCodeFoundEventListener() : BarCodeCaptureView
  • addBarcodeReadCompleteEventListener() : BarCodeReader
  • addCameraInitializationFailedListener() : ImageCaptureView
  • addCameraInitializationListener() : ImageCaptureView
  • addImage() : Page
  • addImageClassificationCompletedEventListener() : ImageClassifier
  • addImageOutEventListener() : ImageProcessor
  • addLevelnessListener() : ImageCaptureView
  • addLicenseFoundEventListener() : LicenseCaptureView
  • addOnAutoFocusResultListener() : ImageCaptureView
  • addOnImageCapturedListener() : CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience , ImageCaptureView
  • addPage() : Document
  • addPageDetectionListener() : DocumentBaseCaptureExperience
  • addPreviewCallbackListener() : ImageCaptureView
  • addProcessProgressEventListener() : ImageProcessor
  • addStabilityDelayListener() : ImageCaptureView
  • addTorchLuminanceListener() : ImageCaptureView
  • addVolumeLicenseEventListener() : Licensing
  • AFRICA : IdRegion
  • AFRICA_OTHER : IdParameters.IdState
  • AggregateException() : AggregateException
  • ALBANIA : IdParameters.IdState
  • ALL : BarCodeReader.Direction , SearchDirection
  • ALWAYS_USE_IF_ENABLED : GpsUsageLimits
  • analysisComplete() : ImageProcessor.AnalysisCompleteListener
  • AnalysisCompleteEvent() : ImageProcessor.AnalysisCompleteEvent
  • analysisProgress() : ImageProcessor.AnalysisProgressListener
  • AnalysisProgressEvent() : ImageProcessor.AnalysisProgressEvent
  • ANSI_X9 : Image.FileRestriction
  • appStatsDaoCurrent : AppStatistics
  • AppStatsSessionEvent() : AppStatsSessionEvent
  • AppStatsWriteToFileResults() : AppStatsWriteToFileResults
  • ASCII : BarCodeDataFormat
  • ASIA : IdRegion
  • ASIA_OTHER : IdParameters.IdState
  • AUSTRALIA : CheckParameters.CheckCountry , IdRegion
  • AUSTRALIA_OTHER : IdParameters.IdState
  • AUTO : Flash , LookAndFeelParameters.TorchMode
  • AutoFocusResultEvent() : AutoFocusResultEvent
  • AUTOTORCH : Flash
  • AZTEC : BarCodeType , Symbology


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- b -

  • BACK : CheckSide , Page.Side , IdParameters.IdSide
  • BACK_CAMERA : CameraType
  • barcode : IdParameters
  • BARCODE_CAPTURE : Licensing.LicenseType
  • BarCodeCaptureView() : BarCodeCaptureView
  • barCodeFound() : BarCodeFoundListener
  • BarCodeFoundEvent() : BarCodeFoundEvent
  • barcodeReadComplete() : BarCodeReader.BarcodeReadCompleteListener
  • BarcodeReadCompleteEvent() : BarCodeReader.BarcodeReadCompleteEvent
  • BarCodeReader() : BarCodeReader
  • BarCodeResult() : BarCodeResult
  • BASE_64 : BarCodeDataFormat
  • BasicSettingsProfile() : BasicSettingsProfile
  • beginSession() : AppStatistics
  • BILL_EXCEPTION : BillWorkflowActivity
  • BILL_EXTRACT_KTA : BillExtractor
  • BILL_EXTRACT_RTTI : BillExtractor
  • BILL_PARAMETERS : BillWorkflowActivity
  • BILL_RESULTS : BillWorkflowActivity
  • BillExtractor() : BillExtractor
  • BillExtractorResponse() : BillExtractorResponse
  • BillParameters() : BillParameters
  • BITDEPTH_BITONAL : Image.OutputColor
  • BITDEPTH_COLOR : Image.OutputColor
  • BITDEPTH_GRAYSCALE : Image.OutputColor
  • BITONAL : BasicSettingsProfile.OutputBitDepth , ColorDepth
  • BOOL : FieldType.DataType
  • BOTTOM_UP : BarCodeReader.Direction , BarCodeDirection
  • BoundingRect() : BoundingRect
  • BoundingTetragon() : BoundingTetragon
  • BRAZIL : IdParameters.IdState
  • build() : ServerBuilder
  • BundleCacheProvider() : BundleCacheProvider
  • BUSINESS_CHECK : MicrLine.CheckType


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- c -

  • cacheProject() : BundleCacheProvider , IBundleCacheProvider
  • cacheVariant() : BundleCacheProvider , IBundleCacheProvider
  • calculateBound() : BarCodeCaptureView
  • CAMERA_IMAGE_RESOLUTION_CHANGED : CameraInitializationEvent.CameraInitStatus
  • CAMERA_STATUS_UNKNOWN : CameraInitializationEvent.CameraInitStatus
  • CAMERA_USE_VIDEO_FRAME_CHANGED : CameraInitializationEvent.CameraInitStatus
  • CAMERA_VIEW_CREATED : CameraInitializationEvent.CameraInitStatus
  • CameraInitializationEvent() : CameraInitializationEvent
  • CameraInitializationFailedEvent() : CameraInitializationFailedEvent
  • CAMEROON : IdParameters.IdState
  • CANADA : CheckParameters.CheckCountry , IdParameters.IdState , IdRegion
  • cancel() : ImageProcessor , IImageProcessor , IIdExtractor , OnDeviceIdExtractor
  • cancelExtraction() : IServerExtractor
  • cancelLoadAllVariants() : ServerProjectProvider
  • cancelSubmission() : CaptureServer , ICaptureServer
  • CAPTURE : ImageSource
  • captureCriteriaMetInternal() : CaptureExperience
  • captureData : ProcessingParameters
  • capturedImageId : CaptureData
  • CaptureExperienceCriteriaHolder() : CaptureExperienceCriteriaHolder
  • captureImage() : CreditCardWorkflowActivity , WorkflowActivity< T extends IParameters >
  • CaptureMessage() : CaptureMessage
  • CaptureServer() : CaptureServer
  • cardStyle : CreditCardParameters
  • CERTIFICATE_VALIDATOR_LISTENER : ExtractActivity< T extends ExtractorResponse > , WorkflowActivity< T extends IParameters >
  • CHECK_EXCEPTION : CheckWorkflowActivity
  • CHECK_EXTRACT_KTA : CheckExtractor
  • CHECK_EXTRACT_RTTI : CheckExtractor
  • CHECK_PARAMETERS : CheckWorkflowActivity
  • CHECK_RESULTS : CheckWorkflowActivity
  • CheckCaptureExperience() : CheckCaptureExperience
  • CheckCaptureExperienceCriteriaHolder() : CheckCaptureExperienceCriteriaHolder
  • CheckDetectionSettings() : CheckDetectionSettings
  • CheckDetector() : CheckDetector
  • CheckExtractor() : CheckExtractor
  • CheckExtractorResponse() : CheckExtractorResponse
  • checkLicense() : BarCodeCaptureView , ImageCaptureView , LicenseCaptureView
  • CheckParameters() : CheckParameters
  • CHINA : IdParameters.IdState
  • classification() : IIdExtractionResult
  • classificationConfidence() : IIdExtractionResult
  • ClassificationResult() : ClassificationResult
  • classifyImage() : ImageClassifier
  • clearBitmap() : WorkflowActivity< T extends IParameters >
  • clearCache() : BundleCacheProvider
  • clearHighlights() : ImgReviewEditCntrl
  • clearImage() : ImgReviewEditCntrl
  • clone() : BasicSettingsProfile , BoundingTetragon , ImagePerfectionProfile , QuickAnalysisFeedback , ImageProcessorConfiguration , ClassificationResult , Document , DocumentType , Field , FieldType , UserProfile , Field< T extends Serializable >
  • close() : ZipFileBundle , ZipInputStreamBundle
  • Codabar : BarCodeReader.Symbology
  • CODABAR : BarCodeType , Symbology
  • Code128 : BarCodeReader.Symbology
  • CODE128 : BarCodeType , Symbology
  • Code25 : BarCodeReader.Symbology
  • CODE25 : BarCodeType , Symbology
  • Code39 : BarCodeReader.Symbology
  • CODE39 : BarCodeType , Symbology
  • Code93 : BarCodeReader.Symbology
  • CODE93 : BarCodeType , Symbology
  • COLOR : BasicSettingsProfile.OutputBitDepth , ColorDepth
  • ColorDepth() : ColorDepth
  • compare() : SdkVersion
  • COMPLETE : ImageClassifier.ImageClassificationStatus , AppStatistics.ExportStatusEvent , AppStatsExportListener.ExportStatus
  • configDsExpFilePath() : AppStatsDsExportHandler
  • ContextImageStorage() : ContextImageStorage
  • ConventionBasedJsonIdDeserializer() : ConventionBasedJsonIdDeserializer
  • country : CheckParameters
  • COUNTRY : KtaCheckExtractor
  • createResponse() : BillExtractor , CheckExtractor , Extractor< T extends Serializable > , IdExtractor , PassportExtractor
  • createScaledBitmap() : Image
  • CREATOR : CreditCard
  • credentials : ExtractionParameters
  • CREDIT_CARD_EXCEPTION : CreditCardWorkflowActivity
  • CREDIT_CARD_PARAMETERS : CreditCardWorkflowActivity
  • CREDIT_CARD_RESULTS : CreditCardWorkflowActivity
  • CreditCard() : CreditCard
  • CreditCardParameters() : CreditCardParameters
  • CROP_AUTO : BasicSettingsProfile.CropType , CropType
  • CROP_NONE : BasicSettingsProfile.CropType , CropType
  • CROP_QUICKANALYSIS : BasicSettingsProfile.CropType
  • CROP_TETRAGON : BasicSettingsProfile.CropType
  • cropType : ImageProcessorConfiguration


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- d -

  • DataField() : DataField
  • Datamatrix : BarCodeReader.Symbology
  • DATAMATRIX : BarCodeType , Symbology
  • dataVersion : LocalProjectProvider.VersionTable.VersionList
  • DATE : FieldType.DataType
  • DEFAULT_JPEG_QUALITY : Image
  • DEFAULT_LUMINANCE_THRESHOLD : ImageCaptureView
  • DEFAULT_TORCH_DELAY : ImageCaptureView
  • describeContents() : CreditCard
  • DESKEW_BY_DOCUMENT_CONTENT : DeskewType
  • DESKEW_BY_DOCUMENT_EDGES : DeskewType
  • DESKEW_NONE : DeskewType
  • deskewType : ImageProcessorConfiguration
  • destroy() : CheckDetector , DocumentDetector , IDocumentDetector< T extends DetectionSettings, U extends DetectionResult > , PassportDetector , CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • detect() : CheckDetector , DocumentDetector , ICheckDetector , IDocumentDetector< T extends DetectionSettings, U extends DetectionResult > , IPassportDetector , PassportDetector
  • DetectionSettings() : DetectionSettings
  • Direction() : BarCodeReader.Direction
  • DISK : ImageCacheType
  • doCleanup() : ImageClassifier , ImageProcessor
  • Document() : Document
  • DocumentBaseCaptureExperience() : DocumentBaseCaptureExperience
  • DocumentBaseCaptureExperienceCriteriaHolder() : DocumentBaseCaptureExperienceCriteriaHolder
  • DocumentCaptureExperience() : DocumentCaptureExperience
  • DocumentCaptureExperienceCriteriaHolder() : DocumentCaptureExperienceCriteriaHolder
  • DocumentDetectionSettings() : DocumentDetectionSettings
  • DocumentDetector() : DocumentDetector
  • DocumentDimensions() : DocumentDimensions
  • documentDimensions : ImageProcessorConfiguration
  • DocumentType() : DocumentType
  • doQuickAnalysis() : ImageProcessor


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- e -

  • Ean : BarCodeReader.Symbology
  • EAN : BarCodeType , Symbology
  • ECUADOR : IdParameters.IdState
  • EL_SALVADOR : IdParameters.IdState
  • EMAIL : FieldType.DataType
  • EMBOSSED : CreditCardParameters.CardStyle
  • enableAnimationTutor() : DocumentBaseCaptureExperience
  • enableConsoleLogging() : KENLogging , KLOLogging , KUILogging , KUTLogging , Logging
  • endSession() : AppStatistics
  • equals() : DocumentDimensions , Size , Field< T extends Serializable >
  • ERROR : ImageClassifier.ImageClassificationStatus
  • ErrorInfo() : ErrorInfo
  • EUROPE : IdRegion
  • EUROPE_OTHER : IdParameters.IdState
  • exceptionMessage() : ExceptionResponse , ExceptionResponseImpl
  • exceptionResponse : ExtractorResponse< T extends Serializable >
  • ExceptionResponseImpl() : ExceptionResponseImpl
  • exceptionType() : ExceptionResponse , ExceptionResponseImpl
  • exitEnabled : LookAndFeelParameters
  • EXP_FORMAT_APP_DEFINED : AppStatistics.AppStatsExportFormat
  • EXP_FORMAT_JSON : AppStatistics.AppStatsExportFormat
  • EXP_FORMAT_SQL_SERVER : AppStatistics.AppStatsExportFormat
  • export() : AppStatistics
  • EXPORTING : AppStatistics.ExportStatusEvent , AppStatsExportListener.ExportStatus
  • exportStatusEvent() : AppStatsExportListener
  • EXTRA_EXTRA_TIME_FOR_EXPIRY : CardIoWrapperActivity
  • extract() : CheckExtractActivity , ExtractActivity< T extends ExtractorResponse > , Extractor< T extends Serializable > , IdExtractActivity , KtaIdExtractor , RttiIdExtractor
  • extractData() : IServerExtractor
  • extractFields() : IIdExtractor , OnDeviceIdExtractor
  • ExtractionParameters() : ExtractionParameters
  • ExtractionServerException() : ExtractionServerException
  • Extractor() : Extractor< T extends Serializable >
  • extraTimeForExpiry : CreditCardParameters


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- f -

  • FAILED : AppStatistics.ExportStatusEvent , AppStatsExportListener.ExportStatus
  • Field() : Field , Field< T extends Serializable >
  • FieldLocation() : FieldLocation
  • FieldType() : FieldType
  • FILE_BUFFERED : Image.ImageFileRep
  • FILE_ENG_ANDROID : Image.FileIOEngine
  • FILE_ENG_KFIL : Image.FileIOEngine
  • FILE_NONE : Image.ImageFileRep
  • FILE_STORED : Image.ImageFileRep
  • finalize() : LocalProjectProvider
  • finish() : CaptureActivity
  • FixedAspectRatioCaptureExperience() : FixedAspectRatioCaptureExperience
  • FixedAspectRatioDetectionSettings() : FixedAspectRatioDetectionSettings
  • FixedAspectRatioExperienceCriteriaHolder() : FixedAspectRatioExperienceCriteriaHolder
  • FLAT : CreditCardParameters.CardStyle
  • FLIP : BoundingTetragon.Rotation
  • FLOAT : FieldType.DataType
  • forceCaptureEnabled : LookAndFeelParameters
  • forceTakePicture() : ImageCaptureView
  • fromExtractorField() : DataField
  • FRONT : CheckSide , Page.Side , IdParameters.IdSide
  • FRONT_CAMERA : CameraType


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- g -

  • galleryEnabled : LookAndFeelParameters
  • gePayeeName() : CheckUsabilityData
  • GERMANY : IdParameters.IdState
  • getAboveMaxFrontImageSize() : CheckIQAData
  • getAboveMaxRearImageSize() : CheckIQAData
  • getAbsolutePath() : IBundleFile
  • getAccountNumber() : MicrParser , KtaJsonBill , RttiJsonBill , Bill
  • getAdditionalBottomScanLinesHeight() : CheckIQAData
  • getAdditionalLeftScanLinesWidth() : CheckIQAData
  • getAdditionalRightScanLinesWidth() : CheckIQAData
  • getAdditionalTopScanLinesHeight() : CheckIQAData
  • getAddress() : ConventionBasedJsonIdDeserializer , Id
  • getAddress2() : ConventionBasedJsonIdDeserializer , Id
  • getAddress3() : ConventionBasedJsonIdDeserializer , Id
  • getAddress4() : ConventionBasedJsonIdDeserializer , Id
  • getAddress5() : ConventionBasedJsonIdDeserializer , Id
  • getAddress6() : ConventionBasedJsonIdDeserializer , Id
  • getAddressLine1() : KtaJsonBill , RttiJsonBill , Bill
  • getAddressLine2() : KtaJsonBill , RttiJsonBill , Bill
  • getAllowableImageResolutions() : ImageCaptureView
  • getAmount() : MicrLine , KtaJsonBill , RttiJsonBill , KtaJsonCheck , RttiJsonCheck , Bill , Check
  • getAspectRatioFraction() : CheckDetectionSettings
  • getAuxiliaryOnUs() : MicrLine , KtaJsonCheck , RttiJsonCheck , Check
  • getAverageSpotNoiseGroupingsPerSquareInch() : CheckIQAData
  • getBackBarcodes() : IdExtractionParameters
  • getBackException() : AggregateException
  • getBackground() : CaptureMessage
  • getBackgroundColor() : CaptureMessage
  • getBackImage() : IdExtractionParameters
  • getBarCode() : BarCodeFoundEvent
  • getBarCodeType() : BarCodeReader.Symbology
  • getBasicSettingsProfile() : ImageProcessor , DocumentType , DocumentTypeR
  • getBasicSettingsProfileUsed() : Image
  • getBcVersion() : BarCodeReader , SdkVersion
  • getBelowMinFrontImageSize() : CheckIQAData
  • getBelowMinRearImageSize() : CheckIQAData
  • getBillers() : KtaJsonBill , RttiJsonBill , Bill
  • getBitmap() : PreviewFrameEvent
  • getBitmapLandscape() : PreviewFrameEvent
  • getBitsPerChannel() : Image.OutputColor
  • getBitsPerPixel() : Image.OutputColor
  • getBlackStreakCount() : CheckIQAData
  • getBlackStreakMaxHeight() : CheckIQAData
  • getBlinkMessage() : SelfieBaseCaptureExperience
  • getBlurCountPercentThreshold() : QuickAnalysisSettings
  • getBlurDetection() : QuickAnalysisSettings
  • getBlurThreshold() : QuickAnalysisSettings
  • getBottomEdgeTearHeight() : CheckIQAData
  • getBottomEdgeTearWidth() : CheckIQAData
  • getBottomLeft() : BoundingTetragon
  • getBottomLeftCornerHeight() : CheckIQAData
  • getBottomLeftCornerWidth() : CheckIQAData
  • getBottomRight() : BoundingTetragon
  • getBottomRightCornerHeight() : CheckIQAData
  • getBottomRightCornerWidth() : CheckIQAData
  • getBound() : PageDetectionEvent
  • getBoundingBox() : BarCodeResult
  • getBounds() : DetectionResult
  • getBundleVersion() : LocalProjectProvider
  • getCameraInitStatus() : CameraInitializationEvent
  • getCameraView() : CaptureActivity , IdCaptureBackActivity
  • getCaptureActivityClass() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getCaptureCriteria() : CheckCaptureExperience , DocumentCaptureExperience , FixedAspectRatioCaptureExperience , PassportCaptureExperience , SelfieBaseCaptureExperience
  • getCapturedMessage() : DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience , SelfieBaseCaptureExperience
  • getCar() : KtaJsonCheck , RttiJsonCheck , Check
  • getCAR() : CheckUsabilityData
  • getCarbonStrip() : CheckIQAData
  • getCarbonStripHeight() : CheckIQAData
  • getCardNumber() : CreditCard
  • getCause() : CameraInitializationFailedEvent
  • getCenterMessage() : CheckCaptureExperience , DocumentBaseCaptureExperience , PassportCaptureExperience
  • getCenterPoint() : DetectionSettings , FixedAspectRatioDetectionSettings , SelfieDetectionSettings
  • getCertificateValidationListener() : ServerExtractionParameters
  • getCertificateValidatorListener() : LoginCredentials
  • getChannels() : Image.OutputColor
  • getCheckDetectionSettings() : CheckCaptureExperienceCriteriaHolder
  • getCheckIQAData() : KtaJsonCheck , RttiJsonCheck , Check
  • getCheckNumber() : MicrParser , KtaJsonCheck , RttiJsonCheck , Check
  • getCheckSampleImage() : CheckCaptureExperience
  • getCheckSide() : CheckDetectionResult
  • getCheckType() : MicrLine
  • getCheckUsabilityData() : KtaJsonCheck , RttiJsonCheck , Check
  • getCity() : KtaJsonBill , RttiJsonBill , ConventionBasedJsonIdDeserializer , Bill , Id
  • getClassId() : ImageClassificationResult , ClassificationResult
  • getClassificationAlternatives() : Document
  • getClassifierVersion() : SdkVersion
  • getCode() : ExtractionServerException
  • getCodeline() : CheckUsabilityData
  • getCompressedFrontImageSize() : CheckIQAData
  • getCompressedRearImageSize() : CheckIQAData
  • getConfidence() : ImageClassificationResult , ClassificationResult , Field< T extends Serializable > , DataField
  • getContext() : AppContextProvider
  • getCountry() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getCountryLong() : Passport , KtaJsonPassport , RttiJsonPassport
  • getCountryShort() : ConventionBasedJsonIdDeserializer , Id
  • getCropCornerColor() : ImgReviewEditCntrl
  • getCropLineColor() : ImgReviewEditCntrl
  • getCroppingTetragon() : BasicSettingsProfile
  • getCropTetragon() : ImgReviewEditCntrl
  • getCropType() : BasicSettingsProfile
  • getCurrentImageIndex() : Page
  • getCustomTag() : FieldType
  • getCvv() : CreditCard
  • getData() : PreviewFrameEvent
  • getDataFormat() : BarCodeResult
  • getDataType() : FieldType
  • getDate() : KtaJsonCheck , RttiJsonCheck , Check , CheckUsabilityData
  • getDateOfBirth() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getDaysRemaining() : LicenseFoundEvent , Licensing
  • getDbFieldKeyType() : AppStatsDaoField
  • getDbFieldType() : AppStatsDaoField
  • getDefault() : FieldType
  • getDefaultImageCaptureResolution() : CameraInitializationEvent
  • getDefaultProcessingString() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getDefaultReturnObject() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getDefaultServerUrl() : BillExtractor , CheckExtractor , Extractor< T extends Serializable > , IdExtractor , PassportExtractor
  • getDetectionSettings() : DocumentCaptureExperienceCriteriaHolder , FixedAspectRatioExperienceCriteriaHolder , SelfieCaptureExperienceCriteriaHolder
  • getDeviceDeclinationPitch() : ImageCaptureView
  • getDeviceDeclinationRoll() : ImageCaptureView
  • getDeviceId() : AppStatistics
  • getDirection() : BarCodeResult
  • getDisplayName() : DocumentType , DocumentTypeR , FieldType
  • getDocHeight() : DocumentType , DocumentTypeR
  • getDocumentFramingError() : CheckIQAData
  • getDocumentId() : Document
  • getDocumentID() : Page
  • getDocumentLevelError() : Document
  • getDocumentSampleImage() : DocumentBaseCaptureExperience
  • getDocumentSkew() : CheckIQAData
  • getDocumentSkewAngle() : CheckIQAData
  • getDocumentState() : Id
  • getDocumentType() : Document , ConventionBasedJsonIdDeserializer , Id , CaptureServer , ICaptureServer
  • getDocumentVerificationConfidenceRating() : ConventionBasedJsonIdDeserializer , Id , IIdExtractionResult
  • getDocWidth() : DocumentType , DocumentTypeR
  • getDoDeskew() : BasicSettingsProfile
  • getDomain() : UserProfile
  • getDsFieldName() : AppStatsDaoField
  • getDsFieldType() : AppStatsDaoField
  • getDsValueDate() : AppStatsDaoField
  • getDsValueFloat() : AppStatsDaoField
  • getDsValueInt() : AppStatsDaoField
  • getDsValueLong() : AppStatsDaoField
  • getDsValueString() : AppStatsDaoField
  • getDueDate() : KtaJsonBill , RttiJsonBill , Bill
  • getEdgeDetection() : DocumentDetectionSettings
  • getEPC() : MicrLine
  • getEpc() : KtaJsonCheck , RttiJsonCheck , Check
  • getErr() : ErrorInfo
  • getErrCause() : ErrorInfo
  • getErrDesc() : ErrorInfo
  • getErrMsg() : ErrorInfo
  • getErrorDescription() : Field
  • getErrorInfo() : LicenseFoundEvent , AppStatsExportEvent , AppStatsWritetoFileEvent , KmcException , KmcRuntimeException
  • getErrorState() : SessionState
  • getExceptionKey() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getExpirationDate() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getExpirationMonth() : CreditCard
  • getExpirationYear() : CreditCard
  • getExportStatus() : AppStatsExportEvent
  • getExtractActivityClass() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getExtractionParameters() : BillParameters , CheckParameters , CreditCardParameters , IdParameters , IParameters , PassportParameters
  • getExtractionType() : ExtractionParameters
  • getEyes() : ConventionBasedJsonIdDeserializer , Id
  • getFaceAngleTolerance() : SelfieDetectionSettings
  • getFaceImage() : ConventionBasedJsonIdDeserializer , Id
  • getFields() : Document , IIdExtractionResult
  • getFieldType() : Field
  • getFieldTypes() : DocumentType , DocumentTypeR
  • getFile() : IBundleFile
  • getFileName() : AppStatistics
  • getFileSize() : AppStatistics
  • getFileSizeThreshold() : AppStatistics
  • getFirstName() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getFlash() : ImageCaptureView
  • getFocusAreas() : ImageCaptureView
  • getFoldedOrTornDocumentCorners() : CheckIQAData
  • getFoldedOrTornDocumentEdges() : CheckIQAData
  • getFrameColor() : SelfieBaseCaptureExperience
  • getFrontBarcodes() : IdExtractionParameters
  • getFrontException() : AggregateException
  • getFrontImage() : IdExtractionParameters
  • getFrontRearHeightDifference() : CheckIQAData
  • getFrontRearWidthDifference() : CheckIQAData
  • getGender() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getGlareDetectedThreshold() : QuickAnalysisSettings
  • getGlareDetection() : QuickAnalysisSettings
  • getGlareDetectionIntensityFraction() : QuickAnalysisSettings
  • getGlareDetectionIntensityThreshold() : QuickAnalysisSettings
  • getGlareDetectionMinimumGlareAreaFraction() : QuickAnalysisSettings
  • getGlareDetectionNumberOfTiles() : QuickAnalysisSettings
  • getGpsUsage() : ImageCaptureView
  • getGrayLevelStreakCount() : CheckIQAData
  • getGrayLevelStreakMaxHeight() : CheckIQAData
  • getGuidanceFrameColor() : DocumentBaseCaptureExperience
  • getGuidingLine() : BarCodeCaptureView
  • getHair() : ConventionBasedJsonIdDeserializer , Id
  • getHeight() : CaptureMessage , PreviewFrameEvent , ConventionBasedJsonIdDeserializer , Id
  • getHighestVersion() : IProjectProvider , LocalProjectProvider , ServerProjectProvider
  • getHighestVersionAsync() : ServerProjectProvider
  • getHoldParallelMessage() : DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience
  • getHoldSteadyDelay() : DocumentBaseCaptureExperienceCriteriaHolder
  • getHoldSteadyMessage() : DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience , SelfieBaseCaptureExperience
  • getHorizontalMovementGuidance() : DetectionResult
  • getHorizontalStreaks() : CheckIQAData
  • getIdClass() : ConventionBasedJsonIdDeserializer , Id
  • getIdentifier() : ImageCacheType
  • getIdNumber() : ConventionBasedJsonIdDeserializer , Id
  • getIdType() : IdExtractionParameters
  • getImage() : BarCodeReader.BarcodeReadCompleteEvent , ImageClassificationCompleteEvent , ImageProcessor.AnalysisCompleteEvent , ImageProcessor.ImageOutEvent , BarCodeFoundEvent , ImageCapturedEvent , ImgReviewEditCntrl , ContextImageStorage , IImageStorage
  • getImageBarCodes() : Image
  • getImageBitmap() : Image
  • getImageBitmapHeight() : Image
  • getImageBitmapScaling() : Image
  • getImageBitmapWidth() : Image
  • getImageByBitmapId() : ExtractActivity< T extends ExtractorResponse > , IdExtractActivity
  • getImageBytes() : ServerExtractionParameters
  • getImageClassifyResults() : Image
  • getImageCreateDateTime() : Image
  • getImageDimensionMismatch() : CheckIQAData
  • getImageDPI() : Image
  • getImageFileBuffer() : Image
  • getImageFileHeight() : Image
  • getImageFilePath() : Image
  • getImageFileRep() : Image
  • getImageFileWidth() : Image
  • getImageFocusScore() : CheckIQAData
  • getImageHeight() : CheckIQAData
  • getImageID() : Image , ImageProcessor.AnalysisProgressEvent , ImageProcessor.ProcessProgressEvent
  • getImageJpegQuality() : Image
  • getImageLatitude() : Image
  • getImageLongitude() : Image
  • getImageMetaData() : Image
  • getImageMimeType() : Image
  • getImageOutputColor() : Image
  • getImagePerfectionProfile() : ImageProcessor , DocumentType , DocumentTypeR
  • getImagePerfectProfileUsed() : Image
  • getImagePitch() : Image
  • getImagePreviewHeight() : ImageCaptureView
  • getImagePreviewWidth() : ImageCaptureView
  • getImageQuickAnalysisFeedBack() : Image
  • getImageRepresentation() : Image
  • getImageRoll() : Image
  • getImages() : Page , ServerExtractionParameters
  • getImageSize() : Image
  • getImageSrcID() : Image
  • getImageStorage() : ApplicationContextImageStore
  • getImageTag() : Image
  • getImageTooDark() : CheckIQAData
  • getImageTooLight() : CheckIQAData
  • getImageWidth() : CheckIQAData
  • getInnerThrowables() : ListOfException
  • getInputDocLongEdge() : BasicSettingsProfile
  • getInputDocShortEdge() : BasicSettingsProfile
  • getInstance() : AppStatistics
  • getIpOperations() : ImagePerfectionProfile
  • getIpOperationsFilePath() : ImagePerfectionProfile
  • getIpVersion() : SdkVersion
  • getIssueDate() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getKtaPassword() : LoginCredentials
  • getKtaUserName() : LoginCredentials
  • getLabel() : FieldType
  • getLar() : KtaJsonCheck , RttiJsonCheck , Check
  • getLAR() : CheckUsabilityData
  • getLastName() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getLatestCachedModelDataBuildInfo() : IProjectProvider , LocalProjectProvider , ServerProjectProvider
  • getLatestModelDataBuildInfo() : BundleCacheProvider , IBundleCacheProvider
  • getLatestVersionForProject() : BundleCacheProvider , IBundleCacheProvider
  • getLeftEdgeTearHeight() : CheckIQAData
  • getLeftEdgeTearWidth() : CheckIQAData
  • getLicense() : ConventionBasedJsonIdDeserializer , Id
  • getLicenseString() : LicenseFoundEvent
  • getListener() : IdExtractionParameters
  • getListenerCallbackThreadType() : ImageProcessor , AppStatistics
  • getLocation() : Field< T extends Serializable >
  • getLongEdge() : DocumentDimensions
  • getLongEdgeThreshold() : DocumentDetectionSettings
  • getLookAndFeelParameters() : BillParameters , CheckParameters , CreditCardParameters , IdParameters , IParameters , PassportParameters
  • getLowContrastBackgroundDetection() : QuickAnalysisSettings
  • getLuminance() : TorchLuminanceEvent
  • getLuminanceThreshold() : ImageCaptureView
  • getMax() : FieldType
  • getMaxBarcodes() : BarCodeReader
  • getMaxFillFraction() : DetectionSettings
  • getMaxFocusAreas() : ImageCaptureView
  • getMaxNumberOfResults() : ImageClassifier
  • getMaxSkewAngle() : DetectionSettings
  • getMessage() : CaptureMessage , ExtractionServerException
  • getMessageIcons() : CaptureMessage
  • getMicr() : KtaJsonCheck , RttiJsonCheck , Check
  • getMicrAmount() : KtaJsonCheck , RttiJsonCheck , Check
  • getMicrData() : Image
  • getMicrLine() : MicrParser
  • getMiddleName() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getMin() : FieldType
  • getMinFillFraction() : DetectionSettings
  • getMinimumFaceSize() : SelfieDetectionSettings
  • getMissingBordersDetection() : QuickAnalysisSettings
  • getMRZ1() : Passport , KtaJsonPassport , RttiJsonPassport
  • getMRZ2() : Passport , KtaJsonPassport , RttiJsonPassport
  • getName() : ImagePerfectionProfile , FieldType , KtaJsonBill , RttiJsonBill , Bill , CreditCard , Field< T extends Serializable > , IBundleFile
  • getNameSuffix() : ConventionBasedJsonIdDeserializer , Id
  • getNationality() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getNextState() : SessionState
  • getObject() : Field< T extends Serializable > , DataField
  • getOnUs() : MicrLine
  • getOnUs1() : MicrLine , KtaJsonCheck , RttiJsonCheck , Check
  • getOnUs2() : MicrLine , KtaJsonCheck , RttiJsonCheck , Check
  • getOptions() : FieldType
  • getOrientation() : ImageClassificationResult , CaptureMessage
  • getOrientationGuidance() : DetectionResult
  • getOriginalImage() : DetectionResult
  • getOuterViewFinderColor() : DocumentBaseCaptureExperience , SelfieBaseCaptureExperience , LicenseCaptureView
  • getOutOfFocus() : CheckIQAData
  • getOutputBitDepth() : BasicSettingsProfile
  • getOutputDPI() : BasicSettingsProfile
  • getOversizeImage() : CheckIQAData
  • getPackageVersion() : KenVersion , KloVersion , KuiVersion , SdkVersion , KutVersion
  • getPaddingPercent() : SelfieBaseCaptureExperience
  • getPageID() : Page
  • getPages() : Document
  • getParameters() : WorkflowActivity< T extends IParameters > , ServerExtractionParameters
  • getParametersInstance() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getParametersKey() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getPassportDetectionSettings() : PassportCaptureExperienceCriteriaHolder
  • getPassportNumber() : Passport , KtaJsonPassport , RttiJsonPassport
  • getPassportSampleImage() : PassportCaptureExperience
  • getPassword() : UserProfile
  • getPayee() : KtaJsonCheck , RttiJsonCheck , Check
  • getPayeeEndorsement() : CheckUsabilityData
  • getPercentAverageImageBrightness() : CheckIQAData
  • getPercentAverageImageContrast() : CheckIQAData
  • getPercentBlackPixels() : CheckIQAData
  • getPercentComplete() : AppStatsExportEvent , AppStatsWritetoFileEvent
  • getPersonalNumber() : Passport , KtaJsonPassport , RttiJsonPassport
  • getPhoneNumber() : KtaJsonBill , RttiJsonBill , Bill
  • getPiggybackDocument() : CheckIQAData
  • getPitch() : LevelnessEvent
  • getPitchThreshold() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • getPosX() : CaptureMessage
  • getPosY() : CaptureMessage
  • getPreviewImage() : PageDetectionEvent
  • getProcessedImageFilePath() : ImageProcessor
  • getProcessedImageJpegQuality() : ImageProcessor
  • getProcessedImageMimeType() : ImageProcessor
  • getProcessedImageRepresentation() : ImageProcessor
  • getProcessingParameters() : BillParameters , CheckParameters , CreditCardParameters , IdParameters , IParameters , PassportParameters
  • getProcessName() : KtaBillExtractor , KtaCheckExtractor , KtaIdExtractor , KtaPassportExtractor
  • getProgressPct() : ImageProcessor.AnalysisProgressEvent , ImageProcessor.ProcessProgressEvent
  • getProject() : BundleCacheProvider , IBundleCacheProvider , IProjectProvider , LocalProjectProvider , ServerProjectProvider
  • getProjectAsync() : LocalProjectProvider
  • getProjectName() : IdExtractionParameters
  • getRamSize() : AppStatistics
  • getRamSizeThreshold() : AppStatistics
  • getRawData() : KtaJsonBill , RttiJsonBill , KtaJsonCheck , RttiJsonCheck , ConventionBasedJsonIdDeserializer , Bill , Check , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getReasonForRejection() : KtaJsonCheck , RttiJsonCheck , Check
  • getRectBottom() : BoundingRect
  • getRectLeft() : BoundingRect
  • getRectRight() : BoundingRect
  • getRectTop() : BoundingRect
  • getRegion() : IdExtractionParameters
  • getRegionName() : IdRegion
  • getRemainingLicenseCount() : Licensing
  • getResponse() : AppStatsSessionEvent
  • getRestrictiveEndorsement() : KtaJsonCheck , RttiJsonCheck , Check
  • getRestrictiveEndorsementPresent() : KtaJsonCheck , RttiJsonCheck , Check
  • getResultKey() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getRetainImage() : ImgReviewEditCntrl
  • getRightEdgeTearHeight() : CheckIQAData
  • getRightEdgeTearWidth() : CheckIQAData
  • getRoll() : LevelnessEvent
  • getRollThreshold() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • getRotateMessage() : DocumentBaseCaptureExperience
  • getRotateType() : BasicSettingsProfile
  • getRotation() : PreviewFrameEvent
  • getRotationLandscape() : PreviewFrameEvent
  • getSaturationDetection() : QuickAnalysisSettings
  • getSdkVersion() : SdkVersion
  • getSearchDirection() : BarCodeCaptureView
  • getSearchDirections() : BarCodeReader
  • getSearchSymbology() : BarCodeReader
  • getServerTimeout() : CaptureServer
  • getServerUrl() : LoginCredentials , ServerExtractionParameters
  • getShadowDetection() : QuickAnalysisSettings
  • getSheetID() : Page
  • getShortEdge() : DocumentDimensions
  • getShortEdgeThreshold() : DocumentDetectionSettings
  • getSide() : CheckDetectionSettings , Page
  • getSignature() : CheckUsabilityData
  • getSignatureImage() : ConventionBasedJsonIdDeserializer , Id
  • getSize() : AppStatsThresholdReachedEvent
  • getSkewDetection() : QuickAnalysisSettings
  • getSource() : KtaJsonBill , RttiJsonBill , Bill
  • getSourceServer() : DocumentType , DocumentTypeR
  • getSpotNoise() : CheckIQAData
  • getSSLSocketFactory() : CertificateValidatorListener
  • getStability() : StabilityDelayEvent
  • getStabilityThreshold() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • getState() : AppStatsWriteToFileResults , KtaJsonBill , RttiJsonBill , ConventionBasedJsonIdDeserializer , Bill , Id
  • getStatus() : BarCodeReader.BarcodeReadCompleteEvent , ImageClassifier , ImageProcessor.AnalysisCompleteEvent , ImageProcessor.AnalysisProgressEvent , ImageProcessor.ImageOutEvent , ImageProcessor.ProcessProgressEvent
  • getSuccess() : AutoFocusResultEvent
  • getSymbologies() : BarCodeCaptureView
  • getTag() : Field
  • getTargetFrame() : Image
  • getTargetFrameAspectRatio() : CheckDetectionSettings , DetectionSettings , FixedAspectRatioDetectionSettings , PassportDetectionSettings , SelfieDetectionSettings
  • getTargetFramePaddingPercent() : DetectionSettings , FixedAspectRatioDetectionSettings , SelfieDetectionSettings
  • getTetragonCorners() : QuickAnalysisFeedback
  • getTextColor() : CaptureMessage
  • getTextSize() : CaptureMessage
  • getThresholdType() : AppStatsThresholdReachedEvent
  • getTimeOut() : TimeOutParameters
  • getTimeOutParameters() : LoginCredentials , ServerExtractionParameters
  • getToleranceFraction() : DetectionSettings
  • getTopEdgeTearHeight() : CheckIQAData
  • getTopEdgeTearWidth() : CheckIQAData
  • getTopLeft() : BoundingTetragon
  • getTopLeftCornerHeight() : CheckIQAData
  • getTopLeftCornerWidth() : CheckIQAData
  • getTopRight() : BoundingTetragon
  • getTopRightCornerHeight() : CheckIQAData
  • getTopRightCornerWidth() : CheckIQAData
  • getTorchDelay() : ImageCaptureView
  • getTransit() : KtaJsonCheck , RttiJsonCheck , Check
  • getTransitNumber() : MicrLine , MicrParser
  • getTurnGuidance() : DetectionResult
  • getTutorialDismissMessage() : DocumentBaseCaptureExperience
  • getType() : BarCodeResult , AppStatsSessionEvent
  • getTypeface() : CaptureMessage
  • getTypeName() : DocumentType , DocumentTypeR
  • getUndersizeImage() : CheckIQAData
  • getUnit() : TimeOutParameters
  • getUsable() : KtaJsonCheck , RttiJsonCheck , Check
  • getUseDocumentDetectionBasedCrop() : ImagePerfectionProfile , QuickAnalysisSettings
  • getUseMRZPassportDetection() : ImagePerfectionProfile , QuickAnalysisSettings
  • getUserEmailAddress() : UserProfile
  • getUserInstructionMessage() : CheckCaptureExperience , DocumentBaseCaptureExperience , PassportCaptureExperience , SelfieBaseCaptureExperience , LicenseCaptureView
  • getUsername() : UserProfile
  • getUseTargetFrameCrop() : ImagePerfectionProfile , QuickAnalysisSettings
  • getUseVideoFrame() : ImageCaptureView
  • getValue() : BarCodeResult , Field , SearchDirection
  • getValueSet() : MicrLine
  • getVariant() : BundleCacheProvider , IBundleCacheProvider , IProjectProvider , LocalProjectProvider , ServerProjectProvider
  • getVariantAsync() : LocalProjectProvider
  • getVersion() : DocumentType , DocumentTypeR
  • getVerticalMovementGuidance() : DetectionResult
  • getViewBoundariesImage() : QuickAnalysisFeedback
  • getViewfinderPaddingPercent() : LicenseCaptureView
  • getViewGroup() : ImageCaptureView
  • getVisibility() : CaptureMessage
  • getWeight() : ConventionBasedJsonIdDeserializer , Id
  • getWidth() : CaptureMessage , PreviewFrameEvent
  • getWritetoFileStatus() : AppStatsWritetoFileEvent
  • getZip() : KtaJsonBill , RttiJsonBill , ConventionBasedJsonIdDeserializer , Bill , Id
  • getZoomGuidance() : DetectionResult
  • getZoomInMessage() : DocumentBaseCaptureExperience
  • getZoomOutMessage() : DocumentBaseCaptureExperience
  • GPU_BASED : DocumentDetectionSettings.DocumentEdgeDetection
  • GRAYSCALE : BasicSettingsProfile.OutputBitDepth , ColorDepth
  • GUATEMALA : IdParameters.IdState


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- h -

  • handleException() : WorkflowActivity< T extends IParameters >
  • hashCode() : DocumentDimensions , Size , Field< T extends Serializable >
  • hasMoreElements() : ZipInputStreamBundle
  • height() : BoundingRect , Size , SizeDouble
  • HONG_KONG : CheckParameters.CheckCountry
  • HORIZONTAL : SearchDirection
  • HORIZONTAL_MOVE_LEFT : HorizontalGuidance
  • HORIZONTAL_MOVE_OK : HorizontalGuidance
  • HORIZONTAL_MOVE_RIGHT : HorizontalGuidance


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- i -

  • Id : IdType
  • ID_BARCODE_RESULTS : IdWorkflowActivity
  • ID_EXCEPTION : IdWorkflowActivity
  • ID_EXTRACT_KTA : IdExtractor
  • ID_EXTRACT_ON_DEVICE : IdExtractor
  • ID_EXTRACT_RTTI : IdExtractor
  • ID_EXTRACTION : Licensing.LicenseType
  • ID_PARAMETERS : IdWorkflowActivity
  • ID_RESULTS : IdWorkflowActivity
  • IdExtractionParameters() : IdExtractionParameters
  • IdExtractor() : IdExtractor
  • IdExtractorResponse() : IdExtractorResponse
  • IdParameters() : IdParameters
  • IdRegion() : IdRegion
  • IdState() : IdParameters.IdState
  • Image() : Image
  • IMAGE : ImageSource
  • IMAGE_CACHE_TYPE_DISK : ImageCacheType
  • IMAGE_CACHE_TYPE_MEMORY : ImageCacheType
  • IMAGE_CAPTURE : Licensing.LicenseType
  • IMAGE_CAPTURED : CaptureActivity
  • IMAGE_PROCESSING : Licensing.LicenseType
  • IMAGE_REP_BITMAP : Image.ImageRep
  • IMAGE_REP_BOTH : Image.ImageRep
  • IMAGE_REP_FILE : Image.ImageRep
  • IMAGE_REP_NONE : Image.ImageRep
  • ImageCacheType() : ImageCacheType
  • ImageCapturedEvent() : ImageCapturedEvent
  • ImageCaptureView() : ImageCaptureView
  • ImageClassificationResult() : ImageClassificationResult
  • ImageClassifier() : ImageClassifier
  • imageClearBitmap() : Image
  • imageClearFileBuffer() : Image
  • imageDeleteFile() : Image
  • imageOut() : ImageProcessor.ImageOutListener
  • ImageOutEvent() : ImageProcessor.ImageOutEvent
  • ImagePerfectionProfile() : ImagePerfectionProfile
  • ImageProcessor() : ImageProcessor
  • ImageProcessorConfiguration() : ImageProcessorConfiguration
  • imageReadFromFile() : Image
  • imageReadFromFileBuffer() : Image
  • imageWriteToFile() : Image
  • imageWriteToFileBuffer() : Image
  • ImgReviewEditCntrl() : ImgReviewEditCntrl
  • IN_PROGRESS : ImageClassifier.ImageClassificationStatus
  • INDIA : IdParameters.IdState
  • initAppStats() : AppStatistics
  • initBase() : DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • initController() : CaptureActivity
  • innerException() : ExceptionResponse , ExceptionResponseImpl
  • INT : FieldType.DataType
  • invokeImageCapturedListeners() : CaptureExperience
  • ippString : ImageProcessorConfiguration
  • isAnimationTutorEnable() : DocumentBaseCaptureExperience
  • isBarcodeRead() : ConventionBasedJsonIdDeserializer , Id , IIdExtractionResult
  • isBelowThreshold() : TorchLuminanceEvent
  • isBlurry() : QuickAnalysisFeedback
  • isDiagnosticsViewEnabled() : DocumentBaseCaptureExperience
  • isDirectory() : IBundleFile
  • isError() : AppStatsWriteToFileResults
  • isFlashSupported() : ImageCaptureView
  • isFocusEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder , SelfieCaptureExperienceCriteriaHolder
  • isForceMatch() : FieldType
  • ISG : DocumentDetectionSettings.DocumentEdgeDetection
  • isGlareDetected() : QuickAnalysisFeedback
  • isHidden() : FieldType
  • isLowContrastBackground() : QuickAnalysisFeedback
  • isMicrValid() : MicrParser
  • isMissingBorders() : QuickAnalysisFeedback
  • isOcrRead() : ConventionBasedJsonIdDeserializer , Id , IIdExtractionResult
  • isOdeSupported() : IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • isOrientationEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder , FixedAspectRatioExperienceCriteriaHolder
  • isOverlySkewed() : QuickAnalysisFeedback
  • isOversaturated() : QuickAnalysisFeedback
  • isPageDetectionEnabled() : DocumentBaseCaptureExperienceCriteriaHolder
  • isPitchThresholdEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • isProcessed() : IdExtractionParameters
  • isReachable() : SessionState
  • isReadOnly() : FieldType
  • isRecording() : AppStatistics
  • isRefocusBeforeCaptureEnabled() : CaptureExperienceCriteriaHolder
  • isRequired() : FieldType
  • isRollThresholdEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • isSdkLicensed() : Licensing
  • isShadowed() : QuickAnalysisFeedback
  • isStabilityThresholdEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • isTorchOn() : TorchLuminanceEvent
  • isUndersaturated() : QuickAnalysisFeedback
  • isValid() : Field
  • isVibrationEnabled() : CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- j -

  • JAPAN : IdParameters.IdState


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- k -

  • KEY_PASS : IdParameters.IdState
  • KMC_BC_BUSY : ErrorInfo
  • KMC_BC_IMAGE_BUFFERED : ErrorInfo
  • KMC_BC_INVALID_IMAGE : ErrorInfo
  • KMC_BC_NO_BARCODE_FOUND : ErrorInfo
  • KMC_BC_NO_REPRESENTATION : ErrorInfo
  • KMC_BC_UNKNOWN : ErrorInfo
  • KMC_BC_UNSUPPORTED_REGION : ErrorInfo
  • KMC_CL_CLASSIFICATION_CONFIDENCE_LOW : ErrorInfo
  • KMC_CL_CLASSIFIER_BUSY : ErrorInfo
  • KMC_CL_CLASSIFIER_NOT_INITIALIZED : ErrorInfo
  • KMC_CL_CONFIG_NOT_LOADED : ErrorInfo
  • KMC_CL_CONFIG_NULL : ErrorInfo
  • KMC_CL_ENCRYPTED_BARCODE_STRING : ErrorInfo
  • KMC_CL_ID_CLASS_NOT_SUPPORTED : ErrorInfo
  • KMC_CL_INVALID_BARCODE_STRING : ErrorInfo
  • KMC_CL_INVALID_IMAGE_SUPPLIED : ErrorInfo
  • KMC_CL_LISTENER_NULL : ErrorInfo
  • KMC_CL_MAX_NUM_RESULTS_INVALID : ErrorInfo
  • KMC_CL_MODEL_NOT_LOADED : ErrorInfo
  • KMC_CL_MODEL_NULL : ErrorInfo
  • KMC_CL_NO_IMAGE_SUPPLIED : ErrorInfo
  • KMC_ED_ALREADY_BUFFERED : ErrorInfo
  • KMC_ED_ALREADY_CLEAR : ErrorInfo
  • KMC_ED_ALTERNATE_FILEIO_ENGINE : ErrorInfo
  • KMC_ED_BITMAP_DIMENSIONS_IMMUTABLE : ErrorInfo
  • KMC_ED_BITMAP_DIMENSIONS_NO_UPSCALE : ErrorInfo
  • KMC_ED_BITMAP_READ_FROM_FILE_FAILED : ErrorInfo
  • KMC_ED_BITMAP_WRITE_TO_FILE_FAILED : ErrorInfo
  • KMC_ED_BUFFER : ErrorInfo
  • KMC_ED_BUFFER_ALREADY_CLEARED : ErrorInfo
  • KMC_ED_BUFFER_EXISTS : ErrorInfo
  • KMC_ED_BUFFERED_READ_FAILED : ErrorInfo
  • KMC_ED_DELETE_BUFFERED_FILE : ErrorInfo
  • KMC_ED_FILE_EXISTS : ErrorInfo
  • KMC_ED_FILE_NOT_DELETABLE : ErrorInfo
  • KMC_ED_FILE_RESTRICTION_BITDEPTH : ErrorInfo
  • KMC_ED_FILE_RESTRICTION_DPI : ErrorInfo
  • KMC_ED_FILE_RESTRICTION_MIMETYPE : ErrorInfo
  • KMC_ED_FILE_STILL_REMAINS : ErrorInfo
  • KMC_ED_FILEPATH : ErrorInfo
  • KMC_ED_IMAGE_FILE_DIMENSIONS_ERROR : ErrorInfo
  • KMC_ED_IMAGE_INVALID_SCALING_FACTOR : ErrorInfo
  • KMC_ED_IMAGE_IS_SCALED : ErrorInfo
  • KMC_ED_IMAGE_PERFECTION_PROFILE_EMPTY : ErrorInfo
  • KMC_ED_IMAGE_WRITTEN_IS_NOT_BITONAL : ErrorInfo
  • KMC_ED_IMAGE_WRITTEN_IS_NOT_GRAY : ErrorInfo
  • KMC_ED_IMAGELEAK : ErrorInfo
  • KMC_ED_INVALID_DOCUMENT_DIMENSIONS : ErrorInfo
  • KMC_ED_INVALID_DPI : ErrorInfo
  • KMC_ED_INVALID_FOR_OBJECT_REP : ErrorInfo
  • KMC_ED_INVALID_ISO_DATE_TIME_FORMAT : ErrorInfo
  • KMC_ED_INVALID_JPEG_QUALITY_VALUE : ErrorInfo
  • KMC_ED_JPEG_BITDEPTH : ErrorInfo
  • KMC_ED_MIMETYPE : ErrorInfo
  • KMC_ED_MIMETYPE_MISMATCH : ErrorInfo
  • KMC_ED_NO_BUFFERED_IMAGE : ErrorInfo
  • KMC_ED_NO_MEMORY_FOR_BUFFERED_FILE : ErrorInfo
  • KMC_ED_NOIMAGE : ErrorInfo
  • KMC_ED_NONEXISTENT_FILE : ErrorInfo
  • KMC_ED_NONEXISTENT_LOAD_SETTINGS_FILE : ErrorInfo
  • KMC_ED_NONEXISTENT_OCR_REGION_TYPE : ErrorInfo
  • KMC_ED_OBJECT_REP_BITMAP_MISMATCH : ErrorInfo
  • KMC_ED_OBJECT_REP_FILE_MISMATCH : ErrorInfo
  • KMC_ED_OBJECT_REP_MISMATCH : ErrorInfo
  • KMC_ED_OBJECT_REP_NO_BITMAP : ErrorInfo
  • KMC_ED_UNRECOGNIZED_MIME_TYPE : ErrorInfo
  • KMC_EV_APPEND_ENCRYPTED : ErrorInfo
  • KMC_EV_APPEND_TO_FILE : ErrorInfo
  • KMC_EV_BAD_CHANNEL : ErrorInfo
  • KMC_EV_BAD_DPI : ErrorInfo
  • KMC_EV_BAD_FILE_FORMAT : ErrorInfo
  • KMC_EV_BAD_LINEWIDTH : ErrorInfo
  • KMC_EV_BAD_WIDTH_HEIGHT : ErrorInfo
  • KMC_EV_BARCODE_DRIVER : ErrorInfo
  • KMC_EV_CANCEL_OPERATION_SUCCESS : ErrorInfo
  • KMC_EV_CANNOT_APPEND : ErrorInfo
  • KMC_EV_EXTERNAL_PAGE : ErrorInfo
  • KMC_EV_FILE_IO_ACCESS_BUSY : ErrorInfo
  • KMC_EV_FILE_METADATA : ErrorInfo
  • KMC_EV_FILE_READ_FAILED : ErrorInfo
  • KMC_EV_FILEOPEN : ErrorInfo
  • KMC_EV_HISTOGRAM : ErrorInfo
  • KMC_EV_IMAGE_PARM : ErrorInfo
  • KMC_EV_IMAGE_PROCESSING : ErrorInfo
  • KMC_EV_IMAGE_WRITE_FAILED : ErrorInfo
  • KMC_EV_INVALID_HANDLE : ErrorInfo
  • KMC_EV_INVALID_POINTER : ErrorInfo
  • KMC_EV_LICENSE_ALREADY_SET : ErrorInfo
  • KMC_EV_LICENSE_EXPIRED : ErrorInfo
  • KMC_EV_LICENSING : ErrorInfo
  • KMC_EV_LOCK_CREATION_ERROR : ErrorInfo
  • KMC_EV_MEMORY : ErrorInfo
  • KMC_EV_METADATA_OVERFLOW : ErrorInfo
  • KMC_EV_NETWORK_READ : ErrorInfo
  • KMC_EV_NONEXISTANT_IMAGE : ErrorInfo
  • KMC_EV_OP_STRING_ERROR : ErrorInfo
  • KMC_EV_PDF_BAD : ErrorInfo
  • KMC_EV_PDF_TOO_LARGE : ErrorInfo
  • KMC_EV_PROCESS_PAGE_BUSY : ErrorInfo
  • KMC_EV_SPEED_ACCURACY : ErrorInfo
  • KMC_EV_UNKNOWN_FILETYPE : ErrorInfo
  • KMC_EV_UNKNOWN_VARIANT : ErrorInfo
  • KMC_EV_UNSUPPORTED_BITMAP_FORMAT : ErrorInfo
  • KMC_EX_PASSPORT_MRZ_DATA_NOT_FOUND : ErrorInfo
  • KMC_GN_BAD_APPLICATION_CONTEXT : ErrorInfo
  • KMC_GN_DESERIALIZE_OBJECT_ERROR : ErrorInfo
  • KMC_GN_DESERIALIZE_VERSION_ERROR : ErrorInfo
  • KMC_GN_FILE_NOT_FOUND : ErrorInfo
  • KMC_GN_FILE_NOT_FOUND_EXCEPTION : ErrorInfo
  • KMC_GN_ILLEGAL_ARGUMENT_EXCEPTION : ErrorInfo
  • KMC_GN_ILLEGAL_THREAD_STATE_EXCEPTION : ErrorInfo
  • KMC_GN_INTERNAL_ERROR : ErrorInfo
  • KMC_GN_IO_EXCEPTION : ErrorInfo
  • KMC_GN_LOGIN_NOT_APPLICABLE : ErrorInfo
  • KMC_GN_NULL_POINTER_EXCEPTION : ErrorInfo
  • KMC_GN_OUT_OF_MEMORY : ErrorInfo
  • KMC_GN_PARAM_NEGATIVE : ErrorInfo
  • KMC_GN_SESSION_CREATE_ERROR : ErrorInfo
  • KMC_GN_SESSION_DISMISS_ERROR : ErrorInfo
  • KMC_GN_UNKNOWN_ERROR : ErrorInfo
  • KMC_GN_UNSUPPORTED_OPERATION : ErrorInfo
  • KMC_IP_FILE_AND_BUFFERED_REPRESENTATION : ErrorInfo
  • KMC_IP_LICENSE_ALREADY_SET : ErrorInfo
  • KMC_IP_LICENSE_EXPIRED : ErrorInfo
  • KMC_IP_LICENSE_INVALID : ErrorInfo
  • KMC_IP_NO_CONFIGURATION : ErrorInfo
  • KMC_IP_NO_PROFILE : ErrorInfo
  • KMC_IP_NO_REPRESENTATION : ErrorInfo
  • KMC_LO_DEVICE_REG_LICENSING_ERROR : ErrorInfo
  • KMC_LO_DOMAIN : ErrorInfo
  • KMC_LO_DOWNLOAD_DOCUMENT_FIELDS_ERROR : ErrorInfo
  • KMC_LO_DOWNLOAD_DOCUMENT_SCAN_SETTINGS_ERROR : ErrorInfo
  • KMC_LO_EMAIL : ErrorInfo
  • KMC_LO_EVENT_LOCK_ACQUIRE_ERROR : ErrorInfo
  • KMC_LO_IMAGE_NOT_FOUND : ErrorInfo
  • KMC_LO_INVALID_CERTIFICATE : ErrorInfo
  • KMC_LO_INVALID_DOCUMENT_TYPE_NAME : ErrorInfo
  • KMC_LO_INVALID_SERVER_URL : ErrorInfo
  • KMC_LO_INVALID_SESSION_STATE : ErrorInfo
  • KMC_LO_INVALID_SESSION_STATE_TRANSITION : ErrorInfo
  • KMC_LO_LOGIN_NOT_ALLOWED : ErrorInfo
  • KMC_LO_NO_OPERATION_TO_CANCEL : ErrorInfo
  • KMC_LO_NOT_LOGGED_IN : ErrorInfo
  • KMC_LO_NOT_REGISTERED : ErrorInfo
  • KMC_LO_OPERATION_CANCEL_ERROR : ErrorInfo
  • KMC_LO_OPERATION_CANCELLED : ErrorInfo
  • KMC_LO_OPERATION_NOT_CANCELLABLE : ErrorInfo
  • KMC_LO_OVERLAPPED_OPERATIONS : ErrorInfo
  • KMC_LO_PAGE_IMAGE_INDEX_INVALID : ErrorInfo
  • KMC_LO_PAGE_NOT_FOUND : ErrorInfo
  • KMC_LO_REGISTER_REQUIRES_AUTH : ErrorInfo
  • KMC_LO_REGISTERING : ErrorInfo
  • KMC_LO_REGISTERING_NOT_ALLOWED : ErrorInfo
  • KMC_LO_REQUEST_TIMEOUT : ErrorInfo
  • KMC_LO_SERVER_TIMEOUT : ErrorInfo
  • KMC_LO_SERVER_URL_NOT_SET : ErrorInfo
  • KMC_LO_SESSION_STATE_BUSY : ErrorInfo
  • KMC_LO_START_SUBMIT_INVALID_JOB_ID : ErrorInfo
  • KMC_LO_START_SUBMIT_JOB_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_BITMAP : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_FILE_CLOSE_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_FILEIO_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_IMAGE_FILE_MISSING : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_IMAGE_REP_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_IMAGES_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_MIMETYPE_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_NO_IMAGE_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_PNG : ErrorInfo
  • KMC_LO_TASK_LOCK_ACQUIRE_ERROR : ErrorInfo
  • KMC_LO_USER_ALREADY_LOGGED_IN : ErrorInfo
  • KMC_LO_USER_ALREADY_LOGGED_OUT : ErrorInfo
  • KMC_LO_USER_LOGGING_IN_ON_LOGIN : ErrorInfo
  • KMC_LO_USER_LOGGING_OUT_ON_LOGOUT : ErrorInfo
  • KMC_LO_USER_LOGIN_ERROR : ErrorInfo
  • KMC_LO_USER_LOGOUT_ERROR : ErrorInfo
  • KMC_LO_USER_NOT_LOGGED_IN_ON_LOGOUT : ErrorInfo
  • KMC_LO_USERNAME_NOT_SET : ErrorInfo
  • KMC_OCR_ID_REGION_NOT_SET : ErrorInfo
  • KMC_OCR_INVALID_BITMAP_SIZE : ErrorInfo
  • KMC_SUCCESS : ErrorInfo
  • KMC_UI_CAMERA_ALREADY_OPEN : ErrorInfo
  • KMC_UI_CAMERA_LOCK_ACQUIRE_FAILURE : ErrorInfo
  • KMC_UI_CAMERA_OPERATION_FAILURE : ErrorInfo
  • KMC_UI_CREDITCARD_ARCH_NOT_SUPPORTED : ErrorInfo
  • KMC_UI_FLASH_AUTO_NOT_SUPPORTED : ErrorInfo
  • KMC_UI_FLASH_OFF_NOT_SUPPORTED : ErrorInfo
  • KMC_UI_FLASH_ON_NOT_SUPPORTED : ErrorInfo
  • KMC_UI_FLASH_TORCH_NOT_SUPPORTED : ErrorInfo
  • KMC_UI_FOCUS_AREA_COUNT : ErrorInfo
  • KMC_UI_FOCUS_AREA_EMPTY : ErrorInfo
  • KMC_UI_FOCUS_AREA_INVALID : ErrorInfo
  • KMC_UI_FOCUS_AREA_NOT_SUPPORTED : ErrorInfo
  • KMC_UI_IMAGE_NULL : ErrorInfo
  • KMC_UI_INVALID_ASPECT_RATIO_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_AXIS_THRESHOLD_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_BORDER_THICKNESS_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_DECLINATION_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_HEIGHT_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_PADDING_PERCENTAGE_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_PAGE_THRESHOLD_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_STABILITY_DELAY_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_THRESHOLD_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_WIDTH_ARGUMENT : ErrorInfo
  • KMC_UI_ODE_NOT_SUPPORTED_FOR_THE_DOCUMENT_TYPE : ErrorInfo
  • KMC_UI_SCALING_FACTOR : ErrorInfo
  • KMC_UI_VIEW_NULL : ErrorInfo
  • KMC_UT_GOOGLE_PLAY_SERVICES_REPAIRABLE : ErrorInfo
  • KMC_UT_LICENSE_BARCODE_CAPTURE : ErrorInfo
  • KMC_UT_LICENSE_ID_EXTRACTION : ErrorInfo
  • KMC_UT_LICENSE_IMAGE_CAPTURE : ErrorInfo
  • KMC_UT_LICENSE_IMAGE_PROCESSING : ErrorInfo
  • KMC_UT_LICENSE_LOGISTICS : ErrorInfo
  • KMC_UT_LICENSING_FEATURE_NOT_LICENSED : ErrorInfo
  • KMC_UT_LICENSING_INVALID_SERVER_RESPONSE : ErrorInfo
  • KMC_UT_LICENSING_NETWORK_EXCEPTION : ErrorInfo
  • KMC_UT_LICENSING_NOT_VOLUME_LICENSE : ErrorInfo
  • KMC_UT_LICENSING_NULL_LICENSE_SERVER : ErrorInfo
  • KMC_UT_LICENSING_NULL_LICENSE_SERVER_TYPE : ErrorInfo
  • KMC_UT_LICENSING_NULL_LICENSE_TYPE : ErrorInfo
  • KMC_UT_OUT_OF_VOLUME_LICENSE : ErrorInfo
  • KMC_UT_STATS_ALREADY_EXPORTING : ErrorInfo
  • KMC_UT_STATS_ALREADY_RECORDING : ErrorInfo
  • KMC_UT_STATS_ALREADY_WRITING : ErrorInfo
  • KMC_UT_STATS_BEGIN_SESSION_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_DATASTORE_NO_UPGRADE_PATH : ErrorInfo
  • KMC_UT_STATS_DATASTORE_OUT_OF_DATE : ErrorInfo
  • KMC_UT_STATS_DATASTORE_UPGRADE_FAILED : ErrorInfo
  • KMC_UT_STATS_DATASTORE_UPGRADE_MISSING_FILE : ErrorInfo
  • KMC_UT_STATS_DATASTORE_UPGRADE_NOT_NEEDED : ErrorInfo
  • KMC_UT_STATS_DATASTORE_UPGRADE_WRONG_STATE : ErrorInfo
  • KMC_UT_STATS_DEVICE_ID_MISSING : ErrorInfo
  • KMC_UT_STATS_END_SESSION_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_EVENT_THROTTLED : ErrorInfo
  • KMC_UT_STATS_EXPORT_HANDLER_MISSING : ErrorInfo
  • KMC_UT_STATS_EXPORT_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_FILEPATH_IS_NULL : ErrorInfo
  • KMC_UT_STATS_INIT_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_INVALID_JSON : ErrorInfo
  • KMC_UT_STATS_INVALID_STATE_TRANSITION : ErrorInfo
  • KMC_UT_STATS_LOG_SESSION_EVENT_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_NO_SESSION_BEGUN : ErrorInfo
  • KMC_UT_STATS_NOTHING_TO_EXPORT : ErrorInfo
  • KMC_UT_STATS_NOTHING_TO_PURGE : ErrorInfo
  • KMC_UT_STATS_PURGE_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_RECORD_AND_WRITING_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_RECORD_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_RECORDING_NOT_OFF : ErrorInfo
  • KMC_UT_STATS_RECORDING_NOT_ON : ErrorInfo
  • KMC_UT_STATS_SESSION_ALREADY_BEGUN : ErrorInfo
  • KMC_UT_STATS_STATE_BUSY : ErrorInfo
  • KMC_UT_STATS_UNINITIALIZED : ErrorInfo
  • KMC_UT_STATS_WRITING_NOT_ALLOWED : ErrorInfo
  • KmcException() : KmcException
  • KmcRuntimeException() : KmcRuntimeException
  • KTA : ExtractionParameters.ExtractionType , ServerBuilder.ServerType
  • KtaBillExtractor() : KtaBillExtractor
  • KtaCheckExtractor() : KtaCheckExtractor
  • KtaIdExtractor() : KtaIdExtractor
  • KtaJsonBill() : KtaJsonBill
  • KtaJsonCheck() : KtaJsonCheck
  • KtaJsonPassport() : KtaJsonPassport
  • KtaPassportExtractor() : KtaPassportExtractor


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- l -

  • LANDSCAPE : CaptureMessage.KUIMessageOrientation , GuidingLine
  • LATIN_AMERICA : IdRegion
  • LATIN_AMERICA_OTHER : IdParameters.IdState
  • LEFT : BoundingTetragon.Rotation
  • LEFT_RIGHT : BarCodeReader.Direction , BarCodeDirection
  • LevelnessEvent() : LevelnessEvent
  • LicenseCaptureView() : LicenseCaptureView
  • licenseFound() : LicenseFoundListener
  • LicenseFoundEvent() : LicenseFoundEvent
  • licenseOperationFailed() : Licensing.VolumeLicenseEventListener
  • licenseOperationSucceeded() : Licensing.VolumeLicenseEventListener
  • licenseType : Licensing.VolumeLicenseFailureData , Licensing.VolumeLicenseResultData
  • LINE_STYLE_DOTTED : ImgReviewEditCntrl.Line_Style_Solid
  • LINE_STYLE_SOLID : ImgReviewEditCntrl.Line_Style_Solid
  • list() : IBundle , ZipFileBundle , ZipInputStreamBundle
  • ListOfException() : ListOfException
  • LITHUANIA : IdParameters.IdState
  • loadAllVariantsForProject() : ServerProjectProvider
  • loadConfigurationFile() : ImageClassifier
  • loadModel() : ImageClassifier
  • LocalProjectProvider() : LocalProjectProvider
  • login() : IServerExtractor , CaptureServer , ICaptureServer
  • loginAnonymously() : CaptureServer , ICaptureServer
  • LoginCredentials() : LoginCredentials
  • LOGISTICS : Licensing.LicenseType
  • logout() : CaptureServer , ICaptureServer
  • logSessionEvent() : AppStatistics
  • LookAndFeelParameters() : LookAndFeelParameters
  • LUXEMBOURG : IdParameters.IdState


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- m -

  • manualCaptureTimer : LookAndFeelParameters
  • MAX_JPEG_QUALITY : Image
  • MAX_SCALING_FACTOR : Image
  • MEMORY : ImageCacheType
  • message() : ExceptionResponse , ExceptionResponseImpl
  • Message : ServerProjectProvider.Error
  • message : ServerProjectProvider.Error
  • MicrLine() : MicrLine
  • MicrParser() : MicrParser
  • MIMETYPE_JPEG : Image.ImageMimeType
  • MIMETYPE_PNG : Image.ImageMimeType
  • MIMETYPE_TIFF : Image.ImageMimeType
  • MIMETYPE_UNKNOWN : Image.ImageMimeType
  • MIN_DPI_VALUE : Image
  • MIN_JPEG_QUALITY : Image
  • MIN_SCALING_FACTOR : Image
  • muteAutoTorch() : ImageCaptureView


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- n -

  • NEVER_USE : GpsUsageLimits
  • nextElement() : ZipInputStreamBundle
  • NO_IMAGE_CAPTURED : CaptureActivity
  • NONE : CheckSide , Image.FileRestriction , MicrLine.CheckType
  • NOT_SPECIFIED : CheckParameters.CheckCountry , IdParameters.IdState


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- o -

  • ODE_CACHE : BundleCacheProvider
  • OFF : ImagePerfectionProfile.UseDocumentDetectionBasedCrop , ImagePerfectionProfile.UseMRZPassportDetection , ImagePerfectionProfile.UseTargetFrameCrop , Flash , GuidingLine , ExtractionParameters.ExtractionType , LookAndFeelParameters.TorchMode , ProcessingParameters.ProcessingType
  • ON : ImagePerfectionProfile.UseDocumentDetectionBasedCrop , ImagePerfectionProfile.UseMRZPassportDetection , ImagePerfectionProfile.UseTargetFrameCrop , Flash , LookAndFeelParameters.TorchMode
  • ON_DEVICE : ExtractionParameters.ExtractionType , ProcessingParameters.ProcessingType
  • onActivityResult() : CaptureActivity , CardIoWrapperActivity , CreditCardWorkflowActivity , IdWorkflowActivity , WorkflowActivity< T extends IParameters >
  • onAttachedToWindow() : ImageCaptureView
  • onAutoFocus() : AutoFocusResultListener , CaptureExperience
  • onBackPressed() : ProcessActivity
  • onCameraInitializationFailed() : CameraInitializationFailedListener
  • onCameraInitialized() : CameraInitializationListener
  • onComplete() : ICompletionListener< T >
  • onCreate() : AppContextProvider , BillCaptureActivity , BillExtractActivity , BillWorkflowActivity , CaptureActivity , CheckCaptureActivity , CheckExtractActivity , CheckWorkflowActivity , CardIoWrapperActivity , CreditCardWorkflowActivity , ExtractActivity< T extends ExtractorResponse > , IdCaptureActivity , IdCaptureBackActivity , IdExtractActivity , IdWorkflowActivity , ImageReviewActivity , PassportCaptureActivity , PassportExtractActivity , PassportWorkflowActivity , ProcessActivity , WorkflowActivity< T extends IParameters >
  • onDestroy() : WorkflowActivity< T extends IParameters >
  • onDetachedFromWindow() : ImageCaptureView
  • OnDeviceIdExtractor() : OnDeviceIdExtractor
  • onDraw() : ImgReviewEditCntrl
  • onExitButtonClick() : CaptureActivity
  • onExportAppStatsRowEvent() : AppStatsDsExportHandler
  • onExtractionComplete() : ExtractActivity< T extends ExtractorResponse > , Extractor< T extends Serializable > , IExtractorListener< T extends ExtractorResponse > , IIdExtractionListener
  • onForceCaptureButtonClick() : CaptureActivity
  • onGalleryButtonClick() : CaptureActivity
  • onImageCaptured() : CaptureExperience , ImageCapturedListener
  • onImageClassified() : ImageClassificationCompletedListener
  • onImageProcessed() : ProcessActivity , IImageProcessorListener
  • onLayout() : ImageCaptureView
  • onLevelness() : CaptureExperience , LevelnessListener
  • onLevelnessChanged() : BarCodeCaptureView
  • onLocationEnableEvent() : BarCodeCaptureView
  • onLocationEvent() : BarCodeCaptureView
  • onPause() : CaptureActivity , ProcessActivity
  • onPreviewFrame() : BarCodeCaptureView , LicenseCaptureView , PreviewCallbackListener
  • onProgress() : IProgressListener
  • onRestoreInstanceState() : ImgReviewEditCntrl
  • onResume() : CaptureActivity , ExtractActivity< T extends ExtractorResponse > , ProcessActivity , WorkflowActivity< T extends IParameters >
  • onSaveInstanceState() : ImgReviewEditCntrl , CaptureActivity , ExtractActivity< T extends ExtractorResponse > , ProcessActivity , WorkflowActivity< T extends IParameters >
  • onSizeChanged() : ImgReviewEditCntrl
  • onStabilityDelay() : CaptureExperience , StabilityDelayListener
  • onTorchChange() : CaptureActivity
  • onTorchLuminance() : TorchLuminanceListener
  • onTouch() : ImgReviewEditCntrl
  • operations : ProcessingParameters
  • ORIENTATION_CHANGE : OrientationGuidance
  • ORIENTATION_OK : OrientationGuidance
  • origin : FieldLocation
  • OutputColor() : Image.OutputColor
  • outputColorDepth : ImageProcessorConfiguration
  • outputDPI : ImageProcessorConfiguration


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- p -

  • Page() : Page
  • pageDetected() : PageDetectionListener
  • PageDetectionEvent() : PageDetectionEvent
  • ParseMicr() : MicrParser
  • Passport : IdType
  • PASSPORT_EXCEPTION : PassportWorkflowActivity
  • PASSPORT_EXTRACT : PassportExtractActivity
  • PASSPORT_EXTRACT_KTA : PassportExtractor
  • PASSPORT_EXTRACT_ON_DEVICE : PassportExtractor
  • PASSPORT_EXTRACT_RTTI : PassportExtractor
  • PASSPORT_PARAMETERS : PassportWorkflowActivity
  • PASSPORT_RESULTS : PassportWorkflowActivity
  • PassportCaptureExperience() : PassportCaptureExperience
  • PassportCaptureExperienceCriteriaHolder() : PassportCaptureExperienceCriteriaHolder
  • PassportDetectionResult() : PassportDetectionResult
  • PassportDetectionSettings() : PassportDetectionSettings
  • PassportDetector() : PassportDetector
  • PassportExtractor() : PassportExtractor
  • PassportExtractorResponse() : PassportExtractorResponse
  • PassportParameters() : PassportParameters
  • password : ExtractionCredentials
  • Pdf417 : BarCodeReader.Symbology
  • PDF417 : BarCodeType , Symbology
  • PERSONAL_CHECK : MicrLine.CheckType
  • PointDouble() : PointDouble
  • PORTRAIT : CaptureMessage.KUIMessageOrientation , GuidingLine
  • Postnet : BarCodeReader.Symbology
  • POSTNET : BarCodeType
  • PREPROCESS_ID2_STRING : IdExtractionParameters
  • PREPROCESS_PASSPORT_STRING : IdExtractionParameters
  • PREPROCESS_STRING : IdExtractionParameters
  • PreviewFrameEvent() : PreviewFrameEvent
  • printStackTrace() : ListOfException
  • process() : IImageProcessor
  • processedImageId : CaptureData
  • processImage() : ImageProcessor
  • ProcessingParameters() : ProcessingParameters
  • processingType : ProcessingParameters
  • PROCESSOR : ImageSource
  • processProgress() : ImageProcessor.ProcessProgressListener
  • ProcessProgressEvent() : ImageProcessor.ProcessProgressEvent
  • ProjectProviderException() : ProjectProviderException
  • purge() : AppStatistics


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- q -

  • QR : BarCodeType , Symbology
  • QRCode : BarCodeReader.Symbology
  • QuickAnalysisFeedback() : QuickAnalysisFeedback
  • QuickAnalysisSettings() : QuickAnalysisSettings


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- r -

  • readBarcode() : BarCodeCaptureView
  • readBarcodes() : BarCodeReader
  • readLicense() : LicenseCaptureView
  • readVersion() : LocalProjectProvider
  • region : IdParameters.IdState
  • registerDevice() : CaptureServer , ICaptureServer
  • registerExportHandler() : AppStatistics
  • removeAllViews() : ImageCaptureView
  • removeAnalysisCompleteEventListener() : ImageProcessor
  • removeAnalysisProgressEventListener() : ImageProcessor
  • removeAppStatsExportListener() : AppStatistics
  • removeAppStatsThresholdListener() : AppStatistics
  • removeAppStatsWriteFileListener() : AppStatistics
  • removeBarCodeFoundEventListener() : BarCodeCaptureView
  • removeBarcodeReadCompleteEventListener() : BarCodeReader
  • removeCameraInitializationFailedListener() : ImageCaptureView
  • removeCameraInitializationListener() : ImageCaptureView
  • removeImage() : Page , ContextImageStorage , IImageStorage
  • removeImageClassificationCompletedEventListener() : ImageClassifier
  • removeImageOutEventListener() : ImageProcessor
  • removeLevelnessListener() : ImageCaptureView
  • removeLicenseFoundEventListener() : LicenseCaptureView
  • removeOnAutoFocusResultListener() : ImageCaptureView
  • removeOnImageCapturedListener() : CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience , ImageCaptureView
  • removePage() : Document
  • removePageDetectionListener() : DocumentBaseCaptureExperience
  • removePreviewCallbackListener() : ImageCaptureView
  • removeProcessProgressEventListener() : ImageProcessor
  • removeStabilityDelayListener() : ImageCaptureView
  • removeTorchLuminanceListener() : ImageCaptureView
  • removeVolumeLicenseEventListener() : Licensing
  • RESULT_CODE : CaptureActivity
  • resultCode : Licensing.VolumeLicenseFailureData , Licensing.VolumeLicenseResultData
  • results : ExtractorResponse< T extends Serializable >
  • REVERSELANDSCAPE : CaptureMessage.KUIMessageOrientation
  • REVERSEPORTRAIT : CaptureMessage.KUIMessageOrientation
  • reverseSideCheck : CheckParameters
  • reverseSideId : IdParameters
  • reviewCapturedImage : LookAndFeelParameters
  • reviewProcessedImage : LookAndFeelParameters
  • RIGHT : BoundingTetragon.Rotation
  • RIGHT_LEFT : BarCodeReader.Direction , BarCodeDirection
  • rotate() : BoundingTetragon
  • ROTATE_180 : BasicSettingsProfile.RotateType , RotateType
  • ROTATE_270 : BasicSettingsProfile.RotateType , RotateType
  • ROTATE_90 : BasicSettingsProfile.RotateType , RotateType
  • ROTATE_AUTO : BasicSettingsProfile.RotateType , RotateType
  • ROTATE_NONE : BasicSettingsProfile.RotateType , RotateType
  • rotateType : ImageProcessorConfiguration
  • RotateType() : RotateType
  • RTTI : Licensing.LicenseServerType , ExtractionParameters.ExtractionType , ServerBuilder.ServerType
  • RttiBillExtractor() : RttiBillExtractor
  • RttiCheckExtractor() : RttiCheckExtractor
  • RttiIdExtractor() : RttiIdExtractor
  • RttiJsonBill() : RttiJsonBill
  • RttiJsonCheck() : RttiJsonCheck
  • RttiJsonPassport() : RttiJsonPassport
  • RttiPassportExtractor() : RttiPassportExtractor


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- s -

  • saveResultAndFinish() : CaptureActivity
  • scaleGestureDetector : ImgReviewEditCntrl
  • sdkMajor : LocalProjectProvider.VersionTable.VersionList
  • sdkMinor : LocalProjectProvider.VersionTable.VersionList
  • sdkVersion() : LocalProjectProvider , ServerProjectProvider
  • SearchDirection() : SearchDirection
  • SelfieBaseCaptureExperience() : SelfieBaseCaptureExperience
  • SelfieCaptureExperience() : SelfieCaptureExperience
  • SelfieCaptureExperienceCriteriaHolder() : SelfieCaptureExperienceCriteriaHolder
  • SelfieDetectionSettings() : SelfieDetectionSettings
  • sendImageService() : CaptureServer , ICaptureServer
  • SERVER_KFS : DocumentType.SourceServer
  • SERVER_KTA : DocumentType.SourceServer
  • SERVER_NONE : DocumentType.SourceServer
  • ServerExtractionParameters() : ServerExtractionParameters
  • ServerProjectProvider() : ServerProjectProvider
  • serverUrl : ExtractionParameters
  • SESSION_DOCUMENT_TYPE_READY : SessionState
  • SESSION_GETTING_DOCUMENT_FIELDS : SessionState
  • SESSION_GETTING_IP_SETTINGS : SessionState
  • SESSION_LOGGED_IN : SessionState
  • SESSION_LOGGING_IN : SessionState
  • SESSION_LOGGING_OUT : SessionState
  • SESSION_PREPARING_DOCUMENT_TYPE : SessionState
  • SESSION_REGISTERED : SessionState
  • SESSION_REGISTERING : SessionState
  • SESSION_SUBMIT_COMPLETED : SessionState
  • SESSION_SUBMITTING : SessionState
  • SESSION_UNREGISTERED : SessionState
  • sessionCreate() : ImageCaptureView
  • sessionDismiss() : ImageCaptureView
  • sessionId : ExtractionCredentials
  • SessionState() : SessionState
  • set() : BoundingRect
  • setAmount() : MicrLine
  • setAspectRatioFraction() : CheckDetectionSettings
  • setAuxiliaryOnUs() : MicrLine
  • setBackground() : CaptureMessage
  • setBackgroundColor() : CaptureMessage
  • setBasicSettingsProfile() : ImageProcessor , DocumentType
  • setBlinkMessage() : SelfieBaseCaptureExperience
  • setBlurCountPercentThreshold() : QuickAnalysisSettings
  • setBlurDetection() : QuickAnalysisSettings
  • setBlurThreshold() : QuickAnalysisSettings
  • setBottomLeft() : BoundingTetragon
  • setBottomRight() : BoundingTetragon
  • setBoundingBox() : BarCodeResult
  • setCameraType() : ImageCaptureView
  • setCaptureCriteria() : CheckCaptureExperience , DocumentCaptureExperience , FixedAspectRatioCaptureExperience , PassportCaptureExperience , SelfieCaptureExperience , CaptureActivity , IdCaptureActivity
  • setCapturedMessage() : DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • setCardNumber() : CreditCard
  • setCenterMessage() : CheckCaptureExperience , DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience , PassportCaptureExperience
  • setCenterPoint() : DetectionSettings , FixedAspectRatioDetectionSettings , SelfieDetectionSettings
  • setCertificateValidatorListener() : Licensing , Extractor< T extends Serializable > , ServerProjectProvider , CaptureServer
  • setCheckDetectionSettings() : CheckCaptureExperienceCriteriaHolder
  • setCheckParameters() : ICheckExtractionServer , KtaCheckExtractor , RttiCheckExtractor
  • setCheckSampleImage() : CheckCaptureExperience
  • setCheckType() : MicrLine
  • setClassificationAlternatives() : Document
  • setContext() : AppContextProvider
  • setCropCornerColor() : ImgReviewEditCntrl
  • setCropLineColor() : ImgReviewEditCntrl
  • setCropLineStyle() : ImgReviewEditCntrl
  • setCroppingTetragon() : BasicSettingsProfile
  • setCropTetragon() : ImgReviewEditCntrl
  • setCropType() : BasicSettingsProfile
  • setCurrentImageIndex() : Page
  • setCustomTag() : FieldType
  • setCvv() : CreditCard
  • setDataFormat() : BarCodeResult
  • setDataType() : FieldType
  • setDefault() : FieldType
  • setDetectionSettings() : DocumentCaptureExperienceCriteriaHolder , FixedAspectRatioExperienceCriteriaHolder , PassportCaptureExperienceCriteriaHolder , SelfieCaptureExperienceCriteriaHolder
  • setDeviceDeclinationPitch() : ImageCaptureView
  • setDeviceDeclinationRoll() : ImageCaptureView
  • setDeviceId() : AppStatistics
  • setDiagnosticsViewEnabled() : DocumentBaseCaptureExperience
  • setDirection() : BarCodeResult
  • setDisplayName() : DocumentType , FieldType
  • setDocHeight() : DocumentType
  • setDocumentID() : Page
  • setDocumentLevelError() : Document
  • setDocumentSampleImage() : DocumentBaseCaptureExperience
  • setDocWidth() : DocumentType
  • setDoDeskew() : BasicSettingsProfile
  • setDomain() : UserProfile
  • setEdgeDetection() : DocumentDetectionSettings
  • setEmpty() : BoundingRect
  • setEPC() : MicrLine
  • setErrCause() : ErrorInfo
  • setError() : AppStatsWriteToFileResults
  • setExceptionResponseDeserializer() : Extractor< T extends Serializable >
  • setExpirationMonth() : CreditCard
  • setExpirationYear() : CreditCard
  • setExtract() : ExtractActivity< T extends ExtractorResponse >
  • setExtractionServer() : Extractor< T extends Serializable >
  • setExtractionType() : ExtractionParameters
  • setExtractorListener() : Extractor< T extends Serializable >
  • setFaceAngleTolerance() : SelfieDetectionSettings
  • setFileSizeThreshold() : AppStatistics
  • setFlash() : ImageCaptureView
  • setFocusAreas() : ImageCaptureView
  • setFocusEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder , SelfieCaptureExperienceCriteriaHolder
  • setForceMatch() : FieldType
  • setFrameColor() : SelfieBaseCaptureExperience
  • setGlareDetectedThreshold() : QuickAnalysisSettings
  • setGlareDetection() : QuickAnalysisSettings
  • setGlareDetectionIntensityFraction() : QuickAnalysisSettings
  • setGlareDetectionIntensityThreshold() : QuickAnalysisSettings
  • setGlareDetectionMinimumGlareAreaFraction() : QuickAnalysisSettings
  • setGlareDetectionNumberOfTiles() : QuickAnalysisSettings
  • setGpsUsage() : ImageCaptureView
  • setGuidanceFrameColor() : DocumentBaseCaptureExperience
  • setGuidingLine() : BarCodeCaptureView
  • setHeight() : CaptureMessage
  • setHidden() : FieldType
  • setHighlightColor() : ImgReviewEditCntrl
  • setHoldParallelMessage() : DocumentBaseCaptureExperience
  • setHoldSteadyDelay() : DocumentBaseCaptureExperienceCriteriaHolder
  • setHoldSteadyMessage() : DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • setIdParameters() : IIdExtractionServer , KtaIdExtractor , RttiIdExtractor
  • setImage() : ImgReviewEditCntrl , ContextImageStorage , IImageStorage
  • setImageBarCodes() : Image
  • setImageBitmap() : Image
  • setImageCacheType() : ImgReviewEditCntrl
  • setImageClassifyResults() : Image
  • setImageCreateDateTime() : Image
  • setImageDPI() : Image
  • setImageFilePath() : Image
  • setImageJpegQuality() : Image
  • setImageMimeType() : Image
  • setImageOutListener() : IImageProcessor
  • setImageOutputColor() : Image
  • setImagePerfectionProfile() : ImageProcessor , DocumentType
  • setImageResolution() : ImageCaptureView
  • setImageStorage() : ApplicationContextImageStore
  • setImageTag() : Image
  • setInputDocLongEdge() : BasicSettingsProfile
  • setInputDocShortEdge() : BasicSettingsProfile
  • setIpOperations() : ImagePerfectionProfile
  • setIpOperationsFilePath() : ImagePerfectionProfile
  • setJson() : KtaJsonBill , RttiJsonBill , KtaJsonCheck , RttiJsonCheck , ConventionBasedJsonIdDeserializer , KtaJsonPassport , RttiJsonPassport
  • setLabel() : FieldType
  • setListenerCallbackThreadType() : ImageProcessor , AppStatistics
  • setLongEdgeThreshold() : DocumentDetectionSettings
  • setLowContrastBackgroundDetection() : QuickAnalysisSettings
  • setLuminanceThreshold() : ImageCaptureView
  • setMax() : FieldType
  • setMaxBarcodes() : BarCodeReader
  • setMaxFillFraction() : DetectionSettings
  • setMaxNumberOfResults() : ImageClassifier
  • setMaxSkewAngle() : DetectionSettings
  • setMessage() : CaptureMessage
  • setMessageIcons() : CaptureMessage
  • setMicrData() : Image
  • setMin() : FieldType
  • setMinFillFraction() : DetectionSettings
  • setMinimumFaceSize() : SelfieDetectionSettings
  • setMissingBordersDetection() : QuickAnalysisSettings
  • setMobileSDKLicense() : Licensing
  • setMobileSDKLicenseServer() : Licensing
  • setName() : ImagePerfectionProfile , FieldType , CreditCard
  • setOnUs() : MicrLine
  • setOnUs1() : MicrLine
  • setOnUs2() : MicrLine
  • setOptions() : FieldType
  • setOrientation() : CaptureMessage
  • setOrientationEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder , FixedAspectRatioExperienceCriteriaHolder
  • setOuterViewFinderColor() : DocumentBaseCaptureExperience , SelfieBaseCaptureExperience , LicenseCaptureView
  • setOutputBitDepth() : BasicSettingsProfile
  • setOutputDPI() : BasicSettingsProfile
  • setPageDetectionEnabled() : DocumentBaseCaptureExperienceCriteriaHolder
  • setParameters() : BillExtractor , CheckExtractor , Extractor< T extends Serializable > , IdExtractor , PassportExtractor , IImageProcessor
  • setPassportSampleImage() : PassportCaptureExperience
  • setPassword() : UserProfile
  • setPitchThreshold() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • setPitchThresholdEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • setPosX() : CaptureMessage
  • setPosY() : CaptureMessage
  • setProcessedImageFilePath() : ImageProcessor
  • setProcessedImageJpegQuality() : ImageProcessor
  • setProcessedImageMimeType() : ImageProcessor
  • setProcessedImageRepresentation() : ImageProcessor
  • setProjectProvider() : ExtractionParameters
  • setRamSizeThreshold() : AppStatistics
  • setReadOnly() : FieldType
  • setRectBottom() : BoundingRect
  • setRectLeft() : BoundingRect
  • setRectRight() : BoundingRect
  • setRectTop() : BoundingRect
  • setRefocusEnabled() : CaptureExperienceCriteriaHolder
  • setRequestTimeout() : ServerProjectProvider
  • setRequired() : FieldType
  • setResponse() : AppStatsSessionEvent
  • setResultDeserializer() : Extractor< T extends Serializable >
  • setRetainImage() : ImgReviewEditCntrl
  • setRollThreshold() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • setRollThresholdEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • setRotateMessage() : DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience
  • setRotateType() : BasicSettingsProfile
  • setSaturationDetection() : QuickAnalysisSettings
  • setSearchDirection() : BarCodeCaptureView
  • setSearchDirections() : BarCodeReader
  • setSearchSymbology() : BarCodeReader
  • setServerTimeout() : CaptureServer
  • setShadowDetection() : QuickAnalysisSettings
  • setSheetID() : Page
  • setShortEdgeThreshold() : DocumentDetectionSettings
  • setSide() : CheckDetectionSettings , Page
  • setSkewDetection() : QuickAnalysisSettings
  • setSourceServer() : DocumentType
  • setStabilityThreshold() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • setStabilityThresholdEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • setState() : AppStatsWriteToFileResults
  • setSteadyGuidanceFrameColor() : DocumentBaseCaptureExperience
  • setSymbologies() : BarCodeCaptureView
  • setTag() : Field
  • setTargetFrame() : Image
  • setTargetFrameAspectRatio() : CheckDetectionSettings , DetectionSettings , FixedAspectRatioDetectionSettings , PassportDetectionSettings , SelfieDetectionSettings
  • setTargetFramePaddingPercent() : DetectionSettings , FixedAspectRatioDetectionSettings , SelfieDetectionSettings
  • setTextColor() : CaptureMessage
  • setTextSize() : CaptureMessage
  • setToleranceFraction() : DetectionSettings
  • setTopLeft() : BoundingTetragon
  • setTopRight() : BoundingTetragon
  • setTorchDelay() : ImageCaptureView
  • setTransitNumber() : MicrLine
  • setTutorialDismissMessage() : DocumentBaseCaptureExperience
  • setType() : BarCodeResult , AppStatsSessionEvent
  • setTypeface() : CaptureMessage
  • setTypeName() : DocumentType
  • setupButtonBarView() : CaptureActivity , IdCaptureBackActivity
  • setupCameraView() : CaptureActivity , IdCaptureBackActivity
  • setUseDocumentDetectionBasedCrop() : ImagePerfectionProfile , QuickAnalysisSettings
  • setUseMRZPassportDetection() : ImagePerfectionProfile , QuickAnalysisSettings
  • setUserEmailAddress() : UserProfile
  • setUserInstructionMessage() : CheckCaptureExperience , DocumentBaseCaptureExperience , PassportCaptureExperience , SelfieBaseCaptureExperience , LicenseCaptureView
  • setUsername() : UserProfile
  • setUseTargetFrameCrop() : ImagePerfectionProfile , QuickAnalysisSettings
  • setUseVideoFrame() : ImageCaptureView
  • setValue() : BarCodeResult
  • setVersion() : DocumentType
  • setVibrationEnabled() : CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • setViewfinderPaddingPercent() : LicenseCaptureView
  • setVisibility() : CaptureMessage
  • setWidth() : CaptureMessage
  • setZoomInMessage() : DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience
  • setZoomOutMessage() : DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience
  • showCropRectangle() : ImgReviewEditCntrl
  • showHighlights() : ImgReviewEditCntrl
  • side : CheckParameters , IdParameters
  • SINGAPORE : CheckParameters.CheckCountry , IdParameters.IdState
  • Size() : Size
  • size : FieldLocation
  • SizeDouble() : SizeDouble
  • SOUTH_KOREA : IdParameters.IdState
  • ST_CHRIST_NEVIS : IdParameters.IdState
  • StabilityDelayEvent() : StabilityDelayEvent
  • stackTrace() : ExceptionResponse , ExceptionResponseImpl
  • startJobService() : CaptureServer , ICaptureServer
  • startRecord() : AppStatistics
  • state : IdParameters
  • stateID : SessionState
  • stopCapture() : CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • stopRecord() : AppStatistics
  • STRING : FieldType.DataType
  • submitDocument() : CaptureServer , ICaptureServer
  • surfaceChanged() : ImageCaptureView
  • surfaceCreated() : ImageCaptureView
  • surfaceDestroyed() : ImageCaptureView
  • Symbology() : BarCodeReader.Symbology


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- t -

  • takePicture() : CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • takePictureContinually() : CaptureExperience , DocumentBaseCaptureExperience
  • TARGET_FRAME_CROP_OFF : TargetFrameCropType
  • TARGET_FRAME_CROP_ON : TargetFrameCropType
  • targetFrameCropType : ImageProcessorConfiguration
  • THRESH_TYPE_FILE : AppStatistics.ThresholdType
  • THRESH_TYPE_RAM : AppStatistics.ThresholdType
  • thresholdReached() : AppstatsThresholdReachedListener
  • TimeOutParameters() : TimeOutParameters
  • TOP_DOWN : BarCodeReader.Direction , BarCodeDirection
  • TORCH : Flash
  • torch : LookAndFeelParameters
  • TorchLuminanceEvent() : TorchLuminanceEvent
  • toString() : BoundingRect , DetectionResult , Size , Field< T extends Serializable > , FieldLocation , PointDouble , SizeDouble
  • TotalAgility : Licensing.LicenseServerType
  • tryRestoreState() : WorkflowActivity< T extends IParameters >
  • TURN_CLOCKWISE : TurnGuidance
  • TURN_COUNTER_CLOCKWISE : TurnGuidance
  • TURN_OK : TurnGuidance
  • type : RotateType


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- u -

  • UI_THREAD : ListenerCallbackThreadType
  • UNDEFINED : FieldLocation
  • UNITED_KINGDOM : CheckParameters.CheckCountry
  • UNITED_STATES : CheckParameters.CheckCountry , IdParameters.IdState
  • UNKNOWN : BarCodeDataFormat , BarCodeDirection , BarCodeType , CaptureMessage.KUIMessageOrientation
  • unmuteAutoTorch() : ImageCaptureView
  • Upc : BarCodeReader.Symbology
  • UPC : BarCodeType , Symbology
  • updateFieldProperties() : Field
  • updateKTARequest() : KtaCheckExtractor , KtaIdExtractor , KtaPassportExtractor
  • updateRttiRequest() : RttiCheckExtractor , RttiIdExtractor , RttiPassportExtractor
  • URL : FieldType.DataType
  • US : IdRegion
  • useMrzPageDetection : ProcessingParameters
  • username : ExtractionCredentials
  • useTargetFrameCrop : ProcessingParameters


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- v -

  • versionCompatible() : SdkVersion
  • VersionList : LocalProjectProvider.VersionTable
  • VERTICAL : SearchDirection
  • VERTICAL_MOVE_DOWN : VerticalGuidance
  • VERTICAL_MOVE_OK : VerticalGuidance
  • VERTICAL_MOVE_UP : VerticalGuidance


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- w -

  • width() : BoundingRect , Size , SizeDouble
  • WORKER_THREAD : ListenerCallbackThreadType
  • WRITE_STATUS_COMPLETE : AppStatsWriteFileListener.WriteFileStatus
  • WRITE_STATUS_FAILED : AppStatsWriteFileListener.WriteFileStatus
  • WRITE_STATUS_WRITING : AppStatsWriteFileListener.WriteFileStatus
  • writeFileStatusEvent() : AppStatsWriteFileListener
  • writeToFile() : AppStatistics
  • writeToParcel() : CreditCard


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- x -

  • x : PointDouble


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- y -

  • y : PointDouble


Kofax Mobile SDK API Reference: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZipFileBundle() : ZipFileBundle
  • ZipInputStreamBundle() : ZipInputStreamBundle
  • ZOOM_IN : ZoomGuidance
  • ZOOM_OK : ZoomGuidance
  • ZOOM_OUT : ZoomGuidance


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- a -

  • acquireVolumeLicenses() : Licensing
  • addAnalysisCompleteEventListener() : ImageProcessor
  • addAnalysisProgressEventListener() : ImageProcessor
  • addAppStatsExportListener() : AppStatistics
  • addAppStatsWriteFileListener() : AppStatistics
  • addAppThresholdListener() : AppStatistics
  • addBarCodeFoundEventListener() : BarCodeCaptureView
  • addBarcodeReadCompleteEventListener() : BarCodeReader
  • addCameraInitializationFailedListener() : ImageCaptureView
  • addCameraInitializationListener() : ImageCaptureView
  • addImage() : Page
  • addImageClassificationCompletedEventListener() : ImageClassifier
  • addImageOutEventListener() : ImageProcessor
  • addLevelnessListener() : ImageCaptureView
  • addLicenseFoundEventListener() : LicenseCaptureView
  • addOnAutoFocusResultListener() : ImageCaptureView
  • addOnImageCapturedListener() : CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience , ImageCaptureView
  • addPage() : Document
  • addPageDetectionListener() : DocumentBaseCaptureExperience
  • addPreviewCallbackListener() : ImageCaptureView
  • addProcessProgressEventListener() : ImageProcessor
  • addStabilityDelayListener() : ImageCaptureView
  • addTorchLuminanceListener() : ImageCaptureView
  • addVolumeLicenseEventListener() : Licensing
  • AggregateException() : AggregateException
  • analysisComplete() : ImageProcessor.AnalysisCompleteListener
  • AnalysisCompleteEvent() : ImageProcessor.AnalysisCompleteEvent
  • analysisProgress() : ImageProcessor.AnalysisProgressListener
  • AnalysisProgressEvent() : ImageProcessor.AnalysisProgressEvent
  • AppStatsSessionEvent() : AppStatsSessionEvent
  • AppStatsWriteToFileResults() : AppStatsWriteToFileResults
  • AutoFocusResultEvent() : AutoFocusResultEvent


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- b -

  • BarCodeCaptureView() : BarCodeCaptureView
  • barCodeFound() : BarCodeFoundListener
  • BarCodeFoundEvent() : BarCodeFoundEvent
  • barcodeReadComplete() : BarCodeReader.BarcodeReadCompleteListener
  • BarcodeReadCompleteEvent() : BarCodeReader.BarcodeReadCompleteEvent
  • BarCodeReader() : BarCodeReader
  • BarCodeResult() : BarCodeResult
  • BasicSettingsProfile() : BasicSettingsProfile
  • beginSession() : AppStatistics
  • BillExtractor() : BillExtractor
  • BillExtractorResponse() : BillExtractorResponse
  • BillParameters() : BillParameters
  • BoundingRect() : BoundingRect
  • BoundingTetragon() : BoundingTetragon
  • build() : ServerBuilder
  • BundleCacheProvider() : BundleCacheProvider


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- c -

  • cacheProject() : BundleCacheProvider , IBundleCacheProvider
  • cacheVariant() : BundleCacheProvider , IBundleCacheProvider
  • calculateBound() : BarCodeCaptureView
  • CameraInitializationEvent() : CameraInitializationEvent
  • CameraInitializationFailedEvent() : CameraInitializationFailedEvent
  • cancel() : ImageProcessor , IImageProcessor , IIdExtractor , OnDeviceIdExtractor
  • cancelExtraction() : IServerExtractor
  • cancelLoadAllVariants() : ServerProjectProvider
  • cancelSubmission() : CaptureServer , ICaptureServer
  • captureCriteriaMetInternal() : CaptureExperience
  • CaptureExperienceCriteriaHolder() : CaptureExperienceCriteriaHolder
  • captureImage() : CreditCardWorkflowActivity , WorkflowActivity< T extends IParameters >
  • CaptureMessage() : CaptureMessage
  • CaptureServer() : CaptureServer
  • CheckCaptureExperience() : CheckCaptureExperience
  • CheckCaptureExperienceCriteriaHolder() : CheckCaptureExperienceCriteriaHolder
  • CheckDetectionSettings() : CheckDetectionSettings
  • CheckDetector() : CheckDetector
  • CheckExtractor() : CheckExtractor
  • CheckExtractorResponse() : CheckExtractorResponse
  • checkLicense() : BarCodeCaptureView , ImageCaptureView , LicenseCaptureView
  • CheckParameters() : CheckParameters
  • classification() : IIdExtractionResult
  • classificationConfidence() : IIdExtractionResult
  • ClassificationResult() : ClassificationResult
  • classifyImage() : ImageClassifier
  • clearBitmap() : WorkflowActivity< T extends IParameters >
  • clearCache() : BundleCacheProvider
  • clearHighlights() : ImgReviewEditCntrl
  • clearImage() : ImgReviewEditCntrl
  • clone() : BasicSettingsProfile , BoundingTetragon , ImagePerfectionProfile , QuickAnalysisFeedback , ImageProcessorConfiguration , ClassificationResult , Document , DocumentType , Field , FieldType , UserProfile , Field< T extends Serializable >
  • close() : ZipFileBundle , ZipInputStreamBundle
  • ColorDepth() : ColorDepth
  • compare() : SdkVersion
  • configDsExpFilePath() : AppStatsDsExportHandler
  • ContextImageStorage() : ContextImageStorage
  • ConventionBasedJsonIdDeserializer() : ConventionBasedJsonIdDeserializer
  • createResponse() : BillExtractor , CheckExtractor , Extractor< T extends Serializable > , IdExtractor , PassportExtractor
  • createScaledBitmap() : Image
  • CreditCard() : CreditCard
  • CreditCardParameters() : CreditCardParameters


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- d -

  • DataField() : DataField
  • describeContents() : CreditCard
  • destroy() : CheckDetector , DocumentDetector , IDocumentDetector< T extends DetectionSettings, U extends DetectionResult > , PassportDetector , CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • detect() : CheckDetector , DocumentDetector , ICheckDetector , IDocumentDetector< T extends DetectionSettings, U extends DetectionResult > , IPassportDetector , PassportDetector
  • DetectionSettings() : DetectionSettings
  • Direction() : BarCodeReader.Direction
  • doCleanup() : ImageClassifier , ImageProcessor
  • Document() : Document
  • DocumentBaseCaptureExperience() : DocumentBaseCaptureExperience
  • DocumentBaseCaptureExperienceCriteriaHolder() : DocumentBaseCaptureExperienceCriteriaHolder
  • DocumentCaptureExperience() : DocumentCaptureExperience
  • DocumentCaptureExperienceCriteriaHolder() : DocumentCaptureExperienceCriteriaHolder
  • DocumentDetectionSettings() : DocumentDetectionSettings
  • DocumentDetector() : DocumentDetector
  • DocumentDimensions() : DocumentDimensions
  • DocumentType() : DocumentType
  • doQuickAnalysis() : ImageProcessor


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- e -

  • enableAnimationTutor() : DocumentBaseCaptureExperience
  • enableConsoleLogging() : KENLogging , KLOLogging , KUILogging , KUTLogging , Logging
  • endSession() : AppStatistics
  • equals() : DocumentDimensions , Size , Field< T extends Serializable >
  • ErrorInfo() : ErrorInfo
  • exceptionMessage() : ExceptionResponse , ExceptionResponseImpl
  • ExceptionResponseImpl() : ExceptionResponseImpl
  • exceptionType() : ExceptionResponse , ExceptionResponseImpl
  • export() : AppStatistics
  • exportStatusEvent() : AppStatsExportListener
  • extract() : CheckExtractActivity , ExtractActivity< T extends ExtractorResponse > , Extractor< T extends Serializable > , IdExtractActivity , KtaIdExtractor , RttiIdExtractor
  • extractData() : IServerExtractor
  • extractFields() : IIdExtractor , OnDeviceIdExtractor
  • ExtractionParameters() : ExtractionParameters
  • ExtractionServerException() : ExtractionServerException
  • Extractor() : Extractor< T extends Serializable >


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- f -

  • Field() : Field , Field< T extends Serializable >
  • FieldLocation() : FieldLocation
  • FieldType() : FieldType
  • finalize() : LocalProjectProvider
  • finish() : CaptureActivity
  • FixedAspectRatioCaptureExperience() : FixedAspectRatioCaptureExperience
  • FixedAspectRatioDetectionSettings() : FixedAspectRatioDetectionSettings
  • FixedAspectRatioExperienceCriteriaHolder() : FixedAspectRatioExperienceCriteriaHolder
  • forceTakePicture() : ImageCaptureView
  • fromExtractorField() : DataField


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- g -

  • gePayeeName() : CheckUsabilityData
  • getAboveMaxFrontImageSize() : CheckIQAData
  • getAboveMaxRearImageSize() : CheckIQAData
  • getAbsolutePath() : IBundleFile
  • getAccountNumber() : MicrParser , KtaJsonBill , RttiJsonBill , Bill
  • getAdditionalBottomScanLinesHeight() : CheckIQAData
  • getAdditionalLeftScanLinesWidth() : CheckIQAData
  • getAdditionalRightScanLinesWidth() : CheckIQAData
  • getAdditionalTopScanLinesHeight() : CheckIQAData
  • getAddress() : ConventionBasedJsonIdDeserializer , Id
  • getAddress2() : ConventionBasedJsonIdDeserializer , Id
  • getAddress3() : ConventionBasedJsonIdDeserializer , Id
  • getAddress4() : ConventionBasedJsonIdDeserializer , Id
  • getAddress5() : ConventionBasedJsonIdDeserializer , Id
  • getAddress6() : ConventionBasedJsonIdDeserializer , Id
  • getAddressLine1() : KtaJsonBill , RttiJsonBill , Bill
  • getAddressLine2() : KtaJsonBill , RttiJsonBill , Bill
  • getAllowableImageResolutions() : ImageCaptureView
  • getAmount() : MicrLine , KtaJsonBill , RttiJsonBill , KtaJsonCheck , RttiJsonCheck , Bill , Check
  • getAspectRatioFraction() : CheckDetectionSettings
  • getAuxiliaryOnUs() : MicrLine , KtaJsonCheck , RttiJsonCheck , Check
  • getAverageSpotNoiseGroupingsPerSquareInch() : CheckIQAData
  • getBackBarcodes() : IdExtractionParameters
  • getBackException() : AggregateException
  • getBackground() : CaptureMessage
  • getBackgroundColor() : CaptureMessage
  • getBackImage() : IdExtractionParameters
  • getBarCode() : BarCodeFoundEvent
  • getBarCodeType() : BarCodeReader.Symbology
  • getBasicSettingsProfile() : ImageProcessor , DocumentType , DocumentTypeR
  • getBasicSettingsProfileUsed() : Image
  • getBcVersion() : BarCodeReader , SdkVersion
  • getBelowMinFrontImageSize() : CheckIQAData
  • getBelowMinRearImageSize() : CheckIQAData
  • getBillers() : KtaJsonBill , RttiJsonBill , Bill
  • getBitmap() : PreviewFrameEvent
  • getBitmapLandscape() : PreviewFrameEvent
  • getBitsPerChannel() : Image.OutputColor
  • getBitsPerPixel() : Image.OutputColor
  • getBlackStreakCount() : CheckIQAData
  • getBlackStreakMaxHeight() : CheckIQAData
  • getBlinkMessage() : SelfieBaseCaptureExperience
  • getBlurCountPercentThreshold() : QuickAnalysisSettings
  • getBlurDetection() : QuickAnalysisSettings
  • getBlurThreshold() : QuickAnalysisSettings
  • getBottomEdgeTearHeight() : CheckIQAData
  • getBottomEdgeTearWidth() : CheckIQAData
  • getBottomLeft() : BoundingTetragon
  • getBottomLeftCornerHeight() : CheckIQAData
  • getBottomLeftCornerWidth() : CheckIQAData
  • getBottomRight() : BoundingTetragon
  • getBottomRightCornerHeight() : CheckIQAData
  • getBottomRightCornerWidth() : CheckIQAData
  • getBound() : PageDetectionEvent
  • getBoundingBox() : BarCodeResult
  • getBounds() : DetectionResult
  • getBundleVersion() : LocalProjectProvider
  • getCameraInitStatus() : CameraInitializationEvent
  • getCameraView() : CaptureActivity , IdCaptureBackActivity
  • getCaptureActivityClass() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getCaptureCriteria() : CheckCaptureExperience , DocumentCaptureExperience , FixedAspectRatioCaptureExperience , PassportCaptureExperience , SelfieBaseCaptureExperience
  • getCapturedMessage() : DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience , SelfieBaseCaptureExperience
  • getCar() : KtaJsonCheck , RttiJsonCheck , Check
  • getCAR() : CheckUsabilityData
  • getCarbonStrip() : CheckIQAData
  • getCarbonStripHeight() : CheckIQAData
  • getCardNumber() : CreditCard
  • getCause() : CameraInitializationFailedEvent
  • getCenterMessage() : CheckCaptureExperience , DocumentBaseCaptureExperience , PassportCaptureExperience
  • getCenterPoint() : DetectionSettings , FixedAspectRatioDetectionSettings , SelfieDetectionSettings
  • getCertificateValidationListener() : ServerExtractionParameters
  • getCertificateValidatorListener() : LoginCredentials
  • getChannels() : Image.OutputColor
  • getCheckDetectionSettings() : CheckCaptureExperienceCriteriaHolder
  • getCheckIQAData() : KtaJsonCheck , RttiJsonCheck , Check
  • getCheckNumber() : MicrParser , KtaJsonCheck , RttiJsonCheck , Check
  • getCheckSampleImage() : CheckCaptureExperience
  • getCheckSide() : CheckDetectionResult
  • getCheckType() : MicrLine
  • getCheckUsabilityData() : KtaJsonCheck , RttiJsonCheck , Check
  • getCity() : KtaJsonBill , RttiJsonBill , ConventionBasedJsonIdDeserializer , Bill , Id
  • getClassId() : ImageClassificationResult , ClassificationResult
  • getClassificationAlternatives() : Document
  • getClassifierVersion() : SdkVersion
  • getCode() : ExtractionServerException
  • getCodeline() : CheckUsabilityData
  • getCompressedFrontImageSize() : CheckIQAData
  • getCompressedRearImageSize() : CheckIQAData
  • getConfidence() : ImageClassificationResult , ClassificationResult , Field< T extends Serializable > , DataField
  • getContext() : AppContextProvider
  • getCountry() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getCountryLong() : Passport , KtaJsonPassport , RttiJsonPassport
  • getCountryShort() : ConventionBasedJsonIdDeserializer , Id
  • getCropCornerColor() : ImgReviewEditCntrl
  • getCropLineColor() : ImgReviewEditCntrl
  • getCroppingTetragon() : BasicSettingsProfile
  • getCropTetragon() : ImgReviewEditCntrl
  • getCropType() : BasicSettingsProfile
  • getCurrentImageIndex() : Page
  • getCustomTag() : FieldType
  • getCvv() : CreditCard
  • getData() : PreviewFrameEvent
  • getDataFormat() : BarCodeResult
  • getDataType() : FieldType
  • getDate() : KtaJsonCheck , RttiJsonCheck , Check , CheckUsabilityData
  • getDateOfBirth() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getDaysRemaining() : LicenseFoundEvent , Licensing
  • getDbFieldKeyType() : AppStatsDaoField
  • getDbFieldType() : AppStatsDaoField
  • getDefault() : FieldType
  • getDefaultImageCaptureResolution() : CameraInitializationEvent
  • getDefaultProcessingString() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getDefaultReturnObject() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getDefaultServerUrl() : BillExtractor , CheckExtractor , Extractor< T extends Serializable > , IdExtractor , PassportExtractor
  • getDetectionSettings() : DocumentCaptureExperienceCriteriaHolder , FixedAspectRatioExperienceCriteriaHolder , SelfieCaptureExperienceCriteriaHolder
  • getDeviceDeclinationPitch() : ImageCaptureView
  • getDeviceDeclinationRoll() : ImageCaptureView
  • getDeviceId() : AppStatistics
  • getDirection() : BarCodeResult
  • getDisplayName() : DocumentType , DocumentTypeR , FieldType
  • getDocHeight() : DocumentType , DocumentTypeR
  • getDocumentFramingError() : CheckIQAData
  • getDocumentId() : Document
  • getDocumentID() : Page
  • getDocumentLevelError() : Document
  • getDocumentSampleImage() : DocumentBaseCaptureExperience
  • getDocumentSkew() : CheckIQAData
  • getDocumentSkewAngle() : CheckIQAData
  • getDocumentState() : Id
  • getDocumentType() : Document , ConventionBasedJsonIdDeserializer , Id , CaptureServer , ICaptureServer
  • getDocumentVerificationConfidenceRating() : ConventionBasedJsonIdDeserializer , Id , IIdExtractionResult
  • getDocWidth() : DocumentType , DocumentTypeR
  • getDoDeskew() : BasicSettingsProfile
  • getDomain() : UserProfile
  • getDsFieldName() : AppStatsDaoField
  • getDsFieldType() : AppStatsDaoField
  • getDsValueDate() : AppStatsDaoField
  • getDsValueFloat() : AppStatsDaoField
  • getDsValueInt() : AppStatsDaoField
  • getDsValueLong() : AppStatsDaoField
  • getDsValueString() : AppStatsDaoField
  • getDueDate() : KtaJsonBill , RttiJsonBill , Bill
  • getEdgeDetection() : DocumentDetectionSettings
  • getEPC() : MicrLine
  • getEpc() : KtaJsonCheck , RttiJsonCheck , Check
  • getErr() : ErrorInfo
  • getErrCause() : ErrorInfo
  • getErrDesc() : ErrorInfo
  • getErrMsg() : ErrorInfo
  • getErrorDescription() : Field
  • getErrorInfo() : LicenseFoundEvent , AppStatsExportEvent , AppStatsWritetoFileEvent , KmcException , KmcRuntimeException
  • getErrorState() : SessionState
  • getExceptionKey() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getExpirationDate() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getExpirationMonth() : CreditCard
  • getExpirationYear() : CreditCard
  • getExportStatus() : AppStatsExportEvent
  • getExtractActivityClass() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getExtractionParameters() : BillParameters , CheckParameters , CreditCardParameters , IdParameters , IParameters , PassportParameters
  • getExtractionType() : ExtractionParameters
  • getEyes() : ConventionBasedJsonIdDeserializer , Id
  • getFaceAngleTolerance() : SelfieDetectionSettings
  • getFaceImage() : ConventionBasedJsonIdDeserializer , Id
  • getFields() : Document , IIdExtractionResult
  • getFieldType() : Field
  • getFieldTypes() : DocumentType , DocumentTypeR
  • getFile() : IBundleFile
  • getFileName() : AppStatistics
  • getFileSize() : AppStatistics
  • getFileSizeThreshold() : AppStatistics
  • getFirstName() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getFlash() : ImageCaptureView
  • getFocusAreas() : ImageCaptureView
  • getFoldedOrTornDocumentCorners() : CheckIQAData
  • getFoldedOrTornDocumentEdges() : CheckIQAData
  • getFrameColor() : SelfieBaseCaptureExperience
  • getFrontBarcodes() : IdExtractionParameters
  • getFrontException() : AggregateException
  • getFrontImage() : IdExtractionParameters
  • getFrontRearHeightDifference() : CheckIQAData
  • getFrontRearWidthDifference() : CheckIQAData
  • getGender() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getGlareDetectedThreshold() : QuickAnalysisSettings
  • getGlareDetection() : QuickAnalysisSettings
  • getGlareDetectionIntensityFraction() : QuickAnalysisSettings
  • getGlareDetectionIntensityThreshold() : QuickAnalysisSettings
  • getGlareDetectionMinimumGlareAreaFraction() : QuickAnalysisSettings
  • getGlareDetectionNumberOfTiles() : QuickAnalysisSettings
  • getGpsUsage() : ImageCaptureView
  • getGrayLevelStreakCount() : CheckIQAData
  • getGrayLevelStreakMaxHeight() : CheckIQAData
  • getGuidanceFrameColor() : DocumentBaseCaptureExperience
  • getGuidingLine() : BarCodeCaptureView
  • getHair() : ConventionBasedJsonIdDeserializer , Id
  • getHeight() : CaptureMessage , PreviewFrameEvent , ConventionBasedJsonIdDeserializer , Id
  • getHighestVersion() : IProjectProvider , LocalProjectProvider , ServerProjectProvider
  • getHighestVersionAsync() : ServerProjectProvider
  • getHoldParallelMessage() : DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience
  • getHoldSteadyDelay() : DocumentBaseCaptureExperienceCriteriaHolder
  • getHoldSteadyMessage() : DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience , SelfieBaseCaptureExperience
  • getHorizontalMovementGuidance() : DetectionResult
  • getHorizontalStreaks() : CheckIQAData
  • getIdClass() : ConventionBasedJsonIdDeserializer , Id
  • getIdentifier() : ImageCacheType
  • getIdNumber() : ConventionBasedJsonIdDeserializer , Id
  • getIdType() : IdExtractionParameters
  • getImage() : BarCodeReader.BarcodeReadCompleteEvent , ImageClassificationCompleteEvent , ImageProcessor.AnalysisCompleteEvent , ImageProcessor.ImageOutEvent , BarCodeFoundEvent , ImageCapturedEvent , ImgReviewEditCntrl , ContextImageStorage , IImageStorage
  • getImageBarCodes() : Image
  • getImageBitmap() : Image
  • getImageBitmapHeight() : Image
  • getImageBitmapScaling() : Image
  • getImageBitmapWidth() : Image
  • getImageByBitmapId() : ExtractActivity< T extends ExtractorResponse > , IdExtractActivity
  • getImageBytes() : ServerExtractionParameters
  • getImageClassifyResults() : Image
  • getImageCreateDateTime() : Image
  • getImageDimensionMismatch() : CheckIQAData
  • getImageDPI() : Image
  • getImageFileBuffer() : Image
  • getImageFileHeight() : Image
  • getImageFilePath() : Image
  • getImageFileRep() : Image
  • getImageFileWidth() : Image
  • getImageFocusScore() : CheckIQAData
  • getImageHeight() : CheckIQAData
  • getImageID() : Image , ImageProcessor.AnalysisProgressEvent , ImageProcessor.ProcessProgressEvent
  • getImageJpegQuality() : Image
  • getImageLatitude() : Image
  • getImageLongitude() : Image
  • getImageMetaData() : Image
  • getImageMimeType() : Image
  • getImageOutputColor() : Image
  • getImagePerfectionProfile() : ImageProcessor , DocumentType , DocumentTypeR
  • getImagePerfectProfileUsed() : Image
  • getImagePitch() : Image
  • getImagePreviewHeight() : ImageCaptureView
  • getImagePreviewWidth() : ImageCaptureView
  • getImageQuickAnalysisFeedBack() : Image
  • getImageRepresentation() : Image
  • getImageRoll() : Image
  • getImages() : Page , ServerExtractionParameters
  • getImageSize() : Image
  • getImageSrcID() : Image
  • getImageStorage() : ApplicationContextImageStore
  • getImageTag() : Image
  • getImageTooDark() : CheckIQAData
  • getImageTooLight() : CheckIQAData
  • getImageWidth() : CheckIQAData
  • getInnerThrowables() : ListOfException
  • getInputDocLongEdge() : BasicSettingsProfile
  • getInputDocShortEdge() : BasicSettingsProfile
  • getInstance() : AppStatistics
  • getIpOperations() : ImagePerfectionProfile
  • getIpOperationsFilePath() : ImagePerfectionProfile
  • getIpVersion() : SdkVersion
  • getIssueDate() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getKtaPassword() : LoginCredentials
  • getKtaUserName() : LoginCredentials
  • getLabel() : FieldType
  • getLar() : KtaJsonCheck , RttiJsonCheck , Check
  • getLAR() : CheckUsabilityData
  • getLastName() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getLatestCachedModelDataBuildInfo() : IProjectProvider , LocalProjectProvider , ServerProjectProvider
  • getLatestModelDataBuildInfo() : BundleCacheProvider , IBundleCacheProvider
  • getLatestVersionForProject() : BundleCacheProvider , IBundleCacheProvider
  • getLeftEdgeTearHeight() : CheckIQAData
  • getLeftEdgeTearWidth() : CheckIQAData
  • getLicense() : ConventionBasedJsonIdDeserializer , Id
  • getLicenseString() : LicenseFoundEvent
  • getListener() : IdExtractionParameters
  • getListenerCallbackThreadType() : ImageProcessor , AppStatistics
  • getLocation() : Field< T extends Serializable >
  • getLongEdge() : DocumentDimensions
  • getLongEdgeThreshold() : DocumentDetectionSettings
  • getLookAndFeelParameters() : BillParameters , CheckParameters , CreditCardParameters , IdParameters , IParameters , PassportParameters
  • getLowContrastBackgroundDetection() : QuickAnalysisSettings
  • getLuminance() : TorchLuminanceEvent
  • getLuminanceThreshold() : ImageCaptureView
  • getMax() : FieldType
  • getMaxBarcodes() : BarCodeReader
  • getMaxFillFraction() : DetectionSettings
  • getMaxFocusAreas() : ImageCaptureView
  • getMaxNumberOfResults() : ImageClassifier
  • getMaxSkewAngle() : DetectionSettings
  • getMessage() : CaptureMessage , ExtractionServerException
  • getMessageIcons() : CaptureMessage
  • getMicr() : KtaJsonCheck , RttiJsonCheck , Check
  • getMicrAmount() : KtaJsonCheck , RttiJsonCheck , Check
  • getMicrData() : Image
  • getMicrLine() : MicrParser
  • getMiddleName() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getMin() : FieldType
  • getMinFillFraction() : DetectionSettings
  • getMinimumFaceSize() : SelfieDetectionSettings
  • getMissingBordersDetection() : QuickAnalysisSettings
  • getMRZ1() : Passport , KtaJsonPassport , RttiJsonPassport
  • getMRZ2() : Passport , KtaJsonPassport , RttiJsonPassport
  • getName() : ImagePerfectionProfile , FieldType , KtaJsonBill , RttiJsonBill , Bill , CreditCard , Field< T extends Serializable > , IBundleFile
  • getNameSuffix() : ConventionBasedJsonIdDeserializer , Id
  • getNationality() : ConventionBasedJsonIdDeserializer , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getNextState() : SessionState
  • getObject() : Field< T extends Serializable > , DataField
  • getOnUs() : MicrLine
  • getOnUs1() : MicrLine , KtaJsonCheck , RttiJsonCheck , Check
  • getOnUs2() : MicrLine , KtaJsonCheck , RttiJsonCheck , Check
  • getOptions() : FieldType
  • getOrientation() : ImageClassificationResult , CaptureMessage
  • getOrientationGuidance() : DetectionResult
  • getOriginalImage() : DetectionResult
  • getOuterViewFinderColor() : DocumentBaseCaptureExperience , SelfieBaseCaptureExperience , LicenseCaptureView
  • getOutOfFocus() : CheckIQAData
  • getOutputBitDepth() : BasicSettingsProfile
  • getOutputDPI() : BasicSettingsProfile
  • getOversizeImage() : CheckIQAData
  • getPackageVersion() : KenVersion , KloVersion , KuiVersion , SdkVersion , KutVersion
  • getPaddingPercent() : SelfieBaseCaptureExperience
  • getPageID() : Page
  • getPages() : Document
  • getParameters() : WorkflowActivity< T extends IParameters > , ServerExtractionParameters
  • getParametersInstance() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getParametersKey() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getPassportDetectionSettings() : PassportCaptureExperienceCriteriaHolder
  • getPassportNumber() : Passport , KtaJsonPassport , RttiJsonPassport
  • getPassportSampleImage() : PassportCaptureExperience
  • getPassword() : UserProfile
  • getPayee() : KtaJsonCheck , RttiJsonCheck , Check
  • getPayeeEndorsement() : CheckUsabilityData
  • getPercentAverageImageBrightness() : CheckIQAData
  • getPercentAverageImageContrast() : CheckIQAData
  • getPercentBlackPixels() : CheckIQAData
  • getPercentComplete() : AppStatsExportEvent , AppStatsWritetoFileEvent
  • getPersonalNumber() : Passport , KtaJsonPassport , RttiJsonPassport
  • getPhoneNumber() : KtaJsonBill , RttiJsonBill , Bill
  • getPiggybackDocument() : CheckIQAData
  • getPitch() : LevelnessEvent
  • getPitchThreshold() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • getPosX() : CaptureMessage
  • getPosY() : CaptureMessage
  • getPreviewImage() : PageDetectionEvent
  • getProcessedImageFilePath() : ImageProcessor
  • getProcessedImageJpegQuality() : ImageProcessor
  • getProcessedImageMimeType() : ImageProcessor
  • getProcessedImageRepresentation() : ImageProcessor
  • getProcessingParameters() : BillParameters , CheckParameters , CreditCardParameters , IdParameters , IParameters , PassportParameters
  • getProcessName() : KtaBillExtractor , KtaCheckExtractor , KtaIdExtractor , KtaPassportExtractor
  • getProgressPct() : ImageProcessor.AnalysisProgressEvent , ImageProcessor.ProcessProgressEvent
  • getProject() : BundleCacheProvider , IBundleCacheProvider , IProjectProvider , LocalProjectProvider , ServerProjectProvider
  • getProjectAsync() : LocalProjectProvider
  • getProjectName() : IdExtractionParameters
  • getRamSize() : AppStatistics
  • getRamSizeThreshold() : AppStatistics
  • getRawData() : KtaJsonBill , RttiJsonBill , KtaJsonCheck , RttiJsonCheck , ConventionBasedJsonIdDeserializer , Bill , Check , Id , Passport , KtaJsonPassport , RttiJsonPassport
  • getReasonForRejection() : KtaJsonCheck , RttiJsonCheck , Check
  • getRectBottom() : BoundingRect
  • getRectLeft() : BoundingRect
  • getRectRight() : BoundingRect
  • getRectTop() : BoundingRect
  • getRegion() : IdExtractionParameters
  • getRegionName() : IdRegion
  • getRemainingLicenseCount() : Licensing
  • getResponse() : AppStatsSessionEvent
  • getRestrictiveEndorsement() : KtaJsonCheck , RttiJsonCheck , Check
  • getRestrictiveEndorsementPresent() : KtaJsonCheck , RttiJsonCheck , Check
  • getResultKey() : BillWorkflowActivity , CheckWorkflowActivity , CreditCardWorkflowActivity , IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • getRetainImage() : ImgReviewEditCntrl
  • getRightEdgeTearHeight() : CheckIQAData
  • getRightEdgeTearWidth() : CheckIQAData
  • getRoll() : LevelnessEvent
  • getRollThreshold() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • getRotateMessage() : DocumentBaseCaptureExperience
  • getRotateType() : BasicSettingsProfile
  • getRotation() : PreviewFrameEvent
  • getRotationLandscape() : PreviewFrameEvent
  • getSaturationDetection() : QuickAnalysisSettings
  • getSdkVersion() : SdkVersion
  • getSearchDirection() : BarCodeCaptureView
  • getSearchDirections() : BarCodeReader
  • getSearchSymbology() : BarCodeReader
  • getServerTimeout() : CaptureServer
  • getServerUrl() : LoginCredentials , ServerExtractionParameters
  • getShadowDetection() : QuickAnalysisSettings
  • getSheetID() : Page
  • getShortEdge() : DocumentDimensions
  • getShortEdgeThreshold() : DocumentDetectionSettings
  • getSide() : CheckDetectionSettings , Page
  • getSignature() : CheckUsabilityData
  • getSignatureImage() : ConventionBasedJsonIdDeserializer , Id
  • getSize() : AppStatsThresholdReachedEvent
  • getSkewDetection() : QuickAnalysisSettings
  • getSource() : KtaJsonBill , RttiJsonBill , Bill
  • getSourceServer() : DocumentType , DocumentTypeR
  • getSpotNoise() : CheckIQAData
  • getSSLSocketFactory() : CertificateValidatorListener
  • getStability() : StabilityDelayEvent
  • getStabilityThreshold() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • getState() : AppStatsWriteToFileResults , KtaJsonBill , RttiJsonBill , ConventionBasedJsonIdDeserializer , Bill , Id
  • getStatus() : BarCodeReader.BarcodeReadCompleteEvent , ImageClassifier , ImageProcessor.AnalysisCompleteEvent , ImageProcessor.AnalysisProgressEvent , ImageProcessor.ImageOutEvent , ImageProcessor.ProcessProgressEvent
  • getSuccess() : AutoFocusResultEvent
  • getSymbologies() : BarCodeCaptureView
  • getTag() : Field
  • getTargetFrame() : Image
  • getTargetFrameAspectRatio() : CheckDetectionSettings , DetectionSettings , FixedAspectRatioDetectionSettings , PassportDetectionSettings , SelfieDetectionSettings
  • getTargetFramePaddingPercent() : DetectionSettings , FixedAspectRatioDetectionSettings , SelfieDetectionSettings
  • getTetragonCorners() : QuickAnalysisFeedback
  • getTextColor() : CaptureMessage
  • getTextSize() : CaptureMessage
  • getThresholdType() : AppStatsThresholdReachedEvent
  • getTimeOut() : TimeOutParameters
  • getTimeOutParameters() : LoginCredentials , ServerExtractionParameters
  • getToleranceFraction() : DetectionSettings
  • getTopEdgeTearHeight() : CheckIQAData
  • getTopEdgeTearWidth() : CheckIQAData
  • getTopLeft() : BoundingTetragon
  • getTopLeftCornerHeight() : CheckIQAData
  • getTopLeftCornerWidth() : CheckIQAData
  • getTopRight() : BoundingTetragon
  • getTopRightCornerHeight() : CheckIQAData
  • getTopRightCornerWidth() : CheckIQAData
  • getTorchDelay() : ImageCaptureView
  • getTransit() : KtaJsonCheck , RttiJsonCheck , Check
  • getTransitNumber() : MicrLine , MicrParser
  • getTurnGuidance() : DetectionResult
  • getTutorialDismissMessage() : DocumentBaseCaptureExperience
  • getType() : BarCodeResult , AppStatsSessionEvent
  • getTypeface() : CaptureMessage
  • getTypeName() : DocumentType , DocumentTypeR
  • getUndersizeImage() : CheckIQAData
  • getUnit() : TimeOutParameters
  • getUsable() : KtaJsonCheck , RttiJsonCheck , Check
  • getUseDocumentDetectionBasedCrop() : ImagePerfectionProfile , QuickAnalysisSettings
  • getUseMRZPassportDetection() : ImagePerfectionProfile , QuickAnalysisSettings
  • getUserEmailAddress() : UserProfile
  • getUserInstructionMessage() : CheckCaptureExperience , DocumentBaseCaptureExperience , PassportCaptureExperience , SelfieBaseCaptureExperience , LicenseCaptureView
  • getUsername() : UserProfile
  • getUseTargetFrameCrop() : ImagePerfectionProfile , QuickAnalysisSettings
  • getUseVideoFrame() : ImageCaptureView
  • getValue() : BarCodeResult , Field , SearchDirection
  • getValueSet() : MicrLine
  • getVariant() : BundleCacheProvider , IBundleCacheProvider , IProjectProvider , LocalProjectProvider , ServerProjectProvider
  • getVariantAsync() : LocalProjectProvider
  • getVersion() : DocumentType , DocumentTypeR
  • getVerticalMovementGuidance() : DetectionResult
  • getViewBoundariesImage() : QuickAnalysisFeedback
  • getViewfinderPaddingPercent() : LicenseCaptureView
  • getViewGroup() : ImageCaptureView
  • getVisibility() : CaptureMessage
  • getWeight() : ConventionBasedJsonIdDeserializer , Id
  • getWidth() : CaptureMessage , PreviewFrameEvent
  • getWritetoFileStatus() : AppStatsWritetoFileEvent
  • getZip() : KtaJsonBill , RttiJsonBill , ConventionBasedJsonIdDeserializer , Bill , Id
  • getZoomGuidance() : DetectionResult
  • getZoomInMessage() : DocumentBaseCaptureExperience
  • getZoomOutMessage() : DocumentBaseCaptureExperience


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- h -

  • handleException() : WorkflowActivity< T extends IParameters >
  • hashCode() : DocumentDimensions , Size , Field< T extends Serializable >
  • hasMoreElements() : ZipInputStreamBundle
  • height() : BoundingRect


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- i -

  • IdExtractionParameters() : IdExtractionParameters
  • IdExtractor() : IdExtractor
  • IdExtractorResponse() : IdExtractorResponse
  • IdParameters() : IdParameters
  • IdRegion() : IdRegion
  • IdState() : IdParameters.IdState
  • Image() : Image
  • ImageCacheType() : ImageCacheType
  • ImageCapturedEvent() : ImageCapturedEvent
  • ImageCaptureView() : ImageCaptureView
  • ImageClassificationResult() : ImageClassificationResult
  • ImageClassifier() : ImageClassifier
  • imageClearBitmap() : Image
  • imageClearFileBuffer() : Image
  • imageDeleteFile() : Image
  • imageOut() : ImageProcessor.ImageOutListener
  • ImageOutEvent() : ImageProcessor.ImageOutEvent
  • ImagePerfectionProfile() : ImagePerfectionProfile
  • ImageProcessor() : ImageProcessor
  • ImageProcessorConfiguration() : ImageProcessorConfiguration
  • imageReadFromFile() : Image
  • imageReadFromFileBuffer() : Image
  • imageWriteToFile() : Image
  • imageWriteToFileBuffer() : Image
  • ImgReviewEditCntrl() : ImgReviewEditCntrl
  • initAppStats() : AppStatistics
  • initBase() : DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • initController() : CaptureActivity
  • innerException() : ExceptionResponse , ExceptionResponseImpl
  • invokeImageCapturedListeners() : CaptureExperience
  • isAnimationTutorEnable() : DocumentBaseCaptureExperience
  • isBarcodeRead() : ConventionBasedJsonIdDeserializer , Id , IIdExtractionResult
  • isBelowThreshold() : TorchLuminanceEvent
  • isBlurry() : QuickAnalysisFeedback
  • isDiagnosticsViewEnabled() : DocumentBaseCaptureExperience
  • isDirectory() : IBundleFile
  • isError() : AppStatsWriteToFileResults
  • isFlashSupported() : ImageCaptureView
  • isFocusEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder , SelfieCaptureExperienceCriteriaHolder
  • isForceMatch() : FieldType
  • isGlareDetected() : QuickAnalysisFeedback
  • isHidden() : FieldType
  • isLowContrastBackground() : QuickAnalysisFeedback
  • isMicrValid() : MicrParser
  • isMissingBorders() : QuickAnalysisFeedback
  • isOcrRead() : ConventionBasedJsonIdDeserializer , Id , IIdExtractionResult
  • isOdeSupported() : IdWorkflowActivity , PassportWorkflowActivity , WorkflowActivity< T extends IParameters >
  • isOrientationEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder , FixedAspectRatioExperienceCriteriaHolder
  • isOverlySkewed() : QuickAnalysisFeedback
  • isOversaturated() : QuickAnalysisFeedback
  • isPageDetectionEnabled() : DocumentBaseCaptureExperienceCriteriaHolder
  • isPitchThresholdEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • isProcessed() : IdExtractionParameters
  • isReachable() : SessionState
  • isReadOnly() : FieldType
  • isRecording() : AppStatistics
  • isRefocusBeforeCaptureEnabled() : CaptureExperienceCriteriaHolder
  • isRequired() : FieldType
  • isRollThresholdEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • isSdkLicensed() : Licensing
  • isShadowed() : QuickAnalysisFeedback
  • isStabilityThresholdEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • isTorchOn() : TorchLuminanceEvent
  • isUndersaturated() : QuickAnalysisFeedback
  • isValid() : Field
  • isVibrationEnabled() : CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- k -

  • KmcException() : KmcException
  • KmcRuntimeException() : KmcRuntimeException
  • KtaBillExtractor() : KtaBillExtractor
  • KtaCheckExtractor() : KtaCheckExtractor
  • KtaIdExtractor() : KtaIdExtractor
  • KtaJsonBill() : KtaJsonBill
  • KtaJsonCheck() : KtaJsonCheck
  • KtaJsonPassport() : KtaJsonPassport
  • KtaPassportExtractor() : KtaPassportExtractor


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- l -

  • LevelnessEvent() : LevelnessEvent
  • LicenseCaptureView() : LicenseCaptureView
  • licenseFound() : LicenseFoundListener
  • LicenseFoundEvent() : LicenseFoundEvent
  • licenseOperationFailed() : Licensing.VolumeLicenseEventListener
  • licenseOperationSucceeded() : Licensing.VolumeLicenseEventListener
  • list() : IBundle , ZipFileBundle , ZipInputStreamBundle
  • ListOfException() : ListOfException
  • loadAllVariantsForProject() : ServerProjectProvider
  • loadConfigurationFile() : ImageClassifier
  • loadModel() : ImageClassifier
  • LocalProjectProvider() : LocalProjectProvider
  • login() : IServerExtractor , CaptureServer , ICaptureServer
  • loginAnonymously() : CaptureServer , ICaptureServer
  • LoginCredentials() : LoginCredentials
  • logout() : CaptureServer , ICaptureServer
  • logSessionEvent() : AppStatistics
  • LookAndFeelParameters() : LookAndFeelParameters


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- m -

  • message() : ExceptionResponse , ExceptionResponseImpl
  • MicrLine() : MicrLine
  • MicrParser() : MicrParser
  • muteAutoTorch() : ImageCaptureView


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- n -

  • nextElement() : ZipInputStreamBundle


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- o -

  • onActivityResult() : CaptureActivity , CardIoWrapperActivity , CreditCardWorkflowActivity , IdWorkflowActivity , WorkflowActivity< T extends IParameters >
  • onAttachedToWindow() : ImageCaptureView
  • onAutoFocus() : AutoFocusResultListener , CaptureExperience
  • onBackPressed() : ProcessActivity
  • onCameraInitializationFailed() : CameraInitializationFailedListener
  • onCameraInitialized() : CameraInitializationListener
  • onComplete() : ICompletionListener< T >
  • onCreate() : AppContextProvider , BillCaptureActivity , BillExtractActivity , BillWorkflowActivity , CaptureActivity , CheckCaptureActivity , CheckExtractActivity , CheckWorkflowActivity , CardIoWrapperActivity , CreditCardWorkflowActivity , ExtractActivity< T extends ExtractorResponse > , IdCaptureActivity , IdCaptureBackActivity , IdExtractActivity , IdWorkflowActivity , ImageReviewActivity , PassportCaptureActivity , PassportExtractActivity , PassportWorkflowActivity , ProcessActivity , WorkflowActivity< T extends IParameters >
  • onDestroy() : WorkflowActivity< T extends IParameters >
  • onDetachedFromWindow() : ImageCaptureView
  • OnDeviceIdExtractor() : OnDeviceIdExtractor
  • onDraw() : ImgReviewEditCntrl
  • onExitButtonClick() : CaptureActivity
  • onExportAppStatsRowEvent() : AppStatsDsExportHandler
  • onExtractionComplete() : ExtractActivity< T extends ExtractorResponse > , Extractor< T extends Serializable > , IExtractorListener< T extends ExtractorResponse > , IIdExtractionListener
  • onForceCaptureButtonClick() : CaptureActivity
  • onGalleryButtonClick() : CaptureActivity
  • onImageCaptured() : CaptureExperience , ImageCapturedListener
  • onImageClassified() : ImageClassificationCompletedListener
  • onImageProcessed() : ProcessActivity , IImageProcessorListener
  • onLayout() : ImageCaptureView
  • onLevelness() : CaptureExperience , LevelnessListener
  • onLevelnessChanged() : BarCodeCaptureView
  • onLocationEnableEvent() : BarCodeCaptureView
  • onLocationEvent() : BarCodeCaptureView
  • onPause() : CaptureActivity , ProcessActivity
  • onPreviewFrame() : BarCodeCaptureView , LicenseCaptureView , PreviewCallbackListener
  • onProgress() : IProgressListener
  • onRestoreInstanceState() : ImgReviewEditCntrl
  • onResume() : CaptureActivity , ExtractActivity< T extends ExtractorResponse > , ProcessActivity , WorkflowActivity< T extends IParameters >
  • onSaveInstanceState() : ImgReviewEditCntrl , CaptureActivity , ExtractActivity< T extends ExtractorResponse > , ProcessActivity , WorkflowActivity< T extends IParameters >
  • onSizeChanged() : ImgReviewEditCntrl
  • onStabilityDelay() : CaptureExperience , StabilityDelayListener
  • onTorchChange() : CaptureActivity
  • onTorchLuminance() : TorchLuminanceListener
  • onTouch() : ImgReviewEditCntrl
  • OutputColor() : Image.OutputColor


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- p -

  • Page() : Page
  • pageDetected() : PageDetectionListener
  • PageDetectionEvent() : PageDetectionEvent
  • ParseMicr() : MicrParser
  • PassportCaptureExperience() : PassportCaptureExperience
  • PassportCaptureExperienceCriteriaHolder() : PassportCaptureExperienceCriteriaHolder
  • PassportDetectionResult() : PassportDetectionResult
  • PassportDetectionSettings() : PassportDetectionSettings
  • PassportDetector() : PassportDetector
  • PassportExtractor() : PassportExtractor
  • PassportExtractorResponse() : PassportExtractorResponse
  • PassportParameters() : PassportParameters
  • PointDouble() : PointDouble
  • PreviewFrameEvent() : PreviewFrameEvent
  • printStackTrace() : ListOfException
  • process() : IImageProcessor
  • processImage() : ImageProcessor
  • ProcessingParameters() : ProcessingParameters
  • processProgress() : ImageProcessor.ProcessProgressListener
  • ProcessProgressEvent() : ImageProcessor.ProcessProgressEvent
  • ProjectProviderException() : ProjectProviderException
  • purge() : AppStatistics


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- q -

  • QuickAnalysisFeedback() : QuickAnalysisFeedback
  • QuickAnalysisSettings() : QuickAnalysisSettings


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- r -

  • readBarcode() : BarCodeCaptureView
  • readBarcodes() : BarCodeReader
  • readLicense() : LicenseCaptureView
  • readVersion() : LocalProjectProvider
  • registerDevice() : CaptureServer , ICaptureServer
  • registerExportHandler() : AppStatistics
  • removeAllViews() : ImageCaptureView
  • removeAnalysisCompleteEventListener() : ImageProcessor
  • removeAnalysisProgressEventListener() : ImageProcessor
  • removeAppStatsExportListener() : AppStatistics
  • removeAppStatsThresholdListener() : AppStatistics
  • removeAppStatsWriteFileListener() : AppStatistics
  • removeBarCodeFoundEventListener() : BarCodeCaptureView
  • removeBarcodeReadCompleteEventListener() : BarCodeReader
  • removeCameraInitializationFailedListener() : ImageCaptureView
  • removeCameraInitializationListener() : ImageCaptureView
  • removeImage() : Page , ContextImageStorage , IImageStorage
  • removeImageClassificationCompletedEventListener() : ImageClassifier
  • removeImageOutEventListener() : ImageProcessor
  • removeLevelnessListener() : ImageCaptureView
  • removeLicenseFoundEventListener() : LicenseCaptureView
  • removeOnAutoFocusResultListener() : ImageCaptureView
  • removeOnImageCapturedListener() : CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience , ImageCaptureView
  • removePage() : Document
  • removePageDetectionListener() : DocumentBaseCaptureExperience
  • removePreviewCallbackListener() : ImageCaptureView
  • removeProcessProgressEventListener() : ImageProcessor
  • removeStabilityDelayListener() : ImageCaptureView
  • removeTorchLuminanceListener() : ImageCaptureView
  • removeVolumeLicenseEventListener() : Licensing
  • rotate() : BoundingTetragon
  • RotateType() : RotateType
  • RttiBillExtractor() : RttiBillExtractor
  • RttiCheckExtractor() : RttiCheckExtractor
  • RttiIdExtractor() : RttiIdExtractor
  • RttiJsonBill() : RttiJsonBill
  • RttiJsonCheck() : RttiJsonCheck
  • RttiJsonPassport() : RttiJsonPassport
  • RttiPassportExtractor() : RttiPassportExtractor


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- s -

  • saveResultAndFinish() : CaptureActivity
  • sdkVersion() : LocalProjectProvider , ServerProjectProvider
  • SearchDirection() : SearchDirection
  • SelfieBaseCaptureExperience() : SelfieBaseCaptureExperience
  • SelfieCaptureExperience() : SelfieCaptureExperience
  • SelfieCaptureExperienceCriteriaHolder() : SelfieCaptureExperienceCriteriaHolder
  • SelfieDetectionSettings() : SelfieDetectionSettings
  • sendImageService() : CaptureServer , ICaptureServer
  • ServerExtractionParameters() : ServerExtractionParameters
  • ServerProjectProvider() : ServerProjectProvider
  • sessionCreate() : ImageCaptureView
  • sessionDismiss() : ImageCaptureView
  • SessionState() : SessionState
  • set() : BoundingRect
  • setAmount() : MicrLine
  • setAspectRatioFraction() : CheckDetectionSettings
  • setAuxiliaryOnUs() : MicrLine
  • setBackground() : CaptureMessage
  • setBackgroundColor() : CaptureMessage
  • setBasicSettingsProfile() : ImageProcessor , DocumentType
  • setBlinkMessage() : SelfieBaseCaptureExperience
  • setBlurCountPercentThreshold() : QuickAnalysisSettings
  • setBlurDetection() : QuickAnalysisSettings
  • setBlurThreshold() : QuickAnalysisSettings
  • setBottomLeft() : BoundingTetragon
  • setBottomRight() : BoundingTetragon
  • setBoundingBox() : BarCodeResult
  • setCameraType() : ImageCaptureView
  • setCaptureCriteria() : CheckCaptureExperience , DocumentCaptureExperience , FixedAspectRatioCaptureExperience , PassportCaptureExperience , SelfieCaptureExperience , CaptureActivity , IdCaptureActivity
  • setCapturedMessage() : DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • setCardNumber() : CreditCard
  • setCenterMessage() : CheckCaptureExperience , DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience , PassportCaptureExperience
  • setCenterPoint() : DetectionSettings , FixedAspectRatioDetectionSettings , SelfieDetectionSettings
  • setCertificateValidatorListener() : Licensing , Extractor< T extends Serializable > , ServerProjectProvider , CaptureServer
  • setCheckDetectionSettings() : CheckCaptureExperienceCriteriaHolder
  • setCheckParameters() : ICheckExtractionServer , KtaCheckExtractor , RttiCheckExtractor
  • setCheckSampleImage() : CheckCaptureExperience
  • setCheckType() : MicrLine
  • setClassificationAlternatives() : Document
  • setContext() : AppContextProvider
  • setCropCornerColor() : ImgReviewEditCntrl
  • setCropLineColor() : ImgReviewEditCntrl
  • setCropLineStyle() : ImgReviewEditCntrl
  • setCroppingTetragon() : BasicSettingsProfile
  • setCropTetragon() : ImgReviewEditCntrl
  • setCropType() : BasicSettingsProfile
  • setCurrentImageIndex() : Page
  • setCustomTag() : FieldType
  • setCvv() : CreditCard
  • setDataFormat() : BarCodeResult
  • setDataType() : FieldType
  • setDefault() : FieldType
  • setDetectionSettings() : DocumentCaptureExperienceCriteriaHolder , FixedAspectRatioExperienceCriteriaHolder , PassportCaptureExperienceCriteriaHolder , SelfieCaptureExperienceCriteriaHolder
  • setDeviceDeclinationPitch() : ImageCaptureView
  • setDeviceDeclinationRoll() : ImageCaptureView
  • setDeviceId() : AppStatistics
  • setDiagnosticsViewEnabled() : DocumentBaseCaptureExperience
  • setDirection() : BarCodeResult
  • setDisplayName() : DocumentType , FieldType
  • setDocHeight() : DocumentType
  • setDocumentID() : Page
  • setDocumentLevelError() : Document
  • setDocumentSampleImage() : DocumentBaseCaptureExperience
  • setDocWidth() : DocumentType
  • setDoDeskew() : BasicSettingsProfile
  • setDomain() : UserProfile
  • setEdgeDetection() : DocumentDetectionSettings
  • setEmpty() : BoundingRect
  • setEPC() : MicrLine
  • setErrCause() : ErrorInfo
  • setError() : AppStatsWriteToFileResults
  • setExceptionResponseDeserializer() : Extractor< T extends Serializable >
  • setExpirationMonth() : CreditCard
  • setExpirationYear() : CreditCard
  • setExtract() : ExtractActivity< T extends ExtractorResponse >
  • setExtractionServer() : Extractor< T extends Serializable >
  • setExtractionType() : ExtractionParameters
  • setExtractorListener() : Extractor< T extends Serializable >
  • setFaceAngleTolerance() : SelfieDetectionSettings
  • setFileSizeThreshold() : AppStatistics
  • setFlash() : ImageCaptureView
  • setFocusAreas() : ImageCaptureView
  • setFocusEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder , SelfieCaptureExperienceCriteriaHolder
  • setForceMatch() : FieldType
  • setFrameColor() : SelfieBaseCaptureExperience
  • setGlareDetectedThreshold() : QuickAnalysisSettings
  • setGlareDetection() : QuickAnalysisSettings
  • setGlareDetectionIntensityFraction() : QuickAnalysisSettings
  • setGlareDetectionIntensityThreshold() : QuickAnalysisSettings
  • setGlareDetectionMinimumGlareAreaFraction() : QuickAnalysisSettings
  • setGlareDetectionNumberOfTiles() : QuickAnalysisSettings
  • setGpsUsage() : ImageCaptureView
  • setGuidanceFrameColor() : DocumentBaseCaptureExperience
  • setGuidingLine() : BarCodeCaptureView
  • setHeight() : CaptureMessage
  • setHidden() : FieldType
  • setHighlightColor() : ImgReviewEditCntrl
  • setHoldParallelMessage() : DocumentBaseCaptureExperience
  • setHoldSteadyDelay() : DocumentBaseCaptureExperienceCriteriaHolder
  • setHoldSteadyMessage() : DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • setIdParameters() : IIdExtractionServer , KtaIdExtractor , RttiIdExtractor
  • setImage() : ImgReviewEditCntrl , ContextImageStorage , IImageStorage
  • setImageBarCodes() : Image
  • setImageBitmap() : Image
  • setImageCacheType() : ImgReviewEditCntrl
  • setImageClassifyResults() : Image
  • setImageCreateDateTime() : Image
  • setImageDPI() : Image
  • setImageFilePath() : Image
  • setImageJpegQuality() : Image
  • setImageMimeType() : Image
  • setImageOutListener() : IImageProcessor
  • setImageOutputColor() : Image
  • setImagePerfectionProfile() : ImageProcessor , DocumentType
  • setImageResolution() : ImageCaptureView
  • setImageStorage() : ApplicationContextImageStore
  • setImageTag() : Image
  • setInputDocLongEdge() : BasicSettingsProfile
  • setInputDocShortEdge() : BasicSettingsProfile
  • setIpOperations() : ImagePerfectionProfile
  • setIpOperationsFilePath() : ImagePerfectionProfile
  • setJson() : KtaJsonBill , RttiJsonBill , KtaJsonCheck , RttiJsonCheck , ConventionBasedJsonIdDeserializer , KtaJsonPassport , RttiJsonPassport
  • setLabel() : FieldType
  • setListenerCallbackThreadType() : ImageProcessor , AppStatistics
  • setLongEdgeThreshold() : DocumentDetectionSettings
  • setLowContrastBackgroundDetection() : QuickAnalysisSettings
  • setLuminanceThreshold() : ImageCaptureView
  • setMax() : FieldType
  • setMaxBarcodes() : BarCodeReader
  • setMaxFillFraction() : DetectionSettings
  • setMaxNumberOfResults() : ImageClassifier
  • setMaxSkewAngle() : DetectionSettings
  • setMessage() : CaptureMessage
  • setMessageIcons() : CaptureMessage
  • setMicrData() : Image
  • setMin() : FieldType
  • setMinFillFraction() : DetectionSettings
  • setMinimumFaceSize() : SelfieDetectionSettings
  • setMissingBordersDetection() : QuickAnalysisSettings
  • setMobileSDKLicense() : Licensing
  • setMobileSDKLicenseServer() : Licensing
  • setName() : ImagePerfectionProfile , FieldType , CreditCard
  • setOnUs() : MicrLine
  • setOnUs1() : MicrLine
  • setOnUs2() : MicrLine
  • setOptions() : FieldType
  • setOrientation() : CaptureMessage
  • setOrientationEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder , FixedAspectRatioExperienceCriteriaHolder
  • setOuterViewFinderColor() : DocumentBaseCaptureExperience , SelfieBaseCaptureExperience , LicenseCaptureView
  • setOutputBitDepth() : BasicSettingsProfile
  • setOutputDPI() : BasicSettingsProfile
  • setPageDetectionEnabled() : DocumentBaseCaptureExperienceCriteriaHolder
  • setParameters() : BillExtractor , CheckExtractor , Extractor< T extends Serializable > , IdExtractor , PassportExtractor , IImageProcessor
  • setPassportSampleImage() : PassportCaptureExperience
  • setPassword() : UserProfile
  • setPitchThreshold() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • setPitchThresholdEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • setPosX() : CaptureMessage
  • setPosY() : CaptureMessage
  • setProcessedImageFilePath() : ImageProcessor
  • setProcessedImageJpegQuality() : ImageProcessor
  • setProcessedImageMimeType() : ImageProcessor
  • setProcessedImageRepresentation() : ImageProcessor
  • setProjectProvider() : ExtractionParameters
  • setRamSizeThreshold() : AppStatistics
  • setReadOnly() : FieldType
  • setRectBottom() : BoundingRect
  • setRectLeft() : BoundingRect
  • setRectRight() : BoundingRect
  • setRectTop() : BoundingRect
  • setRefocusEnabled() : CaptureExperienceCriteriaHolder
  • setRequestTimeout() : ServerProjectProvider
  • setRequired() : FieldType
  • setResponse() : AppStatsSessionEvent
  • setResultDeserializer() : Extractor< T extends Serializable >
  • setRetainImage() : ImgReviewEditCntrl
  • setRollThreshold() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • setRollThresholdEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • setRotateMessage() : DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience
  • setRotateType() : BasicSettingsProfile
  • setSaturationDetection() : QuickAnalysisSettings
  • setSearchDirection() : BarCodeCaptureView
  • setSearchDirections() : BarCodeReader
  • setSearchSymbology() : BarCodeReader
  • setServerTimeout() : CaptureServer
  • setShadowDetection() : QuickAnalysisSettings
  • setSheetID() : Page
  • setShortEdgeThreshold() : DocumentDetectionSettings
  • setSide() : CheckDetectionSettings , Page
  • setSkewDetection() : QuickAnalysisSettings
  • setSourceServer() : DocumentType
  • setStabilityThreshold() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • setStabilityThresholdEnabled() : CaptureExperienceCriteriaHolder , DocumentBaseCaptureExperienceCriteriaHolder
  • setState() : AppStatsWriteToFileResults
  • setSteadyGuidanceFrameColor() : DocumentBaseCaptureExperience
  • setSymbologies() : BarCodeCaptureView
  • setTag() : Field
  • setTargetFrame() : Image
  • setTargetFrameAspectRatio() : CheckDetectionSettings , DetectionSettings , FixedAspectRatioDetectionSettings , PassportDetectionSettings , SelfieDetectionSettings
  • setTargetFramePaddingPercent() : DetectionSettings , FixedAspectRatioDetectionSettings , SelfieDetectionSettings
  • setTextColor() : CaptureMessage
  • setTextSize() : CaptureMessage
  • setToleranceFraction() : DetectionSettings
  • setTopLeft() : BoundingTetragon
  • setTopRight() : BoundingTetragon
  • setTorchDelay() : ImageCaptureView
  • setTransitNumber() : MicrLine
  • setTutorialDismissMessage() : DocumentBaseCaptureExperience
  • setType() : BarCodeResult , AppStatsSessionEvent
  • setTypeface() : CaptureMessage
  • setTypeName() : DocumentType
  • setupButtonBarView() : CaptureActivity , IdCaptureBackActivity
  • setupCameraView() : CaptureActivity , IdCaptureBackActivity
  • setUseDocumentDetectionBasedCrop() : ImagePerfectionProfile , QuickAnalysisSettings
  • setUseMRZPassportDetection() : ImagePerfectionProfile , QuickAnalysisSettings
  • setUserEmailAddress() : UserProfile
  • setUserInstructionMessage() : CheckCaptureExperience , DocumentBaseCaptureExperience , PassportCaptureExperience , SelfieBaseCaptureExperience , LicenseCaptureView
  • setUsername() : UserProfile
  • setUseTargetFrameCrop() : ImagePerfectionProfile , QuickAnalysisSettings
  • setUseVideoFrame() : ImageCaptureView
  • setValue() : BarCodeResult
  • setVersion() : DocumentType
  • setVibrationEnabled() : CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • setViewfinderPaddingPercent() : LicenseCaptureView
  • setVisibility() : CaptureMessage
  • setWidth() : CaptureMessage
  • setZoomInMessage() : DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience
  • setZoomOutMessage() : DocumentBaseCaptureExperience , FixedAspectRatioCaptureExperience
  • showCropRectangle() : ImgReviewEditCntrl
  • showHighlights() : ImgReviewEditCntrl
  • Size() : Size
  • SizeDouble() : SizeDouble
  • StabilityDelayEvent() : StabilityDelayEvent
  • stackTrace() : ExceptionResponse , ExceptionResponseImpl
  • startJobService() : CaptureServer , ICaptureServer
  • startRecord() : AppStatistics
  • stopCapture() : CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • stopRecord() : AppStatistics
  • submitDocument() : CaptureServer , ICaptureServer
  • surfaceChanged() : ImageCaptureView
  • surfaceCreated() : ImageCaptureView
  • surfaceDestroyed() : ImageCaptureView
  • Symbology() : BarCodeReader.Symbology


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- t -

  • takePicture() : CaptureExperience , DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • takePictureContinually() : CaptureExperience , DocumentBaseCaptureExperience
  • thresholdReached() : AppstatsThresholdReachedListener
  • TimeOutParameters() : TimeOutParameters
  • TorchLuminanceEvent() : TorchLuminanceEvent
  • toString() : BoundingRect , DetectionResult , Size , Field< T extends Serializable > , FieldLocation , PointDouble , SizeDouble
  • tryRestoreState() : WorkflowActivity< T extends IParameters >


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- u -

  • unmuteAutoTorch() : ImageCaptureView
  • updateFieldProperties() : Field
  • updateKTARequest() : KtaCheckExtractor , KtaIdExtractor , KtaPassportExtractor
  • updateRttiRequest() : RttiCheckExtractor , RttiIdExtractor , RttiPassportExtractor


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- v -

  • versionCompatible() : SdkVersion


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- w -

  • width() : BoundingRect
  • writeFileStatusEvent() : AppStatsWriteFileListener
  • writeToFile() : AppStatistics
  • writeToParcel() : CreditCard


Kofax Mobile SDK API Reference: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • z

- z -

  • ZipFileBundle() : ZipFileBundle
  • ZipInputStreamBundle() : ZipInputStreamBundle


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- _ -

  • _aspectRatio : CaptureExperience
  • _bus : ImageCaptureView
  • _captureExperienceData : CaptureExperience
  • _continuousCapture : CaptureExperience
  • _ctx : DocumentBaseCaptureExperience , SelfieBaseCaptureExperience
  • _extractor : ExtractActivity< T extends ExtractorResponse >
  • _imageCapturedListeners : CaptureExperience
  • _imageCaptureView : CaptureExperience
  • _lock : CaptureExperience
  • _regionName : IdRegion
  • _sdkCaptureRequested : CaptureExperience
  • _uiHandler : CaptureExperience
  • _vibrationEnabled : CaptureExperience
  • _vibrator : CaptureExperience


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- a -

  • acquiredCount : Licensing.VolumeLicenseResultData
  • AFRICA : IdRegion
  • AFRICA_OTHER : IdParameters.IdState
  • ALBANIA : IdParameters.IdState
  • ALL : BarCodeReader.Direction , SearchDirection
  • ALWAYS_USE_IF_ENABLED : GpsUsageLimits
  • ANSI_X9 : Image.FileRestriction
  • appStatsDaoCurrent : AppStatistics
  • ASCII : BarCodeDataFormat
  • ASIA : IdRegion
  • ASIA_OTHER : IdParameters.IdState
  • AUSTRALIA : CheckParameters.CheckCountry , IdRegion
  • AUSTRALIA_OTHER : IdParameters.IdState
  • AUTO : Flash , LookAndFeelParameters.TorchMode
  • AUTOTORCH : Flash
  • AZTEC : BarCodeType , Symbology


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- b -

  • BACK : CheckSide , Page.Side , IdParameters.IdSide
  • BACK_CAMERA : CameraType
  • barcode : IdParameters
  • BARCODE_CAPTURE : Licensing.LicenseType
  • BASE_64 : BarCodeDataFormat
  • BILL_EXCEPTION : BillWorkflowActivity
  • BILL_EXTRACT_KTA : BillExtractor
  • BILL_EXTRACT_RTTI : BillExtractor
  • BILL_PARAMETERS : BillWorkflowActivity
  • BILL_RESULTS : BillWorkflowActivity
  • BITDEPTH_BITONAL : Image.OutputColor
  • BITDEPTH_COLOR : Image.OutputColor
  • BITDEPTH_GRAYSCALE : Image.OutputColor
  • BITONAL : BasicSettingsProfile.OutputBitDepth , ColorDepth
  • BOOL : FieldType.DataType
  • BOTTOM_UP : BarCodeReader.Direction , BarCodeDirection
  • BRAZIL : IdParameters.IdState
  • BUSINESS_CHECK : MicrLine.CheckType


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- c -

  • CAMERA_IMAGE_RESOLUTION_CHANGED : CameraInitializationEvent.CameraInitStatus
  • CAMERA_STATUS_UNKNOWN : CameraInitializationEvent.CameraInitStatus
  • CAMERA_USE_VIDEO_FRAME_CHANGED : CameraInitializationEvent.CameraInitStatus
  • CAMERA_VIEW_CREATED : CameraInitializationEvent.CameraInitStatus
  • CAMEROON : IdParameters.IdState
  • CANADA : CheckParameters.CheckCountry , IdParameters.IdState , IdRegion
  • CAPTURE : ImageSource
  • captureData : ProcessingParameters
  • capturedImageId : CaptureData
  • cardStyle : CreditCardParameters
  • CERTIFICATE_VALIDATOR_LISTENER : ExtractActivity< T extends ExtractorResponse > , WorkflowActivity< T extends IParameters >
  • CHECK_EXCEPTION : CheckWorkflowActivity
  • CHECK_EXTRACT_KTA : CheckExtractor
  • CHECK_EXTRACT_RTTI : CheckExtractor
  • CHECK_PARAMETERS : CheckWorkflowActivity
  • CHECK_RESULTS : CheckWorkflowActivity
  • CHINA : IdParameters.IdState
  • Codabar : BarCodeReader.Symbology
  • CODABAR : BarCodeType , Symbology
  • Code128 : BarCodeReader.Symbology
  • CODE128 : BarCodeType , Symbology
  • Code25 : BarCodeReader.Symbology
  • CODE25 : BarCodeType , Symbology
  • Code39 : BarCodeReader.Symbology
  • CODE39 : BarCodeType , Symbology
  • Code93 : BarCodeReader.Symbology
  • CODE93 : BarCodeType , Symbology
  • COLOR : BasicSettingsProfile.OutputBitDepth , ColorDepth
  • COMPLETE : ImageClassifier.ImageClassificationStatus , AppStatistics.ExportStatusEvent , AppStatsExportListener.ExportStatus
  • country : CheckParameters
  • COUNTRY : KtaCheckExtractor
  • CREATOR : CreditCard
  • credentials : ExtractionParameters
  • CREDIT_CARD_EXCEPTION : CreditCardWorkflowActivity
  • CREDIT_CARD_PARAMETERS : CreditCardWorkflowActivity
  • CREDIT_CARD_RESULTS : CreditCardWorkflowActivity
  • CROP_AUTO : BasicSettingsProfile.CropType , CropType
  • CROP_NONE : BasicSettingsProfile.CropType , CropType
  • CROP_QUICKANALYSIS : BasicSettingsProfile.CropType
  • CROP_TETRAGON : BasicSettingsProfile.CropType
  • cropType : ImageProcessorConfiguration


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- d -

  • Datamatrix : BarCodeReader.Symbology
  • DATAMATRIX : BarCodeType , Symbology
  • dataVersion : LocalProjectProvider.VersionTable.VersionList
  • DATE : FieldType.DataType
  • DEFAULT_JPEG_QUALITY : Image
  • DEFAULT_LUMINANCE_THRESHOLD : ImageCaptureView
  • DEFAULT_TORCH_DELAY : ImageCaptureView
  • DESKEW_BY_DOCUMENT_CONTENT : DeskewType
  • DESKEW_BY_DOCUMENT_EDGES : DeskewType
  • DESKEW_NONE : DeskewType
  • deskewType : ImageProcessorConfiguration
  • DISK : ImageCacheType
  • documentDimensions : ImageProcessorConfiguration


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- e -

  • Ean : BarCodeReader.Symbology
  • EAN : BarCodeType , Symbology
  • ECUADOR : IdParameters.IdState
  • EL_SALVADOR : IdParameters.IdState
  • EMAIL : FieldType.DataType
  • EMBOSSED : CreditCardParameters.CardStyle
  • ERROR : ImageClassifier.ImageClassificationStatus
  • EUROPE : IdRegion
  • EUROPE_OTHER : IdParameters.IdState
  • exceptionResponse : ExtractorResponse< T extends Serializable >
  • exitEnabled : LookAndFeelParameters
  • EXP_FORMAT_APP_DEFINED : AppStatistics.AppStatsExportFormat
  • EXP_FORMAT_JSON : AppStatistics.AppStatsExportFormat
  • EXP_FORMAT_SQL_SERVER : AppStatistics.AppStatsExportFormat
  • EXPORTING : AppStatistics.ExportStatusEvent , AppStatsExportListener.ExportStatus
  • EXTRA_EXTRA_TIME_FOR_EXPIRY : CardIoWrapperActivity
  • extraTimeForExpiry : CreditCardParameters


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- f -

  • FAILED : AppStatistics.ExportStatusEvent , AppStatsExportListener.ExportStatus
  • FILE_BUFFERED : Image.ImageFileRep
  • FILE_ENG_ANDROID : Image.FileIOEngine
  • FILE_ENG_KFIL : Image.FileIOEngine
  • FILE_NONE : Image.ImageFileRep
  • FILE_STORED : Image.ImageFileRep
  • FLAT : CreditCardParameters.CardStyle
  • FLIP : BoundingTetragon.Rotation
  • FLOAT : FieldType.DataType
  • forceCaptureEnabled : LookAndFeelParameters
  • FRONT : CheckSide , Page.Side , IdParameters.IdSide
  • FRONT_CAMERA : CameraType


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- g -

  • galleryEnabled : LookAndFeelParameters
  • GERMANY : IdParameters.IdState
  • GPU_BASED : DocumentDetectionSettings.DocumentEdgeDetection
  • GRAYSCALE : BasicSettingsProfile.OutputBitDepth , ColorDepth
  • GUATEMALA : IdParameters.IdState


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- h -

  • height : Size , SizeDouble
  • HONG_KONG : CheckParameters.CheckCountry
  • HORIZONTAL : SearchDirection
  • HORIZONTAL_MOVE_LEFT : HorizontalGuidance
  • HORIZONTAL_MOVE_OK : HorizontalGuidance
  • HORIZONTAL_MOVE_RIGHT : HorizontalGuidance


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- i -

  • Id : IdType
  • ID_BARCODE_RESULTS : IdWorkflowActivity
  • ID_EXCEPTION : IdWorkflowActivity
  • ID_EXTRACT_KTA : IdExtractor
  • ID_EXTRACT_ON_DEVICE : IdExtractor
  • ID_EXTRACT_RTTI : IdExtractor
  • ID_EXTRACTION : Licensing.LicenseType
  • ID_PARAMETERS : IdWorkflowActivity
  • ID_RESULTS : IdWorkflowActivity
  • IMAGE : ImageSource
  • IMAGE_CACHE_TYPE_DISK : ImageCacheType
  • IMAGE_CACHE_TYPE_MEMORY : ImageCacheType
  • IMAGE_CAPTURE : Licensing.LicenseType
  • IMAGE_CAPTURED : CaptureActivity
  • IMAGE_PROCESSING : Licensing.LicenseType
  • IMAGE_REP_BITMAP : Image.ImageRep
  • IMAGE_REP_BOTH : Image.ImageRep
  • IMAGE_REP_FILE : Image.ImageRep
  • IMAGE_REP_NONE : Image.ImageRep
  • IN_PROGRESS : ImageClassifier.ImageClassificationStatus
  • INDIA : IdParameters.IdState
  • INT : FieldType.DataType
  • ippString : ImageProcessorConfiguration
  • ISG : DocumentDetectionSettings.DocumentEdgeDetection


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- j -

  • JAPAN : IdParameters.IdState


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- k -

  • KEY_PASS : IdParameters.IdState
  • KMC_BC_BUSY : ErrorInfo
  • KMC_BC_IMAGE_BUFFERED : ErrorInfo
  • KMC_BC_INVALID_IMAGE : ErrorInfo
  • KMC_BC_NO_BARCODE_FOUND : ErrorInfo
  • KMC_BC_NO_REPRESENTATION : ErrorInfo
  • KMC_BC_UNKNOWN : ErrorInfo
  • KMC_BC_UNSUPPORTED_REGION : ErrorInfo
  • KMC_CL_CLASSIFICATION_CONFIDENCE_LOW : ErrorInfo
  • KMC_CL_CLASSIFIER_BUSY : ErrorInfo
  • KMC_CL_CLASSIFIER_NOT_INITIALIZED : ErrorInfo
  • KMC_CL_CONFIG_NOT_LOADED : ErrorInfo
  • KMC_CL_CONFIG_NULL : ErrorInfo
  • KMC_CL_ENCRYPTED_BARCODE_STRING : ErrorInfo
  • KMC_CL_ID_CLASS_NOT_SUPPORTED : ErrorInfo
  • KMC_CL_INVALID_BARCODE_STRING : ErrorInfo
  • KMC_CL_INVALID_IMAGE_SUPPLIED : ErrorInfo
  • KMC_CL_LISTENER_NULL : ErrorInfo
  • KMC_CL_MAX_NUM_RESULTS_INVALID : ErrorInfo
  • KMC_CL_MODEL_NOT_LOADED : ErrorInfo
  • KMC_CL_MODEL_NULL : ErrorInfo
  • KMC_CL_NO_IMAGE_SUPPLIED : ErrorInfo
  • KMC_ED_ALREADY_BUFFERED : ErrorInfo
  • KMC_ED_ALREADY_CLEAR : ErrorInfo
  • KMC_ED_ALTERNATE_FILEIO_ENGINE : ErrorInfo
  • KMC_ED_BITMAP_DIMENSIONS_IMMUTABLE : ErrorInfo
  • KMC_ED_BITMAP_DIMENSIONS_NO_UPSCALE : ErrorInfo
  • KMC_ED_BITMAP_READ_FROM_FILE_FAILED : ErrorInfo
  • KMC_ED_BITMAP_WRITE_TO_FILE_FAILED : ErrorInfo
  • KMC_ED_BUFFER : ErrorInfo
  • KMC_ED_BUFFER_ALREADY_CLEARED : ErrorInfo
  • KMC_ED_BUFFER_EXISTS : ErrorInfo
  • KMC_ED_BUFFERED_READ_FAILED : ErrorInfo
  • KMC_ED_DELETE_BUFFERED_FILE : ErrorInfo
  • KMC_ED_FILE_EXISTS : ErrorInfo
  • KMC_ED_FILE_NOT_DELETABLE : ErrorInfo
  • KMC_ED_FILE_RESTRICTION_BITDEPTH : ErrorInfo
  • KMC_ED_FILE_RESTRICTION_DPI : ErrorInfo
  • KMC_ED_FILE_RESTRICTION_MIMETYPE : ErrorInfo
  • KMC_ED_FILE_STILL_REMAINS : ErrorInfo
  • KMC_ED_FILEPATH : ErrorInfo
  • KMC_ED_IMAGE_FILE_DIMENSIONS_ERROR : ErrorInfo
  • KMC_ED_IMAGE_INVALID_SCALING_FACTOR : ErrorInfo
  • KMC_ED_IMAGE_IS_SCALED : ErrorInfo
  • KMC_ED_IMAGE_PERFECTION_PROFILE_EMPTY : ErrorInfo
  • KMC_ED_IMAGE_WRITTEN_IS_NOT_BITONAL : ErrorInfo
  • KMC_ED_IMAGE_WRITTEN_IS_NOT_GRAY : ErrorInfo
  • KMC_ED_IMAGELEAK : ErrorInfo
  • KMC_ED_INVALID_DOCUMENT_DIMENSIONS : ErrorInfo
  • KMC_ED_INVALID_DPI : ErrorInfo
  • KMC_ED_INVALID_FOR_OBJECT_REP : ErrorInfo
  • KMC_ED_INVALID_ISO_DATE_TIME_FORMAT : ErrorInfo
  • KMC_ED_INVALID_JPEG_QUALITY_VALUE : ErrorInfo
  • KMC_ED_JPEG_BITDEPTH : ErrorInfo
  • KMC_ED_MIMETYPE : ErrorInfo
  • KMC_ED_MIMETYPE_MISMATCH : ErrorInfo
  • KMC_ED_NO_BUFFERED_IMAGE : ErrorInfo
  • KMC_ED_NO_MEMORY_FOR_BUFFERED_FILE : ErrorInfo
  • KMC_ED_NOIMAGE : ErrorInfo
  • KMC_ED_NONEXISTENT_FILE : ErrorInfo
  • KMC_ED_NONEXISTENT_LOAD_SETTINGS_FILE : ErrorInfo
  • KMC_ED_NONEXISTENT_OCR_REGION_TYPE : ErrorInfo
  • KMC_ED_OBJECT_REP_BITMAP_MISMATCH : ErrorInfo
  • KMC_ED_OBJECT_REP_FILE_MISMATCH : ErrorInfo
  • KMC_ED_OBJECT_REP_MISMATCH : ErrorInfo
  • KMC_ED_OBJECT_REP_NO_BITMAP : ErrorInfo
  • KMC_ED_UNRECOGNIZED_MIME_TYPE : ErrorInfo
  • KMC_EV_APPEND_ENCRYPTED : ErrorInfo
  • KMC_EV_APPEND_TO_FILE : ErrorInfo
  • KMC_EV_BAD_CHANNEL : ErrorInfo
  • KMC_EV_BAD_DPI : ErrorInfo
  • KMC_EV_BAD_FILE_FORMAT : ErrorInfo
  • KMC_EV_BAD_LINEWIDTH : ErrorInfo
  • KMC_EV_BAD_WIDTH_HEIGHT : ErrorInfo
  • KMC_EV_BARCODE_DRIVER : ErrorInfo
  • KMC_EV_CANCEL_OPERATION_SUCCESS : ErrorInfo
  • KMC_EV_CANNOT_APPEND : ErrorInfo
  • KMC_EV_EXTERNAL_PAGE : ErrorInfo
  • KMC_EV_FILE_IO_ACCESS_BUSY : ErrorInfo
  • KMC_EV_FILE_METADATA : ErrorInfo
  • KMC_EV_FILE_READ_FAILED : ErrorInfo
  • KMC_EV_FILEOPEN : ErrorInfo
  • KMC_EV_HISTOGRAM : ErrorInfo
  • KMC_EV_IMAGE_PARM : ErrorInfo
  • KMC_EV_IMAGE_PROCESSING : ErrorInfo
  • KMC_EV_IMAGE_WRITE_FAILED : ErrorInfo
  • KMC_EV_INVALID_HANDLE : ErrorInfo
  • KMC_EV_INVALID_POINTER : ErrorInfo
  • KMC_EV_LICENSE_ALREADY_SET : ErrorInfo
  • KMC_EV_LICENSE_EXPIRED : ErrorInfo
  • KMC_EV_LICENSING : ErrorInfo
  • KMC_EV_LOCK_CREATION_ERROR : ErrorInfo
  • KMC_EV_MEMORY : ErrorInfo
  • KMC_EV_METADATA_OVERFLOW : ErrorInfo
  • KMC_EV_NETWORK_READ : ErrorInfo
  • KMC_EV_NONEXISTANT_IMAGE : ErrorInfo
  • KMC_EV_OP_STRING_ERROR : ErrorInfo
  • KMC_EV_PDF_BAD : ErrorInfo
  • KMC_EV_PDF_TOO_LARGE : ErrorInfo
  • KMC_EV_PROCESS_PAGE_BUSY : ErrorInfo
  • KMC_EV_SPEED_ACCURACY : ErrorInfo
  • KMC_EV_UNKNOWN_FILETYPE : ErrorInfo
  • KMC_EV_UNKNOWN_VARIANT : ErrorInfo
  • KMC_EV_UNSUPPORTED_BITMAP_FORMAT : ErrorInfo
  • KMC_EX_PASSPORT_MRZ_DATA_NOT_FOUND : ErrorInfo
  • KMC_GN_BAD_APPLICATION_CONTEXT : ErrorInfo
  • KMC_GN_DESERIALIZE_OBJECT_ERROR : ErrorInfo
  • KMC_GN_DESERIALIZE_VERSION_ERROR : ErrorInfo
  • KMC_GN_FILE_NOT_FOUND : ErrorInfo
  • KMC_GN_FILE_NOT_FOUND_EXCEPTION : ErrorInfo
  • KMC_GN_ILLEGAL_ARGUMENT_EXCEPTION : ErrorInfo
  • KMC_GN_ILLEGAL_THREAD_STATE_EXCEPTION : ErrorInfo
  • KMC_GN_INTERNAL_ERROR : ErrorInfo
  • KMC_GN_IO_EXCEPTION : ErrorInfo
  • KMC_GN_LOGIN_NOT_APPLICABLE : ErrorInfo
  • KMC_GN_NULL_POINTER_EXCEPTION : ErrorInfo
  • KMC_GN_OUT_OF_MEMORY : ErrorInfo
  • KMC_GN_PARAM_NEGATIVE : ErrorInfo
  • KMC_GN_SESSION_CREATE_ERROR : ErrorInfo
  • KMC_GN_SESSION_DISMISS_ERROR : ErrorInfo
  • KMC_GN_UNKNOWN_ERROR : ErrorInfo
  • KMC_GN_UNSUPPORTED_OPERATION : ErrorInfo
  • KMC_IP_FILE_AND_BUFFERED_REPRESENTATION : ErrorInfo
  • KMC_IP_LICENSE_ALREADY_SET : ErrorInfo
  • KMC_IP_LICENSE_EXPIRED : ErrorInfo
  • KMC_IP_LICENSE_INVALID : ErrorInfo
  • KMC_IP_NO_CONFIGURATION : ErrorInfo
  • KMC_IP_NO_PROFILE : ErrorInfo
  • KMC_IP_NO_REPRESENTATION : ErrorInfo
  • KMC_LO_DEVICE_REG_LICENSING_ERROR : ErrorInfo
  • KMC_LO_DOMAIN : ErrorInfo
  • KMC_LO_DOWNLOAD_DOCUMENT_FIELDS_ERROR : ErrorInfo
  • KMC_LO_DOWNLOAD_DOCUMENT_SCAN_SETTINGS_ERROR : ErrorInfo
  • KMC_LO_EMAIL : ErrorInfo
  • KMC_LO_EVENT_LOCK_ACQUIRE_ERROR : ErrorInfo
  • KMC_LO_IMAGE_NOT_FOUND : ErrorInfo
  • KMC_LO_INVALID_CERTIFICATE : ErrorInfo
  • KMC_LO_INVALID_DOCUMENT_TYPE_NAME : ErrorInfo
  • KMC_LO_INVALID_SERVER_URL : ErrorInfo
  • KMC_LO_INVALID_SESSION_STATE : ErrorInfo
  • KMC_LO_INVALID_SESSION_STATE_TRANSITION : ErrorInfo
  • KMC_LO_LOGIN_NOT_ALLOWED : ErrorInfo
  • KMC_LO_NO_OPERATION_TO_CANCEL : ErrorInfo
  • KMC_LO_NOT_LOGGED_IN : ErrorInfo
  • KMC_LO_NOT_REGISTERED : ErrorInfo
  • KMC_LO_OPERATION_CANCEL_ERROR : ErrorInfo
  • KMC_LO_OPERATION_CANCELLED : ErrorInfo
  • KMC_LO_OPERATION_NOT_CANCELLABLE : ErrorInfo
  • KMC_LO_OVERLAPPED_OPERATIONS : ErrorInfo
  • KMC_LO_PAGE_IMAGE_INDEX_INVALID : ErrorInfo
  • KMC_LO_PAGE_NOT_FOUND : ErrorInfo
  • KMC_LO_REGISTER_REQUIRES_AUTH : ErrorInfo
  • KMC_LO_REGISTERING : ErrorInfo
  • KMC_LO_REGISTERING_NOT_ALLOWED : ErrorInfo
  • KMC_LO_REQUEST_TIMEOUT : ErrorInfo
  • KMC_LO_SERVER_TIMEOUT : ErrorInfo
  • KMC_LO_SERVER_URL_NOT_SET : ErrorInfo
  • KMC_LO_SESSION_STATE_BUSY : ErrorInfo
  • KMC_LO_START_SUBMIT_INVALID_JOB_ID : ErrorInfo
  • KMC_LO_START_SUBMIT_JOB_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_BITMAP : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_FILE_CLOSE_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_FILEIO_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_IMAGE_FILE_MISSING : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_IMAGE_REP_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_IMAGES_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_MIMETYPE_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_DOCUMENT_NO_IMAGE_ERROR : ErrorInfo
  • KMC_LO_SUBMIT_PNG : ErrorInfo
  • KMC_LO_TASK_LOCK_ACQUIRE_ERROR : ErrorInfo
  • KMC_LO_USER_ALREADY_LOGGED_IN : ErrorInfo
  • KMC_LO_USER_ALREADY_LOGGED_OUT : ErrorInfo
  • KMC_LO_USER_LOGGING_IN_ON_LOGIN : ErrorInfo
  • KMC_LO_USER_LOGGING_OUT_ON_LOGOUT : ErrorInfo
  • KMC_LO_USER_LOGIN_ERROR : ErrorInfo
  • KMC_LO_USER_LOGOUT_ERROR : ErrorInfo
  • KMC_LO_USER_NOT_LOGGED_IN_ON_LOGOUT : ErrorInfo
  • KMC_LO_USERNAME_NOT_SET : ErrorInfo
  • KMC_OCR_ID_REGION_NOT_SET : ErrorInfo
  • KMC_OCR_INVALID_BITMAP_SIZE : ErrorInfo
  • KMC_SUCCESS : ErrorInfo
  • KMC_UI_CAMERA_ALREADY_OPEN : ErrorInfo
  • KMC_UI_CAMERA_LOCK_ACQUIRE_FAILURE : ErrorInfo
  • KMC_UI_CAMERA_OPERATION_FAILURE : ErrorInfo
  • KMC_UI_CREDITCARD_ARCH_NOT_SUPPORTED : ErrorInfo
  • KMC_UI_FLASH_AUTO_NOT_SUPPORTED : ErrorInfo
  • KMC_UI_FLASH_OFF_NOT_SUPPORTED : ErrorInfo
  • KMC_UI_FLASH_ON_NOT_SUPPORTED : ErrorInfo
  • KMC_UI_FLASH_TORCH_NOT_SUPPORTED : ErrorInfo
  • KMC_UI_FOCUS_AREA_COUNT : ErrorInfo
  • KMC_UI_FOCUS_AREA_EMPTY : ErrorInfo
  • KMC_UI_FOCUS_AREA_INVALID : ErrorInfo
  • KMC_UI_FOCUS_AREA_NOT_SUPPORTED : ErrorInfo
  • KMC_UI_IMAGE_NULL : ErrorInfo
  • KMC_UI_INVALID_ASPECT_RATIO_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_AXIS_THRESHOLD_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_BORDER_THICKNESS_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_DECLINATION_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_HEIGHT_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_PADDING_PERCENTAGE_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_PAGE_THRESHOLD_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_STABILITY_DELAY_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_THRESHOLD_ARGUMENT : ErrorInfo
  • KMC_UI_INVALID_WIDTH_ARGUMENT : ErrorInfo
  • KMC_UI_ODE_NOT_SUPPORTED_FOR_THE_DOCUMENT_TYPE : ErrorInfo
  • KMC_UI_SCALING_FACTOR : ErrorInfo
  • KMC_UI_VIEW_NULL : ErrorInfo
  • KMC_UT_GOOGLE_PLAY_SERVICES_REPAIRABLE : ErrorInfo
  • KMC_UT_LICENSE_BARCODE_CAPTURE : ErrorInfo
  • KMC_UT_LICENSE_ID_EXTRACTION : ErrorInfo
  • KMC_UT_LICENSE_IMAGE_CAPTURE : ErrorInfo
  • KMC_UT_LICENSE_IMAGE_PROCESSING : ErrorInfo
  • KMC_UT_LICENSE_LOGISTICS : ErrorInfo
  • KMC_UT_LICENSING_FEATURE_NOT_LICENSED : ErrorInfo
  • KMC_UT_LICENSING_INVALID_SERVER_RESPONSE : ErrorInfo
  • KMC_UT_LICENSING_NETWORK_EXCEPTION : ErrorInfo
  • KMC_UT_LICENSING_NOT_VOLUME_LICENSE : ErrorInfo
  • KMC_UT_LICENSING_NULL_LICENSE_SERVER : ErrorInfo
  • KMC_UT_LICENSING_NULL_LICENSE_SERVER_TYPE : ErrorInfo
  • KMC_UT_LICENSING_NULL_LICENSE_TYPE : ErrorInfo
  • KMC_UT_OUT_OF_VOLUME_LICENSE : ErrorInfo
  • KMC_UT_STATS_ALREADY_EXPORTING : ErrorInfo
  • KMC_UT_STATS_ALREADY_RECORDING : ErrorInfo
  • KMC_UT_STATS_ALREADY_WRITING : ErrorInfo
  • KMC_UT_STATS_BEGIN_SESSION_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_DATASTORE_NO_UPGRADE_PATH : ErrorInfo
  • KMC_UT_STATS_DATASTORE_OUT_OF_DATE : ErrorInfo
  • KMC_UT_STATS_DATASTORE_UPGRADE_FAILED : ErrorInfo
  • KMC_UT_STATS_DATASTORE_UPGRADE_MISSING_FILE : ErrorInfo
  • KMC_UT_STATS_DATASTORE_UPGRADE_NOT_NEEDED : ErrorInfo
  • KMC_UT_STATS_DATASTORE_UPGRADE_WRONG_STATE : ErrorInfo
  • KMC_UT_STATS_DEVICE_ID_MISSING : ErrorInfo
  • KMC_UT_STATS_END_SESSION_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_EVENT_THROTTLED : ErrorInfo
  • KMC_UT_STATS_EXPORT_HANDLER_MISSING : ErrorInfo
  • KMC_UT_STATS_EXPORT_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_FILEPATH_IS_NULL : ErrorInfo
  • KMC_UT_STATS_INIT_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_INVALID_JSON : ErrorInfo
  • KMC_UT_STATS_INVALID_STATE_TRANSITION : ErrorInfo
  • KMC_UT_STATS_LOG_SESSION_EVENT_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_NO_SESSION_BEGUN : ErrorInfo
  • KMC_UT_STATS_NOTHING_TO_EXPORT : ErrorInfo
  • KMC_UT_STATS_NOTHING_TO_PURGE : ErrorInfo
  • KMC_UT_STATS_PURGE_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_RECORD_AND_WRITING_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_RECORD_NOT_ALLOWED : ErrorInfo
  • KMC_UT_STATS_RECORDING_NOT_OFF : ErrorInfo
  • KMC_UT_STATS_RECORDING_NOT_ON : ErrorInfo
  • KMC_UT_STATS_SESSION_ALREADY_BEGUN : ErrorInfo
  • KMC_UT_STATS_STATE_BUSY : ErrorInfo
  • KMC_UT_STATS_UNINITIALIZED : ErrorInfo
  • KMC_UT_STATS_WRITING_NOT_ALLOWED : ErrorInfo
  • KTA : ExtractionParameters.ExtractionType , ServerBuilder.ServerType


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- l -

  • LANDSCAPE : CaptureMessage.KUIMessageOrientation , GuidingLine
  • LATIN_AMERICA : IdRegion
  • LATIN_AMERICA_OTHER : IdParameters.IdState
  • LEFT : BoundingTetragon.Rotation
  • LEFT_RIGHT : BarCodeReader.Direction , BarCodeDirection
  • licenseType : Licensing.VolumeLicenseFailureData , Licensing.VolumeLicenseResultData
  • LINE_STYLE_DOTTED : ImgReviewEditCntrl.Line_Style_Solid
  • LINE_STYLE_SOLID : ImgReviewEditCntrl.Line_Style_Solid
  • LITHUANIA : IdParameters.IdState
  • LOGISTICS : Licensing.LicenseType
  • LUXEMBOURG : IdParameters.IdState


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- m -

  • manualCaptureTimer : LookAndFeelParameters
  • MAX_JPEG_QUALITY : Image
  • MAX_SCALING_FACTOR : Image
  • MEMORY : ImageCacheType
  • Message : ServerProjectProvider.Error
  • message : ServerProjectProvider.Error
  • MIMETYPE_JPEG : Image.ImageMimeType
  • MIMETYPE_PNG : Image.ImageMimeType
  • MIMETYPE_TIFF : Image.ImageMimeType
  • MIMETYPE_UNKNOWN : Image.ImageMimeType
  • MIN_DPI_VALUE : Image
  • MIN_JPEG_QUALITY : Image
  • MIN_SCALING_FACTOR : Image


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- n -

  • NEVER_USE : GpsUsageLimits
  • NO_IMAGE_CAPTURED : CaptureActivity
  • NONE : CheckSide , Image.FileRestriction , MicrLine.CheckType
  • NOT_SPECIFIED : CheckParameters.CheckCountry , IdParameters.IdState


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- o -

  • ODE_CACHE : BundleCacheProvider
  • OFF : ImagePerfectionProfile.UseDocumentDetectionBasedCrop , ImagePerfectionProfile.UseMRZPassportDetection , ImagePerfectionProfile.UseTargetFrameCrop , Flash , GuidingLine , ExtractionParameters.ExtractionType , LookAndFeelParameters.TorchMode , ProcessingParameters.ProcessingType
  • ON : ImagePerfectionProfile.UseDocumentDetectionBasedCrop , ImagePerfectionProfile.UseMRZPassportDetection , ImagePerfectionProfile.UseTargetFrameCrop , Flash , LookAndFeelParameters.TorchMode
  • ON_DEVICE : ExtractionParameters.ExtractionType , ProcessingParameters.ProcessingType
  • operations : ProcessingParameters
  • ORIENTATION_CHANGE : OrientationGuidance
  • ORIENTATION_OK : OrientationGuidance
  • origin : FieldLocation
  • outputColorDepth : ImageProcessorConfiguration
  • outputDPI : ImageProcessorConfiguration


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- p -

  • Passport : IdType
  • PASSPORT_EXCEPTION : PassportWorkflowActivity
  • PASSPORT_EXTRACT : PassportExtractActivity
  • PASSPORT_EXTRACT_KTA : PassportExtractor
  • PASSPORT_EXTRACT_ON_DEVICE : PassportExtractor
  • PASSPORT_EXTRACT_RTTI : PassportExtractor
  • PASSPORT_PARAMETERS : PassportWorkflowActivity
  • PASSPORT_RESULTS : PassportWorkflowActivity
  • password : ExtractionCredentials
  • Pdf417 : BarCodeReader.Symbology
  • PDF417 : BarCodeType , Symbology
  • PERSONAL_CHECK : MicrLine.CheckType
  • PORTRAIT : CaptureMessage.KUIMessageOrientation , GuidingLine
  • Postnet : BarCodeReader.Symbology
  • POSTNET : BarCodeType
  • PREPROCESS_ID2_STRING : IdExtractionParameters
  • PREPROCESS_PASSPORT_STRING : IdExtractionParameters
  • PREPROCESS_STRING : IdExtractionParameters
  • processedImageId : CaptureData
  • processingType : ProcessingParameters
  • PROCESSOR : ImageSource


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- q -

  • QR : BarCodeType , Symbology
  • QRCode : BarCodeReader.Symbology


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- r -

  • region : IdParameters.IdState
  • RESULT_CODE : CaptureActivity
  • resultCode : Licensing.VolumeLicenseFailureData , Licensing.VolumeLicenseResultData
  • results : ExtractorResponse< T extends Serializable >
  • REVERSELANDSCAPE : CaptureMessage.KUIMessageOrientation
  • REVERSEPORTRAIT : CaptureMessage.KUIMessageOrientation
  • reverseSideCheck : CheckParameters
  • reverseSideId : IdParameters
  • reviewCapturedImage : LookAndFeelParameters
  • reviewProcessedImage : LookAndFeelParameters
  • RIGHT : BoundingTetragon.Rotation
  • RIGHT_LEFT : BarCodeReader.Direction , BarCodeDirection
  • ROTATE_180 : BasicSettingsProfile.RotateType , RotateType
  • ROTATE_270 : BasicSettingsProfile.RotateType , RotateType
  • ROTATE_90 : BasicSettingsProfile.RotateType , RotateType
  • ROTATE_AUTO : BasicSettingsProfile.RotateType , RotateType
  • ROTATE_NONE : BasicSettingsProfile.RotateType , RotateType
  • rotateType : ImageProcessorConfiguration
  • RTTI : Licensing.LicenseServerType , ExtractionParameters.ExtractionType , ServerBuilder.ServerType


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- s -

  • scaleGestureDetector : ImgReviewEditCntrl
  • sdkMajor : LocalProjectProvider.VersionTable.VersionList
  • sdkMinor : LocalProjectProvider.VersionTable.VersionList
  • SERVER_KFS : DocumentType.SourceServer
  • SERVER_KTA : DocumentType.SourceServer
  • SERVER_NONE : DocumentType.SourceServer
  • serverUrl : ExtractionParameters
  • SESSION_DOCUMENT_TYPE_READY : SessionState
  • SESSION_GETTING_DOCUMENT_FIELDS : SessionState
  • SESSION_GETTING_IP_SETTINGS : SessionState
  • SESSION_LOGGED_IN : SessionState
  • SESSION_LOGGING_IN : SessionState
  • SESSION_LOGGING_OUT : SessionState
  • SESSION_PREPARING_DOCUMENT_TYPE : SessionState
  • SESSION_REGISTERED : SessionState
  • SESSION_REGISTERING : SessionState
  • SESSION_SUBMIT_COMPLETED : SessionState
  • SESSION_SUBMITTING : SessionState
  • SESSION_UNREGISTERED : SessionState
  • sessionId : ExtractionCredentials
  • side : CheckParameters , IdParameters
  • SINGAPORE : CheckParameters.CheckCountry , IdParameters.IdState
  • size : FieldLocation
  • SOUTH_KOREA : IdParameters.IdState
  • ST_CHRIST_NEVIS : IdParameters.IdState
  • state : IdParameters
  • stateID : SessionState
  • STRING : FieldType.DataType


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- t -

  • TARGET_FRAME_CROP_OFF : TargetFrameCropType
  • TARGET_FRAME_CROP_ON : TargetFrameCropType
  • targetFrameCropType : ImageProcessorConfiguration
  • THRESH_TYPE_FILE : AppStatistics.ThresholdType
  • THRESH_TYPE_RAM : AppStatistics.ThresholdType
  • TOP_DOWN : BarCodeReader.Direction , BarCodeDirection
  • TORCH : Flash
  • torch : LookAndFeelParameters
  • TotalAgility : Licensing.LicenseServerType
  • TURN_CLOCKWISE : TurnGuidance
  • TURN_COUNTER_CLOCKWISE : TurnGuidance
  • TURN_OK : TurnGuidance
  • type : RotateType


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- u -

  • UI_THREAD : ListenerCallbackThreadType
  • UNDEFINED : FieldLocation
  • UNITED_KINGDOM : CheckParameters.CheckCountry
  • UNITED_STATES : CheckParameters.CheckCountry , IdParameters.IdState
  • UNKNOWN : BarCodeDataFormat , BarCodeDirection , BarCodeType , CaptureMessage.KUIMessageOrientation
  • Upc : BarCodeReader.Symbology
  • UPC : BarCodeType , Symbology
  • URL : FieldType.DataType
  • US : IdRegion
  • useMrzPageDetection : ProcessingParameters
  • username : ExtractionCredentials
  • useTargetFrameCrop : ProcessingParameters


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- v -

  • VersionList : LocalProjectProvider.VersionTable
  • VERTICAL : SearchDirection
  • VERTICAL_MOVE_DOWN : VerticalGuidance
  • VERTICAL_MOVE_OK : VerticalGuidance
  • VERTICAL_MOVE_UP : VerticalGuidance


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- w -

  • width : Size , SizeDouble
  • WORKER_THREAD : ListenerCallbackThreadType
  • WRITE_STATUS_COMPLETE : AppStatsWriteFileListener.WriteFileStatus
  • WRITE_STATUS_FAILED : AppStatsWriteFileListener.WriteFileStatus
  • WRITE_STATUS_WRITING : AppStatsWriteFileListener.WriteFileStatus


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- x -

  • x : PointDouble


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- y -

  • y : PointDouble


Kofax Mobile SDK API Reference: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- z -

  • ZOOM_IN : ZoomGuidance
  • ZOOM_OK : ZoomGuidance
  • ZOOM_OUT : ZoomGuidance


Kofax Mobile SDK API Reference: File List

  • File List
File List
Here is a list of all files with brief descriptions:
AggregateException.java
AppContextProvider.java
ApplicationContextImageStore.java
AppStatistics.java
AppStatsDaoField.java
AppStatsDsExportHandler.java
AppStatsExportEvent.java
AppStatsExportListener.java
AppStatsSessionEvent.java
AppStatsThresholdReachedEvent.java
AppstatsThresholdReachedListener.java
AppStatsWriteFileListener.java
AppStatsWritetoFileEvent.java
AppStatsWriteToFileResults.java
AutoFocusResultEvent.java
AutoFocusResultListener.java
BarCodeCaptureView.java
BarCodeDataFormat.java
BarCodeDirection.java
BarCodeFoundEvent.java
BarCodeFoundListener.java
BarCodeReader.java
BarCodeResult.java
BarCodeType.java
BasicSettingsProfile.java
Bill.java
BillCaptureActivity.java
BillExtractActivity.java
BillExtractor.java
BillExtractorResponse.java
BillParameters.java
BillWorkflowActivity.java
BoundingRect.java
BoundingTetragon.java
BundleCacheProvider.java
CameraInitializationEvent.java
CameraInitializationFailedEvent.java
CameraInitializationFailedListener.java
CameraInitializationListener.java
CameraType.java
CaptureActivity.java
CaptureData.java
CaptureExperience.java
CaptureExperienceCriteriaHolder.java
CaptureMessage.java
CaptureServer.java
CardIoWrapperActivity.java
CertificateValidatorListener.java
Check.java
CheckCaptureActivity.java
CheckCaptureExperience.java
CheckCaptureExperienceCriteriaHolder.java
CheckDetectionResult.java
CheckDetectionSettings.java
CheckDetector.java
CheckExtractActivity.java
CheckExtractor.java
CheckExtractorResponse.java
CheckIQAData.java
CheckParameters.java
CheckSide.java
CheckUsabilityData.java
CheckWorkflowActivity.java
ClassificationResult.java
ColorDepth.java
ContextImageStorage.java
id/ConventionBasedJsonIdDeserializer.java
passport/ConventionBasedJsonIdDeserializer.java
CreditCard.java
CreditCardParameters.java
CreditCardWorkflowActivity.java
CropType.java
DataField.java
DeskewType.java
DetectionResult.java
DetectionSettings.java
Document.java
DocumentBaseCaptureExperience.java
DocumentBaseCaptureExperienceCriteriaHolder.java
DocumentCaptureExperience.java
DocumentCaptureExperienceCriteriaHolder.java
DocumentDetectionResult.java
DocumentDetectionSettings.java
DocumentDetector.java
DocumentDimensions.java
DocumentType.java
DocumentTypeR.java
ErrorInfo.java
ExceptionResponse.java
ExceptionResponseImpl.java
ExtractActivity.java
ExtractionCredentials.java
ExtractionParameters.java
ExtractionServerException.java
Extractor.java
ExtractorResponse.java
kmc/klo/logistics/data/Field.java
mobile/sdk/capture/model/Field.java
FieldLocation.java
FieldType.java
FixedAspectRatioCaptureExperience.java
FixedAspectRatioDetectionSettings.java
FixedAspectRatioExperienceCriteriaHolder.java
Flash.java
GpsUsageLimits.java
GuidingLine.java
HorizontalGuidance.java
IBillDeserializer.java
IBillExtractorListener.java
IBundle.java
IBundleCacheProvider.java
IBundleFile.java
ICaptureServer.java
ICheckDeserializer.java
ICheckDetector.java
ICheckExtractionServer.java
ICheckExtractorListener.java
ICompletionListener.java
Id.java
IdCaptureActivity.java
IdCaptureBackActivity.java
IdExtractActivity.java
IdExtractionParameters.java
IdExtractor.java
IdExtractorResponse.java
IDocumentDetector.java
IdParameters.java
IdRegion.java
IdType.java
IdWorkflowActivity.java
IExtractorListener.java
IIdDeserializer.java
IIdExtractionListener.java
IIdExtractionResult.java
IIdExtractionServer.java
IIdExtractor.java
IIdExtractorListener.java
IImageProcessor.java
IImageProcessorListener.java
IImageStorage.java
Image.java
ImageCacheType.java
ImageCapturedEvent.java
ImageCapturedListener.java
ImageCaptureView.java
ImageClassificationCompletedListener.java
ImageClassificationCompleteEvent.java
ImageClassificationResult.java
ImageClassifier.java
ImagePerfectionProfile.java
ImageProcessor.java
ImageProcessorConfiguration.java
ImageReviewActivity.java
ImageSource.java
ImgReviewEditCntrl.java
IParameters.java
IPassportDeserializer.java
IPassportDetector.java
IPassportExtractorListener.java
IProgressListener.java
IProjectProvider.java
IServerExtractor.java
KENLogging.java
KenVersion.java
KLOLogging.java
KloVersion.java
KmcException.java
KmcRuntimeException.java
KtaBillExtractor.java
KtaCheckExtractor.java
KtaIdExtractor.java
KtaJsonBill.java
KtaJsonCheck.java
KtaJsonPassport.java
KtaPassportExtractor.java
KUILogging.java
KuiVersion.java
KUTLogging.java
KutVersion.java
LevelnessEvent.java
LevelnessListener.java
LicenseCaptureView.java
LicenseFoundEvent.java
LicenseFoundListener.java
Licensing.java
ListenerCallbackThreadType.java
ListOfException.java
LocalProjectProvider.java
Logging.java
LoginCredentials.java
LookAndFeelParameters.java
mainpage.h
MicrLine.java
MicrParser.java
OnDeviceIdExtractor.java
OrientationGuidance.java
Page.java
PageDetectionEvent.java
PageDetectionListener.java
Passport.java
PassportCaptureActivity.java
PassportCaptureExperience.java
PassportCaptureExperienceCriteriaHolder.java
PassportDetectionResult.java
PassportDetectionSettings.java
PassportDetector.java
PassportExtractActivity.java
PassportExtractor.java
PassportExtractorResponse.java
PassportParameters.java
PassportWorkflowActivity.java
PointDouble.java
PreviewCallbackListener.java
PreviewFrameEvent.java
ProcessActivity.java
ProcessingParameters.java
ProjectProviderException.java
QuickAnalysisFeedback.java
QuickAnalysisSettings.java
RotateType.java
RttiBillExtractor.java
RttiCheckExtractor.java
RttiIdExtractor.java
RttiJsonBill.java
RttiJsonCheck.java
RttiJsonPassport.java
RttiPassportExtractor.java
SdkVersion.java
SearchDirection.java
SelfieBaseCaptureExperience.java
SelfieCaptureExperience.java
SelfieCaptureExperienceCriteriaHolder.java
SelfieDetectionSettings.java
ServerBuilder.java
ServerExtractionParameters.java
ServerProjectProvider.java
SessionState.java
Size.java
SizeDouble.java
StabilityDelayEvent.java
StabilityDelayListener.java
Symbology.java
TargetFrameCropType.java
TimeOutParameters.java
TorchLuminanceEvent.java
TorchLuminanceListener.java
TurnGuidance.java
UserProfile.java
VerticalGuidance.java
WorkflowActivity.java
ZipFileBundle.java
ZipInputStreamBundle.java
ZoomGuidance.java


Kofax Mobile SDK API Reference: AggregateException.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
AggregateException.java File Reference

Classes

class AggregateException

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: AppContextProvider.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
Classes | Packages
AppContextProvider.java File Reference

Classes

class AppContextProvider
This class keeps a reference of the application context. More...

Packages

package com.kofax.kmc.kut.utilities


Kofax Mobile SDK API Reference: ApplicationContextImageStore.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
Classes | Packages
ApplicationContextImageStore.java File Reference

Classes

class ApplicationContextImageStore

Packages

package com.kofax.mobile.sdk.capture


Kofax Mobile SDK API Reference: AppStatistics.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • appstats
Classes | Packages
AppStatistics.java File Reference

Classes

class | AppStatistics
Use the AppStatistics class for creating, saving, and exporting statistics related to SDK framework usage. More...
enum | AppStatistics.ThresholdType
enum | AppStatistics.ExportStatusEvent
enum | AppStatistics.AppStatsExportFormat
Indicates the export format desired when calling the export method. More...

Packages

package com.kofax.kmc.kut.utilities.appstats


Kofax Mobile SDK API Reference: AppStatsDaoField.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • appstats
Classes | Packages
AppStatsDaoField.java File Reference

Classes

class AppStatsDaoField
Container for properties that define one field in a table in the datastore. More...

Packages

package com.kofax.kmc.kut.utilities.appstats


Kofax Mobile SDK API Reference: AppStatsDsExportHandler.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • appstats
Classes | Packages
AppStatsDsExportHandler.java File Reference

Classes

interface AppStatsDsExportHandler

Packages

package com.kofax.kmc.kut.utilities.appstats


Kofax Mobile SDK API Reference: AppStatsExportEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • appstats
Classes | Packages
AppStatsExportEvent.java File Reference

Classes

class AppStatsExportEvent
This event is fired when AppStats events are being exported. More...

Packages

package com.kofax.kmc.kut.utilities.appstats


Kofax Mobile SDK API Reference: AppStatsExportListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • appstats
Classes | Packages
AppStatsExportListener.java File Reference

Classes

interface | AppStatsExportListener
enum | AppStatsExportListener.ExportStatus

Packages

package com.kofax.kmc.kut.utilities.appstats


Kofax Mobile SDK API Reference: AppStatsSessionEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • appstats
Classes | Packages
AppStatsSessionEvent.java File Reference

Classes

class AppStatsSessionEvent
This data-only class is used to set properties that define an AppStats Session Event. More...

Packages

package com.kofax.kmc.kut.utilities.appstats


Kofax Mobile SDK API Reference: AppStatsThresholdReachedEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • appstats
Classes | Packages
AppStatsThresholdReachedEvent.java File Reference

Classes

class AppStatsThresholdReachedEvent

Packages

package com.kofax.kmc.kut.utilities.appstats


Kofax Mobile SDK API Reference: AppstatsThresholdReachedListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • appstats
Classes | Packages
AppstatsThresholdReachedListener.java File Reference

Classes

interface AppstatsThresholdReachedListener

Packages

package com.kofax.kmc.kut.utilities.appstats


Kofax Mobile SDK API Reference: AppStatsWriteFileListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • appstats
Classes | Packages
AppStatsWriteFileListener.java File Reference

Classes

interface | AppStatsWriteFileListener
enum | AppStatsWriteFileListener.WriteFileStatus

Packages

package com.kofax.kmc.kut.utilities.appstats


Kofax Mobile SDK API Reference: AppStatsWritetoFileEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • appstats
Classes | Packages
AppStatsWritetoFileEvent.java File Reference

Classes

class AppStatsWritetoFileEvent

Packages

package com.kofax.kmc.kut.utilities.appstats


Kofax Mobile SDK API Reference: AppStatsWriteToFileResults.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • appstats
Classes | Packages
AppStatsWriteToFileResults.java File Reference

Classes

class AppStatsWriteToFileResults

Packages

package com.kofax.kmc.kut.utilities.appstats


Kofax Mobile SDK API Reference: AutoFocusResultEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
AutoFocusResultEvent.java File Reference

Classes

class AutoFocusResultEvent
This event returns the result of the camera's attempt to auto focus. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: AutoFocusResultListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
AutoFocusResultListener.java File Reference

Classes

interface AutoFocusResultListener
The listener interface for responding to camera focus events. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: BarCodeCaptureView.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
BarCodeCaptureView.java File Reference

Classes

class | BarCodeCaptureView
class | BarCodeCaptureView.DecodeInfo
class | BarCodeCaptureView.CameraImageData

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: BarCodeDataFormat.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
BarCodeDataFormat.java File Reference

Classes

enum BarCodeDataFormat
An enum that identifies the format of the bar code found. More...

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: BarCodeDirection.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
BarCodeDirection.java File Reference

Classes

enum BarCodeDirection
An enum that identifies the direction of the bar code found. More...

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: BarCodeFoundEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
BarCodeFoundEvent.java File Reference

Classes

class BarCodeFoundEvent
An event that indicates a barcode has been found. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: BarCodeFoundListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
BarCodeFoundListener.java File Reference

Classes

interface BarCodeFoundListener
The listener interface for receiving barcode events. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: BarCodeReader.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
Classes | Packages
BarCodeReader.java File Reference

Classes

class | BarCodeReader
The barcode recognition engine. More...
interface | BarCodeReader.BarcodeReadCompleteListener
class | BarCodeReader.BarcodeReadCompleteEvent
enum | BarCodeReader.Symbology
enum | BarCodeReader.Direction

Packages

package com.kofax.kmc.ken.engines


Kofax Mobile SDK API Reference: BarCodeResult.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
BarCodeResult.java File Reference

Classes

class BarCodeResult
A single bar code found data item. This object is serializable. More...

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: BarCodeType.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
BarCodeType.java File Reference

Classes

enum BarCodeType
An enum that identifies the type of the bar code found. More...

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: BasicSettingsProfile.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
BasicSettingsProfile.java File Reference

Classes

class | BasicSettingsProfile
The BasicSettingsProfile specifies basic image processing options. This object is serializable. More...
enum | BasicSettingsProfile.RotateType
An enum which identifies the rotation type. More...
enum | BasicSettingsProfile.CropType
An enum which identifies the crop type. More...
enum | BasicSettingsProfile.OutputBitDepth
An enum which identifies the output bit depth. More...

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: Bill.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • model
Classes | Packages
Bill.java File Reference

Classes

class Bill

Packages

package com.kofax.mobile.sdk.capture.model


Kofax Mobile SDK API Reference: BillCaptureActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • bill
Classes | Packages
BillCaptureActivity.java File Reference

Classes

class BillCaptureActivity

Packages

package com.kofax.mobile.sdk.capture.bill


Kofax Mobile SDK API Reference: BillExtractActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • bill
Classes | Packages
BillExtractActivity.java File Reference

Classes

class BillExtractActivity

Packages

package com.kofax.mobile.sdk.capture.bill


Kofax Mobile SDK API Reference: BillExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • bill
Classes | Packages
BillExtractor.java File Reference

Classes

class BillExtractor

Packages

package com.kofax.mobile.sdk.capture.bill


Kofax Mobile SDK API Reference: BillExtractorResponse.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • bill
Classes | Packages
BillExtractorResponse.java File Reference

Classes

class BillExtractorResponse

Packages

package com.kofax.mobile.sdk.capture.bill


Kofax Mobile SDK API Reference: BillParameters.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • bill
Classes | Packages
BillParameters.java File Reference

Classes

class BillParameters

Packages

package com.kofax.mobile.sdk.capture.bill


Kofax Mobile SDK API Reference: BillWorkflowActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • bill
Classes | Packages
BillWorkflowActivity.java File Reference

Classes

class BillWorkflowActivity

Packages

package com.kofax.mobile.sdk.capture.bill


Kofax Mobile SDK API Reference: BoundingRect.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
BoundingRect.java File Reference

Classes

class BoundingRect
The BoundingRect object holds four integer edge coordinates for a rectangle. More...

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: BoundingTetragon.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
BoundingTetragon.java File Reference

Classes

class | BoundingTetragon
The BoundingTetragon object holds four corner points for a tetragon. This object is serializable. More...
enum | BoundingTetragon.Rotation

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: BundleCacheProvider.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
  • bundle
Classes | Packages
BundleCacheProvider.java File Reference

Classes

class BundleCacheProvider

Packages

package com.kofax.mobile.sdk.extract.id.bundle


Kofax Mobile SDK API Reference: CameraInitializationEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
CameraInitializationEvent.java File Reference

Classes

class | CameraInitializationEvent
This event fires when the camera is initialized or reinitialized. More...
enum | CameraInitializationEvent.CameraInitStatus

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: CameraInitializationFailedEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
CameraInitializationFailedEvent.java File Reference

Classes

class CameraInitializationFailedEvent

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: CameraInitializationFailedListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
CameraInitializationFailedListener.java File Reference

Classes

interface CameraInitializationFailedListener

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: CameraInitializationListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
CameraInitializationListener.java File Reference

Classes

interface CameraInitializationListener
The interface that is required to implement CameraInitializationEvent. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: CameraType.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • data
Classes | Packages
CameraType.java File Reference

Classes

enum CameraType
This enum represents the camera type. More...

Packages

package com.kofax.kmc.kui.uicontrols.data


Kofax Mobile SDK API Reference: CaptureActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
Classes | Packages
CaptureActivity.java File Reference

Classes

class CaptureActivity

Packages

package com.kofax.mobile.sdk.capture


Kofax Mobile SDK API Reference: CaptureData.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • model
Classes | Packages
CaptureData.java File Reference

Classes

class CaptureData

Packages

package com.kofax.mobile.sdk.capture.model


Kofax Mobile SDK API Reference: CaptureExperience.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
CaptureExperience.java File Reference

Classes

class CaptureExperience
This class is a base class for the DocumentCaptureExperience and CheckCaptureExperience, PassportCaptureExperience and FixedAspectRatioCaptureExperience. More...

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: CaptureExperienceCriteriaHolder.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
CaptureExperienceCriteriaHolder.java File Reference

Classes

class CaptureExperienceCriteriaHolder

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: CaptureMessage.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
CaptureMessage.java File Reference

Classes

class | CaptureMessage
enum | CaptureMessage.KUIMessageOrientation

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: CaptureServer.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • logistics
Classes | Packages
CaptureServer.java File Reference

Classes

class CaptureServer

Packages

package com.kofax.mobile.sdk.logistics


Kofax Mobile SDK API Reference: CardIoWrapperActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • creditcard
Classes | Packages
CardIoWrapperActivity.java File Reference

Classes

class CardIoWrapperActivity

Packages

package com.kofax.mobile.sdk.capture.creditcard


Kofax Mobile SDK API Reference: CertificateValidatorListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
Classes | Packages
CertificateValidatorListener.java File Reference

Classes

interface CertificateValidatorListener

Packages

package com.kofax.kmc.kut.utilities


Kofax Mobile SDK API Reference: Check.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • model
Classes | Packages
Check.java File Reference

Classes

class Check

Packages

package com.kofax.mobile.sdk.capture.model


Kofax Mobile SDK API Reference: CheckCaptureActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
Classes | Packages
CheckCaptureActivity.java File Reference

Classes

class CheckCaptureActivity

Packages

package com.kofax.mobile.sdk.capture.check


Kofax Mobile SDK API Reference: CheckCaptureExperience.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
CheckCaptureExperience.java File Reference

Classes

class CheckCaptureExperience

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: CheckCaptureExperienceCriteriaHolder.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
CheckCaptureExperienceCriteriaHolder.java File Reference

Classes

class CheckCaptureExperienceCriteriaHolder

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: CheckDetectionResult.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
CheckDetectionResult.java File Reference

Classes

class CheckDetectionResult

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: CheckDetectionSettings.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
CheckDetectionSettings.java File Reference

Classes

class CheckDetectionSettings

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: CheckDetector.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
Classes | Packages
CheckDetector.java File Reference

Classes

class CheckDetector

Packages

package com.kofax.kmc.ken.engines


Kofax Mobile SDK API Reference: CheckExtractActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
Classes | Packages
CheckExtractActivity.java File Reference

Classes

class CheckExtractActivity

Packages

package com.kofax.mobile.sdk.capture.check


Kofax Mobile SDK API Reference: CheckExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
Classes | Packages
CheckExtractor.java File Reference

Classes

class CheckExtractor

Packages

package com.kofax.mobile.sdk.capture.check


Kofax Mobile SDK API Reference: CheckExtractorResponse.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
Classes | Packages
CheckExtractorResponse.java File Reference

Classes

class CheckExtractorResponse

Packages

package com.kofax.mobile.sdk.capture.check


Kofax Mobile SDK API Reference: CheckIQAData.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • model
Classes | Packages
CheckIQAData.java File Reference

Classes

class CheckIQAData

Packages

package com.kofax.mobile.sdk.capture.model


Kofax Mobile SDK API Reference: CheckParameters.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
Classes | Packages
CheckParameters.java File Reference

Classes

class | CheckParameters
enum | CheckParameters.CheckCountry

Packages

package com.kofax.mobile.sdk.capture.check


Kofax Mobile SDK API Reference: CheckSide.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
CheckSide.java File Reference

Classes

enum CheckSide

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: CheckUsabilityData.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • model
Classes | Packages
CheckUsabilityData.java File Reference

Classes

class CheckUsabilityData

Packages

package com.kofax.mobile.sdk.capture.model


Kofax Mobile SDK API Reference: CheckWorkflowActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
Classes | Packages
CheckWorkflowActivity.java File Reference

Classes

class CheckWorkflowActivity

Packages

package com.kofax.mobile.sdk.capture.check


Kofax Mobile SDK API Reference: ClassificationResult.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
  • data
Classes | Packages
ClassificationResult.java File Reference

Classes

class ClassificationResult
Results from classifying a Document using an RTTI web service. This object is serializable. More...

Packages

package com.kofax.kmc.klo.logistics.data


Kofax Mobile SDK API Reference: ColorDepth.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • processing
Classes | Packages
ColorDepth.java File Reference

Classes

enum ColorDepth

Packages

package com.kofax.kmc.ken.engines.processing


Kofax Mobile SDK API Reference: ContextImageStorage.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
Classes | Packages
ContextImageStorage.java File Reference

Classes

class ContextImageStorage

Packages

package com.kofax.mobile.sdk.capture


Kofax Mobile SDK API Reference: ConventionBasedJsonIdDeserializer.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
Classes | Packages
id/ConventionBasedJsonIdDeserializer.java File Reference

Classes

class ConventionBasedJsonIdDeserializer

Packages

package com.kofax.mobile.sdk.capture.id


Kofax Mobile SDK API Reference: ConventionBasedJsonIdDeserializer.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
Classes | Packages
passport/ConventionBasedJsonIdDeserializer.java File Reference

Classes

class ConventionBasedJsonIdDeserializer

Packages

package com.kofax.mobile.sdk.capture.passport


Kofax Mobile SDK API Reference: CreditCard.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • model
Classes | Packages
CreditCard.java File Reference

Classes

class CreditCard

Packages

package com.kofax.mobile.sdk.capture.model


Kofax Mobile SDK API Reference: CreditCardParameters.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • creditcard
Classes | Packages
CreditCardParameters.java File Reference

Classes

class | CreditCardParameters
enum | CreditCardParameters.CardStyle

Packages

package com.kofax.mobile.sdk.capture.creditcard


Kofax Mobile SDK API Reference: CreditCardWorkflowActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • creditcard
Classes | Packages
CreditCardWorkflowActivity.java File Reference

Classes

class CreditCardWorkflowActivity

Packages

package com.kofax.mobile.sdk.capture.creditcard


Kofax Mobile SDK API Reference: CropType.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • processing
Classes | Packages
CropType.java File Reference

Classes

enum CropType

Packages

package com.kofax.kmc.ken.engines.processing


Kofax Mobile SDK API Reference: DataField.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
DataField.java File Reference

Classes

class DataField

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: DeskewType.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • processing
Classes | Packages
DeskewType.java File Reference

Classes

enum DeskewType

Packages

package com.kofax.kmc.ken.engines.processing


Kofax Mobile SDK API Reference: DetectionResult.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
DetectionResult.java File Reference

Classes

class DetectionResult

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: DetectionSettings.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
DetectionSettings.java File Reference

Classes

class DetectionSettings

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: Document.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
  • data
Classes | Packages
Document.java File Reference

Classes

class Document
The Document object is instantiated as a specific DocumentType. This object is serializable. More...

Packages

package com.kofax.kmc.klo.logistics.data


Kofax Mobile SDK API Reference: DocumentBaseCaptureExperience.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
DocumentBaseCaptureExperience.java File Reference

Classes

class DocumentBaseCaptureExperience

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: DocumentBaseCaptureExperienceCriteriaHolder.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
DocumentBaseCaptureExperienceCriteriaHolder.java File Reference

Classes

class DocumentBaseCaptureExperienceCriteriaHolder

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: DocumentCaptureExperience.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
DocumentCaptureExperience.java File Reference

Classes

class DocumentCaptureExperience

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: DocumentCaptureExperienceCriteriaHolder.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
DocumentCaptureExperienceCriteriaHolder.java File Reference

Classes

class DocumentCaptureExperienceCriteriaHolder

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: DocumentDetectionResult.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
DocumentDetectionResult.java File Reference

Classes

class DocumentDetectionResult

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: DocumentDetectionSettings.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
DocumentDetectionSettings.java File Reference

Classes

class | DocumentDetectionSettings
enum | DocumentDetectionSettings.DocumentEdgeDetection
An enumeration containing the possible edge detection algorithms. More...

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: DocumentDetector.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
Classes | Packages
DocumentDetector.java File Reference

Classes

class DocumentDetector

Packages

package com.kofax.kmc.ken.engines


Kofax Mobile SDK API Reference: DocumentDimensions.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • processing
Classes | Packages
DocumentDimensions.java File Reference

Classes

class DocumentDimensions

Packages

package com.kofax.kmc.ken.engines.processing


Kofax Mobile SDK API Reference: DocumentType.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
  • data
Classes | Packages
DocumentType.java File Reference

Classes

class | DocumentType
The DocumentType object is a model that describes the attributes of a document. This object is serializable. More...
enum | DocumentType.SourceServer
An enum that identifies the source server from which the document was obtained. More...

Packages

package com.kofax.kmc.klo.logistics.data


Kofax Mobile SDK API Reference: DocumentTypeR.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
  • data
Classes | Packages
DocumentTypeR.java File Reference

Classes

interface DocumentTypeR
The DocumentTypeR Object is a model that describes the attributes of a document. This object is serializable. More...

Packages

package com.kofax.kmc.klo.logistics.data


Kofax Mobile SDK API Reference: ErrorInfo.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • error
Classes | Packages
ErrorInfo.java File Reference

Classes

class | ErrGrp
The ErrGrp class contains the starting base error code values for each error group (category).
enum | ErrorInfo
The ErrorInfo enum can be used by application developers to lookup error information. More...

Packages

package com.kofax.kmc.kut.utilities.error


Kofax Mobile SDK API Reference: ExceptionResponse.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • extraction
Classes | Packages
ExceptionResponse.java File Reference

Classes

interface ExceptionResponse

Packages

package com.kofax.mobile.sdk.capture.extraction


Kofax Mobile SDK API Reference: ExceptionResponseImpl.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • extraction
Classes | Packages
ExceptionResponseImpl.java File Reference

Classes

class ExceptionResponseImpl

Packages

package com.kofax.mobile.sdk.capture.extraction


Kofax Mobile SDK API Reference: ExtractActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
Classes | Packages
ExtractActivity.java File Reference

Classes

class ExtractActivity< T extends ExtractorResponse >

Packages

package com.kofax.mobile.sdk.capture


Kofax Mobile SDK API Reference: ExtractionCredentials.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • parameter
Classes | Packages
ExtractionCredentials.java File Reference

Classes

class ExtractionCredentials

Packages

package com.kofax.mobile.sdk.capture.parameter


Kofax Mobile SDK API Reference: ExtractionParameters.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • parameter
Classes | Packages
ExtractionParameters.java File Reference

Classes

class | ExtractionParameters
enum | ExtractionParameters.ExtractionType

Packages

package com.kofax.mobile.sdk.capture.parameter


Kofax Mobile SDK API Reference: ExtractionServerException.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • server
Classes | Packages
ExtractionServerException.java File Reference

Classes

class ExtractionServerException

Packages

package com.kofax.mobile.sdk.extract.server


Kofax Mobile SDK API Reference: Extractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • extraction
Classes | Packages
Extractor.java File Reference

Classes

class Extractor< T extends Serializable >

Packages

package com.kofax.mobile.sdk.capture.extraction


Kofax Mobile SDK API Reference: ExtractorResponse.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • extraction
Classes | Packages
ExtractorResponse.java File Reference

Classes

class ExtractorResponse< T extends Serializable >

Packages

package com.kofax.mobile.sdk.capture.extraction


Kofax Mobile SDK API Reference: Field.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
  • data
Classes | Packages
kmc/klo/logistics/data/Field.java File Reference

Classes

class Field
The Field object is instantiated using a particular FieldType object and contains a value which confirms to that Field Type. This object is serializable. More...

Packages

package com.kofax.kmc.klo.logistics.data


Kofax Mobile SDK API Reference: Field.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • model
Classes | Packages
mobile/sdk/capture/model/Field.java File Reference

Classes

class Field< T extends Serializable >

Packages

package com.kofax.mobile.sdk.capture.model


Kofax Mobile SDK API Reference: FieldLocation.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • model
Classes | Packages
FieldLocation.java File Reference

Classes

class FieldLocation

Packages

package com.kofax.mobile.sdk.capture.model


Kofax Mobile SDK API Reference: FieldType.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
  • data
Classes | Packages
FieldType.java File Reference

Classes

class | FieldType
The FieldType Object is a model that describes the attributes of a field. This object is serializable. More...
enum | FieldType.DataType
An enum that defines the data type specified for this Field Type. More...

Packages

package com.kofax.kmc.klo.logistics.data


Kofax Mobile SDK API Reference: FixedAspectRatioCaptureExperience.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
FixedAspectRatioCaptureExperience.java File Reference

Classes

class FixedAspectRatioCaptureExperience

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: FixedAspectRatioDetectionSettings.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
FixedAspectRatioDetectionSettings.java File Reference

Classes

class FixedAspectRatioDetectionSettings

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: FixedAspectRatioExperienceCriteriaHolder.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
FixedAspectRatioExperienceCriteriaHolder.java File Reference

Classes

class FixedAspectRatioExperienceCriteriaHolder

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: Flash.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • data
Classes | Packages
Flash.java File Reference

Classes

enum Flash
This enum represents the various camera flash settings. More...

Packages

package com.kofax.kmc.kui.uicontrols.data


Kofax Mobile SDK API Reference: GpsUsageLimits.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • data
Classes | Packages
GpsUsageLimits.java File Reference

Classes

enum GpsUsageLimits

Packages

package com.kofax.kmc.kui.uicontrols.data


Kofax Mobile SDK API Reference: GuidingLine.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • data
Classes | Packages
GuidingLine.java File Reference

Classes

enum GuidingLine
An enum representing the rendering and orientation of a guiding line for barcode capture. More...

Packages

package com.kofax.kmc.kui.uicontrols.data


Kofax Mobile SDK API Reference: HorizontalGuidance.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
HorizontalGuidance.java File Reference

Classes

enum HorizontalGuidance

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: IBillDeserializer.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • bill
Classes | Packages
IBillDeserializer.java File Reference

Classes

interface IBillDeserializer

Packages

package com.kofax.mobile.sdk.capture.bill


Kofax Mobile SDK API Reference: IBillExtractorListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • bill
Classes | Packages
IBillExtractorListener.java File Reference

Classes

interface IBillExtractorListener

Packages

package com.kofax.mobile.sdk.capture.bill


Kofax Mobile SDK API Reference: IBundle.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
  • bundle
Classes | Packages
IBundle.java File Reference

Classes

interface IBundle

Packages

package com.kofax.mobile.sdk.extract.id.bundle


Kofax Mobile SDK API Reference: IBundleCacheProvider.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
  • bundle
Classes | Packages
IBundleCacheProvider.java File Reference

Classes

interface IBundleCacheProvider

Packages

package com.kofax.mobile.sdk.extract.id.bundle


Kofax Mobile SDK API Reference: IBundleFile.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
  • bundle
Classes | Packages
IBundleFile.java File Reference

Classes

interface IBundleFile

Packages

package com.kofax.mobile.sdk.extract.id.bundle


Kofax Mobile SDK API Reference: ICaptureServer.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • logistics
Classes | Packages
ICaptureServer.java File Reference

Classes

interface ICaptureServer

Packages

package com.kofax.mobile.sdk.logistics


Kofax Mobile SDK API Reference: ICheckDeserializer.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
Classes | Packages
ICheckDeserializer.java File Reference

Classes

interface ICheckDeserializer

Packages

package com.kofax.mobile.sdk.capture.check


Kofax Mobile SDK API Reference: ICheckDetector.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
Classes | Packages
ICheckDetector.java File Reference

Classes

interface ICheckDetector

Packages

package com.kofax.kmc.ken.engines


Kofax Mobile SDK API Reference: ICheckExtractionServer.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
Classes | Packages
ICheckExtractionServer.java File Reference

Classes

interface ICheckExtractionServer

Packages

package com.kofax.mobile.sdk.capture.check


Kofax Mobile SDK API Reference: ICheckExtractorListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
Classes | Packages
ICheckExtractorListener.java File Reference

Classes

interface ICheckExtractorListener

Packages

package com.kofax.mobile.sdk.capture.check


Kofax Mobile SDK API Reference: ICompletionListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
ICompletionListener.java File Reference

Classes

interface ICompletionListener< T >

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: Id.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • model
Classes | Packages
Id.java File Reference

Classes

class Id

Packages

package com.kofax.mobile.sdk.capture.model


Kofax Mobile SDK API Reference: IdCaptureActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
Classes | Packages
IdCaptureActivity.java File Reference

Classes

class IdCaptureActivity

Packages

package com.kofax.mobile.sdk.capture.id


Kofax Mobile SDK API Reference: IdCaptureBackActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
Classes | Packages
IdCaptureBackActivity.java File Reference

Classes

class IdCaptureBackActivity

Packages

package com.kofax.mobile.sdk.capture.id


Kofax Mobile SDK API Reference: IdExtractActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
Classes | Packages
IdExtractActivity.java File Reference

Classes

class IdExtractActivity

Packages

package com.kofax.mobile.sdk.capture.id


Kofax Mobile SDK API Reference: IdExtractionParameters.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
IdExtractionParameters.java File Reference

Classes

class IdExtractionParameters

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: IdExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
Classes | Packages
IdExtractor.java File Reference

Classes

class IdExtractor

Packages

package com.kofax.mobile.sdk.capture.id


Kofax Mobile SDK API Reference: IdExtractorResponse.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
Classes | Packages
IdExtractorResponse.java File Reference

Classes

class IdExtractorResponse

Packages

package com.kofax.mobile.sdk.capture.id


Kofax Mobile SDK API Reference: IDocumentDetector.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
Classes | Packages
IDocumentDetector.java File Reference

Classes

interface IDocumentDetector< T extends DetectionSettings, U extends DetectionResult >

Packages

package com.kofax.kmc.ken.engines


Kofax Mobile SDK API Reference: IdParameters.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
Classes | Packages
IdParameters.java File Reference

Classes

class | IdParameters
enum | IdParameters.IdSide
enum | IdParameters.IdState

Packages

package com.kofax.mobile.sdk.capture.id


Kofax Mobile SDK API Reference: IdRegion.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
IdRegion.java File Reference

Classes

enum IdRegion

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: IdType.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
IdType.java File Reference

Classes

enum IdType

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: IdWorkflowActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
Classes | Packages
IdWorkflowActivity.java File Reference

Classes

class IdWorkflowActivity

Packages

package com.kofax.mobile.sdk.capture.id


Kofax Mobile SDK API Reference: IExtractorListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • extraction
Classes | Packages
IExtractorListener.java File Reference

Classes

interface IExtractorListener< T extends ExtractorResponse >

Packages

package com.kofax.mobile.sdk.capture.extraction


Kofax Mobile SDK API Reference: IIdDeserializer.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
Classes | Packages
IIdDeserializer.java File Reference

Classes

interface IIdDeserializer

Packages

package com.kofax.mobile.sdk.capture.id


Kofax Mobile SDK API Reference: IIdExtractionListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
IIdExtractionListener.java File Reference

Classes

interface IIdExtractionListener

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: IIdExtractionResult.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
IIdExtractionResult.java File Reference

Classes

interface IIdExtractionResult

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: IIdExtractionServer.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
Classes | Packages
IIdExtractionServer.java File Reference

Classes

interface IIdExtractionServer

Packages

package com.kofax.mobile.sdk.capture.id


Kofax Mobile SDK API Reference: IIdExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
IIdExtractor.java File Reference

Classes

interface IIdExtractor

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: IIdExtractorListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
Classes | Packages
IIdExtractorListener.java File Reference

Classes

interface IIdExtractorListener

Packages

package com.kofax.mobile.sdk.capture.id


Kofax Mobile SDK API Reference: IImageProcessor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • processing
Classes | Packages
IImageProcessor.java File Reference

Classes

interface IImageProcessor

Packages

package com.kofax.mobile.sdk.capture.processing


Kofax Mobile SDK API Reference: IImageProcessorListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • processing
Classes | Packages
IImageProcessorListener.java File Reference

Classes

interface IImageProcessorListener

Packages

package com.kofax.mobile.sdk.capture.processing


Kofax Mobile SDK API Reference: IImageStorage.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
Classes | Packages
IImageStorage.java File Reference

Classes

interface IImageStorage

Packages

package com.kofax.mobile.sdk.capture


Kofax Mobile SDK API Reference: Image.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
Image.java File Reference

Classes

class | Image
The Image Object contains an in-memory and/or image file based representation of an image. This object is serializable. More...
enum | Image.ImageRep
An enum which identifies the Image Representation(s) included in this Image Object. More...
enum | Image.ImageMimeType
An enum which identifies the Mime Type of the image file referenced by this Image Object. More...
enum | Image.ImageFileRep
An enum which identifies the File Representation of the image file referenced by this Image Object. More...
enum | Image.FileIOEngine
An enum which optionally identifies the desired File I/O Engine used for reading and writing. More...
enum | Image.FileRestriction
An enum which specifies that ANSI X9.100-181 restrictions are needed for TIFF output. More...
enum | Image.OutputColor
An enum which identifies the output color desired for writing the bitmap to an image file. More...

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: ImageCacheType.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • data
Classes | Packages
ImageCacheType.java File Reference

Classes

enum ImageCacheType

Packages

package com.kofax.kmc.kui.uicontrols.data


Kofax Mobile SDK API Reference: ImageCapturedEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
ImageCapturedEvent.java File Reference

Classes

class ImageCapturedEvent
This event is fired when an image is successfully captured. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: ImageCapturedListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
ImageCapturedListener.java File Reference

Classes

interface ImageCapturedListener

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: ImageCaptureView.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
ImageCaptureView.java File Reference

Classes

class ImageCaptureView

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: ImageClassificationCompletedListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
Classes | Packages
ImageClassificationCompletedListener.java File Reference

Classes

interface ImageClassificationCompletedListener
The listener interface for receiving image classification completed events. More...

Packages

package com.kofax.kmc.ken.engines


Kofax Mobile SDK API Reference: ImageClassificationCompleteEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
Classes | Packages
ImageClassificationCompleteEvent.java File Reference

Classes

class ImageClassificationCompleteEvent
This event is raised in response to an image classification process. More...

Packages

package com.kofax.kmc.ken.engines


Kofax Mobile SDK API Reference: ImageClassificationResult.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
Classes | Packages
ImageClassificationResult.java File Reference

Classes

class ImageClassificationResult
Results from classifying an image. This object is serializable. More...

Packages

package com.kofax.kmc.ken.engines


Kofax Mobile SDK API Reference: ImageClassifier.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
Classes | Packages
ImageClassifier.java File Reference

Classes

class | ImageClassifier
This class is used to classify images based on given configuration and model. More...
enum | ImageClassifier.ImageClassificationStatus

Packages

package com.kofax.kmc.ken.engines


Kofax Mobile SDK API Reference: ImagePerfectionProfile.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
ImagePerfectionProfile.java File Reference

Classes

class | ImagePerfectionProfile
The ImagePerfectionProfile object encapsulates advanced image processing settings. This object is serializable. More...
enum | ImagePerfectionProfile.UseMRZPassportDetection
An enum used with the useMRZPassportDetection property. More...
enum | ImagePerfectionProfile.UseTargetFrameCrop
An enum used with the useTargetFrameCrop property. More...
enum | ImagePerfectionProfile.UseDocumentDetectionBasedCrop
An enum used with the useDocumentDetectionBasedCrop property. More...

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: ImageProcessor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
Classes | Packages
ImageProcessor.java File Reference

Classes

class | ImageProcessor
The ImageProcessor is the image processing engine. More...
interface | ImageProcessor.ImageOutListener
The listener interface for receiving Image Out events. More...
interface | ImageProcessor.ProcessProgressListener
The listener interface for receiving Process Progress events. More...
interface | ImageProcessor.AnalysisCompleteListener
The listener interface for receiving analysis complete events. More...
interface | ImageProcessor.AnalysisProgressListener
The listener interface for receiving Analysis Progress events. More...
class | ImageProcessor.ImageOutEvent
An event that indicates a processed Image is available. More...
class | ImageProcessor.ProcessProgressEvent
An event that indicates Image processing progress information is available. More...
class | ImageProcessor.AnalysisCompleteEvent
An event that indicates that image quick analysis results are available. More...
class | ImageProcessor.AnalysisProgressEvent
An event that indicates Image processing progress information is available. More...

Packages

package com.kofax.kmc.ken.engines


Kofax Mobile SDK API Reference: ImageProcessorConfiguration.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • processing
Classes | Packages
ImageProcessorConfiguration.java File Reference

Classes

class ImageProcessorConfiguration

Packages

package com.kofax.kmc.ken.engines.processing


Kofax Mobile SDK API Reference: ImageReviewActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
Classes | Packages
ImageReviewActivity.java File Reference

Classes

class ImageReviewActivity

Packages

package com.kofax.mobile.sdk.capture


Kofax Mobile SDK API Reference: ImageSource.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
ImageSource.java File Reference

Classes

enum ImageSource

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: ImgReviewEditCntrl.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
ImgReviewEditCntrl.java File Reference

Classes

class | ImgReviewEditCntrl
enum | ImgReviewEditCntrl.Line_Style_Solid
An enum which lists the drawing style options the edge of the tetragon. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: IParameters.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • parameter
Classes | Packages
IParameters.java File Reference

Classes

interface IParameters

Packages

package com.kofax.mobile.sdk.capture.parameter


Kofax Mobile SDK API Reference: IPassportDeserializer.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
Classes | Packages
IPassportDeserializer.java File Reference

Classes

interface IPassportDeserializer

Packages

package com.kofax.mobile.sdk.capture.passport


Kofax Mobile SDK API Reference: IPassportDetector.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
Classes | Packages
IPassportDetector.java File Reference

Classes

interface IPassportDetector

Packages

package com.kofax.kmc.ken.engines


Kofax Mobile SDK API Reference: IPassportExtractorListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
Classes | Packages
IPassportExtractorListener.java File Reference

Classes

interface IPassportExtractorListener

Packages

package com.kofax.mobile.sdk.capture.passport


Kofax Mobile SDK API Reference: IProgressListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • logistics
Classes | Packages
IProgressListener.java File Reference

Classes

interface IProgressListener

Packages

package com.kofax.mobile.sdk.logistics


Kofax Mobile SDK API Reference: IProjectProvider.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
IProjectProvider.java File Reference

Classes

interface IProjectProvider

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: IServerExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • server
Classes | Packages
IServerExtractor.java File Reference

Classes

interface IServerExtractor

Packages

package com.kofax.mobile.sdk.extract.server


Kofax Mobile SDK API Reference: KENLogging.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
Classes | Packages
KENLogging.java File Reference

Classes

class KENLogging

Packages

package com.kofax.kmc.ken.engines


Kofax Mobile SDK API Reference: KenVersion.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • version
Classes | Packages
KenVersion.java File Reference

Classes

class KenVersion

Packages

package com.kofax.kmc.ken.engines.version


Kofax Mobile SDK API Reference: KLOLogging.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
Classes | Packages
KLOLogging.java File Reference

Classes

class KLOLogging

Packages

package com.kofax.kmc.klo.logistics


Kofax Mobile SDK API Reference: KloVersion.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
  • version
Classes | Packages
KloVersion.java File Reference

Classes

class KloVersion

Packages

package com.kofax.kmc.klo.logistics.version


Kofax Mobile SDK API Reference: KmcException.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • error
Classes | Packages
KmcException.java File Reference

Classes

class KmcException
An extended Exception class that specifies KMC errors as defined by the ErrorInfo enum. More...

Packages

package com.kofax.kmc.kut.utilities.error


Kofax Mobile SDK API Reference: KmcRuntimeException.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • error
Classes | Packages
KmcRuntimeException.java File Reference

Classes

class KmcRuntimeException
An extended RuntimeException class that specifies KMC errors as defined by the ErrorInfo enum. More...

Packages

package com.kofax.kmc.kut.utilities.error


Kofax Mobile SDK API Reference: KtaBillExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • bill
Classes | Packages
KtaBillExtractor.java File Reference

Classes

class KtaBillExtractor

Packages

package com.kofax.mobile.sdk.capture.bill


Kofax Mobile SDK API Reference: KtaCheckExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
Classes | Packages
KtaCheckExtractor.java File Reference

Classes

class KtaCheckExtractor

Packages

package com.kofax.mobile.sdk.capture.check


Kofax Mobile SDK API Reference: KtaIdExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
Classes | Packages
KtaIdExtractor.java File Reference

Classes

class KtaIdExtractor

Packages

package com.kofax.mobile.sdk.capture.id


Kofax Mobile SDK API Reference: KtaJsonBill.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • bill
Classes | Packages
KtaJsonBill.java File Reference

Classes

class KtaJsonBill

Packages

package com.kofax.mobile.sdk.capture.bill


Kofax Mobile SDK API Reference: KtaJsonCheck.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
Classes | Packages
KtaJsonCheck.java File Reference

Classes

class KtaJsonCheck

Packages

package com.kofax.mobile.sdk.capture.check


Kofax Mobile SDK API Reference: KtaJsonPassport.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
Classes | Packages
KtaJsonPassport.java File Reference

Classes

class KtaJsonPassport

Packages

package com.kofax.mobile.sdk.capture.passport


Kofax Mobile SDK API Reference: KtaPassportExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
Classes | Packages
KtaPassportExtractor.java File Reference

Classes

class KtaPassportExtractor

Packages

package com.kofax.mobile.sdk.capture.passport


Kofax Mobile SDK API Reference: KUILogging.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
KUILogging.java File Reference

Classes

class KUILogging

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: KuiVersion.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • version
Classes | Packages
KuiVersion.java File Reference

Classes

class KuiVersion

Packages

package com.kofax.kmc.kui.uicontrols.version


Kofax Mobile SDK API Reference: KUTLogging.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
Classes | Packages
KUTLogging.java File Reference

Classes

class KUTLogging

Packages

package com.kofax.kmc.kut.utilities


Kofax Mobile SDK API Reference: KutVersion.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • version
Classes | Packages
KutVersion.java File Reference

Classes

class KutVersion

Packages

package com.kofax.kmc.kut.utilities.version


Kofax Mobile SDK API Reference: LevelnessEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
LevelnessEvent.java File Reference

Classes

class LevelnessEvent
This event fires when the orientation of the device changes. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: LevelnessListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
LevelnessListener.java File Reference

Classes

interface LevelnessListener
The interface that is required to implement StabilityDelayEvent. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: LicenseCaptureView.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
LicenseCaptureView.java File Reference

Classes

class LicenseCaptureView

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: LicenseFoundEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
LicenseFoundEvent.java File Reference

Classes

class LicenseFoundEvent
An event that indicates that a license was found. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: LicenseFoundListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
LicenseFoundListener.java File Reference

Classes

interface LicenseFoundListener
The listener interface for receiving license found events. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: Licensing.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
Classes | Packages
Licensing.java File Reference

Classes

class | Licensing
This class comprises the licensing mechanism for Mobile SDK. More...
enum | Licensing.LicenseType
An enum of license types. More...
enum | Licensing.LicenseServerType
An enum of license server types. Use with Licensing.setMobileSDKLicenseServer. More...
class | Licensing.VolumeLicenseResultData
Data class for volume licensing related successful operations. More...
class | Licensing.VolumeLicenseFailureData
Data class for volume licensing related failures. More...
interface | Licensing.VolumeLicenseEventListener
The listener interface for receiving volume licensing events. More...

Packages

package com.kofax.kmc.kut.utilities


Kofax Mobile SDK API Reference: ListenerCallbackThreadType.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • async
Classes | Packages
ListenerCallbackThreadType.java File Reference

Classes

enum ListenerCallbackThreadType
An enum which identifies the thread type for asynchronous callbacks. More...

Packages

package com.kofax.kmc.kut.utilities.async


Kofax Mobile SDK API Reference: ListOfException.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
ListOfException.java File Reference

Classes

class ListOfException

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: LocalProjectProvider.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
LocalProjectProvider.java File Reference

Classes

class | LocalProjectProvider
class | LocalProjectProvider.VersionTable
class | LocalProjectProvider.VersionTable.VersionList

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: Logging.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
Classes | Packages
Logging.java File Reference

Classes

class Logging

Packages

package com.kofax.mobile.sdk


Kofax Mobile SDK API Reference: LoginCredentials.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • server
Classes | Packages
LoginCredentials.java File Reference

Classes

class LoginCredentials

Packages

package com.kofax.mobile.sdk.extract.server


Kofax Mobile SDK API Reference: LookAndFeelParameters.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • parameter
Classes | Packages
LookAndFeelParameters.java File Reference

Classes

class | LookAndFeelParameters
enum | LookAndFeelParameters.TorchMode

Packages

package com.kofax.mobile.sdk.capture.parameter


Kofax Mobile SDK API Reference: mainpage.h File Reference

  • File List
mainpage.h File Reference

Go to the source code of this file.


Kofax Mobile SDK API Reference: MicrLine.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
Classes | Packages
MicrLine.java File Reference

Classes

class | MicrLine
This class represents the MICR line itself. More...
enum | MicrLine.CheckType
An enum which identifies the type of check. More...

Packages

package com.kofax.kmc.kut.utilities


Kofax Mobile SDK API Reference: MicrParser.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
Classes | Packages
MicrParser.java File Reference

Classes

class MicrParser
This class parses the MICR data line from different check detection algorithms. More...

Packages

package com.kofax.kmc.kut.utilities


Kofax Mobile SDK API Reference: OnDeviceIdExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
OnDeviceIdExtractor.java File Reference

Classes

class OnDeviceIdExtractor

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: OrientationGuidance.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
OrientationGuidance.java File Reference

Classes

enum OrientationGuidance

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: Page.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
  • data
Classes | Packages
Page.java File Reference

Classes

class | Page
There can be one or more Pages in a Document. This object is serializable. More...
enum | Page.Side
Indicates whether this Page is front or back of the sheet. More...

Packages

package com.kofax.kmc.klo.logistics.data


Kofax Mobile SDK API Reference: PageDetectionEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
PageDetectionEvent.java File Reference

Classes

class PageDetectionEvent
An event that indicates a page was detected in the camera preview. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: PageDetectionListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
PageDetectionListener.java File Reference

Classes

interface PageDetectionListener

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: Passport.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • model
Classes | Packages
Passport.java File Reference

Classes

class Passport

Packages

package com.kofax.mobile.sdk.capture.model


Kofax Mobile SDK API Reference: PassportCaptureActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
Classes | Packages
PassportCaptureActivity.java File Reference

Classes

class PassportCaptureActivity

Packages

package com.kofax.mobile.sdk.capture.passport


Kofax Mobile SDK API Reference: PassportCaptureExperience.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
PassportCaptureExperience.java File Reference

Classes

class PassportCaptureExperience

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: PassportCaptureExperienceCriteriaHolder.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
PassportCaptureExperienceCriteriaHolder.java File Reference

Classes

class PassportCaptureExperienceCriteriaHolder

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: PassportDetectionResult.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
PassportDetectionResult.java File Reference

Classes

class PassportDetectionResult

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: PassportDetectionSettings.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
PassportDetectionSettings.java File Reference

Classes

class PassportDetectionSettings

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: PassportDetector.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
Classes | Packages
PassportDetector.java File Reference

Classes

class PassportDetector

Packages

package com.kofax.kmc.ken.engines


Kofax Mobile SDK API Reference: PassportExtractActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
Classes | Packages
PassportExtractActivity.java File Reference

Classes

class PassportExtractActivity

Packages

package com.kofax.mobile.sdk.capture.passport


Kofax Mobile SDK API Reference: PassportExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
Classes | Packages
PassportExtractor.java File Reference

Classes

class PassportExtractor

Packages

package com.kofax.mobile.sdk.capture.passport


Kofax Mobile SDK API Reference: PassportExtractorResponse.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
Classes | Packages
PassportExtractorResponse.java File Reference

Classes

class PassportExtractorResponse

Packages

package com.kofax.mobile.sdk.capture.passport


Kofax Mobile SDK API Reference: PassportParameters.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
Classes | Packages
PassportParameters.java File Reference

Classes

class PassportParameters

Packages

package com.kofax.mobile.sdk.capture.passport


Kofax Mobile SDK API Reference: PassportWorkflowActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
Classes | Packages
PassportWorkflowActivity.java File Reference

Classes

class PassportWorkflowActivity

Packages

package com.kofax.mobile.sdk.capture.passport


Kofax Mobile SDK API Reference: PointDouble.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • model
Classes | Packages
PointDouble.java File Reference

Classes

class PointDouble

Packages

package com.kofax.mobile.sdk.capture.model


Kofax Mobile SDK API Reference: PreviewCallbackListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
PreviewCallbackListener.java File Reference

Classes

interface PreviewCallbackListener

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: PreviewFrameEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
PreviewFrameEvent.java File Reference

Classes

class PreviewFrameEvent

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: ProcessActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
Classes | Packages
ProcessActivity.java File Reference

Classes

class ProcessActivity

Packages

package com.kofax.mobile.sdk.capture


Kofax Mobile SDK API Reference: ProcessingParameters.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • parameter
Classes | Packages
ProcessingParameters.java File Reference

Classes

class | ProcessingParameters
enum | ProcessingParameters.ProcessingType

Packages

package com.kofax.mobile.sdk.capture.parameter


Kofax Mobile SDK API Reference: ProjectProviderException.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
ProjectProviderException.java File Reference

Classes

class ProjectProviderException

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: QuickAnalysisFeedback.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
QuickAnalysisFeedback.java File Reference

Classes

class QuickAnalysisFeedback
The QuickAnalysisFeedback object contains the results of image quality checking using the doQuickAnalysis method of the ImageProcessor object. This object is serializable. More...

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: QuickAnalysisSettings.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
QuickAnalysisSettings.java File Reference

Classes

class QuickAnalysisSettings
A configuration object for controlling the quick analysis image processing. More...

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: RotateType.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • processing
Classes | Packages
RotateType.java File Reference

Classes

enum RotateType

Packages

package com.kofax.kmc.ken.engines.processing


Kofax Mobile SDK API Reference: RttiBillExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • bill
Classes | Packages
RttiBillExtractor.java File Reference

Classes

class RttiBillExtractor

Packages

package com.kofax.mobile.sdk.capture.bill


Kofax Mobile SDK API Reference: RttiCheckExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
Classes | Packages
RttiCheckExtractor.java File Reference

Classes

class RttiCheckExtractor

Packages

package com.kofax.mobile.sdk.capture.check


Kofax Mobile SDK API Reference: RttiIdExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
Classes | Packages
RttiIdExtractor.java File Reference

Classes

class RttiIdExtractor

Packages

package com.kofax.mobile.sdk.capture.id


Kofax Mobile SDK API Reference: RttiJsonBill.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • bill
Classes | Packages
RttiJsonBill.java File Reference

Classes

class RttiJsonBill

Packages

package com.kofax.mobile.sdk.capture.bill


Kofax Mobile SDK API Reference: RttiJsonCheck.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
Classes | Packages
RttiJsonCheck.java File Reference

Classes

class RttiJsonCheck

Packages

package com.kofax.mobile.sdk.capture.check


Kofax Mobile SDK API Reference: RttiJsonPassport.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
Classes | Packages
RttiJsonPassport.java File Reference

Classes

class RttiJsonPassport

Packages

package com.kofax.mobile.sdk.capture.passport


Kofax Mobile SDK API Reference: RttiPassportExtractor.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
Classes | Packages
RttiPassportExtractor.java File Reference

Classes

class RttiPassportExtractor

Packages

package com.kofax.mobile.sdk.capture.passport


Kofax Mobile SDK API Reference: SdkVersion.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
Classes | Packages
SdkVersion.java File Reference

Classes

class SdkVersion
This class provides access to version information for the Kofax Mobile SDK. More...

Packages

package com.kofax.kmc.kut.utilities


Kofax Mobile SDK API Reference: SearchDirection.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • data
Classes | Packages
SearchDirection.java File Reference

Classes

enum SearchDirection
An enum representing a direction or set of directions to search for barcodes. More...

Packages

package com.kofax.kmc.kui.uicontrols.data


Kofax Mobile SDK API Reference: SelfieBaseCaptureExperience.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
SelfieBaseCaptureExperience.java File Reference

Classes

class SelfieBaseCaptureExperience

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: SelfieCaptureExperience.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
SelfieCaptureExperience.java File Reference

Classes

class SelfieCaptureExperience

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: SelfieCaptureExperienceCriteriaHolder.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
Classes | Packages
SelfieCaptureExperienceCriteriaHolder.java File Reference

Classes

class SelfieCaptureExperienceCriteriaHolder

Packages

package com.kofax.kmc.kui.uicontrols.captureanimations


Kofax Mobile SDK API Reference: SelfieDetectionSettings.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
SelfieDetectionSettings.java File Reference

Classes

class SelfieDetectionSettings

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: ServerBuilder.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • server
Classes | Packages
ServerBuilder.java File Reference

Classes

class | ServerBuilder
enum | ServerBuilder.ServerType

Packages

package com.kofax.mobile.sdk.extract.server


Kofax Mobile SDK API Reference: ServerExtractionParameters.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • server
Classes | Packages
ServerExtractionParameters.java File Reference

Classes

class ServerExtractionParameters

Packages

package com.kofax.mobile.sdk.extract.server


Kofax Mobile SDK API Reference: ServerProjectProvider.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
Classes | Packages
ServerProjectProvider.java File Reference

Classes

class | ServerProjectProvider
class | ServerProjectProvider.HttpClientHolder
class | ServerProjectProvider.Error

Packages

package com.kofax.mobile.sdk.extract.id


Kofax Mobile SDK API Reference: SessionState.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
Classes | Packages
SessionState.java File Reference

Classes

enum SessionState
An enum which contains various FrontOfficeServer and TotalAgility session state information. More...

Packages

package com.kofax.kmc.klo.logistics


Kofax Mobile SDK API Reference: Size.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
Classes | Packages
Size.java File Reference

Classes

class Size
Universal class for image size describing. More...

Packages

package com.kofax.kmc.kut.utilities


Kofax Mobile SDK API Reference: SizeDouble.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • model
Classes | Packages
SizeDouble.java File Reference

Classes

class SizeDouble

Packages

package com.kofax.mobile.sdk.capture.model


Kofax Mobile SDK API Reference: StabilityDelayEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
StabilityDelayEvent.java File Reference

Classes

class StabilityDelayEvent
This event fires when stability levels change. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: StabilityDelayListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
StabilityDelayListener.java File Reference

Classes

interface StabilityDelayListener
The interface that is required to implement StabilityDelayEvent. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: Symbology.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • data
Classes | Packages
Symbology.java File Reference

Classes

enum Symbology
An enum representing a barcode symbology. More...

Packages

package com.kofax.kmc.kui.uicontrols.data


Kofax Mobile SDK API Reference: TargetFrameCropType.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • processing
Classes | Packages
TargetFrameCropType.java File Reference

Classes

enum TargetFrameCropType

Packages

package com.kofax.kmc.ken.engines.processing


Kofax Mobile SDK API Reference: TimeOutParameters.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • server
Classes | Packages
TimeOutParameters.java File Reference

Classes

class TimeOutParameters

Packages

package com.kofax.mobile.sdk.extract.server


Kofax Mobile SDK API Reference: TorchLuminanceEvent.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
TorchLuminanceEvent.java File Reference

Classes

class TorchLuminanceEvent
This event fires when torch luminance level changes. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: TorchLuminanceListener.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
Classes | Packages
TorchLuminanceListener.java File Reference

Classes

interface TorchLuminanceListener
The interface that is required to implement TorchLuminanceEvent. More...

Packages

package com.kofax.kmc.kui.uicontrols


Kofax Mobile SDK API Reference: TurnGuidance.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
TurnGuidance.java File Reference

Classes

enum TurnGuidance

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: UserProfile.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
  • data
Classes | Packages
UserProfile.java File Reference

Classes

class UserProfile
The UserProfile Object contains login credentials for a user. More...

Packages

package com.kofax.kmc.klo.logistics.data


Kofax Mobile SDK API Reference: VerticalGuidance.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
VerticalGuidance.java File Reference

Classes

enum VerticalGuidance

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: WorkflowActivity.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
Classes | Packages
WorkflowActivity.java File Reference

Classes

class WorkflowActivity< T extends IParameters >

Packages

package com.kofax.mobile.sdk.capture


Kofax Mobile SDK API Reference: ZipFileBundle.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
  • bundle
Classes | Packages
ZipFileBundle.java File Reference

Classes

class ZipFileBundle

Packages

package com.kofax.mobile.sdk.extract.id.bundle


Kofax Mobile SDK API Reference: ZipInputStreamBundle.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
  • bundle
Classes | Packages
ZipInputStreamBundle.java File Reference

Classes

class ZipInputStreamBundle

Packages

package com.kofax.mobile.sdk.extract.id.bundle


Kofax Mobile SDK API Reference: ZoomGuidance.java File Reference

  • File List
  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
Classes | Packages
ZoomGuidance.java File Reference

Classes

enum ZoomGuidance

Packages

package com.kofax.kmc.ken.engines.data


Kofax Mobile SDK API Reference: processing Directory Reference

  • sdk
  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • processing
processing Directory Reference

Files

file | IImageProcessor.java
file | IImageProcessorListener.java


Kofax Mobile SDK API Reference: version Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • version
version Directory Reference

Files

file KuiVersion.java


Kofax Mobile SDK API Reference: utilities Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
utilities Directory Reference

Directories

directory | appstats
directory | async
directory | error
directory | version

Files

file | AppContextProvider.java
file | CertificateValidatorListener.java
file | KUTLogging.java
file | Licensing.java
file | MicrLine.java
file | MicrParser.java
file | SdkVersion.java
file | Size.java


Kofax Mobile SDK API Reference: server Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • server
server Directory Reference

Files

file | ExtractionServerException.java
file | IServerExtractor.java
file | LoginCredentials.java
file | ServerBuilder.java
file | ServerExtractionParameters.java
file | TimeOutParameters.java


Kofax Mobile SDK API Reference: kofax Directory Reference

  • src
  • main
  • java
  • com
  • kofax
kofax Directory Reference

Directories

directory | kmc
directory | mobile


Kofax Mobile SDK API Reference: bill Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • bill
bill Directory Reference

Files

file | BillCaptureActivity.java
file | BillExtractActivity.java
file | BillExtractor.java
file | BillExtractorResponse.java
file | BillParameters.java
file | BillWorkflowActivity.java
file | IBillDeserializer.java
file | IBillExtractorListener.java
file | KtaBillExtractor.java
file | KtaJsonBill.java
file | RttiBillExtractor.java
file | RttiJsonBill.java


Kofax Mobile SDK API Reference: kut Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
kut Directory Reference

Directories

directory utilities


Kofax Mobile SDK API Reference: mobile Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
mobile Directory Reference

Directories

directory sdk


Kofax Mobile SDK API Reference: main Directory Reference

  • src
  • main
main Directory Reference

Directories

directory java


Kofax Mobile SDK API Reference: com Directory Reference

  • src
  • main
  • java
  • com
com Directory Reference

Directories

directory kofax


Kofax Mobile SDK API Reference: creditcard Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • creditcard
creditcard Directory Reference

Files

file | CardIoWrapperActivity.java
file | CreditCardParameters.java
file | CreditCardWorkflowActivity.java


Kofax Mobile SDK API Reference: captureanimations Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • captureanimations
captureanimations Directory Reference

Files

file | CaptureExperience.java
file | CaptureExperienceCriteriaHolder.java
file | CaptureMessage.java
file | CheckCaptureExperience.java
file | CheckCaptureExperienceCriteriaHolder.java
file | DocumentBaseCaptureExperience.java
file | DocumentBaseCaptureExperienceCriteriaHolder.java
file | DocumentCaptureExperience.java
file | DocumentCaptureExperienceCriteriaHolder.java
file | FixedAspectRatioCaptureExperience.java
file | FixedAspectRatioExperienceCriteriaHolder.java
file | PassportCaptureExperience.java
file | PassportCaptureExperienceCriteriaHolder.java
file | SelfieBaseCaptureExperience.java
file | SelfieCaptureExperience.java
file | SelfieCaptureExperienceCriteriaHolder.java


Kofax Mobile SDK API Reference: logistics Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • logistics
logistics Directory Reference

Files

file | CaptureServer.java
file | ICaptureServer.java
file | IProgressListener.java


Kofax Mobile SDK API Reference: passport Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • passport
passport Directory Reference

Files

file | passport/ConventionBasedJsonIdDeserializer.java
file | IPassportDeserializer.java
file | IPassportExtractorListener.java
file | KtaJsonPassport.java
file | KtaPassportExtractor.java
file | PassportCaptureActivity.java
file | PassportExtractActivity.java
file | PassportExtractor.java
file | PassportExtractorResponse.java
file | PassportParameters.java
file | PassportWorkflowActivity.java
file | RttiJsonPassport.java
file | RttiPassportExtractor.java


Kofax Mobile SDK API Reference: extract Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
extract Directory Reference

Directories

directory | id
directory | server


Kofax Mobile SDK API Reference: sdk Directory Reference

  • sdk
sdk Directory Reference

Directories

directory src


Kofax Mobile SDK API Reference: src Directory Reference

  • src
src Directory Reference

Directories

directory main


Kofax Mobile SDK API Reference: kui Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
kui Directory Reference

Directories

directory uicontrols


Kofax Mobile SDK API Reference: capture Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
capture Directory Reference

Directories

directory | bill
directory | check
directory | creditcard
directory | extraction
directory | id
directory | model
directory | parameter
directory | passport
directory | processing

Files

file | ApplicationContextImageStore.java
file | CaptureActivity.java
file | ContextImageStorage.java
file | ExtractActivity.java
file | IImageStorage.java
file | ImageReviewActivity.java
file | ProcessActivity.java
file | WorkflowActivity.java


Kofax Mobile SDK API Reference: data Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
  • data
data Directory Reference

Files

file | CameraType.java
file | Flash.java
file | GpsUsageLimits.java
file | GuidingLine.java
file | ImageCacheType.java
file | SearchDirection.java
file | Symbology.java


Kofax Mobile SDK API Reference: id Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • id
id Directory Reference

Files

file | id/ConventionBasedJsonIdDeserializer.java
file | IdCaptureActivity.java
file | IdCaptureBackActivity.java
file | IdExtractActivity.java
file | IdExtractor.java
file | IdExtractorResponse.java
file | IdParameters.java
file | IdWorkflowActivity.java
file | IIdDeserializer.java
file | IIdExtractionServer.java
file | IIdExtractorListener.java
file | KtaIdExtractor.java
file | RttiIdExtractor.java


Kofax Mobile SDK API Reference: engines Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
engines Directory Reference

Directories

directory | data
directory | processing
directory | version

Files

file | BarCodeReader.java
file | CheckDetector.java
file | DocumentDetector.java
file | ICheckDetector.java
file | IDocumentDetector.java
file | ImageClassificationCompletedListener.java
file | ImageClassificationCompleteEvent.java
file | ImageClassificationResult.java
file | ImageClassifier.java
file | ImageProcessor.java
file | IPassportDetector.java
file | KENLogging.java
file | PassportDetector.java


Kofax Mobile SDK API Reference: java Directory Reference

  • src
  • main
  • java
java Directory Reference

Directories

directory com


Kofax Mobile SDK API Reference: version Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
  • version
version Directory Reference

Files

file KloVersion.java


Kofax Mobile SDK API Reference: model Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • model
model Directory Reference

Files

file | Bill.java
file | CaptureData.java
file | Check.java
file | CheckIQAData.java
file | CheckUsabilityData.java
file | CreditCard.java
file | mobile/sdk/capture/model/Field.java
file | FieldLocation.java
file | Id.java
file | Passport.java
file | PointDouble.java
file | SizeDouble.java


Kofax Mobile SDK API Reference: data Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • data
data Directory Reference

Files

file | BarCodeDataFormat.java
file | BarCodeDirection.java
file | BarCodeResult.java
file | BarCodeType.java
file | BasicSettingsProfile.java
file | BoundingRect.java
file | BoundingTetragon.java
file | CheckDetectionResult.java
file | CheckDetectionSettings.java
file | CheckSide.java
file | DetectionResult.java
file | DetectionSettings.java
file | DocumentDetectionResult.java
file | DocumentDetectionSettings.java
file | FixedAspectRatioDetectionSettings.java
file | HorizontalGuidance.java
file | Image.java
file | ImagePerfectionProfile.java
file | ImageSource.java
file | OrientationGuidance.java
file | PassportDetectionResult.java
file | PassportDetectionSettings.java
file | QuickAnalysisFeedback.java
file | QuickAnalysisSettings.java
file | SelfieDetectionSettings.java
file | TurnGuidance.java
file | VerticalGuidance.java
file | ZoomGuidance.java


Kofax Mobile SDK API Reference: appstats Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • appstats
appstats Directory Reference

Files

file | AppStatistics.java
file | AppStatsDaoField.java
file | AppStatsDsExportHandler.java
file | AppStatsExportEvent.java
file | AppStatsExportListener.java
file | AppStatsSessionEvent.java
file | AppStatsThresholdReachedEvent.java
file | AppstatsThresholdReachedListener.java
file | AppStatsWriteFileListener.java
file | AppStatsWritetoFileEvent.java
file | AppStatsWriteToFileResults.java


Kofax Mobile SDK API Reference: data Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
  • data
data Directory Reference

Files

file | ClassificationResult.java
file | Document.java
file | DocumentType.java
file | DocumentTypeR.java
file | kmc/klo/logistics/data/Field.java
file | FieldType.java
file | Page.java
file | UserProfile.java


Kofax Mobile SDK API Reference: check Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • check
check Directory Reference

Files

file | CheckCaptureActivity.java
file | CheckExtractActivity.java
file | CheckExtractor.java
file | CheckExtractorResponse.java
file | CheckParameters.java
file | CheckWorkflowActivity.java
file | ICheckDeserializer.java
file | ICheckExtractionServer.java
file | ICheckExtractorListener.java
file | KtaCheckExtractor.java
file | KtaJsonCheck.java
file | RttiCheckExtractor.java
file | RttiJsonCheck.java


Kofax Mobile SDK API Reference: error Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • error
error Directory Reference

Files

file | ErrorInfo.java
file | KmcException.java
file | KmcRuntimeException.java


Kofax Mobile SDK API Reference: id Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
id Directory Reference

Directories

directory bundle

Files

file | AggregateException.java
file | DataField.java
file | ICompletionListener.java
file | IdExtractionParameters.java
file | IdRegion.java
file | IdType.java
file | IIdExtractionListener.java
file | IIdExtractionResult.java
file | IIdExtractor.java
file | IProjectProvider.java
file | ListOfException.java
file | LocalProjectProvider.java
file | OnDeviceIdExtractor.java
file | ProjectProviderException.java
file | ServerProjectProvider.java


Kofax Mobile SDK API Reference: klo Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
klo Directory Reference

Directories

directory logistics


Kofax Mobile SDK API Reference: processing Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • processing
processing Directory Reference

Files

file | ColorDepth.java
file | CropType.java
file | DeskewType.java
file | DocumentDimensions.java
file | ImageProcessorConfiguration.java
file | RotateType.java
file | TargetFrameCropType.java


Kofax Mobile SDK API Reference: kmc Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
kmc Directory Reference

Directories

directory | ken
directory | klo
directory | kui
directory | kut


Kofax Mobile SDK API Reference: ken Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
ken Directory Reference

Directories

directory engines


Kofax Mobile SDK API Reference: uicontrols Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kui
  • uicontrols
uicontrols Directory Reference

Directories

directory | captureanimations
directory | data
directory | version

Files

file | AutoFocusResultEvent.java
file | AutoFocusResultListener.java
file | BarCodeCaptureView.java
file | BarCodeFoundEvent.java
file | BarCodeFoundListener.java
file | CameraInitializationEvent.java
file | CameraInitializationFailedEvent.java
file | CameraInitializationFailedListener.java
file | CameraInitializationListener.java
file | ImageCapturedEvent.java
file | ImageCapturedListener.java
file | ImageCaptureView.java
file | ImgReviewEditCntrl.java
file | KUILogging.java
file | LevelnessEvent.java
file | LevelnessListener.java
file | LicenseCaptureView.java
file | LicenseFoundEvent.java
file | LicenseFoundListener.java
file | PageDetectionEvent.java
file | PageDetectionListener.java
file | PreviewCallbackListener.java
file | PreviewFrameEvent.java
file | StabilityDelayEvent.java
file | StabilityDelayListener.java
file | TorchLuminanceEvent.java
file | TorchLuminanceListener.java


Kofax Mobile SDK API Reference: bundle Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • extract
  • id
  • bundle
bundle Directory Reference

Files

file | BundleCacheProvider.java
file | IBundle.java
file | IBundleCacheProvider.java
file | IBundleFile.java
file | ZipFileBundle.java
file | ZipInputStreamBundle.java


Kofax Mobile SDK API Reference: sdk Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
sdk Directory Reference

Directories

directory | capture
directory | extract
directory | logistics

Files

file Logging.java


Kofax Mobile SDK API Reference: logistics Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • klo
  • logistics
logistics Directory Reference

Directories

directory | data
directory | version

Files

file | KLOLogging.java
file | SessionState.java


Kofax Mobile SDK API Reference: async Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • async
async Directory Reference

Files

file ListenerCallbackThreadType.java


Kofax Mobile SDK API Reference: version Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • kut
  • utilities
  • version
version Directory Reference

Files

file KutVersion.java


Kofax Mobile SDK API Reference: version Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • kmc
  • ken
  • engines
  • version
version Directory Reference

Files

file KenVersion.java


Kofax Mobile SDK API Reference: extraction Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • extraction
extraction Directory Reference

Files

file | ExceptionResponse.java
file | ExceptionResponseImpl.java
file | Extractor.java
file | ExtractorResponse.java
file | IExtractorListener.java


Kofax Mobile SDK API Reference: parameter Directory Reference

  • src
  • main
  • java
  • com
  • kofax
  • mobile
  • sdk
  • capture
  • parameter
parameter Directory Reference

Files

file | ExtractionCredentials.java
file | ExtractionParameters.java
file | IParameters.java
file | LookAndFeelParameters.java
file | ProcessingParameters.java


Kofax Mobile SDK API Reference: Related Pages

Related Pages
Here is a list of all related documentation pages:
Deprecated List


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • version
  • KenVersion
KenVersion Member List

This is the complete list of members for KenVersion, including all inherited members.

getPackageVersion() KenVersion static


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • IDocumentDetector
IDocumentDetector< T extends DetectionSettings, U extends DetectionResult > Member List

This is the complete list of members for IDocumentDetector< T extends DetectionSettings, U extends DetectionResult >, including all inherited members.

destroy() | IDocumentDetector< T extends DetectionSettings, U extends DetectionResult >
detect(T settings, Bitmap image) | IDocumentDetector< T extends DetectionSettings, U extends DetectionResult >
detect(T settings, byte[] data, int width, int height) | IDocumentDetector< T extends DetectionSettings, U extends DetectionResult >


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • Image
  • OutputColor
Image.OutputColor Member List

This is the complete list of members for Image.OutputColor, including all inherited members.

BITDEPTH_BITONAL | Image.OutputColor
BITDEPTH_COLOR | Image.OutputColor
BITDEPTH_GRAYSCALE | Image.OutputColor
getBitsPerChannel() | Image.OutputColor
getBitsPerPixel() | Image.OutputColor
getChannels() | Image.OutputColor
OutputColor(int channels, int bitsPerChannel) | Image.OutputColor


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • BarCodeType
BarCodeType Member List

This is the complete list of members for BarCodeType, including all inherited members.

AZTEC | BarCodeType
CODABAR | BarCodeType
CODE128 | BarCodeType
CODE25 | BarCodeType
CODE39 | BarCodeType
CODE93 | BarCodeType
DATAMATRIX | BarCodeType
EAN | BarCodeType
PDF417 | BarCodeType
POSTNET | BarCodeType
QR | BarCodeType
UNKNOWN | BarCodeType
UPC | BarCodeType


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • check
  • KtaCheckExtractor
KtaCheckExtractor Member List

This is the complete list of members for KtaCheckExtractor, including all inherited members.

COUNTRY | KtaCheckExtractor | static
getProcessName() | KtaCheckExtractor |
KtaCheckExtractor(IKtaSessionIdProviderFactory sessionIdProviderFactory, IImageToByteArray converter) | KtaCheckExtractor |
setCheckParameters(CheckParameters parameters) | KtaCheckExtractor |
updateKTARequest(JobService jobService) | KtaCheckExtractor | protected


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • IdWorkflowActivity
IdWorkflowActivity Member List

This is the complete list of members for IdWorkflowActivity, including all inherited members.

captureImage() | WorkflowActivity< T extends IParameters > | protected
CERTIFICATE_VALIDATOR_LISTENER | WorkflowActivity< T extends IParameters > | static
clearBitmap(String imageId) | WorkflowActivity< T extends IParameters > | protected
getCaptureActivityClass() | IdWorkflowActivity |
getDefaultProcessingString(IdParameters parameters) | IdWorkflowActivity |
com::kofax::mobile::sdk::capture::WorkflowActivity.getDefaultProcessingString(T parameters) | WorkflowActivity< T extends IParameters > |
getDefaultReturnObject() | IdWorkflowActivity |
getExceptionKey() | IdWorkflowActivity |
getExtractActivityClass() | IdWorkflowActivity |
getParameters(Bundle savedInstanceState) | WorkflowActivity< T extends IParameters > |
getParametersInstance() | IdWorkflowActivity |
getParametersKey() | IdWorkflowActivity |
getResultKey() | IdWorkflowActivity |
handleException(final Throwable exc) | WorkflowActivity< T extends IParameters > | protected
ID_BARCODE_RESULTS | IdWorkflowActivity | static
ID_EXCEPTION | IdWorkflowActivity | static
ID_PARAMETERS | IdWorkflowActivity | static
ID_RESULTS | IdWorkflowActivity | static
isOdeSupported() | IdWorkflowActivity | protected
onActivityResult(int requestCode, int resultCode, Intent data) | IdWorkflowActivity | protected
onCreate(Bundle savedInstanceState) | IdWorkflowActivity | protected
onDestroy() | WorkflowActivity< T extends IParameters > | protected
onResume() | WorkflowActivity< T extends IParameters > | protected
onSaveInstanceState(Bundle outState) | WorkflowActivity< T extends IParameters > | protected
tryRestoreState(Bundle savedInstanceState) | WorkflowActivity< T extends IParameters > | protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageClassifier
  • ImageClassificationStatus
ImageClassifier.ImageClassificationStatus Member List

This is the complete list of members for ImageClassifier.ImageClassificationStatus, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • data
  • FieldType
  • DataType
FieldType.DataType Member List

This is the complete list of members for FieldType.DataType, including all inherited members.

BOOL | FieldType.DataType
DATE | FieldType.DataType
EMAIL | FieldType.DataType
FLOAT | FieldType.DataType
INT | FieldType.DataType
STRING | FieldType.DataType
URL | FieldType.DataType


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • DocumentDetectionResult
DocumentDetectionResult Member List

This is the complete list of members for DocumentDetectionResult, including all inherited members.

getBounds() | DetectionResult
getHorizontalMovementGuidance() | DetectionResult
getOrientationGuidance() | DetectionResult
getOriginalImage() | DetectionResult
getTurnGuidance() | DetectionResult
getVerticalMovementGuidance() | DetectionResult
getZoomGuidance() | DetectionResult
toString() | DetectionResult


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • bill
  • BillParameters
BillParameters Member List

This is the complete list of members for BillParameters, including all inherited members.

BillParameters(Context context) BillParameters


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • Licensing
  • LicenseServerType
Licensing.LicenseServerType Member List

This is the complete list of members for Licensing.LicenseServerType, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • TorchLuminanceListener
TorchLuminanceListener Member List

This is the complete list of members for TorchLuminanceListener, including all inherited members.

onTorchLuminance(TorchLuminanceEvent event) TorchLuminanceListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • CameraInitializationListener
CameraInitializationListener Member List

This is the complete list of members for CameraInitializationListener, including all inherited members.

onCameraInitialized(CameraInitializationEvent event) CameraInitializationListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • KLOLogging
KLOLogging Member List

This is the complete list of members for KLOLogging, including all inherited members.

enableConsoleLogging(boolean enable) KLOLogging static


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • ImagePerfectionProfile
  • UseMRZPassportDetection
ImagePerfectionProfile.UseMRZPassportDetection Member List

This is the complete list of members for ImagePerfectionProfile.UseMRZPassportDetection, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • passport
  • IPassportExtractorListener
IPassportExtractorListener Member List

This is the complete list of members for IPassportExtractorListener, including all inherited members.

onExtractionComplete(T results) IExtractorListener< T extends ExtractorResponse >


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • passport
  • KtaPassportExtractor
KtaPassportExtractor Member List

This is the complete list of members for KtaPassportExtractor, including all inherited members.

getProcessName() | KtaPassportExtractor |
KtaPassportExtractor(IKtaSessionIdProviderFactory sessionIdProviderFactory, IImageToByteArray converter) | KtaPassportExtractor |
updateKTARequest(JobService jobService) | KtaPassportExtractor | protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageClassificationCompleteEvent
ImageClassificationCompleteEvent Member List

This is the complete list of members for ImageClassificationCompleteEvent, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • Image
  • ImageRep
Image.ImageRep Member List

This is the complete list of members for Image.ImageRep, including all inherited members.

IMAGE_REP_BITMAP | Image.ImageRep
IMAGE_REP_BOTH | Image.ImageRep
IMAGE_REP_FILE | Image.ImageRep
IMAGE_REP_NONE | Image.ImageRep


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • IdExtractor
IdExtractor Member List

This is the complete list of members for IdExtractor, including all inherited members.

createResponse(Id results, ExceptionResponse exceptionResponse) | IdExtractor | protected
com::kofax::mobile::sdk::capture::extraction::Extractor.createResponse(T results, ExceptionResponse exceptionResponse) | Extractor< T extends Serializable > | protected
extract(Image...images) | Extractor< T extends Serializable > |
Extractor() | Extractor< T extends Serializable > |
getDefaultServerUrl(ExtractionParameters.ExtractionType extractionType) | IdExtractor | protected
ID_EXTRACT_KTA | IdExtractor | static
ID_EXTRACT_ON_DEVICE | IdExtractor | static
ID_EXTRACT_RTTI | IdExtractor | static
IdExtractor() | IdExtractor |
onExtractionComplete(DataUnit unit) | Extractor< T extends Serializable > |
setCertificateValidatorListener(CertificateValidatorListener certificateValidatorListener) | Extractor< T extends Serializable > |
setExceptionResponseDeserializer(IExceptionResponseDeserializer exceptionResponseDeserializer) | Extractor< T extends Serializable > |
setExtractionServer(IExtractionServer extractionServer) | Extractor< T extends Serializable > |
setExtractorListener(IExtractorListener listener) | Extractor< T extends Serializable > |
setParameters(IdParameters parameters) | IdExtractor |
com::kofax::mobile::sdk::capture::extraction::Extractor.setParameters(ExtractionParameters parameters) | Extractor< T extends Serializable > |
setResultDeserializer(IDeserializer< T > resultDeserializer) | Extractor< T extends Serializable > |


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • IIdExtractor
IIdExtractor Member List

This is the complete list of members for IIdExtractor, including all inherited members.

cancel() | IIdExtractor
extractFields(IdExtractionParameters parameters) | IIdExtractor


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • logistics
  • IProgressListener
IProgressListener Member List

This is the complete list of members for IProgressListener, including all inherited members.

onProgress(int progressPercent, String jobID) IProgressListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • ImagePerfectionProfile
  • UseDocumentDetectionBasedCrop
ImagePerfectionProfile.UseDocumentDetectionBasedCrop Member List

This is the complete list of members for ImagePerfectionProfile.UseDocumentDetectionBasedCrop, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • bill
  • BillCaptureActivity
BillCaptureActivity Member List

This is the complete list of members for BillCaptureActivity, including all inherited members.

finish() | CaptureActivity |
getCameraView() | CaptureActivity | protected
IMAGE_CAPTURED | CaptureActivity | static
initController(IOverlayView view, IDetectionAdapter detectorAdapter) | CaptureActivity | protected
NO_IMAGE_CAPTURED | CaptureActivity | static
onActivityResult(int requestCode, int resultCode, Intent data) | CaptureActivity | protected
onCreate(Bundle savedInstanceState) | BillCaptureActivity | protected
onExitButtonClick() | CaptureActivity |
onForceCaptureButtonClick() | CaptureActivity |
onGalleryButtonClick() | CaptureActivity |
onPause() | CaptureActivity | protected
onResume() | CaptureActivity | protected
onSaveInstanceState(Bundle outState) | CaptureActivity | protected
onTorchChange(boolean checked) | CaptureActivity |
RESULT_CODE | CaptureActivity | static
saveResultAndFinish(Image image, Bundle bundle) | CaptureActivity | protected
setCaptureCriteria(CaptureCriteria criteria) | CaptureActivity | protected
setupButtonBarView(LinearLayout mainView) | CaptureActivity | protected
setupCameraView(ViewGroup container) | CaptureActivity | protected


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • extraction
  • ExceptionResponse
ExceptionResponse Member List

This is the complete list of members for ExceptionResponse, including all inherited members.

exceptionMessage() | ExceptionResponse
exceptionType() | ExceptionResponse
innerException() | ExceptionResponse
message() | ExceptionResponse
stackTrace() | ExceptionResponse


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • PageDetectionEvent
PageDetectionEvent Member List

This is the complete list of members for PageDetectionEvent, including all inherited members.

getBound() | PageDetectionEvent
getPreviewImage() | PageDetectionEvent
PageDetectionEvent(Object sender, Bitmap bitmap, BoundingTetragon bounds) | PageDetectionEvent


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • CameraInitializationFailedEvent
CameraInitializationFailedEvent Member List

This is the complete list of members for CameraInitializationFailedEvent, including all inherited members.

CameraInitializationFailedEvent(Object source, Exception cause) CameraInitializationFailedEvent


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • IIdExtractionListener
IIdExtractionListener Member List

This is the complete list of members for IIdExtractionListener, including all inherited members.

onExtractionComplete(IIdExtractionResult result, AggregateException exceptions) IIdExtractionListener


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • passport
  • PassportExtractorResponse
PassportExtractorResponse Member List

This is the complete list of members for PassportExtractorResponse, including all inherited members.

exceptionResponse ExtractorResponse< T extends Serializable >
PassportExtractorResponse(Passport result, ExceptionResponse exception) PassportExtractorResponse


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • creditcard
  • CreditCardWorkflowActivity
CreditCardWorkflowActivity Member List

This is the complete list of members for CreditCardWorkflowActivity, including all inherited members.

captureImage() | CreditCardWorkflowActivity | protected
CERTIFICATE_VALIDATOR_LISTENER | WorkflowActivity< T extends IParameters > | static
clearBitmap(String imageId) | WorkflowActivity< T extends IParameters > | protected
CREDIT_CARD_EXCEPTION | CreditCardWorkflowActivity | static
CREDIT_CARD_PARAMETERS | CreditCardWorkflowActivity | static
CREDIT_CARD_RESULTS | CreditCardWorkflowActivity | static
getCaptureActivityClass() | CreditCardWorkflowActivity |
getDefaultProcessingString(CreditCardParameters parameters) | CreditCardWorkflowActivity |
com::kofax::mobile::sdk::capture::WorkflowActivity.getDefaultProcessingString(T parameters) | WorkflowActivity< T extends IParameters > |
getDefaultReturnObject() | CreditCardWorkflowActivity |
getExceptionKey() | CreditCardWorkflowActivity |
getExtractActivityClass() | CreditCardWorkflowActivity |
getParameters(Bundle savedInstanceState) | WorkflowActivity< T extends IParameters > |
getParametersInstance() | CreditCardWorkflowActivity |
getParametersKey() | CreditCardWorkflowActivity |
getResultKey() | CreditCardWorkflowActivity |
handleException(final Throwable exc) | WorkflowActivity< T extends IParameters > | protected
isOdeSupported() | WorkflowActivity< T extends IParameters > | protected
onActivityResult(int requestCode, int resultCode, Intent data) | CreditCardWorkflowActivity | protected
onCreate(Bundle savedInstanceState) | CreditCardWorkflowActivity | protected
onDestroy() | WorkflowActivity< T extends IParameters > | protected
onResume() | WorkflowActivity< T extends IParameters > | protected
onSaveInstanceState(Bundle outState) | WorkflowActivity< T extends IParameters > | protected
tryRestoreState(Bundle savedInstanceState) | WorkflowActivity< T extends IParameters > | protected


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • model
  • PointDouble
PointDouble Member List

This is the complete list of members for PointDouble, including all inherited members.

PointDouble(double left, double top) PointDouble


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • IdExtractActivity
IdExtractActivity Member List

This is the complete list of members for IdExtractActivity, including all inherited members.

CERTIFICATE_VALIDATOR_LISTENER | ExtractActivity< T extends ExtractorResponse > | static
extract(Image image) | IdExtractActivity | protected
getImageByBitmapId(String id) | IdExtractActivity | protected
onCreate(Bundle savedInstanceState) | IdExtractActivity | protected
onExtractionComplete(T results) | ExtractActivity< T extends ExtractorResponse > |
onResume() | ExtractActivity< T extends ExtractorResponse > | protected
onSaveInstanceState(Bundle outState) | ExtractActivity< T extends ExtractorResponse > | protected
setExtract(Extractor extractor) | ExtractActivity< T extends ExtractorResponse > |


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • check
  • CheckCaptureActivity
CheckCaptureActivity Member List

This is the complete list of members for CheckCaptureActivity, including all inherited members.

finish() | CaptureActivity |
getCameraView() | CaptureActivity | protected
IMAGE_CAPTURED | CaptureActivity | static
initController(IOverlayView view, IDetectionAdapter detectorAdapter) | CaptureActivity | protected
NO_IMAGE_CAPTURED | CaptureActivity | static
onActivityResult(int requestCode, int resultCode, Intent data) | CaptureActivity | protected
onCreate(Bundle savedInstanceState) | CheckCaptureActivity | protected
onExitButtonClick() | CaptureActivity |
onForceCaptureButtonClick() | CaptureActivity |
onGalleryButtonClick() | CaptureActivity |
onPause() | CaptureActivity | protected
onResume() | CaptureActivity | protected
onSaveInstanceState(Bundle outState) | CaptureActivity | protected
onTorchChange(boolean checked) | CaptureActivity |
RESULT_CODE | CaptureActivity | static
saveResultAndFinish(Image image, Bundle bundle) | CaptureActivity | protected
setCaptureCriteria(CaptureCriteria criteria) | CaptureActivity | protected
setupButtonBarView(LinearLayout mainView) | CaptureActivity | protected
setupCameraView(ViewGroup container) | CaptureActivity | protected


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • model
  • Id
Id Member List

This is the complete list of members for Id, including all inherited members.

capturedImageId | CaptureData
getAddress() | Id
getAddress2() | Id
getAddress3() | Id
getAddress4() | Id
getAddress5() | Id
getAddress6() | Id
getCity() | Id
getCountry() | Id
getCountryShort() | Id
getDateOfBirth() | Id
getDocumentState() | Id
getDocumentType() | Id
getDocumentVerificationConfidenceRating() | Id
getExpirationDate() | Id
getEyes() | Id
getFaceImage() | Id
getFirstName() | Id
getGender() | Id
getHair() | Id
getHeight() | Id
getIdClass() | Id
getIdNumber() | Id
getIssueDate() | Id
getLastName() | Id
getLicense() | Id
getMiddleName() | Id
getNameSuffix() | Id
getNationality() | Id
getRawData() | Id
getSignatureImage() | Id
getState() | Id
getWeight() | Id
getZip() | Id
isBarcodeRead() | Id
isOcrRead() | Id
processedImageId | CaptureData


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • KUILogging
KUILogging Member List

This is the complete list of members for KUILogging, including all inherited members.

enableConsoleLogging(boolean enable) KUILogging static


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • parameter
  • LookAndFeelParameters
LookAndFeelParameters Member List

This is the complete list of members for LookAndFeelParameters, including all inherited members.

exitEnabled | LookAndFeelParameters
forceCaptureEnabled | LookAndFeelParameters
galleryEnabled | LookAndFeelParameters
LookAndFeelParameters() | LookAndFeelParameters
manualCaptureTimer | LookAndFeelParameters
reviewCapturedImage | LookAndFeelParameters
reviewProcessedImage | LookAndFeelParameters
torch | LookAndFeelParameters


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • AggregateException
AggregateException Member List

This is the complete list of members for AggregateException, including all inherited members.

AggregateException(Exception front, Exception back) AggregateException


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • passport
  • RttiPassportExtractor
RttiPassportExtractor Member List

This is the complete list of members for RttiPassportExtractor, including all inherited members.

RttiPassportExtractor(IImageToByteArray converter) | RttiPassportExtractor |
updateRttiRequest(RttiRequest rttiRequest) | RttiPassportExtractor | protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • StabilityDelayListener
StabilityDelayListener Member List

This is the complete list of members for StabilityDelayListener, including all inherited members.

onStabilityDelay(StabilityDelayEvent event) StabilityDelayListener


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • bundle
  • ZipInputStreamBundle
ZipInputStreamBundle Member List

This is the complete list of members for ZipInputStreamBundle, including all inherited members.

close() | ZipInputStreamBundle
hasMoreElements() | ZipInputStreamBundle
list() | ZipInputStreamBundle
nextElement() | ZipInputStreamBundle
ZipInputStreamBundle(ZipInputStream file) | ZipInputStreamBundle
ZipInputStreamBundle(InputStream file) | ZipInputStreamBundle


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • BarCodeDirection
BarCodeDirection Member List

This is the complete list of members for BarCodeDirection, including all inherited members.

BOTTOM_UP | BarCodeDirection
LEFT_RIGHT | BarCodeDirection
RIGHT_LEFT | BarCodeDirection
TOP_DOWN | BarCodeDirection
UNKNOWN | BarCodeDirection


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • PreviewFrameEvent
PreviewFrameEvent Member List

This is the complete list of members for PreviewFrameEvent, including all inherited members.

getBitmap() | PreviewFrameEvent
getBitmap(boolean rotated) | PreviewFrameEvent
getBitmapLandscape() | PreviewFrameEvent
getData() | PreviewFrameEvent
getHeight() | PreviewFrameEvent
getRotation() | PreviewFrameEvent
getRotationLandscape() | PreviewFrameEvent
getWidth() | PreviewFrameEvent
PreviewFrameEvent(Object sender, RealtimeVideoEvent evt) | PreviewFrameEvent


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • BarCodeCaptureView
BarCodeCaptureView Member List

This is the complete list of members for BarCodeCaptureView, including all inherited members.

_bus | ImageCaptureView | protected
addBarCodeFoundEventListener(BarCodeFoundListener listener) | BarCodeCaptureView
addCameraInitializationFailedListener(CameraInitializationFailedListener listener) | ImageCaptureView
addCameraInitializationListener(CameraInitializationListener listener) | ImageCaptureView
addLevelnessListener(LevelnessListener listener) | ImageCaptureView
addOnAutoFocusResultListener(AutoFocusResultListener listener) | ImageCaptureView
addOnImageCapturedListener(ImageCapturedListener listener) | ImageCaptureView
addPreviewCallbackListener(PreviewCallbackListener listener) | ImageCaptureView
addStabilityDelayListener(StabilityDelayListener listener) | ImageCaptureView
addTorchLuminanceListener(TorchLuminanceListener listener) | ImageCaptureView
BarCodeCaptureView(Context context) | BarCodeCaptureView
BarCodeCaptureView(Context context, AttributeSet set) | BarCodeCaptureView
BarCodeCaptureView(Context context, AttributeSet set, int defStyle) | BarCodeCaptureView
calculateBound(float[] points, int rotation, int width, int height) | BarCodeCaptureView
checkLicense() | BarCodeCaptureView | protected
DEFAULT_LUMINANCE_THRESHOLD | ImageCaptureView | static
DEFAULT_TORCH_DELAY | ImageCaptureView | static
forceTakePicture() ImageCaptureView
forceTakePicture(boolean focusAgain) | ImageCaptureView
getAllowableImageResolutions() ImageCaptureView
getDeviceDeclinationPitch() ImageCaptureView
getDeviceDeclinationRoll() ImageCaptureView
getFlash() ImageCaptureView
getFocusAreas() ImageCaptureView
getGpsUsage() ImageCaptureView
getGuidingLine() BarCodeCaptureView
getImagePreviewHeight() ImageCaptureView
getImagePreviewWidth() ImageCaptureView
getLuminanceThreshold() ImageCaptureView
getMaxFocusAreas() ImageCaptureView
getSearchDirection() BarCodeCaptureView
getSymbologies() BarCodeCaptureView
getTorchDelay() ImageCaptureView
getUseVideoFrame() ImageCaptureView
getViewGroup() ImageCaptureView
ImageCaptureView(Context context) | ImageCaptureView
ImageCaptureView(Context context, AttributeSet set) | ImageCaptureView
ImageCaptureView(Context context, AttributeSet set, int defStyle) | ImageCaptureView
isFlashSupported(Flash flash) | ImageCaptureView
muteAutoTorch() ImageCaptureView
onAttachedToWindow() | ImageCaptureView | protected
onDetachedFromWindow() | ImageCaptureView | protected
onLayout(boolean changed, int l, int t, int r, int b) | ImageCaptureView | protected
onLevelnessChanged(LevelChangedEvent evt) | BarCodeCaptureView
onLocationEnableEvent(GPSEnabledEvent evt) | BarCodeCaptureView
onLocationEvent(LocationEvent evt) | BarCodeCaptureView
onPreviewFrame(PreviewImageReadyBusEvent evt) | BarCodeCaptureView
readBarcode() BarCodeCaptureView
removeAllViews() ImageCaptureView
removeBarCodeFoundEventListener(BarCodeFoundListener listener) | BarCodeCaptureView
removeCameraInitializationFailedListener(CameraInitializationFailedListener listener) | ImageCaptureView
removeCameraInitializationListener(CameraInitializationListener listener) | ImageCaptureView
removeLevelnessListener(LevelnessListener listener) | ImageCaptureView
removeOnAutoFocusResultListener(AutoFocusResultListener listener) | ImageCaptureView
removeOnImageCapturedListener(ImageCapturedListener listener) | ImageCaptureView
removePreviewCallbackListener(PreviewCallbackListener listener) | ImageCaptureView
removeStabilityDelayListener(StabilityDelayListener listener) | ImageCaptureView
removeTorchLuminanceListener(TorchLuminanceListener listener) | ImageCaptureView
sessionCreate() ImageCaptureView
sessionDismiss() ImageCaptureView
setCameraType(CameraType cameraType) | ImageCaptureView
setDeviceDeclinationPitch(int angle) | ImageCaptureView
setDeviceDeclinationRoll(int angle) | ImageCaptureView
setFlash(Flash flash) | ImageCaptureView
setFocusAreas(List< Rect > focusAreas) | ImageCaptureView
setGpsUsage(GpsUsageLimits limits) | ImageCaptureView
setGuidingLine(GuidingLine value) | BarCodeCaptureView
setImageResolution(Size resolution) | ImageCaptureView
setLuminanceThreshold(int luminanceThreshold) | ImageCaptureView
setSearchDirection(SearchDirection[] value) | BarCodeCaptureView
setSymbologies(Symbology[] value) | BarCodeCaptureView
setTorchDelay(int torchDelay) | ImageCaptureView
setUseVideoFrame(boolean useVideo) | ImageCaptureView
surfaceChanged(SurfaceHolder holder, int format, int width, int height) | ImageCaptureView
surfaceCreated(SurfaceHolder holder) | ImageCaptureView
surfaceDestroyed(SurfaceHolder holder) | ImageCaptureView


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • version
  • KutVersion
KutVersion Member List

This is the complete list of members for KutVersion, including all inherited members.

getPackageVersion() KutVersion static


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • data
  • GpsUsageLimits
GpsUsageLimits Member List

This is the complete list of members for GpsUsageLimits, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageProcessor
  • AnalysisProgressListener
ImageProcessor.AnalysisProgressListener Member List

This is the complete list of members for ImageProcessor.AnalysisProgressListener, including all inherited members.

analysisProgress(AnalysisProgressEvent event) ImageProcessor.AnalysisProgressListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • LevelnessEvent
LevelnessEvent Member List

This is the complete list of members for LevelnessEvent, including all inherited members.

getPitch() | LevelnessEvent
getRoll() | LevelnessEvent
LevelnessEvent(Object source, int pitch, int roll) | LevelnessEvent


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsExportEvent
AppStatsExportEvent Member List

This is the complete list of members for AppStatsExportEvent, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageProcessor
  • AnalysisCompleteEvent
ImageProcessor.AnalysisCompleteEvent Member List

This is the complete list of members for ImageProcessor.AnalysisCompleteEvent, including all inherited members.

AnalysisCompleteEvent(Object sender, ErrorInfo status, Image image) ImageProcessor.AnalysisCompleteEvent


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • passport
  • RttiJsonPassport
RttiJsonPassport Member List

This is the complete list of members for RttiJsonPassport, including all inherited members.

capturedImageId | CaptureData
getCountry() | RttiJsonPassport
getCountryLong() | RttiJsonPassport
getDateOfBirth() | RttiJsonPassport
getExpirationDate() | RttiJsonPassport
getFirstName() | RttiJsonPassport
getGender() | RttiJsonPassport
getIssueDate() | RttiJsonPassport
getLastName() | RttiJsonPassport
getMiddleName() | RttiJsonPassport
getMRZ1() | RttiJsonPassport
getMRZ2() | RttiJsonPassport
getNationality() | RttiJsonPassport
getPassportNumber() | RttiJsonPassport
getPersonalNumber() | RttiJsonPassport
getRawData() | RttiJsonPassport
processedImageId | CaptureData
RttiJsonPassport(Context context, String json) | RttiJsonPassport
setJson(String json) | RttiJsonPassport


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • extraction
  • IExtractorListener
IExtractorListener< T extends ExtractorResponse > Member List

This is the complete list of members for IExtractorListener< T extends ExtractorResponse >, including all inherited members.

onExtractionComplete(T results) IExtractorListener< T extends ExtractorResponse >


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • model
  • CaptureData
CaptureData Member List

This is the complete list of members for CaptureData, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • data
  • Page
Page Member List

This is the complete list of members for Page, including all inherited members.

addImage(Image image) | Page |
getCurrentImageIndex() | Page |
getDocumentID() | Page |
getImages() | Page |
getPageID() | Page |
getSheetID() | Page |
getSide() | Page |
Page() | Page |
removeImage(String imageID) | Page |
setCurrentImageIndex(int currentImageIndex) | Page |
setDocumentID(String documentID) | Page | protected
setSheetID(int sheetID) | Page |
setSide(Side pageSide) | Page |


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • CaptureExperienceCriteriaHolder
CaptureExperienceCriteriaHolder Member List

This is the complete list of members for CaptureExperienceCriteriaHolder, including all inherited members.

CaptureExperienceCriteriaHolder() | CaptureExperienceCriteriaHolder
getPitchThreshold() | CaptureExperienceCriteriaHolder
getRollThreshold() | CaptureExperienceCriteriaHolder
getStabilityThreshold() | CaptureExperienceCriteriaHolder
isFocusEnabled() | CaptureExperienceCriteriaHolder
isOrientationEnabled() | CaptureExperienceCriteriaHolder
isPitchThresholdEnabled() | CaptureExperienceCriteriaHolder
isRefocusBeforeCaptureEnabled() | CaptureExperienceCriteriaHolder
isRollThresholdEnabled() | CaptureExperienceCriteriaHolder
isStabilityThresholdEnabled() | CaptureExperienceCriteriaHolder
setFocusEnabled(boolean focusEnabled) | CaptureExperienceCriteriaHolder
setOrientationEnabled(boolean enabled) | CaptureExperienceCriteriaHolder
setPitchThreshold(int pitchThreshold) | CaptureExperienceCriteriaHolder
setPitchThresholdEnabled(boolean pitchThresholdEnabled) | CaptureExperienceCriteriaHolder
setRefocusEnabled(boolean enabled) | CaptureExperienceCriteriaHolder
setRollThreshold(int rollThreshold) | CaptureExperienceCriteriaHolder
setRollThresholdEnabled(boolean rollThresholdEnabled) | CaptureExperienceCriteriaHolder
setStabilityThreshold(int stabilityThreshold) | CaptureExperienceCriteriaHolder
setStabilityThresholdEnabled(boolean stabilityThresholdEnabled) | CaptureExperienceCriteriaHolder


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • bundle
  • IBundle
IBundle Member List

This is the complete list of members for IBundle, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • Licensing
  • LicenseType
Licensing.LicenseType Member List

This is the complete list of members for Licensing.LicenseType, including all inherited members.

BARCODE_CAPTURE | Licensing.LicenseType
ID_EXTRACTION | Licensing.LicenseType
IMAGE_CAPTURE | Licensing.LicenseType
IMAGE_PROCESSING | Licensing.LicenseType
LOGISTICS | Licensing.LicenseType


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • data
  • DocumentType
DocumentType Member List

This is the complete list of members for DocumentType, including all inherited members.

clone() | DocumentType
DocumentType(List< FieldType > fieldTypes) | DocumentType
getBasicSettingsProfile() | DocumentType
getDisplayName() | DocumentType
getDocHeight() | DocumentType
getDocWidth() | DocumentType
getFieldTypes() | DocumentType
getImagePerfectionProfile() | DocumentType
getSourceServer() | DocumentType
getTypeName() | DocumentType
getVersion() | DocumentType
setBasicSettingsProfile(BasicSettingsProfile basicSettingsProfile) | DocumentType
setDisplayName(String displayName) | DocumentType
setDocHeight(float docHeight) | DocumentType
setDocWidth(float docWidth) | DocumentType
setImagePerfectionProfile(ImagePerfectionProfile imagePerfectionProfile) | DocumentType
setSourceServer(SourceServer sourceServer) | DocumentType
setTypeName(String typeName) | DocumentType
setVersion(String version) | DocumentType


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • IImageStorage
IImageStorage Member List

This is the complete list of members for IImageStorage, including all inherited members.

getImage(String id) | IImageStorage
removeImage(String id) | IImageStorage
setImage(Bitmap image, String id) | IImageStorage


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • creditcard
  • CreditCardParameters
  • CardStyle
CreditCardParameters.CardStyle Member List

This is the complete list of members for CreditCardParameters.CardStyle, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • passport
  • PassportExtractActivity
PassportExtractActivity Member List

This is the complete list of members for PassportExtractActivity, including all inherited members.

CERTIFICATE_VALIDATOR_LISTENER | ExtractActivity< T extends ExtractorResponse > | static
extract(Image image) | ExtractActivity< T extends ExtractorResponse > | protected
getImageByBitmapId(String id) | ExtractActivity< T extends ExtractorResponse > | protected
onCreate(Bundle savedInstanceState) | PassportExtractActivity | protected
onExtractionComplete(T results) | ExtractActivity< T extends ExtractorResponse > |
onResume() | ExtractActivity< T extends ExtractorResponse > | protected
onSaveInstanceState(Bundle outState) | ExtractActivity< T extends ExtractorResponse > | protected
PASSPORT_EXTRACT | PassportExtractActivity | static
setExtract(Extractor extractor) | ExtractActivity< T extends ExtractorResponse > |


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • IProjectProvider
IProjectProvider Member List

This is the complete list of members for IProjectProvider, including all inherited members.

getHighestVersion(final String projectName, final String sdkVersion, final ICompletionListener< String > listener) | IProjectProvider
getLatestCachedModelDataBuildInfo(String projectName) | IProjectProvider
getProject(final String projectName, final String version, final ICompletionListener< File > listener) | IProjectProvider
getVariant(final String projectName, final String variantName, final String version, final ICompletionListener< File > listener) | IProjectProvider


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • PassportDetectionSettings
PassportDetectionSettings Member List

This is the complete list of members for PassportDetectionSettings, including all inherited members.

DetectionSettings() | DetectionSettings | protected
DetectionSettings(DetectionSettings settings) | DetectionSettings | protected
DetectionSettings(Point targetFrameCenter, double targetFrameAspectRatio, double targetFramePaddingPercent) | DetectionSettings |
getCenterPoint() | DetectionSettings |
getMaxFillFraction() | DetectionSettings |
getMaxSkewAngle() | DetectionSettings |
getMinFillFraction() | DetectionSettings |
getTargetFrameAspectRatio() | PassportDetectionSettings |
getTargetFramePaddingPercent() | DetectionSettings |
getToleranceFraction() | DetectionSettings |
PassportDetectionSettings() | PassportDetectionSettings |
PassportDetectionSettings(PassportDetectionSettings detectionSettings) | PassportDetectionSettings |
setCenterPoint(Point targetFrameCenter) | DetectionSettings |
setMaxFillFraction(double maxFillFraction) | DetectionSettings |
setMaxSkewAngle(double maxSkewAngle) | DetectionSettings |
setMinFillFraction(double minFillFraction) | DetectionSettings |
setTargetFrameAspectRatio(double targetFrameAspectRatio) | PassportDetectionSettings |
setTargetFramePaddingPercent(double paddingPercent) | DetectionSettings |
setToleranceFraction(double toleranceFraction) | DetectionSettings |


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • ImageCapturedEvent
ImageCapturedEvent Member List

This is the complete list of members for ImageCapturedEvent, including all inherited members.

getImage() | ImageCapturedEvent
ImageCapturedEvent(Object sender, Image image) | ImageCapturedEvent


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • DetectionSettings
DetectionSettings Member List

This is the complete list of members for DetectionSettings, including all inherited members.

DetectionSettings() | DetectionSettings | protected
DetectionSettings(DetectionSettings settings) | DetectionSettings | protected
DetectionSettings(Point targetFrameCenter, double targetFrameAspectRatio, double targetFramePaddingPercent) | DetectionSettings |
getCenterPoint() | DetectionSettings |
getMaxFillFraction() | DetectionSettings |
getMaxSkewAngle() | DetectionSettings |
getMinFillFraction() | DetectionSettings |
getTargetFrameAspectRatio() | DetectionSettings |
getTargetFramePaddingPercent() | DetectionSettings |
getToleranceFraction() | DetectionSettings |
setCenterPoint(Point targetFrameCenter) | DetectionSettings |
setMaxFillFraction(double maxFillFraction) | DetectionSettings |
setMaxSkewAngle(double maxSkewAngle) | DetectionSettings |
setMinFillFraction(double minFillFraction) | DetectionSettings |
setTargetFrameAspectRatio(double targetFrameAspectRatio) | DetectionSettings |
setTargetFramePaddingPercent(double paddingPercent) | DetectionSettings |
setToleranceFraction(double toleranceFraction) | DetectionSettings |


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • logistics
  • ICaptureServer
ICaptureServer Member List

This is the complete list of members for ICaptureServer, including all inherited members.

cancelSubmission(String submitJobID) | ICaptureServer
getDocumentType(String documentTypeName, ICompletionListener< DocumentType > completionListener) | ICaptureServer
login(UserProfile userProfile, ICompletionListener< List< String >> completionListener) | ICaptureServer
loginAnonymously(ICompletionListener< List< String >> completionListener) | ICaptureServer
logout(ICompletionListener< Void > completionListener) | ICaptureServer
registerDevice(ICompletionListener< Void > completionListener) | ICaptureServer
sendImageService(Document document, String jobID, Image image, int ImageIndex, boolean lastImage, ICompletionListener< Void > completionListener) | ICaptureServer
startJobService(ICompletionListener< String > completionListener) | ICaptureServer
submitDocument(Document document, IProgressListener iProgressListener, ICompletionListener iCompletionListener) | ICaptureServer


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • IdRegion
IdRegion Member List

This is the complete list of members for IdRegion, including all inherited members.

_regionName IdRegion
AFRICA IdRegion
ASIA IdRegion
AUSTRALIA IdRegion
CANADA IdRegion
EUROPE IdRegion
getRegionName() IdRegion
IdRegion(String regionName) IdRegion


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • Logging
Logging Member List

This is the complete list of members for Logging, including all inherited members.

enableConsoleLogging(boolean enable) Logging static


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • ServerProjectProvider
ServerProjectProvider Member List

This is the complete list of members for ServerProjectProvider, including all inherited members.

cancelLoadAllVariants() | ServerProjectProvider |
getHighestVersion(final String projectName, final String sdkVersion, final ICompletionListener< String > listener) | ServerProjectProvider |
getHighestVersionAsync(final String projectName, final String sdkVersion, final boolean bulk) | ServerProjectProvider | protected
getLatestCachedModelDataBuildInfo(String projectName) | ServerProjectProvider |
getProject(final String projectName, final String version, final ICompletionListener< File > listener) | ServerProjectProvider |
getVariant(final String projectName, final String variantName, final String version, final ICompletionListener< File > listener) | ServerProjectProvider |
loadAllVariantsForProject(final String projectName, final ICompletionListener< Void > listener) | ServerProjectProvider |
sdkVersion() | ServerProjectProvider | protected
ServerProjectProvider(Context ctx, String baseUrl) | ServerProjectProvider |
ServerProjectProvider(Context ctx, IBundleCacheProvider cacheProvider, String baseUrl, ConnectivityManager connectivityManager) | ServerProjectProvider |
setCertificateValidatorListener(CertificateValidatorListener certificateValidatorListener) | ServerProjectProvider |
setRequestTimeout(long duration, TimeUnit timeUnit) | ServerProjectProvider |


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • data
  • UserProfile
UserProfile Member List

This is the complete list of members for UserProfile, including all inherited members.

clone() | UserProfile
getDomain() | UserProfile
getPassword() | UserProfile
getUserEmailAddress() | UserProfile
getUsername() | UserProfile
setDomain(String domain) | UserProfile
setPassword(String password) | UserProfile
setUserEmailAddress(String userEmailAddress) | UserProfile
setUsername(String username) | UserProfile


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • bill
  • RttiJsonBill
RttiJsonBill Member List

This is the complete list of members for RttiJsonBill, including all inherited members.

capturedImageId | CaptureData
getAccountNumber() | RttiJsonBill
getAddressLine1() | RttiJsonBill
getAddressLine2() | RttiJsonBill
getAmount() | RttiJsonBill
getBillers() | RttiJsonBill
getCity() | RttiJsonBill
getDueDate() | RttiJsonBill
getName() | RttiJsonBill
getPhoneNumber() | RttiJsonBill
getRawData() | RttiJsonBill
getSource() | RttiJsonBill
getState() | RttiJsonBill
getZip() | RttiJsonBill
processedImageId | CaptureData
RttiJsonBill(Context context, String json) | RttiJsonBill
setJson(String json) | RttiJsonBill


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • PreviewCallbackListener
PreviewCallbackListener Member List

This is the complete list of members for PreviewCallbackListener, including all inherited members.

onPreviewFrame(PreviewFrameEvent event) PreviewCallbackListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • BasicSettingsProfile
BasicSettingsProfile Member List

This is the complete list of members for BasicSettingsProfile, including all inherited members.

BasicSettingsProfile() | BasicSettingsProfile
clone() | BasicSettingsProfile
getCroppingTetragon() | BasicSettingsProfile
getCropType() | BasicSettingsProfile
getDoDeskew() | BasicSettingsProfile
getInputDocLongEdge() | BasicSettingsProfile
getInputDocShortEdge() | BasicSettingsProfile
getOutputBitDepth() | BasicSettingsProfile
getOutputDPI() | BasicSettingsProfile
getRotateType() | BasicSettingsProfile
setCroppingTetragon(BoundingTetragon croppingTetragon) | BasicSettingsProfile
setCropType(CropType cropType) | BasicSettingsProfile
setDoDeskew(boolean doDeskew) | BasicSettingsProfile
setInputDocLongEdge(Float inputDocLongEdge) | BasicSettingsProfile
setInputDocShortEdge(Float inputDocShortEdge) | BasicSettingsProfile
setOutputBitDepth(OutputBitDepth outputBitDepth) | BasicSettingsProfile
setOutputDPI(Integer outputDPI) | BasicSettingsProfile
setRotateType(RotateType rotateType) | BasicSettingsProfile


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • TorchLuminanceEvent
TorchLuminanceEvent Member List

This is the complete list of members for TorchLuminanceEvent, including all inherited members.

getLuminance() | TorchLuminanceEvent
isBelowThreshold() | TorchLuminanceEvent
isTorchOn() | TorchLuminanceEvent
TorchLuminanceEvent(Object sender, int luminance, boolean belowThreshold, boolean torchOn) | TorchLuminanceEvent


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • Licensing
Licensing Member List

This is the complete list of members for Licensing, including all inherited members.

acquireVolumeLicenses(LicenseType licenseType, int count) | Licensing | static
addVolumeLicenseEventListener(VolumeLicenseEventListener listener) | Licensing | static
getDaysRemaining() | Licensing | static
getRemainingLicenseCount(LicenseType licenseType) | Licensing | static
isSdkLicensed(LicenseType licenseType) | Licensing | static
removeVolumeLicenseEventListener(VolumeLicenseEventListener listener) | Licensing | static
setCertificateValidatorListener(CertificateValidatorListener certificateValidatorListener) | Licensing | static
setMobileSDKLicense(String licenseStr) | Licensing | static
setMobileSDKLicenseServer(String licenseServerName, LicenseServerType licenseServerType) | Licensing | static


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • bill
  • RttiBillExtractor
RttiBillExtractor Member List

This is the complete list of members for RttiBillExtractor, including all inherited members.

RttiBillExtractor(IImageToByteArray converter) RttiBillExtractor


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • server
  • IServerExtractor
IServerExtractor Member List

This is the complete list of members for IServerExtractor, including all inherited members.

cancelExtraction() | IServerExtractor
extractData(ServerExtractionParameters serverExtractionParameters, ICompletionListener< String > completionListener) | IServerExtractor
login(LoginCredentials loginCredentials, ICompletionListener< String > completionListener) | IServerExtractor


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • bill
  • BillExtractorResponse
BillExtractorResponse Member List

This is the complete list of members for BillExtractorResponse, including all inherited members.

BillExtractorResponse(Bill result, ExceptionResponse exception) BillExtractorResponse


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • SdkVersion
SdkVersion Member List

This is the complete list of members for SdkVersion, including all inherited members.

compare(String version1, String version2) | SdkVersion | static
getBcVersion() | SdkVersion | static
getClassifierVersion() | SdkVersion | static
getIpVersion() | SdkVersion | static
getPackageVersion() | SdkVersion | static
getSdkVersion() | SdkVersion | static
versionCompatible(String versionCurrent, String versionDeserialized) | SdkVersion | static


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • LicenseCaptureView
LicenseCaptureView Member List

This is the complete list of members for LicenseCaptureView, including all inherited members.

_bus | ImageCaptureView | protected
addCameraInitializationFailedListener(CameraInitializationFailedListener listener) | ImageCaptureView
addCameraInitializationListener(CameraInitializationListener listener) | ImageCaptureView
addLevelnessListener(LevelnessListener listener) | ImageCaptureView
addLicenseFoundEventListener(LicenseFoundListener listener) | LicenseCaptureView
addOnAutoFocusResultListener(AutoFocusResultListener listener) | ImageCaptureView
addOnImageCapturedListener(ImageCapturedListener listener) | ImageCaptureView
addPreviewCallbackListener(PreviewCallbackListener listener) | ImageCaptureView
addStabilityDelayListener(StabilityDelayListener listener) | ImageCaptureView
addTorchLuminanceListener(TorchLuminanceListener listener) | ImageCaptureView
checkLicense() | LicenseCaptureView | protected
DEFAULT_LUMINANCE_THRESHOLD | ImageCaptureView | static
DEFAULT_TORCH_DELAY | ImageCaptureView | static
forceTakePicture() ImageCaptureView
forceTakePicture(boolean focusAgain) | ImageCaptureView
getAllowableImageResolutions() ImageCaptureView
getDeviceDeclinationPitch() ImageCaptureView
getDeviceDeclinationRoll() ImageCaptureView
getFlash() ImageCaptureView
getFocusAreas() ImageCaptureView
getGpsUsage() ImageCaptureView
getImagePreviewHeight() ImageCaptureView
getImagePreviewWidth() ImageCaptureView
getLuminanceThreshold() ImageCaptureView
getMaxFocusAreas() ImageCaptureView
getOuterViewFinderColor() LicenseCaptureView
getTorchDelay() ImageCaptureView
getUserInstructionMessage() LicenseCaptureView
getUseVideoFrame() ImageCaptureView
getViewfinderPaddingPercent() LicenseCaptureView
getViewGroup() ImageCaptureView
ImageCaptureView(Context context) | ImageCaptureView
ImageCaptureView(Context context, AttributeSet set) | ImageCaptureView
ImageCaptureView(Context context, AttributeSet set, int defStyle) | ImageCaptureView
isFlashSupported(Flash flash) | ImageCaptureView
LicenseCaptureView(Context context) | LicenseCaptureView
LicenseCaptureView(Context context, AttributeSet set) | LicenseCaptureView
LicenseCaptureView(Context context, AttributeSet set, int defStyle) | LicenseCaptureView
muteAutoTorch() ImageCaptureView
onAttachedToWindow() | ImageCaptureView | protected
onDetachedFromWindow() | ImageCaptureView | protected
onLayout(boolean changed, int l, int t, int r, int b) | ImageCaptureView | protected
onPreviewFrame(PreviewImageReadyBusEvent evt) | LicenseCaptureView
readLicense() LicenseCaptureView
removeAllViews() ImageCaptureView
removeCameraInitializationFailedListener(CameraInitializationFailedListener listener) | ImageCaptureView
removeCameraInitializationListener(CameraInitializationListener listener) | ImageCaptureView
removeLevelnessListener(LevelnessListener listener) | ImageCaptureView
removeLicenseFoundEventListener(LicenseFoundListener listener) | LicenseCaptureView
removeOnAutoFocusResultListener(AutoFocusResultListener listener) | ImageCaptureView
removeOnImageCapturedListener(ImageCapturedListener listener) | ImageCaptureView
removePreviewCallbackListener(PreviewCallbackListener listener) | ImageCaptureView
removeStabilityDelayListener(StabilityDelayListener listener) | ImageCaptureView
removeTorchLuminanceListener(TorchLuminanceListener listener) | ImageCaptureView
sessionCreate() ImageCaptureView
sessionDismiss() ImageCaptureView
setCameraType(CameraType cameraType) | ImageCaptureView
setDeviceDeclinationPitch(int angle) | ImageCaptureView
setDeviceDeclinationRoll(int angle) | ImageCaptureView
setFlash(Flash flash) | ImageCaptureView
setFocusAreas(List< Rect > focusAreas) | ImageCaptureView
setGpsUsage(GpsUsageLimits limits) | ImageCaptureView
setImageResolution(Size resolution) | ImageCaptureView
setLuminanceThreshold(int luminanceThreshold) | ImageCaptureView
setOuterViewFinderColor(int colorCode) | LicenseCaptureView
setTorchDelay(int torchDelay) | ImageCaptureView
setUserInstructionMessage(CaptureMessage userInstructionsMessage) | LicenseCaptureView
setUseVideoFrame(boolean useVideo) | ImageCaptureView
setViewfinderPaddingPercent(double paddingPercent) | LicenseCaptureView
surfaceChanged(SurfaceHolder holder, int format, int width, int height) | ImageCaptureView
surfaceCreated(SurfaceHolder holder) | ImageCaptureView
surfaceDestroyed(SurfaceHolder holder) | ImageCaptureView


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppstatsThresholdReachedListener
AppstatsThresholdReachedListener Member List

This is the complete list of members for AppstatsThresholdReachedListener, including all inherited members.

thresholdReached(AppStatsThresholdReachedEvent event) AppstatsThresholdReachedListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsWriteFileListener
AppStatsWriteFileListener Member List

This is the complete list of members for AppStatsWriteFileListener, including all inherited members.

writeFileStatusEvent(AppStatsWritetoFileEvent event) AppStatsWriteFileListener


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • LocalProjectProvider
  • VersionTable
  • VersionList
LocalProjectProvider.VersionTable.VersionList Member List

This is the complete list of members for LocalProjectProvider.VersionTable.VersionList, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • Size
Size Member List

This is the complete list of members for Size, including all inherited members.

equals(Object obj) | Size
hashCode() Size
height Size
Size(int w, int h) | Size
Size(Point point) | Size
Size(Camera.Size size) | Size
Size(android.util.Size size) | Size


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • DataField
DataField Member List

This is the complete list of members for DataField, including all inherited members.

clone() | Field< T extends Serializable > |
DataField(String name, String object, double confidence, FieldLocation location) | DataField |
equals(Object o) | Field< T extends Serializable > |
Field(String name, T object, double confidence, FieldLocation location) | Field< T extends Serializable > |
fromExtractorField(com.kofax.android.abc.document.Field field) | DataField | static
getConfidence() | DataField |
getLocation() | Field< T extends Serializable > |
getName() | Field< T extends Serializable > |
getObject() | DataField |
hashCode() | Field< T extends Serializable > |
toString() | Field< T extends Serializable > |


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • PageDetectionListener
PageDetectionListener Member List

This is the complete list of members for PageDetectionListener, including all inherited members.

pageDetected(PageDetectionEvent event) PageDetectionListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageProcessor
  • ImageOutEvent
ImageProcessor.ImageOutEvent Member List

This is the complete list of members for ImageProcessor.ImageOutEvent, including all inherited members.

getImage() | ImageProcessor.ImageOutEvent
getStatus() | ImageProcessor.ImageOutEvent
ImageOutEvent(Object sender, ErrorInfo status, Image image) | ImageProcessor.ImageOutEvent


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • model
  • CheckIQAData
CheckIQAData Member List

This is the complete list of members for CheckIQAData, including all inherited members.

getAboveMaxFrontImageSize() | CheckIQAData
getAboveMaxRearImageSize() | CheckIQAData
getAdditionalBottomScanLinesHeight() | CheckIQAData
getAdditionalLeftScanLinesWidth() | CheckIQAData
getAdditionalRightScanLinesWidth() | CheckIQAData
getAdditionalTopScanLinesHeight() | CheckIQAData
getAverageSpotNoiseGroupingsPerSquareInch() | CheckIQAData
getBelowMinFrontImageSize() | CheckIQAData
getBelowMinRearImageSize() | CheckIQAData
getBlackStreakCount() | CheckIQAData
getBlackStreakMaxHeight() | CheckIQAData
getBottomEdgeTearHeight() | CheckIQAData
getBottomEdgeTearWidth() | CheckIQAData
getBottomLeftCornerHeight() | CheckIQAData
getBottomLeftCornerWidth() | CheckIQAData
getBottomRightCornerHeight() | CheckIQAData
getBottomRightCornerWidth() | CheckIQAData
getCarbonStrip() | CheckIQAData
getCarbonStripHeight() | CheckIQAData
getCompressedFrontImageSize() | CheckIQAData
getCompressedRearImageSize() | CheckIQAData
getDocumentFramingError() | CheckIQAData
getDocumentSkew() | CheckIQAData
getDocumentSkewAngle() | CheckIQAData
getFoldedOrTornDocumentCorners() | CheckIQAData
getFoldedOrTornDocumentEdges() | CheckIQAData
getFrontRearHeightDifference() | CheckIQAData
getFrontRearWidthDifference() | CheckIQAData
getGrayLevelStreakCount() | CheckIQAData
getGrayLevelStreakMaxHeight() | CheckIQAData
getHorizontalStreaks() | CheckIQAData
getImageDimensionMismatch() | CheckIQAData
getImageFocusScore() | CheckIQAData
getImageHeight() | CheckIQAData
getImageTooDark() | CheckIQAData
getImageTooLight() | CheckIQAData
getImageWidth() | CheckIQAData
getLeftEdgeTearHeight() | CheckIQAData
getLeftEdgeTearWidth() | CheckIQAData
getOutOfFocus() | CheckIQAData
getOversizeImage() | CheckIQAData
getPercentAverageImageBrightness() | CheckIQAData
getPercentAverageImageContrast() | CheckIQAData
getPercentBlackPixels() | CheckIQAData
getPiggybackDocument() | CheckIQAData
getRightEdgeTearHeight() | CheckIQAData
getRightEdgeTearWidth() | CheckIQAData
getSpotNoise() | CheckIQAData
getTopEdgeTearHeight() | CheckIQAData
getTopEdgeTearWidth() | CheckIQAData
getTopLeftCornerHeight() | CheckIQAData
getTopLeftCornerWidth() | CheckIQAData
getTopRightCornerHeight() | CheckIQAData
getTopRightCornerWidth() | CheckIQAData
getUndersizeImage() | CheckIQAData


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • bill
  • BillExtractActivity
BillExtractActivity Member List

This is the complete list of members for BillExtractActivity, including all inherited members.

CERTIFICATE_VALIDATOR_LISTENER | ExtractActivity< T extends ExtractorResponse > | static
extract(Image image) | ExtractActivity< T extends ExtractorResponse > | protected
getImageByBitmapId(String id) | ExtractActivity< T extends ExtractorResponse > | protected
onCreate(Bundle savedInstanceState) | BillExtractActivity | protected
onExtractionComplete(T results) | ExtractActivity< T extends ExtractorResponse > |
onResume() | ExtractActivity< T extends ExtractorResponse > | protected
onSaveInstanceState(Bundle outState) | ExtractActivity< T extends ExtractorResponse > | protected
setExtract(Extractor extractor) | ExtractActivity< T extends ExtractorResponse > |


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • passport
  • PassportExtractor
PassportExtractor Member List

This is the complete list of members for PassportExtractor, including all inherited members.

createResponse(Passport results, ExceptionResponse exceptionResponse) | PassportExtractor | protected
com::kofax::mobile::sdk::capture::extraction::Extractor.createResponse(T results, ExceptionResponse exceptionResponse) | Extractor< T extends Serializable > | protected
extract(Image...images) | Extractor< T extends Serializable > |
Extractor() | Extractor< T extends Serializable > |
getDefaultServerUrl(ExtractionParameters.ExtractionType extractionType) | PassportExtractor | protected
onExtractionComplete(DataUnit unit) | Extractor< T extends Serializable > |
PASSPORT_EXTRACT_KTA | PassportExtractor | static
PASSPORT_EXTRACT_ON_DEVICE | PassportExtractor | static
PASSPORT_EXTRACT_RTTI | PassportExtractor | static
PassportExtractor() | PassportExtractor |
setCertificateValidatorListener(CertificateValidatorListener certificateValidatorListener) | Extractor< T extends Serializable > |
setExceptionResponseDeserializer(IExceptionResponseDeserializer exceptionResponseDeserializer) | Extractor< T extends Serializable > |
setExtractionServer(IExtractionServer extractionServer) | Extractor< T extends Serializable > |
setExtractorListener(IExtractorListener listener) | Extractor< T extends Serializable > |
setParameters(ExtractionParameters parameters) | PassportExtractor |
setResultDeserializer(IDeserializer< T > resultDeserializer) | Extractor< T extends Serializable > |


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • BasicSettingsProfile
  • RotateType
BasicSettingsProfile.RotateType Member List

This is the complete list of members for BasicSettingsProfile.RotateType, including all inherited members.

ROTATE_180 | BasicSettingsProfile.RotateType
ROTATE_270 | BasicSettingsProfile.RotateType
ROTATE_90 | BasicSettingsProfile.RotateType
ROTATE_AUTO | BasicSettingsProfile.RotateType
ROTATE_NONE | BasicSettingsProfile.RotateType


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • processing
  • CropType
CropType Member List

This is the complete list of members for CropType, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • DocumentBaseCaptureExperience
DocumentBaseCaptureExperience Member List

This is the complete list of members for DocumentBaseCaptureExperience, including all inherited members.

_aspectRatio | CaptureExperience | protected
_captureExperienceData | CaptureExperience | protected
_continuousCapture | CaptureExperience | protected
_ctx | DocumentBaseCaptureExperience | protected
_imageCapturedListeners | CaptureExperience | protected
_imageCaptureView | CaptureExperience | protected
_lock | CaptureExperience | protected
_sdkCaptureRequested | CaptureExperience | protected
_uiHandler | CaptureExperience | protected
_vibrationEnabled | CaptureExperience | protected
_vibrator | CaptureExperience | protected
addOnImageCapturedListener(ImageCapturedListener listener) | DocumentBaseCaptureExperience
addPageDetectionListener(PageDetectionListener listener) | DocumentBaseCaptureExperience
captureCriteriaMetInternal(CaptureExperienceData data) | CaptureExperience | protected
destroy() DocumentBaseCaptureExperience
DocumentBaseCaptureExperience(ImageCaptureView view, DocumentBaseCaptureExperienceCriteriaHolder criteria) | DocumentBaseCaptureExperience
enableAnimationTutor(boolean enable) | DocumentBaseCaptureExperience
getCapturedMessage() DocumentBaseCaptureExperience
getCenterMessage() DocumentBaseCaptureExperience
getDocumentSampleImage() DocumentBaseCaptureExperience
getGuidanceFrameColor() DocumentBaseCaptureExperience
getHoldParallelMessage() DocumentBaseCaptureExperience
getHoldSteadyMessage() DocumentBaseCaptureExperience
getOuterViewFinderColor() DocumentBaseCaptureExperience
getRotateMessage() DocumentBaseCaptureExperience
getTutorialDismissMessage() DocumentBaseCaptureExperience
getUserInstructionMessage() DocumentBaseCaptureExperience
getZoomInMessage() DocumentBaseCaptureExperience
getZoomOutMessage() DocumentBaseCaptureExperience
initBase(ImageCaptureView view, IDetectionAdapter adapter, DocumentBaseCaptureExperienceCriteriaHolder criteria) | DocumentBaseCaptureExperience | protected
invokeImageCapturedListeners(ImageCapturedEvent event) | CaptureExperience | protected
isAnimationTutorEnable() DocumentBaseCaptureExperience
isDiagnosticsViewEnabled() DocumentBaseCaptureExperience
isVibrationEnabled() DocumentBaseCaptureExperience
onAutoFocus(AutoFocusResultEvent event) | CaptureExperience
onImageCaptured(ImageCapturedEvent event) | CaptureExperience
onLevelness(LevelnessEvent event) | CaptureExperience
onStabilityDelay(StabilityDelayEvent event) | CaptureExperience
removeOnImageCapturedListener(ImageCapturedListener listener) | DocumentBaseCaptureExperience
removePageDetectionListener(PageDetectionListener listener) | DocumentBaseCaptureExperience
setCapturedMessage(CaptureMessage capturedMessage) | DocumentBaseCaptureExperience
setCenterMessage(CaptureMessage centerMessage) | DocumentBaseCaptureExperience
setDiagnosticsViewEnabled(boolean enabled) | DocumentBaseCaptureExperience
setDocumentSampleImage(Bitmap documentSampleImage) | DocumentBaseCaptureExperience
setGuidanceFrameColor(int colorCode) | DocumentBaseCaptureExperience
setHoldParallelMessage(CaptureMessage message) | DocumentBaseCaptureExperience
setHoldSteadyMessage(CaptureMessage holdSteadyMessage) | DocumentBaseCaptureExperience
setOuterViewFinderColor(int colorCode) | DocumentBaseCaptureExperience
setRotateMessage(CaptureMessage message) | DocumentBaseCaptureExperience
setSteadyGuidanceFrameColor(int colorCode) | DocumentBaseCaptureExperience
setTutorialDismissMessage(CaptureMessage tutorialDismissMessage) | DocumentBaseCaptureExperience
setUserInstructionMessage(CaptureMessage userInstructionsMessage) | DocumentBaseCaptureExperience
setVibrationEnabled(boolean enable) | DocumentBaseCaptureExperience
setZoomInMessage(CaptureMessage zoomInMessage) | DocumentBaseCaptureExperience
setZoomOutMessage(CaptureMessage zoomOutMessage) | DocumentBaseCaptureExperience


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • IdParameters
  • IdState
IdParameters.IdState Member List

This is the complete list of members for IdParameters.IdState, including all inherited members.

AFRICA_OTHER | IdParameters.IdState
ALBANIA | IdParameters.IdState
ASIA_OTHER | IdParameters.IdState
AUSTRALIA_OTHER | IdParameters.IdState
BRAZIL | IdParameters.IdState
CAMEROON | IdParameters.IdState
CANADA | IdParameters.IdState
CHINA | IdParameters.IdState
ECUADOR | IdParameters.IdState
EL_SALVADOR | IdParameters.IdState
EUROPE_OTHER | IdParameters.IdState
GERMANY | IdParameters.IdState
GUATEMALA | IdParameters.IdState
IdState(IdRegion region) | IdParameters.IdState
INDIA | IdParameters.IdState
JAPAN | IdParameters.IdState
KEY_PASS | IdParameters.IdState
LATIN_AMERICA_OTHER | IdParameters.IdState
LITHUANIA | IdParameters.IdState
LUXEMBOURG | IdParameters.IdState
NOT_SPECIFIED | IdParameters.IdState
region | IdParameters.IdState
SINGAPORE | IdParameters.IdState
SOUTH_KOREA | IdParameters.IdState
ST_CHRIST_NEVIS | IdParameters.IdState
UNITED_STATES | IdParameters.IdState


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • check
  • CheckExtractorResponse
CheckExtractorResponse Member List

This is the complete list of members for CheckExtractorResponse, including all inherited members.

CheckExtractorResponse(Check check, ExceptionResponse exception) CheckExtractorResponse


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • CertificateValidatorListener
CertificateValidatorListener Member List

This is the complete list of members for CertificateValidatorListener, including all inherited members.

getSSLSocketFactory(String hostname) CertificateValidatorListener


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • CaptureActivity
CaptureActivity Member List

This is the complete list of members for CaptureActivity, including all inherited members.

finish() | CaptureActivity |
getCameraView() | CaptureActivity | protected
IMAGE_CAPTURED | CaptureActivity | static
initController(IOverlayView view, IDetectionAdapter detectorAdapter) | CaptureActivity | protected
NO_IMAGE_CAPTURED | CaptureActivity | static
onActivityResult(int requestCode, int resultCode, Intent data) | CaptureActivity | protected
onCreate(Bundle savedInstanceState) | CaptureActivity | protected
onExitButtonClick() | CaptureActivity |
onForceCaptureButtonClick() | CaptureActivity |
onGalleryButtonClick() | CaptureActivity |
onPause() | CaptureActivity | protected
onResume() | CaptureActivity | protected
onSaveInstanceState(Bundle outState) | CaptureActivity | protected
onTorchChange(boolean checked) | CaptureActivity |
RESULT_CODE | CaptureActivity | static
saveResultAndFinish(Image image, Bundle bundle) | CaptureActivity | protected
setCaptureCriteria(CaptureCriteria criteria) | CaptureActivity | protected
setupButtonBarView(LinearLayout mainView) | CaptureActivity | protected
setupCameraView(ViewGroup container) | CaptureActivity | protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • AppContextProvider
AppContextProvider Member List

This is the complete list of members for AppContextProvider, including all inherited members.

getContext() | AppContextProvider | static
onCreate() | AppContextProvider |
setContext(Context context) | AppContextProvider | static


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • CheckCaptureExperienceCriteriaHolder
CheckCaptureExperienceCriteriaHolder Member List

This is the complete list of members for CheckCaptureExperienceCriteriaHolder, including all inherited members.

CaptureExperienceCriteriaHolder() | CaptureExperienceCriteriaHolder
CheckCaptureExperienceCriteriaHolder() | CheckCaptureExperienceCriteriaHolder
DocumentBaseCaptureExperienceCriteriaHolder() | DocumentBaseCaptureExperienceCriteriaHolder
getCheckDetectionSettings() | CheckCaptureExperienceCriteriaHolder
getHoldSteadyDelay() | DocumentBaseCaptureExperienceCriteriaHolder
getPitchThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
getRollThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
getStabilityThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
isFocusEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isOrientationEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isPageDetectionEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isPitchThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isRefocusBeforeCaptureEnabled() | CaptureExperienceCriteriaHolder
isRollThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isStabilityThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
setCheckDetectionSettings(CheckDetectionSettings detectionSettings) | CheckCaptureExperienceCriteriaHolder
setFocusEnabled(boolean focusEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setHoldSteadyDelay(double seconds) | DocumentBaseCaptureExperienceCriteriaHolder
setOrientationEnabled(boolean enabled) | DocumentBaseCaptureExperienceCriteriaHolder
setPageDetectionEnabled(boolean enabled) | DocumentBaseCaptureExperienceCriteriaHolder
setPitchThreshold(int pitchThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setPitchThresholdEnabled(boolean pitchThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setRefocusEnabled(boolean enabled) | CaptureExperienceCriteriaHolder
setRollThreshold(int rollThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setRollThresholdEnabled(boolean rollThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setStabilityThreshold(int stabilityThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setStabilityThresholdEnabled(boolean stabilityThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • model
  • CheckUsabilityData
CheckUsabilityData Member List

This is the complete list of members for CheckUsabilityData, including all inherited members.

gePayeeName() | CheckUsabilityData
getCAR() | CheckUsabilityData
getCodeline() | CheckUsabilityData
getDate() | CheckUsabilityData
getLAR() | CheckUsabilityData
getPayeeEndorsement() | CheckUsabilityData
getSignature() | CheckUsabilityData


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • CameraInitializationEvent
CameraInitializationEvent Member List

This is the complete list of members for CameraInitializationEvent, including all inherited members.

CameraInitializationEvent(Object source, Camera.Size defaultImageResolution, CameraInitStatus cameraInitStatus) CameraInitializationEvent


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsSessionEvent
AppStatsSessionEvent Member List

This is the complete list of members for AppStatsSessionEvent, including all inherited members.

AppStatsSessionEvent() | AppStatsSessionEvent
AppStatsSessionEvent(String type) | AppStatsSessionEvent
AppStatsSessionEvent(String type, String response) | AppStatsSessionEvent
getResponse() | AppStatsSessionEvent
getType() | AppStatsSessionEvent
setResponse(String response) | AppStatsSessionEvent
setType(String sessionType) | AppStatsSessionEvent


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • ImgReviewEditCntrl
  • Line_Style_Solid
ImgReviewEditCntrl.Line_Style_Solid Member List

This is the complete list of members for ImgReviewEditCntrl.Line_Style_Solid, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • OnDeviceIdExtractor
OnDeviceIdExtractor Member List

This is the complete list of members for OnDeviceIdExtractor, including all inherited members.

cancel() | OnDeviceIdExtractor
extractFields(IdExtractionParameters parameters) | OnDeviceIdExtractor
OnDeviceIdExtractor(Context ctx) | OnDeviceIdExtractor
OnDeviceIdExtractor(Context ctx, IProjectProvider projectProvider) | OnDeviceIdExtractor


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • IdCaptureActivity
IdCaptureActivity Member List

This is the complete list of members for IdCaptureActivity, including all inherited members.

finish() | CaptureActivity |
getCameraView() | CaptureActivity | protected
IMAGE_CAPTURED | CaptureActivity | static
initController(IOverlayView view, IDetectionAdapter detectorAdapter) | CaptureActivity | protected
NO_IMAGE_CAPTURED | CaptureActivity | static
onActivityResult(int requestCode, int resultCode, Intent data) | CaptureActivity | protected
onCreate(Bundle savedInstanceState) | IdCaptureActivity | protected
onExitButtonClick() | CaptureActivity |
onForceCaptureButtonClick() | CaptureActivity |
onGalleryButtonClick() | CaptureActivity |
onPause() | CaptureActivity | protected
onResume() | CaptureActivity | protected
onSaveInstanceState(Bundle outState) | CaptureActivity | protected
onTorchChange(boolean checked) | CaptureActivity |
RESULT_CODE | CaptureActivity | static
saveResultAndFinish(Image image, Bundle bundle) | CaptureActivity | protected
setCaptureCriteria(CaptureCriteria criteria) | IdCaptureActivity | protected
setupButtonBarView(LinearLayout mainView) | CaptureActivity | protected
setupCameraView(ViewGroup container) | CaptureActivity | protected


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • model
  • Bill
Bill Member List

This is the complete list of members for Bill, including all inherited members.

capturedImageId | CaptureData
getAccountNumber() | Bill
getAddressLine1() | Bill
getAddressLine2() | Bill
getAmount() | Bill
getBillers() | Bill
getCity() | Bill
getDueDate() | Bill
getName() | Bill
getPhoneNumber() | Bill
getRawData() | Bill
getSource() | Bill
getState() | Bill
getZip() | Bill
processedImageId | CaptureData


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • IdParameters
  • IdSide
IdParameters.IdSide Member List

This is the complete list of members for IdParameters.IdSide, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • processing
  • TargetFrameCropType
TargetFrameCropType Member List

This is the complete list of members for TargetFrameCropType, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • bill
  • IBillExtractorListener
IBillExtractorListener Member List

This is the complete list of members for IBillExtractorListener, including all inherited members.

onExtractionComplete(T results) IExtractorListener< T extends ExtractorResponse >


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • IdParameters
IdParameters Member List

This is the complete list of members for IdParameters, including all inherited members.

barcode IdParameters
getExtractionParameters() IdParameters
getLookAndFeelParameters() IdParameters
getProcessingParameters() IdParameters
IdParameters(Context context) IdParameters


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • MicrLine
MicrLine Member List

This is the complete list of members for MicrLine, including all inherited members.

getAmount() | MicrLine
getAuxiliaryOnUs() | MicrLine
getCheckType() | MicrLine
getEPC() | MicrLine
getOnUs() | MicrLine
getOnUs1() | MicrLine
getOnUs2() | MicrLine
getTransitNumber() | MicrLine
getValueSet() | MicrLine
MicrLine() | MicrLine
setAmount(String amount) | MicrLine
setAuxiliaryOnUs(String auxiliaryOnUs) | MicrLine
setCheckType(CheckType checkType) | MicrLine
setEPC(String epc) | MicrLine
setOnUs(String onUs) | MicrLine
setOnUs1(String onUs1) | MicrLine
setOnUs2(String onUs2) | MicrLine
setTransitNumber(String transitNumber) | MicrLine


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • BarCodeReader
  • Direction
BarCodeReader.Direction Member List

This is the complete list of members for BarCodeReader.Direction, including all inherited members.

ALL BarCodeReader.Direction
BOTTOM_UP BarCodeReader.Direction
Direction(int cVal) BarCodeReader.Direction


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • async
  • ListenerCallbackThreadType
ListenerCallbackThreadType Member List

This is the complete list of members for ListenerCallbackThreadType, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • bill
  • BillExtractor
BillExtractor Member List

This is the complete list of members for BillExtractor, including all inherited members.

BILL_EXTRACT_KTA | BillExtractor | static
BILL_EXTRACT_RTTI | BillExtractor | static
BillExtractor() | BillExtractor |
createResponse(Bill results, ExceptionResponse exceptionResponse) | BillExtractor | protected
com::kofax::mobile::sdk::capture::extraction::Extractor.createResponse(T results, ExceptionResponse exceptionResponse) | Extractor< T extends Serializable > | protected
extract(Image...images) | Extractor< T extends Serializable > |
Extractor() | Extractor< T extends Serializable > |
getDefaultServerUrl(ExtractionParameters.ExtractionType extractionType) | BillExtractor | protected
onExtractionComplete(DataUnit unit) | Extractor< T extends Serializable > |
setCertificateValidatorListener(CertificateValidatorListener certificateValidatorListener) | Extractor< T extends Serializable > |
setExceptionResponseDeserializer(IExceptionResponseDeserializer exceptionResponseDeserializer) | Extractor< T extends Serializable > |
setExtractionServer(IExtractionServer extractionServer) | Extractor< T extends Serializable > |
setExtractorListener(IExtractorListener listener) | Extractor< T extends Serializable > |
setParameters(ExtractionParameters parameters) | BillExtractor |
setResultDeserializer(IDeserializer< T > resultDeserializer) | Extractor< T extends Serializable > |


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • ZoomGuidance
ZoomGuidance Member List

This is the complete list of members for ZoomGuidance, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • QuickAnalysisFeedback
QuickAnalysisFeedback Member List

This is the complete list of members for QuickAnalysisFeedback, including all inherited members.

clone() | QuickAnalysisFeedback
getTetragonCorners() | QuickAnalysisFeedback
getViewBoundariesImage() | QuickAnalysisFeedback
isBlurry() | QuickAnalysisFeedback
isGlareDetected() | QuickAnalysisFeedback
isLowContrastBackground() | QuickAnalysisFeedback
isMissingBorders() | QuickAnalysisFeedback
isOverlySkewed() | QuickAnalysisFeedback
isOversaturated() | QuickAnalysisFeedback
isShadowed() | QuickAnalysisFeedback
isUndersaturated() | QuickAnalysisFeedback
QuickAnalysisFeedback() | QuickAnalysisFeedback


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • IdExtractorResponse
IdExtractorResponse Member List

This is the complete list of members for IdExtractorResponse, including all inherited members.

exceptionResponse ExtractorResponse< T extends Serializable >
IdExtractorResponse(Id result, ExceptionResponse exception) IdExtractorResponse


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • ServerProjectProvider
  • Error
ServerProjectProvider.Error Member List

This is the complete list of members for ServerProjectProvider.Error, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • MicrParser
MicrParser Member List

This is the complete list of members for MicrParser, including all inherited members.

getAccountNumber() | MicrParser
getCheckNumber() | MicrParser
getMicrLine() | MicrParser
getTransitNumber() | MicrParser
isMicrValid() | MicrParser
MicrParser(String micr) | MicrParser
MicrParser() | MicrParser
ParseMicr(String micrData) | MicrParser


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • check
  • CheckExtractActivity
CheckExtractActivity Member List

This is the complete list of members for CheckExtractActivity, including all inherited members.

CERTIFICATE_VALIDATOR_LISTENER | ExtractActivity< T extends ExtractorResponse > | static
extract(Image image) | CheckExtractActivity | protected
getImageByBitmapId(String id) | ExtractActivity< T extends ExtractorResponse > | protected
onCreate(Bundle savedInstanceState) | CheckExtractActivity | protected
onExtractionComplete(T results) | ExtractActivity< T extends ExtractorResponse > |
onResume() | ExtractActivity< T extends ExtractorResponse > | protected
onSaveInstanceState(Bundle outState) | ExtractActivity< T extends ExtractorResponse > | protected
setExtract(Extractor extractor) | ExtractActivity< T extends ExtractorResponse > |


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsWritetoFileEvent
AppStatsWritetoFileEvent Member List

This is the complete list of members for AppStatsWritetoFileEvent, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • Image
  • FileRestriction
Image.FileRestriction Member List

This is the complete list of members for Image.FileRestriction, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • check
  • CheckWorkflowActivity
CheckWorkflowActivity Member List

This is the complete list of members for CheckWorkflowActivity, including all inherited members.

captureImage() | WorkflowActivity< T extends IParameters > | protected
CERTIFICATE_VALIDATOR_LISTENER | WorkflowActivity< T extends IParameters > | static
CHECK_EXCEPTION | CheckWorkflowActivity | static
CHECK_PARAMETERS | CheckWorkflowActivity | static
CHECK_RESULTS | CheckWorkflowActivity | static
clearBitmap(String imageId) | WorkflowActivity< T extends IParameters > | protected
getCaptureActivityClass() | CheckWorkflowActivity |
getDefaultProcessingString(CheckParameters parameters) | CheckWorkflowActivity |
com::kofax::mobile::sdk::capture::WorkflowActivity.getDefaultProcessingString(T parameters) | WorkflowActivity< T extends IParameters > |
getDefaultReturnObject() | CheckWorkflowActivity |
getExceptionKey() | CheckWorkflowActivity |
getExtractActivityClass() | CheckWorkflowActivity |
getParameters(Bundle savedInstanceState) | WorkflowActivity< T extends IParameters > |
getParametersInstance() | CheckWorkflowActivity |
getParametersKey() | CheckWorkflowActivity |
getResultKey() | CheckWorkflowActivity |
handleException(final Throwable exc) | WorkflowActivity< T extends IParameters > | protected
isOdeSupported() | WorkflowActivity< T extends IParameters > | protected
onActivityResult(int requestCode, int resultCode, Intent data) | WorkflowActivity< T extends IParameters > | protected
onCreate(Bundle savedInstanceState) | CheckWorkflowActivity | protected
onDestroy() | WorkflowActivity< T extends IParameters > | protected
onResume() | WorkflowActivity< T extends IParameters > | protected
onSaveInstanceState(Bundle outState) | WorkflowActivity< T extends IParameters > | protected
tryRestoreState(Bundle savedInstanceState) | WorkflowActivity< T extends IParameters > | protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • BoundingTetragon
  • Rotation
BoundingTetragon.Rotation Member List

This is the complete list of members for BoundingTetragon.Rotation, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • server
  • LoginCredentials
LoginCredentials Member List

This is the complete list of members for LoginCredentials, including all inherited members.

getCertificateValidatorListener() | LoginCredentials
getKtaPassword() | LoginCredentials
getKtaUserName() | LoginCredentials
getServerUrl() | LoginCredentials
getTimeOutParameters() | LoginCredentials
LoginCredentials(String ktaUserName, String ktaPassword, String serverUrl, CertificateValidatorListener certificateValidatorListener, TimeOutParameters timeOutParameters) | LoginCredentials


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • check
  • KtaJsonCheck
KtaJsonCheck Member List

This is the complete list of members for KtaJsonCheck, including all inherited members.

capturedImageId | CaptureData
getAmount() | KtaJsonCheck
getAuxiliaryOnUs() | KtaJsonCheck
getCar() | KtaJsonCheck
getCheckIQAData() | KtaJsonCheck
getCheckNumber() | KtaJsonCheck
getCheckUsabilityData() | KtaJsonCheck
getDate() | KtaJsonCheck
getEpc() | KtaJsonCheck
getLar() | KtaJsonCheck
getMicr() | KtaJsonCheck
getMicrAmount() | KtaJsonCheck
getOnUs1() | KtaJsonCheck
getOnUs2() | KtaJsonCheck
getPayee() | KtaJsonCheck
getRawData() | KtaJsonCheck
getReasonForRejection() | KtaJsonCheck
getRestrictiveEndorsement() | KtaJsonCheck
getRestrictiveEndorsementPresent() | KtaJsonCheck
getTransit() | KtaJsonCheck
getUsable() | KtaJsonCheck
KtaJsonCheck(Context context, String json) | KtaJsonCheck
processedImageId | CaptureData
setJson(String json) | KtaJsonCheck


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • data
  • ClassificationResult
ClassificationResult Member List

This is the complete list of members for ClassificationResult, including all inherited members.

ClassificationResult(String classId, float confidence) ClassificationResult


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • passport
  • KtaJsonPassport
KtaJsonPassport Member List

This is the complete list of members for KtaJsonPassport, including all inherited members.

capturedImageId | CaptureData
getCountry() | KtaJsonPassport
getCountryLong() | KtaJsonPassport
getDateOfBirth() | KtaJsonPassport
getExpirationDate() | KtaJsonPassport
getFirstName() | KtaJsonPassport
getGender() | KtaJsonPassport
getIssueDate() | KtaJsonPassport
getLastName() | KtaJsonPassport
getMiddleName() | KtaJsonPassport
getMRZ1() | KtaJsonPassport
getMRZ2() | KtaJsonPassport
getNationality() | KtaJsonPassport
getPassportNumber() | KtaJsonPassport
getPersonalNumber() | KtaJsonPassport
getRawData() | KtaJsonPassport
KtaJsonPassport(Context context, String json) | KtaJsonPassport
processedImageId | CaptureData
setJson(String json) | KtaJsonPassport


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • check
  • CheckExtractor
CheckExtractor Member List

This is the complete list of members for CheckExtractor, including all inherited members.

CHECK_EXTRACT_KTA | CheckExtractor | static
CHECK_EXTRACT_RTTI | CheckExtractor | static
CheckExtractor() | CheckExtractor |
createResponse(Check check, ExceptionResponse exceptionResponse) | CheckExtractor | protected
com::kofax::mobile::sdk::capture::extraction::Extractor.createResponse(T results, ExceptionResponse exceptionResponse) | Extractor< T extends Serializable > | protected
extract(Image...images) | Extractor< T extends Serializable > |
Extractor() | Extractor< T extends Serializable > |
getDefaultServerUrl(ExtractionParameters.ExtractionType serverType) | CheckExtractor | protected
onExtractionComplete(DataUnit unit) | Extractor< T extends Serializable > |
setCertificateValidatorListener(CertificateValidatorListener certificateValidatorListener) | Extractor< T extends Serializable > |
setExceptionResponseDeserializer(IExceptionResponseDeserializer exceptionResponseDeserializer) | Extractor< T extends Serializable > |
setExtractionServer(IExtractionServer extractionServer) | Extractor< T extends Serializable > |
setExtractorListener(IExtractorListener listener) | Extractor< T extends Serializable > |
setParameters(CheckParameters parameters) | CheckExtractor |
com::kofax::mobile::sdk::capture::extraction::Extractor.setParameters(ExtractionParameters parameters) | Extractor< T extends Serializable > |
setResultDeserializer(IDeserializer< T > resultDeserializer) | Extractor< T extends Serializable > |


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • version
  • KloVersion
KloVersion Member List

This is the complete list of members for KloVersion, including all inherited members.

getPackageVersion() KloVersion static


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • model
  • CreditCard
CreditCard Member List

This is the complete list of members for CreditCard, including all inherited members.

capturedImageId | CaptureData |
CREATOR | CreditCard | static
CreditCard() | CreditCard |
CreditCard(Parcel in) | CreditCard |
describeContents() | CreditCard |
getCardNumber() | CreditCard |
getCvv() | CreditCard |
getExpirationMonth() | CreditCard |
getExpirationYear() | CreditCard |
getName() | CreditCard |
processedImageId | CaptureData |
setCardNumber(String cardNumber) | CreditCard |
setCvv(String cvv) | CreditCard |
setExpirationMonth(String expirationMonth) | CreditCard |
setExpirationYear(String expirationYear) | CreditCard |
setName(String name) | CreditCard |
writeToParcel(Parcel dest, int flags) | CreditCard |


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • bundle
  • ZipFileBundle
ZipFileBundle Member List

This is the complete list of members for ZipFileBundle, including all inherited members.

close() | ZipFileBundle
list() | ZipFileBundle
ZipFileBundle(ZipFile file) | ZipFileBundle


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • data
  • GuidingLine
GuidingLine Member List

This is the complete list of members for GuidingLine, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • model
  • Field
Field< T extends Serializable > Member List

This is the complete list of members for Field< T extends Serializable >, including all inherited members.

clone() | Field< T extends Serializable >
equals(Object o) | Field< T extends Serializable >
Field(String name, T object, double confidence, FieldLocation location) | Field< T extends Serializable >
getConfidence() | Field< T extends Serializable >
getLocation() | Field< T extends Serializable >
getName() | Field< T extends Serializable >
getObject() | Field< T extends Serializable >
hashCode() | Field< T extends Serializable >
toString() | Field< T extends Serializable >


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • ImagePerfectionProfile
ImagePerfectionProfile Member List

This is the complete list of members for ImagePerfectionProfile, including all inherited members.

clone() | ImagePerfectionProfile
getIpOperations() | ImagePerfectionProfile
getIpOperationsFilePath() | ImagePerfectionProfile
getName() | ImagePerfectionProfile
getUseDocumentDetectionBasedCrop() | ImagePerfectionProfile
getUseMRZPassportDetection() | ImagePerfectionProfile
getUseTargetFrameCrop() | ImagePerfectionProfile
ImagePerfectionProfile() | ImagePerfectionProfile
setIpOperations(String ipOperations) | ImagePerfectionProfile
setIpOperationsFilePath(String ipOperationsFilePath) | ImagePerfectionProfile
setName(String name) | ImagePerfectionProfile
setUseDocumentDetectionBasedCrop(UseDocumentDetectionBasedCrop useDocumentDetectionBasedCrop) | ImagePerfectionProfile
setUseMRZPassportDetection(UseMRZPassportDetection useMRZPassportDetection) | ImagePerfectionProfile
setUseTargetFrameCrop(UseTargetFrameCrop useTargetFrameCrop) | ImagePerfectionProfile


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • KENLogging
KENLogging Member List

This is the complete list of members for KENLogging, including all inherited members.

enableConsoleLogging(boolean enable) KENLogging static


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageClassificationCompletedListener
ImageClassificationCompletedListener Member List

This is the complete list of members for ImageClassificationCompletedListener, including all inherited members.

onImageClassified(ImageClassificationCompleteEvent event) ImageClassificationCompletedListener


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • processing
  • IImageProcessor
IImageProcessor Member List

This is the complete list of members for IImageProcessor, including all inherited members.

cancel() | IImageProcessor
process(Image image) | IImageProcessor
process(Bitmap image) | IImageProcessor
setImageOutListener(IImageProcessorListener listener) | IImageProcessor
setParameters(ProcessingParameters parameters) | IImageProcessor


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageClassifier
ImageClassifier Member List

This is the complete list of members for ImageClassifier, including all inherited members.

addImageClassificationCompletedEventListener(ImageClassificationCompletedListener listener) | ImageClassifier
classifyImage(Image image) | ImageClassifier
doCleanup() | ImageClassifier
getMaxNumberOfResults() | ImageClassifier
getStatus() | ImageClassifier
ImageClassifier() | ImageClassifier
loadConfigurationFile(String configFileName) | ImageClassifier
loadModel(String modelFileName) | ImageClassifier
removeImageClassificationCompletedEventListener(ImageClassificationCompletedListener listener) | ImageClassifier
setMaxNumberOfResults(int maxNumberOfResults) | ImageClassifier


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • SessionState
SessionState Member List

This is the complete list of members for SessionState, including all inherited members.

getErrorState(TaskType task, StateID parentState) | SessionState
getNextState(TaskType task, StateID parentState) | SessionState
isReachable(TaskType task, StateID parentState) | SessionState
SESSION_DOCUMENT_TYPE_READY SessionState
SESSION_GETTING_DOCUMENT_FIELDS SessionState
SESSION_GETTING_IP_SETTINGS SessionState
SESSION_LOGGED_IN SessionState
SESSION_LOGGING_IN SessionState
SESSION_LOGGING_OUT SessionState
SESSION_PREPARING_DOCUMENT_TYPE SessionState
SESSION_REGISTERED SessionState
SESSION_REGISTERING SessionState
SESSION_SUBMIT_COMPLETED SessionState
SESSION_SUBMITTING SessionState
SESSION_UNREGISTERED SessionState
SessionState(StateID stateID) | SessionState


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • passport
  • PassportWorkflowActivity
PassportWorkflowActivity Member List

This is the complete list of members for PassportWorkflowActivity, including all inherited members.

captureImage() | WorkflowActivity< T extends IParameters > | protected
CERTIFICATE_VALIDATOR_LISTENER | WorkflowActivity< T extends IParameters > | static
clearBitmap(String imageId) | WorkflowActivity< T extends IParameters > | protected
getCaptureActivityClass() | PassportWorkflowActivity |
getDefaultProcessingString(PassportParameters parameters) | PassportWorkflowActivity |
com::kofax::mobile::sdk::capture::WorkflowActivity.getDefaultProcessingString(T parameters) | WorkflowActivity< T extends IParameters > |
getDefaultReturnObject() | PassportWorkflowActivity |
getExceptionKey() | PassportWorkflowActivity |
getExtractActivityClass() | PassportWorkflowActivity |
getParameters(Bundle savedInstanceState) | WorkflowActivity< T extends IParameters > |
getParametersInstance() | PassportWorkflowActivity |
getParametersKey() | PassportWorkflowActivity |
getResultKey() | PassportWorkflowActivity |
handleException(final Throwable exc) | WorkflowActivity< T extends IParameters > | protected
isOdeSupported() | PassportWorkflowActivity | protected
onActivityResult(int requestCode, int resultCode, Intent data) | WorkflowActivity< T extends IParameters > | protected
onCreate(Bundle savedInstanceState) | PassportWorkflowActivity | protected
onDestroy() | WorkflowActivity< T extends IParameters > | protected
onResume() | WorkflowActivity< T extends IParameters > | protected
onSaveInstanceState(Bundle outState) | WorkflowActivity< T extends IParameters > | protected
PASSPORT_EXCEPTION | PassportWorkflowActivity | static
PASSPORT_PARAMETERS | PassportWorkflowActivity | static
PASSPORT_RESULTS | PassportWorkflowActivity | static
tryRestoreState(Bundle savedInstanceState) | WorkflowActivity< T extends IParameters > | protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • DocumentCaptureExperienceCriteriaHolder
DocumentCaptureExperienceCriteriaHolder Member List

This is the complete list of members for DocumentCaptureExperienceCriteriaHolder, including all inherited members.

CaptureExperienceCriteriaHolder() | CaptureExperienceCriteriaHolder
DocumentBaseCaptureExperienceCriteriaHolder() | DocumentBaseCaptureExperienceCriteriaHolder
DocumentCaptureExperienceCriteriaHolder() | DocumentCaptureExperienceCriteriaHolder
getDetectionSettings() | DocumentCaptureExperienceCriteriaHolder
getHoldSteadyDelay() | DocumentBaseCaptureExperienceCriteriaHolder
getPitchThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
getRollThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
getStabilityThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
isFocusEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isOrientationEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isPageDetectionEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isPitchThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isRefocusBeforeCaptureEnabled() | CaptureExperienceCriteriaHolder
isRollThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isStabilityThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
setDetectionSettings(DocumentDetectionSettings detectionSettings) | DocumentCaptureExperienceCriteriaHolder
setFocusEnabled(boolean focusEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setHoldSteadyDelay(double seconds) | DocumentBaseCaptureExperienceCriteriaHolder
setOrientationEnabled(boolean enabled) | DocumentBaseCaptureExperienceCriteriaHolder
setPageDetectionEnabled(boolean enabled) | DocumentBaseCaptureExperienceCriteriaHolder
setPitchThreshold(int pitchThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setPitchThresholdEnabled(boolean pitchThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setRefocusEnabled(boolean enabled) | CaptureExperienceCriteriaHolder
setRollThreshold(int rollThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setRollThresholdEnabled(boolean rollThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setStabilityThreshold(int stabilityThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setStabilityThresholdEnabled(boolean stabilityThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • processing
  • DocumentDimensions
DocumentDimensions Member List

This is the complete list of members for DocumentDimensions, including all inherited members.

DocumentDimensions(Float shortEdge, Float longEdge) | DocumentDimensions
equals(Object o) | DocumentDimensions


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • parameter
  • ProcessingParameters
  • ProcessingType
ProcessingParameters.ProcessingType Member List

This is the complete list of members for ProcessingParameters.ProcessingType, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • bill
  • KtaBillExtractor
KtaBillExtractor Member List

This is the complete list of members for KtaBillExtractor, including all inherited members.

getProcessName() | KtaBillExtractor
KtaBillExtractor(IKtaSessionIdProviderFactory sessionIdProviderFactory, IImageToByteArray converter) | KtaBillExtractor


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • check
  • ICheckExtractorListener
ICheckExtractorListener Member List

This is the complete list of members for ICheckExtractorListener, including all inherited members.

onExtractionComplete(T results) IExtractorListener< T extends ExtractorResponse >


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • passport
  • PassportCaptureActivity
PassportCaptureActivity Member List

This is the complete list of members for PassportCaptureActivity, including all inherited members.

finish() | CaptureActivity |
getCameraView() | CaptureActivity | protected
IMAGE_CAPTURED | CaptureActivity | static
initController(IOverlayView view, IDetectionAdapter detectorAdapter) | CaptureActivity | protected
NO_IMAGE_CAPTURED | CaptureActivity | static
onActivityResult(int requestCode, int resultCode, Intent data) | CaptureActivity | protected
onCreate(Bundle savedInstanceState) | PassportCaptureActivity | protected
onExitButtonClick() | CaptureActivity |
onForceCaptureButtonClick() | CaptureActivity |
onGalleryButtonClick() | CaptureActivity |
onPause() | CaptureActivity | protected
onResume() | CaptureActivity | protected
onSaveInstanceState(Bundle outState) | CaptureActivity | protected
onTorchChange(boolean checked) | CaptureActivity |
RESULT_CODE | CaptureActivity | static
saveResultAndFinish(Image image, Bundle bundle) | CaptureActivity | protected
setCaptureCriteria(CaptureCriteria criteria) | CaptureActivity | protected
setupButtonBarView(LinearLayout mainView) | CaptureActivity | protected
setupCameraView(ViewGroup container) | CaptureActivity | protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • ImageCapturedListener
ImageCapturedListener Member List

This is the complete list of members for ImageCapturedListener, including all inherited members.

onImageCaptured(ImageCapturedEvent event) ImageCapturedListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • CheckCaptureExperience
CheckCaptureExperience Member List

This is the complete list of members for CheckCaptureExperience, including all inherited members.

_aspectRatio | CaptureExperience | protected
_captureExperienceData | CaptureExperience | protected
_continuousCapture | CaptureExperience | protected
_ctx | DocumentBaseCaptureExperience | protected
_imageCapturedListeners | CaptureExperience | protected
_imageCaptureView | CaptureExperience | protected
_lock | CaptureExperience | protected
_sdkCaptureRequested | CaptureExperience | protected
_uiHandler | CaptureExperience | protected
_vibrationEnabled | CaptureExperience | protected
_vibrator | CaptureExperience | protected
addOnImageCapturedListener(ImageCapturedListener listener) | DocumentBaseCaptureExperience
addPageDetectionListener(PageDetectionListener listener) | DocumentBaseCaptureExperience
captureCriteriaMetInternal(CaptureExperienceData data) | CaptureExperience | protected
CheckCaptureExperience(ImageCaptureView view) | CheckCaptureExperience
CheckCaptureExperience(ImageCaptureView view, CheckCaptureExperienceCriteriaHolder criteria) | CheckCaptureExperience
destroy() DocumentBaseCaptureExperience
DocumentBaseCaptureExperience(ImageCaptureView view, DocumentBaseCaptureExperienceCriteriaHolder criteria) | DocumentBaseCaptureExperience
enableAnimationTutor(boolean enable) | DocumentBaseCaptureExperience
getCaptureCriteria() CheckCaptureExperience
getCapturedMessage() DocumentBaseCaptureExperience
getCenterMessage() CheckCaptureExperience
getCheckSampleImage() CheckCaptureExperience
getDocumentSampleImage() DocumentBaseCaptureExperience
getGuidanceFrameColor() DocumentBaseCaptureExperience
getHoldParallelMessage() DocumentBaseCaptureExperience
getHoldSteadyMessage() DocumentBaseCaptureExperience
getOuterViewFinderColor() DocumentBaseCaptureExperience
getRotateMessage() DocumentBaseCaptureExperience
getTutorialDismissMessage() DocumentBaseCaptureExperience
getUserInstructionMessage() CheckCaptureExperience
getZoomInMessage() DocumentBaseCaptureExperience
getZoomOutMessage() DocumentBaseCaptureExperience
initBase(ImageCaptureView view, IDetectionAdapter adapter, DocumentBaseCaptureExperienceCriteriaHolder criteria) | DocumentBaseCaptureExperience | protected
invokeImageCapturedListeners(ImageCapturedEvent event) | CaptureExperience | protected
isAnimationTutorEnable() DocumentBaseCaptureExperience
isDiagnosticsViewEnabled() DocumentBaseCaptureExperience
isVibrationEnabled() DocumentBaseCaptureExperience
onAutoFocus(AutoFocusResultEvent event) | CaptureExperience
onImageCaptured(ImageCapturedEvent event) | CaptureExperience
onLevelness(LevelnessEvent event) | CaptureExperience
onStabilityDelay(StabilityDelayEvent event) | CaptureExperience
removeOnImageCapturedListener(ImageCapturedListener listener) | DocumentBaseCaptureExperience
removePageDetectionListener(PageDetectionListener listener) | DocumentBaseCaptureExperience
setCaptureCriteria(CheckCaptureExperienceCriteriaHolder criteria) | CheckCaptureExperience
setCapturedMessage(CaptureMessage capturedMessage) | DocumentBaseCaptureExperience
setCenterMessage(CaptureMessage centerMessage) | CheckCaptureExperience
setCheckSampleImage(Bitmap checkSampleImage) | CheckCaptureExperience
setDiagnosticsViewEnabled(boolean enabled) | DocumentBaseCaptureExperience
setDocumentSampleImage(Bitmap documentSampleImage) | DocumentBaseCaptureExperience
setGuidanceFrameColor(int colorCode) | DocumentBaseCaptureExperience
setHoldParallelMessage(CaptureMessage message) | DocumentBaseCaptureExperience
setHoldSteadyMessage(CaptureMessage holdSteadyMessage) | DocumentBaseCaptureExperience
setOuterViewFinderColor(int colorCode) | DocumentBaseCaptureExperience
setRotateMessage(CaptureMessage message) | DocumentBaseCaptureExperience
setSteadyGuidanceFrameColor(int colorCode) | DocumentBaseCaptureExperience
setTutorialDismissMessage(CaptureMessage tutorialDismissMessage) | DocumentBaseCaptureExperience
setUserInstructionMessage(CaptureMessage userInstructionsMessage) | CheckCaptureExperience
setVibrationEnabled(boolean enable) | DocumentBaseCaptureExperience
setZoomInMessage(CaptureMessage zoomInMessage) | DocumentBaseCaptureExperience
setZoomOutMessage(CaptureMessage zoomOutMessage) | DocumentBaseCaptureExperience


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • ApplicationContextImageStore
ApplicationContextImageStore Member List

This is the complete list of members for ApplicationContextImageStore, including all inherited members.

getImageStorage() | ApplicationContextImageStore | static
setImageStorage(IImageStorage imageStorage) | ApplicationContextImageStore | static


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • extraction
  • ExceptionResponseImpl
ExceptionResponseImpl Member List

This is the complete list of members for ExceptionResponseImpl, including all inherited members.

exceptionMessage() | ExceptionResponseImpl
ExceptionResponseImpl(Throwable t) | ExceptionResponseImpl
exceptionType() | ExceptionResponseImpl
innerException() | ExceptionResponseImpl
message() | ExceptionResponseImpl
stackTrace() | ExceptionResponseImpl


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • error
  • ErrorInfo
ErrorInfo Member List

This is the complete list of members for ErrorInfo, including all inherited members.

ErrorInfo(int errCode) | ErrorInfo
getErr() | ErrorInfo
getErrCause() | ErrorInfo
getErrDesc() | ErrorInfo
getErrMsg() | ErrorInfo
KMC_BC_BUSY | ErrorInfo
KMC_BC_IMAGE_BUFFERED | ErrorInfo
KMC_BC_INVALID_IMAGE | ErrorInfo
KMC_BC_NO_BARCODE_FOUND | ErrorInfo
KMC_BC_NO_REPRESENTATION | ErrorInfo
KMC_BC_UNKNOWN | ErrorInfo
KMC_BC_UNSUPPORTED_REGION | ErrorInfo
KMC_CL_CLASSIFICATION_CONFIDENCE_LOW | ErrorInfo
KMC_CL_CLASSIFIER_BUSY | ErrorInfo
KMC_CL_CLASSIFIER_NOT_INITIALIZED | ErrorInfo
KMC_CL_CONFIG_NOT_LOADED | ErrorInfo
KMC_CL_CONFIG_NULL | ErrorInfo
KMC_CL_ENCRYPTED_BARCODE_STRING | ErrorInfo
KMC_CL_ID_CLASS_NOT_SUPPORTED | ErrorInfo
KMC_CL_INVALID_BARCODE_STRING | ErrorInfo
KMC_CL_INVALID_IMAGE_SUPPLIED | ErrorInfo
KMC_CL_LISTENER_NULL | ErrorInfo
KMC_CL_MAX_NUM_RESULTS_INVALID | ErrorInfo
KMC_CL_MODEL_NOT_LOADED | ErrorInfo
KMC_CL_MODEL_NULL | ErrorInfo
KMC_CL_NO_IMAGE_SUPPLIED | ErrorInfo
KMC_ED_ALREADY_BUFFERED | ErrorInfo
KMC_ED_ALREADY_CLEAR | ErrorInfo
KMC_ED_ALTERNATE_FILEIO_ENGINE | ErrorInfo
KMC_ED_BITMAP_DIMENSIONS_IMMUTABLE | ErrorInfo
KMC_ED_BITMAP_DIMENSIONS_NO_UPSCALE | ErrorInfo
KMC_ED_BITMAP_READ_FROM_FILE_FAILED | ErrorInfo
KMC_ED_BITMAP_WRITE_TO_FILE_FAILED | ErrorInfo
KMC_ED_BUFFER | ErrorInfo
KMC_ED_BUFFER_ALREADY_CLEARED | ErrorInfo
KMC_ED_BUFFER_EXISTS | ErrorInfo
KMC_ED_BUFFERED_READ_FAILED | ErrorInfo
KMC_ED_DELETE_BUFFERED_FILE | ErrorInfo
KMC_ED_FILE_EXISTS | ErrorInfo
KMC_ED_FILE_NOT_DELETABLE | ErrorInfo
KMC_ED_FILE_RESTRICTION_BITDEPTH | ErrorInfo
KMC_ED_FILE_RESTRICTION_DPI | ErrorInfo
KMC_ED_FILE_RESTRICTION_MIMETYPE | ErrorInfo
KMC_ED_FILE_STILL_REMAINS | ErrorInfo
KMC_ED_FILEPATH | ErrorInfo
KMC_ED_IMAGE_FILE_DIMENSIONS_ERROR | ErrorInfo
KMC_ED_IMAGE_INVALID_SCALING_FACTOR | ErrorInfo
KMC_ED_IMAGE_IS_SCALED | ErrorInfo
KMC_ED_IMAGE_PERFECTION_PROFILE_EMPTY | ErrorInfo
KMC_ED_IMAGE_WRITTEN_IS_NOT_BITONAL | ErrorInfo
KMC_ED_IMAGE_WRITTEN_IS_NOT_GRAY | ErrorInfo
KMC_ED_IMAGELEAK | ErrorInfo
KMC_ED_INVALID_DOCUMENT_DIMENSIONS | ErrorInfo
KMC_ED_INVALID_DPI | ErrorInfo
KMC_ED_INVALID_FOR_OBJECT_REP | ErrorInfo
KMC_ED_INVALID_ISO_DATE_TIME_FORMAT | ErrorInfo
KMC_ED_INVALID_JPEG_QUALITY_VALUE | ErrorInfo
KMC_ED_JPEG_BITDEPTH | ErrorInfo
KMC_ED_MIMETYPE | ErrorInfo
KMC_ED_MIMETYPE_MISMATCH | ErrorInfo
KMC_ED_NO_BUFFERED_IMAGE | ErrorInfo
KMC_ED_NO_MEMORY_FOR_BUFFERED_FILE | ErrorInfo
KMC_ED_NOIMAGE | ErrorInfo
KMC_ED_NONEXISTENT_FILE | ErrorInfo
KMC_ED_NONEXISTENT_LOAD_SETTINGS_FILE | ErrorInfo
KMC_ED_NONEXISTENT_OCR_REGION_TYPE | ErrorInfo
KMC_ED_OBJECT_REP_BITMAP_MISMATCH | ErrorInfo
KMC_ED_OBJECT_REP_FILE_MISMATCH | ErrorInfo
KMC_ED_OBJECT_REP_MISMATCH | ErrorInfo
KMC_ED_OBJECT_REP_NO_BITMAP | ErrorInfo
KMC_ED_UNRECOGNIZED_MIME_TYPE | ErrorInfo
KMC_EV_APPEND_ENCRYPTED | ErrorInfo
KMC_EV_APPEND_TO_FILE | ErrorInfo
KMC_EV_BAD_CHANNEL | ErrorInfo
KMC_EV_BAD_DPI | ErrorInfo
KMC_EV_BAD_FILE_FORMAT | ErrorInfo
KMC_EV_BAD_LINEWIDTH | ErrorInfo
KMC_EV_BAD_WIDTH_HEIGHT | ErrorInfo
KMC_EV_BARCODE_DRIVER | ErrorInfo
KMC_EV_CANCEL_OPERATION_SUCCESS | ErrorInfo
KMC_EV_CANNOT_APPEND | ErrorInfo
KMC_EV_EXTERNAL_PAGE | ErrorInfo
KMC_EV_FILE_IO_ACCESS_BUSY | ErrorInfo
KMC_EV_FILE_METADATA | ErrorInfo
KMC_EV_FILE_READ_FAILED | ErrorInfo
KMC_EV_FILEOPEN | ErrorInfo
KMC_EV_HISTOGRAM | ErrorInfo
KMC_EV_IMAGE_PARM | ErrorInfo
KMC_EV_IMAGE_PROCESSING | ErrorInfo
KMC_EV_IMAGE_WRITE_FAILED | ErrorInfo
KMC_EV_INVALID_HANDLE | ErrorInfo
KMC_EV_INVALID_POINTER | ErrorInfo
KMC_EV_LICENSE_ALREADY_SET | ErrorInfo
KMC_EV_LICENSE_EXPIRED | ErrorInfo
KMC_EV_LICENSING | ErrorInfo
KMC_EV_LOCK_CREATION_ERROR | ErrorInfo
KMC_EV_MEMORY | ErrorInfo
KMC_EV_METADATA_OVERFLOW | ErrorInfo
KMC_EV_NETWORK_READ | ErrorInfo
KMC_EV_NONEXISTANT_IMAGE | ErrorInfo
KMC_EV_OP_STRING_ERROR | ErrorInfo
KMC_EV_PDF_BAD | ErrorInfo
KMC_EV_PDF_TOO_LARGE | ErrorInfo
KMC_EV_PROCESS_PAGE_BUSY | ErrorInfo
KMC_EV_SPEED_ACCURACY | ErrorInfo
KMC_EV_UNKNOWN_FILETYPE | ErrorInfo
KMC_EV_UNKNOWN_VARIANT | ErrorInfo
KMC_EV_UNSUPPORTED_BITMAP_FORMAT | ErrorInfo
KMC_EX_PASSPORT_MRZ_DATA_NOT_FOUND | ErrorInfo
KMC_GN_BAD_APPLICATION_CONTEXT | ErrorInfo
KMC_GN_DESERIALIZE_OBJECT_ERROR | ErrorInfo
KMC_GN_DESERIALIZE_VERSION_ERROR | ErrorInfo
KMC_GN_FILE_NOT_FOUND | ErrorInfo
KMC_GN_FILE_NOT_FOUND_EXCEPTION | ErrorInfo
KMC_GN_ILLEGAL_ARGUMENT_EXCEPTION | ErrorInfo
KMC_GN_ILLEGAL_THREAD_STATE_EXCEPTION | ErrorInfo
KMC_GN_INTERNAL_ERROR | ErrorInfo
KMC_GN_IO_EXCEPTION | ErrorInfo
KMC_GN_LOGIN_NOT_APPLICABLE | ErrorInfo
KMC_GN_NULL_POINTER_EXCEPTION | ErrorInfo
KMC_GN_OUT_OF_MEMORY | ErrorInfo
KMC_GN_PARAM_NEGATIVE | ErrorInfo
KMC_GN_SESSION_CREATE_ERROR | ErrorInfo
KMC_GN_SESSION_DISMISS_ERROR | ErrorInfo
KMC_GN_UNKNOWN_ERROR | ErrorInfo
KMC_GN_UNSUPPORTED_OPERATION | ErrorInfo
KMC_IP_FILE_AND_BUFFERED_REPRESENTATION | ErrorInfo
KMC_IP_LICENSE_ALREADY_SET | ErrorInfo
KMC_IP_LICENSE_EXPIRED | ErrorInfo
KMC_IP_LICENSE_INVALID | ErrorInfo
KMC_IP_NO_CONFIGURATION | ErrorInfo
KMC_IP_NO_PROFILE | ErrorInfo
KMC_IP_NO_REPRESENTATION | ErrorInfo
KMC_LO_DEVICE_REG_LICENSING_ERROR | ErrorInfo
KMC_LO_DOMAIN | ErrorInfo
KMC_LO_DOWNLOAD_DOCUMENT_FIELDS_ERROR | ErrorInfo
KMC_LO_DOWNLOAD_DOCUMENT_SCAN_SETTINGS_ERROR | ErrorInfo
KMC_LO_EMAIL | ErrorInfo
KMC_LO_EVENT_LOCK_ACQUIRE_ERROR | ErrorInfo
KMC_LO_IMAGE_NOT_FOUND | ErrorInfo
KMC_LO_INVALID_CERTIFICATE | ErrorInfo
KMC_LO_INVALID_DOCUMENT_TYPE_NAME | ErrorInfo
KMC_LO_INVALID_SERVER_URL | ErrorInfo
KMC_LO_INVALID_SESSION_STATE | ErrorInfo
KMC_LO_INVALID_SESSION_STATE_TRANSITION | ErrorInfo
KMC_LO_LOGIN_NOT_ALLOWED | ErrorInfo
KMC_LO_NO_OPERATION_TO_CANCEL | ErrorInfo
KMC_LO_NOT_LOGGED_IN | ErrorInfo
KMC_LO_NOT_REGISTERED | ErrorInfo
KMC_LO_OPERATION_CANCEL_ERROR | ErrorInfo
KMC_LO_OPERATION_CANCELLED | ErrorInfo
KMC_LO_OPERATION_NOT_CANCELLABLE | ErrorInfo
KMC_LO_OVERLAPPED_OPERATIONS | ErrorInfo
KMC_LO_PAGE_IMAGE_INDEX_INVALID | ErrorInfo
KMC_LO_PAGE_NOT_FOUND | ErrorInfo
KMC_LO_REGISTER_REQUIRES_AUTH | ErrorInfo
KMC_LO_REGISTERING | ErrorInfo
KMC_LO_REGISTERING_NOT_ALLOWED | ErrorInfo
KMC_LO_REQUEST_TIMEOUT | ErrorInfo
KMC_LO_SERVER_TIMEOUT | ErrorInfo
KMC_LO_SERVER_URL_NOT_SET | ErrorInfo
KMC_LO_SESSION_STATE_BUSY | ErrorInfo
KMC_LO_START_SUBMIT_INVALID_JOB_ID | ErrorInfo
KMC_LO_START_SUBMIT_JOB_ERROR | ErrorInfo
KMC_LO_SUBMIT_BITMAP | ErrorInfo
KMC_LO_SUBMIT_DOCUMENT_FILE_CLOSE_ERROR | ErrorInfo
KMC_LO_SUBMIT_DOCUMENT_FILEIO_ERROR | ErrorInfo
KMC_LO_SUBMIT_DOCUMENT_IMAGE_FILE_MISSING | ErrorInfo
KMC_LO_SUBMIT_DOCUMENT_IMAGE_REP_ERROR | ErrorInfo
KMC_LO_SUBMIT_DOCUMENT_IMAGES_ERROR | ErrorInfo
KMC_LO_SUBMIT_DOCUMENT_MIMETYPE_ERROR | ErrorInfo
KMC_LO_SUBMIT_DOCUMENT_NO_IMAGE_ERROR | ErrorInfo
KMC_LO_SUBMIT_PNG | ErrorInfo
KMC_LO_TASK_LOCK_ACQUIRE_ERROR | ErrorInfo
KMC_LO_USER_ALREADY_LOGGED_IN | ErrorInfo
KMC_LO_USER_ALREADY_LOGGED_OUT | ErrorInfo
KMC_LO_USER_LOGGING_IN_ON_LOGIN | ErrorInfo
KMC_LO_USER_LOGGING_OUT_ON_LOGOUT | ErrorInfo
KMC_LO_USER_LOGIN_ERROR | ErrorInfo
KMC_LO_USER_LOGOUT_ERROR | ErrorInfo
KMC_LO_USER_NOT_LOGGED_IN_ON_LOGOUT | ErrorInfo
KMC_LO_USERNAME_NOT_SET | ErrorInfo
KMC_OCR_ID_REGION_NOT_SET | ErrorInfo
KMC_OCR_INVALID_BITMAP_SIZE | ErrorInfo
KMC_SUCCESS | ErrorInfo
KMC_UI_CAMERA_ALREADY_OPEN | ErrorInfo
KMC_UI_CAMERA_LOCK_ACQUIRE_FAILURE | ErrorInfo
KMC_UI_CAMERA_OPERATION_FAILURE | ErrorInfo
KMC_UI_CREDITCARD_ARCH_NOT_SUPPORTED | ErrorInfo
KMC_UI_FLASH_AUTO_NOT_SUPPORTED | ErrorInfo
KMC_UI_FLASH_OFF_NOT_SUPPORTED | ErrorInfo
KMC_UI_FLASH_ON_NOT_SUPPORTED | ErrorInfo
KMC_UI_FLASH_TORCH_NOT_SUPPORTED | ErrorInfo
KMC_UI_FOCUS_AREA_COUNT | ErrorInfo
KMC_UI_FOCUS_AREA_EMPTY | ErrorInfo
KMC_UI_FOCUS_AREA_INVALID | ErrorInfo
KMC_UI_FOCUS_AREA_NOT_SUPPORTED | ErrorInfo
KMC_UI_IMAGE_NULL | ErrorInfo
KMC_UI_INVALID_ASPECT_RATIO_ARGUMENT | ErrorInfo
KMC_UI_INVALID_AXIS_THRESHOLD_ARGUMENT | ErrorInfo
KMC_UI_INVALID_BORDER_THICKNESS_ARGUMENT | ErrorInfo
KMC_UI_INVALID_DECLINATION_ARGUMENT | ErrorInfo
KMC_UI_INVALID_HEIGHT_ARGUMENT | ErrorInfo
KMC_UI_INVALID_PADDING_PERCENTAGE_ARGUMENT | ErrorInfo
KMC_UI_INVALID_PAGE_THRESHOLD_ARGUMENT | ErrorInfo
KMC_UI_INVALID_STABILITY_DELAY_ARGUMENT | ErrorInfo
KMC_UI_INVALID_THRESHOLD_ARGUMENT | ErrorInfo
KMC_UI_INVALID_WIDTH_ARGUMENT | ErrorInfo
KMC_UI_ODE_NOT_SUPPORTED_FOR_THE_DOCUMENT_TYPE | ErrorInfo
KMC_UI_SCALING_FACTOR | ErrorInfo
KMC_UI_VIEW_NULL | ErrorInfo
KMC_UT_GOOGLE_PLAY_SERVICES_REPAIRABLE | ErrorInfo
KMC_UT_LICENSE_BARCODE_CAPTURE | ErrorInfo
KMC_UT_LICENSE_ID_EXTRACTION | ErrorInfo
KMC_UT_LICENSE_IMAGE_CAPTURE | ErrorInfo
KMC_UT_LICENSE_IMAGE_PROCESSING | ErrorInfo
KMC_UT_LICENSE_LOGISTICS | ErrorInfo
KMC_UT_LICENSING_FEATURE_NOT_LICENSED | ErrorInfo
KMC_UT_LICENSING_INVALID_SERVER_RESPONSE | ErrorInfo
KMC_UT_LICENSING_NETWORK_EXCEPTION | ErrorInfo
KMC_UT_LICENSING_NOT_VOLUME_LICENSE | ErrorInfo
KMC_UT_LICENSING_NULL_LICENSE_SERVER | ErrorInfo
KMC_UT_LICENSING_NULL_LICENSE_SERVER_TYPE | ErrorInfo
KMC_UT_LICENSING_NULL_LICENSE_TYPE | ErrorInfo
KMC_UT_OUT_OF_VOLUME_LICENSE | ErrorInfo
KMC_UT_STATS_ALREADY_EXPORTING | ErrorInfo
KMC_UT_STATS_ALREADY_RECORDING | ErrorInfo
KMC_UT_STATS_ALREADY_WRITING | ErrorInfo
KMC_UT_STATS_BEGIN_SESSION_NOT_ALLOWED | ErrorInfo
KMC_UT_STATS_DATASTORE_NO_UPGRADE_PATH | ErrorInfo
KMC_UT_STATS_DATASTORE_OUT_OF_DATE | ErrorInfo
KMC_UT_STATS_DATASTORE_UPGRADE_FAILED | ErrorInfo
KMC_UT_STATS_DATASTORE_UPGRADE_MISSING_FILE | ErrorInfo
KMC_UT_STATS_DATASTORE_UPGRADE_NOT_NEEDED | ErrorInfo
KMC_UT_STATS_DATASTORE_UPGRADE_WRONG_STATE | ErrorInfo
KMC_UT_STATS_DEVICE_ID_MISSING | ErrorInfo
KMC_UT_STATS_END_SESSION_NOT_ALLOWED | ErrorInfo
KMC_UT_STATS_EVENT_THROTTLED | ErrorInfo
KMC_UT_STATS_EXPORT_HANDLER_MISSING | ErrorInfo
KMC_UT_STATS_EXPORT_NOT_ALLOWED | ErrorInfo
KMC_UT_STATS_FILEPATH_IS_NULL | ErrorInfo
KMC_UT_STATS_INIT_NOT_ALLOWED | ErrorInfo
KMC_UT_STATS_INVALID_JSON | ErrorInfo
KMC_UT_STATS_INVALID_STATE_TRANSITION | ErrorInfo
KMC_UT_STATS_LOG_SESSION_EVENT_NOT_ALLOWED | ErrorInfo
KMC_UT_STATS_NO_SESSION_BEGUN | ErrorInfo
KMC_UT_STATS_NOTHING_TO_EXPORT | ErrorInfo
KMC_UT_STATS_NOTHING_TO_PURGE | ErrorInfo
KMC_UT_STATS_PURGE_NOT_ALLOWED | ErrorInfo
KMC_UT_STATS_RECORD_AND_WRITING_NOT_ALLOWED | ErrorInfo
KMC_UT_STATS_RECORD_NOT_ALLOWED | ErrorInfo
KMC_UT_STATS_RECORDING_NOT_OFF | ErrorInfo
KMC_UT_STATS_RECORDING_NOT_ON | ErrorInfo
KMC_UT_STATS_SESSION_ALREADY_BEGUN | ErrorInfo
KMC_UT_STATS_STATE_BUSY | ErrorInfo
KMC_UT_STATS_UNINITIALIZED | ErrorInfo
KMC_UT_STATS_WRITING_NOT_ALLOWED | ErrorInfo
setErrCause(String errorCause) | ErrorInfo


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • model
  • Passport
Passport Member List

This is the complete list of members for Passport, including all inherited members.

capturedImageId | CaptureData
getCountry() | Passport
getCountryLong() | Passport
getDateOfBirth() | Passport
getExpirationDate() | Passport
getFirstName() | Passport
getGender() | Passport
getIssueDate() | Passport
getLastName() | Passport
getMiddleName() | Passport
getMRZ1() | Passport
getMRZ2() | Passport
getNationality() | Passport
getPassportNumber() | Passport
getPersonalNumber() | Passport
getRawData() | Passport
processedImageId | CaptureData


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsExportListener
AppStatsExportListener Member List

This is the complete list of members for AppStatsExportListener, including all inherited members.

exportStatusEvent(AppStatsExportEvent event) AppStatsExportListener


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • parameter
  • IParameters
IParameters Member List

This is the complete list of members for IParameters, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • check
  • CheckParameters
  • CheckCountry
CheckParameters.CheckCountry Member List

This is the complete list of members for CheckParameters.CheckCountry, including all inherited members.

AUSTRALIA | CheckParameters.CheckCountry
CANADA | CheckParameters.CheckCountry
HONG_KONG | CheckParameters.CheckCountry
NOT_SPECIFIED | CheckParameters.CheckCountry
SINGAPORE | CheckParameters.CheckCountry
UNITED_KINGDOM | CheckParameters.CheckCountry
UNITED_STATES | CheckParameters.CheckCountry


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • data
  • ImageCacheType
ImageCacheType Member List

This is the complete list of members for ImageCacheType, including all inherited members.

DISK ImageCacheType
getIdentifier() ImageCacheType
IMAGE_CACHE_TYPE_DISK | ImageCacheType | static
IMAGE_CACHE_TYPE_MEMORY | ImageCacheType | static
ImageCacheType(String identifier) | ImageCacheType


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • Image
  • ImageFileRep
Image.ImageFileRep Member List

This is the complete list of members for Image.ImageFileRep, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • PassportCaptureExperienceCriteriaHolder
PassportCaptureExperienceCriteriaHolder Member List

This is the complete list of members for PassportCaptureExperienceCriteriaHolder, including all inherited members.

CaptureExperienceCriteriaHolder() | CaptureExperienceCriteriaHolder
DocumentBaseCaptureExperienceCriteriaHolder() | DocumentBaseCaptureExperienceCriteriaHolder
getHoldSteadyDelay() | DocumentBaseCaptureExperienceCriteriaHolder
getPassportDetectionSettings() | PassportCaptureExperienceCriteriaHolder
getPitchThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
getRollThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
getStabilityThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
isFocusEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isOrientationEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isPageDetectionEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isPitchThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isRefocusBeforeCaptureEnabled() | CaptureExperienceCriteriaHolder
isRollThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isStabilityThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
PassportCaptureExperienceCriteriaHolder() | PassportCaptureExperienceCriteriaHolder
PassportCaptureExperienceCriteriaHolder(PassportCaptureExperienceCriteriaHolder criteria) | PassportCaptureExperienceCriteriaHolder
setDetectionSettings(PassportDetectionSettings detectionSettings) | PassportCaptureExperienceCriteriaHolder
setFocusEnabled(boolean focusEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setHoldSteadyDelay(double seconds) | DocumentBaseCaptureExperienceCriteriaHolder
setOrientationEnabled(boolean enabled) | DocumentBaseCaptureExperienceCriteriaHolder
setPageDetectionEnabled(boolean enabled) | DocumentBaseCaptureExperienceCriteriaHolder
setPitchThreshold(int pitchThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setPitchThresholdEnabled(boolean pitchThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setRefocusEnabled(boolean enabled) | CaptureExperienceCriteriaHolder
setRollThreshold(int rollThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setRollThresholdEnabled(boolean rollThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setStabilityThreshold(int stabilityThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setStabilityThresholdEnabled(boolean stabilityThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • CheckDetector
CheckDetector Member List

This is the complete list of members for CheckDetector, including all inherited members.

CheckDetector() | CheckDetector
destroy() | CheckDetector
detect(CheckDetectionSettings settings, Bitmap image) | CheckDetector
detect(CheckDetectionSettings checkDetectionSettings, byte[] data, int width, int height) | CheckDetector
IDocumentDetector< CheckDetectionSettings, CheckDetectionResult >.detect(T settings, Bitmap image) | IDocumentDetector< CheckDetectionSettings, CheckDetectionResult >
IDocumentDetector< CheckDetectionSettings, CheckDetectionResult >.detect(T settings, byte[] data, int width, int height) | IDocumentDetector< CheckDetectionSettings, CheckDetectionResult >


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • ConventionBasedJsonIdDeserializer
ConventionBasedJsonIdDeserializer Member List

This is the complete list of members for ConventionBasedJsonIdDeserializer, including all inherited members.

capturedImageId | CaptureData
ConventionBasedJsonIdDeserializer(IIdFieldNameConvention convention, IJsonExactionHelper helper, IBase64ImageDecoder base64ImageDecoder, String json) | ConventionBasedJsonIdDeserializer
getAddress() | ConventionBasedJsonIdDeserializer
getAddress2() | ConventionBasedJsonIdDeserializer
getAddress3() | ConventionBasedJsonIdDeserializer
getAddress4() | ConventionBasedJsonIdDeserializer
getAddress5() | ConventionBasedJsonIdDeserializer
getAddress6() | ConventionBasedJsonIdDeserializer
getCity() | ConventionBasedJsonIdDeserializer
getCountry() | ConventionBasedJsonIdDeserializer
getCountryShort() | ConventionBasedJsonIdDeserializer
getDateOfBirth() | ConventionBasedJsonIdDeserializer
getDocumentState() | Id
getDocumentType() | ConventionBasedJsonIdDeserializer
getDocumentVerificationConfidenceRating() | ConventionBasedJsonIdDeserializer
getExpirationDate() | ConventionBasedJsonIdDeserializer
getEyes() | ConventionBasedJsonIdDeserializer
getFaceImage() | ConventionBasedJsonIdDeserializer
getFirstName() | ConventionBasedJsonIdDeserializer
getGender() | ConventionBasedJsonIdDeserializer
getHair() | ConventionBasedJsonIdDeserializer
getHeight() | ConventionBasedJsonIdDeserializer
getIdClass() | ConventionBasedJsonIdDeserializer
getIdNumber() | ConventionBasedJsonIdDeserializer
getIssueDate() | ConventionBasedJsonIdDeserializer
getLastName() | ConventionBasedJsonIdDeserializer
getLicense() | ConventionBasedJsonIdDeserializer
getMiddleName() | ConventionBasedJsonIdDeserializer
getNameSuffix() | ConventionBasedJsonIdDeserializer
getNationality() | ConventionBasedJsonIdDeserializer
getRawData() | ConventionBasedJsonIdDeserializer
getSignatureImage() | ConventionBasedJsonIdDeserializer
getState() | ConventionBasedJsonIdDeserializer
getWeight() | ConventionBasedJsonIdDeserializer
getZip() | ConventionBasedJsonIdDeserializer
isBarcodeRead() | ConventionBasedJsonIdDeserializer
isOcrRead() | ConventionBasedJsonIdDeserializer
processedImageId | CaptureData
setJson(String json) | ConventionBasedJsonIdDeserializer


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • BoundingTetragon
BoundingTetragon Member List

This is the complete list of members for BoundingTetragon, including all inherited members.

BoundingTetragon() | BoundingTetragon
BoundingTetragon(int topLeftX, int topLeftY, int topRightX, int topRightY, int bottomLeftX, int bottomLeftY, int bottomRightX, int bottomRightY) | BoundingTetragon
BoundingTetragon(Point topLeft, Point topRight, Point bottomLeft, Point bottomRight) | BoundingTetragon
clone() | BoundingTetragon
getBottomLeft() | BoundingTetragon
getBottomRight() | BoundingTetragon
getTopLeft() | BoundingTetragon
getTopRight() | BoundingTetragon
rotate(int width, int height, Rotation rotation) | BoundingTetragon
setBottomLeft(Point bottomLeft) | BoundingTetragon
setBottomRight(Point bottomRight) | BoundingTetragon
setTopLeft(Point topLeft) | BoundingTetragon
setTopRight(Point topRight) | BoundingTetragon


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • CaptureMessage
CaptureMessage Member List

This is the complete list of members for CaptureMessage, including all inherited members.

CaptureMessage() | CaptureMessage
getBackground() | CaptureMessage
getBackgroundColor() | CaptureMessage
getHeight() | CaptureMessage
getMessage() | CaptureMessage
getMessageIcons() | CaptureMessage
getOrientation() | CaptureMessage
getPosX() | CaptureMessage
getPosY() | CaptureMessage
getTextColor() | CaptureMessage
getTextSize() | CaptureMessage
getTypeface() | CaptureMessage
getVisibility() | CaptureMessage
getWidth() | CaptureMessage
setBackground(Drawable background) | CaptureMessage
setBackgroundColor(int backgroundColor) | CaptureMessage
setHeight(int height) | CaptureMessage
setMessage(String message) | CaptureMessage
setMessageIcons(Bitmap[] messageIcons) | CaptureMessage
setOrientation(KUIMessageOrientation orientation) | CaptureMessage
setPosX(int posX) | CaptureMessage
setPosY(int posY) | CaptureMessage
setTextColor(int textColor) | CaptureMessage
setTextSize(int textSize) | CaptureMessage
setTypeface(Typeface typeface) | CaptureMessage
setVisibility(boolean visibility) | CaptureMessage
setWidth(int width) | CaptureMessage


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • BarCodeReader
  • BarcodeReadCompleteListener
BarCodeReader.BarcodeReadCompleteListener Member List

This is the complete list of members for BarCodeReader.BarcodeReadCompleteListener, including all inherited members.

barcodeReadComplete(BarcodeReadCompleteEvent event) BarCodeReader.BarcodeReadCompleteListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • data
  • CameraType
CameraType Member List

This is the complete list of members for CameraType, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageProcessor
ImageProcessor Member List

This is the complete list of members for ImageProcessor, including all inherited members.

addAnalysisCompleteEventListener(AnalysisCompleteListener listener) | ImageProcessor
addAnalysisProgressEventListener(AnalysisProgressListener listener) | ImageProcessor
addImageOutEventListener(ImageOutListener listener) | ImageProcessor
addProcessProgressEventListener(ProcessProgressListener listener) | ImageProcessor
cancel() | ImageProcessor
doCleanup() | ImageProcessor
doQuickAnalysis(Image image, boolean returnPreviewImage) | ImageProcessor
doQuickAnalysis(Image image, boolean returnPreviewImage, QuickAnalysisSettings settings) | ImageProcessor
getBasicSettingsProfile() | ImageProcessor
getImagePerfectionProfile() | ImageProcessor
getListenerCallbackThreadType() | ImageProcessor
getProcessedImageFilePath() | ImageProcessor
getProcessedImageJpegQuality() | ImageProcessor
getProcessedImageMimeType() | ImageProcessor
getProcessedImageRepresentation() | ImageProcessor
ImageProcessor() | ImageProcessor
processImage(Image image) | ImageProcessor
processImage(Image image, ImageProcessorConfiguration configuration) | ImageProcessor
removeAnalysisCompleteEventListener(AnalysisCompleteListener listener) | ImageProcessor
removeAnalysisProgressEventListener(AnalysisProgressListener listener) | ImageProcessor
removeImageOutEventListener(ImageOutListener listener) | ImageProcessor
removeProcessProgressEventListener(ProcessProgressListener listener) | ImageProcessor
setBasicSettingsProfile(BasicSettingsProfile basicSettingsProfile) | ImageProcessor
setImagePerfectionProfile(ImagePerfectionProfile imagePerfectionProfile) | ImageProcessor
setListenerCallbackThreadType(ListenerCallbackThreadType listenerCallbackThreadType) | ImageProcessor
setProcessedImageFilePath(String processedImageFilePath) | ImageProcessor
setProcessedImageJpegQuality(int processedImageJpegQuality) | ImageProcessor
setProcessedImageMimeType(ImageMimeType processedImageMimeType) | ImageProcessor
setProcessedImageRepresentation(ImageRep processedImageRepresentation) | ImageProcessor


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • DocumentBaseCaptureExperienceCriteriaHolder
DocumentBaseCaptureExperienceCriteriaHolder Member List

This is the complete list of members for DocumentBaseCaptureExperienceCriteriaHolder, including all inherited members.

CaptureExperienceCriteriaHolder() | CaptureExperienceCriteriaHolder
DocumentBaseCaptureExperienceCriteriaHolder() | DocumentBaseCaptureExperienceCriteriaHolder
getHoldSteadyDelay() | DocumentBaseCaptureExperienceCriteriaHolder
getPitchThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
getRollThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
getStabilityThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
isFocusEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isOrientationEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isPageDetectionEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isPitchThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isRefocusBeforeCaptureEnabled() | CaptureExperienceCriteriaHolder
isRollThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isStabilityThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
setFocusEnabled(boolean focusEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setHoldSteadyDelay(double seconds) | DocumentBaseCaptureExperienceCriteriaHolder
setOrientationEnabled(boolean enabled) | DocumentBaseCaptureExperienceCriteriaHolder
setPageDetectionEnabled(boolean enabled) | DocumentBaseCaptureExperienceCriteriaHolder
setPitchThreshold(int pitchThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setPitchThresholdEnabled(boolean pitchThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setRefocusEnabled(boolean enabled) | CaptureExperienceCriteriaHolder
setRollThreshold(int rollThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setRollThresholdEnabled(boolean rollThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setStabilityThreshold(int stabilityThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setStabilityThresholdEnabled(boolean stabilityThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • creditcard
  • CardIoWrapperActivity
CardIoWrapperActivity Member List

This is the complete list of members for CardIoWrapperActivity, including all inherited members.

EXTRA_EXTRA_TIME_FOR_EXPIRY | CardIoWrapperActivity | static
onActivityResult(int requestCode, int resultCode, Intent data) | CardIoWrapperActivity | protected
onCreate(Bundle savedInstanceState) | CardIoWrapperActivity | protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • BarCodeReader
  • BarcodeReadCompleteEvent
BarCodeReader.BarcodeReadCompleteEvent Member List

This is the complete list of members for BarCodeReader.BarcodeReadCompleteEvent, including all inherited members.

BarcodeReadCompleteEvent(Object sender, ErrorInfo status, Image image) BarCodeReader.BarcodeReadCompleteEvent


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • SelfieCaptureExperienceCriteriaHolder
SelfieCaptureExperienceCriteriaHolder Member List

This is the complete list of members for SelfieCaptureExperienceCriteriaHolder, including all inherited members.

getDetectionSettings() | SelfieCaptureExperienceCriteriaHolder
isFocusEnabled() | SelfieCaptureExperienceCriteriaHolder
SelfieCaptureExperienceCriteriaHolder() | SelfieCaptureExperienceCriteriaHolder
setDetectionSettings(SelfieDetectionSettings selfieDetectionSettings) | SelfieCaptureExperienceCriteriaHolder
setFocusEnabled(boolean focusEnabled) | SelfieCaptureExperienceCriteriaHolder


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • BasicSettingsProfile
  • CropType
BasicSettingsProfile.CropType Member List

This is the complete list of members for BasicSettingsProfile.CropType, including all inherited members.

CROP_AUTO | BasicSettingsProfile.CropType
CROP_NONE | BasicSettingsProfile.CropType
CROP_QUICKANALYSIS | BasicSettingsProfile.CropType
CROP_TETRAGON | BasicSettingsProfile.CropType


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • check
  • ICheckExtractionServer
ICheckExtractionServer Member List

This is the complete list of members for ICheckExtractionServer, including all inherited members.

setCheckParameters(CheckParameters parameters) ICheckExtractionServer


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • ExtractActivity
ExtractActivity< T extends ExtractorResponse > Member List

This is the complete list of members for ExtractActivity< T extends ExtractorResponse >, including all inherited members.

_extractor | ExtractActivity< T extends ExtractorResponse > | protected
CERTIFICATE_VALIDATOR_LISTENER | ExtractActivity< T extends ExtractorResponse > | static
extract(Image image) | ExtractActivity< T extends ExtractorResponse > | protected
getImageByBitmapId(String id) | ExtractActivity< T extends ExtractorResponse > | protected
onCreate(Bundle savedInstanceState) | ExtractActivity< T extends ExtractorResponse > | protected
onExtractionComplete(T results) | ExtractActivity< T extends ExtractorResponse > |
onResume() | ExtractActivity< T extends ExtractorResponse > | protected
onSaveInstanceState(Bundle outState) | ExtractActivity< T extends ExtractorResponse > | protected
setExtract(Extractor extractor) | ExtractActivity< T extends ExtractorResponse > |


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • data
  • FieldType
FieldType Member List

This is the complete list of members for FieldType, including all inherited members.

clone() | FieldType
FieldType() | FieldType
getCustomTag() | FieldType
getDataType() | FieldType
getDefault() | FieldType
getDisplayName() | FieldType
getLabel() | FieldType
getMax() | FieldType
getMin() | FieldType
getName() | FieldType
getOptions() | FieldType
isForceMatch() | FieldType
isHidden() | FieldType
isReadOnly() | FieldType
isRequired() | FieldType
setCustomTag(String customTag) | FieldType
setDataType(DataType dataType) | FieldType
setDefault(String def) | FieldType
setDisplayName(String displayName) | FieldType
setForceMatch(Boolean isForceMatch) | FieldType
setHidden(Boolean isHidden) | FieldType
setLabel(String label) | FieldType
setMax(String max) | FieldType
setMin(String min) | FieldType
setName(String name) | FieldType
setOptions(String[] options) | FieldType
setReadOnly(Boolean isReadOnly) | FieldType
setRequired(Boolean isRequired) | FieldType


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • parameter
  • ProcessingParameters
ProcessingParameters Member List

This is the complete list of members for ProcessingParameters, including all inherited members.

captureData | ProcessingParameters
operations | ProcessingParameters
ProcessingParameters() | ProcessingParameters
processingType | ProcessingParameters
useMrzPageDetection | ProcessingParameters
useTargetFrameCrop | ProcessingParameters


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • ImageReviewActivity
ImageReviewActivity Member List

This is the complete list of members for ImageReviewActivity, including all inherited members.

onCreate(Bundle savedInstanceState) ImageReviewActivity protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatistics
  • ThresholdType
AppStatistics.ThresholdType Member List

This is the complete list of members for AppStatistics.ThresholdType, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • server
  • ExtractionServerException
ExtractionServerException Member List

This is the complete list of members for ExtractionServerException, including all inherited members.

ExtractionServerException(int _code, String _message) ExtractionServerException


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • ContextImageStorage
ContextImageStorage Member List

This is the complete list of members for ContextImageStorage, including all inherited members.

ContextImageStorage() | ContextImageStorage
getImage(String id) | ContextImageStorage
removeImage(String id) | ContextImageStorage
setImage(Bitmap image, String id) | ContextImageStorage


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • KUTLogging
KUTLogging Member List

This is the complete list of members for KUTLogging, including all inherited members.

enableConsoleLogging(boolean enable) KUTLogging static


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • Licensing
  • VolumeLicenseEventListener
Licensing.VolumeLicenseEventListener Member List

This is the complete list of members for Licensing.VolumeLicenseEventListener, including all inherited members.

licenseOperationFailed(VolumeLicenseFailureData failure) | Licensing.VolumeLicenseEventListener
licenseOperationSucceeded(VolumeLicenseResultData results) | Licensing.VolumeLicenseEventListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • CheckDetectionResult
CheckDetectionResult Member List

This is the complete list of members for CheckDetectionResult, including all inherited members.

getBounds() | DetectionResult
getCheckSide() | CheckDetectionResult
getHorizontalMovementGuidance() | DetectionResult
getOrientationGuidance() | DetectionResult
getOriginalImage() | DetectionResult
getTurnGuidance() | DetectionResult
getVerticalMovementGuidance() | DetectionResult
getZoomGuidance() | DetectionResult
toString() | DetectionResult


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ICheckDetector
ICheckDetector Member List

This is the complete list of members for ICheckDetector, including all inherited members.

destroy() | IDocumentDetector< CheckDetectionSettings, CheckDetectionResult >
detect(CheckDetectionSettings settings, Bitmap image) | ICheckDetector
detect(CheckDetectionSettings checkDetectionSettings, byte[] data, int width, int height) | ICheckDetector
IDocumentDetector< CheckDetectionSettings, CheckDetectionResult >.detect(T settings, Bitmap image) | IDocumentDetector< CheckDetectionSettings, CheckDetectionResult >
IDocumentDetector< CheckDetectionSettings, CheckDetectionResult >.detect(T settings, byte[] data, int width, int height) | IDocumentDetector< CheckDetectionSettings, CheckDetectionResult >


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • Image
  • FileIOEngine
Image.FileIOEngine Member List

This is the complete list of members for Image.FileIOEngine, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • FixedAspectRatioExperienceCriteriaHolder
FixedAspectRatioExperienceCriteriaHolder Member List

This is the complete list of members for FixedAspectRatioExperienceCriteriaHolder, including all inherited members.

CaptureExperienceCriteriaHolder() | CaptureExperienceCriteriaHolder
DocumentBaseCaptureExperienceCriteriaHolder() | DocumentBaseCaptureExperienceCriteriaHolder
FixedAspectRatioExperienceCriteriaHolder() | FixedAspectRatioExperienceCriteriaHolder
getDetectionSettings() | FixedAspectRatioExperienceCriteriaHolder
getHoldSteadyDelay() | DocumentBaseCaptureExperienceCriteriaHolder
getPitchThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
getRollThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
getStabilityThreshold() | DocumentBaseCaptureExperienceCriteriaHolder
isFocusEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isOrientationEnabled() | FixedAspectRatioExperienceCriteriaHolder
isPageDetectionEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isPitchThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isRefocusBeforeCaptureEnabled() | CaptureExperienceCriteriaHolder
isRollThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
isStabilityThresholdEnabled() | DocumentBaseCaptureExperienceCriteriaHolder
setDetectionSettings(FixedAspectRatioDetectionSettings detectionSettings) | FixedAspectRatioExperienceCriteriaHolder
setFocusEnabled(boolean focusEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setHoldSteadyDelay(double seconds) | DocumentBaseCaptureExperienceCriteriaHolder
setOrientationEnabled(boolean enabled) | FixedAspectRatioExperienceCriteriaHolder
setPageDetectionEnabled(boolean enabled) | DocumentBaseCaptureExperienceCriteriaHolder
setPitchThreshold(int pitchThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setPitchThresholdEnabled(boolean pitchThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setRefocusEnabled(boolean enabled) | CaptureExperienceCriteriaHolder
setRollThreshold(int rollThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setRollThresholdEnabled(boolean rollThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder
setStabilityThreshold(int stabilityThreshold) | DocumentBaseCaptureExperienceCriteriaHolder
setStabilityThresholdEnabled(boolean stabilityThresholdEnabled) | DocumentBaseCaptureExperienceCriteriaHolder


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • BoundingRect
BoundingRect Member List

This is the complete list of members for BoundingRect, including all inherited members.

BoundingRect() BoundingRect
BoundingRect(BoundingRect r) | BoundingRect
BoundingRect(int left, int top, int right, int bottom) | BoundingRect
getRectBottom() BoundingRect
getRectLeft() BoundingRect
getRectRight() BoundingRect
getRectTop() BoundingRect
height() BoundingRect
set(int left, int top, int right, int bottom) | BoundingRect
set(BoundingRect src) | BoundingRect
setEmpty() BoundingRect
setRectBottom(int bottom) | BoundingRect
setRectLeft(int left) | BoundingRect
setRectRight(int right) | BoundingRect
setRectTop(int top) | BoundingRect


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • RttiIdExtractor
RttiIdExtractor Member List

This is the complete list of members for RttiIdExtractor, including all inherited members.

extract(DataUnit unit, IDataUnitProcessedListener listener) | RttiIdExtractor |
RttiIdExtractor(IImageToByteArray converter) | RttiIdExtractor |
setIdParameters(IdParameters parameters) | RttiIdExtractor |
updateRttiRequest(RttiRequest rttiRequest) | RttiIdExtractor | protected


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • ProcessActivity
ProcessActivity Member List

This is the complete list of members for ProcessActivity, including all inherited members.

onBackPressed() | ProcessActivity |
onCreate(Bundle savedInstanceState) | ProcessActivity | protected
onImageProcessed(Image image) | ProcessActivity |
onPause() | ProcessActivity | protected
onResume() | ProcessActivity | protected
onSaveInstanceState(Bundle outState) | ProcessActivity | protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • data
  • Field
Field Member List

This is the complete list of members for Field, including all inherited members.

clone() | Field
Field(FieldType fieldType) | Field
getErrorDescription() | Field
getFieldType() | Field
getTag() | Field
getValue() | Field
isValid() | Field
setTag(String tag) | Field
updateFieldProperties(String value, boolean isValid, String errorDescription) | Field


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • data
  • Symbology
Symbology Member List

This is the complete list of members for Symbology, including all inherited members.

AZTEC | Symbology
CODABAR | Symbology
CODE128 | Symbology
CODE25 | Symbology
CODE39 | Symbology
CODE93 | Symbology
DATAMATRIX | Symbology
EAN | Symbology
PDF417 | Symbology
QR | Symbology
UPC | Symbology


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • bill
  • KtaJsonBill
KtaJsonBill Member List

This is the complete list of members for KtaJsonBill, including all inherited members.

capturedImageId | CaptureData
getAccountNumber() | KtaJsonBill
getAddressLine1() | KtaJsonBill
getAddressLine2() | KtaJsonBill
getAmount() | KtaJsonBill
getBillers() | KtaJsonBill
getCity() | KtaJsonBill
getDueDate() | KtaJsonBill
getName() | KtaJsonBill
getPhoneNumber() | KtaJsonBill
getRawData() | KtaJsonBill
getSource() | KtaJsonBill
getState() | KtaJsonBill
getZip() | KtaJsonBill
KtaJsonBill(Context context, String json) | KtaJsonBill
processedImageId | CaptureData
setJson(String json) | KtaJsonBill


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageProcessor
  • AnalysisProgressEvent
ImageProcessor.AnalysisProgressEvent Member List

This is the complete list of members for ImageProcessor.AnalysisProgressEvent, including all inherited members.

AnalysisProgressEvent(Object sender, ErrorInfo status, String imageID, int progressPct) ImageProcessor.AnalysisProgressEvent


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • SelfieBaseCaptureExperience
SelfieBaseCaptureExperience Member List

This is the complete list of members for SelfieBaseCaptureExperience, including all inherited members.

_ctx | SelfieBaseCaptureExperience | protected
addOnImageCapturedListener(ImageCapturedListener listener) | SelfieBaseCaptureExperience
destroy() SelfieBaseCaptureExperience
getBlinkMessage() SelfieBaseCaptureExperience
getCaptureCriteria() SelfieBaseCaptureExperience
getCapturedMessage() SelfieBaseCaptureExperience
getFrameColor() SelfieBaseCaptureExperience
getHoldSteadyMessage() SelfieBaseCaptureExperience
getOuterViewFinderColor() SelfieBaseCaptureExperience
getPaddingPercent() SelfieBaseCaptureExperience
getUserInstructionMessage() SelfieBaseCaptureExperience
initBase(ImageCaptureView view, SelfieCaptureExperienceCriteriaHolder criteria) | SelfieBaseCaptureExperience | protected
isVibrationEnabled() SelfieBaseCaptureExperience
removeOnImageCapturedListener(ImageCapturedListener listener) | SelfieBaseCaptureExperience
SelfieBaseCaptureExperience(ImageCaptureView view, SelfieCaptureExperienceCriteriaHolder criteria) | SelfieBaseCaptureExperience
setBlinkMessage(CaptureMessage blinkMessage) | SelfieBaseCaptureExperience
setCapturedMessage(CaptureMessage capturedMessage) | SelfieBaseCaptureExperience
setFrameColor(int colorCode) | SelfieBaseCaptureExperience
setHoldSteadyMessage(CaptureMessage holdSteadyMessage) | SelfieBaseCaptureExperience
setOuterViewFinderColor(int colorCode) | SelfieBaseCaptureExperience
setUserInstructionMessage(CaptureMessage userInstructionMessage) | SelfieBaseCaptureExperience
setVibrationEnabled(boolean enable) | SelfieBaseCaptureExperience


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • error
  • KmcException
KmcException Member List

This is the complete list of members for KmcException, including all inherited members.

getErrorInfo() | KmcException
KmcException(ErrorInfo errorInfo) | KmcException
KmcException(ErrorInfo errorInfo, Throwable cause) | KmcException


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • BasicSettingsProfile
  • OutputBitDepth
BasicSettingsProfile.OutputBitDepth Member List

This is the complete list of members for BasicSettingsProfile.OutputBitDepth, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • VerticalGuidance
VerticalGuidance Member List

This is the complete list of members for VerticalGuidance, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • KtaIdExtractor
KtaIdExtractor Member List

This is the complete list of members for KtaIdExtractor, including all inherited members.

extract(DataUnit unit, IDataUnitProcessedListener listener) | KtaIdExtractor |
getProcessName() | KtaIdExtractor |
KtaIdExtractor(IKtaSessionIdProviderFactory sessionIdProviderFactory, IImageToByteArray converter) | KtaIdExtractor |
setIdParameters(IdParameters parameters) | KtaIdExtractor |
updateKTARequest(JobService jobService) | KtaIdExtractor | protected


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • server
  • ServerExtractionParameters
ServerExtractionParameters Member List

This is the complete list of members for ServerExtractionParameters, including all inherited members.

getCertificateValidationListener() | ServerExtractionParameters
getImageBytes() | ServerExtractionParameters
getImages() | ServerExtractionParameters
getParameters() | ServerExtractionParameters
getServerUrl() | ServerExtractionParameters
getTimeOutParameters() | ServerExtractionParameters
ServerExtractionParameters(String serverUrl, List< Image > images, List< byte[]> imageBytes, CertificateValidatorListener certificateValidationListener, HashMap< String, String > parameters, TimeOutParameters timeOutParameters) | ServerExtractionParameters


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • check
  • RttiCheckExtractor
RttiCheckExtractor Member List

This is the complete list of members for RttiCheckExtractor, including all inherited members.

RttiCheckExtractor(IImageToByteArray converter) | RttiCheckExtractor |
setCheckParameters(CheckParameters parameters) | RttiCheckExtractor |
updateRttiRequest(RttiRequest rttiRequest) | RttiCheckExtractor | protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • PassportCaptureExperience
PassportCaptureExperience Member List

This is the complete list of members for PassportCaptureExperience, including all inherited members.

_aspectRatio | CaptureExperience | protected
_captureExperienceData | CaptureExperience | protected
_continuousCapture | CaptureExperience | protected
_ctx | DocumentBaseCaptureExperience | protected
_imageCapturedListeners | CaptureExperience | protected
_imageCaptureView | CaptureExperience | protected
_lock | CaptureExperience | protected
_sdkCaptureRequested | CaptureExperience | protected
_uiHandler | CaptureExperience | protected
_vibrationEnabled | CaptureExperience | protected
_vibrator | CaptureExperience | protected
addOnImageCapturedListener(ImageCapturedListener listener) | DocumentBaseCaptureExperience
addPageDetectionListener(PageDetectionListener listener) | DocumentBaseCaptureExperience
captureCriteriaMetInternal(CaptureExperienceData data) | CaptureExperience | protected
destroy() DocumentBaseCaptureExperience
DocumentBaseCaptureExperience(ImageCaptureView view, DocumentBaseCaptureExperienceCriteriaHolder criteria) | DocumentBaseCaptureExperience
enableAnimationTutor(boolean enable) | DocumentBaseCaptureExperience
getCaptureCriteria() PassportCaptureExperience
getCapturedMessage() DocumentBaseCaptureExperience
getCenterMessage() PassportCaptureExperience
getDocumentSampleImage() DocumentBaseCaptureExperience
getGuidanceFrameColor() DocumentBaseCaptureExperience
getHoldParallelMessage() DocumentBaseCaptureExperience
getHoldSteadyMessage() DocumentBaseCaptureExperience
getOuterViewFinderColor() DocumentBaseCaptureExperience
getPassportSampleImage() PassportCaptureExperience
getRotateMessage() DocumentBaseCaptureExperience
getTutorialDismissMessage() DocumentBaseCaptureExperience
getUserInstructionMessage() PassportCaptureExperience
getZoomInMessage() DocumentBaseCaptureExperience
getZoomOutMessage() DocumentBaseCaptureExperience
initBase(ImageCaptureView view, IDetectionAdapter adapter, DocumentBaseCaptureExperienceCriteriaHolder criteria) | DocumentBaseCaptureExperience | protected
invokeImageCapturedListeners(ImageCapturedEvent event) | CaptureExperience | protected
isAnimationTutorEnable() DocumentBaseCaptureExperience
isDiagnosticsViewEnabled() DocumentBaseCaptureExperience
isVibrationEnabled() DocumentBaseCaptureExperience
onAutoFocus(AutoFocusResultEvent event) | CaptureExperience
onImageCaptured(ImageCapturedEvent event) | CaptureExperience
onLevelness(LevelnessEvent event) | CaptureExperience
onStabilityDelay(StabilityDelayEvent event) | CaptureExperience
PassportCaptureExperience(ImageCaptureView view) | PassportCaptureExperience
PassportCaptureExperience(ImageCaptureView view, PassportCaptureExperienceCriteriaHolder criteria) | PassportCaptureExperience
removeOnImageCapturedListener(ImageCapturedListener listener) | DocumentBaseCaptureExperience
removePageDetectionListener(PageDetectionListener listener) | DocumentBaseCaptureExperience
setCaptureCriteria(PassportCaptureExperienceCriteriaHolder criteria) | PassportCaptureExperience
setCapturedMessage(CaptureMessage capturedMessage) | DocumentBaseCaptureExperience
setCenterMessage(CaptureMessage centerMessage) | PassportCaptureExperience
setDiagnosticsViewEnabled(boolean enabled) | DocumentBaseCaptureExperience
setDocumentSampleImage(Bitmap documentSampleImage) | DocumentBaseCaptureExperience
setGuidanceFrameColor(int colorCode) | DocumentBaseCaptureExperience
setHoldParallelMessage(CaptureMessage message) | DocumentBaseCaptureExperience
setHoldSteadyMessage(CaptureMessage holdSteadyMessage) | DocumentBaseCaptureExperience
setOuterViewFinderColor(int colorCode) | DocumentBaseCaptureExperience
setPassportSampleImage(Bitmap passportSampleImage) | PassportCaptureExperience
setRotateMessage(CaptureMessage message) | DocumentBaseCaptureExperience
setSteadyGuidanceFrameColor(int colorCode) | DocumentBaseCaptureExperience
setTutorialDismissMessage(CaptureMessage tutorialDismissMessage) | DocumentBaseCaptureExperience
setUserInstructionMessage(CaptureMessage userInstructionsMessage) | PassportCaptureExperience
setVibrationEnabled(boolean enable) | DocumentBaseCaptureExperience
setZoomInMessage(CaptureMessage zoomInMessage) | DocumentBaseCaptureExperience
setZoomOutMessage(CaptureMessage zoomOutMessage) | DocumentBaseCaptureExperience


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • ImgReviewEditCntrl
ImgReviewEditCntrl Member List

This is the complete list of members for ImgReviewEditCntrl, including all inherited members.

clearHighlights() | ImgReviewEditCntrl |
clearImage() | ImgReviewEditCntrl |
getCropCornerColor() | ImgReviewEditCntrl |
getCropLineColor() | ImgReviewEditCntrl |
getCropTetragon() | ImgReviewEditCntrl |
getImage() | ImgReviewEditCntrl |
getRetainImage() | ImgReviewEditCntrl |
ImgReviewEditCntrl(Context context) | ImgReviewEditCntrl |
ImgReviewEditCntrl(Context context, AttributeSet attrs) | ImgReviewEditCntrl |
ImgReviewEditCntrl(Context context, AttributeSet attrs, int defStyle) | ImgReviewEditCntrl |
onDraw(Canvas canvas) | ImgReviewEditCntrl | protected
onRestoreInstanceState(Parcelable state) | ImgReviewEditCntrl |
onSaveInstanceState() | ImgReviewEditCntrl |
onSizeChanged(int w, int h, int oldw, int oldh) | ImgReviewEditCntrl | protected
onTouch(View v, MotionEvent event) | ImgReviewEditCntrl |
scaleGestureDetector | ImgReviewEditCntrl |
setCropCornerColor(int cColor) | ImgReviewEditCntrl |
setCropLineColor(int lColor) | ImgReviewEditCntrl |
setCropLineStyle(Line_Style_Solid myStyle) | ImgReviewEditCntrl |
setCropTetragon(BoundingTetragon bt) | ImgReviewEditCntrl |
setHighlightColor(int color) | ImgReviewEditCntrl |
setImage(Image i) | ImgReviewEditCntrl |
setImageCacheType(ImageCacheType imageCacheType) | ImgReviewEditCntrl |
setRetainImage(boolean retainImage) | ImgReviewEditCntrl |
showCropRectangle(boolean isVisible) | ImgReviewEditCntrl |
showHighlights(BoundingRect[] rectArr) | ImgReviewEditCntrl |


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • data
  • Flash
Flash Member List

This is the complete list of members for Flash, including all inherited members.

AUTO | Flash
AUTOTORCH | Flash
OFF | Flash
ON | Flash
TORCH | Flash


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • SelfieCaptureExperience
SelfieCaptureExperience Member List

This is the complete list of members for SelfieCaptureExperience, including all inherited members.

_ctx | SelfieBaseCaptureExperience | protected
addOnImageCapturedListener(ImageCapturedListener listener) | SelfieBaseCaptureExperience
destroy() SelfieBaseCaptureExperience
getBlinkMessage() SelfieBaseCaptureExperience
getCaptureCriteria() SelfieBaseCaptureExperience
getCapturedMessage() SelfieBaseCaptureExperience
getFrameColor() SelfieBaseCaptureExperience
getHoldSteadyMessage() SelfieBaseCaptureExperience
getOuterViewFinderColor() SelfieBaseCaptureExperience
getPaddingPercent() SelfieBaseCaptureExperience
getUserInstructionMessage() SelfieBaseCaptureExperience
initBase(ImageCaptureView view, SelfieCaptureExperienceCriteriaHolder criteria) | SelfieBaseCaptureExperience | protected
isVibrationEnabled() SelfieBaseCaptureExperience
removeOnImageCapturedListener(ImageCapturedListener listener) | SelfieBaseCaptureExperience
SelfieBaseCaptureExperience(ImageCaptureView view, SelfieCaptureExperienceCriteriaHolder criteria) | SelfieBaseCaptureExperience
SelfieCaptureExperience(ImageCaptureView view) | SelfieCaptureExperience
SelfieCaptureExperience(ImageCaptureView view, SelfieCaptureExperienceCriteriaHolder criteria) | SelfieCaptureExperience
setBlinkMessage(CaptureMessage blinkMessage) | SelfieBaseCaptureExperience
setCaptureCriteria(SelfieCaptureExperienceCriteriaHolder criteria) | SelfieCaptureExperience
setCapturedMessage(CaptureMessage capturedMessage) | SelfieBaseCaptureExperience
setFrameColor(int colorCode) | SelfieBaseCaptureExperience
setHoldSteadyMessage(CaptureMessage holdSteadyMessage) | SelfieBaseCaptureExperience
setOuterViewFinderColor(int colorCode) | SelfieBaseCaptureExperience
setUserInstructionMessage(CaptureMessage userInstructionMessage) | SelfieBaseCaptureExperience
setVibrationEnabled(boolean enable) | SelfieBaseCaptureExperience


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • Image
  • ImageMimeType
Image.ImageMimeType Member List

This is the complete list of members for Image.ImageMimeType, including all inherited members.

MIMETYPE_JPEG | Image.ImageMimeType
MIMETYPE_PNG | Image.ImageMimeType
MIMETYPE_TIFF | Image.ImageMimeType
MIMETYPE_UNKNOWN | Image.ImageMimeType


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • ListOfException
ListOfException Member List

This is the complete list of members for ListOfException, including all inherited members.

getInnerThrowables() | ListOfException
ListOfException(String detailMessage, Throwable[] innerThrowables) | ListOfException
ListOfException(String detailMessage, List<?extends Throwable > innerThrowables) | ListOfException
ListOfException(List<?extends Throwable > innerThrowables) | ListOfException
printStackTrace(PrintStream err) | ListOfException
printStackTrace(PrintWriter err) | ListOfException


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • passport
  • PassportParameters
PassportParameters Member List

This is the complete list of members for PassportParameters, including all inherited members.

getExtractionParameters() | PassportParameters
getLookAndFeelParameters() | PassportParameters
getProcessingParameters() | PassportParameters
PassportParameters(Context context) | PassportParameters


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • LocalProjectProvider
LocalProjectProvider Member List

This is the complete list of members for LocalProjectProvider, including all inherited members.

finalize() | LocalProjectProvider | protected
getBundleVersion(String projectName) | LocalProjectProvider | protected
getHighestVersion(final String projectName, final String sdkVersion, final ICompletionListener< String > listener) | LocalProjectProvider |
getLatestCachedModelDataBuildInfo(String projectName) | LocalProjectProvider |
getProject(final String projectName, final String version, final ICompletionListener< File > listener) | LocalProjectProvider |
getProjectAsync(final String projectName, final String version) | LocalProjectProvider | protected
getVariant(final String projectName, final String variantName, final String version, final ICompletionListener< File > listener) | LocalProjectProvider |
getVariantAsync(final String projectName, final String variantName, final String version) | LocalProjectProvider | protected
LocalProjectProvider(Context ctx) | LocalProjectProvider |
LocalProjectProvider(Context ctx, InputStream projectZipStream, IBundleCacheProvider cacheProvider) | LocalProjectProvider |
readVersion(File versionTable) | LocalProjectProvider | protected
readVersion(String jsonContent) | LocalProjectProvider | protected
sdkVersion() | LocalProjectProvider | protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • error
  • KmcRuntimeException
KmcRuntimeException Member List

This is the complete list of members for KmcRuntimeException, including all inherited members.

getErrorInfo() | KmcRuntimeException
KmcRuntimeException(ErrorInfo errorInfo) | KmcRuntimeException
KmcRuntimeException(ErrorInfo errorInfo, Throwable cause) | KmcRuntimeException


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageProcessor
  • ImageOutListener
ImageProcessor.ImageOutListener Member List

This is the complete list of members for ImageProcessor.ImageOutListener, including all inherited members.

imageOut(ImageOutEvent event) ImageProcessor.ImageOutListener


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • LocalProjectProvider
  • VersionTable
LocalProjectProvider.VersionTable Member List

This is the complete list of members for LocalProjectProvider.VersionTable, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • OrientationGuidance
OrientationGuidance Member List

This is the complete list of members for OrientationGuidance, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • logistics
  • CaptureServer
CaptureServer Member List

This is the complete list of members for CaptureServer, including all inherited members.

cancelSubmission(String submitJobID) | CaptureServer
CaptureServer(String serverURL, SourceServer sourceServer) | CaptureServer
getDocumentType(String documentTypeName, final ICompletionListener< DocumentType > completionListener) | CaptureServer
com::kofax::mobile::sdk::logistics::ICaptureServer.getDocumentType(String documentTypeName, ICompletionListener< DocumentType > completionListener) | ICaptureServer
getServerTimeout() | CaptureServer
login(UserProfile userProfile, final ICompletionListener< List< String >> completionListener) | CaptureServer
com::kofax::mobile::sdk::logistics::ICaptureServer.login(UserProfile userProfile, ICompletionListener< List< String >> completionListener) | ICaptureServer
loginAnonymously(final ICompletionListener< List< String >> completionListener) | CaptureServer
com::kofax::mobile::sdk::logistics::ICaptureServer.loginAnonymously(ICompletionListener< List< String >> completionListener) | ICaptureServer
logout(final ICompletionListener< Void > completionListener) | CaptureServer
com::kofax::mobile::sdk::logistics::ICaptureServer.logout(ICompletionListener< Void > completionListener) | ICaptureServer
registerDevice(final ICompletionListener< Void > completionListener) | CaptureServer
com::kofax::mobile::sdk::logistics::ICaptureServer.registerDevice(ICompletionListener< Void > completionListener) | ICaptureServer
sendImageService(Document document, String jobID, Image image, int ImageIndex, boolean lastImage, final ICompletionListener< Void > completionListener) | CaptureServer
com::kofax::mobile::sdk::logistics::ICaptureServer.sendImageService(Document document, String jobID, Image image, int ImageIndex, boolean lastImage, ICompletionListener< Void > completionListener) | ICaptureServer
setCertificateValidatorListener(CertificateValidatorListener certificateValidatorListener) | CaptureServer
setServerTimeout(int timeout) | CaptureServer
startJobService(final ICompletionListener< String > completionListener) | CaptureServer
com::kofax::mobile::sdk::logistics::ICaptureServer.startJobService(ICompletionListener< String > completionListener) | ICaptureServer
submitDocument(Document document, IProgressListener iProgressListener, final ICompletionListener iCompletionListener) | CaptureServer
com::kofax::mobile::sdk::logistics::ICaptureServer.submitDocument(Document document, IProgressListener iProgressListener, ICompletionListener iCompletionListener) | ICaptureServer


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • version
  • KuiVersion
KuiVersion Member List

This is the complete list of members for KuiVersion, including all inherited members.

getPackageVersion() KuiVersion static


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • parameter
  • ExtractionParameters
ExtractionParameters Member List

This is the complete list of members for ExtractionParameters, including all inherited members.

credentials | ExtractionParameters
ExtractionParameters() | ExtractionParameters
getExtractionType() | ExtractionParameters
serverUrl | ExtractionParameters
setExtractionType(ExtractionType extractionType) | ExtractionParameters
setProjectProvider(Context context, IProjectProvider projectProvider) | ExtractionParameters


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsThresholdReachedEvent
AppStatsThresholdReachedEvent Member List

This is the complete list of members for AppStatsThresholdReachedEvent, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatistics
AppStatistics Member List

This is the complete list of members for AppStatistics, including all inherited members.

addAppStatsExportListener(AppStatsExportListener listener) | AppStatistics
addAppStatsWriteFileListener(AppStatsWriteFileListener listener) | AppStatistics
addAppThresholdListener(AppstatsThresholdReachedListener listener) | AppStatistics
appStatsDaoCurrent | AppStatistics | protected
beginSession(String sessionKey, String category) | AppStatistics
endSession(boolean success, String description) | AppStatistics
export(String exportFilePath, AppStatsExportFormat format) | AppStatistics
getDeviceId() AppStatistics
getFileName() AppStatistics
getFileSize() AppStatistics
getFileSizeThreshold() AppStatistics
getInstance() | AppStatistics | static
getListenerCallbackThreadType() AppStatistics
getRamSize() AppStatistics
getRamSizeThreshold() AppStatistics
initAppStats(String name) | AppStatistics
isRecording() AppStatistics
logSessionEvent(AppStatsSessionEvent sessionEvent) | AppStatistics
purge() AppStatistics
registerExportHandler(AppStatsDsExportHandler handler) | AppStatistics
removeAppStatsExportListener(AppStatsExportListener listener) | AppStatistics
removeAppStatsThresholdListener(AppstatsThresholdReachedListener listener) | AppStatistics
removeAppStatsWriteFileListener(AppStatsWriteFileListener listener) | AppStatistics
setDeviceId(String userDeviceID) | AppStatistics
setFileSizeThreshold(int fileSizeThreshold) | AppStatistics
setListenerCallbackThreadType(ListenerCallbackThreadType listenerCallbackThreadType) | AppStatistics
setRamSizeThreshold(int ramSizeThreshold) | AppStatistics


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageProcessor
  • ProcessProgressListener
ImageProcessor.ProcessProgressListener Member List

This is the complete list of members for ImageProcessor.ProcessProgressListener, including all inherited members.

processProgress(ProcessProgressEvent event) ImageProcessor.ProcessProgressListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • BarCodeReader
  • Symbology
BarCodeReader.Symbology Member List

This is the complete list of members for BarCodeReader.Symbology, including all inherited members.

Codabar BarCodeReader.Symbology
Code128 BarCodeReader.Symbology
Code25 BarCodeReader.Symbology
Code39 BarCodeReader.Symbology
Code93 BarCodeReader.Symbology
Datamatrix BarCodeReader.Symbology
Ean BarCodeReader.Symbology
getBarCodeType(int cVal) | BarCodeReader.Symbology | static
Pdf417 BarCodeReader.Symbology
Postnet BarCodeReader.Symbology
QRCode BarCodeReader.Symbology
Symbology(int cVal) | BarCodeReader.Symbology


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • processing
  • ColorDepth
ColorDepth Member List

This is the complete list of members for ColorDepth, including all inherited members.

BITONAL ColorDepth
COLOR ColorDepth
ColorDepth(int value) ColorDepth


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • IPassportDetector
IPassportDetector Member List

This is the complete list of members for IPassportDetector, including all inherited members.

destroy() | IDocumentDetector< PassportDetectionSettings, PassportDetectionResult >
detect(PassportDetectionSettings settings, Bitmap image) | IPassportDetector
detect(PassportDetectionSettings passportDetectionSettings, byte[] data, int width, int height) | IPassportDetector
IDocumentDetector< PassportDetectionSettings, PassportDetectionResult >.detect(T settings, Bitmap image) | IDocumentDetector< PassportDetectionSettings, PassportDetectionResult >
IDocumentDetector< PassportDetectionSettings, PassportDetectionResult >.detect(T settings, byte[] data, int width, int height) | IDocumentDetector< PassportDetectionSettings, PassportDetectionResult >


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • check
  • RttiJsonCheck
RttiJsonCheck Member List

This is the complete list of members for RttiJsonCheck, including all inherited members.

capturedImageId | CaptureData
getAmount() | RttiJsonCheck
getAuxiliaryOnUs() | RttiJsonCheck
getCar() | RttiJsonCheck
getCheckIQAData() | RttiJsonCheck
getCheckNumber() | RttiJsonCheck
getCheckUsabilityData() | RttiJsonCheck
getDate() | RttiJsonCheck
getEpc() | RttiJsonCheck
getLar() | RttiJsonCheck
getMicr() | RttiJsonCheck
getMicrAmount() | RttiJsonCheck
getOnUs1() | RttiJsonCheck
getOnUs2() | RttiJsonCheck
getPayee() | RttiJsonCheck
getRawData() | RttiJsonCheck
getReasonForRejection() | RttiJsonCheck
getRestrictiveEndorsement() | RttiJsonCheck
getRestrictiveEndorsementPresent() | RttiJsonCheck
getTransit() | RttiJsonCheck
getUsable() | RttiJsonCheck
processedImageId | CaptureData
RttiJsonCheck(Context context, String json) | RttiJsonCheck
setJson(String json) | RttiJsonCheck


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • LicenseFoundEvent
LicenseFoundEvent Member List

This is the complete list of members for LicenseFoundEvent, including all inherited members.

getDaysRemaining() | LicenseFoundEvent
getErrorInfo() | LicenseFoundEvent
getLicenseString() | LicenseFoundEvent
LicenseFoundEvent(Object sender, ErrorInfo errorInfo, int daysRemaining, String licenseString) | LicenseFoundEvent


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • parameter
  • LookAndFeelParameters
  • TorchMode
LookAndFeelParameters.TorchMode Member List

This is the complete list of members for LookAndFeelParameters.TorchMode, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • AutoFocusResultEvent
AutoFocusResultEvent Member List

This is the complete list of members for AutoFocusResultEvent, including all inherited members.

AutoFocusResultEvent(Object sender, boolean success) AutoFocusResultEvent


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • WorkflowActivity
WorkflowActivity< T extends IParameters > Member List

This is the complete list of members for WorkflowActivity< T extends IParameters >, including all inherited members.

captureImage() | WorkflowActivity< T extends IParameters > | protected
CERTIFICATE_VALIDATOR_LISTENER | WorkflowActivity< T extends IParameters > | static
clearBitmap(String imageId) | WorkflowActivity< T extends IParameters > | protected
getCaptureActivityClass() | WorkflowActivity< T extends IParameters > |
getDefaultProcessingString(T parameters) | WorkflowActivity< T extends IParameters > |
getDefaultReturnObject() | WorkflowActivity< T extends IParameters > |
getExceptionKey() | WorkflowActivity< T extends IParameters > |
getExtractActivityClass() | WorkflowActivity< T extends IParameters > |
getParameters(Bundle savedInstanceState) | WorkflowActivity< T extends IParameters > |
getParametersInstance() | WorkflowActivity< T extends IParameters > |
getParametersKey() | WorkflowActivity< T extends IParameters > |
getResultKey() | WorkflowActivity< T extends IParameters > |
handleException(final Throwable exc) | WorkflowActivity< T extends IParameters > | protected
isOdeSupported() | WorkflowActivity< T extends IParameters > | protected
onActivityResult(int requestCode, int resultCode, Intent data) | WorkflowActivity< T extends IParameters > | protected
onCreate(Bundle savedInstanceState) | WorkflowActivity< T extends IParameters > | protected
onDestroy() | WorkflowActivity< T extends IParameters > | protected
onResume() | WorkflowActivity< T extends IParameters > | protected
onSaveInstanceState(Bundle outState) | WorkflowActivity< T extends IParameters > | protected
tryRestoreState(Bundle savedInstanceState) | WorkflowActivity< T extends IParameters > | protected


Kofax Mobile SDK API Reference: mainpage.h Source File

  • File List
mainpage.h
Go to the documentation of this file.
1 //
2 // Copyright (c) 2017 Kofax Inc. All rights reserved.
3 //
4
5 #


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsWriteFileListener
  • WriteFileStatus
AppStatsWriteFileListener.WriteFileStatus Member List

This is the complete list of members for AppStatsWriteFileListener.WriteFileStatus, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • DocumentDetectionSettings
  • DocumentEdgeDetection
DocumentDetectionSettings.DocumentEdgeDetection Member List

This is the complete list of members for DocumentDetectionSettings.DocumentEdgeDetection, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • AutoFocusResultListener
AutoFocusResultListener Member List

This is the complete list of members for AutoFocusResultListener, including all inherited members.

onAutoFocus(AutoFocusResultEvent event) AutoFocusResultListener


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • server
  • ServerBuilder
  • ServerType
ServerBuilder.ServerType Member List

This is the complete list of members for ServerBuilder.ServerType, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • data
  • Page
  • Side
Page.Side Member List

This is the complete list of members for Page.Side, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • data
  • SearchDirection
SearchDirection Member List

This is the complete list of members for SearchDirection, including all inherited members.

ALL SearchDirection
getValue() SearchDirection
HORIZONTAL SearchDirection
SearchDirection(int value) SearchDirection


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • DocumentDetectionSettings
DocumentDetectionSettings Member List

This is the complete list of members for DocumentDetectionSettings, including all inherited members.

DetectionSettings() | DetectionSettings | protected
DetectionSettings(DetectionSettings settings) | DetectionSettings | protected
DetectionSettings(Point targetFrameCenter, double targetFrameAspectRatio, double targetFramePaddingPercent) | DetectionSettings |
DocumentDetectionSettings() | DocumentDetectionSettings |
DocumentDetectionSettings(DocumentDetectionSettings detectionSettings) | DocumentDetectionSettings |
DocumentDetectionSettings(DetectionSettings detectionSettings) | DocumentDetectionSettings |
getCenterPoint() | DetectionSettings |
getEdgeDetection() | DocumentDetectionSettings |
getLongEdgeThreshold() | DocumentDetectionSettings |
getMaxFillFraction() | DetectionSettings |
getMaxSkewAngle() | DetectionSettings |
getMinFillFraction() | DetectionSettings |
getShortEdgeThreshold() | DocumentDetectionSettings |
getTargetFrameAspectRatio() | DetectionSettings |
getTargetFramePaddingPercent() | DetectionSettings |
getToleranceFraction() | DetectionSettings |
setCenterPoint(Point targetFrameCenter) | DetectionSettings |
setEdgeDetection(DocumentEdgeDetection edgeDetection) | DocumentDetectionSettings |
setLongEdgeThreshold(double longEdgeThreshold) | DocumentDetectionSettings |
setMaxFillFraction(double maxFillFraction) | DetectionSettings |
setMaxSkewAngle(double maxSkewAngle) | DetectionSettings |
setMinFillFraction(double minFillFraction) | DetectionSettings |
setShortEdgeThreshold(double shortEdgeThreshold) | DocumentDetectionSettings |
setTargetFrameAspectRatio(double targetFrameAspectRatio) | DetectionSettings |
setTargetFramePaddingPercent(double paddingPercent) | DetectionSettings |
setToleranceFraction(double toleranceFraction) | DetectionSettings |


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • model
  • FieldLocation
FieldLocation Member List

This is the complete list of members for FieldLocation, including all inherited members.

FieldLocation(double left, double top, double width, double height) | FieldLocation |
origin | FieldLocation |
size | FieldLocation |
toString() | FieldLocation |
UNDEFINED | FieldLocation | static


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • ImageCaptureView
ImageCaptureView Member List

This is the complete list of members for ImageCaptureView, including all inherited members.

_bus | ImageCaptureView | protected
addCameraInitializationFailedListener(CameraInitializationFailedListener listener) | ImageCaptureView
addCameraInitializationListener(CameraInitializationListener listener) | ImageCaptureView
addLevelnessListener(LevelnessListener listener) | ImageCaptureView
addOnAutoFocusResultListener(AutoFocusResultListener listener) | ImageCaptureView
addOnImageCapturedListener(ImageCapturedListener listener) | ImageCaptureView
addPreviewCallbackListener(PreviewCallbackListener listener) | ImageCaptureView
addStabilityDelayListener(StabilityDelayListener listener) | ImageCaptureView
addTorchLuminanceListener(TorchLuminanceListener listener) | ImageCaptureView
checkLicense() | ImageCaptureView | protected
DEFAULT_LUMINANCE_THRESHOLD | ImageCaptureView | static
DEFAULT_TORCH_DELAY | ImageCaptureView | static
forceTakePicture() ImageCaptureView
forceTakePicture(boolean focusAgain) | ImageCaptureView
getAllowableImageResolutions() ImageCaptureView
getDeviceDeclinationPitch() ImageCaptureView
getDeviceDeclinationRoll() ImageCaptureView
getFlash() ImageCaptureView
getFocusAreas() ImageCaptureView
getGpsUsage() ImageCaptureView
getImagePreviewHeight() ImageCaptureView
getImagePreviewWidth() ImageCaptureView
getLuminanceThreshold() ImageCaptureView
getMaxFocusAreas() ImageCaptureView
getTorchDelay() ImageCaptureView
getUseVideoFrame() ImageCaptureView
getViewGroup() ImageCaptureView
ImageCaptureView(Context context) | ImageCaptureView
ImageCaptureView(Context context, AttributeSet set) | ImageCaptureView
ImageCaptureView(Context context, AttributeSet set, int defStyle) | ImageCaptureView
isFlashSupported(Flash flash) | ImageCaptureView
muteAutoTorch() ImageCaptureView
onAttachedToWindow() | ImageCaptureView | protected
onDetachedFromWindow() | ImageCaptureView | protected
onLayout(boolean changed, int l, int t, int r, int b) | ImageCaptureView | protected
removeAllViews() ImageCaptureView
removeCameraInitializationFailedListener(CameraInitializationFailedListener listener) | ImageCaptureView
removeCameraInitializationListener(CameraInitializationListener listener) | ImageCaptureView
removeLevelnessListener(LevelnessListener listener) | ImageCaptureView
removeOnAutoFocusResultListener(AutoFocusResultListener listener) | ImageCaptureView
removeOnImageCapturedListener(ImageCapturedListener listener) | ImageCaptureView
removePreviewCallbackListener(PreviewCallbackListener listener) | ImageCaptureView
removeStabilityDelayListener(StabilityDelayListener listener) | ImageCaptureView
removeTorchLuminanceListener(TorchLuminanceListener listener) | ImageCaptureView
sessionCreate() ImageCaptureView
sessionDismiss() ImageCaptureView
setCameraType(CameraType cameraType) | ImageCaptureView
setDeviceDeclinationPitch(int angle) | ImageCaptureView
setDeviceDeclinationRoll(int angle) | ImageCaptureView
setFlash(Flash flash) | ImageCaptureView
setFocusAreas(List< Rect > focusAreas) | ImageCaptureView
setGpsUsage(GpsUsageLimits limits) | ImageCaptureView
setImageResolution(Size resolution) | ImageCaptureView
setLuminanceThreshold(int luminanceThreshold) | ImageCaptureView
setTorchDelay(int torchDelay) | ImageCaptureView
setUseVideoFrame(boolean useVideo) | ImageCaptureView
surfaceChanged(SurfaceHolder holder, int format, int width, int height) | ImageCaptureView
surfaceCreated(SurfaceHolder holder) | ImageCaptureView
surfaceDestroyed(SurfaceHolder holder) | ImageCaptureView


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • MicrLine
  • CheckType
MicrLine.CheckType Member List

This is the complete list of members for MicrLine.CheckType, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • Image
Image Member List

This is the complete list of members for Image, including all inherited members.

createScaledBitmap(float imgBitmapScaling) | Image |
DEFAULT_JPEG_QUALITY | Image | static
getBasicSettingsProfileUsed() | Image |
getImageBarCodes() | Image |
getImageBitmap() | Image |
getImageBitmapHeight() | Image |
getImageBitmapScaling() | Image |
getImageBitmapWidth() | Image |
getImageClassifyResults() | Image |
getImageCreateDateTime() | Image |
getImageDPI() | Image |
getImageFileBuffer() | Image |
getImageFileHeight() | Image |
getImageFilePath() | Image |
getImageFileRep() | Image |
getImageFileWidth() | Image |
getImageID() | Image |
getImageJpegQuality() | Image |
getImageLatitude() | Image |
getImageLongitude() | Image |
getImageMetaData() | Image |
getImageMimeType() | Image |
getImageOutputColor() | Image |
getImagePerfectProfileUsed() | Image |
getImagePitch() | Image |
getImageQuickAnalysisFeedBack() | Image |
getImageRepresentation() | Image |
getImageRoll() | Image |
getImageSize() | Image |
getImageSrcID() | Image |
getImageTag() | Image |
getMicrData() | Image |
getTargetFrame() | Image |
Image() | Image |
Image(Bitmap bitmap) | Image |
Image(File file, ImageMimeType imgMimeType) | Image |
Image(String imgFilePath, ImageMimeType imgMimeType) | Image |
imageClearBitmap() | Image |
imageClearFileBuffer() | Image |
imageDeleteFile() | Image |
imageReadFromFile() | Image |
imageReadFromFile(float imgBitmapScaling) | Image |
imageReadFromFileBuffer() | Image |
imageReadFromFileBuffer(float imgBitmapScaling) | Image |
imageWriteToFile() | Image |
imageWriteToFile(FileIOEngine engine) | Image |
imageWriteToFile(FileRestriction fileRestriction) | Image |
imageWriteToFileBuffer() | Image |
imageWriteToFileBuffer(FileIOEngine engine) | Image |
imageWriteToFileBuffer(FileRestriction fileRestriction) | Image |
MAX_JPEG_QUALITY | Image | static
MAX_SCALING_FACTOR | Image | static
MIN_DPI_VALUE | Image | static
MIN_JPEG_QUALITY | Image | static
MIN_SCALING_FACTOR | Image | static
setImageBarCodes(List< BarCodeResult > imageBarCodes) | Image |
setImageBitmap(Bitmap imgBitmap) | Image |
setImageClassifyResults(List< ImageClassificationResult > imgClassifyResults) | Image |
setImageCreateDateTime(String imgCreateDateTime) | Image |
setImageDPI(int imgDPI) | Image |
setImageFilePath(String imgFilePath) | Image |
setImageJpegQuality(int imgJpegQuality) | Image |
setImageMimeType(ImageMimeType imgMimeType) | Image |
setImageOutputColor(OutputColor imgOutputColor) | Image |
setImageTag(String imgTag) | Image |
setMicrData(String micrData) | Image |
setTargetFrame(Rect targetFrame) | Image |


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageProcessor
  • AnalysisCompleteListener
ImageProcessor.AnalysisCompleteListener Member List

This is the complete list of members for ImageProcessor.AnalysisCompleteListener, including all inherited members.

analysisComplete(AnalysisCompleteEvent event) ImageProcessor.AnalysisCompleteListener


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • model
  • SizeDouble
SizeDouble Member List

This is the complete list of members for SizeDouble, including all inherited members.

height SizeDouble
SizeDouble(double width, double height) SizeDouble


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • bill
  • BillWorkflowActivity
BillWorkflowActivity Member List

This is the complete list of members for BillWorkflowActivity, including all inherited members.

BILL_EXCEPTION | BillWorkflowActivity | static
BILL_PARAMETERS | BillWorkflowActivity | static
BILL_RESULTS | BillWorkflowActivity | static
captureImage() | WorkflowActivity< T extends IParameters > | protected
CERTIFICATE_VALIDATOR_LISTENER | WorkflowActivity< T extends IParameters > | static
clearBitmap(String imageId) | WorkflowActivity< T extends IParameters > | protected
getCaptureActivityClass() | BillWorkflowActivity |
getDefaultProcessingString(BillParameters parameters) | BillWorkflowActivity |
com::kofax::mobile::sdk::capture::WorkflowActivity.getDefaultProcessingString(T parameters) | WorkflowActivity< T extends IParameters > |
getDefaultReturnObject() | BillWorkflowActivity |
getExceptionKey() | BillWorkflowActivity |
getExtractActivityClass() | BillWorkflowActivity |
getParameters(Bundle savedInstanceState) | WorkflowActivity< T extends IParameters > |
getParametersInstance() | BillWorkflowActivity |
getParametersKey() | BillWorkflowActivity |
getResultKey() | BillWorkflowActivity |
handleException(final Throwable exc) | WorkflowActivity< T extends IParameters > | protected
isOdeSupported() | WorkflowActivity< T extends IParameters > | protected
onActivityResult(int requestCode, int resultCode, Intent data) | WorkflowActivity< T extends IParameters > | protected
onCreate(Bundle savedInstanceState) | BillWorkflowActivity | protected
onDestroy() | WorkflowActivity< T extends IParameters > | protected
onResume() | WorkflowActivity< T extends IParameters > | protected
onSaveInstanceState(Bundle outState) | WorkflowActivity< T extends IParameters > | protected
tryRestoreState(Bundle savedInstanceState) | WorkflowActivity< T extends IParameters > | protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • Licensing
  • VolumeLicenseResultData
Licensing.VolumeLicenseResultData Member List

This is the complete list of members for Licensing.VolumeLicenseResultData, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • data
  • Document
Document Member List

This is the complete list of members for Document, including all inherited members.

addPage(Page page) | Document
clone() | Document
Document(DocumentType documentType) | Document
Document(DocumentTypeR documentTypeR) | Document
Document(DocumentType documentType, String documentID) | Document
Document(DocumentTypeR documentTypeR, String documentID) | Document
getClassificationAlternatives() | Document
getDocumentId() | Document
getDocumentLevelError() | Document
getDocumentType() | Document
getFields() | Document
getPages() | Document
removePage(String pageId) | Document
setClassificationAlternatives(List< ClassificationResult > classificationAlternatives) | Document
setDocumentLevelError(String documentLevelError) | Document


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • processing
  • DeskewType
DeskewType Member List

This is the complete list of members for DeskewType, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • extraction
  • ExtractorResponse
ExtractorResponse< T extends Serializable > Member List

This is the complete list of members for ExtractorResponse< T extends Serializable >, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • LevelnessListener
LevelnessListener Member List

This is the complete list of members for LevelnessListener, including all inherited members.

onLevelness(LevelnessEvent event) LevelnessListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • PassportDetector
PassportDetector Member List

This is the complete list of members for PassportDetector, including all inherited members.

destroy() PassportDetector
detect(PassportDetectionSettings settings, Bitmap image) | PassportDetector
detect(PassportDetectionSettings settings, byte[] data, int width, int height) | PassportDetector
IDocumentDetector< PassportDetectionSettings, PassportDetectionResult >.detect(T settings, Bitmap image) | IDocumentDetector< PassportDetectionSettings, PassportDetectionResult >
IDocumentDetector< PassportDetectionSettings, PassportDetectionResult >.detect(T settings, byte[] data, int width, int height) | IDocumentDetector< PassportDetectionSettings, PassportDetectionResult >


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • CaptureExperience
CaptureExperience Member List

This is the complete list of members for CaptureExperience, including all inherited members.

_aspectRatio | CaptureExperience | protected
_captureExperienceData | CaptureExperience | protected
_continuousCapture | CaptureExperience | protected
_imageCapturedListeners | CaptureExperience | protected
_imageCaptureView | CaptureExperience | protected
_lock | CaptureExperience | protected
_sdkCaptureRequested | CaptureExperience | protected
_uiHandler | CaptureExperience | protected
_vibrationEnabled | CaptureExperience | protected
_vibrator | CaptureExperience | protected
addOnImageCapturedListener(ImageCapturedListener listener) | CaptureExperience
captureCriteriaMetInternal(CaptureExperienceData data) | CaptureExperience | protected
destroy() CaptureExperience
invokeImageCapturedListeners(ImageCapturedEvent event) | CaptureExperience | protected
isVibrationEnabled() CaptureExperience
onAutoFocus(AutoFocusResultEvent event) | CaptureExperience
onImageCaptured(ImageCapturedEvent event) | CaptureExperience
onLevelness(LevelnessEvent event) | CaptureExperience
onStabilityDelay(StabilityDelayEvent event) | CaptureExperience
removeOnImageCapturedListener(ImageCapturedListener listener) | CaptureExperience
setVibrationEnabled(boolean enable) | CaptureExperience


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • ImagePerfectionProfile
  • UseTargetFrameCrop
ImagePerfectionProfile.UseTargetFrameCrop Member List

This is the complete list of members for ImagePerfectionProfile.UseTargetFrameCrop, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • QuickAnalysisSettings
QuickAnalysisSettings Member List

This is the complete list of members for QuickAnalysisSettings, including all inherited members.

getBlurCountPercentThreshold() | QuickAnalysisSettings
getBlurDetection() | QuickAnalysisSettings
getBlurThreshold() | QuickAnalysisSettings
getGlareDetectedThreshold() | QuickAnalysisSettings
getGlareDetection() | QuickAnalysisSettings
getGlareDetectionIntensityFraction() | QuickAnalysisSettings
getGlareDetectionIntensityThreshold() | QuickAnalysisSettings
getGlareDetectionMinimumGlareAreaFraction() | QuickAnalysisSettings
getGlareDetectionNumberOfTiles() | QuickAnalysisSettings
getLowContrastBackgroundDetection() | QuickAnalysisSettings
getMissingBordersDetection() | QuickAnalysisSettings
getSaturationDetection() | QuickAnalysisSettings
getShadowDetection() | QuickAnalysisSettings
getSkewDetection() | QuickAnalysisSettings
getUseDocumentDetectionBasedCrop() | QuickAnalysisSettings
getUseMRZPassportDetection() | QuickAnalysisSettings
getUseTargetFrameCrop() | QuickAnalysisSettings
QuickAnalysisSettings() | QuickAnalysisSettings
setBlurCountPercentThreshold(int threshold) | QuickAnalysisSettings
setBlurDetection(boolean enabled) | QuickAnalysisSettings
setBlurThreshold(int threshold) | QuickAnalysisSettings
setGlareDetectedThreshold(double threshold) | QuickAnalysisSettings
setGlareDetection(boolean enabled) | QuickAnalysisSettings
setGlareDetectionIntensityFraction(double fraction) | QuickAnalysisSettings
setGlareDetectionIntensityThreshold(int threshold) | QuickAnalysisSettings
setGlareDetectionMinimumGlareAreaFraction(double fraction) | QuickAnalysisSettings
setGlareDetectionNumberOfTiles(int tiles) | QuickAnalysisSettings
setLowContrastBackgroundDetection(boolean enabled) | QuickAnalysisSettings
setMissingBordersDetection(boolean enabled) | QuickAnalysisSettings
setSaturationDetection(boolean enabled) | QuickAnalysisSettings
setShadowDetection(boolean enabled) | QuickAnalysisSettings
setSkewDetection(boolean enabled) | QuickAnalysisSettings
setUseDocumentDetectionBasedCrop(UseDocumentDetectionBasedCrop useDocumentDetectionBasedCrop) | QuickAnalysisSettings
setUseMRZPassportDetection(UseMRZPassportDetection useMRZPassportDetection) | QuickAnalysisSettings
setUseTargetFrameCrop(UseTargetFrameCrop useTargetFrameCrop) | QuickAnalysisSettings


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatistics
  • ExportStatusEvent
AppStatistics.ExportStatusEvent Member List

This is the complete list of members for AppStatistics.ExportStatusEvent, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • processing
  • IImageProcessorListener
IImageProcessorListener Member List

This is the complete list of members for IImageProcessorListener, including all inherited members.

onImageProcessed(Image image) IImageProcessorListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsDsExportHandler
AppStatsDsExportHandler Member List

This is the complete list of members for AppStatsDsExportHandler, including all inherited members.

configDsExpFilePath(String dsExpFilePath) | AppStatsDsExportHandler
onExportAppStatsRowEvent(String dsExportTblName, AppStatsDaoField[] daoFields) | AppStatsDsExportHandler


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • check
  • CheckParameters
CheckParameters Member List

This is the complete list of members for CheckParameters, including all inherited members.

CheckParameters(Context context) | CheckParameters
country | CheckParameters
getExtractionParameters() | CheckParameters
getLookAndFeelParameters() | CheckParameters
getProcessingParameters() | CheckParameters
reverseSideCheck | CheckParameters
side | CheckParameters


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • LicenseFoundListener
LicenseFoundListener Member List

This is the complete list of members for LicenseFoundListener, including all inherited members.

licenseFound(LicenseFoundEvent event) LicenseFoundListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsExportListener
  • ExportStatus
AppStatsExportListener.ExportStatus Member List

This is the complete list of members for AppStatsExportListener.ExportStatus, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • FixedAspectRatioDetectionSettings
FixedAspectRatioDetectionSettings Member List

This is the complete list of members for FixedAspectRatioDetectionSettings, including all inherited members.

FixedAspectRatioDetectionSettings() | FixedAspectRatioDetectionSettings
FixedAspectRatioDetectionSettings(FixedAspectRatioDetectionSettings settings) | FixedAspectRatioDetectionSettings
getCenterPoint() | FixedAspectRatioDetectionSettings
getTargetFrameAspectRatio() | FixedAspectRatioDetectionSettings
getTargetFramePaddingPercent() | FixedAspectRatioDetectionSettings
setCenterPoint(Point targetFrameCenter) | FixedAspectRatioDetectionSettings
setTargetFrameAspectRatio(double targetFrameAspectRatio) | FixedAspectRatioDetectionSettings
setTargetFramePaddingPercent(double paddingPercent) | FixedAspectRatioDetectionSettings


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • bundle
  • IBundleCacheProvider
IBundleCacheProvider Member List

This is the complete list of members for IBundleCacheProvider, including all inherited members.

cacheProject(String projectName, IBundle file, String version) | IBundleCacheProvider
cacheVariant(String projectName, String variant, IBundle file, String version) | IBundleCacheProvider
getLatestModelDataBuildInfo(String projectName) | IBundleCacheProvider
getLatestVersionForProject(String projectName) | IBundleCacheProvider
getProject(String projectName, String version) | IBundleCacheProvider
getVariant(String projectName, String variant, String version) | IBundleCacheProvider


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • server
  • ServerBuilder
ServerBuilder Member List

This is the complete list of members for ServerBuilder, including all inherited members.

build(Context context, ServerType type) ServerBuilder static


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • FixedAspectRatioCaptureExperience
FixedAspectRatioCaptureExperience Member List

This is the complete list of members for FixedAspectRatioCaptureExperience, including all inherited members.

_aspectRatio | CaptureExperience | protected
_captureExperienceData | CaptureExperience | protected
_continuousCapture | CaptureExperience | protected
_ctx | DocumentBaseCaptureExperience | protected
_imageCapturedListeners | CaptureExperience | protected
_imageCaptureView | CaptureExperience | protected
_lock | CaptureExperience | protected
_sdkCaptureRequested | CaptureExperience | protected
_uiHandler | CaptureExperience | protected
_vibrationEnabled | CaptureExperience | protected
_vibrator | CaptureExperience | protected
addOnImageCapturedListener(ImageCapturedListener listener) | DocumentBaseCaptureExperience
addPageDetectionListener(PageDetectionListener listener) | DocumentBaseCaptureExperience
captureCriteriaMetInternal(CaptureExperienceData data) | CaptureExperience | protected
destroy() DocumentBaseCaptureExperience
DocumentBaseCaptureExperience(ImageCaptureView view, DocumentBaseCaptureExperienceCriteriaHolder criteria) | DocumentBaseCaptureExperience
enableAnimationTutor(boolean enable) | DocumentBaseCaptureExperience
FixedAspectRatioCaptureExperience(ImageCaptureView view) | FixedAspectRatioCaptureExperience
FixedAspectRatioCaptureExperience(ImageCaptureView view, FixedAspectRatioExperienceCriteriaHolder criteria) | FixedAspectRatioCaptureExperience
getCaptureCriteria() FixedAspectRatioCaptureExperience
getCapturedMessage() FixedAspectRatioCaptureExperience
getCenterMessage() DocumentBaseCaptureExperience
getDocumentSampleImage() DocumentBaseCaptureExperience
getGuidanceFrameColor() DocumentBaseCaptureExperience
getHoldParallelMessage() FixedAspectRatioCaptureExperience
getHoldSteadyMessage() FixedAspectRatioCaptureExperience
getOuterViewFinderColor() DocumentBaseCaptureExperience
getRotateMessage() DocumentBaseCaptureExperience
getTutorialDismissMessage() DocumentBaseCaptureExperience
getUserInstructionMessage() DocumentBaseCaptureExperience
getZoomInMessage() DocumentBaseCaptureExperience
getZoomOutMessage() DocumentBaseCaptureExperience
initBase(ImageCaptureView view, IDetectionAdapter adapter, DocumentBaseCaptureExperienceCriteriaHolder criteria) | DocumentBaseCaptureExperience | protected
invokeImageCapturedListeners(ImageCapturedEvent event) | CaptureExperience | protected
isAnimationTutorEnable() DocumentBaseCaptureExperience
isDiagnosticsViewEnabled() DocumentBaseCaptureExperience
isVibrationEnabled() DocumentBaseCaptureExperience
onAutoFocus(AutoFocusResultEvent event) | CaptureExperience
onImageCaptured(ImageCapturedEvent event) | CaptureExperience
onLevelness(LevelnessEvent event) | CaptureExperience
onStabilityDelay(StabilityDelayEvent event) | CaptureExperience
removeOnImageCapturedListener(ImageCapturedListener listener) | DocumentBaseCaptureExperience
removePageDetectionListener(PageDetectionListener listener) | DocumentBaseCaptureExperience
setCaptureCriteria(FixedAspectRatioExperienceCriteriaHolder criteria) | FixedAspectRatioCaptureExperience
setCapturedMessage(CaptureMessage capturedMessage) | DocumentBaseCaptureExperience
setCenterMessage(CaptureMessage centerMessage) | FixedAspectRatioCaptureExperience
setDiagnosticsViewEnabled(boolean enabled) | DocumentBaseCaptureExperience
setDocumentSampleImage(Bitmap documentSampleImage) | DocumentBaseCaptureExperience
setGuidanceFrameColor(int colorCode) | DocumentBaseCaptureExperience
setHoldParallelMessage(CaptureMessage message) | DocumentBaseCaptureExperience
setHoldSteadyMessage(CaptureMessage holdSteadyMessage) | DocumentBaseCaptureExperience
setOuterViewFinderColor(int colorCode) | DocumentBaseCaptureExperience
setRotateMessage(CaptureMessage message) | FixedAspectRatioCaptureExperience
setSteadyGuidanceFrameColor(int colorCode) | DocumentBaseCaptureExperience
setTutorialDismissMessage(CaptureMessage tutorialDismissMessage) | DocumentBaseCaptureExperience
setUserInstructionMessage(CaptureMessage userInstructionsMessage) | DocumentBaseCaptureExperience
setVibrationEnabled(boolean enable) | DocumentBaseCaptureExperience
setZoomInMessage(CaptureMessage zoomInMessage) | FixedAspectRatioCaptureExperience
setZoomOutMessage(CaptureMessage zoomOutMessage) | FixedAspectRatioCaptureExperience


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • server
  • TimeOutParameters
TimeOutParameters Member List

This is the complete list of members for TimeOutParameters, including all inherited members.

getTimeOut() | TimeOutParameters
getUnit() | TimeOutParameters
TimeOutParameters(long duration, TimeUnit timeUnit) | TimeOutParameters


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • DetectionResult
DetectionResult Member List

This is the complete list of members for DetectionResult, including all inherited members.

getBounds() | DetectionResult
getHorizontalMovementGuidance() | DetectionResult
getOrientationGuidance() | DetectionResult
getOriginalImage() | DetectionResult
getTurnGuidance() | DetectionResult
getVerticalMovementGuidance() | DetectionResult
getZoomGuidance() | DetectionResult
toString() | DetectionResult


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • BarCodeReader
BarCodeReader Member List

This is the complete list of members for BarCodeReader, including all inherited members.

addBarcodeReadCompleteEventListener(BarcodeReadCompleteListener listener) | BarCodeReader
BarCodeReader() | BarCodeReader
BarCodeReader(Symbology[] symbology, Direction direction, int maxBarcode) | BarCodeReader
getBcVersion() | BarCodeReader
getMaxBarcodes() | BarCodeReader
getSearchDirections() | BarCodeReader
getSearchSymbology() | BarCodeReader
readBarcodes(Image image) | BarCodeReader
removeBarcodeReadCompleteEventListener(BarcodeReadCompleteListener listener) | BarCodeReader
setMaxBarcodes(int maxBarcodes) | BarCodeReader
setSearchDirections(Direction searchDirections) | BarCodeReader
setSearchSymbology(Symbology[] symbologies) | BarCodeReader


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • ImageSource
ImageSource Member List

This is the complete list of members for ImageSource, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • IIdExtractorListener
IIdExtractorListener Member List

This is the complete list of members for IIdExtractorListener, including all inherited members.

onExtractionComplete(T results) IExtractorListener< T extends ExtractorResponse >


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • CaptureMessage
  • KUIMessageOrientation
CaptureMessage.KUIMessageOrientation Member List

This is the complete list of members for CaptureMessage.KUIMessageOrientation, including all inherited members.

LANDSCAPE | CaptureMessage.KUIMessageOrientation
PORTRAIT | CaptureMessage.KUIMessageOrientation
REVERSELANDSCAPE | CaptureMessage.KUIMessageOrientation
REVERSEPORTRAIT | CaptureMessage.KUIMessageOrientation
UNKNOWN | CaptureMessage.KUIMessageOrientation


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • captureanimations
  • DocumentCaptureExperience
DocumentCaptureExperience Member List

This is the complete list of members for DocumentCaptureExperience, including all inherited members.

_aspectRatio | CaptureExperience | protected
_captureExperienceData | CaptureExperience | protected
_continuousCapture | CaptureExperience | protected
_ctx | DocumentBaseCaptureExperience | protected
_imageCapturedListeners | CaptureExperience | protected
_imageCaptureView | CaptureExperience | protected
_lock | CaptureExperience | protected
_sdkCaptureRequested | CaptureExperience | protected
_uiHandler | CaptureExperience | protected
_vibrationEnabled | CaptureExperience | protected
_vibrator | CaptureExperience | protected
addOnImageCapturedListener(ImageCapturedListener listener) | DocumentBaseCaptureExperience
addPageDetectionListener(PageDetectionListener listener) | DocumentBaseCaptureExperience
captureCriteriaMetInternal(CaptureExperienceData data) | CaptureExperience | protected
destroy() DocumentBaseCaptureExperience
DocumentBaseCaptureExperience(ImageCaptureView view, DocumentBaseCaptureExperienceCriteriaHolder criteria) | DocumentBaseCaptureExperience
DocumentCaptureExperience(ImageCaptureView view) | DocumentCaptureExperience
DocumentCaptureExperience(ImageCaptureView view, DocumentCaptureExperienceCriteriaHolder criteria) | DocumentCaptureExperience
enableAnimationTutor(boolean enable) | DocumentBaseCaptureExperience
getCaptureCriteria() DocumentCaptureExperience
getCapturedMessage() DocumentBaseCaptureExperience
getCenterMessage() DocumentBaseCaptureExperience
getDocumentSampleImage() DocumentBaseCaptureExperience
getGuidanceFrameColor() DocumentBaseCaptureExperience
getHoldParallelMessage() DocumentBaseCaptureExperience
getHoldSteadyMessage() DocumentBaseCaptureExperience
getOuterViewFinderColor() DocumentBaseCaptureExperience
getRotateMessage() DocumentBaseCaptureExperience
getTutorialDismissMessage() DocumentBaseCaptureExperience
getUserInstructionMessage() DocumentBaseCaptureExperience
getZoomInMessage() DocumentBaseCaptureExperience
getZoomOutMessage() DocumentBaseCaptureExperience
initBase(ImageCaptureView view, IDetectionAdapter adapter, DocumentBaseCaptureExperienceCriteriaHolder criteria) | DocumentBaseCaptureExperience | protected
invokeImageCapturedListeners(ImageCapturedEvent event) | CaptureExperience | protected
isAnimationTutorEnable() DocumentBaseCaptureExperience
isDiagnosticsViewEnabled() DocumentBaseCaptureExperience
isVibrationEnabled() DocumentBaseCaptureExperience
onAutoFocus(AutoFocusResultEvent event) | CaptureExperience
onImageCaptured(ImageCapturedEvent event) | CaptureExperience
onLevelness(LevelnessEvent event) | CaptureExperience
onStabilityDelay(StabilityDelayEvent event) | CaptureExperience
removeOnImageCapturedListener(ImageCapturedListener listener) | DocumentBaseCaptureExperience
removePageDetectionListener(PageDetectionListener listener) | DocumentBaseCaptureExperience
setCaptureCriteria(DocumentCaptureExperienceCriteriaHolder criteria) | DocumentCaptureExperience
setCapturedMessage(CaptureMessage capturedMessage) | DocumentBaseCaptureExperience
setCenterMessage(CaptureMessage centerMessage) | DocumentBaseCaptureExperience
setDiagnosticsViewEnabled(boolean enabled) | DocumentBaseCaptureExperience
setDocumentSampleImage(Bitmap documentSampleImage) | DocumentBaseCaptureExperience
setGuidanceFrameColor(int colorCode) | DocumentBaseCaptureExperience
setHoldParallelMessage(CaptureMessage message) | DocumentBaseCaptureExperience
setHoldSteadyMessage(CaptureMessage holdSteadyMessage) | DocumentBaseCaptureExperience
setOuterViewFinderColor(int colorCode) | DocumentBaseCaptureExperience
setRotateMessage(CaptureMessage message) | DocumentBaseCaptureExperience
setSteadyGuidanceFrameColor(int colorCode) | DocumentBaseCaptureExperience
setTutorialDismissMessage(CaptureMessage tutorialDismissMessage) | DocumentBaseCaptureExperience
setUserInstructionMessage(CaptureMessage userInstructionsMessage) | DocumentBaseCaptureExperience
setVibrationEnabled(boolean enable) | DocumentBaseCaptureExperience
setZoomInMessage(CaptureMessage zoomInMessage) | DocumentBaseCaptureExperience
setZoomOutMessage(CaptureMessage zoomOutMessage) | DocumentBaseCaptureExperience


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • CameraInitializationEvent
  • CameraInitStatus
CameraInitializationEvent.CameraInitStatus Member List

This is the complete list of members for CameraInitializationEvent.CameraInitStatus, including all inherited members.

CAMERA_IMAGE_RESOLUTION_CHANGED | CameraInitializationEvent.CameraInitStatus
CAMERA_STATUS_UNKNOWN | CameraInitializationEvent.CameraInitStatus
CAMERA_USE_VIDEO_FRAME_CHANGED | CameraInitializationEvent.CameraInitStatus
CAMERA_VIEW_CREATED | CameraInitializationEvent.CameraInitStatus


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • IdExtractionParameters
IdExtractionParameters Member List

This is the complete list of members for IdExtractionParameters, including all inherited members.

getBackBarcodes() | IdExtractionParameters |
getBackImage() | IdExtractionParameters |
getFrontBarcodes() | IdExtractionParameters |
getFrontImage() | IdExtractionParameters |
getIdType() | IdExtractionParameters |
getListener() | IdExtractionParameters |
getProjectName() | IdExtractionParameters |
getRegion() | IdExtractionParameters |
IdExtractionParameters(IdRegion region, IdType idType, Image frontImage, List< BarCodeResult > frontBarcodes, Image backImage, List< BarCodeResult > backBarcodes, boolean isProcessed, IIdExtractionListener listener) | IdExtractionParameters |
IdExtractionParameters(String projectName, IdType idType, Image frontImage, List< BarCodeResult > frontBarcodes, Image backImage, List< BarCodeResult > backBarcodes, boolean isProcessed, IIdExtractionListener listener) | IdExtractionParameters |
isProcessed() | IdExtractionParameters |
PREPROCESS_ID2_STRING | IdExtractionParameters | static
PREPROCESS_PASSPORT_STRING | IdExtractionParameters | static
PREPROCESS_STRING | IdExtractionParameters | static


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • BarCodeResult
BarCodeResult Member List

This is the complete list of members for BarCodeResult, including all inherited members.

BarCodeResult() | BarCodeResult
getBoundingBox() | BarCodeResult
getDataFormat() | BarCodeResult
getDirection() | BarCodeResult
getType() | BarCodeResult
getValue() | BarCodeResult
setBoundingBox(BoundingTetragon bound) | BarCodeResult
setDataFormat(BarCodeDataFormat format) | BarCodeResult
setDirection(BarCodeDirection direction) | BarCodeResult
setType(BarCodeType type) | BarCodeResult
setValue(String value) | BarCodeResult


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • model
  • Check
Check Member List

This is the complete list of members for Check, including all inherited members.

capturedImageId | CaptureData
getAmount() | Check
getAuxiliaryOnUs() | Check
getCar() | Check
getCheckIQAData() | Check
getCheckNumber() | Check
getCheckUsabilityData() | Check
getDate() | Check
getEpc() | Check
getLar() | Check
getMicr() | Check
getMicrAmount() | Check
getOnUs1() | Check
getOnUs2() | Check
getPayee() | Check
getRawData() | Check
getReasonForRejection() | Check
getRestrictiveEndorsement() | Check
getRestrictiveEndorsementPresent() | Check
getTransit() | Check
getUsable() | Check
processedImageId | CaptureData


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • bundle
  • BundleCacheProvider
BundleCacheProvider Member List

This is the complete list of members for BundleCacheProvider, including all inherited members.

BundleCacheProvider(Context context) | BundleCacheProvider |
BundleCacheProvider(File cache) | BundleCacheProvider |
cacheProject(String projectName, IBundle bundle, String version) | BundleCacheProvider |
cacheVariant(String projectName, String variantName, IBundle bundle, String version) | BundleCacheProvider |
clearCache() | BundleCacheProvider | protected
getLatestModelDataBuildInfo(String projectName) | BundleCacheProvider |
getLatestVersionForProject(final String projectName) | BundleCacheProvider |
com::kofax::mobile::sdk::extract::id::bundle::IBundleCacheProvider.getLatestVersionForProject(String projectName) | IBundleCacheProvider |
getProject(String projectName, String version) | BundleCacheProvider |
getVariant(String projectName, String variant, String version) | BundleCacheProvider |
ODE_CACHE | BundleCacheProvider | static


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • parameter
  • ExtractionParameters
  • ExtractionType
ExtractionParameters.ExtractionType Member List

This is the complete list of members for ExtractionParameters.ExtractionType, including all inherited members.

KTA | ExtractionParameters.ExtractionType
OFF | ExtractionParameters.ExtractionType
ON_DEVICE | ExtractionParameters.ExtractionType
RTTI | ExtractionParameters.ExtractionType


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • StabilityDelayEvent
StabilityDelayEvent Member List

This is the complete list of members for StabilityDelayEvent, including all inherited members.

getStability() | StabilityDelayEvent
StabilityDelayEvent(Object source, int stability) | StabilityDelayEvent


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • BarCodeDataFormat
BarCodeDataFormat Member List

This is the complete list of members for BarCodeDataFormat, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • TurnGuidance
TurnGuidance Member List

This is the complete list of members for TurnGuidance, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageProcessor
  • ProcessProgressEvent
ImageProcessor.ProcessProgressEvent Member List

This is the complete list of members for ImageProcessor.ProcessProgressEvent, including all inherited members.

getImageID() | ImageProcessor.ProcessProgressEvent
getProgressPct() | ImageProcessor.ProcessProgressEvent
getStatus() | ImageProcessor.ProcessProgressEvent
ProcessProgressEvent(Object sender, ErrorInfo status, String imageID, int progressPct) | ImageProcessor.ProcessProgressEvent


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • DocumentDetector
DocumentDetector Member List

This is the complete list of members for DocumentDetector, including all inherited members.

destroy() | DocumentDetector
detect(DocumentDetectionSettings settings, Bitmap image) | DocumentDetector
detect(DocumentDetectionSettings settings, byte[] data, int width, int height) | DocumentDetector
IDocumentDetector< DocumentDetectionSettings, DocumentDetectionResult >.detect(T settings, Bitmap image) | IDocumentDetector< DocumentDetectionSettings, DocumentDetectionResult >
IDocumentDetector< DocumentDetectionSettings, DocumentDetectionResult >.detect(T settings, byte[] data, int width, int height) | IDocumentDetector< DocumentDetectionSettings, DocumentDetectionResult >
DocumentDetector(Context context) | DocumentDetector


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • ImageClassificationResult
ImageClassificationResult Member List

This is the complete list of members for ImageClassificationResult, including all inherited members.

getClassId() | ImageClassificationResult
getConfidence() | ImageClassificationResult
getOrientation() | ImageClassificationResult
ImageClassificationResult() | ImageClassificationResult
ImageClassificationResult(String classId, float confidence, int orientation) | ImageClassificationResult


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • IdCaptureBackActivity
IdCaptureBackActivity Member List

This is the complete list of members for IdCaptureBackActivity, including all inherited members.

finish() | CaptureActivity |
getCameraView() | IdCaptureBackActivity | protected
IMAGE_CAPTURED | CaptureActivity | static
initController(IOverlayView view, IDetectionAdapter detectorAdapter) | CaptureActivity | protected
NO_IMAGE_CAPTURED | CaptureActivity | static
onActivityResult(int requestCode, int resultCode, Intent data) | CaptureActivity | protected
onCreate(Bundle savedInstanceState) | IdCaptureBackActivity | protected
onExitButtonClick() | CaptureActivity |
onForceCaptureButtonClick() | CaptureActivity |
onGalleryButtonClick() | CaptureActivity |
onPause() | CaptureActivity | protected
onResume() | CaptureActivity | protected
onSaveInstanceState(Bundle outState) | CaptureActivity | protected
onTorchChange(boolean checked) | CaptureActivity |
RESULT_CODE | CaptureActivity | static
saveResultAndFinish(Image image, Bundle bundle) | CaptureActivity | protected
setCaptureCriteria(CaptureCriteria criteria) | CaptureActivity | protected
setupButtonBarView(LinearLayout mainView) | IdCaptureBackActivity | protected
setupCameraView(ViewGroup container) | IdCaptureBackActivity | protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • processing
  • RotateType
RotateType Member List

This is the complete list of members for RotateType, including all inherited members.

ROTATE_180 RotateType
ROTATE_270 RotateType
ROTATE_90 RotateType
ROTATE_AUTO RotateType
ROTATE_NONE RotateType
RotateType(int type) RotateType


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • CheckDetectionSettings
CheckDetectionSettings Member List

This is the complete list of members for CheckDetectionSettings, including all inherited members.

CheckDetectionSettings() | CheckDetectionSettings |
CheckDetectionSettings(DetectionSettings settings) | CheckDetectionSettings |
CheckDetectionSettings(CheckDetectionSettings settings) | CheckDetectionSettings |
CheckDetectionSettings(Point targetFrameCenter, double targetFrameAspectRatio, double targetFramePaddingPercent) | CheckDetectionSettings |
DetectionSettings() | DetectionSettings | protected
DetectionSettings(DetectionSettings settings) | DetectionSettings | protected
DetectionSettings(Point targetFrameCenter, double targetFrameAspectRatio, double targetFramePaddingPercent) | DetectionSettings |
getAspectRatioFraction() | CheckDetectionSettings |
getCenterPoint() | DetectionSettings |
getMaxFillFraction() | DetectionSettings |
getMaxSkewAngle() | DetectionSettings |
getMinFillFraction() | DetectionSettings |
getSide() | CheckDetectionSettings |
getTargetFrameAspectRatio() | CheckDetectionSettings |
getTargetFramePaddingPercent() | DetectionSettings |
getToleranceFraction() | DetectionSettings |
setAspectRatioFraction(double aspectRatioFraction) | CheckDetectionSettings |
setCenterPoint(Point targetFrameCenter) | DetectionSettings |
setMaxFillFraction(double maxFillFraction) | DetectionSettings |
setMaxSkewAngle(double maxSkewAngle) | DetectionSettings |
setMinFillFraction(double minFillFraction) | DetectionSettings |
setSide(CheckSide side) | CheckDetectionSettings |
setTargetFrameAspectRatio(double targetFrameAspectRatio) | CheckDetectionSettings |
setTargetFramePaddingPercent(double paddingPercent) | DetectionSettings |
setToleranceFraction(double toleranceFraction) | DetectionSettings |


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • creditcard
  • CreditCardParameters
CreditCardParameters Member List

This is the complete list of members for CreditCardParameters, including all inherited members.

cardStyle | CreditCardParameters
CreditCardParameters(Context context) | CreditCardParameters
extraTimeForExpiry | CreditCardParameters
getExtractionParameters() | CreditCardParameters
getLookAndFeelParameters() | CreditCardParameters
getProcessingParameters() | CreditCardParameters


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • IdType
IdType Member List

This is the complete list of members for IdType, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • ICompletionListener
ICompletionListener< T > Member List

This is the complete list of members for ICompletionListener< T >, including all inherited members.

onComplete(T obj, Exception e) ICompletionListener< T >


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • id
  • IIdExtractionServer
IIdExtractionServer Member List

This is the complete list of members for IIdExtractionServer, including all inherited members.

setIdParameters(IdParameters parameters) IIdExtractionServer


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • BarCodeFoundEvent
BarCodeFoundEvent Member List

This is the complete list of members for BarCodeFoundEvent, including all inherited members.

BarCodeFoundEvent(Object sender, BarCodeResult barcode, Image image) BarCodeFoundEvent


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • bundle
  • IBundleFile
IBundleFile Member List

This is the complete list of members for IBundleFile, including all inherited members.

getAbsolutePath() IBundleFile
getFile() IBundleFile
getFile(File output) IBundleFile


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • SelfieDetectionSettings
SelfieDetectionSettings Member List

This is the complete list of members for SelfieDetectionSettings, including all inherited members.

getCenterPoint() | SelfieDetectionSettings
getFaceAngleTolerance() | SelfieDetectionSettings
getMinimumFaceSize() | SelfieDetectionSettings
getTargetFrameAspectRatio() | SelfieDetectionSettings
getTargetFramePaddingPercent() | SelfieDetectionSettings
SelfieDetectionSettings() | SelfieDetectionSettings
SelfieDetectionSettings(SelfieDetectionSettings settings) | SelfieDetectionSettings
setCenterPoint(Point targetFrameCenter) | SelfieDetectionSettings
setFaceAngleTolerance(double faceAngleTolerance) | SelfieDetectionSettings
setMinimumFaceSize(double minimumFaceSize) | SelfieDetectionSettings
setTargetFrameAspectRatio(double targetFrameAspectRatio) | SelfieDetectionSettings
setTargetFramePaddingPercent(double paddingPercent) | SelfieDetectionSettings


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • CheckSide
CheckSide Member List

This is the complete list of members for CheckSide, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • ProjectProviderException
ProjectProviderException Member List

This is the complete list of members for ProjectProviderException, including all inherited members.

ProjectProviderException(Exception e) | ProjectProviderException
ProjectProviderException(Throwable t) | ProjectProviderException
ProjectProviderException(String e) | ProjectProviderException


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • extract
  • id
  • IIdExtractionResult
IIdExtractionResult Member List

This is the complete list of members for IIdExtractionResult, including all inherited members.

classification() | IIdExtractionResult
classificationConfidence() | IIdExtractionResult
getDocumentVerificationConfidenceRating() | IIdExtractionResult
getFields() | IIdExtractionResult
isBarcodeRead() | IIdExtractionResult
isOcrRead() | IIdExtractionResult


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • Licensing
  • VolumeLicenseFailureData
Licensing.VolumeLicenseFailureData Member List

This is the complete list of members for Licensing.VolumeLicenseFailureData, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsWriteToFileResults
AppStatsWriteToFileResults Member List

This is the complete list of members for AppStatsWriteToFileResults, including all inherited members.

AppStatsWriteToFileResults(ErrorInfo errorState, WriteFileStatus newState) | AppStatsWriteToFileResults
getState() | AppStatsWriteToFileResults
isError() | AppStatsWriteToFileResults
setError(ErrorInfo result) | AppStatsWriteToFileResults
setState(WriteFileStatus status) | AppStatsWriteToFileResults


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • PassportDetectionResult
PassportDetectionResult Member List

This is the complete list of members for PassportDetectionResult, including all inherited members.

getBounds() DetectionResult
getHorizontalMovementGuidance() DetectionResult
getOrientationGuidance() DetectionResult
getOriginalImage() DetectionResult
getTurnGuidance() DetectionResult
getVerticalMovementGuidance() DetectionResult
getZoomGuidance() DetectionResult
PassportDetectionResult(Rect targetRect, List< Point > corners, Frame frame) PassportDetectionResult protected


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • processing
  • ImageProcessorConfiguration
ImageProcessorConfiguration Member List

This is the complete list of members for ImageProcessorConfiguration, including all inherited members.

clone() | ImageProcessorConfiguration
cropType | ImageProcessorConfiguration
deskewType | ImageProcessorConfiguration
documentDimensions | ImageProcessorConfiguration
ImageProcessorConfiguration() | ImageProcessorConfiguration
ImageProcessorConfiguration(String ipOperations) | ImageProcessorConfiguration
ippString | ImageProcessorConfiguration
outputColorDepth | ImageProcessorConfiguration
outputDPI | ImageProcessorConfiguration
rotateType | ImageProcessorConfiguration
targetFrameCropType | ImageProcessorConfiguration


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • CameraInitializationFailedListener
CameraInitializationFailedListener Member List

This is the complete list of members for CameraInitializationFailedListener, including all inherited members.

onCameraInitializationFailed(CameraInitializationFailedEvent event) CameraInitializationFailedListener


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • parameter
  • ExtractionCredentials
ExtractionCredentials Member List

This is the complete list of members for ExtractionCredentials, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatistics
  • AppStatsExportFormat
AppStatistics.AppStatsExportFormat Member List

This is the complete list of members for AppStatistics.AppStatsExportFormat, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • data
  • DocumentType
  • SourceServer
DocumentType.SourceServer Member List

This is the complete list of members for DocumentType.SourceServer, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • ken
  • engines
  • data
  • HorizontalGuidance
HorizontalGuidance Member List

This is the complete list of members for HorizontalGuidance, including all inherited members.


Kofax Mobile SDK API Reference: Member List

  • kmc
  • klo
  • logistics
  • data
  • DocumentTypeR
DocumentTypeR Member List

This is the complete list of members for DocumentTypeR, including all inherited members.

getBasicSettingsProfile() | DocumentTypeR
getDisplayName() | DocumentTypeR
getDocHeight() | DocumentTypeR
getDocWidth() | DocumentTypeR
getFieldTypes() | DocumentTypeR
getImagePerfectionProfile() | DocumentTypeR
getSourceServer() | DocumentTypeR
getTypeName() | DocumentTypeR
getVersion() | DocumentTypeR


Kofax Mobile SDK API Reference: Member List

  • mobile
  • sdk
  • capture
  • extraction
  • Extractor
Extractor< T extends Serializable > Member List

This is the complete list of members for Extractor< T extends Serializable >, including all inherited members.

createResponse(T results, ExceptionResponse exceptionResponse) | Extractor< T extends Serializable > | protected
extract(Image...images) | Extractor< T extends Serializable > |
Extractor() | Extractor< T extends Serializable > |
getDefaultServerUrl(ExtractionParameters.ExtractionType extractionType) | Extractor< T extends Serializable > | protected
onExtractionComplete(DataUnit unit) | Extractor< T extends Serializable > |
setCertificateValidatorListener(CertificateValidatorListener certificateValidatorListener) | Extractor< T extends Serializable > |
setExceptionResponseDeserializer(IExceptionResponseDeserializer exceptionResponseDeserializer) | Extractor< T extends Serializable > |
setExtractionServer(IExtractionServer extractionServer) | Extractor< T extends Serializable > |
setExtractorListener(IExtractorListener listener) | Extractor< T extends Serializable > |
setParameters(ExtractionParameters parameters) | Extractor< T extends Serializable > |
setResultDeserializer(IDeserializer< T > resultDeserializer) | Extractor< T extends Serializable > |


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kui
  • uicontrols
  • BarCodeFoundListener
BarCodeFoundListener Member List

This is the complete list of members for BarCodeFoundListener, including all inherited members.

barCodeFound(BarCodeFoundEvent event) BarCodeFoundListener


Kofax Mobile SDK API Reference: Member List

  • kmc
  • kut
  • utilities
  • appstats
  • AppStatsDaoField
AppStatsDaoField Member List

This is the complete list of members for AppStatsDaoField, including all inherited members.

getDbFieldKeyType() | AppStatsDaoField
getDbFieldType() | AppStatsDaoField
getDsFieldName() | AppStatsDaoField
getDsFieldType() | AppStatsDaoField
getDsValueDate() | AppStatsDaoField
getDsValueFloat() | AppStatsDaoField
getDsValueInt() | AppStatsDaoField
getDsValueLong() | AppStatsDaoField
getDsValueString() | AppStatsDaoField