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Introduction

This document covers the main installation scenarios for the Kofax Power PDF Advanced and Kofax 
Power PDF Reader products in a network environment. The Administrative setup topics contain 
necessary information for special deployment systems such as Active Directory, Microsoft Systems 
Management Server and System Center Configuration Manager.

The document describes all parameters and installer options that you may want to use during the 
installation setup.

The primary source of information about Kofax Power PDF system requirements and dependencies on 
other products is the Technical Specifications document, which is available on the Kofax Power PDF 
Product Documentation page. The document is updated regularly, and we recommend that you review it 
carefully to ensure success with your Kofax Power PDF product.

Product definitions
Most sections in this document are relevant for both Power PDF Advanced and Power PDF Reader. 
Features and options not supported in Power PDF Reader are always marked with a note. Both products 
may be installed on the same computer.

Power PDF Advanced
Kofax Power PDF Advanced combines the power of PDF creation, the flexibility of PDF editing, and 
the versatility of PDF conversion into one easy-to-use, affordable application. It provides all the critical 
business features you need without the cumbersome and costly print and pre-press functionality found in 
more expensive solutions.

Kofax Power PDF Advanced is designed to be deployed and used in a distributed environment. 
Furthermore, it provides additional features compared to the Standard version:
• Software activation turned off
• Electronic product registration turned off
• Automatic product updates turned off
• Silent installation
• Distributable PDF creation parameters
• Distributable PDF product settings
• Redaction tool to filter out sensitive PDF content
• Bates numbering tool for uniquely identifying each page in legal document sets
• Group Policy Object support
• Support for different Document Management Systems (See the release notes for details.)
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Power PDF Reader
Kofax Power PDF Reader serves as an advanced PDF tool for corporate users who do not require the 
powerful editing and conversion features of Power PDF Advanced.

Please note the following information:
• The default skin type is blue in Power PDF Advanced and dark gray in Power PDF Reader.
• Power PDF Reader is installed separately and does not require Active Directory client installation files. 

See the Installation media layout and Installation prerequisites chapters for details.
• Power PDF Reader and Power PDF Advanced .msi installation files have different names. See

Installation media layout for details.

Power PDF Reader does not support the following features:
• Upgrade Behavior feature
• Launch Create Assistant at startup (SSASSISTANSATSTARTUP command line parameter)
• Install PDF Convert component (SSCONVSTATE command line parameter)
• Printer Port Name (PDFPRINTERPORTNAME command line parameter)
• File Explorer (Windows Explorer) integration (WINDOWSEXPLORERALL command line parameter)
• Microsoft Word integration (WORDADDINALL command line parameter)
• Microsoft Excel integration (EXCELADDINALL command line parameter)
• Microsoft PowerPoint integration (PPTADDINALL command line parameter)
• Microsoft Outlook integration (OUTLOOKADDINALL command line parameter)
• Firefox integration (ISINSTALLFIREFOXADDIN command line parameter)
• All options under Office application integration
• Reader mode (ISREADONLYMODE command line parameter)
• Limited reader mode (ISLIMITEDREADONLYMODE command line parameter)
• Allow legacy mode image edit (ISTOUCHUPNEWSTYLE command line parameter)
• Advanced Edit mode (ISDISABLEWRITEMODE command line parameter)
• Auto Save (ISINSTALLAUTOSAVE command line parameter)
• Bates Numbering (ISINSTALLBATESSTAMP command line parameter)
• Create dynamic PDF Forms (ISINSTALLFORMTYPER command line parameter)
• Document Collaboration (ISDISCOLLABORATION command line parameter)
• Favorites (ISINSTALLFAVOURITES command line parameter)
• Flatten (ISFLATTENENABLE command line parameter)
• Indexing PDF files (ISINSTALLCATALOG command line parameter)
• Optimize PDF Documents (ISINSTALLOPTIMIZE command line parameter)
• Reading Order (ISREADINGORDER command line parameter)
• Redact PDF Documents (ISCONTAINREDACTION command line parameter)
• Remove Document Elements (ISINSTALLEXAMINEDOC command line parameter)
• Scan (NUSCAN command line parameter)
• Scan Inbox / Set properties (NUINBOXMONITOR command line parameter)
• Sequencer (ISBATCHPROCESSING command line parameter)
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• Split PDF documents (ISINSTALLPDFCHUNKER command line parameter)
• Stationery (NUSTATIONERY command line parameter)
• Tagging PDF documents (ISINSTALLRETAG command line parameter)
• Use Clip Art (ISINSTALLCLIPART command line parameter)
• Watched Folder (ISINSTALLWATCHEDFOLDER command line parameter)
• Enable Watermark (ISINSTALLWATERMARK command line parameter)
• Read watermarks from a shared location (WATERMARKCOMMONLOC command line parameter)
• Hide downloading User Interface (UI) languages (ISHIDEADDLANGUAGE command line parameter)
• Load security settings from server (ISSHOWLOADSECOPTION command line parameter)
• Modify PDF creation options (ISDRIVERMODIFIABLE command line parameter)
• Show JavaScript button in the Edit tab of the ribbon (OPT_JS_SHOWBUTTON command line 

parameter)

Installation media layout
Power PDF Advanced and Power PDF Reader have a separate installation media or download package 
containing all mandatory components for installation of the respective products.

Both the Power PDF Advanced and Power PDF Reader applications have 32-bit and 64-bit versions. 
Most product components are 32-bit binaries independent from the version of the target operating system. 
The installation media or download package contains both versions of the product in the System32 and 
System64 folders.

Power PDF Advanced .msi files:
• .\System32\Kofax Power PDF Advanced.msi

• .\System64\Kofax Power PDF Advanced.msi

Power PDF Reader .msi files:
• .\System32\Kofax Power PDF Reader.msi

• .\System64\Kofax Power PDF Reader.msi

All folders contain _setup.exe:
• .\System32\_setup.exe

• .\System64\_setup.exe

Important Always use the appropriate version of the .msi files or _setup.exe according to the operating 
system you are targeting.

The supported installation languages and the associated transform files are indicated in the following 
table. Only one language can be used at a time.

Transform file names by language

Language Transform file

Chinese (Traditional) 1028.mst
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Language Transform file

Chinese (Simplified) 2052.mst

Czech 1029.mst

Danish 1030.mst

Dutch 1043.mst

English 1033.mst

Finnish 1035.mst

French 1036.mst

German 1031.mst

Hungarian 1038.mst

Italian 1040.mst

Japanese 1041.mst

Korean 1042.mst

Norwegian 1044.mst

Polish 1045.mst

Portuguese (Brazil) 1046.mst

Russian 1049.mst

Spanish 1034.mst

Swedish 1053.mst

Turkish 1055.mst
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Installation prerequisites

The product requires the Microsoft .NET Framework 4.8 package to be installed on the client computers.

This installer is located in the Prerequisite folder in the installation media or download package.
• File name is ndp48-x86-x64-allos-enu.exe.
• Required on both 32-bit and 64-bit versions of Microsoft Windows.

Note If you perform the standard installation procedure via Setup.exe in the root folder of your 
installation media or download package, the Setup.exe installs the required software packages 
automatically before launching the product installer. A reboot may be required after installation of the 
components.

Active Directory Rights Management Service
To work with RMS protected documents, Active Directory Rights Management Service Client 2.1 must 
be installed. This client can be downloaded from Microsoft at http://www.microsoft.com/en-us/download/
details.aspx?id=38396.

Client installers (both for 32-bit and 64-bit environments) are also available from the Power PDF 
Advanced installation media or download package:
• .\Tools\AD_RMS\setup_msipc_x86.exe

• .\Tools\AD_RMS\setup_msipc_x64.exe

Note The Power PDF Reader installation media or download package does not contain these files and 
was not tested with RMS in a Microsoft App-V environment.
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Installation in distributed environments

In a distributed environment, administrators can use a two-step procedure for software deployment:

1. Customization
The Kofax Customization Kit is available from the Tools folder in your installation media or download 
package (.\Tools\CustomKit\CustomizationKit.exe). The kit presets certain installation 
options to configure client installation.

2. Client installation
Installs the product on the client workstation according to the options configured with the 
Customization Kit.

The following sections describe how administrators can customize and deploy the product. Please note 
that the manual client installation can be replaced with mass deployment.

Customization Kit
The Customization Kit for Power PDF Advanced and Power PDF Reader gives administrators the ability 
to customize the installation of Kofax Power PDF Advanced products prior to deploying the applications 
across an organization.

System requirements: The Customization Kit requires that at least Microsoft Windows Installer (MSI) 3.1 
and Windows .NET Framework 4 are installed on the client computer.

Note You must use a Kofax Customization Kit version that is identical to the product version.

Customization Kit overview
The Kofax Customization Kit helps to create a personalized package of Kofax Power PDF Advanced for 
organization-wide deployment.

Use this tool to define where to install Power PDF Advanced, predefine the serial number and make 
it read-only, set feature installation states, set visibility of features on the Custom Setup dialog box, 
configure default application settings, deploy custom files and import predefined application settings.

When you finish the necessary modifications and publish a package with the Customization Kit, the tool 
stores the modified settings in the following way:
• Personalization, General, Application Integration, Connectors, Document Processing, Languages, 

Application Options, and Upgrade Behavior settings are stored in the admin_customSettings.mst 
transform file. This transform file is located beside the .msi package file.

• Additional Files and Import Application Settings are stored beside the .msi package file.
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Basic customization workflow
1. Launch the Customization Kit.

2. Click Open Package in the Package group and select the supplied .msi file.
3. Specify parameters for your own package in the different panels.
4. Optionally, add extra files or import application settings.
5. Click Publish Package in the Package group to finalize the customized installer for your own 

deployment.
6. Distribute the customized application to end users by doing any of the following:

a. Use command line for installation as described in Client installation using command line.

Important A command line installation must contain all the transform files necessary for your 
deployment, including the admin_customSettings.mst file generated by the Customization Kit 
in step 5.

b. Locate the folder where you saved your customized installer in step 5 and start Setup.exe.

c. Select Open Package in the Package group, then browse to the customized .msi file such as 
Kofax PDF Advanced.msi, and open it.

Note At this stage you are free to select either a 32-bit or a 64-bit package.
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Customize the installer
The first group of options includes Personalization, General, Application Integration, Connectors,
Document Processing, Languages, Application Options, and Upgrade Behavior.

Customizations from this group are saved into a transform (.mst) file.

If you want this .mst file, click Generate Transform in the Transform group and name your file.

If you want this .mst file with the predefined name (admin_customSettings.mst) and the entire installer 
fileset, click the Publish Package button in the Package group.

1. Click Personalization.
2. This panel lets you specify basic customer information, such as User Name.
3. Optionally mark the Suppress display of the Serial Number check box to hide this screen from your 

installation flow.
4. Set the destination folder by accepting the default installation value or clicking Browse to select a 

different location.

Note Installation requires an empty destination folder.

You can restrict end users from modifying any of the preceding options. Select all/none, or select 
individual options to restrict access.

General options
Use the general options to set basic preferences.

You can restrict end users from modifying any of the following options. Select all/none or select individual 
options to restrict access.

1. Click General.
2. Select the applicable check boxes to suit your preferences.

Use this panel to specify general settings for working with PDF files or Power PDF components, such 
as Power PDF Advanced, Convert Assistant, and Create Assistant.

Note These features are not supported in Power PDF Reader:
• Launch Create Assistant at startup
• Install PDF Convert component

3. Specify the setup type suited to your needs.
Select the first option to display only the Install Welcome, License Agreement, and Ready to 
Install dialog boxes or use the radio buttons below to select Typical or Custom installation.

4. Select a help installation type by clicking on one of the options:
• Click the Online from Kofax option to access the Help from the Kofax server (internet access 

required on the workstation).
• Click the On premises option and set the correct shared location if you have already downloaded 

and copied the Help files to a shared location on your server. See How to install help for details.
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5. Modify the printer port name.

Note The Printer Port Name option is not supported in Power PDF Reader.

Application Integration
You can hide any of the following options from end users. Select all/none or select individual options to 
hide.

1. Click Application Integration.
2. Select the desired integrations in programs and browsers.

Access in browsers depends on the selected application.

Note The following options are not supported in Power PDF Reader:
• Windows Explorer Integration
• All options under Office application integration
• Firefox Integration

Windows Desktop Search Integration offers multiple choices. Indexing image-only PDF files is a 
performance-sensitive choice.

Connectors
Use the Connectors group to include cloud and DMS integration in your customized installation package.

1. Click Connectors.
The list of available connectors is displayed.

2. Mark Enable Connectors so that you can make your selections in the list.
3. Enable or disable each Connector by selecting the check boxes individually.
4. For each preceding integration, you can specify whether to enable end users to see them. Select all/

none or individually select integrations to hide from users.

Document Processing
Use the Document Processing parameters to filter the feature set for the Power PDF application.

1. Click Document Processing.
2. Select Reader mode to create a package with a predefined set of functions.

Note The options under Application Mode are not supported in Power PDF Reader.

3. When Reader mode is off, you can select features individually.
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4. You can hide any of the preceding application features from end users.
Select all/none or select individual features to hide from the end user. The Reader mode and 
Advanced Edit mode options are general parameters; therefore, their visibility is basically the set of 
options offered by your installer.

Note The following options are not supported in Power PDF Reader:
• Auto Save
• Bates Numbering
• Create dynamic PDF Forms
• Document Collaboration
• Favorites
• Flatten
• Indexing PDF files
• Optimize PDF Documents
• Reading Order
• Redact PDF Documents
• Remove Document Elements
• Scan
• Sequencer
• Split PDF documents
• Stationery
• Tagging PDF documents
• Use Clip Art
• Watched Folder
• Allow legacy mode image edit
• Enable watermark
• Read watermarks from a shared location

When Reader Mode is selected through the Customization Kit or the ISREADONLYMODE parameter 
is set using command line installation, then the Power PDF Advanced application is installed in 
Reader Mode for any user. However, in Citrix and Terminal Services servers, it is possible to use 
Power PDF in mixed mode. See Use Power PDF Advanced in mixed-mode (Reader mode and 
normal mode).

Languages
Use the Languages group to set preferences for UI languages.

Click Languages to set the parameters of UI languages.
You can deploy more than one UI language at the same time and select one as the active UI language. 
Later, in the Option panel of the application, you can select another UI language.
• The Default language option specifies the actual UI of the running application. Possible values:

• Operation system language: The application automatically selects the UI language based on the 
operating system language. If the OS language was not deployed, the UI language is English.
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• Installation language: The installer sets the UI language based on the installation language 
selected by the user. If the installation language was not deployed, the UI language is English.

• Selecting the UI languages:
• Installation language only: Only the installation language resources are deployed beside English, 

which is always deployed, regardless of UI language settings.
• All available languages: All available languages are deployed.
• Selected languages: Select any available languages.

Application Options
Use the Application Options panel to select which options are displayed to the end user:

1. Click Application Options.
2. Allow end users to change some options in the applications.

Note The default skin type is blue in Power PDF Advanced and dark gray in Power PDF Reader.

3. Set other application options.

Note The following options are not supported in Power PDF Reader:
• Hide downloading UI languages
• Load security settings from server
• Modify PDF creation options
• Show JavaScript button in the Edit tab of the ribbon

4. Use the options to enable or disable the following:
• Requiring a reason for each signature, along with facilities to edit the text
• Displaying fields for location and contact information
• Allowing signatures to be revoked and shown as such
• Requiring time stamp verification of signatures

Upgrade Behavior
Use the Upgrade Behavior panel to define the application behavior in an upgrade scenario.

Note The Upgrade Behavior feature is not supported in Power PDF Reader.

1. Click Upgrade Behavior.
2. Under Legacy products, set the behavior for a legacy product, such as PDF Converter Enterprise or 

PDF Converter Professional, currently installed on the system.
3. Under Previous Power PDF version, set the behavior for an earlier version currently installed on 

the system.
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Optional: Finalize the transform file
Now that all desired parameters are set, you can optionally create a transform file (.mst) for your installer. 
To create the transform file:

1. Click Generate Transform in the Transform group.
Use this option to create a transform file (.mst) based on the differences between the open package 
and the modifications set by you.

2. Select a save location.
3. Specify a file name.
4. Save your transform file.
5. To resume work on an already existing transform file, click Load Transform.

Add more components to the package
Finalizing the transform file (above) is optional. You can also include other files such as plug-ins in your 
custom installation package.

1. Click Additional Files.
2. You can add/modify/remove and reorder files for your package.

Include existing application settings
To enhance propagating a shared collection of settings across your company, you can poll an already 
installed and configured Power PDF for settings and include these in your deployment package.

Available choices are determined by your Import mode selections.
• Use default product settings: Use the default factory settings provided by a clean Power PDF 

installation.
• Use settings from the locally installed product: Use the settings of the Power PDF installation on the 

computer where Customization Kit runs.
• Browse for shared product settings: First collect settings on another computer where Power PDF 

installed, then import those settings into the deployment package. See Import application settings from 
another computer for details.

Make your selections under Settings to import. The selected options are stored in the installation package.

Important If the Security Profile check box is marked under Import Application Settings, the application's 
default Privacy and No Modification Security schemes in the Security panel are not transferred to the 
customized installation. If these two schemes are required, create two new custom schemes that are 
equivalent to them.

Import application settings from another computer
1. Start Customization Kit on the computer where your product installation is polled.
2. In the Wizard group, select Collect Application Settings Wizard.

16



Kofax Power PDF Network Installation Guide

3. Make your selections in the wizard.
The wizard only offers to collect the settings that are different from the package you opened.

4. Browse to the folder to store the collected settings.
5. Review your settings, then launch the collection process.

After a successful settings collection, you are ready to Import Application Settings.
6. Start Customization Kit on the computer where the deployment package should build.
7. To include your collected settings, select the Browse for shared product settings option under

Import mode, then locate the folder where you stored the collected settings in step 4.

Finish the installation package
When the desired parameters are prepared, you are ready to publish the package for your end users.

1. Click Publish Package in the Package group.
2. Set a target location.

It is recommended to have an empty folder for your published package (the tool warns you of this).
3. Select which versions you want to publish, 32-bit and/or 64-bit, and click OK.

Note To restart constructing your package, click Reset Settings to default on the Package group.

To access this installation guide, click Help in the Help group. To view product version information, 
click About.

Client installation using command line
Kofax Power PDF Advanced supports special deployment systems such as Active Directory, Microsoft 
System Management Server and System Center Configuration Manager.

The client installation procedure always requires administrative privileges and must run with a per-
computer installation context (ALLUSERS=1).

Note The suppression of the required reboot does not eliminate the need for a reboot. A required reboot 
must still be performed before installing any hotfixes or using the product.

The following sections provide examples of client installation scenarios, using the following placeholders:
• {install_path}: Replace this placeholder with the installation folder path. If you omit the INSTALLDIR 

parameter, the product is installed into the default installation folder. (Installation requires an empty 
destination folder.)

• {source_path}: Replace this placeholder with the source folder containing the customized .msi package 
file.

In the following examples, the selected installation language is French (1036.mst). See Table 1: Transform 
file names by language for details.

If you do not specify a language transform file:
• _setup.exe prompts for language selection.
• msiexec.exe installs the product in its default language (English).
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Install Power PDF Advanced using command line
1. On the client computer, use Run as administrator to open a Command Prompt window.
2. Run the following command:

MsiExec.exe /i "c:\{source_path}\Kofax Power PDF Advanced.msi"  
INSTALLDIR="c:\{install_path}"
TRANSFORMS="c:\{source_path}\1036.mst;c:\{source_path}\admin_customSettings.mst"

3. If you saved a .mst file with Generate Transform in the Transform tab, then use one of the following 
commands:
• MsiExec.exe /i "c:\{source_path}\Kofax Power PDF Advanced.msi"  

INSTALLDIR="c:\{install_path}"  
TRANSFORMS="c:\{source_path}\1036.mst;c:\{source_path}\your_saved_transform.mst"

• _setup.exe /l1036 /v"INSTALLDIR=\"c:\\{install_path}\"
TRANSFORMS=\"c:\\{source_path}\\your_saved_transform.mst\""

Note Both setup.exe and _setup.exe elevate the installation process. Use setup.exe to trigger the 
installation of prerequisites. If you use Msiexec.exe, ensure that you run Command Prompt as 
administrator.

Install Power PDF Reader using command line
1. On the client computer, use Run as administrator to open a Command Prompt window.
2. Run the following command:

MsiExec.exe /i "c:\{source_path}\Kofax Power PDF Reader.msi"  
INSTALLDIR="c:\{install_path}"
TRANSFORMS="c:\{source_path}\1036.mst;c:\{source_path}\admin_customSettings.mst"

3. If you saved a .mst file with Generate Transform in the Transform tab, then use one of the following 
commands:
• MsiExec.exe /i "c:\{source_path}\Kofax Power PDF Reader.msi"  

INSTALLDIR="c:\{install_path}"
TRANSFORMS="c:\{source_path}\1036.mst;c:\{source_path}\your_saved_transform.mst"

• _setup.exe /l1036 /v"INSTALLDIR=\"c:\\{install_path}\"
TRANSFORMS=\"c:\\{source_path}\\your_saved_transform.mst\""

Note Both setup.exe and _setup.exe elevate the installation process. Use setup.exe to trigger the 
installation of prerequisites. If you use Msiexec.exe, ensure that you run Command Prompt as 
administrator.

Client installation command line examples
The following example shows how to install Power PDF Advanced with different options. To install the 
product with a basic UI and without message box on completion, use the applicable command line:
• MsiExec.exe /i "c:\{source_path}\Kofax Power PDF Advanced.msi"  

INSTALLDIR="c:\{install_path}" /qb

• _setup.exe /s /v"INSTALLDIR=\"c:\\{install_path}\" /qb"

Where q defines what type of UI the installation uses:
• /qn specifies that the UI is not displayed.
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• /qb specifies a basic interface with a progress bar.

Furthermore, (if used) a plus sign (/qb+ or /qn+) specifies that a message box is displayed when the 
installation is finished.

To install Power PDF Reader with the same options as above, use one of the following commands:
• MsiExec.exe /i "c:\{source_path}\Kofax Power PDF Reader.msi"  

INSTALLDIR="c:\{install_path}" /qb

• _setup.exe /s /v"INSTALLDIR=\"c:\\{install_path}\" /qb"

During the installation of the application, specific installation options are available. Several InstallShield 
Wizard pages walk you through the available features. These installer features cover the different 
integration settings (into Microsoft Office, Windows, and Internet Explorer) and the optional components of 
the product. These features are controllable via Customization Kit and/or command line switches.

Note You are also allowed to use standard MSI parameters to specify commonly used installation 
parameters like USERNAME, COMPANYNAME, INSTALLDIR, and ISX_SERIALNUM.

Command line switches and features
The features and command line switches are grouped and detailed in the following topics.

Personalization switches and options

Set the user's name
The USERNAME property refers to the user performing the installation.

USERNAME="{your user name}"

Example:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"  
USERNAME="john.doe"

Note
• If the USERNAME property is not set, the installer sets it automatically using values from the 

registry. Set the NOUSERNAME property (NOUSERNAME="1") to prevent the automatic setting of 
USERNAME.

• For Power PDF Reader, use "Kofax Power PDF Reader.msi" as the installer file name in command 
line parameters.

Set the company name
The COMPANYNAME property refers to the organization or company of the user performing the 
installation.

COMPANYNAME="{your company name}"
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Note If the COMPANYNAME property is not set, the installer sets it automatically using values from the 
registry. Set the NOCOMPANYNAME property (NOCOMPANYNAME="1") to suppress the automatic 
setting of COMPANYNAME.

Set the serial number
ISX_SERIALNUM="{your serial number}"

Hide or show the serial number in the Installer Wizard dialog box
Hide: EDITSN="0"

Show: EDITSN="1"

Example to hide the serial number:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi" EDITSN="0"

Note The serial number is visible by default. For Power PDF Reader, use "Kofax Power PDF 
Reader.msi" as the installer file name in command line parameters.

Hide or show the serial number in the About dialog box of the application
Hide: HIDEABOUTSN="1"

Show: HIDEABOUTSN=""

Note The serial number is visible by default.

General switches

Set application as your default viewer for PDF files
On: SETDEFVIEWER="1"

Example to turn on this setting:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi" SETDEFVIEWER="1"

Off: SETDEFVIEWER=""

Example to turn off this setting:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi" SETDEFVIEWER=""

Note The feature is enabled by default. For Power PDF Reader, use Kofax Power PDF Reader.msi as 
the installer file name in command line parameters.
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View PDF files in Internet Explorer with Power PDF Advanced
On: ISDEFVIEWERIE="1"

Off: ISDEFVIEWERIE=""

Note The feature is enabled by default.

Launch PDF Create assistant at startup
On: SSASSISTANSATSTARTUP="1"

Off: SSASSISTANSATSTARTUP=""

Note The feature is disabled by default and not supported in Power PDF Reader.

Install PDF Converter component
On: SSCONVSTATE="1"

Off: SSCONVSTATE=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Create shortcut for Power PDF Advanced to Desktop
On: SSDESKTOPSHORTCUT="1"

Off: SSDESKTOPSHORTCUT=""

Note The feature is disabled by default.

Delete the user settings when the product is uninstalling
On: DELUSERSETTINGS="1"

Off: DELUSERSETTINGS=""

Note The feature is disabled by default.

Collect usage data
On: ANALYTICSI="1"

Off: ANALYTICSI="0"

Show or hide the Delete user settings dialog box when the product is 
uninstalling
On: HIDEKEEPSETTINGMSG ="1"
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Off: HIDEKEEPSETTINGMSG =""

Note The feature is disabled by default.

Show only Install Welcome, License Agreement, and Ready To Install 
dialog boxes on Setup Wizard
On: MINIMALUI="1"

Off: MINIMALUI=""

Note The feature is disabled by default.

How to install help
The online help is available on the Kofax server by default. This is indicated by the following entry:

HELP_MODE="1"

The online help can also be provided by a local server alternatively. Perform the following steps to 
customize the help server location:

1. Set the HELP_MODE entry to 2, indicating that custom help location must be used:
HELP_MODE="2"

Important If HELP_MODE is 2, entering a correct value for HELP_PATH_SHARED property is 
mandatory.

2. Set the HELP_PATH_SHARED entry to refer to the correct Help root path on your server. Substitute 
the items enclosed in curly brackets with your server parameters:
HELP_PATH_SHARED=\\{computername}\{sharedfolder}\

Important This path should lead to the root folder of the help structure, and not to any of the 
language subfolders.

3. The root folder (HELP_PATH_SHARED) should have subfolders for each language. For example:
• \\{computername}\{sharedfolder}\en_US

• \\{computername}\{sharedfolder}\ja_JA

The offline documentation package does not include these subfolders. Create all required language 
subfolders using the folder names in the following table:

Language Folder Name

Czech cs_CZ

Danish da_DK

German de_DE

English (US) en_US
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Language Folder Name

Spanish es_ES

Finnish fi_FI

French fr_FR

Hungarian hu_HU

Italian it_IT

Japanese ja_JA

Korean ko_KR

Dutch nl_NL

Norwegian (Bokmål) no_NO

Polish pl_PL

Portuguese (Brazilian) pt_BR

Russian ru_RU

Swedish sv_SE

Turkish tr_TR

Chinese (Simplified) zh_CHS

Chinese (Traditional) zh_CHT

4. Extract the offline documentation package ("KofaxPowerPDFDocumentation_4.1.0.zip") into a local 
folder. This creates a .zip file for each language.

Note You can download the package from the Kofax Fulfillment Site.

5. Identify the preferred language package file by the language code in the file name and extract it. This 
creates a folder with the same name.

6. In the extracted folder, open the "help" subfolder.

7. Copy the "PowerPDF_help" subfolder into the relevant language subfolder you created in step 3.

8. Repeat the above steps for all the required languages.

Printer port name
PDFPRINTERPORTNAME="{your port name}"

Note This feature is not supported in Power PDF Reader.

Application integration switches

Windows Explorer integration
On: WINDOWSEXPLORERALL="1"
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Off: WINDOWSEXPLORERALL=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Microsoft Word integration
On: WORDADDINALL="1"

Example:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"  
WORDADDINALL="1"

Off: WORDADDINALL=""

Example:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"  
WORDADDINALL=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Microsoft Excel integration
On: EXCELADDINALL="1"

Off: EXCELADDINALL=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Microsoft PowerPoint integration
On: PPTADDINALL="1"

Off: PPTADDINALL=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Microsoft Outlook integration
On: OUTLOOKADDINALL="1"

Off: OUTLOOKADDINALL=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Firefox integration
On: ISINSTALLFIREFOXADDIN="1"

Off: ISINSTALLFIREFOXADDIN=""
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Note The feature is enabled by default and not supported in Power PDF Reader.

Internet Explorer integration
On: IEINTEGRATIONALL="1"

Off: IEINTEGRATIONALL="0"

Note The feature is enabled by default.

Windows Desktop Search integration
Use the 'SSWDSSUPPORT ' switch to turn on/off Kofax PDF iFilter that enables the Windows Desktop 
Search (WDS) integration.

On: SSWDSSUPPORT="1"

Off: SSWDSSUPPORT=""

If WDS integration is turned on, the Kofax Power PDF built-in OCR (Optical Character Recognition) 
engine is used to find text on pages that contain only images. Using OCR makes indexing slower.

On: WDS_OCRNOTEXT="1"

Off: WDS_OCRNOTEXT="1"

If the OCR is enabled, the e-Discovery functionality is used to discover additional text on image objects 
using OCR on pages that already contain text. Using e-Discovery makes indexing slower.

On: WDS_OCRNOTEXT_EDISC="1"

Off: WDS_OCRNOTEXT_EDISC="0"

If the OCR is enabled, you can define the first n pages which the OCR recognizes. To define this option, 
set the WDS_OCRNOTEXT_ISPAGES to "1", and set the WDS_OCRNOTEXT_NUMPAGES="number of 
pages".

For example:

WDS_OCRNOTEXT="1"

WDS_OCRNOTEXT_ISPAGES="1"

WDS_OCRNOTEXT_NUMPAGES="10"

The application runs OCR on the first 10 pages.

Note Windows Desktop Search Integration features are disabled by default.

Connector switches
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Enable/Disable all connectors
On: ISINSTALLCONNECTORS="1"

Off: ISINSTALLCONNECTORS=""

Box
On: NUCONN_BOX="1"

Off: NUCONN_BOX=""

Dropbox
On: NUCONN_DROPBOX="1"

Off: NUCONN_DROPBOX=""

DocuShare
On: NUCONN_DOCUSHARE="1"

Off: NUCONN_DOCUSHARE=""

EMCDocumentum
On: NUCONN_EMCDOCUMENT="1"

Off: NUCONN_EMCDOCUMENT=""

Enterprise Connect
On: NUCONN_EC="1"

Off: NUCONN_EC=""

Note In Enterprise Connect Framework version 16.2 and earlier, it is possible to enable opening and 
saving files from Enterprise Connect (EC) in Power PDF through the File > Open and File > Save As
dialog boxes directly, without the use of the EC connector. To enable direct open and save, append your 
PDF application executable file name to Enterprise Connect's registry value, separated by a comma.

In case of Power PDF Advanced, edit the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Open Text\Enterprise Connect\

ExtendedIntegrationSupportedApplications=[ExistingValue,]PowerPDF.exe

In case of Power PDF Reader, edit the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Open Text\Enterprise Connect\
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ExtendedIntegrationSupportedApplications=[ExistingValue,]PowerPDFRd.exe

Important
• With EC Framework 16.2 version and later, this registry value change is not needed.
• Saving documents opened directly through the File > Open dialog boxes to the EC connector is 

handled as a new document upload, not as a new version save. This is intentional, to avoid issues 
with the synchronization process of EC.

Evernote
On: NUCONN_EVERNOTE="1"

Off: NUCONN_EVERNOTE=""

eDOCS
On: NUCONN_EDOCS="1"

Off: NUCONN_EDOCS=""

Important If eDOCS is disabled, two other properties are also turned off to ensure correct application 
behavior. These properties are NUCONN_EDOCS_ADDINX and ISENABLEHBADDINOPTIONX.

eDOCS addin-in registration
On: NUCONN_EDOCS_ADDINX="1"

Off: NUCONN_EDOCS_ADDINX=""

Google Drive
On: NUCONN_GD="1"

Off: NUCONN_GD=""

HP Trim
On: NUCONN_HPTRIM="1"

Off: NUCONN_HPTRIM=""

iManage10
On: NUCONN_IMANAGE10="1"

Off: NUCONN_IMANAGE10=""

Tip For details, see iManage connector and server configuration.
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iManage Work
On: NUCONN_IMANAGE="1"

Off: NUCONN_IMANAGE=""

Important If iManage Work is turned off, two other properties are also turned off to ensure 
correct application behavior. These properties are NUCONN_IMANAGE_ADDINX and 
ISENABLEIMANADDINOPTIONX.

iManage addin-in registration
On: NUCONN_IMANAGE_ADDINX="1"

Off: NUCONN_IMANAGE_ADDINX=""

NetDocuments
On: NUCONN_NETDOCUMENTS="1"

Off: NUCONN_NETDOCUMENTS=""

OnBase
On: NUCONN_ONBASE="1"

Off: NUCONN_ONBASE=""

OneDrive
On: NUCONN_ONEDRIVE="1"

Off: NUCONN_ONEDRIVE=""

SharePoint
On: NUCONN_SHAREPOINT="1"

Off: NUCONN_SHAREPOINT=""

Worldox
On: NUCONN_WORLDOX="1"

Off: NUCONN_WORLDOX=""

Important All connectors are disabled by default.

Document processing switches
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Reader mode
On: ISREADONLYMODE="1"

Off: ISREADONLYMODE=""

Note The feature is disabled by default and not supported in Power PDF Reader.

Limited reader mode
On: ISLIMITEDREADONLYMODE="1"

Off: ISLIMITEDREADONLYMODE=""

Note The feature is disabled by default and not supported in Power PDF Reader.

Advanced edit mode
On: ISDISABLEWRITEMODE=""

Off: ISDISABLEWRITEMODE="1"

Note The feature is enabled by default and not supported in Power PDF Reader.

Allow legacy mode image edit
Set this parameter to "0" to enable only the Edit Object button and hide the Edit Text button, so the user 
needs to click twice to activate text editing on text blocks. Selecting the Allow legacy mode image edit
option on the Document Properties page in the Customization Kit results in the same as setting the 
ISTOUCHUPNEWSTYLE parameter to "0".

On: ISTOUCHUPNEWSTYLE="1"

Off: ISTOUCHUPNEWSTYLE="0"

Note The feature is enabled by default and not supported in Power PDF Reader.

Auto save
On: ISINSTALLAUTOSAVE="1"

Off: ISINSTALLAUTOSAVE="0"

Note The feature is enabled by default and not supported in Power PDF Reader.

AutoStore
On: NUAUTOSTORE="1"

Off: NUAUTOSTORE=""
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Note The feature is disabled by default.

Bates numbering
On: ISINSTALLBATESSTAMP="1"

Off: ISINSTALLBATESSTAMP="0"

Note The feature is enabled by default and not supported in Power PDF Reader.

CaseMap support
On: ISINSTALLCASEMAP="1"

Off: ISINSTALLCASEMAP=""

Note The feature is enabled by default.

Create comments summary
On: ISINSTALLCOMMENTPRINT="1"

Off: ISINSTALLCOMMENTPRINT=""

Note The feature is enabled by default.

Create dynamic forms
On: ISINSTALLFORMTYPER="1"

Off: ISINSTALLFORMTYPER=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Document collaboration
On: ISDISCOLLABORATION="0"

Off: ISDISCOLLABORATION="1"

Note The feature is enabled by default and not supported in Power PDF Reader.

DRM security - FileOpen support
On: NUFILEOPEN="1"

Off: NUFILEOPEN=""

Note The feature is enabled by default.
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Export/Import/Migrate comments
On: ISEXPORTCOMMENTS="1"

Off: ISEXPORTCOMMENTS=""

Note The feature is enabled by default.

Favorites
On: ISINSTALLFAVOURITES="1"

Off: ISINSTALLFAVOURITES="0"

Note The feature is enabled by default and not supported in Power PDF Reader.

Fax via E-mail
On: NUFAXVIAEMAIL="1"

Off: NUFAXVIAEMAIL=""

Note The feature is enabled by default.

File storage options
On: NUFILESTORAGE="1"

Off: NUFILESTORAGE=""

Note The feature is enabled by default.

Full form handling – not just filling, except Highlighting and reset form
On: ISFORMTOOLENABLE="1"

Off: ISFORMTOOLENABLE=""

Note The feature is enabled by default.

Flatten
On: ISFLATTENENABLE="1"

Off: ISFLATTENENABLE=""

Note The feature is enabled by default and not supported in Power PDF Reader.
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Imposition
On: ISINSTALLIMPOSITION="1"

Off: ISINSTALLIMPOSITION="0"

Note The feature is enabled by default.

Indexing PDF files
On: ISINSTALLCATALOG="1"

Off: ISINSTALLCATALOG="0"

Note The feature is enabled by default and not supported in Power PDF Reader.

Measurement tools
On: ISMEASURETOOL="1"

Off: ISMEASURETOOL=""

Note The feature is enabled by default.

Microsoft Rights Management Services
On: ISINSTALLRMS="1"

Off: ISINSTALLRMS="0"

Note The feature is enabled by default.

Optimize PDF documents
On: ISINSTALLOPTIMIZE="1"

Off: ISINSTALLOPTIMIZE=""

Note The feature is enabled by default and not supported in Power PDF Reader.

PDF document comparison
On: ISINSTALLCOMPAREDOC="1"

Off: ISINSTALLCOMPAREDOC="0"

Note The feature is enabled by default.
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Read aloud
On: READALOUD="1"

Off: READALOUD=""

Note The feature is enabled by default.

Reading order
On: ISREADINGORDER="1"

Off: ISREADINGORDER=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Redact PDF documents
On: ISCONTAINREDACTION="1"

Off: ISCONTAINREDACTION="0"

Note The feature is enabled by default and not supported in Power PDF Reader.

Remove document elements
On: ISINSTALLEXAMINEDOC="1"

Off: ISINSTALLEXAMINEDOC="0"

Note The feature is enabled by default and not supported in Power PDF Reader.

Scan
On: NUSCAN="1"

Off: NUSCAN=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Scan inbox
On: NUINBOXMONITOR="1"

Off: NUINBOXMONITOR=""

Note The feature is enabled by default.
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Security and digital signature
On: ISINSTALLDIGSIGN="1"

Off: ISINSTALLDIGSIGN="0"

Note The feature is enabled by default.

Self-signed digital ID creation
On: NUSELFSIGNEDID="1"

Off: NUSELFSIGNEDID=""

Note The feature is enabled by default.

Sequencer
On: ISBATCHPROCESSING="1"

Off: ISBATCHPROCESSING=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Sign PDFs with DocuSign
On: NUDOCUSIGN="1"

Off: NUDOCUSIGN=""

Note The feature is disabled by default.

Sign PDFs with SignDoc
Use the property NUSIGNDOC to enable/disable the SignDoc support.

On: NUSIGNDOC="1"

Off: NUSIGNDOC=""

Note The feature is enabled by default.

Trust SignDoc and DocuSign root certificates
On: NUINSTTRUSTCERTS="1"

Off: NUINSTTRUSTCERTS=""

Note The feature is enabled by default.
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SignDoc server location
Use the property SIGNDOCURL to set the location of the SignDoc server. You can push this with the user 
macro with the following syntax:

SIGNDOCURL="\\{Computer name}\{folder1}\{folder2}\"

Note The value must be a valid server address and available from the user's computer.

Signing and time stamping documents
On: ISDISABLESIGNATURE="0"

Off: ISDISABLESIGNATURE="1"

Note The feature is enabled (0) by default.

Spell checker
On: ISINSTALLSPELLCHECK="1"

Off: ISINSTALLSPELLCHECK="0"

Note The feature is enabled by default.

Split PDF documents
On: ISINSTALLPDFCHUNKER="1"

Off: ISINSTALLPDFCHUNKER="0"

Note The feature is enabled by default and not supported in Power PDF Reader.

Stationery
On: NUSTATIONERY="1"

Off: NUSTATIONERY=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Tagging PDF documents
On: ISINSTALLRETAG="1"

Off: ISINSTALLRETAG=""

Note The feature is enabled by default and not supported in Power PDF Reader.
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Use Clip Art
On: ISINSTALLCLIPART="1"

Off: ISINSTALLCLIPART="0"

Note The feature is enabled by default and not supported in Power PDF Reader.

Watched folder
On: ISINSTALLWATCHEDFOLDER="1"

Off: ISINSTALLWATCHEDFOLDER=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Read stamps from a shared location
The STAMPCOMMONLOC property contains the location of stamps.

On: STAMPCOMMONLOC="\\{server}\{folder1}\..."

Off: STAMPCOMMONLOC=""

Note The feature is disabled by default.

Enable watermarks
On: ISINSTALLWATERMARK="1"

Off: ISINSTALLWATERMARK="0"

Note The feature is enabled by default and not supported in Power PDF Reader.

Read watermarks from a shared location
The WATERMARKCOMMONLOC property contains the location of watermarks.

On: WATERMARKCOMMONLOC="\\{server}\{folder1}\..."

Off: WATERMARKCOMMONLOC=""

Note The feature is disabled by default and not supported in Power PDF Reader.

UI languages
Installation language only: If the value of the property NUUSERLANGUI is 0, the installer deploys the 
installation language and the English language. The installation language is selected as the default UI 
language.
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This example deploys French and English UI languages. The application uses French by default:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"  
NUUSERLANGUI="0" TRANSFORMS="1036.mst"

This example deploys only English UI language. The application uses English by default:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"  
NUUSERLANGUI="0"

All available languages: If the value of NUUSERLANGUI property is 1, the installer deploys all the 
available UI languages. The default UI language of the application is the installation language.

This example deploys all the UI languages. The application uses French by default:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"  
NUUSERLANGUI="1" TRANSFORMS="1036.mst"

This example deploys all the UI languages. The application uses English by default:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"  
NUUSERLANGUI="1"

Selected languages: If the value of the property NUUSERLANGUI is 2, the installer deploys all the 
command line defined UI languages. The default UI language of the application is the installation 
language.

The supported languages and the command line options are indicated in the following table.

Command line options of UI languages

Language Option

Chinese (traditional) NUCHTUI

Chinese (simplified) NUCHSUI

Czech NUCZHUI

Danish NUDANUI

Dutch NUDUTUI

English NUENGUI

Finnish NUFINUI

French NUFREUI

German NUGERUI

Hungarian NUHUNUI

Italian NUITAUI

Japanese NUJPNUI

Korean NUKORUI

Norwegian NUNORUI

Polish NUPOLUI
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Language Option

Portuguese (Brazil) NUBRAUI

Russian NURUSUI

Spanish NUSPAUI

Swedish NUSWEUI

Turkish NUTURUI

The following example deploys 4 UI languages: English, Chinese (Simplified), Spanish and German. The 
installation language is German. The default UI language is also German because DEFUILANG (see 
below) is not defined.

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"  
NUUSERLANGUI="2" NUENGUI="1" NUCHSUI="1" NUSPAUI="1" NUGERUI="1"
TRANSFORMS="1031.mst"

Note By default, the value of NUUSERLANGUI is 0. For Power PDF Reader, use the Kofax Power PDF 
Reader.msi as the installer file name command line parameter.

Default UI language
The DEFUILANG property used to specify the default UI language of the application. The possible values 
are:

DEFUILANG="auto"

When starting, the application automatically selects the UI language based on the OS language. If the OS 
language was not deployed, the UI language is English.

DEFUILANG=""

The installer sets the UI language based on the installation language selected by the user. If the 
installation language was not deployed, the UI language is English. This is the default value.

The following example deploys 4 UI languages, English, Chinese (Simplified), Spanish, and German. The 
installation language is German. The default UI language is depending on the OS of the client computer.

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"  
NUUSERLANGUI="2" NUENGUI="1" NUCHSUI="1" NUSPAUI="1" NUGERUI="1"
TRANSFORMS="1031.mst" DEFUILANG="auto"

Note For Power PDF Reader, use Kofax Power PDF Reader.msi as the installer file name in command 
line parameters.

Application options

Color skins
Set the SKINTYPE command line switch:
• 1: Dark Gray
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• 2: Light Gray
• 3: Blue
• 4: Purple

Example:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi" SKINTYPE=3

Note The default skin type is blue in Power PDF Advanced and dark gray in Power PDF Reader. For 
Power PDF Reader, use Kofax Power PDF Reader.msi as the installer file name in command line 
parameters.

Page display options
Set the OPT_ PAGEVIEW_LAYOUT command line switch:
• 1: Automatic
• 2: SinglePage
• 3: Continuous
• 4: ContinuousFacing
• 5: Facing

Set the OPT_ PAGEVIEW_ZOOM command line switch:
• 6: Automatic
• 5: FitVisible
• 4: FitHeight
• 3: FitWidth
• 2: FitPage
• 1: ActualSize
• 8192: 12.5 percent
• 16384: 25 percent
• 32768: 50 percent
• 49152: 75 percent
• 65536: 100 percent
• 81920: 125 percent
• 98304: 150 percent
• 131072: 200 percent
• 262144: 400 percent
• 524288: 800 percent
• 1048576: 1600 percent
• 2097152: 3200 percent
• 4194304: 6400 percent

Example:
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MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi" OPT_PAGEVIEW_LAYOUT=3, 
 OPT_PAGEVIEW_ZOOM=65536

Note The default value for pageview layout is automatic (value=1) and for pageview zoom is also 
automatic (value=6). For Power PDF Reader, use Kofax Power PDF Reader.msi as the installer file 
name in command line parameters.

Allow running JavaScript
On: OPT_JS_ALLOWRUN="1"

Off: OPT_JS_ALLOWRUN="0"

Note The feature is enabled by default.

Allow JavaScript in documents with trusted certificates
On: OPT_JS_ALLOWRUN_TRUSTCERT="1"

Off: OPT_JS_ALLOWRUN_TRUSTCERT="0"

Note The setting only comes into effect if the "Allow running JavaScript" feature is disabled. This feature 
is disabled by default.

Maintain revisions
On: SAVEREVISIONS="1"

Off: SAVEREVISIONS=""

Note The feature is enabled by default.

Show splash window
On: ISSHOWSPLASHSCREEN="1"

Off: ISSHOWSPLASHSCREEN="0"

Note The feature is enabled by default.

Show start screen
On: ISSHOWSTARTSCREEN="1"

Off: ISSHOWSTARTSCREEN="0"

Note The feature is enabled by default.

Use select tool as default instead of hand tool
On: ISUSESELECTTOOL="1"
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Off: ISUSESELECTTOOL=""

Note The feature is disabled by default.

Allow user to disable/enable eDOCS connector
On: ISENABLEHBADDINOPTION="1"

Off: ISENABLEHBADDINOPTION=""

Note The feature is disabled by default.

Allow user to disable/enable iManage connector
On: ISENABLEIMANADDINOPTION="1"

Off: ISENABLEIMANADDINOPTION=""

Note The feature is disabled by default.

Allow user to disable/enable JavaScript
On: OPT_JS_DISABLEALLOWRUN="1"

Off: OPT_JS_DISABLEALLOWRUN="0"

Note The feature is enabled by default.

Hide downloading UI languages
On: ISHIDEADDLANGUAGE="1"

Off: ISHIDEADDLANGUAGE="0"

Load security settings
Note The feature is disabled by default and not supported in Power PDF Reader. Allow user to disable/
enable the Load security settings option in the application.

On: ISSHOWLOADSECOPTION="1"

Off: ISSHOWLOADSECOPTION=""

Maintain Revisions
Allow user to disable/enable Maintain Revisions in the application.

On: ISSHOWREVOPTION="1"

Off: ISSHOWREVOPTION=""
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Note The feature is enabled by default and not supported in Power PDF Reader.

Allow user to modify PDF creation options
Turn this feature off if you want to deploy read-only PDF printer settings and Create Assistant profiles.

On: ISDRIVERMODIFIABLE="1"

Off: ISDRIVERMODIFIABLE=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Allow user to disable/enable the View Documents in Internet Explorer 
option
On: ISENABLEIEPDFVIEWOPTION="1"

Off: ISENABLEIEPDFVIEWOPTION=""

Note The feature is enabled by default.

Windows Desktop Search
Allow user to disable/enable Windows Desktop Search integration in the application.

On: ISENABLEWDSOPTION="1"

Off: ISENABLEWDSOPTION=""

Note The feature is enabled by default.

Show JavaScript button in the Edit tab of the ribbon
On: OPT_JS_SHOWBUTTON="1"

Off: OPT_JS_SHOWBUTTON=""

Note The feature is enabled by default and not supported in Power PDF Reader.

Show next file and previous file in the File menu
On: ISINSTALLVIEWFOLDER="1"

Off: ISINSTALLVIEWFOLDER="0"

Note The feature is enabled by default.

Show Open Revisions and Save Revisions in the File menu
On: FILE_REVISION="1"

42



Kofax Power PDF Network Installation Guide

Off: FILE_REVISION="0"

Note The feature is enabled by default.

Show Recent Documents and Recent Places in the File menu
On: FILE_RECENT="1"

Off: FILE_RECENT="0"

Note The feature is enabled by default.

Show Revert File in the File menu
On: FILE_REVERT="1"

Off: FILE_REVERT="0"

Note The feature is enabled by default.

Signature switches

Enable Signing Reason-related controls
Enable Require Signing Reason and Show Reasons in the application.

On: OPT_SIGN_REQUIRERESON="1"

Off: OPT_SIGN_REQUIRERESON=""

Note The feature is disabled by default.

Disable Signing Reason-related controls
Disable Require Signing Reason, Show Reasons, and Edit Reasons controls in the Settings dialog box of 
the application.

On: OPT_SIGN_DISABLEREASONS="1"

Off: OPT_SIGN_DISABLEREASONS=""

Note The feature is disabled by default.

Enable Show location and contact information
On: OPT_SIGN_LOCATION="1"

Off: OPT_SIGN_LOCATION=""
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Note The feature is disabled by default.

Disable Show location and contact information
On: OPT_SIGN_DISABLELOCATION="1"

Off: OPT_SIGN_DISABLELOCATION=""

Note The feature is disabled by default.

Enable Include signature's revocation status
On: OPT_SIGN_REVOCSTATUS="1"

Off: OPT_SIGN_REVOCSTATUS=""

Note The feature is disabled by default.

Disable Include signature's revocation status
On: OPT_SIGN_DISABLEREVOCSTATUS="1"

Off: OPT_SIGN_DISABLEREVOCSTATUS=""

Note The feature is disabled by default.

Enable Require time stamp information
On: OPT_SIGN_TSINFO="1"

Off: OPT_SIGN_TSINFO=""

Note The feature is disabled by default.

Disable Require time stamp information
On: OPT_SIGN_DISABLETSINFO="1"

Off: OPT_SIGN_DISABLETSINFO=""

Note The feature is disabled by default.

Enable Allow the use of self-signed certificates during signature verification
On: SEC_SELFSIGNED_VALIDATE="1"

Off: SEC_SELFSIGNED_VALIDATE="0"

Note The feature is enabled by default.
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Enable Allow the creation and use of self-signed certificates for signing
On: SEC_SELFSIGNED_CREATEANDSIGN="1"

Off: SEC_SELFSIGNED_CREATEANDSIGN="0"

Note The feature is enabled by default.

Upgrade behavior

Set the behavior if legacy product was installed to the system
Ask the user: UPGLEGACY=""

Remove without any question: UPGLEGACY="1"

Keep without any question: UPGLEGACY="2"

Note The default behavior is "Ask the user". This feature is not supported in Power PDF Reader.

Remove previous Kofax Power PDF without question
On: UPGNOQUESTION="1"

Off: UPGNOQUESTION=""

Note The feature is disabled by default.

Keep installer settings of the previously installed Kofax Power PDF
On: UPGKEEP="1"

Off: UPGKEEP=""

Note The feature is enabled by default.

Other switches

Use shared watermarks
Allows using shared watermarks within the deployed printer settings.

On: USESHAREDWTM="1"

Off: USESHAREDWTM=""
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Scan to Desktop
Use the property S2DFILEPATH for Scan to Desktop in manual mode. You can push this with the user 
macro with the following syntax:

S2DFILEPATH="\\{Computer name}\Inboxes\{user}"

Note The parameter for {user} must be entered. When the scan inbox is accessed, {user} is 
automatically replaced with the name of the person logged in to Windows and points to their inbox.

You cannot use this variable in conjunction with S2DSERVER or S2DSUBDIR.

Use the S2DSERVER property with ShareScan in "home directory" mode. The value must be a valid 
server address that contains the home directory information for the ShareScan users. If you use home 
directories, entering a value for S2DDSERVER is mandatory, but entering a value for S2DSUBDIR is 
optional.

S2DSERVER="\\{Server name}"

The S2DSUBDIR property must match the value for ShareScan "home directory" mode. This is an 
optional value.

S2DSUBDIR="\\{folder name}"

Important Command line installation parameters always overwrite .mst file settings.

Client installation using Active Directory
Active Directory is a feature of Microsoft Windows servers. Group Policy (GPO), a component of Active 
Directory, includes a Software Installation snap-in that enables an administrator to create a network 
installation. The administrator can install software to Windows clients. The administrator cannot use the 
snap-in to install to clients with older versions of the Windows operating system.

Active Directory supports three main installation scenarios: Publish to Users, Assign to Users and Assign 
to Computers.
• Publish to Users adds the product to the list of installed programs that the user can access from the 

Control Panel. The program is not installed until the user selects to add it.
• Assign to Users adds a program shortcut to the user's Start menu and Desktop, and to the list of 

installed programs that the user can access from the Control Panel.
• Assign to Computers installs the software on the computer during the next computer reboot.

Power PDF Advanced supports the Assign to Computers scenario and installs the software when the 
computer is rebooted. The installation takes place silently, and the software is installed for all users on the 
computer.

Important Power PDF Advanced does not support the Publish to Users or Assign to Users scenarios.

Active Directory also supports ZAP files as a mechanism for installing programs that are not compatible 
with the Microsoft Windows Installer. Because Power PDF Advanced is Windows Installer compatible, 
ZAP files are not necessary.

46



Kofax Power PDF Network Installation Guide

Deployment example (installation in existing organizational units)
• A deployment target computer that is a member of a domain, site, or organizational unit.
• MSI 3.1 installed on the target (client) computer.
• A working Active Directory environment.
• Installer ready for deployment on a shared network location including the previously created transform 

file. This file must contain at least the serial number of the product. See Customization Kit. About the 
language-specific transform files in the case of a multi-language setup package, see Table 1: Transform 
file names by language.

1. Select Control Panel > Administrative Tools > Active Directory Users and Computers.
2. Right-click the site, domain, or organizational unit that contains the deployment computer.
3. Select Properties, click the Group Policy tab, and then click New.
4. Specify a descriptive name.
5. Click Edit.
6. In the Group Policy window, right-click Computer Configuration > Software Settings > Software 

Installation.
7. Click New, and then click Package.
8. Select Advanced Published or assigned.
9. Click OK.

10. Select the right .msi package. Remember, different .msi package files must be used on 32- and 64-
bit systems.
• Use Kofax Power PDF Advanced.msi for Power PDF Advanced.
• Use Kofax Power PDF Reader.msi for Power PDF Reader.

11. Select the Modifications tab, click Add when the Properties dialog box appears, and select the 
transform files with the modifications. In the case of a multi-language setup package, do not forget 
the relevant language transform file.

12. Click OK.

Active Directory is ready to install the product on client computers.

Client uninstallation
1. Select the package Power PDF Advanced from Software settings > Software installation.
2. Right-click and select All tasks > Remove.
3. Select Immediately uninstall the software from users and computers.

All integration entries are removed.

Note In a Windows Server 2012 Active Directory environment, removal of Kofax Power PDF 
Advanced from client computers may fail. If this happens, use Startup or Shutdown scripts with the 
following command included:
MsiExec.exe /x{PRODUCTCODE} /qb
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Group Policy settings
Group Policy settings for computer and user configurations are available in the Administrative template 
provided with Power PDF. The template is available in the Tools\Group Policy Templates folder in 
the distribution media of Power PDF Advanced, both in classic (ADM) and new (adml/adml) formats. Use 
the Local Group Policy Editor to configure these settings by editing Group Policy Objects. Both templates 
contain detailed explanations in English for each setting.

These policies are already installed and running control features, UI elements, and application options 
related to Power PDF Advanced.

Tip When using policy settings to hide buttons on the ribbon, consider that some buttons display 
dependent on the application state or context.

Important The Administrative template and the Customization Kit share most settings, but these tools 
are not equivalent.

• Some of the features cannot be enabled in the Administrative template if they were not enabled before, 
during customization and installation.

• Reader mode is connected to the Customization Kit and becomes definitive by the installation process, 
so Reader mode cannot be enabled in the Administrative template.

Installation under Citrix Metaframe or Remote Desktop Services 
(formerly Terminal Services)

1. Log in as an administrator.
2. Browse the setup.exe of Power PDF Advanced from the installation media.
3. Follow the instructions in the InstallShield Wizard.
4. When the installation is complete, click the Finish button.
5. Log off, then log on again to complete the installation and to enable the proper functioning of various 

components.

Publish application
To publish product to client computers, follow the steps below:

1. In the Windows Start menu, select Citrix > Management Consoles > Presentation Server 
Console.

2. Log on to the Server Farm.
3. Right-click Applications and select Publish Applications (Ctrl + P). The Application Publishing 

Wizard launches.
4. Specify the Display Name and Application Description and click Next .
5. Select the Application option and click Next.
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6. Under the Command line box, click Browse and locate the Power PDF Advanced executable as 
installed on the server, and click Next.

7. Select the servers that the Power PDF Advanced product runs on and click Next.
8. Specify the group of users whom you want to publish the application to and click Next.
9. Configure the appearance and location of the application shortcut and click Next.

10. Click Finish to publish the application or select Configure advanced application settings now to 
modify advanced options like Access control, File type associations, Limit of instances to run, Client 
options (such as encryption), and Application appearance (such as display size and color quality).

When you are finished, the published application becomes available under the Citrix Program 
Neighborhood on the client computers. If the application icon is not displayed there, double-click the
Application Set Manager icon, then click Find New Application Set and follow the instructions in the 
wizard.

Use Power PDF Advanced in mixed-mode (Reader mode and 
normal mode)

Note This feature is not supported in Power PDF Reader.

In Citrix and Terminal Services servers, it is possible to use Power PDF in mixed-mode. This means that 
one group of users can use Power PDF in Reader mode, while other users can use the same installation 
in normal mode. To configure the mode, Power PDF must be installed without Reader mode set, and for 
those users that need Reader mode, the following DWORD type registry value must be set:

HKEY_CURRENT_USER\SOFTWARE\Kofax\PDF\V1

ReaderMode=1

Access the installed product from clients
The following commands give you an example on how to access Power PDF Advanced from Citrix clients:

1. Have an installed Citrix client on the user computer.
2. Start Citrix MetaFrame Program Neighborhood.
3. Double-click Application Set Manager.
4. Create an ICA connection: double-click Custom ICA Connection, then double-click Add ICA 

connection.
5. Select the type of connection and click Next.
6. Enter a description for the connection and select the appropriate network protocol. Click Next.
7. Select to connect to the server, or to a published application. Change the defaults for encryption level 

and session reliability if you wish. Click Next.
8. Specify User Name, Password and Domain. Click Next.
9. Set the window color and size and click Next.

10. Browse to PDF application and the Working Directory. Click Next, then Finish.
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11. To launch the application, double-click the application icon in the MetaFrame Program 
Neighborhood window.

Uninstallation
To uninstall the PDF application, follow the steps below:

1. Log in to the Remote Desktop Services or the Citrix server as an administrator.
2. Go to Add/Remove programs.
3. Select the PDF application.
4. Click Remove.
5. The server may require a system restart. If so, click Yes.

This removes all integration entries.
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Microsoft App-V virtualization

This section describes how to sequence a Power PDF package and what additional installations are 
needed on the client computer. This guide shows how to integrate with Microsoft Office applications when 
Office is virtualized in another package.

Power PDF 4.1.0 is tested with Microsoft App-V for Windows 10, Version 2004.

Virtualize Microsoft Office with Office Deployment tool
1. Download the Office Deployment Tool from Microsoft: http://www.microsoft.com/en-us/download/

details.aspx?id=49117
2. Extract the .odt files.
3. Launch the downloaded .exe file.
4. Accept the EULA and click Continue.
5. Browse for a folder where the files of the Office Deployment Tool are extracted, and click OK.
6. Open and edit Configuration.xml with Notepad from the folder where you extracted the .odt files.
7. Change the content to the following:

<Configuration>  
<Add OfficeClientEdition="32">  
<Product ID="O365ProPlusRetail">  
<Language ID="en-us"/>  
</Product>  
</Add>  
</Configuration>

8. Change 32 to 64 if 64-bit office is needed.
9. Change en-us to the desired language code.

10. Save the .xml file.
11. Launch a Command Prompt (cmd.exe) with administrator rights (Run as Administrator).
12. Type the following line into the Command Prompt:

{path}\setup.exe" /packager "{path}\Configuration.xml" "{output path}

13. Replace {path} and {output path} with the actual paths, then press Enter.
14. Wait until the package is downloaded and converted, which may take several minutes.

Note The following Microsoft Knowledge Base also describes how to deploy Microsoft Office 2013 
using App-V 5.1: https://technet.microsoft.com/en-us/itpro/mdop/appv-v5/deploying-microsoft-
office-2013-by-using-app-v51
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Sequence Power PDF
Before sequencing Power PDF, perform the prerequisite steps in Prepare computer for sequencing.

Prepare computer for sequencing
1. Prepare a clean computer.
2. Install Microsoft .NET Framework 4.8 full version. It can be downloaded from Microsoft: https://

dotnet.microsoft.com/download/dotnet-framework/net48 or can be found in the Prerequisites folder 
on the Power PDF installation media.

3. Select Windows update from Start menu, and then download and install all recommended updates.
4. If you are running Windows 8 or later, skip this step. For earlier versions, you must install 

Windows Power Shell 3.0. Download Windows Management Framework 3.0 from Microsoft: http://
www.microsoft.com/en-us/download/details.aspx?id=34595

5. Stop Windows Defender.
6. Go to Control Panel, change to Small icons view, and click Windows Defender.
7. In Tools > Options > Administrator, clear the Use this program option.
8. On Windows 10, click Settings then turn off Real-time protection.
9. Stop Windows Search.

10. Select Control Panel > Administrative tools > Services, and browse to Windows Search Service. 
Click Stop.

11. Disable Automatic Windows Update:
• In Windows 10, search for "Update" in the Start menu, and then click Check for updates. Click

Advanced Options and use the Pause Updates switch to turn off updates.
• In Windows 7, search for "Update" in the Start menu, and then click Windows Update. On the left, 

select Change Settings. Select Never check for updates (not recommended) in the Important 
updates list, then click OK to turn off updates.

12. Install Microsoft App-V Sequencer.
13. Reboot the computer.

Sequence Power PDF as a plugin for Office 2016
1. Launch the Microsoft Application Virtualization Sequencer.
2. Click Create a New Virtual Application Package.
3. Select Create Package, and click Next.
4. Resolve issues that are listed in the Prepare Computer dialog box. Click Next.
5. Select the Add-on or Plugin radio button, click Next.
6. Install Power PDF.

Under the Select the installer for the application box, click Browse and locate Setup.exe in Kofax 
Power PDF Advanced installation media and install Power PDF.

Note It is possible to use either the original build or an installer package that you already 
customized and Published using the Customization Kit.

52

https://dotnet.microsoft.com/download/dotnet-framework/net48
https://dotnet.microsoft.com/download/dotnet-framework/net48
http://www.microsoft.com/en-us/download/details.aspx?id=34595
http://www.microsoft.com/en-us/download/details.aspx?id=34595


Kofax Power PDF Network Installation Guide

7. Expand the Office App-V Package: Click Expand Package. Wait until the package is expanded.
8. Select the I have installed the primary parent program check box and click Next.
9. Enter a name you prefer, such as PowerPDF as the package name. Avoid spaces. Click Next.

10. Go through the Pro installer steps:
• Select language.
• Click Start installation.
• Accept the EULA and enter the serial number.
• Select Custom install, make necessary customization.
• In the Destination folder step, make sure that the destination folder is the same as you defined in 

the App-V sequencer.
• Complete the installation.

11. Select the I am finished installing check box and click Next.
12. Click Next in the Installation Report dialog box. The Installation report can report errors such as

Printer driver detected, Files excluded from package, or Unsupported shell extension detected.
13. Select the Customize radio button, click Next.
14. Run and close applications one by one in the Prepare for Streaming dialog box, then click Next. If 

the Terminate child processes dialog box appears, click Yes to close the background processes.
15. Select Allow this package to run on any operating system and click Next.
16. Select Continue to modify package without saving using the package editor and click Next.
17. Click Close in the Package completed step.
18. In the Microsoft Application Virtualization Sequencer, select the Virtual Registry tab and update the 

following keys:
• Select the Registry\User\[{AppVCurrentUserSID}]\Software\Kofax key and right click. Select Key >

Merge with Local Key in the context menu.
• Select the Registry\User\[{AppVCurrentUserSID}]\Software\Kofax\PDF key and right click. Select

Key > Merge with Local Key in the context menu.
• Select the Registry\User\[{AppVCurrentUserSID}]\Software\Kofax\PDF\PDF Driver key and right 

click. Select Key > Merge with Local Key in the context menu.
19. Select File > Save as and save the package.
20. Open PowerPDF_DeploymentConfig.xml with Notepad from the folder where the package was 

saved and edit it.
• Find "<COM mode=" and change settings to the following:

<COM Mode="Integrated">
<IntegratedCOMAttributes OutOfProcessEnabled="true" InProcessEnabled="true" />  
</COM>  
<!-- Objects -->
<Objects Enabled="false" />

• Find " EnvironmentVariables" and change settings to the following:
<EnvironmentVariables Enabled="true">
<Include>  
<Variable Name="MOZ_PLUGIN_PATH" Value="[{AppVPackageRoot}]\Bin\" />  
<Variable Name="powerpdfinappv" Value="501" />  
</Include>

21. Open PowerPDF_UserConfig.xml with Notepad from the created folder.
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22. Find "<COM mode=" and change settings to the following:
<COM Mode="Integrated">
<IntegratedCOMAttributes OutOfProcessEnabled="true" InProcessEnabled="true" />  
</COM>  
<!-- Objects -->
<Objects Enabled="false" />

23. Copy the created folder (package) to a shared location.

Deploy on client computers
The following sections list the necessary preparations and steps to deploy App-V packages.

Prepare client
1. Install Windows 10 Enterprise.
2. Install Microsoft .NET Framework 4.8 full version.
3. Install the Microsoft App-V client.
4. Reboot the computer.

Install printer driver
The printer driver is excluded during the sequencing process and must be installed locally on the client.

1. Browse for the installation folder of Kofax PDF Create for App-V deployed Power PDF and launch 
setup.exe.

2. Select a language and click Start Installation.
3. Finish the installation.

Deploy Microsoft Office App-V package
1. Launch Accessories > Windows PowerShell > Windows PowerShell ISE with Run as 

Administrator.
2. Type Set-ExecutionPolicy Unrestricted and press Enter. Click Yes to confirm the policy change.
3. Type Import-Module appvclient and press Enter.
4. Type Set-AppvClientConfiguration -EnablePackageScripts $true and press Enter.
5. Type Add-AppvClientPackage -Path <path_of_Office.appv> -DynamicDeploymentConfiguration 

<path_of_DeploymentConfig.xml> | Publish-AppvClientPackage -Global and press Enter.
Change the following to the actual paths:
• <path_of_Office.appv>
• <path_of_DeploymentConfig.xml>

Wait until the package is added and published.
Verify that Microsoft Office 2013 has appeared in the Start Menu.
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Deploy Power PDF App-V package
1. Type Add-AppvClientPackage -Path <path_of_PowerPDF.appv> -DynamicDeploymentConfiguration 

<path_of_DeploymentConfig.xml> | Publish-AppvClientPackage -Global and press Enter.
2. Change the following to the actual paths:

• <path_of_PowerPDF.appv>
• <path_of_DeploymentConfig.xml>

3. Wait until the package is added and published.

Set Connection Group
1. Copy the following text into Notepad:

<?xml version="1.0" encoding="UTF-16"?>  
<appv:AppConnectionGroup
xmlns="http://schemas.microsoft.com/appv/2010/virtualapplicationconnectiongroup"
xmlns:appv="http://schemas.microsoft.com/appv/2010/
virtualapplicationconnectiongroup"  
AppConnectionGroupId="" VersionId=""
Priority="0" DisplayName="PDF and Office">  
  <appv:Packages>  
    <appv:Package PackageId="" VersionId="" /> 
    <appv:Package PackageId="" VersionId="" />  
  </appv:Packages>  
</appv:AppConnectionGroup>

2. Open PowerShell ISE (Run as Administrator).
3. Create 2 new GUIDs with this command: [guid]::NewGuid()
4. Copy the new GUIDs between the quotation marks of AppConnectionGroupId and the first VersionId 

rows.
5. Type Get-AppvClientPackage to PowerShell ISE and press Enter.
6. Copy and paste the PackageId and VersionId for both the Power PDF and Office packages.
7. Save the file as Unicode text as ConGroup.xml.
8. Type Add-AppvClientConnectionGroup -path <path_of_ConGroup.xml> and press Enter.
9. Type Enable-AppvClientConnectionGroup -name "PDF and Office" -Global and press Enter.

Enable other integrations (optional)
1. Open Notepad.
2. Copy the PackageId of PowerPDF package from PowerShell and paste it to Notepad.
3. Type an _ (underscore) character after the package id.
4. Copy the VersionID of PowerPDF package from PowerShell and paste it after _ (underscore).
5. Open Regedit with admin rights.
6. Select HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppV\Client\RunVirtual key. The following 

sections detail the rest of the steps for various browsers.

Microsoft Edge
1. Right click RunVirtual key and select New > Key.
2. Type microsoftedgecp.exe and press Enter.
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3. Right click (Default) and select Modify.
4. Copy the concatenated IDs from Notepad, paste to Value Data and click OK.

Internet Explorer
1. Right click RunVirtual key and select New > Key.
2. Type iexplore.exe and press Enter.
3. Right click (Default) and select Modify.
4. Copy the concatenated IDs from Notepad, paste to Value Data and click OK.

Google Chrome
1. Right click RunVirtual key and select New > Key.
2. Type chrome.exe and press Enter.
3. Right click (Default) and select Modify.
4. Copy the concatenated IDs from Notepad, paste to Value Data and click OK.

Mozilla Firefox
1. Right click RunVirtual key and select New > Key.
2. Type firefox.exe and press Enter.
3. Right click (Default) and select Modify.
4. Copy the concatenated IDs from Notepad, paste to Value Data and click OK.
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iManage connector and server configuration

Users can install the Kofax iManage 10 v2 connector with Power PDF Advanced, if the installation 
package is not configured otherwise. The following sections describe how to configure the iManage server 
to use with Power PDF Advanced.

Configure the iManage server
The Power PDF iManage connector uses OAuth2 authentication by default with the recent iManage 
server versions, which support the v2 API. If you want to use OAuth2 for Power PDF, you need to register 
the Power PDF application on the server side.

Register the Power PDF application in Control Center
1. Open Control Center.
2. In the Dashboard on the left, select Applications.

The Application panel appears on the right.
3. At the top-right corner, click Add Application.

The Add Application dialog box appears.
4. Click Configure Manually.
5. On the Configuration tab, fill the text boxes as follows, then click Authentication.

• Name: Power PDF
• Description: Power PDF Application
• API Key: 00fb6221-3f3f-4b48-85e1-d2e49c8fd44f
• API Secret: 7a71dd05-e921-4fcd-9246-94ea29b7d603
• Publisher: Kofax

6. On the Authentication tab, fill the text boxes and set the switches as follows, then click Access.
• iManage Work Authentication Required?: Yes
• Application Type: Native
• Redirect URL: http://localhost/
• Client Secret Expires: Never
• Allow Refresh Token: Yes

Note The Allow Refresh Token switch appears on iManage server version 10.3 or later. If this 
option is not available, use the iManageServer_ART.exe to enable it. See Enable the Allow Refresh 
Token option using iManageServer_ART.exe for details.

7. On the Access tab, select All Users then click Access.
8. On the Review tab, switch Enable Application to Yes, then click Finish.
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As a result, Power PDF appears in the list of registered applications.

Enable the Allow Refresh Token option using iManageServer_ART.exe
On the iManage server versions earlier than 10.3, the Allow Refresh Token switch might not be 
available in the Application settings in Control Center. To enable Allow Refresh Token, use the 
iManageServer_ART.exe command line tool, which is located in the Power PDF installation package, in 
the Tools\iManage server subfolder.

1. Start the Command Prompt and navigate to the folder containing iManageServer_ART.exe.
2. Issue the following command:

iManageserver_ART.exe <server_url> <user_name> <password> <ClientID> [true/false]

Replace the variables in brackets with the actual parameters:
• server_url: The iManage server URL, such as http://localhost/
• user_name: The user name of your iManage server administrator account.
• password: The password of the above account.
• ClientID: The client ID of Power PDF, which is: 00fb6221-3f3f-4b48-85e1-d2e49c8fd44f
• true or false: Optional parameters.

Use the iManage v2 connector without OAuth2
Power PDF uses OAuth2 authentication by default if the server supports the v2 API. To ignore OAuth2, do 
any of the following:
• Reveal and use the OAuth2 option in the Add Server dialog box.

a. In Power PDF, on the  Connectors  > iManage  page of the Options dialog box, click Add 
Account to start the Add Server dialog box.

b. Double-click the Web address label above the text box.

As a result, the Use Oauth2 option appears below, and becomes available as soon as the web 
address is specified.

a. In the Web address text box, specify the URL of the iManage server.

b. Click Login and proceed with the login process as usual.
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• Alternatively, edit the setting in the configuration file.

a. In a plain text editor, such as Notepad, open the DMSProDMS.ini file, which is located in this 
folder:
%ProgramData%\Kofax\PDFProDMS.ini

If there is no such file, you need to create it manually.

b. Append the following two lines to this .ini file, or edit these lines, if they already exist:
[iManage10]
DO_NOT_USE_OAUTH2=1

c. Save the file.
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