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Introduction

This document covers the main installation scenarios for the Kofax Power PDF Advanced and Kofax
Power PDF Reader products in a network environment. The Administrative setup topics contain
necessary information for special deployment systems such as Active Directory, Microsoft Systems
Management Server and System Center Configuration Manager.

The document describes all parameters and installer options that you may want to use during the
installation setup.

The primary source of information about Kofax Power PDF system requirements and dependencies
on other products is the Technical Specifications document, which is available on the Kofax Power
PDF Product Documentation page. The document is updated regularly, and we recommend that you
review it carefully to ensure success with your Kofax Power PDF product.

Product definitions

Most sections in this document are relevant for both Power PDF Advanced and Power PDF Reader.
Features and options not supported in Power PDF Reader are always marked with a note. Both
products may be installed on the same computer.

Power PDF Advanced

Kofax Power PDF Advanced combines the power of PDF creation, the flexibility of PDF editing,
and the versatility of PDF conversion into one easy-to-use, affordable application. It provides all
the critical business features you need without the cumbersome and costly print and pre-press
functionality found in more expensive solutions.

Kofax Power PDF Advanced is designed to be deployed and used in a distributed environment.
Furthermore, it provides additional features compared to the Standard version:

+ Software activation turned off

+ Electronic product registration turned off

« Automatic product updates turned off

+ Silent installation

+ Distributable PDF creation parameters

+ Distributable PDF product settings

+ Redaction tool to filter out sensitive PDF content

+ Bates numbering tool for uniquely identifying each page in legal document sets


https://docshield.kofax.com/Portal/Products/en_US/PowerPDF/5.0.0-3uoz7ssq2b/PowerPDF.htm
https://docshield.kofax.com/Portal/Products/en_US/PowerPDF/5.0.0-3uoz7ssq2b/PowerPDF.htm
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+ Group Policy Object support

Support for different Document Management Systems (See the release notes for details.)
* Document collaboration

* Online collaboration (available with Advanced Volume license only)

Power PDF Reader

Kofax Power PDF Reader serves as an advanced PDF tool for corporate users who do not require the
powerful editing and conversion features of Power PDF Advanced.

Please note the following information:
+ The default skin type is blue in Power PDF Advanced and dark gray in Power PDF Reader.

+ Power PDF Reader is installed separately and does not require Active Directory client installation
files. See the Installation media layout and Installation prerequisites chapters for details.

* Power PDF Reader and Power PDF Advanced .msi installation files have different names. See
Installation media layout for details.

Power PDF Reader does not support the following features:

+ Upgrade Behavior feature

* Launch Create Assistant at startup (SSASSISTANSATSTARTUP command line parameter)
+ Install PDF Convert component (SSCONVSTATE command line parameter)

* Printer Port Name (PDFPRINTERPORTNAME command line parameter)

+ File Explorer (Windows Explorer) integration (WINDOWSEXPLORERALL command line parameter)
* Microsoft Word integration (WORDADDINALL command line parameter)

* Microsoft Excel integration (EXCELADDINALL command line parameter)

* Microsoft PowerPoint integration (PPTADDINALL command line parameter)

* Microsoft Outlook integration (OUTLOOKADDINALL command line parameter)

+ All options under Office application integration

* Reader mode (ISREADONLYMODE command line parameter)

+ Limited reader mode (ISLIMITEDREADONLYMODE command line parameter)

+ Allow legacy mode image edit (ISTOUCHUPNEWSTYLE command line parameter)
+ Advanced Edit mode (ISDISABLEWRITEMODE command line parameter)

+ Auto Save (ISINSTALLAUTOSAVE command line parameter)

+ Bates Numbering (ISINSTALLBATESSTAMP command line parameter)

+ Create dynamic PDF Forms (ISINSTALLFORMTYPER command line parameter)

+ Document Collaboration (ISDISCOLLABORATION command line parameter)

+ Favorites (ISINSTALLFAVOURITES command line parameter)

+ Flatten (ISFLATTENENABLE command line parameter)

+ Indexing PDF files (ISINSTALLCATALOG command line parameter)

+ Optimize PDF Documents (ISINSTALLOPTIMIZE command line parameter)

+ Reading Order (ISREADINGORDER command line parameter)

+ Redact PDF Documents (ISCONTAINREDACTION command line parameter)

+ Remove Document Elements (ISINSTALLEXAMINEDOC command line parameter)
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+ Scan (NUSCAN command line parameter)

* Scan Inbox / Set properties (NUINBOXMONITOR command line parameter)

+ Sequencer (ISBATCHPROCESSING command line parameter)

+ Split PDF documents (ISINSTALLPDFCHUNKER command line parameter)

+ Stationery (NUSTATIONERY command line parameter)

+ Tagging PDF documents (ISINSTALLRETAG command line parameter)

+ Use Clip Art (ISINSTALLCLIPART command line parameter)

* Watched Folder (ISINSTALLWATCHEDFOLDER command line parameter)

+ Enable Watermark (ISINSTALLWATERMARK command line parameter)

+ Read watermarks from a shared location (WATERMARKCOMMONLOC command line parameter)

+ Hide downloading User Interface (UI) languages (ISHIDEADDLANGUAGE command line
parameter)

+ Load security settings from server (ISSHOWLOADSECOPTION command line parameter)
+ Modify PDF creation options (ISDRIVERMODIFIABLE command line parameter)

+ Show JavaScript button in the Edit tab of the ribbon (OPT_JS_SHOWBUTTON command line
parameter)

* Document collaboration
* Online collaboration

Installation media layout

Power PDF Advanced and Power PDF Reader have a separate installation media or download
package containing all mandatory components for installation of the respective products.

Both the Power PDF Advanced and Power PDF Reader applications have 32-bit and 64-bit versions.
Most product components are 32-bit binaries independent from the version of the target operating
system. The installation media or download package contains both versions of the product in the
System32 and System64 folders.

Power PDF Advanced .msi files:
* .\System32\Kofax Power PDF Advanced.msi
* .\System64\Kofax Power PDF Advanced.msi

Power PDF Reader .msi files:
* .\System32\Kofax Power PDF Reader.msi
* .\System64\Kofax Power PDF Reader.msi

All folders contain _setup.exe:
* .\System32\ setup.exe
* .\System64\ setup.exe

o Always use the appropriate version of the .msi files or _setup.exe according to the operating
system you are targeting.
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The supported installation languages and the associated transform files are indicated in the
following table. Only one language can be used at a time.

Transform file names by language

Language Transform file
Chinese (Traditional) 1028.mst
Chinese (Simplified) 2052.mst
Czech 1029.mst
Danish 1030.mst
Dutch 1043.mst
English 1033.mst
Finnish 1035.mst
French 1036.mst
German 1031.mst
Hungarian 1038.mst
Italian 1040.mst
Japanese 1041.mst
Korean 1042.mst
Norwegian 1044.mst
Polish 1045.mst
Portuguese (Brazil) 1046.mst
Russian 1049.mst
Spanish 1034.mst
Swedish 1053.mst
Turkish 1055.mst




Installation prerequisites

The product requires the Microsoft .NET Framework 4.8 package to be installed on the client
computers.

Webview?2 is required for using the SignDoc and DocuSign functionalities.

This installer is located in the Prerequisite folder in the installation media or download package.
+ File name is ndp48-x86-x64-allos-enu.exe.
* Required on both 32-bit and 64-bit versions of Microsoft Windows.

i B you perform the standard installation procedure via Setup.exe in the root folder of your
installation media or download package, the Setup.exe installs the required software packages
automatically before launching the product installer. A reboot may be required after installation of
the components.

Rights Management Service

Power PDF uses Azure Information Protection by default.

To step back to the legacy Active Directory Rights Management Service, follow the steps in the
section below.

© sct the ISINSTALLRMS command line switch to "0" to disable right management services.

Use legacy Active Directory Rights Management Service

To step back to Active Directory Rights Management Service to work with legacy RMS-protected
documents, do the following.

1. Install Active Directory Rights Management Service Client 2.1 by proceeding with any of the
following steps:

+ Use the client installer appropriate for your operating system, provided with the Power PDF
Advanced installation media or download package:

+ For 32-bit operating systems: .\Tools\AD RMS\setup msipc x86.exe
+ For 64-bit operating systems: .\Tools\AD RMS\setup msipc x64.exe

+ Download the installer from Microsoft, at https://www.microsoft.com/en-us/download/
details.aspx?id=38396.

1


https://www.microsoft.com/en-us/download/details.aspx?id=38396
https://www.microsoft.com/en-us/download/details.aspx?id=38396
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© The Power PDF Reader installation media or download package does not contain these
files and was not tested with RMS in a Microsoft App-V environment.

2. In Power PDF, select File > Options > Security, then clear the "Use Azure Information
Protection instead of AD RMS" check box under Rights Management Services.

12



Installation in distributed environments

In a distributed environment, administrators can use a two-step procedure for software
deployment:

1. Customization

The Kofax Customization Kit is available from the Tools folder in your installation media or
download package (. \Tools\CustomKit\CustomizationKit.exe). The kit presets certain
installation options to configure client installation.

2. Client installation

Installs the product on the client workstation according to the options configured with the
Customization Kit.

The following sections describe how administrators can customize and deploy the product. Please
note that the manual client installation can be replaced with mass deployment.

Customization Kit

The Customization Kit for Power PDF Advanced and Power PDF Reader gives administrators the

ability to customize the installation of Kofax Power PDF Advanced products prior to deploying the
applications across an organization.

System requirements: The Customization Kit requires that at least Microsoft Windows Installer (MSI)
3.1 and Windows .NET Framework 4 are installed on the client computer.

© You must use a Kofax Customization Kit version that is identical to the product version.

Customization Kit overview

The Kofax Customization Kit helps to create a personalized package of Kofax Power PDF Advanced
for organization-wide deployment.

Use this tool to define where to install Power PDF Advanced, predefine the serial number and make
it read-only, set feature installation states, set visibility of features on the Custom Setup dialog

box, configure default application settings, deploy custom files and import predefined application
settings.

13
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When you finish the necessary modifications and publish a package with the Customization Kit, the

tool stores the modified settings in the following way:

+ Personalization, General, Application Integration, Connectors, Document Processing, Languages,
Application Options, and Upgrade Behavior settings are stored in the admin_customSettings.mst
transform file. This transform file is located beside the .msi package file.

+ Additional Files and Import Application Settings are stored beside the .msi package file.

Basic customization workflow

1. Launch the Customization Kit.

usewnN

=l Customization Kit

Qpen
Package..  Pac
Package
/ﬁ“ Welcome
Personalization
Licensing
IE' General
Application Integrations
2] connectors
% Document Procassing
8" Languages
G¥® Application Options

(® upgrade Behavior

m Additional Files

L3 \mport Application Settings

® @

Collect Application Load Generate Help About
Settings Transform...  Transform...

Wizard Transform Help

Welcome

KOFAX

Welcome to the Kofax Power PDF Customization Kit.

This product gives System Administrators the ability to customize the installation of Kofax Power PDF
Advanced and Kofax Power PDF Reader products prior to deploying the applications across their

organization.

Using this tool. you can:
- Choose where to install the product
- Define a serial number and hide it
- Set feature installation states
- Set feature installation visibilties
- Configure default application settings
- Add custom files
- Import predefined application settings

For more information about the usage of the Customization Kit and the installation of the product in an

enterprise environment click here and read the Network Installation Guide.

st use @ Customization Kit version that is identical to the product versio

deployment.

Click Open Package in the Package group and select the supplied .msi file.

Specify parameters for your own package in the different panels.

Optionally, add extra files or import application settings.

Click Publish Package in the Package group to finalize the customized installer for your own

Distribute the customized application to end users by doing any of the following:

a. Use command line for installation as described in Client installation using command line.

© A command line installation must contain all the transform files necessary for

your deployment, including the admin_customSettings.mst file generated by the
Customization Kit in step 5.

b. Locate the folder where you saved your customized installer in step 5 and start Setup.exe.

c. Select Open Package in the Package group, then browse to the customized .msi file such
as Kofax PDF Advanced.msi, and open it.

O At this stage you are free to select either a 32-bit or a 64-bit package.

14
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Customize the installer

The first group of options includes Personalization, Licensing, General, Application Integration,
Connectors, Document Processing, Languages, Application Options, and Upgrade Behavior.

Customizations from this group are saved into a transform (.mst) file.
If you want this .mst file, click Generate Transform in the Transform group and name your file.
If you want this .mst file with the predefined name (admin_customSettings.mst) and the entire
installer fileset, click the Publish Package button in the Package group.

1. Click Personalization.

2. Specify basic customer information, such as User Name.

3. Set the destination folder by accepting the default installation value or clicking Browse to
select a different location.

@ 1nstallation requires an empty destination folder.

You can restrict end users from modifying any of the preceding options. Select all/none, or
select individual options to restrict access.

Licensing options

Administrators has the ability to set the serial number or define the server settings. Use the
command line licensing switches to set the license preferences.

General options
Use the general options to set basic preferences.

You can restrict end users from modifying any of the following options. Select all/none or select
individual options to restrict access.

1. Click General.
2. Select the applicable check boxes to suit your preferences.

Use this panel to specify general settings for working with PDF files or Power PDF components,
such as Power PDF Advanced, Convert Assistant, and Create Assistant.

© These features are not supported in Power PDF Reader:
+ Launch Create Assistant at startup
+ Install PDF Convert component

3. Specify the setup type suited to your needs.

Select the first option to display only the Install Welcome, License Agreement, and Ready to
Install dialog boxes or use the radio buttons below to select Typical or Custom installation.

15
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4. Select a help installation type by clicking on one of the options:

+ Click the Online from Kofax option to access the Help from the Kofax server (internet access
required on the workstation).

+ Click the On premises option and set the correct shared location if you have already

downloaded and copied the Help files to a shared location on your server. See How to install
help for details.

5. Modify the printer port name.

© The Printer Port Name option is not supported in Power PDF Reader.

Application Integration

You can hide any of the following options from end users. Select all/none or select individual
options to hide.

1. Click Application Integration.
2. Select the desired integrations in programs and browsers.
Access in browsers depends on the selected application.

O The following options are not supported in Power PDF Reader:
+ Windows Explorer Integration

+ All options under Office application integration

*+ Firefox Integration

Windows Desktop Search Integration offers multiple choices. Indexing image-only PDF files
is a performance-sensitive choice.

Connectors

Use the Connectors group to include cloud and DMS integration in your customized installation
package.

1. Click Connectors.

The list of available connectors is displayed.
2. Mark Enable Connectors so that you can make your selections in the list.
Enable or disable each Connector by selecting the check boxes individually.

4. For each preceding integration, you can specify whether to enable end users to see them.
Select all/none or individually select integrations to hide from users.

w

Document Processing

Use the Document Processing parameters to filter the feature set for the Power PDF application.
1. Click Document Processing.

2. Select Reader mode to create a package with a predefined set of functions.

16
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O 1he options under Application Mode are not supported in Power PDF Reader.

3. When Reader mode is off, you can select features individually.
4. You can hide any of the preceding application features from end users.

Select all/none or select individual features to hide from the end user. The Reader mode and
Advanced Edit mode options are general parameters; therefore, their visibility is basically the
set of options offered by your installer.

O The following options are not supported in Power PDF Reader:
+ Auto Save

+ Bates Numbering

+ Create dynamic PDF Forms

+ Document Collaboration

+ Favorites

+ Flatten

+ Indexing PDF files

+ Optimize PDF Documents

+ Reading Order

* Redact PDF Documents

+ Remove Document Elements
+ Scan

+ Sequencer

+ Split PDF documents

+ Stationery

+ Tagging PDF documents

+ Use Clip Art

+ Watched Folder

+ Allow legacy mode image edit
+ Enable watermark

+ Read watermarks from a shared location

When Reader Mode is selected through the Customization Kit or the ISREADONLYMODE
parameter is set using command line installation, then the Power PDF Advanced application
is installed in Reader Mode for any user. However, in Citrix and Terminal Services servers, it
is possible to use Power PDF in mixed mode. See Use Power PDF Advanced in mixed-mode
(Reader mode and normal mode).

Languages

Use the Languages group to set preferences for Ul languages.

Click Languages to set the parameters of Ul languages.

17
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You can deploy more than one Ul language at the same time and select one as the active UI
language. Later, in the Option panel of the application, you can select another UI language.

+ The Default language option specifies the actual UI of the running application. Possible values:

+ Operation system language: The application automatically selects the UI language based
on the operating system language. If the OS language was not deployed, the UI language is
English.

+ Installation language: The installer sets the UI language based on the installation language
selected by the user. If the installation language was not deployed, the UI language is English.

+ Selecting the UI languages:

+ Installation language only: Only the installation language resources are deployed beside
English, which is always deployed, regardless of UI language settings.

+ All available languages: All available languages are deployed.
+ Selected languages: Select any available languages.

For command line switches related to Ul languages, see Ul languages.

Application Options

Use the Application Options panel to select which options are displayed to the end user:
1. Click Application Options.
2. Allow end users to change some options in the applications.

O The default skin type is blue in Power PDF Advanced and dark gray in Power PDF Reader.
3. Set other application options.

O The following options are not supported in Power PDF Reader:
+ Hide downloading UI languages

+ Load security settings from server

+ Modify PDF creation options

+ Show JavaScript button in the Edit tab of the ribbon

4. Use the options to enable or disable the following:
+ Requiring a reason for each signature, along with facilities to edit the text
+ Displaying fields for location and contact information
+ Allowing signatures to be revoked and shown as such
* Requiring time stamp verification of signatures

Upgrade Behavior

Use the Upgrade Behavior panel to define the application behavior in an upgrade scenario.

18
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O The Upgrade Behavior feature is not supported in Power PDF Reader.

Click Upgrade Behavior.

Under Legacy products, set the behavior for a legacy product, such as PDF Converter
Enterprise or PDF Converter Professional, currently installed on the system.

Under Previous Power PDF version, set the behavior for an earlier version currently installed
on the system.

Optional: Finalize the transform file

Now that all desired parameters are set, you can optionally create a transform file (.mst) for your
installer. To create the transform file:

1.

uswnN

Click Generate Transform in the Transform group.

Use this option to create a transform file (.mst) based on the differences between the open
package and the modifications set by you.

Select a save location.

Specify a file name.

Save your transform file.

To resume work on an already existing transform file, click Load Transform.

Add more components to the package

Finalizing the transform file (above) is optional. You can also include other files such as plug-ins in
your custom installation package.

1.
2.

Click Additional Files.
You can add/modify/remove and reorder files for your package.

Include existing application settings

To enhance propagating a shared collection of settings across your company, you can poll an
already installed and configured Power PDF for settings and include these in your deployment
package.

Available choices are determined by your Import mode selections.

+ Use default product settings: Use the default factory settings provided by a clean Power PDF
installation.

+ Use settings from the locally installed product: Use the settings of the Power PDF installation on
the computer where Customization Kit runs.

+ Browse for shared product settings: First collect settings on another computer where Power
PDF installed, then import those settings into the deployment package. See Import application
settings from another computer for details.

Make your selections under Settings to import. The selected options are stored in the installation
package.
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O i1f the Security Profile check box is marked under Import Application Settings, the application's
default Privacy and No Modification Security schemes in the Security panel are not transferred to
the customized installation. If these two schemes are required, create two new custom schemes
that are equivalent to them.

Import application settings from another computer

1. Start Customization Kit on the computer where your product installation is polled.
2. Inthe Wizard group, select Collect Application Settings Wizard.
3. Make your selections in the wizard.
The wizard only offers to collect the settings that are different from the package you opened.
4. Browse to the folder to store the collected settings.
5. Review your settings, then launch the collection process.
After a successful settings collection, you are ready to Import Application Settings.
6. Start Customization Kit on the computer where the deployment package should build.

7. Toinclude your collected settings, select the Browse for shared product settings option
under Import mode, then locate the folder where you stored the collected settings in step 4.

Finish the installation package

When the desired parameters are prepared, you are ready to publish the package for your end
users.

1. Click Publish Package in the Package group.
2. Set atarget location.

It is recommended to have an empty folder for your published package (the tool warns you of
this).

3. Select which versions you want to publish, 32-bit and/or 64-bit, and click OK.

© 10 restart constructing your package, click Reset Settings to default on the Package
group.

To access this installation guide, click Help in the Help group. To view product version
information, click About.

Client installation using command line

Kofax Power PDF Advanced supports special deployment systems such as Active Directory,
Microsoft System Management Server and System Center Configuration Manager.

The client installation procedure always requires administrative privileges and must run with a per-
computer installation context (ALLUSERS=1).
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O the suppression of the required reboot does not eliminate the need for a reboot. A required
reboot must still be performed before installing any hotfixes or using the product.

The following sections provide examples of client installation scenarios, using the following
placeholders:

« {install_path}. Replace this placeholder with the installation folder path. If you omit the
INSTALLDIR parameter, the product is installed into the default installation folder. (Installation
requires an empty destination folder.)

« {source_path}: Replace this placeholder with the source folder containing the customized .msi
package file.

In the following examples, the selected installation language is French (1036.mst). See Transform
file names by language for details.

If you do not specify a language transform file:
+ _setup.exe prompts for language selection.
* msiexec.exe installs the product in its default language (English).

Install Power PDF Advanced using command line

1. On the client computer, use Run as administrator to open a Command Prompt window.
2. Run the following command:

MsiExec.exe /i "c:\{source path}\Kofax Power PDF Advanced.msi"
INSTALLDIR="c:\{install path}"
TRANSFORMS="c:\ {source path}\1036.mst;c:\{source path}\admin customSettings.mst"
3. Ifyou saved a .mst file with Generate Transform in the Transform tab, then use one of the
following commands:
« MsiExec.exe /i "c:\{source path}\Kofax Power PDF Advanced.msi"
INSTALLDIR="C:\{install_path}"
TRANSFORMS="c:\{source path}\1036.mst;c:\{source path}\your saved transform.mst"

o+ _setup.exe /11036 /v"INSTALLDIR=\"c:\\{install path}\"
TRANSFORMS=\"c:\\{source path}\\your saved transform.mst\""

O soth setup.exe and _setup.exe elevate the installation process. Use setup.exe to trigger
the installation of prerequisites. If you use Msiexec.exe, ensure that you run Command
Prompt as administrator.

Install Power PDF Reader using command line

1. On the client computer, use Run as administrator to open a Command Prompt window.
2. Run the following command:

MsiExec.exe /i "c:\{source path}\Kofax Power PDF Reader.msi"

INSTALLDIR="c:\{install path}"

TRANSFORMS="c:\ {source path}\1036.mst;c:\{source path}\admin customSettings.mst"
3. Ifyou saved a .mst file with Generate Transform in the Transform tab, then use one of the

following commands:

« MsiExec.exe /i "c:\{source path}\Kofax Power PDF Reader.msi"
INSTALLDIR="C:\{install_path}"
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TRANSFORMS="c:\{source path}\1036.mst;c:\{source path}\your saved transform.mst"

o _setup.exe /11036 /v"INSTALLDIR=\"c:\\{install path}\"
TRANSFORMS=\"c:\\ {source path}\\your saved transform.mst\""

O Both setup.exe and _setup.exe elevate the installation process. Use setup.exe to trigger
the installation of prerequisites. If you use Msiexec.exe, ensure that you run Command
Prompt as administrator.

Client installation command line examples

The following example shows how to install Power PDF Advanced with different options. To install

the product with a basic UI and without message box on completion, use the applicable command

line:

« MsiExec.exe /i "c:\{source path}\Kofax Power PDF Advanced.msi"
INSTALLDIR="c:\{install path}" /gb

+ _setup.exe /s /v"INSTALLDIR=\"c:\\{install path}\" /gb"

Where q defines what type of UI the installation uses:
+ /qn specifies that the Ul is not displayed.
+ /qb specifies a basic interface with a progress bar.

Furthermore, (if used) a plus sign (/gb+ or /gn+) specifies that a message box is displayed when the
installation is finished.

To install Power PDF Reader with the same options as above, use one of the following commands:

¢« MsiExec.exe /i "c:\{source path}\Kofax Power PDF Reader.msi"
INSTALLDIR="c:\{install path}" /gb

e _setup.exe /s /v"INSTALLDIR=\"c:\\{install path}\" /gb"

During the installation of the application, specific installation options are available. Several
InstallShield Wizard pages walk you through the available features. These installer features cover
the different integration settings (into Microsoft Office, Windows, and Internet Explorer) and the

optional components of the product. These features are controllable via Customization Kit and/or
command line switches.

© You are also allowed to use standard MSI parameters to specify commonly used installation
parameters like USERNAME, COMPANYNAME, INSTALLDIR, and ISX_SERIALNUM.

Command line switches and features

The features and command line switches are grouped and detailed in the following topics, following
the order as the related controls appear on the user interface.

Personalization switches and options
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Set the user's name
The USERNAME property refers to the user performing the installation.
USERNAME="{your user name}"

Example:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"
USERNAME="john.doe"

+ If the USERNAME property is not set, the installer sets it automatically using values from the
registry. Set the NOUSERNAME property (NOUSERNAME="1") to prevent the automatic setting
of USERNAME.

* For Power PDF Reader, use "Kofax Power PDF Reader.msi" as the installer file name in
command line parameters.

Set the company name

The COMPANYNAME property refers to the organization or company of the user performing the
installation.

COMPANYNAME="{your company name}"

© 1f the COMPANYNAME property is not set, the installer sets it automatically using values
from the registry. Set the NOCOMPANYNAME property (NOCOMPANYNAME="1") to suppress the
automatic setting of COMPANYNAME.

Set the serial number

To set a specific serial number, use the following command line option:

ISX SERIALNUM="{your serial number}"

For example:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi" ISX SERIALNUM="{your serial
number}"

Hide or show the serial number in the Installer Wizard dialog box
Hide: EDITSN="0"
Show: EDITSN="1"

Example to hide the serial number:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi" EDITSN="0"
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© The serial number is visible by default. For Power PDF Reader, use "Kofax Power PDF
Reader.msi" as the installer file name in command line parameters.

Hide or show the serial number in the About dialog box of the
application

Hide: HIDEABOUTSN="1"

Show: HIDEABOUTSN=""

© The serial number is visible by default.

Licensing switches

The following sections detail how to set the licensing type and serial number for Power PDF.

Enable secure communication (HTTPS)

Enable: KLHTTPS="1"
Disable: KLHTTPS=""

Hide or show the serial number in the About dialog box of the
application

See Hide or show the serial number in the About dialog box of the application for details.

Hide or show the serial number in the Installer Wizard dialog box

See Hide or show the serial number in the Installer Wizard dialog box for details.

Overwrite license settings on the destination computers

Enabling this setting affects all products on the destination computer relying on Kofax Licensing
Server.

Overwrite: KLOW="1"

Not overwrite: KLOW=""

Set the licensing option

To define the licensing option, set one of the following installer property values during command
line installation:

+ User Choice:
ACTMODE="Hybrid”
+ Serial Number (Legacy):
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ACTMODE="SN"
+ Kofax License Server:
ACTMODE="LicSrv”

Set the serial number
See Set the serial number for details.
Show warning on Power PDF UI about expiring license

Enable: KLSLWE="1"
Disable: KLSLWE="0"

© The feature is enabled by default.

Specify primary Kofax License Server host name and port number

KLHOST="{hosthame_string}"
KLPORT="{port_number}"

Specify backup Kofax License Server host name and port number

KLHOSTB="{backup_hostname_string}"
KLPORTB="{backup_port_number}"

General switches

Set application as your default viewer for PDF files

On: SETDEFVIEWER="1"

Example to turn on this setting:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi" SETDEFVIEWER="1"
Off: SETDEFVIEWER=""

Example to turn off this setting:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi" SETDEFVIEWER=""

© The feature is enabled by default. For Power PDF Reader, use Kofax Power PDF Reader.msi as
the installer file name in command line parameters.
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View PDF files in Internet Explorer with Power PDF Advanced
On: ISDEFVIEWERIE="1"

Off: ISDEFVIEWERIE=""

© The feature is enabled by default.

Launch PDF Create assistant at startup
On: SSASSISTANSATSTARTUP="1"

Off: SSASSISTANSATSTARTUP=""

© The feature is disabled by default and not supported in Power PDF Reader.

Install PDF Converter component
On: SSCONVSTATE="1"

Off: SSCONVSTATE=""

© The feature is enabled by default and not supported in Power PDF Reader.

Create shortcut for Power PDF Advanced to Desktop
On: SSDESKTOPSHORTCUT="1"
Off: SSDESKTOPSHORTCUT=""

© T1he feature is disabled by default.

Delete the user settings when the product is uninstalling
On: DELUSERSETTINGS="1"
Off: DELUSERSETTINGS=""

© T1he feature is disabled by default.

Collect usage data
On: ANALYTICSI="1"
Off: ANALYTICSI="0"
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Hide the delete user settings confirmation box when the product is
uninstalling

The switch works only if Power PDF runs in basic silent mode, started with the gb or gb+ command-
line options.

If the switch is on, the message box about deleting user settings does not appear, but a progress
bar is visible during uninstallation.

For example:

msiexec.exe /x "Kofax Power PDF Advanced.msi" HIDEKEEPSETTINGMSG="1" /gb+
On: HIDEKEEPSETTINGMSG ="1"
Off: HIDEKEEPSETTINGMSG =""

© The feature is disabled by default.

Show only Install Welcome, License Agreement, and Ready To Install
dialog boxes on Setup Wizard

On: MINIMALUI="1"
Off: MINIMALUI=""

© The feature is disabled by default.

How to install help
The online help is available on the Kofax server by default. This is indicated by the following entry:
HELP_MODE="1"

The online help can also be provided by a local server alternatively. Perform the following steps to
customize the help server location:

1. Set the HELP_MODE entry to 2, indicating that custom help location must be used:
HELP_ MODE="2"

! B HELP_MODE is 2, entering a correct value for HELP_PATH_SHARED property is
mandatory.

2. Set the HELP_PATH_SHARED entry to refer to the correct Help root path on your server.
Substitute the items enclosed in curly brackets with your server parameters:

HELP_ PATH SHARED=\\{computername}\{sharedfolder}\
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O This path should lead to the root folder of the help structure, and not to any of the

language subfolders.

3. The root folder (HELP_PATH_SHARED) should have subfolders for each language. For example:
* \\{computername}\{sharedfolder}\en US

* \\{computername}\{sharedfolder}\ja JA

The offline documentation package does not include these subfolders. Create all required
language subfolders using the folder names in the following table:

Language Folder Name
Czech cs_CZ
Danish da_DK
German de_DE
English (US) en_US
Spanish es_ES
Finnish fi_FI
French fr_FR
Hungarian hu_HU
Italian it IT
Japanese ja_JA
Korean ko_KR
Dutch nl_NL
Norwegian (Bokmal) no_NO
Polish pl_PL
Portuguese (Brazilian) pt_BR
Russian ru_RU
Swedish sv_SE
Turkish tr_TR
Chinese (Simplified) zh_CHS
Chinese (Traditional) zh CHT

4. Extract the offline documentation package ("KofaxPowerPDFDocumentation_5.0.0.zip") into a
local folder. This creates a .zip file for each language.

5.

© You can download the package from the Kofax Fulfillment Site.

Identify the preferred language package file by the language code in the file name and extract

it. This creates a folder with the same name.
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6. In the extracted folder, open the "help" subfolder.

7. Copy the "PowerPDF_help" subfolder into the relevant language subfolder you created in step
3.

8. Repeat the above steps for all the required languages.
Printer port name

PDFPRINTERPORTNAME="{your port name}"

© This feature is not supported in Power PDF Reader.

Application integration switches

Windows Explorer integration
On: WINDOWSEXPLORERALL="1"
Off: WINDOWSEXPLORERALL=""

© The feature is enabled by default and not supported in Power PDF Reader.

Microsoft Word integration
On: WORDADDINALL="1"

Example:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"
WORDADDINALL="1"

Off: WORDADDINALL=""

Example:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"
WORDADDINALL=""

© The feature is enabled by default and not supported in Power PDF Reader.
Microsoft Excel integration

On: EXCELADDINALL="1"
Off: EXCELADDINALL=""

© The feature is enabled by default and not supported in Power PDF Reader.
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Microsoft PowerPoint integration
On: PPTADDINALL="1"
Off: PPTADDINALL=""

© The feature is enabled by default and not supported in Power PDF Reader.

Microsoft Outlook integration

On: OUTLOOKADDINALL="1"
Off: OUTLOOKADDINALL=""

© The feature is enabled by default and not supported in Power PDF Reader.

Internet Explorer integration
On: IEINTEGRATIONALL="1"
Off: IEINTEGRATIONALL="0"

© The feature is enabled by default.

In Kofax Power PDF Reader, the integration menu supports the Open with Power PDF Reader
command only.

Windows Desktop Search integration

Use the 'SSWDSSUPPORT ' switch to turn on/off Kofax PDF iFilter that enables the Windows Desktop
Search (WDS) integration.

On: SSWDSSUPPORT="1"
Off: SSWDSSUPPORT=""

If WDS integration is turned on, the Kofax Power PDF built-in OCR (Optical Character Recognition)
engine is used to find text on pages that contain only images. Using OCR makes indexing slower.

On: WDS_OCRNOTEXT="1"
Off: WDS_OCRNOTEXT=""

If the OCR is enabled, the e-Discovery functionality is used to discover additional text on image
objects using OCR on pages that already contain text. Using e-Discovery makes indexing slower.

On: WDS_OCRNOTEXT_EDISC="1"
Off: WDS_OCRNOTEXT_EDISC="0"
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If the OCR is enabled, you can define the first n pages which the OCR recognizes.

To define this option, set the WDS_OCRNOTEXT_ISPAGES to "1", and set the
WDS_OCRNOTEXT_NUMPAGES="number of pages".

For example:

WDS_OCRNOTEXT="1"
WDS_OCRNOTEXT_ISPAGES="1"
WDS_OCRNOTEXT_NUMPAGES="10"

The application runs OCR on the first 10 pages.

© windows Desktop Search Integration features are disabled by default.

Connector switches

Enable/Disable all connectors

On: ISINSTALLCONNECTORS="1"
Off: ISINSTALLCONNECTORS=""

Box
On: NUCONN_BOX="1"
Off: NUCONN_BOX=""

DocuShare

On: NUCONN_DOCUSHARE="1"
Off: NUCONN_DOCUSHARE=""

Dropbox
On: NUCONN_DROPBOX="1"
Off: NUCONN_DROPBOX=""

EMCDocumentum

On: NUCONN_EMCDOCUMENT="1"
Off: NUCONN_EMCDOCUMENT=""
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Enterprise Connect
On: NUCONN_EC="1"
Off: NUCONN_EC=""

(i B Enterprise Connect Framework version 16.2 and earlier, it is possible to enable opening
and saving files from Enterprise Connect (EC) in Power PDF through the File > Open and File >
Save As dialog boxes directly, without the use of the EC connector. To enable direct open and
save, append your PDF application executable file name to Enterprise Connect's registry value,
separated by a comma.

In case of Power PDF Advanced, edit the following key:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Open Text\Enterprise Connect\
ExtendedIntegrationSupportedApplications=[ExistingValue,]JPowerPDF.exe

In case of Power PDF Reader, edit the following key:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Open Text\Enterprise Connect\

ExtendedIntegrationSupportedApplications=[ExistingValue,]PowerPDFRd.exe

+ With EC Framework 16.2 version and later, this registry value change is not needed.

+ Saving documents opened directly through the File > Open dialog boxes to the EC connector
is handled as a new document upload, not as a new version save. This is intentional, to avoid
issues with the synchronization process of EC.

Evernote
On: NUCONN_EVERNOTE="1"
Off: NUCONN_EVERNOTE=""

eDOCS

On: NUCONN_EDOCS="1"
Off: NUCONN_EDOCS=""

© 17 eDOCS is disabled, two other properties are also turned off to ensure correct application
behavior. These properties are NUCONN_EDOCS_ADDINX and ISENABLEHBADDINOPTIONX.

eDOCS addin-in registration

On: NUCONN_EDOCS_ADDINX="1"
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Off: NUCONN_EDOCS_ADDINX=""

Google Drive
On: NUCONN_GD="1"
Off: NUCONN_GD=""

HP Trim

On: NUCONN_HPTRIM="1"
Off: NUCONN_HPTRIM=""

iManage10
On: NUCONN_IMANAGE10="1"
Off: NUCONN_IMANAGE10=""

O ror details, see iManage connector and server configuration.

iManage Work
On: NUCONN_IMANAGE="1"
Off: NUCONN_IMANAGE=""

O if iManage Work is turned off, two other properties are also turned off to ensure
correct application behavior. These properties are NUCONN_IMANAGE_ADDINX and
ISENABLEIMANADDINOPTIONX.

iManage Work addin-in registration

On: NUCONN_IMANAGE_ADDINX="1"
Off: NUCONN_IMANAGE_ADDINX=""

NetDocuments

On: NUCONN_NETDOCUMENTS="1"
Off: NUCONN_NETDOCUMENTS=""

OnBase

On: NUCONN_ONBASE="1"
Off: NUCONN_ONBASE=""
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OneDrive
On: NUCONN_ONEDRIVE="1"
Off: NUCONN_ONEDRIVE=""

SharePoint
On: NUCONN_SHAREPOINT="1"
Off: NUCONN_SHAREPOINT=""

Worldox
On: NUCONN_WORLDOX="1"
Off: NUCONN_WORLDOX=""

© All connectors are disabled by default.

Document processing switches

Reader mode

On: ISREADONLYMODE="1"
Off: ISREADONLYMODE=""

© The feature is disabled by default and not supported in Power PDF Reader.

Limited reader mode
On: ISLIMITEDREADONLYMODE="1"
Off: ISLIMITEDREADONLYMODE=""

© The feature is disabled by default and not supported in Power PDF Reader.

Advanced edit mode

On: ISDISABLEWRITEMODE=""
Off: ISDISABLEWRITEMODE="1"

© The feature is enabled by default and not supported in Power PDF Reader.
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Auto save
On: ISINSTALLAUTOSAVE="1"

Off: ISINSTALLAUTOSAVE="0"

© The feature is enabled by default and not supported in Power PDF Reader.

AutoStore
On: NUAUTOSTORE="1"

Off: NUAUTOSTORE=""

© The feature is disabled by default.

Bates numbering
On: ISINSTALLBATESSTAMP="1"

Off: ISINSTALLBATESSTAMP="0"

© The feature is enabled by default and not supported in Power PDF Reader.

CaseMap support
On: ISINSTALLCASEMAP="1"
Off: ISINSTALLCASEMAP=""

© The feature is enabled by default.

Create comments summary
On: ISINSTALLCOMMENTPRINT="1"
Off: ISINSTALLCOMMENTPRINT=""

© The feature is enabled by default.

Create dynamic forms

On: ISINSTALLFORMTYPER="1"
Off: ISINSTALLFORMTYPER=""
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© The feature is enabled by default and not supported in Power PDF Reader.

Document collaboration
On: ISDISCOLLABORATION="0"
Off: ISDISCOLLABORATION="1"

© The feature is enabled by default and not supported in Power PDF Reader.
Online collaboration

On: ISDISCOLLABORATIONONLINE="0"
Off: ISDISCOLLABORATIONONLINE="1"

© The feature is enabled by default and works only if Document collaboration is also enabled.

For details on preparing for online collaboration, see Collaboration Server configuration.

This feature is not supported in Kofax Power PDF Reader.

DRM security - FileOpen support
On: NUFILEOPEN="1"
Off: NUFILEOPEN=""

© The feature is enabled by default.

Export/Import/Migrate comments
On: ISEXPORTCOMMENTS="1"
Off: ISEXPORTCOMMENTS=""

© The feature is enabled by default.
Favorites

On: ISINSTALLFAVOURITES="1"
Off: ISINSTALLFAVOURITES="0"

© The feature is enabled by default and not supported in Power PDF Reader.
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Fax via E-mail
On: NUFAXVIAEMAIL="1"
Off: NUFAXVIAEMAIL=""

© The feature is enabled by default.

File storage options
On: NUFILESTORAGE="1"
Off: NUFILESTORAGE=""

© The feature is enabled by default.

Flatten

On: ISFLATTENENABLE="1"
Off: ISFLATTENENABLE=""

© The feature is enabled by default and not supported in Power PDF Reader.

Full form handling - not just filling, except Highlighting and reset form
On: ISFORMTOOLENABLE="1"

Off: ISFORMTOOLENABLE=""

© The feature is enabled by default.

Imposition
On: ISINSTALLIMPOSITION="1"
Off: ISINSTALLIMPOSITION="0"

© The feature is enabled by default.

Indexing PDF files

On: ISINSTALLCATALOG="1"
Off: ISINSTALLCATALOG="0"
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© The feature is enabled by default and not supported in Power PDF Reader.

Measurement tools
On: ISMEASURETOOL="1"

Off: ISMEASURETOOL=""

© The feature is enabled by default.

Microsoft Rights Management Services
On: ISINSTALLRMS="1"

Off: ISINSTALLRMS="0"

© The feature is enabled by default.

Optimize PDF documents
On: ISINSTALLOPTIMIZE="1"
Off: ISINSTALLOPTIMIZE=""

© The feature is enabled by default and not supported in Power PDF Reader.

PDF document comparison
On: ISINSTALLCOMPAREDOC="1"
Off: ISINSTALLCOMPAREDOC="0"

© The feature is enabled by default.

Read aloud
On: READALOUD="1"
Off: READALOUD=""

© The feature is enabled by default.
Reading order

On: ISREADINGORDER="1"
Off: ISREADINGORDER=""
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© The feature is enabled by default and not supported in Power PDF Reader.

Redact PDF documents

On: ISCONTAINREDACTION="1"
Off: ISCONTAINREDACTION="0"

© The feature is enabled by default and not supported in Power PDF Reader.

Remove document elements

On: ISINSTALLEXAMINEDOC="1"
Off: ISINSTALLEXAMINEDOC="0"

© The feature is enabled by default and not supported in Power PDF Reader.

Scan
On: NUSCAN="1"
Off: NUSCAN=""

© The feature is enabled by default and not supported in Power PDF Reader.

Scan inbox
On: NUINBOXMONITOR="1"
Off: NUINBOXMONITOR=""

© The feature is enabled by default.

Security and digital signature
On: ISINSTALLDIGSIGN="1"
Off: ISINSTALLDIGSIGN="0"

© The feature is enabled by default.
Self-signed digital ID creation

On: NUSELFSIGNEDID="1"
Off: NUSELFSIGNEDID=""
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© The feature is enabled by default.

Sequencer

On: ISBATCHPROCESSING="1"
Off: ISBATCHPROCESSING=""

© The feature is enabled by default and not supported in Power PDF Reader.

Sign PDFs with DocuSign
On: NUDOCUSIGN="1"
Off: NUDOCUSIGN=""

© The feature is disabled by default.

Sign PDFs with SignDoc

Use the property NUSIGNDOC to enable/disable the SignDoc support.
On: NUSIGNDOC="1"

Off: NUSIGNDOC=""

© The feature is enabled by default.

SignDoc server location

Use the property SIGNDOCURL to set the location of the SignDoc server. You can push this with the
user macro with the following syntax:

SIGNDOCURL="\\ {Computer name}\{folderl}\{folder2}\"
© The value must be a valid server address and available from the user's computer.
Trust SignDoc and root certificates

On: NUINSTTRUSTCERTS="1"
Off: NUINSTTRUSTCERTS=""

© The feature is enabled by default.
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Signing and time stamping documents
On: ISDISABLESIGNATURE="0"

Off: ISDISABLESIGNATURE="1"

(i) The feature is enabled (0) by default.

Spell checker
On: ISINSTALLSPELLCHECK="1"

Off: ISINSTALLSPELLCHECK="0"

© The feature is enabled by default.

Split PDF documents
On: ISINSTALLPDFCHUNKER="1"

Off: ISINSTALLPDFCHUNKER="0"
© The feature is enabled by default and not supported in Power PDF Reader.
Stationery

On: NUSTATIONERY="1"
Off: NUSTATIONERY=""

© T1he feature is disabled by default and not supported in Power PDF Reader.

Tagging PDF documents

On: ISINSTALLRETAG="1"
Off: ISINSTALLRETAG=""

© The feature is enabled by default and not supported in Power PDF Reader.
Use Clip Art

On: ISINSTALLCLIPART="1"
Off: ISINSTALLCLIPART="0"

41



Kofax Power PDF Network Installation Guide

© The feature is enabled by default and not supported in Power PDF Reader.

Watched folder

On: ISINSTALLWATCHEDFOLDER="1"
Off: ISINSTALLWATCHEDFOLDER=""

© The feature is enabled by default and not supported in Power PDF Reader.

Allow legacy mode image edit

Set this parameter to "0" to enable only the Edit Object button and hide the Edit Text button, so the
user needs to click twice to activate text editing on text blocks. Selecting the Allow legacy mode
image edit option on the Document Properties page in the Customization Kit results in the same as
setting the ISTOUCHUPNEWSTYLE parameter to "0".

On: ISTOUCHUPNEWSTYLE="1"
Off: ISTOUCHUPNEWSTYLE="0"

© The feature is enabled by default and not supported in Power PDF Reader.

Read stamps from a shared location

The STAMPCOMMONLOC property contains the location of stamps.
On: STAMPCOMMONLOC="\\ {server}\{folderl}\..."
Off: STAMPCOMMONLOC=""

© The feature is disabled by default.

Enable watermarks
On: ISINSTALLWATERMARK="1"
Off: ISINSTALLWATERMARK="0"

© The feature is enabled by default and not supported in Power PDF Reader.

Read watermarks from a shared location

The WATERMARKCOMMONLOC property contains the location of watermarks.
On: WATERMARKCOMMONLOC="\\ {server}\{folderl}\..."

Off: WATERMARKCOMMONLOC=""
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© The feature is disabled by default and not supported in Power PDF Reader.

UI languages

Installation language only: If the value of the property NUUSERLANGUI is 0, the installer deploys
the installation language and the English language. The installation language is selected as the
default UI language.

This example deploys French and English UI languages. The application uses French by default:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"
NUUSERLANGUI="0" TRANSFORMS="1036.mst"

This example deploys only English Ul language. The application uses English by default:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"
NUUSERLANGUI="0"

All available languages: If the value of NUUSERLANGUI property is 1, the installer deploys all the
available UI languages. The default UI language of the application is the installation language.

This example deploys all the UI languages. The application uses French by default:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"
NUUSERLANGUI="1" TRANSFORMS="1036.mst"

This example deploys all the UI languages. The application uses English by default:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"
NUUSERLANGUI="1"

Selected languages: If the value of the property NUUSERLANGUI is 2, the installer deploys all the
command line defined Ul languages. The default UI language of the application is the installation
language.

The supported languages and the command line options are indicated in the following table.

Command line options of UI languages

Language Option
Chinese (traditional) NUCHTUI
Chinese (simplified) NUCHSUI
Czech NUCZHUI
Danish NUDANUI
Dutch NUDUTUIL
English NUENGUI
Finnish NUFINUI
French NUFREUI
German NUGERUI
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Language Option
Hungarian NUHUNUI
Italian NUITAUI
Japanese NUJPNUI
Korean NUKORUI
Norwegian NUNORUI
Polish NUPOLUI
Portuguese (Brazil) NUBRAUI
Russian NURUSUI
Spanish NUSPAUI
Swedish NUSWEUI
Turkish NUTURUI

The following example deploys 4 UI languages: English, Chinese (Simplified), Spanish and German.
The installation language is German. The default Ul language is also German because DEFUILANG
(see below) is not defined.

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"

NUUSERLANGUI="2" NUENGUI="1" NUCHSUI="1" NUSPAUI="1" NUGERUI="1"
TRANSFORMS="1031.mst"

i ) By default, the value of NUUSERLANGUI is 0. For Power PDF Reader, use the Kofax Power PDF
Reader.msi as the installer file name command line parameter.
Default UI language

The DEFUILANG property used to specify the default Ul language of the application. The possible
values are:

DEFUILANG="auto"

When starting, the application automatically selects the Ul language based on the OS language. If
the OS language was not deployed, the Ul language is English.

DEFUILANG=""

The installer sets the Ul language based on the installation language selected by the user. If the
installation language was not deployed, the UI language is English. This is the default value.

The following example deploys 4 UI languages, English, Chinese (Simplified), Spanish, and German.

The installation language is German. The default UI language is depending on the OS of the client
computer.

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi"
NUUSERLANGUI="2" NUENGUI="1" NUCHSUI="1" NUSPAUI="1" NUGERUI="1"
TRANSFORMS="1031.mst" DEFUILANG="auto"
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0 For Power PDF Reader, use Kofax Power PDF Reader.msi as the installer file name in command
line parameters.

Application options

Color skins

Set the SKINTYPE command line switch:
+ 1:Dark Gray

+ 2:Light Gray

+ 3:Blue

« 4:Purple

Example:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi" SKINTYPE=3

O The default skin type is blue in Power PDF Advanced and dark gray in Power PDF Reader. For
Power PDF Reader, use Kofax Power PDF Reader.msi as the installer file name in command line
parameters.

Allow running JavaScript
On: OPT_JS_ALLOWRUN="1"
Off: OPT_JS_ALLOWRUN="0"

© The feature is enabled by default.

Allow JavaScript in documents with trusted certificates
On: OPT_JS_ALLOWRUN_TRUSTCERT="1"
Off: OPT_JS_ALLOWRUN_TRUSTCERT="0"

O the setting only comes into effect if the "Allow running JavaScript" feature is disabled. This
feature is disabled by default.

Maintain revisions
On: SAVEREVISIONS="1"
Off: SAVEREVISIONS="0"

© The feature is enabled by default.
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Show splash window
On: ISSHOWSPLASHSCREEN="1"

Off: ISSHOWSPLASHSCREEN="0"

© The feature is enabled by default.

Show start screen
On: ISSHOWSTARTSCREEN="1"

Off: ISSHOWSTARTSCREEN="0"

© The feature is enabled by default.

Use select tool as default instead of hand tool
On: ISUSESELECTTOOL="1"

Off: ISUSESELECTTOOL=""

© T1he feature is disabled by default.

Make comment tools persistent
On: ISCOMMENTTOOLPERSISTENT="1"
Off: ISCOMMENTTOOLPERSISTENT=""

© The feature is enabled by default.

Restore last view settings when reopening documents
On: ISRESTORELASTVIEW="1"
Off: ISRESTORELASTVIEW=""

© The feature is enabled by default.

Allow user to disable/enable eDOCS connector

On: ISENABLEHBADDINOPTION="1"
Off: ISENABLEHBADDINOPTION=""
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© The feature is disabled by default.

Allow user to disable/enable iManage connector

On: ISENABLEIMANADDINOPTION="1"
Off: ISENABLEIMANADDINOPTION=""

© The feature is disabled by default.

Allow user to disable/enable JavaScript
On: OPT_JS_DISABLEALLOWRUN="1"
Off: OPT_JS_DISABLEALLOWRUN="0"

© The feature is enabled by default.

Hide downloading UI languages
On: ISHIDEADDLANGUAGE="1"
Off: ISHIDEADDLANGUAGE="0"

Load security settings

© T1he feature is disabled by default and not supported in Power PDF Reader. Allow user to
disable/enable the Load security settings option in the application.

On: ISSHOWLOADSECOPTION="1"
Off: ISSHOWLOADSECOPTION=""

Maintain Revisions

Allow user to disable/enable Maintain Revisions in the application.
On: ISSHOWREVOPTION="1"

Off: ISSHOWREVOPTION="0"

© The feature is enabled by default and not supported in Power PDF Reader.

Allow user to modify PDF creation options

Turn this feature off if you want to deploy read-only PDF printer settings and Create Assistant
profiles.



Kofax Power PDF Network Installation Guide

On: ISDRIVERMODIFIABLE="1"
Off: ISDRIVERMODIFIABLE=""

© The feature is enabled by default and not supported in Power PDF Reader.
Allow user to disable/enable the View Documents in Internet Explorer
option
On: ISENABLEIEPDFVIEWOPTION="1"
Off: ISENABLEIEPDFVIEWOPTION=""

© The feature is enabled by default.

Windows Desktop Search

Allow user to disable/enable Windows Desktop Search integration in the application.
On: ISENABLEWDSOPTION="1"
Off: ISENABLEWDSOPTION=""

© The feature is enabled by default.

Show JavaScript button on the Edit tab of the ribbon
On: OPT_JS_SHOWBUTTON="1"
Off: OPT_JS_SHOWBUTTON="0"

© The feature is enabled by default and not supported in Power PDF Reader.

Show next file and previous file in the File menu
On: ISINSTALLVIEWFOLDER="1"
Off: ISINSTALLVIEWFOLDER="0"

© The feature is enabled by default.
Show Open Revisions and Save Revisions in the File menu

On: FILE_REVISION="1"
Off: FILE_REVISION="0"
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© The feature is enabled by default.

Show Recent Documents and Recent Places in the File menu
On: FILE_RECENT="1"
Off: FILE_RECENT="0"

© The feature is enabled by default.

Show Revert File in the File menu
On: FILE_REVERT="1"
Off: FILE_REVERT="0"

© The feature is enabled by default.

Page display options

Set the OPT_ PAGEVIEW_LAYOUT command line switch:
* 1: Automatic

+ 2:SinglePage

* 3: Continuous

* 4: ContinuousFacing

* 5:Facing

Set the OPT_ PAGEVIEW_ZOOM command line switch:
* 6: Automatic

+ 5:FitVisible

+ 4: FitHeight

+ 3: Fitwidth

+ 2:FitPage

+ 1:ActualSize

* 8192:12.5 percent

* 16384: 25 percent

* 32768: 50 percent

* 49152: 75 percent

* 65536: 100 percent
+ 81920: 125 percent
* 98304: 150 percent
* 131072: 200 percent
* 262144: 400 percent
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* 524288: 800 percent

+ 1048576: 1600 percent
* 2097152: 3200 percent
* 4194304: 6400 percent

Example:

MSIEXEC.EXE /i "[full path]\Kofax Power PDF Advanced.msi" OPT PAGEVIEW LAYOUT=3,
OPT_ PAGEVIEW ZOOM=65536

© The default value for pageview layout is automatic (value=1) and for pageview zoom is also
automatic (value=6). For Power PDF Reader, use Kofax Power PDF Reader.msi as the installer file
name in command line parameters.

Load trusted certificates from a Kofax EUTL server
On: ISLOADEUTL="1"
Off: ISLOADEUTL="0"

© The feature is enabled by default.

Load certificates for eIDAS compliant qualified services only

On: ISLOADEUTLEIDAS="1"
Off: ISLOADEUTLEIDAS="0"

© The feature is enabled by default.
Signature switches

Allow the use of self-signed certificates during signature verification
On: SEC_SELFSIGNED_VALIDATE="1"
Off: SEC_SELFSIGNED_VALIDATE="0"

© The feature is enabled by default.
Allow the creation and use of self-signed certificates for signing

On: SEC_SELFSIGNED_CREATEANDSIGN="1"
Off: SEC_SELFSIGNED_CREATEANDSIGN="0"

© The feature is enabled by default.
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Signature appearance switches

The following switches affect the controls in the Creation and Appearance Preferences dialog box
in Power PDF. To open the dialog box, click Options on the File menu, select the Signatures tab,
then click More under Creation & Appearance.

Require Signing Reason

Selects the Require Signing Reason and Show Reasons check boxes in the application.
On: OPT_SIGN_REQUIREREASON="1"

Off: OPT_SIGN_REQUIREREASON=""

© The feature is disabled by default.

Disable Signing Reason-related controls

Disables the Require Signing Reason and Show Reasons check boxes in the Creation and
Appearance Preferences dialog box. Also disables the Edit Reasons combo box in the Sign
Document dialog box.

On: OPT_SIGN_DISABLEREASONS="1"
Off: OPT_SIGN_DISABLEREASONS=""

© The feature is disabled by default.
Show location and contact information
Selects the Show location and contact information check box in the application.

On: OPT_SIGN_LOCATION="1"
Off: OPT_SIGN_LOCATION=""

© T1he feature is disabled by default.
Disable the Show location and contact information check box
Disables the Show location and contact information check box in the application.

On: OPT_SIGN_DISABLELOCATION="1"
Off: OPT_SIGN_DISABLELOCATION=""

© The feature is disabled by default.

Include signature's revocation status

Selects the Include signature's revocation status check box in the application.
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On: OPT_SIGN_REVOCSTATUS="1"
Off: OPT_SIGN_REVOCSTATUS=""

© The feature is disabled by default.
Disable the Include signature's revocation status check box
Disables the Include signature's revocation status check box in the application.

On: OPT_SIGN_DISABLEREVOCSTATUS="1"
Off: OPT_SIGN_DISABLEREVOCSTATUS=""

© The feature is disabled by default.
Require time stamp information
Selects the Require time stamp information check box in the application.

On: OPT_SIGN_TSINFO="1"
Off: OPT_SIGN_TSINFO=""

© The feature is disabled by default.
Disable the Require time stamp information check box
Disables the Require time stamp information check box in the application.

On: OPT_SIGN_DISABLETSINFO="1"
Off: OPT_SIGN_DISABLETSINFO=""

© T1he feature is disabled by default.

Online Collaboration server URL
Sets the server URL for the online collaboration server.

COLLABONLINESERVER="{collaboration_server_url_string}"

© The feature is not supported in Power PDF Reader.

Upgrade behavior
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Set the behavior if legacy product was installed to the system

Ask the user: UPGLEGACY=""
Remove without any question: UPGLEGACY="1"

Keep without any question: UPGLEGACY="2"

© The default behavior is "Ask the user". This feature is not supported in Power PDF Reader.

Remove previous Kofax Power PDF without question
On: UPGNOQUESTION="1"
Off: UPGNOQUESTION=""

© The feature is disabled by default.

Keep installer settings of the previously installed Kofax Power PDF
On: UPGKEEP="1"

Off: UPGKEEP=""

© The feature is enabled by default.

Other switches

Use shared watermarks

Allows using shared watermarks within the deployed printer settings.
On: USESHAREDWTM="1"

Off: USESHAREDWTM=""

Scan to Desktop

Use the property S2DFILEPATH for Scan to Desktop in manual mode. You can push this with the user
macro with the following syntax:

S2DFILEPATH="\\ {Computer name}\Inboxes\{user}"
0 The parameter for {user} must be entered. When the scan inbox is accessed, {user} is

automatically replaced with the name of the person logged in to Windows and points to their
inbox.
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You cannot use this variable in conjunction with S2DSERVER or S2DSUBDIR.

Use the S2DSERVER property with ShareScan in "home directory" mode. The value must be a
valid server address that contains the home directory information for the ShareScan users. If you
use home directories, entering a value for S2DDSERVER is mandatory, but entering a value for
S2DSUBDIR is optional.

S2DSERVER="\\{Server name}"

The S2DSUBDIR property must match the value for ShareScan "home directory" mode. This is an
optional value.

S2DSUBDIR="\\{folder name}"

© command line installation parameters always overwrite .mst file settings.

Client installation using Active Directory

Active Directory is a feature of Microsoft Windows servers. Group Policy (GPO), a component of
Active Directory, includes a Software Installation snap-in that enables an administrator to create a
network installation. The administrator can install software to Windows clients. The administrator
cannot use the snap-in to install to clients with older versions of the Windows operating system.

Active Directory supports three main installation scenarios: Publish to Users, Assign to Users and
Assign to Computers.

+ Publish to Users adds the product to the list of installed programs that the user can access from
the Control Panel. The program is not installed until the user selects to add it.

+ Assign to Users adds a program shortcut to the user's Start menu and Desktop, and to the list of
installed programs that the user can access from the Control Panel.

+ Assign to Computers installs the software on the computer during the next computer reboot.

Power PDF Advanced supports the Assign to Computers scenario and installs the software when the
computer is rebooted. The installation takes place silently, and the software is installed for all users
on the computer.

© pPower PDF Advanced does not support the Publish to Users or Assign to Users scenarios.

Active Directory also supports ZAP files as a mechanism for installing programs that are not
compatible with the Microsoft Windows Installer. Because Power PDF Advanced is Windows Installer
compatible, ZAP files are not necessary.

Deployment example (installation in existing organizational units)

+ A deployment target computer that is a member of a domain, site, or organizational unit.
+ MSI 3.1 installed on the target (client) computer.
+ A working Active Directory environment.

+ Installer ready for deployment on a shared network location including the previously created
transform file. This file must contain at least the serial number of the product. See Customization
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Kit. About the language-specific transform files in the case of a multi-language setup package,
see Transform file names by language.

N

10.

1.

12.

oukwbh-=

Select Control Panel > Administrative Tools > Active Directory Users and Computers.
Right-click the site, domain, or organizational unit that contains the deployment computer.
Select Properties, click the Group Policy tab, and then click New.

Specify a descriptive name.

Click Edit.

In the Group Policy window, right-click Computer Configuration > Software Settings >
Software Installation.

Click New, and then click Package.
Select Advanced Published or assigned.
Click OK.

Select the right .msi package. Remember, different .msi package files must be used on 32- and
64-bit systems.

« Use Kofax Power PDF Advanced.msi for Power PDF Advanced.
+ Use Kofax Power PDF Reader.msi for Power PDF Reader.

Select the Modifications tab, click Add when the Properties dialog box appears, and select the
transform files with the modifications. In the case of a multi-language setup package, do not
forget the relevant language transform file.

Click OK.

Active Directory is ready to install the product on client computers.

Client uninstallation

1.
2.
3.

Select the package Power PDF Advanced from Software settings > Software installation.
Right-click and select All tasks > Remove.

Select Immediately uninstall the software from users and computers.

All integration entries are removed.

© 11 2 Windows Server 2012 Active Directory environment, removal of Kofax Power PDF
Advanced from client computers may fail. If this happens, use Startup or Shutdown scripts
with the following command included:

MsiExec.exe /x{PRODUCTCODE} /gb

Group Policy settings

Group Policy settings for computer and user configurations are available in the Administrative
template provided with Power PDF. The template is available in the Tools\Group Policy
Templates folder in the distribution media of Power PDF Advanced, both in classic (ADM) and new
(adml/adml) formats. Use the Local Group Policy Editor to configure these settings by editing Group
Policy Objects. Both templates contain detailed explanations in English for each setting.

These policies are already installed and running control features, UI elements, and application
options related to Power PDF Advanced.
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O when using policy settings to hide buttons on the ribbon, consider that some buttons display
dependent on the application state or context.

© The Administrative template and the Customization Kit share most settings, but these tools are
not equivalent.

+ Some of the features cannot be enabled in the Administrative template if they were not enabled
before, during customization and installation.

+ Reader mode is connected to the Customization Kit and becomes definitive by the installation
process, so Reader mode cannot be enabled in the Administrative template.

Installation under Citrix Metaframe or Remote Desktop
Services (formerly Terminal Services)

uiewbh=

Log in as an administrator.

Browse the setup.exe of Power PDF Advanced from the installation media.
Follow the instructions in the InstallShield Wizard.

When the installation is complete, click the Finish button.

Log off, then log on again to complete the installation and to enable the proper functioning of
various components.

Publish application

To publish product to client computers, follow the steps below:

1.

2.
3.

bl

o

10.

In the Windows Start menu, select Citrix > Management Consoles > Presentation Server
Console.

Log on to the Server Farm.

Right-click Applications and select Publish Applications (Ctrl + P). The Application Publishing
Wizard launches.

Specify the Display Name and Application Description and click Next .
Select the Application option and click Next.

Under the Command line box, click Browse and locate the Power PDF Advanced executable as
installed on the server, and click Next.

Select the servers that the Power PDF Advanced product runs on and click Next.
Specify the group of users whom you want to publish the application to and click Next.
Configure the appearance and location of the application shortcut and click Next.

Click Finish to publish the application or select Configure advanced application settings now
to modify advanced options like Access control, File type associations, Limit of instances to run,
Client options (such as encryption), and Application appearance (such as display size and color
quality).
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When you are finished, the published application becomes available under the Citrix Program
Neighborhood on the client computers. If the application icon is not displayed there, double-click
the Application Set Manager icon, then click Find New Application Set and follow the instructions in
the wizard.

Use Power PDF Advanced in mixed-mode (Reader mode and
normal mode)

© This feature is not supported in Power PDF Reader.

In Citrix and Terminal Services servers, it is possible to use Power PDF in mixed-mode. This means
that one group of users can use Power PDF in Reader mode, while other users can use the same
installation in normal mode. To configure the mode, Power PDF must be installed without Reader
mode set, and for those users that need Reader mode, the following DWORD type registry value
must be set:

HKEY_CURRENT_USER\SOFTWARE\Kofax\PDF\V1
ReaderMode=1

Access the installed product from clients

The following commands give you an example on how to access Power PDF Advanced from Citrix
clients:

1. Have an installed Citrix client on the user computer.
2. Start Citrix MetaFrame Program Neighborhood.

3. Double-click Application Set Manager.
4

. Create an ICA connection: double-click Custom ICA Connection, then double-click Add ICA
connection.

Select the type of connection and click Next.
Enter a description for the connection and select the appropriate network protocol. Click Next.

7. Select to connect to the server, or to a published application. Change the defaults for
encryption level and session reliability if you wish. Click Next.

8. Specify User Name, Password and Domain. Click Next.
9. Set the window color and size and click Next.
10. Browse to PDF application and the Working Directory. Click Next, then Finish.

11. To launch the application, double-click the application icon in the MetaFrame Program
Neighborhood window.

o v
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Uninstallation

To uninstall the PDF application, follow the steps below:

1.

Log in to the Remote Desktop Services or the Citrix server as an administrator.

2. Go to Add/Remove programs.

vk w

Select the PDF application.

Click Remove.

The server may require a system restart. If so, click Yes.
This removes all integration entries.
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Microsoft App-V virtualization

This section describes how to sequence a Power PDF package and what additional installations
are needed on the client computer. This guide shows how to integrate with Microsoft Office
applications when Office is virtualized in another package.

Power PDF 5.0.0 is tested with Microsoft App-V for Windows 10, Version 2004.

Virtualize Microsoft Office with Office Deployment tool

1.

oukscwNh

10.
11.
12.

13.
14.

Download the Office Deployment Tool from Microsoft: https://www.microsoft.com/en-us/
download/details.aspx?id=49117

Extract the .odt files.
Launch the downloaded .exe file.
Accept the EULA and click Continue.

Browse for a folder where the files of the Office Deployment Tool are extracted, and click OK.

Open and edit Configuration.xml with Notepad from the folder where you extracted the .odt
files.

Change the content to the following:

<Configuration>

<Add OfficeClientEdition="32">
<Product ID="0365ProPlusRetail">
<Language ID="en-us"/>
</Product>

</Add>

</Configuration>

Change 32 to 64 if 64-bit office is needed.

Change en-us to the desired language code.

Save the .xml file.

Launch a Command Prompt (cmd.exe) with administrator rights (Run as Administrator).
Type the following line into the Command Prompt:

{path}\setup.exe" /packager "{path}\Configuration.xml" "{output path}
Replace {path} and {output path} with the actual paths, then press Enter.

Wait until the package is downloaded and converted, which may take several minutes.
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O 1he following Microsoft Knowledge Base also describes how to deploy Microsoft Office
2013 using App-V 5.1: https://technet.microsoft.com/en-us/itpro/mdop/appv-v5/deploying-

microsoft-office-2013-by-using-app-v51

Sequence Power PDF

Before sequencing Power PDF, perform the prerequisite steps in Prepare computer for sequencing.

Prepare computer for sequencing

1.
2.

Ve NNU A

10.

11.
12.

Prepare a clean computer.

Install Microsoft .NET Framework 4.8 full version. It can be downloaded from Microsoft: https://
dotnet.microsoft.com/download/dotnet-framework/net48 or can be found in the Prerequisites

folder on the Power PDF installation media.

Select Windows update from Start menu, and then download and install all recommended
updates.

Stop Windows Defender.

Go to Control Panel, change to Small icons view, and click Windows Defender.
In Tools > Options > Administrator, clear the Use this program option.

On Windows 10, click Settings then turn off Real-time protection.

Stop Windows Search.

Select Control Panel > Administrative tools > Services, and browse to Windows Search
Service. Click Stop.

Disable Automatic Windows Update.

Search for "Update" in the Start menu, and then click Check for updates. Click Advanced
Options and use the Pause Updates switch to turn off updates.

Install Microsoft App-V Sequencer.
Reboot the computer.

Sequence Power PDF as a plugin for Office 2016

ouhswh-=

Launch the Microsoft Application Virtualization Sequencer.

Click Create a New Virtual Application Package.

Select Create Package, and click Next.

Resolve issues that are listed in the Prepare Computer dialog box. Click Next.
Select the Add-on or Plugin radio button, click Next.

Install Power PDF.

Under the Select the installer for the application box, click Browse and locate Setup.exe in

Kofax Power PDF Advanced installation media and install Power PDF.
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7.
8.
o.
10.

11.
12.

13.

14.

15.

16.

17.
18.

19.

20.

O1is possible to use either the original build or an installer package that you already
customized and Published using the Customization Kit.

Expand the Office App-V Package: Click Expand Package. Wait until the package is expanded.
Select the I have installed the primary parent program check box and click Next.

Enter a name you prefer, such as PowerPDF as the package name. Avoid spaces. Click Next.
Go through the Power PDF Advanced Volume installer steps:

+ Select language.

+ Click Start installation.

+ Accept the EULA and select the activation type.

+ If you select Activate with legacy serial number, Power PDF prompts you for the serial
number.

« If you select Activate with Kofax License Server, prompts you for the name or IP
address of the computer running Kofax License Server.

+ Select Custom install, make necessary customization.

+ In the Destination folder step, make sure that the destination folder is the same as you
defined in the App-V sequencer.

+ Complete the installation.
Select the I am finished installing check box and click Next.

Click Next in the Installation Report dialog box. The Installation report can report errors such
as Printer driver detected, Files excluded from package, or Unsupported shell extension detected.

Select the Customize radio button, click Next.

Run and close applications one by one in the Prepare for Streaming dialog box, then click
Next. If the Terminate child processes dialog box appears, click Yes to close the background
processes.

Select Allow this package to run on any operating system and click Next.

Select Continue to modify package without saving using the package editor and click
Next.

Click Close in the Package completed step.

In the Microsoft Application Virtualization Sequencer, select the Virtual Registry tab and

update the following keys:

+ Add the Registry\Machine\Software\Google\Chrome\NavigateMessagingHosts
\com.kofax.html2pdf key with the following content:
[{ProgramFilesX86}]\Kofax\Power PDF 50\bin\SChromeExtn\com.kofax.html2pdf.json

+ Select the Registry\User\[{AppVCurrentUserSID}\Software\Kofax key and right click. Select
Key > Merge with Local Key in the context menu.

+ Select the Registry\User\[{AppVCurrentUserSID}\Software\Kofax\PDF key and right click.
Select Key > Merge with Local Key in the context menu.

+ Select the Registry\User\[{AppVCurrentUserSID}]\Software\Kofax\PDF\PDF Driver key and
right click. Select Key > Merge with Local Key in the context menu.

Select the Package Files tab, then select the Package-Root-VFS-Appdata-Kofax-PDF-PDFDirect

folder and delete it.

Select File >Save as and save the package.
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21. Open PowerPDF_DeploymentConfig.xml with Notepad from the folder where the package was
saved and edit it.

+ Find "<COM mode="and change settings to the following:

<COM Mode="Integrated">

<IntegratedCOMAttributes OutOfProcessEnabled="true" InProcessEnabled="true" />
</COoM>

<!-- Objects —-->

<Objects Enabled="false" />

+ Find " EnvironmentVariables" and change settings to the following:

<EnvironmentVariables Enabled="true">

<Include>

<Variable Name="MOZ PLUGIN PATH" Value="[{AppVPackageRoot}]\Bin\" />
<Variable Name="powerpdfinappv" Value="501" />

</Include>

22. Open PowerPDF_UserConfig.xml with Notepad from the created folder.
23. Find "<COM mode=" and change settings to the following:

<COM Mode="Integrated">

<IntegratedCOMAttributes OutOfProcessEnabled="true" InProcessEnabled="true" />
</COoM>

<!-- Objects -->

<Objects Enabled="false" />

24. Copy the created folder (package) to a shared location.

Deploy on client computers

The following sections list the necessary preparations and steps to deploy App-V packages.

Prepare client

1. Install Windows 10 Enterprise.

2. Install Microsoft .NET Framework 4.8 full version.
3. Install the Microsoft App-V client.

4. Reboot the computer.

Install printer driver

The printer driver is excluded during the sequencing process and must be installed locally on the
client.

1. Browse for the installation folder of Kofax PDF Create for App-V deployed Power PDF and
launch setup.exe.

2. Select alanguage and click Start Installation.
3. Finish the installation.

Deploy Microsoft Office App-V package

1. Launch Accessories > Windows PowerShell > Windows PowerShell ISE with Run as
Administrator.
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W

Type Set-ExecutionPolicy Unrestricted and press Enter. Click Yes to confirm the policy change.
Type Import-Module appvclient and press Enter.
Type Set-AppvClientConfiguration -EnablePackageScripts $true and press Enter.

Type Add-AppvClientPackage -Path <path_of_Office.appv> -DynamicDeploymentConfiguration
<path_of_DeploymentConfig.xml> | Publish-AppvClientPackage -Global and press Enter.

Change the following to the actual paths:
+ <path_of_Office.appv>
+ <path_of_DeploymentConfig.xml|>

Wait until the package is added and published.
Verify that Microsoft Office 2013 has appeared in the Start Menu.

Deploy Power PDF App-V package

1.

3.

Type Add-AppvClientPackage -Path <path_of_PowerPDF.appv> -
DynamicDeploymentConfiguration <path_of_DeploymentConfig.xml> | Publish-
AppvClientPackage -Global and press Enter.

Change the following to the actual paths:

+ <path_of_PowerPDF.appv>

+ <path_of_DeploymentConfig.xml>

Wait until the package is added and published.

Set Connection Group

1.

bW

Ve N W

Copy the following text into Notepad:

<?xml version="1.0" encoding="UTF-16"7?>
<appv:AppConnectionGroup
xmlns="http://schemas.microsoft.com/appv/2010/virtualapplicationconnectiongroup"
xmlns:appv="http://schemas.microsoft.com/appv/2010/
virtualapplicationconnectiongroup"
AppConnectionGroupId="" VersionId=""
Priority="0" DisplayName="PDF and Office">
<appv:Packages>
<appv:Package PackageId="" VersionId="" />
<appv:Package PackageId="" VersionId="" />
</appv:Packages>
</appv:AppConnectionGroup>

Open PowerShell ISE (Run as Administrator).
Create 2 new GUIDs with this command: [guid] : :NewGuid ()

Copy the new GUIDs between the quotation marks of AppConnectionGroupld and the first
VersionId rows.

Type Get-AppvClientPackage to PowerShell ISE and press Enter.

Copy and paste the Packageld and Versionld for both the Power PDF and Office packages.
Save the file as Unicode text as ConGroup.xml.

Type Add-AppvClientConnectionGroup -path <path_of_ConGroup.xml> and press Enter.
Type Enable-AppvClientConnectionGroup -name "PDF and Office" -Global and press Enter.
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Enable other integrations (optional)

ok whbh=

Open Notepad.

Copy the Packageld of PowerPDF package from PowerShell and paste it to Notepad.

Type an _ (underscore) character after the package id.

Copy the VersionID of PowerPDF package from PowerShell and paste it after _ (underscore).
Open Regedit with admin rights.

Select HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppV\Client\RunVirtual key. The following
sections detail the rest of the steps for various browsers.

Microsoft Edge

O NoOWUm AWM=

Right click RunVirtual key and select New > Key .

Type microsoftedgecp.exe and press Enter.

Right click (Default) and select Modify.

Copy the concatenated IDs from Notepad, paste to Value Data and click OK.
Right click RunVirtual key and select New > Key .

Type msedge.exe and press Enter.

Right click (Default) and select Modify.

Copy the concatenated IDs from Notepad, paste to Value Data and click OK.

Internet Explorer

1.

Right click RunVirtual key and select New > Key.

2. Type iexplore.exe and press Enter.
3.
4. Copy the concatenated IDs from Notepad, paste to Value Data and click OK.

Right click (Default) and select Modify.

Google Chrome

PWN-=

Right click RunVirtual key and select New > Key.

Type chrome.exe and press Enter.

Right click (Default) and select Modify.

Copy the concatenated IDs from Notepad, paste to Value Data and click OK.

Mozilla Firefox

PN =

Right click RunVirtual key and select New > Key.

Type firefox.exe and press Enter.

Right click (Default) and select Modify.

Copy the concatenated IDs from Notepad, paste to Value Data and click OK.
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iIManage connector and server
configuration

Users can install the Kofax iManage 10 v2 connector with Power PDF Advanced, if the installation
package is not configured otherwise. The following sections describe how to configure the iManage
server to use with Power PDF Advanced.

Configure the iManage server

The Power PDF iManage connector uses OAuth2 authentication by default with the recent iManage
server versions, which support the v2 APL. If you want to use OAuth2 for Power PDF, you need to
register the Power PDF application on the server side.

Register the Power PDF application in Control Center

1.
2.

Open Control Center.

In the Dashboard on the left, select Applications.

The Application panel appears on the right.

At the top-right corner, click Add Application.

The Add Application dialog box appears.

Click Configure Manually.

On the Configuration tab, fill the text boxes as follows, then click Authentication.
* Name: Power PDF

+ Description: Power PDF Application

* API Key: 00fb6221-3f3f-4b48-85e1-d2e49c8fd44f

* API Secret: 7a71dd05-e921-4fcd-9246-94ea29b7d603
+ Publisher: Kofax

On the Authentication tab, fill the text boxes and set the switches as follows, then click
Access.

+ iManage Work Authentication Required?: Yes
+ Application Type: Native

* Redirect URL: http://localhost/

+ Client Secret Expires: Never

* Allow Refresh Token: Yes
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© The Allow Refresh Token switch appears on iManage server version 10.3 or later. If this
option is not available, use the iManageServer_ART.exe to enable it. See Enable the Allow
Refresh Token option using iManageServer_ART.exe for details.

7. On the Access tab, select All Users then click Access.
8. On the Review tab, switch Enable Application to Yes, then click Finish.

As a result, Power PDF appears in the list of registered applications.

Enable the Allow Refresh Token option using iManageServer_ART.exe

On the iManage server versions earlier than 10.3, the Allow Refresh Token switch might not be
available in the Application settings in Control Center. To enable Allow Refresh Token, use the
iManageServer_ART.exe command line tool, which is located in the Power PDF installation package,
inthe Tools\iManage server\config tool subfolder.

1. Start the Command Prompt and navigate to the folder containing iManageServer_ART.exe.

2. Issue the following command:

iManageserver ART.exe <server url> <user name> <password> <ClientID> [true/false]

Replace the variables in brackets with the actual parameters:

server_url: The iManage server URL, such as http://localhost/

user_name: The user name of your iManage server administrator account.

password: The password of the above account.

ClientID: The client ID of Power PDF, which is: 00fb6221-3f3f-4b48-85e1-d2e49c8fd44f
true or false: Optional parameters.

Use the iManage v2 connector without OAuth2

Power PDF uses OAuth2 authentication by default if the server supports the v2 API. To ignore
OAuth2, do any of the following:

* Reveal and use the OAuth2 option in the Add Server dialog box.

a.

In Power PDF, on the Connectors >iManage page of the Options dialog box, click Add
Account to start the Add Server dialog box.

Double-click the Web address label above the text box.

Add server B

Web address:
[

Enter web address for the iManage server

Use credential cache

As a result, the Use Oauth2 option appears below, and becomes available as soon as the
web address is specified.
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Add server B

Web address:
[

Enter web address for the iManage server

Use credential cache

===

a. Inthe Web address text box, specify the URL of the iManage server.

b. Click Login and proceed with the login process as usual.

+ Alternatively, edit the setting in the configuration file.

a. In a plain text editor, such as Notepad, open the DMSProDMS.ini file, which is located in this

folder:
$ProgramData%$\Kofax\PDFProDMS.ini

If there is no such file, you need to create it manually.

b. Append the following two lines to this .ini file, or edit these lines, if they already exist:

[iManagelO]
DO _NOT USE_OAUTH2=1

c. Save the file.

Installation

This section includes the procedures you need to successfully install, activate and launch Kofax
Power PDF add-on for iManage 10.

You must have Tier 2 administrator or NRTADMIN iManage Work system administrator rights to
install the program, and add its functions to the menu.

Install Power PDF add-on for iManage 10

Use this procedure to install Kofax Power PDF add-on for iManage 10 workspace.

1.

Log into your iManage webserver as an administrator.

2. Go to Control Center.

W

6.
7.
8.

Select Applications in the settings group.
Click Add Application > Upload Package .

Browse to the <installation folder>\Tools\iManage server\addon and selectthe
addon.zip file.

On the Authentication tab, set iManage Work Authentication Required to No.
On the Access tab, select users to have access to the Kofax Power PDF add-on.
On the Review tab, make sure the add-on is enabled and the settings are correct. Click Finish.

The Kofax Power PDF add-on is listed in the Applications.

If the Outlook work panel browser refuses to load with Work Desktop 10.5 and 10.6, refer to the
Known issues section in the Release Notes.
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Customize the menu

Follow these steps to add the Kofax Power PDF related functions to the iManage Work menu.

1.

Log into your iManage webserver as an administrator.

2. Go to Control Center.

vk w

Select Web Client in the work clients group.
Click the CONTEXT MENUS tab.
Add the Create PDF and Open with Convert Assistant to the Documents menu.

a. Move the pointer over the top right corner of the Documents menu, click on the
appearing pencil icon.

b. Click +Add at the bottom and select the new functionalities to add.
If it does not appear, click Restore Defaults.

c. Click Save.

Users can access the new functionalities the following ways:
Click the ... icon beside the document.

Click the icons on the header of the document list. The icons related to the new functionalities are
displayed, when the box in front of a document is selected.

Use the context-sensitive menu by right-clicking on a document.
Open the preview of the document. The Kofax Power PDF related icons are added to the toolbar.
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Collaboration Server configuration

Enterprise customers can install Kofax Power PDF Collaboration Server, which is required for the

Online Collaboration feature. Online Collaboration works across all remote locations that can access

the Collaboration Server.

© Users should specify the URL of the Collaboration Server in Power PDF before starting the
feature.

The following packages are provided to install Collaboration Server:

Installation package Edition

KofaxPowerPDFCollaborationServer-1.0.0.zip (online) Console application
KofaxPowerPDFCollaborationServer-1.0.0.1.zip (offline)

KofaxPowerPDFCollaborationServer-1.0.0.2.zip Service

Install Collaboration Server

© 1nstallation packages of version 1.0.0.2 and higher only support the installation of
Collaboration Server in service mode.

Service

To install the Collaboration Server as a service, do the following:

1. Ensure that the console edition of the Collaboration Server is not installed on your computer.

To uninstall it, see the uninstallation instructions for the console application.

2. Download the installation package (KofaxPowerPDFCollaborationServer-1.0.0.2.zip) from the
Kofax Network. The actual location is included in the fulfillment email.

3. Extract the .zip file to an empty folder on the server.
4. Open the folder in File Explorer.
5. Optionally, modify the installation path in the .bat files.

The default installation path is C:\PowerPDFCollaboration. It is specified in each batch file at
the coll inst path variable as follows:

set coll inst path=c:\PowerPDFCollaboration
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Use a plain-text editor and update the following batch files by editing the value of the
coll inst path variable as you prefer:

* server install 1 run as user.bat
* server install 2 run as admin.bat
* server launch run as_admin.bat

* server stop run as admin.bat

* server uninstall run as admin.bat

© Besureto specify the same installation path in all batch files.
Start server install 1 run as user.bat.
i ] During installation, click Yes each time the User Access Control confirmation appears.

Start server install 2 run as_ admin.bat by selecting Run as administrator from the

context menu of the file.

Now Collaboration Server is installed. You can configure HTTPS (optional) and run Collaboration
Server before using the Online Collaboration feature.

Console application

To install the Collaboration Server as an application, do the following:

1.

w

5.

Download the installation package (KofaxPowerPDFCollaborationServer-1.0.0.zip or
KofaxPowerPDFCollaborationServer-1.0.0.1.zip) from the Kofax Network. The actual location is
included in the fulfillment email.

Extract the .zip file to an empty folder on the server.
Open the folder in File Explorer.
Optionally, modify the installation path in the .bat files.

The default installation path is C:\PowerPDFCollaboration. It is specified in each batch file at
the coll inst path variable as follows:

set coll inst path=c:\PowerPDFCollaboration

Use a plain-text editor and update the following batch files by editing the value of the
coll inst path variable as you prefer:

* server install 1 run as user.bat

* server install 2 run as_admin.bat
* server launch 1 as admin nginx.bat
* server launch 2 as admin redis.bat

* server launch 4 as admin wsgi.bat

© Be sure to specify the same installation path in all batch files.

Start server install 1 run as user.bat
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i ] During installation, click Yes each time the User Access Control confirmation appears.

6. Start server install 2 run as admin.bat by selecting Run as administrator from the

context menu of the file.

Now Collaboration Server is installed. You can configure HTTPS (optional) and run Collaboration
Server before using the Online Collaboration feature.

Configure ports and HTTPS for Collaboration Server

Collaboration Server can work with HTTP or HTTPS. HTTPS is recommended for security reasons.

1. Power PDF is shipped with a default self-signed certificate. Optionally, use your certificate to
comply with your company's security.

a.

Build your certificate. The following batch sample code demonstrates how to use OpenSSL
to create certificate files.

rem generate RSA Private key and self-signed certificate:

"c:\Program Files\OpenSSL-Win64\bin\openssl" genrsa -out ca.key 2048
"openssl" req -new -key ca.key -out ca.csr
"openssl" x509 -req -days 3650 -in ca.csr -signkey ca.key -out ca.crt

rem generate client-side Private key and self-signed certificate:

"openssl" genrsa -des3 -out client.key 1024

"openssl" req -new -key client.key -out client.csr

"openssl" ca -config ".\openssl.cnf" -in client.csr -out client.crt -cert
ca.crt -keyfile ca.key

rem ----remove password:

"openssl" rsa -in client.key -out client.key.pem

rem generate server-side Private key and self-signed certificate (these are
the two files we sent):

"openssl" genrsa -des3 -out server.key 1024
"openssl" req -new -key server.key -out server.csr

"openssl" ca -config ".\openssl.cnf" -in server.csr -out server.crt -cert
ca.crt —-keyfile ca.key
rem —----remove password:

"openssl" rsa -in server.key -out server.key.pem
rem use server.key.pen ad server.key on the collaboration server

Replace the following certificate files on the server:

* server.crt: Server certificate

* server.key: PEM format key file for server.crt

The certificate files are located in a subfolder under the installation folder of Collaboration
Server. By default, this path is: C:\PowerPDFCollaboration\web\nginx-1.14.2\conf

Replace the following certificate files on the computer where Power PDF runs:

* ca.crt: The certificate used to create or sign server.crt and client.crt certificates

* client.crt: Server certificate

* client.key.pem: PEM format key file for client.crt
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The files are located in the bin folder under the Power PDF installation path. By default,
this Power PDF path is: C:\Program Files (x86)\Kofax\Power PDF 50\bin

2. Enable port 443 for HTTPS in Windows Firewall. Refer to Microsoft firewall instructions for
details.

© Ensure that ports 80 and 443 are free and not used by any other application such as
Internet Information Services (IIS).

You should run Collaboration Server before using the Online Collaboration feature.

Run Collaboration Server

The following sections describe how to run the different editions of Collaboration Server after
installation.

Ensure that Online collaboration is enabled before using the feature.

Service

If you installed Collaboration Server using the package below, run Collaboration Server as a service
according to the instructions that follow.

+ KofaxPowerPDFCollaborationServer-1.0.0.2.zip (or higher)

To run Collaboration Server:
1. In File Explorer, open the folder in which Collaboration Server is installed.

2. Start server launch run as admin.bat with administrator rights. To start with
administrator rights, select Run as administrator from the context menu of the file.

© collaboration Server continues to run as you log off Windows. If you restart the computer,
Collaboration Server starts automatically.

Console application

If you installed Collaboration Server using either of the below packages, run Collaboration Server as
a console application according to the instructions that follow:

+ KofaxPowerPDFCollaborationServer-1.0.0.zip
+ KofaxPowerPDFCollaborationServer-1.0.0.1.zip

During this task:
+ Click Yes each time the User Access Control confirmation appears.
+ Click Allow access each time the Windows Security Alert confirmation appears.

To run Collaboration Server:
1. In File Explorer, open the folder in which Collaboration Server is installed.
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2. Start server launch 1 as admin nginx.bat with administrator rights. To start with
administrator rights, select Run as administrator from the context menu of the file.

3. Start server launch 2 as admin redis.bat with administrator rights.
The Command Prompt window with redis-cli.exe appears, waiting for your input.
4. Enter the following command:
config set requirepass pdf.redis.auth
As you press Enter, "OK" appears in the next line as a confirmation.
5. Enter exit at the prompt to close the Command Prompt window.
6. Inthe File Explorer, start server launch 4 as admin wsgi.bat with administrator rights.
The Command Prompt appears.

© Do not click into the window to avoid blocking the run of Collaboration Server.

© Collaboration Server closes as you log off Windows. Use Lock instead to keep your user logged
in and maintain online collaboration. If you restart the computer, you need to repeat the above
steps before using collaboration again.

Uninstall Collaboration Server

The following sections describe how to uninstall the different editions of Collaboration Server.

Service

If Collaboration Server was installed as a service (using the package
KofaxPowerPDFCollaborationServer-1.0.0.2.zip), do the following to uninstall it:

+ Start server uninstall run as_admin.bat with administrator rights. To start with
administrator rights, select Run as administrator from the context menu of the file.

Console application

If Collaboration Server was installed as an application (using the package
KofaxPowerPDFCollaborationServer-1.0.0.zip or KofaxPowerPDFCollaborationServer-1.0.0.1.zip), do
the following to uninstall it:

1. Stop the Redis service. Go to Task Manager > Services, right-click Redis, and then select Stop
from the context menu that appears.

2. Stop nginx.exe. Go to Task Manager > Details, select nginx.exe, and then click End task.
3. Repeat step 2 for all running instances of nginx.exe.
4. Delete the folder in which the Collaboration Server was installed.

The default folder is C:\PowerPDFCollaboration.
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Kofax License Server configuration

Kofax License Server supports only Kofax Power PDF Advanced with Advanced Volume license and
Power PDF Reader.

Ensure that the third-party components required by the Technical Specifications document are
installed on the server computer before using Kofax License Server.

© Download the third-party installers from the internet or find those in the Prerequisite folder of
the Kofax License Server installation package.

Install Kofax License Server and Client

The following steps use InstallSAL.bat Or UpgradeSAL.bat to install or upgrade both License
Server and License Client on the server computer.

1. Download the installation package (KofaxLicenseServer-6.5.0 R2.zip)from the Kofax
Network. The actual location is included in the fulfillment email.

2. Extract the installation package to a temporary folder on the server computer and open
the folder in File Explorer. The folder should contain a .iso file and the Prerequisite folder
mentioned above.

3. Double-click the .iso file to map the content to the next free drive letter, such as D:.

4. Copythe Installs folder and the InstallSAL.bat and UpgradeSAL.bat filesto a
temporary folder, such as c: \temp on the server computer.

5. Optionally, set up HTTPS.

0 Using HTTPS requires the Internet Information Services (IIS) feature enabled on the
server computer.

a. Create your self-signed certificate and copy the thumbprint.

* On the Start menu, click Administrative Tools > Internet Information Services (IIS)
Manager .

+ Double-click Server certificates, then in the Actions list on the right, click Create Self-
Signed Certificate. The Create Self-Signed Certificate window appears.

« Enter a certificate name you prefer, then click OK.
Your certificate appears in the Server Certificates list.
+ Double-click your certificate.
The Certificate dialog box appears.
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10.

11.

« On the Details tab, select the Thumbprint item in the list, then select and copy the
thumbprint value from the box.

b. Use a plain text editor to modify the thumbprint in the .bat file. Look for SET CERTHASH=
and paste the thumbprint to the end of the line. Do not use spaces and quotes.

c. Look for SET ENABLEHTTPS= and append 1 to the end of the line.

d. Specify the port number as described below.
Optionally, specify the port number.
a. Openthe .bat file in a plain text editor.
b. Look for SET PORT= and append the preferred port number to the end of the line. Do not
use spaces and quotes.
The default ports are the following:
« HTTP: 3581
« HTTPS: 3582
Optionally, specify the log file path.
a. Open the .bat file in a plain text editor.
b. Look for SET LOGFILEDIR= and append the full path for the preferred log file location to
the end of the line. Do not use spaces and quotes.

In the Start menu search box, type Command Prompt, then click Run as administrator on the
right.

After the User Access Control (UAC) confirmation, the Administrator: Command Prompt
window appears.

At the prompt, use the cD command to switch to the temporary folder where you copied
InstallSAL.bat.
Example: For example:

CD c:\temp

For a new installation, enter InstallSAL.bat at the command prompt.

The installation script runs.

For upgrading the previous release, enter UpgradeSAL.bat at the command prompt.
The installation script runs.

During a successful installation, the following messages appear at the command prompt:
+ Server install succeeded.
+ Client install succeeded.

Now Kofax License Server is installed. Configure Kofax License Client before license activation.

Kofax License Server writes to the Windows event log when entering a warning period or a term is
expired. Administrators can use these events to get notified in time for license renewal.
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Upgrade the License Server and Client using .msi files

To use the latest licensing features, upgrade both the License Server and Client. Either use the .bat
file as described in the Install Kofax License Server and Client section above, or use msiexec at the
command prompt.

+ To upgrade the server from the previous version, run the following command on the server
computer:

msiexec /famusv “<server msi path>" /qn
Replace <server_msi_path> with the path to the Kofax License Server installation .msi file.

+ To upgrade the client from the previous version, run the following command on the client
computers:

msiexec /famusv “<client msi path>” /gn

Replace <client msi_path> with the path to the updated licensing client installation .msi file.

Configure Kofax License Client

Do the following to configure License Client.
1. Obtain the name of the computer where License Server runs.

a. Onthe computer where License Server runs, go to Settings > About on the Start menu.

b. Under Device Specifications, use your mouse to select the Device name value and copy
it to the clipboard.

i ] Alternatively, you can use the IP address of the computer.

2. Onthe computer or server where License Client is installed, click Kofax License Client on the
Start menu.

The Kofax License Utility application appears.
3. On the File menu, click Select Servers.
The Select Servers dialog box appears.
4. Inthe Primary License Server box, paste the name of the computer running License Server.

5. For a secondary License Server, repeat steps 1 to 3 and fill in the Secondary License Server
box.

6. Optionally, set up HTTPS.

a. Transfer the Server Certificate from the computer running License Server to the client
computer. In a corporate IT environment, contact your system administrator for details.

b. Make sure the certificate is trusted.

Now Kofax License Client is configured, you can use license activation. See Activate a license.
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Activate a license

Activation requires having your serial number and product code at hand. Find this code in the
fulfillment email.

The following steps activate a license automatically, through an internet connection. For manual
activation steps, refer to the Activate Your Licenses section in the Help for Kofax License Utility.

O 1o start the help, click Help topics on the Help menu.

1. On the computer or server where License Client is installed, click Kofax License Client on the
Start menu.

The Kofax License Utility application appears.
2. On the File menu, click Activate.
The Activate dialog box appears with the Machine ID box already filled.
3. Inthe Serial number box, enter or paste your serial number (product key).
In the Product code box, enter or paste your product code.
5. Click Automatic.

»

Now your license is activated.

Enhanced license management

Enhanced license management requires Kofax License Server version 6.5.0.0.0.1231 or later. For
details on installation and upgrade, see Install Kofax License Server and Client.

By default, if no Allow List file is available, Kofax License Server provides licenses upon request from
any user.

Allow List format and location

To control the group of authorized users, you need to maintain an Allow List file on the computer
that runs Kofax License Server. If the file is missing, all license requests are granted without user
authorization.

The Allow List should be a plain-text file (NamedUsersList.txt) placed in the common application
data folder. By default, the full path is:

C:\ProgramData\Kofax\Licensing\NamedUsersList.txt

© 1o override the default path, specify a report path by the ReportspPath setting in app.config.
In this case, the Allow List path copies the report path.
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The Allow List should specify all users authorized to consume a Power PDF or Power PDF Reader
license by the Windows user name (domain\username), the security identifier (SID), or both. The list
is case-insensitive. You may list a user with multiple entries. Place each entry in a separate line.

For example:

kofax\userl

Kofax\user2

S-1-5-21-2349634669-572318953-3610473378-2204

The above Allow List example grants the following:

+ User1 can request a user license with kofax\userl.

+ User2 can request a user license with Kofax\user?2.

* The user with SID S-1-5-21-2349634669-572318953-3610473378-2204 can request a user license.
« Any other user requesting a user license adds an error message to the log.

© User name formatting depends on the corporate environment. To make license allocation
straightforward, use the SID if possible.

Allow List updates

You may edit the Allow List file, freely updating, removing, or adding user entries. Kofax License

Server processes any the updates automatically.

+ Add a new user to instruct Kofax License Server to let the user consume a license as soon as
Power PDF requests one on behalf of the user.

* Remove all entries of a registered user to instruct the server to release the consumed user
license. However, this does not immediately affect the previously registered client. The client can
continue to use Power PDF until the registration period is expired, but it cannot acquire a new
registration and consume a license.

+ Delete the Allow List file to suspend user authorization, and allow all users to request user
licenses. Licenses already consumed remain registered and active.

Import users from an Active Directory group

Administrators can export users from an Active Directory (AD) group to NamedUsersList.txt
using the following PowerShell script sample.

O The script requires the Active Directory tools installed on the computer and running
PowerShell as an administrator. See Install Active Directory tools for details.

# Prompt the user to enter the group name
SgroupName = Read-Host "Enter the name of the group"

# Get the group object
Sgroup = Get-ADGroup -Filter "Name -eq 'S$groupName'"

# Get the members of the group, including those in nested groups
Smembers = Get-ADGroupMember -Identity $group -Recursive

# Create an empty hash table to hold the SIDs
$sids = @{}
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# Create an empty array to hold the user objects
Susers = @()

# Loop through each member and add their SID to the hash table
foreach ($member in S$members) ({

}

if (Smember.objectClass -eq "user") {

$sids[$member.Sid.Value] = Strue
Suser = Get-ADUser -Identity S$member -Properties Name, EmailAddress
Susers += Suser

# Output the unique SIDs to a file
$sids.Keys | Out-File -FilePath "NamedUsersList.txt"

# Select the properties to export to the CSV file
Sproperties = "SID", "Name", "EmailAddress"

# Export the user objects to a CSV file
Susers | Select-Object $properties | Export-Csv -Path "NamedUsersList.csv" -NoTypelInformation

The sample script prompts for the AD group name and then outputs these files:
* NamedUsersList.txt includes SIDs in aformat appropriate for the Allow List.

* NamedUsersList.csv includes attributes such as user name and email address to provide
more information.

Install Active Directory tools

Importing users from an Active Directory group requires Active Directory tools installed on the
computer. You can install the RSAT tools directly from the Windows Settings app:

1.
2
3.
4

5.

Open the Settings app.
Go to Apps > Optional features .
Click Add a feature.

Scroll down and select RSAT: Active Directory Domain Services and Lightweight Directory
Services Tools.

Click Install.

About logging user license requests

Kofax License Server writes all messages specific to the Allow List file to the default License Server
log file in the common application data folder. By default, the path is:

C:\ProgramData\Kofax\KSALic\logs

The file naming follows the Lic yymMM. txt schema, where
* YY stands for the year on two numeric digits.
* MM stands for the month on two numeric digits.

For example, the file name for July 2023 should be Lic 2307.txt.
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Cause

Message

License acquisition failure occurs when the user is not
on the Allow List.

Fail to acquire license (4000 - PowerPDF Named
User). User <UserID> with <SID> is not found in the
NamedUsersList file.

The license server reclaims a user license as the user
was removed from the Allow List.

Releasing named user license (4000 - PowerPDF
Named User) as the user <UserID> is not found in the
NamedUsersList file.
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