Tungsten Automation

Build date:

Introduction

Install Tungsten RPA to resolve the issues and apply the new features listed in this ReadMe.

Issues resolved

ID Issue Solution
956068Request to apply additional security.Enhanced security by locking npm packages to specific versions.
954704Pie Chart preview in Kapplets has overlaying text.Expanded the preview.
954021, 954009, 953984, 953825, 952127, 944950, 942079, 936853Request to apply additional security.Enhanced security by upgrading jgit, dom4j, commons-fileupload, form-data, node, and Tomcat.
952983Automating against Chrome or Edge after Edge build 140 could cause robots to hang.Prevent recursive application tree.
951955Read File step with RFS does not work with Tomcat 9.0.105 or newer.Adjusted code to work with updated Tomcat.
950307Timing issue could cause null pointer crash in CEF.The drivers now check pointer before using it.
949905Custom Kapplet icons were not available in icon gallery if a workspace was selected.Custom Kapplet icons are now available in the icon gallery.
949903When restoring a MC backup in Kapplets schedule owner is changed to admin.The owner of Kapplet schedules is preserved.
949894Saving a Kapplet schedule with invalid input redirects to the list view without error message.The view is no longer changed, and an error message is shown when trying to save a schedule with errors.
949892A robot with no output would fail if started from a Kapplet.A robot without output is now marked as completed when the Kapplet run is completed.
949890Restoring Kapplets from a Management Console backup would grant global developer rights to Kapplet Administrators.Kapplets Administrators are no longer granted additional rights automatically.
949888A paused Kapplets schedule would no longer be paused when restored from backup.The schedule remains paused after restoring.
949886Kapplet input value types were not properly restored from Management Console backups.Fixed bug.
949884Kapplets user with "User" role could not see results from commit action.Kapplet users can now see commit action results.
949879Scrolling in the Icon Gallery in Kapplets did not work properly.Fixed the scrolling issue.
949877In Kapplets, the context menu was not removed when deleting a workspace.The context menu is handled properly.
949875Kapplet template icons were set to the workspace icon when modifying the template.The Kapplet template icon is preserved when modifying the template.
949873When sorting Kapplet templates, the input values could be lost.Input values are no longer cleared when sorting.
949871In Kapplets, if a default value is set to hidden it becomes required.Hidden values are no longer set by default to required.
949809Kapplet chart page preview was very small and could not be resized.The chart page preview now fills the display area.
949805On the Kapplets start page, the type name was displayed for types with hidden attributes.The type name is no longer displayed on the start page if it only contains hidden attributes.
949802Files could lose the extension when downloaded from Kapplet history.Ensured correct use of utf-8 when handling full width characters.
947013CEF robot could timeout on clearing guards.DOMChanged events are now bundled and do not fire while JS code is running.
946681Issue importing backup with Vault data when using MS SQL.Removed unnecessary unique constraints from specific MS SQL tables.
943974It was not possible to add more than one OAuth client to a robot access item.Fixed bug.
943500Deselecting "Enable OAuth" in the vault caused unresponsive UI.Fixed the issue.
943041CEF client certificates did not provide the full certificate chain.Client certificates now provide the full certificate chain.
943012Query Database step in Basic Engine Robots failed for large storage data types such as clob or binary.The step now works with large storage types.
942650Importing backup with vault entries failed when using MS SQL Server.Fixed constraint issue.
942163The Query Database step in Basic Engine Robots failed for certain column types.Fixed the Query Database step.
936083In rare cases, a robot could hang forever when executing certain steps.Interruptions are now handled correctly.
934774Quick RPA did not work with Kofax Total Agility 7.11.Fixed.
847141Multiple clicks on the submit button when updating a schedule might cause constraint errors in the database.Disabled the save button after the first click.
847051Inserting a remote device step could freeze Design Studio for about 4 minutes.Fixed deadlock that could freeze the application.
846999The Ignore Load Errors option did not work with SOAP request.Content of the response is now loaded if Ignore Load Errors is set.
846994In Browser Tracer, the "Unknown source" warning is shown on JavaScript tab.Sources are now added to traces successfully.
846985Repeatedly running Browse step with client certificate failed after some time.Private keys can now be looked up, even after the application owning them is closed.
846984Robots with "Suspend DA Service" action did not work properly when executed from Management Console.The Desktop Automation Service is now suspended properly.
846983Unable to detect cell content in a table for a specific Java application.Match the table children to the table cells.
846982Characters outside the Unicode BMP are mangled on input.Fixed encoding extended Unicode characters.
846981Enhanced security.Improved input parameter validation for the Desktop Automation Service.
846776, 846775Vault did not restore properly when using Oracle database.Added handling of empty fields required for Oracle.
846774Projects with empty description were not restored properly.Fixed handling empty description when restoring backups.
846773RoboServers connected with client connection did not always reconnect after a Management Console restart.Fixed the reconnection issue.

New and enhanced features

This update is cumulative and includes the following new and enhanced features from all updates for .

Support for MySql 8.4

Tungsten RPA now fully supports MySQL 8.4.

View running robots with viewClusters permission

A new permission viewClusters is available for admins to configure manually in the roles.xml file. Use this setting to grant permission to users for viewing robots with status Running on the Management Console > Admin> RoboServers page without granting permission to view database and cluster data.

To configure this permission:

  1. In the roles.xml file, add the viewClusters permission under the clustersAndSettingsTabPermissions property.
  2. Set the viewClustersAndDBMappings permission to false and the viewClusters permission to true.

Example:

	<property name="clustersAndSettingsTabPermissions">
	<bean class="com.kapowtech.scheduler.client.auth.ClustersAndSettingsTabPermissions">
	<property name="viewClustersAndDBMappings" value="false"/>
	<property name="viewClusters" value="true"/>
	

Documentation updates

This ReadMe includes the following documentation updates.

ID Issue Solution
957158 The .NET version for DAS in Tungsten RPA Technical Specifications needs an update. The .NET version should be 4.8.
956789 Desktop Automation Service no longer forcibly starts WebClient. The WebClient Windows Service is not started automatically as stated in the installation guide, to use RFS from Desktop Automation Service make sure that the WebClient windows service is started.
933468 The description of the project access for Kapplet Administrators in Tungsten RPA Help needs clarification. The description of the Kapplet Administrator role says that "Users with this role gain a read/write access to projects in Management Console from Kapplets." The statement should be "Users with this role gain read access to projects in Management Console from Kapplets."
954110 Add more details about the scope of the MC REST API documentation in the Tungsten RPA Developer's Guide. The majority of the Tungsten RPA Management Console REST API is used internally by the Management Console. The REST API is subject to change and has limited documentation. The JSON API specification file can be downloaded as-is, without additional support and documentation.
954114 The "Tungsten RPA limitations" in Tungsten RPA Help has an omission. The "Execution mode" list of steps that are not available in the Smart Re-execution mode should include Remove Tags.
955873 Update to the known issues section. The RFS test button does not work properly. This does not prevent using RFS.

Applies to

This update is a full installation.

Apply this update to replace any RPA product version or install it next to the current version.

Files included

This update includes the following files.

File name Version
TungstenAnalyticsforRPA-.zip
TungstenRPADocumentation-_EN.zip
TungstenRPADocumentation-_FR.zip
TungstenRPADocumentation-_JA.zip
TungstenRPAManagementConsoleDocumentation-.zip
TungstenRPAProcessDiscoveryAnalyzer-.zip
TungstenRPA-.tar.gz
TungstenRPA-.msi
TungstenRPADesignStudio-.msi
TungstenRPADesktopAutomationService-.msi
TungstenRPADocumentTransformationService-.msi
TungstenRPAProcessDiscoveryAgent-.msi
TungstenRPARoboServer- .msi
ReadMe-TungstenRPA-.htm N/A

Install this update

To install this update on top of an existing installation of Tungsten RPA Management Console database schema, use the following procedure:

  1. Back up your existing installation by creating a Management Console backup.
  2. Install the required components. For details, see the Tungsten RPA Installation Guide.
  3. Use the existing database schema when installing the Management Console in Tomcat.

To upgrade from older RPA versions, use the following procedure:

  1. Back up your existing installation by creating a Management Console backup.
  2. Install the required components. For details, see the Tungsten RPA Installation Guide.
  3. In the new Management Console, restore the backup.

Remove this update

This update is a full installation. Follow the standard uninstallation procedure for Windows or Linux applications.